Welcome to the PowerWEB TextBox for ASP.NET

PowerWEB TextBox for ASP.NET

The PowerWEB TextBox for ASP.NET enables Web developers to replace the standard TextArea of their web application with support for HTML content and traditional word processing capabilities without relying on any client-side components or controls.

For developers creating ASP.NET content-management applications, Web mail products, Web Forums, or just want their users to have word processor-like control and HTML content, the PowerWEB TextBox for ASP.NET allows instant replacement for the standard TextBox control used in most Web applications. Just like a standard word processor or HTML editor, the developer has control over the look and feel of all the items on the screen, and has the ability to create custom buttons, toolbar items, and Windows-like dialogs that encapsulate customized code. All data is visible in either WYSIWYG form or as HTML tags. For the end-user, all standard HTML capability is available, including Table editing, image manipulation, color pickers, and text formatting.

Designed for both beginners and advanced users, the TextBox control supports zero-code customization, as virtually every aspect of the product can be customized using built-in editors that leverage the capabilities of Microsoft Visual Studio .NET. For advanced users, the rich object model allows complete customization in Code Behind or through direct tag manipulation in the ASPX file. All objects in the control can be manipulated to meet the developer’s business requirements, including customization of the Toolbars, Dialogs, Progress Bar, Tab Strip, text and for greater efficiency; the control supports skins and configuration persistence. The lower-level base classes can be customized to create unique dialogs and buttons. Microsoft Help 2.0 integration with comprehensive F1 support is included to get developers up-and-running in the shortest possible time, plus dozens of tutorials and samples.

Dart Communications has been a leading provider of components for Microsoft developers for the past 10 years with its market leading PowerTCP line of Internet components. As a Microsoft VSIP Partner and an original member of the .NET Early Adaptor Program, Dart has worked closely with Microsoft throughout the development of our .NET Framework components and controls. The design decisions incorporated into the product reflect the most effective techniques for developing a user-friendly, but powerful component in the Microsoft .NET Framework. These techniques not only reflect the actual code design, but also extend to documentation, incorporating the Microsoft Help 2.0 engine that includes integrated dynamic Help within the development environment.

Thank you for choosing PowerWEB for ASP.NET. We hope you will agree that this product is a perfect complement to the .NET Framework, bringing you the quality and value you have learned to expect from Dart Communications.

In PowerWEB TextBox for ASP.NET.

Getting Started
Provides an overview of PowerWEB TextBox for ASP.NET and discusses such topics as distribution, licensing, and support.
Using PowerWEB in VS.NET
Provides step-by-step instructions for creating a project using VS.NET, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB in WebMatrix
Provides step-by-step instructions for creating a project using WebMatrix, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Configuring the HtmlBox
Discusses how to easily configure the HtmlBox, including style, layout, and toolbar configuration.
Advanced Customization
Discusses the many ways the HtmlBox control can be customized, from simple style changes to advanced interface element creation.
Optimizing Performance
Discusses techniques for optimizing performance of the HtmlBox control, including reducing ViewState and render-size.
Reference
Provides a language/syntax and client-side API reference for PowerWEB TextBox for ASP.NET.
HtmlBox Control Samples
Describes the samples that are installed with PowerWEB TextBox for ASP.NET.

Send comments on this topic.

© 2002 Dart Communications. All rights reserved.


Getting Started

PowerWEB TextBox for ASP.NET is a powerful HTML editing web server control for use in ASP.NET. This topic, and related subtopics, address issues such as licensing, distribution, and support for PowerWEB TextBox for ASP.NET. For tutorials and walkthroughs pertaining to usage of PowerWEB TextBox for ASP.NET, see either Using PowerWEB Within VS.NET, Using PowerWEB Within WebMatrix, or Configuring the HtmlBox. For a programmer's reference of the classes used by the PowerWEB TextBox for ASP.NET, see the Reference topic.

In This Section

Documentation Map
Provides a good navigational aid to quickly find the topic you want.
Requirements
Discusses the components that are licensed in PowerWEB TextBox for ASP.NET.
Licensed Components
Discusses the requirements needed to use PowerWEB TextBox for ASP.NET.
License Installation
Provides step-by-step instructions on installing a license.
Trial Operation
Provides an overview on using PowerWEB TextBox in ASP.NET in trial mode.
Deployment
Discusses the steps that are required to distribute an application in ASP.NET.
Support
Provides an overview of the support options that are available for this product.

Related Sections

Using PowerWEB in VS.NET
Provides step-by-step instructions for creating a project using VS.NET, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB in WebMatrix
Provides step-by-step instructions for creating a project using WebMatrix, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB with Notepad
Provides step-by-step instructions for creating a simple project using notepad only.
Configuring the HtmlBox
Discusses how to easily configure the HtmlBox, including style, layout, and toolbar configuration.
Advanced Customization
Discusses the many ways the HtmlBox control can be customized, from simple style changes to advanced interface element creation.
Optimizing Performance
Discusses techniques for optimizing performance of the HtmlBox control, including reducing ViewState and render-size.
Reference
Provides a language/syntax and client-side API reference for PowerWEB TextBox for ASP.NET.
HtmlBox Control Samples
Describes the samples that are installed with PowerWEB TextBox for ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Documentation Map

The following topics were designed to get you quickly developing using PowerWEB TextBox for ASP.NET

To | See
Learn how to obtain and install a license. | License Installation
Learn how to deploy a web application | Deployment
Learn how to create a web project in VS.NET | Creating A New Project in VS.NET
Learn how to add the HtmlBox to a web form in VS.NET | Adding the HtmlBox to a WebForm in VS.NET
Learn how to write a simple app using VS.NET | Walkthrough: Creating a Simple Editor Application in VS.NET using Code Behind
Learn how to create a web project in WebMatrix | Creating A New Project in WebMatrix
Learn how to add the HtmlBox to a web form in WebMatrix | Adding the HtmlBox to a WebForm in Web Matrix
Learn how to write a simple app using WebMatrix | Walkthrough: Creating a Simple Editor Application in ASP.NET Web Matrix
Learn how to configure the HtmlBox using the Property Builder application | Configuring the HtmlBox using the Property Builder
Learn how to configure the toolbar layout using code. | Configuring Toolbar Layout
Learn how to configure style using code. | Configuring Style
Learn how to use high-level helper properties | Using Helper Properties
Learn how to use skins | Using HtmlBox Skins
Learn how to create a custom button | Creating a Custom Button
Learn how to create a custom dialog button | Creating a Custom Dialog Button
Learn how to create a custom menu button | Creating a Custom Menu Button
Learn how to create a custom toolbar image | Creating a Custom Toolbar Image
Learn how to create custom toolbar text | Creating Custom Text
Learn how to optimize performace/TD> | Optimizing Performance
Get syntax descriptions for properties, methods, and events of PowerWEB TextBox for .ASPNET components. | Reference Overview
Get descriptions of samples installed with PowerWEB TextBox for ASP.NET. | Samples Overview

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Requirements

In order to use PowerWEB TextBox for ASP.NET you must have the following:

  • .NET Framework
  • Microsoft Visual Studio .NET (recommended)
  • Internet Information Server (IIS) (Recommended)

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Licensed Components

The following control is licensed:

  • HtmlBox

A license must be purchased from Dart Communications or an authorized reseller to deploy web applications using the controls listed above.

Please refer to License Installation for more information.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


License Installation

This topic covers:

  • Installation
  • Installing a Server License
  • Adding Servers to your License
  • License Summary
  • Troubleshooting Licensing

Installation

Installing a PowerWEB product involves running the setup program available from www.dart.com. A free development license allows you to develop and test applications in loop-back mode indefinitely. Developed applications are fully functional, and include a 7 day trial server license when compiled under Visual Studio. Proceed to step 2 of Installing a Server License when you are ready to license your application for distribution.

See Trial Operation for more information.

Installing a Server License

Once you have downloaded the latest version, complete the following steps to install a server license:

  1. From the Start menu, select Programs, select PowerWEB, select the PowerWEB product you downloaded, and then click License Manager. You should see the screen below:

  2. To being the registration process, click Next to move to the screen below.

  3. Enter your personal information, and then click Next.
  4. The next screen, shown below, will allow you to specify the product you wish to register, add serial numbers and Web server NetBIOS names that are to be covered under the license. To add a license, click the Add button in the New Licenses.

  5. When Add is clicked a window will appear, enter the serial number given to you during purchase and click OK.

  6. The license agreement will now appear. If you agree to the terms, click "Agree" to proceed. You should now see the license added to the “New Licenses” window as demonstrated below (in this example, a 4 Server license and a Corporate license have been added). If you have added a Server license, you will also be informed how many more servers can be installed under the current license in the “New Web Server NetBIOS Names” window. Click Add in the “New Web Server NetBIOS Names” window to add a Web server name.

  7. Enter the name of the Web server that you wish to license, as shown below. If you have multiple servers, use Add as many times as your license allows. When server names are added, you will see them appear in the “New Web Server NetBIOS Names” window, as demonstrated below.

  8. Click Next for the confirmation screen, as shown below. Make sure the server names are correct; as once they are registered you will have to contact Dart to correct a mistake.

  9. The License Manager will now contact Dart to register the server names with the license. Upon completion you should see the screen below. If you are not able to access the Internet from your location, please call Dart at 315-339-8040 and we can register your servers manually.

A license file named "Dart.PowerWEB.LiveControls.lic" will be created next to the installed "Dart.PowerWEB.LiveControls.dll". Other developers in your organization must have the file present in order to develop for the licensed servers. You can use the License Manager to export license files or just manually copy the file from your installation directory.

Adding Servers to your License

At some point you may wish to purchase a serial number for more servers. The License Manager application can be easily used to add Web servers and generate a new "Dart.PowerWEB.LiveControls.lic" file that will replace your previous file. After receiving your new serial number from Dart:

  1. From the Start menu, select Programs, select PowerWEB, select the PowerWEB product you downloaded, and then click License Manager . You should see the screen below.

  2. The information screen should be pre-filled with all the previously entered information. If you are on a different machine than what was used to register the product, you can import your "Dart.PowerWEB.LiveControls.lic" on the next screen. Click Next to continue.

  3. The screen will show your current licenses and the servers registered for your licenses. Click Next to continue to the screen below.

  4. Under “Registered License(s)” you will see all the current serial numbers that have been registered and to the right you will see all the Web server names that have been registered for the serial numbers. To add another serial number, click Add in the “New Licenses” window to see the screen below.

  5. Enter the new serial number into the provided input area and click OK. You should now see the new server license added to the “New Licenses” window and the option to add the number of servers purchased in the “New Web Server NetBIOS Names” window (in the example below a 3 server license was purchased in addition to a previous single server license). You can now have a total of 4 Web servers licensed for deployment.

  6. You can now add two more Web servers using the Add button in the “New Web Server NetBIOS Names” window. The new servers will be visible in the “New Web Server NetBIOS Names” window.

  7. Click Next to verify the revised status of your licenses as demonstrated below.

  8. Click Next to register your new servers and license. Once the Registration Complete message is displayed you will have a new "Dart.PowerWEB.LiveControls.lic" file placed next to the installed "Dart.PowerWEB.LiveControls.dll" file. The next time you use the License Manager, your license and server information will be updated, as shown below. You export the new license if you need to distribute it to other developers or deployment servers.

License Summary

After purchasing a serial number from Dart or an authorized reseller, that serial number must be registered using the License Manager application or directly by telephone (315-339-8040) before the Web application can be deployed.

When you are ready to register, you'll need the NetBIOS names of the Web servers that will be hosting your Web application (if you do not have access to these names, you may purchase a Site or Corporate License that does not require you to license each server name). The serial number you purchased should contain a license for the required number of Web servers. You do not have to register all the servers at once. For example, if you purchased a serial number for 5 Web servers, but only have one at the moment, you can register one now and return later to register the other Web server names.

When registering a serial number for a PowerWEB for ASP.NET product, a license file, such as "Dart.PowerWEB.LiveControls.lic", is created on your system (or sent to you if you do not have Internet access for the License Manager application). This file is located in the installation directory of the Web control. "Dart.PowerWEB.LiveControls.lic" contains the NetBIOS server names specified during registration. If, at a later time, you add more Web server names then a new "Dart.PowerWEB.LiveControls.lic" file will be generated to replace the old one. Once you receive this file, it should also be distributed to any other developers working with the PowerWEB for ASP.NET product.

When you compile your Web application using Visual Studio C# or VB, the information from "Dart.PowerWEB.LiveControls.lic" is automatically compiled into the Web application enabling you to XCOPY the application to a target Web server. If you deployed your application using the free 7 day trial server license, and no valid serial number is installed, it will operate for 7 days without a nag screen. If you deployed your application using the free 7 day trial server license, and a valid serial number is installed, it will operate for 7 days with a notification screen (our assumption being that you may have made a mistake specifying the server's NetBIOS name).

When you compile your Web application using Visual Studio C++ 7 or IIS compiles your application on-the-fly, the information from "Dart.PowerWEB.LiveControls.lic" is NOT automatically compiled into the Web application, so you will have to include "Dart.PowerWEB.LiveControls.lic" in your application's "\Bin" directory. This technique will also work when LiveControl classes are not added to your application's ".licx" file. However, when not compiled in, the trial server license cannot be reset to 7 days. To work around this, just start the License Manager and shut it down. This will reset the trial server license to 7 days in "Dart.PowerWEB.LiveControls.lic", so that you may now copy it into your "\Bin" directory for testing.

If you require any changes to your license, such as changing a Web server name after registration, please contact Dart at 315-339-8040 or email sales@dart.com with your questions. Our license is designed to provide maximum flexibility so please contact us with any comments or requirements that are not listed in this document.

Troubleshooting Licensing

For help troubleshooting licensing issues, see www.dart.com/support/lictrouble.asp.

See Also

Reference | Advanced Topics

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Trial Operation

PowerWEB for ASP.NET is a suite of products that is licensed as follows:

Development License

All PowerWEB products include an unlimited development license for development and loop-back runtime testing (the URL is "localhost" or "127.0.0.1"). A reminder will appear once a day indicating that a 7 day trial server license is in effect for remote testing of the application. Once a serial number has been registered, this reminder will no longer appear.

7 Day Trial Server License

When your Web application is compiled using Visual Studio C# or VB, your fully functional application can be remotely run for 7 days with no nag screen. However, if a valid serial number is present and the server name does not match the host's NetBIOS name, then a dialog appears to indicate that the provided NetBIOS name(s) do not match the server. After 7 days, a short grace period allows operation with a nag screen.

When your Web application is compiled using Visual Studio C++ or you are not using Visual Studio, then you will need to manually reset your 7 day trial server license. This can be done by starting the License Manager and immediately exiting. You will need to include the generated "Dart.PowerWEB.LiveControls.lic" in your "\Bin" directory.

Server License

Most users will purchase a Server License and enter the names of the licensed servers by using the Register Program. Other licensing options include Site, Corporate, and Distribuition Licenses. Please contact our sales department if you have any questions.

See License Installation for more information on product registration.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Deployment In ASP.NET

Deploying a Web application to a target server that uses the PowerWEB TextBox for ASP.NET is easy. First, the server's NetBIOS name must be registered with Dart by running the License Manager. Then, Visual Studio users will typically recompile (to insert the license), XCOPY their application to the server, and copy the contents of the "PowerWEB_TextBox_Common" directory (scripts, images, etc.) to a directory that may be shared by all applications using TextBox.

When PowerWEB TextBox for ASP.NET is installed on your development platform, a virtual directory named "PowerWEB_TextBox_Common" is automatically created and set to refer to "C:\Program Files\PowerWEB\TextBox for ASP.NET\Common". All usage of TextBox subsequently uses this common directory to access necessary scripting text, images, etc. When deploying to a server, you need to ensure that such a directory is present and populated. If you are using a hosting service that does not allow this, just use a directory within your application and update each component's ScriptsDirectory property to the directory you are using.

To deploy your project follow these steps

  1. Ensure the NetBIOS name of your server is present in "Dart.PowerWEB.TextBox.lic". The License Manager may be run at any time to check for registered server names. New server names may be entered and registered at any time.
  2. If using Visual Studio, ensure that "HtmlBox" is included in "licenses.licx" and recompile your application. This will embed the PowerWEB license into your dll.
  3. Add a "\Bin" subdirectory to your project's directory (if you are using Visual Studio .NET or WebMatrix this will most likely already be there). For example, if the project is called TextBox, you should have a directory structure with "TextBox\Bin".
  4. Copy both "Dart.PowerWEB.TextBox.dll" and "Dart.PowerWEB.LiveControls.dll" to the "\Bin" directory. Your development environment may have already put a copy there when you added HtmlBox as a reference.
  5. Be sure that a copy of "Dart.PowerWEB.TextBox.lic" is in the project's "\Bin" directory. In VS.Net, if not already present, this file will be automatically imported into "\Bin" when the control is added to the project. If no "lic" file is found containing registered server names, a trial "lic" file will be created. It is important to note that updates performed by the Registration program to the "lic" file will only be reflected in projects that do not already have a "lic" file present. Therefore, after licensing a server name, it is necessary to delete the "lic" file from a project's "\Bin" directory so that it can be replaced with the updated version. The file can manually be copied and pasted to the "\Bin". Alternatively, it can automatically be imported, either by adding a new HtmlBox to the project, or by switching between HTML and Design modes in design-time.
  6. You should now have the TextBox directory with your ASPX file present (in this example we will call it default.aspx).
  7. XCOPY or FTP your project, including the "\Bin" folder, to the target server.
  8. Create a virtual directory on the target server that refers to the application's new directory. Of course, you can always install directly to the "wwwroot" structure.
  9. If you have previously set up a TextBox project on that server and you already have directories for images, scripts, and uploads created, everything is finished. If not, please continue.

    10. Note:
    The HtmlBox control will look for images, scripts, uploads, and skins in the default virtual directories of \PowerWEB_TextBox_Common\Images, \PowerWEB_TextBox_Common\Scripts, \PowerWEB_TextBox_Common\Skins, and \PowerWEB_TextBox_Common\UploadedFiles. The control contains properties that let you specify your own file locations, if a different directory is required. For this example, we will use the default settings.

  10. When you installed the PowerWEB TextBox for ASP.NET product, the files required for the virtual directory were placed in c:\Program Files\PowerWEB\TextBox for ASP.NET\Common. You can just FTP or XCOPY the directory to the target web server.
  11. Once on the target server, you will need to create a virtual directory called PowerWEB_TextBox_Common that points to the directory where you placed the \Common directory.
  12. Now access the we site using IE at http://yourservername/BoxTest.

Common Errors

Within the Visual Studio environment, when you drag the HtmlBox onto a form, the classname is automatically added to the project's ".licx" file. If you are dynamically creating HtmlBox, then you will have to add this reference yourself.

Be sure to always include "Dart.PowerWEB.TextBox.lic" in your "\Bin" directory so your run-time license can be found when HtmlBox is used.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Support Options

Our mission at Dart is to deliver high quality controls for Web developers. Our goal is to supplement these solutions with timely support resources that can help at many different levels.

Related Links (you have an active connection to the Internet to view these links).

Paid Support Options
Discusses the paid support options available covering everything from single incidences, to extensive subscriptions.
Free Support Options
Provides access to free materials to help your development, including FAQS, online help files, tutorials, code snippets, online asp samples, and a free support forum.
Support Forum
Provides access to our support forum, monitored by our own development staff as time permits.
Beyond Support
Discusses the custom development support offered by Dart Solutions.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Using PowerWEB Within VS.NET

PowerWEB TextBox for ASP.NET is a powerful WYSIWYG HTML editing area that can be added to any ASP.NET application. This topic and associated subtopics are mostly prerequisite to the usage of PowerWEB TextBox for ASP.NET. For example, this topic illustrates such things as basic usage within Visual Studio.NET. If you are already familiar with these tasks, you may benefit more by examining other topics.

In This Section

Creating a new project
Describes how to create a new project in VS.NET.
Adding an HtmlBox control to a WebForm.
Describes how to add the HtmlBox to a WebForm.
Designer Support
Discusses designer support features available when using VS.NET.
Walkthrough: Creating a simple application using code-behind
Demonstrates how to create a simple HTML editing application in VS.NET using code-behind techniques.
Walkthrough: Creating a simple application using the Properties Builder
Demonstrates how to create a simple HTML editing application in VS.NET using the Properties Builder.
Deploying Your Project
Discusses how to deploy your finished project.

Related Sections

Getting Started
Provides an overview of PowerWEB TextBox for ASP.NET and discusses such topics as distribution, licensing, and support.
Using PowerWEB in WebMatrix
Provides step-by-step instructions for creating a project using WebMatrix, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB with Notepad
Provides step-by-step instructions for creating a simple project using notepad only.
Configuring the HtmlBox
Discusses how to easily configure the HtmlBox, including style, layout, and toolbar configuration.
Advanced Customization
Discusses the many ways the HtmlBox control can be customized, from simple style changes to advanced interface element creation.
Optimizing Performance
Discusses techniques for optimizing performance of the HtmlBox control, including reducing ViewState and render-size.
Reference
Provides a language/syntax and client-side API reference for PowerWEB TextBox for ASP.NET.
HtmlBox Control Samples
Describes the samples that are installed with PowerWEB TextBox for ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Creating A New Project in VS.NET

The following steps provide a walkthrough to create a project in Visual Studio.NET. Although PowerWEB TextBox for ASP.NET can be used in your preferred environment on any machine that has the .NET Framework installed, the recommended method is to use the Visual Studio .NET environment.

To create a project in Visual Studio .NET, use the following steps (the following steps demonstrate using the HtmlBox control):

  1. Start Visual Studio .NET.
  2. From the File menu, choose New, and then choose Project.
  3. From the resulting dialog box, choose either Visual C# Projects or Visual Basic Projects and then choose ASP.NET Web Application. Specify a name and a location for the project, and then click OK.

  4. After these steps have been completed, the project is created.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Adding the HtmlBox to a WebForm in VS.NET

Although PowerWEB TextBox for ASP.NET can be used in your preferred environment on any machine that has the .NET Framework installed, the recommended method is to use the Visual Studio .NET environment.

NOTE If you copy and paste a HtmlBox from one form to another in the designer, be sure to add the <%@ Register %> directive to your page.

To add the HtmlBox control to a WebForm within Visual Studio .NET, use the following steps (the following steps demonstrate using the HtmlBox component):

  1. Create a project as described in Creating A Project.
  2. Add the HtmlBox control to the form. To do this, right-click on the ToolBox and choose Customize ToolBox If the ToolBox is not visible, navigate to the View menu and choose ToolBox

  3. From the resulting dialog box, choose the .NET Framework Components tab, and then scroll until you find the HtmlBox component (see the screen shot below). Check the checkbox next to it and select OK.

  4. Click the HtmlBox control icon on the ToolBox, and "drag" an instance of it onto the design surface that represents a WebForm. The Visual Studio .NET environment will automatically create and instantiate an instance of the HtmlBox control.
  5. "Dart.PowerWEB.LiveControls.dll" will also appear as a reference after inserting the control. If it does not, manually add it by selecting "Add Reference ..." from the Project menu.
  6. Make a quick application to test. Just navigate to the Debug menu and choose Start The app will compile and execute. You should see Internet Explorer launch with the default layout of the HtmlBox component.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Designer Support

Visual Studio .NET provides for a rich design time experience in their Designer. When the HtmlBox is dragged on the Designer, a visual representation of the default HtmlBox view is displayed.

There are three ways to manipulate the HtmlBox control:

  • Code Behind is the standard Microsoft methodology for writing ASP.NET applications. By double clicking on the Designer, the class representing the WebForm will be available for coding.
  • Advanced users can directly manipulate the tags in the ASPX file by choosing the HTML button at the bottom of the Designer. The HTML tag view with just the default HtmlBox is shown below.
  • For rapid application development, the HtmlBox can be configured without any code by using the Property Builder, available by choosing the link at the bottom of the Property Window shown below.
  • Once the Property Builder link is clicked, the Property Builder will launch, as shown below:

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Walkthrough: Creating a Simple Editor Application in VS.NET using Code Behind

  1. Follow the steps outlines in Adding the HtmlBox to a WebForm in VS.NET so that an HtmlBox control is visible on the Designer.
  2. To add code using Code Behind double click the Designer to bring up the class representing the WebForm, then enter your code into the Page_Load event.

    3. [Visual Basic, C#] The following code demonstrates setting the HtmlBox.BackColor, HtmlBox.BorderWidth properties and the AddToolbarItem method. For the purposes of this walkthrough, simply put this code in the Page_Load event for the WebForm.

    [C#]
HtmlBox1.BackColor = System.Drawing.Color.Red;
HtmlBox1.BorderWidth = 4;
HtmlBox1.AddToolbarItem(Dart.PowerWEB.TextBox.ToolbarItemType.InsertTable);
[Visual Basic]
HtmlBox1.BackColor = System.Drawing.Color.Red
HtmlBox1.BorderWidth = 4
HtmlBox1.AddToolbarItem(Dart.PowerWEB.TextBox.ToolbarItemType.InsertTable)
  3. Compile and run the Web application. You should now have a Web page in Internet Explorer that contains an HtmlBox with a red back color, a border width of 4, and a new toolbar item for inserting tables, as shown below.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Walkthrough: Creating a Simple Editor Application in VS.NET using the Properties Builder

The following steps provide a walkthrough to create a project in Visual Studio.NET. Although PowerTCP Mail for .NET can be used in your preferred environment on any machine that has the .NET Framework installed, the recommended method is to use the Visual Studio .NET environment.

  1. Follow the steps outlines in Adding the HtmlBox to a WebForm in VS.NET so that an HtmlBox control is visible on the Designer.
  2. Launch the Property Builder as specified in Designer Support topic.
  3. Choose the Format tab and change the BackColor and Border Width values as shown below.
  4. Compile and run the Web application. You should now have a Web page in Internet Explorer that contains an HtmlBox with a red back color, a border width of 4, and a new toolbar item for inserting tables, as shown below.

  5. Now change the tab to Toolbar to add a new button, click the Add button, choose Add Button from the menu and then Insert Table from the sub-menu as shown below. You will see the Insert Table button added to the list of available buttons
  6. Click OK and you will see the changes reflected in the Design view.
  7. Compile and run the Web application. You should now have a Web page in Internet Explorer that contains an HtmlBox with a red back color, a border width of 4, and a new toolbar item for inserting tables

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Deploying Your Project

For information on how to deploy your finished project to the production server, see Deployment In ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Using PowerWEB Within WebMatrix

This topic and associated subtopics are mostly prerequisite to the usage of PowerWEB TextBox for ASP.NET in ASP.NET Web Matrix. If you are already familiar with these tasks, you may benefit more by examining other topics. Web Matrix is a free ASP.NET development environment provided by Microsoft. While it does not possess all the features of Visual Studio .NET, many of the core technologies are re-used in Web Matrix. While Web Matrix is similar to Visual Studio .NET, certain limitations of the environment necessitate special instructions.

In This Section

Creating a new project
Describes how to create a new project in WebMatrix.
Adding an HtmlBox control to a WebForm.
Describes how to add the HtmlBox to a WebForm.
Designer Support
Discusses designer support features available when using VS.NET.
Walkthrough: Creating a simple application
Demonstrates how to create a simple HTML editing application in WebMatrix.
Deploying Your Project
Discusses how to deploy your finished project.

Related Sections

Getting Started
Provides an overview of PowerWEB TextBox for ASP.NET and discusses such topics as distribution, licensing, and support.
Using PowerWEB in VS.NET
Provides step-by-step instructions for creating a project using VS.NET, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB with Notepad
Provides step-by-step instructions for creating a simple project using notepad only.
Configuring the HtmlBox
Discusses how to easily configure the HtmlBox, including style, layout, and toolbar configuration.
Advanced Customization
Discusses the many ways the HtmlBox control can be customized, from simple style changes to advanced interface element creation.
Optimizing Performance
Discusses techniques for optimizing performance of the HtmlBox control, including reducing ViewState and render-size.
Reference
Provides a language/syntax and client-side API reference for PowerWEB TextBox for ASP.NET.
HtmlBox Control Samples
Describes the samples that are installed with PowerWEB TextBox for ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Creating A New Project in WebMatrix

The following steps provide a walkthrough to create a project in ASP.NET Web Matrix.

To create a project in Web Matrix, use the following steps (the following steps demonstrate using the HtmlBox control):

  1. Start ASP.NET Web Matrix.
  2. From the File menu, choose New File
  3. From the resulting dialog box, choose either C# or Visual Basic and then choose ASP.NET Page Specify a name and a location for the project, and then click OK

  4. After these steps have been completed, the ASPX page is created.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Adding the HtmlBox to a WebForm in Web Matrix

To add the HtmlBox control to a WebForm using Web Matrix, use the following steps (the following steps demonstrate using the HtmlBox component):

  1. Create a project as described in Creating a New Project.
  2. Add the HtmlBox control to the form. To do this, right-click on the ToolBox and choose Add Local Toolbox Component. If the ToolBox is not visible, navigate to the View menu and choose ToolBox.
  3. From the resulting dialog box, scroll until you find the Dart.PowerWEB.TextBox assembly (see the screen shot below). Check the checkbox next to it and select Add and then OK. The HtmlBox control will be added to the ToolBox. If the Dart.PowerWEB.TextBox.dll is not in the GAC, you can choose the Browse button and find the control manually.

  4. Click the HtmlBox control icon on the ToolBox, and "drag" an instance of it onto the design surface that represents a WebForm. The Web Matrix environment will automatically create and instantiate an instance of the HtmlBox control. You may notice that the images on the designer are not visible and are represented by an X. This occurs when the Web Matrix environment can’t find the Images Directory and the Script Directory. Because Web Matrix does not create a virtual directory like Visual Studio .NET, you may have to set the ImagesDirectory and ScriptsDirectory properties to the necessary directories. The directories can be found in the installation directory of PowerWeb/TextBox/Common. You should now see the Designer get updated. If not, switch the Designer to HTML view and back again to force a refresh.
  5. Check to make sure "Dart.PowerWEB.LiveControls.dll" appears alongside Dart.PowerWEB.TextBox.dll in the application's bin directory after inserting the control. If it does not, find it in the bin folder under the directory where the Toolkit was installed, and copy it to the application's bin folder.
  6. Make a quick application to test. Just navigate to the Start button on the toolbar. The app will compile and execute. Selecting the IIS option for testing is recommended. You should see Internet Explorer launch with the default layout of the HtmlBox component.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Designer Support

ASP.NET Web Matrix provides for a design time experience in the Designer. When the HtmlBox is dragged on the Designer, a visual representation of the default HtmlBox view is displayed.

There are two primary ways to manipulate the HtmlBox control:

  • Users can directly manipulate the tags in the ASPX file by choosing the Code or All tab at the bottom of the Designer. The All view with just the default HtmlBox is shown below.
  • For rapid application development, the HtmlBox can be configured without any code by using the Property Builder, available by choosing the link at the bottom of the Property Window shown below.
  • 3. Once the Property Builder link is clicked, the Property Builder will launch, as shown below:

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Walkthrough: Creating a Simple Editor Application in ASP.NET Web Matrix

  1. Follow the steps outlines in Creating an Instance of the Control Using ASP.NET Web Matrix so that an HtmlBox control is visible on the Designer.
  2. To add code Code tab to bring up the code view.

    3. [Visual Basic, C#] The following code demonstrates setting the HtmlBox.BackColor, HtmlBox.BorderWidth properties and the AddToolbarItem method. For the purposes of this walkthrough, simply add this code.

    [C#]
void Page_Load(object sender, EventArgs e)
{
HtmlBox1.BackColor = System.Drawing.Color.Red;
HtmlBox1.BorderWidth = 4;
HtmlBox1.AddToolbarItem(Dart.PowerWEB.TextBox.ToolbarItemType.InsertTable);
}
[Visual Basic]
Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
   HtmlBox1.BackColor = System.Drawing.Color.Red
   HtmlBox1.BorderWidth = Unit.Parse(4)
   HtmlBox1.AddToolbarItem(Dart.PowerWEB.TextBox.ToolbarItemType.InsertTable)
End Sub
  3. Compile and run the Web application. You should now have a Web page in Internet Explorer that contains an HtmlBox with a red back color, a border width of 4, and a new toolbar item for inserting tables, as shown below.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Using PowerWEB With Notepad

This topic and associated subtopics are mostly prerequisite to the usage of PowerWEB TextBox for ASP.NET in notepad. If you are already familiar with these tasks, you may benefit more by examining other topics.

In This Section

Adding an HtmlBox control to a webform.
Describes how to add the HtmlBox to a WebForm.
Walkthrough: Creating a simple application
Demonstrates how to create a simple HTML editing application using notepad.
Deploying Your Project
Discusses how to deploy your finished project.

Related Sections

Getting Started
Provides an overview of PowerWEB TextBox for ASP.NET and discusses such topics as distribution, licensing, and support.
Using PowerWEB in VS.NET
Provides step-by-step instructions for creating a project using VS.NET, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB in WebMatrix
Provides step-by-step instructions for creating a project using WebMatrix, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Configuring the HtmlBox
Discusses how to easily configure the HtmlBox, including style, layout, and toolbar configuration.
Advanced Customization
Discusses the many ways the HtmlBox control can be customized, from simple style changes to advanced interface element creation.
Optimizing Performance
Discusses techniques for optimizing performance of the HtmlBox control, including reducing ViewState and render-size.
Reference
Provides a language/syntax and client-side API reference for PowerWEB TextBox for ASP.NET.
HtmlBox Control Samples
Describes the samples that are installed with PowerWEB TextBox for ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Adding the HtmlBox to a WebForm Using Notepad

To add the HtmlBox control to a WebForm using notepad, use the following steps:

  1. Be sure PowerWEB TextBox for ASP.NET has been properly installed.
  2. Create a new file in notepad.
  3. Add the proper @Register directive to the top of the new file, for example:
    <%@ Register TagPrefix="cc1" Namespace="Dart.PowerWEB.TextBox" Assembly="Dart.PowerWEB.TextBox, Version=1.0.0.0, Culture=neutral, PublicKeyToken=5966291b8955e4bb" %>
  4. Be sure you have added form runat="server" tags to the HTML body. These tags are required for the HtmlBox.
    5. <form runat="server" ID="Form1">
</form>
  5. Create the HtmlBox server tags within the form tags. This will create an HtmlBox with default configuration.
    6. <cc1:HtmlBox id="HtmlBox1" runat="server"></cc1:HtmlBox>
  6. When complete, your entire file should look like the following.
    7. <%@ Register TagPrefix="cc1" Namespace="Dart.PowerWEB.TextBox" Assembly="Dart.PowerWEB.TextBox, Version=1.0.0.0, Culture=neutral, PublicKeyToken=5966291b8955e4bb" %>
<html>
   <body>
      <form runat="server" ID="Form1">
         <cc1:HtmlBox id="HtmlBox1" runat="server"></cc1:HtmlBox>
      </form>
   </body>
</html>
  7. Save the file.
  8. Using IIS Administrator, create a virtual directory pointing to the directory where you just saved the file.
  9. Open the file in IE, it should compile automatically and run, displaying the editor.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Walkthrough: Creating a Simple Editor Application Using Notepad

  1. Follow the steps outlines in Creating an Instance of the Control Using Notepad.
  2. Add an ASP.NET Label to the form.
    <asp:Label id="Label1" runat="server">Result</asp:Label>
  3. Add an ASP.NET Button to the form.
    <asp:Button id="Button1" onclick="Button1_Click" runat="server" Text="Get Results"></asp:Button>
  4. Add the following code to handle the button click.
    <script runat="server">
    Sub Button1_Click(sender As Object, e As EventArgs)
        Label1.Text = HtmlBox1.Text
    End Sub
</script>
  5. When complete, your entire file should look like the following.
    6. <%@ Page Language="VB" %>
<%@ Register TagPrefix="cc1" Namespace="Dart.PowerWEB.TextBox" Assembly="Dart.PowerWEB.TextBox, Version=1.0.0.0, Culture=neutral, PublicKeyToken=5966291b8955e4bb" %>
<script runat="server">
    Sub Button1_Click(sender As Object, e As EventArgs)
        Label1.Text = HtmlBox1.Text
    End Sub
</script>
<html>
<head>
</head>
<body>
    <form runat="server">
        <cc1:HtmlBox id="HtmlBox1" runat="server"></cc1:HtmlBox>
        <asp:Label id="Label1" runat="server">Label</asp:Label>
        <asp:Button id="Button1" onclick="Button1_Click" runat="server" Text="Button"></asp:Button>
    </form>
</body>
</html>
  6. Save the file.
  7. Using IIS Administrator, create a virtual directory pointing to the directory where you just saved the file.
  8. Open the file in IE, it should compile automatically and run, displaying the editor. Add some content to the editor and click the button.

Note: You can also use codebehind files for server-side functions. Be sure to add a "src" attribute to the Page tag so the code page is automatically compiled. For example:

<%@ Page Language="c#" src="myCode.asax.cs" %>

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Configuring the HtmlBox

PowerWEB TextBox for .NET is capable of implementing an HTML editor in a variety of scenarios, from a full-blown content editor application to a simple, scaled-down editor. Depending on the type of application, and other Internet considerations (such as typical bandwidth of your users), you may wish to tune the HtmlBox for optimal performance. This section describes steps you can take to tune for performance.

In This Section

Using the Property Builder
Describes how to use the built-in Property Builder to completely configure the HtmlBox without writing code.
Configuring Toolbar Layout
Describes the techniques that can be used to easily configure the items on a toolbar.
Configuring Style
Describes the techniqes that can be used to easily configure the style of the HtmlBox.
Using Helper Properties
Describes using the high-level "helper properties" to easily customize elements such as font names available in the drop down.

Related Sections

Getting Started
Provides an overview of PowerWEB TextBox for ASP.NET and discusses such topics as distribution, licensing, and support.
Using PowerWEB in VS.NET
Provides step-by-step instructions for creating a project using VS.NET, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB in WebMatrix
Provides step-by-step instructions for creating a project using WebMatrix, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB with Notepad
Provides step-by-step instructions for creating a simple project using notepad only.
Advanced Customization
Discusses the many ways the HtmlBox control can be customized, from simple style changes to advanced interface element creation.
Optimizing Performance
Discusses techniques for optimizing performance of the HtmlBox control, including reducing ViewState and render-size.
Reference
Provides a language/syntax and client-side API reference for PowerWEB TextBox for ASP.NET.
HtmlBox Control Samples
Describes the samples that are installed with PowerWEB TextBox for ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Configuring the HtmlBox using the Property Builder

The HtmlBox control can be configured using Code Behind, HTML server-side tags, skins, or the Property Builder. This topic will discuss configuring the HtmlBox control using the Property Builder, which allows almost all aspects of the control to be customized without writing any code. When a change is made using the Property Builder or the Property Window of the IDE, all changes are reflected in the Designer, enabling a preview of the output that will occur when the HtmlBox is rendered to the client. The following subtopics address the Property Builder:

  • Launching the Property Builder
  • Property Builder Organization
  • Using the Property Builder

Launching the Property Builder

To launch the Property Builder, bring up the Property Window from the IDE and click the Property Builder hyperlink at the bottom as shown below.

You should see the Property Builder appear as shown below:

Property Builder Organization:

The Property Builder is organized into eight sections.

  1. General – Lets you specify fonts, general appearance, general behavior, and directories for uploads, Images, and Scripts.
  2. Format – Lets you format high-level objects such as the HtmlBox, toolbar, tabstrip, progress bar, buttons, dialogs, menus, dropdowns, and down level. For each of these you can change the font, color, and border details.
  3. Toolbar – Lets you to add and remove buttons from the toolbar. Every button has properties that can be set.
  4. Text Window – Lets you configure how the text area of the HtmlBox will operate.
  5. Tabstrip – Lets you configure the tabstrip text and images.
  6. Progress Bar - Lets you specify the operation of the progress bar.
  7. Skins – Lets you load and save skins.
  8. Down Level – Lets you specify down level operation.

Using the Property Builder:

The Property Builder allows for the customization of the HtmlBox without writing any code. You can update the designer with your changes by using the Apply button. After you hit Apply, you can undo your changes with the Undo button, but once you make another change, Undo will no longer be available.

When setting color-based properties, a color-picker is available to the right of the input area. If you are specifying directories, such as the scripts or images directory, you will have a directory dialog allowing for the selection of a directory relative to the document, a virtual directory, an absolute URL, or a local path.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Configuring Toolbar Layout

The most common form of configuration is configuration of the toolbar, such as adding new items to the toolbar, removing default items from the toolbar, or changing the order of items in the toolbar. This can all be done using the Property Builder application without writing code (see Configuring the HtmlBox using the Property Builder for more information about this). This topic addresses configuring the toolbar using coding techniques. PowerWEB TextBox for ASP.NET provides a set of preconfigured items which are enumerated by the ToolbarItemType enumeration. This enumeration can be used in conjunction with the AddToolbarItem method to quickly create and add a toolbar item or with the associated object constructor to provide default values to a created object.

The following topics address configuration using preconfigured items. If you need to create custom items, see the Advanced Customization topic.

  • Creating a toolbar layout using server tags
  • Creating a toolbar layout quickly using AddToolbarItem
  • Fine-tuned toolbar layout using the Items collection

Creating a toolbar layout using server tags

If you are not using code-behind, you can configure the toolbar layout using server tags only.

<cc1:htmlbox id=HtmlBox1 runat="server">
   <Toolbar>
      <cc1:ToolbarButton Type="Bold"></cc1:ToolbarButton>
      <cc1:ToolbarButton Type="Italic"></cc1:ToolbarButton>
      <cc1:ToolbarButton Type="Underline"></cc1:ToolbarButton>
      <cc1:ToolbarImage Type="RowSeparator"></cc1:ToolbarImage>
      <cc1:ToolbarDropDown Type="FontName"></cc1:ToolbarDropDown>
      <cc1:ToolbarDialogButton Type="FontColor"></cc1:ToolbarDialogButton>
      <cc1:ToolbarMenuButton Type="InsertTable"></cc1:ToolbarMenuButton>
      <cc1:ToolbarUploadButton Type="InsertImage"></cc1:ToolbarUploadButton>
   </Toolbar>
</cc1:htmlbox>

Creating a toolbar layout quickly using AddToolbarItem

The quickest way to create a toolbar layout is to use the AddToolbarItem method. The following example demonstrates clearing the default layout, adding a few buttons, adding a row, and adding a few more buttons.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   if(!Page.IsPostBack)
   {
      // First clear the default config.
      HtmlBox1.Clear();

      // Add a few standard buttons
      HtmlBox1.AddToolbarItem(ToolbarItemType.Bold);
      HtmlBox1.AddToolbarItem(ToolbarItemType.Italic);
      HtmlBox1.AddToolbarItem(ToolbarItemType.Underline);

      // Add a new row
      HtmlBox1.AddToolbarItem(ToolbarItemType.RowSeperator);

      // Add a few more buttons
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontName);
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontColor);
      HtmlBox1.AddToolbarItem(ToolbarItemType.InsertTable);
      HtmlBox1.AddToolbarItem(ToolbarItemType.InsertImage);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' First clear the default config.
      HtmlBox1.Clear()

      ' Add a few standard buttons
      HtmlBox1.AddToolbarItem(ToolbarItemType.Bold)
      HtmlBox1.AddToolbarItem(ToolbarItemType.Italic)
      HtmlBox1.AddToolbarItem(ToolbarItemType.Underline)

      ' Add a new row
      HtmlBox1.AddToolbarItem(ToolbarItemType.RowSeperator)

      ' Add a few more buttons
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontName)
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontColor)
      HtmlBox1.AddToolbarItem(ToolbarItemType.InsertTable)
      HtmlBox1.AddToolbarItem(ToolbarItemType.InsertImage)
   End If
End Sub

Fine-tuned toolbar layout using the Items collection

The AddToolbarItem method provides an easy to use mechanism to quickly create a toolbar without concern for the type of object you are adding. While this works well for most scenarios, it doesn't provide the absolute flexibility required for every scenario. For optimal flexibility, use the Items collection, which gives you the ability to Add, Insert, Remove, and other collection specific methods.

In order to use this, you must have knowledge of the various object types used to represent each toolbar item. These are listed in the ToolbarItemType enumeration topic.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   if(!Page.IsPostBack)
   {
      // First clear the default config.
      HtmlBox1.Toolbar.Items.Clear();

      // Add a few standard buttons

      // First bold (which is a ToolbarButton type)
      ToolbarButton bold = new ToolbarButton(ToolbarButtonType.Bold);

      // Italic (also a ToolbarButton type)
      ToolbarButton italic = new ToolbarButton(ToolbarButtonType.Italic);

      // Underline (also a ToolbarButton type)
      ToolbarButton underline = new ToolbarButton(ToolbarButtonType.Underline);

      // Add them to the toolbar
      HtmlBox1.Toolbar.Items.Add(bold);
      HtmlBox1.Toolbar.Items.Add(italic);
      HtmlBox1.Toolbar.Items.Add(underline);

      // Add a new row (which is a ToolbarImage type)
      ToolbarImage row = new ToolbarImage(ToolbarImageType.RowSeperator);
      HtmlBox1.Toolbar.Items.Add(row);

      // Add a few more buttons

      // FontName is a ToolbarDropDown type
      ToolbarDropDown fontName = new ToolbarDropDown(ToolbarDropDownType.FontName);

      // FontColor is a ToolbarDialogButton type
      ToolbarDialogButton fontColor = new ToolbarDialogButton(ToolbarDialogButtonType.FontColor);

      // InsertTable is a ToolbarMenuButton type
      ToolbarMenuButton insertTable = new ToolbarMenuButton(ToolbarMenuButtonType.InsertTable);

      // InsertImage is a ToolbarUploadButton type
      ToolbarUploadButton insertImage = new ToolbarUploadButton(ToolbarUploadButtonType.InsertImage);

      // Add them to the toolbar
      HtmlBox1.Toolbar.Items.Add(fontName);
      HtmlBox1.Toolbar.Items.Add(fontColor);
      HtmlBox1.Toolbar.Items.Add(insertTable);
      HtmlBox1.Toolbar.Items.Add(insertImage);

      // Now, to demonstrate the advanced Toolbar.Items management, we
      // will insert a button just before the new row.

      // First, get the row instance
      row = (ToolbarImage)HtmlBox1.Toolbar.Items.GetByType(ToolbarItemType.RowSeperator);

      // Get the index of the row
      int index = HtmlBox1.Toolbar.Items.IndexOf(row);

      // Insert a new button just before the row
      ToolbarButton subscript = new ToolbarButton(ToolbarButtonType.Subscript);
      HtmlBox1.Toolbar.Items.Insert(index-1, subscript);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' First clear the default config.
      HtmlBox1.Toolbar.Items.Clear()

      ' Add a few standard buttons

      ' First bold (which is a ToolbarButton type)
      Dim bold As New ToolbarButton(ToolbarButtonType.Bold)

      ' Italic (also a ToolbarButton type)
      Dim italic As New ToolbarButton(ToolbarButtonType.Italic)

      ' Underline (also a ToolbarButton type)
      Dim underline As New ToolbarButton(ToolbarButtonType.Underline)

      ' Add them to the toolbar
      HtmlBox1.Toolbar.Items.Add(bold)
      HtmlBox1.Toolbar.Items.Add(italic)
      HtmlBox1.Toolbar.Items.Add(underline)

      ' Add a new row (which is a ToolbarImage type)
      Dim row As New ToolbarImage(ToolbarImageType.RowSeperator)
      HtmlBox1.Toolbar.Items.Add(row)

      ' Add a few more buttons

      ' FontName is a ToolbarDropDown type
      Dim fontName As New ToolbarDropDown(ToolbarDropDownType.FontName)

      ' FontColor is a ToolbarDialogButton type
      Dim fontColor As New ToolbarDialogButton(ToolbarDialogButtonType.FontColor)

      ' InsertTable is a ToolbarMenuButton type
      Dim insertTable As New ToolbarMenuButton(ToolbarMenuButtonType.InsertTable)

      ' InsertImage is a ToolbarUploadButton type
      Dim insertImage As New ToolbarUploadButton(ToolbarUploadButtonType.InsertImage)

      ' Add them to the toolbar
      HtmlBox1.Toolbar.Items.Add(fontName)
      HtmlBox1.Toolbar.Items.Add(fontColor)
      HtmlBox1.Toolbar.Items.Add(insertTable)
      HtmlBox1.Toolbar.Items.Add(insertImage)

      ' Now, to demonstrate the advanced Toolbar.Items management, we
      ' will insert a button just before the new row.

      ' First, get the row instance
      row = HtmlBox1.Toolbar.Items.GetByType(ToolbarItemType.RowSeperator)

      ' Get the index of the row
      Dim index As Integer = HtmlBox1.Toolbar.Items.IndexOf(row)

      ' Insert a new button just before the row
      Dim subscript As New ToolbarButton(ToolbarButtonType.Subscript)
      HtmlBox1.Toolbar.Items.Insert(index-1, subscript)
   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Configuring Style

PowerWEB TextBox for ASP.NET provides extensive support for style modification. Every object used by PowerWEB TextBox for ASP.NET derives from web control (for example, HtmlBox, ToolbarButton, Toolbar, TabStrip, etc all derive from WebControl). This means that every object has it's own style object attached to it, allowing you to customize the look and feel of every displayed item. This can be as simple as making the editor a different color, or as elaborate as making each button, dialog, and menu a different color. To make it easier to configure, several global style objects are available. These are useful because they apply style changes to all applicable objects, which can be a time-saver when you want all similar objects to have the same style. For example, if you want all buttons to be yellow, instead of changing the BackColor of each button object to yellow, you cn simply change ButtonStyle.BackColor to yellow, which will apply the change to all buttons. The global style objects available are:

  • HtmlBox.ButtonStyle - Any style changes applied to this object are applied to all buttons on the editor.
  • HtmlBox.MenuStyle - Any style changes applied to this object are applied to all menus on the editor. These could be menus launched by a button (which is the case when using an InsertTable type of button) or the right-click menu.
  • HtmlBox.DialogStyle - Any style changes applied to this object are applied to all dialogs launched by the editor.
  • HtmlBox.DropDownStyle - Any style changes applied to this object are applied to all dropdowns on the editor.

This can all be done using the Property Builder application without writing code (see Configuring the HtmlBox using the Property Builder for more information about this). This topic addresses configuring styles using coding techniques.

The following topics are addressed:

  • Setting styles using server tags
  • General style implementation.
  • Using the global style objects
  • Special note about ButtonStyle
  • Applying style to individual toolbar items

Setting styles using server tags

If you are not using code-behind, you can easily set styles of all objects in the server tags. The following example demonstrates setting styles of the editor, the buttons, and the dialogs.

<cc1:HtmlBox id=HtmlBox1 runat="server" BackColor="Lime" DialogStyle-BackColor="Blue" ButtonStyle-BackColor="Red">
</cc1:HtmlBox>

General style implementation.

Often, it may only be necessary to apply style changes to the HtmlBox class. This is because other classes (such as Toolbar, TabStrip, etc) have no style, and any style changes made to the HtmlBox class will "show through", as the following code demonstrates.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Change the HtmlBox BackColor to yellow. This will cause the entire editor to appear yellow.
      HtmlBox1.BackColor = Color.Yellow;

      // Change the Toolbar BackColor to blue. This will cause the toolbar to be blue while the
      // rest of the editor remains yellow.
      HtmlBox1.Toolbar.BackColor = Color.Blue;

      // Change the TabStrip to green. This will cause the tabstrip to be green, while the toolbar
      // and editor remain blue and yellow respectively
      HtmlBox1.TabStrip.BackColor = Color.Green;
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' Change the HtmlBox BackColor to yellow. This will cause the entire editor to appear yellow.
      HtmlBox1.BackColor = Color.Yellow

      ' Change the Toolbar BackColor to blue. This will cause the toolbar to be blue while the
      ' rest of the editor remains yellow.
      HtmlBox1.Toolbar.BackColor = Color.Blue

      ' Change the TabStrip to green. This will cause the tabstrip to be green, while the toolbar
      ' and editor remain blue and yellow respectively
      HtmlBox1.TabStrip.BackColor = Color.Green
   End If
End Sub

Using the global style objects

As indicated above, it is easy to change style properties on "single occurrence" objects such as HtmlBox, Toolbar, and TabStrip. However, it is another story when there are many occurrences of an object such as in the case with buttons, dialogs, dropdowns, and menus. Instead of having to change each style of each object, several global style objects can be used to control the style of all applicable items.

ButtonStyle (a more complex case) is addressed seperately in the next section. Changing style of each object is also addressed in another section.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   if(!Page.IsPostBack)
   {
      // First change styles of all menus used (this includes the right-click menu)
      HtmlBox1.MenuStyle.ImageColumnColor = Color.Orange;
      HtmlBox1.MenuStyle.BackColor = Color.Beige;
      HtmlBox1.MenuStyle.BorderColor = Color.Blue;
      HtmlBox1.MenuStyle.BorderStyle = BorderStyle.Dotted;

      // Change styles of all dialogs.
      HtmlBox1.DialogStyle.TitlebarBackColor = Color.RoyalBlue;
      HtmlBox1.DialogStyle.BackColor = Color.BlanchedAlmond;

      // Change styles of all dropdowns
      HtmlBox1.DropDownStyle.BorderColor = Color.Red;
      HtmlBox1.DropDownStyle.BorderWidth = new Unit(3);
      HtmlBox1.DropDownStyle.BorderStyle = BorderStyle.Groove;
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' First change styles of all menus used (this includes the right-click menu)
      HtmlBox1.MenuStyle.ImageColumnColor = Color.Orange
      HtmlBox1.MenuStyle.BackColor = Color.Beige
      HtmlBox1.MenuStyle.BorderColor = Color.Blue
      HtmlBox1.MenuStyle.BorderStyle = BorderStyle.Dotted

      ' Change styles of all dialogs.
      HtmlBox1.DialogStyle.TitlebarBackColor = Color.RoyalBlue
      HtmlBox1.DialogStyle.BackColor = Color.BlanchedAlmond

      ' Change styles of all dropdowns
      HtmlBox1.DropDownStyle.BorderColor = Color.Red
      HtmlBox1.DropDownStyle.BorderWidth = new Unit(3)
      HtmlBox1.DropDownStyle.BorderStyle = BorderStyle.Groove
   End If
End Sub

Special note about ButtonStyle

The ButtonStyle property deserves special mention as it provides the capability for mouse-interaction effects. This enabled you to easily gain several different button "effects" by changing the mouse over style effects. For example, by default the buttons are set up to apply XP style effects. However, this can be changed to make the buttons appear three dimensional, as the following code illustrates.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Clear the current button style
      HtmlBox1.ButtonStyle.Clear();

      // Set the standard width, style, and color.
      HtmlBox1.ButtonStyle.BorderWidth = new Unit(2);
      HtmlBox1.ButtonStyle.BorderStyle = BorderStyle.Solid;
      HtmlBox1.ButtonStyle.BorderColor = HtmlBox1.BackColor; // Same as editor, so you don't see it.

      // Set the mouse over effects
      HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Outset;
      HtmlBox1.ButtonStyle.MouseOverBorderColor = Color.Gray;

      // Set the mouse down effects
      HtmlBox1.ButtonStyle.MouseDownBorderStyle = BorderStyle.Inset;
      HtmlBox1.ButtonStyle.MouseDownBorderColor = Color.Gray;

      // Set the mouse up effects
      HtmlBox1.ButtonStyle.MouseUpBorderStyle = BorderStyle.Solid;
      HtmlBox1.ButtonStyle.MouseUpBorderColor = HtmlBox1.BackColor;
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' Clear the current button style
      HtmlBox1.ButtonStyle.Clear()

      ' Set the standard width, style, and color.
      HtmlBox1.ButtonStyle.BorderWidth = new Unit(2)
      HtmlBox1.ButtonStyle.BorderStyle = BorderStyle.Solid
      HtmlBox1.ButtonStyle.BorderColor = HtmlBox1.BackColor ' Same as editor, so you don't see it.

      ' Set the mouse over effects
      HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Outset
      HtmlBox1.ButtonStyle.MouseOverBorderColor = Color.Gray

      ' Set the mouse down effects
      HtmlBox1.ButtonStyle.MouseDownBorderStyle = BorderStyle.Inset
      HtmlBox1.ButtonStyle.MouseDownBorderColor = Color.Gray

      ' Set the mouse up effects
      HtmlBox1.ButtonStyle.MouseUpBorderStyle = BorderStyle.Solid
      HtmlBox1.ButtonStyle.MouseUpBorderColor = HtmlBox1.BackColor
   End If
End Sub

Applying style to individual toolbar items

If you would like to apply a different style to each toolbar item, this is possible. The following code demonstrates applying a different BackColor to every button on the default toolbar.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   if(!Page.IsPostBack)
   {
      foreach(BaseToolbarItem item in HtmlBox1.Toolbar.Items)
      {
         if(item is BaseToolbarButton)
         {
            // Get random RGB values
            Random rand = new Random();
            int R = rand.Next(255);
            int G = rand.Next(255);
            int B = rand.Next(255);

            // Convert to Color object and set
            item.BackColor = Color.FromArgb(R,G,B);

            // Put thread to sleep for a bit, otherwise the random values will be the same.
            System.Threading.Thread.Sleep(100);
         }
      }
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      Dim item As BaseToolbarItem
      For Each item in HtmlBox1.Toolbar.Items

         If TypeOf(item) is BaseToolbarButton Then

            ' Get random RGB values
            Dim rand As New Random()
            Dim R As Integer = rand.Next(255)
            Dim G As Integer = rand.Next(255)
            Dim B As Integer = rand.Next(255)

            ' Convert to Color object and set
            item.BackColor = Color.FromArgb(R,G,B)

            ' Put thread to sleep for a bit, otherwise the random values will be the same.
            System.Threading.Thread.Sleep(100)
         End If
      Next
   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Using Helper Properties

The HtmlBox control exposes several high-level "helper properties", which can be used to quickly configure many aspects of the HtmlBox. The following high-level properties are addressed.

  • HtmlBox.FontNameList property
  • HtmlBox.FontSizeList property
  • HtmlBox.FontFormattingList property
  • HtmlBox.FontStyleList property
  • HtmlBox.SpecialCharacterList property
  • HtmlBox.ColorPaletteType property
  • HtmlBox.RightClickBehavior property

This can all be done using the Property Builder application without writing code (see Configuring the HtmlBox using the Property Builder for more information about this). This topic addresses configuring styles using coding techniques.

HtmlBox.FontNameList property

The FontNameList provides default values to the "font name" drop-down. Simply manage the collection exposed by this property to change the font names available on the editor.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // First make sure you have added a FontName item (this is included in the default configuration,
      // so typically you will not need this line of code.
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontName);

      // Now clear out the default fonts and add new ones.
      HtmlBox1.FontNameList.Clear();
      HtmlBox1.FontNameList.Add("Courier");
      HtmlBox1.FontNameList.Add("Times New Roman");
      HtmlBox1.FontNameList.Add("Arial");
      HtmlBox1.FontNameList.Add("Verdana");
      HtmlBox1.FontNameList.Add("Comic Sans MS");
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' First make sure you have added a FontName item (this is included in the default configuration,
      ' so typically you will not need this line of code.
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontName)

      ' Now clear out the default fonts and add new ones.
      HtmlBox1.FontNameList.Clear()
      HtmlBox1.FontNameList.Add("Courier")
      HtmlBox1.FontNameList.Add("Times New Roman")
      HtmlBox1.FontNameList.Add("Arial")
      HtmlBox1.FontNameList.Add("Verdana")
      HtmlBox1.FontNameList.Add("Comic Sans MS")

   End If
End Sub

HtmlBox.FontSizeList property

The FontSizeList provides default values to the "font size" drop-down. Simply manage the collection exposed by this property to change the font sizes available on the editor.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // First make sure you have added a FontSize item (this is included in the default configuration,
      // so typically you will not need this line of code.
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontSize);

      // Now clear out the default font names and add new ones.
      HtmlBox1.FontSizeList.Clear();
      HtmlBox1.FontSizeList.Add("1");
      HtmlBox1.FontSizeList.Add("2");
      HtmlBox1.FontSizeList.Add("3");
      HtmlBox1.FontSizeList.Add("4");
      HtmlBox1.FontSizeList.Add("5");
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' First make sure you have added a FontSize item (this is included in the default configuration,
      ' so typically you will not need this line of code.
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontSize)

      ' Now clear out the default font sizes and add new ones.
      HtmlBox1.FontSizeList.Clear()
      HtmlBox1.FontSizeList.Add("1")
      HtmlBox1.FontSizeList.Add("2")
      HtmlBox1.FontSizeList.Add("3")
      HtmlBox1.FontSizeList.Add("4")
      HtmlBox1.FontSizeList.Add("5")

   End If
End Sub

HtmlBox.FontFormatting List property

The FontFormattingList provides default values to the "font formatting" drop-down. Simply manage the collection exposed by this property to change the font formatting types available on the editor.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // First make sure you have added a FontFormatting item (this is included in the default configuration,
      // so typically you will not need this line of code.
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontFormatting);

      // Now clear out the default font formatting types and add new ones.
      HtmlBox1.FontFormattingList.Clear();
      HtmlBox1.FontFormattingList.Add("Heading 1", "<H1>");
      HtmlBox1.FontFormattingList.Add("Heading 2", "<H2>");
      HtmlBox1.FontFormattingList.Add("Heading 3", "<H3>");
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' First make sure you have added a FontFormatting item (this is included in the default configuration,
      ' so typically you will not need this line of code.
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontFormatting)

      ' Now clear out the default font formatting types and add new ones.
      HtmlBox1.FontFormattingList.Clear()
      HtmlBox1.FontFormattingList.Add("Heading 1", "<H1>")
      HtmlBox1.FontFormattingList.Add("Heading 2", "<H2>")
      HtmlBox1.FontFormattingList.Add("Heading 3", "<H3>")

   End If
End Sub

HtmlBox.FontStyleList property

The FontStyleList provides default values to the "font style" drop-down. Simply manage the collection exposed by this property to change the font formatting types available on the editor. The FontStyleList accepts two types of font style definitions, either classes (i.e. "mystyle") defined in an external CSS, or actual style definitions ("color:blue;font-name:courier");

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // First make sure you have added a FontStyle item
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontStyle);

      // Now clear out the default font formatting types and add new ones.
      HtmlBox1.FontStyleList.Clear();
      HtmlBox1.FontStyleList.Add("My Style", "mystyle"); // Assume defined in external CSS
      HtmlBox1.FontStyleList.Add("Red Bold", "color:red;font-weight:bold;");
      HtmlBox1.FontStyleList.Add("ALL CAPS", "text-transform:uppercase;");
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' First make sure you have added a FontStyle item
      HtmlBox1.AddToolbarItem(ToolbarItemType.FontStyle)

      ' Now clear out the default font formatting types and add new ones.
      HtmlBox1.FontStyleList.Clear()
      HtmlBox1.FontStyleList.Add("My Style", "mystyle") ' Assume defined in external CSS
      HtmlBox1.FontStyleList.Add("Red Bold", "color:red;font-weight:bold;")'
      HtmlBox1.FontStyleList.Add("ALL CAPS", "text-transform:uppercase;")'

   End If
End Sub

HtmlBox.SpecialCharacterList property

The SpecialCharacterList provides default values to the "special character picker" button. Simply manage the collection exposed by this property to change the special characters available on the editor.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // First make sure you have added a SpecialCharacter item (this is included in the default configuration,
      // so typically you will not need this line of code.
      HtmlBox1.AddToolbarItem(ToolbarItemType.SpecialCharacter);

      // Now clear out the default special characters and add new ones.
      HtmlBox1.SpecialCharacterList.Clear();
      HtmlBox1.SpecialCharacterList.Add("&lt;"); // <
      HtmlBox1.SpecialCharacterList.Add("&gt;"); // >
      HtmlBox1.SpecialCharacterList.Add("&©"); // ©
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' First make sure you have added a SpecialCharacter item (this is included in the default configuration,
      ' so typically you will not need this line of code.
      HtmlBox1.AddToolbarItem(ToolbarItemType.SpecialCharacter)

      ' Now clear out the default special characters and add new ones.
      HtmlBox1.SpecialCharacterList.Clear()
      HtmlBox1.SpecialCharacterList.Add("&lt;") ' <
      HtmlBox1.SpecialCharacterList.Add("&gt;") ' >
      HtmlBox1.SpecialCharacterList.Add("&©") ' ©

   End If
End Sub

HtmlBox.ColorPaletteType property

The ColorPaletteType property enables you to choose a color palette type which is used throughout the editor. The choices are:

  • Standard - The standard 140 color palette (default).
  • WebSafe - Expanded 216 web-safe palette.
  • Condensed - Abbreviated 40 color palette. Good for low bandwidth scenarios.
[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Change the color palette to Condensed
      HtmlBox1.ColorPaletteType = ColorPaletteType.Condensed;
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' Change the color palette to Condensed
      HtmlBox1.ColorPaletteType = ColorPaletteType.Condensed

   End If
End Sub

HtmlBox.RightClickBehavior property

The RightClicBehavior property enables you to choose a what happens when a user right-clicks on the editor. The choices are:

  • Nothing - No menu is displayed at all.
  • HtmlBoxMenu - A menu tightly integrated with the HtmlBox is displayed (default).
  • WindowsMenu - Default windows menu is displayed.
[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Change the right click behavior to nothing
      HtmlBox1.RightClickBehavior = RightClickBehavior.Nothing;
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' Change the right click behavior to nothing
      HtmlBox1.RightClickBehavior = RightClickBehavior.Nothing

   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Advanced Customization

PowerWEB TextBox for ASP.NET's flexible object model makes it possible to highly customize your editor. Create custom dialog boxes, menus, dropdown boxes, and other elements with only a few lines of code. The following topics describe common customization scenarios.

In This Section

Using HtmlBox skins
Describes how skins can be applied to enhance the HtmlBox and how to create your own skins.
Creating a custom button
Describes how to create a custom button to call a JavaScript function.
Creating a custom dialog button
Describes how to create a custom button which launches a dialog when clicked.
Creating a custom menu button
Describes how to create a custom button which opens a menu when clicked.
Creating a custom drop down
Describes how to create a custom dropdown box.
Creating a custom toolbar image
Describes how to create a custom toolbar image.
Creating custom toolbar text
Describes how to create custom toolbar text.
Customizing file upload
Describes the built in upload support and how it can be customized.
Integrating spell checking capability.
Provides steps of how to use a spell checker with the editor.
Integrating PowerWEB TextBox for ASP.NET with PowerTCP Mail for .NET for Web Mail Solutions
Provides information on how to integrate the HtmlBox with PowerTCP Mail for .NET to create mail applications which are capable of mailing HTML email messsages.

Related Sections

Getting Started
Provides an overview of PowerWEB TextBox for ASP.NET and discusses such topics as distribution, licensing, and support.
Using PowerWEB in VS.NET
Provides step-by-step instructions for creating a project using VS.NET, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB in WebMatrix
Provides step-by-step instructions for creating a project using WebMatrix, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB with Notepad
Provides step-by-step instructions for creating a simple project using notepad only.
Configuring the HtmlBox
Discusses how to easily configure the HtmlBox, including style, layout, and toolbar configuration.
Optimizing Performance
Discusses techniques for optimizing performance of the HtmlBox control, including reducing ViewState and render-size.
Reference
Provides a language/syntax and client-side API reference for PowerWEB TextBox for ASP.NET.
HtmlBox Control Samples
Describes the samples that are installed with PowerWEB TextBox for ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Using HtmlBox Skins

PowerWEB TextBox for ASP.NET supports skinning, which is a way to easily apply a "look and feel" via use of an XML configuration file. The skins may be highly graphical, including a background image and images for the various button states. The skins may also be non-graphical, only specifying a color/style change from the standard editor. The following topics are addressed

  • Loading existing skins
  • Creating non-graphical skins
  • Creating graphical skins

This can all be done using the Property Builder application without writing code (see Configuring the HtmlBox using the Property Builder for more information about this). This topic addresses configuring skins using coding techniques.

Loading existing skins

The HtmlBox installation includes several sample skins. These can be easily loaded by using the Property Builder, or by using the LoadSkin method. The following code demonstrates the latter.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Load the notepad skin included with the installation using the virtual conversion tool.
      // (unless you modified the virtual directories included with
      // the installation kit, this path should work for you too).
      VirtualPathConversion converter = new VirtualPathConversion();
      string path = converter.ConvertVirtualToPhysicalPath("/PowerWEB_TextBox_Common/skins/notepad.xml");
      HtmlBox1.LoadSkin(path);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then
      ' Load the notepad skin included with the installation using the virtual conversion tool.
      ' (unless you modified the virtual directories included with
      ' the installation kit, this path should work for you too).
      Dim converter As New VirtualPathConversion()
      Dim path As String = converter.ConvertVirtualToPhysicalPath("/PowerWEB_TextBox_Common/skins/notepad.xml")
      HtmlBox1.LoadSkin(path)
   End If
End Sub

Creating non-graphical skins

There are two basic types of skins you can create, non-graphical and graphical skins. Non-graphical skins are created simply by modiying the style properties of the objects comprising the editor. Graphical skins are created by customizing background images, button state images, etc to apply a radically different look to the HtmlBox.

When using the Property Builder, simply modify the styles of the objects using the "Format" tab, then go to the "Skin" tab and choose the "Save" option. Alternately, you can configure your skin using code-behind, then save using the SaveSkin method. The following code demonstrates creating a simple, non-graphical skin in code-behind.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
            // We want to make a green skin.

            // Set the background of the editor to green
            HtmlBox1.BackColor = Color.Green;

            // Set MouseOverStyles to shades of green.
            HtmlBox1.ButtonStyle.MouseOverBorderColor = Color.DarkGreen;
            HtmlBox1.ButtonStyle.MouseOverBackColor = Color.PaleGreen;
            HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dashed;

            // Set MouseDownStyle to shades of green
            HtmlBox1.ButtonStyle.MouseDownBorderColor = Color.DarkGreen;
            HtmlBox1.ButtonStyle.MouseDownBackColor = Color.DarkGreen;
            HtmlBox1.ButtonStyle.MouseDownBorderStyle = BorderStyle.Solid;

            // Set dialogs to be green
            HtmlBox1.DialogStyle.BackColor = Color.Green;
            HtmlBox1.DialogStyle.TitlebarBackColor = Color.DarkGreen;

            // Set menus to be green
            HtmlBox1.MenuStyle.BackColor = Color.PaleGreen;
            HtmlBox1.MenuStyle.ImageColumnColor = Color.Green;

            // Now save the configuration
            HtmlBox1.SaveSkin("C:\\temp", "green");
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

            ' We want to make a green skin.

            ' Set the background of the editor to green
            HtmlBox1.BackColor = Color.Green

            ' Set MouseOverStyles to shades of green.
            HtmlBox1.ButtonStyle.MouseOverBorderColor = Color.DarkGreen
            HtmlBox1.ButtonStyle.MouseOverBackColor = Color.PaleGreen
            HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dashed

            ' Set MouseDownStyle to shades of green
            HtmlBox1.ButtonStyle.MouseDownBorderColor = Color.DarkGreen
            HtmlBox1.ButtonStyle.MouseDownBackColor = Color.DarkGreen
            HtmlBox1.ButtonStyle.MouseDownBorderStyle = BorderStyle.Solid

            ' Set dialogs to be green
            HtmlBox1.DialogStyle.BackColor = Color.Green
            HtmlBox1.DialogStyle.TitlebarBackColor = Color.DarkGreen

            ' Set menus to be green
            HtmlBox1.MenuStyle.BackColor = Color.PaleGreen
            HtmlBox1.MenuStyle.ImageColumnColor = Color.Green

            ' Now save the configuration
            HtmlBox1.SaveSkin("C:\temp", "green")

   End If
End Sub

Creating graphical skins

Creating graphical skins is a bit more complex than creating non-graphical skins because typically, creating graphical skins involves setting skin specific properties. These properties are:

  • HtmlBox1.BackgroundImageName - Sets the name of an image to use as the background for the editor. This can be either a single large graphic which acts as an "interface", or a small background image which tiles.
  • HtmlBox1.ButtonMode - Sets whether or not you wish to use highly-graphical buttons including mouse-over/down image swaps.
  • HtmlBox1.Height - Set this to the dimensions of your background image if you do not wish for the image to "tile".
  • HtmlBox1.Width - Set this to the dimensions of your background image if you do not wish for the image to "tile".
  • HtmlBox1.LayoutType - Set this to Skin to clear any default style formatting.
  • HtmlBox1.BottomMargin - Set this to configure how far the tabstrip is (in pixels) from the bottom of the editor.
  • HtmlBox1.TopMargin - Set this to configure how far the toolbar is (in pixels) from the top of the editor.
  • HtmlBox1.ImagesDirectory - If using a highly graphical ButtonMode, set this to the directory containing your button and background images.

The following code demonstrates creating a default editor. In this example, the skin is demonstrating a three state ButtonMode, meaning there is a graphic to represent the standard button state, a graphic to represent the "over" button state, and a graphic to represent the "click" button state. Be sure to follow the naming convention, so your buttons will work without any further configuration. The naming convention is as follows:

  • "Standard" buttons are ItemPrefix concatenated with FileType (ex. "bold.gif")
  • "Over" buttons are ImagePrefix concatenated with "_over" and FileType. (ex. "bold_over.gif")
  • "Click" buttons are ImagePrefix concatenated with "_down" and FileType. (ex. "bold_down.gif")

To see an example of the naming convention, look at the images contained with one of the default skins shipped with PowerWEB TextBox for ASP.NET.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Set the images directory to the directory containing the skin graphics
      HtmlBox1.ImagesDirectory = "/PowerWEB_TextBox_Common/skins/CoolBlue";

      // Change the LayoutType to use the Skin type.
      HtmlBox1.LayoutType = LayoutType.Skin;

      // Buttons will be represented by three images.
      HtmlBox1.ButtonMode = ButtonMode.ThreeStateImage;

      // Set the BackgroundImage
      HtmlBox1.BackgroundImageName = "background_700X400.jpg";

      // Set the height to the same height as the background image so it doesn't tile
      HtmlBox1.Height = new Unit(400);

      // Set the width to the same width as the background image so it doesn't tile.
      HtmlBox1.Width = new Unit(700);

      // Make the TextWindow a tad narrower (so more of the background is showing).
      HtmlBox1.TextWindow.Width = new Unit("90%");

      // Make the Toolbar a tad narrower (so more of the background is showing)
      HtmlBox1.Toolbar.Width = new Unit("90%");

      // Lower the toolbar a tad
      HtmlBox1.TopMargin = 15;

      // Raise the tabstrip a tad
      HtmlBox1.BottomMargin = 25;

      // Now save
      HtmlBox1.Save("C:\\temp", "mygraphicalskin");

      // You can also set other Styles (such as DialogStyle, MenuStyle) to match your new skin

   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' Set the images directory to the directory containing the skin graphics
      HtmlBox1.ImagesDirectory = "/PowerWEB_TextBox_Common/skins/CoolBlue"

      ' Change the LayoutType to use the Skin type.
      HtmlBox1.LayoutType = LayoutType.Skin

      ' Buttons will be represented by three images.
      HtmlBox1.ButtonMode = ButtonMode.ThreeStateImage

      ' Set the BackgroundImage
      HtmlBox1.BackgroundImageName = "background_700X400.jpg"

      ' Set the height to the same height as the background image so it doesn't tile
      HtmlBox1.Height = new Unit(400)

      ' Set the width to the same width as the background image so it doesn't tile.
      HtmlBox1.Width = new Unit(700)

      ' Make the TextWindow a tad narrower (so more of the background is showing).
      HtmlBox1.TextWindow.Width = new Unit("90%")

      ' Make the Toolbar a tad narrower (so more of the background is showing)
      HtmlBox1.Toolbar.Width = new Unit("90%")

      ' Lower the toolbar
      HtmlBox1.TopMargin = 15

      ' Raise the tabstrip
      HtmlBox1.BottomMargin = 25

      ' Now save
      HtmlBox1.Save("C:\temp", "mygraphicalskin")

      ' You can also set other Styles (such as DialogStyle, MenuStyle) to match your new skin
   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Creating a Custom Button

While PowerWEB TextBox for ASP.NET includes a default set of preconfigured Toolbar items (enumerated by the ToolbarItemType enumeration) it also allows easy creation of custom buttons which can be used to call a JavaScript function. This function can be either (1) one of the PowerWEB TextBox for ASP.NET client-side API calls, (2) your own JavaScript function which you've already defined on the page or in an external js file, or (3) a code block that you set programatically. For this topic, the first and last options are addressed.

  • Creating a custom button which calls a client-side API.
  • Creating a custom button which calls a code block.

Creating a custom button which calls a client-side API

The client-side API exposes many of the functions that PowerWEB TextBox for ASP.NET uses internally. You can create a custom button to call one of these functions. For this example "pwInsertText" is demonstrated, which inserts text into the editor.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom button
      ToolbarButton b = new ToolbarButton(ToolbarButtonType.Custom);

      // Set the function name to call when clicked.
      b.OnClickFunctionName = "pwInsertText('text inserted from button!', false, true)";

      // Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then
      ' Create a custom button
      Dim b As New ToolbarButton(ToolbarButtonType.Custom)

      ' Set the function name to call when clicked.
      b.OnClickFunctionName = "pwInsertText(""text inserted from button!"", false, true)"

      ' Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b)
   End If
End Sub

Creating a custom button which calls a code block

It is also useful to call your own custom function instead of using the client-side API. This can be easily done by setting OnClickFunctionName to the name of the function you wish to call, and OnClickFunctionCode to the actual function code, as demonstrated below.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom button
      ToolbarButton b = new ToolbarButton(ToolbarButtonType.Custom);

      // Set the function name to call when clicked.
      b.OnClickFunctionName = "myFunc()";

      // Set the function code block itself
      string func = "";
      func += "function myFunc()\r\n";
      func += "{\r\n";
      func += "alert('hey, you called myFunc');\r\n";
      func += "}\r\n";
      b.OnClickFunctionCode = func;

      // Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' Create a custom button
      Dim b As New ToolbarButton(ToolbarButtonType.Custom)

      ' Set the function name to call when clicked.
      b.OnClickFunctionName = "myFunc()"

      ' Set the function code block itself
      Dim func as String = ""
      func = func & "function myFunc()" + vbCrLf
      func = func & "{" + vbCrLf
      func = func & "alert(""hey, you called myFunc"");" + vbCrLf
      func = func & "}" + vbCrLf
      b.OnClickFunctionCode = func;

      ' Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b)

   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Creating a Custom Dialog Button

While PowerWEB TextBox for ASP.NET includes a default set of preconfigured Toolbar items (enumerated by the ToolbarItemType enumeration) it also allows easy creation of custom buttons which can be used to open a dialog (simply by setting the Dialog.Text property).

NOTE! In order for the "built in" font style functionality to properly work (for example, setting HtmlBoxDialog.Font.Name) your HTML content must use the "pwdialogstyle" stylesheet class (which is the stylesheet class automatically applied to dialogs used by the HtmlBox). If you are defining your own styles for the dialog content, you do not need to do this.

The following code demostrates a simple dialog button which opens an "About" box.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom dialog button
      ToolbarDialogButton b = new ToolbarDialogButton(ToolbarDialogButtonType.Custom);

      // Set the text of the dialog to whatever content you would like to display.
      string text = "";

      // Note, the "pwdialogstyle" css class is used, so if dialog font properties are set they will work properly
      text += "<p class='pwdialogstyle'>";
      text += "<h1>About Us</h1>";
      text += "<p>Hello, we are here to provide you with the<br>";
      text += "highest quality Internet applications. If you need<br>";
      text += "more information, contact us using the information below</p>";
      text += "FakeTech Inc<br>";
      text += "111 Phoney Road<br>";
      text += "Madeupville NY, 13441<br>";
      text += "555-555-1212<br>";
      text += "info@faketech.com<br><br>";
      text += "</p>";
      b.Dialog.Text = text;

      // Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then
      ' Create a custom dialog button
      Dim b As New ToolbarDialogButton(ToolbarDialogButtonType.Custom)

      ' Set the text of the dialog to whatever content you would like to display.
      Dim text As String = ""

      ' Note, the "pwdialogstyle" css class is used, so if dialog font properties are set they will work properly
      text = text & "<p class='pwdialogstyle'>"
      text = text & "<h1>About Us</h1>"
      text = text & "<p>Hello, we are here to provide you with the<br>"
      text = text & "highest quality Internet applications. If you need<br>"
      text = text & "more information, contact us using the information below</p>"
      text = text & "FakeTech Inc<br>"
      text = text & "111 Phoney Road<br>"
      text = text & "Madeupville NY, 13441<br>"
      text = text & "555-555-1212<br>"
      text = text & "info@faketech.com<br><br>"
      text = text & "</p>"
      b.Dialog.Text = text

      ' Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b)
   End If
End Sub

You can also call a function from the dialog.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom dialog button
      Dim b As New ToolbarDialogButton(ToolbarDialogButtonType.Custom)

      ' Set the text of the dialog to whatever content you would like to display.
      Dim text As String = ""
      text = text & "<p>Click the button below to insert text from a dialog.</p>"
      text = text & "<input type='button' value='click' onclick='pwInsertText(""Blah"", false, true)' ID="Button1" NAME="Button1">"
      b.Dialog.Text = text

      ' Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b)
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' Create a custom dialog button
      ToolbarDialogButton b = new ToolbarDialogButton(ToolbarDialogButtonType.Custom);

      // Set the text of the dialog to whatever content you would like to display.
      string text = "";
text += "<p>Click the button below to insert text from a dialog.</p>";
      text += "<input type='button' value='click' onclick='pwInsertText(\"Blah\", false, true)' ID="Button1" NAME="Button1">";
      b.Dialog.Text = text;

      // Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b);

   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Creating a Custom Menu Button

While PowerWEB TextBox for ASP.NET includes a default set of preconfigured Toolbar items (enumerated by the ToolbarItemType enumeration) it also allows easy creation of custom buttons which can be used to open a menu. The following code demonstrates creating a menu button that enables bold, italic, and underline formatting from a menu.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom menu button
      ToolbarMenuButton b = new ToolbarMenuButton(ToolbarMenuButtonType.Custom);

      // Add some new items to the menu
      b.Menu.Items.Add(new HtmlBoxMenuItem("Make Bold", "bold.gif", "pwFormat('bold', '', true);"));
      b.Menu.Items.Add(new HtmlBoxMenuItem("Make Italic", "italic.gif", "pwFormat('italic', '', true);"));
      b.Menu.Items.Add(new HtmlBoxMenuItem("Make Underline", "underline.gif", "pwFormat('underline', '', true);"));
      b.Menu.Items.Add(new HtmlBoxMenuItem("Show alert", "custom.gif", "alert('hello')"));

      // Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then
      ' Create a custom menu button
      Dim b As New ToolbarMenuButton(ToolbarMenuButtonType.Custom)

      ' Add some new items to the menu
      b.Menu.Items.Add(New HtmlBoxMenuItem("Make Bold", "bold.gif", "pwFormat(""bold"", """", true);"))
      b.Menu.Items.Add(New HtmlBoxMenuItem("Make Italic", "italic.gif", "pwFormat(""italic"", """", true);"))
      b.Menu.Items.Add(New HtmlBoxMenuItem("Make Underline", "underline.gif", "pwFormat(""underline"", """", true);"))
      b.Menu.Items.Add(New HtmlBoxMenuItem("Show alert", "custom.gif", "alert(""hello"")"))

      ' Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b)
   End If
End Sub

You can also call a function from the dialog.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom dialog button
      Dim b As New ToolbarDialogButton(ToolbarDialogButtonType.Custom)

      ' Set the text of the dialog to whatever content you would like to display.
      Dim text As String = ""
      text = text & "<p>Click the button below to insert text from a dialog.</p>"
      text = text & "<input type='button' value='click' onclick='pwInsertText(""Blah"", false, true)' ID="Button1" NAME="Button1">"
      b.Dialog.Text = text

      ' Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b)
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' Create a custom dialog button
      ToolbarDialogButton b = new ToolbarDialogButton(ToolbarDialogButtonType.Custom);

      // Set the text of the dialog to whatever content you would like to display.
      string text = "";
text += "<p>Click the button below to insert text from a dialog.</p>";
      text += "<input type='button' value='click' onclick='pwInsertText(\"Blah\", false, true)' ID="Button1" NAME="Button1">";
      b.Dialog.Text = text;

      // Add the button to the toolbar
      HtmlBox1.Toolbar.Items.Add(b);

   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Creating a Custom DropDown

While PowerWEB TextBox for ASP.NET includes a default set of preconfigured Toolbar items (enumerated by the ToolbarItemType enumeration) it also allows easy creation of custom drop down boxes. When creating custom drop downs, there are two choices, which are addressed in this topic:

  • Create a custom dropdown for inserting text
  • Create a custom dropdown of your own implementation

Create a custom dropdown for inserting text

If you create a ToolbarDropDown with Type = Insert, the initialized ToolbarDropDown comes preconfigured for inserting text values, as the example below illustrates.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom dropdown for inserting text
      ToolbarDropDown d = new ToolbarDropDown(ToolbarDropDownType.Insert);

      // Add some items to be inserted
      d.Items.Add(new ToolbarDropDownItem("Greeting", "To whom it may concern,<br>"));
      d.Items.Add(new ToolbarDropDownItem("Signature", "Best Regards,<br>"));
      d.Items.Add(new ToolbarDropDownItem("Date", DateTime.Now.ToShortDateString()));

      // Add the dropdown to the toolbar
      HtmlBox1.Toolbar.Items.Add(d);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then
      ' Create a custom dropdown for inserting text
      Dim d As New ToolbarDropDown(ToolbarDropDownType.Insert)

      ' Add some items to be inserted
      d.Items.Add(New ToolbarDropDownItem("Greeting", "To whom it may concern,<br>"))
      d.Items.Add(New ToolbarDropDownItem("Signature", "Best Regards,<br>"))
      d.Items.Add(New ToolbarDropDownItem("Date", DateTime.Now.ToShortDateString()))

      ' Add the dropdown to the toolbar
      HtmlBox1.Toolbar.Items.Add(d)
   End If
End Sub

Create a custom dropdown of your own implementation

If you need a more general custom drop down, create a ToolbarDropDown with Type = Custom. This will enable you to configure a drop down that can call any JavaScript function.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom dropdown for inserting text
      ToolbarDropDown d = new ToolbarDropDown(ToolbarDropDownType.Custom);

      // Add some items
      d.Items.Add(new ToolbarDropDownItem("Alert 1", "alert1", "alert('you clicked alert 1')"));
      d.Items.Add(new ToolbarDropDownItem("Alert 2", "alert2", "alert('you clicked alert 2')"));
      d.Items.Add(new ToolbarDropDownItem("Alert 3", "alert3", "alert('you clicked alert 3')"));

      // Add the dropdown to the toolbar
      HtmlBox1.Toolbar.Items.Add(d);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then

      ' Create a custom dropdown for inserting text
      Dim d As New ToolbarDropDown(ToolbarDropDownType.Custom)

      ' Add some items
      d.Items.Add(New ToolbarDropDownItem("Alert 1", "alert1", "alert(""you clicked alert 1"")"))
      d.Items.Add(New ToolbarDropDownItem("Alert 2", "alert2", "alert(""you clicked alert 2"")"))
      d.Items.Add(New ToolbarDropDownItem("Alert 3", "alert3", "alert(""you clicked alert 3"")"))

      ' Add the dropdown to the toolbar
      HtmlBox1.Toolbar.Items.Add(d)

   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Creating a Custom Toolbar Image

Custom images (non-interactive images) can be added to the toolbar to enhance the "look and feel" of the editor. To do this, simply create a new ToolbarImage, set the ImageName property, and add the ToolbarImage to the toolbar. The following code snippet demonstrates creating a custom "icon" in the upper left corner of the editor.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom image for our icon
      ToolbarImage icon = new ToolbarImage(ToolbarImageType.Custom);

      // Set the image name
      icon.ImageName = "custom.gif";

      // Add it as the first item, so it looks like an "icon"
      HtmlBox1.Toolbar.Items.Insert(0, icon);
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then
      ' Create a custom image for our icon
      Dim icon As New ToolbarImage(ToolbarImageType.Custom)

      ' Set the image name
      icon.ImageName = "custom.gif"

      ' Add it as the first item, so it looks like an "icon"
      HtmlBox1.Toolbar.Items.Insert(0, icon)
   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Creating Custom Toolbar Text

Custom text (non-interactive text) can be added to the toolbar to enhance the editor. To do this, simply create a new ToolbarText, set the Text property, and add the ToolbarText to the toolbar. The following code snippet demonstrates creating adding "banner" text to the top of the toolbar.

[C#]
// Be sure to add "Using Dart.PowerWEB.TextBox" to the top of your code-behind class.

private void Page_Load(object sender, System.EventArgs e)
{
   // Check if it is the first page request. State will be maintained for additional postbacks.
   if(!Page.IsPostBack)
   {
      // Create a custom text
      ToolbarText banner = new ToolbarText(ToolbarTextType.Custom);

      // Change the style of the text to make it stand out
      banner.Width = new Unit("100%");
      banner.Font.Bold = true;
      banner.BackColor = Color.Red;
      banner.ForeColor = Color.White;

      // Set the text
      banner.Text = "Welcome to the PowerWEB HtmlBox for ASP.NET editor demo";

      // Add it as the first item, then add a row
      HtmlBox1.Toolbar.Items.Insert(0, banner);
      HtmlBox1.Toolbar.Items.Insert(1, new ToolbarImage(ToolbarImageType.RowSeparator));
   }
}
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

   ' Check if it is the first page request. The toolbar will maintain its state for additional postbacks.
   If Not Page.IsPostBack Then
      ' Create a custom text
      Dim banner As New ToolbarText(ToolbarTextType.Custom)

      ' Change the style of the text to make it stand out
      banner.Width = New Unit("100%")
      banner.Font.Bold = True
      banner.BackColor = Color.Red
      banner.ForeColor = Color.White

      ' Set the text
      banner.Text = "Welcome to the PowerWEB HtmlBox for ASP.NET editor demo"

      ' Add it as the first item, then add a row
      HtmlBox1.Toolbar.Items.Insert(0, banner)
      HtmlBox1.Toolbar.Items.Insert(1, new ToolbarImage(ToolbarImageType.RowSeparator))
   End If
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Customizing File Uploads

PowerWEB TextBox for ASP.NET has built-in support for file upload and manipulation through the use of the ToolbarUploadButton. There are three basic default configurations for this type of button:

  • ToolbarUploadButton.Type = InsertImage. This button displays a dialog that can be used to upload images to the server, and insert them into the editor.
  • ToolbarUploadButton.Type = OpenFile. This button displays a dialog that can be used to upload files (typically HTML) to the server and load them into the editor.
  • ToolbarUploadButton.Type = Upload. This button displays a dialog that can be used to upload files to the server.

These buttons can be easily created and added to the toolbar using the techniques discussed in Configuring The Toolbar. The following code demonstrates adding a InsertImage button.

[C#]
// Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.
HtmlBox1.AddToolbarItem(ToolbarItemType.InsertImage);
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.
HtmlBox1.AddToolbarItem(ToolbarItemType.InsertImage)

Once added to the toolbar, several properties control the behavior of the upload.

  • HtmlBox.UploadedFilesDirectory - Controls where uploaded files are stored. All file uploads on the toolbar will upload to this directory by default. If you need to specify custom upload location for each file upload, set the InitialDirectory property.
  • HtmlBoxUpload.InitialDirectory - Overrides the value of UploadedFilesDirectory if you need fine tuned support.
  • HtmlBoxUpload.AllowDownwardBrowsing - If true, the user can "drill down" into subdirectories.
  • HtmlBoxUpload.AllowDelete - If true, the user can delete files from the server.
  • HtmlBoxUpload.UploadEnabled - If true, the upload portion of the dialog is displayed.
  • HtmlBoxUpload.MaxFileSize - Sets the maximum allowable file size for uploaded files.
  • HtmlBoxUpload.Filter - Sets the file types that are displayed in the file browser.
  • HtmlBoxUpload.FileTypeMustMatchFilter - If true, uploaded files must match the filter.

The following code demonstrates adding an ImageUpload button and setting some of these properties.

[C#]
// Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.
ToolbarUploadButton b = new ToolbarUploadButton(ToolbarUploadButtonType.InsertImage);

// Set the MaxFileSize to 1 MB
b.Upload.MaxFileSize = 1048576;

// Set the filter to accept jpgs and gifs only
b.Upload.Filter = "*.jpg,*.gif"

// Allow the user to delete files
b.Upload.AllowDelete = true;

// Add the button
HtmlBox1.Toolbar.Items.Add(b);
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.
Dim b As New ToolbarUploadButton(ToolbarUploadButtonType.InsertImage)

' Set the MaxFileSize to 1 MB
b.Upload.MaxFileSize = 1048576

' Set the filter to accept jpgs and gifs only
b.Upload.Filter = "*.jpg,*.gif

' Allow the user to delete files
b.Upload.AllowDelete = True

' Add the button
HtmlBox1.Toolbar.Items.Add(b)

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Integrating With Mail Applications

Integrating PowerWEB TextBox for ASP.NET with PowerTCP Mail for .NET for Web Mail Solutions

The PowerWEB TextBox for ASP.NET is ideally suited for creating Web Mail solutions by handling the HTML message body of an email, including handling image insertion and attachment uploads. This fits perfectly with the PowerTCP Mail for .NET product, which is geared to not only providing mail communications components such as Smtp, Pop, and Imap, but also includes a powerful MIME message encoder/decoder called the MessageStream, which is capable of properly encoding an HTML message body. For a live sample and source code download, please visit http://www.dart.com/powerweb/textbox_samples.asp. Because there is more to creating a Web Mail application than just feeding in HTML, the complete code for the sample is only available online. The online sample demonstrates session management, attachment management, and other requirements for the application. A general, but incomplete code snippet is seen below:

Private Sub cmdSend_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdSend.Click

   ' Create instance of Smtp Component
   Smtp1 = New Smtp()

   ' Save the message to the session directory.SessionMessageFile has already been initialized with the path information
   ' in SetSessionDirectories, visible online.
   Dim Stream As New FileStream(SessionMessageFile, FileMode.Create)
   Dim Writer As New StreamWriter(Stream)
   Writer.Write(HtmlBox1.Text)
   Writer.Flush()
   Stream.Close()

   ' Create a new message stream, using the message file as source
   Dim msg As New MessageStream(SessionMessageFile)

   ' Set fields. These are guarenteed to have content, because of the InputValidators
   msg.From = New MailAddress(txtFrom.Text)
   msg.To.Add(New MailAddress(txtTo.Text))
   msg.Subject = txtSubject.Text

   ' Add any uploaded files as attachments
   ' AttachDir has been set in SetSessionDirectories, visible online.
   Dim Attachment As String
   Dim Attachments() As String = Directory.GetFiles(AttachDir)
   For Each Attachment In Attachments
      msg.Attachments.Add(Attachment)
   Next

   ' Create SmtpResult object which is returned by the Send operation
   ' and provides data about the success/failure of the Send operation.
   Dim resultObj As Dart.PowerTCP.Mail.SmtpResult

   Try
      ' Send the message (change the mail server to your mail server)
      Smtp1.Server = "mail.dart.com"
      resultObj = Smtp1.Send(msg)

      ' Save the result object to a session variable, so results
      ' can be displayed on the next page.
      Page.Session.Add("resultObj", resultObj)

      ' Send to notification page.
      Page.Response.Redirect("SmtpResult.aspx?result=success", False)
   Catch ex As Exception
      ' Save the Exception object to a session variable, so results
      ' can be displayed on the next page.
      AddTextToDebugLog("# ERROR: " + ex.ToString)
      Page.Session.Add("ex", ex)
      Page.Response.Redirect("SmtpResult.aspx?result=failure")
End Try
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Optimizing Performance

PowerWEB TextBox for .NET is capable of implementing an HTML editor in a variety of scenarios, from a full-blown content editor application to a simple, scaled-down editor. Depending on the type of application, and other Internet considerations (such as typical bandwidth of your users), you may wish to tune the HtmlBox for optimal performance. This section describes steps you can take to tune for performance.

In This Section

Optimizing ViewState
Describes techniques to reduce the size of ViewState.
Optimizing Rendering
Describes techniques to reduce page size and rending time.

Related Sections

Getting Started
Provides an overview of PowerWEB TextBox for ASP.NET and discusses such topics as distribution, licensing, and support.
Using PowerWEB in VS.NET
Provides step-by-step instructions for creating a project using VS.NET, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB in WebMatrix
Provides step-by-step instructions for creating a project using WebMatrix, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB with Notepad
Provides step-by-step instructions for creating a simple project using notepad only.
Configuring the HtmlBox
Discusses how to easily configure the HtmlBox, including style, layout, and toolbar configuration.
Advanced Customization
Discusses the many ways the HtmlBox control can be customized, from simple style changes to advanced interface element creation.
Reference
Provides a language/syntax and client-side API reference for PowerWEB TextBox for ASP.NET.
HtmlBox Control Samples
Describes the samples that are installed with PowerWEB TextBox for ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Optimizing ViewState

HTTP applications are stateless applications, meaning that consecutive HTTP requests have no knowledge of each other. This makes it challenging to write a complex Internet application, since it is necessary for applications of this type to have information about other requests. Many techniques (such as cookies, session variables, querystring passing) have been used to add state to HTTP. ViewState is a technique used by ASP.NET server controls to store and recover state. When a control renders itself to a page, it also encodes some data into a ViewState field. When a postback occurs, the server control will read in the ViewState field to recover it's state.

If the HtmlBox has undergone a lot of configuration, ViewState can become rather large. The following are techniques you can use to reduce/eliminate the size of ViewState.

Disable ViewState, perform configuration with each request

The simplest and most effective way to control ViewState size is simply to disable it. This is done by setting the EnableViewState property to false.

[C#]
HtmlBox1.EnableViewState = false;
[Visual Basic]
HtmlBox1.EnableViewState = False

When EnableViewState is set to false, no ViewState information is stored on the page, completely eliminating overhead caused by ViewState. The drawback is that the control will not retain initial values with postbacks. As a result, the HtmlBox must be configured to your settings with each request (if you are using the default HtmlBox you do not need to reconfigure it). The following example demonstrates adding an Insert Table button and changing the background color to red. Note that this code is placed within the Page_Load event, so it runs with each request.

[C#]
private void Page_Load(object sender, System.EventArgs e)
{
   HtmlBox1.AddToolbarItem(ToolbarItemType.InsertTable);
   HtmlBox1.BackColor = Color.Red;
}
[Visual Basic]
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
   HtmlBox.AddToolbarItem(ToolbarItemType.InsertTable)
   HtmlBox.BackColor = Color.Red
End Sub

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Optimizing Rendering

Depending on how you configure the HtmlBox, the page output can range from relatively small and non-complex, to rather large and complex. Often, situation will dictate which one is the case. For example, if the HtmlBox is used to provide simple editing to a web forum, it can use a scaled-back configuration. If the HtmlBox is used for a complex application like an advanced content management application, it can use a more advanced, content-heavy configuration. The following techniques describe steps you can take to make your page output smaller (requiring less bandwidth to transfer) and less complex (reducing the rendering time).

Use a smaller color picker.

One of the largest and most complex pieces of the control output is the color picker, displayed when the user clicks the Font Color or Font Highlight button. The HtmlBox has several types of built in color pickers, controlled by the ColorPaletteType property. Choosing the Condensed color palette will reduce page size and complexity.

[C#]
HtmlBox1.ColorPaletteType = ColorPaletteType.Condensed;
[Visual Basic]
HtmlBox1.ColorPaletteType = ColorPaletteType.Condensed

Do not enable table support for simple editing purposes.

Typically, table support does not need to be enabled for simple usage scenarios. Enabling table support causes the HtmlBox to render extra HTML code to construct the table-specific dialogs and also additional JavaScript files containing table functions.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Reference

This section contains reference documentation for all of the controls and classes that comprise PowerWEB TextBox for ASP.NET and the JavaScript API. This section is intended solely for use as a class reference guide for use while building an application.

In This Section

Dart.PowerWeb.Textbox Namespace
Contains classes that support and enable creation of HTML-editing capable web applications.
Client-Side API
Describes client-side JavaScript functions that are used by PowerWEB TextBox for ASP.NET.

Related Sections

Getting Started
Provides an overview of PowerWEB TextBox for ASP.NET and discusses such topics as distribution, licensing, and support.
Using PowerWEB in VS.NET
Provides step-by-step instructions for creating a project using VS.NET, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB in WebMatrix
Provides step-by-step instructions for creating a project using WebMatrix, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB with Notepad
Provides step-by-step instructions for creating a simple project using notepad only.
Configuring the HtmlBox
Discusses how to easily configure the HtmlBox, including style, layout, and toolbar configuration.
Advanced Customization
Discusses the many ways the HtmlBox control can be customized, from simple style changes to advanced interface element creation.
Optimizing Performance
Discusses techniques for optimizing performance of the HtmlBox control, including reducing ViewState and render-size.
HtmlBox Control Samples
Describes the samples that are installed with PowerWEB TextBox for ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Dart.PowerWEB.TextBox

Dart.PowerWEB.TextBox Namespace

Namespace hierarchy

Classes

Class | Description
AttDef |
AttList |
BaseChildControl | Base class for all child controls used by PowerWEB TextBox for .NET
BaseStyle | Summary description for BaseStyle.
BaseToolbarButton | Base class for all toolbar buttons.
BaseToolbarItem | Provides a common interface for all items on the toolbar.
ButtonStyle | Represents the style used by buttons.
ContentModel |
DialogStyle | Represents the style used by dialogs.
DownlevelLabel | Represents the text displayed to downlevel browsers.
DownlevelTextArea | Summary description for DownlevelTextBox.
ElementDecl |
Entity |
FileUploadEventArgs | Provides data for the HtmlBox.FileUpload event.
Group |
HighlightStyle | Represents the style used by controls that have a highlighted area.
HtmlBox | Replaces the TextBox control to provide advanced HTML editing within a browser.
HtmlBoxDialog | Represents a dialog.
HtmlBoxMenu | Represents a menu.
HtmlBoxMenuItem | Represents a single menu item on an HtmlBoxMenu.
HtmlBoxMenuItemCollection | Represents a collection used to manage HtmlBoxMenuItems.
HtmlBoxProgressBar | Represents a progress bar displayed while the HtmlBox is loading.
HtmlBoxTabStrip | Represents the tab strip used to change the modes of the HtmlBox
HtmlBoxTextWindow | Represents the actual editing window of the HtmlBox.
HtmlBoxUpload | Represents a dialog used to upload/browse for files.
HtmlReader | HTMLReader
MenuStyle | Represents the style used by menus.
ResourceHttpHandler | Summary description for ResourceHttpHandler.
SgmlDtd |
SgmlReader | SgmlReader is an XmlReader API over any SGML document (including built in support for HTML).
StringArrayList | Represents a collection used to maintain strings.
StringArrayListConverter |
StringValueCollection | Represents a collection used to maintain string names and values.
StringValueCollectionConverter |
Toolbar | Represents the toolbar of the HtmlBox.
ToolbarButton | Represents a button that performs standard formatting.
ToolbarButtonEventArgs | Provides data for the HtmlBox.ToolbarButtonClick event.
ToolbarDialogButton | Represents a button that raises a dialog.
ToolbarDropDown | Represents a drop-down select box.
ToolbarDropDownItem | Represents a single item of a ToolbarDropDown.
ToolbarDropDownItemCollection | Manages ToolbarDropDownItems
ToolbarImage | Represents a non-interactive image on the toolbar.
ToolbarItemCollection | Represents a collection used to manage BaseToolbarItem controls.
ToolbarMenuButton | Represents a button that opens a menu.
ToolbarText | Represents non-interactive text on the toolbar.
ToolbarUploadButton | Represents a button that raises an upload dialog.

Delegates

Delegate | Description
AutoSaveEventHandler | Represents a method which will handle the HtmlBox.AutoSave event.
FileUploadEventHandler | Represents a method which will handle the HtmlBox.FileUpload event.
ToolbarButtonClickEventHandler | Represents a method which will handle the HtmlBox.ToolbarButtonClick event.

Enumerations

Enumeration | Description
AttributePresence |
AttributeType |
ButtonMode | Enumerates possible values for the HtmlBox.ButtonMode property.
CaseFolding | SGML is case insensitive, so here you can choose between converting to lower case or upper case tags. "None" means that the case is left alone, except that end tags will be folded to match the start tags.
ClickBehavior | Enumerates the different types of ClickBehavior for ToolbarButtons.
ColorPaletteType | Enumerates possible values for the HtmlBox.ColorPaletteType property.
CursorType | Enumerates possible values for the MouseOverCursor, MouseUpCursor, and MouseDownCursor properties of buttons.
DeclaredContent |
DialogType | Enumerates the different types of dialog windows.
DownlevelMode | Enumerates what users with incompatible browsers see when they load the editor.
GroupType |
InternalDialogType | Enumerates the internally rendered type of dialog associated with a ToolbarDialogButton.
LayoutType | Enumerates the different ways the HtmlBox can be rendered.
LiteralType |
LocalizationType | Enumerates the localization type used to display strings in the HtmlBox.
Occurrence |
RightClickBehavior | Enumerates what occurs when the user right-clicks on the HtmlBox.
StartupMode | Enumerates the ways the HtmlBox can be started.
ToolbarButtonType | Enumerates the different types of ToolbarButton controls.
ToolbarDialogButtonType | Enumerates the different types of ToolbarDialogButton controls.
ToolbarDropDownType | Enumerates the different types of ToolbarDropDown controls.
ToolbarImageType | Enumerates the different types of ToolbarImage controls.
ToolbarItemType | Provides a common interface for all items on the toolbar.
ToolbarMenuButtonType | Enumerates the different types of ToolbarMenuButton controls.
ToolbarTextType | Enumerates the different types of ToolbarText controls.
ToolbarUploadButtonType | Enumerates the different types of ToolbarUploadButton controls.
UploadMode | Enumerates the different types of file uploads.
UrlType | Enumerates the types of url conversions.

Syntax based on .NET Framework version 1.1.
Documentation version 1.0.0.0.


AttDef Class

For a list of all members of this type, see AttDef Members.

System.Object
Dart.PowerWEB.TextBox.AttDef

[Visual Basic]
Public Class AttDef
[C#]
public class AttDef
[C++]
public __gc class AttDef
[JScript]
public class AttDef

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

AttDef Members | Dart.PowerWEB.TextBox Namespace


AttDef Members

AttDef overview

Public Instance Constructors

AttDef Constructor

Public Instance Fields

Default
EnumValues
Name
Presence
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetPresence |
SetType |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


AttDef Constructor

[Visual Basic]
Public Sub New( _
   ByVal name As String _
)
[C#]
public AttDef(
   string name
);
[C++]
public: AttDef(
   String* name
);
[JScript]
public function AttDef(
   String name
);

Parameters

name

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


AttDef Fields

The fields of the AttDef class are listed below. For a complete list of AttDef class members, see the AttDef Members topic.

Public Instance Fields

Default
EnumValues
Name
Presence
Type

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


Default Field

AttDef.Default Field

[Visual Basic]
Public Default As String
[C#]
public string Default;
[C++]
public: String* Default;
[JScript]
public var Default: String;

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


EnumValues Field

AttDef.EnumValues Field

[Visual Basic]
Public EnumValues As String()
[C#]
public string[] EnumValues;
[C++]
public: String* EnumValues __gc[];
[JScript]
public var EnumValues: String[];

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


Name Field

AttDef.Name Field

[Visual Basic]
Public Name As String
[C#]
public string Name;
[C++]
public: String* Name;
[JScript]
public var Name: String;

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


Presence Field

AttDef.Presence Field

[Visual Basic]
Public Presence As AttributePresence
[C#]
public AttributePresence Presence;
[C++]
public: AttributePresence Presence;
[JScript]
public var Presence: AttributePresence;

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


Type Field

AttDef.Type Field

[Visual Basic]
Public Type As AttributeType
[C#]
public AttributeType Type;
[C++]
public: AttributeType Type;
[JScript]
public var Type: AttributeType;

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


AttDef Methods

The methods of the AttDef class are listed below. For a complete list of AttDef class members, see the AttDef Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetPresence |
SetType |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


SetPresence Method

AttDef.SetPresence Method

[Visual Basic]
Public Function SetPresence( _
   ByVal token As String _
) As Boolean
[C#]
public bool SetPresence(
   string token
);
[C++]
public: bool SetPresence(
   String* token
);
[JScript]
public function SetPresence(
   String token
): bool;

Parameters

token

Return Value

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


SetType Method

AttDef.SetType Method

[Visual Basic]
Public Sub SetType( _
   ByVal type As String _
)
[C#]
public void SetType(
   string type
);
[C++]
public: void SetType(
   String* type
);
[JScript]
public function SetType(
   String type
);

Parameters

type

See Also

AttDef Class | Dart.PowerWEB.TextBox Namespace


AttList Class

For a list of all members of this type, see AttList Members.

System.Object
Dart.PowerWEB.TextBox.AttList

[Visual Basic]
Public Class AttList
    Implements IEnumerable
[C#]
public class AttList : IEnumerable
[C++]
public __gc class AttList : public IEnumerable
[JScript]
public class AttList extends IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

AttList Members | Dart.PowerWEB.TextBox Namespace


AttList Members

AttList overview

Public Instance Constructors

AttList Constructor

Public Instance Properties

Item

Public Instance Methods

Add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AttList Class | Dart.PowerWEB.TextBox Namespace


AttList Constructor

[Visual Basic]
Public Sub New()
[C#]
public AttList();
[C++]
public: AttList();
[JScript]
public function AttList();

See Also

AttList Class | Dart.PowerWEB.TextBox Namespace


AttList Properties

The properties of the AttList class are listed below. For a complete list of AttList class members, see the AttList Members topic.

Public Instance Properties

Item

See Also

AttList Class | Dart.PowerWEB.TextBox Namespace


Item Property

AttList.Item Property

[C#] In C#, this property is the indexer for the AttList class.

[Visual Basic]
Public Default Property ReadOnly Item( _
   ByVal name As String _
) As AttDef
[C#]
public AttDef this[
   string name
] { get; }
[C++]
public: __property AttDef* get_Item(
   String* name
);
[JScript]
returnValue = AttListObject.Item( name );
-or-
returnValue = AttListObject( name );

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

See Also

AttList Class | Dart.PowerWEB.TextBox Namespace


AttList Methods

The methods of the AttList class are listed below. For a complete list of AttList class members, see the AttList Members topic.

Public Instance Methods

Add |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AttList Class | Dart.PowerWEB.TextBox Namespace


Add Method

AttList.Add Method

[Visual Basic]
Public Sub Add( _
   ByVal a As AttDef _
)
[C#]
public void Add(
   AttDef a
);
[C++]
public: void Add(
   AttDef* a
);
[JScript]
public function Add(
   AttDef a
);

Parameters

a

See Also

AttList Class | Dart.PowerWEB.TextBox Namespace


GetEnumerator Method

AttList.GetEnumerator Method

[Visual Basic]
Public Function GetEnumerator() _
    Implements IEnumerable.GetEnumerator As IEnumerator
[C#]
public IEnumerator GetEnumerator();
[C++]
public: IEnumerator* GetEnumerator();
[JScript]
public function GetEnumerator(): IEnumerator;

Return Value

Implements

IEnumerable.GetEnumerator

See Also

AttList Class | Dart.PowerWEB.TextBox Namespace


AttributePresence Enumeration

[Visual Basic]
Public Enum AttributePresence
[C#]
public enum AttributePresence
[C++]
public __value enum AttributePresence
[JScript]
public enum AttributePresence

Members

Member Name | Description
DEFAULT |
FIXED |
REQUIRED |
IMPLIED |

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


AttributeType Enumeration

[Visual Basic]
Public Enum AttributeType
[C#]
public enum AttributeType
[C++]
public __value enum AttributeType
[JScript]
public enum AttributeType

Members

Member Name | Description
DEFAULT |
CDATA |
ENTITY |
ENTITIES |
ID |
IDREF |
IDREFS |
NAME |
NAMES |
NMTOKEN |
NMTOKENS |
NUMBER |
NUMBERS |
NUTOKEN |
NUTOKENS |
NOTATION |
ENUMERATION |

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


AutoSaveEventHandler Delegate

Represents a method which will handle the HtmlBox.AutoSave event.

[Visual Basic]
Public Delegate Function Sub  AutoSaveEventHandler( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
[C#]
public delegate void AutoSaveEventHandler(
   object sender,
   EventArgs e
)
[C++]
public __gc __delegate void AutoSaveEventHandler(
   Object* sender,
   EventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Remarks

When you create a AutoSaveEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


BaseChildControl Class

Base class for all child controls used by PowerWEB TextBox for .NET

For a list of all members of this type, see BaseChildControl Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Derived types

[Visual Basic]
Public Class BaseChildControl
    Inherits WebControl
[C#]
public class BaseChildControl : WebControl
[C++]
public __gc class BaseChildControl : public WebControl
[JScript]
public class BaseChildControl extends WebControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class provides designer support for all child controls.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

BaseChildControl Members | Dart.PowerWEB.TextBox Namespace


BaseChildControl Members

BaseChildControl overview

Public Instance Constructors

BaseChildControl Constructor Creates and initializes a default instance of BaseChildControl

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor | Overidden. Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor | Overidden. Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth | Overidden. Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass | Overidden. Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled | Overidden. Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font | Overidden. Gets the font properties associated with the control.
ForeColor | Overidden. Gets or sets the foreground color (typically the color of the text) of the control.
Height | Overidden. Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex | Overidden. Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip | Overidden. Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible | Overidden. Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width | Overidden. Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


BaseChildControl Constructor

Creates and initializes a default instance of BaseChildControl

[Visual Basic]
Public Sub New()
[C#]
public BaseChildControl();
[C++]
public: BaseChildControl();
[JScript]
public function BaseChildControl();

Remarks

Use this constructor to create and initialize a new instance of the BaseChildControl class.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


BaseChildControl Properties

The properties of the BaseChildControl class are listed below. For a complete list of BaseChildControl class members, see the BaseChildControl Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor | Overidden. Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor | Overidden. Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth | Overidden. Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass | Overidden. Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled | Overidden. Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font | Overidden. Gets the font properties associated with the control.
ForeColor | Overidden. Gets or sets the foreground color (typically the color of the text) of the control.
Height | Overidden. Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex | Overidden. Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip | Overidden. Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible | Overidden. Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width | Overidden. Gets or sets the width of the control.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


BackColor Property

BaseChildControl.BackColor Property

Gets or sets the background color of the control.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override Color BackColor { get; set; }
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(Color );
[JScript]
public override function get BackColor() : Color
public override function set BackColor(Color);

Property Value

A System.Drawing.Color that represents the background color of the control. The default is Color.Empty, which indicates that this property is not set.

Remarks

Use the BackColor property to specify the background color of the control. This property is set using a System.Drawing.Color object.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


BorderColor Property

BaseChildControl.BorderColor Property

Gets or sets the border color of the control.

[Visual Basic]
Overrides Public Property BorderColor As Color
[C#]
public override Color BorderColor { get; set; }
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color );
[JScript]
public override function get BorderColor() : Color
public override function set BorderColor(Color);

Property Value

A System.Drawing.Color that represents the border color of the control. The default is Color.Empty, which indicates that this property is not set.

Remarks

Use the BorderColor property to specify the border color of the control. This property is set using a System.Drawing.Color object.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


BorderStyle Property

BaseChildControl.BorderStyle Property

Gets or sets the border style of the control.

[Visual Basic]
Overrides Public Property BorderStyle As BorderStyle
[C#]
public override BorderStyle BorderStyle { get; set; }
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle );
[JScript]
public override function get BorderStyle() : BorderStyle
public override function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration values. The default is NotSet.

Remarks

Use the BorderStyle property to specify the border style for the control. This property is set using one of the BorderStyle enumeration values.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


BorderWidth Property

BaseChildControl.BorderWidth Property

Gets or sets the border width of the control

[Visual Basic]
Overrides Public Property BorderWidth As Unit
[C#]
public override Unit BorderWidth { get; set; }
[C++]
public: __property Unit get_BorderWidth();
public: __property void set_BorderWidth(Unit );
[JScript]
public override function get BorderWidth() : Unit
public override function set BorderWidth(Unit);

Property Value

A Unit that represents the border width of the control. The default value is Unit.Empty, which indicates that this property is not set.

Remarks

Use the BorderWidth property to specify a border width for a control

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


CssClass Property

BaseChildControl.CssClass Property

Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.

[Visual Basic]
Overrides Public Property CssClass As String
[C#]
public override string CssClass { get; set; }
[C++]
public: __property String* get_CssClass();
public: __property void set_CssClass(String* );
[JScript]
public override function get CssClass() : String
public override function set CssClass(String);

Property Value

The CSS class rendered by the control on the client. The default is String.Empty.

Remarks

Use the CssClass property to specify the CSS class to render on the client for the control. This property will render on browsers for all controls. It will always be rendered as the class attribute, regardless of the browser.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


Enabled Property

BaseChildControl.Enabled Property

Gets or sets a value indicating whether the Web server control is enabled.

[Visual Basic]
Overrides Public Property Enabled As Boolean
[C#]
public override bool Enabled { get; set; }
[C++]
public: __property bool get_Enabled();
public: __property void set_Enabled(bool );
[JScript]
public override function get Enabled() : bool
public override function set Enabled(bool);

Property Value

true if control is enabled; otherwise, false. The default is true.

Remarks

Use the Enabled property to specify or determine whether a control is functional. When set to false, the control appears dimmed, preventing any input from being entered in the control.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


Font Property

BaseChildControl.Font Property

Gets the font properties associated with the control.

[Visual Basic]
Overrides Public Property ReadOnly Font As FontInfo
[C#]
public override FontInfo Font { get; }
[C++]
public: __property FontInfo* get_Font();
[JScript]
public override function get Font() : FontInfo

Property Value

A FontInfo that represents the font properties of the control.

Remarks

Use the Font property to specify the font properties of the Web Server control. This property includes subproperties that can be accessed declaratively in the form of Property-Subproperty (for example Font-Bold) or programmatically in the form of Property.Subproperty (for example Font.Bold).

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


ForeColor Property

BaseChildControl.ForeColor Property

Gets or sets the foreground color (typically the color of the text) of the control.

[Visual Basic]
Overrides Public Property ForeColor As Color
[C#]
public override Color ForeColor { get; set; }
[C++]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(Color );
[JScript]
public override function get ForeColor() : Color
public override function set ForeColor(Color);

Property Value

A System.Drawing.Color that represents the foreground color of the control. The default is Color.Empty.

Remarks

Use the ForeColor property to specify the foreground color of the control. The foreground color is usually the color of the text. This property will render on browsers earlier than Microsoft Internet

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


Height Property

BaseChildControl.Height Property

Gets or sets the height of the control.

[Visual Basic]
Overrides Public Property Height As Unit
[C#]
public override Unit Height { get; set; }
[C++]
public: __property Unit get_Height();
public: __property void set_Height(Unit );
[JScript]
public override function get Height() : Unit
public override function set Height(Unit);

Property Value

A Unit that represents the height of the control. The default is Unit.Empty.

Remarks

Use the Height property to specify the height of the control

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


TabIndex Property

BaseChildControl.TabIndex Property

Gets or sets the tab index of the Web server control.

[Visual Basic]
Overrides Public Property TabIndex As Short
[C#]
public override short TabIndex { get; set; }
[C++]
public: __property short get_TabIndex();
public: __property void set_TabIndex(short );
[JScript]
public override function get TabIndex() : short
public override function set TabIndex(short);

Property Value

The tab index of the Web server control. The default is 0, which indicates that this property is not set.

Remarks

Use the TabIndex property to specify or determine the tab index of a Web server control on the Web Forms page. When you press the Tab key, the order in which the Web server controls receive focus is determined by the TabIndex property of each control. When a page is initially loaded, the first item that receives focus when the Tab key is pressed is the addess bar. Next, the controls on the Web Forms page are tabbed to in ascending order, based on the value of the TabIndex property of each control, starting with the smallest positive, nonzero value. If multiple controls share the same tab index, the controls will receive focus in the order they are declared on the Web Forms page. Finally, controls that have a tab index of zero are tabbed to in the order they are declared.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


ToolTip Property

BaseChildControl.ToolTip Property

Gets or sets the text displayed when the mouse pointer hovers over the Web server control.

[Visual Basic]
Overrides Public Property ToolTip As String
[C#]
public override string ToolTip { get; set; }
[C++]
public: __property String* get_ToolTip();
public: __property void set_ToolTip(String* );
[JScript]
public override function get ToolTip() : String
public override function set ToolTip(String);

Property Value

The text displayed when the mouse pointer hovers over the Web server control. The default is String.Empty.

Remarks

Use the ToolTip property to specify the custom text that is displayed when the mouse pointer hovers over the Web server control.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


Visible Property

BaseChildControl.Visible Property

Gets or sets a value that indicates whether a server control is rendered as UI on the page.

[Visual Basic]
Overrides Public Property Visible As Boolean
[C#]
public override bool Visible { get; set; }
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(bool );
[JScript]
public override function get Visible() : bool
public override function set Visible(bool);

Property Value

true if the control is visible on the page; otherwise false.

Remarks

If this property is false, the server control is not rendered. You should take this into account when organizing the lay out of your page.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


Width Property

BaseChildControl.Width Property

Gets or sets the width of the control.

[Visual Basic]
Overrides Public Property Width As Unit
[C#]
public override Unit Width { get; set; }
[C++]
public: __property Unit get_Width();
public: __property void set_Width(Unit );
[JScript]
public override function get Width() : Unit
public override function set Width(Unit);

Property Value

A Unit that represents the width of the control. The default is Unit.Empty.

Remarks

Use the Width property to specify the width of the control

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


BaseChildControl Methods

The methods of the BaseChildControl class are listed below. For a complete list of BaseChildControl class members, see the BaseChildControl Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


MergeStyle Method

BaseChildControl.MergeStyle Method

Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.

[Visual Basic]
Public Sub MergeStyle( _
   ByVal s As Style _
)
[C#]
public void MergeStyle(
   Style s
);
[C++]
public: void MergeStyle(
   Style* s
);
[JScript]
public function MergeStyle(
   Style s
);

Parameters

s
A Style that represents the style to be copied.

See Also

BaseChildControl Class | Dart.PowerWEB.TextBox Namespace


BaseStyle Class

Summary description for BaseStyle.

For a list of all members of this type, see BaseStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.TextBox.BaseStyle
Dart.PowerWEB.TextBox.ButtonStyle
Dart.PowerWEB.TextBox.DialogStyle
Dart.PowerWEB.TextBox.HighlightStyle
Dart.PowerWEB.TextBox.MenuStyle

[Visual Basic]
Public Class BaseStyle
    Inherits Style
[C#]
public class BaseStyle : Style
[C++]
public __gc class BaseStyle : public Style
[JScript]
public class BaseStyle extends Style

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

BaseStyle Members | Dart.PowerWEB.TextBox Namespace


BaseStyle Members

BaseStyle overview

Public Instance Constructors

BaseStyle Overloaded. Initializes a new instance of the BaseStyle class.

Public Instance Properties

BackColor | Gets or sets the background color of the control.
BorderColor | Gets or sets the border color of the control.
BorderStyle | Gets or sets the border style of the control.
BorderWidth | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font | Gets the font properties associated with the Web server control.
ForeColor | Gets or sets the foreground color (typically the color of the text) of the control.
Height | Gets or sets the height of the control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width | Gets or sets the width of the control.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
Clear | Sets all style properties to "non-set" equivalents.
CopyFrom (inherited from Style) | Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith (inherited from Style) | Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset (inherited from Style) | Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


BaseStyle Constructor

Creates and initializes a default instance of BaseStyle.

Overload List

Creates and initializes a default instance of BaseStyle.

[Visual Basic] Public Sub New()
[C#] public BaseStyle();
[C++] public: BaseStyle();
[JScript] public function BaseStyle();

Initializes a new instance of the BaseStyle class with the specified state bag information.

[Visual Basic] Public Sub New(ByVal StateBag)
[C#] public BaseStyle(StateBag);
[C++] public: BaseStyle(StateBag*);
[JScript] public function BaseStyle(StateBag);

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


BaseStyle Constructor ()

Creates and initializes a default instance of BaseStyle.

[Visual Basic]
Public Sub New()
[C#]
public BaseStyle();
[C++]
public: BaseStyle();
[JScript]
public function BaseStyle();

Remarks

Use this constructor to create and initialize a new instance of the BaseStyle class.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace | BaseStyle Constructor Overload List


BaseStyle Constructor (StateBag)

Initializes a new instance of the BaseStyle class with the specified state bag information.

[Visual Basic]
Public Sub New( _
   ByVal bag As StateBag _
)
[C#]
public BaseStyle(
   StateBag bag
);
[C++]
public: BaseStyle(
   StateBag* bag
);
[JScript]
public function BaseStyle(
   StateBag bag
);

Parameters

bag
A System.Web.UI.StateBag that represents the state bag in which to store style information.

Remarks

Use this constructor to create an initialize a new instance of the BaseStyle class using the System.Web.UI.StateBag specified by the bag parameter.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace | BaseStyle Constructor Overload List


BaseStyle Properties

The properties of the BaseStyle class are listed below. For a complete list of BaseStyle class members, see the BaseStyle Members topic.

Public Instance Properties

BackColor | Gets or sets the background color of the control.
BorderColor | Gets or sets the border color of the control.
BorderStyle | Gets or sets the border style of the control.
BorderWidth | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font | Gets the font properties associated with the Web server control.
ForeColor | Gets or sets the foreground color (typically the color of the text) of the control.
Height | Gets or sets the height of the control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width | Gets or sets the width of the control.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


BackColor Property

BaseStyle.BackColor Property

Gets or sets the background color of the control.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor { get; set; }
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(Color );
[JScript]
public function get BackColor() : Color
public function set BackColor(Color);

Property Value

A System.Drawing.Color that represents the background color of the control. The default is Color.Empty, which indicates that this property is not set.

Remarks

Use the BackColor property to specify the background color of the control. This property is set using a System.Drawing.Color object.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


BorderColor Property

BaseStyle.BorderColor Property

Gets or sets the border color of the control.

[Visual Basic]
Public Property BorderColor As Color
[C#]
public Color BorderColor { get; set; }
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color );
[JScript]
public function get BorderColor() : Color
public function set BorderColor(Color);

Property Value

A System.Drawing.Color that represents the border color of the control. The default is Color.Empty, which indicates that this property is not set.

Remarks

Use the BorderColor property to specify the border color of the control. This property is set using a System.Drawing.Color object.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


BorderStyle Property

BaseStyle.BorderStyle Property

Gets or sets the border style of the control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle { get; set; }
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle );
[JScript]
public function get BorderStyle() : BorderStyle
public function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration values. The default is NotSet.

Remarks

Use the BorderStyle property to specify the border style for the control. This property is set using one of the BorderStyle enumeration values.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


BorderWidth Property

BaseStyle.BorderWidth Property

Gets or sets the border width of the control

[Visual Basic]
Public Property BorderWidth As Unit
[C#]
public Unit BorderWidth { get; set; }
[C++]
public: __property Unit get_BorderWidth();
public: __property void set_BorderWidth(Unit );
[JScript]
public function get BorderWidth() : Unit
public function set BorderWidth(Unit);

Property Value

A Unit that represents the border width of the control. The default value is Unit.Empty, which indicates that this property is not set.

Remarks

Use the BorderWidth property to specify a border width for a control

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


CssClass Property

BaseStyle.CssClass Property

Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.

[Visual Basic]
Public Property CssClass As String
[C#]
public string CssClass { get; set; }
[C++]
public: __property String* get_CssClass();
public: __property void set_CssClass(String* );
[JScript]
public function get CssClass() : String
public function set CssClass(String);

Property Value

The CSS class rendered by the control on the client. The default is String.Empty.

Remarks

Use the CssClass property to specify the CSS class to render on the client for the control. This property will render on browsers for all controls. It will always be rendered as the class attribute, regardless of the browser.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


Font Property

BaseStyle.Font Property

Gets the font properties associated with the Web server control.

[Visual Basic]
Public Property ReadOnly Font As FontInfo
[C#]
public FontInfo Font { get; }
[C++]
public: __property FontInfo* get_Font();
[JScript]
public function get Font() : FontInfo

Property Value

A FontInfo that represents the font properties of the Web server control.

Remarks

Use the Font property to specify the font properties of the Web server control. This property includes subproperties that can be accessed declaratively in the form of Property-Subproperty (for example Font-Bold) or programmatically in the form of Property.Subproperty (for example Font.Bold).

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


ForeColor Property

BaseStyle.ForeColor Property

Gets or sets the foreground color (typically the color of the text) of the control.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor { get; set; }
[C++]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(Color );
[JScript]
public function get ForeColor() : Color
public function set ForeColor(Color);

Property Value

A System.Drawing.Color that represents the foreground color of the control. The default is Color.Empty.

Remarks

Use the ForeColor property to specify the foreground color of the control. The foreground color is usually the color of the text. This property will render on browsers earlier than Microsoft Internet

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


Height Property

BaseStyle.Height Property

Gets or sets the height of the control.

[Visual Basic]
Public Property Height As Unit
[C#]
public Unit Height { get; set; }
[C++]
public: __property Unit get_Height();
public: __property void set_Height(Unit );
[JScript]
public function get Height() : Unit
public function set Height(Unit);

Property Value

A Unit that represents the height of the control. The default is Unit.Empty.

Remarks

Use the Height property to specify the height of the control

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


Width Property

BaseStyle.Width Property

Gets or sets the width of the control.

[Visual Basic]
Public Property Width As Unit
[C#]
public Unit Width { get; set; }
[C++]
public: __property Unit get_Width();
public: __property void set_Width(Unit );
[JScript]
public function get Width() : Unit
public function set Width(Unit);

Property Value

A Unit that represents the width of the control. The default is Unit.Empty.

Remarks

Use the Width property to specify the width of the control

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


BaseStyle Methods

The methods of the BaseStyle class are listed below. For a complete list of BaseStyle class members, see the BaseStyle Members topic.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
Clear | Sets all style properties to "non-set" equivalents.
CopyFrom (inherited from Style) | Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith (inherited from Style) | Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset (inherited from Style) | Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


Clear Method

BaseStyle.Clear Method

Sets all style properties to "non-set" equivalents.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();
[C++]
public: virtual void Clear();
[JScript]
public virtual function Clear();

Remarks

For example, Height is set to 0, BackColor is set to Color.Empty, etc.

This method resets the properties of the style. For example, Style.BackColor will become Color.Empty, Style.BorderStyle will become BorderStyle.NotSet, etc.

See Also

BaseStyle Class | Dart.PowerWEB.TextBox Namespace


BaseToolbarButton Class

Base class for all toolbar buttons.

For a list of all members of this type, see BaseToolbarButton Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.BaseToolbarButton
Dart.PowerWEB.TextBox.ToolbarButton
Dart.PowerWEB.TextBox.ToolbarDialogButton
Dart.PowerWEB.TextBox.ToolbarMenuButton
Dart.PowerWEB.TextBox.ToolbarUploadButton

[Visual Basic]
Public Class BaseToolbarButton
    Inherits BaseToolbarItem
[C#]
public class BaseToolbarButton : BaseToolbarItem
[C++]
public __gc class BaseToolbarButton : public BaseToolbarItem
[JScript]
public class BaseToolbarButton extends BaseToolbarItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class provides a common button interface and provides mouse-effect capabilites.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

BaseToolbarButton Members | Dart.PowerWEB.TextBox Namespace


BaseToolbarButton Members

BaseToolbarButton overview

Public Instance Constructors

BaseToolbarButton Constructor Creates and initializes a default instance of BaseToolbarButton

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor | Overidden. Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth | Overidden. Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight | Gets or sets the height of the button image in pixels.
ImageName | The name of the image displayed on the button.
ImageWidth | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
MouseDownBackColor | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


BaseToolbarButton Constructor

Creates and initializes a default instance of BaseToolbarButton

[Visual Basic]
Public Sub New()
[C#]
public BaseToolbarButton();
[C++]
public: BaseToolbarButton();
[JScript]
public function BaseToolbarButton();

Remarks

Use this constructor to create and initialize a new instance of the BaseToolbarButton class.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


BaseToolbarButton Properties

The properties of the BaseToolbarButton class are listed below. For a complete list of BaseToolbarButton class members, see the BaseToolbarButton Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor | Overidden. Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth | Overidden. Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight | Gets or sets the height of the button image in pixels.
ImageName | The name of the image displayed on the button.
ImageWidth | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
MouseDownBackColor | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


BorderColor Property

BaseToolbarButton.BorderColor Property

Gets or sets the border color of the control.

[Visual Basic]
Overrides Public Property BorderColor As Color
[C#]
public override Color BorderColor { get; set; }
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color );
[JScript]
public override function get BorderColor() : Color
public override function set BorderColor(Color);

Property Value

A System.Drawing.Color that represents the border color of the control. The default is Color.Empty, which indicates that this property is not set.

Remarks

Use the BorderColor property to specify the border color of the control. This property is set using a System.Drawing.Color object.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


BorderStyle Property

BaseToolbarButton.BorderStyle Property

Gets or sets the border style of the control.

[Visual Basic]
Overrides Public Property BorderStyle As BorderStyle
[C#]
public override BorderStyle BorderStyle { get; set; }
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle );
[JScript]
public override function get BorderStyle() : BorderStyle
public override function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration values. The default is NotSet.

Remarks

Use the BorderStyle property to specify the border style for the control. This property is set using one of the BorderStyle enumeration values.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


BorderWidth Property

BaseToolbarButton.BorderWidth Property

Gets or sets the border width of the control

[Visual Basic]
Overrides Public Property BorderWidth As Unit
[C#]
public override Unit BorderWidth { get; set; }
[C++]
public: __property Unit get_BorderWidth();
public: __property void set_BorderWidth(Unit );
[JScript]
public override function get BorderWidth() : Unit
public override function set BorderWidth(Unit);

Property Value

A Unit that represents the border width of the control. The default value is Unit.Empty, which indicates that this property is not set.

Remarks

Use the BorderWidth property to specify a border width for a control

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


FileType Property

BaseToolbarButton.FileType Property

Gets or sets the file extention to be used for all image-related properties of the button.

[Visual Basic]
Public Property FileType As String
[C#]
public string FileType { get; set; }
[C++]
public: __property String* get_FileType();
public: __property void set_FileType(String* );
[JScript]
public function get FileType() : String
public function set FileType(String);

Property Value

A string containing the file type to be used for all image-related properties. The default value is ".gif".

Remarks

The value of this property is combined with BaseToolbarItem.ItemPrefix to derive the image-related property names. For example (using the default values for a "bold" button):

  • ItemPrefix = "bold"
  • FileType = ".gif"
  • ImageName = "bold.gif"
  • MouseOverImageName = "bold_over.gif"
  • MouseDownImageName = "bold_down.gif"

Using this example, if the FileType was changed to ".jpg", ImageName would return "bold.jpg" by default, MouseOverImageName would return "bold_over.jpg" by default, etc.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


ImageHeight Property

BaseToolbarButton.ImageHeight Property

Gets or sets the height of the button image in pixels.

[Visual Basic]
Overridable Public Property ImageHeight As Integer
[C#]
public virtual int ImageHeight { get; set; }
[C++]
public: virtual __property int get_ImageHeight();
public: virtual __property void set_ImageHeight(int );
[JScript]
public virtual function get ImageHeight() : int
public virtual function set ImageHeight(int);

Property Value

An integer specifying the height of the image in pixels.

Remarks

This property differs from the Height property in that the Height property controls the height of the border surrounding the image, while this property controls the height of the image itself.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


ImageName Property

BaseToolbarButton.ImageName Property

The name of the image displayed on the button.

[Visual Basic]
Public Property ImageName As String
[C#]
public string ImageName { get; set; }
[C++]
public: __property String* get_ImageName();
public: __property void set_ImageName(String* );
[JScript]
public function get ImageName() : String
public function set ImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

This property is not used when HtmlBox.ButtonMode = ButtonMode.HTML.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


ImageWidth Property

BaseToolbarButton.ImageWidth Property

Gets or sets the width of the button image in pixels.

[Visual Basic]
Overridable Public Property ImageWidth As Integer
[C#]
public virtual int ImageWidth { get; set; }
[C++]
public: virtual __property int get_ImageWidth();
public: virtual __property void set_ImageWidth(int );
[JScript]
public virtual function get ImageWidth() : int
public virtual function set ImageWidth(int);

Property Value

An integer specifying the width of the image in pixels.

Remarks

This property differs from the Width property in that the Width property controls the width of the border surrounding the image, while this property controls the width of the image itself.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseDownBackColor Property

BaseToolbarButton.MouseDownBackColor Property

Gets or sets the background color of the button when the button is clicked by the mouse.

[Visual Basic]
Overridable Public Property MouseDownBackColor As Color
[C#]
public virtual Color MouseDownBackColor { get; set; }
[C++]
public: virtual __property Color get_MouseDownBackColor();
public: virtual __property void set_MouseDownBackColor(Color );
[JScript]
public virtual function get MouseDownBackColor() : Color
public virtual function set MouseDownBackColor(Color);

Property Value

A System.Drawing.Color value specifying the background color.

Remarks

The background color of the button changes to the color specified by this property when the button is clicked by the mouse. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseDownBorderColor Property

BaseToolbarButton.MouseDownBorderColor Property

Gets or sets the border color of the button when the button is clicked by the mouse.

[Visual Basic]
Overridable Public Property MouseDownBorderColor As Color
[C#]
public virtual Color MouseDownBorderColor { get; set; }
[C++]
public: virtual __property Color get_MouseDownBorderColor();
public: virtual __property void set_MouseDownBorderColor(Color );
[JScript]
public virtual function get MouseDownBorderColor() : Color
public virtual function set MouseDownBorderColor(Color);

Property Value

A System.Drawing.Color value specifying the border color.

Remarks

The border color of the button changes to the color specified by this property when the button is clicked by the mouse. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseDownBorderStyle Property

BaseToolbarButton.MouseDownBorderStyle Property

Gets or sets the border style of the button when the button is clicked by the mouse.

[Visual Basic]
Overridable Public Property MouseDownBorderStyle As BorderStyle
[C#]
public virtual BorderStyle MouseDownBorderStyle { get; set; }
[C++]
public: virtual __property BorderStyle get_MouseDownBorderStyle();
public: virtual __property void set_MouseDownBorderStyle(BorderStyle );
[JScript]
public virtual function get MouseDownBorderStyle() : BorderStyle
public virtual function set MouseDownBorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration members.

Remarks

The border style of the button changes to the border style specified by this property when the button is clicked by the mouse. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseDownCursor Property

BaseToolbarButton.MouseDownCursor Property

Gets or sets the mouse cursor style when the button is clicked by the mouse.

[Visual Basic]
Overridable Public Property MouseDownCursor As CursorType
[C#]
public virtual CursorType MouseDownCursor { get; set; }
[C++]
public: virtual __property CursorType get_MouseDownCursor();
public: virtual __property void set_MouseDownCursor(CursorType );
[JScript]
public virtual function get MouseDownCursor() : CursorType
public virtual function set MouseDownCursor(CursorType);

Property Value

One of the CursorType enumeration members

Remarks

The cursor changes to the style specified by this property when the button is clicked by the mouse. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseDownImageName Property

BaseToolbarButton.MouseDownImageName Property

Gets or sets the name of the image displayed when the user clicks the button with the mouse.

[Visual Basic]
Public Property MouseDownImageName As String
[C#]
public string MouseDownImageName { get; set; }
[C++]
public: __property String* get_MouseDownImageName();
public: __property void set_MouseDownImageName(String* );
[JScript]
public function get MouseDownImageName() : String
public function set MouseDownImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

Buttons will ALWAYS be provided with default values upon creation. See the Property Defaults topic for more information.

This property is only used when HtmlBox.ButtonMode = ButtonMode.TwoStateImage or ButtonMode.ThreeStateImage. For information about the naming convention used for this property see Image Naming Convention.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseOverBackColor Property

BaseToolbarButton.MouseOverBackColor Property

Gets or sets the background color of the button when the mouse is placed over the button.

[Visual Basic]
Overridable Public Property MouseOverBackColor As Color
[C#]
public virtual Color MouseOverBackColor { get; set; }
[C++]
public: virtual __property Color get_MouseOverBackColor();
public: virtual __property void set_MouseOverBackColor(Color );
[JScript]
public virtual function get MouseOverBackColor() : Color
public virtual function set MouseOverBackColor(Color);

Property Value

A System.Drawing.Color value specifying the background color.

Remarks

The background color of the button changes to the color specified by this property when the mouse is placed over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseOverBorderColor Property

BaseToolbarButton.MouseOverBorderColor Property

Gets or sets the border color of the button when the mouse is placed over the button.

[Visual Basic]
Overridable Public Property MouseOverBorderColor As Color
[C#]
public virtual Color MouseOverBorderColor { get; set; }
[C++]
public: virtual __property Color get_MouseOverBorderColor();
public: virtual __property void set_MouseOverBorderColor(Color );
[JScript]
public virtual function get MouseOverBorderColor() : Color
public virtual function set MouseOverBorderColor(Color);

Property Value

A System.Drawing.Color value specifying the border color.

Remarks

The border color of the button changes to the color specified by this property when the mouse is placed over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseOverBorderStyle Property

BaseToolbarButton.MouseOverBorderStyle Property

Gets or sets the border style of the button when the mouse is placed over the button.

[Visual Basic]
Overridable Public Property MouseOverBorderStyle As BorderStyle
[C#]
public virtual BorderStyle MouseOverBorderStyle { get; set; }
[C++]
public: virtual __property BorderStyle get_MouseOverBorderStyle();
public: virtual __property void set_MouseOverBorderStyle(BorderStyle );
[JScript]
public virtual function get MouseOverBorderStyle() : BorderStyle
public virtual function set MouseOverBorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration members.

Remarks

The border style of the button changes to the border style specified by this property when the mouse is placed over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseOverCursor Property

BaseToolbarButton.MouseOverCursor Property

Gets or sets the mouse cursor style when the mouse is over the button.

[Visual Basic]
Overridable Public Property MouseOverCursor As CursorType
[C#]
public virtual CursorType MouseOverCursor { get; set; }
[C++]
public: virtual __property CursorType get_MouseOverCursor();
public: virtual __property void set_MouseOverCursor(CursorType );
[JScript]
public virtual function get MouseOverCursor() : CursorType
public virtual function set MouseOverCursor(CursorType);

Property Value

One of the CursorType enumeration members

Remarks

The cursor changes to the style specified by this property when the mouse is placed over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseOverImageName Property

BaseToolbarButton.MouseOverImageName Property

Gets or sets the name of the image displayed when the mouse is over the button.

[Visual Basic]
Public Property MouseOverImageName As String
[C#]
public string MouseOverImageName { get; set; }
[C++]
public: __property String* get_MouseOverImageName();
public: __property void set_MouseOverImageName(String* );
[JScript]
public function get MouseOverImageName() : String
public function set MouseOverImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

Buttons will ALWAYS be provided with default values upon creation. See the Property Defaults topic for more information.

This property is only used when HtmlBox.ButtonMode = ButtonMode.ThreeStateImage. For information about the naming convention used for this property see Image Naming Convention.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseUpBackColor Property

BaseToolbarButton.MouseUpBackColor Property

Gets or sets the background color of the button when the mouse click is released over the button.

[Visual Basic]
Overridable Public Property MouseUpBackColor As Color
[C#]
public virtual Color MouseUpBackColor { get; set; }
[C++]
public: virtual __property Color get_MouseUpBackColor();
public: virtual __property void set_MouseUpBackColor(Color );
[JScript]
public virtual function get MouseUpBackColor() : Color
public virtual function set MouseUpBackColor(Color);

Property Value

A System.Drawing.Color value specifying the background color.

Remarks

The background color of the button changes to the color specified by this property when the mouse click is released over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseUpBorderColor Property

BaseToolbarButton.MouseUpBorderColor Property

Gets or sets the border color of the button when the mouse click is released over the button.

[Visual Basic]
Overridable Public Property MouseUpBorderColor As Color
[C#]
public virtual Color MouseUpBorderColor { get; set; }
[C++]
public: virtual __property Color get_MouseUpBorderColor();
public: virtual __property void set_MouseUpBorderColor(Color );
[JScript]
public virtual function get MouseUpBorderColor() : Color
public virtual function set MouseUpBorderColor(Color);

Property Value

A System.Drawing.Color value specifying the border color.

Remarks

The border color of the button changes to the color specified by this property when the mouse click is released over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseUpBorderStyle Property

BaseToolbarButton.MouseUpBorderStyle Property

Gets or sets the border style of the button when the mouse click is released over the button.

[Visual Basic]
Overridable Public Property MouseUpBorderStyle As BorderStyle
[C#]
public virtual BorderStyle MouseUpBorderStyle { get; set; }
[C++]
public: virtual __property BorderStyle get_MouseUpBorderStyle();
public: virtual __property void set_MouseUpBorderStyle(BorderStyle );
[JScript]
public virtual function get MouseUpBorderStyle() : BorderStyle
public virtual function set MouseUpBorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration members.

Remarks

The border style of the button changes to the border style specified by this property when the mouse click is released over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


MouseUpCursor Property

BaseToolbarButton.MouseUpCursor Property

Gets or sets the mouse cursor style when the mouse click is released over the button.

[Visual Basic]
Overridable Public Property MouseUpCursor As CursorType
[C#]
public virtual CursorType MouseUpCursor { get; set; }
[C++]
public: virtual __property CursorType get_MouseUpCursor();
public: virtual __property void set_MouseUpCursor(CursorType );
[JScript]
public virtual function get MouseUpCursor() : CursorType
public virtual function set MouseUpCursor(CursorType);

Property Value

One of the CursorType enumeration members

Remarks

The cursor changes to the style specified by this property when the mouse click is released over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

BaseToolbarButton Class | Dart.PowerWEB.TextBox Namespace


BaseToolbarItem Class

Provides a common interface for all items on the toolbar.

For a list of all members of this type, see BaseToolbarItem Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.BaseToolbarButton
Dart.PowerWEB.TextBox.ToolbarDropDown
Dart.PowerWEB.TextBox.ToolbarImage
Dart.PowerWEB.TextBox.ToolbarText

[Visual Basic]
Public Class BaseToolbarItem
    Inherits BaseChildControl
[C#]
public class BaseToolbarItem : BaseChildControl
[C++]
public __gc class BaseToolbarItem : public BaseChildControl
[JScript]
public class BaseToolbarItem extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Only items which derive from BaseToolbarItem can be added to the toolbar.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

BaseToolbarItem Members | Dart.PowerWEB.TextBox Namespace


BaseToolbarItem Members

BaseToolbarItem overview

Public Instance Constructors

BaseToolbarItem Constructor Creates and initializes a default instance of BaseToolbarItem.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID | Overidden. Gets or sets the programmatic identifier assigned to the server control.
ItemPrefix | Gets or sets the prefix used to identify the item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

BaseToolbarItem Class | Dart.PowerWEB.TextBox Namespace


BaseToolbarItem Constructor

Creates and initializes a default instance of BaseToolbarItem.

[Visual Basic]
Public Sub New()
[C#]
public BaseToolbarItem();
[C++]
public: BaseToolbarItem();
[JScript]
public function BaseToolbarItem();

See Also

BaseToolbarItem Class | Dart.PowerWEB.TextBox Namespace


BaseToolbarItem Properties

The properties of the BaseToolbarItem class are listed below. For a complete list of BaseToolbarItem class members, see the BaseToolbarItem Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID | Overidden. Gets or sets the programmatic identifier assigned to the server control.
ItemPrefix | Gets or sets the prefix used to identify the item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

BaseToolbarItem Class | Dart.PowerWEB.TextBox Namespace


BorderStyle Property

BaseToolbarItem.BorderStyle Property

Gets or sets the border style of the control.

[Visual Basic]
Overrides Public Property BorderStyle As BorderStyle
[C#]
public override BorderStyle BorderStyle { get; set; }
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle );
[JScript]
public override function get BorderStyle() : BorderStyle
public override function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration values. The default is NotSet.

Remarks

Use the BorderStyle property to specify the border style for the control. This property is set using one of the BorderStyle enumeration values.

See Also

BaseToolbarItem Class | Dart.PowerWEB.TextBox Namespace


ID Property

BaseToolbarItem.ID Property

Gets or sets the programmatic identifier assigned to the server control.

[Visual Basic]
Overrides Public Property ID As String
[C#]
public override string ID { get; set; }
[C++]
public: __property String* get_ID();
public: __property void set_ID(String* );
[JScript]
public override function get ID() : String
public override function set ID(String);

Property Value

The programmatic identifier assigned to the control.

Remarks

PowerWEB will automatically assign values to this property on initialization. Do not modify the value of this property.

See Also

BaseToolbarItem Class | Dart.PowerWEB.TextBox Namespace


ItemPrefix Property

BaseToolbarItem.ItemPrefix Property

Gets or sets the prefix used to identify the item.

[Visual Basic]
Public Property ItemPrefix As String
[C#]
public string ItemPrefix { get; set; }
[C++]
public: __property String* get_ItemPrefix();
public: __property void set_ItemPrefix(String* );
[JScript]
public function get ItemPrefix() : String
public function set ItemPrefix(String);

Property Value

A string representing the prefix of the item.

Remarks

The prefix is used to provide a naming convention for the item. For example, if the ItemPrefix was "bold" (such as in the case of a bold button), the BaseToolbarItem.ImageName is "bold.gif", the BaseToolbarItem.MouseOverImageName is "bold_over.gif", etc.

All toolbar items are provided with default values. See Property Defaults for more information.

See Also

BaseToolbarItem Class | Dart.PowerWEB.TextBox Namespace


BaseToolbarItem Methods

The methods of the BaseToolbarItem class are listed below. For a complete list of BaseToolbarItem class members, see the BaseToolbarItem Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

See Also

BaseToolbarItem Class | Dart.PowerWEB.TextBox Namespace


ToString Method

BaseToolbarItem.ToString Method

Returns the value of the BaseToolbarItem.ItemPrefix property.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();
[C++]
public: String* ToString();
[JScript]
public override function ToString(): String;

Return Value

A string value representing the value of the BaseToolbarItem.ItemPrefix property.

See Also

BaseToolbarItem Class | Dart.PowerWEB.TextBox Namespace


ButtonMode Enumeration

Enumerates possible values for the HtmlBox.ButtonMode property.

[Visual Basic]
Public Enum ButtonMode
[C#]
public enum ButtonMode
[C++]
public __value enum ButtonMode
[JScript]
public enum ButtonMode

Remarks

By default the HtmlBox.ButtonMode property of the HtmlBox is ButtonMode.Image, which specifies that a single image will represent each button and mouse-effects will be applied using DHTML (see the HtmlBox.ButtonStyle property for more information on this). If you would like to use such highly-graphical button representations such as mouse-over image swaps set HtmlBox.ButtonMode to either ButtonMode.TwoStateImage (which specifies that there will be two images for each button, an "off" image and a "clicked" image) or ButtonMode.ThreeStateImage (which specifies that there will be three images for each button, an "off", an "over", and a "click" image). One of these two types will typically be used in skin implementations (see Using Skins) for more information. If you would like to remove images from the toolbr buttons altogether, set this property to ButtonMode.HTML and HTML input buttons will be used to represent the toolbar buttons.

Some image-name related properties will not have meaning depending on the button mode. For example:

ButtonMode.HTML

  • ImageName property - not used
  • MouseDownImageName property - not used
  • MouseOverImageName property - not used

ButtonMode.Image

  • ImageName property - represents the image used for the button (ex. "bold.gif")
  • MouseDownImageName property - not used
  • MouseOverImageName property - not used

ButtonMode.TwoStateImage

  • ImageName property - represents the image used for the button (ex. "bold.gif")
  • MouseDownImageName property - represents the image used for the button when it is clicked (ex. "bold_down.gif")
  • MouseOverImageName property - not used

ButtonMode.TwoStateImage

  • ImageName property - represents the image used for the button (ex. "bold.gif")
  • MouseDownImageName property - represents the image used for the button when it is clicked (ex. "bold_down.gif")
  • MouseOverImageName property - represents the image used for the button when the mouse is over the button (ex. "bold_over.gif")

Members

Member Name | Description
Image | Single images will be used to represent buttons. Mouse-effects will be applied by changing the style of the image using DHTML.
TwoStateImage | Two images will be used to represent each button ("off" and "down").
ThreeStateImage | Three images will be used to represent each button ("off", "over", and "down").
HTML | HTML buttons (input type='button') will be used to represent toolbar buttons.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ButtonStyle Class

Represents the style used by buttons.

For a list of all members of this type, see ButtonStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.TextBox.BaseStyle
Dart.PowerWEB.TextBox.ButtonStyle

[Visual Basic]
Public Class ButtonStyle
    Inherits BaseStyle
[C#]
public class ButtonStyle : BaseStyle
[C++]
public __gc class ButtonStyle : public BaseStyle
[JScript]
public class ButtonStyle extends BaseStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The ButtonStyle class extends the Style class by providing additional properties for DHMTL mouse-effects (such as mouse-over, mouse-down, and mouse-up style changes).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ButtonStyle Members | Dart.PowerWEB.TextBox Namespace


ButtonStyle Members

ButtonStyle overview

Public Instance Constructors

ButtonStyle Overloaded. Initializes a new instance of the ButtonStyle class.

Public Instance Properties

BackColor (inherited from BaseStyle) | Gets or sets the background color of the control.
BorderColor (inherited from BaseStyle) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseStyle) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseStyle) | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from BaseStyle) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font (inherited from BaseStyle) | Gets the font properties associated with the Web server control.
ForeColor (inherited from BaseStyle) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseStyle) | Gets or sets the height of the control.
ImageHeight | Gets or sets the height of the button image in pixels.
ImageWidth | Gets or sets the width of the button image in pixels.
MouseDownBackColor | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseOverBackColor | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor | Gets or sets the mouse cursor style when the mouse is over the button.
MouseUpBackColor | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor | Gets or sets the mouse cursor style when the mouse click is released over the button.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from BaseStyle) | Gets or sets the width of the control.

Public Instance Methods

AddAttributesToRender | Overidden. Overloaded. Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriter.
AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter. This method is primarily used by control developers.
Clear | Overidden. Sets all style properties to "non-set" equivalents.
CopyFrom | Overidden. Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith | Overidden. Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset | Overidden. Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


ButtonStyle Constructor

Creates and initializes a default instance of ButtonStyle.

Overload List

Creates and initializes a default instance of ButtonStyle.

[Visual Basic] Public Sub New()
[C#] public ButtonStyle();
[C++] public: ButtonStyle();
[JScript] public function ButtonStyle();

Initializes a new instance of the ButtonStyle class with the specified state bag information.

[Visual Basic] Public Sub New(ByVal StateBag)
[C#] public ButtonStyle(StateBag);
[C++] public: ButtonStyle(StateBag*);
[JScript] public function ButtonStyle(StateBag);

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


ButtonStyle Constructor ()

Creates and initializes a default instance of ButtonStyle.

[Visual Basic]
Public Sub New()
[C#]
public ButtonStyle();
[C++]
public: ButtonStyle();
[JScript]
public function ButtonStyle();

Remarks

Use this constructor to create and initialize a new instance of the ButtonStyle class.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace | ButtonStyle Constructor Overload List


ButtonStyle Constructor (StateBag)

Initializes a new instance of the ButtonStyle class with the specified state bag information.

[Visual Basic]
Public Sub New( _
   ByVal bag As StateBag _
)
[C#]
public ButtonStyle(
   StateBag bag
);
[C++]
public: ButtonStyle(
   StateBag* bag
);
[JScript]
public function ButtonStyle(
   StateBag bag
);

Parameters

bag
A System.Web.UI.StateBag that represents the state bag in which to store style information.

Remarks

Use this constructor to create an initialize a new instance of the ButtonStyle class using the System.Web.UI.StateBag specified by the bag parameter.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace | ButtonStyle Constructor Overload List


ButtonStyle Properties

The properties of the ButtonStyle class are listed below. For a complete list of ButtonStyle class members, see the ButtonStyle Members topic.

Public Instance Properties

BackColor (inherited from BaseStyle) | Gets or sets the background color of the control.
BorderColor (inherited from BaseStyle) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseStyle) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseStyle) | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from BaseStyle) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font (inherited from BaseStyle) | Gets the font properties associated with the Web server control.
ForeColor (inherited from BaseStyle) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseStyle) | Gets or sets the height of the control.
ImageHeight | Gets or sets the height of the button image in pixels.
ImageWidth | Gets or sets the width of the button image in pixels.
MouseDownBackColor | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseOverBackColor | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor | Gets or sets the mouse cursor style when the mouse is over the button.
MouseUpBackColor | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor | Gets or sets the mouse cursor style when the mouse click is released over the button.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from BaseStyle) | Gets or sets the width of the control.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


ImageHeight Property

ButtonStyle.ImageHeight Property

Gets or sets the height of the button image in pixels.

[Visual Basic]
Overridable Public Property ImageHeight As Integer
[C#]
public virtual int ImageHeight { get; set; }
[C++]
public: virtual __property int get_ImageHeight();
public: virtual __property void set_ImageHeight(int );
[JScript]
public virtual function get ImageHeight() : int
public virtual function set ImageHeight(int);

Property Value

An integer specifying the height of the image in pixels.

Remarks

This property differs from the Height property in that the Height property controls the height of the border surrounding the image, while this property controls the height of the image itself.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


ImageWidth Property

ButtonStyle.ImageWidth Property

Gets or sets the width of the button image in pixels.

[Visual Basic]
Overridable Public Property ImageWidth As Integer
[C#]
public virtual int ImageWidth { get; set; }
[C++]
public: virtual __property int get_ImageWidth();
public: virtual __property void set_ImageWidth(int );
[JScript]
public virtual function get ImageWidth() : int
public virtual function set ImageWidth(int);

Property Value

An integer specifying the width of the image in pixels.

Remarks

This property differs from the Width property in that the Width property controls the width of the border surrounding the image, while this property controls the width of the image itself.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseDownBackColor Property

ButtonStyle.MouseDownBackColor Property

Gets or sets the background color of the button when the button is clicked by the mouse.

[Visual Basic]
Overridable Public Property MouseDownBackColor As Color
[C#]
public virtual Color MouseDownBackColor { get; set; }
[C++]
public: virtual __property Color get_MouseDownBackColor();
public: virtual __property void set_MouseDownBackColor(Color );
[JScript]
public virtual function get MouseDownBackColor() : Color
public virtual function set MouseDownBackColor(Color);

Property Value

A System.Drawing.Color value specifying the background color.

Remarks

The background color of the button changes to the color specified by this property when the button is clicked by the mouse. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseDownBorderColor Property

ButtonStyle.MouseDownBorderColor Property

Gets or sets the border color of the button when the button is clicked by the mouse.

[Visual Basic]
Overridable Public Property MouseDownBorderColor As Color
[C#]
public virtual Color MouseDownBorderColor { get; set; }
[C++]
public: virtual __property Color get_MouseDownBorderColor();
public: virtual __property void set_MouseDownBorderColor(Color );
[JScript]
public virtual function get MouseDownBorderColor() : Color
public virtual function set MouseDownBorderColor(Color);

Property Value

A System.Drawing.Color value specifying the border color.

Remarks

The border color of the button changes to the color specified by this property when the button is clicked by the mouse. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseDownBorderStyle Property

ButtonStyle.MouseDownBorderStyle Property

Gets or sets the border style of the button when the button is clicked by the mouse.

[Visual Basic]
Overridable Public Property MouseDownBorderStyle As BorderStyle
[C#]
public virtual BorderStyle MouseDownBorderStyle { get; set; }
[C++]
public: virtual __property BorderStyle get_MouseDownBorderStyle();
public: virtual __property void set_MouseDownBorderStyle(BorderStyle );
[JScript]
public virtual function get MouseDownBorderStyle() : BorderStyle
public virtual function set MouseDownBorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration members.

Remarks

The border style of the button changes to the border style specified by this property when the button is clicked by the mouse. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseDownCursor Property

ButtonStyle.MouseDownCursor Property

Gets or sets the mouse cursor style when the button is clicked by the mouse.

[Visual Basic]
Overridable Public Property MouseDownCursor As CursorType
[C#]
public virtual CursorType MouseDownCursor { get; set; }
[C++]
public: virtual __property CursorType get_MouseDownCursor();
public: virtual __property void set_MouseDownCursor(CursorType );
[JScript]
public virtual function get MouseDownCursor() : CursorType
public virtual function set MouseDownCursor(CursorType);

Property Value

One of the CursorType enumeration members

Remarks

The cursor changes to the style specified by this property when the button is clicked by the mouse. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseOverBackColor Property

ButtonStyle.MouseOverBackColor Property

Gets or sets the background color of the button when the mouse is placed over the button.

[Visual Basic]
Overridable Public Property MouseOverBackColor As Color
[C#]
public virtual Color MouseOverBackColor { get; set; }
[C++]
public: virtual __property Color get_MouseOverBackColor();
public: virtual __property void set_MouseOverBackColor(Color );
[JScript]
public virtual function get MouseOverBackColor() : Color
public virtual function set MouseOverBackColor(Color);

Property Value

A System.Drawing.Color value specifying the background color.

Remarks

The background color of the button changes to the color specified by this property when the mouse is placed over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseOverBorderColor Property

ButtonStyle.MouseOverBorderColor Property

Gets or sets the border color of the button when the mouse is placed over the button.

[Visual Basic]
Overridable Public Property MouseOverBorderColor As Color
[C#]
public virtual Color MouseOverBorderColor { get; set; }
[C++]
public: virtual __property Color get_MouseOverBorderColor();
public: virtual __property void set_MouseOverBorderColor(Color );
[JScript]
public virtual function get MouseOverBorderColor() : Color
public virtual function set MouseOverBorderColor(Color);

Property Value

A System.Drawing.Color value specifying the border color.

Remarks

The border color of the button changes to the color specified by this property when the mouse is placed over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseOverBorderStyle Property

ButtonStyle.MouseOverBorderStyle Property

Gets or sets the border style of the button when the mouse is placed over the button.

[Visual Basic]
Overridable Public Property MouseOverBorderStyle As BorderStyle
[C#]
public virtual BorderStyle MouseOverBorderStyle { get; set; }
[C++]
public: virtual __property BorderStyle get_MouseOverBorderStyle();
public: virtual __property void set_MouseOverBorderStyle(BorderStyle );
[JScript]
public virtual function get MouseOverBorderStyle() : BorderStyle
public virtual function set MouseOverBorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration members.

Remarks

The border style of the button changes to the border style specified by this property when the mouse is placed over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseOverCursor Property

ButtonStyle.MouseOverCursor Property

Gets or sets the mouse cursor style when the mouse is over the button.

[Visual Basic]
Overridable Public Property MouseOverCursor As CursorType
[C#]
public virtual CursorType MouseOverCursor { get; set; }
[C++]
public: virtual __property CursorType get_MouseOverCursor();
public: virtual __property void set_MouseOverCursor(CursorType );
[JScript]
public virtual function get MouseOverCursor() : CursorType
public virtual function set MouseOverCursor(CursorType);

Property Value

One of the CursorType enumeration members

Remarks

The cursor changes to the style specified by this property when the mouse is placed over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseUpBackColor Property

ButtonStyle.MouseUpBackColor Property

Gets or sets the background color of the button when the mouse click is released over the button.

[Visual Basic]
Overridable Public Property MouseUpBackColor As Color
[C#]
public virtual Color MouseUpBackColor { get; set; }
[C++]
public: virtual __property Color get_MouseUpBackColor();
public: virtual __property void set_MouseUpBackColor(Color );
[JScript]
public virtual function get MouseUpBackColor() : Color
public virtual function set MouseUpBackColor(Color);

Property Value

A System.Drawing.Color value specifying the background color.

Remarks

The background color of the button changes to the color specified by this property when the mouse click is released over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseUpBorderColor Property

ButtonStyle.MouseUpBorderColor Property

Gets or sets the border color of the button when the mouse click is released over the button.

[Visual Basic]
Overridable Public Property MouseUpBorderColor As Color
[C#]
public virtual Color MouseUpBorderColor { get; set; }
[C++]
public: virtual __property Color get_MouseUpBorderColor();
public: virtual __property void set_MouseUpBorderColor(Color );
[JScript]
public virtual function get MouseUpBorderColor() : Color
public virtual function set MouseUpBorderColor(Color);

Property Value

A System.Drawing.Color value specifying the border color.

Remarks

The border color of the button changes to the color specified by this property when the mouse click is released over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseUpBorderStyle Property

ButtonStyle.MouseUpBorderStyle Property

Gets or sets the border style of the button when the mouse click is released over the button.

[Visual Basic]
Overridable Public Property MouseUpBorderStyle As BorderStyle
[C#]
public virtual BorderStyle MouseUpBorderStyle { get; set; }
[C++]
public: virtual __property BorderStyle get_MouseUpBorderStyle();
public: virtual __property void set_MouseUpBorderStyle(BorderStyle );
[JScript]
public virtual function get MouseUpBorderStyle() : BorderStyle
public virtual function set MouseUpBorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration members.

Remarks

The border style of the button changes to the border style specified by this property when the mouse click is released over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MouseUpCursor Property

ButtonStyle.MouseUpCursor Property

Gets or sets the mouse cursor style when the mouse click is released over the button.

[Visual Basic]
Overridable Public Property MouseUpCursor As CursorType
[C#]
public virtual CursorType MouseUpCursor { get; set; }
[C++]
public: virtual __property CursorType get_MouseUpCursor();
public: virtual __property void set_MouseUpCursor(CursorType );
[JScript]
public virtual function get MouseUpCursor() : CursorType
public virtual function set MouseUpCursor(CursorType);

Property Value

One of the CursorType enumeration members

Remarks

The cursor changes to the style specified by this property when the mouse click is released over the button. This property is only used when the HtmlBox.ButtonMode = ButtonMode.Image.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


ButtonStyle Methods

The methods of the ButtonStyle class are listed below. For a complete list of ButtonStyle class members, see the ButtonStyle Members topic.

Public Instance Methods

AddAttributesToRender | Overidden. Overloaded. Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriter.
AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter. This method is primarily used by control developers.
Clear | Overidden. Sets all style properties to "non-set" equivalents.
CopyFrom | Overidden. Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith | Overidden. Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset | Overidden. Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


AddAttributesToRender Method

ButtonStyle.AddAttributesToRender Method

Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriter.

Overload List

Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter. This method is primarily used by control developers.
Inherited from Style.

[Visual Basic] Public Sub AddAttributesToRender(ByVal HtmlTextWriter)
[C#] public void AddAttributesToRender(HtmlTextWriter);
[C++] public: void AddAttributesToRender(HtmlTextWriter*);
[JScript] public function AddAttributesToRender(HtmlTextWriter);

Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriter.

[Visual Basic] Overrides OverloadsPublic Sub AddAttributesToRender(ByVal HtmlTextWriter,ByVal WebControl)
[C#] public override void AddAttributesToRender(HtmlTextWriter,WebControl);
[C++] public: void AddAttributesToRender(HtmlTextWriter*,WebControl*);
[JScript] public override function AddAttributesToRender(HtmlTextWriter,WebControl);

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


AddAttributesToRender Method (HtmlTextWriter, WebControl)

ButtonStyle.AddAttributesToRender Method (HtmlTextWriter, WebControl)

Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriter.

[Visual Basic]
Overrides  OverloadsPublic Sub AddAttributesToRender( _
   ByVal writer As HtmlTextWriter, _
   ByVal owner As WebControl _
)
[C#]
public override void AddAttributesToRender(
   HtmlTextWriter writer,
   WebControl owner
);
[C++]
public: void AddAttributesToRender(
   HtmlTextWriter* writer,
   WebControl* owner
);
[JScript]
public override function AddAttributesToRender(
   HtmlTextWriter writer,
   WebControl owner
);

Parameters

writer
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.
owner
A WebControl or WebControl derived object that represents the Web server control associated with the Style.

Remarks

To render attributes and styles for a Web server control on the client, you typically call the HtmlTextWriter.AddAttribute and HtmlTextWriter.AddStyleAttribute methods to insert each attribute and style individually to the System.Web.UI.HtmlTextWriter output stream. To simplify the process, this method encapsulates all calls to the HtmlTextWriter.AddAttribute and HtmlTextWriter.AddStyleAttribute methods for every attribute and style associated with the Web server control. All attributes and styles are inserted into the System.Web.UI.HtmlTextWriter output stream in a single method call. This method is typically overridden by control developers in derived classes to insert the appropriate attributes and styles to the System.Web.UI.HtmlTextWriter output stream for the class.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace | ButtonStyle.AddAttributesToRender Overload List


Clear Method

ButtonStyle.Clear Method

Sets all style properties to "non-set" equivalents.

[Visual Basic]
Overrides Public Sub Clear()
[C#]
public override void Clear();
[C++]
public: void Clear();
[JScript]
public override function Clear();

Remarks

For example, Height is set to 0, BackColor is set to Color.Empty, etc.

This method resets the properties of the style. For example, Style.BackColor will become Color.Empty, Style.BorderStyle will become BorderStyle.NotSet, etc.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


CopyFrom Method

ButtonStyle.CopyFrom Method

Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.

[Visual Basic]
Overrides Public Sub CopyFrom( _
   ByVal s As Style _
)
[C#]
public override void CopyFrom(
   Style s
);
[C++]
public: void CopyFrom(
   Style* s
);
[JScript]
public override function CopyFrom(
   Style s
);

Parameters

s
A style type that represents the style to copy.

Remarks

Use the CopyFrom method to duplicate the style properties of the specified Style into the instance of the Style class that this method is called from.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


MergeWith Method

ButtonStyle.MergeWith Method

Combines the style properties of the specified Style with the instance of the Style class that this method is called from.

[Visual Basic]
Overrides Public Sub MergeWith( _
   ByVal s As Style _
)
[C#]
public override void MergeWith(
   Style s
);
[C++]
public: void MergeWith(
   Style* s
);
[JScript]
public override function MergeWith(
   Style s
);

Parameters

s
A style type that represents the style to combine.

Remarks

Use the MergeWith method to combine the style properties of the specified Style with the instance of the Style class that this method is called from.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


Reset Method

ButtonStyle.Reset Method

Removes any defined style elements from the state bag.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
public: void Reset();
[JScript]
public override function Reset();

Return Value

Use this method to remove any defined style elements from the state bag.

See Also

ButtonStyle Class | Dart.PowerWEB.TextBox Namespace


CaseFolding Enumeration

SGML is case insensitive, so here you can choose between converting to lower case or upper case tags. "None" means that the case is left alone, except that end tags will be folded to match the start tags.

[Visual Basic]
Public Enum CaseFolding
[C#]
public enum CaseFolding
[C++]
public __value enum CaseFolding
[JScript]
public enum CaseFolding

Members

Member Name | Description
None |
ToUpper |
ToLower |

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ClickBehavior Enumeration

Enumerates the different types of ClickBehavior for ToolbarButtons.

[Visual Basic]
Public Enum ClickBehavior
[C#]
public enum ClickBehavior
[C++]
public __value enum ClickBehavior
[JScript]
public enum ClickBehavior

Remarks

This enumeration replaces the RaisePostback boolean. ClickBehavior represents the postback behavior of the button when pressed.

Members

Member Name | Description
Postback | When clicked, the ToolbarButton will perform a traditional postback to the server, causing a ToolbarButtonClick event.
Callback | When clicked, the ToolbarButton will cause a callback to the server, causing a ToolbarButtonClick event. Unlike traditional postbacks, the entire page will not refresh.
None | When clicked, no postback or callback will occur.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ColorPaletteType Enumeration

Enumerates possible values for the HtmlBox.ColorPaletteType property.

[Visual Basic]
Public Enum ColorPaletteType
[C#]
public enum ColorPaletteType
[C++]
public __value enum ColorPaletteType
[JScript]
public enum ColorPaletteType

Remarks

A color palette appears in multiple places in several different forms throughout the editor. For example, the font color picker button displays a palette of colors when clicked. The insert table dialog displays a drop down list of all colors when loaded. This enumeration controls the colors that are displayed.

By default, the HtmlBox.ColorPaletteType property of the HtmlBox is set to ColorPaletteType.Standard, which indicates the standard 140 color standard palette (also found in System.Drawing.Color) will be used. Set HtmlBox.ColorPaletteType to ColorPaletteType.WebSafe to use the 216 color web-safe palette. If bandwidth or rendering time is an issue, set HtmlBox.ColorPaletteType to ColorPaletteType.Condensed to get a condensed 40 color palette.

Members

Member Name | Description
WebSafe | Causes the HtmlBox to use an expanded 216-color, web-safe palette.
Standard | Causes the HtmlBox to use the standard 140-color palette.
Condensed | Causes the HtmlBox to use a condensed 40-color palette, good for low-bandwidth scenarios.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ContentModel Class

For a list of all members of this type, see ContentModel Members.

System.Object
Dart.PowerWEB.TextBox.ContentModel

[Visual Basic]
Public Class ContentModel
[C#]
public class ContentModel
[C++]
public __gc class ContentModel
[JScript]
public class ContentModel

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ContentModel Members | Dart.PowerWEB.TextBox Namespace


ContentModel Members

ContentModel overview

Public Instance Constructors

ContentModel Constructor

Public Instance Fields

CurrentDepth
DeclaredContent
Model

Public Instance Methods

AddConnector |
AddOccurrence |
AddSymbol |
CanContain |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PopGroup |
PushGroup |
SetDeclaredContent |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


ContentModel Constructor

[Visual Basic]
Public Sub New()
[C#]
public ContentModel();
[C++]
public: ContentModel();
[JScript]
public function ContentModel();

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


ContentModel Fields

The fields of the ContentModel class are listed below. For a complete list of ContentModel class members, see the ContentModel Members topic.

Public Instance Fields

CurrentDepth
DeclaredContent
Model

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


CurrentDepth Field

ContentModel.CurrentDepth Field

[Visual Basic]
Public CurrentDepth As Integer
[C#]
public int CurrentDepth;
[C++]
public: int CurrentDepth;
[JScript]
public var CurrentDepth: int;

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


DeclaredContent Field

ContentModel.DeclaredContent Field

[Visual Basic]
Public DeclaredContent As DeclaredContent
[C#]
public DeclaredContent DeclaredContent;
[C++]
public: DeclaredContent DeclaredContent;
[JScript]
public var DeclaredContent: DeclaredContent;

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


Model Field

ContentModel.Model Field

[Visual Basic]
Public Model As Group
[C#]
public Group Model;
[C++]
public: Group* Model;
[JScript]
public var Model: Group;

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


ContentModel Methods

The methods of the ContentModel class are listed below. For a complete list of ContentModel class members, see the ContentModel Members topic.

Public Instance Methods

AddConnector |
AddOccurrence |
AddSymbol |
CanContain |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
PopGroup |
PushGroup |
SetDeclaredContent |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


AddConnector Method

ContentModel.AddConnector Method

[Visual Basic]
Public Sub AddConnector( _
   ByVal c As Char _
)
[C#]
public void AddConnector(
   char c
);
[C++]
public: void AddConnector(
   wchar_t c
);
[JScript]
public function AddConnector(
   char c
);

Parameters

c

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


AddOccurrence Method

ContentModel.AddOccurrence Method

[Visual Basic]
Public Sub AddOccurrence( _
   ByVal c As Char _
)
[C#]
public void AddOccurrence(
   char c
);
[C++]
public: void AddOccurrence(
   wchar_t c
);
[JScript]
public function AddOccurrence(
   char c
);

Parameters

c

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


AddSymbol Method

ContentModel.AddSymbol Method

[Visual Basic]
Public Sub AddSymbol( _
   ByVal sym As String _
)
[C#]
public void AddSymbol(
   string sym
);
[C++]
public: void AddSymbol(
   String* sym
);
[JScript]
public function AddSymbol(
   String sym
);

Parameters

sym

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


CanContain Method

ContentModel.CanContain Method

[Visual Basic]
Public Function CanContain( _
   ByVal name As String, _
   ByVal dtd As SgmlDtd _
) As Boolean
[C#]
public bool CanContain(
   string name,
   SgmlDtd dtd
);
[C++]
public: bool CanContain(
   String* name,
   SgmlDtd* dtd
);
[JScript]
public function CanContain(
   String name,
   SgmlDtd dtd
): bool;

Parameters

name
dtd

Return Value

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


PopGroup Method

ContentModel.PopGroup Method

[Visual Basic]
Public Function PopGroup() As Integer
[C#]
public int PopGroup();
[C++]
public: int PopGroup();
[JScript]
public function PopGroup(): int;

Return Value

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


PushGroup Method

ContentModel.PushGroup Method

[Visual Basic]
Public Sub PushGroup()
[C#]
public void PushGroup();
[C++]
public: void PushGroup();
[JScript]
public function PushGroup();

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


SetDeclaredContent Method

ContentModel.SetDeclaredContent Method

[Visual Basic]
Public Sub SetDeclaredContent( _
   ByVal dc As String _
)
[C#]
public void SetDeclaredContent(
   string dc
);
[C++]
public: void SetDeclaredContent(
   String* dc
);
[JScript]
public function SetDeclaredContent(
   String dc
);

Parameters

dc

See Also

ContentModel Class | Dart.PowerWEB.TextBox Namespace


CursorType Enumeration

Enumerates possible values for the MouseOverCursor, MouseUpCursor, and MouseDownCursor properties of buttons.

[Visual Basic]
Public Enum CursorType
[C#]
public enum CursorType
[C++]
public __value enum CursorType
[JScript]
public enum CursorType

Remarks

This enumeration controls what the mouse cursor looks like while it interacts with buttons. For example, if you would like to display a "crosshair" when the mouse cursor is over a particular button, set the MouseOverCursor property to CursorType.Crosshair.

Members

Member Name | Description
AllScroll | Internet Explorer 6 and later. Arrows pointing up, down, left, and right with a dot in the middle, indicating that the page can be scrolled in any direction.
Auto | Browser determines which cursor to display based on the current context.
ColumnResize | Internet Explorer 6 and later. Arrows pointing left and right with a vertical bar separating them, indicating that the item/column can be resized horizontally.
Crosshair | Simple cross hair.
Default | Platform-dependent default cursor; usually an arrow.
Hand | Hand with the first finger pointing up, as when the user moves the pointer over a link.
Help | Arrow with question mark, indicating help is available.
Move | Crossed arrows, indicating something is to be moved.
NoDrop | Internet Explorer 6 and later. Hand with a small circle with a line through it, indicating that the dragged item cannot be dropped at the current cursor location.
NotAllowed | Internet Explorer 6 and later. Circle with a line through it, indicating that the requested action will not be carried out.
NotSet | No cursor type is specified. The browser will determine the cursor to display.
Pointer | Internet Explorer 6 and later. Hand with the first finger pointing up, as when the user moves the pointer over a link. Identical to hand.
Progress | Internet Explorer 6 and later. Arrow with an hourglass next to it, indicating that a process is running in the background. User interaction with the page is unaffected.
RowResize | Internet Explorer 6 and later. Arrows pointing up and down with a horizontal bar separating them, indicating that the item/row can be resized vertically.
Text | Editable text; usually an I-bar.
VerticalText | Internet Explorer 6 and later. Editable vertical text, indicated by a horizontal I-bar.
Wait | Hourglass or watch, indicating that the program is busy and the user should wait.
NorthResize | Arrows, indicating an edge is to be moved.
NorthEastResize | Arrows, indicating an edge is to be moved.
NorthWestResize | Arrows, indicating an edge is to be moved.
SouthResize | Arrows, indicating an edge is to be moved.
SouthEastResize | Arrows, indicating an edge is to be moved.
SouthWestResize | Arrows, indicating an edge is to be moved.
EastResize | Arrows, indicating an edge is to be moved.
WestResize | Arrows, indicating an edge is to be moved.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


DeclaredContent Enumeration

[Visual Basic]
Public Enum DeclaredContent
[C#]
public enum DeclaredContent
[C++]
public __value enum DeclaredContent
[JScript]
public enum DeclaredContent

Members

Member Name | Description
Default |
CDATA |
RCDATA |
EMPTY |

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


DialogStyle Class

Represents the style used by dialogs.

For a list of all members of this type, see DialogStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.TextBox.BaseStyle
Dart.PowerWEB.TextBox.DialogStyle

[Visual Basic]
Public Class DialogStyle
    Inherits BaseStyle
[C#]
public class DialogStyle : BaseStyle
[C++]
public __gc class DialogStyle : public BaseStyle
[JScript]
public class DialogStyle extends BaseStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The DialogStyle class extends the Style class by providing additional properties for dialog style support such as TitlebarColor.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

DialogStyle Members | Dart.PowerWEB.TextBox Namespace


DialogStyle Members

DialogStyle overview

Public Instance Constructors

DialogStyle Overloaded. Initializes a new instance of the DialogStyle class.

Public Instance Properties

BackColor (inherited from BaseStyle) | Gets or sets the background color of the control.
BorderColor (inherited from BaseStyle) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseStyle) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseStyle) | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from BaseStyle) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font (inherited from BaseStyle) | Gets the font properties associated with the Web server control.
ForeColor (inherited from BaseStyle) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseStyle) | Gets or sets the height of the control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TitlebarBackColor | Gets or sets the background color of the titlebar.
TitlebarFontName | Gets or sets the font name of the text on the titlebar.
TitlebarFontSize | Gets or sets the font size of the text on the titlebar.
TitlebarForeColor | Gets or sets the font color of the text on the titlebar.
Width (inherited from BaseStyle) | Gets or sets the width of the control.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
Clear | Overidden. Sets all style properties to "non-set" equivalents.
CopyFrom | Overidden. Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith | Overidden. Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset | Overidden. Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


DialogStyle Constructor

Creates and initializes a default instance of DialogStyle.

Overload List

Creates and initializes a default instance of DialogStyle.

[Visual Basic] Public Sub New()
[C#] public DialogStyle();
[C++] public: DialogStyle();
[JScript] public function DialogStyle();

Initializes a new instance of the DialogStyle class with the specified state bag information.

[Visual Basic] Public Sub New(ByVal StateBag)
[C#] public DialogStyle(StateBag);
[C++] public: DialogStyle(StateBag*);
[JScript] public function DialogStyle(StateBag);

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


DialogStyle Constructor ()

Creates and initializes a default instance of DialogStyle.

[Visual Basic]
Public Sub New()
[C#]
public DialogStyle();
[C++]
public: DialogStyle();
[JScript]
public function DialogStyle();

Remarks

Use this constructor to create and initialize a new instance of the DialogStyle class.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace | DialogStyle Constructor Overload List


DialogStyle Constructor (StateBag)

Initializes a new instance of the DialogStyle class with the specified state bag information.

[Visual Basic]
Public Sub New( _
   ByVal bag As StateBag _
)
[C#]
public DialogStyle(
   StateBag bag
);
[C++]
public: DialogStyle(
   StateBag* bag
);
[JScript]
public function DialogStyle(
   StateBag bag
);

Parameters

bag
A System.Web.UI.StateBag that represents the state bag in which to store style information.

Remarks

Use this constructor to create an initialize a new instance of the DialogStyle class using the System.Web.UI.StateBag specified by the bag parameter.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace | DialogStyle Constructor Overload List


DialogStyle Properties

The properties of the DialogStyle class are listed below. For a complete list of DialogStyle class members, see the DialogStyle Members topic.

Public Instance Properties

BackColor (inherited from BaseStyle) | Gets or sets the background color of the control.
BorderColor (inherited from BaseStyle) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseStyle) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseStyle) | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from BaseStyle) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font (inherited from BaseStyle) | Gets the font properties associated with the Web server control.
ForeColor (inherited from BaseStyle) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseStyle) | Gets or sets the height of the control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TitlebarBackColor | Gets or sets the background color of the titlebar.
TitlebarFontName | Gets or sets the font name of the text on the titlebar.
TitlebarFontSize | Gets or sets the font size of the text on the titlebar.
TitlebarForeColor | Gets or sets the font color of the text on the titlebar.
Width (inherited from BaseStyle) | Gets or sets the width of the control.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


TitlebarBackColor Property

DialogStyle.TitlebarBackColor Property

Gets or sets the background color of the titlebar.

[Visual Basic]
Overridable Public Property TitlebarBackColor As Color
[C#]
public virtual Color TitlebarBackColor { get; set; }
[C++]
public: virtual __property Color get_TitlebarBackColor();
public: virtual __property void set_TitlebarBackColor(Color );
[JScript]
public virtual function get TitlebarBackColor() : Color
public virtual function set TitlebarBackColor(Color);

Property Value

A System.Drawing.Color value specifying the color of the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


TitlebarFontName Property

DialogStyle.TitlebarFontName Property

Gets or sets the font name of the text on the titlebar.

[Visual Basic]
Overridable Public Property TitlebarFontName As String
[C#]
public virtual string TitlebarFontName { get; set; }
[C++]
public: virtual __property String* get_TitlebarFontName();
public: virtual __property void set_TitlebarFontName(String* );
[JScript]
public virtual function get TitlebarFontName() : String
public virtual function set TitlebarFontName(String);

Property Value

A string value specifying the font name of the text on the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


TitlebarFontSize Property

DialogStyle.TitlebarFontSize Property

Gets or sets the font size of the text on the titlebar.

[Visual Basic]
Overridable Public Property TitlebarFontSize As FontUnit
[C#]
public virtual FontUnit TitlebarFontSize { get; set; }
[C++]
public: virtual __property FontUnit get_TitlebarFontSize();
public: virtual __property void set_TitlebarFontSize(FontUnit );
[JScript]
public virtual function get TitlebarFontSize() : FontUnit
public virtual function set TitlebarFontSize(FontUnit);

Property Value

A FontUnit value specifying the font size of the on the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


TitlebarForeColor Property

DialogStyle.TitlebarForeColor Property

Gets or sets the font color of the text on the titlebar.

[Visual Basic]
Overridable Public Property TitlebarForeColor As Color
[C#]
public virtual Color TitlebarForeColor { get; set; }
[C++]
public: virtual __property Color get_TitlebarForeColor();
public: virtual __property void set_TitlebarForeColor(Color );
[JScript]
public virtual function get TitlebarForeColor() : Color
public virtual function set TitlebarForeColor(Color);

Property Value

A System.Drawing.Color value specifying the font color of the on the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


DialogStyle Methods

The methods of the DialogStyle class are listed below. For a complete list of DialogStyle class members, see the DialogStyle Members topic.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
Clear | Overidden. Sets all style properties to "non-set" equivalents.
CopyFrom | Overidden. Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith | Overidden. Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset | Overidden. Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


Clear Method

DialogStyle.Clear Method

Sets all style properties to "non-set" equivalents.

[Visual Basic]
Overrides Public Sub Clear()
[C#]
public override void Clear();
[C++]
public: void Clear();
[JScript]
public override function Clear();

Remarks

For example, Height is set to 0, BackColor is set to Color.Empty, etc.

This method resets the properties of the style. For example, Style.BackColor will become Color.Empty, Style.BorderStyle will become BorderStyle.NotSet, etc.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


CopyFrom Method

DialogStyle.CopyFrom Method

Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.

[Visual Basic]
Overrides Public Sub CopyFrom( _
   ByVal s As Style _
)
[C#]
public override void CopyFrom(
   Style s
);
[C++]
public: void CopyFrom(
   Style* s
);
[JScript]
public override function CopyFrom(
   Style s
);

Parameters

s
A style type that represents the style to copy.

Remarks

Use the CopyFrom method to duplicate the style properties of the specified Style into the instance of the Style class that this method is called from.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


MergeWith Method

DialogStyle.MergeWith Method

Combines the style properties of the specified Style with the instance of the Style class that this method is called from.

[Visual Basic]
Overrides Public Sub MergeWith( _
   ByVal s As Style _
)
[C#]
public override void MergeWith(
   Style s
);
[C++]
public: void MergeWith(
   Style* s
);
[JScript]
public override function MergeWith(
   Style s
);

Parameters

s
A style type that represents the style to combine.

Remarks

Use the MergeWith method to combine the style properties of the specified Style with the instance of the Style class that this method is called from.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


Reset Method

DialogStyle.Reset Method

Removes any defined style elements from the state bag.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
public: void Reset();
[JScript]
public override function Reset();

Return Value

Use this method to remove any defined style elements from the state bag.

See Also

DialogStyle Class | Dart.PowerWEB.TextBox Namespace


DialogType Enumeration

Enumerates the different types of dialog windows.

[Visual Basic]
Public Enum DialogType
[C#]
public enum DialogType
[C++]
public __value enum DialogType
[JScript]
public enum DialogType

Remarks

This property is used by the HtmlBoxDialog.Type property.

Members

Member Name | Description
InternalWindow | The dialog is a simple panel. This is the type used by the color picker.
InternalWindowWithTitlebar | The dialog is a windows-style dialog. This is used by dialogs such as insert table.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


DownlevelLabel Class

Represents the text displayed to downlevel browsers.

For a list of all members of this type, see DownlevelLabel Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.DownlevelLabel

[Visual Basic]
Public Class DownlevelLabel
    Inherits BaseChildControl
[C#]
public class DownlevelLabel : BaseChildControl
[C++]
public __gc class DownlevelLabel : public BaseChildControl
[JScript]
public class DownlevelLabel extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The label represented by this property is shown to downlevel browsers (browsers that are detected to be incompatible with the editor) if the HtmlBox.DownlevelMode property is DownlevelMode.Label.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

DownlevelLabel Members | Dart.PowerWEB.TextBox Namespace


DownlevelLabel Members

DownlevelLabel overview

Public Instance Constructors

DownlevelLabel Constructor Creates and initializes a default instance of DownlevelLabel.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text content.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

DownlevelLabel Class | Dart.PowerWEB.TextBox Namespace


DownlevelLabel Constructor

Creates and initializes a default instance of DownlevelLabel.

[Visual Basic]
Public Sub New()
[C#]
public DownlevelLabel();
[C++]
public: DownlevelLabel();
[JScript]
public function DownlevelLabel();

Remarks

Use this constructor to create and initialize a new instance of the DownlevelLabel class.

See Also

DownlevelLabel Class | Dart.PowerWEB.TextBox Namespace


DownlevelLabel Properties

The properties of the DownlevelLabel class are listed below. For a complete list of DownlevelLabel class members, see the DownlevelLabel Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text content.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

DownlevelLabel Class | Dart.PowerWEB.TextBox Namespace


Text Property

DownlevelLabel.Text Property

Gets or sets the text content.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

A string representing the text content.

Remarks

If HtmlBox.DownlevelMode is DownlevelMode.Label, set this property to the text you wish these users to see, such as "Please upgrade your browser to see the HtmlBox.

See Also

DownlevelLabel Class | Dart.PowerWEB.TextBox Namespace


DownlevelMode Enumeration

Enumerates what users with incompatible browsers see when they load the editor.

[Visual Basic]
Public Enum DownlevelMode
[C#]
public enum DownlevelMode
[C++]
public __value enum DownlevelMode
[JScript]
public enum DownlevelMode

Members

Member Name | Description
Label | Incompatible browser will see a Label control.
TextArea | Incompatibel browser will see a TextBox control.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


DownlevelTextArea Class

Summary description for DownlevelTextBox.

For a list of all members of this type, see DownlevelTextArea Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.DownlevelTextArea

[Visual Basic]
Public Class DownlevelTextArea
    Inherits BaseChildControl
    Implements IPostBackDataHandler
[C#]
public class DownlevelTextArea : BaseChildControl, IPostBackDataHandler
[C++]
public __gc class DownlevelTextArea : public BaseChildControl, IPostBackDataHandler
[JScript]
public class DownlevelTextArea extends BaseChildControl, IPostBackDataHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

DownlevelTextArea Members | Dart.PowerWEB.TextBox Namespace


DownlevelTextArea Members

DownlevelTextArea overview

Public Instance Constructors

DownlevelTextArea Constructor Creates and initializes a default instance of DownlevelTextArea.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Columns | Gets or sets the display width of the text box in characters.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Rows | Gets or sets the display height of a multiline text box.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text content of the text box.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.
Wrap | Gets or sets a value indicating whether the text content wraps within the text box.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
TextChanged | Occurs when the content of the text box is changed upon server postback.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

DownlevelTextArea Class | Dart.PowerWEB.TextBox Namespace


DownlevelTextArea Constructor

Creates and initializes a default instance of DownlevelTextArea.

[Visual Basic]
Public Sub New()
[C#]
public DownlevelTextArea();
[C++]
public: DownlevelTextArea();
[JScript]
public function DownlevelTextArea();

Remarks

Use this constructor to create and initialize a new instance of the DownlevelTextArea class.

See Also

DownlevelTextArea Class | Dart.PowerWEB.TextBox Namespace


DownlevelTextArea Properties

The properties of the DownlevelTextArea class are listed below. For a complete list of DownlevelTextArea class members, see the DownlevelTextArea Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Columns | Gets or sets the display width of the text box in characters.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Rows | Gets or sets the display height of a multiline text box.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text content of the text box.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.
Wrap | Gets or sets a value indicating whether the text content wraps within the text box.

See Also

DownlevelTextArea Class | Dart.PowerWEB.TextBox Namespace


Columns Property

DownlevelTextArea.Columns Property

Gets or sets the display width of the text box in characters.

[Visual Basic]
Public Property Columns As Integer
[C#]
public int Columns { get; set; }
[C++]
public: __property int get_Columns();
public: __property void set_Columns(int );
[JScript]
public function get Columns() : int
public function set Columns(int);

Property Value

The display width (in characters) of the text box.

See Also

DownlevelTextArea Class | Dart.PowerWEB.TextBox Namespace


Rows Property

DownlevelTextArea.Rows Property

Gets or sets the display height of a multiline text box.

[Visual Basic]
Public Property Rows As Integer
[C#]
public int Rows { get; set; }
[C++]
public: __property int get_Rows();
public: __property void set_Rows(int );
[JScript]
public function get Rows() : int
public function set Rows(int);

Property Value

The display height of a multiline text box.

See Also

DownlevelTextArea Class | Dart.PowerWEB.TextBox Namespace


Text Property

DownlevelTextArea.Text Property

Gets or sets the text content of the text box.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

The text content of the text box. The default is String.Empty.

Remarks

The value of this property is propogated to the HtmlBox.Text property.

See Also

DownlevelTextArea Class | Dart.PowerWEB.TextBox Namespace


Wrap Property

DownlevelTextArea.Wrap Property

Gets or sets a value indicating whether the text content wraps within the text box.

[Visual Basic]
Public Property Wrap As Boolean
[C#]
public bool Wrap { get; set; }
[C++]
public: __property bool get_Wrap();
public: __property void set_Wrap(bool );
[JScript]
public function get Wrap() : bool
public function set Wrap(bool);

Property Value

true if the text content wraps within the text box; otherwise, false. The default is true.

See Also

DownlevelTextArea Class | Dart.PowerWEB.TextBox Namespace


DownlevelTextArea Events

The events of the DownlevelTextArea class are listed below. For a complete list of DownlevelTextArea class members, see the DownlevelTextArea Members topic.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
TextChanged | Occurs when the content of the text box is changed upon server postback.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

DownlevelTextArea Class | Dart.PowerWEB.TextBox Namespace


TextChanged Event

DownlevelTextArea.TextChanged Event

Occurs when the content of the text box is changed upon server postback.

[Visual Basic]
Public Event TextChanged As EventHandler
[C#]
public event EventHandler TextChanged;
[C++]
public: __event EventHandler* TextChanged;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

Note: The control must have viewstate enabled for the TextChanged event to work correctly

See Also

DownlevelTextArea Class | Dart.PowerWEB.TextBox Namespace


ElementDecl Class

For a list of all members of this type, see ElementDecl Members.

System.Object
Dart.PowerWEB.TextBox.ElementDecl

[Visual Basic]
Public Class ElementDecl
[C#]
public class ElementDecl
[C++]
public __gc class ElementDecl
[JScript]
public class ElementDecl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ElementDecl Members | Dart.PowerWEB.TextBox Namespace


ElementDecl Members

ElementDecl overview

Public Instance Constructors

ElementDecl Constructor

Public Instance Fields

AttList
ContentModel
EndTagOptional
Exclusions
Inclusions
Name
StartTagOptional

Public Instance Methods

AddAttDefs |
CanContain |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindAttribute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


ElementDecl Constructor

[Visual Basic]
Public Sub New( _
   ByVal name As String, _
   ByVal sto As Boolean, _
   ByVal eto As Boolean, _
   ByVal cm As ContentModel, _
   ByVal inclusions As String(), _
   ByVal exclusions As String() _
)
[C#]
public ElementDecl(
   string name,
   bool sto,
   bool eto,
   ContentModel cm,
   string[] inclusions,
   string[] exclusions
);
[C++]
public: ElementDecl(
   String* name,
   bool sto,
   bool eto,
   ContentModel* cm,
   String* inclusions __gc[],
   String* exclusions __gc[]
);
[JScript]
public function ElementDecl(
   String name,
   bool sto,
   bool eto,
   ContentModel cm,
   String[] inclusions,
   String[] exclusions
);

Parameters

name
sto
eto
cm
inclusions
exclusions

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


ElementDecl Fields

The fields of the ElementDecl class are listed below. For a complete list of ElementDecl class members, see the ElementDecl Members topic.

Public Instance Fields

AttList
ContentModel
EndTagOptional
Exclusions
Inclusions
Name
StartTagOptional

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


AttList Field

ElementDecl.AttList Field

[Visual Basic]
Public AttList As AttList
[C#]
public AttList AttList;
[C++]
public: AttList* AttList;
[JScript]
public var AttList: AttList;

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


ContentModel Field

ElementDecl.ContentModel Field

[Visual Basic]
Public ContentModel As ContentModel
[C#]
public ContentModel ContentModel;
[C++]
public: ContentModel* ContentModel;
[JScript]
public var ContentModel: ContentModel;

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


EndTagOptional Field

ElementDecl.EndTagOptional Field

[Visual Basic]
Public EndTagOptional As Boolean
[C#]
public bool EndTagOptional;
[C++]
public: bool EndTagOptional;
[JScript]
public var EndTagOptional: bool;

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


Exclusions Field

ElementDecl.Exclusions Field

[Visual Basic]
Public Exclusions As String()
[C#]
public string[] Exclusions;
[C++]
public: String* Exclusions __gc[];
[JScript]
public var Exclusions: String[];

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


Inclusions Field

ElementDecl.Inclusions Field

[Visual Basic]
Public Inclusions As String()
[C#]
public string[] Inclusions;
[C++]
public: String* Inclusions __gc[];
[JScript]
public var Inclusions: String[];

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


Name Field

ElementDecl.Name Field

[Visual Basic]
Public Name As String
[C#]
public string Name;
[C++]
public: String* Name;
[JScript]
public var Name: String;

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


StartTagOptional Field

ElementDecl.StartTagOptional Field

[Visual Basic]
Public StartTagOptional As Boolean
[C#]
public bool StartTagOptional;
[C++]
public: bool StartTagOptional;
[JScript]
public var StartTagOptional: bool;

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


ElementDecl Methods

The methods of the ElementDecl class are listed below. For a complete list of ElementDecl class members, see the ElementDecl Members topic.

Public Instance Methods

AddAttDefs |
CanContain |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindAttribute |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


AddAttDefs Method

ElementDecl.AddAttDefs Method

[Visual Basic]
Public Sub AddAttDefs( _
   ByVal list As AttList _
)
[C#]
public void AddAttDefs(
   AttList list
);
[C++]
public: void AddAttDefs(
   AttList* list
);
[JScript]
public function AddAttDefs(
   AttList list
);

Parameters

list

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


CanContain Method

ElementDecl.CanContain Method

[Visual Basic]
Public Function CanContain( _
   ByVal name As String, _
   ByVal dtd As SgmlDtd _
) As Boolean
[C#]
public bool CanContain(
   string name,
   SgmlDtd dtd
);
[C++]
public: bool CanContain(
   String* name,
   SgmlDtd* dtd
);
[JScript]
public function CanContain(
   String name,
   SgmlDtd dtd
): bool;

Parameters

name
dtd

Return Value

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


FindAttribute Method

ElementDecl.FindAttribute Method

[Visual Basic]
Public Function FindAttribute( _
   ByVal name As String _
) As AttDef
[C#]
public AttDef FindAttribute(
   string name
);
[C++]
public: AttDef* FindAttribute(
   String* name
);
[JScript]
public function FindAttribute(
   String name
): AttDef;

Parameters

name

Return Value

See Also

ElementDecl Class | Dart.PowerWEB.TextBox Namespace


Entity Class

For a list of all members of this type, see Entity Members.

System.Object
Dart.PowerWEB.TextBox.Entity

[Visual Basic]
Public Class Entity
[C#]
public class Entity
[C++]
public __gc class Entity
[JScript]
public class Entity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Entity Members | Dart.PowerWEB.TextBox Namespace


Entity Members

Entity overview

Public Static (Shared) Fields

EOF

Public Static (Shared) Methods

IsLiteralType

Public Instance Constructors

Entity Overloaded. Initializes a new instance of the Entity class.

Public Instance Fields

Html
Internal
IsWhitespace
Lastchar
Line
Literal
LiteralType
Name
Parent
Proxy
PublicId
Uri

Public Instance Properties

LinePosition
ResolvedUri

Public Instance Methods

Close |
Context |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Error | Overloaded.
ExpandCharEntity |
GetEncoding |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Open |
ReadChar |
ScanLiteral |
ScanToEnd |
ScanToken |
SetLiteralType |
SkipWhitespace |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Entity Constructor

Overload List

[Visual Basic] Public Sub New(ByVal String,ByVal String)
[C#] public Entity(string,string);
[C++] public: Entity(String*,String*);
[JScript] public function Entity(String,String);

[Visual Basic] Public Sub New(ByVal String,ByVal String,ByVal String,ByVal String)
[C#] public Entity(string,string,string,string);
[C++] public: Entity(String*,String*,String*,String*);
[JScript] public function Entity(String,String,String,String);

[Visual Basic] Public Sub New(ByVal String,ByVal Uri,ByVal TextReader,ByVal String)
[C#] public Entity(string,Uri,TextReader,string);
[C++] public: Entity(String*,Uri*,TextReader*,String*);
[JScript] public function Entity(String,Uri,TextReader,String);

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Entity Constructor (String, String, String, String)

[Visual Basic]
Public Sub New( _
   ByVal name As String, _
   ByVal pubid As String, _
   ByVal uri As String, _
   ByVal proxy As String _
)
[C#]
public Entity(
   string name,
   string pubid,
   string uri,
   string proxy
);
[C++]
public: Entity(
   String* name,
   String* pubid,
   String* uri,
   String* proxy
);
[JScript]
public function Entity(
   String name,
   String pubid,
   String uri,
   String proxy
);

Parameters

name
pubid
uri
proxy

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace | Entity Constructor Overload List


Entity Constructor (String, String)

[Visual Basic]
Public Sub New( _
   ByVal name As String, _
   ByVal literal As String _
)
[C#]
public Entity(
   string name,
   string literal
);
[C++]
public: Entity(
   String* name,
   String* literal
);
[JScript]
public function Entity(
   String name,
   String literal
);

Parameters

name
literal

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace | Entity Constructor Overload List


Entity Constructor (String, Uri, TextReader, String)

[Visual Basic]
Public Sub New( _
   ByVal name As String, _
   ByVal baseUri As Uri, _
   ByVal stm As TextReader, _
   ByVal proxy As String _
)
[C#]
public Entity(
   string name,
   Uri baseUri,
   TextReader stm,
   string proxy
);
[C++]
public: Entity(
   String* name,
   Uri* baseUri,
   TextReader* stm,
   String* proxy
);
[JScript]
public function Entity(
   String name,
   Uri baseUri,
   TextReader stm,
   String proxy
);

Parameters

name
baseUri
stm
proxy

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace | Entity Constructor Overload List


Entity Fields

The fields of the Entity class are listed below. For a complete list of Entity class members, see the Entity Members topic.

Public Static (Shared) Fields

EOF

Public Instance Fields

Html
Internal
IsWhitespace
Lastchar
Line
Literal
LiteralType
Name
Parent
Proxy
PublicId
Uri

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


EOF Field

Entity.EOF Field

[Visual Basic]
Public const EOF As Char = 
[C#]
public const char EOF = ;
[C++]
public: const wchar_t EOF = ;
[JScript]
public const var EOF: char = ;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Html Field

Entity.Html Field

[Visual Basic]
Public Html As Boolean
[C#]
public bool Html;
[C++]
public: bool Html;
[JScript]
public var Html: bool;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Internal Field

Entity.Internal Field

[Visual Basic]
Public Internal As Boolean
[C#]
public bool Internal;
[C++]
public: bool Internal;
[JScript]
public var Internal: bool;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


IsWhitespace Field

Entity.IsWhitespace Field

[Visual Basic]
Public IsWhitespace As Boolean
[C#]
public bool IsWhitespace;
[C++]
public: bool IsWhitespace;
[JScript]
public var IsWhitespace: bool;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Lastchar Field

Entity.Lastchar Field

[Visual Basic]
Public Lastchar As Char
[C#]
public char Lastchar;
[C++]
public: wchar_t Lastchar;
[JScript]
public var Lastchar: char;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Line Field

Entity.Line Field

[Visual Basic]
Public Line As Integer
[C#]
public int Line;
[C++]
public: int Line;
[JScript]
public var Line: int;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Literal Field

Entity.Literal Field

[Visual Basic]
Public Literal As String
[C#]
public string Literal;
[C++]
public: String* Literal;
[JScript]
public var Literal: String;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


LiteralType Field

Entity.LiteralType Field

[Visual Basic]
Public LiteralType As LiteralType
[C#]
public LiteralType LiteralType;
[C++]
public: LiteralType LiteralType;
[JScript]
public var LiteralType: LiteralType;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Name Field

Entity.Name Field

[Visual Basic]
Public Name As String
[C#]
public string Name;
[C++]
public: String* Name;
[JScript]
public var Name: String;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Parent Field

Entity.Parent Field

[Visual Basic]
Public Parent As Entity
[C#]
public Entity Parent;
[C++]
public: Entity* Parent;
[JScript]
public var Parent: Entity;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Proxy Field

Entity.Proxy Field

[Visual Basic]
Public Proxy As String
[C#]
public string Proxy;
[C++]
public: String* Proxy;
[JScript]
public var Proxy: String;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


PublicId Field

Entity.PublicId Field

[Visual Basic]
Public PublicId As String
[C#]
public string PublicId;
[C++]
public: String* PublicId;
[JScript]
public var PublicId: String;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Uri Field

Entity.Uri Field

[Visual Basic]
Public Uri As String
[C#]
public string Uri;
[C++]
public: String* Uri;
[JScript]
public var Uri: String;

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Entity Properties

The properties of the Entity class are listed below. For a complete list of Entity class members, see the Entity Members topic.

Public Instance Properties

LinePosition
ResolvedUri

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


LinePosition Property

Entity.LinePosition Property

[Visual Basic]
Public Property ReadOnly LinePosition As Integer
[C#]
public int LinePosition { get; }
[C++]
public: __property int get_LinePosition();
[JScript]
public function get LinePosition() : int

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


ResolvedUri Property

Entity.ResolvedUri Property

[Visual Basic]
Public Property ReadOnly ResolvedUri As Uri
[C#]
public Uri ResolvedUri { get; }
[C++]
public: __property Uri* get_ResolvedUri();
[JScript]
public function get ResolvedUri() : Uri

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Entity Methods

The methods of the Entity class are listed below. For a complete list of Entity class members, see the Entity Members topic.

Public Static (Shared) Methods

IsLiteralType

Public Instance Methods

Close |
Context |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Error | Overloaded.
ExpandCharEntity |
GetEncoding |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Open |
ReadChar |
ScanLiteral |
ScanToEnd |
ScanToken |
SetLiteralType |
SkipWhitespace |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Close Method

Entity.Close Method

[Visual Basic]
Public Sub Close()
[C#]
public void Close();
[C++]
public: void Close();
[JScript]
public function Close();

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Context Method

Entity.Context Method

[Visual Basic]
Public Function Context() As String
[C#]
public string Context();
[C++]
public: String* Context();
[JScript]
public function Context(): String;

Return Value

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Error Method

Entity.Error Method

Overload List

[Visual Basic] Public Sub Error(ByVal String)
[C#] public void Error(string);
[C++] public: void Error(String*);
[JScript] public function Error(String);

[Visual Basic] Public Sub Error(ByVal String,ByVal Char)
[C#] public void Error(string,char);
[C++] public: void Error(String*,wchar_t);
[JScript] public function Error(String,char);

[Visual Basic] Public Sub Error(ByVal String,ByVal Integer)
[C#] public void Error(string,int);
[C++] public: void Error(String*,int);
[JScript] public function Error(String,int);

[Visual Basic] Public Sub Error(ByVal String,ByVal String)
[C#] public void Error(string,string);
[C++] public: void Error(String*,String*);
[JScript] public function Error(String,String);

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Error Method (String)

Entity.Error Method (String)

[Visual Basic]
Public Sub Error( _
   ByVal msg As String _
)
[C#]
public void Error(
   string msg
);
[C++]
public: void Error(
   String* msg
);
[JScript]
public function Error(
   String msg
);

Parameters

msg

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace | Entity.Error Overload List


Error Method (String, Char)

Entity.Error Method (String, Char)

[Visual Basic]
Public Sub Error( _
   ByVal msg As String, _
   ByVal ch As Char _
)
[C#]
public void Error(
   string msg,
   char ch
);
[C++]
public: void Error(
   String* msg,
   wchar_t ch
);
[JScript]
public function Error(
   String msg,
   char ch
);

Parameters

msg
ch

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace | Entity.Error Overload List


Error Method (String, Int32)

Entity.Error Method (String, Int32)

[Visual Basic]
Public Sub Error( _
   ByVal msg As String, _
   ByVal x As Integer _
)
[C#]
public void Error(
   string msg,
   int x
);
[C++]
public: void Error(
   String* msg,
   int x
);
[JScript]
public function Error(
   String msg,
   int x
);

Parameters

msg
x

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace | Entity.Error Overload List


Error Method (String, String)

Entity.Error Method (String, String)

[Visual Basic]
Public Sub Error( _
   ByVal msg As String, _
   ByVal arg As String _
)
[C#]
public void Error(
   string msg,
   string arg
);
[C++]
public: void Error(
   String* msg,
   String* arg
);
[JScript]
public function Error(
   String msg,
   String arg
);

Parameters

msg
arg

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace | Entity.Error Overload List


ExpandCharEntity Method

Entity.ExpandCharEntity Method

[Visual Basic]
Public Function ExpandCharEntity() As String
[C#]
public string ExpandCharEntity();
[C++]
public: String* ExpandCharEntity();
[JScript]
public function ExpandCharEntity(): String;

Return Value

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


GetEncoding Method

Entity.GetEncoding Method

[Visual Basic]
Public Function GetEncoding() As Encoding
[C#]
public Encoding GetEncoding();
[C++]
public: Encoding* GetEncoding();
[JScript]
public function GetEncoding(): Encoding;

Return Value

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


IsLiteralType Method

Entity.IsLiteralType Method

[Visual Basic]
Shared Public Function IsLiteralType( _
   ByVal token As String _
) As Boolean
[C#]
public static bool IsLiteralType(
   string token
);
[C++]
public: static bool IsLiteralType(
   String* token
);
[JScript]
public static function IsLiteralType(
   String token
): bool;

Parameters

token

Return Value

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


Open Method

Entity.Open Method

[Visual Basic]
Public Sub Open( _
   ByVal parent As Entity, _
   ByVal baseUri As Uri _
)
[C#]
public void Open(
   Entity parent,
   Uri baseUri
);
[C++]
public: void Open(
   Entity* parent,
   Uri* baseUri
);
[JScript]
public function Open(
   Entity parent,
   Uri baseUri
);

Parameters

parent
baseUri

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


ReadChar Method

Entity.ReadChar Method

[Visual Basic]
Public Function ReadChar() As Char
[C#]
public char ReadChar();
[C++]
public: wchar_t ReadChar();
[JScript]
public function ReadChar(): char;

Return Value

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


ScanLiteral Method

Entity.ScanLiteral Method

[Visual Basic]
Public Function ScanLiteral( _
   ByVal sb As StringBuilder, _
   ByVal quote As Char _
) As String
[C#]
public string ScanLiteral(
   StringBuilder sb,
   char quote
);
[C++]
public: String* ScanLiteral(
   StringBuilder* sb,
   wchar_t quote
);
[JScript]
public function ScanLiteral(
   StringBuilder sb,
   char quote
): String;

Parameters

sb
quote

Return Value

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


ScanToEnd Method

Entity.ScanToEnd Method

[Visual Basic]
Public Function ScanToEnd( _
   ByVal sb As StringBuilder, _
   ByVal type As String, _
   ByVal terminators As String _
) As String
[C#]
public string ScanToEnd(
   StringBuilder sb,
   string type,
   string terminators
);
[C++]
public: String* ScanToEnd(
   StringBuilder* sb,
   String* type,
   String* terminators
);
[JScript]
public function ScanToEnd(
   StringBuilder sb,
   String type,
   String terminators
): String;

Parameters

sb
type
terminators

Return Value

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


ScanToken Method

Entity.ScanToken Method

[Visual Basic]
Public Function ScanToken( _
   ByVal sb As StringBuilder, _
   ByVal term As String, _
   ByVal nmtoken As Boolean _
) As String
[C#]
public string ScanToken(
   StringBuilder sb,
   string term,
   bool nmtoken
);
[C++]
public: String* ScanToken(
   StringBuilder* sb,
   String* term,
   bool nmtoken
);
[JScript]
public function ScanToken(
   StringBuilder sb,
   String term,
   bool nmtoken
): String;

Parameters

sb
term
nmtoken

Return Value

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


SetLiteralType Method

Entity.SetLiteralType Method

[Visual Basic]
Public Sub SetLiteralType( _
   ByVal token As String _
)
[C#]
public void SetLiteralType(
   string token
);
[C++]
public: void SetLiteralType(
   String* token
);
[JScript]
public function SetLiteralType(
   String token
);

Parameters

token

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


SkipWhitespace Method

Entity.SkipWhitespace Method

[Visual Basic]
Public Function SkipWhitespace() As Char
[C#]
public char SkipWhitespace();
[C++]
public: wchar_t SkipWhitespace();
[JScript]
public function SkipWhitespace(): char;

Return Value

See Also

Entity Class | Dart.PowerWEB.TextBox Namespace


FileUploadEventArgs Class

Provides data for the HtmlBox.FileUpload event.

For a list of all members of this type, see FileUploadEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.TextBox.FileUploadEventArgs

[Visual Basic]
Public Class FileUploadEventArgs
    Inherits EventArgs
[C#]
public class FileUploadEventArgs : EventArgs
[C++]
public __gc class FileUploadEventArgs : public EventArgs
[JScript]
public class FileUploadEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

When a HtmlBox.Upload event is raised (after a file upload) a FileUploadEventArgs object will be passed into the event handler.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

FileUploadEventArgs Members | Dart.PowerWEB.TextBox Namespace


FileUploadEventArgs Members

FileUploadEventArgs overview

Public Instance Constructors

FileUploadEventArgs Constructor Creates a new instance of FileUploadEventArgs.

Public Instance Properties

Exception | Gets the exception, if any, that occurred during a file upload.
FilePath | Gets the path of the file as sent by the browser.
SavedFilePath | Gets the path of the file as saved on the server.
UserMessage | Gets or sets the message displayed to the user after a file upload.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileUploadEventArgs Class | Dart.PowerWEB.TextBox Namespace


FileUploadEventArgs Constructor

Creates a new instance of FileUploadEventArgs.

[Visual Basic]
Public Sub New( _
   ByVal filePath As String, _
   ByVal savedFilePath As String, _
   ByVal exception As Exception, _
   ByVal userMessage As String _
)
[C#]
public FileUploadEventArgs(
   string filePath,
   string savedFilePath,
   Exception exception,
   string userMessage
);
[C++]
public: FileUploadEventArgs(
   String* filePath,
   String* savedFilePath,
   Exception* exception,
   String* userMessage
);
[JScript]
public function FileUploadEventArgs(
   String filePath,
   String savedFilePath,
   Exception exception,
   String userMessage
);

Parameters

filePath
Path of the file as sent by the browser.
savedFilePath
Path of the file as saved on the server.
exception
Exceptions that occurred during the file upload.
userMessage
Message to show the user after the upload.

Remarks

A new object of this type is created and passed into the event handler of the HtmlBox.FileUpload event.

See Also

FileUploadEventArgs Class | Dart.PowerWEB.TextBox Namespace


FileUploadEventArgs Properties

The properties of the FileUploadEventArgs class are listed below. For a complete list of FileUploadEventArgs class members, see the FileUploadEventArgs Members topic.

Public Instance Properties

Exception | Gets the exception, if any, that occurred during a file upload.
FilePath | Gets the path of the file as sent by the browser.
SavedFilePath | Gets the path of the file as saved on the server.
UserMessage | Gets or sets the message displayed to the user after a file upload.

See Also

FileUploadEventArgs Class | Dart.PowerWEB.TextBox Namespace


Exception Property

FileUploadEventArgs.Exception Property

Gets the exception, if any, that occurred during a file upload.

[Visual Basic]
Public Property ReadOnly Exception As Exception
[C#]
public Exception Exception { get; }
[C++]
public: __property Exception* get_Exception();
[JScript]
public function get Exception() : Exception

Remarks

Check this property to see if an exception occurred during the file upload.

See Also

FileUploadEventArgs Class | Dart.PowerWEB.TextBox Namespace


FilePath Property

FileUploadEventArgs.FilePath Property

Gets the path of the file as sent by the browser.

[Visual Basic]
Public Property ReadOnly FilePath As String
[C#]
public string FilePath { get; }
[C++]
public: __property String* get_FilePath();
[JScript]
public function get FilePath() : String

Remarks

Check this property to see what the path of the file was on the client.

See Also

FileUploadEventArgs Class | Dart.PowerWEB.TextBox Namespace


SavedFilePath Property

FileUploadEventArgs.SavedFilePath Property

Gets the path of the file as saved on the server.

[Visual Basic]
Public Property ReadOnly SavedFilePath As String
[C#]
public string SavedFilePath { get; }
[C++]
public: __property String* get_SavedFilePath();
[JScript]
public function get SavedFilePath() : String

Remarks

Check this property to see what the path of the file is on the server.

See Also

FileUploadEventArgs Class | Dart.PowerWEB.TextBox Namespace


UserMessage Property

FileUploadEventArgs.UserMessage Property

Gets or sets the message displayed to the user after a file upload.

[Visual Basic]
Public Property UserMessage As String
[C#]
public string UserMessage { get; set; }
[C++]
public: __property String* get_UserMessage();
public: __property void set_UserMessage(String* );
[JScript]
public function get UserMessage() : String
public function set UserMessage(String);

Remarks

Set this property to change the message displayed after an upload. The default message is "file [filename] successfully uploaded".

See Also

FileUploadEventArgs Class | Dart.PowerWEB.TextBox Namespace


FileUploadEventHandler Delegate

Represents a method which will handle the HtmlBox.FileUpload event.

[Visual Basic]
Public Delegate Function Sub  FileUploadEventHandler( _
   ByVal sender As Object, _
   ByVal e As FileUploadEventArgs _
)
[C#]
public delegate void FileUploadEventHandler(
   object sender,
   FileUploadEventArgs e
)
[C++]
public __gc __delegate void FileUploadEventHandler(
   Object* sender,
   FileUploadEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Remarks

When you create a FileUploadEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


Group Class

For a list of all members of this type, see Group Members.

System.Object
Dart.PowerWEB.TextBox.Group

[Visual Basic]
Public Class Group
[C#]
public class Group
[C++]
public __gc class Group
[JScript]
public class Group

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Group Members | Dart.PowerWEB.TextBox Namespace


Group Members

Group overview

Public Instance Constructors

Group Constructor

Public Instance Fields

GroupType
Members
Mixed
Occurrence
Parent

Public Instance Properties

TextOnly

Public Instance Methods

AddConnector |
AddGroup |
AddOccurrence |
AddSymbol |
CanContain |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


Group Constructor

[Visual Basic]
Public Sub New( _
   ByVal parent As Group _
)
[C#]
public Group(
   Group parent
);
[C++]
public: Group(
   Group* parent
);
[JScript]
public function Group(
   Group parent
);

Parameters

parent

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


Group Fields

The fields of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Instance Fields

GroupType
Members
Mixed
Occurrence
Parent

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


GroupType Field

Group.GroupType Field

[Visual Basic]
Public GroupType As GroupType
[C#]
public GroupType GroupType;
[C++]
public: GroupType GroupType;
[JScript]
public var GroupType: GroupType;

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


Members Field

Group.Members Field

[Visual Basic]
Public Members As ArrayList
[C#]
public ArrayList Members;
[C++]
public: ArrayList* Members;
[JScript]
public var Members: ArrayList;

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


Mixed Field

Group.Mixed Field

[Visual Basic]
Public Mixed As Boolean
[C#]
public bool Mixed;
[C++]
public: bool Mixed;
[JScript]
public var Mixed: bool;

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


Occurrence Field

Group.Occurrence Field

[Visual Basic]
Public Occurrence As Occurrence
[C#]
public Occurrence Occurrence;
[C++]
public: Occurrence Occurrence;
[JScript]
public var Occurrence: Occurrence;

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


Parent Field

Group.Parent Field

[Visual Basic]
Public Parent As Group
[C#]
public Group Parent;
[C++]
public: Group* Parent;
[JScript]
public var Parent: Group;

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


Group Properties

The properties of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Instance Properties

TextOnly

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


TextOnly Property

Group.TextOnly Property

[Visual Basic]
Public Property ReadOnly TextOnly As Boolean
[C#]
public bool TextOnly { get; }
[C++]
public: __property bool get_TextOnly();
[JScript]
public function get TextOnly() : bool

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


Group Methods

The methods of the Group class are listed below. For a complete list of Group class members, see the Group Members topic.

Public Instance Methods

AddConnector |
AddGroup |
AddOccurrence |
AddSymbol |
CanContain |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


AddConnector Method

Group.AddConnector Method

[Visual Basic]
Public Sub AddConnector( _
   ByVal c As Char _
)
[C#]
public void AddConnector(
   char c
);
[C++]
public: void AddConnector(
   wchar_t c
);
[JScript]
public function AddConnector(
   char c
);

Parameters

c

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


AddGroup Method

Group.AddGroup Method

[Visual Basic]
Public Sub AddGroup( _
   ByVal g As Group _
)
[C#]
public void AddGroup(
   Group g
);
[C++]
public: void AddGroup(
   Group* g
);
[JScript]
public function AddGroup(
   Group g
);

Parameters

g

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


AddOccurrence Method

Group.AddOccurrence Method

[Visual Basic]
Public Sub AddOccurrence( _
   ByVal c As Char _
)
[C#]
public void AddOccurrence(
   char c
);
[C++]
public: void AddOccurrence(
   wchar_t c
);
[JScript]
public function AddOccurrence(
   char c
);

Parameters

c

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


AddSymbol Method

Group.AddSymbol Method

[Visual Basic]
Public Sub AddSymbol( _
   ByVal sym As String _
)
[C#]
public void AddSymbol(
   string sym
);
[C++]
public: void AddSymbol(
   String* sym
);
[JScript]
public function AddSymbol(
   String sym
);

Parameters

sym

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


CanContain Method

Group.CanContain Method

[Visual Basic]
Public Function CanContain( _
   ByVal name As String, _
   ByVal dtd As SgmlDtd _
) As Boolean
[C#]
public bool CanContain(
   string name,
   SgmlDtd dtd
);
[C++]
public: bool CanContain(
   String* name,
   SgmlDtd* dtd
);
[JScript]
public function CanContain(
   String name,
   SgmlDtd dtd
): bool;

Parameters

name
dtd

Return Value

See Also

Group Class | Dart.PowerWEB.TextBox Namespace


GroupType Enumeration

[Visual Basic]
Public Enum GroupType
[C#]
public enum GroupType
[C++]
public __value enum GroupType
[JScript]
public enum GroupType

Members

Member Name | Description
None |
And |
Or |
Sequence |

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


HighlightStyle Class

Represents the style used by controls that have a highlighted area.

For a list of all members of this type, see HighlightStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.TextBox.BaseStyle
Dart.PowerWEB.TextBox.HighlightStyle

[Visual Basic]
Public Class HighlightStyle
    Inherits BaseStyle
[C#]
public class HighlightStyle : BaseStyle
[C++]
public __gc class HighlightStyle : public BaseStyle
[JScript]
public class HighlightStyle extends BaseStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The HighlightStyle class extends the Style class by providing additional properties for highlight support such as HighlightBackColor.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HighlightStyle Members | Dart.PowerWEB.TextBox Namespace


HighlightStyle Members

HighlightStyle overview

Public Instance Constructors

HighlightStyle Overloaded. Initializes a new instance of the HighlightStyle class.

Public Instance Properties

BackColor (inherited from BaseStyle) | Gets or sets the background color of the control.
BorderColor (inherited from BaseStyle) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseStyle) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseStyle) | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from BaseStyle) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font (inherited from BaseStyle) | Gets the font properties associated with the Web server control.
ForeColor (inherited from BaseStyle) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseStyle) | Gets or sets the height of the control.
HighlightBackColor | Gets or sets the color of the highlighted tab option.
HighlightBorderColor | Gets or sets the border color of the highlighted tab option.
HighlightBorderStyle | Gets or sets the border style of the highlighted tab option.
HighlightForeColor | Gets or sets the text color of the highlighted tab option.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from BaseStyle) | Gets or sets the width of the control.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
Clear | Overidden. Sets all style properties to "non-set" equivalents.
CopyFrom | Overidden. Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith | Overidden. Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset | Overidden. Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


HighlightStyle Constructor

Creates and initializes a default instance of HighlightStyle.

Overload List

Creates and initializes a default instance of HighlightStyle.

[Visual Basic] Public Sub New()
[C#] public HighlightStyle();
[C++] public: HighlightStyle();
[JScript] public function HighlightStyle();

Initializes a new instance of the HighlightStyle class with the specified state bag information.

[Visual Basic] Public Sub New(ByVal StateBag)
[C#] public HighlightStyle(StateBag);
[C++] public: HighlightStyle(StateBag*);
[JScript] public function HighlightStyle(StateBag);

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


HighlightStyle Constructor ()

Creates and initializes a default instance of HighlightStyle.

[Visual Basic]
Public Sub New()
[C#]
public HighlightStyle();
[C++]
public: HighlightStyle();
[JScript]
public function HighlightStyle();

Remarks

Use this constructor to create and initialize a new instance of the HighlightStyle class.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace | HighlightStyle Constructor Overload List


HighlightStyle Constructor (StateBag)

Initializes a new instance of the HighlightStyle class with the specified state bag information.

[Visual Basic]
Public Sub New( _
   ByVal bag As StateBag _
)
[C#]
public HighlightStyle(
   StateBag bag
);
[C++]
public: HighlightStyle(
   StateBag* bag
);
[JScript]
public function HighlightStyle(
   StateBag bag
);

Parameters

bag
A System.Web.UI.StateBag that represents the state bag in which to store style information.

Remarks

Use this constructor to create an initialize a new instance of the HighlightStyle class using the System.Web.UI.StateBag specified by the bag parameter.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace | HighlightStyle Constructor Overload List


HighlightStyle Properties

The properties of the HighlightStyle class are listed below. For a complete list of HighlightStyle class members, see the HighlightStyle Members topic.

Public Instance Properties

BackColor (inherited from BaseStyle) | Gets or sets the background color of the control.
BorderColor (inherited from BaseStyle) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseStyle) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseStyle) | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from BaseStyle) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font (inherited from BaseStyle) | Gets the font properties associated with the Web server control.
ForeColor (inherited from BaseStyle) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseStyle) | Gets or sets the height of the control.
HighlightBackColor | Gets or sets the color of the highlighted tab option.
HighlightBorderColor | Gets or sets the border color of the highlighted tab option.
HighlightBorderStyle | Gets or sets the border style of the highlighted tab option.
HighlightForeColor | Gets or sets the text color of the highlighted tab option.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from BaseStyle) | Gets or sets the width of the control.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


HighlightBackColor Property

HighlightStyle.HighlightBackColor Property

Gets or sets the color of the highlighted tab option.

[Visual Basic]
Overridable Public Property HighlightBackColor As Color
[C#]
public virtual Color HighlightBackColor { get; set; }
[C++]
public: virtual __property Color get_HighlightBackColor();
public: virtual __property void set_HighlightBackColor(Color );
[JScript]
public virtual function get HighlightBackColor() : Color
public virtual function set HighlightBackColor(Color);

Property Value

A System.Drawing.Color value indicating the color of the highlighted tab option.

Remarks

When using the HtmlBoxTabStrip, one of the two tab options is always selected (for instance, when the HtmlBox is initially loaded, the "Design" tab is selected). This property is used to modify the visual appearance of the selected tab.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


HighlightBorderColor Property

HighlightStyle.HighlightBorderColor Property

Gets or sets the border color of the highlighted tab option.

[Visual Basic]
Overridable Public Property HighlightBorderColor As Color
[C#]
public virtual Color HighlightBorderColor { get; set; }
[C++]
public: virtual __property Color get_HighlightBorderColor();
public: virtual __property void set_HighlightBorderColor(Color );
[JScript]
public virtual function get HighlightBorderColor() : Color
public virtual function set HighlightBorderColor(Color);

Property Value

A System.Drawing.Color value indicating the border color of the highlighted tab option.

Remarks

When using the HtmlBoxTabStrip, one of the two tab options is always selected (for instance, when the HtmlBox is initially loaded, the "Design" tab is selected). This property is used to modify the visual appearance of the selected tab.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


HighlightBorderStyle Property

HighlightStyle.HighlightBorderStyle Property

Gets or sets the border style of the highlighted tab option.

[Visual Basic]
Overridable Public Property HighlightBorderStyle As BorderStyle
[C#]
public virtual BorderStyle HighlightBorderStyle { get; set; }
[C++]
public: virtual __property BorderStyle get_HighlightBorderStyle();
public: virtual __property void set_HighlightBorderStyle(BorderStyle );
[JScript]
public virtual function get HighlightBorderStyle() : BorderStyle
public virtual function set HighlightBorderStyle(BorderStyle);

Property Value

A BorderStyle value indicating the border style of the highlighted tab option.

Remarks

When using the HtmlBoxTabStrip, one of the two tab options is always selected (for instance, when the HtmlBox is initially loaded, the "Design" tab is selected). This property is used to modify the visual appearance of the selected tab.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


HighlightForeColor Property

HighlightStyle.HighlightForeColor Property

Gets or sets the text color of the highlighted tab option.

[Visual Basic]
Overridable Public Property HighlightForeColor As Color
[C#]
public virtual Color HighlightForeColor { get; set; }
[C++]
public: virtual __property Color get_HighlightForeColor();
public: virtual __property void set_HighlightForeColor(Color );
[JScript]
public virtual function get HighlightForeColor() : Color
public virtual function set HighlightForeColor(Color);

Property Value

A System.Drawing.Color value indicating the text color of the highlighted tab option.

Remarks

When using the HtmlBoxTabStrip, one of the two tab options is always selected (for instance, when the HtmlBox is initially loaded, the "Design" tab is selected). This property is used to modify the visual appearance of the selected tab.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


HighlightStyle Methods

The methods of the HighlightStyle class are listed below. For a complete list of HighlightStyle class members, see the HighlightStyle Members topic.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
Clear | Overidden. Sets all style properties to "non-set" equivalents.
CopyFrom | Overidden. Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith | Overidden. Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset | Overidden. Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


Clear Method

HighlightStyle.Clear Method

Sets all style properties to "non-set" equivalents.

[Visual Basic]
Overrides Public Sub Clear()
[C#]
public override void Clear();
[C++]
public: void Clear();
[JScript]
public override function Clear();

Remarks

For example, Height is set to 0, BackColor is set to Color.Empty, etc.

This method resets the properties of the style. For example, Style.BackColor will become Color.Empty, Style.BorderStyle will become BorderStyle.NotSet, etc.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


CopyFrom Method

HighlightStyle.CopyFrom Method

Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.

[Visual Basic]
Overrides Public Sub CopyFrom( _
   ByVal s As Style _
)
[C#]
public override void CopyFrom(
   Style s
);
[C++]
public: void CopyFrom(
   Style* s
);
[JScript]
public override function CopyFrom(
   Style s
);

Parameters

s
A style type that represents the style to copy.

Remarks

Use the CopyFrom method to duplicate the style properties of the specified Style into the instance of the Style class that this method is called from.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


MergeWith Method

HighlightStyle.MergeWith Method

Combines the style properties of the specified Style with the instance of the Style class that this method is called from.

[Visual Basic]
Overrides Public Sub MergeWith( _
   ByVal s As Style _
)
[C#]
public override void MergeWith(
   Style s
);
[C++]
public: void MergeWith(
   Style* s
);
[JScript]
public override function MergeWith(
   Style s
);

Parameters

s
A style type that represents the style to combine.

Remarks

Use the MergeWith method to combine the style properties of the specified Style with the instance of the Style class that this method is called from.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


Reset Method

HighlightStyle.Reset Method

Removes any defined style elements from the state bag.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
public: void Reset();
[JScript]
public override function Reset();

Return Value

Use this method to remove any defined style elements from the state bag.

See Also

HighlightStyle Class | Dart.PowerWEB.TextBox Namespace


HtmlBox Class

Replaces the TextBox control to provide advanced HTML editing within a browser.

For a list of all members of this type, see HtmlBox Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
System.Web.UI.WebControls.Label
Dart.PowerWEB.LiveControls.LiveLabel
Dart.PowerWEB.TextBox.HtmlBox

[Visual Basic]
Public Class HtmlBox
    Inherits LiveLabel
    Implements IPostBackDataHandler, INamingContainer
[C#]
public class HtmlBox : LiveLabel, IPostBackDataHandler, INamingContainer
[C++]
public __gc class HtmlBox : public LiveLabel, IPostBackDataHandler, INamingContainer
[JScript]
public class HtmlBox extends LiveLabel, IPostBackDataHandler, INamingContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Use the HtmlBox control included with PowerWEB TextBox for .NET to replace the TextBox control within your web application to provide advanced HTML editing. The HtmlBox control uses the MS DHTML engine to enable WYSIWYG-style editing within a browser. The HtmlBox control renders an IFRAME, associated tables to provide an "editor" interface, and the necessary JavaScript to perform the editing actions.

For introductory steps and tutorials on using the HtmlBox in a web application, see either of the topics Using PowerWEB in VS.NET or Using PowerWEB in WebMatrix.

Basic Configuration

Once a project is created, the HtmlBox is provided with default display settings (for more information, see the HtmlBox constructor topic). This default configuration can be modified one of two ways:

  • Using the Properties Builder. Open the properties builder by right-clicking the HtmlBox in the designer and choosing "Properties". This opens a configuration application which can be used to customize the look and configuration of the HtmlBox.
  • Using Code. Within code (such as in your code-behind page) the editor can easily be configured by setting properties and calling methods. For example, easily create a toolbar configuration by using the HtmlBox.Clear method to clear the existing configuration and the HtmlBox.AddToolbarItem to quickly add new items to the toolbar. Look and feel of the editor can be easily customized as well. For example, to set the styles of all buttons, set the properties of the HtmlBox.ButtonStyles object.

For more information about configuration, see the topic Configuring the Editor.

Advanced Customization

The HtmlBox allows highly advanced customization, enabling a developer to create complex client-side objects such as custom windows-style dfialog boxes with only a few lines of code. For more information about this see the topic Advanced Customization.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlBox Members | Dart.PowerWEB.TextBox Namespace


HtmlBox Members

HtmlBox overview

Public Instance Constructors

HtmlBox Overloaded. Initializes a new instance of the HtmlBox class.

Public Instance Properties

AccessKey (inherited from LiveLabel) |
AssociatedControlID (inherited from Label) |
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
AutoSaveFrequency | Gets or sets a value which indicates the number of keystrokes between AutoSave events.
AutoSaveInterval | Gets or sets a value which indicates the number of seconds between AutoSave events.
BackColor | Overidden. Gets or sets the background color of the control.
BackgroundImageName | Gets or sets the name of the background image to display as the background of the HtmlBox.
BasePath | Gets or sets the base path value for url conversions.
BindingContainer (inherited from Control) |
Blocking (inherited from LiveLabel) |
BorderColor | Overidden. Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth | Overidden. Gets or sets the border width of the control
BottomMargin | Gets or sets the amount of space (in pixels) between the bottom edge of the editor and the TabStrip.
BrowserType (inherited from LiveLabel) |
BufferedScript (inherited from LiveLabel) |
ButtonMode | Gets or sets ButtonMode value specifying the current mode of the toolbar buttons.
ButtonStyle | Gets a ButtonStyle object representing the style that will be applied to all classes derived from BaseToolbarButton on the toolbar.
CallbackType (inherited from LiveLabel) |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ColorPaletteType | Gets or sets a ColorPaletteType value representing the color palette that the user can select from when editing HTML.
CompatibleBrowser | Gets a value indicating if the browser was detected to be compatible with the HtmlBox.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DataPersistenceType (inherited from LiveLabel) | Obsolete.
Debug (inherited from LiveLabel) |
DesignerFont |
DesignerToolbar |
DetectedBrowserType | Gets the automatically detected browser type, sets a value to override the automatically detected value if required.
DialogStyle | Gets or sets a DialogStyle object representing the style that will be applied to all HtmlBoxDialog controls used by the HtmlBox.
DownlevelLabel | Represents the label rendered to the user if the HtmlBox.DownlevelMode = DownlevelMode.Label.
DownlevelMode | Controls whether the user sees a Label or a TextArea if their browser is incompatible with the HtmlBox.
DownlevelTextArea | Represents the textarea control rendered to the user if the HtmlBox.DownlevelMode = DownlevelMode.TextArea.
DropDownStyle | Gets a Style object representing the style that will be applied to all ToolbarDropDown controls used by the HtmlBox.
EnableCallback (inherited from LiveLabel) |
Enabled | Overidden. Gets or sets a value indicating whether the HtmlBox control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ErrorBehavior (inherited from LiveLabel) |
ErrorMessage (inherited from LiveLabel) |
Focus | Controls whether or not the HtmlBox receives the mouse focus when the page is loaded.
Font (inherited from LiveLabel) |
FontEx (inherited from LiveLabel) | Obsolete.
FontFormattingList | High-level "helper" collection which provides font formatting values to applicable ToolbarDropDown controls.
FontNameList | High-level "helper" collection which provides font name values to applicable ToolbarDropDown controls.
FontSizeList | High-level "helper" collection which provides font size values to applicable ToolbarDropDown controls.
FontStyleList | High-level "helper" collection which provides font style values to applicable ToolbarDropDown controls.
ForeColor | Overidden. Gets or sets the foreground color (typically the color of the text) of the control.
Height | Overidden. Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
ImagesDirectory | Gets or sets a virtual, relative, or absolute pathname of the directory containing all of the images used by the HtmlBox.
IsCallback (inherited from LiveLabel) |
IsLive (inherited from LiveLabel) |
IsPostbackFromUpload | Gets a value specifying if the current page request was due to a postback from an HtmlBoxUpload control.
LayoutType | Gets or sets the current LayoutType of the HtmlBox.
Left (inherited from LiveLabel) |
LocalizationFile | Gets or sets a value specifying a file path to an XML file specifying localization strings.
LocalizationType | Gets or sets a value which determines in what language strings are displayed
MenuStyle | Gets a MenuStyle object representing the style that will be applied to all HtmlBoxMenu controls used by the HtmlBox.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PlaceholderFilename | Gets or sets a virtual, relative, or absolute pathname of the directory containing all of the images used by the HtmlBox.
ProgressBar | Gets the HtmlBoxProgressBar representing the progressbar used for the HtmlBox preload, if it is enabled.
ReadOnly | Gets or sets a value which indicates whether the HtmlBox should be an active HTML editor, or a read-only document viewer.
RightClickBehavior | Gets or sets a value which indicates how the HtmlBox should behave when it is right-clicked with the mouse.
RightClickMenu | Gets an HtmlBoxMenu control representing the right-click menu displayed when the user right-clicks on the HtmlBox with the mouse.
SecureConnection | Gets or sets a value which indicates if the HtmlBox is being requested by a secure connection.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
SpecialCharacterList | High-level "helper" collection which provides special character values to applicable ToolbarDialogButton controls.
StartupMode | Gets or sets a StartupMode value indicating the startup mode of the HtmlBox.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from LiveLabel) |
TabStrip | Gets a HtmlBoxTabStrip object representing the tabstrip used by the HtmlBox.
Tag (inherited from LiveLabel) |
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text displayed in the editor.
TextPlain | Gets the value of the HtmlBox.Text property stripped of any HTML tags.
TextWindow | Gets an HtmlBoxTextWindow control representing the actual editing window of the HtmlBox.
TextXhtml | Gets the value of the HtmlBox.Text property converted to XHTML.
Toolbar | Gets an HtmlBoxToolbar control representing the toolbar.
ToolTip (inherited from LiveLabel) |
Top (inherited from LiveLabel) |
TopMargin | Gets or sets the amount of space (in pixels) between the top edge of the editor and the toolbar.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll (inherited from LiveLabel) |
UploadedFilesDirectory | Gets or sets a virtual, relative, or absolute pathname of the directory where all files are uploaded.
UrlType | Gets or sets a value which determines how links are represented in the editor.
UseLineBreak | Gets or sets a value which determines how enter key presses behave.
UseSection508Compliance | Gets or sets whether the HtmlBox should be rendered in Section 508 compliant mode.
Visible | Overidden. Gets or sets a value that indicates whether a server control is rendered as UI on the page.
WaitElementID (inherited from LiveLabel) |
WaitMessage (inherited from LiveLabel) |
Width | Overidden. Gets or sets the width of the control.

Public Instance Methods

AddToolbarItem | High-level "shortcut" method to quickly create, initialize, and add an item to the toolbar.
ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clear | Clears the HtmlBox.
ClearStyles | Clears the HtmlBox.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference (inherited from LiveLabel) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript (inherited from LiveLabel) |
GetScriptObjectReference (inherited from LiveLabel) |
GetScriptStyleReference (inherited from LiveLabel) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState (inherited from LiveLabel) |
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadSkin | Load a predefined skin XML file.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag | Overidden. Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag | Overidden. Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
Reset | Returns the HtmlBox control to it's inital state.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SaveSkin | Overloaded. Save the current HtmlBox configuration as an XML skin file.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

AutoSave | Raised after a specified interval or keystroke count.
ContextMenuChanged (inherited from LiveLabel) |
DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
DoubleClick (inherited from LiveLabel) |
FileUpload | Raised after an attempted file upload.
GotFocus (inherited from LiveLabel) |
HelpRequested (inherited from LiveLabel) |
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
KeyDown (inherited from LiveLabel) |
KeyPress (inherited from LiveLabel) |
KeyUp (inherited from LiveLabel) |
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
LocationClick (inherited from LiveLabel) |
LostFocus (inherited from LiveLabel) |
MouseDown (inherited from LiveLabel) |
MouseEnter (inherited from LiveLabel) |
MouseLeave (inherited from LiveLabel) |
MouseUp (inherited from LiveLabel) |
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
TextChanged | Occurs when the content of the HtmlBox is changed upon server postback.
ToolbarButtonClick | Raised when a postback is raised by a toolbar button click.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


HtmlBox Constructor

Initializes a new instance of the HtmlBox control.

Overload List

Initializes a new instance of the HtmlBox control.

[Visual Basic] Public Sub New()
[C#] public HtmlBox();
[C++] public: HtmlBox();
[JScript] public function HtmlBox();

This constructor is used primarily by control developers.

[Visual Basic] Public Sub New(ByVal String)
[C#] public HtmlBox(string);
[C++] public: HtmlBox(String*);
[JScript] public function HtmlBox(String);

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


HtmlBox Constructor ()

Initializes a new instance of the HtmlBox control.

[Visual Basic]
Public Sub New()
[C#]
public HtmlBox();
[C++]
public: HtmlBox();
[JScript]
public function HtmlBox();

Remarks

The default constuctor creates and initializes the HtmlBox with default settings. These settings are as follows:

Element | Default Value
HtmlBox.Toolbar Layout The default toolbar layout includes the following toolbar items:
  • Double separator graphic
  • Bold button
  • Italic button
  • Underline button
  • Separator graphic
  • Cut button
  • Copy button
  • Paste button
  • Separator graphic
  • Undo
  • Redo
  • Separator graphic
  • Left justify button
  • Center justify button
  • Right justify button
  • Separator graphic
  • Unordered list button
  • Ordered list button
  • Separator graphic
  • Font color button
  • Font highlight button
  • Insert special character button
  • Row separator graphic
  • Font name drop down box
  • Font size drop down box
  • Font formatting drop down box
HtmlBox.ControlStyle The default HtmlBox style is as follows:
  • ForeColor = "#000000"
  • BackColor = "#ECE9D8"
  • BorderColor = "#909090"
  • Width = 600
  • Height = 300
  • BorderWidth = 1
  • BorderStyle = Solid
  • Font.Name = "sans-serif"
  • Font.Size = "9pt"
HtmlBox.ButtonStyle The default HtmlBox button styles are as follows:
  • BorderColor = "#ECE9D8"
  • BorderWidth = 1
  • BorderStyle = Solid
  • MouseDownBackColor = "#98B5E2"
  • MouseDownBorderColor = "#316AC5"
  • MouseDownBorderStyle = Solid
  • MouseOverBackColor = "#C1D2EE"
  • MouseOverBorderColor = "#316AC5"
  • MouseOverBorderStyle = Solid
  • MouseUpBackColor = "#C1D2EE"
  • MouseUpBorderColor = "#316AC5"
  • MouseUpBorderStyle = Solid
HtmlBox.DialogStyle The default HtmlBox dialog styles are as follows:
  • BackColor = "#ECE9D8"
  • BorderColor = "#000000"
  • BorderWidth = 1
  • BorderStyle = Solid
  • Font.Name = "sans-serif"
  • Font.Size = "8pt"
  • ForeColor = "#000000"
  • TitlebarBackColor = "#0055E5"
  • TitlebarForeColor = "#FFFFFF"
  • TitlebarFontSize = "8pt"
HtmlBox.DropDownStyle The default HtmlBox dropdown styles are as follows:
  • BackColor = "#FFFFFF"
  • BorderColor = "#7F9DB9"
  • BorderWidth = 1
  • BorderStyle = Solid
  • Font.Names = "arial", "verdana", "helvetica", "sans-serif"
  • Font.Size = "11pt"
HtmlBox.MenuStyle The default HtmlBox menu styles are as follows:
  • BackColor = "#FFFFFF"
  • BorderColor = "#8E8E8E"
  • BorderWidth = 1
  • BorderStyle = Solid
  • Font.Name = "sans-serif"
  • Font.Size = "8pt"
  • Height = Unit.Empty
  • ImageColumnColor = "#EFEDDE"
  • MouseOverColor = "#C1d2EE"
HtmlBox.SpecialCharacterList | "&copy;","&reg;","&#153;","&#151;","&#133;","&#209","&aacute;","&yen;","&euro;","&pound;","&#147;","&#148;","&#149;","&para;","&eacute;","&uacute;"
HtmlBox.FontNameList | "Arial", "Verdana", "Tahoma", "Courier New", "Georgia"
HtmlBox.FontSizeList | "1","2","3","4","5","6","7"
HtmlBox.FontFormattingList
  • "Heading 1", "<h1>"
  • "Heading 2", "<h2>"
  • "Heading 3", "<h3>"
  • "Heading 4", "<h4>"
  • "Heading 5", "<h5>"
  • "Pre", "<pre>"
  • "Code", "<code>"

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace | HtmlBox Constructor Overload List


HtmlBox Constructor (String)

This constructor is used primarily by control developers.

[Visual Basic]
Public Sub New( _
   ByVal oemLK As String _
)
[C#]
public HtmlBox(
   string oemLK
);
[C++]
public: HtmlBox(
   String* oemLK
);
[JScript]
public function HtmlBox(
   String oemLK
);

Remarks

This constructor is used primarily by control developers.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace | HtmlBox Constructor Overload List


HtmlBox Properties

The properties of the HtmlBox class are listed below. For a complete list of HtmlBox class members, see the HtmlBox Members topic.

Public Instance Properties

AccessKey (inherited from LiveLabel) |
AssociatedControlID (inherited from Label) |
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
AutoSaveFrequency | Gets or sets a value which indicates the number of keystrokes between AutoSave events.
AutoSaveInterval | Gets or sets a value which indicates the number of seconds between AutoSave events.
BackColor | Overidden. Gets or sets the background color of the control.
BackgroundImageName | Gets or sets the name of the background image to display as the background of the HtmlBox.
BasePath | Gets or sets the base path value for url conversions.
BindingContainer (inherited from Control) |
Blocking (inherited from LiveLabel) |
BorderColor | Overidden. Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth | Overidden. Gets or sets the border width of the control
BottomMargin | Gets or sets the amount of space (in pixels) between the bottom edge of the editor and the TabStrip.
BrowserType (inherited from LiveLabel) |
BufferedScript (inherited from LiveLabel) |
ButtonMode | Gets or sets ButtonMode value specifying the current mode of the toolbar buttons.
ButtonStyle | Gets a ButtonStyle object representing the style that will be applied to all classes derived from BaseToolbarButton on the toolbar.
CallbackType (inherited from LiveLabel) |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ColorPaletteType | Gets or sets a ColorPaletteType value representing the color palette that the user can select from when editing HTML.
CompatibleBrowser | Gets a value indicating if the browser was detected to be compatible with the HtmlBox.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DataPersistenceType (inherited from LiveLabel) | Obsolete.
Debug (inherited from LiveLabel) |
DesignerFont |
DesignerToolbar |
DetectedBrowserType | Gets the automatically detected browser type, sets a value to override the automatically detected value if required.
DialogStyle | Gets or sets a DialogStyle object representing the style that will be applied to all HtmlBoxDialog controls used by the HtmlBox.
DownlevelLabel | Represents the label rendered to the user if the HtmlBox.DownlevelMode = DownlevelMode.Label.
DownlevelMode | Controls whether the user sees a Label or a TextArea if their browser is incompatible with the HtmlBox.
DownlevelTextArea | Represents the textarea control rendered to the user if the HtmlBox.DownlevelMode = DownlevelMode.TextArea.
DropDownStyle | Gets a Style object representing the style that will be applied to all ToolbarDropDown controls used by the HtmlBox.
EnableCallback (inherited from LiveLabel) |
Enabled | Overidden. Gets or sets a value indicating whether the HtmlBox control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ErrorBehavior (inherited from LiveLabel) |
ErrorMessage (inherited from LiveLabel) |
Focus | Controls whether or not the HtmlBox receives the mouse focus when the page is loaded.
Font (inherited from LiveLabel) |
FontEx (inherited from LiveLabel) | Obsolete.
FontFormattingList | High-level "helper" collection which provides font formatting values to applicable ToolbarDropDown controls.
FontNameList | High-level "helper" collection which provides font name values to applicable ToolbarDropDown controls.
FontSizeList | High-level "helper" collection which provides font size values to applicable ToolbarDropDown controls.
FontStyleList | High-level "helper" collection which provides font style values to applicable ToolbarDropDown controls.
ForeColor | Overidden. Gets or sets the foreground color (typically the color of the text) of the control.
Height | Overidden. Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
ImagesDirectory | Gets or sets a virtual, relative, or absolute pathname of the directory containing all of the images used by the HtmlBox.
IsCallback (inherited from LiveLabel) |
IsLive (inherited from LiveLabel) |
IsPostbackFromUpload | Gets a value specifying if the current page request was due to a postback from an HtmlBoxUpload control.
LayoutType | Gets or sets the current LayoutType of the HtmlBox.
Left (inherited from LiveLabel) |
LocalizationFile | Gets or sets a value specifying a file path to an XML file specifying localization strings.
LocalizationType | Gets or sets a value which determines in what language strings are displayed
MenuStyle | Gets a MenuStyle object representing the style that will be applied to all HtmlBoxMenu controls used by the HtmlBox.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PlaceholderFilename | Gets or sets a virtual, relative, or absolute pathname of the directory containing all of the images used by the HtmlBox.
ProgressBar | Gets the HtmlBoxProgressBar representing the progressbar used for the HtmlBox preload, if it is enabled.
ReadOnly | Gets or sets a value which indicates whether the HtmlBox should be an active HTML editor, or a read-only document viewer.
RightClickBehavior | Gets or sets a value which indicates how the HtmlBox should behave when it is right-clicked with the mouse.
RightClickMenu | Gets an HtmlBoxMenu control representing the right-click menu displayed when the user right-clicks on the HtmlBox with the mouse.
SecureConnection | Gets or sets a value which indicates if the HtmlBox is being requested by a secure connection.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
SpecialCharacterList | High-level "helper" collection which provides special character values to applicable ToolbarDialogButton controls.
StartupMode | Gets or sets a StartupMode value indicating the startup mode of the HtmlBox.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from LiveLabel) |
TabStrip | Gets a HtmlBoxTabStrip object representing the tabstrip used by the HtmlBox.
Tag (inherited from LiveLabel) |
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text displayed in the editor.
TextPlain | Gets the value of the HtmlBox.Text property stripped of any HTML tags.
TextWindow | Gets an HtmlBoxTextWindow control representing the actual editing window of the HtmlBox.
TextXhtml | Gets the value of the HtmlBox.Text property converted to XHTML.
Toolbar | Gets an HtmlBoxToolbar control representing the toolbar.
ToolTip (inherited from LiveLabel) |
Top (inherited from LiveLabel) |
TopMargin | Gets or sets the amount of space (in pixels) between the top edge of the editor and the toolbar.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll (inherited from LiveLabel) |
UploadedFilesDirectory | Gets or sets a virtual, relative, or absolute pathname of the directory where all files are uploaded.
UrlType | Gets or sets a value which determines how links are represented in the editor.
UseLineBreak | Gets or sets a value which determines how enter key presses behave.
UseSection508Compliance | Gets or sets whether the HtmlBox should be rendered in Section 508 compliant mode.
Visible | Overidden. Gets or sets a value that indicates whether a server control is rendered as UI on the page.
WaitElementID (inherited from LiveLabel) |
WaitMessage (inherited from LiveLabel) |
Width | Overidden. Gets or sets the width of the control.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


AutoSaveFrequency Property

HtmlBox.AutoSaveFrequency Property

Gets or sets a value which indicates the number of keystrokes between AutoSave events.

[Visual Basic]
Public Property AutoSaveFrequency As Integer
[C#]
public int AutoSaveFrequency { get; set; }
[C++]
public: __property int get_AutoSaveFrequency();
public: __property void set_AutoSaveFrequency(int );
[JScript]
public function get AutoSaveFrequency() : int
public function set AutoSaveFrequency(int);

Remarks

Gets or sets a value which indicates the number of keystrokes between AutoSave events.

See also AutoSaveInterval.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


AutoSaveInterval Property

HtmlBox.AutoSaveInterval Property

Gets or sets a value which indicates the number of seconds between AutoSave events.

[Visual Basic]
Public Property AutoSaveInterval As Integer
[C#]
public int AutoSaveInterval { get; set; }
[C++]
public: __property int get_AutoSaveInterval();
public: __property void set_AutoSaveInterval(int );
[JScript]
public function get AutoSaveInterval() : int
public function set AutoSaveInterval(int);

Remarks

Gets or sets a value which indicates the number of seconds between AutoSave events.

See also AutoSaveFrequency.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


BackColor Property

HtmlBox.BackColor Property

Gets or sets the background color of the control.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override Color BackColor { get; set; }
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(Color );
[JScript]
public override function get BackColor() : Color
public override function set BackColor(Color);

Property Value

A System.Drawing.Color that represents the background color of the control. The default is Color.Empty, which indicates that this property is not set.

Remarks

Use the BackColor property to specify the background color of the control. This property is set using a System.Drawing.Color object.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


BackgroundImageName Property

HtmlBox.BackgroundImageName Property

Gets or sets the name of the background image to display as the background of the HtmlBox.

[Visual Basic]
Public Property BackgroundImageName As String
[C#]
public string BackgroundImageName { get; set; }
[C++]
public: __property String* get_BackgroundImageName();
public: __property void set_BackgroundImageName(String* );
[JScript]
public function get BackgroundImageName() : String
public function set BackgroundImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

This property is only indended to be used if you are applying a highly graphical skin to the HtmlBox. Typically, when using this property you would also set HtmlBox.LayoutType to LayoutType.Skin, which configures the HtmlBox to the optimal configuration for graphical skins. For more information about skin creation and usage, see the topic Using Skins.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


BasePath Property

HtmlBox.BasePath Property

Gets or sets the base path value for url conversions.

[Visual Basic]
Public Property BasePath As String
[C#]
public string BasePath { get; set; }
[C++]
public: __property String* get_BasePath();
public: __property void set_BasePath(String* );
[JScript]
public function get BasePath() : String
public function set BasePath(String);

Property Value

A string value representing the base path value for url conversions.

Remarks

If editing web pages, set this property to the url of the eventual destination of the page.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


BorderColor Property

HtmlBox.BorderColor Property

Gets or sets the border color of the control.

[Visual Basic]
Overrides Public Property BorderColor As Color
[C#]
public override Color BorderColor { get; set; }
[C++]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(Color );
[JScript]
public override function get BorderColor() : Color
public override function set BorderColor(Color);

Property Value

A System.Drawing.Color that represents the border color of the control. The default is Color.Empty, which indicates that this property is not set.

Remarks

Use the BorderColor property to specify the border color of the control. This property is set using a System.Drawing.Color object.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


BorderStyle Property

HtmlBox.BorderStyle Property

Gets or sets the border style of the control.

[Visual Basic]
Overrides Public Property BorderStyle As BorderStyle
[C#]
public override BorderStyle BorderStyle { get; set; }
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle );
[JScript]
public override function get BorderStyle() : BorderStyle
public override function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration values. The default is NotSet.

Remarks

Use the BorderStyle property to specify the border style for the control. This property is set using one of the BorderStyle enumeration values.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


BorderWidth Property

HtmlBox.BorderWidth Property

Gets or sets the border width of the control

[Visual Basic]
Overrides Public Property BorderWidth As Unit
[C#]
public override Unit BorderWidth { get; set; }
[C++]
public: __property Unit get_BorderWidth();
public: __property void set_BorderWidth(Unit );
[JScript]
public override function get BorderWidth() : Unit
public override function set BorderWidth(Unit);

Property Value

A Unit that represents the border width of the control. The default value is Unit.Empty, which indicates that this property is not set.

Remarks

Use the BorderWidth property to specify a border width for a control

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


BottomMargin Property

HtmlBox.BottomMargin Property

Gets or sets the amount of space (in pixels) between the bottom edge of the editor and the TabStrip.

[Visual Basic]
Public Property BottomMargin As Integer
[C#]
public int BottomMargin { get; set; }
[C++]
public: __property int get_BottomMargin();
public: __property void set_BottomMargin(int );
[JScript]
public function get BottomMargin() : int
public function set BottomMargin(int);

Property Value

An integer specifying the amount of space (in pixels) between the bottom edge of the editor and the TabStrip. The default value is 0.

Remarks

This property is primarily used when applying a graphical skin to the HtmlBox. For more information about skin creation and usage, see the topic Using Skins. For standard implementations, this property does not typically need to be set (although it may be).

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


ButtonMode Property

HtmlBox.ButtonMode Property

Gets or sets ButtonMode value specifying the current mode of the toolbar buttons.

[Visual Basic]
Public Property ButtonMode As ButtonMode
[C#]
public ButtonMode ButtonMode { get; set; }
[C++]
public: __property ButtonMode get_ButtonMode();
public: __property void set_ButtonMode(ButtonMode );
[JScript]
public function get ButtonMode() : ButtonMode
public function set ButtonMode(ButtonMode);

Property Value

A ButtonMode value specifying the current mode of the toolbar buttons. The default value is ButtonMode.Image.

Remarks

By default this property is ButtonMode.Image, which specifies that a single image will represent each button and mouse-effects will be applied using DHTML (see the HtmlBox.ButtonStyle property for more information on this). If you would like to use such highly-graphical button representations such as mouse-over image swaps set this property to either ButtonMode.TwoStateImage (which specifies that there will be two images for each button, an "off" image and a "clicked" image) or ButtonMode.ThreeStateImage (which specifies that there will be three images for each button, an "off", an "over", and a "click" image). One of these two types will typically be used in skin implementations (see Using Skins) for more information. If you would like to remove images from the toolbar buttons altogether, set this property to ButtonMode.HTML and HTML input buttons will be used to represent the toolbar buttons.

Some image-name related properties will not have meaning depending on the button mode. For example:

ButtonMode.HTML

  • ImageName property - not used
  • MouseDownImageName property - not used
  • MouseOverImageName property - not used

ButtonMode.Image

  • ImageName property - represents the image used for the button (ex. "bold.gif")
  • MouseDownImageName property - not used
  • MouseOverImageName property - not used

ButtonMode.TwoStateImage

  • ImageName property - represents the image used for the button (ex. "bold.gif")
  • MouseDownImageName property - represents the image used for the button when it is clicked (ex. "bold_down.gif")
  • MouseOverImageName property - not used

ButtonMode.TwoStateImage

  • ImageName property - represents the image used for the button (ex. "bold.gif")
  • MouseDownImageName property - represents the image used for the button when it is clicked (ex. "bold_down.gif")
  • MouseOverImageName property - represents the image used for the button when the mouse is over the button (ex. "bold_over.gif")

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


ButtonStyle Property

HtmlBox.ButtonStyle Property

Gets a ButtonStyle object representing the style that will be applied to all classes derived from BaseToolbarButton on the toolbar.

[Visual Basic]
Public Property ButtonStyle As ButtonStyle
[C#]
public ButtonStyle ButtonStyle { get; set; }
[C++]
public: __property ButtonStyle* get_ButtonStyle();
public: __property void set_ButtonStyle(ButtonStyle* );
[JScript]
public function get ButtonStyle() : ButtonStyle
public function set ButtonStyle(ButtonStyle);

Property Value

A ButtonStyle object representing the styles of all buttons.

Remarks

Use this object to globally apply styles to all buttons at once. For example, setting ButtonStyle.BackColor to Color.Red will cause all of the buttons to have a red background.

If HtmlBox.ButtonMode is ButtonMode.Image (the default), the HtmlBox.ButtonStyle property can be used to apply visual "mouse effects" to buttons. For example, setting ButtonStyle.MouseOverBackColor to Color.Blue will cause all of the buttons to turn blue when the mouse is placed over them.

If you would one (or many) buttons to have a different style than the rest, you can set the style properties on the button level instead of using this global style mechanism.

For default values of this property, see the HtmlBox constructor topic.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


ColorPaletteType Property

HtmlBox.ColorPaletteType Property

Gets or sets a ColorPaletteType value representing the color palette that the user can select from when editing HTML.

[Visual Basic]
Public Property ColorPaletteType As ColorPaletteType
[C#]
public ColorPaletteType ColorPaletteType { get; set; }
[C++]
public: __property ColorPaletteType get_ColorPaletteType();
public: __property void set_ColorPaletteType(ColorPaletteType );
[JScript]
public function get ColorPaletteType() : ColorPaletteType
public function set ColorPaletteType(ColorPaletteType);

Property Value

A ColorPaletteType representing the color palette available to users. The default is ColorPaletteType.Standard.

Remarks

A color palette appears in multiple places in several different forms throughout the editor. For example, the font color picker button displays a palette of colors when clicked. The insert table dialog displays a drop down list of all colors when loaded. This property controls the colors that are displayed.

By default, this property is set to ColorPaletteType.Standard, which indicates the standard 140 color standard palette (also found in System.Drawing.Color) will be used. Set this property to ColorPaletteType.WebSafe to use the 216 color web-safe palette. If bandwidth or rendering time is an issue, set this property to ColorPaletteType.Condensed to get a condensed 40 color palette.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


CompatibleBrowser Property

HtmlBox.CompatibleBrowser Property

Gets a value indicating if the browser was detected to be compatible with the HtmlBox.

[Visual Basic]
Public Property ReadOnly CompatibleBrowser As Boolean
[C#]
public bool CompatibleBrowser { get; }
[C++]
public: __property bool get_CompatibleBrowser();
[JScript]
public function get CompatibleBrowser() : bool

Remarks

NOTE. This property has been superceded by HtmlBox.DetectedBrowserType and is available for backwards compatibility only. It returns a value based off od the value of DetectedBrowserType.

The editor is compatible with IE 5.5+ and Mozilla 1.3+. For all other browser types, this property will return false. Check this property if you need to take any specific action within your web page based on whether the HtmlBox will be rendered.

The HtmlBox control has automatic support for downlevel (non-compatible) browsers, which is controlled by the HtmlBox.DownlevelMode property. Set the HtmlBox.DownlevelMode property to DownlevelMode.Label to render a label to the user (accessable via the HtmlBox.DownlevelLabel property). This is useful for displaying a message to your non-compatible users such as "Upgrade your browser to IE 5.5+ or Mozilla 1.3+". Set the HtmlBox.DownlevelMode property to DownlevelMode.TextArea (the default value) to render an textarea to the user (accessable via the HtmlBox.DownlevelTextBox property). This will render an HTML textarea element, which will allow them to enter and post text just like the HtmlBox, with the exception that the text is plain text.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Controls Property

HtmlBox.Controls Property

Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.

[Visual Basic]
Overrides Public Property ReadOnly Controls As ControlCollection
[C#]
public override ControlCollection Controls { get; }
[C++]
public: __property ControlCollection* get_Controls();
[JScript]
public override function get Controls() : ControlCollection

Property Value

The collection of child controls for the specified server control.

Remarks

On an ASP.NET page, when controls are added declaratively between the opening and closing tags of a server control, ASP.NET automatically adds the controls to the containing server control's ControlCollection. Any HTML tags or text strings that are not processed on the server are treated as LiteralControl objects. These are added to the collection like other server controls.

The Controls property allows you programmatic access to the instance of the ControlCollection class for any server control. You can add controls to the collection, remove controls from the collection, or iterate through the server controls in the collection.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


DesignerFont Property

HtmlBox.DesignerFont Property

[Visual Basic]
Public Property DesignerFont As FontInfo
[C#]
public FontInfo DesignerFont { get; set; }
[C++]
public: __property FontInfo* get_DesignerFont();
public: __property void set_DesignerFont(FontInfo* );
[JScript]
public function get DesignerFont() : FontInfo
public function set DesignerFont(FontInfo);

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


DesignerToolbar Property

HtmlBox.DesignerToolbar Property

[Visual Basic]
Public Property DesignerToolbar As Toolbar
[C#]
public Toolbar DesignerToolbar { get; set; }
[C++]
public: __property Toolbar* get_DesignerToolbar();
public: __property void set_DesignerToolbar(Toolbar* );
[JScript]
public function get DesignerToolbar() : Toolbar
public function set DesignerToolbar(Toolbar);

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


DetectedBrowserType Property

HtmlBox.DetectedBrowserType Property

Gets the automatically detected browser type, sets a value to override the automatically detected value if required.

[Visual Basic]
Public Property DetectedBrowserType As BrowserType
[C#]
public BrowserType DetectedBrowserType { get; set; }
[C++]
public: __property BrowserType get_DetectedBrowserType();
public: __property void set_DetectedBrowserType(BrowserType );
[JScript]
public function get DetectedBrowserType() : BrowserType
public function set DetectedBrowserType(BrowserType);

Remarks

When a request is received, the HtmlBox control attempts to autodetect the type of browser sending the request. The content sent to the browser depends on the value of this property.

Note, HTTP headers such as USER-AGENT are easily changed, which may cause the HtmlBox control to incorrectly detect the browser type. If you require a more accurate detection mechanism, use a "proxy" page which does browser detection using client-side JavaScript before forwarding the request to the page that contains the HtmlBox control. On the page that contains the HtmlBox control, set the DetectedBrowserType property with the value you detected using your client-side script.

The HtmlBox control has automatic support for downlevel (non-compatible) browsers, which is controlled by the HtmlBox.DownlevelMode property. Set the HtmlBox.DownlevelMode property to DownlevelMode.Label to render a label to the user (accessable via the HtmlBox.DownlevelLabel property). This is useful for displaying a message to your non-compatible users such as "Upgrade your browser to IE 5.5+ or Mozilla 1.3+". Set the HtmlBox.DownlevelMode property to DownlevelMode.TextArea (the default value) to render an textarea to the user (accessable via the HtmlBox.DownlevelTextBox property). This will render an HTML textarea element, which will allow them to enter and post text just like the HtmlBox, with the exception that the text is plain text.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


DialogStyle Property

HtmlBox.DialogStyle Property

Gets or sets a DialogStyle object representing the style that will be applied to all HtmlBoxDialog controls used by the HtmlBox.

[Visual Basic]
Public Property DialogStyle As DialogStyle
[C#]
public DialogStyle DialogStyle { get; set; }
[C++]
public: __property DialogStyle* get_DialogStyle();
public: __property void set_DialogStyle(DialogStyle* );
[JScript]
public function get DialogStyle() : DialogStyle
public function set DialogStyle(DialogStyle);

Property Value

A DialogStyle object representing the styles of all dialogs.

Remarks

Use this object to globally apply styles to all dialogs at once. For example, setting DialogStyle.TitlebarBackColor to Color.Blue will cause all of the dialogs to have a blue titlebar.

If you would one (or many) dialogs to have a different style than the rest, you can set the style properties on the dialog level instead of using this global style mechanism.

For default values of this property, see the HtmlBox constructor topic.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


DownlevelLabel Property

HtmlBox.DownlevelLabel Property

Represents the label rendered to the user if the HtmlBox.DownlevelMode = DownlevelMode.Label.

[Visual Basic]
Public Property DownlevelLabel As DownlevelLabel
[C#]
public DownlevelLabel DownlevelLabel { get; set; }
[C++]
public: __property DownlevelLabel* get_DownlevelLabel();
public: __property void set_DownlevelLabel(DownlevelLabel* );
[JScript]
public function get DownlevelLabel() : DownlevelLabel
public function set DownlevelLabel(DownlevelLabel);

Property Value

A DownlevelLabel control representing the Label rendered to the user.

Remarks

You have two choices as to what downlevel (non-compatible) browsers see when they load the editor, a DownlevelLabel or a DownlevelTextArea. Use the Label if the user CANNOT continue without a compatible browser. You can use the Label to display a message such as "Please upgrade your browser to IE 5.5+ or Mozilla 1.3+". Use the TextArea if the user can continue with a comaptible browser. In this case, a standard HTML TEXTAREA will be displayed to the user, allowing them to enter plain text.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


DownlevelMode Property

HtmlBox.DownlevelMode Property

Controls whether the user sees a Label or a TextArea if their browser is incompatible with the HtmlBox.

[Visual Basic]
Public Property DownlevelMode As DownlevelMode
[C#]
public DownlevelMode DownlevelMode { get; set; }
[C++]
public: __property DownlevelMode get_DownlevelMode();
public: __property void set_DownlevelMode(DownlevelMode );
[JScript]
public function get DownlevelMode() : DownlevelMode
public function set DownlevelMode(DownlevelMode);

Property Value

A DownlevelMode value specifying what non-compatible browsers see. The default value is DownlevelMode.TextArea.

Remarks

You have two choices as to what downlevel (non-compatible) browsers see when they load the editor, a DownlevelLabel or a DownlevelTextArea. Use the Label if the user CANNOT continue without a compatible browser. You can use the Label to display a message such as "Please upgrade your browser to IE 5.5+ or Mozilla 1.3+". Use the TextArea if the user can continue with a comaptible browser. In this case, a standard HTML TEXTAREA will be displayed to the user, allowing them to enter plain text.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


DownlevelTextArea Property

HtmlBox.DownlevelTextArea Property

Represents the textarea control rendered to the user if the HtmlBox.DownlevelMode = DownlevelMode.TextArea.

[Visual Basic]
Public Property DownlevelTextArea As DownlevelTextArea
[C#]
public DownlevelTextArea DownlevelTextArea { get; set; }
[C++]
public: __property DownlevelTextArea* get_DownlevelTextArea();
public: __property void set_DownlevelTextArea(DownlevelTextArea* );
[JScript]
public function get DownlevelTextArea() : DownlevelTextArea
public function set DownlevelTextArea(DownlevelTextArea);

Property Value

A DownlevelTextArea control representing the textarea rendered to the user.

Remarks

You have two choices as to what downlevel (non-compatible) browsers see when they load the editor, a DownlevelLabel or a DownlevelTextArea. Use the Label if the user CANNOT continue without a compatible browser. You can use the Label to display a message such as "Please upgrade your browser to IE 5.5+ or Mozilla 1.3+". Use the TextArea if the user can continue with a comaptible browser. In this case, a standard HTML TEXTAREA will be displayed to the user, allowing them to enter plain text.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


DropDownStyle Property

HtmlBox.DropDownStyle Property

Gets a Style object representing the style that will be applied to all ToolbarDropDown controls used by the HtmlBox.

[Visual Basic]
Public Property DropDownStyle As BaseStyle
[C#]
public BaseStyle DropDownStyle { get; set; }
[C++]
public: __property BaseStyle* get_DropDownStyle();
public: __property void set_DropDownStyle(BaseStyle* );
[JScript]
public function get DropDownStyle() : BaseStyle
public function set DropDownStyle(BaseStyle);

Property Value

A Style object representing the styles of all dialogs.

Remarks

Use this object to globally apply styles to all dropdowns at once. For example, setting Style.BackColor to Color.Blue will cause all of the dropdowns to have a blue background.

If you would one (or many) dropdowns to have a different style than the rest, you can set the style properties on the dropdown level instead of using this global style mechanism.

For default values of this property, see the HtmlBox constructor topic.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Enabled Property

HtmlBox.Enabled Property

Gets or sets a value indicating whether the HtmlBox control is enabled.

[Visual Basic]
Overrides Public Property Enabled As Boolean
[C#]
public override bool Enabled { get; set; }
[C++]
public: __property bool get_Enabled();
public: __property void set_Enabled(bool );
[JScript]
public override function get Enabled() : bool
public override function set Enabled(bool);

Property Value

true if control is enabled; otherwise, false. The default is true.

Remarks

Use the Enabled property to specify or determine whether a control is functional. When set to false, the control appears dimmed, preventing any input from being entered in the control.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Focus Property

HtmlBox.Focus Property

Controls whether or not the HtmlBox receives the mouse focus when the page is loaded.

[Visual Basic]
Public Property Focus As Boolean
[C#]
public bool Focus { get; set; }
[C++]
public: __property bool get_Focus();
public: __property void set_Focus(bool );
[JScript]
public function get Focus() : bool
public function set Focus(bool);

Property Value

true if the HtmlBox should receive the mouse focus when the page is loaded, false otherwise. The default value is true.

Remarks

Depending on the scenario, you may or may not want the HtmlBox to receive the mouse focus. For example, if the HtmlBox is the only control on the page, you probably want it to receive the mouse focus. If the HtmlBox is one of many form controls on the page, you may not want the HtmlBox to receive the mouse focus.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


FontFormattingList Property

HtmlBox.FontFormattingList Property

High-level "helper" collection which provides font formatting values to applicable ToolbarDropDown controls.

[Visual Basic]
Public Property FontFormattingList As StringValueCollection
[C#]
public StringValueCollection FontFormattingList { get; set; }
[C++]
public: __property StringValueCollection* get_FontFormattingList();
public: __property void set_FontFormattingList(StringValueCollection* );
[JScript]
public function get FontFormattingList() : StringValueCollection
public function set FontFormattingList(StringValueCollection);

Property Value

A NameValueCollection containing the names and values of the font formatting types available. The default values are:

  • "Heading 1", "<h1>"
  • "Heading 2", "<h2>"
  • "Heading 3", "<h3>"
  • "Heading 4", "<h4>"
  • "Heading 5", "<h5>"
  • "Pre", "<pre>"
  • "Code", "<code>"

Remarks

If you have any ToolbarDropDown controls with a ToolbarDropDown.Type property = ToolbarDropDownType.FontFormatting, that control will get it's values from the values in this collection.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


FontNameList Property

HtmlBox.FontNameList Property

High-level "helper" collection which provides font name values to applicable ToolbarDropDown controls.

[Visual Basic]
Public Property FontNameList As StringArrayList
[C#]
public StringArrayList FontNameList { get; set; }
[C++]
public: __property StringArrayList* get_FontNameList();
public: __property void set_FontNameList(StringArrayList* );
[JScript]
public function get FontNameList() : StringArrayList
public function set FontNameList(StringArrayList);

Property Value

An ArrayList containing the font names available. Default values: "Arial", "Verdana", "Tahoma", "Courier New", "Georgia"

Remarks

If you have any ToolbarDropDown controls with a ToolbarDropDown.Type property = ToolbarDropDownType.FontName, that control will get it's values from the values in this collection.

For default values of this property, see the HtmlBox constructor topic.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


FontSizeList Property

HtmlBox.FontSizeList Property

High-level "helper" collection which provides font size values to applicable ToolbarDropDown controls.

[Visual Basic]
Public Property FontSizeList As StringArrayList
[C#]
public StringArrayList FontSizeList { get; set; }
[C++]
public: __property StringArrayList* get_FontSizeList();
public: __property void set_FontSizeList(StringArrayList* );
[JScript]
public function get FontSizeList() : StringArrayList
public function set FontSizeList(StringArrayList);

Property Value

An ArrayList containing the font sizes available. Default values: "1","2","3","4","5","6","7"

Remarks

If you have any ToolbarDropDown controls with a ToolbarDropDown.Type property = ToolbarDropDownType.FontSize, that control will get it's values from the values in this collection.

For default values of this property, see the HtmlBox constructor topic.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


FontStyleList Property

HtmlBox.FontStyleList Property

High-level "helper" collection which provides font style values to applicable ToolbarDropDown controls.

[Visual Basic]
Public Property FontStyleList As StringValueCollection
[C#]
public StringValueCollection FontStyleList { get; set; }
[C++]
public: __property StringValueCollection* get_FontStyleList();
public: __property void set_FontStyleList(StringValueCollection* );
[JScript]
public function get FontStyleList() : StringValueCollection
public function set FontStyleList(StringValueCollection);

Property Value

A NameValueCollection containing the font style values available.

Remarks

If you have any ToolbarDropDown controls with a ToolbarDropDown.Type property = ToolbarDropDownType.FontStyle, that control will get it's values from the values in this collection.

For default values of this property, see the HtmlBox constructor topic.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


ForeColor Property

HtmlBox.ForeColor Property

Gets or sets the foreground color (typically the color of the text) of the control.

[Visual Basic]
Overrides Public Property ForeColor As Color
[C#]
public override Color ForeColor { get; set; }
[C++]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(Color );
[JScript]
public override function get ForeColor() : Color
public override function set ForeColor(Color);

Property Value

A System.Drawing.Color that represents the foreground color of the control. The default is Color.Empty.

Remarks

Use the ForeColor property to specify the foreground color of the control. The foreground color is usually the color of the text. This property will render on browsers earlier than Microsoft Internet

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Height Property

HtmlBox.Height Property

Gets or sets the height of the control.

[Visual Basic]
Overrides Public Property Height As Unit
[C#]
public override Unit Height { get; set; }
[C++]
public: __property Unit get_Height();
public: __property void set_Height(Unit );
[JScript]
public override function get Height() : Unit
public override function set Height(Unit);

Property Value

A Unit that represents the height of the control. The default is Unit.Empty.

Remarks

Use the Height property to specify the height of the control

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


ImagesDirectory Property

HtmlBox.ImagesDirectory Property

Gets or sets a virtual, relative, or absolute pathname of the directory containing all of the images used by the HtmlBox.

[Visual Basic]
Public Property ImagesDirectory As String
[C#]
public string ImagesDirectory { get; set; }
[C++]
public: __property String* get_ImagesDirectory();
public: __property void set_ImagesDirectory(String* );
[JScript]
public function get ImagesDirectory() : String
public function set ImagesDirectory(String);

Property Value

A string representing the virtual, relative, or absolute pathname of the directory containing all of the images used by the HtmlBox. The default value is "/PowerWEB_TextBox_Common/images".

Remarks

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example (using HtmlBox.BackgroundImageName as an example), if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and the HtmlBox.BackgroundImageName property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If the HtmlBox.BackgroundImageName property was set to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


IsPostbackFromUpload Property

HtmlBox.IsPostbackFromUpload Property

Gets a value specifying if the current page request was due to a postback from an HtmlBoxUpload control.

[Visual Basic]
Public Property ReadOnly IsPostbackFromUpload As Boolean
[C#]
public bool IsPostbackFromUpload { get; }
[C++]
public: __property bool get_IsPostbackFromUpload();
[JScript]
public function get IsPostbackFromUpload() : bool

Property Value

true if the current request was a postback from an HtmlBoxUpload control, false otherwise.

Remarks

The HtmlBox control may have one or many instances of a ToolbarUploadButton on the toolbar. This button launches an "upload" dialog which can be used to upload files to the server via a post request. Use this property to check if the postback to the page was due to an "upload" postback, instead of a standard postback (triggered by a button click, for example).

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


LayoutType Property

HtmlBox.LayoutType Property

Gets or sets the current LayoutType of the HtmlBox.

[Visual Basic]
Public Property LayoutType As LayoutType
[C#]
public LayoutType LayoutType { get; set; }
[C++]
public: __property LayoutType get_LayoutType();
public: __property void set_LayoutType(LayoutType );
[JScript]
public function get LayoutType() : LayoutType
public function set LayoutType(LayoutType);

Property Value

A LayoutType value specifying the type of layout for the HtmlBox. The default type is LayoutType.Standard.

Remarks

The HtmlBox can be rendered multiple ways depending on the scenario. LayoutType.Standard renders a standard editor. LayoutType.Condensed renders a condensed editor (good for low-bandwidth scenarios). LayoutType.Skin renders a editor optimized for displaying graphical skins. NOTE! Changing from one layout type to another WILL change some property values. For example, if you are using the LayoutType.Standard layout, change the HtmlBox.BackColor to red, then change the HtmlBox.LayoutType to LayoutType.Skin, that property will be nulled out. For this reason, it is suggested that you always change the HtmlBox.LayoutType FIRST, before making other changes, to eliminate any chances of a property being overwritten.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


LocalizationFile Property

HtmlBox.LocalizationFile Property

Gets or sets a value specifying a file path to an XML file specifying localization strings.

[Visual Basic]
Public Property LocalizationFile As String
[C#]
public string LocalizationFile { get; set; }
[C++]
public: __property String* get_LocalizationFile();
public: __property void set_LocalizationFile(String* );
[JScript]
public function get LocalizationFile() : String
public function set LocalizationFile(String);

Remarks

Use this property only if the language translation you require is not included in the LocalizationType enumeration. You must create this XML file yourself, using the same XML format as the PowerWEB file.

NOTE. When this property is set, all strings are cleared and reinitialized with the correct defaults language string. Any changes you made to child controls strings will be lost.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


LocalizationType Property

HtmlBox.LocalizationType Property

Gets or sets a value which determines in what language strings are displayed

[Visual Basic]
Public Property LocalizationType As LocalizationType
[C#]
public LocalizationType LocalizationType { get; set; }
[C++]
public: __property LocalizationType get_LocalizationType();
public: __property void set_LocalizationType(LocalizationType );
[JScript]
public function get LocalizationType() : LocalizationType
public function set LocalizationType(LocalizationType);

Remarks

All predefined strings are sourced from an embedded XML resource file. Changing the value of this property will cause all predefined strings to be translated into the selected language. For example if the current LocalizationType is English, and French is chosen, the string "Color" becomes "Couleur".

NOTE. When this property is set, all strings are cleared and reinitialized with the correct defaults language string. Any changes you made to child controls strings will be lost.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


MenuStyle Property

HtmlBox.MenuStyle Property

Gets a MenuStyle object representing the style that will be applied to all HtmlBoxMenu controls used by the HtmlBox.

[Visual Basic]
Public Property MenuStyle As MenuStyle
[C#]
public MenuStyle MenuStyle { get; set; }
[C++]
public: __property MenuStyle* get_MenuStyle();
public: __property void set_MenuStyle(MenuStyle* );
[JScript]
public function get MenuStyle() : MenuStyle
public function set MenuStyle(MenuStyle);

Property Value

A MenuStyle object representing the styles of all dialogs.

Remarks

Use this object to globally apply styles to all menus at once. For example, setting MenuStyle.BackColor to Color.Blue will cause all of the menus to have a blue background.

If you would one (or many) menus to have a different style than the rest, you can set the style properties on the menu level instead of using this global style mechanism.

For default values of this property, see the HtmlBox constructor topic.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


PlaceholderFilename Property

HtmlBox.PlaceholderFilename Property

Gets or sets a virtual, relative, or absolute pathname of the directory containing all of the images used by the HtmlBox.

[Visual Basic]
Public Property PlaceholderFilename As String
[C#]
public string PlaceholderFilename { get; set; }
[C++]
public: __property String* get_PlaceholderFilename();
public: __property void set_PlaceholderFilename(String* );
[JScript]
public function get PlaceholderFilename() : String
public function set PlaceholderFilename(String);

Property Value

A string representing the virtual, relative, or absolute pathname of the directory containing all of the images used by the HtmlBox. The default value is "/PowerWEB_TextBox_Common/images".

Remarks

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example (using HtmlBox.BackgroundImageName as an example), if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and the HtmlBox.BackgroundImageName property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If the HtmlBox.BackgroundImageName property was set to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


ProgressBar Property

HtmlBox.ProgressBar Property

Gets the HtmlBoxProgressBar representing the progressbar used for the HtmlBox preload, if it is enabled.

[Visual Basic]
Public Property ProgressBar As HtmlBoxProgressBar
[C#]
public HtmlBoxProgressBar ProgressBar { get; set; }
[C++]
public: __property HtmlBoxProgressBar* get_ProgressBar();
public: __property void set_ProgressBar(HtmlBoxProgressBar* );
[JScript]
public function get ProgressBar() : HtmlBoxProgressBar
public function set ProgressBar(HtmlBoxProgressBar);

Property Value

An HtmlBoxProgressBar representing the progressbar used for the HtmlBox preload.

Remarks

If the progress bar is enabled (by setting HtmlBoxProgressBar.Display to true), progress will be displayed while the editor is loading. Progress is automatically incremented each time a new graphic is loaded. The default HtmlBox settings are very light graphically and, as such, there is little benefit in using a progress bar. A good scenario for using the progress bar would be in the case of a highly-graphical editor in a low-bandwidth scenario.

The progress bar is only displayed on the initial load. For any subsequent loads resulting from postback the progress bar is not displayed.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


ReadOnly Property

HtmlBox.ReadOnly Property

Gets or sets a value which indicates whether the HtmlBox should be an active HTML editor, or a read-only document viewer.

[Visual Basic]
Public Property ReadOnly As Boolean
[C#]
public bool ReadOnly { get; set; }
[C++]
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(bool );
[JScript]
public function get ReadOnly() : bool
public function set ReadOnly(bool);

Property Value

true if the HtmlBox should be a read-only document viewer; false otherwise. The default value is false.

Remarks

Set this property to true if you would like to display read-only content in the HtmlBox.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


RightClickBehavior Property

HtmlBox.RightClickBehavior Property

Gets or sets a value which indicates how the HtmlBox should behave when it is right-clicked with the mouse.

[Visual Basic]
Public Property RightClickBehavior As RightClickBehavior
[C#]
public RightClickBehavior RightClickBehavior { get; set; }
[C++]
public: __property RightClickBehavior get_RightClickBehavior();
public: __property void set_RightClickBehavior(RightClickBehavior );
[JScript]
public function get RightClickBehavior() : RightClickBehavior
public function set RightClickBehavior(RightClickBehavior);

Property Value

A RightClickBehavior value indicating how the HtmlBox should behave when it is right-clicked with the mouse. The default setting is RightClickBehavior. The default value is RightClickMenu.HtmlBoxMenu.

Remarks

The default value displays a "Windows-style" right-click menu which is tightly coupled with the HtmlBox. Set this property to RightClickBehavior.WindowsMenu to display the standard Windows menu. Set this property to RightClickBehavior.None to suppress all menus.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


RightClickMenu Property

HtmlBox.RightClickMenu Property

Gets an HtmlBoxMenu control representing the right-click menu displayed when the user right-clicks on the HtmlBox with the mouse.

[Visual Basic]
Public Property ReadOnly RightClickMenu As HtmlBoxMenu
[C#]
public HtmlBoxMenu RightClickMenu { get; }
[C++]
public: __property HtmlBoxMenu* get_RightClickMenu();
[JScript]
public function get RightClickMenu() : HtmlBoxMenu

Property Value

An HtmlBox control representing the right-click menu displayed when the user right-clicks on the HtmlBox with the mouse.

Remarks

The default right-click menu (used when the HtmlBox.RightClickBehavior property is RightClickBehavior.HtmlBoxMenu) is a context sensitive right-click menu tightly coupled with the HtmlBox. For example, when if the user right-clicks within a table, they are presented with table specific options such as "Table Properties" and "Cell Properties".

Style changes to the global HtmlBox.MenuStyle object are applied to the HtmlBox.RightClickMenu.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


SecureConnection Property

HtmlBox.SecureConnection Property

Gets or sets a value which indicates if the HtmlBox is being requested by a secure connection.

[Visual Basic]
Public Property SecureConnection As Boolean
[C#]
public bool SecureConnection { get; set; }
[C++]
public: __property bool get_SecureConnection();
public: __property void set_SecureConnection(bool );
[JScript]
public function get SecureConnection() : bool
public function set SecureConnection(bool);

Property Value

true if the HtmlBox is on a page accessed over HTTPS; false otherwise.

Remarks

When the HtmlBox loads, the control will automatically detect if it is being used on a secure (HTTPS) page. If this property is true, the IFRAME src will be initialized to the file "sslstub.htm" (which is contained in the default scripts directory) which will suppress any warnings about non-secure elements on the page.

This property can also be set if the control's autodetection incorrectly detects HTTPS.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


SpecialCharacterList Property

HtmlBox.SpecialCharacterList Property

High-level "helper" collection which provides special character values to applicable ToolbarDialogButton controls.

[Visual Basic]
Public Property SpecialCharacterList As StringArrayList
[C#]
public StringArrayList SpecialCharacterList { get; set; }
[C++]
public: __property StringArrayList* get_SpecialCharacterList();
public: __property void set_SpecialCharacterList(StringArrayList* );
[JScript]
public function get SpecialCharacterList() : StringArrayList
public function set SpecialCharacterList(StringArrayList);

Property Value

An ArrayList containing the special characters available. Default values: "&copy;","&reg;","&#153;","&#151;","&#133;","&#209","&aacute;","&yen;","&euro;","&pound;","&#147;","&#148;","&#149;","&para;","&eacute;","&uacute;"

Remarks

If you have any ToolbarDialogButton controls with a ToolbarDialogButton.Type property = ToolbarDialogButtonType.SpecialCharacter, that control will get it's values from the values in this collection.

For default values of this property, see the HtmlBox constructor topic.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


StartupMode Property

HtmlBox.StartupMode Property

Gets or sets a StartupMode value indicating the startup mode of the HtmlBox.

[Visual Basic]
Public Property StartupMode As StartupMode
[C#]
public StartupMode StartupMode { get; set; }
[C++]
public: __property StartupMode get_StartupMode();
public: __property void set_StartupMode(StartupMode );
[JScript]
public function get StartupMode() : StartupMode
public function set StartupMode(StartupMode);

Property Value

An StartupMode value indicating the startup mode of the HtmlBox. The default value is StartupMode.Design

Remarks

Set this property to StartupMode.HTML to start the HtmlBox in HTML mode.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


TabStrip Property

HtmlBox.TabStrip Property

Gets a HtmlBoxTabStrip object representing the tabstrip used by the HtmlBox.

[Visual Basic]
Public Property TabStrip As HtmlBoxTabStrip
[C#]
public HtmlBoxTabStrip TabStrip { get; set; }
[C++]
public: __property HtmlBoxTabStrip* get_TabStrip();
public: __property void set_TabStrip(HtmlBoxTabStrip* );
[JScript]
public function get TabStrip() : HtmlBoxTabStrip
public function set TabStrip(HtmlBoxTabStrip);

Property Value

The HtmlBoxTabStrip object representing the tabstrip used by the HtmlBox.

Remarks

This object represents the "Design/HTML" tab strip at the bottom of the HtmlBox. Set the properties of this object to change the visual representation of the tabstrip.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Text Property

HtmlBox.Text Property

Gets or sets the text displayed in the editor.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

A string containing the text displayed in the editor.

Remarks

Set this property to provide initial text for the editor. Read this property to get any changed text when the user submits the page. The HtmlBox.TextChanged event is raised whenever the value of this property changes.

This property returns the same data as HtmlBox.TextWindow.Text.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


TextPlain Property

HtmlBox.TextPlain Property

Gets the value of the HtmlBox.Text property stripped of any HTML tags.

[Visual Basic]
Public Property ReadOnly TextPlain As String
[C#]
public string TextPlain { get; }
[C++]
public: __property String* get_TextPlain();
[JScript]
public function get TextPlain() : String

Property Value

A string containing the value of the HtmlBox.Text property stripped of any HTML tags.

Remarks

This property is read-only.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


TextWindow Property

HtmlBox.TextWindow Property

Gets an HtmlBoxTextWindow control representing the actual editing window of the HtmlBox.

[Visual Basic]
Public Property TextWindow As HtmlBoxTextWindow
[C#]
public HtmlBoxTextWindow TextWindow { get; set; }
[C++]
public: __property HtmlBoxTextWindow* get_TextWindow();
public: __property void set_TextWindow(HtmlBoxTextWindow* );
[JScript]
public function get TextWindow() : HtmlBoxTextWindow
public function set TextWindow(HtmlBoxTextWindow);

Property Value

An HtmlBoxTextWindow control representing the actual editing window of the HtmlBox.

Remarks

Set the properties of this object to change the visual representation of the text window. For example, set the HtmlBoxTextWindow.Transparent property to cause the text window to be transparent. Set the HtmlBoxTextWindow.BackgroundImage property to place a backround image on the text window.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


TextXhtml Property

HtmlBox.TextXhtml Property

Gets the value of the HtmlBox.Text property converted to XHTML.

[Visual Basic]
Public Property ReadOnly TextXhtml As String
[C#]
public string TextXhtml { get; }
[C++]
public: __property String* get_TextXhtml();
[JScript]
public function get TextXhtml() : String

Property Value

A string containing the value of the HtmlBox.Text property converted to XHTML.

Remarks

This property is read-only.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Toolbar Property

HtmlBox.Toolbar Property

Gets an HtmlBoxToolbar control representing the toolbar.

[Visual Basic]
Public Property ReadOnly Toolbar As Toolbar
[C#]
public Toolbar Toolbar { get; }
[C++]
public: __property Toolbar* get_Toolbar();
[JScript]
public function get Toolbar() : Toolbar

Property Value

An HtmlBoxToolbar control representing the toolbar.

Remarks

The Toolbar contains/manages all toolbar items. Only classes that derive from BaseToolbarItem can be placed on the toolbar. The following list describes each class that derives from BaseToolbarItem:

  • ToolbarButton - Represents a standard formatting button.
  • ToolbarDialogButton - Represents a button which launches a dialog.
  • ToolbarUploadButton - Represents a button which launches a file upload dialog.
  • ToolbarMenuButton - Represents a button which launches a menu.
  • ToolbarImage - Represents an image on the toolbar.
  • ToolbarText - Represents text on the toolbar.

The HtmlBoxToolbar.Items property exposes the ToolbarItemCollection which contains/manages all toolbar items. Use the HtmlBox.AddToolbarItem method as a shortcut method to easily add a new toolbar item. The ToolbarItemCollection.Clear method of the ToolbarItemCollection and the HtmlBox.Clear method of the HtmlBox both clear this collection.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


TopMargin Property

HtmlBox.TopMargin Property

Gets or sets the amount of space (in pixels) between the top edge of the editor and the toolbar.

[Visual Basic]
Public Property TopMargin As Integer
[C#]
public int TopMargin { get; set; }
[C++]
public: __property int get_TopMargin();
public: __property void set_TopMargin(int );
[JScript]
public function get TopMargin() : int
public function set TopMargin(int);

Property Value

An integer specifying the amount of space (in pixels) between the top edge of the editor and the toolbar. The default value is 0.

Remarks

This property is primarily used when applying a graphical skin to the HtmlBox. For more information about skin creation and usage, see the topic Using Skins. For standard implementations, this property does not typically need to be set (although it may be).

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


UploadedFilesDirectory Property

HtmlBox.UploadedFilesDirectory Property

Gets or sets a virtual, relative, or absolute pathname of the directory where all files are uploaded.

[Visual Basic]
Public Property UploadedFilesDirectory As String
[C#]
public string UploadedFilesDirectory { get; set; }
[C++]
public: __property String* get_UploadedFilesDirectory();
public: __property void set_UploadedFilesDirectory(String* );
[JScript]
public function get UploadedFilesDirectory() : String
public function set UploadedFilesDirectory(String);

Property Value

A string representing the virtual, relative, or absolute pathname of the directory where all files uploaded using the HtmlBox are stored. The default value is "/PowerWEB_TextBox_Common/uploadedfiles".

Remarks

This property impacts all ToolbarUploadButton controls on the toolbar. Each ToolbarUploadButton has a ToolbarUploadButton.Upload property representing the upload dialog that will be displayed to the user when the button is clicked. The user can use this dialog to upload files. This upload dialog, by default, will upload files to the directory specified by this property. If you have multiple ToolbarUploadButton controls on the toolbar, they will all upload to this directory by default. If you want to change this so multiple ToolbarUploadButton controls upload to different directories, you must do this on the ToolbarUploadButton level instead of setting this property, which acts globally.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


UrlType Property

HtmlBox.UrlType Property

Gets or sets a value which determines how links are represented in the editor.

[Visual Basic]
Public Property UrlType As UrlType
[C#]
public UrlType UrlType { get; set; }
[C++]
public: __property UrlType get_UrlType();
public: __property void set_UrlType(UrlType );
[JScript]
public function get UrlType() : UrlType
public function set UrlType(UrlType);

Property Value

A UrlType value. The default value is UrlType.RootRelative.

Remarks

Some browsers improperly convert urls within the editor. For example, IE will convert the following link:

<a href="#blah">my link</a>

to

<a href="http://localhost/myproject/webform1.aspx#blah">my link</a>

which results in a broken link. TextBox for ASP.NET automatically converts these improper links to a proper link. This property controls how these links are converted.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


UseLineBreak Property

HtmlBox.UseLineBreak Property

Gets or sets a value which determines how enter key presses behave.

[Visual Basic]
Public Property UseLineBreak As Boolean
[C#]
public bool UseLineBreak { get; set; }
[C++]
public: __property bool get_UseLineBreak();
public: __property void set_UseLineBreak(bool );
[JScript]
public function get UseLineBreak() : bool
public function set UseLineBreak(bool);

Property Value

true if enter key presses insert a <BR> tag; false if enter key presses insert a <P> tag

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


UseSection508Compliance Property

HtmlBox.UseSection508Compliance Property

Gets or sets whether the HtmlBox should be rendered in Section 508 compliant mode.

[Visual Basic]
Public Property UseSection508Compliance As Boolean
[C#]
public bool UseSection508Compliance { get; set; }
[C++]
public: __property bool get_UseSection508Compliance();
public: __property void set_UseSection508Compliance(bool );
[JScript]
public function get UseSection508Compliance() : bool
public function set UseSection508Compliance(bool);

Property Value

true if 508 Section Compliance is adhered to, false otherwise. The default value is false.

Remarks

Set the property to make the control more accessible to users with disabilities. For example, an element that is purely visual (such as an image) includes required alternate text describing the image.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Visible Property

HtmlBox.Visible Property

Gets or sets a value that indicates whether a server control is rendered as UI on the page.

[Visual Basic]
Overrides Public Property Visible As Boolean
[C#]
public override bool Visible { get; set; }
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(bool );
[JScript]
public override function get Visible() : bool
public override function set Visible(bool);

Property Value

true if the control is visible on the page; otherwise false.

Remarks

If this property is false, the server control is not rendered. You should take this into account when organizing the lay out of your page.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Width Property

HtmlBox.Width Property

Gets or sets the width of the control.

[Visual Basic]
Overrides Public Property Width As Unit
[C#]
public override Unit Width { get; set; }
[C++]
public: __property Unit get_Width();
public: __property void set_Width(Unit );
[JScript]
public override function get Width() : Unit
public override function set Width(Unit);

Property Value

A Unit that represents the width of the control. The default is Unit.Empty.

Remarks

Use the Width property to specify the width of the control

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


HtmlBox Methods

The methods of the HtmlBox class are listed below. For a complete list of HtmlBox class members, see the HtmlBox Members topic.

Public Instance Methods

AddToolbarItem | High-level "shortcut" method to quickly create, initialize, and add an item to the toolbar.
ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clear | Clears the HtmlBox.
ClearStyles | Clears the HtmlBox.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference (inherited from LiveLabel) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript (inherited from LiveLabel) |
GetScriptObjectReference (inherited from LiveLabel) |
GetScriptStyleReference (inherited from LiveLabel) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState (inherited from LiveLabel) |
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadSkin | Load a predefined skin XML file.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag | Overidden. Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag | Overidden. Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
Reset | Returns the HtmlBox control to it's inital state.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SaveSkin | Overloaded. Save the current HtmlBox configuration as an XML skin file.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


AddToolbarItem Method

HtmlBox.AddToolbarItem Method

High-level "shortcut" method to quickly create, initialize, and add an item to the toolbar.

[Visual Basic]
Public Function AddToolbarItem( _
   ByVal type As ToolbarItemType _
) As BaseToolbarItem
[C#]
public BaseToolbarItem AddToolbarItem(
   ToolbarItemType type
);
[C++]
public: BaseToolbarItem* AddToolbarItem(
   ToolbarItemType type
);
[JScript]
public function AddToolbarItem(
   ToolbarItemType type
): BaseToolbarItem;

Parameters

type
A ToolbarItemType specifying the type of toolbar item to create.

Remarks

This method provides an easy way to quickly configure the toolbar. Simply call the HtmlBox.AddToolbarItem, passing in a ToolbarItemType, and the proper object will be created, provided with the proper default values, and added. For example if you call the following:

HtmlBox1.AddToolbarItem(ToolbarItemType.Bold)

a ToolbarButton object will be created, configured as a "bold" button (i.e., it will display the "bold" image and and call the client-side script which causes text to be formatted as bold), and added to the Toolbar.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Clear Method

HtmlBox.Clear Method

Clears the HtmlBox.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();
[C++]
public: void Clear();
[JScript]
public function Clear();

Remarks

This method clears the HtmlBox.Text property, and removes all items from the HtmlBox.Toolbar. This is a helpful method to use if you want to quickly configure a toolbar layout by first calling HtmlBox.Clear, then calling HtmlBox.AddToolbarItem to add toolbar items to the toolbar.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


ClearStyles Method

HtmlBox.ClearStyles Method

Clears the HtmlBox.

[Visual Basic]
Public Sub ClearStyles()
[C#]
public void ClearStyles();
[C++]
public: void ClearStyles();
[JScript]
public function ClearStyles();

Remarks

This method clears the HtmlBox.Text property, and removes all items from the HtmlBox.Toolbar. This is a helpful method to use if you want to quickly configure a toolbar layout by first calling HtmlBox.Clear, then calling HtmlBox.AddToolbarItem to add toolbar items to the toolbar.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Clone Method

HtmlBox.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As HtmlBox
[C#]
public HtmlBox Clone();
[C++]
public: HtmlBox* Clone();
[JScript]
public function Clone(): HtmlBox;

Return Value

An HtmlBox control.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


LoadSkin Method

HtmlBox.LoadSkin Method

Load a predefined skin XML file.

[Visual Basic]
Public Sub LoadSkin( _
   ByVal filepath As String _
)
[C#]
public void LoadSkin(
   string filepath
);
[C++]
public: void LoadSkin(
   String* filepath
);
[JScript]
public function LoadSkin(
   String filepath
);

Parameters

filepath
The filepath of the XML skin file.

Remarks

This method loads a predefined XML skin file and uses this file to populate the control's properties. Easily create an XML skin file by using the HtmlBox.SaveSkin method. For more information about creating and using skins, see the topic Using Skins.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


RenderBeginTag Method

HtmlBox.RenderBeginTag Method

Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.

[Visual Basic]
Overrides Public Sub RenderBeginTag( _
   ByVal writer As HtmlTextWriter _
)
[C#]
public override void RenderBeginTag(
   HtmlTextWriter writer
);
[C++]
public: void RenderBeginTag(
   HtmlTextWriter* writer
);
[JScript]
public override function RenderBeginTag(
   HtmlTextWriter writer
);

Parameters

writer
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.

Remarks

This is made public so other controls can render multiple controls in between the opening and closing tags of a Web server control. This method is not intended to be used from within your code.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


RenderEndTag Method

HtmlBox.RenderEndTag Method

Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.

[Visual Basic]
Overrides Public Sub RenderEndTag( _
   ByVal writer As HtmlTextWriter _
)
[C#]
public override void RenderEndTag(
   HtmlTextWriter writer
);
[C++]
public: void RenderEndTag(
   HtmlTextWriter* writer
);
[JScript]
public override function RenderEndTag(
   HtmlTextWriter writer
);

Parameters

writer
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.

Remarks

This is made public so other controls can render multiple controls in between the opening and closing tags of a Web server control. This method is not intended to be used from within your code.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


Reset Method

HtmlBox.Reset Method

Returns the HtmlBox control to it's inital state.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[JScript]
public function Reset();

Remarks

Note. All changes made to the HtmlBox will be lost.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


SaveSkin Method

HtmlBox.SaveSkin Method

Save the current HtmlBox configuration as an XML skin file.

Overload List

Save the current HtmlBox configuration as an XML skin file.

[Visual Basic] Public Sub SaveSkin(ByVal String,ByVal String)
[C#] public void SaveSkin(string,string);
[C++] public: void SaveSkin(String*,String*);
[JScript] public function SaveSkin(String,String);

Save the current HtmlBox configuration as an XML skin file.

[Visual Basic] Public Sub SaveSkin(ByVal String,ByVal String,ByVal String)
[C#] public void SaveSkin(string,string,string);
[C++] public: void SaveSkin(String*,String*,String*);
[JScript] public function SaveSkin(String,String,String);

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


SaveSkin Method (String, String)

HtmlBox.SaveSkin Method (String, String)

Save the current HtmlBox configuration as an XML skin file.

[Visual Basic]
Public Sub SaveSkin( _
   ByVal filepath As String, _
   ByVal name As String _
)
[C#]
public void SaveSkin(
   string filepath,
   string name
);
[C++]
public: void SaveSkin(
   String* filepath,
   String* name
);
[JScript]
public function SaveSkin(
   String filepath,
   String name
);

Parameters

filepath
The filepath to which the XML file will be saved.
name
The name of the skin (for example "The Purple Skin"). This is used by the designer.

Remarks

This method saves the current HtmlBox configuration as an XML skin file. Load the skin by using the HtmlBox.LoadSkin method. For more information about creating a using skins, see Using Skins.

This method DOES NOT save information about individual toolbar items. For example, if you have changed the background color of a SINGLE button, this will not be persisted to the skin file. You must use the global properties for controlling style (such as the HtmlBox.ButtonStyle property of HtmlBox).

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace | HtmlBox.SaveSkin Overload List


SaveSkin Method (String, String, String)

HtmlBox.SaveSkin Method (String, String, String)

Save the current HtmlBox configuration as an XML skin file.

[Visual Basic]
Public Sub SaveSkin( _
   ByVal filepath As String, _
   ByVal name As String, _
   ByVal previewImage As String _
)
[C#]
public void SaveSkin(
   string filepath,
   string name,
   string previewImage
);
[C++]
public: void SaveSkin(
   String* filepath,
   String* name,
   String* previewImage
);
[JScript]
public function SaveSkin(
   String filepath,
   String name,
   String previewImage
);

Parameters

filepath
The filepath to which the XML file will be saved.
name
The name of the skin (for example "The Purple Skin"). This is used by the Properties Builder.
previewImage
The preview image of the skin. This is used by the Properties Builder.

Remarks

This method saves the current HtmlBox configuration as an XML skin file. Load the skin by using the HtmlBox.LoadSkin method. For more information about creating a using skins, see Using Skins.

This method DOES NOT save information about individual toolbar items. For example, if you have changed the background color of a SINGLE button, this will not be persisted to the skin file. You must use the global properties for controlling style (such as the HtmlBox.ButtonStyle property of HtmlBox).

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace | HtmlBox.SaveSkin Overload List


HtmlBox Events

The events of the HtmlBox class are listed below. For a complete list of HtmlBox class members, see the HtmlBox Members topic.

Public Instance Events

AutoSave | Raised after a specified interval or keystroke count.
ContextMenuChanged (inherited from LiveLabel) |
DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
DoubleClick (inherited from LiveLabel) |
FileUpload | Raised after an attempted file upload.
GotFocus (inherited from LiveLabel) |
HelpRequested (inherited from LiveLabel) |
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
KeyDown (inherited from LiveLabel) |
KeyPress (inherited from LiveLabel) |
KeyUp (inherited from LiveLabel) |
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
LocationClick (inherited from LiveLabel) |
LostFocus (inherited from LiveLabel) |
MouseDown (inherited from LiveLabel) |
MouseEnter (inherited from LiveLabel) |
MouseLeave (inherited from LiveLabel) |
MouseUp (inherited from LiveLabel) |
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
TextChanged | Occurs when the content of the HtmlBox is changed upon server postback.
ToolbarButtonClick | Raised when a postback is raised by a toolbar button click.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


AutoSave Event

HtmlBox.AutoSave Event

Raised after a specified interval or keystroke count.

[Visual Basic]
Public Event AutoSave As AutoSaveEventHandler
[C#]
public event AutoSaveEventHandler AutoSave;
[C++]
public: __event AutoSaveEventHandler* AutoSave;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The AutoSave event fires periodically, according to a specified interval or keystroke count. Set AutoSaveInterval to cause the event to fire according to a specified time interval. Set AutoSaveFrequency to cause the event to fire according to a specified number of keystrokes. Both properties can be simultaneously set. This event provides the perfect opportunity for frequently saving the state of the HtmlBox (for example, in a database or to disk).

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


FileUpload Event

HtmlBox.FileUpload Event

Raised after an attempted file upload.

[Visual Basic]
Public Event FileUpload As FileUploadEventHandler
[C#]
public event FileUploadEventHandler FileUpload;
[C++]
public: __event FileUploadEventHandler* FileUpload;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type FileUploadEventArgs containing data related to this event. The following FileUploadEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the exception, if any, that occurred during a file upload.
FilePath | Gets the path of the file as sent by the browser.
SavedFilePath | Gets the path of the file as saved on the server.
UserMessage | Gets or sets the message displayed to the user after a file upload.

Remarks

The FileUpload event fires after an attempted file upload. A FileUploadEventArgs object will be passed into this event.

This object includes an FileUploadEventArgs.Exception property that will contain any exceptions that occurred during the upload, or null if the upload was successful. The FileUploadEventArgs.FilePath property will contain the path of the file as sent by the browser. The FileUploadEventArgs.SavedFilePath property will contain the path of the file as saved on the server. The FileUploadEventArgs.UserMessage property is the message presented to the user after the upload.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


TextChanged Event

HtmlBox.TextChanged Event

Occurs when the content of the HtmlBox is changed upon server postback.

[Visual Basic]
Public Event TextChanged As EventHandler
[C#]
public event EventHandler TextChanged;
[C++]
public: __event EventHandler* TextChanged;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The control must have viewstate enabled for the HtmlBox.TextChanged event to work correctly.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


ToolbarButtonClick Event

HtmlBox.ToolbarButtonClick Event

Raised when a postback is raised by a toolbar button click.

[Visual Basic]
Public Event ToolbarButtonClick As ToolbarButtonClickEventHandler
[C#]
public event ToolbarButtonClickEventHandler ToolbarButtonClick;
[C++]
public: __event ToolbarButtonClickEventHandler* ToolbarButtonClick;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type ToolbarButtonEventArgs containing data related to this event. The following ToolbarButtonEventArgs property provides information specific to this event.

Property | Description
Button | Gets the ToolbarButton object responsible for this event.

Remarks

A ToolbarButton can raise a postback if it's ToolbarButton.RaisePostback property is true. When this occurs, the ToolbarButtonClick will be raised. A ToolbarButtonClickEventArgs object will be passed into this event. This object will include a ToolbarButtonClickEventArgs.Button property which encapsulates the button which was clicked.

See Also

HtmlBox Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxDialog Class

Represents a dialog.

For a list of all members of this type, see HtmlBoxDialog Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.HtmlBoxDialog

[Visual Basic]
Public Class HtmlBoxDialog
    Inherits BaseChildControl
[C#]
public class HtmlBoxDialog : BaseChildControl
[C++]
public __gc class HtmlBoxDialog : public BaseChildControl
[JScript]
public class HtmlBoxDialog extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A single instance of HtmlBoxDialog object is tied to each instance of ToolbarDialogButton on the toolbar. When a button of this type is clicked, the dialog represented by the HtmlBoxDialog objectis displayed.

There are two scenarios for creating/using dialogs:

  • Predefined dialogs: These types of dialogs are tied to predefined toolbar buttons. For example, if you add a ToolbarDialogButton with a ToolbarDialogButton.Type == ToolbarDialogButtonType.FindReplace, a predefined find/replace HtmlBoxDialog will be tied to the ToolbarDialogButton (and exposed as the ToolbarDialogButton.Dialog property). Typically, you won't want want to modify the actual content of the dialog, but instead would modify the look and feel of the dialog using properties such as BackColor or TitlebarBackColor.
  • Custom dialogs: These types of dialogs are tied to custom toolbar buttons. For example, if you add a ToolbarDialogButton with a ToolbarDialogButton.Type == ToolbarDialogButtonType.Custom, an HtmlBox dialog would be tied to the ToolbarDialogButton (and exposed as the ToolbarDialogButton.Dialog property). However, this dialog would be empty until some content was supplied for the dialog. This is done by using the HtmlBoxDialog.Text property.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlBoxDialog Members | Dart.PowerWEB.TextBox Namespace


HtmlBoxDialog Members

HtmlBoxDialog overview

Public Instance Constructors

HtmlBoxDialog Overloaded. Initializes a new instance of the HtmlBoxDialog class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
Caption | Gets or sets the text that is displayed as the dialog caption.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ExternalFile | Gets or sets the url of an external file containing the content for the dialog.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
InternalDialogID | Not intended to be used by the developer. Gets or sets the ID of the dialog that will be displayed when the ToolbarDialogButton is clicked.
InternalDialogType | Not intended to be used by the developer. Gets or sets the type of internally rendered dialog that will be displayed when the ToolbarDialogButton is clicked.
LaunchX | Gets or sets a the value of the X-coordinate where the dialog is launched.
LaunchY | Gets or sets a the value of the Y-coordinate where the dialog is launched.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Strings | Gets or sets a collection of strings used in the dialog.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the content of the dialog.
TitlebarBackColor | Gets or sets the background color of the titlebar.
TitlebarFontName | Gets or sets the font name of the text on the titlebar.
TitlebarFontSize | Gets or sets the font size of the text on the titlebar.
TitlebarForeColor | Gets or sets the font color of the text on the titlebar.
TitlebarImageName | Gets or sets the image name of the titlebar image.
TitlebarXImageName | Gets or sets the image name of the titlebar X (close window) image.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the display type of the HtmlBox dialog.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
MergeWith | Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag | Overidden. Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxDialog Constructor

Creates and initializes a default instance of HtmlBoxDialog.

Overload List

Creates and initializes a default instance of HtmlBoxDialog.

[Visual Basic] Public Sub New()
[C#] public HtmlBoxDialog();
[C++] public: HtmlBoxDialog();
[JScript] public function HtmlBoxDialog();

Creates and initializes a default instance of HtmlBoxDialog.

[Visual Basic] Public Sub New(ByVal String)
[C#] public HtmlBoxDialog(string);
[C++] public: HtmlBoxDialog(String*);
[JScript] public function HtmlBoxDialog(String);

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxDialog Constructor ()

Creates and initializes a default instance of HtmlBoxDialog.

[Visual Basic]
Public Sub New()
[C#]
public HtmlBoxDialog();
[C++]
public: HtmlBoxDialog();
[JScript]
public function HtmlBoxDialog();

Remarks

Use this constructor to create and initialize a new instance of the HtmlBoxDialog class.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace | HtmlBoxDialog Constructor Overload List


HtmlBoxDialog Constructor (String)

Creates and initializes a default instance of HtmlBoxDialog.

[Visual Basic]
Public Sub New( _
   ByVal dialogText As String _
)
[C#]
public HtmlBoxDialog(
   string dialogText
);
[C++]
public: HtmlBoxDialog(
   String* dialogText
);
[JScript]
public function HtmlBoxDialog(
   String dialogText
);

Remarks

Use this constructor to create and initialize a new instance of the HtmlBoxDialog class.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace | HtmlBoxDialog Constructor Overload List


HtmlBoxDialog Properties

The properties of the HtmlBoxDialog class are listed below. For a complete list of HtmlBoxDialog class members, see the HtmlBoxDialog Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
Caption | Gets or sets the text that is displayed as the dialog caption.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ExternalFile | Gets or sets the url of an external file containing the content for the dialog.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
InternalDialogID | Not intended to be used by the developer. Gets or sets the ID of the dialog that will be displayed when the ToolbarDialogButton is clicked.
InternalDialogType | Not intended to be used by the developer. Gets or sets the type of internally rendered dialog that will be displayed when the ToolbarDialogButton is clicked.
LaunchX | Gets or sets a the value of the X-coordinate where the dialog is launched.
LaunchY | Gets or sets a the value of the Y-coordinate where the dialog is launched.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Strings | Gets or sets a collection of strings used in the dialog.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the content of the dialog.
TitlebarBackColor | Gets or sets the background color of the titlebar.
TitlebarFontName | Gets or sets the font name of the text on the titlebar.
TitlebarFontSize | Gets or sets the font size of the text on the titlebar.
TitlebarForeColor | Gets or sets the font color of the text on the titlebar.
TitlebarImageName | Gets or sets the image name of the titlebar image.
TitlebarXImageName | Gets or sets the image name of the titlebar X (close window) image.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the display type of the HtmlBox dialog.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


Caption Property

HtmlBoxDialog.Caption Property

Gets or sets the text that is displayed as the dialog caption.

[Visual Basic]
Public Property Caption As String
[C#]
public string Caption { get; set; }
[C++]
public: __property String* get_Caption();
public: __property void set_Caption(String* );
[JScript]
public function get Caption() : String
public function set Caption(String);

Property Value

A string representing the text that is displayed as the dialog caption.

Remarks

This property is only used when the HtmlBoxDialog.Type = DialogType.InnerWindowWithTitlebar.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


Controls Property

HtmlBoxDialog.Controls Property

Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.

[Visual Basic]
Overrides Public Property ReadOnly Controls As ControlCollection
[C#]
public override ControlCollection Controls { get; }
[C++]
public: __property ControlCollection* get_Controls();
[JScript]
public override function get Controls() : ControlCollection

Property Value

The collection of child controls for the specified server control.

Remarks

On an ASP.NET page, when controls are added declaratively between the opening and closing tags of a server control, ASP.NET automatically adds the controls to the containing server control's ControlCollection. Any HTML tags or text strings that are not processed on the server are treated as LiteralControl objects. These are added to the collection like other server controls.

The Controls property allows you programmatic access to the instance of the ControlCollection class for any server control. You can add controls to the collection, remove controls from the collection, or iterate through the server controls in the collection.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


ExternalFile Property

HtmlBoxDialog.ExternalFile Property

Gets or sets the url of an external file containing the content for the dialog.

[Visual Basic]
Public Property ExternalFile As String
[C#]
public string ExternalFile { get; set; }
[C++]
public: __property String* get_ExternalFile();
public: __property void set_ExternalFile(String* );
[JScript]
public function get ExternalFile() : String
public function set ExternalFile(String);

Property Value

A string representing a url of an external file containing the content for the dialog.

Remarks

This property is not used by any of the predefined dialogs used by the HtmlBox. However, you may set this property if you would like to supply the content for the dialog from a file on the server. If this is the case, the dialog will launch in a modal dialog box that you will not be able to modify the titlebar properties (such as TitlebarBackColor) of.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


InternalDialogID Property

HtmlBoxDialog.InternalDialogID Property

Not intended to be used by the developer. Gets or sets the ID of the dialog that will be displayed when the ToolbarDialogButton is clicked.

[Visual Basic]
Public Property InternalDialogID As String
[C#]
public string InternalDialogID { get; set; }
[C++]
public: __property String* get_InternalDialogID();
public: __property void set_InternalDialogID(String* );
[JScript]
public function get InternalDialogID() : String
public function set InternalDialogID(String);

Remarks

This value is automatically assigned by the control. Do not change the value.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


InternalDialogType Property

HtmlBoxDialog.InternalDialogType Property

Not intended to be used by the developer. Gets or sets the type of internally rendered dialog that will be displayed when the ToolbarDialogButton is clicked.

[Visual Basic]
Public Property InternalDialogType As InternalDialogType
[C#]
public InternalDialogType InternalDialogType { get; set; }
[C++]
public: __property InternalDialogType get_InternalDialogType();
public: __property void set_InternalDialogType(InternalDialogType );
[JScript]
public function get InternalDialogType() : InternalDialogType
public function set InternalDialogType(InternalDialogType);

Remarks

This value is automatically assigned by the control. Do not change the value.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


LaunchX Property

HtmlBoxDialog.LaunchX Property

Gets or sets a the value of the X-coordinate where the dialog is launched.

[Visual Basic]
Public Property LaunchX As String
[C#]
public string LaunchX { get; set; }
[C++]
public: __property String* get_LaunchX();
public: __property void set_LaunchX(String* );
[JScript]
public function get LaunchX() : String
public function set LaunchX(String);

Property Value

A string representing the value of the X-coordinate where the dialog is launched).

Remarks

This value can either be a absolute screen coordinate (such as "150", specifying that the dialog appears 150 pixels from the left side of the screen) or a JavaScript variable or function which is evaluated (such as "event.clientX", specifying that the dialog will launch at the X-coordinate of the calling event.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


LaunchY Property

HtmlBoxDialog.LaunchY Property

Gets or sets a the value of the Y-coordinate where the dialog is launched.

[Visual Basic]
Public Property LaunchY As String
[C#]
public string LaunchY { get; set; }
[C++]
public: __property String* get_LaunchY();
public: __property void set_LaunchY(String* );
[JScript]
public function get LaunchY() : String
public function set LaunchY(String);

Property Value

A string representing the value of the Y-coordinate where the dialog is launched).

Remarks

This value can either be a absolute screen coordinate (such as "150", specifying that the dialog appears 150 pixels from the top of the screen) or a JavaScript variable or function which is evaluated (such as "event.clientY", specifying that the dialog will launch at the Y-coordinate of the calling event.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


Strings Property

HtmlBoxDialog.Strings Property

Gets or sets a collection of strings used in the dialog.

[Visual Basic]
Public Property Strings As StringValueCollection
[C#]
public StringValueCollection Strings { get; set; }
[C++]
public: __property StringValueCollection* get_Strings();
public: __property void set_Strings(StringValueCollection* );
[JScript]
public function get Strings() : StringValueCollection
public function set Strings(StringValueCollection);

Property Value

A StringValueCollection collection representing the strings to be used in the dialog.

Remarks

For predefined dialogs, this collection will contain a list of strings used within the dialog. For custom dialogs, this collection is not used. This collection is useful if you wish to modify the strings used within predefined dialogs. For example, if you would like to change the text on the "Cancel" button to say "Close", you could do the following:

MyDialogButton.Dialog.Strings["Cancel"] = "Close";

This is especially useful in scenarios where you need to localize the HtmlBox to a non-English language. See the topic Localizing the HtmlBox for more information and for a list of keys used for each Strings collection associated with each predefined dialog.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


Text Property

HtmlBoxDialog.Text Property

Gets or sets the content of the dialog.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

A string representing the content of the dialog.

Remarks

This property is not used by any predefined dialogs. Use this property to provide the content for custom dialog implementations.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


TitlebarBackColor Property

HtmlBoxDialog.TitlebarBackColor Property

Gets or sets the background color of the titlebar.

[Visual Basic]
Overridable Public Property TitlebarBackColor As Color
[C#]
public virtual Color TitlebarBackColor { get; set; }
[C++]
public: virtual __property Color get_TitlebarBackColor();
public: virtual __property void set_TitlebarBackColor(Color );
[JScript]
public virtual function get TitlebarBackColor() : Color
public virtual function set TitlebarBackColor(Color);

Property Value

A System.Drawing.Color value specifying the color of the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


TitlebarFontName Property

HtmlBoxDialog.TitlebarFontName Property

Gets or sets the font name of the text on the titlebar.

[Visual Basic]
Overridable Public Property TitlebarFontName As String
[C#]
public virtual string TitlebarFontName { get; set; }
[C++]
public: virtual __property String* get_TitlebarFontName();
public: virtual __property void set_TitlebarFontName(String* );
[JScript]
public virtual function get TitlebarFontName() : String
public virtual function set TitlebarFontName(String);

Property Value

A string value specifying the font name of the text on the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


TitlebarFontSize Property

HtmlBoxDialog.TitlebarFontSize Property

Gets or sets the font size of the text on the titlebar.

[Visual Basic]
Overridable Public Property TitlebarFontSize As FontUnit
[C#]
public virtual FontUnit TitlebarFontSize { get; set; }
[C++]
public: virtual __property FontUnit get_TitlebarFontSize();
public: virtual __property void set_TitlebarFontSize(FontUnit );
[JScript]
public virtual function get TitlebarFontSize() : FontUnit
public virtual function set TitlebarFontSize(FontUnit);

Property Value

A FontUnit value specifying the font size of the on the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


TitlebarForeColor Property

HtmlBoxDialog.TitlebarForeColor Property

Gets or sets the font color of the text on the titlebar.

[Visual Basic]
Overridable Public Property TitlebarForeColor As Color
[C#]
public virtual Color TitlebarForeColor { get; set; }
[C++]
public: virtual __property Color get_TitlebarForeColor();
public: virtual __property void set_TitlebarForeColor(Color );
[JScript]
public virtual function get TitlebarForeColor() : Color
public virtual function set TitlebarForeColor(Color);

Property Value

A System.Drawing.Color value specifying the font color of the on the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


TitlebarImageName Property

HtmlBoxDialog.TitlebarImageName Property

Gets or sets the image name of the titlebar image.

[Visual Basic]
Public Property TitlebarImageName As String
[C#]
public string TitlebarImageName { get; set; }
[C++]
public: __property String* get_TitlebarImageName();
public: __property void set_TitlebarImageName(String* );
[JScript]
public function get TitlebarImageName() : String
public function set TitlebarImageName(String);

Property Value

A string representing the image name of the titlebar image.

Remarks

This property supplies an image name which is used as a dialog "icon" in the upper left corner of the dialog. This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


TitlebarXImageName Property

HtmlBoxDialog.TitlebarXImageName Property

Gets or sets the image name of the titlebar X (close window) image.

[Visual Basic]
Public Property TitlebarXImageName As String
[C#]
public string TitlebarXImageName { get; set; }
[C++]
public: __property String* get_TitlebarXImageName();
public: __property void set_TitlebarXImageName(String* );
[JScript]
public function get TitlebarXImageName() : String
public function set TitlebarXImageName(String);

Property Value

A string representing the image name of the titlebar X (close window) image.

Remarks

This property supplies an image name which is used as a close window image in the upper right corner of the dialog. This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


Type Property

HtmlBoxDialog.Type Property

Gets or sets the display type of the HtmlBox dialog.

[Visual Basic]
Public Property Type As DialogType
[C#]
public DialogType Type { get; set; }
[C++]
public: __property DialogType get_Type();
public: __property void set_Type(DialogType );
[JScript]
public function get Type() : DialogType
public function set Type(DialogType);

Property Value

A DialogType value specifying the display type of the HtmlBox dialog.

Remarks

If this property is DialogType.InternalWindowWithTitlebar, the dialog will be a "Windows-style" dialog, complete with titlebar. This type of dialog is draggable with the mouse. If this property is InternalWindow, the dialog will be a titlebar-less panel which is non-draggable. This property only needs to be set for custom dialog implementations, as in predefined dialogs this property will already be configured to the appropriate value for the dialog.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxDialog Methods

The methods of the HtmlBoxDialog class are listed below. For a complete list of HtmlBoxDialog class members, see the HtmlBoxDialog Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
MergeWith | Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag | Overidden. Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


MergeWith Method

HtmlBoxDialog.MergeWith Method

Combines the style properties of the specified Style with the instance of the Style class that this method is called from.

[Visual Basic]
Overridable Public Sub MergeWith( _
   ByVal s As Style _
)
[C#]
public virtual void MergeWith(
   Style s
);
[C++]
public: virtual void MergeWith(
   Style* s
);
[JScript]
public virtual function MergeWith(
   Style s
);

Parameters

s
A style type that represents the style to combine.

Remarks

Use the MergeWith method to combine the style properties of the specified Style with the instance of the Style class that this method is called from.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


RenderEndTag Method

HtmlBoxDialog.RenderEndTag Method

Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.

[Visual Basic]
Overrides Public Sub RenderEndTag( _
   ByVal writer As HtmlTextWriter _
)
[C#]
public override void RenderEndTag(
   HtmlTextWriter writer
);
[C++]
public: void RenderEndTag(
   HtmlTextWriter* writer
);
[JScript]
public override function RenderEndTag(
   HtmlTextWriter writer
);

Parameters

writer
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.

Remarks

This is made public so other controls can render multiple controls in between the opening and closing tags of a Web server control. This method is not intended to be used from within your code.

See Also

HtmlBoxDialog Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenu Class

Represents a menu.

For a list of all members of this type, see HtmlBoxMenu Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.HtmlBoxMenu

[Visual Basic]
Public Class HtmlBoxMenu
    Inherits BaseChildControl
[C#]
public class HtmlBoxMenu : BaseChildControl
[C++]
public __gc class HtmlBoxMenu : public BaseChildControl
[JScript]
public class HtmlBoxMenu extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A single instance of HtmlBoxMenu object is tied to each instance of ToolbarMenuButton on the toolbar. When a button of this type is clicked, the menu represented by the HtmlBoxMenu object is displayed. In addition, another instance of HtmlBoxMenu is used to represent the right-click menu (exposed by the HtmlBox.RightClickMenu property) which is displayed when the user right-clicks on the HtmlBox.

There are two scenarios for creating/using menus:

  • Predefined menus: These types of menus are either tied to predefined toolbar buttons or are used as the right-click menu. For example, if you add a ToolbarDialogButton with a ToolbarMenuButton.Type == ToolbarMenuButtonType.InsertTable, a predefined table formatting HtmlBoxMenu will be tied to the ToolbarMenuButton (and exposed as the ToolbarMenuButton.Menu property). Typically, you won't want want to modify the actual content of the menu, but instead would modify the look and feel of the menu using properties such as BackColor or ImageColumnColor.
  • Custom menus: These types of menus are tied to custom toolbar buttons. For example, if you add a ToolbarMenuButton with a ToolbarMenuButton.Type == ToolbarMenuButtonType.Custom, an HtmlBoxMenu would be tied to the ToolbarMenuButton (and exposed as the ToolbarMenuButton.Menu property). However, this menu would be empty until some content was supplied for the menu. This is done by adding items to the ToolbarMenuButton.Menu.Items collection.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlBoxMenu Members | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenu Members

HtmlBoxMenu overview

Public Instance Constructors

HtmlBoxMenu Constructor Creates and initializes a default instance of HtmlBoxMenu.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor | Overidden. Gets or sets the foreground color (typically the color of the text) of the control.
Height | Overidden. Gets or sets the height of the control.
ID | Overidden. Gets or sets the programmatic identifier assigned to the server control.
ImageColumnColor | Gets or sets the value of the color used for the image column.
Items | Gets a HtmlBoxMenuItemCollection which manages the HtmlBoxMenuItem objects for this HtmlBoxMenu.
LaunchX | Gets or sets a the value of the X-coordinate where the menu is launched.
LaunchY | Gets or sets a the value of the Y-coordinate where the menu is launched.
MouseOverColor | Gets or sets the color that is displayed when the mouse is over an item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width | Overidden. Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenu Constructor

Creates and initializes a default instance of HtmlBoxMenu.

[Visual Basic]
Public Sub New()
[C#]
public HtmlBoxMenu();
[C++]
public: HtmlBoxMenu();
[JScript]
public function HtmlBoxMenu();

Remarks

Use this constructor to create and initialize a new instance of the HtmlBoxMenu class.

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenu Properties

The properties of the HtmlBoxMenu class are listed below. For a complete list of HtmlBoxMenu class members, see the HtmlBoxMenu Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor | Overidden. Gets or sets the foreground color (typically the color of the text) of the control.
Height | Overidden. Gets or sets the height of the control.
ID | Overidden. Gets or sets the programmatic identifier assigned to the server control.
ImageColumnColor | Gets or sets the value of the color used for the image column.
Items | Gets a HtmlBoxMenuItemCollection which manages the HtmlBoxMenuItem objects for this HtmlBoxMenu.
LaunchX | Gets or sets a the value of the X-coordinate where the menu is launched.
LaunchY | Gets or sets a the value of the Y-coordinate where the menu is launched.
MouseOverColor | Gets or sets the color that is displayed when the mouse is over an item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width | Overidden. Gets or sets the width of the control.

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


BorderStyle Property

HtmlBoxMenu.BorderStyle Property

Gets or sets the border style of the control.

[Visual Basic]
Overrides Public Property BorderStyle As BorderStyle
[C#]
public override BorderStyle BorderStyle { get; set; }
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle );
[JScript]
public override function get BorderStyle() : BorderStyle
public override function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration values. The default is NotSet.

Remarks

Use the BorderStyle property to specify the border style for the control. This property is set using one of the BorderStyle enumeration values.

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


ForeColor Property

HtmlBoxMenu.ForeColor Property

Gets or sets the foreground color (typically the color of the text) of the control.

[Visual Basic]
Overrides Public Property ForeColor As Color
[C#]
public override Color ForeColor { get; set; }
[C++]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(Color );
[JScript]
public override function get ForeColor() : Color
public override function set ForeColor(Color);

Property Value

A System.Drawing.Color that represents the foreground color of the control. The default is Color.Empty.

Remarks

Use the ForeColor property to specify the foreground color of the control. The foreground color is usually the color of the text. This property will render on browsers earlier than Microsoft Internet

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


Height Property

HtmlBoxMenu.Height Property

Gets or sets the height of the control.

[Visual Basic]
Overrides Public Property Height As Unit
[C#]
public override Unit Height { get; set; }
[C++]
public: __property Unit get_Height();
public: __property void set_Height(Unit );
[JScript]
public override function get Height() : Unit
public override function set Height(Unit);

Property Value

A Unit that represents the height of the control. The default is Unit.Empty.

Remarks

Use the Height property to specify the height of the control

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


ID Property

HtmlBoxMenu.ID Property

Gets or sets the programmatic identifier assigned to the server control.

[Visual Basic]
Overrides Public Property ID As String
[C#]
public override string ID { get; set; }
[C++]
public: __property String* get_ID();
public: __property void set_ID(String* );
[JScript]
public override function get ID() : String
public override function set ID(String);

Property Value

The programmatic identifier assigned to the control.

Remarks

PowerWEB will automatically assign values to this property on initialization. Do not modify the value of this property.

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


ImageColumnColor Property

HtmlBoxMenu.ImageColumnColor Property

Gets or sets the value of the color used for the image column.

[Visual Basic]
Overridable Public Property ImageColumnColor As Color
[C#]
public virtual Color ImageColumnColor { get; set; }
[C++]
public: virtual __property Color get_ImageColumnColor();
public: virtual __property void set_ImageColumnColor(Color );
[JScript]
public virtual function get ImageColumnColor() : Color
public virtual function set ImageColumnColor(Color);

Property Value

A System.Drawing.Color value specifying the color used for the image column.

Remarks

Each menu item is made up of two entities, the menu item text (such as "Table Properties") and the menu item image (such as a table properties icon) arranged in two columns. This property sets the value of the column that displays the images.

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


Items Property

HtmlBoxMenu.Items Property

Gets a HtmlBoxMenuItemCollection which manages the HtmlBoxMenuItem objects for this HtmlBoxMenu.

[Visual Basic]
Public Property ReadOnly Items As HtmlBoxMenuItemCollection
[C#]
public HtmlBoxMenuItemCollection Items { get; }
[C++]
public: __property HtmlBoxMenuItemCollection* get_Items();
[JScript]
public function get Items() : HtmlBoxMenuItemCollection

Property Value

A HtmlBoxMenuItemCollection which manages the HtmlBoxMenuItem objects for this HtmlBoxMenu.

Remarks

It is not recommended to modify this collection when using predefined HtmlBoxMenu controls (such as in the case of an "Insert Table" ToolbarMenuButton or the HtmlBox.RightClickMenu. Only use this property for custom toolbar menu button implementations (when ToolbarMenuButton.Type = ToolbarMenuButtonType.Custom). In this case, the collection will be empty. Add new ToolbarMenuItem objects using HtmlBoxMenuItemCollection.Add.

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


LaunchX Property

HtmlBoxMenu.LaunchX Property

Gets or sets a the value of the X-coordinate where the menu is launched.

[Visual Basic]
Public Property LaunchX As String
[C#]
public string LaunchX { get; set; }
[C++]
public: __property String* get_LaunchX();
public: __property void set_LaunchX(String* );
[JScript]
public function get LaunchX() : String
public function set LaunchX(String);

Property Value

A string representing the value of the X-coordinate where the menu is launched.

Remarks

This value can either be a absolute screen coordinate (such as "150", specifying that the menu appears 150 pixels from the left side of the screen) or a JavaScript variable or function which is evaluated (such as "event.clientX", specifying that the menu will launch at the X-coordinate of the calling event).

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


LaunchY Property

HtmlBoxMenu.LaunchY Property

Gets or sets a the value of the Y-coordinate where the menu is launched.

[Visual Basic]
Public Property LaunchY As String
[C#]
public string LaunchY { get; set; }
[C++]
public: __property String* get_LaunchY();
public: __property void set_LaunchY(String* );
[JScript]
public function get LaunchY() : String
public function set LaunchY(String);

Property Value

A string representing the value of the Y-coordinate where the menu is launched.

Remarks

This value can either be a absolute screen coordinate (such as "150", specifying that the dialog appears 150 pixels from the top of the screen) or a JavaScript variable or function which is evaluated (such as "event.clientY", specifying that the menu will launch at the Y-coordinate of the calling event).

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


MouseOverColor Property

HtmlBoxMenu.MouseOverColor Property

Gets or sets the color that is displayed when the mouse is over an item.

[Visual Basic]
Overridable Public Property MouseOverColor As Color
[C#]
public virtual Color MouseOverColor { get; set; }
[C++]
public: virtual __property Color get_MouseOverColor();
public: virtual __property void set_MouseOverColor(Color );
[JScript]
public virtual function get MouseOverColor() : Color
public virtual function set MouseOverColor(Color);

Property Value

A System.Drawing.Color value specifying the color that is displayed when the mouse is over an item.

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


Width Property

HtmlBoxMenu.Width Property

Gets or sets the width of the control.

[Visual Basic]
Overrides Public Property Width As Unit
[C#]
public override Unit Width { get; set; }
[C++]
public: __property Unit get_Width();
public: __property void set_Width(Unit );
[JScript]
public override function get Width() : Unit
public override function set Width(Unit);

Property Value

A Unit that represents the width of the control. The default is Unit.Empty.

Remarks

Use the Width property to specify the width of the control

See Also

HtmlBoxMenu Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItem Class

Represents a single menu item on an HtmlBoxMenu.

For a list of all members of this type, see HtmlBoxMenuItem Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.HtmlBoxMenuItem

[Visual Basic]
Public Class HtmlBoxMenuItem
    Inherits BaseChildControl
[C#]
public class HtmlBoxMenuItem : BaseChildControl
[C++]
public __gc class HtmlBoxMenuItem : public BaseChildControl
[JScript]
public class HtmlBoxMenuItem extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

There are two types of HtmlBoxMenuItem objects. The standard type calls a client-side JavaScript function. Create an HtmlBoxMenuItem of this type by using the HtmlBoxMenuItem(string,string,string) constructor. The dialog type launches an HtmlBoxDialog object. Create an HtmlBoxMenuItem of this type by using the HtmlBoxMenuItem(string,string,HtmlBoxDialog constructor).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlBoxMenuItem Members | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItem Members

HtmlBoxMenuItem overview

Public Instance Constructors

HtmlBoxMenuItem Overloaded. Initializes a new instance of the HtmlBoxMenuItem class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Dialog | Gets or sets the HtmlBoxDialog to launch when this item is chosen.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
ImageName | Gets or sets the name of the image to display for this menu item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
OnClickFunctionCode | Gets or sets the code block associated with this object.
OnClickFunctionName | Gets or sets the name of the client-side function to call when the item is chosen.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text to display for this menu item.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItem Constructor

Creates and initializes an instance of HtmlBoxMenu.

Overload List

Creates and initializes an instance of HtmlBoxMenu.

[Visual Basic] Public Sub New()
[C#] public HtmlBoxMenuItem();
[C++] public: HtmlBoxMenuItem();
[JScript] public function HtmlBoxMenuItem();

Creates and initializes an instance of HtmlBoxMenu which launches an HtmlBoxDialog.

[Visual Basic] Public Sub New(ByVal String,ByVal String,ByVal HtmlBoxDialog)
[C#] public HtmlBoxMenuItem(string,string,HtmlBoxDialog);
[C++] public: HtmlBoxMenuItem(String*,String*,HtmlBoxDialog*);
[JScript] public function HtmlBoxMenuItem(String,String,HtmlBoxDialog);

Creates and initializes an instance of HtmlBoxMenu which calls a client-side JavaScript function.

[Visual Basic] Public Sub New(ByVal String,ByVal String,ByVal String)
[C#] public HtmlBoxMenuItem(string,string,string);
[C++] public: HtmlBoxMenuItem(String*,String*,String*);
[JScript] public function HtmlBoxMenuItem(String,String,String);

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItem Constructor ()

Creates and initializes an instance of HtmlBoxMenu.

[Visual Basic]
Public Sub New()
[C#]
public HtmlBoxMenuItem();
[C++]
public: HtmlBoxMenuItem();
[JScript]
public function HtmlBoxMenuItem();

Remarks

Use this constructor to create and initialize a new instance of the HtmlBoxMenuItem class.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace | HtmlBoxMenuItem Constructor Overload List


HtmlBoxMenuItem Constructor (String, String, String)

Creates and initializes an instance of HtmlBoxMenu which calls a client-side JavaScript function.

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal imageName As String, _
   ByVal onClickFunctionName As String _
)
[C#]
public HtmlBoxMenuItem(
   string text,
   string imageName,
   string onClickFunctionName
);
[C++]
public: HtmlBoxMenuItem(
   String* text,
   String* imageName,
   String* onClickFunctionName
);
[JScript]
public function HtmlBoxMenuItem(
   String text,
   String imageName,
   String onClickFunctionName
);

Remarks

Use this constructor to create and initialize a new instance of the HtmlBoxMenuItem class.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace | HtmlBoxMenuItem Constructor Overload List


HtmlBoxMenuItem Constructor (String, String, HtmlBoxDialog)

Creates and initializes an instance of HtmlBoxMenu which launches an HtmlBoxDialog.

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal imageName As String, _
   ByVal dialog As HtmlBoxDialog _
)
[C#]
public HtmlBoxMenuItem(
   string text,
   string imageName,
   HtmlBoxDialog dialog
);
[C++]
public: HtmlBoxMenuItem(
   String* text,
   String* imageName,
   HtmlBoxDialog* dialog
);
[JScript]
public function HtmlBoxMenuItem(
   String text,
   String imageName,
   HtmlBoxDialog dialog
);

Remarks

Use this constructor to create and initialize a new instance of the HtmlBoxMenuItem class.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace | HtmlBoxMenuItem Constructor Overload List


HtmlBoxMenuItem Properties

The properties of the HtmlBoxMenuItem class are listed below. For a complete list of HtmlBoxMenuItem class members, see the HtmlBoxMenuItem Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Dialog | Gets or sets the HtmlBoxDialog to launch when this item is chosen.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
ImageName | Gets or sets the name of the image to display for this menu item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
OnClickFunctionCode | Gets or sets the code block associated with this object.
OnClickFunctionName | Gets or sets the name of the client-side function to call when the item is chosen.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text to display for this menu item.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


Dialog Property

HtmlBoxMenuItem.Dialog Property

Gets or sets the HtmlBoxDialog to launch when this item is chosen.

[Visual Basic]
Public Property Dialog As HtmlBoxDialog
[C#]
public HtmlBoxDialog Dialog { get; set; }
[C++]
public: __property HtmlBoxDialog* get_Dialog();
public: __property void set_Dialog(HtmlBoxDialog* );
[JScript]
public function get Dialog() : HtmlBoxDialog
public function set Dialog(HtmlBoxDialog);

Property Value

An HtmlBoxDialog object representing the dialog to launch when this item is chosen.

Remarks

This property must be set to a already created and initialized HtmlBoxDialog object if you want a dialog to launch when the item is chosen. If you wish to simply call a JavaScript function when the item is chosen, use the HtmlBoxMenuItem.OnClickFunctionName property.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


ImageName Property

HtmlBoxMenuItem.ImageName Property

Gets or sets the name of the image to display for this menu item.

[Visual Basic]
Public Property ImageName As String
[C#]
public string ImageName { get; set; }
[C++]
public: __property String* get_ImageName();
public: __property void set_ImageName(String* );
[JScript]
public function get ImageName() : String
public function set ImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


OnClickFunctionCode Property

HtmlBoxMenuItem.OnClickFunctionCode Property

Gets or sets the code block associated with this object.

[Visual Basic]
Public Property OnClickFunctionCode As String
[C#]
public string OnClickFunctionCode { get; set; }
[C++]
public: __property String* get_OnClickFunctionCode();
public: __property void set_OnClickFunctionCode(String* );
[JScript]
public function get OnClickFunctionCode() : String
public function set OnClickFunctionCode(String);

Remarks

This property is not used by any of the predefined object controls. It is provided as an easy way to associate a code block with an object.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


OnClickFunctionName Property

HtmlBoxMenuItem.OnClickFunctionName Property

Gets or sets the name of the client-side function to call when the item is chosen.

[Visual Basic]
Public Property OnClickFunctionName As String
[C#]
public string OnClickFunctionName { get; set; }
[C++]
public: __property String* get_OnClickFunctionName();
public: __property void set_OnClickFunctionName(String* );
[JScript]
public function get OnClickFunctionName() : String
public function set OnClickFunctionName(String);

Property Value

A string containing the name of the client-side function to call when the item is chosen.

Remarks

To launch a dialog when the item is chosen, use the HtmlBoxMenuItem.Dialog property.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


Text Property

HtmlBoxMenuItem.Text Property

Gets or sets the text to display for this menu item.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

A string containing the text to display for this menu item.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItem Methods

The methods of the HtmlBoxMenuItem class are listed below. For a complete list of HtmlBoxMenuItem class members, see the HtmlBoxMenuItem Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


Clone Method

HtmlBoxMenuItem.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As HtmlBoxMenuItem
[C#]
public HtmlBoxMenuItem Clone();
[C++]
public: HtmlBoxMenuItem* Clone();
[JScript]
public function Clone(): HtmlBoxMenuItem;

Return Value

An HtmlBoxMenuItem object.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

HtmlBoxMenuItem Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItemCollection Class

Represents a collection used to manage HtmlBoxMenuItems.

For a list of all members of this type, see HtmlBoxMenuItemCollection Members.

System.Object
System.Collections.ArrayList
Dart.PowerWEB.TextBox.HtmlBoxMenuItemCollection

[Visual Basic]
Public Class HtmlBoxMenuItemCollection
    Inherits ArrayList
[C#]
public class HtmlBoxMenuItemCollection : ArrayList
[C++]
public __gc class HtmlBoxMenuItemCollection : public ArrayList
[JScript]
public class HtmlBoxMenuItemCollection extends ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

When the HtmlBox creates this collection internally, it provides a reference to the HtmlBoxMenu web control that is the "parent" of this collection. When items are added/removed to the collection, references to these items are also added/removed to the ASP.NET web control heirarchy. For this reason, it is NOT recommended that you create an object of this type within your code. Simply used the instance already created and initialized, and exposed as the HtmlBoxMenu.Items property of the HtmlBoxMenu control.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlBoxMenuItemCollection Members | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItemCollection Members

HtmlBoxMenuItemCollection overview

Public Instance Constructors

HtmlBoxMenuItemCollection Constructor Initializes a new instance of the class that is empty and has the default initial capacity.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
ParentMenu | Gets a reference to the parent HtmlBoxMenu.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add | Overloaded. Adds an object to the end of the collection.
AddRange | Overidden. Adds the elements from the passed collection to the end of the collection.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear | Overidden. Removes all objects from the collection.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert | Overidden. Inserts an element into the collection at the specified index.
InsertRange | Overidden. Inserts the elements of a collection into this collection at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove | Overidden. Removes the first occurrence of a specific object from the collection.
RemoveAt | Overidden. Removes the element at the specified index in the collection.
RemoveRange | Overidden. Removes a range of elements from the collection.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange | Overidden. Copies the elements of a collection over a range of elements in this collection.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItemCollection Constructor

Initializes a new instance of the class that is empty and has the default initial capacity.

[Visual Basic]
Public Sub New()
[C#]
public HtmlBoxMenuItemCollection();
[C++]
public: HtmlBoxMenuItemCollection();
[JScript]
public function HtmlBoxMenuItemCollection();

Remarks

Creates and initializes a default instance of HtmlBoxMenuItemCollection.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItemCollection Properties

The properties of the HtmlBoxMenuItemCollection class are listed below. For a complete list of HtmlBoxMenuItemCollection class members, see the HtmlBoxMenuItemCollection Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
ParentMenu | Gets a reference to the parent HtmlBoxMenu.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


ParentMenu Property

HtmlBoxMenuItemCollection.ParentMenu Property

Gets a reference to the parent HtmlBoxMenu.

[Visual Basic]
Public Property ParentMenu As HtmlBoxMenu
[C#]
public HtmlBoxMenu ParentMenu { get; set; }
[C++]
public: __property HtmlBoxMenu* get_ParentMenu();
public: __property void set_ParentMenu(HtmlBoxMenu* );
[JScript]
public function get ParentMenu() : HtmlBoxMenu
public function set ParentMenu(HtmlBoxMenu);

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxMenuItemCollection Methods

The methods of the HtmlBoxMenuItemCollection class are listed below. For a complete list of HtmlBoxMenuItemCollection class members, see the HtmlBoxMenuItemCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds an object to the end of the collection.
AddRange | Overidden. Adds the elements from the passed collection to the end of the collection.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear | Overidden. Removes all objects from the collection.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert | Overidden. Inserts an element into the collection at the specified index.
InsertRange | Overidden. Inserts the elements of a collection into this collection at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove | Overidden. Removes the first occurrence of a specific object from the collection.
RemoveAt | Overidden. Removes the element at the specified index in the collection.
RemoveRange | Overidden. Removes a range of elements from the collection.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange | Overidden. Copies the elements of a collection over a range of elements in this collection.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


Add Method

HtmlBoxMenuItemCollection.Add Method

Adds an object to the end of the collection.

Overload List

Adds an object to the end of the collection.

[Visual Basic] Public Function Add(ByVal HtmlBoxMenuItem) As Integer
[C#] public int Add(HtmlBoxMenuItem);
[C++] public: int Add(HtmlBoxMenuItem*);
[JScript] public function Add(HtmlBoxMenuItem): int;

Adds an object to the end of the collection.

[Visual Basic] Overrides OverloadsPublic Function Add(ByVal Object) _ Implements IList.Add As Integer
[C#] public override int Add(object);
[C++] public: int Add(Object*);
[JScript] public override function Add(Object): int;

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


Add Method (HtmlBoxMenuItem)

HtmlBoxMenuItemCollection.Add Method (HtmlBoxMenuItem)

Adds an object to the end of the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As HtmlBoxMenuItem _
) As Integer
[C#]
public int Add(
   HtmlBoxMenuItem value
);
[C++]
public: int Add(
   HtmlBoxMenuItem* value
);
[JScript]
public function Add(
   HtmlBoxMenuItem value
): int;

Parameters

value
The object to add to the end of the collection.

Return Value

The index to which value has been added.

Remarks

This method both adds an object to the collection, and adds a reference to this object in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace | HtmlBoxMenuItemCollection.Add Overload List


Add Method (Object)

HtmlBoxMenuItemCollection.Add Method (Object)

Adds an object to the end of the collection.

[Visual Basic]
Overrides  OverloadsPublic Function Add( _
   ByVal value As Object _
) _
    Implements IList.Add As Integer
[C#]
public override int Add(
   object value
);
[C++]
public: int Add(
   Object* value
);
[JScript]
public override function Add(
   Object value
): int;

Parameters

value
The object to add to the end of the collection.

Return Value

The index to which value has been added.

Implements

IList.Add

Remarks

This method both adds an object to the collection, and adds a reference to this object in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace | HtmlBoxMenuItemCollection.Add Overload List


AddRange Method

HtmlBoxMenuItemCollection.AddRange Method

Adds the elements from the passed collection to the end of the collection.

[Visual Basic]
Overrides Public Sub AddRange( _
   ByVal c As ICollection _
)
[C#]
public override void AddRange(
   ICollection c
);
[C++]
public: void AddRange(
   ICollection* c
);
[JScript]
public override function AddRange(
   ICollection c
);

Parameters

c
The collection whose elements should be added to the end of the ArrayList.

Remarks

This method both adds the objects in c to the collection, and adds a reference to these objects in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


Clear Method

HtmlBoxMenuItemCollection.Clear Method

Removes all objects from the collection.

[Visual Basic]
Overrides Public Sub Clear() _
    Implements IList.Clear
[C#]
public override void Clear();
[C++]
public: void Clear();
[JScript]
public override function Clear();

Implements

IList.Clear

Remarks

This method both clears the objects in the collection, and clears references to these objects in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


Insert Method

HtmlBoxMenuItemCollection.Insert Method

Inserts an element into the collection at the specified index.

[Visual Basic]
Overrides Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
) _
    Implements IList.Insert
[C#]
public override void Insert(
   int index,
   object value
);
[C++]
public: void Insert(
   int index,
   Object* value
);
[JScript]
public override function Insert(
   int index,
   Object value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The object to insert.

Implements

IList.Insert

Remarks

This method both inserts an object into the collection, and adds a reference to this object in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


InsertRange Method

HtmlBoxMenuItemCollection.InsertRange Method

Inserts the elements of a collection into this collection at the specified index.

[Visual Basic]
Overrides Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal c As ICollection _
)
[C#]
public override void InsertRange(
   int index,
   ICollection c
);
[C++]
public: void InsertRange(
   int index,
   ICollection* c
);
[JScript]
public override function InsertRange(
   int index,
   ICollection c
);

Parameters

index
The zero-based index at which the new elements should be inserted.
c
The collection whose elements are inserted into this collection.

Remarks

This method both inserts the objects in c into the collection, and adds a reference to these objects in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


Remove Method

HtmlBoxMenuItemCollection.Remove Method

Removes the first occurrence of a specific object from the collection.

[Visual Basic]
Overrides Public Sub Remove( _
   ByVal obj As Object _
) _
    Implements IList.Remove
[C#]
public override void Remove(
   object obj
);
[C++]
public: void Remove(
   Object* obj
);
[JScript]
public override function Remove(
   Object obj
);

Parameters

obj
The object to remove from the collection.

Implements

IList.Remove

Remarks

This method both removes the object from the collection (if found), and removes the reference to this object in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


RemoveAt Method

HtmlBoxMenuItemCollection.RemoveAt Method

Removes the element at the specified index in the collection.

[Visual Basic]
Overrides Public Sub RemoveAt( _
   ByVal index As Integer _
) _
    Implements IList.RemoveAt
[C#]
public override void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
);
[JScript]
public override function RemoveAt(
   int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

IList.RemoveAt

Remarks

This method both removes the object from the collection, and removes the reference to this object in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


RemoveRange Method

HtmlBoxMenuItemCollection.RemoveRange Method

Removes a range of elements from the collection.

[Visual Basic]
Overrides Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void RemoveRange(
   int index,
   int count
);
[C++]
public: void RemoveRange(
   int index,
   int count
);
[JScript]
public override function RemoveRange(
   int index,
   int count
);

Parameters

index
The zero-based starting index of the range of elements to remove.
count
The number of elements to remove.

Remarks

This method both removes the range of objects from the collection, and removes the references to these objects in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


SetRange Method

HtmlBoxMenuItemCollection.SetRange Method

Copies the elements of a collection over a range of elements in this collection.

[Visual Basic]
Overrides Public Sub SetRange( _
   ByVal index As Integer, _
   ByVal c As ICollection _
)
[C#]
public override void SetRange(
   int index,
   ICollection c
);
[C++]
public: void SetRange(
   int index,
   ICollection* c
);
[JScript]
public override function SetRange(
   int index,
   ICollection c
);

Parameters

index
The zero-based index at which to start copying the elements of c.
c
The collection whose elements are copied to this collection.

Remarks

This method both copies the elements of c to this collection, and adds a reference to these objects in the ASP.NET web control heirarchy.

See Also

HtmlBoxMenuItemCollection Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxProgressBar Class

Represents a progress bar displayed while the HtmlBox is loading.

For a list of all members of this type, see HtmlBoxProgressBar Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.HtmlBoxProgressBar

[Visual Basic]
Public Class HtmlBoxProgressBar
    Inherits BaseChildControl
[C#]
public class HtmlBoxProgressBar : BaseChildControl
[C++]
public __gc class HtmlBoxProgressBar : public BaseChildControl
[JScript]
public class HtmlBoxProgressBar extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If the progress bar is enabled (by setting HtmlBoxProgressBar.Display to true, progress will be displayed while the editor is loading. Progress is automatically incremented each time a new graphic is loaded. The default HtmlBox settings are very light graphically and, as such, there is little benefit in using a progress bar. A good scenario for using the progress bar would be in the case of a highly-graphical editor in a low-bandwidth scenario.

The progress bar is only displayed on the initial load. For any subsequent loads resulting from postback the progress bar is not displayed.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlBoxProgressBar Members | Dart.PowerWEB.TextBox Namespace


HtmlBoxProgressBar Members

HtmlBoxProgressBar overview

Public Instance Constructors

HtmlBoxProgressBar Constructor Creates a new instance of HtmlBoxProgressBar.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
BoxBackColor | Gets or sets the color of the "box" surrounding the progress bar.
BoxBorderColor | Gets or sets the border color of the "box" surrounding the progress bar.
BoxBorderStyle | Gets or sets the border style of the "box" surrounding the progress bar.
BoxBorderWidth | Gets or sets the border width of the "box" surrounding the progress bar.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Display | Gets or sets a value which indicates if the progressbar is displayed.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
ImageTimeout | Gets or sets a value which indicates how long to wait for each image to load.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text that is displayed next to the progress bar.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxProgressBar Constructor

Creates a new instance of HtmlBoxProgressBar.

[Visual Basic]
Public Sub New()
[C#]
public HtmlBoxProgressBar();
[C++]
public: HtmlBoxProgressBar();
[JScript]
public function HtmlBoxProgressBar();

Remarks

The default constructor creates and initializes a default instance of HtmlBoxProgressBar.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxProgressBar Properties

The properties of the HtmlBoxProgressBar class are listed below. For a complete list of HtmlBoxProgressBar class members, see the HtmlBoxProgressBar Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
BoxBackColor | Gets or sets the color of the "box" surrounding the progress bar.
BoxBorderColor | Gets or sets the border color of the "box" surrounding the progress bar.
BoxBorderStyle | Gets or sets the border style of the "box" surrounding the progress bar.
BoxBorderWidth | Gets or sets the border width of the "box" surrounding the progress bar.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Display | Gets or sets a value which indicates if the progressbar is displayed.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
ImageTimeout | Gets or sets a value which indicates how long to wait for each image to load.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text that is displayed next to the progress bar.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


BoxBackColor Property

HtmlBoxProgressBar.BoxBackColor Property

Gets or sets the color of the "box" surrounding the progress bar.

[Visual Basic]
Public Property BoxBackColor As Color
[C#]
public Color BoxBackColor { get; set; }
[C++]
public: __property Color get_BoxBackColor();
public: __property void set_BoxBackColor(Color );
[JScript]
public function get BoxBackColor() : Color
public function set BoxBackColor(Color);

Property Value

A System.Drawing.Color value representing the color of the frame box.

Remarks

When the progress bar is enabled, a place-holding "box", the dimensions of the HtmlBox, surrounds the progress bar. This property gets or sets the background color of that box.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


BoxBorderColor Property

HtmlBoxProgressBar.BoxBorderColor Property

Gets or sets the border color of the "box" surrounding the progress bar.

[Visual Basic]
Public Property BoxBorderColor As Color
[C#]
public Color BoxBorderColor { get; set; }
[C++]
public: __property Color get_BoxBorderColor();
public: __property void set_BoxBorderColor(Color );
[JScript]
public function get BoxBorderColor() : Color
public function set BoxBorderColor(Color);

Property Value

A System.Drawing.Color value representing the color of the frame box border.

Remarks

When the progress bar is enabled, a place-holding "box", the dimensions of the HtmlBox, surrounds the progress bar. This property gets or sets the border color of that box.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


BoxBorderStyle Property

HtmlBoxProgressBar.BoxBorderStyle Property

Gets or sets the border style of the "box" surrounding the progress bar.

[Visual Basic]
Public Property BoxBorderStyle As BorderStyle
[C#]
public BorderStyle BoxBorderStyle { get; set; }
[C++]
public: __property BorderStyle get_BoxBorderStyle();
public: __property void set_BoxBorderStyle(BorderStyle );
[JScript]
public function get BoxBorderStyle() : BorderStyle
public function set BoxBorderStyle(BorderStyle);

Property Value

A BorderStyle value representing the width of the frame box border.

Remarks

When the progress bar is enabled, a place-holding "box", the dimensions of the HtmlBox, surrounds the progress bar. This property gets or sets the border style of that box.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


BoxBorderWidth Property

HtmlBoxProgressBar.BoxBorderWidth Property

Gets or sets the border width of the "box" surrounding the progress bar.

[Visual Basic]
Public Property BoxBorderWidth As Unit
[C#]
public Unit BoxBorderWidth { get; set; }
[C++]
public: __property Unit get_BoxBorderWidth();
public: __property void set_BoxBorderWidth(Unit );
[JScript]
public function get BoxBorderWidth() : Unit
public function set BoxBorderWidth(Unit);

Property Value

A Unit value representing the width of the frame box border.

Remarks

When the progress bar is enabled, a place-holding "box", the dimensions of the HtmlBox, surrounds the progress bar. This property gets or sets the border width of that box.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


Display Property

HtmlBoxProgressBar.Display Property

Gets or sets a value which indicates if the progressbar is displayed.

[Visual Basic]
Public Property Display As Boolean
[C#]
public bool Display { get; set; }
[C++]
public: __property bool get_Display();
public: __property void set_Display(bool );
[JScript]
public function get Display() : bool
public function set Display(bool);

Property Value

true if the progressbar is displayed; false otherwise. The default value is false.true if a progress bar is displayed while loading images; false otherwise. The default value is false.

Remarks

When this property is set to true, a preload progressbar is displayed while the editor's images are loading.

If this property is set to true, a progress bar is displayed while images used by the HtmlBox are loading. The progress bar will only be displayed for the first request. For any subsequent postbacks, this property will be set to false, so the progress bar will not be displayed.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


ImageTimeout Property

HtmlBoxProgressBar.ImageTimeout Property

Gets or sets a value which indicates how long to wait for each image to load.

[Visual Basic]
Public Property ImageTimeout As Integer
[C#]
public int ImageTimeout { get; set; }
[C++]
public: __property int get_ImageTimeout();
public: __property void set_ImageTimeout(int );
[JScript]
public function get ImageTimeout() : int
public function set ImageTimeout(int);

Property Value

An integer value specifying the amount of milliseconds to wait for each image to load. The default value is 5000.

Remarks

The client-side JavaScript will monitor how long it takes for each image to load. If an image is not found, the JavaScript code will continue to try and load the image until the value of this property is reached.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


Text Property

HtmlBoxProgressBar.Text Property

Gets or sets the text that is displayed next to the progress bar.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

A string containing the text that is displayed next to the progress bar. The default value is "Loading...".

Remarks

Set this property to change the text that is displayed while the editor is loading. The HtmlBox.Font property controls the format of the text.

See Also

HtmlBoxProgressBar Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxTabStrip Class

Represents the tab strip used to change the modes of the HtmlBox

For a list of all members of this type, see HtmlBoxTabStrip Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.HtmlBoxTabStrip

[Visual Basic]
Public Class HtmlBoxTabStrip
    Inherits BaseChildControl
[C#]
public class HtmlBoxTabStrip : BaseChildControl
[C++]
public __gc class HtmlBoxTabStrip : public BaseChildControl
[JScript]
public class HtmlBoxTabStrip extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This object represents the "Design/HTML" tab strip at the bottom of the HtmlBox. Set the properties of this object to change the visual representation of the tabstrip.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlBoxTabStrip Members | Dart.PowerWEB.TextBox Namespace


HtmlBoxTabStrip Members

HtmlBoxTabStrip overview

Public Instance Constructors

HtmlBoxTabStrip Constructor Creates a new instance of HtmlBoxTabStrip.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DesignImageName | Gets or sets the name of the "Design" image.
DesignText | Gets or sets the text that is displayed on the "Design" tab.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
HighlightBackColor | Gets or sets the color of the highlighted tab option.
HighlightBorderColor | Gets or sets the border color of the highlighted tab option.
HighlightBorderStyle | Gets or sets the border style of the highlighted tab option.
HighlightForeColor | Gets or sets the text color of the highlighted tab option.
HtmlImageName | Gets or sets the name of the "HTML" image.
HtmlText | Gets or sets the text that is displayed on the "HTML" tab.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxTabStrip Constructor

Creates a new instance of HtmlBoxTabStrip.

[Visual Basic]
Public Sub New()
[C#]
public HtmlBoxTabStrip();
[C++]
public: HtmlBoxTabStrip();
[JScript]
public function HtmlBoxTabStrip();

Remarks

The default constructor creates and initializes a default instance of HtmlBoxTabStrip.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxTabStrip Properties

The properties of the HtmlBoxTabStrip class are listed below. For a complete list of HtmlBoxTabStrip class members, see the HtmlBoxTabStrip Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DesignImageName | Gets or sets the name of the "Design" image.
DesignText | Gets or sets the text that is displayed on the "Design" tab.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
HighlightBackColor | Gets or sets the color of the highlighted tab option.
HighlightBorderColor | Gets or sets the border color of the highlighted tab option.
HighlightBorderStyle | Gets or sets the border style of the highlighted tab option.
HighlightForeColor | Gets or sets the text color of the highlighted tab option.
HtmlImageName | Gets or sets the name of the "HTML" image.
HtmlText | Gets or sets the text that is displayed on the "HTML" tab.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


DesignImageName Property

HtmlBoxTabStrip.DesignImageName Property

Gets or sets the name of the "Design" image.

[Visual Basic]
Public Property DesignImageName As String
[C#]
public string DesignImageName { get; set; }
[C++]
public: __property String* get_DesignImageName();
public: __property void set_DesignImageName(String* );
[JScript]
public function get DesignImageName() : String
public function set DesignImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

The image specified by this property is displayed next to the value of the HtmlBoxTabStrip.DesignText property on the tab strip.

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


DesignText Property

HtmlBoxTabStrip.DesignText Property

Gets or sets the text that is displayed on the "Design" tab.

[Visual Basic]
Public Property DesignText As String
[C#]
public string DesignText { get; set; }
[C++]
public: __property String* get_DesignText();
public: __property void set_DesignText(String* );
[JScript]
public function get DesignText() : String
public function set DesignText(String);

Property Value

A string containing the text that is displayed on the "Design" tab. The default value is "Design".

Remarks

This property is displayed as the text on the tab strip option which causes the HtmlBox to switch to design mode when pressed.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


HighlightBackColor Property

HtmlBoxTabStrip.HighlightBackColor Property

Gets or sets the color of the highlighted tab option.

[Visual Basic]
Overridable Public Property HighlightBackColor As Color
[C#]
public virtual Color HighlightBackColor { get; set; }
[C++]
public: virtual __property Color get_HighlightBackColor();
public: virtual __property void set_HighlightBackColor(Color );
[JScript]
public virtual function get HighlightBackColor() : Color
public virtual function set HighlightBackColor(Color);

Property Value

A System.Drawing.Color value indicating the color of the highlighted tab option.

Remarks

When using the HtmlBoxTabStrip, one of the two tab options is always selected (for instance, when the HtmlBox is initially loaded, the "Design" tab is selected). This property is used to modify the visual appearance of the selected tab.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


HighlightBorderColor Property

HtmlBoxTabStrip.HighlightBorderColor Property

Gets or sets the border color of the highlighted tab option.

[Visual Basic]
Overridable Public Property HighlightBorderColor As Color
[C#]
public virtual Color HighlightBorderColor { get; set; }
[C++]
public: virtual __property Color get_HighlightBorderColor();
public: virtual __property void set_HighlightBorderColor(Color );
[JScript]
public virtual function get HighlightBorderColor() : Color
public virtual function set HighlightBorderColor(Color);

Property Value

A System.Drawing.Color value indicating the border color of the highlighted tab option.

Remarks

When using the HtmlBoxTabStrip, one of the two tab options is always selected (for instance, when the HtmlBox is initially loaded, the "Design" tab is selected). This property is used to modify the visual appearance of the selected tab.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


HighlightBorderStyle Property

HtmlBoxTabStrip.HighlightBorderStyle Property

Gets or sets the border style of the highlighted tab option.

[Visual Basic]
Overridable Public Property HighlightBorderStyle As BorderStyle
[C#]
public virtual BorderStyle HighlightBorderStyle { get; set; }
[C++]
public: virtual __property BorderStyle get_HighlightBorderStyle();
public: virtual __property void set_HighlightBorderStyle(BorderStyle );
[JScript]
public virtual function get HighlightBorderStyle() : BorderStyle
public virtual function set HighlightBorderStyle(BorderStyle);

Property Value

A BorderStyle value indicating the border style of the highlighted tab option.

Remarks

When using the HtmlBoxTabStrip, one of the two tab options is always selected (for instance, when the HtmlBox is initially loaded, the "Design" tab is selected). This property is used to modify the visual appearance of the selected tab.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


HighlightForeColor Property

HtmlBoxTabStrip.HighlightForeColor Property

Gets or sets the text color of the highlighted tab option.

[Visual Basic]
Overridable Public Property HighlightForeColor As Color
[C#]
public virtual Color HighlightForeColor { get; set; }
[C++]
public: virtual __property Color get_HighlightForeColor();
public: virtual __property void set_HighlightForeColor(Color );
[JScript]
public virtual function get HighlightForeColor() : Color
public virtual function set HighlightForeColor(Color);

Property Value

A System.Drawing.Color value indicating the text color of the highlighted tab option.

Remarks

When using the HtmlBoxTabStrip, one of the two tab options is always selected (for instance, when the HtmlBox is initially loaded, the "Design" tab is selected). This property is used to modify the visual appearance of the selected tab.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


HtmlImageName Property

HtmlBoxTabStrip.HtmlImageName Property

Gets or sets the name of the "HTML" image.

[Visual Basic]
Public Property HtmlImageName As String
[C#]
public string HtmlImageName { get; set; }
[C++]
public: __property String* get_HtmlImageName();
public: __property void set_HtmlImageName(String* );
[JScript]
public function get HtmlImageName() : String
public function set HtmlImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

The image specified by this property is displayed next to the value of the HtmlBoxTabStrip.HtmlText property on the tab strip.

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


HtmlText Property

HtmlBoxTabStrip.HtmlText Property

Gets or sets the text that is displayed on the "HTML" tab.

[Visual Basic]
Public Property HtmlText As String
[C#]
public string HtmlText { get; set; }
[C++]
public: __property String* get_HtmlText();
public: __property void set_HtmlText(String* );
[JScript]
public function get HtmlText() : String
public function set HtmlText(String);

Property Value

A string containing the text that is displayed on the "HTML" tab. The default value is "HTML".

Remarks

This property is displayed as the text on the tab strip option which causes the HtmlBox to switch to HTML mode when pressed.

See Also

HtmlBoxTabStrip Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxTextWindow Class

Represents the actual editing window of the HtmlBox.

For a list of all members of this type, see HtmlBoxTextWindow Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.HtmlBoxTextWindow

[Visual Basic]
Public Class HtmlBoxTextWindow
    Inherits BaseChildControl
[C#]
public class HtmlBoxTextWindow : BaseChildControl
[C++]
public __gc class HtmlBoxTextWindow : public BaseChildControl
[JScript]
public class HtmlBoxTextWindow extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This object represents the actual editing window (where the text is typed) of the HtmlBox. Set the style-related properties (such as BackgroundColor, Font.Name, etc) to change the visual appearance of the editing window itself.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlBoxTextWindow Members | Dart.PowerWEB.TextBox Namespace


HtmlBoxTextWindow Members

HtmlBoxTextWindow overview

Public Instance Constructors

HtmlBoxTextWindow Constructor Creates a new instance of HtmlBoxTextWindow.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BackgroundImageName | Gets or sets a value specifying the image name to display within the editing window.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
ShowWindowBorder | Gets or sets a value specifying if the editing window border is shown.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text displayed in the editor window.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Transparent | Gets or sets a value indicating if the editing window is transparent.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

HtmlBoxTextWindow Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxTextWindow Constructor

Creates a new instance of HtmlBoxTextWindow.

[Visual Basic]
Public Sub New()
[C#]
public HtmlBoxTextWindow();
[C++]
public: HtmlBoxTextWindow();
[JScript]
public function HtmlBoxTextWindow();

Remarks

The default constructor creates and initializes a default instance of HtmlBoxTextWindow.

See Also

HtmlBoxTextWindow Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxTextWindow Properties

The properties of the HtmlBoxTextWindow class are listed below. For a complete list of HtmlBoxTextWindow class members, see the HtmlBoxTextWindow Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BackgroundImageName | Gets or sets a value specifying the image name to display within the editing window.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
ShowWindowBorder | Gets or sets a value specifying if the editing window border is shown.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text displayed in the editor window.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Transparent | Gets or sets a value indicating if the editing window is transparent.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

HtmlBoxTextWindow Class | Dart.PowerWEB.TextBox Namespace


BackgroundImageName Property

HtmlBoxTextWindow.BackgroundImageName Property

Gets or sets a value specifying the image name to display within the editing window.

[Visual Basic]
Public Property BackgroundImageName As String
[C#]
public string BackgroundImageName { get; set; }
[C++]
public: __property String* get_BackgroundImageName();
public: __property void set_BackgroundImageName(String* );
[JScript]
public function get BackgroundImageName() : String
public function set BackgroundImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

When this property is set, an image is displayed on the background of the editing surface. This image does not interfere with editing. Typing occurs "over" the image. This is a useful property to use if you would like to set a watermark for the editor.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBoxTextWindow Class | Dart.PowerWEB.TextBox Namespace


ShowWindowBorder Property

HtmlBoxTextWindow.ShowWindowBorder Property

Gets or sets a value specifying if the editing window border is shown.

[Visual Basic]
Public Property ShowWindowBorder As Boolean
[C#]
public bool ShowWindowBorder { get; set; }
[C++]
public: __property bool get_ShowWindowBorder();
public: __property void set_ShowWindowBorder(bool );
[JScript]
public function get ShowWindowBorder() : bool
public function set ShowWindowBorder(bool);

Property Value

true is the editing window border is shown, false otherwise. The default value is true.

Remarks

This property differs from the style-related border properties of HtmlBoxTextWindow (such as HtmlBox.BorderStyle, HtmlBox.BorderWidth) in that those properties are used to draw a border around the editing window, while this property is used to get/set whether the intrinsic border of the editing window is displayed. This is a useful property for skin implementations, especially useful when HtmlBox.Transparent is true.

See Also

HtmlBoxTextWindow Class | Dart.PowerWEB.TextBox Namespace


Text Property

HtmlBoxTextWindow.Text Property

Gets or sets the text displayed in the editor window.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

A string containing the text displayed in the editor.

Remarks

This property returns the same data as HtmlBox.Text.

See Also

HtmlBoxTextWindow Class | Dart.PowerWEB.TextBox Namespace


Transparent Property

HtmlBoxTextWindow.Transparent Property

Gets or sets a value indicating if the editing window is transparent.

[Visual Basic]
Public Property Transparent As Boolean
[C#]
public bool Transparent { get; set; }
[C++]
public: __property bool get_Transparent();
public: __property void set_Transparent(bool );
[JScript]
public function get Transparent() : bool
public function set Transparent(bool);

Property Value

true if the editing window is transparent; false otherwise. The default value is true.

Remarks

When this property is set to true, the editing window will be transparent (allowing the background to show through) while still allowing typing/editing to occur. This property is useful in skin implementations.

See Also

HtmlBoxTextWindow Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxUpload Class

Represents a dialog used to upload/browse for files.

For a list of all members of this type, see HtmlBoxUpload Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.HtmlBoxUpload

[Visual Basic]
Public Class HtmlBoxUpload
    Inherits BaseChildControl
[C#]
public class HtmlBoxUpload : BaseChildControl
[C++]
public __gc class HtmlBoxUpload : public BaseChildControl
[JScript]
public class HtmlBoxUpload extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This control is attached to a ToolbarUploadButton (as the ToolbarUploadButton.Upload property). When a button of this type is clicked, the upload dialog represented by the attached HtmlBoxUpload control is displayed. This dialog is used to upload local files to the server, and to browse for and load files from the server onto the editor.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlBoxUpload Members | Dart.PowerWEB.TextBox Namespace


HtmlBoxUpload Members

HtmlBoxUpload overview

Public Instance Constructors

HtmlBoxUpload Constructor Creates a new instance of HtmlBoxUpload

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
AllowDelete | Gets or sets a value which indicates if the user is able to delete files.
AllowDownwardBrowsing | Gets or sets a value which indicates if downward browsing is enabled.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
Caption | Gets or sets the text that is displayed as the dialog caption.
ChangeDirectoryUpImageName | Gets or sets the image name to use for the "change directory up" icon.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DirectoryImageName | Gets or sets the image name to use for the "directory" icon.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ExternalFile | Gets or sets the url of an external file containing the content for the dialog.
FileImageName | Gets or sets the image name to use for the "file" icon.
FileTypeMustMatchFilter | Gets or sets a value which indicates if file types not matching the current Filter are accepted.
Filter | Gets or sets the filter used for displaying files in the file browser.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
InitialDirectory | Gets or sets the initial directory of the file browser.
LaunchX | Gets or sets a the value of the X-coordinate where the dialog is launched.
LaunchY | Gets or sets a the value of the Y-coordinate where the dialog is launched.
MaxFileSize | Gets or sets the maximum file size (in bytes) that the server will accept when uploading files.
Mode | Gets or sets the mode of the upload dialog.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Strings | Gets or sets a collection of strings used in the dialog.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
TitlebarBackColor | Gets or sets the background color of the titlebar.
TitlebarFontName | Gets or sets the font name of the text on the titlebar.
TitlebarFontSize | Gets or sets the font size of the text on the titlebar.
TitlebarForeColor | Gets or sets the font color of the text on the titlebar.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UploadEnabled | Gets or sets a value indicating if the user is allowed to upload files.
UseRelativePaths | Gets or sets a value which determines if relative paths are used for <A> and <IMG> tags.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxUpload Constructor

Creates a new instance of HtmlBoxUpload

[Visual Basic]
Public Sub New()
[C#]
public HtmlBoxUpload();
[C++]
public: HtmlBoxUpload();
[JScript]
public function HtmlBoxUpload();

Remarks

The default constructor creates and initializes a default instance of HtmlBoxUpload.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


HtmlBoxUpload Properties

The properties of the HtmlBoxUpload class are listed below. For a complete list of HtmlBoxUpload class members, see the HtmlBoxUpload Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
AllowDelete | Gets or sets a value which indicates if the user is able to delete files.
AllowDownwardBrowsing | Gets or sets a value which indicates if downward browsing is enabled.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
Caption | Gets or sets the text that is displayed as the dialog caption.
ChangeDirectoryUpImageName | Gets or sets the image name to use for the "change directory up" icon.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DirectoryImageName | Gets or sets the image name to use for the "directory" icon.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ExternalFile | Gets or sets the url of an external file containing the content for the dialog.
FileImageName | Gets or sets the image name to use for the "file" icon.
FileTypeMustMatchFilter | Gets or sets a value which indicates if file types not matching the current Filter are accepted.
Filter | Gets or sets the filter used for displaying files in the file browser.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
InitialDirectory | Gets or sets the initial directory of the file browser.
LaunchX | Gets or sets a the value of the X-coordinate where the dialog is launched.
LaunchY | Gets or sets a the value of the Y-coordinate where the dialog is launched.
MaxFileSize | Gets or sets the maximum file size (in bytes) that the server will accept when uploading files.
Mode | Gets or sets the mode of the upload dialog.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Strings | Gets or sets a collection of strings used in the dialog.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
TitlebarBackColor | Gets or sets the background color of the titlebar.
TitlebarFontName | Gets or sets the font name of the text on the titlebar.
TitlebarFontSize | Gets or sets the font size of the text on the titlebar.
TitlebarForeColor | Gets or sets the font color of the text on the titlebar.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UploadEnabled | Gets or sets a value indicating if the user is allowed to upload files.
UseRelativePaths | Gets or sets a value which determines if relative paths are used for <A> and <IMG> tags.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


AllowDelete Property

HtmlBoxUpload.AllowDelete Property

Gets or sets a value which indicates if the user is able to delete files.

[Visual Basic]
Public Property AllowDelete As Boolean
[C#]
public bool AllowDelete { get; set; }
[C++]
public: __property bool get_AllowDelete();
public: __property void set_AllowDelete(bool );
[JScript]
public function get AllowDelete() : bool
public function set AllowDelete(bool);

Property Value

true if the user is allowed to delete files; false otherwise. The default value is true.

Remarks

When this property is true, a delete link is displayed next to each file in the dialog. The user can click this link to delete the file.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


AllowDownwardBrowsing Property

HtmlBoxUpload.AllowDownwardBrowsing Property

Gets or sets a value which indicates if downward browsing is enabled.

[Visual Basic]
Public Property AllowDownwardBrowsing As Boolean
[C#]
public bool AllowDownwardBrowsing { get; set; }
[C++]
public: __property bool get_AllowDownwardBrowsing();
public: __property void set_AllowDownwardBrowsing(bool );
[JScript]
public function get AllowDownwardBrowsing() : bool
public function set AllowDownwardBrowsing(bool);

Property Value

true if the user is allowed to browse downward from the InitialDirectory; false otherwise. The default value is true.

Remarks

When this property is true, the user is allowed to browse down (into subdirectories) of the HtmlBox.InitialDirectory.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


Caption Property

HtmlBoxUpload.Caption Property

Gets or sets the text that is displayed as the dialog caption.

[Visual Basic]
Public Property Caption As String
[C#]
public string Caption { get; set; }
[C++]
public: __property String* get_Caption();
public: __property void set_Caption(String* );
[JScript]
public function get Caption() : String
public function set Caption(String);

Property Value

A string representing the text that is displayed as the dialog caption.

Remarks

This property is only used when the HtmlBoxDialog.Type = DialogType.InnerWindowWithTitlebar.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


ChangeDirectoryUpImageName Property

HtmlBoxUpload.ChangeDirectoryUpImageName Property

Gets or sets the image name to use for the "change directory up" icon.

[Visual Basic]
Public Property ChangeDirectoryUpImageName As String
[C#]
public string ChangeDirectoryUpImageName { get; set; }
[C++]
public: __property String* get_ChangeDirectoryUpImageName();
public: __property void set_ChangeDirectoryUpImageName(String* );
[JScript]
public function get ChangeDirectoryUpImageName() : String
public function set ChangeDirectoryUpImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


DirectoryImageName Property

HtmlBoxUpload.DirectoryImageName Property

Gets or sets the image name to use for the "directory" icon.

[Visual Basic]
Public Property DirectoryImageName As String
[C#]
public string DirectoryImageName { get; set; }
[C++]
public: __property String* get_DirectoryImageName();
public: __property void set_DirectoryImageName(String* );
[JScript]
public function get DirectoryImageName() : String
public function set DirectoryImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


ExternalFile Property

HtmlBoxUpload.ExternalFile Property

Gets or sets the url of an external file containing the content for the dialog.

[Visual Basic]
Public Property ExternalFile As String
[C#]
public string ExternalFile { get; set; }
[C++]
public: __property String* get_ExternalFile();
public: __property void set_ExternalFile(String* );
[JScript]
public function get ExternalFile() : String
public function set ExternalFile(String);

Property Value

A string representing a url of an external file containing the content for the dialog.

Remarks

This property is not used by any of the predefined dialogs used by the HtmlBox. However, you may set this property if you would like to supply the content for the dialog from a file on the server. If this is the case, the dialog will launch in a modal dialog box that you will not be able to modify the titlebar properties (such as TitlebarBackColor) of.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


FileImageName Property

HtmlBoxUpload.FileImageName Property

Gets or sets the image name to use for the "file" icon.

[Visual Basic]
Public Property FileImageName As String
[C#]
public string FileImageName { get; set; }
[C++]
public: __property String* get_FileImageName();
public: __property void set_FileImageName(String* );
[JScript]
public function get FileImageName() : String
public function set FileImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


FileTypeMustMatchFilter Property

HtmlBoxUpload.FileTypeMustMatchFilter Property

Gets or sets a value which indicates if file types not matching the current Filter are accepted.

[Visual Basic]
Public Property FileTypeMustMatchFilter As Boolean
[C#]
public bool FileTypeMustMatchFilter { get; set; }
[C++]
public: __property bool get_FileTypeMustMatchFilter();
public: __property void set_FileTypeMustMatchFilter(bool );
[JScript]
public function get FileTypeMustMatchFilter() : bool
public function set FileTypeMustMatchFilter(bool);

Property Value

true if only file types matching the current filter are accepted; false if any file types are accepted. The default value is true.

Remarks

The HtmlBoxUpload.Filter property specifies the types of files displayed in the "file browser" of the upload. If this property is true, all uploaded files will be compared to the HtmlBox.Filter property. If the file type does not match, the file is not uploaded and an error message is displayed.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


Filter Property

HtmlBoxUpload.Filter Property

Gets or sets the filter used for displaying files in the file browser.

[Visual Basic]
Public Property Filter As String
[C#]
public string Filter { get; set; }
[C++]
public: __property String* get_Filter();
public: __property void set_Filter(String* );
[JScript]
public function get Filter() : String
public function set Filter(String);

Property Value

A string representing the current file filter. The default value is "*.gif,*.jpg,*.bmp".

Remarks

The format of the filter is a comma delimited list of file types (ex "*.gif,*.jpg,*.bmp"). The filter is also used by the HtmlBoxUpload.FileTypeMustMatchFilter property, which controls whether or not file types that do not match the filter are uploaded.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


InitialDirectory Property

HtmlBoxUpload.InitialDirectory Property

Gets or sets the initial directory of the file browser.

[Visual Basic]
Public Property InitialDirectory As String
[C#]
public string InitialDirectory { get; set; }
[C++]
public: __property String* get_InitialDirectory();
public: __property void set_InitialDirectory(String* );
[JScript]
public function get InitialDirectory() : String
public function set InitialDirectory(String);

Property Value

A string representing the initial directory of the file browser.

Remarks

Each upload dialog instance has a file browser associated with it which displays files on the server. This property sets the directory which the file browser is initialized to when the upload is first displayed. Any files uploaded will be stored in this directory. This property gets it's initial value from the HtmlBox.UploadedFiles property.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


LaunchX Property

HtmlBoxUpload.LaunchX Property

Gets or sets a the value of the X-coordinate where the dialog is launched.

[Visual Basic]
Public Property LaunchX As String
[C#]
public string LaunchX { get; set; }
[C++]
public: __property String* get_LaunchX();
public: __property void set_LaunchX(String* );
[JScript]
public function get LaunchX() : String
public function set LaunchX(String);

Property Value

A string representing the value of the X-coordinate where the dialog is launched).

Remarks

This value can either be a absolute screen coordinate (such as "150", specifying that the dialog appears 150 pixels from the left side of the screen) or a JavaScript variable or function which is evaluated (such as "event.clientX", specifying that the dialog will launch at the X-coordinate of the calling event.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


LaunchY Property

HtmlBoxUpload.LaunchY Property

Gets or sets a the value of the Y-coordinate where the dialog is launched.

[Visual Basic]
Public Property LaunchY As String
[C#]
public string LaunchY { get; set; }
[C++]
public: __property String* get_LaunchY();
public: __property void set_LaunchY(String* );
[JScript]
public function get LaunchY() : String
public function set LaunchY(String);

Property Value

A string representing the value of the Y-coordinate where the dialog is launched).

Remarks

This value can either be a absolute screen coordinate (such as "150", specifying that the dialog appears 150 pixels from the top of the screen) or a JavaScript variable or function which is evaluated (such as "event.clientY", specifying that the dialog will launch at the Y-coordinate of the calling event.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


MaxFileSize Property

HtmlBoxUpload.MaxFileSize Property

Gets or sets the maximum file size (in bytes) that the server will accept when uploading files.

[Visual Basic]
Public Property MaxFileSize As Integer
[C#]
public int MaxFileSize { get; set; }
[C++]
public: __property int get_MaxFileSize();
public: __property void set_MaxFileSize(int );
[JScript]
public function get MaxFileSize() : int
public function set MaxFileSize(int);

Property Value

The maximum file size (in bytes) that will be accepted by the server when uploading files. The default value is 1048576.

Remarks

If a user attempts to upload a size larger than the value specified here, the file will not be accepted and an error message will be displayed. Set this property to 0 to accept any files. Set the HtmlBoxUpload.UploadEnabled property to false to completely disable file upload.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


Mode Property

HtmlBoxUpload.Mode Property

Gets or sets the mode of the upload dialog.

[Visual Basic]
Public Property Mode As UploadMode
[C#]
public UploadMode Mode { get; set; }
[C++]
public: __property UploadMode get_Mode();
public: __property void set_Mode(UploadMode );
[JScript]
public function get Mode() : UploadMode
public function set Mode(UploadMode);

Property Value

An UploadMode value indicating the mode of the upload dialog; the default value is UploadMode.Image.

Remarks

When this property is UploadMode.Image, the upload dialog will come preconfigured to display and load images into the editor window. When this property is UploadMode.File, the upload dialog will come preconfigured to displaye and load files (such as .htm files) into the editor window.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


Strings Property

HtmlBoxUpload.Strings Property

Gets or sets a collection of strings used in the dialog.

[Visual Basic]
Public Property Strings As StringValueCollection
[C#]
public StringValueCollection Strings { get; set; }
[C++]
public: __property StringValueCollection* get_Strings();
public: __property void set_Strings(StringValueCollection* );
[JScript]
public function get Strings() : StringValueCollection
public function set Strings(StringValueCollection);

Property Value

A StringValueCollection collection representing the strings to be used in the dialog.

Remarks

For predefined dialogs, this collection will contain a list of strings used within the dialog. For custom dialogs, this collection is not used. This collection is useful if you wish to modify the strings used within predefined dialogs. For example, if you would like to change the text on the "Cancel" button to say "Close", you could do the following:

MyDialogButton.Dialog.Strings["Cancel"] = "Close";

This is especially useful in scenarios where you need to localize the HtmlBox to a non-English language. See the topic Localizing the HtmlBox for more information and for a list of keys used for each Strings collection associated with each predefined dialog.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


TitlebarBackColor Property

HtmlBoxUpload.TitlebarBackColor Property

Gets or sets the background color of the titlebar.

[Visual Basic]
Overridable Public Property TitlebarBackColor As Color
[C#]
public virtual Color TitlebarBackColor { get; set; }
[C++]
public: virtual __property Color get_TitlebarBackColor();
public: virtual __property void set_TitlebarBackColor(Color );
[JScript]
public virtual function get TitlebarBackColor() : Color
public virtual function set TitlebarBackColor(Color);

Property Value

A System.Drawing.Color value specifying the color of the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


TitlebarFontName Property

HtmlBoxUpload.TitlebarFontName Property

Gets or sets the font name of the text on the titlebar.

[Visual Basic]
Overridable Public Property TitlebarFontName As String
[C#]
public virtual string TitlebarFontName { get; set; }
[C++]
public: virtual __property String* get_TitlebarFontName();
public: virtual __property void set_TitlebarFontName(String* );
[JScript]
public virtual function get TitlebarFontName() : String
public virtual function set TitlebarFontName(String);

Property Value

A string value specifying the font name of the text on the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


TitlebarFontSize Property

HtmlBoxUpload.TitlebarFontSize Property

Gets or sets the font size of the text on the titlebar.

[Visual Basic]
Overridable Public Property TitlebarFontSize As FontUnit
[C#]
public virtual FontUnit TitlebarFontSize { get; set; }
[C++]
public: virtual __property FontUnit get_TitlebarFontSize();
public: virtual __property void set_TitlebarFontSize(FontUnit );
[JScript]
public virtual function get TitlebarFontSize() : FontUnit
public virtual function set TitlebarFontSize(FontUnit);

Property Value

A FontUnit value specifying the font size of the on the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


TitlebarForeColor Property

HtmlBoxUpload.TitlebarForeColor Property

Gets or sets the font color of the text on the titlebar.

[Visual Basic]
Overridable Public Property TitlebarForeColor As Color
[C#]
public virtual Color TitlebarForeColor { get; set; }
[C++]
public: virtual __property Color get_TitlebarForeColor();
public: virtual __property void set_TitlebarForeColor(Color );
[JScript]
public virtual function get TitlebarForeColor() : Color
public virtual function set TitlebarForeColor(Color);

Property Value

A System.Drawing.Color value specifying the font color of the on the titlebar.

Remarks

This property is only used when the HtmlBoxDialog.Type property = DialogType.InternalWindowWithTitlebar.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


UploadEnabled Property

HtmlBoxUpload.UploadEnabled Property

Gets or sets a value indicating if the user is allowed to upload files.

[Visual Basic]
Public Property UploadEnabled As Boolean
[C#]
public bool UploadEnabled { get; set; }
[C++]
public: __property bool get_UploadEnabled();
public: __property void set_UploadEnabled(bool );
[JScript]
public function get UploadEnabled() : bool
public function set UploadEnabled(bool);

Property Value

true if the user is allowed to upload files; false otherwise. The default value is true.

Remarks

Setting this property to false will cause the upload portion of the upload dialog to not be rendered, causing the upload dialog to be a read-only mechanism for loading images/files into the editor window.

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


UseRelativePaths Property

HtmlBoxUpload.UseRelativePaths Property

Gets or sets a value which determines if relative paths are used for <A> and <IMG> tags.

[Visual Basic]
Public Property UseRelativePaths As Boolean
[C#]
public bool UseRelativePaths { get; set; }
[C++]
public: __property bool get_UseRelativePaths();
public: __property void set_UseRelativePaths(bool );
[JScript]
public function get UseRelativePaths() : bool
public function set UseRelativePaths(bool);

Property Value

true if relative paths should be fixed, false otherwise. The default value is true.

Remarks

The IFRAME object automatically makes all paths absolute. When this value is set to true, these absolute paths will be fixed to be relative, for example a link like "http://myserver/myimages/blah.gif" might be turned into "../myimages/blah.gif".

See Also

HtmlBoxUpload Class | Dart.PowerWEB.TextBox Namespace


HtmlReader Class

HTMLReader

For a list of all members of this type, see HtmlReader Members.

System.Object
System.MarshalByRefObject
System.IO.TextReader
System.IO.StringReader
Dart.PowerWEB.TextBox.HtmlReader

[Visual Basic]
Public Class HtmlReader
    Inherits StringReader
[C#]
public class HtmlReader : StringReader
[C++]
public __gc class HtmlReader : public StringReader
[JScript]
public class HtmlReader extends StringReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

HtmlReader Members | Dart.PowerWEB.TextBox Namespace


HtmlReader Members

HtmlReader overview

Public Instance Constructors

HtmlReader Constructor

Public Instance Properties

Log | Activity log - contains INFO, WARNING and ERROR messages
RawHTML | The raw HTML provided when constructing the current instance of HTMLReader

Public Instance Methods

Close (inherited from StringReader) | Overidden. Closes the StringReader.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Peek (inherited from StringReader) | Overidden. Returns the next available character but does not consume it.
Read (inherited from StringReader) | Overidden. Overloaded. Reads a block of characters from the input string and advances the character position by count.
Read | Overidden. Overloaded. Overrides the base Read() method which reads the next character from the input string
ReadBlock (inherited from TextReader) | Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.
ReadLine (inherited from StringReader) | Overidden. Reads a line from the underlying string.
ReadToEnd (inherited from StringReader) | Overidden. Reads the stream as a string, either in its entirety or from the current position to the end of the stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ToXHTML | Return string contents as properly formatted XHTML

See Also

HtmlReader Class | Dart.PowerWEB.TextBox Namespace


HtmlReader Constructor

[Visual Basic]
Public Sub New( _
   ByVal html As String _
)
[C#]
public HtmlReader(
   string html
);
[C++]
public: HtmlReader(
   String* html
);
[JScript]
public function HtmlReader(
   String html
);

Parameters

html

See Also

HtmlReader Class | Dart.PowerWEB.TextBox Namespace


HtmlReader Properties

The properties of the HtmlReader class are listed below. For a complete list of HtmlReader class members, see the HtmlReader Members topic.

Public Instance Properties

Log | Activity log - contains INFO, WARNING and ERROR messages
RawHTML | The raw HTML provided when constructing the current instance of HTMLReader

See Also

HtmlReader Class | Dart.PowerWEB.TextBox Namespace


Log Property

HtmlReader.Log Property

Activity log - contains INFO, WARNING and ERROR messages

[Visual Basic]
Public Property ReadOnly Log As String
[C#]
public string Log { get; }
[C++]
public: __property String* get_Log();
[JScript]
public function get Log() : String

See Also

HtmlReader Class | Dart.PowerWEB.TextBox Namespace


RawHTML Property

HtmlReader.RawHTML Property

The raw HTML provided when constructing the current instance of HTMLReader

[Visual Basic]
Public Property ReadOnly RawHTML As String
[C#]
public string RawHTML { get; }
[C++]
public: __property String* get_RawHTML();
[JScript]
public function get RawHTML() : String

See Also

HtmlReader Class | Dart.PowerWEB.TextBox Namespace


HtmlReader Methods

The methods of the HtmlReader class are listed below. For a complete list of HtmlReader class members, see the HtmlReader Members topic.

Public Instance Methods

Close (inherited from StringReader) | Overidden. Closes the StringReader.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Peek (inherited from StringReader) | Overidden. Returns the next available character but does not consume it.
Read (inherited from StringReader) | Overidden. Overloaded. Reads a block of characters from the input string and advances the character position by count.
Read | Overidden. Overloaded. Overrides the base Read() method which reads the next character from the input string
ReadBlock (inherited from TextReader) | Reads a maximum of count characters from the current stream and writes the data to buffer, beginning at index.
ReadLine (inherited from StringReader) | Overidden. Reads a line from the underlying string.
ReadToEnd (inherited from StringReader) | Overidden. Reads the stream as a string, either in its entirety or from the current position to the end of the stream.
ToString (inherited from Object) | Returns a String that represents the current Object.
ToXHTML | Return string contents as properly formatted XHTML

See Also

HtmlReader Class | Dart.PowerWEB.TextBox Namespace


Read Method

HtmlReader.Read Method

Overrides the base Read() method which reads the next character from the input string

Overload List

Overrides the base Read() method which reads the next character from the input string

[Visual Basic] Overrides OverloadsPublic Function Read() As Integer
[C#] public override int Read();
[C++] public: int Read();
[JScript] public override function Read(): int;

Reads a block of characters from the input string and advances the character position by count.
Inherited from StringReader.

[Visual Basic] Overrides OverloadsPublic Function Read(ByVal Char(),ByVal Integer,ByVal Integer) As Integer
[C#] public override int Read(char[],int,int);
[C++] public: int Read(wchar_t __gc[],int,int);
[JScript] public override function Read(char[],int,int): int;

See Also

HtmlReader Class | Dart.PowerWEB.TextBox Namespace


Read Method ()

HtmlReader.Read Method ()

Overrides the base Read() method which reads the next character from the input string

[Visual Basic]
Overrides  OverloadsPublic Function Read() As Integer
[C#]
public override int Read();
[C++]
public: int Read();
[JScript]
public override function Read(): int;

Return Value

byte code for character read - will be -1 if EOF is encountered

See Also

HtmlReader Class | Dart.PowerWEB.TextBox Namespace | HtmlReader.Read Overload List


ToXHTML Method

HtmlReader.ToXHTML Method

Return string contents as properly formatted XHTML

[Visual Basic]
Public Function ToXHTML() As String
[C#]
public string ToXHTML();
[C++]
public: String* ToXHTML();
[JScript]
public function ToXHTML(): String;

Return Value

XHTML string

See Also

HtmlReader Class | Dart.PowerWEB.TextBox Namespace


InternalDialogType Enumeration

Enumerates the internally rendered type of dialog associated with a ToolbarDialogButton.

[Visual Basic]
Public Enum InternalDialogType
[C#]
public enum InternalDialogType
[C++]
public __value enum InternalDialogType
[JScript]
public enum InternalDialogType

Remarks

This enumeration is not intended to be used by a developer. It is public so it can be used by the ASP.NET tag parser, if needed.

Members

Member Name | Description
NotSet | The internally renderd dialog is not set.
CellPropertiesDialog | The internally rendered dialog is a cell properties dialog.
ColorList | The internally rendered dialog is a color list.
ColorPicker | The internally rendered dialog is a color picker.
FindReplaceDialog | The internally rendered dialog is a find/replace dialog.
InsertBookmarkDialog | The internally rendered dialog is an insert bookmark dialog.
InsertRuleDialog | The internally rendered dialog is an insert rule dialog.
InsertTableDialog | The internally rendered dialog is an insert table dialog.
SpecialCharacterPicker | The internally rendered dialog is a special character picker.
TextDialog | The internally rendered dialog is specified by the Dialog.Text property. Used for custom dialogs.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


LayoutType Enumeration

Enumerates the different ways the HtmlBox can be rendered.

[Visual Basic]
Public Enum LayoutType
[C#]
public enum LayoutType
[C++]
public __value enum LayoutType
[JScript]
public enum LayoutType

Remarks

The HtmlBox can be rendered multiple ways depending on the scenario. LayoutType.Standard renders a standard editor. LayoutType.Condensed renders a condensed editor (good for low-bandwidth scenarios). LayoutType.Skin renders a editor optimized for displaying graphical skins. NOTE! Changing from one layout type to another WILL change some property values. For example, if you are using the LayoutType.Standard layout, change the HtmlBox.BackColor to red, then change the HtmlBox.LayoutType to LayoutType.Skin, that property will be nulled out. For this reason, it is suggested that you always change the HtmlBox.LayoutType FIRST, before making other changes, to eliminate any chances of a property being overwritten.

Members

Member Name | Description
Standard | The standard HtmlBox layout.
Condensed | Layout configured to use a condensed HtmlBox, good for low bandwidth scenarios.
Skin | Layout configured for use with graphical skins.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


LiteralType Enumeration

[Visual Basic]
Public Enum LiteralType
[C#]
public enum LiteralType
[C++]
public __value enum LiteralType
[JScript]
public enum LiteralType

Members

Member Name | Description
CDATA |
SDATA |
PI |

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


LocalizationType Enumeration

Enumerates the localization type used to display strings in the HtmlBox.

[Visual Basic]
Public Enum LocalizationType
[C#]
public enum LocalizationType
[C++]
public __value enum LocalizationType
[JScript]
public enum LocalizationType

Remarks

This property is used by the LocalizationType property of the HtmlBox control. All predefined strings are sourced from an embedded XML resource file. Changing the value of the LocalizationType property will cause all predefined strings to be translated into the selected language. For example if the current LocalizationType is English, and French is chosen, the string "Color" becomes "Couleur".

Members

Member Name | Description
English | All strings are English (the default).
Spanish | All strings are Spanish.
French | All strings are French.
German | All strings are German.
Custom | Custom strings. You must set HtmlBox.LocalizationFile to the filepath of the XML document which specifies the strings to use. You must follow the format used by the PowerWEB XML localization files (look in the PowerWEB/Common/scripts directory for an example).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


MenuStyle Class

Represents the style used by menus.

For a list of all members of this type, see MenuStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.TextBox.BaseStyle
Dart.PowerWEB.TextBox.MenuStyle

[Visual Basic]
Public Class MenuStyle
    Inherits BaseStyle
[C#]
public class MenuStyle : BaseStyle
[C++]
public __gc class MenuStyle : public BaseStyle
[JScript]
public class MenuStyle extends BaseStyle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The MenuStyle class extends the Style class by providing additional properties for menu style support such as ImageColumnColor.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

MenuStyle Members | Dart.PowerWEB.TextBox Namespace


MenuStyle Members

MenuStyle overview

Public Instance Constructors

MenuStyle Overloaded. Initializes a new instance of the MenuStyle class.

Public Instance Properties

BackColor | Gets or sets the background color of the control.
BorderColor (inherited from BaseStyle) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseStyle) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseStyle) | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from BaseStyle) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font (inherited from BaseStyle) | Gets the font properties associated with the Web server control.
ForeColor (inherited from BaseStyle) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseStyle) | Gets or sets the height of the control.
ImageColumnColor | Gets or sets the value of the color used for the image column.
MouseOverColor | Gets or sets the color that is displayed when the mouse is over an item.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from BaseStyle) | Gets or sets the width of the control.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
Clear | Overidden. Sets all style properties to "non-set" equivalents.
CopyFrom | Overidden. Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith | Overidden. Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset | Overidden. Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


MenuStyle Constructor

Creates and initializes a default instance of MenuStyle.

Overload List

Creates and initializes a default instance of MenuStyle.

[Visual Basic] Public Sub New()
[C#] public MenuStyle();
[C++] public: MenuStyle();
[JScript] public function MenuStyle();

Initializes a new instance of the DialogStyle class with the specified state bag information.

[Visual Basic] Public Sub New(ByVal StateBag)
[C#] public MenuStyle(StateBag);
[C++] public: MenuStyle(StateBag*);
[JScript] public function MenuStyle(StateBag);

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


MenuStyle Constructor ()

Creates and initializes a default instance of MenuStyle.

[Visual Basic]
Public Sub New()
[C#]
public MenuStyle();
[C++]
public: MenuStyle();
[JScript]
public function MenuStyle();

Remarks

Use this constructor to create and initialize a new instance of the DialogStyle class.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace | MenuStyle Constructor Overload List


MenuStyle Constructor (StateBag)

Initializes a new instance of the DialogStyle class with the specified state bag information.

[Visual Basic]
Public Sub New( _
   ByVal bag As StateBag _
)
[C#]
public MenuStyle(
   StateBag bag
);
[C++]
public: MenuStyle(
   StateBag* bag
);
[JScript]
public function MenuStyle(
   StateBag bag
);

Parameters

bag
A System.Web.UI.StateBag that represents the state bag in which to store style information.

Remarks

Use this constructor to create an initialize a new instance of the MenuStyle class using the System.Web.UI.StateBag specified by the bag parameter.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace | MenuStyle Constructor Overload List


MenuStyle Properties

The properties of the MenuStyle class are listed below. For a complete list of MenuStyle class members, see the MenuStyle Members topic.

Public Instance Properties

BackColor | Gets or sets the background color of the control.
BorderColor (inherited from BaseStyle) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseStyle) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseStyle) | Gets or sets the border width of the control
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from BaseStyle) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Font (inherited from BaseStyle) | Gets the font properties associated with the Web server control.
ForeColor (inherited from BaseStyle) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseStyle) | Gets or sets the height of the control.
ImageColumnColor | Gets or sets the value of the color used for the image column.
MouseOverColor | Gets or sets the color that is displayed when the mouse is over an item.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from BaseStyle) | Gets or sets the width of the control.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


BackColor Property

MenuStyle.BackColor Property

Gets or sets the background color of the control.

[Visual Basic]
Shadows Overridable Public Property BackColor As Color
[C#]
public new virtual Color BackColor { get; set; }
[C++]
public: virtual __property Color get_BackColor();
public: virtual __property void set_BackColor(Color );
[JScript]
public virtual function get BackColor() : Color
public virtual function set BackColor(Color);

Property Value

A System.Drawing.Color that represents the background color of the control. The default is Color.Empty, which indicates that this property is not set.

Remarks

Use the BackColor property to specify the background color of the control. This property is set using a System.Drawing.Color object.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


ImageColumnColor Property

MenuStyle.ImageColumnColor Property

Gets or sets the value of the color used for the image column.

[Visual Basic]
Overridable Public Property ImageColumnColor As Color
[C#]
public virtual Color ImageColumnColor { get; set; }
[C++]
public: virtual __property Color get_ImageColumnColor();
public: virtual __property void set_ImageColumnColor(Color );
[JScript]
public virtual function get ImageColumnColor() : Color
public virtual function set ImageColumnColor(Color);

Property Value

A System.Drawing.Color value specifying the color used for the image column.

Remarks

Each menu item is made up of two entities, the menu item text (such as "Table Properties") and the menu item image (such as a table properties icon) arranged in two columns. This property sets the value of the column that displays the images.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


MouseOverColor Property

MenuStyle.MouseOverColor Property

Gets or sets the color that is displayed when the mouse is over an item.

[Visual Basic]
Overridable Public Property MouseOverColor As Color
[C#]
public virtual Color MouseOverColor { get; set; }
[C++]
public: virtual __property Color get_MouseOverColor();
public: virtual __property void set_MouseOverColor(Color );
[JScript]
public virtual function get MouseOverColor() : Color
public virtual function set MouseOverColor(Color);

Property Value

A System.Drawing.Color value specifying the color that is displayed when the mouse is over an item.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


MenuStyle Methods

The methods of the MenuStyle class are listed below. For a complete list of MenuStyle class members, see the MenuStyle Members topic.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
Clear | Overidden. Sets all style properties to "non-set" equivalents.
CopyFrom | Overidden. Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith | Overidden. Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset | Overidden. Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overidden.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


Clear Method

MenuStyle.Clear Method

Sets all style properties to "non-set" equivalents.

[Visual Basic]
Overrides Public Sub Clear()
[C#]
public override void Clear();
[C++]
public: void Clear();
[JScript]
public override function Clear();

Remarks

For example, Height is set to 0, BackColor is set to Color.Empty, etc.

This method resets the properties of the style. For example, Style.BackColor will become Color.Empty, Style.BorderStyle will become BorderStyle.NotSet, etc.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


CopyFrom Method

MenuStyle.CopyFrom Method

Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.

[Visual Basic]
Overrides Public Sub CopyFrom( _
   ByVal s As Style _
)
[C#]
public override void CopyFrom(
   Style s
);
[C++]
public: void CopyFrom(
   Style* s
);
[JScript]
public override function CopyFrom(
   Style s
);

Parameters

s
A style type that represents the style to copy.

Remarks

Use the CopyFrom method to duplicate the style properties of the specified Style into the instance of the Style class that this method is called from.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


MergeWith Method

MenuStyle.MergeWith Method

Combines the style properties of the specified Style with the instance of the Style class that this method is called from.

[Visual Basic]
Overrides Public Sub MergeWith( _
   ByVal s As Style _
)
[C#]
public override void MergeWith(
   Style s
);
[C++]
public: void MergeWith(
   Style* s
);
[JScript]
public override function MergeWith(
   Style s
);

Parameters

s
A style type that represents the style to combine.

Remarks

Use the MergeWith method to combine the style properties of the specified Style with the instance of the Style class that this method is called from.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


Reset Method

MenuStyle.Reset Method

Removes any defined style elements from the state bag.

[Visual Basic]
Overrides Public Sub Reset()
[C#]
public override void Reset();
[C++]
public: void Reset();
[JScript]
public override function Reset();

Return Value

Use this method to remove any defined style elements from the state bag.

See Also

MenuStyle Class | Dart.PowerWEB.TextBox Namespace


Occurrence Enumeration

[Visual Basic]
Public Enum Occurrence
[C#]
public enum Occurrence
[C++]
public __value enum Occurrence
[JScript]
public enum Occurrence

Members

Member Name | Description
Required |
Optional |
ZeroOrMore |
OneOrMore |

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ResourceHttpHandler Class

Summary description for ResourceHttpHandler.

For a list of all members of this type, see ResourceHttpHandler Members.

System.Object
Dart.PowerWEB.TextBox.ResourceHttpHandler

[Visual Basic]
Public Class ResourceHttpHandler
    Implements IHttpHandler
[C#]
public class ResourceHttpHandler : IHttpHandler
[C++]
public __gc class ResourceHttpHandler : public IHttpHandler
[JScript]
public class ResourceHttpHandler extends IHttpHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ResourceHttpHandler Members | Dart.PowerWEB.TextBox Namespace


ResourceHttpHandler Members

ResourceHttpHandler overview

Public Instance Constructors

ResourceHttpHandler Constructor Initializes a new instance of the ResourceHttpHandler class.

Public Instance Properties

IsReusable This property is used to indicate that the object instance can be used by other requests. It always returns true.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRequest | Load the resource specified in the query string and return it as the HTTP response.
ReadBinaryResource | Read a binary resource such as an image in from the stream. Since the size of the resource cannot be obtained, it is read in a block at a time until the end of the stream is reached.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceHttpHandler Class | Dart.PowerWEB.TextBox Namespace


ResourceHttpHandler Constructor

Initializes a new instance of the ResourceHttpHandler class.

[Visual Basic]
Public Sub New()
[C#]
public ResourceHttpHandler();
[C++]
public: ResourceHttpHandler();
[JScript]
public function ResourceHttpHandler();

See Also

ResourceHttpHandler Class | Dart.PowerWEB.TextBox Namespace


ResourceHttpHandler Properties

The properties of the ResourceHttpHandler class are listed below. For a complete list of ResourceHttpHandler class members, see the ResourceHttpHandler Members topic.

Public Instance Properties

IsReusable This property is used to indicate that the object instance can be used by other requests. It always returns true.

See Also

ResourceHttpHandler Class | Dart.PowerWEB.TextBox Namespace


IsReusable Property

ResourceHttpHandler.IsReusable Property

This property is used to indicate that the object instance can be used by other requests. It always returns true.

[Visual Basic]
Public Property ReadOnly IsReusable As Boolean _
    Implements IHttpHandler.IsReusable
[C#]
public bool IsReusable { get; }
[C++]
public: __property bool get_IsReusable();
[JScript]
public function get IsReusable() : bool

Implements

IHttpHandler.IsReusable

See Also

ResourceHttpHandler Class | Dart.PowerWEB.TextBox Namespace


ResourceHttpHandler Methods

The methods of the ResourceHttpHandler class are listed below. For a complete list of ResourceHttpHandler class members, see the ResourceHttpHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRequest | Load the resource specified in the query string and return it as the HTTP response.
ReadBinaryResource | Read a binary resource such as an image in from the stream. Since the size of the resource cannot be obtained, it is read in a block at a time until the end of the stream is reached.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceHttpHandler Class | Dart.PowerWEB.TextBox Namespace


ProcessRequest Method

ResourceHttpHandler.ProcessRequest Method

Load the resource specified in the query string and return it as the HTTP response.

[Visual Basic]
Public Sub ProcessRequest( _
   ByVal hc As HttpContext _
) _
    Implements IHttpHandler.ProcessRequest
[C#]
public void ProcessRequest(
   HttpContext hc
);
[C++]
public: void ProcessRequest(
   HttpContext* hc
);
[JScript]
public function ProcessRequest(
   HttpContext hc
);

Parameters

hc
The context object for the request

Implements

IHttpHandler.ProcessRequest

See Also

ResourceHttpHandler Class | Dart.PowerWEB.TextBox Namespace


ReadBinaryResource Method

ResourceHttpHandler.ReadBinaryResource Method

Read a binary resource such as an image in from the stream. Since the size of the resource cannot be obtained, it is read in a block at a time until the end of the stream is reached.

[Visual Basic]
Public Sub ReadBinaryResource( _
   ByVal sIn As Stream, _
   ByRef byBuffer As Byte(), _
   ByRef nLen As Integer _
)
[C#]
public void ReadBinaryResource(
   Stream sIn,
   out byte[] byBuffer,
   out int nLen
);
[C++]
public: void ReadBinaryResource(
   Stream* sIn,
   * char byBuffer __gc[],
   * int nLen
);
[JScript]
public function ReadBinaryResource(
   Stream sIn,
   Byte[] byBuffer,
   int nLen
);

Parameters

sIn
The stream from which to read the resource
byBuffer
An out parameter to receive the resource bytes
nLen
An out parameter to receive the resource length

See Also

ResourceHttpHandler Class | Dart.PowerWEB.TextBox Namespace


RightClickBehavior Enumeration

Enumerates what occurs when the user right-clicks on the HtmlBox.

[Visual Basic]
Public Enum RightClickBehavior
[C#]
public enum RightClickBehavior
[C++]
public __value enum RightClickBehavior
[JScript]
public enum RightClickBehavior

Members

Member Name | Description
Nothing | Nothing is displayed. The right-click event is suppressed.
HtmlBoxMenu | A context-sensitive HtmlBox menu is displayed.
WindowsMenu | The standard windows right-click menu is displayed.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


SgmlDtd Class

For a list of all members of this type, see SgmlDtd Members.

System.Object
Dart.PowerWEB.TextBox.SgmlDtd

[Visual Basic]
Public Class SgmlDtd
[C#]
public class SgmlDtd
[C++]
public __gc class SgmlDtd
[JScript]
public class SgmlDtd

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

SgmlDtd Members | Dart.PowerWEB.TextBox Namespace


SgmlDtd Members

SgmlDtd overview

Public Static (Shared) Methods

Parse Overloaded.

Public Instance Constructors

SgmlDtd Constructor

Public Instance Fields

Name

Public Instance Properties

NameTable

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindElement |
FindEntity |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


SgmlDtd Constructor

[Visual Basic]
Public Sub New( _
   ByVal name As String, _
   ByVal nt As XmlNameTable _
)
[C#]
public SgmlDtd(
   string name,
   XmlNameTable nt
);
[C++]
public: SgmlDtd(
   String* name,
   XmlNameTable* nt
);
[JScript]
public function SgmlDtd(
   String name,
   XmlNameTable nt
);

Parameters

name
nt

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


SgmlDtd Fields

The fields of the SgmlDtd class are listed below. For a complete list of SgmlDtd class members, see the SgmlDtd Members topic.

Public Instance Fields

Name

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


Name Field

SgmlDtd.Name Field

[Visual Basic]
Public Name As String
[C#]
public string Name;
[C++]
public: String* Name;
[JScript]
public var Name: String;

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


SgmlDtd Properties

The properties of the SgmlDtd class are listed below. For a complete list of SgmlDtd class members, see the SgmlDtd Members topic.

Public Instance Properties

NameTable

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


NameTable Property

SgmlDtd.NameTable Property

[Visual Basic]
Public Property ReadOnly NameTable As XmlNameTable
[C#]
public XmlNameTable NameTable { get; }
[C++]
public: __property XmlNameTable* get_NameTable();
[JScript]
public function get NameTable() : XmlNameTable

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


SgmlDtd Methods

The methods of the SgmlDtd class are listed below. For a complete list of SgmlDtd class members, see the SgmlDtd Members topic.

Public Static (Shared) Methods

Parse Overloaded.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindElement |
FindEntity |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


FindElement Method

SgmlDtd.FindElement Method

[Visual Basic]
Public Function FindElement( _
   ByVal name As String _
) As ElementDecl
[C#]
public ElementDecl FindElement(
   string name
);
[C++]
public: ElementDecl* FindElement(
   String* name
);
[JScript]
public function FindElement(
   String name
): ElementDecl;

Parameters

name

Return Value

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


FindEntity Method

SgmlDtd.FindEntity Method

[Visual Basic]
Public Function FindEntity( _
   ByVal name As String _
) As Entity
[C#]
public Entity FindEntity(
   string name
);
[C++]
public: Entity* FindEntity(
   String* name
);
[JScript]
public function FindEntity(
   String name
): Entity;

Parameters

name

Return Value

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


Parse Method

SgmlDtd.Parse Method

Overload List

[Visual Basic] Shared OverloadsPublic Function Parse(ByVal Uri,ByVal String,ByVal String,ByVal TextReader,ByVal String,ByVal String,ByVal XmlNameTable) As SgmlDtd
[C#] public static SgmlDtd Parse(Uri,string,string,TextReader,string,string,XmlNameTable);
[C++] public: static SgmlDtd* Parse(Uri*,String*,String*,TextReader*,String*,String*,XmlNameTable*);
[JScript] public static function Parse(Uri,String,String,TextReader,String,String,XmlNameTable): SgmlDtd;

[Visual Basic] Shared OverloadsPublic Function Parse(ByVal Uri,ByVal String,ByVal String,ByVal String,ByVal String,ByVal String,ByVal XmlNameTable) As SgmlDtd
[C#] public static SgmlDtd Parse(Uri,string,string,string,string,string,XmlNameTable);
[C++] public: static SgmlDtd* Parse(Uri*,String*,String*,String*,String*,String*,XmlNameTable*);
[JScript] public static function Parse(Uri,String,String,String,String,String,XmlNameTable): SgmlDtd;

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace


Parse Method (Uri, String, String, TextReader, String, String, XmlNameTable)

SgmlDtd.Parse Method (Uri, String, String, TextReader, String, String, XmlNameTable)

[Visual Basic]
Shared  OverloadsPublic Function Parse( _
   ByVal baseUri As Uri, _
   ByVal name As String, _
   ByVal pubid As String, _
   ByVal input As TextReader, _
   ByVal subset As String, _
   ByVal proxy As String, _
   ByVal nt As XmlNameTable _
) As SgmlDtd
[C#]
public static SgmlDtd Parse(
   Uri baseUri,
   string name,
   string pubid,
   TextReader input,
   string subset,
   string proxy,
   XmlNameTable nt
);
[C++]
public: static SgmlDtd* Parse(
   Uri* baseUri,
   String* name,
   String* pubid,
   TextReader* input,
   String* subset,
   String* proxy,
   XmlNameTable* nt
);
[JScript]
public static function Parse(
   Uri baseUri,
   String name,
   String pubid,
   TextReader input,
   String subset,
   String proxy,
   XmlNameTable nt
): SgmlDtd;

Parameters

baseUri
name
pubid
input
subset
proxy
nt

Return Value

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace | SgmlDtd.Parse Overload List


Parse Method (Uri, String, String, String, String, String, XmlNameTable)

SgmlDtd.Parse Method (Uri, String, String, String, String, String, XmlNameTable)

[Visual Basic]
Shared  OverloadsPublic Function Parse( _
   ByVal baseUri As Uri, _
   ByVal name As String, _
   ByVal pubid As String, _
   ByVal url As String, _
   ByVal subset As String, _
   ByVal proxy As String, _
   ByVal nt As XmlNameTable _
) As SgmlDtd
[C#]
public static SgmlDtd Parse(
   Uri baseUri,
   string name,
   string pubid,
   string url,
   string subset,
   string proxy,
   XmlNameTable nt
);
[C++]
public: static SgmlDtd* Parse(
   Uri* baseUri,
   String* name,
   String* pubid,
   String* url,
   String* subset,
   String* proxy,
   XmlNameTable* nt
);
[JScript]
public static function Parse(
   Uri baseUri,
   String name,
   String pubid,
   String url,
   String subset,
   String proxy,
   XmlNameTable nt
): SgmlDtd;

Parameters

baseUri
name
pubid
url
subset
proxy
nt

Return Value

See Also

SgmlDtd Class | Dart.PowerWEB.TextBox Namespace | SgmlDtd.Parse Overload List


SgmlReader Class

SgmlReader is an XmlReader API over any SGML document (including built in support for HTML).

For a list of all members of this type, see SgmlReader Members.

System.Object
System.Xml.XmlReader
Dart.PowerWEB.TextBox.SgmlReader

[Visual Basic]
Public Class SgmlReader
    Inherits XmlReader
[C#]
public class SgmlReader : XmlReader
[C++]
public __gc class SgmlReader : public XmlReader
[JScript]
public class SgmlReader extends XmlReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

SgmlReader Members | Dart.PowerWEB.TextBox Namespace


SgmlReader Members

SgmlReader overview

Public Instance Constructors

SgmlReader Constructor

Public Instance Properties

AttributeCount | Overidden.
BaseURI | Overidden.
CanResolveEntity (inherited from XmlReader) | Gets a value indicating whether this reader can parse and resolve entities.
CaseFolding |
Depth | Overidden.
DocType | The name of root element specified in the DOCTYPE tag.
Dtd | Specify the SgmlDtd object directly. This allows you to cache the Dtd and share it across multipl SgmlReaders. To load a DTD from a URL use the SystemLiteral property.
EOF | Overidden.
ErrorLog | DTD validation errors are written to this stream.
ErrorLogFile | DTD validation errors are written to this log file.
HasAttributes (inherited from XmlReader) | Gets a value indicating whether the current node has any attributes.
HasValue | Overidden.
Href | Specify the location of the input SGML document as a URL.
InputStream | The input stream containing SGML data to parse. You must specify this property or the Href property before calling Read().
InternalSubset | The DTD internal subset in the DOCTYPE tag
IsDefault | Overidden.
IsEmptyElement | Overidden.
Item | Overloaded.
LocalName | Overidden.
Name | Overidden.
NamespaceURI | Overidden.
NameTable | Overidden.
NodeType | Overidden.
Prefix | Overidden.
PublicIdentifier | The PUBLIC identifier in the DOCTYPE tag
QuoteChar | Overidden.
ReadState | Overidden.
StripDocType | Whether to strip out the DOCTYPE tag from the output (default true)
SystemLiteral | The SYSTEM literal in the DOCTYPE tag identifying the location of the DTD.
Value | Overidden.
WebProxy | Sometimes you need to specify a proxy server in order to load data via HTTP from outside the firewall. For example: "itgproxy:80".
WhitespaceHandling |
XmlLang | Overidden.
XmlSpace | Overidden.

Public Instance Methods

Close | Overidden.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute | Overloaded.
GetEncoding |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStartElement (inherited from XmlReader) | Overloaded. Calls MoveToContent and tests if the current content node is a start tag or empty element tag and if the LocalName and NamespaceURI properties of the element found match the given strings.
LookupNamespace | Overidden.
MoveToAttribute | Overloaded.
MoveToContent (inherited from XmlReader) | Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity ) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.
MoveToElement | Overidden.
MoveToFirstAttribute | Overidden.
MoveToNextAttribute | Overidden.
Read | Overidden.
ReadAttributeValue | Overidden.
ReadElementString (inherited from XmlReader) | Overloaded. Checks that the LocalName and NamespaceURI properties of the element found matches the given strings before reading a text-only element.
ReadEndElement (inherited from XmlReader) | Checks that the current content node is an end tag and advances the reader to the next node.
ReadInnerXml | Overidden.
ReadOuterXml | Overidden.
ReadStartElement (inherited from XmlReader) | Overloaded. Checks that the current content node is an element with the given LocalName and NamespaceURI and advances the reader to the next node.
ReadString | Overidden.
ResolveEntity | Overidden.
ScanLiteral |
SetBaseUri | The base Uri is used to resolve relative Uri's like the SystemLiteral and Href properties. This is a method because BaseURI is a read-only property on the base XmlReader class.
Skip (inherited from XmlReader) | Skips the children of the current node.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


SgmlReader Constructor

[Visual Basic]
Public Sub New()
[C#]
public SgmlReader();
[C++]
public: SgmlReader();
[JScript]
public function SgmlReader();

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


SgmlReader Properties

The properties of the SgmlReader class are listed below. For a complete list of SgmlReader class members, see the SgmlReader Members topic.

Public Instance Properties

AttributeCount | Overidden.
BaseURI | Overidden.
CanResolveEntity (inherited from XmlReader) | Gets a value indicating whether this reader can parse and resolve entities.
CaseFolding |
Depth | Overidden.
DocType | The name of root element specified in the DOCTYPE tag.
Dtd | Specify the SgmlDtd object directly. This allows you to cache the Dtd and share it across multipl SgmlReaders. To load a DTD from a URL use the SystemLiteral property.
EOF | Overidden.
ErrorLog | DTD validation errors are written to this stream.
ErrorLogFile | DTD validation errors are written to this log file.
HasAttributes (inherited from XmlReader) | Gets a value indicating whether the current node has any attributes.
HasValue | Overidden.
Href | Specify the location of the input SGML document as a URL.
InputStream | The input stream containing SGML data to parse. You must specify this property or the Href property before calling Read().
InternalSubset | The DTD internal subset in the DOCTYPE tag
IsDefault | Overidden.
IsEmptyElement | Overidden.
Item | Overloaded.
LocalName | Overidden.
Name | Overidden.
NamespaceURI | Overidden.
NameTable | Overidden.
NodeType | Overidden.
Prefix | Overidden.
PublicIdentifier | The PUBLIC identifier in the DOCTYPE tag
QuoteChar | Overidden.
ReadState | Overidden.
StripDocType | Whether to strip out the DOCTYPE tag from the output (default true)
SystemLiteral | The SYSTEM literal in the DOCTYPE tag identifying the location of the DTD.
Value | Overidden.
WebProxy | Sometimes you need to specify a proxy server in order to load data via HTTP from outside the firewall. For example: "itgproxy:80".
WhitespaceHandling |
XmlLang | Overidden.
XmlSpace | Overidden.

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


AttributeCount Property

SgmlReader.AttributeCount Property

[Visual Basic]
Overrides Public Property ReadOnly AttributeCount As Integer
[C#]
public override int AttributeCount { get; }
[C++]
public: __property int get_AttributeCount();
[JScript]
public override function get AttributeCount() : int

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


BaseURI Property

SgmlReader.BaseURI Property

[Visual Basic]
Overrides Public Property ReadOnly BaseURI As String
[C#]
public override string BaseURI { get; }
[C++]
public: __property String* get_BaseURI();
[JScript]
public override function get BaseURI() : String

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


CaseFolding Property

SgmlReader.CaseFolding Property

[Visual Basic]
Public Property CaseFolding As CaseFolding
[C#]
public CaseFolding CaseFolding { get; set; }
[C++]
public: __property CaseFolding get_CaseFolding();
public: __property void set_CaseFolding(CaseFolding );
[JScript]
public function get CaseFolding() : CaseFolding
public function set CaseFolding(CaseFolding);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Depth Property

SgmlReader.Depth Property

[Visual Basic]
Overrides Public Property ReadOnly Depth As Integer
[C#]
public override int Depth { get; }
[C++]
public: __property int get_Depth();
[JScript]
public override function get Depth() : int

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


DocType Property

SgmlReader.DocType Property

The name of root element specified in the DOCTYPE tag.

[Visual Basic]
Public Property DocType As String
[C#]
public string DocType { get; set; }
[C++]
public: __property String* get_DocType();
public: __property void set_DocType(String* );
[JScript]
public function get DocType() : String
public function set DocType(String);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Dtd Property

SgmlReader.Dtd Property

Specify the SgmlDtd object directly. This allows you to cache the Dtd and share it across multipl SgmlReaders. To load a DTD from a URL use the SystemLiteral property.

[Visual Basic]
Public Property Dtd As SgmlDtd
[C#]
public SgmlDtd Dtd { get; set; }
[C++]
public: __property SgmlDtd* get_Dtd();
public: __property void set_Dtd(SgmlDtd* );
[JScript]
public function get Dtd() : SgmlDtd
public function set Dtd(SgmlDtd);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


EOF Property

SgmlReader.EOF Property

[Visual Basic]
Overrides Public Property ReadOnly EOF As Boolean
[C#]
public override bool EOF { get; }
[C++]
public: __property bool get_EOF();
[JScript]
public override function get EOF() : bool

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


ErrorLog Property

SgmlReader.ErrorLog Property

DTD validation errors are written to this stream.

[Visual Basic]
Public Property ErrorLog As TextWriter
[C#]
public TextWriter ErrorLog { get; set; }
[C++]
public: __property TextWriter* get_ErrorLog();
public: __property void set_ErrorLog(TextWriter* );
[JScript]
public function get ErrorLog() : TextWriter
public function set ErrorLog(TextWriter);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


ErrorLogFile Property

SgmlReader.ErrorLogFile Property

DTD validation errors are written to this log file.

[Visual Basic]
Public Property ErrorLogFile As String
[C#]
public string ErrorLogFile { get; set; }
[C++]
public: __property String* get_ErrorLogFile();
public: __property void set_ErrorLogFile(String* );
[JScript]
public function get ErrorLogFile() : String
public function set ErrorLogFile(String);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


HasValue Property

SgmlReader.HasValue Property

[Visual Basic]
Overrides Public Property ReadOnly HasValue As Boolean
[C#]
public override bool HasValue { get; }
[C++]
public: __property bool get_HasValue();
[JScript]
public override function get HasValue() : bool

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Href Property

SgmlReader.Href Property

Specify the location of the input SGML document as a URL.

[Visual Basic]
Public Property Href As String
[C#]
public string Href { get; set; }
[C++]
public: __property String* get_Href();
public: __property void set_Href(String* );
[JScript]
public function get Href() : String
public function set Href(String);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


InputStream Property

SgmlReader.InputStream Property

The input stream containing SGML data to parse. You must specify this property or the Href property before calling Read().

[Visual Basic]
Public Property InputStream As TextReader
[C#]
public TextReader InputStream { get; set; }
[C++]
public: __property TextReader* get_InputStream();
public: __property void set_InputStream(TextReader* );
[JScript]
public function get InputStream() : TextReader
public function set InputStream(TextReader);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


InternalSubset Property

SgmlReader.InternalSubset Property

The DTD internal subset in the DOCTYPE tag

[Visual Basic]
Public Property InternalSubset As String
[C#]
public string InternalSubset { get; set; }
[C++]
public: __property String* get_InternalSubset();
public: __property void set_InternalSubset(String* );
[JScript]
public function get InternalSubset() : String
public function set InternalSubset(String);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


IsDefault Property

SgmlReader.IsDefault Property

[Visual Basic]
Overrides Public Property ReadOnly IsDefault As Boolean
[C#]
public override bool IsDefault { get; }
[C++]
public: __property bool get_IsDefault();
[JScript]
public override function get IsDefault() : bool

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


IsEmptyElement Property

SgmlReader.IsEmptyElement Property

[Visual Basic]
Overrides Public Property ReadOnly IsEmptyElement As Boolean
[C#]
public override bool IsEmptyElement { get; }
[C++]
public: __property bool get_IsEmptyElement();
[JScript]
public override function get IsEmptyElement() : bool

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Item Property

SgmlReader.Item Property

Overload List

[Visual Basic] Overrides OverloadsPublic Default Property ReadOnly Item(ByVal Integer) As String
[C#] public override string this[int] { get; }
[C++] public: __property String* get_Item(int);

[Visual Basic] Overrides OverloadsPublic Default Property ReadOnly Item(ByVal String) As String
[C#] public override string this[string] { get; }
[C++] public: __property String* get_Item(String*);

[Visual Basic] Overrides OverloadsPublic Default Property ReadOnly Item(ByVal String,ByVal String) As String
[C#] public override string this[string,string] { get; }
[C++] public: __property String* get_Item(String*,String*);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Item Property (Int32)

SgmlReader.Item Property (Int32)

[C#] In C#, this property is the indexer for the SgmlReader class.

[Visual Basic]
Overrides  OverloadsPublic Default Property ReadOnly Item( _
   ByVal i As Integer _
) As String
[C#]
public override string this[
   int i
] { get; }
[C++]
public: __property String* get_Item(
   int i
);
[JScript]
returnValue = SgmlReaderObject.Item( i );
-or-
returnValue = SgmlReaderObject( i );

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace | SgmlReader.Item Overload List


Item Property (String)

SgmlReader.Item Property (String)

[C#] In C#, this property is the indexer for the SgmlReader class.

[Visual Basic]
Overrides  OverloadsPublic Default Property ReadOnly Item( _
   ByVal name As String _
) As String
[C#]
public override string this[
   string name
] { get; }
[C++]
public: __property String* get_Item(
   String* name
);
[JScript]
returnValue = SgmlReaderObject.Item( name );
-or-
returnValue = SgmlReaderObject( name );

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace | SgmlReader.Item Overload List


Item Property (String, String)

SgmlReader.Item Property (String, String)

[C#] In C#, this property is the indexer for the SgmlReader class.

[Visual Basic]
Overrides  OverloadsPublic Default Property ReadOnly Item( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public override string this[
   string name,
   string namespaceURI
] { get; }
[C++]
public: __property String* get_Item(
   String* name,
   String* namespaceURI
);
[JScript]
returnValue = SgmlReaderObject.Item( name, namespaceURI );
-or-
returnValue = SgmlReaderObject( name, namespaceURI );

[JScript] In JScript, you can use the default indexed properties defined by a type, but you cannot explicitly define your own. However, specifying the expando attribute on a class automatically provides a default indexed property whose type is Object and whose index type is String.

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace | SgmlReader.Item Overload List


LocalName Property

SgmlReader.LocalName Property

[Visual Basic]
Overrides Public Property ReadOnly LocalName As String
[C#]
public override string LocalName { get; }
[C++]
public: __property String* get_LocalName();
[JScript]
public override function get LocalName() : String

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Name Property

SgmlReader.Name Property

[Visual Basic]
Overrides Public Property ReadOnly Name As String
[C#]
public override string Name { get; }
[C++]
public: __property String* get_Name();
[JScript]
public override function get Name() : String

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


NamespaceURI Property

SgmlReader.NamespaceURI Property

[Visual Basic]
Overrides Public Property ReadOnly NamespaceURI As String
[C#]
public override string NamespaceURI { get; }
[C++]
public: __property String* get_NamespaceURI();
[JScript]
public override function get NamespaceURI() : String

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


NameTable Property

SgmlReader.NameTable Property

[Visual Basic]
Overrides Public Property ReadOnly NameTable As XmlNameTable
[C#]
public override XmlNameTable NameTable { get; }
[C++]
public: __property XmlNameTable* get_NameTable();
[JScript]
public override function get NameTable() : XmlNameTable

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


NodeType Property

SgmlReader.NodeType Property

[Visual Basic]
Overrides Public Property ReadOnly NodeType As XmlNodeType
[C#]
public override XmlNodeType NodeType { get; }
[C++]
public: __property XmlNodeType get_NodeType();
[JScript]
public override function get NodeType() : XmlNodeType

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Prefix Property

SgmlReader.Prefix Property

[Visual Basic]
Overrides Public Property ReadOnly Prefix As String
[C#]
public override string Prefix { get; }
[C++]
public: __property String* get_Prefix();
[JScript]
public override function get Prefix() : String

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


PublicIdentifier Property

SgmlReader.PublicIdentifier Property

The PUBLIC identifier in the DOCTYPE tag

[Visual Basic]
Public Property PublicIdentifier As String
[C#]
public string PublicIdentifier { get; set; }
[C++]
public: __property String* get_PublicIdentifier();
public: __property void set_PublicIdentifier(String* );
[JScript]
public function get PublicIdentifier() : String
public function set PublicIdentifier(String);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


QuoteChar Property

SgmlReader.QuoteChar Property

[Visual Basic]
Overrides Public Property ReadOnly QuoteChar As Char
[C#]
public override char QuoteChar { get; }
[C++]
public: __property wchar_t get_QuoteChar();
[JScript]
public override function get QuoteChar() : char

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


ReadState Property

SgmlReader.ReadState Property

[Visual Basic]
Overrides Public Property ReadOnly ReadState As ReadState
[C#]
public override ReadState ReadState { get; }
[C++]
public: __property ReadState get_ReadState();
[JScript]
public override function get ReadState() : ReadState

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


StripDocType Property

SgmlReader.StripDocType Property

Whether to strip out the DOCTYPE tag from the output (default true)

[Visual Basic]
Public Property StripDocType As Boolean
[C#]
public bool StripDocType { get; set; }
[C++]
public: __property bool get_StripDocType();
public: __property void set_StripDocType(bool );
[JScript]
public function get StripDocType() : bool
public function set StripDocType(bool);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


SystemLiteral Property

SgmlReader.SystemLiteral Property

The SYSTEM literal in the DOCTYPE tag identifying the location of the DTD.

[Visual Basic]
Public Property SystemLiteral As String
[C#]
public string SystemLiteral { get; set; }
[C++]
public: __property String* get_SystemLiteral();
public: __property void set_SystemLiteral(String* );
[JScript]
public function get SystemLiteral() : String
public function set SystemLiteral(String);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Value Property

SgmlReader.Value Property

[Visual Basic]
Overrides Public Property ReadOnly Value As String
[C#]
public override string Value { get; }
[C++]
public: __property String* get_Value();
[JScript]
public override function get Value() : String

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


WebProxy Property

SgmlReader.WebProxy Property

Sometimes you need to specify a proxy server in order to load data via HTTP from outside the firewall. For example: "itgproxy:80".

[Visual Basic]
Public Property WebProxy As String
[C#]
public string WebProxy { get; set; }
[C++]
public: __property String* get_WebProxy();
public: __property void set_WebProxy(String* );
[JScript]
public function get WebProxy() : String
public function set WebProxy(String);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


WhitespaceHandling Property

SgmlReader.WhitespaceHandling Property

[Visual Basic]
Public Property WhitespaceHandling As WhitespaceHandling
[C#]
public WhitespaceHandling WhitespaceHandling { get; set; }
[C++]
public: __property WhitespaceHandling get_WhitespaceHandling();
public: __property void set_WhitespaceHandling(WhitespaceHandling );
[JScript]
public function get WhitespaceHandling() : WhitespaceHandling
public function set WhitespaceHandling(WhitespaceHandling);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


XmlLang Property

SgmlReader.XmlLang Property

[Visual Basic]
Overrides Public Property ReadOnly XmlLang As String
[C#]
public override string XmlLang { get; }
[C++]
public: __property String* get_XmlLang();
[JScript]
public override function get XmlLang() : String

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


XmlSpace Property

SgmlReader.XmlSpace Property

[Visual Basic]
Overrides Public Property ReadOnly XmlSpace As XmlSpace
[C#]
public override XmlSpace XmlSpace { get; }
[C++]
public: __property XmlSpace get_XmlSpace();
[JScript]
public override function get XmlSpace() : XmlSpace

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


SgmlReader Methods

The methods of the SgmlReader class are listed below. For a complete list of SgmlReader class members, see the SgmlReader Members topic.

Public Instance Methods

Close | Overidden.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAttribute | Overloaded.
GetEncoding |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStartElement (inherited from XmlReader) | Overloaded. Calls MoveToContent and tests if the current content node is a start tag or empty element tag and if the LocalName and NamespaceURI properties of the element found match the given strings.
LookupNamespace | Overidden.
MoveToAttribute | Overloaded.
MoveToContent (inherited from XmlReader) | Checks whether the current node is a content (non-white space text, CDATA, Element, EndElement, EntityReference, or EndEntity ) node. If the node is not a content node, the reader skips ahead to the next content node or end of file. It skips over nodes of the following type: ProcessingInstruction, DocumentType, Comment, Whitespace, or SignificantWhitespace.
MoveToElement | Overidden.
MoveToFirstAttribute | Overidden.
MoveToNextAttribute | Overidden.
Read | Overidden.
ReadAttributeValue | Overidden.
ReadElementString (inherited from XmlReader) | Overloaded. Checks that the LocalName and NamespaceURI properties of the element found matches the given strings before reading a text-only element.
ReadEndElement (inherited from XmlReader) | Checks that the current content node is an end tag and advances the reader to the next node.
ReadInnerXml | Overidden.
ReadOuterXml | Overidden.
ReadStartElement (inherited from XmlReader) | Overloaded. Checks that the current content node is an element with the given LocalName and NamespaceURI and advances the reader to the next node.
ReadString | Overidden.
ResolveEntity | Overidden.
ScanLiteral |
SetBaseUri | The base Uri is used to resolve relative Uri's like the SystemLiteral and Href properties. This is a method because BaseURI is a read-only property on the base XmlReader class.
Skip (inherited from XmlReader) | Skips the children of the current node.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Close Method

SgmlReader.Close Method

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();
[C++]
public: void Close();
[JScript]
public override function Close();

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


GetAttribute Method

SgmlReader.GetAttribute Method

Overload List

[Visual Basic] Overrides OverloadsPublic Function GetAttribute(ByVal Integer) As String
[C#] public override string GetAttribute(int);
[C++] public: String* GetAttribute(int);
[JScript] public override function GetAttribute(int): String;

[Visual Basic] Overrides OverloadsPublic Function GetAttribute(ByVal String) As String
[C#] public override string GetAttribute(string);
[C++] public: String* GetAttribute(String*);
[JScript] public override function GetAttribute(String): String;

[Visual Basic] Overrides OverloadsPublic Function GetAttribute(ByVal String,ByVal String) As String
[C#] public override string GetAttribute(string,string);
[C++] public: String* GetAttribute(String*,String*);
[JScript] public override function GetAttribute(String,String): String;

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


GetAttribute Method (Int32)

SgmlReader.GetAttribute Method (Int32)

[Visual Basic]
Overrides  OverloadsPublic Function GetAttribute( _
   ByVal i As Integer _
) As String
[C#]
public override string GetAttribute(
   int i
);
[C++]
public: String* GetAttribute(
   int i
);
[JScript]
public override function GetAttribute(
   int i
): String;

Parameters

i

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace | SgmlReader.GetAttribute Overload List


GetAttribute Method (String)

SgmlReader.GetAttribute Method (String)

[Visual Basic]
Overrides  OverloadsPublic Function GetAttribute( _
   ByVal name As String _
) As String
[C#]
public override string GetAttribute(
   string name
);
[C++]
public: String* GetAttribute(
   String* name
);
[JScript]
public override function GetAttribute(
   String name
): String;

Parameters

name

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace | SgmlReader.GetAttribute Overload List


GetAttribute Method (String, String)

SgmlReader.GetAttribute Method (String, String)

[Visual Basic]
Overrides  OverloadsPublic Function GetAttribute( _
   ByVal name As String, _
   ByVal namespaceURI As String _
) As String
[C#]
public override string GetAttribute(
   string name,
   string namespaceURI
);
[C++]
public: String* GetAttribute(
   String* name,
   String* namespaceURI
);
[JScript]
public override function GetAttribute(
   String name,
   String namespaceURI
): String;

Parameters

name
namespaceURI

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace | SgmlReader.GetAttribute Overload List


GetEncoding Method

SgmlReader.GetEncoding Method

[Visual Basic]
Public Function GetEncoding() As Encoding
[C#]
public Encoding GetEncoding();
[C++]
public: Encoding* GetEncoding();
[JScript]
public function GetEncoding(): Encoding;

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


LookupNamespace Method

SgmlReader.LookupNamespace Method

[Visual Basic]
Overrides Public Function LookupNamespace( _
   ByVal prefix As String _
) As String
[C#]
public override string LookupNamespace(
   string prefix
);
[C++]
public: String* LookupNamespace(
   String* prefix
);
[JScript]
public override function LookupNamespace(
   String prefix
): String;

Parameters

prefix

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


MoveToAttribute Method

SgmlReader.MoveToAttribute Method

Overload List

[Visual Basic] Overrides OverloadsPublic Sub MoveToAttribute(ByVal Integer)
[C#] public override void MoveToAttribute(int);
[C++] public: void MoveToAttribute(int);
[JScript] public override function MoveToAttribute(int);

[Visual Basic] Overrides OverloadsPublic Function MoveToAttribute(ByVal String) As Boolean
[C#] public override bool MoveToAttribute(string);
[C++] public: bool MoveToAttribute(String*);
[JScript] public override function MoveToAttribute(String): bool;

[Visual Basic] Overrides OverloadsPublic Function MoveToAttribute(ByVal String,ByVal String) As Boolean
[C#] public override bool MoveToAttribute(string,string);
[C++] public: bool MoveToAttribute(String*,String*);
[JScript] public override function MoveToAttribute(String,String): bool;

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


MoveToAttribute Method (Int32)

SgmlReader.MoveToAttribute Method (Int32)

[Visual Basic]
Overrides  OverloadsPublic Sub MoveToAttribute( _
   ByVal i As Integer _
)
[C#]
public override void MoveToAttribute(
   int i
);
[C++]
public: void MoveToAttribute(
   int i
);
[JScript]
public override function MoveToAttribute(
   int i
);

Parameters

i

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace | SgmlReader.MoveToAttribute Overload List


MoveToAttribute Method (String)

SgmlReader.MoveToAttribute Method (String)

[Visual Basic]
Overrides  OverloadsPublic Function MoveToAttribute( _
   ByVal name As String _
) As Boolean
[C#]
public override bool MoveToAttribute(
   string name
);
[C++]
public: bool MoveToAttribute(
   String* name
);
[JScript]
public override function MoveToAttribute(
   String name
): bool;

Parameters

name

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace | SgmlReader.MoveToAttribute Overload List


MoveToAttribute Method (String, String)

SgmlReader.MoveToAttribute Method (String, String)

[Visual Basic]
Overrides  OverloadsPublic Function MoveToAttribute( _
   ByVal name As String, _
   ByVal ns As String _
) As Boolean
[C#]
public override bool MoveToAttribute(
   string name,
   string ns
);
[C++]
public: bool MoveToAttribute(
   String* name,
   String* ns
);
[JScript]
public override function MoveToAttribute(
   String name,
   String ns
): bool;

Parameters

name
ns

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace | SgmlReader.MoveToAttribute Overload List


MoveToElement Method

SgmlReader.MoveToElement Method

[Visual Basic]
Overrides Public Function MoveToElement() As Boolean
[C#]
public override bool MoveToElement();
[C++]
public: bool MoveToElement();
[JScript]
public override function MoveToElement(): bool;

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


MoveToFirstAttribute Method

SgmlReader.MoveToFirstAttribute Method

[Visual Basic]
Overrides Public Function MoveToFirstAttribute() As Boolean
[C#]
public override bool MoveToFirstAttribute();
[C++]
public: bool MoveToFirstAttribute();
[JScript]
public override function MoveToFirstAttribute(): bool;

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


MoveToNextAttribute Method

SgmlReader.MoveToNextAttribute Method

[Visual Basic]
Overrides Public Function MoveToNextAttribute() As Boolean
[C#]
public override bool MoveToNextAttribute();
[C++]
public: bool MoveToNextAttribute();
[JScript]
public override function MoveToNextAttribute(): bool;

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


Read Method

SgmlReader.Read Method

[Visual Basic]
Overrides Public Function Read() As Boolean
[C#]
public override bool Read();
[C++]
public: bool Read();
[JScript]
public override function Read(): bool;

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


ReadAttributeValue Method

SgmlReader.ReadAttributeValue Method

[Visual Basic]
Overrides Public Function ReadAttributeValue() As Boolean
[C#]
public override bool ReadAttributeValue();
[C++]
public: bool ReadAttributeValue();
[JScript]
public override function ReadAttributeValue(): bool;

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


ReadInnerXml Method

SgmlReader.ReadInnerXml Method

[Visual Basic]
Overrides Public Function ReadInnerXml() As String
[C#]
public override string ReadInnerXml();
[C++]
public: String* ReadInnerXml();
[JScript]
public override function ReadInnerXml(): String;

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


ReadOuterXml Method

SgmlReader.ReadOuterXml Method

[Visual Basic]
Overrides Public Function ReadOuterXml() As String
[C#]
public override string ReadOuterXml();
[C++]
public: String* ReadOuterXml();
[JScript]
public override function ReadOuterXml(): String;

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


ReadString Method

SgmlReader.ReadString Method

[Visual Basic]
Overrides Public Function ReadString() As String
[C#]
public override string ReadString();
[C++]
public: String* ReadString();
[JScript]
public override function ReadString(): String;

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


ResolveEntity Method

SgmlReader.ResolveEntity Method

[Visual Basic]
Overrides Public Sub ResolveEntity()
[C#]
public override void ResolveEntity();
[C++]
public: void ResolveEntity();
[JScript]
public override function ResolveEntity();

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


ScanLiteral Method

SgmlReader.ScanLiteral Method

[Visual Basic]
Public Function ScanLiteral( _
   ByVal sb As StringBuilder, _
   ByVal quote As Char _
) As String
[C#]
public string ScanLiteral(
   StringBuilder sb,
   char quote
);
[C++]
public: String* ScanLiteral(
   StringBuilder* sb,
   wchar_t quote
);
[JScript]
public function ScanLiteral(
   StringBuilder sb,
   char quote
): String;

Parameters

sb
quote

Return Value

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


SetBaseUri Method

SgmlReader.SetBaseUri Method

The base Uri is used to resolve relative Uri's like the SystemLiteral and Href properties. This is a method because BaseURI is a read-only property on the base XmlReader class.

[Visual Basic]
Public Sub SetBaseUri( _
   ByVal uri As String _
)
[C#]
public void SetBaseUri(
   string uri
);
[C++]
public: void SetBaseUri(
   String* uri
);
[JScript]
public function SetBaseUri(
   String uri
);

See Also

SgmlReader Class | Dart.PowerWEB.TextBox Namespace


StartupMode Enumeration

Enumerates the ways the HtmlBox can be started.

[Visual Basic]
Public Enum StartupMode
[C#]
public enum StartupMode
[C++]
public __value enum StartupMode
[JScript]
public enum StartupMode

Remarks

By default, the HtmlBox will be started in Design mode. Set the HtmlBox.StartupMode property to StartupMode.HTML to start the HtmlBox in HTML mode.

Members

Member Name | Description
Design | The HtmlBox will start up in design mode.
HTML | The HtmlBox will start up in HTML mode.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


StringArrayList Class

Represents a collection used to maintain strings.

For a list of all members of this type, see StringArrayList Members.

System.Object
System.Collections.ArrayList
Dart.PowerWEB.TextBox.StringArrayList

[Visual Basic]
Public Class StringArrayList
    Inherits ArrayList
[C#]
public class StringArrayList : ArrayList
[C++]
public __gc class StringArrayList : public ArrayList
[JScript]
public class StringArrayList extends ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This colllection is optimized for string handling.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

StringArrayList Members | Dart.PowerWEB.TextBox Namespace


StringArrayList Members

StringArrayList overview

Public Instance Constructors

StringArrayList Overloaded. Initializes a new instance of the StringArrayList class.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
List | Gets or sets a string of default values.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add (inherited from ArrayList) | Overloaded. Adds an object to the end of the ArrayList.
Add | Overloaded. Adds an object to the end of the collection.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Overloaded. Inserts an element into the ArrayList at the specified index.
Insert | Overloaded. Inserts an element into the collection at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace


StringArrayList Constructor

Creates a new instance of StringArrayList.

Overload List

Creates a new instance of StringArrayList.

[Visual Basic] Public Sub New()
[C#] public StringArrayList();
[C++] public: StringArrayList();
[JScript] public function StringArrayList();

Creates a new instance of StringArrayList.

[Visual Basic] Public Sub New(ByVal String)
[C#] public StringArrayList(string);
[C++] public: StringArrayList(String*);
[JScript] public function StringArrayList(String);

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace


StringArrayList Constructor ()

Creates a new instance of StringArrayList.

[Visual Basic]
Public Sub New()
[C#]
public StringArrayList();
[C++]
public: StringArrayList();
[JScript]
public function StringArrayList();

Remarks

Creates a default instance of StringArrayList.

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace | StringArrayList Constructor Overload List


StringArrayList Constructor (String)

Creates a new instance of StringArrayList.

[Visual Basic]
Public Sub New( _
   ByVal list As String _
)
[C#]
public StringArrayList(
   string list
);
[C++]
public: StringArrayList(
   String* list
);
[JScript]
public function StringArrayList(
   String list
);

Remarks

Creates a default instance of StringArrayList, supplying a comma-delimited list of default values.

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace | StringArrayList Constructor Overload List


StringArrayList Properties

The properties of the StringArrayList class are listed below. For a complete list of StringArrayList class members, see the StringArrayList Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
List | Gets or sets a string of default values.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace


List Property

StringArrayList.List Property

Gets or sets a string of default values.

[Visual Basic]
Public Property List As String
[C#]
public string List { get; set; }
[C++]
public: __property String* get_List();
public: __property void set_List(String* );
[JScript]
public function get List() : String
public function set List(String);

Remarks

When getting this property, all of the strings in the collection will be returned as a comma-delimited list. When setting this property, the comma-delimited list will be split and added to the collection as values.

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace


StringArrayList Methods

The methods of the StringArrayList class are listed below. For a complete list of StringArrayList class members, see the StringArrayList Members topic.

Public Instance Methods

Add (inherited from ArrayList) | Overloaded. Adds an object to the end of the ArrayList.
Add | Overloaded. Adds an object to the end of the collection.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert (inherited from ArrayList) | Overloaded. Inserts an element into the ArrayList at the specified index.
Insert | Overloaded. Inserts an element into the collection at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace


Add Method

StringArrayList.Add Method

Adds an object to the end of the collection.

Overload List

Adds an object to the end of the ArrayList.
Inherited from ArrayList.

[Visual Basic] Overridable OverloadsPublic Function Add(ByVal Object) _ Implements IList.Add As Integer
[C#] public virtual int Add(object);
[C++] public: virtual int Add(Object*);
[JScript] public virtual function Add(Object): int;

Adds an object to the end of the collection.

[Visual Basic] Public Function Add(ByVal String) As Integer
[C#] public int Add(string);
[C++] public: int Add(String*);
[JScript] public function Add(String): int;

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace


Add Method (String)

StringArrayList.Add Method (String)

Adds an object to the end of the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As String _
) As Integer
[C#]
public int Add(
   string value
);
[C++]
public: int Add(
   String* value
);
[JScript]
public function Add(
   String value
): int;

Parameters

value
The object to add to the end of the collection.

Return Value

The index to which value has been added.

Remarks

This method both adds an object to the end of the collection.

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace | StringArrayList.Add Overload List


Insert Method

StringArrayList.Insert Method

Inserts an element into the collection at the specified index.

Overload List

Inserts an element into the ArrayList at the specified index.
Inherited from ArrayList.

[Visual Basic] Overridable OverloadsPublic Sub Insert(ByVal Integer,ByVal Object) _ Implements IList.Insert
[C#] public virtual void Insert(int,object);
[C++] public: virtual void Insert(int,Object*);
[JScript] public virtual function Insert(int,Object);

Inserts an element into the collection at the specified index.

[Visual Basic] Public Sub Insert(ByVal Integer,ByVal String)
[C#] public void Insert(int,string);
[C++] public: void Insert(int,String*);
[JScript] public function Insert(int,String);

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace


Insert Method (Int32, String)

StringArrayList.Insert Method (Int32, String)

Inserts an element into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As String _
)
[C#]
public void Insert(
   int index,
   string value
);
[C++]
public: void Insert(
   int index,
   String* value
);
[JScript]
public function Insert(
   int index,
   String value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The object to insert.

Remarks

This method both inserts an object into the collection.

See Also

StringArrayList Class | Dart.PowerWEB.TextBox Namespace | StringArrayList.Insert Overload List


StringArrayListConverter Class

For a list of all members of this type, see StringArrayListConverter Members.

System.Object
System.ComponentModel.TypeConverter
Dart.PowerWEB.TextBox.StringArrayListConverter

[Visual Basic]
Public Class StringArrayListConverter
    Inherits TypeConverter
[C#]
public class StringArrayListConverter : TypeConverter
[C++]
public __gc class StringArrayListConverter : public TypeConverter
[JScript]
public class StringArrayListConverter extends TypeConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

StringArrayListConverter Members | Dart.PowerWEB.TextBox Namespace


StringArrayListConverter Members

StringArrayListConverter overview

Public Instance Constructors

StringArrayListConverter Constructor

Public Instance Methods

CanConvertFrom | Overidden. Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo | Overidden. Overloaded.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overidden. Overloaded.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo | Overidden. Overloaded.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace


StringArrayListConverter Constructor

[Visual Basic]
Public Sub New()
[C#]
public StringArrayListConverter();
[C++]
public: StringArrayListConverter();
[JScript]
public function StringArrayListConverter();

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace


StringArrayListConverter Methods

The methods of the StringArrayListConverter class are listed below. For a complete list of StringArrayListConverter class members, see the StringArrayListConverter Members topic.

Public Instance Methods

CanConvertFrom | Overidden. Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo | Overidden. Overloaded.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overidden. Overloaded.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo | Overidden. Overloaded.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace


CanConvertFrom Method

StringArrayListConverter.CanConvertFrom Method

Overload List

[Visual Basic] Overrides OverloadsPublic Function CanConvertFrom(ByVal ITypeDescriptorContext,ByVal Type) As Boolean
[C#] public override bool CanConvertFrom(ITypeDescriptorContext,Type);
[C++] public: bool CanConvertFrom(ITypeDescriptorContext*,Type*);
[JScript] public override function CanConvertFrom(ITypeDescriptorContext,Type): bool;

Returns whether this converter can convert an object of the given type to the type of this converter.
Inherited from TypeConverter.

[Visual Basic] Public Function CanConvertFrom(ByVal Type) As Boolean
[C#] public bool CanConvertFrom(Type);
[C++] public: bool CanConvertFrom(Type*);
[JScript] public function CanConvertFrom(Type): bool;

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

StringArrayListConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

[Visual Basic]
Overrides  OverloadsPublic Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public override function CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
): bool;

Parameters

context
sourceType

Return Value

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace | StringArrayListConverter.CanConvertFrom Overload List


CanConvertTo Method

StringArrayListConverter.CanConvertTo Method

Overload List

[Visual Basic] Overrides OverloadsPublic Function CanConvertTo(ByVal ITypeDescriptorContext,ByVal Type) As Boolean
[C#] public override bool CanConvertTo(ITypeDescriptorContext,Type);
[C++] public: bool CanConvertTo(ITypeDescriptorContext*,Type*);
[JScript] public override function CanConvertTo(ITypeDescriptorContext,Type): bool;

Returns whether this converter can convert the object to the specified type.
Inherited from TypeConverter.

[Visual Basic] Public Function CanConvertTo(ByVal Type) As Boolean
[C#] public bool CanConvertTo(Type);
[C++] public: bool CanConvertTo(Type*);
[JScript] public function CanConvertTo(Type): bool;

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace


CanConvertTo Method (ITypeDescriptorContext, Type)

StringArrayListConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

[Visual Basic]
Overrides  OverloadsPublic Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
[C#]
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
);
[C++]
public: bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
);
[JScript]
public override function CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
): bool;

Parameters

context
destinationType

Return Value

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace | StringArrayListConverter.CanConvertTo Overload List


ConvertFrom Method

StringArrayListConverter.ConvertFrom Method

Overload List

[Visual Basic] Overrides OverloadsPublic Function ConvertFrom(ByVal ITypeDescriptorContext,ByVal CultureInfo,ByVal Object) As Object
[C#] public override object ConvertFrom(ITypeDescriptorContext,CultureInfo,object);
[C++] public: Object* ConvertFrom(ITypeDescriptorContext*,CultureInfo*,Object*);
[JScript] public override function ConvertFrom(ITypeDescriptorContext,CultureInfo,Object): Object;

Converts the given value to the type of this converter.
Inherited from TypeConverter.

[Visual Basic] Public Function ConvertFrom(ByVal Object) As Object
[C#] public object ConvertFrom(object);
[C++] public: Object* ConvertFrom(Object*);
[JScript] public function ConvertFrom(Object): Object;

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

StringArrayListConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[Visual Basic]
Overrides  OverloadsPublic Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
);
[C++]
public: Object* ConvertFrom(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value
);
[JScript]
public override function ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   Object value
): Object;

Parameters

context
culture
value

Return Value

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace | StringArrayListConverter.ConvertFrom Overload List


ConvertTo Method

StringArrayListConverter.ConvertTo Method

Overload List

[Visual Basic] Overrides OverloadsPublic Function ConvertTo(ByVal ITypeDescriptorContext,ByVal CultureInfo,ByVal Object,ByVal Type) As Object
[C#] public override object ConvertTo(ITypeDescriptorContext,CultureInfo,object,Type);
[C++] public: Object* ConvertTo(ITypeDescriptorContext*,CultureInfo*,Object*,Type*);
[JScript] public override function ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type): Object;

Converts the given value object to the specified type, using the arguments.
Inherited from TypeConverter.

[Visual Basic] Public Function ConvertTo(ByVal Object,ByVal Type) As Object
[C#] public object ConvertTo(object,Type);
[C++] public: Object* ConvertTo(Object*,Type*);
[JScript] public function ConvertTo(Object,Type): Object;

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

StringArrayListConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[Visual Basic]
Overrides  OverloadsPublic Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
);
[C++]
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
);
[JScript]
public override function ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   Object value,
   Type destinationType
): Object;

Parameters

context
culture
value
destinationType

Return Value

See Also

StringArrayListConverter Class | Dart.PowerWEB.TextBox Namespace | StringArrayListConverter.ConvertTo Overload List


StringValueCollection Class

Represents a collection used to maintain string names and values.

For a list of all members of this type, see StringValueCollection Members.

System.Object
System.Collections.Specialized.NameObjectCollectionBase
System.Collections.Specialized.NameValueCollection
Dart.PowerWEB.TextBox.StringValueCollection

[Visual Basic]
Public Class StringValueCollection
    Inherits NameValueCollection
[C#]
public class StringValueCollection : NameValueCollection
[C++]
public __gc class StringValueCollection : public NameValueCollection
[JScript]
public class StringValueCollection extends NameValueCollection

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This colllection is optimized for string name and value handling.

The contents of the collection can be serialized/deserialized by using the List property.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

StringValueCollection Members | Dart.PowerWEB.TextBox Namespace


StringValueCollection Members

StringValueCollection overview

Public Instance Constructors

StringValueCollection Overloaded. Initializes a new instance of the StringValueCollection class.

Public Instance Properties

AllKeys (inherited from NameValueCollection) | Gets all the keys in the NameValueCollection.
Count (inherited from NameObjectCollectionBase) | Gets the number of key-and-value pairs contained in the NameObjectCollectionBase instance.
Item (inherited from NameValueCollection) | Gets or sets the entry with the specified key in the NameValueCollection.
Item (inherited from NameValueCollection) | Gets the entry at the specified index of the NameValueCollection.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
List | Gets or sets a string of default values.

Public Instance Methods

Add (inherited from NameValueCollection) | Overloaded. Adds an entry with the specified name and value to the NameValueCollection.
Clear (inherited from NameValueCollection) | Invalidates the cached arrays and removes all entries from the NameValueCollection.
CopyTo (inherited from NameValueCollection) | Copies the entire NameValueCollection to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get (inherited from NameValueCollection) | Overloaded. Gets the values at the specified index of the NameValueCollection combined into one comma-separated list.
GetEnumerator (inherited from NameObjectCollectionBase) | Returns an enumerator that can iterate through the NameObjectCollectionBase.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetKey (inherited from NameValueCollection) | Gets the key at the specified index of the NameValueCollection.
GetObjectData (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues (inherited from NameValueCollection) | Overloaded. Gets the values at the specified index of the NameValueCollection.
HasKeys (inherited from NameValueCollection) | Gets a value indicating whether the NameValueCollection contains keys that are not a null reference (Nothing in Visual Basic).
OnDeserialization (inherited from NameObjectCollectionBase) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
Remove (inherited from NameValueCollection) | Removes the entries with the specified key from the NameObjectCollectionBase instance.
Set (inherited from NameValueCollection) | Sets the value of an entry in the NameValueCollection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringValueCollection Class | Dart.PowerWEB.TextBox Namespace


StringValueCollection Constructor

Creates a new instance of StringValueCollection.

Overload List

Creates a new instance of StringValueCollection.

[Visual Basic] Public Sub New()
[C#] public StringValueCollection();
[C++] public: StringValueCollection();
[JScript] public function StringValueCollection();

Creates a new instance of StringValueCollection.

[Visual Basic] Public Sub New(ByVal String)
[C#] public StringValueCollection(string);
[C++] public: StringValueCollection(String*);
[JScript] public function StringValueCollection(String);

See Also

StringValueCollection Class | Dart.PowerWEB.TextBox Namespace


StringValueCollection Constructor ()

Creates a new instance of StringValueCollection.

[Visual Basic]
Public Sub New()
[C#]
public StringValueCollection();
[C++]
public: StringValueCollection();
[JScript]
public function StringValueCollection();

Remarks

Creates a default instance of StringValueCollection.

See Also

StringValueCollection Class | Dart.PowerWEB.TextBox Namespace | StringValueCollection Constructor Overload List


StringValueCollection Constructor (String)

Creates a new instance of StringValueCollection.

[Visual Basic]
Public Sub New( _
   ByVal list As String _
)
[C#]
public StringValueCollection(
   string list
);
[C++]
public: StringValueCollection(
   String* list
);
[JScript]
public function StringValueCollection(
   String list
);

Remarks

Creates a default instance of StringValueCollection, supplying a comma and ampersand-delimited list of default values.

See Also

StringValueCollection Class | Dart.PowerWEB.TextBox Namespace | StringValueCollection Constructor Overload List


StringValueCollection Properties

The properties of the StringValueCollection class are listed below. For a complete list of StringValueCollection class members, see the StringValueCollection Members topic.

Public Instance Properties

AllKeys (inherited from NameValueCollection) | Gets all the keys in the NameValueCollection.
Count (inherited from NameObjectCollectionBase) | Gets the number of key-and-value pairs contained in the NameObjectCollectionBase instance.
Item (inherited from NameValueCollection) | Gets or sets the entry with the specified key in the NameValueCollection.
Item (inherited from NameValueCollection) | Gets the entry at the specified index of the NameValueCollection.
Keys (inherited from NameObjectCollectionBase) | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance.
List | Gets or sets a string of default values.

See Also

StringValueCollection Class | Dart.PowerWEB.TextBox Namespace


List Property

StringValueCollection.List Property

Gets or sets a string of default values.

[Visual Basic]
Public Property List As String
[C#]
public string List { get; set; }
[C++]
public: __property String* get_List();
public: __property void set_List(String* );
[JScript]
public function get List() : String
public function set List(String);

Remarks

When getting this property, all of the strings in the collection will be returned as a comma and ampersand-delimited list. When setting this property, the comma and ampersand-delimited list will be split and added to the collection as values.

This property is intended to be used by the ASP.NET tag parser only.

See Also

StringValueCollection Class | Dart.PowerWEB.TextBox Namespace


StringValueCollectionConverter Class

For a list of all members of this type, see StringValueCollectionConverter Members.

System.Object
System.ComponentModel.TypeConverter
Dart.PowerWEB.TextBox.StringValueCollectionConverter

[Visual Basic]
Public Class StringValueCollectionConverter
    Inherits TypeConverter
[C#]
public class StringValueCollectionConverter : TypeConverter
[C++]
public __gc class StringValueCollectionConverter : public TypeConverter
[JScript]
public class StringValueCollectionConverter extends TypeConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

StringValueCollectionConverter Members | Dart.PowerWEB.TextBox Namespace


StringValueCollectionConverter Members

StringValueCollectionConverter overview

Public Instance Constructors

StringValueCollectionConverter Constructor

Public Instance Methods

CanConvertFrom | Overidden. Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo | Overidden. Overloaded.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overidden. Overloaded.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo | Overidden. Overloaded.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace


StringValueCollectionConverter Constructor

[Visual Basic]
Public Sub New()
[C#]
public StringValueCollectionConverter();
[C++]
public: StringValueCollectionConverter();
[JScript]
public function StringValueCollectionConverter();

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace


StringValueCollectionConverter Methods

The methods of the StringValueCollectionConverter class are listed below. For a complete list of StringValueCollectionConverter class members, see the StringValueCollectionConverter Members topic.

Public Instance Methods

CanConvertFrom | Overidden. Overloaded.
CanConvertFrom (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter.
CanConvertTo | Overidden. Overloaded.
CanConvertTo (inherited from TypeConverter) | Overloaded. Returns whether this converter can convert the object to the specified type.
ConvertFrom | Overidden. Overloaded.
ConvertFrom (inherited from TypeConverter) | Overloaded. Converts the given value to the type of this converter.
ConvertFromInvariantString (inherited from TypeConverter) | Overloaded. Converts the given string to the type of this converter, using the invariant culture.
ConvertFromString (inherited from TypeConverter) | Overloaded. Converts the specified text to an object.
ConvertTo | Overidden. Overloaded.
ConvertTo (inherited from TypeConverter) | Overloaded. Converts the given value object to the specified type, using the arguments.
ConvertToInvariantString (inherited from TypeConverter) | Overloaded. Converts the specified value to a culture-invariant string representation.
ConvertToString (inherited from TypeConverter) | Overloaded. Converts the specified value to a string representation.
CreateInstance (inherited from TypeConverter) | Overloaded. Creates an instance of the Type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCreateInstanceSupported (inherited from TypeConverter) | Overloaded. Returns whether changing a value on this object requires a call to CreateInstance to create a new value, using the specified context.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetProperties (inherited from TypeConverter) | Overloaded. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetPropertiesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports properties, using the specified context.
GetStandardValues (inherited from TypeConverter) | Overloaded. Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.
GetStandardValuesExclusive (inherited from TypeConverter) | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context.
GetStandardValuesSupported (inherited from TypeConverter) | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.
GetType (inherited from Object) | Gets the Type of the current instance.
IsValid (inherited from TypeConverter) | Overloaded. Returns whether the given value object is valid for this type and for the specified context.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace


CanConvertFrom Method

StringValueCollectionConverter.CanConvertFrom Method

Overload List

[Visual Basic] Overrides OverloadsPublic Function CanConvertFrom(ByVal ITypeDescriptorContext,ByVal Type) As Boolean
[C#] public override bool CanConvertFrom(ITypeDescriptorContext,Type);
[C++] public: bool CanConvertFrom(ITypeDescriptorContext*,Type*);
[JScript] public override function CanConvertFrom(ITypeDescriptorContext,Type): bool;

Returns whether this converter can convert an object of the given type to the type of this converter.
Inherited from TypeConverter.

[Visual Basic] Public Function CanConvertFrom(ByVal Type) As Boolean
[C#] public bool CanConvertFrom(Type);
[C++] public: bool CanConvertFrom(Type*);
[JScript] public function CanConvertFrom(Type): bool;

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

StringValueCollectionConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

[Visual Basic]
Overrides  OverloadsPublic Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
);
[C++]
public: bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
);
[JScript]
public override function CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
): bool;

Parameters

context
sourceType

Return Value

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace | StringValueCollectionConverter.CanConvertFrom Overload List


CanConvertTo Method

StringValueCollectionConverter.CanConvertTo Method

Overload List

[Visual Basic] Overrides OverloadsPublic Function CanConvertTo(ByVal ITypeDescriptorContext,ByVal Type) As Boolean
[C#] public override bool CanConvertTo(ITypeDescriptorContext,Type);
[C++] public: bool CanConvertTo(ITypeDescriptorContext*,Type*);
[JScript] public override function CanConvertTo(ITypeDescriptorContext,Type): bool;

Returns whether this converter can convert the object to the specified type.
Inherited from TypeConverter.

[Visual Basic] Public Function CanConvertTo(ByVal Type) As Boolean
[C#] public bool CanConvertTo(Type);
[C++] public: bool CanConvertTo(Type*);
[JScript] public function CanConvertTo(Type): bool;

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace


CanConvertTo Method (ITypeDescriptorContext, Type)

StringValueCollectionConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

[Visual Basic]
Overrides  OverloadsPublic Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
[C#]
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
);
[C++]
public: bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
);
[JScript]
public override function CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
): bool;

Parameters

context
destinationType

Return Value

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace | StringValueCollectionConverter.CanConvertTo Overload List


ConvertFrom Method

StringValueCollectionConverter.ConvertFrom Method

Overload List

[Visual Basic] Overrides OverloadsPublic Function ConvertFrom(ByVal ITypeDescriptorContext,ByVal CultureInfo,ByVal Object) As Object
[C#] public override object ConvertFrom(ITypeDescriptorContext,CultureInfo,object);
[C++] public: Object* ConvertFrom(ITypeDescriptorContext*,CultureInfo*,Object*);
[JScript] public override function ConvertFrom(ITypeDescriptorContext,CultureInfo,Object): Object;

Converts the given value to the type of this converter.
Inherited from TypeConverter.

[Visual Basic] Public Function ConvertFrom(ByVal Object) As Object
[C#] public object ConvertFrom(object);
[C++] public: Object* ConvertFrom(Object*);
[JScript] public function ConvertFrom(Object): Object;

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

StringValueCollectionConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[Visual Basic]
Overrides  OverloadsPublic Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
);
[C++]
public: Object* ConvertFrom(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value
);
[JScript]
public override function ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   Object value
): Object;

Parameters

context
culture
value

Return Value

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace | StringValueCollectionConverter.ConvertFrom Overload List


ConvertTo Method

StringValueCollectionConverter.ConvertTo Method

Overload List

[Visual Basic] Overrides OverloadsPublic Function ConvertTo(ByVal ITypeDescriptorContext,ByVal CultureInfo,ByVal Object,ByVal Type) As Object
[C#] public override object ConvertTo(ITypeDescriptorContext,CultureInfo,object,Type);
[C++] public: Object* ConvertTo(ITypeDescriptorContext*,CultureInfo*,Object*,Type*);
[JScript] public override function ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type): Object;

Converts the given value object to the specified type, using the arguments.
Inherited from TypeConverter.

[Visual Basic] Public Function ConvertTo(ByVal Object,ByVal Type) As Object
[C#] public object ConvertTo(object,Type);
[C++] public: Object* ConvertTo(Object*,Type*);
[JScript] public function ConvertTo(Object,Type): Object;

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

StringValueCollectionConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[Visual Basic]
Overrides  OverloadsPublic Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
);
[C++]
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
);
[JScript]
public override function ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   Object value,
   Type destinationType
): Object;

Parameters

context
culture
value
destinationType

Return Value

See Also

StringValueCollectionConverter Class | Dart.PowerWEB.TextBox Namespace | StringValueCollectionConverter.ConvertTo Overload List


Toolbar Class

Represents the toolbar of the HtmlBox.

For a list of all members of this type, see Toolbar Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.Toolbar

[Visual Basic]
Public Class Toolbar
    Inherits BaseChildControl
[C#]
public class Toolbar : BaseChildControl
[C++]
public __gc class Toolbar : public BaseChildControl
[JScript]
public class Toolbar extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

There is one Toolbar instance associated with each HtmlBox (as the HtmlBox.Toolbar property). Configure the Toolbar by adding items derived from BaseToolbarItem (ToolbarButton, ToolbarDropDown, ToolbarImage, ToolbarMenuButton, ToolbarText, and ToolbarUploadButton). This can be done using the easy-to-use high level HtmlBox.AddToolbarItem method of the HtmlBox control, or by using the Toolbar.Items collection (i.e., calling' HtmlBox.Toolbar.Items.Add, HtmlBox.Toolbar.Items.Remove, etc).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Toolbar Members | Dart.PowerWEB.TextBox Namespace


Toolbar Members

Toolbar overview

Public Instance Constructors

Toolbar Constructor Creates a new instance of Toolbar

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
Items | Returns a collection which is used to manage the items currently on the toolbar.
Layout | Gets or sets a string representation of the toolbar.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

Toolbar Class | Dart.PowerWEB.TextBox Namespace


Toolbar Constructor

Creates a new instance of Toolbar

[Visual Basic]
Public Sub New()
[C#]
public Toolbar();
[C++]
public: Toolbar();
[JScript]
public function Toolbar();

Remarks

The default constructor creates and initializes a default instance of Toolbar.

See Also

Toolbar Class | Dart.PowerWEB.TextBox Namespace


Toolbar Properties

The properties of the Toolbar class are listed below. For a complete list of Toolbar class members, see the Toolbar Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle | Overidden. Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
Items | Returns a collection which is used to manage the items currently on the toolbar.
Layout | Gets or sets a string representation of the toolbar.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

Toolbar Class | Dart.PowerWEB.TextBox Namespace


BorderStyle Property

Toolbar.BorderStyle Property

Gets or sets the border style of the control.

[Visual Basic]
Overrides Public Property BorderStyle As BorderStyle
[C#]
public override BorderStyle BorderStyle { get; set; }
[C++]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(BorderStyle );
[JScript]
public override function get BorderStyle() : BorderStyle
public override function set BorderStyle(BorderStyle);

Property Value

One of the BorderStyle enumeration values. The default is NotSet.

Remarks

Use the BorderStyle property to specify the border style for the control. This property is set using one of the BorderStyle enumeration values.

See Also

Toolbar Class | Dart.PowerWEB.TextBox Namespace


Items Property

Toolbar.Items Property

Returns a collection which is used to manage the items currently on the toolbar.

[Visual Basic]
Public Property ReadOnly Items As ToolbarItemCollection
[C#]
public ToolbarItemCollection Items { get; }
[C++]
public: __property ToolbarItemCollection* get_Items();
[JScript]
public function get Items() : ToolbarItemCollection

Property Value

A ToolbarItemCollection which manages the BaseToolbarItem types on the toolbar.

Remarks

Use the members of this collection to configure/manage the items on the Toolbar.

See Also

Toolbar Class | Dart.PowerWEB.TextBox Namespace


Layout Property

Toolbar.Layout Property

Gets or sets a string representation of the toolbar.

[Visual Basic]
Public Property Layout As String
[C#]
public string Layout { get; set; }
[C++]
public: __property String* get_Layout();
public: __property void set_Layout(String* );
[JScript]
public function get Layout() : String
public function set Layout(String);

Property Value

A string representation of the toolbar.

Remarks

This property returns a string representation of the current toolbar, or can be used to set a configuration. This property is mainly used to facilitate skin construction. If you need to build a toolbar, use either the HtmlBox.AddToolbarItem method of the HtmlBox control or the methods of the Toolbar.Items collection.

See Also

Toolbar Class | Dart.PowerWEB.TextBox Namespace


ToolbarButton Class

Represents a button that performs standard formatting.

For a list of all members of this type, see ToolbarButton Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.BaseToolbarButton
Dart.PowerWEB.TextBox.ToolbarButton

[Visual Basic]
Public Class ToolbarButton
    Inherits BaseToolbarButton
[C#]
public class ToolbarButton : BaseToolbarButton
[C++]
public __gc class ToolbarButton : public BaseToolbarButton
[JScript]
public class ToolbarButton extends BaseToolbarButton

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The ToolbarButton control represents a button that performs standard formatting (formatting which occurs without any other dialogs or menus). A ToolbarButton can be created and used one of two ways:

  • Calling HtmlBox.AddToolbarItem, passing in a ToolbarItemType associated with ToolbarButton (such as ToolbarItemType.Bold) creates the ToolbarButton, initializing it with default values for the "bold" type, and adds it to the Toolbar in one step.
  • Create a new ToolbarButton, passing in a ToolbarButtonType (such as ToolbarButtonType.Bold). This will create and initialize the ToolbarButton with default values for the "bold" type. Add the ToolbarButton using the ToolbarItemCollection.Add method (HtmlBox.Toolbar.Items.Add).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarButton Members | Dart.PowerWEB.TextBox Namespace


ToolbarButton Members

ToolbarButton overview

Public Instance Constructors

ToolbarButton Overloaded. Initializes a new instance of the ToolbarButton class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseToolbarButton) | Gets or sets the border width of the control
ClickBehavior | Gets or sets a value which indicates the postback behavior of the ToolbarButton.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType (inherited from BaseToolbarButton) | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight (inherited from BaseToolbarButton) | Gets or sets the height of the button image in pixels.
ImageName (inherited from BaseToolbarButton) | The name of the image displayed on the button.
ImageWidth (inherited from BaseToolbarButton) | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
MouseDownBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
OnClickFunctionCode | Gets or sets the code block associated with this ToolbarButton.
OnClickFunctionName | Gets or sets the JavaScript function call that is made when the ToolbarButton is clicked.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
RaisePostback | Obsolete. Gets or sets a value which indicates the ToolbarButton will initiate a server postback when clicked.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarButtonType associated with this ToolbarButton.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarButton Constructor

Creates a custom ToolbarButton

Overload List

Creates a custom ToolbarButton

[Visual Basic] Public Sub New()
[C#] public ToolbarButton();
[C++] public: ToolbarButton();
[JScript] public function ToolbarButton();

Creates a predefined ToolbarButton

[Visual Basic] Public Sub New(ByVal ToolbarButtonType)
[C#] public ToolbarButton(ToolbarButtonType);
[C++] public: ToolbarButton(ToolbarButtonType);
[JScript] public function ToolbarButton(ToolbarButtonType);

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarButton Constructor ()

Creates a custom ToolbarButton

[Visual Basic]
Public Sub New()
[C#]
public ToolbarButton();
[C++]
public: ToolbarButton();
[JScript]
public function ToolbarButton();

Remarks

The default constructor creates and initializes a ToolBarButton as a ToolbarButtonType.Custom button.

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace | ToolbarButton Constructor Overload List


ToolbarButton Constructor (ToolbarButtonType)

Creates a predefined ToolbarButton

[Visual Basic]
Public Sub New( _
   ByVal type As ToolbarButtonType _
)
[C#]
public ToolbarButton(
   ToolbarButtonType type
);
[C++]
public: ToolbarButton(
   ToolbarButtonType type
);
[JScript]
public function ToolbarButton(
   ToolbarButtonType type
);

Parameters

type
The ToolbarButtonType which is used to supply the proper default properties for the ToolbarButton.

Remarks

This constructor creates a ToolbarButton of the specified type and supplies it with the default values for the specified type. For example, if type == ToolbarButtonType.Bold, the properties would be as follows:

  • ToolbarButton.ItemPrefix = "bold"
  • ToolbarButton.ImageName = "bold.gif"
  • ToolbarButton.OnClickFunctionName = "pwFormatBold()"
  • etc...

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace | ToolbarButton Constructor Overload List


ToolbarButton Properties

The properties of the ToolbarButton class are listed below. For a complete list of ToolbarButton class members, see the ToolbarButton Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseToolbarButton) | Gets or sets the border width of the control
ClickBehavior | Gets or sets a value which indicates the postback behavior of the ToolbarButton.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType (inherited from BaseToolbarButton) | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight (inherited from BaseToolbarButton) | Gets or sets the height of the button image in pixels.
ImageName (inherited from BaseToolbarButton) | The name of the image displayed on the button.
ImageWidth (inherited from BaseToolbarButton) | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
MouseDownBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
OnClickFunctionCode | Gets or sets the code block associated with this ToolbarButton.
OnClickFunctionName | Gets or sets the JavaScript function call that is made when the ToolbarButton is clicked.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
RaisePostback | Obsolete. Gets or sets a value which indicates the ToolbarButton will initiate a server postback when clicked.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarButtonType associated with this ToolbarButton.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


ClickBehavior Property

ToolbarButton.ClickBehavior Property

Gets or sets a value which indicates the postback behavior of the ToolbarButton.

[Visual Basic]
Public Property ClickBehavior As ClickBehavior
[C#]
public ClickBehavior ClickBehavior { get; set; }
[C++]
public: __property ClickBehavior get_ClickBehavior();
public: __property void set_ClickBehavior(ClickBehavior );
[JScript]
public function get ClickBehavior() : ClickBehavior
public function set ClickBehavior(ClickBehavior);

Remarks

Gets or sets a value which indicates the postback behavior of the ToolbarButton. Set ClickBehavior to Postback for the button to perform a traditional postback. Setting to Callback for the button to perform an Ajax callback (no refresh of the page). Both Postback and Callback cause a ToolbarButtonClick event to fire.

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


OnClickFunctionCode Property

ToolbarButton.OnClickFunctionCode Property

Gets or sets the code block associated with this ToolbarButton.

[Visual Basic]
Public Property OnClickFunctionCode As String
[C#]
public string OnClickFunctionCode { get; set; }
[C++]
public: __property String* get_OnClickFunctionCode();
public: __property void set_OnClickFunctionCode(String* );
[JScript]
public function get OnClickFunctionCode() : String
public function set OnClickFunctionCode(String);

Remarks

This property is not used by any of the predefined ToolbarButton controls. It is provided as an easy way to associate a code block with a button, for example:

ToolbarButton b = new ToolbarButton(ToolbarButtonType.Custom);
b.OnClickFunctionName = "myFunction()"
b.OnClickFunctionCode = "function MyFunction()";
b.OnClickFunctionCode+= "{";
b.OnClickFunctionCode+= "alert('you clicked the button');";
b.OnClickFunctionCode+= "}";

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


OnClickFunctionName Property

ToolbarButton.OnClickFunctionName Property

Gets or sets the JavaScript function call that is made when the ToolbarButton is clicked.

[Visual Basic]
Public Property OnClickFunctionName As String
[C#]
public string OnClickFunctionName { get; set; }
[C++]
public: __property String* get_OnClickFunctionName();
public: __property void set_OnClickFunctionName(String* );
[JScript]
public function get OnClickFunctionName() : String
public function set OnClickFunctionName(String);

Property Value

A string containing the JavaScript function that is called when the ToolbarButton is clicked.

Remarks

By default, with predefined types (i.e. all types in the ToolbarButtonType enumeration with the exception of Custom), this property will be set to the proper value during initialization. For example, if the ToolbarButton created is of type ToolbarButtonType.Bold, this property will return "pwFormatBold()", indicating that it will call the client-side script to format the selected text as bold. This property should ONLY be set in the case of ToolbarButtonType.Custom, in which this property will be an empty string until properly set by the developer. In this case, you can set the ToolbarButton.OnClickFunctionCode property to the code block called when the button is clicked, for example:

ToolbarButton b = new ToolbarButton(ToolbarButtonType.Custom);
b.OnClickFunctionName = "myFunction()"
b.OnClickFunctionCode = "function MyFunction()";
b.OnClickFunctionCode+= "{";
b.OnClickFunctionCode+= "alert('you clicked the button');";
b.OnClickFunctionCode+= "}";

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


RaisePostback Property

ToolbarButton.RaisePostback Property

NOTE: This property is now obsolete.

The RaisePostback property is obsolete and should not be used. Please use the ClickBehavior property instead.

Gets or sets a value which indicates the ToolbarButton will initiate a server postback when clicked.

[Visual Basic]
Public Property RaisePostback As Boolean
[C#]
public bool RaisePostback { get; set; }
[C++]
public: __property bool get_RaisePostback();
public: __property void set_RaisePostback(bool );
[JScript]
public function get RaisePostback() : bool
public function set RaisePostback(bool);

Property Value

true if the button initiates a server postback when clicked; false otherwise.

Remarks

The ToolbarButtonType.Save type is the only button type that sets this property to true by default. If this property is true, the ToolbarButton will cause a postback to the server when clicked. The HtmlBox.ToolbarButtonClick event will be raised when this is detected. A ToolbarButtonEventArgs object will be passed into the event handler, making the ToolbarButton control responsible for the event available to the event handler.

The ToolbarButton.OnClickFunctionName property is ignored if this property is true.

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


Type Property

ToolbarButton.Type Property

Gets or sets the ToolbarButtonType associated with this ToolbarButton.

[Visual Basic]
Public Property Type As ToolbarButtonType
[C#]
public ToolbarButtonType Type { get; set; }
[C++]
public: __property ToolbarButtonType get_Type();
public: __property void set_Type(ToolbarButtonType );
[JScript]
public function get Type() : ToolbarButtonType
public function set Type(ToolbarButtonType);

Property Value

A ToolbarButtonType associated with this ToolbarButton.

Remarks

Typically, this property gets it's value during initialization. However, this property can be set. If this occurs, the current values of the ToolbarButton will be lost and replaced with the default settings associated with the new ToolbarButtonType.

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarButton Methods

The methods of the ToolbarButton class are listed below. For a complete list of ToolbarButton class members, see the ToolbarButton Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


Clone Method

ToolbarButton.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As ToolbarButton
[C#]
public ToolbarButton Clone();
[C++]
public: ToolbarButton* Clone();
[JScript]
public function Clone(): ToolbarButton;

Return Value

An HtmlBox control.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

ToolbarButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarButtonClickEventHandler Delegate

Represents a method which will handle the HtmlBox.ToolbarButtonClick event.

[Visual Basic]
Public Delegate Function Sub  ToolbarButtonClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolbarButtonEventArgs _
)
[C#]
public delegate void ToolbarButtonClickEventHandler(
   object sender,
   ToolbarButtonEventArgs e
)
[C++]
public __gc __delegate void ToolbarButtonClickEventHandler(
   Object* sender,
   ToolbarButtonEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Remarks

When you create a ToolbarButtonClickEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ToolbarButtonEventArgs Class

Provides data for the HtmlBox.ToolbarButtonClick event.

For a list of all members of this type, see ToolbarButtonEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.TextBox.ToolbarButtonEventArgs

[Visual Basic]
Public Class ToolbarButtonEventArgs
    Inherits EventArgs
[C#]
public class ToolbarButtonEventArgs : EventArgs
[C++]
public __gc class ToolbarButtonEventArgs : public EventArgs
[JScript]
public class ToolbarButtonEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

When a HtmlBox.ToolbarButtonClick event is raised (when a ToolbarButton with its ToolbarButton.RaisePostback property set to true is clicked) a ToolbarButtonEventArgs object will be passed into the event handler. Check the ToolbarButtonEventArgs.Button property to get a reference to the button responsible for raising the event.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarButtonEventArgs Members | Dart.PowerWEB.TextBox Namespace


ToolbarButtonEventArgs Members

ToolbarButtonEventArgs overview

Public Instance Constructors

ToolbarButtonEventArgs Constructor Creates a new instance of ToolbarButtonEventArgs.

Public Instance Properties

Button Gets the ToolbarButton object responsible for this event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ToolbarButtonEventArgs Class | Dart.PowerWEB.TextBox Namespace


ToolbarButtonEventArgs Constructor

Creates a new instance of ToolbarButtonEventArgs.

[Visual Basic]
Public Sub New( _
   ByVal button As ToolbarButton _
)
[C#]
public ToolbarButtonEventArgs(
   ToolbarButton button
);
[C++]
public: ToolbarButtonEventArgs(
   ToolbarButton* button
);
[JScript]
public function ToolbarButtonEventArgs(
   ToolbarButton button
);

Parameters

button
The ToolbarButton instance responsible for raising the event.

Remarks

A new object of this type is created and passed into the event handler of the HtmlBox.ToolbarButtonClick event.

See Also

ToolbarButtonEventArgs Class | Dart.PowerWEB.TextBox Namespace


ToolbarButtonEventArgs Properties

The properties of the ToolbarButtonEventArgs class are listed below. For a complete list of ToolbarButtonEventArgs class members, see the ToolbarButtonEventArgs Members topic.

Public Instance Properties

Button Gets the ToolbarButton object responsible for this event.

See Also

ToolbarButtonEventArgs Class | Dart.PowerWEB.TextBox Namespace


Button Property

ToolbarButtonEventArgs.Button Property

Gets the ToolbarButton object responsible for this event.

[Visual Basic]
Public Property ReadOnly Button As ToolbarButton
[C#]
public ToolbarButton Button { get; }
[C++]
public: __property ToolbarButton* get_Button();
[JScript]
public function get Button() : ToolbarButton

Remarks

Check this property to see which button raised the postback and take action accordingly.

See Also

ToolbarButtonEventArgs Class | Dart.PowerWEB.TextBox Namespace


ToolbarButtonType Enumeration

Enumerates the different types of ToolbarButton controls.

[Visual Basic]
Public Enum ToolbarButtonType
[C#]
public enum ToolbarButtonType
[C++]
public __value enum ToolbarButtonType
[JScript]
public enum ToolbarButtonType

Remarks

The ToolbarButtonType is used to supply default values to a ToolbarButton. For example, when creating a new ToolbarButton, simply pass a ToolbarButtonType into the constructor to supply the object with preset values associated with that type.

This enumeration is a subset of the ToolbarItemType enumeration.

Members

Member Name | Description
TogglePositioning | Defines a toolbar button which toggles HTML elements between absolute and relative positioning: Associated type: ToolbarButton
BringForward | Defines a toolbar item which increases the z-index of an HTML element. Associated type: ToolbarButton
SendBackward | Defines a toolbar button which decreases the z-index of an HTML element. Associated type: ToolbarButton
PasteHtml | Defines a toolbar button which pastes the item on the clipboard while stripping HTML tags. Associated type: ToolbarButton
WordCount | Defines a toolbar button which displays a count of words and characters when clicked. Associated type: ToolbarButton
CleanWord | Defines a toolbar button which cleans extranous MS Word tags from the content in the editor. Associated type: ToolbarButton
Justify | Defines a toolbar button which justifies text. Associated type: ToolbarButton
Bold | Defines a toolbar button which applies bold formatting. Associated type: ToolbarButton
CenterJustify | Defines a toolbar button which centers justify text. Associated type: ToolbarButton
Copy | Defines a toolbar button which copies selected text. Associated type: ToolbarButton
Custom | Represents a custom button. The button will not do anything client side unless you provide some values for the properties of the object.
Cut | Defines a toolbar button which can cut selected text. Associated type: ToolbarButton
Indent | Defines a toolbar button which indents text. Associated type: ToolbarButton
InsertLink | Defines a toolbar button which raises an insert link modal box. Associated type: ToolbarButton
Italic | Defines a toolbar button which applies italic formatting. Associated type: ToolbarButton
LeftJustify | Defines a toolbar button which left justifies text. Associated type: ToolbarButton
Outdent | Defines a toolbar button which outdents text. Associated type: ToolbarButton
OrderedList | Defines a toolbar button which formats the selected text as an ordered list. Associated type: ToolbarButton
Paste | Defines a toolbar button which pastes the item on the clipboard. Associated type: ToolbarButton
Preview | Defines a toolbar button which displays a preview dialog. Associated type: ToolbarButton
Print | Defines a toolbar button which sends the content of the HtmlBox to the printer. Associated type: ToolbarButton
Redo | Defines a toolbar button which redoes the last operation. Associated type: ToolbarButton
RemoveLink | Defines a toolbar button which removes a link. Associated type: ToolbarButton
RightJustify | Defines a toolbar button which right justifies text. Associated type: ToolbarButton
Save | Defines a toolbar button which raises a postback to the server. Associated type: ToolbarButton
Strikethrough | Defines a toolbar button which places a strikethrough through text. Associated type: ToolbarButton
Superscript | Defines a toolbar button which applies superscript formatting. Associated type: ToolbarButton
Subscript | Defines a toolbar button which applies subscript formatting. Associated type: ToolbarButton
ToggleBorders | Defines a toolbar button which toggles whether table borders are shown. Associated type: ToolbarButton
Underline | Defines a toolbar button which applies underline formatting. Associated type: ToolbarButton
Undo | Defines a toolbar button which undoes an operation. Associated type: ToolbarButton
UnorderedList | Defines a toolbar button which formats the selected text as an unordered list. Associated type: ToolbarButton
NotSet | No Type is associated with this object (typically because object was created using the default (paramaterless) constructor. Set the Type property to provide default values.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ToolbarDialogButton Class

Represents a button that raises a dialog.

For a list of all members of this type, see ToolbarDialogButton Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.BaseToolbarButton
Dart.PowerWEB.TextBox.ToolbarDialogButton

[Visual Basic]
Public Class ToolbarDialogButton
    Inherits BaseToolbarButton
[C#]
public class ToolbarDialogButton : BaseToolbarButton
[C++]
public __gc class ToolbarDialogButton : public BaseToolbarButton
[JScript]
public class ToolbarDialogButton extends BaseToolbarButton

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The ToolbarDialogButton control represents a button that raises a dialog. This may be a non-draggable "panel" (such as with a "font-color" dialog, created by using the ToolbarDialogButtonType.FontColor value) or a fully-interactive, draggable "window" (such as with "insert horizontal rule" created by using the ToolbarDialogButtonType.InsertRule value).

The dialog that appears when the ToolbarDialogButton is clicked is represented by an HtmlBoxDialog, exposed by the ToolbarDialogButton.Dialog property.

A ToolbarDialogButton can be created and used one of two ways:

  • Calling HtmlBox.AddToolbarItem, passing in a ToolbarItemType associated with ToolbarDialogButton (such as ToolbarItemType.FontColor) creates the ToolbarDialogButton, initializing it with default values for the "font color" type, and adds it to the Toolbar in one step.
  • Create a new ToolbarDialogButton, passing in a ToolbarDialogButtonType (such as ToolbarDialogButtonType.FontColor). This will create and initialize the ToolbarDialogButton with default values for the "font color" type. Add the ToolbarDialogButton using the ToolbarItemCollection.Add method (HtmlBox.Toolbar.Items.Add).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarDialogButton Members | Dart.PowerWEB.TextBox Namespace


ToolbarDialogButton Members

ToolbarDialogButton overview

Public Instance Constructors

ToolbarDialogButton Overloaded. Initializes a new instance of the ToolbarDialogButton class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseToolbarButton) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Dialog | Returns the HtmlBoxDialog associated with this ToolbarDialogButton.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType (inherited from BaseToolbarButton) | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight (inherited from BaseToolbarButton) | Gets or sets the height of the button image in pixels.
ImageName (inherited from BaseToolbarButton) | The name of the image displayed on the button.
ImageWidth (inherited from BaseToolbarButton) | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
MouseDownBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarDialogButtonType associated with this ToolbarDialogButton.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarDialogButton Constructor

Creates a custom ToolbarDialogButton

Overload List

Creates a custom ToolbarDialogButton

[Visual Basic] Public Sub New()
[C#] public ToolbarDialogButton();
[C++] public: ToolbarDialogButton();
[JScript] public function ToolbarDialogButton();

Creates a predefined ToolbarDialogButton

[Visual Basic] Public Sub New(ByVal ToolbarDialogButtonType)
[C#] public ToolbarDialogButton(ToolbarDialogButtonType);
[C++] public: ToolbarDialogButton(ToolbarDialogButtonType);
[JScript] public function ToolbarDialogButton(ToolbarDialogButtonType);

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarDialogButton Constructor ()

Creates a custom ToolbarDialogButton

[Visual Basic]
Public Sub New()
[C#]
public ToolbarDialogButton();
[C++]
public: ToolbarDialogButton();
[JScript]
public function ToolbarDialogButton();

Remarks

The default constructor creates and initializes a ToolBarDialogButton as a ToolbarDialogButtonType.Custom button.

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace | ToolbarDialogButton Constructor Overload List


ToolbarDialogButton Constructor (ToolbarDialogButtonType)

Creates a predefined ToolbarDialogButton

[Visual Basic]
Public Sub New( _
   ByVal type As ToolbarDialogButtonType _
)
[C#]
public ToolbarDialogButton(
   ToolbarDialogButtonType type
);
[C++]
public: ToolbarDialogButton(
   ToolbarDialogButtonType type
);
[JScript]
public function ToolbarDialogButton(
   ToolbarDialogButtonType type
);

Parameters

type
The ToolbarDialogButtonType which is used to supply the proper default properties for the ToolbarDialogButton.

Remarks

This constructor creates a ToolbarDialogButton of the specified type and supplies it with the default values for the specified type.

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace | ToolbarDialogButton Constructor Overload List


ToolbarDialogButton Properties

The properties of the ToolbarDialogButton class are listed below. For a complete list of ToolbarDialogButton class members, see the ToolbarDialogButton Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseToolbarButton) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Dialog | Returns the HtmlBoxDialog associated with this ToolbarDialogButton.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType (inherited from BaseToolbarButton) | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight (inherited from BaseToolbarButton) | Gets or sets the height of the button image in pixels.
ImageName (inherited from BaseToolbarButton) | The name of the image displayed on the button.
ImageWidth (inherited from BaseToolbarButton) | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
MouseDownBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarDialogButtonType associated with this ToolbarDialogButton.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace


Controls Property

ToolbarDialogButton.Controls Property

Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.

[Visual Basic]
Overrides Public Property ReadOnly Controls As ControlCollection
[C#]
public override ControlCollection Controls { get; }
[C++]
public: __property ControlCollection* get_Controls();
[JScript]
public override function get Controls() : ControlCollection

Property Value

The collection of child controls for the specified server control.

Remarks

On an ASP.NET page, when controls are added declaratively between the opening and closing tags of a server control, ASP.NET automatically adds the controls to the containing server control's ControlCollection. Any HTML tags or text strings that are not processed on the server are treated as LiteralControl objects. These are added to the collection like other server controls.

The Controls property allows you programmatic access to the instance of the ControlCollection class for any server control. You can add controls to the collection, remove controls from the collection, or iterate through the server controls in the collection.

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace


Dialog Property

ToolbarDialogButton.Dialog Property

Returns the HtmlBoxDialog associated with this ToolbarDialogButton.

[Visual Basic]
Public Property ReadOnly Dialog As HtmlBoxDialog
[C#]
public HtmlBoxDialog Dialog { get; }
[C++]
public: __property HtmlBoxDialog* get_Dialog();
[JScript]
public function get Dialog() : HtmlBoxDialog

Property Value

The HtmlBoxDialog associated with the ToolbarDialogButton.

Remarks

This property returns the HtmlBoxDialog representing the dialog that appears when the ToolbarDialogButton is clicked. For all predefined ToolbarDialogButtons (all ToolbarDialogButtonType values except for ToolbarDialogButtonType.Custom) this property will be properly initialized. For ToolbarDialogButtonType.Custom, create the dialog content by setting the HtmlBoxDialog.Text property.

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace


Type Property

ToolbarDialogButton.Type Property

Gets or sets the ToolbarDialogButtonType associated with this ToolbarDialogButton.

[Visual Basic]
Public Property Type As ToolbarDialogButtonType
[C#]
public ToolbarDialogButtonType Type { get; set; }
[C++]
public: __property ToolbarDialogButtonType get_Type();
public: __property void set_Type(ToolbarDialogButtonType );
[JScript]
public function get Type() : ToolbarDialogButtonType
public function set Type(ToolbarDialogButtonType);

Property Value

A ToolbarDialogButtonType associated with this ToolbarDialogButton.

Remarks

Typically, this property gets it's value during initialization. However, this property can be set. If this occurs, the current values of the ToolbarDialogButton will be lost and replaced with the default settings associated with the new ToolbarDialogButtonType.

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarDialogButton Methods

The methods of the ToolbarDialogButton class are listed below. For a complete list of ToolbarDialogButton class members, see the ToolbarDialogButton Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace


Clone Method

ToolbarDialogButton.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As ToolbarDialogButton
[C#]
public ToolbarDialogButton Clone();
[C++]
public: ToolbarDialogButton* Clone();
[JScript]
public function Clone(): ToolbarDialogButton;

Return Value

A ToolbarDialogButton control.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

ToolbarDialogButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarDialogButtonType Enumeration

Enumerates the different types of ToolbarDialogButton controls.

[Visual Basic]
Public Enum ToolbarDialogButtonType
[C#]
public enum ToolbarDialogButtonType
[C++]
public __value enum ToolbarDialogButtonType
[JScript]
public enum ToolbarDialogButtonType

Remarks

The ToolbarDialogButtonType is used to supply default values to a ToolbarDialogButton. For example, when creating a new ToolbarDialogButton, simply pass a ToolbarDialogButtonType into the constructor to supply the object with preset values associated with that type.

This enumeration is a subset of the ToolbarItemType enumeration.

Members

Member Name | Description
InsertRule | Defines a toolbar button which raises a dialog which inserts horizontal rules. Associated type: ToolbarDialogButton
InsertBookmark | Defines a toolbar button which raises an insert bookmark dialog when clicked. Associated type: ToolbarDialogButton
FindReplace | Defines a toolbar button which raises a find/replace dialog when clicked. Associated type: ToolbarDialogButton
SpecialCharacter | Defines a toolbar button which raises a "select special character" panel. Associated type: ToolbarDialogButton
FontColor | Defines a toolbar button which raises a color picker palette when clicked. Associated type: ToolbarDialogButton
FontHighlight | Defines a toolbar button which raises a color picker palette when clicked. Associated type :ToolbarDialogButton
Help | Defines a toolbar button which raises a help dialog when clicked. Associated type: ToolbarDialogButton
Custom | Represents a custom button. The button will not do anything client side unless you provide some values for the properties of the object.
NotSet | No Type is associated with this object (typically because object was created using the default (paramaterless) constructor. Set the Type property to provide default values.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ToolbarDropDown Class

Represents a drop-down select box.

For a list of all members of this type, see ToolbarDropDown Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.ToolbarDropDown

[Visual Basic]
Public Class ToolbarDropDown
    Inherits BaseToolbarItem
[C#]
public class ToolbarDropDown : BaseToolbarItem
[C++]
public __gc class ToolbarDropDown : public BaseToolbarItem
[JScript]
public class ToolbarDropDown extends BaseToolbarItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The ToolbarDropDown control represents a drop-down select box. On the control level, each ToolbarDropDown is made up of ToolbarDropDownItems (accessable via the ToolbarDropDown.Items property). When creating predefined ToolbarDropDown types (all ToolbarDropDownTypes besides ToolbarDropDownType.Custom) the ToolbarDropDown will be created with the proper default calues for the type.

A ToolbarDropDown can be created and used one of two ways:

  • Calling HtmlBox.AddToolbarItem, passing in a ToolbarItemType associated with ToolbarDropDown (such as ToolbarItemType.FontName) creates the ToolbarDropDown, initializing it with default values for the "font name" type, and adds it to the Toolbar in one step.
  • Create a new ToolbarDropDown, passing in a ToolbarDropDownType (such as ToolbarDropDownType.FontName). This will create and initialize the ToolbarDropDown with default values for the "font name" type. Add the ToolbarDropDown using the ToolbarItemCollection.Add method (HtmlBox.Toolbar.Items.Add).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarDropDown Members | Dart.PowerWEB.TextBox Namespace


ToolbarDropDown Members

ToolbarDropDown overview

Public Instance Constructors

ToolbarDropDown Overloaded. Initializes a new instance of the ToolbarDropDown class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarItem) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DropDownHeight | Gets or sets the height of the drop down.
DropDownWidth | Gets or sets the width of the drop down.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageName | The name of the image displayed as the drop-down arrow.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
Items | Returns a collection which is used to manage the items currently on the dropdown.
MouseDownImageName | The name of the image displayed as the "mouse-down" drop-down arrow.
MouseOverImageName | The name of the image displayed as the drop-down "mouse-over" arrow.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Title | Gets or sets the title for the drop-down.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarDropDownType associated with this ToolbarDropDown.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UseAdvancedDisplay | Gets or sets a value which indicates if advanced drop-down displays should be used.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDown Constructor

Creates a custom ToolbarDropDown

Overload List

Creates a custom ToolbarDropDown

[Visual Basic] Public Sub New()
[C#] public ToolbarDropDown();
[C++] public: ToolbarDropDown();
[JScript] public function ToolbarDropDown();

Creates a predefined ToolbarDropDown

[Visual Basic] Public Sub New(ByVal ToolbarDropDownType)
[C#] public ToolbarDropDown(ToolbarDropDownType);
[C++] public: ToolbarDropDown(ToolbarDropDownType);
[JScript] public function ToolbarDropDown(ToolbarDropDownType);

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDown Constructor ()

Creates a custom ToolbarDropDown

[Visual Basic]
Public Sub New()
[C#]
public ToolbarDropDown();
[C++]
public: ToolbarDropDown();
[JScript]
public function ToolbarDropDown();

Remarks

The default constructor creates and initializes a ToolbarDropDown as a ToolbarDropDownType.Custom type.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace | ToolbarDropDown Constructor Overload List


ToolbarDropDown Constructor (ToolbarDropDownType)

Creates a predefined ToolbarDropDown

[Visual Basic]
Public Sub New( _
   ByVal type As ToolbarDropDownType _
)
[C#]
public ToolbarDropDown(
   ToolbarDropDownType type
);
[C++]
public: ToolbarDropDown(
   ToolbarDropDownType type
);
[JScript]
public function ToolbarDropDown(
   ToolbarDropDownType type
);

Parameters

type
The ToolbarDropDownType which is used to supply the proper default properties for the ToolbarDropDown.

Remarks

This constructor creates a ToolbarDropDown of the specified type and supplies it with the default values for the specified type.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace | ToolbarDropDown Constructor Overload List


ToolbarDropDown Properties

The properties of the ToolbarDropDown class are listed below. For a complete list of ToolbarDropDown class members, see the ToolbarDropDown Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarItem) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
DropDownHeight | Gets or sets the height of the drop down.
DropDownWidth | Gets or sets the width of the drop down.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageName | The name of the image displayed as the drop-down arrow.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
Items | Returns a collection which is used to manage the items currently on the dropdown.
MouseDownImageName | The name of the image displayed as the "mouse-down" drop-down arrow.
MouseOverImageName | The name of the image displayed as the drop-down "mouse-over" arrow.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Title | Gets or sets the title for the drop-down.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarDropDownType associated with this ToolbarDropDown.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UseAdvancedDisplay | Gets or sets a value which indicates if advanced drop-down displays should be used.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


DropDownHeight Property

ToolbarDropDown.DropDownHeight Property

Gets or sets the height of the drop down.

[Visual Basic]
Public Property DropDownHeight As Unit
[C#]
public Unit DropDownHeight { get; set; }
[C++]
public: __property Unit get_DropDownHeight();
public: __property void set_DropDownHeight(Unit );
[JScript]
public function get DropDownHeight() : Unit
public function set DropDownHeight(Unit);

Property Value

A Unit value, indicating the height of the drop down.

Remarks

This value applies to the portion of the drop down that is visible when the drop down is clicked to display the list of values.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


DropDownWidth Property

ToolbarDropDown.DropDownWidth Property

Gets or sets the width of the drop down.

[Visual Basic]
Public Property DropDownWidth As Unit
[C#]
public Unit DropDownWidth { get; set; }
[C++]
public: __property Unit get_DropDownWidth();
public: __property void set_DropDownWidth(Unit );
[JScript]
public function get DropDownWidth() : Unit
public function set DropDownWidth(Unit);

Property Value

A Unit value, indicating the width of the drop down.

Remarks

This value applies to the portion of the drop down that is visible when the drop down is clicked to display the list of values.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


ImageName Property

ToolbarDropDown.ImageName Property

The name of the image displayed as the drop-down arrow.

[Visual Basic]
Public Property ImageName As String
[C#]
public string ImageName { get; set; }
[C++]
public: __property String* get_ImageName();
public: __property void set_ImageName(String* );
[JScript]
public function get ImageName() : String
public function set ImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


Items Property

ToolbarDropDown.Items Property

Returns a collection which is used to manage the items currently on the dropdown.

[Visual Basic]
Public Property ReadOnly Items As ToolbarDropDownItemCollection
[C#]
public ToolbarDropDownItemCollection Items { get; }
[C++]
public: __property ToolbarDropDownItemCollection* get_Items();
[JScript]
public function get Items() : ToolbarDropDownItemCollection

Property Value

A ToolbarDropDownCollection which manages the ToolbarDropDownItems types on the dropdown.

Remarks

Use the members of this collection to configure/manage the items on the dropdown.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


MouseDownImageName Property

ToolbarDropDown.MouseDownImageName Property

The name of the image displayed as the "mouse-down" drop-down arrow.

[Visual Basic]
Public Property MouseDownImageName As String
[C#]
public string MouseDownImageName { get; set; }
[C++]
public: __property String* get_MouseDownImageName();
public: __property void set_MouseDownImageName(String* );
[JScript]
public function get MouseDownImageName() : String
public function set MouseDownImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


MouseOverImageName Property

ToolbarDropDown.MouseOverImageName Property

The name of the image displayed as the drop-down "mouse-over" arrow.

[Visual Basic]
Public Property MouseOverImageName As String
[C#]
public string MouseOverImageName { get; set; }
[C++]
public: __property String* get_MouseOverImageName();
public: __property void set_MouseOverImageName(String* );
[JScript]
public function get MouseOverImageName() : String
public function set MouseOverImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

This property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


Title Property

ToolbarDropDown.Title Property

Gets or sets the title for the drop-down.

[Visual Basic]
Public Property Title As String
[C#]
public string Title { get; set; }
[C++]
public: __property String* get_Title();
public: __property void set_Title(String* );
[JScript]
public function get Title() : String
public function set Title(String);

Property Value

A string containing the title for the drop-down.

Remarks

When this property is set, a non-selectable title will be displayed as the first drop-down item.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


Type Property

ToolbarDropDown.Type Property

Gets or sets the ToolbarDropDownType associated with this ToolbarDropDown.

[Visual Basic]
Public Property Type As ToolbarDropDownType
[C#]
public ToolbarDropDownType Type { get; set; }
[C++]
public: __property ToolbarDropDownType get_Type();
public: __property void set_Type(ToolbarDropDownType );
[JScript]
public function get Type() : ToolbarDropDownType
public function set Type(ToolbarDropDownType);

Property Value

A ToolbarDropDownType associated with this ToolbarDropDown.

Remarks

Typically, this property gets it's value during initialization. However, this property can be set. If this occurs, the current values of the ToolbarDropDown will be lost and replaced with the default settings associated with the new ToolbarDropDownType.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


UseAdvancedDisplay Property

ToolbarDropDown.UseAdvancedDisplay Property

Gets or sets a value which indicates if advanced drop-down displays should be used.

[Visual Basic]
Public Property UseAdvancedDisplay As Boolean
[C#]
public bool UseAdvancedDisplay { get; set; }
[C++]
public: __property bool get_UseAdvancedDisplay();
public: __property void set_UseAdvancedDisplay(bool );
[JScript]
public function get UseAdvancedDisplay() : bool
public function set UseAdvancedDisplay(bool);

Property Value

true if advanced display should be used; false otherwise. The default value is true.

Remarks

This property only has effect on the predefined drop-down types ToolbarDropDownType.FontFormatting, ToolbarDropDownType.FontName, and ToolbarDropDownType.FontStyle. If this property is true, advanced displays are used. For example, in the case of ToolbarDropDownType.FontName, the font name will be displayed using the actual font. Set this property to false to have the drop-down look like a standard, non-formatted drop-down.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDown Methods

The methods of the ToolbarDropDown class are listed below. For a complete list of ToolbarDropDown class members, see the ToolbarDropDown Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


Clone Method

ToolbarDropDown.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As ToolbarDropDown
[C#]
public ToolbarDropDown Clone();
[C++]
public: ToolbarDropDown* Clone();
[JScript]
public function Clone(): ToolbarDropDown;

Return Value

An HtmlBox control.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

ToolbarDropDown Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownItem Class

Represents a single item of a ToolbarDropDown.

For a list of all members of this type, see ToolbarDropDownItem Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.ToolbarDropDownItem

[Visual Basic]
Public Class ToolbarDropDownItem
    Inherits BaseChildControl
[C#]
public class ToolbarDropDownItem : BaseChildControl
[C++]
public __gc class ToolbarDropDownItem : public BaseChildControl
[JScript]
public class ToolbarDropDownItem extends BaseChildControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The ToolbarDropDown.Text property represents the text that is displayed. The ToolbarDropDown.OnClickFunctionName represents theh JavaScript code that is called when the ToolbarDropDownItem is clicked.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarDropDownItem Members | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownItem Members

ToolbarDropDownItem overview

Public Instance Constructors

ToolbarDropDownItem Overloaded. Initializes a new instance of the ToolbarDropDownItem class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
OnClickFunctionCode | Gets or sets the code block associated with this object.
OnClickFunctionName | Represents the JavaScript code that is run when the item is clicked.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Represents the text that is displayed for the item.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Value | Represents the value that is passed into functions.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownItem Constructor

Creates a new instance of ToolbarDropDown.

Overload List

Creates a new instance of ToolbarDropDown.

[Visual Basic] Public Sub New()
[C#] public ToolbarDropDownItem();
[C++] public: ToolbarDropDownItem();
[JScript] public function ToolbarDropDownItem();

Creates a new instance of ToolbarDropDown, supplying the Text and OnClickFunctionName.

[Visual Basic] Public Sub New(ByVal String,ByVal String)
[C#] public ToolbarDropDownItem(string,string);
[C++] public: ToolbarDropDownItem(String*,String*);
[JScript] public function ToolbarDropDownItem(String,String);

Creates a new instance of ToolbarDropDown, supplying the Text, the Value, and OnClickFunctionName.

[Visual Basic] Public Sub New(ByVal String,ByVal String,ByVal String)
[C#] public ToolbarDropDownItem(string,string,string);
[C++] public: ToolbarDropDownItem(String*,String*,String*);
[JScript] public function ToolbarDropDownItem(String,String,String);

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownItem Constructor ()

Creates a new instance of ToolbarDropDown.

[Visual Basic]
Public Sub New()
[C#]
public ToolbarDropDownItem();
[C++]
public: ToolbarDropDownItem();
[JScript]
public function ToolbarDropDownItem();

Remarks

Creates a default instance of ToolbarDropDown.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace | ToolbarDropDownItem Constructor Overload List


ToolbarDropDownItem Constructor (String, String)

Creates a new instance of ToolbarDropDown, supplying the Text and OnClickFunctionName.

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal value As String _
)
[C#]
public ToolbarDropDownItem(
   string text,
   string value
);
[C++]
public: ToolbarDropDownItem(
   String* text,
   String* value
);
[JScript]
public function ToolbarDropDownItem(
   String text,
   String value
);

Remarks

Creates a new instance of ToolbarDropDown, supplying the Text and OnClickFunctionName.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace | ToolbarDropDownItem Constructor Overload List


ToolbarDropDownItem Constructor (String, String, String)

Creates a new instance of ToolbarDropDown, supplying the Text, the Value, and OnClickFunctionName.

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal value As String, _
   ByVal onClickFunctionName As String _
)
[C#]
public ToolbarDropDownItem(
   string text,
   string value,
   string onClickFunctionName
);
[C++]
public: ToolbarDropDownItem(
   String* text,
   String* value,
   String* onClickFunctionName
);
[JScript]
public function ToolbarDropDownItem(
   String text,
   String value,
   String onClickFunctionName
);

Remarks

Creates a new instance of ToolbarDropDown, supplying the Text, the Value, and OnClickFunctionName.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace | ToolbarDropDownItem Constructor Overload List


ToolbarDropDownItem Properties

The properties of the ToolbarDropDownItem class are listed below. For a complete list of ToolbarDropDownItem class members, see the ToolbarDropDownItem Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseChildControl) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
OnClickFunctionCode | Gets or sets the code block associated with this object.
OnClickFunctionName | Represents the JavaScript code that is run when the item is clicked.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Represents the text that is displayed for the item.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Value | Represents the value that is passed into functions.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace


OnClickFunctionCode Property

ToolbarDropDownItem.OnClickFunctionCode Property

Gets or sets the code block associated with this object.

[Visual Basic]
Public Property OnClickFunctionCode As String
[C#]
public string OnClickFunctionCode { get; set; }
[C++]
public: __property String* get_OnClickFunctionCode();
public: __property void set_OnClickFunctionCode(String* );
[JScript]
public function get OnClickFunctionCode() : String
public function set OnClickFunctionCode(String);

Remarks

This property is not used by any of the predefined object controls. It is provided as an easy way to associate a code block with an object.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace


OnClickFunctionName Property

ToolbarDropDownItem.OnClickFunctionName Property

Represents the JavaScript code that is run when the item is clicked.

[Visual Basic]
Public Property OnClickFunctionName As String
[C#]
public string OnClickFunctionName { get; set; }
[C++]
public: __property String* get_OnClickFunctionName();
public: __property void set_OnClickFunctionName(String* );
[JScript]
public function get OnClickFunctionName() : String
public function set OnClickFunctionName(String);

Property Value

A string containing the onclick function name.

Remarks

Set this when creating a custom ToolbarDropDown to the code you would like to run when the item is clicked.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace


Text Property

ToolbarDropDownItem.Text Property

Represents the text that is displayed for the item.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

A string containing the text that is displayed for the item.

Remarks

The ToolbarDropDown will not automatically resize. If the Text length is too long, be sure to set the ToolbarDropDown.Width property to compensate.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace


Value Property

ToolbarDropDownItem.Value Property

Represents the value that is passed into functions.

[Visual Basic]
Public Property Value As String
[C#]
public string Value { get; set; }
[C++]
public: __property String* get_Value();
public: __property void set_Value(String* );
[JScript]
public function get Value() : String
public function set Value(String);

Remarks

This property represents the value that the user does not see, that is passed into functions when the item is clicked. For example, if the Text property was "Heading 1", Value might be "h1" reflecting the actual formatting that would be applied when the button is clicked.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownItem Methods

The methods of the ToolbarDropDownItem class are listed below. For a complete list of ToolbarDropDownItem class members, see the ToolbarDropDownItem Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace


Clone Method

ToolbarDropDownItem.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As ToolbarDropDownItem
[C#]
public ToolbarDropDownItem Clone();
[C++]
public: ToolbarDropDownItem* Clone();
[JScript]
public function Clone(): ToolbarDropDownItem;

Return Value

An HtmlBox control.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

ToolbarDropDownItem Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownItemCollection Class

Manages ToolbarDropDownItems

For a list of all members of this type, see ToolbarDropDownItemCollection Members.

System.Object
System.Collections.ArrayList
Dart.PowerWEB.TextBox.ToolbarDropDownItemCollection

[Visual Basic]
Public Class ToolbarDropDownItemCollection
    Inherits ArrayList
[C#]
public class ToolbarDropDownItemCollection : ArrayList
[C++]
public __gc class ToolbarDropDownItemCollection : public ArrayList
[JScript]
public class ToolbarDropDownItemCollection extends ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The ToolbarDropDownItemCollection extends the ArrayList class to provide type checking to the base class.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarDropDownItemCollection Members | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownItemCollection Members

ToolbarDropDownItemCollection overview

Public Instance Constructors

ToolbarDropDownItemCollection Constructor Initializes a new instance of the class that is empty and has the default initial capacity.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add | Overloaded. Adds an object to the end of the collection.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert | Overidden. Inserts an element into the collection at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

ToolbarDropDownItemCollection Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownItemCollection Constructor

Initializes a new instance of the class that is empty and has the default initial capacity.

[Visual Basic]
Public Sub New()
[C#]
public ToolbarDropDownItemCollection();
[C++]
public: ToolbarDropDownItemCollection();
[JScript]
public function ToolbarDropDownItemCollection();

Remarks

Creates and initializes a default instance of ToolbarDropDownItemCollection.

See Also

ToolbarDropDownItemCollection Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownItemCollection Methods

The methods of the ToolbarDropDownItemCollection class are listed below. For a complete list of ToolbarDropDownItemCollection class members, see the ToolbarDropDownItemCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds an object to the end of the collection.
AddRange (inherited from ArrayList) | Adds the elements of an ICollection to the end of the ArrayList.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear (inherited from ArrayList) | Removes all elements from the ArrayList.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Determines whether an element is in the ArrayList.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Insert | Overidden. Inserts an element into the collection at the specified index.
InsertRange (inherited from ArrayList) | Inserts the elements of a collection into the ArrayList at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Remove (inherited from ArrayList) | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt (inherited from ArrayList) | Removes the element at the specified index of the ArrayList.
RemoveRange (inherited from ArrayList) | Removes a range of elements from the ArrayList.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange (inherited from ArrayList) | Copies the elements of a collection over a range of elements in the ArrayList.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

ToolbarDropDownItemCollection Class | Dart.PowerWEB.TextBox Namespace


Add Method

ToolbarDropDownItemCollection.Add Method

Adds an object to the end of the collection.

Overload List

Adds an object to the end of the collection.

[Visual Basic] Public Function Add(ByVal ToolbarDropDownItem) As Integer
[C#] public int Add(ToolbarDropDownItem);
[C++] public: int Add(ToolbarDropDownItem*);
[JScript] public function Add(ToolbarDropDownItem): int;

Adds an object to the end of the collection.

[Visual Basic] Overrides OverloadsPublic Function Add(ByVal Object) _ Implements IList.Add As Integer
[C#] public override int Add(object);
[C++] public: int Add(Object*);
[JScript] public override function Add(Object): int;

See Also

ToolbarDropDownItemCollection Class | Dart.PowerWEB.TextBox Namespace


Add Method (ToolbarDropDownItem)

ToolbarDropDownItemCollection.Add Method (ToolbarDropDownItem)

Adds an object to the end of the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As ToolbarDropDownItem _
) As Integer
[C#]
public int Add(
   ToolbarDropDownItem value
);
[C++]
public: int Add(
   ToolbarDropDownItem* value
);
[JScript]
public function Add(
   ToolbarDropDownItem value
): int;

Parameters

value
The object to add to the end of the collection.

Return Value

The index to which value has been added.

Remarks

This method both adds an object to the end of the collection.

See Also

ToolbarDropDownItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarDropDownItemCollection.Add Overload List


Add Method (Object)

ToolbarDropDownItemCollection.Add Method (Object)

Adds an object to the end of the collection.

[Visual Basic]
Overrides  OverloadsPublic Function Add( _
   ByVal value As Object _
) _
    Implements IList.Add As Integer
[C#]
public override int Add(
   object value
);
[C++]
public: int Add(
   Object* value
);
[JScript]
public override function Add(
   Object value
): int;

Parameters

value
The object to add to the end of the collection.

Return Value

The index to which value has been added.

Implements

IList.Add

Remarks

This method both adds an object to the end of the collection.

See Also

ToolbarDropDownItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarDropDownItemCollection.Add Overload List


Insert Method

ToolbarDropDownItemCollection.Insert Method

Inserts an element into the collection at the specified index.

[Visual Basic]
Overrides Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
) _
    Implements IList.Insert
[C#]
public override void Insert(
   int index,
   object value
);
[C++]
public: void Insert(
   int index,
   Object* value
);
[JScript]
public override function Insert(
   int index,
   Object value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The object to insert.

Implements

IList.Insert

Remarks

This method both inserts an object into the collection.

See Also

ToolbarDropDownItemCollection Class | Dart.PowerWEB.TextBox Namespace


ToolbarDropDownType Enumeration

Enumerates the different types of ToolbarDropDown controls.

[Visual Basic]
Public Enum ToolbarDropDownType
[C#]
public enum ToolbarDropDownType
[C++]
public __value enum ToolbarDropDownType
[JScript]
public enum ToolbarDropDownType

Remarks

The ToolbarDropDownType is used to supply default values to a ToolbarDropDown. For example, when creating a new ToolbarDropDown, simply pass a ToolbarDropDownType into the constructor to supply the object with preset values associated with that type.

This enumeration is a subset of the ToolbarItemType enumeration.

Members

Member Name | Description
FontName | Defines a toolbar dropdown which displays font names. Associated type: ToolbarDropDown
FontSize | Defines a toolbar dropdown which displays font sizes. Associated type: ToolbarDropDown
FontStyle | Defines a toolbar dropdown which displays font styles. Associated type: ToolbarDropDown
FontFormatting | Defines a toolbar dropdown which displays font formatting types. Associated type: ToolbarDropDown
Insert | Defines a toolbar dropdown which inserts text. Associated type: ToolbarDropDown
Custom | Represents a dropdown. The dropdown will not do anything client side unless you provide some values for the properties of the object.
NotSet | No Type is associated with this object (typically because object was created using the default (paramaterless) constructor. Set the Type property to provide default values.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ToolbarImage Class

Represents a non-interactive image on the toolbar.

For a list of all members of this type, see ToolbarImage Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.ToolbarImage

[Visual Basic]
Public Class ToolbarImage
    Inherits BaseToolbarItem
[C#]
public class ToolbarImage : BaseToolbarItem
[C++]
public __gc class ToolbarImage : public BaseToolbarItem
[JScript]
public class ToolbarImage extends BaseToolbarItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Create a custom ToolbarImage to insert your own image onto the toolbar or use a predefined ToolbarImage type to apply formatting to your toolbar such as item seperators and row seperators.

A ToolbarImage can be created and used one of two ways:

  • Calling HtmlBox.AddToolbarItem, passing in a ToolbarItemType associated with ToolbarImage (such as ToolbarItemType.Seperator) creates the ToolbarImage, initializing it with default values for the "seperator" type, and adds it to the Toolbar in one step.
  • Create a new ToolbarImage, passing in a ToolbarImageType (such as ToolbarImageType.Seperator). This will create and initialize the ToolbarImage with default values for the "seperator" type. Add the ToolbarImage using the ToolbarItemCollection.Add method (HtmlBox.Toolbar.Items.Add).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarImage Members | Dart.PowerWEB.TextBox Namespace


ToolbarImage Members

ToolbarImage overview

Public Instance Constructors

ToolbarImage Overloaded. Initializes a new instance of the ToolbarImage class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarItem) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageName | Gets or sets the name of the image displayed on the toolbar.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarImageType associated with this ToolbarImage.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ToolbarImage Class | Dart.PowerWEB.TextBox Namespace


ToolbarImage Constructor

Creates a predefined ToolbarImage

Overload List

Creates a custom ToolbarImage

[Visual Basic] Public Sub New()
[C#] public ToolbarImage();
[C++] public: ToolbarImage();
[JScript] public function ToolbarImage();

Creates a predefined ToolbarImage

[Visual Basic] Public Sub New(ByVal ToolbarImageType)
[C#] public ToolbarImage(ToolbarImageType);
[C++] public: ToolbarImage(ToolbarImageType);
[JScript] public function ToolbarImage(ToolbarImageType);

See Also

ToolbarImage Class | Dart.PowerWEB.TextBox Namespace


ToolbarImage Constructor (ToolbarImageType)

Creates a predefined ToolbarImage

[Visual Basic]
Public Sub New( _
   ByVal type As ToolbarImageType _
)
[C#]
public ToolbarImage(
   ToolbarImageType type
);
[C++]
public: ToolbarImage(
   ToolbarImageType type
);
[JScript]
public function ToolbarImage(
   ToolbarImageType type
);

Parameters

type
The ToolbarImageType which is used to supply the proper default properties for the ToolbarImage.

Remarks

This constructor creates a ToolbarImage of the specified type and supplies it with the default values for the specified type.

See Also

ToolbarImage Class | Dart.PowerWEB.TextBox Namespace | ToolbarImage Constructor Overload List


ToolbarImage Constructor ()

Creates a custom ToolbarImage

[Visual Basic]
Public Sub New()
[C#]
public ToolbarImage();
[C++]
public: ToolbarImage();
[JScript]
public function ToolbarImage();

Remarks

The default constructor creates and initializes a ToolBarImage as a ToolbarImageType.Custom image.

See Also

ToolbarImage Class | Dart.PowerWEB.TextBox Namespace | ToolbarImage Constructor Overload List


ToolbarImage Properties

The properties of the ToolbarImage class are listed below. For a complete list of ToolbarImage class members, see the ToolbarImage Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarItem) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageName | Gets or sets the name of the image displayed on the toolbar.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarImageType associated with this ToolbarImage.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

ToolbarImage Class | Dart.PowerWEB.TextBox Namespace


ImageName Property

ToolbarImage.ImageName Property

Gets or sets the name of the image displayed on the toolbar.

[Visual Basic]
Public Property ImageName As String
[C#]
public string ImageName { get; set; }
[C++]
public: __property String* get_ImageName();
public: __property void set_ImageName(String* );
[JScript]
public function get ImageName() : String
public function set ImageName(String);

Property Value

A string containing no instances of "/", "\", or "~" indicating a image file contained within HtmlBox.ImagesDirectory or a string containing one or many instances of "/", "\", or "~" indicating a full virtual, relative, or absolute path to an image file. The default value is an empty string.

Remarks

For preset types, this property will come preset to a valid imagename found in the images directory (specified by HtmlBox.ImagesDirectory) created during the product installation. Set this property only if you wish to change from the presets or if you are creating a custom ToolbarImage.

PowerWEB TextBox for .NET automatically assumes that all images are in the directory specified by HtmlBox.ImagesDirectory. For example, if the value of HtmlBox.ImagesDirectory is "/PowerWEB_TextBox_Common/images" (the default) and this property was set to "myimage.jpg", the control would assume the file can be found at "/PowerWEB_TextBox_Common/images/myimage.jpg". If you set this property to a string that has some form of directory designation, such as "slashes" within it (for example "C:\temp\myimage.jpg") the control would no longer assume that the image is within HtmlBox.ImagesDirectory but would use the full path you supplied for this property.

See Also

ToolbarImage Class | Dart.PowerWEB.TextBox Namespace


Type Property

ToolbarImage.Type Property

Gets or sets the ToolbarImageType associated with this ToolbarImage.

[Visual Basic]
Public Property Type As ToolbarImageType
[C#]
public ToolbarImageType Type { get; set; }
[C++]
public: __property ToolbarImageType get_Type();
public: __property void set_Type(ToolbarImageType );
[JScript]
public function get Type() : ToolbarImageType
public function set Type(ToolbarImageType);

Property Value

A ToolbarImageType associated with this ToolbarImage.

Remarks

Typically, this property gets it's value during initialization. However, this property can be set. If this occurs, the current values of the ToolbarImage will be lost and replaced with the default settings associated with the new ToolbarImageType.

See Also

ToolbarImage Class | Dart.PowerWEB.TextBox Namespace


ToolbarImage Methods

The methods of the ToolbarImage class are listed below. For a complete list of ToolbarImage class members, see the ToolbarImage Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

See Also

ToolbarImage Class | Dart.PowerWEB.TextBox Namespace


Clone Method

ToolbarImage.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As ToolbarImage
[C#]
public ToolbarImage Clone();
[C++]
public: ToolbarImage* Clone();
[JScript]
public function Clone(): ToolbarImage;

Return Value

An HtmlBox control.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

ToolbarImage Class | Dart.PowerWEB.TextBox Namespace


ToolbarImageType Enumeration

Enumerates the different types of ToolbarImage controls.

[Visual Basic]
Public Enum ToolbarImageType
[C#]
public enum ToolbarImageType
[C++]
public __value enum ToolbarImageType
[JScript]
public enum ToolbarImageType

Remarks

The ToolbarImageType is used to supply default values to a ToolbarImage. For example, when creating a new ToolbarImage, simply pass a ToolbarImageType into the constructor to supply the object with preset values associated with that type.

This enumeration is a subset of the ToolbarItemType enumeration.

Members

Member Name | Description
Separator | Defines a toolbar item which inserts a graphica seperator between buttons. Associated type: ToolbarImage
DoubleSeparator | Defines a toolbar image which represents a "double seperator" (typically used at the start of rows). Associated type: ToolbarImage
RowSeparator | Defines a toolbar item which inserts a graphical row seperator. Associated type: ToolbarImage
Custom | Represents a dropdown. The dropdown will not do anything client side unless you provide some values for the properties of the object.
NotSet | No Type is associated with this object (typically because object was created using the default (paramaterless) constructor. Set the Type property to provide default values.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ToolbarItemCollection Class

Represents a collection used to manage BaseToolbarItem controls.

For a list of all members of this type, see ToolbarItemCollection Members.

System.Object
System.Collections.ArrayList
Dart.PowerWEB.TextBox.ToolbarItemCollection

[Visual Basic]
Public Class ToolbarItemCollection
    Inherits ArrayList
[C#]
public class ToolbarItemCollection : ArrayList
[C++]
public __gc class ToolbarItemCollection : public ArrayList
[JScript]
public class ToolbarItemCollection extends ArrayList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

When the HtmlBox creates this collection internally, it provides a reference to the Toolbar web control that is the "parent" of this collection. When items are added/removed to the collection, references to these items are also added/removed to the ASP.NET web control heirarchy. For this reason, it is NOT recommended that you create an object of this type within your code. Simply used the instance already created and initialized, and exposed as the Toolbar.Items property of the Toolbar control.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarItemCollection Members | Dart.PowerWEB.TextBox Namespace


ToolbarItemCollection Members

ToolbarItemCollection overview

Public Instance Constructors

ToolbarItemCollection Constructor Initializes a new instance of the class that is empty and has the default initial capacity.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
ParentToolbar | Gets a reference to the parent Toolbar.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

Public Instance Methods

Add | Overloaded. Adds an object to the end of the collection.
AddRange | Overloaded. Adds the elements from the passed collection to the end of the collection.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear | Overidden. Removes all objects from the collection.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Overloaded. Determines whether an element is in the ArrayList.
Contains | Overloaded. Determines if an object is in the collection.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetByType | Returns the first BaseToolItem with a Type property that matches the passed value.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
IndexOf | Overloaded. Searches the collection for the object and returns the zero-based index of the first occurrence within the collection.
Insert | Overloaded. Inserts an element into the collection at the specified index.
InsertRange | Overloaded. Inserts the elements of a collection into this collection at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
LastIndexOf | Overloaded. Searches the collection for a BaseToolbarItem based on the Type property and returns the zero-based index of the last occurrence within the collection.
Remove | Overloaded. Removes the first occurrence of a specific object from the collection.
RemoveAt | Overidden. Removes the element at the specified index in the collection.
RemoveRange | Overidden. Removes a range of elements from the collection.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange | Overloaded. Copies the elements of a collection over a range of elements in this collection.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


ToolbarItemCollection Constructor

Initializes a new instance of the class that is empty and has the default initial capacity.

[Visual Basic]
Public Sub New()
[C#]
public ToolbarItemCollection();
[C++]
public: ToolbarItemCollection();
[JScript]
public function ToolbarItemCollection();

Remarks

Creates and initializes a default instance of ToolbarItemCollection.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


ToolbarItemCollection Properties

The properties of the ToolbarItemCollection class are listed below. For a complete list of ToolbarItemCollection class members, see the ToolbarItemCollection Members topic.

Public Instance Properties

Capacity (inherited from ArrayList) | Gets or sets the number of elements that the ArrayList can contain.
Count (inherited from ArrayList) | Gets the number of elements actually contained in the ArrayList.
IsFixedSize (inherited from ArrayList) | Gets a value indicating whether the ArrayList has a fixed size.
IsReadOnly (inherited from ArrayList) | Gets a value indicating whether the ArrayList is read-only.
IsSynchronized (inherited from ArrayList) | Gets a value indicating whether access to the ArrayList is synchronized (thread-safe).
Item (inherited from ArrayList) | Gets or sets the element at the specified index.
ParentToolbar | Gets a reference to the parent Toolbar.
SyncRoot (inherited from ArrayList) | Gets an object that can be used to synchronize access to the ArrayList.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


ParentToolbar Property

ToolbarItemCollection.ParentToolbar Property

Gets a reference to the parent Toolbar.

[Visual Basic]
Public Property ParentToolbar As Toolbar
[C#]
public Toolbar ParentToolbar { get; set; }
[C++]
public: __property Toolbar* get_ParentToolbar();
public: __property void set_ParentToolbar(Toolbar* );
[JScript]
public function get ParentToolbar() : Toolbar
public function set ParentToolbar(Toolbar);

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


ToolbarItemCollection Methods

The methods of the ToolbarItemCollection class are listed below. For a complete list of ToolbarItemCollection class members, see the ToolbarItemCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds an object to the end of the collection.
AddRange | Overloaded. Adds the elements from the passed collection to the end of the collection.
BinarySearch (inherited from ArrayList) | Overloaded. Searches the entire sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element.
Clear | Overidden. Removes all objects from the collection.
Clone (inherited from ArrayList) | Creates a shallow copy of the ArrayList.
Contains (inherited from ArrayList) | Overloaded. Determines whether an element is in the ArrayList.
Contains | Overloaded. Determines if an object is in the collection.
CopyTo (inherited from ArrayList) | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the specified index of the target array.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetByType | Returns the first BaseToolItem with a Type property that matches the passed value.
GetEnumerator (inherited from ArrayList) | Overloaded. Returns an enumerator for the entire ArrayList.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetRange (inherited from ArrayList) | Returns an ArrayList which represents a subset of the elements in the source ArrayList.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
IndexOf | Overloaded. Searches the collection for the object and returns the zero-based index of the first occurrence within the collection.
Insert | Overloaded. Inserts an element into the collection at the specified index.
InsertRange | Overloaded. Inserts the elements of a collection into this collection at the specified index.
LastIndexOf (inherited from ArrayList) | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
LastIndexOf | Overloaded. Searches the collection for a BaseToolbarItem based on the Type property and returns the zero-based index of the last occurrence within the collection.
Remove | Overloaded. Removes the first occurrence of a specific object from the collection.
RemoveAt | Overidden. Removes the element at the specified index in the collection.
RemoveRange | Overidden. Removes a range of elements from the collection.
Reverse (inherited from ArrayList) | Overloaded. Reverses the order of the elements in the specified range.
SetRange | Overloaded. Copies the elements of a collection over a range of elements in this collection.
Sort (inherited from ArrayList) | Overloaded. Sorts the elements in a section of ArrayList using the specified comparer.
ToArray (inherited from ArrayList) | Overloaded. Copies the elements of the ArrayList to a new array of the specified type.
ToString (inherited from Object) | Returns a String that represents the current Object.
TrimToSize (inherited from ArrayList) | Sets the capacity to the actual number of elements in the ArrayList.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


Add Method

ToolbarItemCollection.Add Method

Adds an object to the end of the collection.

Overload List

Adds an object to the end of the collection.

[Visual Basic] Public Function Add(ByVal BaseToolbarItem) As Integer
[C#] public int Add(BaseToolbarItem);
[C++] public: int Add(BaseToolbarItem*);
[JScript] public function Add(BaseToolbarItem): int;

Adds an object to the end of the collection.

[Visual Basic] Overrides OverloadsPublic Function Add(ByVal Object) _ Implements IList.Add As Integer
[C#] public override int Add(object);
[C++] public: int Add(Object*);
[JScript] public override function Add(Object): int;

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


Add Method (BaseToolbarItem)

ToolbarItemCollection.Add Method (BaseToolbarItem)

Adds an object to the end of the collection.

[Visual Basic]
Public Function Add( _
   ByVal value As BaseToolbarItem _
) As Integer
[C#]
public int Add(
   BaseToolbarItem value
);
[C++]
public: int Add(
   BaseToolbarItem* value
);
[JScript]
public function Add(
   BaseToolbarItem value
): int;

Parameters

value
The object to add to the end of the collection.

Return Value

The index to which value has been added.

Remarks

This method both adds an object to the collection, and adds a reference to this object in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.Add Overload List


Add Method (Object)

ToolbarItemCollection.Add Method (Object)

Adds an object to the end of the collection.

[Visual Basic]
Overrides  OverloadsPublic Function Add( _
   ByVal value As Object _
) _
    Implements IList.Add As Integer
[C#]
public override int Add(
   object value
);
[C++]
public: int Add(
   Object* value
);
[JScript]
public override function Add(
   Object value
): int;

Parameters

value
The object to add to the end of the collection.

Return Value

The index to which value has been added.

Implements

IList.Add

Remarks

This method both adds an object to the collection, and adds a reference to this object in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.Add Overload List


AddRange Method

ToolbarItemCollection.AddRange Method

Adds the elements from the passed collection to the end of the collection.

Overload List

Adds the elements from the passed collection to the end of the collection.

[Visual Basic] Public Sub AddRange(ByVal BaseToolbarItem())
[C#] public void AddRange(BaseToolbarItem[]);
[C++] public: void AddRange(BaseToolbarItem* __gc[]);
[JScript] public function AddRange(BaseToolbarItem[]);

Adds the elements from the passed collection to the end of the collection.

[Visual Basic] Overrides OverloadsPublic Sub AddRange(ByVal ICollection)
[C#] public override void AddRange(ICollection);
[C++] public: void AddRange(ICollection*);
[JScript] public override function AddRange(ICollection);

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


AddRange Method (BaseToolbarItem[])

ToolbarItemCollection.AddRange Method (BaseToolbarItem[])

Adds the elements from the passed collection to the end of the collection.

[Visual Basic]
Public Sub AddRange( _
   ByVal c As BaseToolbarItem() _
)
[C#]
public void AddRange(
   BaseToolbarItem[] c
);
[C++]
public: void AddRange(
   BaseToolbarItem* c __gc[]
);
[JScript]
public function AddRange(
   BaseToolbarItem[] c
);

Parameters

c
The collection whose elements should be added to the end of the ArrayList.

Remarks

This method both adds the objects in c to the collection, and adds a reference to these objects in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.AddRange Overload List


AddRange Method (ICollection)

ToolbarItemCollection.AddRange Method (ICollection)

Adds the elements from the passed collection to the end of the collection.

[Visual Basic]
Overrides  OverloadsPublic Sub AddRange( _
   ByVal c As ICollection _
)
[C#]
public override void AddRange(
   ICollection c
);
[C++]
public: void AddRange(
   ICollection* c
);
[JScript]
public override function AddRange(
   ICollection c
);

Parameters

c
The collection whose elements should be added to the end of the ArrayList.

Remarks

This method both adds the objects in c to the collection, and adds a reference to these objects in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.AddRange Overload List


Clear Method

ToolbarItemCollection.Clear Method

Removes all objects from the collection.

[Visual Basic]
Overrides Public Sub Clear() _
    Implements IList.Clear
[C#]
public override void Clear();
[C++]
public: void Clear();
[JScript]
public override function Clear();

Implements

IList.Clear

Remarks

This method both clears the objects in the collection, and clears references to these objects in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


Contains Method

ToolbarItemCollection.Contains Method

Determines if an object is in the collection.

Overload List

Determines if an object is in the collection.

[Visual Basic] Public Function Contains(ByVal BaseToolbarItem) As Boolean
[C#] public bool Contains(BaseToolbarItem);
[C++] public: bool Contains(BaseToolbarItem*);
[JScript] public function Contains(BaseToolbarItem): bool;

Determines if ToolbarItemType is in the collection.

[Visual Basic] Public Function Contains(ByVal ToolbarItemType) As Boolean
[C#] public bool Contains(ToolbarItemType);
[C++] public: bool Contains(ToolbarItemType);
[JScript] public function Contains(ToolbarItemType): bool;

Determines whether an element is in the ArrayList.
Inherited from ArrayList.

[Visual Basic] Overridable OverloadsPublic Function Contains(ByVal Object) _ Implements IList.Contains As Boolean
[C#] public virtual bool Contains(object);
[C++] public: virtual bool Contains(Object*);
[JScript] public virtual function Contains(Object): bool;

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


Contains Method (BaseToolbarItem)

ToolbarItemCollection.Contains Method (BaseToolbarItem)

Determines if an object is in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal item As BaseToolbarItem _
) As Boolean
[C#]
public bool Contains(
   BaseToolbarItem item
);
[C++]
public: bool Contains(
   BaseToolbarItem* item
);
[JScript]
public function Contains(
   BaseToolbarItem item
): bool;

Parameters

item
The object to find in the collection.

Return Value

true if the item is found in the collection; false otherwise.

Remarks

This method performs a linear search; therefore, the average execution time is proportional to Count. That is, this method is an O(n) operation, where n is Count.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.Contains Overload List


Contains Method (ToolbarItemType)

ToolbarItemCollection.Contains Method (ToolbarItemType)

Determines if ToolbarItemType is in the collection.

[Visual Basic]
Public Function Contains( _
   ByVal type As ToolbarItemType _
) As Boolean
[C#]
public bool Contains(
   ToolbarItemType type
);
[C++]
public: bool Contains(
   ToolbarItemType type
);
[JScript]
public function Contains(
   ToolbarItemType type
): bool;

Parameters

type
The ToolbarItemType to find in the collection.

Return Value

true if an item in the collection has the same Type as type; false otherwise.

Remarks

This method checks the BaseToolbarItem.Type property of each BaseToolbarItem against the value passed in as type.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.Contains Overload List


GetByType Method

ToolbarItemCollection.GetByType Method

Returns the first BaseToolItem with a Type property that matches the passed value.

[Visual Basic]
Public Function GetByType( _
   ByVal type As ToolbarItemType _
) As BaseToolbarItem
[C#]
public BaseToolbarItem GetByType(
   ToolbarItemType type
);
[C++]
public: BaseToolbarItem* GetByType(
   ToolbarItemType type
);
[JScript]
public function GetByType(
   ToolbarItemType type
): BaseToolbarItem;

Parameters

type
The ToolbarItemType to check against the Type property of each BaseToolbarItem.

Return Value

If type matches the Type property of a BaseToolbarItem in the collection, this BaseToolbarItem is returned; null otherwise.

Remarks

This method enables easy retrieval of a BaseToolbarItem based on the Type property of the control.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


IndexOf Method

ToolbarItemCollection.IndexOf Method

Searches the collection for the object and returns the zero-based index of the first occurrence within the collection.

Overload List

Searches the collection for the object and returns the zero-based index of the first occurrence within the collection.

[Visual Basic] Public Function IndexOf(ByVal BaseToolbarItem) As Integer
[C#] public int IndexOf(BaseToolbarItem);
[C++] public: int IndexOf(BaseToolbarItem*);
[JScript] public function IndexOf(BaseToolbarItem): int;

Searches the collection for a BaseToolbarItem based on the Type property and returns the zero-based index of the first occurrence within the collection.

[Visual Basic] Public Function IndexOf(ByVal ToolbarItemType) As Integer
[C#] public int IndexOf(ToolbarItemType);
[C++] public: int IndexOf(ToolbarItemType);
[JScript] public function IndexOf(ToolbarItemType): int;

Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList.
Inherited from ArrayList.

[Visual Basic] Overridable OverloadsPublic Function IndexOf(ByVal Object) _ Implements IList.IndexOf As Integer
[C#] public virtual int IndexOf(object);
[C++] public: virtual int IndexOf(Object*);
[JScript] public virtual function IndexOf(Object): int;

Searches for the specified Object and returns the zero-based index of the first occurrence within the section of the ArrayList that extends from the specified index to the last element.
Inherited from ArrayList.

[Visual Basic] Overridable OverloadsPublic Function IndexOf(ByVal Object,ByVal Integer) As Integer
[C#] public virtual int IndexOf(object,int);
[C++] public: virtual int IndexOf(Object*,int);
[JScript] public virtual function IndexOf(Object,int): int;

Searches for the specified Object and returns the zero-based index of the first occurrence within the section of the ArrayList that starts at the specified index and contains the specified number of elements.
Inherited from ArrayList.

[Visual Basic] Overridable OverloadsPublic Function IndexOf(ByVal Object,ByVal Integer,ByVal Integer) As Integer
[C#] public virtual int IndexOf(object,int,int);
[C++] public: virtual int IndexOf(Object*,int,int);
[JScript] public virtual function IndexOf(Object,int,int): int;

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


IndexOf Method (BaseToolbarItem)

ToolbarItemCollection.IndexOf Method (BaseToolbarItem)

Searches the collection for the object and returns the zero-based index of the first occurrence within the collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal value As BaseToolbarItem _
) As Integer
[C#]
public int IndexOf(
   BaseToolbarItem value
);
[C++]
public: int IndexOf(
   BaseToolbarItem* value
);
[JScript]
public function IndexOf(
   BaseToolbarItem value
): int;

Parameters

value
The object to locate in the collection.

Return Value

The zero-based index of the object if it is found; -1 if the object is not found in the collection.

Remarks

The collection is searched forward starting at the first element and ending at the last element.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.IndexOf Overload List


IndexOf Method (ToolbarItemType)

ToolbarItemCollection.IndexOf Method (ToolbarItemType)

Searches the collection for a BaseToolbarItem based on the Type property and returns the zero-based index of the first occurrence within the collection.

[Visual Basic]
Public Function IndexOf( _
   ByVal type As ToolbarItemType _
) As Integer
[C#]
public int IndexOf(
   ToolbarItemType type
);
[C++]
public: int IndexOf(
   ToolbarItemType type
);
[JScript]
public function IndexOf(
   ToolbarItemType type
): int;

Parameters

type
The ToolbarItemType to locate in the collection.

Return Value

The zero-based index of the object if an object with a Type property matching type is found; -1 if not found.

Remarks

The collection is searched forward starting at the first element and ending at the last element. The Type property of each BaseToolbarItem is compared against type.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.IndexOf Overload List


Insert Method

ToolbarItemCollection.Insert Method

Inserts an element into the collection at the specified index.

Overload List

Inserts an element into the collection at the specified index.

[Visual Basic] Public Sub Insert(ByVal Integer,ByVal BaseToolbarItem)
[C#] public void Insert(int,BaseToolbarItem);
[C++] public: void Insert(int,BaseToolbarItem*);
[JScript] public function Insert(int,BaseToolbarItem);

Inserts an element into the collection at the specified index.

[Visual Basic] Overrides OverloadsPublic Sub Insert(ByVal Integer,ByVal Object) _ Implements IList.Insert
[C#] public override void Insert(int,object);
[C++] public: void Insert(int,Object*);
[JScript] public override function Insert(int,Object);

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


Insert Method (Int32, BaseToolbarItem)

ToolbarItemCollection.Insert Method (Int32, BaseToolbarItem)

Inserts an element into the collection at the specified index.

[Visual Basic]
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As BaseToolbarItem _
)
[C#]
public void Insert(
   int index,
   BaseToolbarItem value
);
[C++]
public: void Insert(
   int index,
   BaseToolbarItem* value
);
[JScript]
public function Insert(
   int index,
   BaseToolbarItem value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The object to insert.

Remarks

This method both inserts an object into the collection, and adds a reference to this object in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.Insert Overload List


Insert Method (Int32, Object)

ToolbarItemCollection.Insert Method (Int32, Object)

Inserts an element into the collection at the specified index.

[Visual Basic]
Overrides  OverloadsPublic Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
) _
    Implements IList.Insert
[C#]
public override void Insert(
   int index,
   object value
);
[C++]
public: void Insert(
   int index,
   Object* value
);
[JScript]
public override function Insert(
   int index,
   Object value
);

Parameters

index
The zero-based index at which value should be inserted.
value
The object to insert.

Implements

IList.Insert

Remarks

This method both inserts an object into the collection, and adds a reference to this object in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.Insert Overload List


InsertRange Method

ToolbarItemCollection.InsertRange Method

Inserts the elements of a collection into this collection at the specified index.

Overload List

Inserts the elements of a collection into this collection at the specified index.

[Visual Basic] Public Sub InsertRange(ByVal Integer,ByVal BaseToolbarItem())
[C#] public void InsertRange(int,BaseToolbarItem[]);
[C++] public: void InsertRange(int,BaseToolbarItem* __gc[]);
[JScript] public function InsertRange(int,BaseToolbarItem[]);

Inserts the elements of a collection into this collection at the specified index.

[Visual Basic] Overrides OverloadsPublic Sub InsertRange(ByVal Integer,ByVal ICollection)
[C#] public override void InsertRange(int,ICollection);
[C++] public: void InsertRange(int,ICollection*);
[JScript] public override function InsertRange(int,ICollection);

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


InsertRange Method (Int32, BaseToolbarItem[])

ToolbarItemCollection.InsertRange Method (Int32, BaseToolbarItem[])

Inserts the elements of a collection into this collection at the specified index.

[Visual Basic]
Public Sub InsertRange( _
   ByVal index As Integer, _
   ByVal c As BaseToolbarItem() _
)
[C#]
public void InsertRange(
   int index,
   BaseToolbarItem[] c
);
[C++]
public: void InsertRange(
   int index,
   BaseToolbarItem* c __gc[]
);
[JScript]
public function InsertRange(
   int index,
   BaseToolbarItem[] c
);

Parameters

index
The zero-based index at which the new elements should be inserted.
c
The collection whose elements are inserted into this collection.

Remarks

This method both inserts the objects in c into the collection, and adds a reference to these objects in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.InsertRange Overload List


InsertRange Method (Int32, ICollection)

ToolbarItemCollection.InsertRange Method (Int32, ICollection)

Inserts the elements of a collection into this collection at the specified index.

[Visual Basic]
Overrides  OverloadsPublic Sub InsertRange( _
   ByVal index As Integer, _
   ByVal c As ICollection _
)
[C#]
public override void InsertRange(
   int index,
   ICollection c
);
[C++]
public: void InsertRange(
   int index,
   ICollection* c
);
[JScript]
public override function InsertRange(
   int index,
   ICollection c
);

Parameters

index
The zero-based index at which the new elements should be inserted.
c
The collection whose elements are inserted into this collection.

Remarks

This method both inserts the objects in c into the collection, and adds a reference to these objects in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.InsertRange Overload List


LastIndexOf Method

ToolbarItemCollection.LastIndexOf Method

Searches the collection for a BaseToolbarItem based on the Type property and returns the zero-based index of the last occurrence within the collection.

Overload List

Searches the collection for a BaseToolbarItem based on the Type property and returns the zero-based index of the last occurrence within the collection.

[Visual Basic] Public Function LastIndexOf(ByVal ToolbarItemType) As Integer
[C#] public int LastIndexOf(ToolbarItemType);
[C++] public: int LastIndexOf(ToolbarItemType);
[JScript] public function LastIndexOf(ToolbarItemType): int;

Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList.
Inherited from ArrayList.

[Visual Basic] Overridable OverloadsPublic Function LastIndexOf(ByVal Object) As Integer
[C#] public virtual int LastIndexOf(object);
[C++] public: virtual int LastIndexOf(Object*);
[JScript] public virtual function LastIndexOf(Object): int;

Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that extends from the first element to the specified index.
Inherited from ArrayList.

[Visual Basic] Overridable OverloadsPublic Function LastIndexOf(ByVal Object,ByVal Integer) As Integer
[C#] public virtual int LastIndexOf(object,int);
[C++] public: virtual int LastIndexOf(Object*,int);
[JScript] public virtual function LastIndexOf(Object,int): int;

Searches for the specified Object and returns the zero-based index of the last occurrence within the section of the ArrayList that contains the specified number of elements and ends at the specified index.
Inherited from ArrayList.

[Visual Basic] Overridable OverloadsPublic Function LastIndexOf(ByVal Object,ByVal Integer,ByVal Integer) As Integer
[C#] public virtual int LastIndexOf(object,int,int);
[C++] public: virtual int LastIndexOf(Object*,int,int);
[JScript] public virtual function LastIndexOf(Object,int,int): int;

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


LastIndexOf Method (ToolbarItemType)

ToolbarItemCollection.LastIndexOf Method (ToolbarItemType)

Searches the collection for a BaseToolbarItem based on the Type property and returns the zero-based index of the last occurrence within the collection.

[Visual Basic]
Public Function LastIndexOf( _
   ByVal type As ToolbarItemType _
) As Integer
[C#]
public int LastIndexOf(
   ToolbarItemType type
);
[C++]
public: int LastIndexOf(
   ToolbarItemType type
);
[JScript]
public function LastIndexOf(
   ToolbarItemType type
): int;

Parameters

type
The ToolbarItemType to locate in the collection.

Return Value

The zero-based index of the object if an object with a Type property matching type is found; -1 if not found.

Remarks

The collection is searched backward starting at the last element and ending at the first element. The Type property of each BaseToolbarItem is compared against type.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.LastIndexOf Overload List


Remove Method

ToolbarItemCollection.Remove Method

Removes the first occurrence of a specific object from the collection.

Overload List

Removes the first occurrence of a specific object from the collection.

[Visual Basic] Public Sub Remove(ByVal BaseToolbarItem)
[C#] public void Remove(BaseToolbarItem);
[C++] public: void Remove(BaseToolbarItem*);
[JScript] public function Remove(BaseToolbarItem);

Removes the first occurrence of a specific BaseToolbarItem with a Type property matching the passed value.

[Visual Basic] Public Sub Remove(ByVal ToolbarItemType)
[C#] public void Remove(ToolbarItemType);
[C++] public: void Remove(ToolbarItemType);
[JScript] public function Remove(ToolbarItemType);

Removes the first occurrence of a specific object from the collection.

[Visual Basic] Overrides OverloadsPublic Sub Remove(ByVal Object) _ Implements IList.Remove
[C#] public override void Remove(object);
[C++] public: void Remove(Object*);
[JScript] public override function Remove(Object);

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


Remove Method (BaseToolbarItem)

ToolbarItemCollection.Remove Method (BaseToolbarItem)

Removes the first occurrence of a specific object from the collection.

[Visual Basic]
Public Sub Remove( _
   ByVal obj As BaseToolbarItem _
)
[C#]
public void Remove(
   BaseToolbarItem obj
);
[C++]
public: void Remove(
   BaseToolbarItem* obj
);
[JScript]
public function Remove(
   BaseToolbarItem obj
);

Parameters

obj
The object to remove from the collection.

Remarks

This method both removes the object from the collection (if found), and removes the reference to this object in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.Remove Overload List


Remove Method (ToolbarItemType)

ToolbarItemCollection.Remove Method (ToolbarItemType)

Removes the first occurrence of a specific BaseToolbarItem with a Type property matching the passed value.

[Visual Basic]
Public Sub Remove( _
   ByVal type As ToolbarItemType _
)
[C#]
public void Remove(
   ToolbarItemType type
);
[C++]
public: void Remove(
   ToolbarItemType type
);
[JScript]
public function Remove(
   ToolbarItemType type
);

Parameters

type
The ToolbarItemType specifying the BaseToolbarItem to remove from the collection.

Remarks

This method both removes the object from the collection (if found), and removes the reference to this object in the ASP.NET web control heirarchy. type is compared to the Type property of each BaseToolbarItem in the collection.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.Remove Overload List


Remove Method (Object)

ToolbarItemCollection.Remove Method (Object)

Removes the first occurrence of a specific object from the collection.

[Visual Basic]
Overrides  OverloadsPublic Sub Remove( _
   ByVal obj As Object _
) _
    Implements IList.Remove
[C#]
public override void Remove(
   object obj
);
[C++]
public: void Remove(
   Object* obj
);
[JScript]
public override function Remove(
   Object obj
);

Parameters

obj
The object to remove from the collection.

Implements

IList.Remove

Remarks

This method both removes the object from the collection (if found), and removes the reference to this object in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.Remove Overload List


RemoveAt Method

ToolbarItemCollection.RemoveAt Method

Removes the element at the specified index in the collection.

[Visual Basic]
Overrides Public Sub RemoveAt( _
   ByVal index As Integer _
) _
    Implements IList.RemoveAt
[C#]
public override void RemoveAt(
   int index
);
[C++]
public: void RemoveAt(
   int index
);
[JScript]
public override function RemoveAt(
   int index
);

Parameters

index
The zero-based index of the element to remove.

Implements

IList.RemoveAt

Remarks

This method both removes the object from the collection, and removes the reference to this object in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


RemoveRange Method

ToolbarItemCollection.RemoveRange Method

Removes a range of elements from the collection.

[Visual Basic]
Overrides Public Sub RemoveRange( _
   ByVal index As Integer, _
   ByVal count As Integer _
)
[C#]
public override void RemoveRange(
   int index,
   int count
);
[C++]
public: void RemoveRange(
   int index,
   int count
);
[JScript]
public override function RemoveRange(
   int index,
   int count
);

Parameters

index
The zero-based starting index of the range of elements to remove.
count
The number of elements to remove.

Remarks

This method both removes the range of objects from the collection, and removes the references to these objects in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


SetRange Method

ToolbarItemCollection.SetRange Method

Copies the elements of a collection over a range of elements in this collection.

Overload List

Copies the elements of a collection over a range of elements in this collection.

[Visual Basic] Public Sub SetRange(ByVal Integer,ByVal BaseToolbarItem())
[C#] public void SetRange(int,BaseToolbarItem[]);
[C++] public: void SetRange(int,BaseToolbarItem* __gc[]);
[JScript] public function SetRange(int,BaseToolbarItem[]);

Copies the elements of a collection over a range of elements in this collection.

[Visual Basic] Overrides OverloadsPublic Sub SetRange(ByVal Integer,ByVal ICollection)
[C#] public override void SetRange(int,ICollection);
[C++] public: void SetRange(int,ICollection*);
[JScript] public override function SetRange(int,ICollection);

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace


SetRange Method (Int32, BaseToolbarItem[])

ToolbarItemCollection.SetRange Method (Int32, BaseToolbarItem[])

Copies the elements of a collection over a range of elements in this collection.

[Visual Basic]
Public Sub SetRange( _
   ByVal index As Integer, _
   ByVal c As BaseToolbarItem() _
)
[C#]
public void SetRange(
   int index,
   BaseToolbarItem[] c
);
[C++]
public: void SetRange(
   int index,
   BaseToolbarItem* c __gc[]
);
[JScript]
public function SetRange(
   int index,
   BaseToolbarItem[] c
);

Parameters

index
The zero-based index at which to start copying the elements of c.
c
The collection whose elements are copied to this collection.

Remarks

This method both copies the elements of c to this collection, and adds a reference to these objects in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.SetRange Overload List


SetRange Method (Int32, ICollection)

ToolbarItemCollection.SetRange Method (Int32, ICollection)

Copies the elements of a collection over a range of elements in this collection.

[Visual Basic]
Overrides  OverloadsPublic Sub SetRange( _
   ByVal index As Integer, _
   ByVal c As ICollection _
)
[C#]
public override void SetRange(
   int index,
   ICollection c
);
[C++]
public: void SetRange(
   int index,
   ICollection* c
);
[JScript]
public override function SetRange(
   int index,
   ICollection c
);

Parameters

index
The zero-based index at which to start copying the elements of c.
c
The collection whose elements are copied to this collection.

Remarks

This method both copies the elements of c to this collection, and adds a reference to these objects in the ASP.NET web control heirarchy.

See Also

ToolbarItemCollection Class | Dart.PowerWEB.TextBox Namespace | ToolbarItemCollection.SetRange Overload List


ToolbarItemType Enumeration

Provides a common interface for all items on the toolbar.

[Visual Basic]
Public Enum ToolbarItemType
[C#]
public enum ToolbarItemType
[C++]
public __value enum ToolbarItemType
[JScript]
public enum ToolbarItemType

Remarks

Only items which derive from BaseToolbarItem can be added to the toolbar.

Members

Member Name | Description
TogglePositioning | Defines a toolbar button which toggles HTML elements between absolute and relative positioning: Associated type: ToolbarButton
BringForward | Defines a toolbar item which increases the z-index of an HTML element. Associated type: ToolbarButton
SendBackward | Defines a toolbar button which decreases the z-index of an HTML element. Associated type: ToolbarButton
InsertFlash | Defines a toolbar button which raises a dialog which inserts Macromedia Flash movies. Associated type: ToolbarUploadButton
InsertWindowsMedia | Defines a toolbar button which raises a dialog which inserts Windows Media Player compatible files. Associated type: ToolbarUploadButton
Zoom | Defines a toolbar button which zooms in or out of the editor content. Associated type: ToolbarMenuButton
PasteHtml | Defines a toolbar button which pastes the item on the clipboard while stripping HTML tags. Associated type: ToolbarButton
CleanWord | Defines a toolbar button which cleans extranous MS Word tags from the content in the editor. Associated type: ToolbarButton
WordCount | Defines a toolbar button which displays a count of words and characters when clicked. Associated type: ToolbarButton
UploadFile | Defines a toolbar button which raises a dialog that can be used to upload files (but nothing else). Associated type: ToolbarUploadButton
Justify | Defines a toolbar button which justifies text. Associated type: ToolbarButton
Bold | Defines a toolbar button which applies bold formatting. Associated type: ToolbarButton
CenterJustify | Defines a toolbar button which centers justify text. Associated type: ToolbarButton
Copy | Defines a toolbar button which copies selected text. Associated type: ToolbarButton
Cut | Defines a toolbar button which can cut selected text. Associated type: ToolbarButton
FindReplace | Defines a toolbar button which raises a find/replace dialog when clicked. Associated type: ToolbarDialogButton
FontName | Defines a toolbar dropdown which displays font names. Associated type: ToolbarDropDown
FontFormatting | Defines a toolbar dropdown which displays font formatting types. Associated type: ToolbarDropDown
FontSize | Defines a toolbar dropdown which displays font sizes. Associated type: ToolbarDropDown
FontStyle | Defines a toolbar dropdown which displays font styles. Associated type: ToolbarDropDown
Help | Defines a toolbar button which raises a help dialog when clicked. Associated type: ToolbarDialogButton
Indent | Defines a toolbar button which indents text. Associated type: ToolbarButton
SpecialCharacter | Defines a toolbar button which raises a "select special character" panel. Associated type: ToolbarDialogButton
InsertBookmark | Defines a toolbar button which raises an insert bookmark dialog when clicked. Associated type: ToolbarDialogButton
InsertImage | Defines a toolbar button which raises a dialog which inserts/uploads images. Associated type: ToolbarUploadButton
InsertLink | Defines a toolbar button which raises an insert link modal box. Associated type: ToolbarButton
InsertRule | Defines a toolbar button which raises a dialog which inserts horizontal rules. Associated type: ToolbarDialogButton
InsertTable | Defines a toolbar button which displays a menu of table specific options. Associated type: ToolbarMenuButton
Italic | Defines a toolbar button which applies italic formatting. Associated type: ToolbarButton
LeftJustify | Defines a toolbar button which left justifies text. Associated type: ToolbarButton
OrderedList | Defines a toolbar button which formats the selected text as an ordered list. Associated type: ToolbarButton
Outdent | Defines a toolbar button which outdents text. Associated type: ToolbarButton
Preview | Defines a toolbar button which displays a preview dialog. Associated type: ToolbarButton
Paste | Defines a toolbar button which pastes the item on the clipboard. Associated type: ToolbarButton
Print | Defines a toolbar button which sends the content of the HtmlBox to the printer. Associated type: ToolbarButton
Redo | Defines a toolbar button which redoes the last operation. Associated type: ToolbarButton
RemoveLink | Defines a toolbar button which removes a link. Associated type: ToolbarButton
RightJustify | Defines a toolbar button which right justifies text. Associated type: ToolbarButton
Save | Defines a toolbar button which raises a postback to the server. Associated type: ToolbarButton
Strikethrough | Defines a toolbar button which places a strikethrough through text. Associated type: ToolbarButton
Superscript | Defines a toolbar button which applies superscript formatting. Associated type: ToolbarButton
Subscript | Defines a toolbar button which applies subscript formatting. Associated type: ToolbarButton
Underline | Defines a toolbar button which applies underline formatting. Associated type: ToolbarButton
Undo | Defines a toolbar button which undoes an operation. Associated type: ToolbarButton
UnorderedList | Defines a toolbar button which formats the selected text as an unordered list. Associated type: ToolbarButton
Insert | Defines a toolbar dropdown which inserts text. Associated type: ToolbarDropDown
DoubleSeparator | Defines a toolbar image which represents a "double seperator" (typically used at the start of rows). Associated type: ToolbarImage
RowSeparator | Defines a toolbar item which inserts a graphical row seperator. Associated type: ToolbarImage
Separator | Defines a toolbar item which inserts a graphica seperator between buttons. Associated type: ToolbarImage
OpenFile | Defines a toolbar button which raises a dialog which can be use to open/upload files. Associated type: ToolbarUploadButton
InsertFile | Defines a toolbar button which raises a dialog which can be use to insert file text at the cursor location. Associated type: ToolbarUploadButton
FontColor | Defines a toolbar button which raises a color picker palette when clicked. Associated type: ToolbarDialogButton
FontHighlight | Defines a toolbar button which raises a color picker palette when clicked. Associated type :ToolbarDialogButton
ToggleBorders | Defines a toolbar button which toggles whether table borders are shown. Associated type: ToolbarButton
Break | Defines a toolbar item which makes a non-graphical row break. Associated type: ToolbarImage
Tab | Defines a toolbar item which inserts a tab between buttons. Associated type: ToolbarText
Space | Defines a toolbar item which inserts a space (placeholder) between buttons. Associated type: ToolbarText
CustomButton | Defines a custom toolbar button. Associated type: ToolbarButton
CustomDialogButton | Defines a custom toolbar dialog button. Assocated type: ToolbarDialogButton
CustomDropDown | Defines a custom toolbar dropdown. Associated type: ToolbarDropDown
CustomImage | Defines a custom toolbar image. Associated type: ToolbarImage
CustomMenuButton | Defines a custom toolbar menu button. Associated type: ToolbarMenuButton
CustomText | Defines custom toolbar text. Associated type: ToolbarText
NotSet | No Type is associated with this object (typically because object was created using the default (paramaterless) constructor. Set the Type property to provide default values.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ToolbarMenuButton Class

Represents a button that opens a menu.

For a list of all members of this type, see ToolbarMenuButton Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.BaseToolbarButton
Dart.PowerWEB.TextBox.ToolbarMenuButton

[Visual Basic]
Public Class ToolbarMenuButton
    Inherits BaseToolbarButton
[C#]
public class ToolbarMenuButton : BaseToolbarButton
[C++]
public __gc class ToolbarMenuButton : public BaseToolbarButton
[JScript]
public class ToolbarMenuButton extends BaseToolbarButton

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The ToolbarMenuButton control represents a button that opens a menu. For example, if the ToolbarMenuButton.Type is ToolbarMenuButtonType.InsertTable, the button will open a menu used to create and format a table.

The menu that appears when the ToolbarMenuButton is clicked is represented by an HtmlBoxMenu, exposed by the ToolbarMenuButton.Menu property.

A ToolbarMenuButton can be created and used one of two ways:

  • Calling HtmlBox.AddToolbarItem, passing in a ToolbarItemType associated with ToolbarMenuButton (such as ToolbarItemType.InsertTable) creates the ToolbarMenuButton, initializing it with default values for the "insert table" type, and adds it to the Toolbar in one step.
  • Create a new ToolbarMenuButton, passing in a ToolbarMenuButtonType (such as ToolbarMenuButtonType.InsertTable). This will create and initialize the ToolbarMenuButton with default values for the "insert table" type. Add the ToolbarMenuButton using the ToolbarItemCollection.Add method (HtmlBox.Toolbar.Items.Add).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarMenuButton Members | Dart.PowerWEB.TextBox Namespace


ToolbarMenuButton Members

ToolbarMenuButton overview

Public Instance Constructors

ToolbarMenuButton Overloaded. Initializes a new instance of the ToolbarMenuButton class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseToolbarButton) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType (inherited from BaseToolbarButton) | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight (inherited from BaseToolbarButton) | Gets or sets the height of the button image in pixels.
ImageName (inherited from BaseToolbarButton) | The name of the image displayed on the button.
ImageWidth (inherited from BaseToolbarButton) | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
Menu | Returns the HtmlBoxMenu associated with this ToolbarMenuButton.
MouseDownBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarMenuButtonType associated with this ToolbarMenuButton.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarMenuButton Constructor

Creates a custom ToolbarMenuButton

Overload List

Creates a custom ToolbarMenuButton

[Visual Basic] Public Sub New()
[C#] public ToolbarMenuButton();
[C++] public: ToolbarMenuButton();
[JScript] public function ToolbarMenuButton();

Creates a predefined ToolbarMenuButton

[Visual Basic] Public Sub New(ByVal ToolbarMenuButtonType)
[C#] public ToolbarMenuButton(ToolbarMenuButtonType);
[C++] public: ToolbarMenuButton(ToolbarMenuButtonType);
[JScript] public function ToolbarMenuButton(ToolbarMenuButtonType);

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarMenuButton Constructor ()

Creates a custom ToolbarMenuButton

[Visual Basic]
Public Sub New()
[C#]
public ToolbarMenuButton();
[C++]
public: ToolbarMenuButton();
[JScript]
public function ToolbarMenuButton();

Remarks

The default constructor creates and initializes a ToolBarMenuButton as a ToolbarMenuButtonType.Custom button.

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace | ToolbarMenuButton Constructor Overload List


ToolbarMenuButton Constructor (ToolbarMenuButtonType)

Creates a predefined ToolbarMenuButton

[Visual Basic]
Public Sub New( _
   ByVal type As ToolbarMenuButtonType _
)
[C#]
public ToolbarMenuButton(
   ToolbarMenuButtonType type
);
[C++]
public: ToolbarMenuButton(
   ToolbarMenuButtonType type
);
[JScript]
public function ToolbarMenuButton(
   ToolbarMenuButtonType type
);

Parameters

type
The ToolbarMenuButtonType which is used to supply the proper default properties for the ToolbarMenuButton.

Remarks

This constructor creates a ToolbarMenuButton of the specified type and supplies it with the default values for the specified type.

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace | ToolbarMenuButton Constructor Overload List


ToolbarMenuButton Properties

The properties of the ToolbarMenuButton class are listed below. For a complete list of ToolbarMenuButton class members, see the ToolbarMenuButton Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseToolbarButton) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType (inherited from BaseToolbarButton) | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight (inherited from BaseToolbarButton) | Gets or sets the height of the button image in pixels.
ImageName (inherited from BaseToolbarButton) | The name of the image displayed on the button.
ImageWidth (inherited from BaseToolbarButton) | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
Menu | Returns the HtmlBoxMenu associated with this ToolbarMenuButton.
MouseDownBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarMenuButtonType associated with this ToolbarMenuButton.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace


Controls Property

ToolbarMenuButton.Controls Property

Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.

[Visual Basic]
Overrides Public Property ReadOnly Controls As ControlCollection
[C#]
public override ControlCollection Controls { get; }
[C++]
public: __property ControlCollection* get_Controls();
[JScript]
public override function get Controls() : ControlCollection

Property Value

The collection of child controls for the specified server control.

Remarks

On an ASP.NET page, when controls are added declaratively between the opening and closing tags of a server control, ASP.NET automatically adds the controls to the containing server control's ControlCollection. Any HTML tags or text strings that are not processed on the server are treated as LiteralControl objects. These are added to the collection like other server controls.

The Controls property allows you programmatic access to the instance of the ControlCollection class for any server control. You can add controls to the collection, remove controls from the collection, or iterate through the server controls in the collection.

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace


Menu Property

ToolbarMenuButton.Menu Property

Returns the HtmlBoxMenu associated with this ToolbarMenuButton.

[Visual Basic]
Public Property ReadOnly Menu As HtmlBoxMenu
[C#]
public HtmlBoxMenu Menu { get; }
[C++]
public: __property HtmlBoxMenu* get_Menu();
[JScript]
public function get Menu() : HtmlBoxMenu

Property Value

The HtmlBoxMenu associated with the ToolbarMenuButton.

Remarks

This property returns the HtmlBoxMenu representing the menu that appears when the ToolbarMenuButton is clicked. For all predefined ToolbarMenuButtons (all ToolbarMenuButtonType values except for ToolbarMenuButtonType.Custom) this property will be properly initialized. For ToolbarMenuButtonType.Custom, create the menu by adding items to the HtmlBoxMenu.Items colletion of the HtmlBoxMenu control.

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace


Type Property

ToolbarMenuButton.Type Property

Gets or sets the ToolbarMenuButtonType associated with this ToolbarMenuButton.

[Visual Basic]
Public Property Type As ToolbarMenuButtonType
[C#]
public ToolbarMenuButtonType Type { get; set; }
[C++]
public: __property ToolbarMenuButtonType get_Type();
public: __property void set_Type(ToolbarMenuButtonType );
[JScript]
public function get Type() : ToolbarMenuButtonType
public function set Type(ToolbarMenuButtonType);

Property Value

A ToolbarMenuButtonType associated with this ToolbarMenuButton.

Remarks

Typically, this property gets it's value during initialization. However, this property can be set. If this occurs, the current values of the ToolbarMenuButton will be lost and replaced with the default settings associated with the new ToolbarMenuButtonType.

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarMenuButton Methods

The methods of the ToolbarMenuButton class are listed below. For a complete list of ToolbarMenuButton class members, see the ToolbarMenuButton Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace


Clone Method

ToolbarMenuButton.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As ToolbarMenuButton
[C#]
public ToolbarMenuButton Clone();
[C++]
public: ToolbarMenuButton* Clone();
[JScript]
public function Clone(): ToolbarMenuButton;

Return Value

An HtmlBox control.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

ToolbarMenuButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarMenuButtonType Enumeration

Enumerates the different types of ToolbarMenuButton controls.

[Visual Basic]
Public Enum ToolbarMenuButtonType
[C#]
public enum ToolbarMenuButtonType
[C++]
public __value enum ToolbarMenuButtonType
[JScript]
public enum ToolbarMenuButtonType

Remarks

The ToolbarMenuButtonType is used to supply default values to a ToolbarMenuButton. For example, when creating a new ToolbarMenuButton, simply pass a ToolbarMenuButtonType into the constructor to supply the object with preset values associated with that type.

This enumeration is a subset of the ToolbarItemType enumeration.

Members

Member Name | Description
InsertTable | Defines a toolbar button which displays a menu of table specific options. Associated type: ToolbarMenuButton
Zoom | Defines a toolbar button which zooms in or out of the editor content. Associated type: ToolbarMenuButton
Custom | Represents a custom menu button. The button will not do anything client side unless you provide some values for the properties of the object.
NotSet | No Type is associated with this object (typically because object was created using the default (paramaterless) constructor. Set the Type property to provide default values.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ToolbarText Class

Represents non-interactive text on the toolbar.

For a list of all members of this type, see ToolbarText Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.ToolbarText

[Visual Basic]
Public Class ToolbarText
    Inherits BaseToolbarItem
[C#]
public class ToolbarText : BaseToolbarItem
[C++]
public __gc class ToolbarText : public BaseToolbarItem
[JScript]
public class ToolbarText extends BaseToolbarItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Create a custom ToolbarText to insert your own text onto the toolbar or use a predefined ToolbarText type to apply formatting to your toolbar such as line breaks and tabs

A ToolbarText can be created and used one of two ways:

  • Calling HtmlBox.AddToolbarItem, passing in a ToolbarItemType associated with ToolbarText (such as ToolbarItemType.Tab) creates the ToolbarText, initializing it with default values for the "tab" type, and adds it to the Toolbar in one step.
  • Create a new ToolbarText, passing in a ToolbarTextType (such as ToolbarTextType.Seperator). This will create and initialize the ToolbarText with default values for the "tab" type. Add the ToolbarText using the ToolbarItemCollection.Add method (HtmlBox.Toolbar.Items.Add).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarText Members | Dart.PowerWEB.TextBox Namespace


ToolbarText Members

ToolbarText overview

Public Instance Constructors

ToolbarText Overloaded. Initializes a new instance of the ToolbarText class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarItem) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text that is displayed on the toolbar.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarTextType associated with this ToolbarText.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ToolbarText Class | Dart.PowerWEB.TextBox Namespace


ToolbarText Constructor

Creates a custom ToolbarText

Overload List

Creates a custom ToolbarText

[Visual Basic] Public Sub New()
[C#] public ToolbarText();
[C++] public: ToolbarText();
[JScript] public function ToolbarText();

Creates a predefined ToolbarText

[Visual Basic] Public Sub New(ByVal ToolbarTextType)
[C#] public ToolbarText(ToolbarTextType);
[C++] public: ToolbarText(ToolbarTextType);
[JScript] public function ToolbarText(ToolbarTextType);

See Also

ToolbarText Class | Dart.PowerWEB.TextBox Namespace


ToolbarText Constructor ()

Creates a custom ToolbarText

[Visual Basic]
Public Sub New()
[C#]
public ToolbarText();
[C++]
public: ToolbarText();
[JScript]
public function ToolbarText();

Remarks

The default constructor creates and initializes a ToolBarText as a ToolbarTextType.Custom text.

See Also

ToolbarText Class | Dart.PowerWEB.TextBox Namespace | ToolbarText Constructor Overload List


ToolbarText Constructor (ToolbarTextType)

Creates a predefined ToolbarText

[Visual Basic]
Public Sub New( _
   ByVal type As ToolbarTextType _
)
[C#]
public ToolbarText(
   ToolbarTextType type
);
[C++]
public: ToolbarText(
   ToolbarTextType type
);
[JScript]
public function ToolbarText(
   ToolbarTextType type
);

Parameters

type
The ToolbarTextType which is used to supply the proper default properties for the ToolbarText.

Remarks

This constructor creates a ToolbarText of the specified type and supplies it with the default values for the specified type.

See Also

ToolbarText Class | Dart.PowerWEB.TextBox Namespace | ToolbarText Constructor Overload List


ToolbarText Properties

The properties of the ToolbarText class are listed below. For a complete list of ToolbarText class members, see the ToolbarText Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseChildControl) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarItem) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseChildControl) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | Gets or sets the text that is displayed on the toolbar.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarTextType associated with this ToolbarText.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

ToolbarText Class | Dart.PowerWEB.TextBox Namespace


Text Property

ToolbarText.Text Property

Gets or sets the text that is displayed on the toolbar.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

A string containing the text that is displayed on the toolbar.

Remarks

For preset types, this property will come preset to a valid string. Set this property only if you wish to change from the presets or if you are creating a custom ToolbarText.

See Also

ToolbarText Class | Dart.PowerWEB.TextBox Namespace


Type Property

ToolbarText.Type Property

Gets or sets the ToolbarTextType associated with this ToolbarText.

[Visual Basic]
Public Property Type As ToolbarTextType
[C#]
public ToolbarTextType Type { get; set; }
[C++]
public: __property ToolbarTextType get_Type();
public: __property void set_Type(ToolbarTextType );
[JScript]
public function get Type() : ToolbarTextType
public function set Type(ToolbarTextType);

Property Value

A ToolbarTextType associated with this ToolbarText.

Remarks

Typically, this property gets it's value during initialization. However, this property can be set. If this occurs, the current values of the ToolbarText will be lost and replaced with the default settings associated with the new ToolbarTextType.

See Also

ToolbarText Class | Dart.PowerWEB.TextBox Namespace


ToolbarText Methods

The methods of the ToolbarText class are listed below. For a complete list of ToolbarText class members, see the ToolbarText Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

See Also

ToolbarText Class | Dart.PowerWEB.TextBox Namespace


Clone Method

ToolbarText.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As ToolbarText
[C#]
public ToolbarText Clone();
[C++]
public: ToolbarText* Clone();
[JScript]
public function Clone(): ToolbarText;

Return Value

An HtmlBox control.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

ToolbarText Class | Dart.PowerWEB.TextBox Namespace


ToolbarTextType Enumeration

Enumerates the different types of ToolbarText controls.

[Visual Basic]
Public Enum ToolbarTextType
[C#]
public enum ToolbarTextType
[C++]
public __value enum ToolbarTextType
[JScript]
public enum ToolbarTextType

Remarks

The ToolbarTextType is used to supply default values to a ToolbarText control. For example, when creating a new ToolbarText, simply pass a ToolbarTextType into the constructor to supply the object with preset values associated with that type.

This enumeration is a subset of the ToolbarItemType enumeration.

Members

Member Name | Description
Break | Defines a toolbar item which makes a non-graphical row break. Associated type: ToolbarImage
Tab | Defines a toolbar item which inserts a tab between buttons. Associated type: ToolbarText
Space | Defines a toolbar item which inserts a space (placeholder) between buttons. Associated type: ToolbarText
Custom | Represents custom text. You must set the Text property for the text to be shown .
NotSet | No Type is associated with this object (typically because object was created using the default (paramaterless) constructor. Set the Type property to provide default values.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


ToolbarUploadButton Class

Represents a button that raises an upload dialog.

For a list of all members of this type, see ToolbarUploadButton Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.BaseToolbarButton
Dart.PowerWEB.TextBox.ToolbarUploadButton

[Visual Basic]
Public Class ToolbarUploadButton
    Inherits BaseToolbarButton
[C#]
public class ToolbarUploadButton : BaseToolbarButton
[C++]
public __gc class ToolbarUploadButton : public BaseToolbarButton
[JScript]
public class ToolbarUploadButton extends BaseToolbarButton

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The ToolbarUploadButton control represents a button that raises an upload dialog ( a dialog that is used to upload files to the server and browse files on the server).

The upload dialog that appears when the ToolbarUploadButton is clicked is represented by an HtmlBoxUpload, exposed by the ToolbarUploadButton.Upload property.

A ToolbarUploadButton can be created and used one of two ways:

  • Calling HtmlBox.AddToolbarItem, passing in a ToolbarItemType associated with ToolbarUploadButton (such as ToolbarItemType.InsertImage) creates the ToolbarUploadButton, initializing it with default values for the "insert image" type, and adds it to the Toolbar in one step.
  • Create a new ToolbarUploadButton, passing in a ToolbarUploadButtonType (such as ToolbarUploadButtonType.InsertImage). This will create and initialize the ToolbarUploadButton with default values for the "insert image" type. Add the ToolbarUploadButton using the ToolbarItemCollection.Add method (HtmlBox.Toolbar.Items.Add).

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

ToolbarUploadButton Members | Dart.PowerWEB.TextBox Namespace


ToolbarUploadButton Members

ToolbarUploadButton overview

Public Instance Constructors

ToolbarUploadButton Overloaded. Initializes a new instance of the ToolbarUploadButton class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseToolbarButton) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType (inherited from BaseToolbarButton) | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight (inherited from BaseToolbarButton) | Gets or sets the height of the button image in pixels.
ImageName (inherited from BaseToolbarButton) | The name of the image displayed on the button.
ImageWidth (inherited from BaseToolbarButton) | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
MouseDownBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarUploadButtonType associated with this ToolbarUploadButton.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Upload | Returns the HtmlBoxUpload associated with this ToolbarUploadButton.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarUploadButton Constructor

Creates a custom ToolbarUploadButton

Overload List

Creates a custom ToolbarUploadButton

[Visual Basic] Public Sub New()
[C#] public ToolbarUploadButton();
[C++] public: ToolbarUploadButton();
[JScript] public function ToolbarUploadButton();

Creates a predefined ToolbarUploadButton

[Visual Basic] Public Sub New(ByVal ToolbarUploadButtonType)
[C#] public ToolbarUploadButton(ToolbarUploadButtonType);
[C++] public: ToolbarUploadButton(ToolbarUploadButtonType);
[JScript] public function ToolbarUploadButton(ToolbarUploadButtonType);

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarUploadButton Constructor ()

Creates a custom ToolbarUploadButton

[Visual Basic]
Public Sub New()
[C#]
public ToolbarUploadButton();
[C++]
public: ToolbarUploadButton();
[JScript]
public function ToolbarUploadButton();

Remarks

The default constructor creates and initializes a ToolBarUploadButton as a ToolbarUploadButtonType.Custom button.

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace | ToolbarUploadButton Constructor Overload List


ToolbarUploadButton Constructor (ToolbarUploadButtonType)

Creates a predefined ToolbarUploadButton

[Visual Basic]
Public Sub New( _
   ByVal type As ToolbarUploadButtonType _
)
[C#]
public ToolbarUploadButton(
   ToolbarUploadButtonType type
);
[C++]
public: ToolbarUploadButton(
   ToolbarUploadButtonType type
);
[JScript]
public function ToolbarUploadButton(
   ToolbarUploadButtonType type
);

Parameters

type
The ToolbarUploadButtonType which is used to supply the proper default properties for the ToolbarUploadButton.

Remarks

This constructor creates a ToolbarUploadButton of the specified type and supplies it with the default values for the specified type.

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace | ToolbarUploadButton Constructor Overload List


ToolbarUploadButton Properties

The properties of the ToolbarUploadButton class are listed below. For a complete list of ToolbarUploadButton class members, see the ToolbarUploadButton Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from BaseChildControl) | Gets or sets the background color of the control.
BindingContainer (inherited from Control) |
BorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the control.
BorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the control.
BorderWidth (inherited from BaseToolbarButton) | Gets or sets the border width of the control
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls | Overidden. Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from BaseChildControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Enabled (inherited from BaseChildControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
FileType (inherited from BaseToolbarButton) | Gets or sets the file extention to be used for all image-related properties of the button.
Font (inherited from BaseChildControl) | Gets the font properties associated with the control.
ForeColor (inherited from BaseChildControl) | Gets or sets the foreground color (typically the color of the text) of the control.
Height (inherited from BaseChildControl) | Gets or sets the height of the control.
ID (inherited from BaseToolbarItem) | Gets or sets the programmatic identifier assigned to the server control.
ImageHeight (inherited from BaseToolbarButton) | Gets or sets the height of the button image in pixels.
ImageName (inherited from BaseToolbarButton) | The name of the image displayed on the button.
ImageWidth (inherited from BaseToolbarButton) | Gets or sets the width of the button image in pixels.
ItemPrefix (inherited from BaseToolbarItem) | Gets or sets the prefix used to identify the item.
MouseDownBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the button is clicked by the mouse.
MouseDownBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the button is clicked by the mouse.
MouseDownBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the button is clicked by the mouse.
MouseDownCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the button is clicked by the mouse.
MouseDownImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the user clicks the button with the mouse.
MouseOverBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse is placed over the button.
MouseOverBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse is placed over the button.
MouseOverBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse is placed over the button.
MouseOverCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse is over the button.
MouseOverImageName (inherited from BaseToolbarButton) | Gets or sets the name of the image displayed when the mouse is over the button.
MouseUpBackColor (inherited from BaseToolbarButton) | Gets or sets the background color of the button when the mouse click is released over the button.
MouseUpBorderColor (inherited from BaseToolbarButton) | Gets or sets the border color of the button when the mouse click is released over the button.
MouseUpBorderStyle (inherited from BaseToolbarButton) | Gets or sets the border style of the button when the mouse click is released over the button.
MouseUpCursor (inherited from BaseToolbarButton) | Gets or sets the mouse cursor style when the mouse click is released over the button.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from BaseChildControl) | Gets or sets the tab index of the Web server control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from BaseChildControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Type | Gets or sets the ToolbarUploadButtonType associated with this ToolbarUploadButton.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
Upload | Returns the HtmlBoxUpload associated with this ToolbarUploadButton.
Visible (inherited from BaseChildControl) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.
Width (inherited from BaseChildControl) | Gets or sets the width of the control.

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace


Controls Property

ToolbarUploadButton.Controls Property

Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.

[Visual Basic]
Overrides Public Property ReadOnly Controls As ControlCollection
[C#]
public override ControlCollection Controls { get; }
[C++]
public: __property ControlCollection* get_Controls();
[JScript]
public override function get Controls() : ControlCollection

Property Value

The collection of child controls for the specified server control.

Remarks

On an ASP.NET page, when controls are added declaratively between the opening and closing tags of a server control, ASP.NET automatically adds the controls to the containing server control's ControlCollection. Any HTML tags or text strings that are not processed on the server are treated as LiteralControl objects. These are added to the collection like other server controls.

The Controls property allows you programmatic access to the instance of the ControlCollection class for any server control. You can add controls to the collection, remove controls from the collection, or iterate through the server controls in the collection.

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace


Type Property

ToolbarUploadButton.Type Property

Gets or sets the ToolbarUploadButtonType associated with this ToolbarUploadButton.

[Visual Basic]
Public Property Type As ToolbarUploadButtonType
[C#]
public ToolbarUploadButtonType Type { get; set; }
[C++]
public: __property ToolbarUploadButtonType get_Type();
public: __property void set_Type(ToolbarUploadButtonType );
[JScript]
public function get Type() : ToolbarUploadButtonType
public function set Type(ToolbarUploadButtonType);

Property Value

A ToolbarUploadButtonType associated with this ToolbarUploadButton.

Remarks

Typically, this property gets it's value during initialization. However, this property can be set. If this occurs, the current values of the ToolbarUploadButton will be lost and replaced with the default settings associated with the new ToolbarUploadButtonType.

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace


Upload Property

ToolbarUploadButton.Upload Property

Returns the HtmlBoxUpload associated with this ToolbarUploadButton.

[Visual Basic]
Public Property ReadOnly Upload As HtmlBoxUpload
[C#]
public HtmlBoxUpload Upload { get; }
[C++]
public: __property HtmlBoxUpload* get_Upload();
[JScript]
public function get Upload() : HtmlBoxUpload

Property Value

The HtmlBoxUpload associated with the ToolbarUploadButton.

Remarks

This property returns the HtmlBoxUpload representing the upload dialog that appears when the ToolbarUploadButton is clicked. For all predefined ToolbarUploadButtons (all ToolbarUploadButtonType values except for ToolbarUploadButtonType.Custom) this property will be properly initialized.

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarUploadButton Methods

The methods of the ToolbarUploadButton class are listed below. For a complete list of ToolbarUploadButton class members, see the ToolbarUploadButton Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
Clone | Returns a deep copy of the current object.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from BaseChildControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from BaseToolbarItem) | Overidden. Returns the value of the BaseToolbarItem.ItemPrefix property.

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace


Clone Method

ToolbarUploadButton.Clone Method

Returns a deep copy of the current object.

[Visual Basic]
Public Function Clone() As ToolbarUploadButton
[C#]
public ToolbarUploadButton Clone();
[C++]
public: ToolbarUploadButton* Clone();
[JScript]
public function Clone(): ToolbarUploadButton;

Return Value

An HtmlBox control.

Remarks

This method is indended for designer support only. It is not indended to be called within your code.

See Also

ToolbarUploadButton Class | Dart.PowerWEB.TextBox Namespace


ToolbarUploadButtonType Enumeration

Enumerates the different types of ToolbarUploadButton controls.

[Visual Basic]
Public Enum ToolbarUploadButtonType
[C#]
public enum ToolbarUploadButtonType
[C++]
public __value enum ToolbarUploadButtonType
[JScript]
public enum ToolbarUploadButtonType

Remarks

The ToolbarUploadButtonType is used to supply default values to a ToolbarUploadButton. For example, when creating a new ToolbarUploadButton, simply pass a ToolbarUploadButtonType into the constructor to supply the object with preset values associated with that type.

This enumeration is a subset of the ToolbarItemType enumeration.

Members

Member Name | Description
InsertWindowsMedia | Defines a toolbar button which raises a dialog which inserts Windows Media Player compatible files. Associated type: ToolbarUploadButton
InsertFlash | Defines a toolbar button which raises a dialog which inserts Macromedia Flash movies. Associated type: ToolbarUploadButton
InsertImage | Defines a toolbar button which raises a dialog which inserts/uploads images. Associated type: ToolbarUploadButton
OpenFile | Defines a toolbar button which raises a dialog which can be use to open/upload files. Associated type: ToolbarUploadButton
InsertFile | Defines a toolbar button which raises a dialog which can be use to insert file text at the cursor location. Associated type: ToolbarUploadButton
UploadFile | Defines a toolbar button which raises a dialog that can be used to upload files (but nothing else). Associated type: ToolbarUploadButton
NotSet | No Type is associated with this object (typically because object was created using the default (paramaterless) constructor. Set the Type property to provide default values.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


UploadMode Enumeration

Enumerates the different types of file uploads.

[Visual Basic]
Public Enum UploadMode
[C#]
public enum UploadMode
[C++]
public __value enum UploadMode
[JScript]
public enum UploadMode

Remarks

This enumeration effects the way HtmlBoxUpload controls are rendered.

Members

Member Name | Description
Image | The HtmlBoxUpload is configured to handle images.
File | The HtmlBoxUpload is configured to open text/html files (such as .htm, .html, .asp files).
InsertFile | The HtmlBoxUpload is configured to insert text/html files (such as .htm, .html, .asp files) at the current cursor location.
Flash | The HtmlBoxUpload is configured to handle Macromedia Flash files.
Upload | The HtmlBoxUpload is configured to be a generic file uploader.
WindowsMedia | The HtmlBoxUpload is configured to handle Windows Media Player compatible files.
None | The HtmlBoxUpload is not yet configured.

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


UrlType Enumeration

Enumerates the types of url conversions.

[Visual Basic]
Public Enum UrlType
[C#]
public enum UrlType
[C++]
public __value enum UrlType
[JScript]
public enum UrlType

Remarks

Some browsers modify the value of urls to improper values. This enumeration is used by the HtmlBox.UrlType property to specify how these urls should be converted to proper values.

Members

Member Name | Description
Absolute | Urls are represented as absolute urls (ex: "http://www.myserver.com/blah/file1.htm").
DocumentRelative | Urls are represented as document relative (ex: "../file1.htm").
RootRelative | Urls are represented as root relative (ex: "/blah/file1.htm").

Requirements

Namespace: Dart.PowerWEB.TextBox

Assembly: Dart.PowerWEB.TextBox (in Dart.PowerWEB.TextBox.dll)

See Also

Dart.PowerWEB.TextBox Namespace


Client-Side API Overview

Client-Side API Overview

The Client-Side API exposes many of the JavaScript functions used by the HtmlBox.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwCurHtmlBox Property

pwCurHtmlBox Property

Represents the current HtmlBox (the HtmlBox that currently has the focus).

[JavaScript]
pwCurHtmlBox

Remarks

All client-side API methods operate on the HtmlBox instance referenced by this property.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwCurPopup Property

pwCurPopup Property

Represents the current popup window, or null if no popup window is open.

[JavaScript]
pwCurPopup

Remarks

There can only be one popup per window at a time.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwChangeStyle Method

pwChangeStyle Method

Applies style information to an HTML element.

[JavaScript]
pwChangeStyle(pwObj, pwBackgroundColor, pwBorderColor, pwBorderStyle, pwCursor)

Parameters

pwObj
Required. The HTML element to apply the styles to.
pwBackgroundColor
The backgroundColor to apply to the HTML element.
pwBorderColor
The borderColor to apply to the HTML element.
pwBorderStyle
The borderStyle to apply to the HTML element.
pwCursor
The mouse cursor to display when the mouse is over the element.

Remarks

This method is used by PowerWEB TextBox for .NET for the button mouseover effects.

Example

[JavaScript] The following example demonstrates using the pwChangeStyle method to change the visual appearance of an HTML elements.

<DIV id='div1' style='border-color:#434343;border-style:solid'></DIV>DIV #1</DIV>
<script language="javascript">
pwChangeStyle(div1, 'red', 'blue', 'solid', 'default');
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwChangeView Method

pwChangeView Method

Toggles the Design/HTML mode for the specified HtmlBox.

[JavaScript]
pwChangeView(pwIframe, pwTextarea, pwDesignDiv, pwHTMLDiv, pwToolbar, pwShowHTML)

Parameters

pwIframe
Required. The IFRAME instance to toggle modes for.
pwTextarea
Required. The TEXTAREA instance for the current HtmlBox.
pwDesignDiv
Required. The "design tab" instance.
pwHTMLDiv
Required. The "HTML tab" instance.
pwToolbar
Required. The TOOLBAR instance for the current HtmlBox.
pwShowHtml
true if changing the mode to HTML. false if changing the mode to Design.

Remarks

This method is only intended to be called by internal members of PowerWEB Textbox for .NET. It is not recommended to call this method within your code.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwClearHtmlBox Method

pwClearHtmlBox Method

Clears the content of the current editor.

[JavaScript]
pwClearHtmlBox()

Remarks

This method clears all text from the current HtmlBox (the HtmlBox that has the focus).

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwCloseCurrentPopup Method

pwCloseCurrentPopup Method

Closes any open popups, if any.

[JavaScript]
pwCloseCurrentPopup()

Remarks

This method closes any popups opened by using pwLaunchPopup or pwLaunchPopupWindow. If no such popups are open, this method has no effect.

Example

[JavaScript] The following example demonstrates closing the current popup.

<input type='button' value='Close Popup' onclick='pwCloseCurrentPopup()'>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormat Method

pwFormat Method

Executes a command identifier on the current IFRAME.

[JavaScript]
pwFormat(pwCommand, pwModifier, pwRestoreRange)

Parameters

pwCommand
Required. The string command identifier to execute.
pwModifier
The modifier for the supplied command identifier. Required by some command identifiers.
pwRestoreRange
true if the last saved text range should be restored before the command is executed. false otherwise

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormat method to apply bold formatting.

<script language="javascript">
pwFormat('bold', '', false);
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatBold Method

pwFormatBold Method

Applies bold formatting on the selected text of the current HtmlBox.

[JavaScript]
pwFormatBold()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatBold method to apply bold formatting.

<script language="javascript">
<input type='button' value='Click here to make bold' onclick='pwFormatBold()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatCenterJustify Method

pwFormatCenterJustify Method

Center justifies the selected text of the current HtmlBox.

[JavaScript]
pwFormatCenterJustify()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatCenterJustify method to center text.

<script language="javascript">
<input type='button' value='Click here to center' onclick='pwFormatCenterJustify()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatCopy Method

pwFormatCopy Method

Copies the selected text of the current HtmlBox to the clipboard.

[JavaScript]
pwFormatCopy()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatCopy method to copy text.

<script language="javascript">
<input type='button' value='Click here to copy' onclick='pwFormatCopy()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatCut Method

pwFormatCut Method

Cuts the selected text of the current HtmlBox and saves it to the clipboard.

[JavaScript]
pwFormatCut()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatCut method to cut text.

<script language="javascript">
<input type='button' value='Click here to cut' onclick='pwFormatCut()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatFontColor Method

pwFormatFontColor Method

Changes the font color of the selected text to the supplied color.

[JavaScript]
pwFormatFontColor(pwColor)

Parameters

pwColor
Required. An string representing the color to change the font to.

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatFontColor method to change the font color.

<script language="javascript">
<input type='button' value='Click here to change the color to red' onclick='pwFormatFontColor("red")'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatFontHighlight Method

pwFormatFontHighlight Method

Changes the background of the selected text to the supplied color.

[JavaScript]
pwFormatFontHighlight(pwColor)

Parameters

pwColor
Required. An string representing the color to change the background to.

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatFontHighlight method to change the background color.

<script language="javascript">
<input type='button' value='Click here to change the background color to blue' onclick='pwFormatFontHighlight("blue")'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatIndent Method

pwFormatIndent Method

Indents selected text of the current HtmlBox.

[JavaScript]
pwFormatIndent()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatIndent method to indent text.

<script language="javascript">
<input type='button' value='Click here to indent' onclick='pwFormatIndent()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatInsertBookmark Method

pwFormatInsertBookmark Method

Inserts a bookmark (anchor tag) into the current HtmlBox.

[JavaScript]
pwFormatInsertBookmark(pwBookmarkName)

Parameters

pwBookmarkName
The name of the bookmark.

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatInsertBookmark method to insert an anchor tag.

<script language="javascript">
<input type='button' value='Click here to insert a bookmark' onclick='pwFormatBookmark("mybookmark")'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatInsertLink Method

pwFormatInsertLink Method

Brings up the insert link dialog to insert a link into the current HtmlBox.

[JavaScript]
pwFormatInsertLink()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatInsertLink method to create an insert link dialog.

<script language="javascript">
<input type='button' value='Insert Link' onclick='pwFormatInsertLink()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatInsertRule Method

pwFormatInsertRule Method

Inserts a horizontal rule into the current HtmlBox.

[JavaScript]
pwFormatInsertRule(pwAlign, pwWidth, pwColor, pwSize, pwNoShade)

Parameters

pwAlign
The alignment of the horizontal rule.
pwWidth
The width of the horizontal rule.
pwColor
The color of the horizontal rule.
pwSize
The size of the horizontal rule.
pwNoShade
true if the horizontal rule should be shaded, false otherwise.

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatInsertRule method to insert a horizontal rule.

<script language="javascript">
<input type='button' value='Click here to insert a rule' onclick='pwFormatInsertRule("center", "80%", "red", "3", true)'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatItalic Method

pwFormatItalic Method

Applies italic formatting on the selected text of the current HtmlBox.

[JavaScript]
pwFormatItalic()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatItalic method to apply italic formatting.

<script language="javascript">
<input type='button' value='Click here to make italic' onclick='pwFormatItalic()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatJustify Method

pwFormatJustify Method

Justifies the selected text of the current HtmlBox.

[JavaScript]
pwFormatJustify()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatJustify method to left-justify text.

<script language="javascript">
<input type='button' value='Click here to justify' onclick='pwFormatJustify()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatLeftJustify Method

pwFormatLeftJustify Method

Left justifies the selected text of the current HtmlBox.

[JavaScript]
pwFormatLeftJustify()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatLeftJustify method to left-justify text.

<script language="javascript">
<input type='button' value='Click here to left justify' onclick='pwFormatLeftJustify()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatOrderedList Method

pwFormatOrderedList Method

Formats the selected text of the current HtmlBox as an ordered list.

[JavaScript]
pwFormatOrderedList()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatOrderedList method to change the selected text into an ordered list.

<script language="javascript">
<input type='button' value='Click here to format as an ordered list' onclick='pwFormatOrderedList()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatOutdent Method

pwFormatOutdent Method

Outdents selected text of the current HtmlBox.

[JavaScript]
pwFormatOutdent()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatOutdent method to outdent text.

<script language="javascript">
<input type='button' value='Click here to indent' onclick='pwFormatOutdent()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatPaste Method

pwFormatPaste Method

Paste the contents of the clipboard onto the selected HtmlBox.

[JavaScript]
pwFormatPaste()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatPaste method to Paste text.

<script language="javascript">
<input type='button' value='Click here to paste' onclick='pwFormatPaste()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatPrint Method

pwFormatPrint Method

Brings up the print dialog to print the contents of the HtmlBox.

[JavaScript]
pwFormatPrint()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatPrint method to print text.

<script language="javascript">
<input type='button' value='Click here to print' onclick='pwFormatPrint()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatRedo Method

pwFormatRedo Method

Redoes the most recently undone operation.

[JavaScript]
pwFormatRedo()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatRedo method to redo an operation.

<script language="javascript">
<input type='button' value='Click here to redo' onclick='pwFormatRedo()'>
</script>

See Also

Client-Side API Overview | | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatRemoveLink Method

pwFormatRemoveLink Method

Removes any links found within the selected text of the current HtmlBox.

[JavaScript]
pwFormatRemoveLink()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatRemoveLink method to remove a link.

<script language="javascript">
<input type='button' value='Remove Link' onclick='pwFormatRemoveLink()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatRightJustify Method

pwFormatRightJustify Method

Right justifies the selected text of the current HtmlBox.

[JavaScript]
pwFormatRightJustify()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatRightJustify method to right-justify text.

<script language="javascript">
<input type='button' value='Click here to right justify' onclick='pwFormatRightJustify()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatStrikethrough Method

pwFormatStrikethrough Method

Places a strikethrough line through the selected text of the current HtmlBox.

[JavaScript]
pwFormatStrikethrough()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatStrikethrough method to place a strikethrough line through the selected text.

<script language="javascript">
<input type='button' value='strike out text' onclick='pwFormatStrikethrough()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatSubscript Method

Formats the selected text of the current HtmlBox as subscript characters.

[JavaScript]
pwFormatSubscript()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatSubscript method to change the selected text into subscript characters.

<script language="javascript">
<input type='button' value='Click here to format as subscript characters' onclick='pwFormatSubscript()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatSuperscript Method

Formats the selected text of the current HtmlBox as superscript characters.

[JavaScript]
pwFormatSuperscript()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatSuperscript method to change the selected text into subscript characters.

<script language="javascript">
<input type='button' value='Click here to format as superscript characters' onclick='pwFormatSuperscript()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatUnderline Method

pwFormatUnderline Method

Underlines the selected text of the current HtmlBox.

[JavaScript]
pwFormatUnderline()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatUnderline method to underline the selected text.

<script language="javascript">
<input type='button' value='Click here to underline' onclick='pwFormatUnderline()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatUndo Method

pwFormatUndo Method

Undoes the most recently performed operation.

[JavaScript]
pwFormatUndo()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatUndo method to undo an operation.

<script language="javascript">
<input type='button' value='Click here to undo' onclick='pwFormatUndo()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwFormatUnorderedList Method

pwFormatUnorderedList Method

Formats the selected text of the current HtmlBox as an unordered list.

[JavaScript]
pwFormatUnorderedList()

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus). See the MSDN DHTML execCommand method for more information on command indentifiers.

Example

[JavaScript] The following example demonstrates using the pwFormatUnorderedList method to change the selected text into an unordered list.

<script language="javascript">
<input type='button' value='Click here to format as an unordered list' onclick='pwFormatUnorderedList()'>
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwGetSelectedRadio Method

pwGetSelectedRadio Method

Returns the selected item of a radio button instance.

[JavaScript]
objRadioItem = pwGetSelectedRadio(pwRadio)

Parameters

pwRadio
The radio instance (input type='radio') to find the selected item of.

Return Value

The DHTML object representing the selected radio.

Remarks

This method returns null if no item of the radio instance is selected

Example

[JavaScript] The following example demonstrates displaying the selected item of a radio item.

<INPUT type=radio name="myradio" CHECKED>Option 1
<INPUT type=radio name="myradio">Option 2
<INPUT type=radio name="myradio">Option 3
<input type='button' value='Click here to insert a bookmark' onclick='alert(pwGetSelectedRadio(myRadio).value)'>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwInitHtmlBox Method

pwInitHtmlBox Method

Initializes an IFRAME instance for HTML editing.

[JavaScript]
pwInitEditor(pwIframe, pwTextarea, pwEdit, pwUseBR)

Parameters

pwIframe
Required. The IFRAME instance to initialize.
pwTextarea
Required. The TEXTAREA instance containing the initial text for the IFRAME.
edit
true if the IFRAME allows editing, false if the IFRAME is read-only.
useBR
true if <BR> tags are inserted when the enter key is pressed, false if <P> tags are inserted.

Remarks

This method is only intended to be called by internal members of PowerWEB Textbox for .NET. It is not recommended to call this method within your code.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwIsInTable Method

pwIsInTable Method

Checks if the cursor is within a table cell.

[JavaScript]
bInTable = pwIsInTable()

Return Value

true if the cursor is within a table cell, false otherwise.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwInsertText Method

pwInsertText Method

Inserts the supplied text into the current HtmlBox.

[JavaScript]
pwInsertText(pwText, pwDoStripTags, pwRestoreRange)

Parameters

pwText
Required. The text to insert into the HtmlBox.
pwDoStripTags
true if HTML tags should be stripped before inserting the text, false otherwise.
pwRestoreRange
true if the last saved text range should be restored before the command is executed. false otherwise

Remarks

This method operates on the current HtmlBox (the HtmlBox that currently has focus).

Example

[JavaScript] The following example demonstrates using the pwInsertText method to insert text into the current HtmlBox.

<script language="javascript">
pwInsertText("Hello world", false, false);
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwLaunchPopup Method

pwLaunchPopup Method

Launches a hidden HTML element as a popup.

[JavaScript]
pwLaunchPopup(pwElementId, pwX, pwY, pwBackgroundColor, pwBorderColor, pwBorderStyle, pwBorderWidth, pwFontFamily, pwFontSize, pwFontColor, pwHeight, pwWidth, pwArg)

Parameters

pwElementId
Required. The HTML element containing the data which makes up the dialog.
pwX
Required. The X screen coordinate to launch the dialog.
pwY
Required. The Y screen coordinate to launch the dialog.
pwBackgroundColor
The background color of the dialog.
pwBorderColor
The border color of the dialog.
pwBorderStyle
The border style of the dialog.
pwBorderWidth
The border width of the dialog.
pwFontFamily
The font face of the dialog.
pwFontSize
The font size of the dialog.
pwFontColor
The font color of the dialog.
pwHeight
The height of the dialog.
pwWidth
The width of the dialog.
pwArg
Optional argument which is saved as the global pwCurArg property.

Remarks

This method launches a dialog without a titlebar. Typical usage would include creating a hidden HTML element (such as a DIV or SPAN) which contains the dialog content and passing the ID of this element into the pwLaunchPopup method.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwLaunchPopupWindow Method

pwLaunchPopupWindow Method

Launches a hidden HTML element as a popup with a titlebar.

[JavaScript]
pwLaunchPopupWindow(pwElementId, pwX, pwY, pwBackgroundColor, pwBorderColor, pwBorderStyle, pwBorderWidth, pwFontFamily, pwFontSize, pwFontColor, pwCaption, pwTitlebarBackgroundColor, pwTitlebarFontFamily, pwTitlebarFontSize, pwTitlebarFontColor, pwTitlebarImage, pwTitlebarXImage, pwArg)

Parameters

pwElementId
Required. The HTML element containing the data which makes up the dialog.
pwX
Required. The X screen coordinate to launch the dialog.
pwY
Required. The Y screen coordinate to launch the dialog.
pwBackgroundColor
The background color of the dialog.
pwBorderColor
The border color of the dialog.
pwBorderStyle
The border style of the dialog.
pwBorderWidth
The border width of the dialog.
pwFontFamily
The font face of the dialog.
pwFontSize
The font size of the dialog.
pwFontColor
The font color of the dialog.
pwCaption
The titlebar caption.
pwTitlebarBackgroundColor
The background color of the titlebar.
pwTitlebarFontFamily
The font name for the titlebar.
pwTitlebarFontColor
The font color for the titlebar.
pwTitlebarImage
The image to display as the window icon.
pwTitlebarXImage
The image to display as the window "close X" icon.
pwArg
Optional argument which is saved as the global pwCurArg property.

Remarks

This method launches a dialog with titlebar. Typical usage would include creating a hidden HTML element (such as a DIV or SPAN) which contains the dialog content and passing the ID of this element into the pwLaunchPopupWindow method.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwNavigateLocation Method

pwNavigateLocation Method

Navigates to a new url.

[JavaScript]
pwNavigateLocation(pwUrl)

Parameters

pwUrl
Required. The url to navigate to.

Remarks

This method navigates to a new location by setting "window.location.href".

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwObj Method

pwObj Method

Shortcut method which gets an instance of an element from the element's ID.

[JavaScript]
objElement = pwObj(pwElementId)

Parameters

pwElementId
Required. The ID of the HTML element to get an object instance of.

Return Value

The object reference referring to the element with the specified ID, or null if no element is found.

Remarks

This method calls "document.getElementById" and provides a shortcut to this often used method.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwPreviewContent Method

pwPreviewContent Method

Launches the content of the editor in a new "preview" window.

[JavaScript]
pwPreviewContent()

Remarks

This method is useful for creating a preview of the content. The preview differs from the design view because it is a "live" page with clickable links.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwReplaceElementText Method

pwReplaceElementText Method

Replaces all occurrences of a specified token found within the HTML of an element with the contents of another element.

[JavaScript]
pwReplaceElementText(pwElementId1, pwElementId2, pwToken)

Parameters

pwElementId1
Required. The ID of the element which will be searched for occurrences of pwToken.
pwElementId2
Required. The ID of the element containing the HTML to replace pwToken with.
pwToken
Required. The token to replace.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwReplaceString Method

pwReplaceString Method

Replaces all occurrences of a string with the specified value.

[JavaScript]
sReplacedText = pwReplaceString(pwStr1, pwStr2, pwStr3)

Parameters

pwStr1
Required. The string to replace text within.
pwStr2
Required. The string to find
pwStr3
Required. The string to replace all occurrences of str2 with.

Return Value

This method returns pwStr1 with all occurrences of pwStr2 replaced with pwStr3.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwSetVisibility Method

pwSetVisibility Method

Sets/hides an HTML element.

[JavaScript]
pwSetVisibility(pwElement, pwVisible)

Parameters

pwElement
The HTML element to show/hide.
pwVisible
true to show the element, false to hide the element.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwStripTags Method

pwStripTags Method

Strips any HTML formatting from the supplied text.

[JavaScript]
sStrippedText = pwStripTags(pwHTML)

Parameters

pwHTML
Required. The HTML text to remove HTML formatting from.

Return Value

A string with all HTML formatting removed.

Remarks

This method removes all HTML formatting from the supplied pwHTML.

Example

[JavaScript] The following example demonstrates using the pwStripTags method to remove HTML formatting.

<script language="javascript">
var htmlText = "<b>My HTML text</b>"
alert("before: " + htmlText);
htmlText = pwStripTags(htmlText);
alert("after: " + htmlText);
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwSwapStyles Method

pwSwapStyles Method

Swaps style information for any two HTML elements.

[JavaScript]
pwSwapStylespwObj1, pwObj2)

Parameters

pwObj1
Required. The HTML element which will take on the style properties of pwObj2.
pwObj2
Required. The HTML element which will take on the style properties of pwObj1.

Remarks

This method "swaps" some visual style properties of two HTML elements. The style properties swapped are backgroundColor, borderColor, color, and borderStyle.

Example

[JavaScript] The following example demonstrates using the pwSwapStyles method to change the visual appearance of two HTML elements.

<DIV id='div1' style='border-color:#434343;border-style:solid'></DIV>DIV #1</DIV>
<DIV id="div2" style='border-color:#434343;border-style:solid'></DIV>DIV #2</DIV>
<script language="javascript">
pwSwapStyles(div1, div2);
</script>

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


pwToggleBorders Method

Toggles (shows/hides) table borders.

[JavaScript]
pwToggleBorders(pwTurnOn)

Parameters

pwTurnOn
true if the borders should be toggled on no matter what the current state.

Remarks

If calling this method with no parameters, the borders will be toggled. If calling this method with parameters, the border state will reflect the value of the parameter.

See Also

Client-Side API Overview | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Samples

Sample applications are provided to demonstrate usage of the PowerWEB TextBox for ASP.NET in both Visual Studio .NET and in Web Matrix. The Visual Studio .NET samples are available in both VB.NET and C#, while the Web Matrix samples are only available in C# at the present time. The samples are structured around a single Web application per environment that demonstrates usage from links off a central page. For example, the Visual Studio .NET C# samples are available from the PowerWEB TextBox C# Samples project.

Please note the documentation also includes a number of tutorials and code snippets for certain control members.

IMPORTANT: These samples are setup for the .NET Framework 1.1, rather than 1.0. This means that the samples have the following attribute set: ValidateRequest="false" If you wish to use these samples with the 1.0 version of the Framework, you will need to remove that attribute from the ASPX file. Below is an example ASPX header that will contain that attribute:

<%@ Page language="c#" Codebehind="LatestNews.aspx.cs" AutoEventWireup="false" Inherits="PowerWEB_TextBox_CSharp.LatestNews" ValidateRequest="false"%>

The following table shows the samples for this release and their default install locations.

Sample | Language | Location
Default Editor | VB.NET Web Application (ASP.NET) C# Web Application (ASP.NET) | C:\Program Files\PowerWEB\TextBox for ASP.NET\Samples\C# C:\Program Files\PowerWEB\TextBox for ASP.NET\Samples\VB.NET
Latest News | VB.NET Web Application (ASP.NET) C# Web Application (ASP.NET) | C:\Program Files\PowerWEB\TextBox for ASP.NET\Samples\C# C:\Program Files\PowerWEB\TextBox for ASP.NET\Samples\VB.NET
Configurator | VB.NET Web Application (ASP.NET) C# Web Application (ASP.NET) | C:\Program Files\PowerWEB\TextBox for ASP.NET\Samples\C# C:\Program Files\PowerWEB\TextBox for ASP.NET\Samples\VB.NET
Two Editors | VB.NET Web Application (ASP.NET) C# Web Application (ASP.NET) | C:\Program Files\PowerWEB\TextBox for ASP.NET\Samples\C# C:\Program Files\PowerWEB\TextBox for ASP.NET\Samples\VB.NET

Related Sections

Getting Started
Provides an overview of PowerWEB TextBox for ASP.NET and discusses such topics as distribution, licensing, and support.
Using PowerWEB in VS.NET
Provides step-by-step instructions for creating a project using VS.NET, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB in WebMatrix
Provides step-by-step instructions for creating a project using WebMatrix, integrating PowerWEB TextBox for ASP.NET, and creating a simple application.
Using PowerWEB with Notepad
Provides step-by-step instructions for creating a simple project using notepad only.
Configuring the HtmlBox
Discusses how to easily configure the HtmlBox, including style, layout, and toolbar configuration.
Advanced Customization
Discusses the many ways the HtmlBox control can be customized, from simple style changes to advanced interface element creation.
Optimizing Performance
Discusses techniques for optimizing performance of the HtmlBox control, including reducing ViewState and render-size.
Reference
Provides a language/syntax and client-side API reference for PowerWEB TextBox for ASP.NET.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Default Editor Sample

Description: A simple email Web client application that uses the HtmlBox control to construct an HTML email and send it to a recipient.

Notes: Uses the built-in SMTP classes from .NET. For creating a more advanced Web mail application please see the PowerTCP Mail for .NET product.

Virtual Directory: PowerWEB_TextBox_CSharp, PowerWEB_TextBox_VB

Requirements

Assemblies: Dart.PowerWEB.TextBox

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Latest News Sample

Description: Loads text files and displays them as news items. Allows user to add new items using the HtmlBox control.

Notes: Requires ASPNET to have write permission for the sample directory as data is saved as text files.

Virtual Directory: PowerWEB_TextBox_CSharp, PowerWEB_TextBox_VB

Requirements

Assemblies: Dart.PowerWEB.TextBox

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Configurator Sample

Description: Demonstrates some of the configuration flexibility of the HtmlBox control.

Notes: None.

Virtual Directory: PowerWEB_TextBox_CSharp, PowerWEB_TextBox_VB

Requirements

Assemblies: Dart.PowerWEB.TextBox

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Two Editors Sample

Description:: Demonstrates how to have two separate HtmlBox controls on the same Web Form.

Notes: None.

Virtual Directory: PowerWEB_TextBox_CSharp, PowerWEB_TextBox_VB

Requirements

Assemblies: Dart.PowerWEB.TextBox

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


BaseChildControl Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.DownlevelLabel
Dart.PowerWEB.TextBox.DownlevelTextArea
Dart.PowerWEB.TextBox.HtmlBoxDialog
Dart.PowerWEB.TextBox.HtmlBoxMenu
Dart.PowerWEB.TextBox.HtmlBoxMenuItem
Dart.PowerWEB.TextBox.HtmlBoxProgressBar
Dart.PowerWEB.TextBox.HtmlBoxTabStrip
Dart.PowerWEB.TextBox.HtmlBoxTextWindow
Dart.PowerWEB.TextBox.HtmlBoxUpload
Dart.PowerWEB.TextBox.Toolbar
Dart.PowerWEB.TextBox.ToolbarDropDownItem

See Also

BaseChildControl Class | BaseChildControl Members | Dart.PowerWEB.TextBox Namespace


Dart.PowerWEB.TextBoxHierarchy

Dart.PowerWEB.TextBox Hierarchy

System.Object
Dart.PowerWEB.TextBox.AttDef
Dart.PowerWEB.TextBox.AttList ---- System.Collections.IEnumerable
Dart.PowerWEB.TextBox.ContentModel
Dart.PowerWEB.TextBox.ElementDecl
Dart.PowerWEB.TextBox.Entity
Dart.PowerWEB.TextBox.Group
Dart.PowerWEB.TextBox.ResourceHttpHandler ---- System.Web.IHttpHandler
Dart.PowerWEB.TextBox.SgmlDtd
System.Collections.ArrayList ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ICloneable
Dart.PowerWEB.TextBox.HtmlBoxMenuItemCollection
Dart.PowerWEB.TextBox.StringArrayList
Dart.PowerWEB.TextBox.ToolbarDropDownItemCollection
Dart.PowerWEB.TextBox.ToolbarItemCollection
System.Collections.Specialized.NameObjectCollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
System.Collections.Specialized.NameValueCollection
Dart.PowerWEB.TextBox.StringValueCollection
System.ComponentModel.TypeConverter
Dart.PowerWEB.TextBox.StringArrayListConverter
Dart.PowerWEB.TextBox.StringValueCollectionConverter
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Dart.PowerWEB.TextBox.AutoSaveEventHandler
Dart.PowerWEB.TextBox.FileUploadEventHandler
Dart.PowerWEB.TextBox.ToolbarButtonClickEventHandler
System.EventArgs
Dart.PowerWEB.TextBox.FileUploadEventArgs
Dart.PowerWEB.TextBox.ToolbarButtonEventArgs
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Web.UI.WebControls.Style ---- System.Web.UI.IStateManager
Dart.PowerWEB.TextBox.BaseStyle
Dart.PowerWEB.TextBox.ButtonStyle
Dart.PowerWEB.TextBox.DialogStyle
Dart.PowerWEB.TextBox.HighlightStyle
Dart.PowerWEB.TextBox.MenuStyle
System.IO.TextReader ---- System.IDisposable
System.IO.StringReader
Dart.PowerWEB.TextBox.HtmlReader
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Dart.PowerWEB.TextBox.AttributePresence
Dart.PowerWEB.TextBox.AttributeType
Dart.PowerWEB.TextBox.ButtonMode
Dart.PowerWEB.TextBox.CaseFolding
Dart.PowerWEB.TextBox.ClickBehavior
Dart.PowerWEB.TextBox.ColorPaletteType
Dart.PowerWEB.TextBox.CursorType
Dart.PowerWEB.TextBox.DeclaredContent
Dart.PowerWEB.TextBox.DialogType
Dart.PowerWEB.TextBox.DownlevelMode
Dart.PowerWEB.TextBox.GroupType
Dart.PowerWEB.TextBox.InternalDialogType
Dart.PowerWEB.TextBox.LayoutType
Dart.PowerWEB.TextBox.LiteralType
Dart.PowerWEB.TextBox.LocalizationType
Dart.PowerWEB.TextBox.Occurrence
Dart.PowerWEB.TextBox.RightClickBehavior
Dart.PowerWEB.TextBox.StartupMode
Dart.PowerWEB.TextBox.ToolbarButtonType
Dart.PowerWEB.TextBox.ToolbarDialogButtonType
Dart.PowerWEB.TextBox.ToolbarDropDownType
Dart.PowerWEB.TextBox.ToolbarImageType
Dart.PowerWEB.TextBox.ToolbarItemType
Dart.PowerWEB.TextBox.ToolbarMenuButtonType
Dart.PowerWEB.TextBox.ToolbarTextType
Dart.PowerWEB.TextBox.ToolbarUploadButtonType
Dart.PowerWEB.TextBox.UploadMode
Dart.PowerWEB.TextBox.UrlType
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IParserAccessor
System.Web.UI.WebControls.WebControl ---- System.Web.UI.IAttributeAccessor
Dart.PowerWEB.TextBox.BaseChildControl
Dart.PowerWEB.TextBox.BaseToolbarItem
Dart.PowerWEB.TextBox.BaseToolbarButton
Dart.PowerWEB.TextBox.ToolbarButton
Dart.PowerWEB.TextBox.ToolbarDialogButton
Dart.PowerWEB.TextBox.ToolbarMenuButton
Dart.PowerWEB.TextBox.ToolbarUploadButton
Dart.PowerWEB.TextBox.ToolbarDropDown
Dart.PowerWEB.TextBox.ToolbarImage
Dart.PowerWEB.TextBox.ToolbarText
Dart.PowerWEB.TextBox.DownlevelLabel
Dart.PowerWEB.TextBox.DownlevelTextArea ---- System.Web.UI.IPostBackDataHandler
Dart.PowerWEB.TextBox.HtmlBoxDialog
Dart.PowerWEB.TextBox.HtmlBoxMenu
Dart.PowerWEB.TextBox.HtmlBoxMenuItem
Dart.PowerWEB.TextBox.HtmlBoxProgressBar
Dart.PowerWEB.TextBox.HtmlBoxTabStrip
Dart.PowerWEB.TextBox.HtmlBoxTextWindow
Dart.PowerWEB.TextBox.HtmlBoxUpload
Dart.PowerWEB.TextBox.Toolbar
Dart.PowerWEB.TextBox.ToolbarDropDownItem
System.Web.UI.WebControls.Label
Dart.PowerWEB.LiveControls.LiveLabel ---- Dart.PowerWEB.LiveControls.ILiveCallbackHandler, Dart.PowerWEB.LiveControls.ILiveControl, Dart.PowerWEB.LiveControls.ILiveWebControl, System.Web.UI.IPostBackEventHandler
Dart.PowerWEB.TextBox.HtmlBox ---- System.Web.UI.INamingContainer, System.Web.UI.IPostBackDataHandler
System.Xml.XmlReader
Dart.PowerWEB.TextBox.SgmlReader

See Also

Dart.PowerWEB.TextBox Namespace


Toolbar Item Descriptions: Bold Button

Name: Bold button
Description: Applies bold formatting to selected non-bold text. Removes bold formatting from selected bold text.
Associated type: ToolbarButton
Item prefix: "bold"
Default image name: "bold.gif"
Default mouse-over image name: "bold_over.gif"
Default mouse-down image name: "bold_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Bold".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Bold);

// OPTION 2. Create and add a bold button.
ToolbarButton b = new ToolbarButton(Bold);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Bold)

' OPTION 2. Create and add a bold button.
Dim b As New ToolbarButton(Bold)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Bold button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Bold button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Bold" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(Bold);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(Bold)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Center Justify Button

Name: Center Justify button
Description: Justifies the selected text to the center.
Associated type: ToolbarButton
Item prefix: "centerjustify"
Default image name: "centerjustify.gif"
Default mouse-over image name: "centerjustify_over.gif"
Default mouse-down image name: "centerjustify_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Center Justify".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(CenterJustify);

// OPTION 2. Create and add a centerjustify button.
ToolbarButton b = new ToolbarButton(CenterJustify);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(CenterJustify)

' OPTION 2. Create and add a centerjustify button.
Dim b As New ToolbarButton(CenterJustify)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Center Justify button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Center Justify button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Center Justify" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(CenterJustify);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(CenterJustify)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Copy Button

Name: Copy button
Description: Copies (saves to clipboard) selected text or object on the clipboard.
Associated type: ToolbarButton
Item prefix: "copy"
Default image name: "copy.gif"
Default mouse-over image name: "copy_over.gif"
Default mouse-down image name: "copy_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Copy".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Copy);

// OPTION 2. Create and add a copy button.
ToolbarButton b = new ToolbarButton(Copy);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Copy)

' OPTION 2. Create and add a copy button.
Dim b As New ToolbarButton(Copy)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Copy button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Copy button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Copy" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(Copy);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(Copy)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Cut Button

Name: Cut button
Description: Cuts (removes and saves to clipboard) selected text or object from the editor window.
Associated type: ToolbarButton
Item prefix: "cut"
Default image name: "cut.gif"
Default mouse-over image name: "cut_over.gif"
Default mouse-down image name: "cut_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Cut".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Cut);

// OPTION 2. Create and add a cut button.
ToolbarButton b = new ToolbarButton(Cut);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Cut)

' OPTION 2. Create and add a cut button.
Dim b As New ToolbarButton(Cut)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Cut button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Cut button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Cut" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(Cut);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(Cut)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Italic Button

Name: Italic button
Description: Applies italic formatting to selected non-italic text. Removes italic formatting from selected italic text.
Associated type: ToolbarButton
Item prefix: "italic"
Default image name: "italic.gif"
Default mouse-over image name: "italic_over.gif"
Default mouse-down image name: "italic_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Italic".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Italic);

// OPTION 2. Create and add an italic button.
ToolbarButton b = new ToolbarButton(Italic);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Italic)

' OPTION 2. Create and add an italic button.
Dim b As New ToolbarButton(Italic)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Italic button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Italic button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Italic" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(Italic);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(Italic)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Left Justify Button

Name: Left Justify button
Description: Justifies the selected text to the left.
Associated type: ToolbarButton
Item prefix: "leftjustify"
Default image name: "leftjustify.gif"
Default mouse-over image name: "leftjustify_over.gif"
Default mouse-down image name: "leftjustify_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Left Justify".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(LeftJustify);

// OPTION 2. Create and add a leftjustify button.
ToolbarButton b = new ToolbarButton(LeftJustify);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(LeftJustify)

' OPTION 2. Create and add a leftjustify button.
Dim b As New ToolbarButton(LeftJustify)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Left Justify button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Left Justify button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Left Justify" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(LeftJustify);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(LeftJustify)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Ordered List Button

Name: Ordered List button
Description: Creates an ordered (numbered) list.
Associated type: ToolbarButton
Item prefix: "orderedlist"
Default image name: "orderedlist.gif"
Default mouse-over image name: "orderedlist_over.gif"
Default mouse-down image name: "orderedlist_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "OrderedList".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(OrderedList);

// OPTION 2. Create and add a orderedlist button.
ToolbarButton b = new ToolbarButton(OrderedList);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(OrderedList)

' OPTION 2. Create and add a orderedlist button.
Dim b As New ToolbarButton(OrderedList)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Ordered List button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Ordered List button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "OrderedList" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(OrderedList);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(OrderedList)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Paste Button

Name: Paste button
Description: Pastes (inserts from clipboard) text into the editor window.
Associated type: ToolbarButton
Item prefix: "paste"
Default image name: "paste.gif"
Default mouse-over image name: "paste_over.gif"
Default mouse-down image name: "paste_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Paste".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Paste);

// OPTION 2. Create and add a paste button.
ToolbarButton b = new ToolbarButton(Paste);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Paste)

' OPTION 2. Create and add a paste button.
Dim b As New ToolbarButton(Paste)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Paste button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Paste button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Paste" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(Paste);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(Paste)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Redo Button

Name: Redo button
Description: Redoes the most recently undone formatting operation.
Associated type: ToolbarButton
Item prefix: "redo"
Default image name: "redo.gif"
Default mouse-over image name: "redo_over.gif"
Default mouse-down image name: "redo_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Redo".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Redo);

// OPTION 2. Create and add a redo button.
ToolbarButton b = new ToolbarButton(Redo);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Redo)

' OPTION 2. Create and add a redo button.
Dim b As New ToolbarButton(Redo)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Redo button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Redo button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Redo" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(Redo);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(Redo)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Right Justify Button

Name: Right Justify button
Description: Justifies the selected text to the right.
Associated type: ToolbarButton
Item prefix: "rightjustify"
Default image name: "rightjustify.gif"
Default mouse-over image name: "rightjustify_over.gif"
Default mouse-down image name: "rightjustify_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Right Justify".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(RightJustify);

// OPTION 2. Create and add a rightjustify button.
ToolbarButton b = new ToolbarButton(RightJustify);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(RightJustify)

' OPTION 2. Create and add a rightjustify button.
Dim b As New ToolbarButton(RightJustify)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Right Justify button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Right Justify button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Right Justify" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(RightJustify);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(RightJustify)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Underline Button

Name: Underline button
Description: Applies underline formatting to selected non-underline text. Removes underline formatting from selected underline text.
Associated type: ToolbarButton
Item prefix: "underline"
Default image name: "underline.gif"
Default mouse-over image name: "underline_over.gif"
Default mouse-down image name: "underline_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Underline".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Underline);

// OPTION 2. Create and add a underline button.
ToolbarButton b = new ToolbarButton(Underline);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Underline)

' OPTION 2. Create and add a underline button.
Dim b As New ToolbarButton(Underline)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Underline button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Underline button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Underline" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(Underline);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(Underline)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Undo Button

Name: Undo button
Description: Undoes the last formatting action.
Associated type: ToolbarButton
Item prefix: "undo"
Default image name: "undo.gif"
Default mouse-over image name: "undo_over.gif"
Default mouse-down image name: "undo_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "Undo".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Undo);

// OPTION 2. Create and add a undo button.
ToolbarButton b = new ToolbarButton(Undo);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(Undo)

' OPTION 2. Create and add a undo button.
Dim b As New ToolbarButton(Undo)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Undo button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Undo button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "Undo" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(Undo);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(Undo)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Toolbar Item Descriptions: Unordered List Button

Name: Unordered List button
Description: Creates an unordered (bulleted) list.
Associated type: ToolbarButton
Item prefix: "unorderedlist"
Default image name: "unorderedlist.gif"
Default mouse-over image name: "unorderedlist_over.gif"
Default mouse-down image name: "unorderedlist_down.gif"
Included in default toolbar config: yes

Adding a new instance:

NOTE. This button is included in the default toolbar config, and, as a result, this button does not typically need to be added to the toolbar. However, steps are included here for demonstration purposes.

Adding a new instance using the Property Builder.

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose "Add".
  4. Choose the "Add Button" option.
  5. Choose "UnorderedList".

Adding a new instance using code.

[C#]
// OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(UnorderedList);

// OPTION 2. Create and add a unorderedlist button.
ToolbarButton b = new ToolbarButton(UnorderedList);
HtmlBox1.Toolbar.Items.Add(b);

[VB.NET]
' OPTION 1. Use AddToolbarItem for the quickest way to add a button using code.
HtmlBox1.AddToolbarItem(UnorderedList)

' OPTION 2. Create and add a unorderedlist button.
Dim b As New ToolbarButton(UnorderedList)
HtmlBox1.Toolbar.Items.Add(b)

Modifying style/configuration:

Modifying style/config using the Property Builder (global styles).

To modify ALL buttons at once using the Property Builder (including the Unordered List button) use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Format" tab.
  3. Choose the particular button-state you would like to modify (for example, if you want to change the background color of the button when it is clicked, choose "Mouse Over").
  4. Use the form elements provided to modify the styles.

To modify ONLY the style of the Unordered List button using the Property Builder, use the following steps:

  1. Open the Property Builder using the steps provided in the topic Using The Property Builder.
  2. Choose the "Toolbar" tab.
  3. Choose the "UnorderedList" button in the toolbar layout list.
  4. Use Properties Window on the right to modify the style.

Modifying style/config using code.

[C#]
// OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
// (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red;
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted;

// OPTION 2. Use code to apply a style to a single button.
// (this is done by accessing the object representing the button,
// then changing the propeties of that object).
ToolbarButton b = (ToolbarButton)HtmlBox1.Toolbar.Items.GetByType(UnorderedList);
b.BackColor = Color.Red;
b.MouseOverBorderStyle = BorderStyle.Dotted;

[VB.NET]
' OPTION 1. Use code to apply a style to ALL buttons on the toolbar.
' (this is done by using the high-level ButtonStyle object)
HtmlBox1.ButtonStyle.BackColor = Color.Red
HtmlBox1.ButtonStyle.MouseOverBorderStyle = BorderStyle.Dotted

' OPTION 2. Use code to apply a style to a single button.
' (this is done by accessing the object representing the button,
' then changing the propeties of that object).
Dim b as ToolbarButton = HtmlBox1.Toolbar.Items.GetByType(UnorderedList)
b.BackColor = Color.Red
b.MouseOverBorderStyle = BorderStyle.Dotted

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.


Integrating Spell Checking

This topic discusses integrating PowerWEB TextBox for ASP.NET with a 3rd party spell-checker (in this case, RapidSpell Web .NET by Keyoti.

To integrate PowerWEB TextBox for ASP.NET with RapidSpell Web .NET, use the following steps.

  1. Download RapidSpell Web .NET (http://www.keyoti.com/products/rapidspell/dotNetWeb/.
  2. Create a new web project in Visual Studio .NET.
  3. Add the HtmlBox dll to the Toolbox.
  4. Add the "Keyoti.RapidSpellWeb.dll" to the Toolbox.
  5. Drag the HtmlBox Control onto the form.
  6. Drag the RapidSpellWebLauncher Control onto the form. Be sure the ID is "RapidSpellWebLauncher1".
  7. Set the TextComponentInterface property of the RapidSpellWebLauncher control to PowerWEBTextBox. Set TextComponentName to HtmlBox1.
  8. Set the IgnoreXML property of the RapidSpellWebLauncher control to True.
  9. Create a new form called "checker.aspx", and drag the RapidSpellWeb Control onto it.
  10. Return to your first form. Set RapidSpellWebLauncher1.RapidSpellWebPage = "checker.aspx".
  11. In the Page load event of the first form, add the following code.
    [C#]
// Be sure to add "using Dart.PowerWEB.TextBox" to the top of your code-behind class.
ToolbarButton b = new ToolbarButton(ToolbarButtonType.Custom);
b.ImageName = "spellcheck.gif";
b.ToolTip = "Check spelling";
b.OnClickFunctionName = "popUpCheckSpellingRapidSpellWebLauncher1('rsTCIntRapidSpellWebLauncher1')";
HtmlBox1.Toolbar.Items.Add(b);
[Visual Basic]
' Be sure to add "Imports Dart.PowerWEB.TextBox" to the top of your code-behind class.
Dim b As New ToolbarButton(ToolbarButtonType.Custom)
b.ImageName = "spellcheck.gif"
b.ToolTip = "Check spelling"
b.OnClickFunctionName = "popUpCheckSpellingRapidSpellWebLauncher1(""rsTCIntRapidSpellWebLauncher1"")"
HtmlBox1.Toolbar.Items.Add(b)
  12. Finally, to remove the "Check Spelling" button rendered by the RapidSpell, go to HTML view and add to/modify the RapidSpell server tags so they have the ButtonStyle information like so:
    <RapidSpellWeb:RapidSpellWebLauncher id="RapidSpellWebLauncher1" runat="server" ....>
     <Button Style="visibility:hidden;width:0px;" ID="Button1"/>
</RapidSpellWeb:RapidSpellWebLauncher>
  13. Compile and run the application. Type some text. Click the spellcheck button on the toolbar to check the spelling.
  14. Special note about using a User Control. Note, if you are using the HtmlBox on a User Control and would like to integrate spell-checking, you may have to use the hierarchical name instead of the ID. For instance instead of using b.OnClickFunctionName = "popUpCheckSpellingRapidSpellWebLauncher1(""rsTCIntRapidSpellWebLauncher1"")" you may have to use something like b.OnClickFunctionName = "popUpCheckSpelling_ctl0_RapidSpellWebLauncher1('rsTCInt_ctl0_RapidSpellWebLauncher1')" where "ct10" is the dynamic name for the user control. This name will be implementation specific and can best be determined by viewing the source of the page.

See Also

Reference | Configuring the HtmlBox | Advanced Customization of the HtmlBox | Server-side reference

Send comments on this topic.

© 2004 Dart Communications. All rights reserved.