Welcome! - PowerSNMP for .NET CF

PowerSNMP for .NET CF
Welcome!
Send comments on this topic.

PowerSNMP for .NET CF has been designed for SNMP novices and experts alike, providing powerful but easy-to-use components and classes that can be plugged into any Compact Framework 2.0+ application.

Overview

This latest version of the venerable PowerSNMP product line gets a new .NET 2.0 re-design that leverages the power of the latest .NET environments to provide the most advanced Internet Communications components available. Some of the features include:

  • SNMP version 1, 2 and 3 with authentication, encryption/decryption
  • Built-in objects, identifiers, traps, tables, notifications, and groups as defined in RFCs 1155, 1157, 1158, 1213, 2578, 2579, 3417 and 3418
  • MIB parsing, where any custom MIB file can be used to load MIB definitions
  • Start method for easily implemented multi-threaded applications, including cross-threading marshaling support
  • EncodedMessage property for easy debugging of bytes sent and received, as well as session logging

Background

The Visual Basic environment introduced the use of components (VBX and OCX), but typically only executed on the UI thread. Though multi-threaded support was added at the Operating System level, developers needed C++ to create multi-threaded applications.

When 32-bit application support was added to Visual Basic, PowerSNMP was able to use background worker threads to execute communication tasks, and not interfere with the UI. Events, however, could only be raised on the UI thread.

.NET Version 1

The use of worker threads, delegates and events was greatly improved under .NET 1.0:

  • Background threads could be conveniently started
  • Events could be raised on worker threads

In fact, the multi-threaded environment became so powerful that users needed to become aware of concepts like thread safety and synchronization, which were never concerns before.

PowerSNMP evolved as well, providing an interface that included blocking methods (which block the executing thread until completion), pseudo-blocking methods (which block the UI thread until completion, but process events while doing so), and asynchronous methods (which execute on background threads). The goal was to provide an interface that was as complete as possible, without making it complex or difficult to use.

.NET Version 2

The .NET environment has evolved, and so has its users. Customers are developing more applications for ASP.NET, more console applications, and more service applications. Lacking UIs, pseudo-blocking and asynchronous methods are not relevant for these environments. There are also trends towards greater levels of customer control. For these reasons, PowerSNMP for .NET CF was designed with the following emphases:

  • Improved Asynchronous Support
    Traditional PowerSNMP asynchronous support provided a means for executing methods on worker threads, but this required a signaling mechanism indicating when operations completed. This resulted in difficult-to-maintain, event-driven code. With the new design, code is more self-documenting, uses fewer resources, and is more flexible to use. Please see Asynchronous Operation for a more detailed examination of the benefits of this new design.

  • Improved Use of .NET 2.0 Features
    PowerSNMP 4.x has taken advantage of generics and other features introduced in .NET 2.0. Now that most users have migrated from .NET 1.x, PowerSNMP can be upgraded without sacrificing backward compatibility. Of course, the .NET 1.x product line will still be licensed for use in the .NET 1.x environment to support legacy applications.

  • Support for .NET CF (Compact Framework)
    Comprehensive support of the Compact Framework has been extended with the new design.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Component
Manager Component

Documentation Version 4.2
© 2010 Dart Communications. All Rights Reserved.


Getting Started - PowerSNMP for .NET CF

Getting Started
Send comments on this topic.

In addition to perusing this documentation, it is highly recommended that the user examine the sample applications available on the website.

For the most basic quick-start, create a new Windows Application project in Visual Studio, drag a Manager or Agent component and a button onto the form, and add code to your Click event handler.

The scope of this documentation and product samples illustrates some common SNMP usage scenarios, but SNMP communications can be more complex. This product can be used to implement the most complex of SNMP communications, but such scenario descriptions may fall beyond the scope of this documentation. For learning advanced usage we recommend SNMP, SNMPv2, SNMPv3, and RMON 1 and 2, Third Edition, by William Stallings and published by Addison-Wesley.

Sample Applications

All samples include C# and VB.NET versions.

Sample | Description
Agent | Demonstrates responding to v1, v2 and v3 SNMP requests.
GetAndSetRequests | Demonstrates getting and setting Agent variable values.
Trap Catcher | Demonstrates receiving and handling trap, notification and inform messages.

Download the SNMP for .NET Sample Applications

Support Options

Our mission at Dart is to deliver high quality Internet connectivity solutions to Internet application developers. Our goal is to supplement these solutions with timely support resources that can help at many different levels.

You must have an active connection to the Internet to view these links.

Paid Support Options
Discusses the paid support options available.
Free Support Options
Provides access to free materials to help your development, including FAQS, online help files, tutorials, code snippets, online asp samples, and a free support forum.
Support Forum
Provides access to our support forum, monitored by our own development staff as time permits.
Dart Solutions
Discusses the custom development support offered by Dart Solutions.

Authenticode Signing

Dart installation executables are authenticode signed with a "Dart Communications" digital certificate to ensure against tampering during distribution.

Dart dlls included in the installation bin directory are .NET strong name signed, but not authenticode signed. These dlls are used by the sample applications and typically referenced in users' products.

For those users who require dlls signed by the author company (for example, for Windows logo compliance), dlls that have been signed with the "Dart Communications" digital certificate are also included in the product. These dlls are contained in the "Signed Distributables" sub-folder under the installation bin folder.

In accordance with the End-User Licensing Agreement, pre-compiled Dart dlls may NOT be signed with a user's own certificate. However, for users who wish to independently sign these dlls, Dart offers Enterprise licenses which allow for this. Please contact sales@dart.com for more information.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Component
Manager Component


Licensing and Trial Operation - PowerSNMP for .NET CF

Licensing and Trial Operation
Send comments on this topic.

Licensing the Product

The Developer License

Licensed components require the presence of a Developer License in order to create a valid runtime license resource. Developer Licenses are specific to the user's development machine, and to the version of the Dart assembly used.

Obtaining a Developer License

After purchase of the product, the developer is furnished with a Product Key (Serial Number) that licenses development for a single user on up to two machines.

To obtain the Developer License, run the included DartActivateLicense utility and enter the Product Key. This utility opens a web browser and navigates to the Dart Customer Center, where a zip file containing the Developer License file is available for download. If an Internet connection does not exist, the utility provides a URL for downloading the Developer License file at a later date.

Subscription customers can obtain a Product Key for a product that has been upgraded by visiting the "My Products" page of the Customer Center and clicking on the listed current license.

Location of the Developer License

The Developer License file should be extracted from the downloaded zip file and saved to the following location:

Program Files \ Dart \ PowerSNMP for .NET CF \ <Version Number> \ bin

where <Version Number> is a placeholder for the product version number associated with the license.

This location is also accessible from a shortcut added to the Start menu:

Start \ All Programs \ Dart \ PowerSNMP for .NET CF \ <Version Number> \ Binaries Folder

At runtime, the component will search this location for the Developer License. No trial messages are subsequently seen.

The Developer License should never be deployed with an application.

Versioning

Developer Licenses are version-specific. Each minor version of the product (for example, 4.0 and 4.1) requires a separate Developer License. Build updates to the product (for example, 4.0.0 and 4.0.1) do not require new Developer Licenses. Minor version upgrades are available to developers with active subscriptions for the product.

Developer License Filename

The Developer License filename has the following format:

Dart.SNMP.CF.developer.dartlic

Important!!!

A machine must have a Developer License to license runtime use.

The .licenses Resource

An <appname>.licenses resource file is linked into the developed assembly during compilation. This file contains either the Product Key or a trial expiration date. This resource is read at runtime to confirm that the topmost managed assembly is licensed. A LicenseException is thrown if no license is found.

The licenses.licx File

When a licensed control or component is added to a Visual Studio project using the designer, a licenses.licx text file is created (if one does not already exist) and added to the project. A single-line entry is added to the file, which includes the licensed Class (for example, "Dart.Snmp.Manager"), the Assembly name (for example, "Dart.Snmp.CF"), and some optional information such as Version Number. This file can be found in the Solution Explorer.

The presence of this licx file triggers the Microsoft license compiler utility (lc.exe) to create the .licenses resource during compilation.

Manual Creation of the licenses.licx

If the licenses.licx file is not automatically updated (such as when a licensed component is created in code or when the target platform is a device), the licenses.licx entry must be added manually. If it does not already exist in the project, a new text file named "licenses.licx" must be added to the Project. It is not enough for the file to exist in the working directory, or for it to be added to the Solution. The entry for the licensed component is a single line that includes the name of the component and the assembly name, separated by a comma. For example:

Dart.Snmp.Manager, Dart.Snmp.CF20

Web Site Projects

Web Site projects include an App_Licenses.dll that must be rebuilt when changes are made to the licenses.licx file. This is accomplished by right-clicking on the licenses.licx file in the Solution Explorer, and selecting the "Rebuild Runtime Licenses" option.

Compilation Environments That Do Not Support the licenses.licx File, Like MONO

For environments that do not recognize the licenses.licx file, Dart has its own License Compiler application. This utility can be used to generate the <appname>.licenses resource file, which can then be added to the project as an embedded resource, or linked during compilation using the appropriate resource switch. Please contact Dart Support for help with compilation in environments that do not recognize the licenses.licx file.

Scripting Environments

A Developer License can be used in place of the license resource for environments without compilation.

Troubleshooting

LicenseExceptions thrown by the executing application should provide detailed information regarding the problem causing the exception.

In addition, the product utilizes the system's Application Event log, under the "Dart Components" source (or the ".NET Runtime" source, if the "Dart Components" log could not be created).

Important!!!

  • The license resource must be for the Entry (topmost managed) Assembly (exe or dll).
  • Cases in which the Entry Assembly is not the topmost executing application are considered "Plug-In" scenarios and require a Plug-In Distribution License or an ISV Distribution License (see below for more details).

Plug-In and ISV Licensing

Please contact Dart Sales to further explore the Plug-In and ISV licensing options.

Plug-In Distribution License

In "Plug-In" scenarios, a license resource cannot be created for the topmost executing assembly. This includes cases where the developed project is a

  • COM interop dll to be used by unmanaged applications
  • Managed dll to be used by managed applications developed by non-licensed users of the product

For most applications, Dart's intellectual property is protected when a strongly bound license resource is added. When used in a plug-in, however, there is no licensing relationship with the using application, as it is not strongly bound to the Dart product. Visual Studio, Firefox, IE, Access, BizTalk and many other products support the use of plug-ins. In addition, some users create their own plug-in environments. Dart's plug-in licensing naturally extends to these environments.

Plug-in operation requires the purchase of a Plug-In Distribution License. This license does not require the license resource be embedded in the topmost executing assembly.

ISV Distribution License

For Independent Software Developers (ISVs) or Enterprises who wish to bypass all licensing mechanisms, Dart offers the ISV Distribution License. The ISV license permits the tight integration of Dart source code directly into a library or application.

Trial Operation

At Runtime

Components used by applications running in trial mode will periodically show a trial message, and, after seven days of operation, expire.

7-Day Trial

An application compiled with a trial license can be deployed to other platforms for testing, but the license expires after 7 days.

  • No messages are shown during the Trial License's first 4 days.
  • After 4 days, the user is informed of the date the trial license will expire.
  • After 7 days, the user is informed of the trial's expiration. The application will cease functioning and throw a License Exception when used.
  • A trial license can be reset by recompiling the application.

Trial Messages

  • Trial messages and exceptions will always appear in the system's Application event log under the "Dart Components" source (or the ".NET Runtime" source, if the "Dart Components" log could not be created).
  • A trial message or exception will also appear in a MessageBox, if the environment is capable of showing MessageBoxes.
  • Components used in ASP.NET applications will show trial messages or exceptions in client-side alert boxes when possible.

Important!!!

For environments without an active desktop (for example, under some Windows service and web application scenarios), examine the Application event log for trial messages and exceptions.

With the exception of the trial messages and instance expiration exception, runtime trial operation is the same as licensed operation. The same dll is used for both trial and licensed operation.

During Development

A trial message is always displayed when a 7-Day Trial license is created.

See Also

Reference

Agent Component
Manager Component


Product Page - PowerSNMP for .NET CF

[image]
PowerSNMP for .NET CF
SNMP Overview
Send comments on this topic.

The following information provides a basic understanding of the SNMP protocol and related concepts. This topic does not attempt to demonstrate usage of PowerSNMP for .NET. For information of this type, see Asynchronous Operation and Assembly Overview.

Protocol Overview

SNMP provides basic network monitoring and management functions between management stations ("managers") and managed nodes ("agents"). Managers get and set agent data using a query-response protocol over UDP. Agents also send unsolicited informational messages ("traps" and "notifications") to managers. SNMP version 2 enhanced and added features to version 1. The most current version of SNMP is version 3, which added security to version 2.

Agents listen for queries on the well-known port 161. Managers listen for traps and notifications on the well-known port 162. Managers can use any port for sending requests; agents will respond to the message's source address and port.

The SNMP MIB (Management Information Base) contains objects to be managed. Objects in the MIB are assigned OIDs (Object Identifiers). A typical OID is 1.3.6.1.2.1.1.1 (sysDescr). An SNMP variable is an instance of a MIB object, and contains a value. SNMP messages generally include one or more variables. The following chart describes the various SNMP message types.

Message Type | Version | Description
Get Request | 1, 2, 3 | A manager requests the values of one or more variables supported by an agent.
GetNext Request | 1, 2, 3 | A manager requests the values of the next lexicographical variables supported by an agent.
GetBulk Request | 2, 3 | Similar to a GetNext, but multiple "next" values can be requested for each variable.
Set Request | 1, 2, 3 | A manager sets the values of one or more variables supported by an agent.
Response | 1, 2, 3 | An agent confirms receipt of a manager's Get, GetNext, GetBulk or Set request, or a manager confirms receipt of an Inform request.
Inform Request | 2, 3 | A manager sends information to another manager.
Trap | 1 | An agent informs a manager of an event.
Notification | 2, 3 | An agent informs a manager of an event (replaces Trap messages in version 2 and 3).
Report | 2, 3 | Used in version 3 to send security information.

Object and Instance Identifiers (OIDs and IIDs)

Object and instance identifiers are defined using the Abstract Syntax Notation One (ASN.1) standard.

An object identifier (OID) uniquely describes a node within the Management Information Base (MIB) tree. Each node in the tree is a ;definition; not an actual instance of an object. Typical OIDs include "1.3.6.1.2.1.1" and "1.3.6.1.2.1.1.1," which correspond to the "system" branch and "sysDescr" object, respectively.

A MIB tree leaf node may be referenced as an object instance, with an instance identifier (IID). There are two possible type of leaf nodes:

  1. A scalar may only have a single instance, and it is referenced by appending a ".0" suffix to its OID. For example, an instance of the "sysDescr" object has an IID of "1.3.6.1.2.1.1.1.0."
  2. A table column normally has multiple instances, and each is referenced by appending an indexer suffix to its OID. The indexer identifies a conceptual row in the table. For example, an "ifDescr" cell (column OID of "1.3.6.1.2.1.2.2.1.2") has an IID of "1.3.6.1.2.1.2.2.1.2.1" in row 1, "1.3.6.1.2.1.2.2.1.2.2" in row 2, etc. Many tables use a simple integer indexer, but more complex indexers can be used, provided the ASN.1 standard is adhered to.

PowerSNMP provides numerous scalar OIDs for use in the Dart.SNMP.Mib.Object namespace. When MIB files are parsed, additional classes are conveniently added to the Mib.Object namespace for reference. Numerous non-scalar OIDs fall under additional namespaces. The following table summarizes these:

Namespace | Example | Description
Mib.Object | sysDescr (1.3.6.1.2.1.1.1) | OIDs for scalar objects.
Mib.TableColumn | ifDescr (1.3.6.1.2.1.2.2.1.2) | OIDs for columns in a table. GetNext and GetBulk requests frequently include variables that are cells in a table.
Mib.Table | ifTable (1.3.6.1.2.1.2.2) | OIDs for tables, which are not leaf objects.
Mib.TableEntry | ifTableEntry(1.3.6.1.2.1.2.2.1) | OIDs for table rows. Like tables, these objects are not leaves and have limited practical application beyond providing table definition information.
Mib.Identifier | system (1.3.6.1.2.1.1) | OIDs that serve as branches; do not have associated IIDs.
Mib.Group | systemGroup (1.3.6.1.6.3.1.2.2.6) | OIDs of notification and object groups; do not have associated IIDs.
Mib.Notification | authenticationFailure (1.3.6.1.6.3.1.1.5.5) | OIDs of notification messages; do not have associated IIDs.

Mib Parsing

A Management Information Base, or MIB, is a definition of managed objects in a text file. Such files are commonly called "MIB files," and are shared between SNMP agents and managers to define a language of objects. PowerSNMP has built-in support for many standard MIB definitions.

There are two mechanisms available for extending support to additional MIB files:

  1. Parse mibs to generate code files using MibNodes.GenerateCode. This method creates MibNode and MibTrap objects that can be imported at runtime, without the need to parse mibs at runtime. Also, enumerations are generated which can be used in the GetByNodeName and GetByTrapName functions, providing the developer with Intellisense for the generated MibNodes and MibTraps.
  2. Dynamically parse mibs to add MibNodes and MibTraps at runtime using MibNodes.GenerateNodes.

NOTE: Dart has tested numerous MIB files for parsing compatibility. Still, it is possible for an application to require the processing of a MIB file that either does not parse well or will not compile. If a MIB file fails to parse, it may be possible to edit the file to bring it closer to conformance with the specification. Dart provides optional paid support for this kind of problem. If compilation fails, the source code can be edited to modify the offending syntax. For example, Visual Basic may have problems with duplicate class names due to its case-insensitivity (sysDescr confused with SysDescr). Issues such as this can be dealt with on a case-by-case basis. Of course, classes can always be manually constructed, providing applications the benefits of self-documenting type-safety.

See Also

Reference

Agent Component
Manager Component


Product Page - PowerSNMP for .NET CF

FIPS Compliance
Send comments on this topic.

Federal Information Processing Standard 140 (FIPS 140) defines approved cryptographic algorithms for computer systems used by the U.S. federal government. The current version of the standard is FIPS 140-2. Cryptographic algorithms can be validated as FIPS certified through the Cryptographic Module Validation Program (CMVP).

Application using PowerSNMP for .NET can be made FIPS 140-2 compliant by using SnmpVersion.Three with AuthenticationProtocol.Sha and PrivacyProtocol.TripleDes. Dart offers Subscriptions which include source code for users who wish to obtain FIPS validation through a CMVP vendor.

The following registry settings are used to inform applications to only use cryptographic algorithms that are FIPS 140 compliant. To enable these settings, set their values to 1.

For Windows 2008 and Vista:

HKLM\System\CurrentControlSet\Control\Lsa\FIPSAlgorithmPolicy\Enabled

For Windows Server 2003 and XP:

HKLM\System\CurrentControlSet\Control\Lsa\FIPSAlgorithmPolicy

See Also

Reference

Agent Component
Manager Component


Asynchronous Operation - PowerSNMP for .NET CF

[image]
PowerSNMP for .NET CF
Asynchronous Operation
Send comments on this topic.

The following provides information on using PowerSNMP components in an asynchronous manner, by executing method calls on worker threads.

Introduction

Traditional PowerSNMP asynchronous support provided a means for executing methods on worker threads, but this required a signaling mechanism indicating when operations completed. This resulted in difficult-to-maintain, event-driven code.

With the new version 4.0 design, code is more self-documenting, uses fewer resources, and is more flexible to use. A convenient Start method allows the user to string together multiple blocking methods with the following benefits:

  • Less event-driven code. Methods are called inline, producing self-documenting code that is easier to write and maintain.
  • Marshal methods are included that permit the user to conveniently marshal data back to the UI thread for display in any UI control.
  • A simplified and more efficient interface.
  • Removal of all asynchronous methods. The simple Start method allows users to conveniently execute directly on a worker thread.
  • No need for pseudo-blocking functionality. Problems associated with possible re-entrancy (caused when UI messages are processes while a communication method is in progress) are eliminated.
  • A single worker thread can be used to string together any combination of blocking methods, allowing the user to execute any combination of methods without using multiple worker threads in serial (a requirement of less advanced designs).

The Start Method

All PowerSNMP components fully support both synchronous (blocking) and asynchronous (non-blocking) use. However, the simple, streamlined interface contains only blocking methods. This is possible through use of the Start method call.

Each component's Start method will execute one or more functions on a separate worker thread. In other words, any function containing blocking calls can be made asynchronous by simply passing it to the Start method. The syntax for this method is simple (C# and VB code snippets follow):

C# Copy Code
manager1.Start(myBlockingFunction, myObject); //Can also be called without passing an object

private void myBlockingFunction(ManagerSlave slave, object myObject)
{
   ...
}

Visual Basic Copy Code
manager1.Start(AddressOf myBlockingFunction, myObject) 'Can also be called without passing an object

Private Sub myBlockingFunction(ByVal slave As ManagerSlave, ByVal myObject As Object)
   ...
End Sub

There are several advantages to this approach.

First, a function that performs some process is the same, whether it will be executed synchronously or asynchronously. It is no longer necessary to write separate code for blocking and non-blocking applications.

Second, asynchronous code can be written in a sequential, step-by-step manner. It is no longer necessary to implement numerous event handlers, with code that jumps from one handler to another.

Third, it is no longer necessary to keep track of state in event handlers. For example, take the simple case where the following sequence must take place:

  1. Receive data A
  2. Send data B
  3. Receive data C
  4. Send data D

In other asynchronous implementations, an event will fire signifying data received. In this paradigm, a state machine must be implemented in the event handler (if A received then send B, else if C received then send D). With the new approach, a function is written with sequential statement (Receive A, Send B, Receive C, Send D). This produces code that is much easier to debug and to maintain.

Marshaling Data

The above example demonstrates how the Start method provides code that is easy to write, debug and maintain. But now the functions are operating on their own threads. How does the code report back to the main thread?

PowerSNMP components have convenient Marshal method calls which are paired with events that fire on the main thread. For example (C# and VB code snippets follow):

C# Copy Code
manager1.Marshal(responses, null) //Execute on worker thread

private void manager1_Message(object sender, MessageEventArgs e)
{
   //Whenever messages are received, display them in UI element (raised on the UI thread)
   foreach (MessageBase message in e.Messages) { ... }
}
Visual Basic Copy Code
manager1.Marshal(responses, Nothing) 'Execute on worker thread

Private Sub manager1_Message(ByVal sender As Object, ByVal e As MessageEventArgs) Handles manager1.Message
   'Whenever messages are received, display them in UI element (raised on the UI thread)
   For Each message As MessageBase In e.Messages
      ...
   Next
End Sub

This is an easy-to-use mechanism for marshaling data back to the main thread.

Typical Uses

Below are two typical asynchronous use examples.

In the first example, the developer wants to send a Get request and receive a response on a worker thread. A button, textbox and Manager component are added to the form. Pressing the button will send the request and wait for the response. When the response is received, the value of the requested variable is shown in the textbox. The performRequest function, which could also be used in a strictly blocking application, is passed to the Start call to be executed on a worker thread (C# and VB code snippets follow).

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   try
   {
       //Get agent's sysDescription value
       manager1.Start(performRequest, manager1.Mib.CreateVariable(NodeName.sysDescr));
   }
   catch (Exception ex)
   {
       //Problems creating the socket will be caught here
       MessageBox.Show(ex.Message);
   }
}

private void performRequest(ManagerSlave slave, object variable)
{
   GetMessage request = null;
   try
   {
       //Create Get request and get response
       request = new GetMessage();
       request.Version = SnmpVersion.One;
       request.Variables.Add((Variable)variable);
       ResponseMessage response = slave.GetResponse(request, myAgentAddress);

       //Marshal response to UI thread
       manager1.Marshal(new ResponseMessage[] { response }, null);
   }
   catch (Exception ex)
   {
       //Marshal exception to UI thread
       manager1.Marshal(ex);
   }
}

void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
   //Show value of first variable
   ResponseMessage response = e.Messages[0] as ResponseMessage;
   textBox1.Text = response.Variables[0].Value.ToString();
}

private void manager1_Error(object sender, System.IO.ErrorEventArgs e)
{
   //Show exception
   MessageBox.Show(e.GetException().Message);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    Try
        'Get agent's sysDescription value
        manager1.Start(AddressOf performRequest, manager1.Mib.CreateVariable(NodeName.sysDescr))
    Catch ex As Exception
        'Problems creating the socket will be caught here
        MessageBox.Show(ex.Message)
    End Try
End Sub

Private Sub performRequest(ByVal slave As ManagerSlave, ByVal variable As Object)
    Dim request As GetMessage = Nothing
    Try
        'Create Get request and get response
        request = New GetMessage()
        request.Version = SnmpVersion.One
        request.Variables.Add(CType(variable, Variable))
        Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

        'Marshal response to UI thread
        manager1.Marshal(New ResponseMessage() { response }, Nothing)
    Catch ex As Exception
        'Marshal exception to UI thread
        manager1.Marshal(ex)
    End Try
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs) Handles manager1.Message
    'Show value of first variable
    Dim response As ResponseMessage = TryCast(e.Messages(0), ResponseMessage)
    textBox1.Text = response.Variables(0).Value.ToString()
End Sub

Private Sub manager1_Error(ByVal sender As Object, ByVal e As System.IO.ErrorEventArgs) Handles manager1.Error
    'Show exception
    MessageBox.Show(e.GetException().Message)
End Sub

In the second example, the developer wants to start a thread for receiving request messages from SNMP managers. Similar code is used for the manager component to listen for trap, notification and inform messages.

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   try
   {
       //Start a thread for receiving requests
       agent1.Start(requestReceived, null);
   }
   catch (Exception ex)
   {
       //Problems with the socket will be caught here
       MessageBox.Show(ex.Message);
   }
}

void requestReceived(Agent agent, RequestMessage request, ref ResponseMessage response, object state)
{
   //Create and send a response for the request
   agent1.Send(agent1.CreateDefaultResponse(request), request.Origin);

   //Also, log any set requests received
   if (request is SetMessage)
       agent1.Marshal(new ResponseMessage[] { response }, null);
}

void agent1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
   ResponseMessage request = e.Messages[0] as ResponseMessage;
   foreach (Variable v in request.Variables)
       logSetRequest(v.Id, v.Value);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    Try
        'Start a thread for receiving requests
        agent1.Start(AddressOf requestReceived, Nothing)
    Catch ex As Exception
        'Problems with the socket will be caught here
        MessageBox.Show(ex.Message)
    End Try
End Sub

Private Sub requestReceived(ByVal agent As Agent, ByVal request As RequestMessage, _
    ByRef response As ResponseMessage, ByVal state As Object)
    'Create and send a response for the request
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin)

    'Also, log any set requests received
    If Typeof request Is SetMessage Then
        agent1.Marshal(New ResponseMessage() { response }, Nothing)
    End If
End Sub

Private Sub agent1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs) Handles agent1.Message
    Dim request As ResponseMessage = TryCast(e.Messages(0), ResponseMessage)
    For Each v As Variable In request.Variables
        logSetRequest(v.Id, v.Value)
    Next v
End Sub

See Also

Reference

Agent Component
Manager Component


Assembly Overview

Dart.Snmp.CF Assembly
See Also Send comments on this topic.
PowerSNMP includes the following namespaces.

Namespaces

Namespace | Description
Dart.Common |
Dart.Snmp |
Dart.Snmp.Notification |
Dart.Snmp.SimpleType |
Dart.Snmp.Trap |

See Also

Reference

Agent Component
Manager Component


Dart.Common Namespace

Dart.Common Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Classes

 | Class | Description
Class | AuthenticationException | Thrown when a client or server cannot be authenticated.
Class | ComponentBase | Base class for PowerTCP Components.
Class | ComponentErrorEventArgs | Provides data for the ComponentBase.Error event.
Class | DartLicenseException | The base class for all Dart component license exceptions.
Class | LicenseException | Thrown when a component fails it's license check.
Class | NetworkStream | Used to provide a ReadTimeout property for a CF NetworkStream.
Class | Segment | Class used to encapsulate a byte[] segment.
Class | SocketBase | Base class for PowerTCP Components.
Class | UdpSocket | Derived from System.Net.Sockets.Socket to provide a ReceiveTimeout property for CF.
Class | UserStateEventArgs | Provides data for the UserState event.
Class | X509CertificateCollection | A generic list of X509Certificate objects.
Class | X509Chain | Represents a chain-building engine for X509Certificate certificates. Not implemented.
Class | X509ChainPolicy | Represents the chain policy to be applied when building an X509 certificate chain. This class cannot be inherited.

Structures

 | Structure | Description
Structure | X509ChainStatus | Provides a simple structure for storing X509 chain status and error information.

Delegates

 | Delegate | Description
Delegate | ComponentErrorEventHandler | Represents the method that will handle an event raised due to an component error.
Delegate | LocalCertificateSelectionCallback | Selects the local Secure Sockets Layer (SSL) certificate used for authentication.
Delegate | RemoteCertificateValidationCallback | Verifies the remote Secure Sockets Layer (SSL) certificate used for authentication.
Delegate | UserStateEventHandler | Represents the method that will handle an event raised by the user calling Marshal.

Enumerations

 | Enumeration | Description
Enumeration | CipherAlgorithmType | Defines the possible cipher algorithms for the SslStream class.
Enumeration | ExchangeAlgorithmType | Specifies the algorithm used to create keys shared by the client and server.
Enumeration | HashAlgorithmType | Specifies the algorithm used for generating message authentication codes (MACs).
Enumeration | SslPolicyErrors | Enumerates Secure Socket Layer (SSL) policy errors. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Enumeration | SslProtocols | Defines the possible values of SslProtocols.
Enumeration | X509ChainStatusFlags | Defines the status of an X509 chain. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Enumeration | X509RevocationFlag | Specifies which X509 certificates in the chain should be checked for revocation.
Enumeration | X509RevocationMode | Specifies the mode used to check for X509 certificate revocation.

See Also

Reference

Dart.Snmp.CF Assembly


AuthenticationException Class

[image]
PowerSNMP for .NET CF
AuthenticationException Class
Members See Also Send comments on this topic.
Dart.Common Namespace : AuthenticationException Class

Thrown when a client or server cannot be authenticated.

Object Model

AuthenticationException Class

Syntax

Visual Basic (Declaration)
Public Class AuthenticationException
   Inherits System.SystemException
Visual Basic (Usage) Copy Code
Dim instance As AuthenticationException
C#
public class AuthenticationException : System.SystemException
Managed Extensions for C++
public __gc class AuthenticationException : public System.SystemException
C++/CLI
public ref class AuthenticationException : public System.SystemException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
Dart.Common.AuthenticationException

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AuthenticationException Members
Dart.Common Namespace


AuthenticationException Class Members

[image]
PowerSNMP for .NET CF
AuthenticationException Class Members
See Also Properties Methods Send comments on this topic.
Dart.Common Namespace : AuthenticationException Class

The following tables list the members exposed by AuthenticationException.

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

AuthenticationException Class
Dart.Common Namespace


ComponentBase Class

[image]
PowerSNMP for .NET CF
ComponentBase Class
Members See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

Base class for PowerTCP Components.

Object Model

ComponentBase Class

Syntax

Visual Basic (Declaration)
Public Class ComponentBase
   Inherits System.ComponentModel.Component
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
C#
public class ComponentBase : System.ComponentModel.Component
Managed Extensions for C++
public __gc class ComponentBase : public System.ComponentModel.Component
C++/CLI
public ref class ComponentBase : public System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Members
Dart.Common Namespace


ComponentBase Class Members

[image]
PowerSNMP for .NET CF
ComponentBase Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

The following tables list the members exposed by ComponentBase.

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component.
public Field | Tag | Gets or sets an object that stores any user data.
Top

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread.
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an exception to the UI thread.
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event.
protected Method | OnUserState | Raises the UserState event.
Top

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method.
public Event | UserState | Raised when user state information is marshaled.
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


ComponentBase Class Methods

[image]
PowerSNMP for .NET CF
ComponentBase Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

"

For a list of all members of this type, see ComponentBase members.

"

Public Methods

 | Name | Description
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an exception to the UI thread.
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event.
protected Method | OnUserState | Raises the UserState event.
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


Marshal Method

[image]
PowerSNMP for .NET CF
Marshal Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : Marshal Method

Marshals an exception to the UI thread.

Overload List

Overload | Description
Marshal(Exception) | Marshals an exception to the UI thread.
Marshal(Object) | Marshals user state information to the UI thread.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


Marshal(Exception) Method

[image]
PowerSNMP for .NET CF
Marshal(Exception) Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class > Marshal Method : Marshal(Exception) Method

exception
The Exception to be marshaled.
Marshals an exception to the UI thread.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim exception As Exception

instance.Marshal(exception)
C#
public void Marshal(
   Exception exception
)
Managed Extensions for C++
public: void Marshal(
   Exception* exception
)
C++/CLI
public:
void Marshal(
   Exception^ exception
)

Parameters

exception
The Exception to be marshaled.

Remarks

This method is used to marshal exceptions from a worker thread back to the UI thread for typical display purposes. It calls the OnError method, which raises the Error event.

This method automatically marshals any unhandled exceptions generated by worker threads created with the Start method.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


Marshal(Object) Method

[image]
PowerSNMP for .NET CF
Marshal(Object) Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class > Marshal Method : Marshal(Object) Method

userState
The user state information to be marshaled.
Marshals user state information to the UI thread.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal userState As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim userState As Object

instance.Marshal(userState)
C#
public void Marshal(
   object userState
)
Managed Extensions for C++
public: void Marshal(
   Object* userState
)
C++/CLI
public:
void Marshal(
   Object^ userState
)

Parameters

userState
The user state information to be marshaled.

Remarks

This method can be used to marshal user state information from a worker thread back to the UI thread for typical display purposes. It calls the OnUserState method, which raises the UserState event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


OnError Method

[image]
PowerSNMP for .NET CF
OnError Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : OnError Method

e
A ComponentErrorEventArgs object that contains the exception.
Raises the Error event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnError( _
   ByVal e As ComponentErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim e As ComponentErrorEventArgs

instance.OnError(e)
C#
protected virtual void OnError(
   ComponentErrorEventArgs e
)
Managed Extensions for C++
protected: virtual void OnError(
   ComponentErrorEventArgs* e
)
C++/CLI
protected:
virtual void OnError(
   ComponentErrorEventArgs^ e
)

Parameters

e
A ComponentErrorEventArgs object that contains the exception.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnError method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnError in a derived class, be sure to call the base class OnError method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


OnUserState Method

[image]
PowerSNMP for .NET CF
OnUserState Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : OnUserState Method

e
A UserStateEventArgs object containing user state information.
Raises the UserState event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUserState( _
   ByVal e As UserStateEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim e As UserStateEventArgs

instance.OnUserState(e)
C#
protected virtual void OnUserState(
   UserStateEventArgs e
)
Managed Extensions for C++
protected: virtual void OnUserState(
   UserStateEventArgs* e
)
C++/CLI
protected:
virtual void OnUserState(
   UserStateEventArgs^ e
)

Parameters

e
A UserStateEventArgs object containing user state information.

Remarks

Raising an event invokes the event handler through a delegate. The Synchronizing property must be set.

The OnUserState method also allows derived classes to handle the event without attaching a delegate. This is the preferred technique for handling the event in a derived class.

Note to Inheritors: When overriding OnUserState in a derived class, be sure to call the base class OnUserState method, so that registered delegates receive the event.

See the SynchronizingObject property for important information on updating UI controls from within derived classes and events.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Properties

[image]
PowerSNMP for .NET CF
ComponentBase Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

"

For a list of all members of this type, see ComponentBase members.

"

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread.
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


SynchronizingObject Property

[image]
PowerSNMP for .NET CF
SynchronizingObject Property
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : SynchronizingObject Property

Gets or sets the object used to marshal data to the UI thread.

Syntax

Visual Basic (Declaration)
Public Property SynchronizingObject As Control
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Control

instance.SynchronizingObject = value

value = instance.SynchronizingObject
C#
public Control SynchronizingObject {get; set;}
Managed Extensions for C++
public: __property Control* get_SynchronizingObject();
public: __property void set_SynchronizingObject(
   Control* value
);
C++/CLI
public:
property Control^ SynchronizingObject {
   Control^ get();
   void set (    Control^ value);
}

Remarks

This property determines the thread on which the component's event handlers are called. This is usually the same thread the component was created on.

This property is automatically set to the containing control when used in the Windows Forms designer. This is typically the form or user control in which the component is used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Fields

[image]
PowerSNMP for .NET CF
ComponentBase Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

"

For a list of all members of this type, see ComponentBase members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component.
public Field | Tag | Gets or sets an object that stores any user data.
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


Encoding Field

[image]
PowerSNMP for .NET CF
Encoding Field
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : Encoding Field

Character encoding used by the component.

Syntax

Visual Basic (Declaration)
Public Encoding As Encoding
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Encoding

value = instance.Encoding

instance.Encoding = value
C#
public Encoding Encoding
Managed Extensions for C++
public: Encoding* Encoding
C++/CLI
public:
Encoding^ Encoding

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


Tag Field

[image]
PowerSNMP for .NET CF
Tag Field
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : Tag Field

Gets or sets an object that stores any user data.

Syntax

Visual Basic (Declaration)
Public Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Object

value = instance.Tag

instance.Tag = value
C#
public object Tag
Managed Extensions for C++
public: Object* Tag
C++/CLI
public:
Object^ Tag

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Events

[image]
PowerSNMP for .NET CF
ComponentBase Class Events
See Also Send comments on this topic.
Dart.Common Namespace : ComponentBase Class

"

For a list of all members of this type, see ComponentBase members.

"

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method.
public Event | UserState | Raised when user state information is marshaled.
Top

See Also

Reference

ComponentBase Class
Dart.Common Namespace


Error Event

[image]
PowerSNMP for .NET CF
Error Event
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : Error Event

Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method.

Syntax

Visual Basic (Declaration)
Public Event Error As ComponentErrorEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim handler As ComponentErrorEventHandler

AddHandler instance.Error, handler
C#
public event ComponentErrorEventHandler Error
Managed Extensions for C++
public: __event ComponentErrorEventHandler* Error
C++/CLI
public:
event ComponentErrorEventHandler^ Error

Remarks

This event is always raised on the UI thread so that data can be used with UI components.

See SynchronizingObject for important information on updating UI controls from within this event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


UserState Event

[image]
PowerSNMP for .NET CF
UserState Event
See Also Send comments on this topic.
Dart.Common Namespace > ComponentBase Class : UserState Event

Raised when user state information is marshaled.

Syntax

Visual Basic (Declaration)
Public Event UserState As UserStateEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim handler As UserStateEventHandler

AddHandler instance.UserState, handler
C#
public event UserStateEventHandler UserState
Managed Extensions for C++
public: __event UserStateEventHandler* UserState
C++/CLI
public:
event UserStateEventHandler^ UserState

Remarks

This event is raised when an object is passed to the Marshal method.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentErrorEventArgs Class

[image]
PowerSNMP for .NET CF
ComponentErrorEventArgs Class
Members See Also Send comments on this topic.
Dart.Common Namespace : ComponentErrorEventArgs Class

Provides data for the ComponentBase.Error event.

Object Model

ComponentErrorEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ComponentErrorEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ComponentErrorEventArgs
C#
public class ComponentErrorEventArgs
Managed Extensions for C++
public __gc class ComponentErrorEventArgs
C++/CLI
public ref class ComponentErrorEventArgs

Inheritance Hierarchy

System.Object
Dart.Common.ComponentErrorEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentErrorEventArgs Members
Dart.Common Namespace


ComponentErrorEventArgs Class Members

[image]
PowerSNMP for .NET CF
ComponentErrorEventArgs Class Members
See Also Methods Send comments on this topic.
Dart.Common Namespace : ComponentErrorEventArgs Class

The following tables list the members exposed by ComponentErrorEventArgs.

Public Constructors

 | Name | Description
public Constructor | ComponentErrorEventArgs Constructor | Wrap an exception within this class.
Top

Public Methods

 | Name | Description
public Method | GetException | Returns the Exception marshaled to the UI thread.
Top

See Also

Reference

ComponentErrorEventArgs Class
Dart.Common Namespace


ComponentErrorEventArgs Constructor

[image]
PowerSNMP for .NET CF
ComponentErrorEventArgs Constructor
See Also Send comments on this topic.
Dart.Common Namespace > ComponentErrorEventArgs Class : ComponentErrorEventArgs Constructor

exception
Exception to wrap.
Wrap an exception within this class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim exception As Exception

Dim instance As New ComponentErrorEventArgs(exception)
C#
public ComponentErrorEventArgs(
   Exception exception
)
Managed Extensions for C++
public: ComponentErrorEventArgs(
   Exception* exception
)
C++/CLI
public:
ComponentErrorEventArgs(
   Exception^ exception
)

Parameters

exception
Exception to wrap.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentErrorEventArgs Class
ComponentErrorEventArgs Members


ComponentErrorEventArgs Class Methods

[image]
PowerSNMP for .NET CF
ComponentErrorEventArgs Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : ComponentErrorEventArgs Class

"

For a list of all members of this type, see ComponentErrorEventArgs members.

"

Public Methods

 | Name | Description
public Method | GetException | Returns the Exception marshaled to the UI thread.
Top

See Also

Reference

ComponentErrorEventArgs Class
Dart.Common Namespace


GetException Method

[image]
PowerSNMP for .NET CF
GetException Method
See Also Send comments on this topic.
Dart.Common Namespace > ComponentErrorEventArgs Class : GetException Method

Returns the Exception marshaled to the UI thread.

Syntax

Visual Basic (Declaration)
Public Function GetException() As Exception
Visual Basic (Usage) Copy Code
Dim instance As ComponentErrorEventArgs
Dim value As Exception

value = instance.GetException()
C#
public Exception GetException()
Managed Extensions for C++
public: Exception* GetException();
C++/CLI
public:
Exception^ GetException();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentErrorEventArgs Class
ComponentErrorEventArgs Members


DartLicenseException Class

[image]
PowerSNMP for .NET CF
DartLicenseException Class
Members See Also Send comments on this topic.
Dart.Common Namespace : DartLicenseException Class

The base class for all Dart component license exceptions.

Object Model

DartLicenseException Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class DartLicenseException
   Inherits System.Exception
Visual Basic (Usage) Copy Code
Dim instance As DartLicenseException
C#
public abstract class DartLicenseException : System.Exception
Managed Extensions for C++
public __gc abstract class DartLicenseException : public System.Exception
C++/CLI
public ref class DartLicenseException abstract : public System.Exception

Remarks

Use the DartLicenseException class to catch runtime licensing exceptions. These exceptions are thrown at component creation time and during access of select properites or methods. The Message property will provide a description of the specific licensing problem encountered. The InnerException property should also be examined for additional details.

Inheritance Hierarchy

System.Object
System.Exception
Dart.Common.DartLicenseException

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DartLicenseException Members
Dart.Common Namespace


DartLicenseException Class Members

[image]
PowerSNMP for .NET CF
DartLicenseException Class Members
See Also Properties Methods Send comments on this topic.
Dart.Common Namespace : DartLicenseException Class

The following tables list the members exposed by DartLicenseException.

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Common Namespace


LicenseException Class

[image]
PowerSNMP for .NET CF
LicenseException Class
Members See Also Send comments on this topic.
Dart.Common Namespace : LicenseException Class

Thrown when a component fails it's license check.

Object Model

LicenseException Class

Syntax

Visual Basic (Declaration)
Public Class LicenseException
   Inherits System.SystemException
Visual Basic (Usage) Copy Code
Dim instance As LicenseException
C#
public class LicenseException : System.SystemException
Managed Extensions for C++
public __gc class LicenseException : public System.SystemException
C++/CLI
public ref class LicenseException : public System.SystemException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
Dart.Common.LicenseException

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LicenseException Members
Dart.Common Namespace


LicenseException Class Members

[image]
PowerSNMP for .NET CF
LicenseException Class Members
See Also Properties Methods Send comments on this topic.
Dart.Common Namespace : LicenseException Class

The following tables list the members exposed by LicenseException.

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | LicensedType | The Type of the licensed object.
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

LicenseException Class
Dart.Common Namespace


LicenseException Class Properties

[image]
PowerSNMP for .NET CF
LicenseException Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : LicenseException Class

"

For a list of all members of this type, see LicenseException members.

"

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | LicensedType | The Type of the licensed object.
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

LicenseException Class
Dart.Common Namespace


LicensedType Property

[image]
PowerSNMP for .NET CF
LicensedType Property
See Also Send comments on this topic.
Dart.Common Namespace > LicenseException Class : LicensedType Property

The Type of the licensed object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LicensedType As Type
Visual Basic (Usage) Copy Code
Dim instance As LicenseException
Dim value As Type

value = instance.LicensedType
C#
public Type LicensedType {get;}
Managed Extensions for C++
public: __property Type* get_LicensedType();
C++/CLI
public:
property Type^ LicensedType {
   Type^ get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LicenseException Class
LicenseException Members


NetworkStream Class

[image]
PowerSNMP for .NET CF
NetworkStream Class
Members See Also Send comments on this topic.
Dart.Common Namespace : NetworkStream Class

Used to provide a ReadTimeout property for a CF NetworkStream.

Object Model

NetworkStream Class

Syntax

Visual Basic (Declaration)
Public Class NetworkStream
   Inherits System.Net.Sockets.NetworkStream
Visual Basic (Usage) Copy Code
Dim instance As NetworkStream
C#
public class NetworkStream : System.Net.Sockets.NetworkStream
Managed Extensions for C++
public __gc class NetworkStream : public System.Net.Sockets.NetworkStream
C++/CLI
public ref class NetworkStream : public System.Net.Sockets.NetworkStream

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
System.Net.Sockets.NetworkStream
Dart.Common.NetworkStream

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NetworkStream Members
Dart.Common Namespace


NetworkStream Class Members

[image]
PowerSNMP for .NET CF
NetworkStream Class Members
See Also Properties Methods Send comments on this topic.
Dart.Common Namespace : NetworkStream Class

The following tables list the members exposed by NetworkStream.

Public Constructors

 | Name | Description
public Constructor | NetworkStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | (Inherited from System.IO.Stream)
public Property | CanSeek | (Inherited from System.IO.Stream)
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | (Inherited from System.IO.Stream)
public Property | DataAvailable | (Inherited from System.Net.Sockets.NetworkStream)
public Property | Length | (Inherited from System.IO.Stream)
public Property | Position | (Inherited from System.IO.Stream)
public Property | ReadTimeout | Overridden. Gets or sets a value, in milliseconds, that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

Protected Properties

 | Name | Description
protected Property | Readable | (Inherited from System.Net.Sockets.NetworkStream)
protected Property | Socket | (Inherited from System.Net.Sockets.NetworkStream)
protected Property | Writeable | (Inherited from System.Net.Sockets.NetworkStream)
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overloaded. Overridden. Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | (Inherited from System.IO.Stream)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Perform a blocking read on the socket.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | (Inherited from System.IO.Stream)
public Method | SetLength | (Inherited from System.IO.Stream)
public Method | Write | (Inherited from System.IO.Stream)
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

NetworkStream Class
Dart.Common Namespace


NetworkStream Constructor

[image]
PowerSNMP for .NET CF
NetworkStream Constructor
See Also Send comments on this topic.
Dart.Common Namespace > NetworkStream Class : NetworkStream Constructor

Overload List

Overload | Description
NetworkStream Constructor | Initialized the class with a Socket instance.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NetworkStream Class
NetworkStream Members


NetworkStream Constructor

[image]
PowerSNMP for .NET CF
NetworkStream Constructor
See Also Send comments on this topic.
Dart.Common Namespace > NetworkStream Class : NetworkStream Constructor

socket
Initialized the class with a Socket instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal socket As Socket _
)
Visual Basic (Usage) Copy Code
Dim socket As Socket

Dim instance As New NetworkStream(socket)
C#
public NetworkStream(
   Socket socket
)
Managed Extensions for C++
public: NetworkStream(
   Socket* socket
)
C++/CLI
public:
NetworkStream(
   Socket^ socket
)

Parameters

socket

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NetworkStream Class
NetworkStream Members


NetworkStream Class Methods

[image]
PowerSNMP for .NET CF
NetworkStream Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : NetworkStream Class

"

For a list of all members of this type, see NetworkStream members.

"

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overloaded. Overridden. Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | (Inherited from System.IO.Stream)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Perform a blocking read on the socket.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | (Inherited from System.IO.Stream)
public Method | SetLength | (Inherited from System.IO.Stream)
public Method | Write | (Inherited from System.IO.Stream)
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

NetworkStream Class
Dart.Common Namespace


Close Method

[image]
PowerSNMP for .NET CF
Close Method
See Also Send comments on this topic.
Dart.Common Namespace > NetworkStream Class : Close Method

Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.

Overload List

Overload | Description
Close() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
Close(Int32) | (Inherited from System.Net.Sockets.NetworkStream)

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NetworkStream Class
NetworkStream Members


Close() Method

[image]
PowerSNMP for .NET CF
Close() Method
See Also Send comments on this topic.
Dart.Common Namespace > NetworkStream Class > Close Method : Close() Method

Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As NetworkStream

instance.Close()
C#
public override void Close()
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NetworkStream Class
NetworkStream Members
Overload List


Read Method

[image]
PowerSNMP for .NET CF
Read Method
See Also Send comments on this topic.
Dart.Common Namespace > NetworkStream Class : Read Method

buffer
Destination for all data read.
offset
Starting location for destination.
count
Maximum number of bytes to be read.
Perform a blocking read on the socket.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As NetworkStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
Destination for all data read.
offset
Starting location for destination.
count
Maximum number of bytes to be read.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NetworkStream Class
NetworkStream Members


NetworkStream Class Properties

[image]
PowerSNMP for .NET CF
NetworkStream Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : NetworkStream Class

"

For a list of all members of this type, see NetworkStream members.

"

Public Properties

 | Name | Description
public Property | CanRead | (Inherited from System.IO.Stream)
public Property | CanSeek | (Inherited from System.IO.Stream)
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | (Inherited from System.IO.Stream)
public Property | DataAvailable | (Inherited from System.Net.Sockets.NetworkStream)
public Property | Length | (Inherited from System.IO.Stream)
public Property | Position | (Inherited from System.IO.Stream)
public Property | ReadTimeout | Overridden. Gets or sets a value, in milliseconds, that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

Protected Properties

 | Name | Description
protected Property | Readable | (Inherited from System.Net.Sockets.NetworkStream)
protected Property | Socket | (Inherited from System.Net.Sockets.NetworkStream)
protected Property | Writeable | (Inherited from System.Net.Sockets.NetworkStream)
Top

See Also

Reference

NetworkStream Class
Dart.Common Namespace


ReadTimeout Property

[image]
PowerSNMP for .NET CF
ReadTimeout Property
See Also Send comments on this topic.
Dart.Common Namespace > NetworkStream Class : ReadTimeout Property

Gets or sets a value, in milliseconds, that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As NetworkStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NetworkStream Class
NetworkStream Members


Segment Class

[image]
PowerSNMP for .NET CF
Segment Class
Members See Also Send comments on this topic.
Dart.Common Namespace : Segment Class

Class used to encapsulate a byte[] segment.

Object Model

Segment Class

Syntax

Visual Basic (Declaration)
Public Class Segment
Visual Basic (Usage) Copy Code
Dim instance As Segment
C#
public class Segment
Managed Extensions for C++
public __gc class Segment
C++/CLI
public ref class Segment

Inheritance Hierarchy

System.Object
Dart.Common.Segment

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Segment Members
Dart.Common Namespace


Segment Class Members

[image]
PowerSNMP for .NET CF
Segment Class Members
See Also Fields Send comments on this topic.
Dart.Common Namespace : Segment Class

The following tables list the members exposed by Segment.

Public Constructors

 | Name | Description
public Constructor | Segment Constructor | Used to create a Segment object that holds a buffer of data.
Top

Public Fields

 | Name | Description
public Field | Buffer | Gets the buffer that holds data.
public Field | Count | The number of bytes of data.
public Field | Offset | The offset into the buffer where the data starts.
Top

See Also

Reference

Segment Class
Dart.Common Namespace


Segment Constructor

[image]
PowerSNMP for .NET CF
Segment Constructor
See Also Send comments on this topic.
Dart.Common Namespace > Segment Class : Segment Constructor

buffer
Byte[] containing data.
offset
Offset of the start of meaningful data.
count
Byte count of meaningful data.
Used to create a Segment object that holds a buffer of data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

Dim instance As New Segment(buffer, offset, count)
C#
public Segment(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Segment(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Segment(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
Byte[] containing data.
offset
Offset of the start of meaningful data.
count
Byte count of meaningful data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Segment Class
Segment Members


Segment Class Fields

[image]
PowerSNMP for .NET CF
Segment Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : Segment Class

"

For a list of all members of this type, see Segment members.

"

Public Fields

 | Name | Description
public Field | Buffer | Gets the buffer that holds data.
public Field | Count | The number of bytes of data.
public Field | Offset | The offset into the buffer where the data starts.
Top

See Also

Reference

Segment Class
Dart.Common Namespace


Buffer Field

[image]
PowerSNMP for .NET CF
Buffer Field
See Also Send comments on this topic.
Dart.Common Namespace > Segment Class : Buffer Field

Gets the buffer that holds data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Buffer As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Segment
Dim value() As Byte

value = instance.Buffer
C#
public readonly byte[] Buffer
Managed Extensions for C++
public: readonly byte[]* Buffer
C++/CLI
public:
readonly array<byte>^ Buffer

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Segment Class
Segment Members


Count Field

[image]
PowerSNMP for .NET CF
Count Field
See Also Send comments on this topic.
Dart.Common Namespace > Segment Class : Count Field

The number of bytes of data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Segment
Dim value As Integer

value = instance.Count
C#
public readonly int Count
Managed Extensions for C++
public: readonly int Count
C++/CLI
public:
readonly int Count

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Segment Class
Segment Members


Offset Field

[image]
PowerSNMP for .NET CF
Offset Field
See Also Send comments on this topic.
Dart.Common Namespace > Segment Class : Offset Field

The offset into the buffer where the data starts.

Syntax

Visual Basic (Declaration)
Public ReadOnly Offset As Integer
Visual Basic (Usage) Copy Code
Dim instance As Segment
Dim value As Integer

value = instance.Offset
C#
public readonly int Offset
Managed Extensions for C++
public: readonly int Offset
C++/CLI
public:
readonly int Offset

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Segment Class
Segment Members


SocketBase Class

[image]
PowerSNMP for .NET CF
SocketBase Class
Members See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

Base class for PowerTCP Components.

Object Model

SocketBase Class

Syntax

Visual Basic (Declaration)
Public Class SocketBase
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As SocketBase
C#
public class SocketBase : ComponentBase
Managed Extensions for C++
public __gc class SocketBase : public ComponentBase
C++/CLI
public ref class SocketBase : public ComponentBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Snmp.SnmpBase

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketBase Members
Dart.Common Namespace


SocketBase Class Members

[image]
PowerSNMP for .NET CF
SocketBase Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Common Namespace : SocketBase Class

The following tables list the members exposed by SocketBase.

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications.
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an exception to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


SocketBase Class Properties

[image]
PowerSNMP for .NET CF
SocketBase Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

"

For a list of all members of this type, see SocketBase members.

"

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications.
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


Socket Property

[image]
PowerSNMP for .NET CF
Socket Property
See Also Send comments on this topic.
Dart.Common Namespace > SocketBase Class : Socket Property

Gets the socket used by the component for communications.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Socket As Socket
Visual Basic (Usage) Copy Code
Dim instance As SocketBase
Dim value As Socket

value = instance.Socket
C#
public Socket Socket {get;}
Managed Extensions for C++
public: __property Socket* get_Socket();
C++/CLI
public:
property Socket^ Socket {
   Socket^ get();
}

Property Value

The Socket used for UDP or TCP communications. Returns null when not in use.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SocketBase Class
SocketBase Members


UdpSocket Class

[image]
PowerSNMP for .NET CF
UdpSocket Class
Members See Also Send comments on this topic.
Dart.Common Namespace : UdpSocket Class

Derived from System.Net.Sockets.Socket to provide a ReceiveTimeout property for CF.

Object Model

UdpSocket Class

Syntax

Visual Basic (Declaration)
Public Class UdpSocket
   Inherits System.Net.Sockets.Socket
Visual Basic (Usage) Copy Code
Dim instance As UdpSocket
C#
public class UdpSocket : System.Net.Sockets.Socket
Managed Extensions for C++
public __gc class UdpSocket : public System.Net.Sockets.Socket
C++/CLI
public ref class UdpSocket : public System.Net.Sockets.Socket

Inheritance Hierarchy

System.Object
System.Net.Sockets.Socket
Dart.Common.UdpSocket

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UdpSocket Members
Dart.Common Namespace


UdpSocket Class Members

[image]
PowerSNMP for .NET CF
UdpSocket Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Common Namespace : UdpSocket Class

The following tables list the members exposed by UdpSocket.

Public Constructors

 | Name | Description
public Constructor | UdpSocket Constructor | Create a Socket for sending and receiving datagrams.
Top

Public Fields

 | Name | Description
public Field | ReceiveTimeout | Gets or sets a value that specifies the milliseconds after which a synchronous Receive call will time out.
Top

Public Properties

 | Name | Description
public Property | AddressFamily | (Inherited from System.Net.Sockets.Socket)
public Property | Available | (Inherited from System.Net.Sockets.Socket)
public Property | Blocking | (Inherited from System.Net.Sockets.Socket)
public Property | Connected | (Inherited from System.Net.Sockets.Socket)
public Property | DontFragment | (Inherited from System.Net.Sockets.Socket)
public Property | EnableBroadcast | (Inherited from System.Net.Sockets.Socket)
public Property | ExclusiveAddressUse | (Inherited from System.Net.Sockets.Socket)
public Property | Handle | (Inherited from System.Net.Sockets.Socket)
public Property | IsBound | (Inherited from System.Net.Sockets.Socket)
public Property | LingerState | (Inherited from System.Net.Sockets.Socket)
public Property | LocalEndPoint | (Inherited from System.Net.Sockets.Socket)
public Property | MulticastLoopback | (Inherited from System.Net.Sockets.Socket)
public Property | NoDelay | (Inherited from System.Net.Sockets.Socket)
public Property | ProtocolType | (Inherited from System.Net.Sockets.Socket)
public Property | ReceiveBufferSize | (Inherited from System.Net.Sockets.Socket)
public Property | ReceiveTimeout | Gets or sets a value that specifies the milliseconds after which a synchronous Receive call will time out. (Inherited from System.Net.Sockets.Socket)
public Property | RemoteEndPoint | (Inherited from System.Net.Sockets.Socket)
public Property | SendBufferSize | (Inherited from System.Net.Sockets.Socket)
public Property | SendTimeout | (Inherited from System.Net.Sockets.Socket)
public Property | SocketType | (Inherited from System.Net.Sockets.Socket)
public Property | Ttl | (Inherited from System.Net.Sockets.Socket)
public Property | UseOnlyOverlappedIO | (Inherited from System.Net.Sockets.Socket)
Top

Public Methods

 | Name | Description
public Method | Accept | (Inherited from System.Net.Sockets.Socket)
public Method | AcceptAsync | (Inherited from System.Net.Sockets.Socket)
public Method | BeginAccept | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginConnect | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginDisconnect | (Inherited from System.Net.Sockets.Socket)
public Method | BeginReceive | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginReceiveFrom | (Inherited from System.Net.Sockets.Socket)
public Method | BeginReceiveMessageFrom | (Inherited from System.Net.Sockets.Socket)
public Method | BeginSend | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginSendFile | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginSendTo | (Inherited from System.Net.Sockets.Socket)
public Method | Bind | (Inherited from System.Net.Sockets.Socket)
public Method | Close | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | Connect | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | ConnectAsync | (Inherited from System.Net.Sockets.Socket)
public Method | Disconnect | (Inherited from System.Net.Sockets.Socket)
public Method | DisconnectAsync | (Inherited from System.Net.Sockets.Socket)
public Method | DuplicateAndClose | (Inherited from System.Net.Sockets.Socket)
public Method | EndAccept | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | EndConnect | (Inherited from System.Net.Sockets.Socket)
public Method | EndDisconnect | (Inherited from System.Net.Sockets.Socket)
public Method | EndReceive | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | EndReceiveFrom | (Inherited from System.Net.Sockets.Socket)
public Method | EndReceiveMessageFrom | (Inherited from System.Net.Sockets.Socket)
public Method | EndSend | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | EndSendFile | (Inherited from System.Net.Sockets.Socket)
public Method | EndSendTo | (Inherited from System.Net.Sockets.Socket)
public Method | GetSocketOption | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | IOControl | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | Listen | (Inherited from System.Net.Sockets.Socket)
public Method | Poll | (Inherited from System.Net.Sockets.Socket)
public Method | Receive | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | ReceiveAsync | (Inherited from System.Net.Sockets.Socket)
public Method | ReceiveFrom | Overloaded. Read a datagram off the socket. The ReceiveTimeout property controls how long this method will block.
public Method | ReceiveFromAsync | (Inherited from System.Net.Sockets.Socket)
public Method | ReceiveMessageFrom | (Inherited from System.Net.Sockets.Socket)
public Method | ReceiveMessageFromAsync | (Inherited from System.Net.Sockets.Socket)
public Method | Send | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | SendAsync | (Inherited from System.Net.Sockets.Socket)
public Method | SendFile | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | SendPacketsAsync | (Inherited from System.Net.Sockets.Socket)
public Method | SendTo | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | SendToAsync | (Inherited from System.Net.Sockets.Socket)
public Method | SetSocketOption | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | Shutdown | (Inherited from System.Net.Sockets.Socket)
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Net.Sockets.Socket)
Top

See Also

Reference

UdpSocket Class
Dart.Common Namespace


UdpSocket Constructor

[image]
PowerSNMP for .NET CF
UdpSocket Constructor
See Also Send comments on this topic.
Dart.Common Namespace > UdpSocket Class : UdpSocket Constructor

addressFamily
AddressFamily.Internetwork and AddressFamily.InternetworkV6 are supported.
Create a Socket for sending and receiving datagrams.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal addressFamily As AddressFamily _
)
Visual Basic (Usage) Copy Code
Dim addressFamily As AddressFamily

Dim instance As New UdpSocket(addressFamily)
C#
public UdpSocket(
   AddressFamily addressFamily
)
Managed Extensions for C++
public: UdpSocket(
   AddressFamily addressFamily
)
C++/CLI
public:
UdpSocket(
   AddressFamily addressFamily
)

Parameters

addressFamily
AddressFamily.Internetwork and AddressFamily.InternetworkV6 are supported.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UdpSocket Class
UdpSocket Members


UdpSocket Class Methods

[image]
PowerSNMP for .NET CF
UdpSocket Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : UdpSocket Class

"

For a list of all members of this type, see UdpSocket members.

"

Public Methods

 | Name | Description
public Method | Accept | (Inherited from System.Net.Sockets.Socket)
public Method | AcceptAsync | (Inherited from System.Net.Sockets.Socket)
public Method | BeginAccept | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginConnect | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginDisconnect | (Inherited from System.Net.Sockets.Socket)
public Method | BeginReceive | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginReceiveFrom | (Inherited from System.Net.Sockets.Socket)
public Method | BeginReceiveMessageFrom | (Inherited from System.Net.Sockets.Socket)
public Method | BeginSend | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginSendFile | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | BeginSendTo | (Inherited from System.Net.Sockets.Socket)
public Method | Bind | (Inherited from System.Net.Sockets.Socket)
public Method | Close | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | Connect | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | ConnectAsync | (Inherited from System.Net.Sockets.Socket)
public Method | Disconnect | (Inherited from System.Net.Sockets.Socket)
public Method | DisconnectAsync | (Inherited from System.Net.Sockets.Socket)
public Method | DuplicateAndClose | (Inherited from System.Net.Sockets.Socket)
public Method | EndAccept | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | EndConnect | (Inherited from System.Net.Sockets.Socket)
public Method | EndDisconnect | (Inherited from System.Net.Sockets.Socket)
public Method | EndReceive | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | EndReceiveFrom | (Inherited from System.Net.Sockets.Socket)
public Method | EndReceiveMessageFrom | (Inherited from System.Net.Sockets.Socket)
public Method | EndSend | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | EndSendFile | (Inherited from System.Net.Sockets.Socket)
public Method | EndSendTo | (Inherited from System.Net.Sockets.Socket)
public Method | GetSocketOption | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | IOControl | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | Listen | (Inherited from System.Net.Sockets.Socket)
public Method | Poll | (Inherited from System.Net.Sockets.Socket)
public Method | Receive | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | ReceiveAsync | (Inherited from System.Net.Sockets.Socket)
public Method | ReceiveFrom | Overloaded. Read a datagram off the socket. The ReceiveTimeout property controls how long this method will block.
public Method | ReceiveFromAsync | (Inherited from System.Net.Sockets.Socket)
public Method | ReceiveMessageFrom | (Inherited from System.Net.Sockets.Socket)
public Method | ReceiveMessageFromAsync | (Inherited from System.Net.Sockets.Socket)
public Method | Send | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | SendAsync | (Inherited from System.Net.Sockets.Socket)
public Method | SendFile | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | SendPacketsAsync | (Inherited from System.Net.Sockets.Socket)
public Method | SendTo | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | SendToAsync | (Inherited from System.Net.Sockets.Socket)
public Method | SetSocketOption | Overloaded. (Inherited from System.Net.Sockets.Socket)
public Method | Shutdown | (Inherited from System.Net.Sockets.Socket)
Top

Protected Methods

 | Name | Description
protected Method | Dispose | (Inherited from System.Net.Sockets.Socket)
Top

See Also

Reference

UdpSocket Class
Dart.Common Namespace


ReceiveFrom Method

[image]
PowerSNMP for .NET CF
ReceiveFrom Method
See Also Send comments on this topic.
Dart.Common Namespace > UdpSocket Class : ReceiveFrom Method

Read a datagram off the socket. The ReceiveTimeout property controls how long this method will block.

Overload List

Overload | Description
ReceiveFrom(Byte[],EndPoint) | Read a datagram off the socket. The ReceiveTimeout property controls how long this method will block.
ReceiveFrom(Byte[],Int32,Int32,SocketFlags,EndPoint) | (Inherited from System.Net.Sockets.Socket)
ReceiveFrom(Byte[],Int32,SocketFlags,EndPoint) | (Inherited from System.Net.Sockets.Socket)
ReceiveFrom(Byte[],SocketFlags,EndPoint) | (Inherited from System.Net.Sockets.Socket)

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UdpSocket Class
UdpSocket Members


ReceiveFrom(Byte[],EndPoint) Method

[image]
PowerSNMP for .NET CF
ReceiveFrom(Byte[],EndPoint) Method
See Also Send comments on this topic.
Dart.Common Namespace > UdpSocket Class > ReceiveFrom Method : ReceiveFrom(Byte[],EndPoint) Method

buffer
Byte[] to which data will be copied.
remoteEP
The IPEndPoint representing the origin of the datagram.
Read a datagram off the socket. The ReceiveTimeout property controls how long this method will block.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReceiveFrom( _
   ByVal buffer() As Byte, _
   ByRef remoteEP As EndPoint _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As UdpSocket
Dim buffer() As Byte
Dim remoteEP As EndPoint
Dim value As Integer

value = instance.ReceiveFrom(buffer, remoteEP)
C#
public int ReceiveFrom(
   byte[] buffer,
   ref EndPoint remoteEP
)
Managed Extensions for C++
public: int ReceiveFrom(
   byte[]* buffer,
   ref EndPoint* remoteEP
)
C++/CLI
public:
int ReceiveFrom(
   array<byte>^ buffer,
   EndPoint^% remoteEP
)

Parameters

buffer
Byte[] to which data will be copied.
remoteEP
The IPEndPoint representing the origin of the datagram.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UdpSocket Class
UdpSocket Members
Overload List


UdpSocket Class Fields

[image]
PowerSNMP for .NET CF
UdpSocket Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : UdpSocket Class

"

For a list of all members of this type, see UdpSocket members.

"

Public Fields

 | Name | Description
public Field | ReceiveTimeout | Gets or sets a value that specifies the milliseconds after which a synchronous Receive call will time out.
Top

See Also

Reference

UdpSocket Class
Dart.Common Namespace


ReceiveTimeout Field

[image]
PowerSNMP for .NET CF
ReceiveTimeout Field
See Also Send comments on this topic.
Dart.Common Namespace > UdpSocket Class : ReceiveTimeout Field

Gets or sets a value that specifies the milliseconds after which a synchronous Receive call will time out.

Syntax

Visual Basic (Declaration)
Public ReceiveTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As UdpSocket
Dim value As Integer

value = instance.ReceiveTimeout

instance.ReceiveTimeout = value
C#
public int ReceiveTimeout
Managed Extensions for C++
public: int ReceiveTimeout
C++/CLI
public:
int ReceiveTimeout

Property Value

Default value is 0.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UdpSocket Class
UdpSocket Members


UserStateEventArgs Class

[image]
PowerSNMP for .NET CF
UserStateEventArgs Class
Members See Also Send comments on this topic.
Dart.Common Namespace : UserStateEventArgs Class

Provides data for the UserState event.

Object Model

UserStateEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class UserStateEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
C#
public class UserStateEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class UserStateEventArgs : public System.EventArgs
C++/CLI
public ref class UserStateEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Common.UserStateEventArgs
Dart.Snmp.MessageEventArgs
Dart.Snmp.TableEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Members
Dart.Common Namespace


UserStateEventArgs Class Members

[image]
PowerSNMP for .NET CF
UserStateEventArgs Class Members
See Also Fields Send comments on this topic.
Dart.Common Namespace : UserStateEventArgs Class

The following tables list the members exposed by UserStateEventArgs.

Public Constructors

 | Name | Description
public Constructor | UserStateEventArgs Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | UserState | Gets the user information provided by the UserState event.
Top

See Also

Reference

UserStateEventArgs Class
Dart.Common Namespace


UserStateEventArgs Constructor

[image]
PowerSNMP for .NET CF
UserStateEventArgs Constructor
See Also Send comments on this topic.
Dart.Common Namespace > UserStateEventArgs Class : UserStateEventArgs Constructor

Overload List

Overload | Description
UserStateEventArgs Constructor() | Default constructor.
UserStateEventArgs Constructor(Object) | Initializes a new instance of the UserStateEventArgs class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members


UserStateEventArgs Constructor()

[image]
PowerSNMP for .NET CF
UserStateEventArgs Constructor()
See Also Send comments on this topic.
Dart.Common Namespace > UserStateEventArgs Class > UserStateEventArgs Constructor : UserStateEventArgs Constructor()

Default constructor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New UserStateEventArgs()
C#
public UserStateEventArgs()
Managed Extensions for C++
public: UserStateEventArgs();
C++/CLI
public:
UserStateEventArgs();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members
Overload List


UserStateEventArgs Constructor(Object)

[image]
PowerSNMP for .NET CF
UserStateEventArgs Constructor(Object)
See Also Send comments on this topic.
Dart.Common Namespace > UserStateEventArgs Class > UserStateEventArgs Constructor : UserStateEventArgs Constructor(Object)

state
Initializes a new instance of the UserStateEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim state As Object

Dim instance As New UserStateEventArgs(state)
C#
public UserStateEventArgs(
   object state
)
Managed Extensions for C++
public: UserStateEventArgs(
   Object* state
)
C++/CLI
public:
UserStateEventArgs(
   Object^ state
)

Parameters

state

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members
Overload List


UserStateEventArgs Class Fields

[image]
PowerSNMP for .NET CF
UserStateEventArgs Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : UserStateEventArgs Class

"

For a list of all members of this type, see UserStateEventArgs members.

"

Public Fields

 | Name | Description
public Field | UserState | Gets the user information provided by the UserState event.
Top

See Also

Reference

UserStateEventArgs Class
Dart.Common Namespace


UserState Field

[image]
PowerSNMP for .NET CF
UserState Field
See Also Send comments on this topic.
Dart.Common Namespace > UserStateEventArgs Class : UserState Field

Gets the user information provided by the UserState event.

Syntax

Visual Basic (Declaration)
Public ReadOnly UserState As Object
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
Dim value As Object

value = instance.UserState
C#
public readonly object UserState
Managed Extensions for C++
public: readonly Object* UserState
C++/CLI
public:
readonly Object^ UserState

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members


X509CertificateCollection Class

[image]
PowerSNMP for .NET CF
X509CertificateCollection Class
Members See Also Send comments on this topic.
Dart.Common Namespace : X509CertificateCollection Class

A generic list of X509Certificate objects.

Object Model

X509CertificateCollection ClassX509Certificate Class

Syntax

Visual Basic (Declaration)
Public Class X509CertificateCollection
   Inherits System.Collections.Generic.List(Of X509Certificate)
Visual Basic (Usage) Copy Code
Dim instance As X509CertificateCollection
C#
public class X509CertificateCollection : System.Collections.Generic.List<X509Certificate>
Managed Extensions for C++
public __gc class X509CertificateCollection : public System.Collections.Generic.List<X509Certificate>
C++/CLI
public ref class X509CertificateCollection : public System.Collections.Generic.List<X509Certificate>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
Dart.Common.X509CertificateCollection

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509CertificateCollection Members
Dart.Common Namespace


X509CertificateCollection Class Members

[image]
PowerSNMP for .NET CF
X509CertificateCollection Class Members
See Also Properties Methods Send comments on this topic.
Dart.Common Namespace : X509CertificateCollection Class

The following tables list the members exposed by X509CertificateCollection.

Public Constructors

 | Name | Description
public Constructor | X509CertificateCollection Constructor |
Top

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Property | Count | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Property | Item | (Inherited from System.Collections.Generic.List<X509Certificate>)
Top

Public Methods

 | Name | Description
public Method | Add | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | AddRange | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Clear | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Contains | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ConvertAll | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Exists | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Find | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindAll | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindLast | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ForEach | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | GetRange | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Insert | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | InsertRange | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Remove | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveAll | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveAt | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveRange | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ToArray | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | TrimExcess | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | TrueForAll | (Inherited from System.Collections.Generic.List<X509Certificate>)
Top

See Also

Reference

X509CertificateCollection Class
Dart.Common Namespace


X509CertificateCollection Constructor

[image]
PowerSNMP for .NET CF
X509CertificateCollection Constructor
See Also Send comments on this topic.
Dart.Common Namespace > X509CertificateCollection Class : X509CertificateCollection Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New X509CertificateCollection()
C#
public X509CertificateCollection()
Managed Extensions for C++
public: X509CertificateCollection();
C++/CLI
public:
X509CertificateCollection();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509CertificateCollection Class
X509CertificateCollection Members


X509Chain Class

[image]
PowerSNMP for .NET CF
X509Chain Class
Members See Also Send comments on this topic.
Dart.Common Namespace : X509Chain Class

Represents a chain-building engine for X509Certificate certificates. Not implemented.

Object Model

X509Chain Class

Syntax

Visual Basic (Declaration)
Public Class X509Chain
Visual Basic (Usage) Copy Code
Dim instance As X509Chain
C#
public class X509Chain
Managed Extensions for C++
public __gc class X509Chain
C++/CLI
public ref class X509Chain

Inheritance Hierarchy

System.Object
Dart.Common.X509Chain

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Members
Dart.Common Namespace


X509Chain Class Members

[image]
PowerSNMP for .NET CF
X509Chain Class Members
See Also Fields Methods Send comments on this topic.
Dart.Common Namespace : X509Chain Class

The following tables list the members exposed by X509Chain.

Public Constructors

 | Name | Description
public Constructor | X509Chain Constructor |
Top

Public Fields

 | Name | Description
public Field | ChainPolicy | Gets or sets the X509ChainPolicy to use when building an X.509 certificate chain.
public Field | ChainStatus | Gets the status of each element in an X509Chain object.
Top

Public Methods

 | Name | Description
public Method | Build | Builds an X.509 chain using the policy specified in X509ChainPolicy.
Top

See Also

Reference

X509Chain Class
Dart.Common Namespace


X509Chain Constructor

[image]
PowerSNMP for .NET CF
X509Chain Constructor
See Also Send comments on this topic.
Dart.Common Namespace > X509Chain Class : X509Chain Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New X509Chain()
C#
public X509Chain()
Managed Extensions for C++
public: X509Chain();
C++/CLI
public:
X509Chain();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Class
X509Chain Members


X509Chain Class Methods

[image]
PowerSNMP for .NET CF
X509Chain Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : X509Chain Class

"

For a list of all members of this type, see X509Chain members.

"

Public Methods

 | Name | Description
public Method | Build | Builds an X.509 chain using the policy specified in X509ChainPolicy.
Top

See Also

Reference

X509Chain Class
Dart.Common Namespace


Build Method

[image]
PowerSNMP for .NET CF
Build Method
See Also Send comments on this topic.
Dart.Common Namespace > X509Chain Class : Build Method

certificate
Builds an X.509 chain using the policy specified in X509ChainPolicy.

Syntax

Visual Basic (Declaration)
Public Function Build( _
   ByVal certificate As X509Certificate _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As X509Chain
Dim certificate As X509Certificate
Dim value As Boolean

value = instance.Build(certificate)
C#
public bool Build(
   X509Certificate certificate
)
Managed Extensions for C++
public: bool Build(
   X509Certificate* certificate
)
C++/CLI
public:
bool Build(
   X509Certificate^ certificate
)

Parameters

certificate

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Class
X509Chain Members


X509Chain Class Fields

[image]
PowerSNMP for .NET CF
X509Chain Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : X509Chain Class

"

For a list of all members of this type, see X509Chain members.

"

Public Fields

 | Name | Description
public Field | ChainPolicy | Gets or sets the X509ChainPolicy to use when building an X.509 certificate chain.
public Field | ChainStatus | Gets the status of each element in an X509Chain object.
Top

See Also

Reference

X509Chain Class
Dart.Common Namespace


ChainPolicy Field

[image]
PowerSNMP for .NET CF
ChainPolicy Field
See Also Send comments on this topic.
Dart.Common Namespace > X509Chain Class : ChainPolicy Field

Gets or sets the X509ChainPolicy to use when building an X.509 certificate chain.

Syntax

Visual Basic (Declaration)
Public ChainPolicy As X509ChainPolicy
Visual Basic (Usage) Copy Code
Dim instance As X509Chain
Dim value As X509ChainPolicy

value = instance.ChainPolicy

instance.ChainPolicy = value
C#
public X509ChainPolicy ChainPolicy
Managed Extensions for C++
public: X509ChainPolicy* ChainPolicy
C++/CLI
public:
X509ChainPolicy^ ChainPolicy

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Class
X509Chain Members


ChainStatus Field

[image]
PowerSNMP for .NET CF
ChainStatus Field
See Also Send comments on this topic.
Dart.Common Namespace > X509Chain Class : ChainStatus Field

Gets the status of each element in an X509Chain object.

Syntax

Visual Basic (Declaration)
Public ChainStatus As X509ChainStatus()
Visual Basic (Usage) Copy Code
Dim instance As X509Chain
Dim value() As X509ChainStatus

value = instance.ChainStatus

instance.ChainStatus = value
C#
public X509ChainStatus[] ChainStatus
Managed Extensions for C++
public: X509ChainStatus[]* ChainStatus
C++/CLI
public:
array<X509ChainStatus>^ ChainStatus

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509Chain Class
X509Chain Members


X509ChainPolicy Class

[image]
PowerSNMP for .NET CF
X509ChainPolicy Class
Members See Also Send comments on this topic.
Dart.Common Namespace : X509ChainPolicy Class

Represents the chain policy to be applied when building an X509 certificate chain. This class cannot be inherited.

Object Model

X509ChainPolicy Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class X509ChainPolicy
Visual Basic (Usage) Copy Code
Dim instance As X509ChainPolicy
C#
public sealed class X509ChainPolicy
Managed Extensions for C++
public __gc __sealed class X509ChainPolicy
C++/CLI
public ref class X509ChainPolicy sealed

Inheritance Hierarchy

System.Object
Dart.Common.X509ChainPolicy

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainPolicy Members
Dart.Common Namespace


X509ChainPolicy Class Members

[image]
PowerSNMP for .NET CF
X509ChainPolicy Class Members
See Also Fields Send comments on this topic.
Dart.Common Namespace : X509ChainPolicy Class

The following tables list the members exposed by X509ChainPolicy.

Public Constructors

 | Name | Description
public Constructor | X509ChainPolicy Constructor |
Top

Public Fields

 | Name | Description
public Field | RevocationFlag | Gets or sets values for X509 revocation flags.
public Field | RevocationMode | Gets or sets values for X509 certificate revocation mode.
Top

See Also

Reference

X509ChainPolicy Class
Dart.Common Namespace


X509ChainPolicy Constructor

[image]
PowerSNMP for .NET CF
X509ChainPolicy Constructor
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainPolicy Class : X509ChainPolicy Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New X509ChainPolicy()
C#
public X509ChainPolicy()
Managed Extensions for C++
public: X509ChainPolicy();
C++/CLI
public:
X509ChainPolicy();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainPolicy Class
X509ChainPolicy Members


X509ChainPolicy Class Fields

[image]
PowerSNMP for .NET CF
X509ChainPolicy Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : X509ChainPolicy Class

"

For a list of all members of this type, see X509ChainPolicy members.

"

Public Fields

 | Name | Description
public Field | RevocationFlag | Gets or sets values for X509 revocation flags.
public Field | RevocationMode | Gets or sets values for X509 certificate revocation mode.
Top

See Also

Reference

X509ChainPolicy Class
Dart.Common Namespace


RevocationFlag Field

[image]
PowerSNMP for .NET CF
RevocationFlag Field
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainPolicy Class : RevocationFlag Field

Gets or sets values for X509 revocation flags.

Syntax

Visual Basic (Declaration)
Public RevocationFlag As X509RevocationFlag
Visual Basic (Usage) Copy Code
Dim instance As X509ChainPolicy
Dim value As X509RevocationFlag

value = instance.RevocationFlag

instance.RevocationFlag = value
C#
public X509RevocationFlag RevocationFlag
Managed Extensions for C++
public: X509RevocationFlag RevocationFlag
C++/CLI
public:
X509RevocationFlag RevocationFlag

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainPolicy Class
X509ChainPolicy Members


RevocationMode Field

[image]
PowerSNMP for .NET CF
RevocationMode Field
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainPolicy Class : RevocationMode Field

Gets or sets values for X509 certificate revocation mode.

Syntax

Visual Basic (Declaration)
Public RevocationMode As X509RevocationMode
Visual Basic (Usage) Copy Code
Dim instance As X509ChainPolicy
Dim value As X509RevocationMode

value = instance.RevocationMode

instance.RevocationMode = value
C#
public X509RevocationMode RevocationMode
Managed Extensions for C++
public: X509RevocationMode RevocationMode
C++/CLI
public:
X509RevocationMode RevocationMode

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainPolicy Class
X509ChainPolicy Members


CipherAlgorithmType Enumeration

[image]
PowerSNMP for .NET CF
CipherAlgorithmType Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : CipherAlgorithmType Enumeration

Defines the possible cipher algorithms for the SslStream class.

Syntax

Visual Basic (Declaration)
Public Enum CipherAlgorithmType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CipherAlgorithmType
C#
public enum CipherAlgorithmType : System.Enum
Managed Extensions for C++
__value public enum CipherAlgorithmType : public System.Enum
C++/CLI
public enum class CipherAlgorithmType : public System.Enum

Members

Member | Description
Aes | The Advanced Encryption Standard (AES) algorithm.
Aes128 | The Advanced Encryption Standard (AES) algorithm with a 128 bit key.
Aes192 | The Advanced Encryption Standard (AES) algorithm with a 192 bit key.
Aes256 | The Advanced Encryption Standard (AES) algorithm with a 256 bit key.
Des | The Data Encryption Standard (DES) algorithm.
None | No encryption algorithm is used.
Rc2 | Rivest's Code 2 (RC2) algorithm.
Rc4 | Rivest's Code 4 (RC4) algorithm.
TripleDes | The Triple Data Encryption Standard (3DES) algorithm.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.CipherAlgorithmType

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


ExchangeAlgorithmType Enumeration

[image]
PowerSNMP for .NET CF
ExchangeAlgorithmType Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : ExchangeAlgorithmType Enumeration

Specifies the algorithm used to create keys shared by the client and server.

Syntax

Visual Basic (Declaration)
Public Enum ExchangeAlgorithmType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ExchangeAlgorithmType
C#
public enum ExchangeAlgorithmType : System.Enum
Managed Extensions for C++
__value public enum ExchangeAlgorithmType : public System.Enum
C++/CLI
public enum class ExchangeAlgorithmType : public System.Enum

Members

Member | Description
DiffieHellman | The Diffie Hellman ephemeral key exchange algorithm.
None | No key exchange algorithm is used.
RsaKeyX | The RSA public-key exchange algorithm.
RsaSign | The RSA public-key signature algorithm.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.ExchangeAlgorithmType

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


HashAlgorithmType Enumeration

[image]
PowerSNMP for .NET CF
HashAlgorithmType Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : HashAlgorithmType Enumeration

Specifies the algorithm used for generating message authentication codes (MACs).

Syntax

Visual Basic (Declaration)
Public Enum HashAlgorithmType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As HashAlgorithmType
C#
public enum HashAlgorithmType : System.Enum
Managed Extensions for C++
__value public enum HashAlgorithmType : public System.Enum
C++/CLI
public enum class HashAlgorithmType : public System.Enum

Members

Member | Description
Md5 | The Message Digest 5 (MD5) hashing algorithm.
None | No hashing algorithm is used.
Sha1 | The Secure Hashing Algorithm (SHA1).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.HashAlgorithmType

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


SslPolicyErrors Enumeration

[image]
PowerSNMP for .NET CF
SslPolicyErrors Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : SslPolicyErrors Enumeration

Enumerates Secure Socket Layer (SSL) policy errors. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum SslPolicyErrors
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SslPolicyErrors
C#
[FlagsAttribute()]
public enum SslPolicyErrors : System.Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum SslPolicyErrors : public System.Enum
C++/CLI
[FlagsAttribute()]
public enum class SslPolicyErrors : public System.Enum

Members

Member | Description
None | No SSL policy errors.
RemoteCertificateChainErrors | ChainStatus has returned a non empty array.
RemoteCertificateNameMismatch | Certificate name mismatch.
RemoteCertificateNotAvailable | Certificate not available.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.SslPolicyErrors

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


SslProtocols Enumeration

[image]
PowerSNMP for .NET CF
SslProtocols Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : SslProtocols Enumeration

Defines the possible values of SslProtocols.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum SslProtocols
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SslProtocols
C#
[FlagsAttribute()]
public enum SslProtocols : System.Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum SslProtocols : public System.Enum
C++/CLI
[FlagsAttribute()]
public enum class SslProtocols : public System.Enum

Members

Member | Description
Default | Specifies that either Secure Sockets Layer (SSL) 3.0 or Transport Layer Security (TLS) 1.0 are acceptable for secure communications.
None | No SSL encryption is to be used.
Ssl2 | Specifies the SSL 2.0 protocol. SSL 2.0 has been superseded by the TLS protocol and is provided for backward compatibility only.
Ssl3 | Specifies the SSL 3.0 protocol. SSL 3.0 has been superseded by the TLS protocol and is provided for backward compatibility only.
Tls | Specifies the TLS 1.0 security protocol. The TLS protocol is defined in IETF RFC 2246.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.SslProtocols

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


X509ChainStatusFlags Enumeration

[image]
PowerSNMP for .NET CF
X509ChainStatusFlags Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : X509ChainStatusFlags Enumeration

Defines the status of an X509 chain. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum X509ChainStatusFlags
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As X509ChainStatusFlags
C#
[FlagsAttribute()]
public enum X509ChainStatusFlags : System.Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum X509ChainStatusFlags : public System.Enum
C++/CLI
[FlagsAttribute()]
public enum class X509ChainStatusFlags : public System.Enum

Members

Member | Description
CtlNotSignatureValid | Specifies that the certificate trust list (CTL) contains an invalid signature.
CtlNotTimeValid | Specifies that the certificate trust list (CTL) is not valid because of an invalid time value, such as one that indicates that the CTL has expired.
CtlNotValidForUsage | Specifies that the certificate trust list (CTL) is not valid for this use.
Cyclic | Specifies that the X509 chain could not be built.
HasExcludedNameConstraint | Specifies that the X509 chain is invalid because a certificate has excluded a name constraint.
HasNotDefinedNameConstraint | Specifies that the certificate has an undefined name constant.
HasNotPermittedNameConstraint | Specifies that the certificate has an impermissible name constraint.
HasNotSupportedNameConstraint | Specifies that the certificate does not have a supported name constant or has a name constant that is unsupported.
InvalidBasicConstraints | Specifies that the X509 chain is invalid due to invalid basic constraints.
InvalidExtension | Specifies that the X509 chain is invalid due to an invalid extension.
InvalidNameConstraints | Specifies that the X509 chain is invalid due to invalid name constraints.
InvalidPolicyConstraints | Specifies that the X509 chain is invalid due to invalid policy constraints.
NoError | Specifies that the X509 chain has no errors.
NoIssuanceChainPolicy | Specifies that there is no certificate policy extension in the certificate. This error would occur if a group policy has specified that all certificates must have a certificate policy.
NotSignatureValid | Specifies that the X509 chain is invalid due to an invalid certificate signature.
NotTimeNested | Specifies that the CA (certificate authority) certificate and the issued certificate have validity periods that are not nested. For example, the CA cert can be valid from January 1 to December 1 and the issued certificate from January 2 to December 2, which would mean the validity periods are not nested.
NotTimeValid | Specifies that the X509 chain is not valid due to an invalid time value, such as a value that indicates an expired certificate.
NotValidForUsage | Specifies that the key usage is not valid.
OfflineRevocation | Specifies that the online certificate revocation list (CRL) the X509 chain relies on is currently offline.
PartialChain | Specifies that the X509 chain could not be built up to the root certificate.
RevocationStatusUnknown | Specifies that it is not possible to determine whether the certificate has been revoked. This can be due to the certificate revocation list (CRL) being offline or unavailable.
Revoked | Specifies that the X509 chain is invalid due to a revoked certificate.
UntrustedRoot | Specifies that the X509 chain is invalid due to an untrusted root certificate.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.X509ChainStatusFlags

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


X509RevocationFlag Enumeration

[image]
PowerSNMP for .NET CF
X509RevocationFlag Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : X509RevocationFlag Enumeration

Specifies which X509 certificates in the chain should be checked for revocation.

Syntax

Visual Basic (Declaration)
Public Enum X509RevocationFlag
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As X509RevocationFlag
C#
public enum X509RevocationFlag : System.Enum
Managed Extensions for C++
__value public enum X509RevocationFlag : public System.Enum
C++/CLI
public enum class X509RevocationFlag : public System.Enum

Members

Member | Description
EndCertificateOnly | Only the end certificate is checked for revocation.
EntireChain | The entire chain of certificates is checked for revocation.
ExcludeRoot | The entire chain, except the root certificate, is checked for revocation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.X509RevocationFlag

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


X509RevocationMode Enumeration

[image]
PowerSNMP for .NET CF
X509RevocationMode Enumeration
See Also Send comments on this topic.
Dart.Common Namespace : X509RevocationMode Enumeration

Specifies the mode used to check for X509 certificate revocation.

Syntax

Visual Basic (Declaration)
Public Enum X509RevocationMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As X509RevocationMode
C#
public enum X509RevocationMode : System.Enum
Managed Extensions for C++
__value public enum X509RevocationMode : public System.Enum
C++/CLI
public enum class X509RevocationMode : public System.Enum

Members

Member | Description
NoCheck | No revocation check is performed on the certificate.
Offline | A revocation check is made using a cached certificate revocation list (CRL).
Online | A revocation check is made using an online certificate revocation list (CRL).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Common.X509RevocationMode

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Common Namespace


X509ChainStatus Structure

[image]
PowerSNMP for .NET CF
X509ChainStatus Structure
Members See Also Send comments on this topic.
Dart.Common Namespace : X509ChainStatus Structure

Provides a simple structure for storing X509 chain status and error information.

Object Model

X509ChainStatus Structure

Syntax

Visual Basic (Declaration)
Public Structure X509ChainStatus
   Inherits System.ValueType
Visual Basic (Usage) Copy Code
Dim instance As X509ChainStatus
C#
public struct X509ChainStatus : System.ValueType
Managed Extensions for C++
public __value struct X509ChainStatus : public System.ValueType
C++/CLI
public value class X509ChainStatus : public System.ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Dart.Common.X509ChainStatus

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainStatus Members
Dart.Common Namespace


X509ChainStatus Structure Members

[image]
PowerSNMP for .NET CF
X509ChainStatus Structure Members
See Also Fields Send comments on this topic.
Dart.Common Namespace : X509ChainStatus Structure

"

The following tables list the members exposed by X509ChainStatus.

"

Public Fields

 | Name | Description
public Field | Status | Specifies the status of the X509 chain.
public Field | StatusInformation | Specifies a description of the ChainStatus value.
Top

See Also

Reference

X509ChainStatus Structure
Dart.Common Namespace


X509ChainStatus Structure Fields

[image]
PowerSNMP for .NET CF
X509ChainStatus Structure Fields
See Also Send comments on this topic.
Dart.Common Namespace : X509ChainStatus Structure

"

For a list of all members of this type, see X509ChainStatus members.

"

Public Fields

 | Name | Description
public Field | Status | Specifies the status of the X509 chain.
public Field | StatusInformation | Specifies a description of the ChainStatus value.
Top

See Also

Reference

X509ChainStatus Structure
Dart.Common Namespace


Status Field

[image]
PowerSNMP for .NET CF
Status Field
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainStatus Structure : Status Field

Specifies the status of the X509 chain.

Syntax

Visual Basic (Declaration)
Public Status As X509ChainStatusFlags
Visual Basic (Usage) Copy Code
Dim instance As X509ChainStatus
Dim value As X509ChainStatusFlags

value = instance.Status

instance.Status = value
C#
public X509ChainStatusFlags Status
Managed Extensions for C++
public: X509ChainStatusFlags Status
C++/CLI
public:
X509ChainStatusFlags Status

Remarks

The flag can be used to determine the details of a chain error.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainStatus Structure
X509ChainStatus Members


StatusInformation Field

[image]
PowerSNMP for .NET CF
StatusInformation Field
See Also Send comments on this topic.
Dart.Common Namespace > X509ChainStatus Structure : StatusInformation Field

Specifies a description of the ChainStatus value.

Syntax

Visual Basic (Declaration)
Public StatusInformation As String
Visual Basic (Usage) Copy Code
Dim instance As X509ChainStatus
Dim value As String

value = instance.StatusInformation

instance.StatusInformation = value
C#
public string StatusInformation
Managed Extensions for C++
public: string* StatusInformation
C++/CLI
public:
String^ StatusInformation

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

X509ChainStatus Structure
X509ChainStatus Members


ComponentErrorEventHandler Delegate

[image]
PowerSNMP for .NET CF
ComponentErrorEventHandler Delegate
See Also Send comments on this topic.
Dart.Common Namespace : ComponentErrorEventHandler Delegate

sender
The source of the event.
e
A ComponentsErrorEventArgs that contains error arguments.
Represents the method that will handle an event raised due to an component error.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ComponentErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As ComponentErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ComponentErrorEventHandler(AddressOf HandlerMethod)
C#
public delegate void ComponentErrorEventHandler(
   object sender,
   ComponentErrorEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ComponentErrorEventHandler(
   Object* sender,
   ComponentErrorEventArgs* e
)
C++/CLI
public delegate void ComponentErrorEventHandler(
   Object^ sender,
   ComponentErrorEventArgs^ e
)

Parameters

sender
The source of the event.
e
A ComponentsErrorEventArgs that contains error arguments.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ComponentErrorEventHandler Members
Dart.Common Namespace


LocalCertificateSelectionCallback Delegate

[image]
PowerSNMP for .NET CF
LocalCertificateSelectionCallback Delegate
See Also Send comments on this topic.
Dart.Common Namespace : LocalCertificateSelectionCallback Delegate

sender
An object that contains state information for this validation.
targetHost
The host server specified by the client.
localCertificates
An X509CertificateCollection containing local certificates.
remoteCertificate
The certificate used to authenticate the remote party.
acceptableIssuers
A String array of certificate issuers acceptable to the remote party.
Selects the local Secure Sockets Layer (SSL) certificate used for authentication.

Syntax

Visual Basic (Declaration)
Public Delegate Function LocalCertificateSelectionCallback( _
   ByVal sender As Object, _
   ByVal targetHost As String, _
   ByVal localCertificates As X509CertificateCollection, _
   ByVal remoteCertificate As X509Certificate, _
   ByVal acceptableIssuers() As String _
) As X509Certificate
Visual Basic (Usage) Copy Code
Dim instance As New LocalCertificateSelectionCallback(AddressOf HandlerMethod)
C#
public delegate X509Certificate LocalCertificateSelectionCallback(
   object sender,
   string targetHost,
   X509CertificateCollection localCertificates,
   X509Certificate remoteCertificate,
   string[] acceptableIssuers
)
Managed Extensions for C++
public: __gc __delegate X509Certificate* LocalCertificateSelectionCallback(
   Object* sender,
   string* targetHost,
   X509CertificateCollection* localCertificates,
   X509Certificate* remoteCertificate,
   string*[]* acceptableIssuers
)
C++/CLI
public delegate X509Certificate^ LocalCertificateSelectionCallback(
   Object^ sender,
   String^ targetHost,
   X509CertificateCollection^ localCertificates,
   X509Certificate^ remoteCertificate,
   array<String^>^ acceptableIssuers
)

Parameters

sender
An object that contains state information for this validation.
targetHost
The host server specified by the client.
localCertificates
An X509CertificateCollection containing local certificates.
remoteCertificate
The certificate used to authenticate the remote party.
acceptableIssuers
A String array of certificate issuers acceptable to the remote party.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

LocalCertificateSelectionCallback Members
Dart.Common Namespace


RemoteCertificateValidationCallback Delegate

[image]
PowerSNMP for .NET CF
RemoteCertificateValidationCallback Delegate
See Also Send comments on this topic.
Dart.Common Namespace : RemoteCertificateValidationCallback Delegate

sender
An object that contains state information for this validation.
certificate
The certificate used to authenticate the remote party.
chain
The chain of certificate authorities associated with the remote certificate. Not implemented (always null).
sslPolicyErrors
One or more errors associated with the remote certificate.
Verifies the remote Secure Sockets Layer (SSL) certificate used for authentication.

Syntax

Visual Basic (Declaration)
Public Delegate Function RemoteCertificateValidationCallback( _
   ByVal sender As Object, _
   ByVal certificate As X509Certificate, _
   ByVal chain As X509Chain, _
   ByVal sslPolicyErrors As SslPolicyErrors _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As New RemoteCertificateValidationCallback(AddressOf HandlerMethod)
C#
public delegate bool RemoteCertificateValidationCallback(
   object sender,
   X509Certificate certificate,
   X509Chain chain,
   SslPolicyErrors sslPolicyErrors
)
Managed Extensions for C++
public: __gc __delegate bool RemoteCertificateValidationCallback(
   Object* sender,
   X509Certificate* certificate,
   X509Chain* chain,
   SslPolicyErrors sslPolicyErrors
)
C++/CLI
public delegate bool RemoteCertificateValidationCallback(
   Object^ sender,
   X509Certificate^ certificate,
   X509Chain^ chain,
   SslPolicyErrors sslPolicyErrors
)

Parameters

sender
An object that contains state information for this validation.
certificate
The certificate used to authenticate the remote party.
chain
The chain of certificate authorities associated with the remote certificate. Not implemented (always null).
sslPolicyErrors
One or more errors associated with the remote certificate.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

RemoteCertificateValidationCallback Members
Dart.Common Namespace


UserStateEventHandler Delegate

[image]
PowerSNMP for .NET CF
UserStateEventHandler Delegate
See Also Send comments on this topic.
Dart.Common Namespace : UserStateEventHandler Delegate

sender
The source of the event.
e
A UserStateEventArgs that contains user data.
Represents the method that will handle an event raised by the user calling Marshal.

Syntax

Visual Basic (Declaration)
Public Delegate Sub UserStateEventHandler( _
   ByVal sender As Object, _
   ByVal e As UserStateEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New UserStateEventHandler(AddressOf HandlerMethod)
C#
public delegate void UserStateEventHandler(
   object sender,
   UserStateEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void UserStateEventHandler(
   Object* sender,
   UserStateEventArgs* e
)
C++/CLI
public delegate void UserStateEventHandler(
   Object^ sender,
   UserStateEventArgs^ e
)

Parameters

sender
The source of the event.
e
A UserStateEventArgs that contains user data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UserStateEventHandler Members
Dart.Common Namespace


Dart.Snmp Namespace

Dart.Snmp Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Classes

 | Class | Description
Class | Agent | A communications component that can be configured as a version 1, 2 or 3 SNMP agent.
Class | AuthoritativeEngine | Holds authoritative engine information that is used by SNMPv3 authentication processing.
Class | DecodingException | A DecodingException is thrown when there is an error decoding the encoded message.
Class | DiscoveredEngine | Holds authoritative engine information that is used by SNMPv3 authentication processing.
Class | GetBulkMessage | The GetBulkMessage class can be used to request large amounts of information from SNMP version 2/3 agents.
Class | GetMessage | The GetMessage class is the class used to request information about IIDs from an SNMP agent.
Class | GetNextMessage | The GetNextMessage class is used to request information about IIDs from an SNMP agent while discovering what IIDs that agent manages.
Class | InformMessage | The InformMessage class is used to send information between SNMP version 2/ 3 managers.
Class | Manager | Specializes UDP communications for SNMP Manager functionality.
Class | ManagerSlave | The ManagerSlave class provides Manager communications that can be invoked in parallel, all running on unique worker threads.
Class | MessageBase | The MessageBase class is the abstract base class for all SNMP messages.
Class | MessageEventArgs | Provides data for the SnmpBase.Message event.
Class | MibDefinition | Base class containing members that are common to MibNode and MibTrap.
Class | MibNode | This class is used to represent nodes and objects defined in MIB files.
Class | MibNodes | The MibNodes Class localizes all mib file management to a single class.
Class | MibTrap | This class is used to represent traps defined in MIB files.
Class | MibTraps | A collection of trap types.
Class | Module | Contains all names either imported or defined within a module.
Class | NotificationMessage | The NotificationMessage class is used by agents to notify managers of an event. It uses SNMP version 2/3 and is the functional equivalent of the TrapMessage used by SNMP version 1.
Class | Passwords | Provides passwords used to authenticate and decrypt SNMP version 3 packets.
Class | ReportMessage | The ReportMessage class is used to send user-defined information.
Class | RequestMessage | The RequestMessage class is the base class for all request messages: SetMessage, GetMessage, GetNextMessage, GetBulkMessage and InformMessage.
Class | ResponseMessage | The ResponseMessage class is used to send information about IIDs from an SNMP agent to a manager .
Class | Security | This class controls Version 3 authentication and privacy procedures.
Class | SecurityException | A SecurityException is thrown by the Manager when it is notified that a request failed to be authenticated by the agent.
Class | Sequence | A tagged type representing a sequence of tagged types.
Class | SequenceOf | A tagged type representing a sequence of tagged types that are ordered and of the same type.
Class | SetMessage | The SetMessage class is used to send update information from an SNMP version 1/2/3 manager to an agent.
Class | SetOf | A tagged type representing a sequence of tagged types that are of the same type.
Class | SimpleTaggedType | The SimpleTaggedType class is the base class for all encoded value types in an SNMP message.
Class | SnmpBase | SnmpBase is the base class used by Agent and Manager for common functionality.
Class | StandardMessage | The StandardMessage Class is the base class for all SNMP messages except TrapMessage.
Class | TableEventArgs | Provides data for the Table event.
Class | TaggedType | The TaggedType class is the base class for the SimpleTaggedType class.
Class | TrapMessage | The TrapMessage class is used to send SNMP version 1 traps from an agent to a manager.
Class | Variable | A Sequence that contains an instance of the Id class and an instance of the SimpleTaggedType class.
Class | VariableCollection | A Sequence that contains a collection of Variable objects.
Class | VariableList | Used to hold the MIB data managed by the Agent.

Delegates

 | Delegate | Description
Delegate | AgentMessageReceived | Represents the method that will be called as each RequestMessage is received.
Delegate | ManagerMessageReceived | Represents the method that will be called as asynchronous messages are received.
Delegate | MessageEventHandler | Represents the method that will handle an event raised by the user calling SnmpBase.Marshal.
Delegate | SlaveThreadStart | Represents the method that will be called on a new worker thread.
Delegate | TableEventHandler | Represents the method that will handle an event raised by the user calling Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object).

Enumerations

 | Enumeration | Description
Enumeration | Access | Defines the operation allowed to a MibNode object.
Enumeration | AuthenticationProtocol | Defines the algorithm to be used for Version 3 message authentication.
Enumeration | ErrorCode | Defines the possible ErrorCode values returned in DecodingException.
Enumeration | ErrorStatus | Defines the possible values returned in ResponseMessage.ErrorStatus
Enumeration | Language | Defines the programming language used to output generated classes that derive from MibNode.
Enumeration | NodeName | Defines the names of all the intrinsic MibNode names that can be used to lookup MibNode instances in the MibNodes dictionary.
Enumeration | PrivacyProtocol | Defines the algorithm to be used for Version 3 message encryption.
Enumeration | SecurityErrorCode | Defines the possible values of SecurityException.ErrorCode.
Enumeration | SnmpVersion | Defines the possible Version values in MessageBase.
Enumeration | Status | Defines the current implementation status of the MibNode object.
Enumeration | TrapName | Defines the names of all the intrinsic trap names that can be used to lookup MibTrap instances in the MibNodes.MibTraps dictionary.
Enumeration | Usage | Indicates the Usage of each class derived from MibNode.

See Also

Reference

Dart.Snmp.CF Assembly


Agent Class

[image]
PowerSNMP for .NET CF
Agent Class
Members Example See Also Send comments on this topic.
Dart.Snmp Namespace : Agent Class

A communications component that can be configured as a version 1, 2 or 3 SNMP agent.

Object Model

Agent Class

Syntax

Visual Basic (Declaration)
Public Class Agent
   Inherits SnmpBase
Visual Basic (Usage) Copy Code
Dim instance As Agent
C#
public class Agent : SnmpBase
Managed Extensions for C++
public __gc class Agent : public SnmpBase
C++/CLI
public ref class Agent : public SnmpBase

Example

The following example demonstrates starting a simple agent supporting a MIB variable.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Add variable to agent
    agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace");
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"));

    //Start listening for requests
    agent1.Start(agent1_MessageReceived, null);
}

private void agent1_MessageReceived(Agent agent, RequestMessage request, object state)
{
    //Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    'Add variable to agent
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"))

    'Start listening for requests
    agent1.Start(agent1_MessageReceived, Nothing)
End Sub

Private Sub agent1_MessageReceived(ByVal agent As Agent, ByVal request As RequestMessage, ByVal state As Object)
    'Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin)
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Snmp.SnmpBase
Dart.Snmp.Agent

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Members
Dart.Snmp Namespace


Agent Class Members

[image]
PowerSNMP for .NET CF
Agent Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Snmp Namespace : Agent Class

The following tables list the members exposed by Agent.

Public Constructors

 | Name | Description
public Constructor | Agent Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | AuthoritativeEngine | Used to store EngineId, EngineTime, and EngineBoot values used for SNMPv3 authentication. (Inherited from Dart.Snmp.SnmpBase)
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | LocalEndPoint | Used to specify the local address, port, and address family. (Inherited from Dart.Snmp.SnmpBase)
public Field | Mib | Gets the MibNodes object containing MIB definitions. (Inherited from Dart.Snmp.SnmpBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
public Field | Variables | A VariableList of Variable objects used to populate default response messages.
Top

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | Close | Terminates Agent or Trap operation by releasing communication resources. (Inherited from Dart.Snmp.SnmpBase)
public Method | CreateDefaultResponse | Creates a default ResponseMessage from the RequestMessage received. This method can be used to handle SNMPv3 discovery packets.
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals SNMP messages to the UI thread. (Inherited from Dart.Snmp.SnmpBase)
public Method | Send | Overloaded. Send a message to the SNMP manager specified.
public Method | Start | Starts a worker thread on which the specified delegate is called each time a RequestMessage is received.
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnMessage | Called on the UI thread when SnmpBase.Marshal is used. (Inherited from Dart.Snmp.SnmpBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Message | The Message event is raised when SnmpBase.Marshal is used. (Inherited from Dart.Snmp.SnmpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Agent Class
Dart.Snmp Namespace


Agent Constructor

[image]
PowerSNMP for .NET CF
Agent Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > Agent Class : Agent Constructor

Overload List

Overload | Description
Agent Constructor(IContainer) | Initializes a new instance of the Agent component.
Agent Constructor() | Initializes a new instance of the Agent component.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Class
Agent Members


Agent Constructor(IContainer)

[image]
PowerSNMP for .NET CF
Agent Constructor(IContainer)
See Also Send comments on this topic.
Dart.Snmp Namespace > Agent Class > Agent Constructor : Agent Constructor(IContainer)

container
An object that implements IContainer. The Agent component adds itself to this container so it will not be disposed of until the container is disposed of.
Initializes a new instance of the Agent component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Agent(container)
C#
public Agent(
   IContainer container
)
Managed Extensions for C++
public: Agent(
   IContainer* container
)
C++/CLI
public:
Agent(
   IContainer^ container
)

Parameters

container
An object that implements IContainer. The Agent component adds itself to this container so it will not be disposed of until the container is disposed of.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Class
Agent Members
Overload List


Agent Constructor()

[image]
PowerSNMP for .NET CF
Agent Constructor()
See Also Send comments on this topic.
Dart.Snmp Namespace > Agent Class > Agent Constructor : Agent Constructor()

Initializes a new instance of the Agent component.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Agent()
C#
public Agent()
Managed Extensions for C++
public: Agent();
C++/CLI
public:
Agent();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Class
Agent Members
Overload List


Agent Class Methods

[image]
PowerSNMP for .NET CF
Agent Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : Agent Class

"

For a list of all members of this type, see Agent members.

"

Public Methods

 | Name | Description
public Method | Close | Terminates Agent or Trap operation by releasing communication resources. (Inherited from Dart.Snmp.SnmpBase)
public Method | CreateDefaultResponse | Creates a default ResponseMessage from the RequestMessage received. This method can be used to handle SNMPv3 discovery packets.
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals SNMP messages to the UI thread. (Inherited from Dart.Snmp.SnmpBase)
public Method | Send | Overloaded. Send a message to the SNMP manager specified.
public Method | Start | Starts a worker thread on which the specified delegate is called each time a RequestMessage is received.
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnMessage | Called on the UI thread when SnmpBase.Marshal is used. (Inherited from Dart.Snmp.SnmpBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Agent Class
Dart.Snmp Namespace


CreateDefaultResponse Method

[image]
PowerSNMP for .NET CF
CreateDefaultResponse Method
See Also Send comments on this topic.
Dart.Snmp Namespace > Agent Class : CreateDefaultResponse Method

request
The received RequestMessage.
Creates a default ResponseMessage from the RequestMessage received. This method can be used to handle SNMPv3 discovery packets.

Syntax

Visual Basic (Declaration)
Public Function CreateDefaultResponse( _
   ByVal request As RequestMessage _
) As ResponseMessage
Visual Basic (Usage) Copy Code
Dim instance As Agent
Dim request As RequestMessage
Dim value As ResponseMessage

value = instance.CreateDefaultResponse(request)
C#
public ResponseMessage CreateDefaultResponse(
   RequestMessage request
)
Managed Extensions for C++
public: ResponseMessage* CreateDefaultResponse(
   RequestMessage* request
)
C++/CLI
public:
ResponseMessage^ CreateDefaultResponse(
   RequestMessage^ request
)

Parameters

request
The received RequestMessage.

Return Value

The ResponseMessage created based on the RequestMessage.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Class
Agent Members


Send Method

[image]
PowerSNMP for .NET CF
Send Method
See Also Send comments on this topic.
Dart.Snmp Namespace > Agent Class : Send Method

Send a message to the SNMP manager specified.

Overload List

Overload | Description
Send(MessageBase,String) | Send a message to the SNMP manager specified.
Send(MessageBase,String,Int32) | Send a message to the SNMP manager specified.
Send | Send a message to the SNMP manager specified. (Inherited from Dart.Snmp.SnmpBase)

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Class
Agent Members


Send(MessageBase,String) Method

[image]
PowerSNMP for .NET CF
Send(MessageBase,String) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > Agent Class > Send Method : Send(MessageBase,String) Method

message
An instance of a ResponseMessage, ReportMessage, TrapMessage or NotificationMessage.
hostNameOrAddress
The name or IP address (in dot notation) of the target SNMP manager.
Send a message to the SNMP manager specified.

Syntax

Visual Basic (Declaration)
Public Overloads Function Send( _
   ByVal message As MessageBase, _
   ByVal hostNameOrAddress As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Agent
Dim message As MessageBase
Dim hostNameOrAddress As String
Dim value As Integer

value = instance.Send(message, hostNameOrAddress)
C#
public int Send(
   MessageBase message,
   string hostNameOrAddress
)
Managed Extensions for C++
public: int Send(
   MessageBase* message,
   string* hostNameOrAddress
)
C++/CLI
public:
int Send(
   MessageBase^ message,
   String^ hostNameOrAddress
)

Parameters

message
An instance of a ResponseMessage, ReportMessage, TrapMessage or NotificationMessage.
hostNameOrAddress
The name or IP address (in dot notation) of the target SNMP manager.

Exceptions

Exception | Description
System.Net.Sockets.SocketException | A problem occurred with network resources.
System.InvalidOperationException | The provided message parameter is not a ResponseMessage, ReportMessage, TrapMessage or NotificationMessage.

Example

The following example demonstrates starting a simple agent supporting a MIB variable.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Add variable to agent
    agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace");
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"));

    //Start listening for requests
    agent1.Start(agent1_MessageReceived, null);
}

private void agent1_MessageReceived(Agent agent, RequestMessage request, object state)
{
    //Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    'Add variable to agent
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"))

    'Start listening for requests
    agent1.Start(agent1_MessageReceived, Nothing)
End Sub

Private Sub agent1_MessageReceived(ByVal agent As Agent, ByVal request As RequestMessage, ByVal state As Object)
    'Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin)
End Sub

Remarks

The default trap/notification port of 162 is used.

The EncodedMessage property of the message is updated with the encoded message actually sent.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Class
Agent Members
Overload List


Send(MessageBase,String,Int32) Method

[image]
PowerSNMP for .NET CF
Send(MessageBase,String,Int32) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > Agent Class > Send Method : Send(MessageBase,String,Int32) Method

message
An instance of a ResponseMessage, ReportMessage, TrapMessage or NotificationMessage.
hostNameOrAddress
The name or IP address (in dot notation) of the target SNMP manager.
port
May be used to specify a port other than the default port of 162. Managers may be configured to listen for traps on non-default ports.
Send a message to the SNMP manager specified.

Syntax

Visual Basic (Declaration)
Public Overloads Function Send( _
   ByVal message As MessageBase, _
   ByVal hostNameOrAddress As String, _
   ByVal port As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Agent
Dim message As MessageBase
Dim hostNameOrAddress As String
Dim port As Integer
Dim value As Integer

value = instance.Send(message, hostNameOrAddress, port)
C#
public int Send(
   MessageBase message,
   string hostNameOrAddress,
   int port
)
Managed Extensions for C++
public: int Send(
   MessageBase* message,
   string* hostNameOrAddress,
   int port
)
C++/CLI
public:
int Send(
   MessageBase^ message,
   String^ hostNameOrAddress,
   int port
)

Parameters

message
An instance of a ResponseMessage, ReportMessage, TrapMessage or NotificationMessage.
hostNameOrAddress
The name or IP address (in dot notation) of the target SNMP manager.
port
May be used to specify a port other than the default port of 162. Managers may be configured to listen for traps on non-default ports.

Exceptions

Exception | Description
System.Net.Sockets.SocketException | A problem occurred with network resources.
System.InvalidOperationException | The provided message parameter is not a ResponseMessage, ReportMessage, TrapMessage or NotificationMessage.

Example

The following example demonstrates starting a simple agent supporting a MIB variable.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Add variable to agent
    agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace");
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"));

    //Start listening for requests
    agent1.Start(agent1_MessageReceived, null);
}

private void agent1_MessageReceived(Agent agent, RequestMessage request, object state)
{
    //Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    'Add variable to agent
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"))

    'Start listening for requests
    agent1.Start(agent1_MessageReceived, Nothing)
End Sub

Private Sub agent1_MessageReceived(ByVal agent As Agent, ByVal request As RequestMessage, ByVal state As Object)
    'Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin)
End Sub

Remarks

The EncodedMessage property of the message is updated with the encoded message actually sent.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Class
Agent Members
Overload List


Start Method

[image]
PowerSNMP for .NET CF
Start Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > Agent Class : Start Method

worker
AgentMessageReceived delegate specifying the function to execute.
state
Information to pass to the worker function; can be null.
Starts a worker thread on which the specified delegate is called each time a RequestMessage is received.

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As AgentMessageReceived, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Agent
Dim worker As AgentMessageReceived
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   AgentMessageReceived worker,
   object state
)
Managed Extensions for C++
public: void Start(
   AgentMessageReceived* worker,
   Object* state
)
C++/CLI
public:
void Start(
   AgentMessageReceived^ worker,
   Object^ state
)

Parameters

worker
AgentMessageReceived delegate specifying the function to execute.
state
Information to pass to the worker function; can be null.

Example

The following example demonstrates starting a simple agent supporting a MIB variable.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Add variable to agent
    agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace");
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"));

    //Start listening for requests
    agent1.Start(agent1_MessageReceived, null);
}

private void agent1_MessageReceived(Agent agent, RequestMessage request, object state)
{
    //Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    'Add variable to agent
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"))

    'Start listening for requests
    agent1.Start(agent1_MessageReceived, Nothing)
End Sub

Private Sub agent1_MessageReceived(ByVal agent As Agent, ByVal request As RequestMessage, ByVal state As Object)
    'Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin)
End Sub

Remarks

This method provides a convenient means for receiving SNMP request messages on a worker thread, and should be used to receive and respond to SNMP requests.

The state parameter can be null when no state information is passed to the worker delegate function.

Unhandled exceptions occurring on the worker thread are caught and reported in the ComponentBase.Error event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Class
Agent Members


Agent Class Fields

[image]
PowerSNMP for .NET CF
Agent Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : Agent Class

"

For a list of all members of this type, see Agent members.

"

Public Fields

 | Name | Description
public Field | AuthoritativeEngine | Used to store EngineId, EngineTime, and EngineBoot values used for SNMPv3 authentication. (Inherited from Dart.Snmp.SnmpBase)
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | LocalEndPoint | Used to specify the local address, port, and address family. (Inherited from Dart.Snmp.SnmpBase)
public Field | Mib | Gets the MibNodes object containing MIB definitions. (Inherited from Dart.Snmp.SnmpBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
public Field | Variables | A VariableList of Variable objects used to populate default response messages.
Top

See Also

Reference

Agent Class
Dart.Snmp Namespace


Variables Field

[image]
PowerSNMP for .NET CF
Variables Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Agent Class : Variables Field

A VariableList of Variable objects used to populate default response messages.

Syntax

Visual Basic (Declaration)
Public Variables As VariableList
Visual Basic (Usage) Copy Code
Dim instance As Agent
Dim value As VariableList

value = instance.Variables

instance.Variables = value
C#
public VariableList Variables
Managed Extensions for C++
public: VariableList* Variables
C++/CLI
public:
VariableList^ Variables

Example

The following example demonstrates starting a simple agent supporting a MIB variable.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Add variable to agent
    agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace");
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"));

    //Start listening for requests
    agent1.Start(agent1_MessageReceived, null);
}

private void agent1_MessageReceived(Agent agent, RequestMessage request, object state)
{
    //Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    'Add variable to agent
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"))

    'Start listening for requests
    agent1.Start(agent1_MessageReceived, Nothing)
End Sub

Private Sub agent1_MessageReceived(ByVal agent As Agent, ByVal request As RequestMessage, ByVal state As Object)
    'Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin)
End Sub

Remarks

When a SetMessage arrives, the Variable values are updated with information sent by the manager. When a GetMessage arrives, the Variable values are used to intialize the default ResponseMessage. If the Variable values contain OIDs that are in Mib, then the MibNode.Access property is checked for read-write access priviledges to the Agent.Variables list, and the ResponseMessage is constructed accordingly.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Agent Class
Agent Members


AuthoritativeEngine Class

[image]
PowerSNMP for .NET CF
AuthoritativeEngine Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : AuthoritativeEngine Class

Holds authoritative engine information that is used by SNMPv3 authentication processing.

Object Model

AuthoritativeEngine Class

Syntax

Visual Basic (Declaration)
Public Class AuthoritativeEngine
Visual Basic (Usage) Copy Code
Dim instance As AuthoritativeEngine
C#
public class AuthoritativeEngine
Managed Extensions for C++
public __gc class AuthoritativeEngine
C++/CLI
public ref class AuthoritativeEngine

Inheritance Hierarchy

System.Object
Dart.Snmp.AuthoritativeEngine

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AuthoritativeEngine Members
Dart.Snmp Namespace


AuthoritativeEngine Class Members

[image]
PowerSNMP for .NET CF
AuthoritativeEngine Class Members
See Also Fields Properties Send comments on this topic.
Dart.Snmp Namespace : AuthoritativeEngine Class

The following tables list the members exposed by AuthoritativeEngine.

Public Constructors

 | Name | Description
public Constructor | AuthoritativeEngine Constructor |
Top

Public Fields

 | Name | Description
public Field | Boots | Used to get and set the number of boots the authoritative engine wishes to report.
public Field | Id | Used to get and set a byte array that identifies the SNMP engine.
public Field | StartTime | Used to get and set the starting time of the authoritative engine.
public Field | Users | A table of authorized SNMP version 3 users with associated passwords.
Top

Public Properties

 | Name | Description
public Property | Time | Gets the number of seconds since StartTime.
Top

See Also

Reference

AuthoritativeEngine Class
Dart.Snmp Namespace


AuthoritativeEngine Constructor

[image]
PowerSNMP for .NET CF
AuthoritativeEngine Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > AuthoritativeEngine Class : AuthoritativeEngine Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New AuthoritativeEngine()
C#
public AuthoritativeEngine()
Managed Extensions for C++
public: AuthoritativeEngine();
C++/CLI
public:
AuthoritativeEngine();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AuthoritativeEngine Class
AuthoritativeEngine Members


AuthoritativeEngine Class Properties

[image]
PowerSNMP for .NET CF
AuthoritativeEngine Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : AuthoritativeEngine Class

"

For a list of all members of this type, see AuthoritativeEngine members.

"

Public Properties

 | Name | Description
public Property | Time | Gets the number of seconds since StartTime.
Top

See Also

Reference

AuthoritativeEngine Class
Dart.Snmp Namespace


Time Property

[image]
PowerSNMP for .NET CF
Time Property
See Also Send comments on this topic.
Dart.Snmp Namespace > AuthoritativeEngine Class : Time Property

Gets the number of seconds since StartTime.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Time As Integer
Visual Basic (Usage) Copy Code
Dim instance As AuthoritativeEngine
Dim value As Integer

value = instance.Time
C#
public int Time {get;}
Managed Extensions for C++
public: __property int get_Time();
C++/CLI
public:
property int Time {
   int get();
}

Property Value

Int32

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AuthoritativeEngine Class
AuthoritativeEngine Members


AuthoritativeEngine Class Fields

[image]
PowerSNMP for .NET CF
AuthoritativeEngine Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : AuthoritativeEngine Class

"

For a list of all members of this type, see AuthoritativeEngine members.

"

Public Fields

 | Name | Description
public Field | Boots | Used to get and set the number of boots the authoritative engine wishes to report.
public Field | Id | Used to get and set a byte array that identifies the SNMP engine.
public Field | StartTime | Used to get and set the starting time of the authoritative engine.
public Field | Users | A table of authorized SNMP version 3 users with associated passwords.
Top

See Also

Reference

AuthoritativeEngine Class
Dart.Snmp Namespace


Boots Field

[image]
PowerSNMP for .NET CF
Boots Field
See Also Send comments on this topic.
Dart.Snmp Namespace > AuthoritativeEngine Class : Boots Field

Used to get and set the number of boots the authoritative engine wishes to report.

Syntax

Visual Basic (Declaration)
Public Boots As Integer
Visual Basic (Usage) Copy Code
Dim instance As AuthoritativeEngine
Dim value As Integer

value = instance.Boots

instance.Boots = value
C#
public int Boots
Managed Extensions for C++
public: int Boots
C++/CLI
public:
int Boots

Property Value

Int32

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AuthoritativeEngine Class
AuthoritativeEngine Members


Id Field

[image]
PowerSNMP for .NET CF
Id Field
See Also Send comments on this topic.
Dart.Snmp Namespace > AuthoritativeEngine Class : Id Field

Used to get and set a byte array that identifies the SNMP engine.

Syntax

Visual Basic (Declaration)
Public Id As Byte()
Visual Basic (Usage) Copy Code
Dim instance As AuthoritativeEngine
Dim value() As Byte

value = instance.Id

instance.Id = value
C#
public byte[] Id
Managed Extensions for C++
public: byte[]* Id
C++/CLI
public:
array<byte>^ Id

Property Value

A byte array that identifies the SNMP authoritative engine in use.

Remarks

Defaults to the ASCII byte representation of "Dart.Snmp". This property is used at run-time only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AuthoritativeEngine Class
AuthoritativeEngine Members


StartTime Field

[image]
PowerSNMP for .NET CF
StartTime Field
See Also Send comments on this topic.
Dart.Snmp Namespace > AuthoritativeEngine Class : StartTime Field

Used to get and set the starting time of the authoritative engine.

Syntax

Visual Basic (Declaration)
Public StartTime As Date
Visual Basic (Usage) Copy Code
Dim instance As AuthoritativeEngine
Dim value As Date

value = instance.StartTime

instance.StartTime = value
C#
public DateTime StartTime
Managed Extensions for C++
public: DateTime StartTime
C++/CLI
public:
DateTime StartTime

Property Value

A DateTime object

Remarks

Used to compute the value of the Time property. This property is used at run-time only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AuthoritativeEngine Class
AuthoritativeEngine Members


Users Field

[image]
PowerSNMP for .NET CF
Users Field
See Also Send comments on this topic.
Dart.Snmp Namespace > AuthoritativeEngine Class : Users Field

A table of authorized SNMP version 3 users with associated passwords.

Syntax

Visual Basic (Declaration)
Public ReadOnly Users As Dictionary(Of String,Passwords)
Visual Basic (Usage) Copy Code
Dim instance As AuthoritativeEngine
Dim value As Dictionary(Of String,Passwords)

value = instance.Users
C#
public readonly Dictionary<string,Passwords> Users
Managed Extensions for C++
public: readonly Dictionary<string*,Passwords*>* Users
C++/CLI
public:
readonly Dictionary<String^,Passwords^>^ Users

Property Value

A Hashtable using Username as the key and a Passwords object as the value.

Remarks

Initialize this Hashtable with Usernames and the associated Passwords object to process received SNMP version 3 packets. Packets received from other users, or packets that cannot be authenticated or decrypted will generate a DecodingException.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AuthoritativeEngine Class
AuthoritativeEngine Members


DecodingException Class

[image]
PowerSNMP for .NET CF
DecodingException Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : DecodingException Class

A DecodingException is thrown when there is an error decoding the encoded message.

Object Model

DecodingException Class

Syntax

Visual Basic (Declaration)
Public Class DecodingException
   Inherits System.ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As DecodingException
C#
public class DecodingException : System.ApplicationException
Managed Extensions for C++
public __gc class DecodingException : public System.ApplicationException
C++/CLI
public ref class DecodingException : public System.ApplicationException

Remarks

ErrorCode contains a value that represents a reason for the failure and System.Exception.Message contains a human readable error message. The bytes of the message that causes the exception can be examined using EncodedMessage, while the offset into the message indicating where the problem occurred is Offset.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Dart.Snmp.DecodingException

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DecodingException Members
Dart.Snmp Namespace


DecodingException Class Members

[image]
PowerSNMP for .NET CF
DecodingException Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : DecodingException Class

The following tables list the members exposed by DecodingException.

Public Fields

 | Name | Description
public Field | EncodedMessage | Gets the encoded bytes of the message.
public Field | ErrorCode | Gets the ErrorCode encountered while decoding an encoded message.
public Field | Id | Gets the message Id from the security header.
public Field | Offset | Gets the offset into the buffer where the error occurred.
public Field | Origin | Gets the address of the sender of the message.
public Field | Username | Gets the user name from the security header.
Top

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

DecodingException Class
Dart.Snmp Namespace


DecodingException Class Fields

[image]
PowerSNMP for .NET CF
DecodingException Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : DecodingException Class

"

For a list of all members of this type, see DecodingException members.

"

Public Fields

 | Name | Description
public Field | EncodedMessage | Gets the encoded bytes of the message.
public Field | ErrorCode | Gets the ErrorCode encountered while decoding an encoded message.
public Field | Id | Gets the message Id from the security header.
public Field | Offset | Gets the offset into the buffer where the error occurred.
public Field | Origin | Gets the address of the sender of the message.
public Field | Username | Gets the user name from the security header.
Top

See Also

Reference

DecodingException Class
Dart.Snmp Namespace


EncodedMessage Field

[image]
PowerSNMP for .NET CF
EncodedMessage Field
See Also Send comments on this topic.
Dart.Snmp Namespace > DecodingException Class : EncodedMessage Field

Gets the encoded bytes of the message.

Syntax

Visual Basic (Declaration)
Public ReadOnly EncodedMessage As Byte()
Visual Basic (Usage) Copy Code
Dim instance As DecodingException
Dim value() As Byte

value = instance.EncodedMessage
C#
public readonly byte[] EncodedMessage
Managed Extensions for C++
public: readonly byte[]* EncodedMessage
C++/CLI
public:
readonly array<byte>^ EncodedMessage

Property Value

A byte array that contains the encoded bytes of the message.

Remarks

Use DecodingException.Offset to determine what part of the encoded message caused the exception to be thrown.

This field is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DecodingException Class
DecodingException Members


ErrorCode Field

[image]
PowerSNMP for .NET CF
ErrorCode Field
See Also Send comments on this topic.
Dart.Snmp Namespace > DecodingException Class : ErrorCode Field

Gets the ErrorCode encountered while decoding an encoded message.

Syntax

Visual Basic (Declaration)
Public ReadOnly ErrorCode As ErrorCode
Visual Basic (Usage) Copy Code
Dim instance As DecodingException
Dim value As ErrorCode

value = instance.ErrorCode
C#
public readonly ErrorCode ErrorCode
Managed Extensions for C++
public: readonly ErrorCode ErrorCode
C++/CLI
public:
readonly ErrorCode ErrorCode

Property Value

The ErrorCode encountered while decoding an encoded message.

Remarks

This field is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DecodingException Class
DecodingException Members


Id Field

[image]
PowerSNMP for .NET CF
Id Field
See Also Send comments on this topic.
Dart.Snmp Namespace > DecodingException Class : Id Field

Gets the message Id from the security header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Id As Integer
Visual Basic (Usage) Copy Code
Dim instance As DecodingException
Dim value As Integer

value = instance.Id
C#
public readonly int Id
Managed Extensions for C++
public: readonly int Id
C++/CLI
public:
readonly int Id

Remarks

This field is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DecodingException Class
DecodingException Members


Offset Field

[image]
PowerSNMP for .NET CF
Offset Field
See Also Send comments on this topic.
Dart.Snmp Namespace > DecodingException Class : Offset Field

Gets the offset into the buffer where the error occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Offset As Integer
Visual Basic (Usage) Copy Code
Dim instance As DecodingException
Dim value As Integer

value = instance.Offset
C#
public readonly int Offset
Managed Extensions for C++
public: readonly int Offset
C++/CLI
public:
readonly int Offset

Remarks

This field is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DecodingException Class
DecodingException Members


Origin Field

[image]
PowerSNMP for .NET CF
Origin Field
See Also Send comments on this topic.
Dart.Snmp Namespace > DecodingException Class : Origin Field

Gets the address of the sender of the message.

Syntax

Visual Basic (Declaration)
Public ReadOnly Origin As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As DecodingException
Dim value As IPEndPoint

value = instance.Origin
C#
public readonly IPEndPoint Origin
Managed Extensions for C++
public: readonly IPEndPoint* Origin
C++/CLI
public:
readonly IPEndPoint^ Origin

Property Value

The address of the sender of the message.

Remarks

May be null if the message was created from a byte stream, otherwise Origin contains the IP address and port of the agent or manager that sent the message.

This field is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DecodingException Class
DecodingException Members


Username Field

[image]
PowerSNMP for .NET CF
Username Field
See Also Send comments on this topic.
Dart.Snmp Namespace > DecodingException Class : Username Field

Gets the user name from the security header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Username As String
Visual Basic (Usage) Copy Code
Dim instance As DecodingException
Dim value As String

value = instance.Username
C#
public readonly string Username
Managed Extensions for C++
public: readonly string* Username
C++/CLI
public:
readonly String^ Username

Remarks

This field is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DecodingException Class
DecodingException Members


DiscoveredEngine Class

[image]
PowerSNMP for .NET CF
DiscoveredEngine Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : DiscoveredEngine Class

Holds authoritative engine information that is used by SNMPv3 authentication processing.

Object Model

DiscoveredEngine Class

Syntax

Visual Basic (Declaration)
Public Class DiscoveredEngine
Visual Basic (Usage) Copy Code
Dim instance As DiscoveredEngine
C#
public class DiscoveredEngine
Managed Extensions for C++
public __gc class DiscoveredEngine
C++/CLI
public ref class DiscoveredEngine

Inheritance Hierarchy

System.Object
Dart.Snmp.DiscoveredEngine

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DiscoveredEngine Members
Dart.Snmp Namespace


DiscoveredEngine Class Members

[image]
PowerSNMP for .NET CF
DiscoveredEngine Class Members
See Also Fields Properties Send comments on this topic.
Dart.Snmp Namespace : DiscoveredEngine Class

The following tables list the members exposed by DiscoveredEngine.

Public Fields

 | Name | Description
public Field | Boots | Used to get and set the number of boots the authoritative engine wishes to report.
public Field | Id | Used to get and a byte array that identifies the SNMP authoritative engine.
Top

Public Properties

 | Name | Description
public Property | Time | Initialized automatically by the manager during discovery. This property is used at run-time only and compensates for the elapsed time since discovery occurred.
Top

See Also

Reference

DiscoveredEngine Class
Dart.Snmp Namespace


DiscoveredEngine Class Properties

[image]
PowerSNMP for .NET CF
DiscoveredEngine Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : DiscoveredEngine Class

"

For a list of all members of this type, see DiscoveredEngine members.

"

Public Properties

 | Name | Description
public Property | Time | Initialized automatically by the manager during discovery. This property is used at run-time only and compensates for the elapsed time since discovery occurred.
Top

See Also

Reference

DiscoveredEngine Class
Dart.Snmp Namespace


Time Property

[image]
PowerSNMP for .NET CF
Time Property
See Also Send comments on this topic.
Dart.Snmp Namespace > DiscoveredEngine Class : Time Property

Initialized automatically by the manager during discovery. This property is used at run-time only and compensates for the elapsed time since discovery occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Time As Integer
Visual Basic (Usage) Copy Code
Dim instance As DiscoveredEngine
Dim value As Integer

value = instance.Time
C#
public int Time {get;}
Managed Extensions for C++
public: __property int get_Time();
C++/CLI
public:
property int Time {
   int get();
}

Property Value

Int32 that identifies how many seconds the authoritative engine has running since Boots was incremented.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DiscoveredEngine Class
DiscoveredEngine Members


DiscoveredEngine Class Fields

[image]
PowerSNMP for .NET CF
DiscoveredEngine Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : DiscoveredEngine Class

"

For a list of all members of this type, see DiscoveredEngine members.

"

Public Fields

 | Name | Description
public Field | Boots | Used to get and set the number of boots the authoritative engine wishes to report.
public Field | Id | Used to get and a byte array that identifies the SNMP authoritative engine.
Top

See Also

Reference

DiscoveredEngine Class
Dart.Snmp Namespace


Boots Field

[image]
PowerSNMP for .NET CF
Boots Field
See Also Send comments on this topic.
Dart.Snmp Namespace > DiscoveredEngine Class : Boots Field

Used to get and set the number of boots the authoritative engine wishes to report.

Syntax

Visual Basic (Declaration)
Public ReadOnly Boots As Integer
Visual Basic (Usage) Copy Code
Dim instance As DiscoveredEngine
Dim value As Integer

value = instance.Boots
C#
public readonly int Boots
Managed Extensions for C++
public: readonly int Boots
C++/CLI
public:
readonly int Boots

Property Value

Int32

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DiscoveredEngine Class
DiscoveredEngine Members


Id Field

[image]
PowerSNMP for .NET CF
Id Field
See Also Send comments on this topic.
Dart.Snmp Namespace > DiscoveredEngine Class : Id Field

Used to get and a byte array that identifies the SNMP authoritative engine.

Syntax

Visual Basic (Declaration)
Public ReadOnly Id As Byte()
Visual Basic (Usage) Copy Code
Dim instance As DiscoveredEngine
Dim value() As Byte

value = instance.Id
C#
public readonly byte[] Id
Managed Extensions for C++
public: readonly byte[]* Id
C++/CLI
public:
readonly array<byte>^ Id

Property Value

A byte array that identifies the SNMP authoritative engine in use.

Remarks

Initialized automatically by the manager during discovery. This property is used at run-time only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

DiscoveredEngine Class
DiscoveredEngine Members


GetBulkMessage Class

[image]
PowerSNMP for .NET CF
GetBulkMessage Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : GetBulkMessage Class

The GetBulkMessage class can be used to request large amounts of information from SNMP version 2/3 agents.

Object Model

GetBulkMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class GetBulkMessage
   Inherits RequestMessage
Visual Basic (Usage) Copy Code
Dim instance As GetBulkMessage
C#
public class GetBulkMessage : RequestMessage
Managed Extensions for C++
public __gc class GetBulkMessage : public RequestMessage
C++/CLI
public ref class GetBulkMessage : public RequestMessage

Remarks

GetBulkMessage derives from the RequestMessage class. It is typically used by an SNMP manager to request repetitive row (table) information from an SNMP agent. The agent will typically respond by constructing and sending the manager a ResponseMessage that can be very large.

ManagerSlave.GetTable is an easy-to-use method that "walks" a table using the relatively inefficient GetNextMessage technique. More advanced applications can use GetBulkMessage to get an entire table using a single message (the Microsoft platform will support packets as large as 64K bytes).

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.RequestMessage
Dart.Snmp.GetBulkMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

GetBulkMessage Members
Dart.Snmp Namespace


GetBulkMessage Class Members

[image]
PowerSNMP for .NET CF
GetBulkMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : GetBulkMessage Class

The following tables list the members exposed by GetBulkMessage.

Public Constructors

 | Name | Description
public Constructor | GetBulkMessage Constructor | Initializes a new instance of the GetBulkMessage class.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | NonRepeaters | Gets or sets the number of variables in MessageBase.Variables (starting at the beginning) that should be used to return values for the specified IIDs.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Repetitions | Gets or sets the maximum number of variables that should be returned in ResponseMessage for each variable in MessageBase.Variables that follow the first "non-repeating" variables.
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetBulkMessage Class
Dart.Snmp Namespace


GetBulkMessage Constructor

[image]
PowerSNMP for .NET CF
GetBulkMessage Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > GetBulkMessage Class : GetBulkMessage Constructor

Initializes a new instance of the GetBulkMessage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New GetBulkMessage()
C#
public GetBulkMessage()
Managed Extensions for C++
public: GetBulkMessage();
C++/CLI
public:
GetBulkMessage();

Remarks

The application must set NonRepeaters and Repetitions, and then add the corresponding "non-repeating" Variable instances followed by the "repeating" Variable instances. The "non-repeating" variables behave like a GetNextMessage, so the first GetBulkMessage.NonRepeaters will be returned as that many variables in the ResponseMessage. The "repeating" variables behave like GetNextMessage, so up to that many variable objects will be returned in the ResponseMessage for each "repeating" variable added to the list.

The application will typically set GetBulkMessage.NonRepeaters to 0 and GetBulkMessage.Repetitions to the maximum number of rows expected in the table of interest. Then variables are added to MessageBase.Variables that represent the OID for each table column in the table. When the returned MessageBase.Variables collection is enumerated, each IID should be parsed to determine which value belongs to each row in each table column. The IID for each value is the OID of the table column to which it belongs with the "indexer" into that row added as a suffix. Repeating variables are returned as consecutive rows. For example, if 5 column "repeaters" are provided as OID variables, then the first row is returned in the first 5 variables of the response, the second row is returned in the second 5 variables, and so on.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

GetBulkMessage Class
GetBulkMessage Members


GetBulkMessage Class Properties

[image]
PowerSNMP for .NET CF
GetBulkMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : GetBulkMessage Class

"

For a list of all members of this type, see GetBulkMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | NonRepeaters | Gets or sets the number of variables in MessageBase.Variables (starting at the beginning) that should be used to return values for the specified IIDs.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Repetitions | Gets or sets the maximum number of variables that should be returned in ResponseMessage for each variable in MessageBase.Variables that follow the first "non-repeating" variables.
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetBulkMessage Class
Dart.Snmp Namespace


NonRepeaters Property

[image]
PowerSNMP for .NET CF
NonRepeaters Property
See Also Send comments on this topic.
Dart.Snmp Namespace > GetBulkMessage Class : NonRepeaters Property

Gets or sets the number of variables in MessageBase.Variables (starting at the beginning) that should be used to return values for the specified IIDs.

Syntax

Visual Basic (Declaration)
Public Property NonRepeaters As Integer
Visual Basic (Usage) Copy Code
Dim instance As GetBulkMessage
Dim value As Integer

instance.NonRepeaters = value

value = instance.NonRepeaters
C#
public int NonRepeaters {get; set;}
Managed Extensions for C++
public: __property int get_NonRepeaters();
public: __property void set_NonRepeaters(
   int value
);
C++/CLI
public:
property int NonRepeaters {
   int get();
   void set (    int value);
}

Property Value

The number of variable objects that should be treated as non-repeating IIDs.

Remarks

A positive value is used to combine a GetNextMessage operation with the "repeating" functionality provided by Repetitions.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

GetBulkMessage Class
GetBulkMessage Members


Repetitions Property

[image]
PowerSNMP for .NET CF
Repetitions Property
See Also Send comments on this topic.
Dart.Snmp Namespace > GetBulkMessage Class : Repetitions Property

Gets or sets the maximum number of variables that should be returned in ResponseMessage for each variable in MessageBase.Variables that follow the first "non-repeating" variables.

Syntax

Visual Basic (Declaration)
Public Property Repetitions As Integer
Visual Basic (Usage) Copy Code
Dim instance As GetBulkMessage
Dim value As Integer

instance.Repetitions = value

value = instance.Repetitions
C#
public int Repetitions {get; set;}
Managed Extensions for C++
public: __property int get_Repetitions();
public: __property void set_Repetitions(
   int value
);
C++/CLI
public:
property int Repetitions {
   int get();
   void set (    int value);
}

Property Value

The maximum number of row values requested for each variable specified.

Remarks

A positive value is used to limit the size of the ResponseMessage generated by the agent.

The application will typically set NonRepeaters to 0 and Repetitions to the maximum number of rows expected in the table of interest. Then variables are added to MessageBase.Variables that represent the OID for each table column in the table. When the returned MessageBase.Variables collection is enumerated, each IID should be parsed to determine which value belongs to each row in each table column. The IID for each value is the OID of the table column with an appended "indexer" into the row. Repeating variables are returned as consecutive rows. For example, if 5 column "repeaters" are provided as OID variables, then the first row is returned in the first 5 variables in the response, the second row is returned in the second 5 variables, and so on.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

GetBulkMessage Class
GetBulkMessage Members


GetMessage Class

[image]
PowerSNMP for .NET CF
GetMessage Class
Members Example See Also Send comments on this topic.
Dart.Snmp Namespace : GetMessage Class

The GetMessage class is the class used to request information about IIDs from an SNMP agent.

Object Model

GetMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class GetMessage
   Inherits RequestMessage
Visual Basic (Usage) Copy Code
Dim instance As GetMessage
C#
public class GetMessage : RequestMessage
Managed Extensions for C++
public __gc class GetMessage : public RequestMessage
C++/CLI
public ref class GetMessage : public RequestMessage

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Remarks

GetMessage derives from the RequestMessage class. It is used by an SNMP agent to request information from an SNMP manager. The agent responds by constructing and sending the manager a ResponseMessage that contains the requested IIDs with their retrieved values.

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.RequestMessage
Dart.Snmp.GetMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

GetMessage Members
Dart.Snmp Namespace


GetMessage Class Members

[image]
PowerSNMP for .NET CF
GetMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : GetMessage Class

The following tables list the members exposed by GetMessage.

Public Constructors

 | Name | Description
public Constructor | GetMessage Constructor | Initializes a new instance of the GetMessage class.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetMessage Class
Dart.Snmp Namespace


GetMessage Constructor

[image]
PowerSNMP for .NET CF
GetMessage Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > GetMessage Class : GetMessage Constructor

Initializes a new instance of the GetMessage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New GetMessage()
C#
public GetMessage()
Managed Extensions for C++
public: GetMessage();
C++/CLI
public:
GetMessage();

Remarks

An SNMP manager will use this constructor before adding variables to MessageBase.Variables. It is expected that the agent will provide the values for those IIDs provided in MessageBase.Variables. The Manager component uses the Encode method to encode the message before sending.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

GetMessage Class
GetMessage Members


GetNextMessage Class

[image]
PowerSNMP for .NET CF
GetNextMessage Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : GetNextMessage Class

The GetNextMessage class is used to request information about IIDs from an SNMP agent while discovering what IIDs that agent manages.

Object Model

GetNextMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class GetNextMessage
   Inherits RequestMessage
Visual Basic (Usage) Copy Code
Dim instance As GetNextMessage
C#
public class GetNextMessage : RequestMessage
Managed Extensions for C++
public __gc class GetNextMessage : public RequestMessage
C++/CLI
public ref class GetNextMessage : public RequestMessage

Remarks

GetNextMessage derives from the RequestMessage class. It is used by an SNMP manager to request information from an SNMP agent while discovering what IIDs are being managed. The agent will typically respond by constructing and sending the manager a ResponseMessage that contains the next IID it manages (in lexigraphical order) along with that instance’s value. Multiple ID "fragments" may be requested, with the manager expecting a ResponseMessage containing the "next" IID for each ID fragment specified in the GetNextMessage.

For example, using an ID fragment of "1" in GetNextMessage might return an IID of "1.3.6.1.2.1.1.1.0" in the ResponseMessage, indicating that this is the first instance being managed by the agent.

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.RequestMessage
Dart.Snmp.GetNextMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

GetNextMessage Members
Dart.Snmp Namespace


GetNextMessage Class Members

[image]
PowerSNMP for .NET CF
GetNextMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : GetNextMessage Class

The following tables list the members exposed by GetNextMessage.

Public Constructors

 | Name | Description
public Constructor | GetNextMessage Constructor | Initializes a new instance of the GetNextMessage class.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetNextMessage Class
Dart.Snmp Namespace


GetNextMessage Constructor

[image]
PowerSNMP for .NET CF
GetNextMessage Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > GetNextMessage Class : GetNextMessage Constructor

Initializes a new instance of the GetNextMessage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New GetNextMessage()
C#
public GetNextMessage()
Managed Extensions for C++
public: GetNextMessage();
C++/CLI
public:
GetNextMessage();

Remarks

An SNMP manager will use this constructor before adding Variable instances to MessageBase.Variables. The Manager component will use the Encode method to encode the message before sending, but the application can also use the Encode method to inspect the contents of the encoded message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

GetNextMessage Class
GetNextMessage Members


InformMessage Class

[image]
PowerSNMP for .NET CF
InformMessage Class
Members Example See Also Send comments on this topic.
Dart.Snmp Namespace : InformMessage Class

The InformMessage class is used to send information between SNMP version 2/ 3 managers.

Object Model

InformMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class InformMessage
   Inherits RequestMessage
Visual Basic (Usage) Copy Code
Dim instance As InformMessage
C#
public class InformMessage : RequestMessage
Managed Extensions for C++
public __gc class InformMessage : public RequestMessage
C++/CLI
public ref class InformMessage : public RequestMessage

Example

The following example demonstrates sending an inform message.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
  //Send an Inform request on a worker thread
  manager1.Start(sendInformRequest, null);
}

private void sendInformRequest(ManagerSlave slave, object state)
{
  //Create an inform message and send it to a manager
  InformMessage inform = new InformMessage();
  inform.Version = SnmpVersion.Two;

  //The inform includes this manager's uptime
  inform.Variables.Add(manager1.Mib.CreateVariable(NodeName.sysUpTime, manager1.AuthoritativeEngine.Time.ToString()));
  slave.GetResponse(inform, myManagerAddress, 162);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
  'Send an Inform request on a worker thread
  manager1.Start(AddressOf sendInformRequest, Nothing)
End Sub

Private Sub sendInformRequest(ByVal slave As ManagerSlave, ByVal state As Object)
  'Create an inform message and send it to a manager
  Dim inform As InformMessage = New InformMessage()
  inform.Version = SnmpVersion.Two

  'The inform includes this manager's uptime
  inform.Variables.Add(manager1.Mib.CreateVariable(NodeName.sysUpTime, manager1.AuthoritativeEngine.Time.ToString()))
  slave.GetResponse(inform, myManagerAddress, 162)
End Sub

Remarks

This message is used to send variables from one manager to another. A ResponseMessage containing the same variables is used to acknowledge the receipt of the information.

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.RequestMessage
Dart.Snmp.InformMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

InformMessage Members
Dart.Snmp Namespace


InformMessage Class Members

[image]
PowerSNMP for .NET CF
InformMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : InformMessage Class

The following tables list the members exposed by InformMessage.

Public Constructors

 | Name | Description
public Constructor | InformMessage Constructor | Initializes a new instance of the InformMessage class.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

InformMessage Class
Dart.Snmp Namespace


InformMessage Constructor

[image]
PowerSNMP for .NET CF
InformMessage Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > InformMessage Class : InformMessage Constructor

Initializes a new instance of the InformMessage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New InformMessage()
C#
public InformMessage()
Managed Extensions for C++
public: InformMessage();
C++/CLI
public:
InformMessage();

Remarks

This constructor will create an empty version 2 message. The application will typically use VariableCollection.Add to initialize the variables to be sent.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

InformMessage Class
InformMessage Members


Manager Class

[image]
PowerSNMP for .NET CF
Manager Class
Members Example See Also Send comments on this topic.
Dart.Snmp Namespace : Manager Class

Specializes UDP communications for SNMP Manager functionality.

Object Model

Manager Class

Syntax

Visual Basic (Declaration)
Public Class Manager
   Inherits SnmpBase
Visual Basic (Usage) Copy Code
Dim instance As Manager
C#
public class Manager : SnmpBase
Managed Extensions for C++
public __gc class Manager : public SnmpBase
C++/CLI
public ref class Manager : public SnmpBase

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Snmp.SnmpBase
Dart.Snmp.Manager

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Members
Dart.Snmp Namespace


Manager Class Members

[image]
PowerSNMP for .NET CF
Manager Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Snmp Namespace : Manager Class

The following tables list the members exposed by Manager.

Public Constructors

 | Name | Description
public Constructor | Manager Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | AuthoritativeEngine | Used to store EngineId, EngineTime, and EngineBoot values used for SNMPv3 authentication. (Inherited from Dart.Snmp.SnmpBase)
public Field | DiscoveredEngines | Used to cache EngineId, EngineTime, and EngineBoot values that have been previously discovered.
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | LocalEndPoint | Used to specify the local address, port, and address family. (Inherited from Dart.Snmp.SnmpBase)
public Field | Mib | Gets the MibNodes object containing MIB definitions. (Inherited from Dart.Snmp.SnmpBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | Close | Terminates Agent or Trap operation by releasing communication resources. (Inherited from Dart.Snmp.SnmpBase)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an array of table variables to the UI thread.
public Method | Send | Send a message to the SNMP manager specified. (Inherited from Dart.Snmp.SnmpBase)
public Method | Start | Overloaded. Starts a worker thread on which the specified delegate function executes using a passed SlaveThreadStart instance.
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnMessage | Called on the UI thread when SnmpBase.Marshal is used. (Inherited from Dart.Snmp.SnmpBase)
protected Method | OnTable | Called on the UI thread when Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object) is used.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Message | The Message event is raised when SnmpBase.Marshal is used. (Inherited from Dart.Snmp.SnmpBase)
public Event | Table | The Table event is raised when Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object) is called.
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Manager Class
Dart.Snmp Namespace


Manager Constructor

[image]
PowerSNMP for .NET CF
Manager Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > Manager Class : Manager Constructor

Overload List

Overload | Description
Manager Constructor(IContainer) | Creates a new instance of the Manager class.
Manager Constructor() | Creates a new instance of the Manager class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members


Manager Constructor(IContainer)

[image]
PowerSNMP for .NET CF
Manager Constructor(IContainer)
See Also Send comments on this topic.
Dart.Snmp Namespace > Manager Class > Manager Constructor : Manager Constructor(IContainer)

container
An object that implements IContainer. The Manager component adds itself to this container so it will not be disposed of until the container is disposed of.
Creates a new instance of the Manager class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Manager(container)
C#
public Manager(
   IContainer container
)
Managed Extensions for C++
public: Manager(
   IContainer* container
)
C++/CLI
public:
Manager(
   IContainer^ container
)

Parameters

container
An object that implements IContainer. The Manager component adds itself to this container so it will not be disposed of until the container is disposed of.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members
Overload List


Manager Constructor()

[image]
PowerSNMP for .NET CF
Manager Constructor()
See Also Send comments on this topic.
Dart.Snmp Namespace > Manager Class > Manager Constructor : Manager Constructor()

Creates a new instance of the Manager class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Manager()
C#
public Manager()
Managed Extensions for C++
public: Manager();
C++/CLI
public:
Manager();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members
Overload List


Manager Class Methods

[image]
PowerSNMP for .NET CF
Manager Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : Manager Class

"

For a list of all members of this type, see Manager members.

"

Public Methods

 | Name | Description
public Method | Close | Terminates Agent or Trap operation by releasing communication resources. (Inherited from Dart.Snmp.SnmpBase)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an array of table variables to the UI thread.
public Method | Send | Send a message to the SNMP manager specified. (Inherited from Dart.Snmp.SnmpBase)
public Method | Start | Overloaded. Starts a worker thread on which the specified delegate function executes using a passed SlaveThreadStart instance.
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnMessage | Called on the UI thread when SnmpBase.Marshal is used. (Inherited from Dart.Snmp.SnmpBase)
protected Method | OnTable | Called on the UI thread when Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object) is used.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Manager Class
Dart.Snmp Namespace


Marshal Method

[image]
PowerSNMP for .NET CF
Marshal Method
See Also Send comments on this topic.
Dart.Snmp Namespace > Manager Class : Marshal Method

Marshals an array of table variables to the UI thread.

Overload List

Overload | Description
Marshal(String,Variable[,],Object) | Marshals an array of table variables to the UI thread.
Marshal(MessageBase[],Object) | Marshals SNMP messages to the UI thread. (Inherited from Dart.Snmp.SnmpBase)
Marshal(Exception) | Marshals an exception to the UI thread. (Inherited from Dart.Common.ComponentBase)
Marshal(Object) | Marshals user state information to the UI thread. (Inherited from Dart.Common.ComponentBase)

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members


Marshal(String,Variable[,],Object) Method

[image]
PowerSNMP for .NET CF
Marshal(String,Variable[,],Object) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > Manager Class > Marshal Method : Marshal(String,Variable[,],Object) Method

oid
The oid of the table used in ManagerSlave.GetTable or ManagerSlave.GetTable.
table
Array of table variables to be marshaled.
state
User state information passes to Marshal.
Marshals an array of table variables to the UI thread.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal oid As String, _
   ByVal table(,) As Variable, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Manager
Dim oid As String
Dim table() As Variable
Dim state As Object

instance.Marshal(oid, table, state)
C#
public void Marshal(
   string oid,
   Variable[,] table,
   object state
)
Managed Extensions for C++
public: void Marshal(
   string* oid,
   Variable*[,]* table,
   Object* state
)
C++/CLI
public:
void Marshal(
   String^ oid,
   array<Variable^>^ table,
   Object^ state
)

Parameters

oid
The oid of the table used in ManagerSlave.GetTable or ManagerSlave.GetTable.
table
Array of table variables to be marshaled.
state
User state information passes to Marshal.

Example

The following example demonstrates how to retrieve a table using internal GetBulk requests to retrieve 20 cells at a time.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Retrieve and display an SNMP Table
    manager1.Start(getTable, myAgentAddress);
}

private void getTable(ManagerSlave slave, object state)
{
    //Get SNMP ifTable at specified address
    string address = state.ToString();
    slave.Socket.ReceiveTimeout = 3000;

    //Retrieve table using GetBulk with 20 max-repetitions
    Variable[,] table = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, SnmpVersion.Two, "public", null,
        new System.Net.IPEndPoint(System.Net.IPAddress.Parse(address), 161), 20);

    //Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, null);
}

void manager1_Table(object sender, Dart.Snmp.TableEventArgs e)
{
    buildTable(e.Table);
}

private void buildTable(Variable[,] table)
{
    //Add columns to the listview for each column in the table
    for (int i = 0; i < table.GetLength(1); i++)
        lvwTable.Columns.Add("Column " + (i + 1).ToString(), 100, HorizontalAlignment.Left);

    ListViewItem tableRow;
    int r, c = 0;
    for (r = 0; r < table.GetLength(0); r++)
    {
        //Create a new row and add the first cell
        tableRow = new ListViewItem(table[r, 0].Value.ToString());

        //Add each additional cell in the row
        for (c = 1; c < table.GetLength(1); c++)
            tableRow.SubItems.Add((table[r, c] == null) ? "NULL" : table[r, c].Value.ToString());

        //Add the row to the listview
        lvwTable.Items.Add(tableRow);
    }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Retrieve and display an SNMP Table
    manager1.Start(AddressOf getTable, myAgentAddress)
End Sub

Private Sub getTable(ByVal slave As ManagerSlave, ByVal state As Object)
    'Get SNMP ifTable at specified address
    Dim address As String = state.ToString()
    slave.Socket.ReceiveTimeout = 3000

    //Retrieve table using GetBulk with 20 max-repetitions
    Dim table(,) As Variable = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, _
        SnmpVersion.Two, "public", Nothing, New System.Net.IPEndPoint(System.Net.IPAddress.Parse(address), 161), 20)

    'Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, Nothing)
End Sub

Private Sub manager1_Table(ByVal sender As Object, ByVal e As Dart.Snmp.TableEventArgs)
    buildTable(e.Table)
End Sub

Private Sub buildTable(ByVal table(,) As Variable)
    'Add columns to the listview for each column in the table
    For i As Integer = 0 To table.GetLength(1) - 1
        lvwTable.Columns.Add("Column " & (i + 1).ToString(), 100, HorizontalAlignment.Left)
    Next i

    Dim tableRow As ListViewItem
    Dim r As Integer, c As Integer = 0
    For r = 0 To table.GetLength(0) - 1
        'Create a new row and add the first cell
        tableRow = New ListViewItem(table(r, 0).Value.ToString())

        'Add each additional cell in the row
        For c = 1 To table.GetLength(1) - 1
            If (table(r, c) Is Nothing) Then
                tableRow.SubItems.Add("NULL")
            Else
                tableRow.SubItems.Add(table(r, c).Value.ToString())
            End If
        Next c

        'Add the row to the listview
        lvwTable.Items.Add(tableRow)
    Next r
End Sub

Remarks

This method can be used to marshal table information from a worker thread to the UI thread for typical display purposes. It calls OnTable on the UI thread, which raises the Table event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members
Overload List


OnTable Method

[image]
PowerSNMP for .NET CF
OnTable Method
See Also Send comments on this topic.
Dart.Snmp Namespace > Manager Class : OnTable Method

e
Instance of arguments passing data for display in UI elements.
Called on the UI thread when Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object) is used.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTable( _
   ByVal e As TableEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Manager
Dim e As TableEventArgs

instance.OnTable(e)
C#
protected virtual void OnTable(
   TableEventArgs e
)
Managed Extensions for C++
protected: virtual void OnTable(
   TableEventArgs* e
)
C++/CLI
protected:
virtual void OnTable(
   TableEventArgs^ e
)

Parameters

e
Instance of arguments passing data for display in UI elements.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members


Start Method

[image]
PowerSNMP for .NET CF
Start Method
See Also Send comments on this topic.
Dart.Snmp Namespace > Manager Class : Start Method

Starts a worker thread on which the specified delegate function executes using a passed SlaveThreadStart instance.

Overload List

Overload | Description
Start(SlaveThreadStart,Object) | Starts a worker thread on which the specified delegate function executes using a passed SlaveThreadStart instance.
Start(ManagerMessageReceived,Object) | Starts a worker thread on which the specified delegate function reports each TrapMessage, NotificationMessage or InformMessage received.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members


Start(SlaveThreadStart,Object) Method

[image]
PowerSNMP for .NET CF
Start(SlaveThreadStart,Object) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > Manager Class > Start Method : Start(SlaveThreadStart,Object) Method

worker
SlaveThreadStart delegate specifying the method to execute.
state
Information to pass to the worker delegate method; can be null.
Starts a worker thread on which the specified delegate function executes using a passed SlaveThreadStart instance.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Start( _
   ByVal worker As SlaveThreadStart, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Manager
Dim worker As SlaveThreadStart
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   SlaveThreadStart worker,
   object state
)
Managed Extensions for C++
public: void Start(
   SlaveThreadStart* worker,
   Object* state
)
C++/CLI
public:
void Start(
   SlaveThreadStart^ worker,
   Object^ state
)

Parameters

worker
SlaveThreadStart delegate specifying the method to execute.
state
Information to pass to the worker delegate method; can be null.

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Remarks

This method provides an easy means for executing blocking functions on multiple, concurrent worker threads. Applications should use this technique to execute processes (like a series of GetRequest methods) that would block the current thread. Typically, a complex application could contact several agents concurrently by running multiple requests on multiple threads.

Unhandled exceptions thrown on the worker thread are caught and reported by the ComponentBase.Error event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members
Overload List


Start(ManagerMessageReceived,Object) Method

[image]
PowerSNMP for .NET CF
Start(ManagerMessageReceived,Object) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > Manager Class > Start Method : Start(ManagerMessageReceived,Object) Method

worker
ManagerMessageReceived delegate specifying the method to execute.
state
Information to pass to the worker delegate method; can be null.
Starts a worker thread on which the specified delegate function reports each TrapMessage, NotificationMessage or InformMessage received.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Start( _
   ByVal worker As ManagerMessageReceived, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Manager
Dim worker As ManagerMessageReceived
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   ManagerMessageReceived worker,
   object state
)
Managed Extensions for C++
public: void Start(
   ManagerMessageReceived* worker,
   Object* state
)
C++/CLI
public:
void Start(
   ManagerMessageReceived^ worker,
   Object^ state
)

Parameters

worker
ManagerMessageReceived delegate specifying the method to execute.
state
Information to pass to the worker delegate method; can be null.

Example

The following example demonstrates receiving trap, notification and inform messages.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
  //Start listening for traps, notifications and informs
  manager1.Start(manager1_MessageReceived, null);
}

private void manager1_MessageReceived(Manager manager, MessageBase message, object state)
{
  //Marshal message to the UI thread using the Message event
  if (message is TrapMessage)
    manager.Marshal(new MessageBase[] { message }, "trap");
    else if (message is NotificationMessage)
    manager.Marshal(new MessageBase[] { message }, "notification");
  else if (message is InformMessage)
  {
    manager.Marshal(new MessageBase[] { message }, "inform");

    //Send response to inform message origin
    manager.Send(new ResponseMessage(message as InformMessage), message.Origin);
  }
}

private void manager1_Message(object sender, MessageEventArgs e)
{
  //Update interface according to message type received
  switch (e.UserState.ToString())
  {
    case "trap":
      TrapMessage trap = e.Messages[0] as TrapMessage;
      label1.Text = "Trap received with Enterprise(" + trap.Enterprise + "), Generic Type (" +
        trap.GenericTrap.ToString() + "), Specific Type(" + trap.SpecificTrap.ToString() + ")";
      break;
    case "notification":
      NotificationMessage notification = e.Messages[0] as NotificationMessage;
      label1.Text = "Notification received with OID (" + notification.Oid + ")";
      break;
    case "inform":
      InformMessage inform = e.Messages[0] as InformMessage;
      label1.Text = "Inform received with " + inform.Variables.Count.ToString() + " variable(s).";
      break;
  }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
  'Start listening for traps, notifications and informs
  manager1.Start(AddressOf manager1_MessageReceived, Nothing)
End Sub

Private Sub manager1_MessageReceived(ByVal manager As Manager, ByVal message As MessageBase, ByVal state As Object)
  'Marshal message to the UI thread using the Message event
  If TypeOf message Is TrapMessage Then
    manager.Marshal(New MessageBase() {message}, "trap")
  ElseIf TypeOf message Is NotificationMessage Then
    manager.Marshal(New MessageBase() {message}, "notification")
  ElseIf TypeOf message Is InformMessage Then
    manager.Marshal(New MessageBase() {message}, "inform")

    'Send response to inform message origin
    manager.Send(New ResponseMessage(TryCast(message, InformMessage)), message.Origin)
  End If
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As MessageEventArgs) Handles manager1.Message
  'Update interface according to message type received
  Select Case e.UserState.ToString()
    Case "trap"
      Dim trap As TrapMessage = TryCast(e.Messages(0), TrapMessage)
      label1.Text = "Trap received with Enterprise(" & trap.Enterprise & "), Generic Type (" & _
        trap.GenericTrap.ToString() & "), Specific Type(" & trap.SpecificTrap.ToString() & ")"
    Case "notification"
      Dim notification As NotificationMessage = TryCast(e.Messages(0), NotificationMessage)
      label1.Text = "Notification received with OID (" & notification.Oid & ")"
    Case "inform"
      Dim inform As InformMessage = TryCast(e.Messages(0), InformMessage)
      label1.Text = "Inform received with " & inform.Variables.Count.ToString() & " variable(s)."
  End Select
End Sub

Remarks

This method presents all asynchronous messages that may be received by a Manager (typically listening on well-known port 162). The Dart.Common.SocketBase.Socket property references the socket in use.

Unhandled exceptions occurring on the worker thread will be caught and reported by the ComponentBase.Error event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members
Overload List


Manager Class Fields

[image]
PowerSNMP for .NET CF
Manager Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : Manager Class

"

For a list of all members of this type, see Manager members.

"

Public Fields

 | Name | Description
public Field | AuthoritativeEngine | Used to store EngineId, EngineTime, and EngineBoot values used for SNMPv3 authentication. (Inherited from Dart.Snmp.SnmpBase)
public Field | DiscoveredEngines | Used to cache EngineId, EngineTime, and EngineBoot values that have been previously discovered.
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | LocalEndPoint | Used to specify the local address, port, and address family. (Inherited from Dart.Snmp.SnmpBase)
public Field | Mib | Gets the MibNodes object containing MIB definitions. (Inherited from Dart.Snmp.SnmpBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Manager Class
Dart.Snmp Namespace


DiscoveredEngines Field

[image]
PowerSNMP for .NET CF
DiscoveredEngines Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Manager Class : DiscoveredEngines Field

Used to cache EngineId, EngineTime, and EngineBoot values that have been previously discovered.

Syntax

Visual Basic (Declaration)
Public ReadOnly DiscoveredEngines As Dictionary(Of IPEndPoint,DiscoveredEngine)
Visual Basic (Usage) Copy Code
Dim instance As Manager
Dim value As Dictionary(Of IPEndPoint,DiscoveredEngine)

value = instance.DiscoveredEngines
C#
public readonly Dictionary<IPEndPoint,DiscoveredEngine> DiscoveredEngines
Managed Extensions for C++
public: readonly Dictionary<IPEndPoint*,DiscoveredEngine*>* DiscoveredEngines
C++/CLI
public:
readonly Dictionary<IPEndPoint^,DiscoveredEngine^>^ DiscoveredEngines

Property Value

A Dictionary that uses an IPEndPoint to look-up engine information previously discovered.

Remarks

This cache will be used by subsequent SNMPv3 communications to an IPEndPoint previously communicated with.

Note that this cache is shared with any ManagerSlave instances created with this Manager instance. These ManagerSlave instances may add or remove DiscoveredEngines to and from the cache.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members


Manager Class Events

[image]
PowerSNMP for .NET CF
Manager Class Events
See Also Send comments on this topic.
Dart.Snmp Namespace : Manager Class

"

For a list of all members of this type, see Manager members.

"

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Message | The Message event is raised when SnmpBase.Marshal is used. (Inherited from Dart.Snmp.SnmpBase)
public Event | Table | The Table event is raised when Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object) is called.
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Manager Class
Dart.Snmp Namespace


Table Event

[image]
PowerSNMP for .NET CF
Table Event
See Also Send comments on this topic.
Dart.Snmp Namespace > Manager Class : Table Event

The Table event is raised when Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object) is called.

Syntax

Visual Basic (Declaration)
Public Event Table As TableEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Manager
Dim handler As TableEventHandler

AddHandler instance.Table, handler
C#
public event TableEventHandler Table
Managed Extensions for C++
public: __event TableEventHandler* Table
C++/CLI
public:
event TableEventHandler^ Table

Remarks

This method is raised on the UI thread so that the passed parameters may be displayed in UI controls.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Manager Class
Manager Members


ManagerSlave Class

[image]
PowerSNMP for .NET CF
ManagerSlave Class
Members Example See Also Send comments on this topic.
Dart.Snmp Namespace : ManagerSlave Class

The ManagerSlave class provides Manager communications that can be invoked in parallel, all running on unique worker threads.

Object Model

ManagerSlave ClassUdpSocket Class

Syntax

Visual Basic (Declaration)
Public Class ManagerSlave
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
C#
public class ManagerSlave
Managed Extensions for C++
public __gc class ManagerSlave
C++/CLI
public ref class ManagerSlave

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Remarks

Users will typically drag the Manager Component onto a form and use SlaveThreadStart to instantiate a session using a single ManagerSlave instance.

Alternatively, the user can instantiate a Manager directly on a worker thread and create an instance of ManagerSlave on the same thread.

Inheritance Hierarchy

System.Object
Dart.Snmp.ManagerSlave

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Members
Dart.Snmp Namespace


ManagerSlave Class Members

[image]
PowerSNMP for .NET CF
ManagerSlave Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : ManagerSlave Class

The following tables list the members exposed by ManagerSlave.

Public Constructors

 | Name | Description
public Constructor | ManagerSlave Constructor | Used to create an instance of a ManagerSlave.
Top

Public Fields

 | Name | Description
public Field | LocalEndPoint | Used to specify the local address, port, and address family. This must be set before the Socket property is used.
public Field | Manager | Provides read-only access to the parent Manager.
Top

Public Properties

 | Name | Description
public Property | Socket | Gets the UdpSocket instance used for network communications.
Top

Public Methods

 | Name | Description
public Method | Close | Close the underlying Socket.
public Method | GetResponse | Overloaded. Sends a blocking request to the specified agent on port 161.
public Method | GetResponses | Overloaded. Sends a blocking broadcast request to the default agent port (161).
public Method | GetTable | Overloaded. Performs a series of blocking requests to retrieve a table using SNMP version 1.
public Method | Receive | Performs a blocking receive on the socket and decodes the received SNMP packet.
public Method | Send | Sends a RequestMessage to the specified agent on the specifed port.
Top

See Also

Reference

ManagerSlave Class
Dart.Snmp Namespace


ManagerSlave Constructor

[image]
PowerSNMP for .NET CF
ManagerSlave Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : ManagerSlave Constructor

manager
The parent Manager that holds information common to multiple ManagerSlave objects.
Used to create an instance of a ManagerSlave.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal manager As Manager _
)
Visual Basic (Usage) Copy Code
Dim manager As Manager

Dim instance As New ManagerSlave(manager)
C#
public ManagerSlave(
   Manager manager
)
Managed Extensions for C++
public: ManagerSlave(
   Manager* manager
)
C++/CLI
public:
ManagerSlave(
   Manager^ manager
)

Parameters

manager
The parent Manager that holds information common to multiple ManagerSlave objects.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


ManagerSlave Class Methods

[image]
PowerSNMP for .NET CF
ManagerSlave Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : ManagerSlave Class

"

For a list of all members of this type, see ManagerSlave members.

"

Public Methods

 | Name | Description
public Method | Close | Close the underlying Socket.
public Method | GetResponse | Overloaded. Sends a blocking request to the specified agent on port 161.
public Method | GetResponses | Overloaded. Sends a blocking broadcast request to the default agent port (161).
public Method | GetTable | Overloaded. Performs a series of blocking requests to retrieve a table using SNMP version 1.
public Method | Receive | Performs a blocking receive on the socket and decodes the received SNMP packet.
public Method | Send | Sends a RequestMessage to the specified agent on the specifed port.
Top

See Also

Reference

ManagerSlave Class
Dart.Snmp Namespace


Close Method

[image]
PowerSNMP for .NET CF
Close Method
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : Close Method

Close the underlying Socket.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave

instance.Close()
C#
public void Close()
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


GetResponse Method

[image]
PowerSNMP for .NET CF
GetResponse Method
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : GetResponse Method

Sends a blocking request to the specified agent on port 161.

Overload List

Overload | Description
GetResponse(RequestMessage,String) | Sends a blocking request to the specified agent on port 161.
GetResponse(RequestMessage,String,Int32) | Sends a blocking request to the specified agent on the specifed port.
GetResponse(RequestMessage,IPEndPoint) | Sends a blocking request to the specified agent on the specifed port.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


GetResponse(RequestMessage,String) Method

[image]
PowerSNMP for .NET CF
GetResponse(RequestMessage,String) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetResponse Method : GetResponse(RequestMessage,String) Method

request
An instance of GetMessage, GetNextMessage, GetBulkMessage or SetMessage. An InformMessage will normally be sent to a Manager on port 162.
hostNameOrAddress
The IP Address in dot notation or hostname of the agent.
Sends a blocking request to the specified agent on port 161.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetResponse( _
   ByVal request As RequestMessage, _
   ByVal hostNameOrAddress As String _
) As ResponseMessage
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim request As RequestMessage
Dim hostNameOrAddress As String
Dim value As ResponseMessage

value = instance.GetResponse(request, hostNameOrAddress)
C#
public ResponseMessage GetResponse(
   RequestMessage request,
   string hostNameOrAddress
)
Managed Extensions for C++
public: ResponseMessage* GetResponse(
   RequestMessage* request,
   string* hostNameOrAddress
)
C++/CLI
public:
ResponseMessage^ GetResponse(
   RequestMessage^ request,
   String^ hostNameOrAddress
)

Parameters

request
An instance of GetMessage, GetNextMessage, GetBulkMessage or SetMessage. An InformMessage will normally be sent to a Manager on port 162.
hostNameOrAddress
The IP Address in dot notation or hostname of the agent.

Return Value

The ResponseMessage from the remote host.

Exceptions

Exception | Description
System.Net.Sockets.SocketException | A problem was experienced using the Socket or the Socket.ReceiveTimeout period expired.
Dart.Snmp.DecodingException | A problem was encountered decoding the Response.
Dart.Snmp.SecurityException | A problem was encountered with the Security attributes of the Request or the Response.

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Remarks

This method blocks and does not return until either a response from the agent is received or a socket timeout occurs.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetResponse(RequestMessage,String,Int32) Method

[image]
PowerSNMP for .NET CF
GetResponse(RequestMessage,String,Int32) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetResponse Method : GetResponse(RequestMessage,String,Int32) Method

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
hostNameOrAddress
The IP Address in dot notation or hostname of the agent or manager.
port
The port to use.
Sends a blocking request to the specified agent on the specifed port.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetResponse( _
   ByVal request As RequestMessage, _
   ByVal hostNameOrAddress As String, _
   ByVal port As Integer _
) As ResponseMessage
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim request As RequestMessage
Dim hostNameOrAddress As String
Dim port As Integer
Dim value As ResponseMessage

value = instance.GetResponse(request, hostNameOrAddress, port)
C#
public ResponseMessage GetResponse(
   RequestMessage request,
   string hostNameOrAddress,
   int port
)
Managed Extensions for C++
public: ResponseMessage* GetResponse(
   RequestMessage* request,
   string* hostNameOrAddress,
   int port
)
C++/CLI
public:
ResponseMessage^ GetResponse(
   RequestMessage^ request,
   String^ hostNameOrAddress,
   int port
)

Parameters

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
hostNameOrAddress
The IP Address in dot notation or hostname of the agent or manager.
port
The port to use.

Return Value

The ResponseMessage from the remote host.

Exceptions

Exception | Description
System.Net.Sockets.SocketException | A problem was experienced using the Socket or the Socket.ReceiveTimeout period has expired.
Dart.Snmp.DecodingException | A problem was encountered decoding the Response.
Dart.Snmp.SecurityException | A problem was encountered with the Security attributes of the Request or the Response.

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Remarks

This method blocks and does not return until either a response from the agent is received or a socket timeout occurs.

Agents normally listen on port 161, but can be configured to listen on other ports as well. If sending an InformMessage to another Manager, port 162 is often used (which is normally open for accepting Trap and Notification messages).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetResponse(RequestMessage,IPEndPoint) Method

[image]
PowerSNMP for .NET CF
GetResponse(RequestMessage,IPEndPoint) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetResponse Method : GetResponse(RequestMessage,IPEndPoint) Method

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
remoteEP
The IPEndPoint specifying the target agent or manager.
Sends a blocking request to the specified agent on the specifed port.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetResponse( _
   ByVal request As RequestMessage, _
   ByVal remoteEP As IPEndPoint _
) As ResponseMessage
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim request As RequestMessage
Dim remoteEP As IPEndPoint
Dim value As ResponseMessage

value = instance.GetResponse(request, remoteEP)
C#
public ResponseMessage GetResponse(
   RequestMessage request,
   IPEndPoint remoteEP
)
Managed Extensions for C++
public: ResponseMessage* GetResponse(
   RequestMessage* request,
   IPEndPoint* remoteEP
)
C++/CLI
public:
ResponseMessage^ GetResponse(
   RequestMessage^ request,
   IPEndPoint^ remoteEP
)

Parameters

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
remoteEP
The IPEndPoint specifying the target agent or manager.

Return Value

The ResponseMessage from the remote host.

Exceptions

Exception | Description
System.Net.Sockets.SocketException | A problem was experienced using the Socket or the Socket.ReceiveTimeout period has expired.
Dart.Snmp.DecodingException | A problem was encountered decoding the Response.
Dart.Snmp.SecurityException | A problem was encountered with the Security attributes of the Request or the Response.

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Remarks

This method blocks and does not return until either a response from the agent is received or a socket timeout occurs.

Agents normally listen on port 161, but can be configured to listen on other ports also. If sending an InformMessage to another Manager, port 162 is often used (which is normally open for accepting Trap and Notification messages).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetResponses Method

[image]
PowerSNMP for .NET CF
GetResponses Method
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : GetResponses Method

Sends a blocking broadcast request to the default agent port (161).

Overload List

Overload | Description
GetResponses(RequestMessage) | Sends a blocking broadcast request to the default agent port (161).
GetResponses(RequestMessage,String,Int32) | Sends a blocking broadcast request to any address and port.
GetResponses(RequestMessage,IPEndPoint) | Sends a blocking broadcast request to any IPEndPoint.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


GetResponses(RequestMessage) Method

[image]
PowerSNMP for .NET CF
GetResponses(RequestMessage) Method
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetResponses Method : GetResponses(RequestMessage) Method

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
Sends a blocking broadcast request to the default agent port (161).

Syntax

Visual Basic (Declaration)
Public Overloads Function GetResponses( _
   ByVal request As RequestMessage _
) As ResponseMessage()
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim request As RequestMessage
Dim value() As ResponseMessage

value = instance.GetResponses(request)
C#
public ResponseMessage[] GetResponses(
   RequestMessage request
)
Managed Extensions for C++
public: ResponseMessage*[]* GetResponses(
   RequestMessage* request
)
C++/CLI
public:
array<ResponseMessage^>^ GetResponses(
   RequestMessage^ request
)

Parameters

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.

Return Value

An array of ResponseMessage objects returned from SNMP agents. Since multiple responses are typically returned, this method reads responses from the socket until a timeout occurs.

Remarks

This method sends a Request to many agents at once using the default broadcast address of 255.255.255.255.

Use this method to request the sysUpTime value (to 'discover’ all the Agents available on the network with a single call).

The returned Response array may contain as few as 0 responses up to as many agents as there are available on the network. Use MessageBase.Origin to determine from which agent each ResponseMessage originated.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetResponses(RequestMessage,String,Int32) Method

[image]
PowerSNMP for .NET CF
GetResponses(RequestMessage,String,Int32) Method
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetResponses Method : GetResponses(RequestMessage,String,Int32) Method

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
broadcastAddress
The broadcast address to use.
agentPort
The target port to use.
Sends a blocking broadcast request to any address and port.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetResponses( _
   ByVal request As RequestMessage, _
   ByVal broadcastAddress As String, _
   ByVal agentPort As Integer _
) As ResponseMessage()
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim request As RequestMessage
Dim broadcastAddress As String
Dim agentPort As Integer
Dim value() As ResponseMessage

value = instance.GetResponses(request, broadcastAddress, agentPort)
C#
public ResponseMessage[] GetResponses(
   RequestMessage request,
   string broadcastAddress,
   int agentPort
)
Managed Extensions for C++
public: ResponseMessage*[]* GetResponses(
   RequestMessage* request,
   string* broadcastAddress,
   int agentPort
)
C++/CLI
public:
array<ResponseMessage^>^ GetResponses(
   RequestMessage^ request,
   String^ broadcastAddress,
   int agentPort
)

Parameters

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
broadcastAddress
The broadcast address to use.
agentPort
The target port to use.

Return Value

An array of ResponseMessage objects returned from SNMP agents. Since multiple responses are typically returned, this method reads responses from the socket until a timeout occurs.

Remarks

This method sends a Request to many agents at once.

Use this method to request the sysUpTime value (to 'discover’ all the Agents available on the network with a single call).

The returned Response array may contain as few as 0 responses up to as many agents as there are available on the network. Use MessageBase.Origin to determine from which agent each ResponseMessage originated.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetResponses(RequestMessage,IPEndPoint) Method

[image]
PowerSNMP for .NET CF
GetResponses(RequestMessage,IPEndPoint) Method
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetResponses Method : GetResponses(RequestMessage,IPEndPoint) Method

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
broadcastEP
The broadcast IPEndPoint to use.
Sends a blocking broadcast request to any IPEndPoint.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetResponses( _
   ByVal request As RequestMessage, _
   ByVal broadcastEP As IPEndPoint _
) As ResponseMessage()
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim request As RequestMessage
Dim broadcastEP As IPEndPoint
Dim value() As ResponseMessage

value = instance.GetResponses(request, broadcastEP)
C#
public ResponseMessage[] GetResponses(
   RequestMessage request,
   IPEndPoint broadcastEP
)
Managed Extensions for C++
public: ResponseMessage*[]* GetResponses(
   RequestMessage* request,
   IPEndPoint* broadcastEP
)
C++/CLI
public:
array<ResponseMessage^>^ GetResponses(
   RequestMessage^ request,
   IPEndPoint^ broadcastEP
)

Parameters

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
broadcastEP
The broadcast IPEndPoint to use.

Return Value

An array of ResponseMessage objects returned from SNMP agents. Since multiple responses are typically returned, this method reads responses from the socket until a timeout occurs.

Remarks

This method sends a Request to many agents at once.

Use this method to request the sysUpTime value (to 'discover’ all the Agents available on the network with a single call).

The returned Response array may contain as few as 0 responses up to as many agents as there are available on the network. Use MessageBase.Origin to determine from which agent each ResponseMessage originated.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetTable Method

[image]
PowerSNMP for .NET CF
GetTable Method
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : GetTable Method

Performs a series of blocking requests to retrieve a table using SNMP version 1.

Overload List

Overload | Description
GetTable(String,String) | Performs a series of blocking requests to retrieve a table using SNMP version 1.
GetTable(String,SnmpVersion,String,Security,String,Int32) | Performs a series of blocking requests to retrieve a table.
GetTable(String,SnmpVersion,String,Security,IPEndPoint) | Performs a series of blocking requests to retrieve a table.
GetTable(String,SnmpVersion,String,Security,String,Int32,Int32) | Performs one or more blocking GetBulk requests to retrieve a table.
GetTable(String,SnmpVersion,String,Security,IPEndPoint,Int32) | Performs one or more blocking GetBulk requests to retrieve a table.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


GetTable(String,String) Method

[image]
PowerSNMP for .NET CF
GetTable(String,String) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetTable Method : GetTable(String,String) Method

tableOid
The OID that indicates the table to retrieve.
agentNameOrAddress
The IP Address in dot notation or hostname of the agent managing the table.
Performs a series of blocking requests to retrieve a table using SNMP version 1.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetTable( _
   ByVal tableOid As String, _
   ByVal agentNameOrAddress As String _
) As Variable(,)
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim tableOid As String
Dim agentNameOrAddress As String
Dim value() As Variable

value = instance.GetTable(tableOid, agentNameOrAddress)
C#
public Variable[,] GetTable(
   string tableOid,
   string agentNameOrAddress
)
Managed Extensions for C++
public: Variable*[,]* GetTable(
   string* tableOid,
   string* agentNameOrAddress
)
C++/CLI
public:
array<Variable^,>^ GetTable(
   String^ tableOid,
   String^ agentNameOrAddress
)

Parameters

tableOid
The OID that indicates the table to retrieve.
agentNameOrAddress
The IP Address in dot notation or hostname of the agent managing the table.

Return Value

A two-dimensional Variable array representing the table.

Example

The following example demonstrates how to retrieve a table using a series of internal GetNext requests.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Retrieve and display an SNMP Table
    manager1.Start(getTable, myAgentAddress);
}

private void getTable(ManagerSlave slave, object state)
{
    //Get SNMP ifTable at specified address
    string address = state.ToString();
    slave.Socket.ReceiveTimeout = 3000;

    //Retrieve table using GetNext requests
    Variable[,] table = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid,
        SnmpVersion.Two, "public", null, address, 161);

    //Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, null);
}

void manager1_Table(object sender, Dart.Snmp.TableEventArgs e)
{
    buildTable(e.Table);
}

private void buildTable(Variable[,] table)
{
    //Add columns to the listview for each column in the table
    for (int i = 0; i < table.GetLength(1); i++)
        lvwTable.Columns.Add("Column " + (i + 1).ToString(), 100, HorizontalAlignment.Left);

    ListViewItem tableRow;
    int r, c = 0;
    for (r = 0; r < table.GetLength(0); r++)
    {
        //Create a new row and add the first cell
        tableRow = new ListViewItem(table[r, 0].Value.ToString());

        //Add each additional cell in the row
        for (c = 1; c < table.GetLength(1); c++)
            tableRow.SubItems.Add((table[r, c] == null) ? "NULL" : table[r, c].Value.ToString());

        //Add the row to the listview
        lvwTable.Items.Add(tableRow);
    }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Retrieve and display an SNMP Table
    manager1.Start(AddressOf getTable, myAgentAddress)
End Sub

Private Sub getTable(ByVal slave As ManagerSlave, ByVal state As Object)
    'Get SNMP ifTable at specified address
    Dim address As String = state.ToString()
    slave.Socket.ReceiveTimeout = 3000

    //Retrieve table using GetNext requests
    Dim table(,) As Variable = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, _
        SnmpVersion.Two, "public", Nothing, address, 161)

    'Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, Nothing)
End Sub

Private Sub manager1_Table(ByVal sender As Object, ByVal e As Dart.Snmp.TableEventArgs)
    buildTable(e.Table)
End Sub

Private Sub buildTable(ByVal table(,) As Variable)
    'Add columns to the listview for each column in the table
    For i As Integer = 0 To table.GetLength(1) - 1
        lvwTable.Columns.Add("Column " & (i + 1).ToString(), 100, HorizontalAlignment.Left)
    Next i

    Dim tableRow As ListViewItem
    Dim r As Integer, c As Integer = 0
    For r = 0 To table.GetLength(0) - 1
        'Create a new row and add the first cell
        tableRow = New ListViewItem(table(r, 0).Value.ToString())

        'Add each additional cell in the row
        For c = 1 To table.GetLength(1) - 1
            If (table(r, c) Is Nothing) Then
                tableRow.SubItems.Add("NULL")
            Else
                tableRow.SubItems.Add(table(r, c).Value.ToString())
            End If
        Next c

        'Add the row to the listview
        lvwTable.Items.Add(tableRow)
    Next r
End Sub

Remarks

This method walks the MIB by sending a GetNextMessage for each element in the table. The method blocks and will not return until the complete table has been retrieved or any single request exceeds the value of the Socket.ReceiveTimeout property. The time required to complete this request is a function of the number of elements in a table. Very large tables can take some time to retrieve.

The returned Variable array is a two dimensional array. Use Array.GetLength(0) and Array.GetLength(1), respectively, to determine the number of rows and columns in the returned table.

The remotePort defaults to the "well-known" agent port 161. The community defaults to "public".

The format of the requested table array depends upon the specification of a valid tableOid.

For improved performance, use GetResponse(RequestMessage,String) or GetResponse(RequestMessage,IPEndPoint) with GetBulkMessage and specify the OIDs of the table columns.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetTable(String,SnmpVersion,String,Security,String,Int32) Method

[image]
PowerSNMP for .NET CF
GetTable(String,SnmpVersion,String,Security,String,Int32) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetTable Method : GetTable(String,SnmpVersion,String,Security,String,Int32) Method

tableOid
The OID that indicates the table to retrieve.
version
SnmpVersion to use.
community
Community string to use. "public" is a typical value.
security
Security parameters to use for SnmpVersion.Three.
agentNameOrAddress
The IP Address in dot notation or hostname of the agent managing the table.
port
The target agent port. Port 161 is the agent "well-known" port.
Performs a series of blocking requests to retrieve a table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetTable( _
   ByVal tableOid As String, _
   ByVal version As SnmpVersion, _
   ByVal community As String, _
   ByVal security As Security, _
   ByVal agentNameOrAddress As String, _
   ByVal port As Integer _
) As Variable(,)
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim tableOid As String
Dim version As SnmpVersion
Dim community As String
Dim security As Security
Dim agentNameOrAddress As String
Dim port As Integer
Dim value() As Variable

value = instance.GetTable(tableOid, version, community, security, agentNameOrAddress, port)
C#
public Variable[,] GetTable(
   string tableOid,
   SnmpVersion version,
   string community,
   Security security,
   string agentNameOrAddress,
   int port
)
Managed Extensions for C++
public: Variable*[,]* GetTable(
   string* tableOid,
   SnmpVersion version,
   string* community,
   Security* security,
   string* agentNameOrAddress,
   int port
)
C++/CLI
public:
array<Variable^,>^ GetTable(
   String^ tableOid,
   SnmpVersion version,
   String^ community,
   Security^ security,
   String^ agentNameOrAddress,
   int port
)

Parameters

tableOid
The OID that indicates the table to retrieve.
version
SnmpVersion to use.
community
Community string to use. "public" is a typical value.
security
Security parameters to use for SnmpVersion.Three.
agentNameOrAddress
The IP Address in dot notation or hostname of the agent managing the table.
port
The target agent port. Port 161 is the agent "well-known" port.

Return Value

A two-dimensional Variable array representing the table.

Example

The following example demonstrates how to retrieve a table using a series of internal GetNext requests.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Retrieve and display an SNMP Table
    manager1.Start(getTable, myAgentAddress);
}

private void getTable(ManagerSlave slave, object state)
{
    //Get SNMP ifTable at specified address
    string address = state.ToString();
    slave.Socket.ReceiveTimeout = 3000;

    //Retrieve table using GetNext requests
    Variable[,] table = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid,
        SnmpVersion.Two, "public", null, address, 161);

    //Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, null);
}

void manager1_Table(object sender, Dart.Snmp.TableEventArgs e)
{
    buildTable(e.Table);
}

private void buildTable(Variable[,] table)
{
    //Add columns to the listview for each column in the table
    for (int i = 0; i < table.GetLength(1); i++)
        lvwTable.Columns.Add("Column " + (i + 1).ToString(), 100, HorizontalAlignment.Left);

    ListViewItem tableRow;
    int r, c = 0;
    for (r = 0; r < table.GetLength(0); r++)
    {
        //Create a new row and add the first cell
        tableRow = new ListViewItem(table[r, 0].Value.ToString());

        //Add each additional cell in the row
        for (c = 1; c < table.GetLength(1); c++)
            tableRow.SubItems.Add((table[r, c] == null) ? "NULL" : table[r, c].Value.ToString());

        //Add the row to the listview
        lvwTable.Items.Add(tableRow);
    }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Retrieve and display an SNMP Table
    manager1.Start(AddressOf getTable, myAgentAddress)
End Sub

Private Sub getTable(ByVal slave As ManagerSlave, ByVal state As Object)
    'Get SNMP ifTable at specified address
    Dim address As String = state.ToString()
    slave.Socket.ReceiveTimeout = 3000

    //Retrieve table using GetNext requests
    Dim table(,) As Variable = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, _
        SnmpVersion.Two, "public", Nothing, address, 161)

    'Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, Nothing)
End Sub

Private Sub manager1_Table(ByVal sender As Object, ByVal e As Dart.Snmp.TableEventArgs)
    buildTable(e.Table)
End Sub

Private Sub buildTable(ByVal table(,) As Variable)
    'Add columns to the listview for each column in the table
    For i As Integer = 0 To table.GetLength(1) - 1
        lvwTable.Columns.Add("Column " & (i + 1).ToString(), 100, HorizontalAlignment.Left)
    Next i

    Dim tableRow As ListViewItem
    Dim r As Integer, c As Integer = 0
    For r = 0 To table.GetLength(0) - 1
        'Create a new row and add the first cell
        tableRow = New ListViewItem(table(r, 0).Value.ToString())

        'Add each additional cell in the row
        For c = 1 To table.GetLength(1) - 1
            If (table(r, c) Is Nothing) Then
                tableRow.SubItems.Add("NULL")
            Else
                tableRow.SubItems.Add(table(r, c).Value.ToString())
            End If
        Next c

        'Add the row to the listview
        lvwTable.Items.Add(tableRow)
    Next r
End Sub

Remarks

This method walks the MIB by sending a GetNextMessage for each element in the table. The method blocks and will not return until the complete table has been retrieved. The time required to complete this request is a function of the number of elements in a table. Very large tables can take some time to retrieve.

The returned Variable array is a two dimensional array. Use Array.GetLength(0) and Array.GetLength(1), respectively, to determine the number of rows and columns in the returned table.

The remotePort defaults to the "well-known" agent port 161. The community defaults to "public".

The format of the requested table array depends upon the specification of a valid tableOid.

For improved performance, use GetResponse(RequestMessage,String) or GetResponse(RequestMessage,IPEndPoint) with GetBulkMessage and specify the OIDs of the table columns.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetTable(String,SnmpVersion,String,Security,IPEndPoint) Method

[image]
PowerSNMP for .NET CF
GetTable(String,SnmpVersion,String,Security,IPEndPoint) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetTable Method : GetTable(String,SnmpVersion,String,Security,IPEndPoint) Method

tableOid
The OID that indicates the table to retrieve.
version
SnmpVersion to use.
community
Community string to use. "public" is a typical value.
security
Security parameters to use for SnmpVersion.Three.
agentEP
The target IPEndPoint being used by the agent.
Performs a series of blocking requests to retrieve a table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetTable( _
   ByVal tableOid As String, _
   ByVal version As SnmpVersion, _
   ByVal community As String, _
   ByVal security As Security, _
   ByVal agentEP As IPEndPoint _
) As Variable(,)
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim tableOid As String
Dim version As SnmpVersion
Dim community As String
Dim security As Security
Dim agentEP As IPEndPoint
Dim value() As Variable

value = instance.GetTable(tableOid, version, community, security, agentEP)
C#
public Variable[,] GetTable(
   string tableOid,
   SnmpVersion version,
   string community,
   Security security,
   IPEndPoint agentEP
)
Managed Extensions for C++
public: Variable*[,]* GetTable(
   string* tableOid,
   SnmpVersion version,
   string* community,
   Security* security,
   IPEndPoint* agentEP
)
C++/CLI
public:
array<Variable^,>^ GetTable(
   String^ tableOid,
   SnmpVersion version,
   String^ community,
   Security^ security,
   IPEndPoint^ agentEP
)

Parameters

tableOid
The OID that indicates the table to retrieve.
version
SnmpVersion to use.
community
Community string to use. "public" is a typical value.
security
Security parameters to use for SnmpVersion.Three.
agentEP
The target IPEndPoint being used by the agent.

Return Value

A two-dimensional Variable array representing the table.

Example

The following example demonstrates how to retrieve a table using a series of internal GetNext requests.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Retrieve and display an SNMP Table
    manager1.Start(getTable, myAgentAddress);
}

private void getTable(ManagerSlave slave, object state)
{
    //Get SNMP ifTable at specified address
    string address = state.ToString();
    slave.Socket.ReceiveTimeout = 3000;

    //Retrieve table using GetNext requests
    Variable[,] table = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid,
        SnmpVersion.Two, "public", null, address, 161);

    //Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, null);
}

void manager1_Table(object sender, Dart.Snmp.TableEventArgs e)
{
    buildTable(e.Table);
}

private void buildTable(Variable[,] table)
{
    //Add columns to the listview for each column in the table
    for (int i = 0; i < table.GetLength(1); i++)
        lvwTable.Columns.Add("Column " + (i + 1).ToString(), 100, HorizontalAlignment.Left);

    ListViewItem tableRow;
    int r, c = 0;
    for (r = 0; r < table.GetLength(0); r++)
    {
        //Create a new row and add the first cell
        tableRow = new ListViewItem(table[r, 0].Value.ToString());

        //Add each additional cell in the row
        for (c = 1; c < table.GetLength(1); c++)
            tableRow.SubItems.Add((table[r, c] == null) ? "NULL" : table[r, c].Value.ToString());

        //Add the row to the listview
        lvwTable.Items.Add(tableRow);
    }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Retrieve and display an SNMP Table
    manager1.Start(AddressOf getTable, myAgentAddress)
End Sub

Private Sub getTable(ByVal slave As ManagerSlave, ByVal state As Object)
    'Get SNMP ifTable at specified address
    Dim address As String = state.ToString()
    slave.Socket.ReceiveTimeout = 3000

    //Retrieve table using GetNext requests
    Dim table(,) As Variable = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, _
        SnmpVersion.Two, "public", Nothing, address, 161)

    'Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, Nothing)
End Sub

Private Sub manager1_Table(ByVal sender As Object, ByVal e As Dart.Snmp.TableEventArgs)
    buildTable(e.Table)
End Sub

Private Sub buildTable(ByVal table(,) As Variable)
    'Add columns to the listview for each column in the table
    For i As Integer = 0 To table.GetLength(1) - 1
        lvwTable.Columns.Add("Column " & (i + 1).ToString(), 100, HorizontalAlignment.Left)
    Next i

    Dim tableRow As ListViewItem
    Dim r As Integer, c As Integer = 0
    For r = 0 To table.GetLength(0) - 1
        'Create a new row and add the first cell
        tableRow = New ListViewItem(table(r, 0).Value.ToString())

        'Add each additional cell in the row
        For c = 1 To table.GetLength(1) - 1
            If (table(r, c) Is Nothing) Then
                tableRow.SubItems.Add("NULL")
            Else
                tableRow.SubItems.Add(table(r, c).Value.ToString())
            End If
        Next c

        'Add the row to the listview
        lvwTable.Items.Add(tableRow)
    Next r
End Sub

Remarks

This method walks the MIB by sending a GetNextMessage for each element in the table. The method blocks and will not return until the complete table has been retrieved or any single request exceeds the value of the Socket.ReceiveTimeout property. The time required to complete this request is a function of the number of elements in a table. Very large tables can take some time to retrieve.

The returned Variable array is a two dimensional array. Use Array.GetLength(0) and Array.GetLength(1), respectively, to determine the number of rows and columns in the returned table.

The remotePort defaults to the "well-known" agent port 161. The community defaults to "public".

The format of the requested table array depends upon the specification of a valid tableOid.

For improved performance, use GetResponse(RequestMessage,String) or GetResponse(RequestMessage,IPEndPoint) with GetBulkMessage and specify the OIDs of the table columns.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetTable(String,SnmpVersion,String,Security,String,Int32,Int32) Method

[image]
PowerSNMP for .NET CF
GetTable(String,SnmpVersion,String,Security,String,Int32,Int32) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetTable Method : GetTable(String,SnmpVersion,String,Security,String,Int32,Int32) Method

tableOid
The OID that indicates the table to retrieve.
version
SnmpVersion to use (cannot be SnmpVersion.One).
community
Community string to use. "public" is a typical value.
security
Security parameters to use for SnmpVersion.Three.
agentNameOrAddress
The IP Address in dot notation or hostname of the agent managing the table.
port
The target agent port. Port 161 is the agent "well-known" port.
maxRepetitions
The max-repetitions value for each GetBulk request sent.
Performs one or more blocking GetBulk requests to retrieve a table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetTable( _
   ByVal tableOid As String, _
   ByVal version As SnmpVersion, _
   ByVal community As String, _
   ByVal security As Security, _
   ByVal agentNameOrAddress As String, _
   ByVal port As Integer, _
   ByVal maxRepetitions As Integer _
) As Variable(,)
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim tableOid As String
Dim version As SnmpVersion
Dim community As String
Dim security As Security
Dim agentNameOrAddress As String
Dim port As Integer
Dim maxRepetitions As Integer
Dim value() As Variable

value = instance.GetTable(tableOid, version, community, security, agentNameOrAddress, port, maxRepetitions)
C#
public Variable[,] GetTable(
   string tableOid,
   SnmpVersion version,
   string community,
   Security security,
   string agentNameOrAddress,
   int port,
   int maxRepetitions
)
Managed Extensions for C++
public: Variable*[,]* GetTable(
   string* tableOid,
   SnmpVersion version,
   string* community,
   Security* security,
   string* agentNameOrAddress,
   int port,
   int maxRepetitions
)
C++/CLI
public:
array<Variable^,>^ GetTable(
   String^ tableOid,
   SnmpVersion version,
   String^ community,
   Security^ security,
   String^ agentNameOrAddress,
   int port,
   int maxRepetitions
)

Parameters

tableOid
The OID that indicates the table to retrieve.
version
SnmpVersion to use (cannot be SnmpVersion.One).
community
Community string to use. "public" is a typical value.
security
Security parameters to use for SnmpVersion.Three.
agentNameOrAddress
The IP Address in dot notation or hostname of the agent managing the table.
port
The target agent port. Port 161 is the agent "well-known" port.
maxRepetitions
The max-repetitions value for each GetBulk request sent.

Return Value

A two-dimensional Variable array representing the table.

Example

The following example demonstrates how to retrieve a table using internal GetBulk requests to retrieve 20 cells at a time.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Retrieve and display an SNMP Table
    manager1.Start(getTable, myAgentAddress);
}

private void getTable(ManagerSlave slave, object state)
{
    //Get SNMP ifTable at specified address
    string address = state.ToString();
    slave.Socket.ReceiveTimeout = 3000;

    //Retrieve table using GetBulk with 20 max-repetitions
    Variable[,] table = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, SnmpVersion.Two, "public", null,
        new System.Net.IPEndPoint(System.Net.IPAddress.Parse(address), 161), 20);

    //Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, null);
}

void manager1_Table(object sender, Dart.Snmp.TableEventArgs e)
{
    buildTable(e.Table);
}

private void buildTable(Variable[,] table)
{
    //Add columns to the listview for each column in the table
    for (int i = 0; i < table.GetLength(1); i++)
        lvwTable.Columns.Add("Column " + (i + 1).ToString(), 100, HorizontalAlignment.Left);

    ListViewItem tableRow;
    int r, c = 0;
    for (r = 0; r < table.GetLength(0); r++)
    {
        //Create a new row and add the first cell
        tableRow = new ListViewItem(table[r, 0].Value.ToString());

        //Add each additional cell in the row
        for (c = 1; c < table.GetLength(1); c++)
            tableRow.SubItems.Add((table[r, c] == null) ? "NULL" : table[r, c].Value.ToString());

        //Add the row to the listview
        lvwTable.Items.Add(tableRow);
    }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Retrieve and display an SNMP Table
    manager1.Start(AddressOf getTable, myAgentAddress)
End Sub

Private Sub getTable(ByVal slave As ManagerSlave, ByVal state As Object)
    'Get SNMP ifTable at specified address
    Dim address As String = state.ToString()
    slave.Socket.ReceiveTimeout = 3000

    //Retrieve table using GetBulk with 20 max-repetitions
    Dim table(,) As Variable = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, _
        SnmpVersion.Two, "public", Nothing, New System.Net.IPEndPoint(System.Net.IPAddress.Parse(address), 161), 20)

    'Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, Nothing)
End Sub

Private Sub manager1_Table(ByVal sender As Object, ByVal e As Dart.Snmp.TableEventArgs)
    buildTable(e.Table)
End Sub

Private Sub buildTable(ByVal table(,) As Variable)
    'Add columns to the listview for each column in the table
    For i As Integer = 0 To table.GetLength(1) - 1
        lvwTable.Columns.Add("Column " & (i + 1).ToString(), 100, HorizontalAlignment.Left)
    Next i

    Dim tableRow As ListViewItem
    Dim r As Integer, c As Integer = 0
    For r = 0 To table.GetLength(0) - 1
        'Create a new row and add the first cell
        tableRow = New ListViewItem(table(r, 0).Value.ToString())

        'Add each additional cell in the row
        For c = 1 To table.GetLength(1) - 1
            If (table(r, c) Is Nothing) Then
                tableRow.SubItems.Add("NULL")
            Else
                tableRow.SubItems.Add(table(r, c).Value.ToString())
            End If
        Next c

        'Add the row to the listview
        lvwTable.Items.Add(tableRow)
    Next r
End Sub

Remarks

This method walks the MIB by sending one or more GetBulkMessage requests until the table is complete. The method blocks and will not return until the complete table has been retrieved or any single request exceeds the value of the Socket.ReceiveTimeout property. The time required to complete this request is a function of the number of elements in a table. Very large tables can take some time to retrieve.

The returned Variable array is a two dimensional array. Use Array.GetLength(0) and Array.GetLength(1), respectively, to determine the number of rows and columns in the returned table.

The version must be SnmpVersion.Two or SnmpVersion.Three.

The format of the requested table array depends upon the specification of a valid tableOid.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


GetTable(String,SnmpVersion,String,Security,IPEndPoint,Int32) Method

[image]
PowerSNMP for .NET CF
GetTable(String,SnmpVersion,String,Security,IPEndPoint,Int32) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class > GetTable Method : GetTable(String,SnmpVersion,String,Security,IPEndPoint,Int32) Method

tableOid
The OID that indicates the table to retrieve.
version
SnmpVersion to use (cannot be SnmpVersion.One).
community
Community string to use. "public" is a typical value.
security
Security parameters to use for SnmpVersion.Three.
agentEP
The target IPEndPoint being used by the agent.
maxRepetitions
The max-repetitions value for each GetBulk request sent.
Performs one or more blocking GetBulk requests to retrieve a table.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetTable( _
   ByVal tableOid As String, _
   ByVal version As SnmpVersion, _
   ByVal community As String, _
   ByVal security As Security, _
   ByVal agentEP As IPEndPoint, _
   ByVal maxRepetitions As Integer _
) As Variable(,)
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim tableOid As String
Dim version As SnmpVersion
Dim community As String
Dim security As Security
Dim agentEP As IPEndPoint
Dim maxRepetitions As Integer
Dim value() As Variable

value = instance.GetTable(tableOid, version, community, security, agentEP, maxRepetitions)
C#
public Variable[,] GetTable(
   string tableOid,
   SnmpVersion version,
   string community,
   Security security,
   IPEndPoint agentEP,
   int maxRepetitions
)
Managed Extensions for C++
public: Variable*[,]* GetTable(
   string* tableOid,
   SnmpVersion version,
   string* community,
   Security* security,
   IPEndPoint* agentEP,
   int maxRepetitions
)
C++/CLI
public:
array<Variable^,>^ GetTable(
   String^ tableOid,
   SnmpVersion version,
   String^ community,
   Security^ security,
   IPEndPoint^ agentEP,
   int maxRepetitions
)

Parameters

tableOid
The OID that indicates the table to retrieve.
version
SnmpVersion to use (cannot be SnmpVersion.One).
community
Community string to use. "public" is a typical value.
security
Security parameters to use for SnmpVersion.Three.
agentEP
The target IPEndPoint being used by the agent.
maxRepetitions
The max-repetitions value for each GetBulk request sent.

Return Value

A two-dimensional Variable array representing the table.

Example

The following example demonstrates how to retrieve a table using internal GetBulk requests to retrieve 20 cells at a time.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Retrieve and display an SNMP Table
    manager1.Start(getTable, myAgentAddress);
}

private void getTable(ManagerSlave slave, object state)
{
    //Get SNMP ifTable at specified address
    string address = state.ToString();
    slave.Socket.ReceiveTimeout = 3000;

    //Retrieve table using GetBulk with 20 max-repetitions
    Variable[,] table = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, SnmpVersion.Two, "public", null,
        new System.Net.IPEndPoint(System.Net.IPAddress.Parse(address), 161), 20);

    //Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, null);
}

void manager1_Table(object sender, Dart.Snmp.TableEventArgs e)
{
    buildTable(e.Table);
}

private void buildTable(Variable[,] table)
{
    //Add columns to the listview for each column in the table
    for (int i = 0; i < table.GetLength(1); i++)
        lvwTable.Columns.Add("Column " + (i + 1).ToString(), 100, HorizontalAlignment.Left);

    ListViewItem tableRow;
    int r, c = 0;
    for (r = 0; r < table.GetLength(0); r++)
    {
        //Create a new row and add the first cell
        tableRow = new ListViewItem(table[r, 0].Value.ToString());

        //Add each additional cell in the row
        for (c = 1; c < table.GetLength(1); c++)
            tableRow.SubItems.Add((table[r, c] == null) ? "NULL" : table[r, c].Value.ToString());

        //Add the row to the listview
        lvwTable.Items.Add(tableRow);
    }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Retrieve and display an SNMP Table
    manager1.Start(AddressOf getTable, myAgentAddress)
End Sub

Private Sub getTable(ByVal slave As ManagerSlave, ByVal state As Object)
    'Get SNMP ifTable at specified address
    Dim address As String = state.ToString()
    slave.Socket.ReceiveTimeout = 3000

    //Retrieve table using GetBulk with 20 max-repetitions
    Dim table(,) As Variable = slave.GetTable(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, _
        SnmpVersion.Two, "public", Nothing, New System.Net.IPEndPoint(System.Net.IPAddress.Parse(address), 161), 20)

    'Marshal table to UI thread
    manager1.Marshal(manager1.Mib.GetByNodeName(NodeName.ifTable).Oid, table, Nothing)
End Sub

Private Sub manager1_Table(ByVal sender As Object, ByVal e As Dart.Snmp.TableEventArgs)
    buildTable(e.Table)
End Sub

Private Sub buildTable(ByVal table(,) As Variable)
    'Add columns to the listview for each column in the table
    For i As Integer = 0 To table.GetLength(1) - 1
        lvwTable.Columns.Add("Column " & (i + 1).ToString(), 100, HorizontalAlignment.Left)
    Next i

    Dim tableRow As ListViewItem
    Dim r As Integer, c As Integer = 0
    For r = 0 To table.GetLength(0) - 1
        'Create a new row and add the first cell
        tableRow = New ListViewItem(table(r, 0).Value.ToString())

        'Add each additional cell in the row
        For c = 1 To table.GetLength(1) - 1
            If (table(r, c) Is Nothing) Then
                tableRow.SubItems.Add("NULL")
            Else
                tableRow.SubItems.Add(table(r, c).Value.ToString())
            End If
        Next c

        'Add the row to the listview
        lvwTable.Items.Add(tableRow)
    Next r
End Sub

Remarks

This method walks the MIB by sending one or more GetBulkMessage requests until the table is complete. The method blocks and will not return until the complete table has been retrieved or any single request exceeds the value of the Socket.ReceiveTimeout property. The time required to complete this request is a function of the number of elements in a table. Very large tables can take some time to retrieve.

The returned Variable array is a two dimensional array. Use Array.GetLength(0) and Array.GetLength(1), respectively, to determine the number of rows and columns in the returned table.

The version must be SnmpVersion.Two or SnmpVersion.Three.

The format of the requested table array depends upon the specification of a valid tableOid.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members
Overload List


Receive Method

[image]
PowerSNMP for .NET CF
Receive Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : Receive Method

request
An optional instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage. Can be null.
Performs a blocking receive on the socket and decodes the received SNMP packet.

Syntax

Visual Basic (Declaration)
Public Function Receive( _
   ByVal request As RequestMessage _
) As ResponseMessage
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim request As RequestMessage
Dim value As ResponseMessage

value = instance.Receive(request)
C#
public ResponseMessage Receive(
   RequestMessage request
)
Managed Extensions for C++
public: ResponseMessage* Receive(
   RequestMessage* request
)
C++/CLI
public:
ResponseMessage^ Receive(
   RequestMessage^ request
)

Parameters

request
An optional instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage. Can be null.

Return Value

The ResponseMessage from the remote host.

Exceptions

Exception | Description
System.Net.Sockets.SocketException | A problem was experienced using the Socket or the Socket.ReceiveTimeout period has expired.
Dart.Snmp.DecodingException | A problem was encountered decoding the Response.
Dart.Snmp.SecurityException | A problem was encountered with the Security attributes of the Request or the Response.

Example

The following example demonstrates how to send requests and receive responses using the same port.
C# Copy Code
string myAgentAddress = "192.168.0.11";
ManagerSlave managerSlave = null;

private void button1_Click(object sender, EventArgs e)
{
    //Start listening for responses on a specified port
    manager1.Start(new SlaveThreadStart(receiveResponses), new IPEndPoint(IPAddress.Any, 777));
}

private void button2_Click(object sender, EventArgs e)
{
    //Send a request to myAgentAddress
    manager1.Start(new SlaveThreadStart(sendRequest), new IPEndPoint(IPAddress.Parse(myAgentAddress), 161));
}

private void receiveResponses(ManagerSlave slave, object state)
{
    //Continue receiving responses until the managerSlave is closed
    managerSlave = slave;
    managerSlave.LocalEndPoint = (IPEndPoint)state;
    managerSlave.Socket.ReceiveTimeout = 0;
    ResponseMessage response = null;
    do
    {
        try {response = managerSlave.Receive(null);}
        catch (Exception ex)
        {
            manager1.Marshal(new Exception("The socket is no longer receiving", ex));
            break;
        }

        //Marshal response to UI thread
        manager1.Marshal(new MessageBase[] { response }, null);
    } while(managerSlave.Socket != null);
}

private void sendRequest(ManagerSlave slave, object state)
{
    //Create and send a Get Request using existing slave
    try
    {
        GetMessage request = new GetMessage();
        request.Version = SnmpVersion.One;
        request.Community = "public";
        request.Variables.Add(manager1.Mib.CreateVariable(NodeName.sysUpTime));

        //Use managerSlave to send the request
        managerSlave.Send(request, (IPEndPoint)state);
    }
    catch (Exception ex) { manager1.Marshal(ex); }
}

private void manager1_Message(object sender, MessageEventArgs e)
{
    //Display response
    ResponseMessage response = (ResponseMessage)e.Messages[0];
    displayResponse(DateTime.Now.ToString() + " : " + response.Variables[0].Value.ToString());
}

private void displayResponse(string s)
{
    ...
}
Visual Basic Copy Code
Private myAgentAddress As String = "192.168.0.11"
Private managerSlave As ManagerSlave = Nothing

Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Start listening for responses on a specified port
    manager1.Start(New SlaveThreadStart(AddressOf receiveResponses), New IPEndPoint(IPAddress.Any, 777))
End Sub

Private Sub button2_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Send a request to myAgentAddress
    manager1.Start(New SlaveThreadStart(AddressOf sendRequest), New IPEndPoint(IPAddress.Parse(myAgentAddress), 161))
End Sub

Private Sub receiveResponses(ByVal slave As ManagerSlave, ByVal state As Object)
    'Continue receiving responses until the managerSlave is closed
    managerSlave = slave
    managerSlave.LocalEndPoint = CType(state, IPEndPoint)
    managerSlave.Socket.ReceiveTimeout = 0
    Dim response As ResponseMessage = Nothing
    Do
        Try
            response = managerSlave.Receive(Nothing)
        Catch ex As Exception
            manager1.Marshal(New Exception("The socket is no longer receiving", ex))
            Exit Do
        End Try

        'Marshal response to UI thread
        manager1.Marshal(New MessageBase() { response }, Nothing)
    Loop While Not managerSlave.Socket Is Nothing
End Sub

Private Sub sendRequest(ByVal slave As ManagerSlave, ByVal state As Object)
    'Create and send a Get Request using existing slave
    Try
        Dim request As GetMessage = New GetMessage()
        request.Version = SnmpVersion.One
        request.Community = "public"
        request.Variables.Add(manager1.Mib.CreateVariable(NodeName.sysUpTime))

        'Use managerSlave to send the request
        managerSlave.Send(request, CType(state, IPEndPoint))
    Catch ex As Exception
        manager1.Marshal(ex)
    End Try
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As MessageEventArgs)
    'Display response
    Dim response As ResponseMessage = CType(e.Messages(0), ResponseMessage)
    displayResponse(DateTime.Now.ToString() & " : " & response.Variables(0).Value.ToString())
End Sub

Private Sub displayResponse(ByVal s As String)
    ...
End Sub

Remarks

This method blocks and does not return until either a response from the agent is received or a socket timeout occurs. It should be used on a worker thread with Send (being called on another thread) when a single socket must be used for handling responses from multiple outstanding requests in an asynchronous manner.

This method may be used on a worker threat to received Agent responses from multiple requests using Send from another thread.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


Send Method

[image]
PowerSNMP for .NET CF
Send Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : Send Method

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
remoteEP
The IPEndPoint specifying the target agent or manager.
Sends a RequestMessage to the specified agent on the specifed port.

Syntax

Visual Basic (Declaration)
Public Sub Send( _
   ByVal request As RequestMessage, _
   ByVal remoteEP As IPEndPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim request As RequestMessage
Dim remoteEP As IPEndPoint

instance.Send(request, remoteEP)
C#
public void Send(
   RequestMessage request,
   IPEndPoint remoteEP
)
Managed Extensions for C++
public: void Send(
   RequestMessage* request,
   IPEndPoint* remoteEP
)
C++/CLI
public:
void Send(
   RequestMessage^ request,
   IPEndPoint^ remoteEP
)

Parameters

request
An instance of GetMessage, GetNextMessage, GetBulkMessage, SetMessage or InformMessage.
remoteEP
The IPEndPoint specifying the target agent or manager.

Exceptions

Exception | Description
System.Net.Sockets.SocketException | A problem was experienced using the Socket.
Dart.Snmp.SecurityException | A problem was encountered with the Security attributes of the Request.

Example

The following example demonstrates how to send requests and receive responses using the same port.
C# Copy Code
string myAgentAddress = "192.168.0.11";
ManagerSlave managerSlave = null;

private void button1_Click(object sender, EventArgs e)
{
    //Start listening for responses on a specified port
    manager1.Start(new SlaveThreadStart(receiveResponses), new IPEndPoint(IPAddress.Any, 777));
}

private void button2_Click(object sender, EventArgs e)
{
    //Send a request to myAgentAddress
    manager1.Start(new SlaveThreadStart(sendRequest), new IPEndPoint(IPAddress.Parse(myAgentAddress), 161));
}

private void receiveResponses(ManagerSlave slave, object state)
{
    //Continue receiving responses until the managerSlave is closed
    managerSlave = slave;
    managerSlave.LocalEndPoint = (IPEndPoint)state;
    managerSlave.Socket.ReceiveTimeout = 0;
    ResponseMessage response = null;
    do
    {
        try {response = managerSlave.Receive(null);}
        catch (Exception ex)
        {
            manager1.Marshal(new Exception("The socket is no longer receiving", ex));
            break;
        }

        //Marshal response to UI thread
        manager1.Marshal(new MessageBase[] { response }, null);
    } while(managerSlave.Socket != null);
}

private void sendRequest(ManagerSlave slave, object state)
{
    //Create and send a Get Request using existing slave
    try
    {
        GetMessage request = new GetMessage();
        request.Version = SnmpVersion.One;
        request.Community = "public";
        request.Variables.Add(manager1.Mib.CreateVariable(NodeName.sysUpTime));

        //Use managerSlave to send the request
        managerSlave.Send(request, (IPEndPoint)state);
    }
    catch (Exception ex) { manager1.Marshal(ex); }
}

private void manager1_Message(object sender, MessageEventArgs e)
{
    //Display response
    ResponseMessage response = (ResponseMessage)e.Messages[0];
    displayResponse(DateTime.Now.ToString() + " : " + response.Variables[0].Value.ToString());
}

private void displayResponse(string s)
{
    ...
}
Visual Basic Copy Code
Private myAgentAddress As String = "192.168.0.11"
Private managerSlave As ManagerSlave = Nothing

Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Start listening for responses on a specified port
    manager1.Start(New SlaveThreadStart(AddressOf receiveResponses), New IPEndPoint(IPAddress.Any, 777))
End Sub

Private Sub button2_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Send a request to myAgentAddress
    manager1.Start(New SlaveThreadStart(AddressOf sendRequest), New IPEndPoint(IPAddress.Parse(myAgentAddress), 161))
End Sub

Private Sub receiveResponses(ByVal slave As ManagerSlave, ByVal state As Object)
    'Continue receiving responses until the managerSlave is closed
    managerSlave = slave
    managerSlave.LocalEndPoint = CType(state, IPEndPoint)
    managerSlave.Socket.ReceiveTimeout = 0
    Dim response As ResponseMessage = Nothing
    Do
        Try
            response = managerSlave.Receive(Nothing)
        Catch ex As Exception
            manager1.Marshal(New Exception("The socket is no longer receiving", ex))
            Exit Do
        End Try

        'Marshal response to UI thread
        manager1.Marshal(New MessageBase() { response }, Nothing)
    Loop While Not managerSlave.Socket Is Nothing
End Sub

Private Sub sendRequest(ByVal slave As ManagerSlave, ByVal state As Object)
    'Create and send a Get Request using existing slave
    Try
        Dim request As GetMessage = New GetMessage()
        request.Version = SnmpVersion.One
        request.Community = "public"
        request.Variables.Add(manager1.Mib.CreateVariable(NodeName.sysUpTime))

        'Use managerSlave to send the request
        managerSlave.Send(request, CType(state, IPEndPoint))
    Catch ex As Exception
        manager1.Marshal(ex)
    End Try
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As MessageEventArgs)
    'Display response
    Dim response As ResponseMessage = CType(e.Messages(0), ResponseMessage)
    displayResponse(DateTime.Now.ToString() & " : " & response.Variables(0).Value.ToString())
End Sub

Private Sub displayResponse(ByVal s As String)
    ...
End Sub

Remarks

This method encodes and sends a message, performing any necessary discovery if using SNMPv3. It is used with Receive when a single socket must be used for handling responses from multiple outstanding requests in a synchronous blocking manner.

This method checks the LocalEndPoint property for an AddressFamily that matches the remoteEP parameter. If they do not match, then the LocalEndPoint property is reset to the remoteEP.AddressFamily and the Socket is recreated. Consequently, multiple IPv4 and IPv6 hosts can be contacted using a single ManagerSlave object.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


ManagerSlave Class Properties

[image]
PowerSNMP for .NET CF
ManagerSlave Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : ManagerSlave Class

"

For a list of all members of this type, see ManagerSlave members.

"

Public Properties

 | Name | Description
public Property | Socket | Gets the UdpSocket instance used for network communications.
Top

See Also

Reference

ManagerSlave Class
Dart.Snmp Namespace


Socket Property

[image]
PowerSNMP for .NET CF
Socket Property
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : Socket Property

Gets the UdpSocket instance used for network communications.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Socket As UdpSocket
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim value As UdpSocket

value = instance.Socket
C#
public UdpSocket Socket {get;}
Managed Extensions for C++
public: __property UdpSocket* get_Socket();
C++/CLI
public:
property UdpSocket^ Socket {
   UdpSocket^ get();
}

Property Value

Read-only value is available at run-time only.

Remarks

The socket is automatically created when accessed or used. It is initialized using the System.Net.Sockets.AddressFamily property. Use the Close method to release socket resources. Created sockets are bound to IpAddress.Any and an ephemeral port. If a specific binding is required, use the System.Net.Sockets.Socket.Bind(System.Net.EndPoint) method.

The ReceiveTimeout defaults to 1000.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


ManagerSlave Class Fields

[image]
PowerSNMP for .NET CF
ManagerSlave Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : ManagerSlave Class

"

For a list of all members of this type, see ManagerSlave members.

"

Public Fields

 | Name | Description
public Field | LocalEndPoint | Used to specify the local address, port, and address family. This must be set before the Socket property is used.
public Field | Manager | Provides read-only access to the parent Manager.
Top

See Also

Reference

ManagerSlave Class
Dart.Snmp Namespace


LocalEndPoint Field

[image]
PowerSNMP for .NET CF
LocalEndPoint Field
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : LocalEndPoint Field

Used to specify the local address, port, and address family. This must be set before the Socket property is used.

Syntax

Visual Basic (Declaration)
Public LocalEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim value As IPEndPoint

value = instance.LocalEndPoint

instance.LocalEndPoint = value
C#
public IPEndPoint LocalEndPoint
Managed Extensions for C++
public: IPEndPoint* LocalEndPoint
C++/CLI
public:
IPEndPoint^ LocalEndPoint

Remarks

The default address is IPAddress.Any. The default port is 0 (any). The default address family is AddressFamily.Internetwork (only AddressFamily.Internetwork and AddressFamily.InternetworkV6 are supported).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


Manager Field

[image]
PowerSNMP for .NET CF
Manager Field
See Also Send comments on this topic.
Dart.Snmp Namespace > ManagerSlave Class : Manager Field

Provides read-only access to the parent Manager.

Syntax

Visual Basic (Declaration)
Public ReadOnly Manager As Manager
Visual Basic (Usage) Copy Code
Dim instance As ManagerSlave
Dim value As Manager

value = instance.Manager
C#
public readonly Manager Manager
Managed Extensions for C++
public: readonly Manager* Manager
C++/CLI
public:
readonly Manager^ Manager

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerSlave Class
ManagerSlave Members


MessageBase Class

[image]
PowerSNMP for .NET CF
MessageBase Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : MessageBase Class

The MessageBase class is the abstract base class for all SNMP messages.

Object Model

MessageBase ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class MessageBase
Visual Basic (Usage) Copy Code
Dim instance As MessageBase
C#
public abstract class MessageBase
Managed Extensions for C++
public __gc abstract class MessageBase
C++/CLI
public ref class MessageBase abstract

Remarks

Two classes derive from MessageBase:

1. The TrapMessage class specializes the MessageBase class for SNMP version 1 trap processing.

2. The StandardMessage class specializes the MessageBase class for all other formats.

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.TrapMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Members
Dart.Snmp Namespace


MessageBase Class Members

[image]
PowerSNMP for .NET CF
MessageBase Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : MessageBase Class

The following tables list the members exposed by MessageBase.

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message.
public Field | Tag | Gets or sets a value that can store any associated object.
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message.
static (Shared in Visual Basic) | SysUpTime | Gets or sets the time since the agent was reinitialized, in hundredths of a second.
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message.
public Property | Version | Gets or sets the SNMP version used for encoding.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Initializes an instance of a class derived from MessageBase using the provided buffer.
public Method | Encode | Encodes all SNMP version 1/2 messages.
Top

See Also

Reference

MessageBase Class
Dart.Snmp Namespace


MessageBase Class Methods

[image]
PowerSNMP for .NET CF
MessageBase Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : MessageBase Class

"

For a list of all members of this type, see MessageBase members.

"

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Initializes an instance of a class derived from MessageBase using the provided buffer.
public Method | Encode | Encodes all SNMP version 1/2 messages.
Top

See Also

Reference

MessageBase Class
Dart.Snmp Namespace


Create Method

[image]
PowerSNMP for .NET CF
Create Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageBase Class : Create Method

source
A Segment containing the source (encoded) SNMP message. Version 1/2/3 is supported.
origin
An IPEndPoint indicating the source of the message. Used to initialize MessageBase.Origin. Can be null.
users
A Dictionary containing Username strings as keys and Passwords objects as values. Used to authenticate and decrypt SNMP3 messages. Can be null.
mib
A MibNodes object that defines the MIB.
Initializes an instance of a class derived from MessageBase using the provided buffer.

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal source As Segment, _
   ByVal origin As IPEndPoint, _
   ByVal users As Dictionary(Of String,Passwords), _
   ByVal mib As MibNodes _
) As MessageBase
Visual Basic (Usage) Copy Code
Dim source As Segment
Dim origin As IPEndPoint
Dim users As Dictionary(Of String,Passwords)
Dim mib As MibNodes
Dim value As MessageBase

value = MessageBase.Create(source, origin, users, mib)
C#
public static MessageBase Create(
   Segment source,
   IPEndPoint origin,
   Dictionary<string,Passwords> users,
   MibNodes mib
)
Managed Extensions for C++
public: static MessageBase* Create(
   Segment* source,
   IPEndPoint* origin,
   Dictionary<string*,Passwords*>* users,
   MibNodes* mib
)
C++/CLI
public:
static MessageBase^ Create(
   Segment^ source,
   IPEndPoint^ origin,
   Dictionary<String^,Passwords^>^ users,
   MibNodes^ mib
)

Parameters

source
A Segment containing the source (encoded) SNMP message. Version 1/2/3 is supported.
origin
An IPEndPoint indicating the source of the message. Used to initialize MessageBase.Origin. Can be null.
users
A Dictionary containing Username strings as keys and Passwords objects as values. Used to authenticate and decrypt SNMP3 messages. Can be null.
mib
A MibNodes object that defines the MIB.

Return Value

A newly created message.

Exceptions

Exception | Description
Dart.Snmp.DecodingException | A decoding problem was experienced.
Dart.Snmp.SecurityException | A security related problem was experienced while decoding the message. Thrown if a password is required and not present in the cache and passwordDelegate is null.

Remarks

The returned MessageBase object will normally be cast to the appropriate type before being used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Class
MessageBase Members


Encode Method

[image]
PowerSNMP for .NET CF
Encode Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageBase Class : Encode Method

Encodes all SNMP version 1/2 messages.

Syntax

Visual Basic (Declaration)
Public Overridable Function Encode() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As MessageBase
Dim value() As Byte

value = instance.Encode()
C#
public virtual byte[] Encode()
Managed Extensions for C++
public: virtual byte[]* Encode();
C++/CLI
public:
virtual array<byte>^ Encode();

Return Value

A byte array with the encoded message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Class
MessageBase Members


MessageBase Class Properties

[image]
PowerSNMP for .NET CF
MessageBase Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : MessageBase Class

"

For a list of all members of this type, see MessageBase members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message.
static (Shared in Visual Basic) | SysUpTime | Gets or sets the time since the agent was reinitialized, in hundredths of a second.
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message.
public Property | Version | Gets or sets the SNMP version used for encoding.
Top

See Also

Reference

MessageBase Class
Dart.Snmp Namespace


EncodedMessage Property

[image]
PowerSNMP for .NET CF
EncodedMessage Property
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageBase Class : EncodedMessage Property

Returns the encoded message.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EncodedMessage As Segment
Visual Basic (Usage) Copy Code
Dim instance As MessageBase
Dim value As Segment

value = instance.EncodedMessage
C#
public Segment EncodedMessage {get;}
Managed Extensions for C++
public: __property Segment* get_EncodedMessage();
C++/CLI
public:
property Segment^ EncodedMessage {
   Segment^ get();
}

Example

The following example demonstrates logging request and response messages to disk.
C# Copy Code
//Create Get Request
GetMessage request = new GetMessage();
request.Community = "public";
request.Version = SnmpVersion.One;
request.Variables.Add(manager1.Mib.CreateVariable(NodeName.sysDescr));

//Send request and get response
ManagerSlave slave = new ManagerSlave(manager1);
ResponseMessage response = slave.GetResponse(request, myAgentAddress);

//Log the request and response PDUs
FileStream file = new FileStream("log.txt", FileMode.Append, FileAccess.Write);
string requestLabel = "\r\nRequest:\r\n";
string responseLabel = "\r\nResponse:\r\n";
file.Write(System.Text.Encoding.Default.GetBytes(requestLabel), 0, requestLabel.Length);
file.Write(request.EncodedMessage.Buffer, request.EncodedMessage.Offset, request.EncodedMessage.Count);
file.Write(System.Text.Encoding.Default.GetBytes(responseLabel), 0, responseLabel.Length);
file.Write(response.EncodedMessage.Buffer, response.EncodedMessage.Offset, response.EncodedMessage.Count);
file.Close();
Visual Basic Copy Code
'Create Get Request
Dim request As GetMessage = New GetMessage()
request.Community = "public"
request.Version = SnmpVersion.One
request.Variables.Add(manager1.Mib.CreateVariable(NodeName.sysDescr))

'Send request and get response
Dim slave As ManagerSlave = New ManagerSlave(manager1)
Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

'Log the request and response PDUs
Dim file As FileStream = New FileStream("log.txt", FileMode.Append, FileAccess.Write)
Dim requestLabel As String = Constants.vbCrLf & "Request:" & Constants.vbCrLf
Dim responseLabel As String = Constants.vbCrLf & "Response:" & Constants.vbCrLf
file.Write(System.Text.Encoding.Default.GetBytes(requestLabel), 0, requestLabel.Length)
file.Write(request.EncodedMessage.Buffer, request.EncodedMessage.Offset, request.EncodedMessage.Count)
file.Write(System.Text.Encoding.Default.GetBytes(responseLabel), 0, responseLabel.Length)
file.Write(response.EncodedMessage.Buffer, response.EncodedMessage.Offset, response.EncodedMessage.Count)
file.Close()

Remarks

For messages received asynchronously, this property contains a reference to the byte array used to receive the encoded message. Data in this byte array is overwritten as each message is received, so it can only be used reliably within the user's function handling the received trap or notification (Manager), or received requests (Agent).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Class
MessageBase Members


Origin Property

[image]
PowerSNMP for .NET CF
Origin Property
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageBase Class : Origin Property

Gets a value that indicates the origin of a received message or can be set to hold the destination of a message.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As MessageBase
Dim value As IPEndPoint

value = instance.Origin
C#
public IPEndPoint Origin {get;}
Managed Extensions for C++
public: __property IPEndPoint* get_Origin();
C++/CLI
public:
property IPEndPoint^ Origin {
   IPEndPoint^ get();
}

Property Value

The value is initialized by Create or set by the user.

Remarks

The value is not used in encoded messages, and is advisory in nature.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Class
MessageBase Members


SysUpTime Property

[image]
PowerSNMP for .NET CF
SysUpTime Property
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageBase Class : SysUpTime Property

Gets or sets the time since the agent was reinitialized, in hundredths of a second.

Syntax

Visual Basic (Declaration)
Public Shared Property SysUpTime As Long
Visual Basic (Usage) Copy Code
Dim value As Long

MessageBase.SysUpTime = value

value = MessageBase.SysUpTime
C#
public static long SysUpTime {get; set;}
Managed Extensions for C++
public: __property static long get_SysUpTime();
public: __property static void set_SysUpTime(
   long value
);
C++/CLI
public:
static property int64 SysUpTime {
   int64 get();
   void set (    int64 value);
}

Property Value

This property is initialized to 0 when the library is loaded (normally at the time your application starts).

Remarks

This value is used to initialize TrapMessage.SysUpTime and SysUpTime when they are encoded.

This value is also used by the ResponseMessage.ResponseMessage Constructor(RequestMessage,VariableList) constructor when creating a ResponseMessage if MessageBase.Variables contains a sysUpTime Variable.

Applications can set this property to other values to indicate the Agent has been up for a different length of time.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Class
MessageBase Members


Variables Property

[image]
PowerSNMP for .NET CF
Variables Property
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageBase Class : Variables Property

Gets or sets the VariableCollection containing the IDs and their associated values in the message.

Syntax

Visual Basic (Declaration)
Public Overridable Property Variables As VariableCollection
Visual Basic (Usage) Copy Code
Dim instance As MessageBase
Dim value As VariableCollection

instance.Variables = value

value = instance.Variables
C#
public virtual VariableCollection Variables {get; set;}
Managed Extensions for C++
public: __property virtual VariableCollection* get_Variables();
public: __property virtual void set_Variables(
   VariableCollection* value
);
C++/CLI
public:
virtual property VariableCollection^ Variables {
   VariableCollection^ get();
   void set (    VariableCollection^ value);
}

Property Value

This value is initialized when a message is decoded. The application will normally add variables to this collection when constructing a message.

Remarks

Gets or sets the VariableCollection containing the IDs and their associated values in the message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Class
MessageBase Members


Version Property

[image]
PowerSNMP for .NET CF
Version Property
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageBase Class : Version Property

Gets or sets the SNMP version used for encoding.

Syntax

Visual Basic (Declaration)
Public Property Version As SnmpVersion
Visual Basic (Usage) Copy Code
Dim instance As MessageBase
Dim value As SnmpVersion

instance.Version = value

value = instance.Version
C#
public SnmpVersion Version {get; set;}
Managed Extensions for C++
public: __property SnmpVersion get_Version();
public: __property void set_Version(
   SnmpVersion value
);
C++/CLI
public:
property SnmpVersion Version {
   SnmpVersion get();
   void set (    SnmpVersion value);
}

Property Value

This value is initialized when a message is decoded. The application can set this property to indicate the SNMP version to be used for encoding.

Exceptions

Exception | Description
System.ArgumentException | An invalid version is being specified for the message.

Remarks

Messages of type TrapMessage can only be set to SnmpVersion.One.

Messages of type InformMessage, GetBulkMessage, ReportMessage and NotificationMessage can only be set to SnmpVersion.Two or SnmpVersion.Three.

Messages of type ResponseMessage, SetMessage, GetMessage and GetNextMessage can be set to any value.

If set to SnmpVersion.Three then StandardMessage.Security should be initialized to the security values needed to control the authentication and encryption process while encoding. When decoding SnmpVersion.Three packets the Agent and Manager get their passwords from the Users property.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Class
MessageBase Members


MessageBase Class Fields

[image]
PowerSNMP for .NET CF
MessageBase Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : MessageBase Class

"

For a list of all members of this type, see MessageBase members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message.
public Field | Tag | Gets or sets a value that can store any associated object.
Top

See Also

Reference

MessageBase Class
Dart.Snmp Namespace


Community Field

[image]
PowerSNMP for .NET CF
Community Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageBase Class : Community Field

Gets or sets the community field in the message.

Syntax

Visual Basic (Declaration)
Public Community As String
Visual Basic (Usage) Copy Code
Dim instance As MessageBase
Dim value As String

value = instance.Community

instance.Community = value
C#
public string Community
Managed Extensions for C++
public: string* Community
C++/CLI
public:
String^ Community

Property Value

Initialized to "public" when the default constructor is used. This property is not used for version 3 packets.

Remarks

This property is used as a primitive type of authentication. The application can check for valid values when a version 1/2 RequestMessage is processed in the AgentMessageReceived delegate function.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Class
MessageBase Members


Tag Field

[image]
PowerSNMP for .NET CF
Tag Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageBase Class : Tag Field

Gets or sets a value that can store any associated object.

Syntax

Visual Basic (Declaration)
Public Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As MessageBase
Dim value As Object

value = instance.Tag

instance.Tag = value
C#
public object Tag
Managed Extensions for C++
public: Object* Tag
C++/CLI
public:
Object^ Tag

Property Value

Any System.Object instance.

Remarks

The value is not included in the encoded message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageBase Class
MessageBase Members


MessageEventArgs Class

[image]
PowerSNMP for .NET CF
MessageEventArgs Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : MessageEventArgs Class

Provides data for the SnmpBase.Message event.

Object Model

MessageEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class MessageEventArgs
   Inherits Dart.Common.UserStateEventArgs
Visual Basic (Usage) Copy Code
Dim instance As MessageEventArgs
C#
public class MessageEventArgs : Dart.Common.UserStateEventArgs
Managed Extensions for C++
public __gc class MessageEventArgs : public Dart.Common.UserStateEventArgs
C++/CLI
public ref class MessageEventArgs : public Dart.Common.UserStateEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Common.UserStateEventArgs
Dart.Snmp.MessageEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageEventArgs Members
Dart.Snmp Namespace


MessageEventArgs Class Members

[image]
PowerSNMP for .NET CF
MessageEventArgs Class Members
See Also Fields Send comments on this topic.
Dart.Snmp Namespace : MessageEventArgs Class

The following tables list the members exposed by MessageEventArgs.

Public Fields

 | Name | Description
public Field | Messages | An array of messages derived from MessageBase.
public Field | UserState | Gets the user information provided by the UserState event. (Inherited from Dart.Common.UserStateEventArgs)
Top

See Also

Reference

MessageEventArgs Class
Dart.Snmp Namespace


MessageEventArgs Class Fields

[image]
PowerSNMP for .NET CF
MessageEventArgs Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : MessageEventArgs Class

"

For a list of all members of this type, see MessageEventArgs members.

"

Public Fields

 | Name | Description
public Field | Messages | An array of messages derived from MessageBase.
public Field | UserState | Gets the user information provided by the UserState event. (Inherited from Dart.Common.UserStateEventArgs)
Top

See Also

Reference

MessageEventArgs Class
Dart.Snmp Namespace


Messages Field

[image]
PowerSNMP for .NET CF
Messages Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MessageEventArgs Class : Messages Field

An array of messages derived from MessageBase.

Syntax

Visual Basic (Declaration)
Public ReadOnly Messages As MessageBase()
Visual Basic (Usage) Copy Code
Dim instance As MessageEventArgs
Dim value() As MessageBase

value = instance.Messages
C#
public readonly MessageBase[] Messages
Managed Extensions for C++
public: readonly MessageBase*[]* Messages
C++/CLI
public:
readonly array<MessageBase^>^ Messages

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageEventArgs Class
MessageEventArgs Members


MibDefinition Class

[image]
PowerSNMP for .NET CF
MibDefinition Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : MibDefinition Class

Base class containing members that are common to MibNode and MibTrap.

Object Model

MibDefinition Class

Syntax

Visual Basic (Declaration)
Public Class MibDefinition
Visual Basic (Usage) Copy Code
Dim instance As MibDefinition
C#
public class MibDefinition
Managed Extensions for C++
public __gc class MibDefinition
C++/CLI
public ref class MibDefinition

Inheritance Hierarchy

System.Object
Dart.Snmp.MibDefinition
Dart.Snmp.MibNode
Dart.Snmp.MibTrap

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibDefinition Members
Dart.Snmp Namespace


MibDefinition Class Members

[image]
PowerSNMP for .NET CF
MibDefinition Class Members
See Also Fields Send comments on this topic.
Dart.Snmp Namespace : MibDefinition Class

The following tables list the members exposed by MibDefinition.

Public Constructors

 | Name | Description
public Constructor | MibDefinition Constructor | Base constructor for MibNode and MibTrap.
Top

Public Fields

 | Name | Description
public Field | Description | Gets or sets the description.
public Field | Module | Gets or sets the module identifier.
public Field | Name | Gets or sets the human readable name.
Top

See Also

Reference

MibDefinition Class
Dart.Snmp Namespace


MibDefinition Constructor

[image]
PowerSNMP for .NET CF
MibDefinition Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > MibDefinition Class : MibDefinition Constructor

description
Description of the MIB definition.
name
Name of the MIB definition.
module
Module name where the definition occurs.
Base constructor for MibNode and MibTrap.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal description As String, _
   ByVal name As String, _
   ByVal module As String _
)
Visual Basic (Usage) Copy Code
Dim description As String
Dim name As String
Dim module As String

Dim instance As New MibDefinition(description, name, module)
C#
public MibDefinition(
   string description,
   string name,
   string module
)
Managed Extensions for C++
public: MibDefinition(
   string* description,
   string* name,
   string* module
)
C++/CLI
public:
MibDefinition(
   String^ description,
   String^ name,
   String^ module
)

Parameters

description
Description of the MIB definition.
name
Name of the MIB definition.
module
Module name where the definition occurs.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibDefinition Class
MibDefinition Members


MibDefinition Class Fields

[image]
PowerSNMP for .NET CF
MibDefinition Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : MibDefinition Class

"

For a list of all members of this type, see MibDefinition members.

"

Public Fields

 | Name | Description
public Field | Description | Gets or sets the description.
public Field | Module | Gets or sets the module identifier.
public Field | Name | Gets or sets the human readable name.
Top

See Also

Reference

MibDefinition Class
Dart.Snmp Namespace


Description Field

[image]
PowerSNMP for .NET CF
Description Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibDefinition Class : Description Field

Gets or sets the description.

Syntax

Visual Basic (Declaration)
Public ReadOnly Description As String
Visual Basic (Usage) Copy Code
Dim instance As MibDefinition
Dim value As String

value = instance.Description
C#
public readonly string Description
Managed Extensions for C++
public: readonly string* Description
C++/CLI
public:
readonly String^ Description

Property Value

String

Remarks

The value is extracted from the MIB file used to define the MIB node or trap.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibDefinition Class
MibDefinition Members


Module Field

[image]
PowerSNMP for .NET CF
Module Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibDefinition Class : Module Field

Gets or sets the module identifier.

Syntax

Visual Basic (Declaration)
Public ReadOnly Module As String
Visual Basic (Usage) Copy Code
Dim instance As MibDefinition
Dim value As String

value = instance.Module
C#
public readonly string Module
Managed Extensions for C++
public: readonly string* Module
C++/CLI
public:
readonly String^ Module

Property Value

String

Remarks

The value is extracted from the MIB file used to define the MIB node or trap.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibDefinition Class
MibDefinition Members


Name Field

[image]
PowerSNMP for .NET CF
Name Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibDefinition Class : Name Field

Gets or sets the human readable name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Name As String
Visual Basic (Usage) Copy Code
Dim instance As MibDefinition
Dim value As String

value = instance.Name
C#
public readonly string Name
Managed Extensions for C++
public: readonly string* Name
C++/CLI
public:
readonly String^ Name

Property Value

String

Remarks

This property is used as the key for looking up a specific MibNode in the MibNodes dictionary or looking up a specific MibTrap in the MibNodes.Traps dictionary.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibDefinition Class
MibDefinition Members


MibNode Class

[image]
PowerSNMP for .NET CF
MibNode Class
Members Example See Also Send comments on this topic.
Dart.Snmp Namespace : MibNode Class

This class is used to represent nodes and objects defined in MIB files.

Object Model

MibNode Class

Syntax

Visual Basic (Declaration)
Public Class MibNode
   Inherits MibDefinition
Visual Basic (Usage) Copy Code
Dim instance As MibNode
C#
public class MibNode : MibDefinition
Managed Extensions for C++
public __gc class MibNode : public MibDefinition
C++/CLI
public ref class MibNode : public MibDefinition

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Remarks

Object defined in MIB-II are automatically created and added to the MibNodes dictionary. Developers can add additional MibNode instances by importing them directly from MIB files or by manually adding instances of this class to the MibNodes class.

Inheritance Hierarchy

System.Object
Dart.Snmp.MibDefinition
Dart.Snmp.MibNode

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Members
Dart.Snmp Namespace


MibNode Class Members

[image]
PowerSNMP for .NET CF
MibNode Class Members
See Also Fields Methods Send comments on this topic.
Dart.Snmp Namespace : MibNode Class

The following tables list the members exposed by MibNode.

Public Constructors

 | Name | Description
public Constructor | MibNode Constructor | Initializes a new instance of the MibNode class.
Top

Public Fields

 | Name | Description
public Field | Access | Gets or sets the Access value of the MibNode.
public Field | Augments | Gets or sets the AUGMENTS clause of the MibNode.
public Field | ComposedSyntax | Gets or sets the Syntax of the MibNode as defined in the MIB.
public Field | DefVal | Gets or sets the DEFVAL clause of the MibNode.
public Field | Description | Gets or sets the description. (Inherited from Dart.Snmp.MibDefinition)
public Field | Iid | This value is created by adding a ".0" suffix to the Oid.
public Field | Index | Gets or sets the INDEX clause of the MibNode.
public Field | Module | Gets or sets the module identifier. (Inherited from Dart.Snmp.MibDefinition)
public Field | Name | Gets or sets the human readable name. (Inherited from Dart.Snmp.MibDefinition)
public Field | Notifications | Gets or sets the NOTIFICATIONS clause defined in the MIB.
public Field | Objects | Gets the OBJECTS clause defined in the MIB.
public Field | Oid | Gets or sets the identifier of the MibNode.
public Field | Status | Gets or sets the Status value of the MibNode.
public Field | Syntax | Gets or sets the Syntax of the MibNode.
public Field | Units | Gets or sets the UNITS clause of the MibNode.
public Field | Usage | Gets or sets the type of the MibNode.
public Field | ValueType | Gets or sets the .NET class Type (derived from SimpleTaggedType) used by this MibNode.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetOid | Strips off the trailing instance suffix and returns the root OID.
public Method | ToString | Creates a string representation of the MibNode that can be used as a label.
Top

See Also

Reference

MibNode Class
Dart.Snmp Namespace


MibNode Constructor

[image]
PowerSNMP for .NET CF
MibNode Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : MibNode Constructor

usage
A MibNodeUsage value that indicates the usage of the MibNode.
oid
String value of the OID of the MibNode.
syntax
String value that describes the syntax of the MibNode.
access
Access enum that defines the availability of the MibNode.
status
Status enum that describes the current status of the MibNode.
description
A string value assigned to the Description of the MibNode.
name
A string value assigned to the Name of the MibNode.
valueType
System.Type value that describes the .NET type of the value associated with the MibNode.
units
String value indicating the units.
defVal
String value indicating the default value.
index
String value indicating the index used if Usage is Dart.Snmp.Usage.TableEntry.
augments
String value indicating the augments field imported from the MIB.
objects
String value indicating the objects if Usage is Dart.Snmp.Usage.Notification or Dart.Snmp.Usage.Group.
notifications
String value indicating the notifications if Usage is Dart.Snmp.Usage.Group.
module
String value indicating the source module (MIB file).
composedsyntax
String value that indicates the raw syntax from a mib definition.
Initializes a new instance of the MibNode class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal usage As Usage, _
   ByVal oid As String, _
   ByVal syntax As String, _
   ByVal access As Access, _
   ByVal status As Status, _
   ByVal description As String, _
   ByVal name As String, _
   ByVal valueType As Type, _
   ByVal units As String, _
   ByVal defVal As String, _
   ByVal index As String, _
   ByVal augments As String, _
   ByVal objects As String, _
   ByVal notifications As String, _
   ByVal module As String, _
   ByVal composedsyntax As String _
)
Visual Basic (Usage) Copy Code
Dim usage As Usage
Dim oid As String
Dim syntax As String
Dim access As Access
Dim status As Status
Dim description As String
Dim name As String
Dim valueType As Type
Dim units As String
Dim defVal As String
Dim index As String
Dim augments As String
Dim objects As String
Dim notifications As String
Dim module As String
Dim composedsyntax As String

Dim instance As New MibNode(usage, oid, syntax, access, status, description, name, valueType, units, defVal, index, augments, objects, notifications, module, composedsyntax)
C#
public MibNode(
   Usage usage,
   string oid,
   string syntax,
   Access access,
   Status status,
   string description,
   string name,
   Type valueType,
   string units,
   string defVal,
   string index,
   string augments,
   string objects,
   string notifications,
   string module,
   string composedsyntax
)
Managed Extensions for C++
public: MibNode(
   Usage usage,
   string* oid,
   string* syntax,
   Access access,
   Status status,
   string* description,
   string* name,
   Type* valueType,
   string* units,
   string* defVal,
   string* index,
   string* augments,
   string* objects,
   string* notifications,
   string* module,
   string* composedsyntax
)
C++/CLI
public:
MibNode(
   Usage usage,
   String^ oid,
   String^ syntax,
   Access access,
   Status status,
   String^ description,
   String^ name,
   Type^ valueType,
   String^ units,
   String^ defVal,
   String^ index,
   String^ augments,
   String^ objects,
   String^ notifications,
   String^ module,
   String^ composedsyntax
)

Parameters

usage
A MibNodeUsage value that indicates the usage of the MibNode.
oid
String value of the OID of the MibNode.
syntax
String value that describes the syntax of the MibNode.
access
Access enum that defines the availability of the MibNode.
status
Status enum that describes the current status of the MibNode.
description
A string value assigned to the Description of the MibNode.
name
A string value assigned to the Name of the MibNode.
valueType
System.Type value that describes the .NET type of the value associated with the MibNode.
units
String value indicating the units.
defVal
String value indicating the default value.
index
String value indicating the index used if Usage is Dart.Snmp.Usage.TableEntry.
augments
String value indicating the augments field imported from the MIB.
objects
String value indicating the objects if Usage is Dart.Snmp.Usage.Notification or Dart.Snmp.Usage.Group.
notifications
String value indicating the notifications if Usage is Dart.Snmp.Usage.Group.
module
String value indicating the source module (MIB file).
composedsyntax
String value that indicates the raw syntax from a mib definition.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


MibNode Class Methods

[image]
PowerSNMP for .NET CF
MibNode Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : MibNode Class

"

For a list of all members of this type, see MibNode members.

"

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetOid | Strips off the trailing instance suffix and returns the root OID.
public Method | ToString | Creates a string representation of the MibNode that can be used as a label.
Top

See Also

Reference

MibNode Class
Dart.Snmp Namespace


GetOid Method

[image]
PowerSNMP for .NET CF
GetOid Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : GetOid Method

iid
Any instance id.
Strips off the trailing instance suffix and returns the root OID.

Syntax

Visual Basic (Declaration)
Public Shared Function GetOid( _
   ByVal iid As String _
) As String
Visual Basic (Usage) Copy Code
Dim iid As String
Dim value As String

value = MibNode.GetOid(iid)
C#
public static string GetOid(
   string iid
)
Managed Extensions for C++
public: static string* GetOid(
   string* iid
)
C++/CLI
public:
static String^ GetOid(
   String^ iid
)

Parameters

iid
Any instance id.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : ToString Method

Creates a string representation of the MibNode that can be used as a label.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

String

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


MibNode Class Fields

[image]
PowerSNMP for .NET CF
MibNode Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : MibNode Class

"

For a list of all members of this type, see MibNode members.

"

Public Fields

 | Name | Description
public Field | Access | Gets or sets the Access value of the MibNode.
public Field | Augments | Gets or sets the AUGMENTS clause of the MibNode.
public Field | ComposedSyntax | Gets or sets the Syntax of the MibNode as defined in the MIB.
public Field | DefVal | Gets or sets the DEFVAL clause of the MibNode.
public Field | Description | Gets or sets the description. (Inherited from Dart.Snmp.MibDefinition)
public Field | Iid | This value is created by adding a ".0" suffix to the Oid.
public Field | Index | Gets or sets the INDEX clause of the MibNode.
public Field | Module | Gets or sets the module identifier. (Inherited from Dart.Snmp.MibDefinition)
public Field | Name | Gets or sets the human readable name. (Inherited from Dart.Snmp.MibDefinition)
public Field | Notifications | Gets or sets the NOTIFICATIONS clause defined in the MIB.
public Field | Objects | Gets the OBJECTS clause defined in the MIB.
public Field | Oid | Gets or sets the identifier of the MibNode.
public Field | Status | Gets or sets the Status value of the MibNode.
public Field | Syntax | Gets or sets the Syntax of the MibNode.
public Field | Units | Gets or sets the UNITS clause of the MibNode.
public Field | Usage | Gets or sets the type of the MibNode.
public Field | ValueType | Gets or sets the .NET class Type (derived from SimpleTaggedType) used by this MibNode.
Top

See Also

Reference

MibNode Class
Dart.Snmp Namespace


Access Field

[image]
PowerSNMP for .NET CF
Access Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Access Field

Gets or sets the Access value of the MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Access As Access
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As Access

value = instance.Access
C#
public readonly Access Access
Managed Extensions for C++
public: readonly Access Access
C++/CLI
public:
readonly Access Access

Property Value

Returns an Access value assigned to the MibNode.

Remarks

Access describes the operations that can be performed by a Variable. The Agent uses this information when creating a ResponseMessage for Get, GetNext, GetBulk and Set Requests to determine whether the request is a valid operation on the variable.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Augments Field

[image]
PowerSNMP for .NET CF
Augments Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Augments Field

Gets or sets the AUGMENTS clause of the MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Augments As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.Augments
C#
public readonly string Augments
Managed Extensions for C++
public: readonly string* Augments
C++/CLI
public:
readonly String^ Augments

Property Value

String

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


ComposedSyntax Field

[image]
PowerSNMP for .NET CF
ComposedSyntax Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : ComposedSyntax Field

Gets or sets the Syntax of the MibNode as defined in the MIB.

Syntax

Visual Basic (Declaration)
Public ReadOnly ComposedSyntax As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.ComposedSyntax
C#
public readonly string ComposedSyntax
Managed Extensions for C++
public: readonly string* ComposedSyntax
C++/CLI
public:
readonly String^ ComposedSyntax

Property Value

Returns a string containing the Syntax of the MibNode as defined in the MIB.

Remarks

Syntax describes the data type for a Variable object. Syntax may also describe additional constraints of the data such as a length or maximum value.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


DefVal Field

[image]
PowerSNMP for .NET CF
DefVal Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : DefVal Field

Gets or sets the DEFVAL clause of the MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly DefVal As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.DefVal
C#
public readonly string DefVal
Managed Extensions for C++
public: readonly string* DefVal
C++/CLI
public:
readonly String^ DefVal

Property Value

String

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Iid Field

[image]
PowerSNMP for .NET CF
Iid Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Iid Field

This value is created by adding a ".0" suffix to the Oid.

Syntax

Visual Basic (Declaration)
Public ReadOnly Iid As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.Iid
C#
public readonly string Iid
Managed Extensions for C++
public: readonly string* Iid
C++/CLI
public:
readonly String^ Iid

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Index Field

[image]
PowerSNMP for .NET CF
Index Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Index Field

Gets or sets the INDEX clause of the MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Index As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.Index
C#
public readonly string Index
Managed Extensions for C++
public: readonly string* Index
C++/CLI
public:
readonly String^ Index

Property Value

String

Remarks

Usually provided when MibNode.Usage is Dart.Snmp.Usage.TableEntry, this property defines how the associated table column is indexed into.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Notifications Field

[image]
PowerSNMP for .NET CF
Notifications Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Notifications Field

Gets or sets the NOTIFICATIONS clause defined in the MIB.

Syntax

Visual Basic (Declaration)
Public ReadOnly Notifications As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.Notifications
C#
public readonly string Notifications
Managed Extensions for C++
public: readonly string* Notifications
C++/CLI
public:
readonly String^ Notifications

Property Value

String

Remarks

Used when MibNode.Usage is Dart.Snmp.Usage.Group.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Objects Field

[image]
PowerSNMP for .NET CF
Objects Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Objects Field

Gets the OBJECTS clause defined in the MIB.

Syntax

Visual Basic (Declaration)
Public ReadOnly Objects As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.Objects
C#
public readonly string Objects
Managed Extensions for C++
public: readonly string* Objects
C++/CLI
public:
readonly String^ Objects

Property Value

String

Remarks

Used when MibNode.Usage is Dart.Snmp.Usage.Notification or Dart.Snmp.Usage.Group.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Oid Field

[image]
PowerSNMP for .NET CF
Oid Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Oid Field

Gets or sets the identifier of the MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Oid As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.Oid
C#
public readonly string Oid
Managed Extensions for C++
public: readonly string* Oid
C++/CLI
public:
readonly String^ Oid

Property Value

Returns a string in the form of n.n.n...n that represents the OID value assigned.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Status Field

[image]
PowerSNMP for .NET CF
Status Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Status Field

Gets or sets the Status value of the MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Status As Status
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As Status

value = instance.Status
C#
public readonly Status Status
Managed Extensions for C++
public: readonly Status Status
C++/CLI
public:
readonly Status Status

Property Value

Returns a Status value assigned to the MibNode.

Remarks

Status describes the suggested implementation requirement of the MibNode.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Syntax Field

[image]
PowerSNMP for .NET CF
Syntax Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Syntax Field

Gets or sets the Syntax of the MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Syntax As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.Syntax
C#
public readonly string Syntax
Managed Extensions for C++
public: readonly string* Syntax
C++/CLI
public:
readonly String^ Syntax

Property Value

Returns a string containing the Syntax of the MibNode (expanded to include all textual conventions).

Remarks

Syntax describes the data type for a Variable object. Syntax may also describe additional constraints of the data such as a length or maximum value.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Units Field

[image]
PowerSNMP for .NET CF
Units Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Units Field

Gets or sets the UNITS clause of the MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Units As String
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As String

value = instance.Units
C#
public readonly string Units
Managed Extensions for C++
public: readonly string* Units
C++/CLI
public:
readonly String^ Units

Property Value

String

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


Usage Field

[image]
PowerSNMP for .NET CF
Usage Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : Usage Field

Gets or sets the type of the MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Usage As Usage
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As Usage

value = instance.Usage
C#
public readonly Usage Usage
Managed Extensions for C++
public: readonly Usage Usage
C++/CLI
public:
readonly Usage Usage

Property Value

Returns a Usage value that indicates how the MibNode can be used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


ValueType Field

[image]
PowerSNMP for .NET CF
ValueType Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNode Class : ValueType Field

Gets or sets the .NET class Type (derived from SimpleTaggedType) used by this MibNode.

Syntax

Visual Basic (Declaration)
Public ReadOnly ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As MibNode
Dim value As Type

value = instance.ValueType
C#
public readonly Type ValueType
Managed Extensions for C++
public: readonly Type* ValueType
C++/CLI
public:
readonly Type^ ValueType

Property Value

One of the types in the Dart.Snmp.SimpleType namespace will be returned.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNode Class
MibNode Members


MibNodes Class

[image]
PowerSNMP for .NET CF
MibNodes Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : MibNodes Class

The MibNodes Class localizes all mib file management to a single class.

Object Model

MibNodes ClassMibNode Class

Syntax

Visual Basic (Declaration)
Public Class MibNodes
   Inherits System.Collections.Generic.Dictionary(Of String,MibNode)
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
C#
public class MibNodes : System.Collections.Generic.Dictionary<string,MibNode>
Managed Extensions for C++
public __gc class MibNodes : public System.Collections.Generic.Dictionary<string,MibNode>
C++/CLI
public ref class MibNodes : public System.Collections.Generic.Dictionary<String,MibNode>

Remarks

Use MibNodes[NodeName.xxx.ToString()] to lookup specific names.

Inheritance Hierarchy

System.Object
System.Collections.Generic.Dictionary<TKey,TValue>
Dart.Snmp.MibNodes

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Members
Dart.Snmp Namespace


MibNodes Class Members

[image]
PowerSNMP for .NET CF
MibNodes Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : MibNodes Class

The following tables list the members exposed by MibNodes.

Public Constructors

 | Name | Description
public Constructor | MibNodes Constructor | The default constuctor.
Top

Public Fields

 | Name | Description
public Field | MibNodesByOid | The MibNodes class is used to list and look-up the MibNode objects known to the Manager.
public Field | Modules | Gets a hash table of modules that have been parsed.
public Field | Traps | Gets a hash table of MibTrap objects that have been parsed.
Top

Public Properties

 | Name | Description
public Property | Comparer | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Property | Count | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Property | Item | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Property | Keys | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Property | Values | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
Top

Public Methods

 | Name | Description
public Method | Add | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | Clear | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | ContainsKey | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | ContainsValue | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | CreateVariable | Overloaded. Creates a variable from the specified NodeName and value.
public Method | GenerateNodes | Generates MibNode and MibTrap objects from previously parsed mib files and adds them to the Dictionary using MibDefinition.Name as key.
public Method | GetByIid | Gets a MibNode using the specified IID.
public Method | GetByNodeName | Returns the MibNode with the given name.
public Method | GetByOid | Gets a MibNode with the specified OID.
public Method | GetEnumerator | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | GetObjectData | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
static (Shared in Visual Basic) | GetOid | Returns the OID associated with the specified IID.
public Method | Import | Imports additional MibNode and MibTrap objects.
public Method | OnDeserialization | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | Parse | Parses the mib file provided.
public Method | Populate | Populates a TreeView with MibNode objects.
public Method | Remove | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | Reset | Resets the collection to its default state.
public Method | TryGetValue | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
Top

See Also

Reference

MibNodes Class
Dart.Snmp Namespace


MibNodes Constructor

[image]
PowerSNMP for .NET CF
MibNodes Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : MibNodes Constructor

The default constuctor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New MibNodes()
C#
public MibNodes()
Managed Extensions for C++
public: MibNodes();
C++/CLI
public:
MibNodes();

Remarks

Use Use MibNodes[NodeName.xxx.ToString()] to get the MibNode object corresponding to the name.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


MibNodes Class Methods

[image]
PowerSNMP for .NET CF
MibNodes Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : MibNodes Class

"

For a list of all members of this type, see MibNodes members.

"

Public Methods

 | Name | Description
public Method | Add | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | Clear | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | ContainsKey | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | ContainsValue | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | CreateVariable | Overloaded. Creates a variable from the specified NodeName and value.
public Method | GenerateNodes | Generates MibNode and MibTrap objects from previously parsed mib files and adds them to the Dictionary using MibDefinition.Name as key.
public Method | GetByIid | Gets a MibNode using the specified IID.
public Method | GetByNodeName | Returns the MibNode with the given name.
public Method | GetByOid | Gets a MibNode with the specified OID.
public Method | GetEnumerator | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | GetObjectData | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
static (Shared in Visual Basic) | GetOid | Returns the OID associated with the specified IID.
public Method | Import | Imports additional MibNode and MibTrap objects.
public Method | OnDeserialization | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | Parse | Parses the mib file provided.
public Method | Populate | Populates a TreeView with MibNode objects.
public Method | Remove | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Method | Reset | Resets the collection to its default state.
public Method | TryGetValue | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
Top

See Also

Reference

MibNodes Class
Dart.Snmp Namespace


CreateVariable Method

[image]
PowerSNMP for .NET CF
CreateVariable Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : CreateVariable Method

Creates a variable from the specified NodeName and value.

Overload List

Overload | Description
CreateVariable(Enum,String) | Creates a variable from the specified NodeName and value.
CreateVariable(Enum) | Creates a variable from the specified NodeName.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


CreateVariable(Enum,String) Method

[image]
PowerSNMP for .NET CF
CreateVariable(Enum,String) Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class > CreateVariable Method : CreateVariable(Enum,String) Method

nodeName
The MibNode enumerated type to use.
value
The value of the variable.
Creates a variable from the specified NodeName and value.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateVariable( _
   ByVal nodeName As Enum, _
   ByVal value As String _
) As Variable
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim nodeName As Enum
Dim value As String
Dim value As Variable

value = instance.CreateVariable(nodeName, value)
C#
public Variable CreateVariable(
   Enum nodeName,
   string value
)
Managed Extensions for C++
public: Variable* CreateVariable(
   Enum* nodeName,
   string* value
)
C++/CLI
public:
Variable^ CreateVariable(
   Enum^ nodeName,
   String^ value
)

Parameters

nodeName
The MibNode enumerated type to use.
value
The value of the variable.

Return Value

A Variable with the specified value

Remarks

The nodeName parameter is an enumeration of default nodes. Variables cannot be created from dynamically added nodes using this method.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members
Overload List


CreateVariable(Enum) Method

[image]
PowerSNMP for .NET CF
CreateVariable(Enum) Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class > CreateVariable Method : CreateVariable(Enum) Method

nodeName
The MibNode enumerated type to use.
Creates a variable from the specified NodeName.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateVariable( _
   ByVal nodeName As Enum _
) As Variable
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim nodeName As Enum
Dim value As Variable

value = instance.CreateVariable(nodeName)
C#
public Variable CreateVariable(
   Enum nodeName
)
Managed Extensions for C++
public: Variable* CreateVariable(
   Enum* nodeName
)
C++/CLI
public:
Variable^ CreateVariable(
   Enum^ nodeName
)

Parameters

nodeName
The MibNode enumerated type to use.

Return Value

A Variable with an empty value

Remarks

The nodeName parameter is an enumeration of default nodes. Variables cannot be created from dynamically added nodes using this method.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members
Overload List


GenerateNodes Method

[image]
PowerSNMP for .NET CF
GenerateNodes Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : GenerateNodes Method

Generates MibNode and MibTrap objects from previously parsed mib files and adds them to the Dictionary using MibDefinition.Name as key.

Syntax

Visual Basic (Declaration)
Public Sub GenerateNodes()
Visual Basic (Usage) Copy Code
Dim instance As MibNodes

instance.GenerateNodes()
C#
public void GenerateNodes()
Managed Extensions for C++
public: void GenerateNodes();
C++/CLI
public:
void GenerateNodes();

Remarks

Parse will be normally be used once or multiple times before this method is used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


GetByIid Method

[image]
PowerSNMP for .NET CF
GetByIid Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : GetByIid Method

iid
The IID to use in the lookup.
Gets a MibNode using the specified IID.

Syntax

Visual Basic (Declaration)
Public Function GetByIid( _
   ByVal iid As String _
) As MibNode
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim iid As String
Dim value As MibNode

value = instance.GetByIid(iid)
C#
public MibNode GetByIid(
   string iid
)
Managed Extensions for C++
public: MibNode* GetByIid(
   string* iid
)
C++/CLI
public:
MibNode^ GetByIid(
   String^ iid
)

Parameters

iid
The IID to use in the lookup.

Return Value

A MibNode associated with the specified OID.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


GetByNodeName Method

[image]
PowerSNMP for .NET CF
GetByNodeName Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : GetByNodeName Method

nodeName
The name of the MibNode to get.
Returns the MibNode with the given name.

Syntax

Visual Basic (Declaration)
Public Function GetByNodeName( _
   ByVal nodeName As Enum _
) As MibNode
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim nodeName As Enum
Dim value As MibNode

value = instance.GetByNodeName(nodeName)
C#
public MibNode GetByNodeName(
   Enum nodeName
)
Managed Extensions for C++
public: MibNode* GetByNodeName(
   Enum* nodeName
)
C++/CLI
public:
MibNode^ GetByNodeName(
   Enum^ nodeName
)

Parameters

nodeName
The name of the MibNode to get.

Return Value

A MibNode

Remarks

The nodeName parameter is an enumeration of node names. Intrinsic names are provided by the Dart.Snmp.NodeName enumeration. Node names of imported MIB files are provided by the Dart.Snmp.Mib.NodeName enumeration.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


GetByOid Method

[image]
PowerSNMP for .NET CF
GetByOid Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : GetByOid Method

oid
The OID to use in the lookup.
Gets a MibNode with the specified OID.

Syntax

Visual Basic (Declaration)
Public Function GetByOid( _
   ByVal oid As String _
) As MibNode
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim oid As String
Dim value As MibNode

value = instance.GetByOid(oid)
C#
public MibNode GetByOid(
   string oid
)
Managed Extensions for C++
public: MibNode* GetByOid(
   string* oid
)
C++/CLI
public:
MibNode^ GetByOid(
   String^ oid
)

Parameters

oid
The OID to use in the lookup.

Return Value

A MibNode with the specified OID.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


GetOid Method

[image]
PowerSNMP for .NET CF
GetOid Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : GetOid Method

iid
The IID from which to get the OID.
Returns the OID associated with the specified IID.

Syntax

Visual Basic (Declaration)
Public Shared Function GetOid( _
   ByVal iid As String _
) As String
Visual Basic (Usage) Copy Code
Dim iid As String
Dim value As String

value = MibNodes.GetOid(iid)
C#
public static string GetOid(
   string iid
)
Managed Extensions for C++
public: static string* GetOid(
   string* iid
)
C++/CLI
public:
static String^ GetOid(
   String^ iid
)

Parameters

iid
The IID from which to get the OID.

Return Value

An OID string

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


Import Method

[image]
PowerSNMP for .NET CF
Import Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : Import Method

mibDefs
Imports additional MibNode and MibTrap objects.

Syntax

Visual Basic (Declaration)
Public Sub Import( _
   ByVal mibDefs As List(Of MibDefinition) _
)
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim mibDefs As List(Of MibDefinition)

instance.Import(mibDefs)
C#
public void Import(
   List<MibDefinition> mibDefs
)
Managed Extensions for C++
public: void Import(
   List<MibDefinition*>* mibDefs
)
C++/CLI
public:
void Import(
   List<MibDefinition^>^ mibDefs
)

Parameters

mibDefs

Remarks

The imported MibNode and MibTrap objects are normally created within Visual Studio (using "Import MIB Files").

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


Parse Method

[image]
PowerSNMP for .NET CF
Parse Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : Parse Method

mib
A stream containing the mib file to parse.
Parses the mib file provided.

Syntax

Visual Basic (Declaration)
Public Sub Parse( _
   ByVal mib As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim mib As Stream

instance.Parse(mib)
C#
public void Parse(
   Stream mib
)
Managed Extensions for C++
public: void Parse(
   Stream* mib
)
C++/CLI
public:
void Parse(
   Stream^ mib
)

Parameters

mib
A stream containing the mib file to parse.

Remarks

This method can be called once or multiple times to process multiple MIB files. After parsing is completed, use GenerateNodes to add nodes to the Dictionary.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


Populate Method

[image]
PowerSNMP for .NET CF
Populate Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : Populate Method

treeView
The TreeView object to populate.
mibNodes
A sorted collection of MibNode objects uses to populate the treeView.
Populates a TreeView with MibNode objects.

Syntax

Visual Basic (Declaration)
Public Sub Populate( _
   ByVal treeView As TreeView, _
   ByVal mibNodes As ICollection(Of MibNode) _
)
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim treeView As TreeView
Dim mibNodes As ICollection(Of MibNode)

instance.Populate(treeView, mibNodes)
C#
public void Populate(
   TreeView treeView,
   ICollection<MibNode> mibNodes
)
Managed Extensions for C++
public: void Populate(
   TreeView* treeView,
   ICollection<MibNode*>* mibNodes
)
C++/CLI
public:
void Populate(
   TreeView^ treeView,
   ICollection<MibNode^>^ mibNodes
)

Parameters

treeView
The TreeView object to populate.
mibNodes
A sorted collection of MibNode objects uses to populate the treeView.

Remarks

To use images for the node, set the treeView's ImageList property to an ImageList with the following image indices:

0 = branch, 1 = leaf, 2 = notification, 3 = table, 4 = selected branch, 5 = selected leaf, 6 = selected notification, 7 = selected table

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


Reset Method

[image]
PowerSNMP for .NET CF
Reset Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : Reset Method

Resets the collection to its default state.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As MibNodes

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


MibNodes Class Fields

[image]
PowerSNMP for .NET CF
MibNodes Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : MibNodes Class

"

For a list of all members of this type, see MibNodes members.

"

Public Fields

 | Name | Description
public Field | MibNodesByOid | The MibNodes class is used to list and look-up the MibNode objects known to the Manager.
public Field | Modules | Gets a hash table of modules that have been parsed.
public Field | Traps | Gets a hash table of MibTrap objects that have been parsed.
Top

See Also

Reference

MibNodes Class
Dart.Snmp Namespace


MibNodesByOid Field

[image]
PowerSNMP for .NET CF
MibNodesByOid Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : MibNodesByOid Field

The MibNodes class is used to list and look-up the MibNode objects known to the Manager.

Syntax

Visual Basic (Declaration)
Public MibNodesByOid As Dictionary(Of String,MibNode)
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim value As Dictionary(Of String,MibNode)

value = instance.MibNodesByOid

instance.MibNodesByOid = value
C#
public Dictionary<string,MibNode> MibNodesByOid
Managed Extensions for C++
public: Dictionary<string*,MibNode*>* MibNodesByOid
C++/CLI
public:
Dictionary<String^,MibNode^>^ MibNodesByOid

Remarks

Contains a collection of MibNode objects representing all intrinsic MIB nodes, nodes generated and compiled into the application, and nodes loaded at runtime. The collection is indexed by MibNode.Oid.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


Modules Field

[image]
PowerSNMP for .NET CF
Modules Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : Modules Field

Gets a hash table of modules that have been parsed.

Syntax

Visual Basic (Declaration)
Public Modules As Dictionary(Of String,Module)
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim value As Dictionary(Of String,Module)

value = instance.Modules

instance.Modules = value
C#
public Dictionary<string,Module> Modules
Managed Extensions for C++
public: Dictionary<string*,Module*>* Modules
C++/CLI
public:
Dictionary<String^,Module^>^ Modules

Remarks

Use the module name as the key to lookup the Module object. The dictionary is cleared when Reset is used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


Traps Field

[image]
PowerSNMP for .NET CF
Traps Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibNodes Class : Traps Field

Gets a hash table of MibTrap objects that have been parsed.

Syntax

Visual Basic (Declaration)
Public Traps As MibTraps
Visual Basic (Usage) Copy Code
Dim instance As MibNodes
Dim value As MibTraps

value = instance.Traps

instance.Traps = value
C#
public MibTraps Traps
Managed Extensions for C++
public: MibTraps* Traps
C++/CLI
public:
MibTraps^ Traps

Remarks

Use the trap name as the key to lookup the MibTrap object. The dictionary is cleared when Reset is used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibNodes Class
MibNodes Members


MibTrap Class

[image]
PowerSNMP for .NET CF
MibTrap Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : MibTrap Class

This class is used to represent traps defined in MIB files.

Object Model

MibTrap Class

Syntax

Visual Basic (Declaration)
Public Class MibTrap
   Inherits MibDefinition
Visual Basic (Usage) Copy Code
Dim instance As MibTrap
C#
public class MibTrap : MibDefinition
Managed Extensions for C++
public __gc class MibTrap : public MibDefinition
C++/CLI
public ref class MibTrap : public MibDefinition

Remarks

Object defined in MIB-II are automatically created and added to the MibNodes.Traps dictionary. Developers can add additional MibTrap instances by importing them directly from MIB files or by manually adding instances of this class to the MibNodes.MibTraps class.

Inheritance Hierarchy

System.Object
Dart.Snmp.MibDefinition
Dart.Snmp.MibTrap

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTrap Members
Dart.Snmp Namespace


MibTrap Class Members

[image]
PowerSNMP for .NET CF
MibTrap Class Members
See Also Fields Send comments on this topic.
Dart.Snmp Namespace : MibTrap Class

The following tables list the members exposed by MibTrap.

Public Constructors

 | Name | Description
public Constructor | MibTrap Constructor | Constructs a MibTrap initialized to the specified values.
Top

Public Fields

 | Name | Description
public Field | Description | Gets or sets the description. (Inherited from Dart.Snmp.MibDefinition)
public Field | Enterprise | Use 'snmp' for generic traps, and other values specified in the MIB for specific traps.
public Field | GenericTrap | Generic trap value. Use 6 if a SpecificTrap value is provided.
public Field | Module | Gets or sets the module identifier. (Inherited from Dart.Snmp.MibDefinition)
public Field | Name | Gets or sets the human readable name. (Inherited from Dart.Snmp.MibDefinition)
public Field | SpecificTrap | If GenericTrap is 6, provide an enterprise-specific trap value here.
public Field | Variables | A list of variable names present in the trap.
Top

See Also

Reference

MibTrap Class
Dart.Snmp Namespace


MibTrap Constructor

[image]
PowerSNMP for .NET CF
MibTrap Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTrap Class : MibTrap Constructor

genericTrap
Generic trap value. Use 6 if a specificTrap value is provided.
specificTrap
If genericTrap is 6, provide an enterprise-specific trap value here.
name
The human-readable trap name.
enterprise
Use 'snmp' for generic traps, and other values specified in the MIB for specific traps.
variables
A list of comma delimited variable names present in the trap.
description
A description found in the MIB.
module
The module name that identifies where the trap is described.
Constructs a MibTrap initialized to the specified values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal genericTrap As Integer, _
   ByVal specificTrap As Integer, _
   ByVal name As String, _
   ByVal enterprise As String, _
   ByVal variables As String, _
   ByVal description As String, _
   ByVal module As String _
)
Visual Basic (Usage) Copy Code
Dim genericTrap As Integer
Dim specificTrap As Integer
Dim name As String
Dim enterprise As String
Dim variables As String
Dim description As String
Dim module As String

Dim instance As New MibTrap(genericTrap, specificTrap, name, enterprise, variables, description, module)
C#
public MibTrap(
   int genericTrap,
   int specificTrap,
   string name,
   string enterprise,
   string variables,
   string description,
   string module
)
Managed Extensions for C++
public: MibTrap(
   int genericTrap,
   int specificTrap,
   string* name,
   string* enterprise,
   string* variables,
   string* description,
   string* module
)
C++/CLI
public:
MibTrap(
   int genericTrap,
   int specificTrap,
   String^ name,
   String^ enterprise,
   String^ variables,
   String^ description,
   String^ module
)

Parameters

genericTrap
Generic trap value. Use 6 if a specificTrap value is provided.
specificTrap
If genericTrap is 6, provide an enterprise-specific trap value here.
name
The human-readable trap name.
enterprise
Use 'snmp' for generic traps, and other values specified in the MIB for specific traps.
variables
A list of comma delimited variable names present in the trap.
description
A description found in the MIB.
module
The module name that identifies where the trap is described.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTrap Class
MibTrap Members


MibTrap Class Fields

[image]
PowerSNMP for .NET CF
MibTrap Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : MibTrap Class

"

For a list of all members of this type, see MibTrap members.

"

Public Fields

 | Name | Description
public Field | Description | Gets or sets the description. (Inherited from Dart.Snmp.MibDefinition)
public Field | Enterprise | Use 'snmp' for generic traps, and other values specified in the MIB for specific traps.
public Field | GenericTrap | Generic trap value. Use 6 if a SpecificTrap value is provided.
public Field | Module | Gets or sets the module identifier. (Inherited from Dart.Snmp.MibDefinition)
public Field | Name | Gets or sets the human readable name. (Inherited from Dart.Snmp.MibDefinition)
public Field | SpecificTrap | If GenericTrap is 6, provide an enterprise-specific trap value here.
public Field | Variables | A list of variable names present in the trap.
Top

See Also

Reference

MibTrap Class
Dart.Snmp Namespace


Enterprise Field

[image]
PowerSNMP for .NET CF
Enterprise Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTrap Class : Enterprise Field

Use 'snmp' for generic traps, and other values specified in the MIB for specific traps.

Syntax

Visual Basic (Declaration)
Public ReadOnly Enterprise As String
Visual Basic (Usage) Copy Code
Dim instance As MibTrap
Dim value As String

value = instance.Enterprise
C#
public readonly string Enterprise
Managed Extensions for C++
public: readonly string* Enterprise
C++/CLI
public:
readonly String^ Enterprise

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTrap Class
MibTrap Members


GenericTrap Field

[image]
PowerSNMP for .NET CF
GenericTrap Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTrap Class : GenericTrap Field

Generic trap value. Use 6 if a SpecificTrap value is provided.

Syntax

Visual Basic (Declaration)
Public ReadOnly GenericTrap As Integer
Visual Basic (Usage) Copy Code
Dim instance As MibTrap
Dim value As Integer

value = instance.GenericTrap
C#
public readonly int GenericTrap
Managed Extensions for C++
public: readonly int GenericTrap
C++/CLI
public:
readonly int GenericTrap

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTrap Class
MibTrap Members


SpecificTrap Field

[image]
PowerSNMP for .NET CF
SpecificTrap Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTrap Class : SpecificTrap Field

If GenericTrap is 6, provide an enterprise-specific trap value here.

Syntax

Visual Basic (Declaration)
Public ReadOnly SpecificTrap As Integer
Visual Basic (Usage) Copy Code
Dim instance As MibTrap
Dim value As Integer

value = instance.SpecificTrap
C#
public readonly int SpecificTrap
Managed Extensions for C++
public: readonly int SpecificTrap
C++/CLI
public:
readonly int SpecificTrap

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTrap Class
MibTrap Members


Variables Field

[image]
PowerSNMP for .NET CF
Variables Field
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTrap Class : Variables Field

A list of variable names present in the trap.

Syntax

Visual Basic (Declaration)
Public ReadOnly Variables As String
Visual Basic (Usage) Copy Code
Dim instance As MibTrap
Dim value As String

value = instance.Variables
C#
public readonly string Variables
Managed Extensions for C++
public: readonly string* Variables
C++/CLI
public:
readonly String^ Variables

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTrap Class
MibTrap Members


MibTraps Class

[image]
PowerSNMP for .NET CF
MibTraps Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : MibTraps Class

A collection of trap types.

Object Model

MibTraps ClassMibTrap Class

Syntax

Visual Basic (Declaration)
Public Class MibTraps
   Inherits System.Collections.Generic.Dictionary(Of String,MibTrap)
Visual Basic (Usage) Copy Code
Dim instance As MibTraps
C#
public class MibTraps : System.Collections.Generic.Dictionary<string,MibTrap>
Managed Extensions for C++
public __gc class MibTraps : public System.Collections.Generic.Dictionary<string,MibTrap>
C++/CLI
public ref class MibTraps : public System.Collections.Generic.Dictionary<String,MibTrap>

Inheritance Hierarchy

System.Object
System.Collections.Generic.Dictionary<TKey,TValue>
Dart.Snmp.MibTraps

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTraps Members
Dart.Snmp Namespace


MibTraps Class Members

[image]
PowerSNMP for .NET CF
MibTraps Class Members
See Also Properties Methods Send comments on this topic.
Dart.Snmp Namespace : MibTraps Class

The following tables list the members exposed by MibTraps.

Public Constructors

 | Name | Description
public Constructor | MibTraps Constructor |
Top

Public Properties

 | Name | Description
public Property | Comparer | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Property | Count | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Property | Item | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Property | Keys | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Property | Values | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
Top

Public Methods

 | Name | Description
public Method | Add | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | Clear | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | ContainsKey | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | ContainsValue | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | CreateGenericTrapMessage | Creates a generic trap from the specified TrapName and enterprise.
public Method | CreateSpecificTrapMessage | Creates a specific trap from the specified TrapName.
public Method | GetByTrapAttributes | Returns the MibTrap with the specified generic trap, specific trap, and enterprise values.
public Method | GetByTrapName | Returns the MibTrap with the given name.
public Method | GetEnumerator | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | GetObjectData | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | OnDeserialization | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | Remove | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | TryGetValue | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
Top

See Also

Reference

MibTraps Class
Dart.Snmp Namespace


MibTraps Constructor

[image]
PowerSNMP for .NET CF
MibTraps Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTraps Class : MibTraps Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New MibTraps()
C#
public MibTraps()
Managed Extensions for C++
public: MibTraps();
C++/CLI
public:
MibTraps();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTraps Class
MibTraps Members


MibTraps Class Methods

[image]
PowerSNMP for .NET CF
MibTraps Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : MibTraps Class

"

For a list of all members of this type, see MibTraps members.

"

Public Methods

 | Name | Description
public Method | Add | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | Clear | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | ContainsKey | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | ContainsValue | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | CreateGenericTrapMessage | Creates a generic trap from the specified TrapName and enterprise.
public Method | CreateSpecificTrapMessage | Creates a specific trap from the specified TrapName.
public Method | GetByTrapAttributes | Returns the MibTrap with the specified generic trap, specific trap, and enterprise values.
public Method | GetByTrapName | Returns the MibTrap with the given name.
public Method | GetEnumerator | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | GetObjectData | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | OnDeserialization | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | Remove | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Method | TryGetValue | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
Top

See Also

Reference

MibTraps Class
Dart.Snmp Namespace


CreateGenericTrapMessage Method

[image]
PowerSNMP for .NET CF
CreateGenericTrapMessage Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTraps Class : CreateGenericTrapMessage Method

trapName
The TrapName enumerated type to use.
enterprise
The value of the enterprise.
Creates a generic trap from the specified TrapName and enterprise.

Syntax

Visual Basic (Declaration)
Public Function CreateGenericTrapMessage( _
   ByVal trapName As TrapName, _
   ByVal enterprise As String _
) As TrapMessage
Visual Basic (Usage) Copy Code
Dim instance As MibTraps
Dim trapName As TrapName
Dim enterprise As String
Dim value As TrapMessage

value = instance.CreateGenericTrapMessage(trapName, enterprise)
C#
public TrapMessage CreateGenericTrapMessage(
   TrapName trapName,
   string enterprise
)
Managed Extensions for C++
public: TrapMessage* CreateGenericTrapMessage(
   TrapName trapName,
   string* enterprise
)
C++/CLI
public:
TrapMessage^ CreateGenericTrapMessage(
   TrapName trapName,
   String^ enterprise
)

Parameters

trapName
The TrapName enumerated type to use.
enterprise
The value of the enterprise.

Return Value

A generic TrapMessage with the specified enterprise

Remarks

The trapName parameter is an enumeration of trap names. TrapMessages cannot be created from dynamically added traps using this method.

For Enterprise-specific traps, use CreateSpecificTrapMessage.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTraps Class
MibTraps Members


CreateSpecificTrapMessage Method

[image]
PowerSNMP for .NET CF
CreateSpecificTrapMessage Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTraps Class : CreateSpecificTrapMessage Method

trapName
The TrapName enumerated type to use.
Creates a specific trap from the specified TrapName.

Syntax

Visual Basic (Declaration)
Public Function CreateSpecificTrapMessage( _
   ByVal trapName As Enum _
) As TrapMessage
Visual Basic (Usage) Copy Code
Dim instance As MibTraps
Dim trapName As Enum
Dim value As TrapMessage

value = instance.CreateSpecificTrapMessage(trapName)
C#
public TrapMessage CreateSpecificTrapMessage(
   Enum trapName
)
Managed Extensions for C++
public: TrapMessage* CreateSpecificTrapMessage(
   Enum* trapName
)
C++/CLI
public:
TrapMessage^ CreateSpecificTrapMessage(
   Enum^ trapName
)

Parameters

trapName
The TrapName enumerated type to use.

Return Value

A specific TrapMessage.

Remarks

The trapName parameter is an enumeration of trap names. TrapMessages cannot be created from dynamically added traps using this method.

For generic traps such as warmstart, use CreateGenericTrapMessage.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTraps Class
MibTraps Members


GetByTrapAttributes Method

[image]
PowerSNMP for .NET CF
GetByTrapAttributes Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTraps Class : GetByTrapAttributes Method

genericTrap
The generic trap value.
specificTrap
The specific trap value.
enterprise
The enterprise value.
Returns the MibTrap with the specified generic trap, specific trap, and enterprise values.

Syntax

Visual Basic (Declaration)
Public Function GetByTrapAttributes( _
   ByVal genericTrap As Integer, _
   ByVal specificTrap As Integer, _
   ByVal enterprise As String _
) As MibTrap
Visual Basic (Usage) Copy Code
Dim instance As MibTraps
Dim genericTrap As Integer
Dim specificTrap As Integer
Dim enterprise As String
Dim value As MibTrap

value = instance.GetByTrapAttributes(genericTrap, specificTrap, enterprise)
C#
public MibTrap GetByTrapAttributes(
   int genericTrap,
   int specificTrap,
   string enterprise
)
Managed Extensions for C++
public: MibTrap* GetByTrapAttributes(
   int genericTrap,
   int specificTrap,
   string* enterprise
)
C++/CLI
public:
MibTrap^ GetByTrapAttributes(
   int genericTrap,
   int specificTrap,
   String^ enterprise
)

Parameters

genericTrap
The generic trap value.
specificTrap
The specific trap value.
enterprise
The enterprise value.

Return Value

A matching MibTrap object, otherwise null.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTraps Class
MibTraps Members


GetByTrapName Method

[image]
PowerSNMP for .NET CF
GetByTrapName Method
See Also Send comments on this topic.
Dart.Snmp Namespace > MibTraps Class : GetByTrapName Method

trapName
The name of the MibTrap to get.
Returns the MibTrap with the given name.

Syntax

Visual Basic (Declaration)
Public Function GetByTrapName( _
   ByVal trapName As Enum _
) As MibTrap
Visual Basic (Usage) Copy Code
Dim instance As MibTraps
Dim trapName As Enum
Dim value As MibTrap

value = instance.GetByTrapName(trapName)
C#
public MibTrap GetByTrapName(
   Enum trapName
)
Managed Extensions for C++
public: MibTrap* GetByTrapName(
   Enum* trapName
)
C++/CLI
public:
MibTrap^ GetByTrapName(
   Enum^ trapName
)

Parameters

trapName
The name of the MibTrap to get.

Return Value

A MibTrap

Remarks

The trapName parameter is an enumeration of trap names. Intrinsic names are provided by the Dart.Snmp.TrapName enumeration. Trap names from imported MIB files are provided by the Dart.Snmp.Mib.TrapName enumeration.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MibTraps Class
MibTraps Members


Module Class

[image]
PowerSNMP for .NET CF
Module Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : Module Class

Contains all names either imported or defined within a module.

Object Model

Module Class

Syntax

Visual Basic (Declaration)
Public Class Module
Visual Basic (Usage) Copy Code
Dim instance As Module
C#
public class Module
Managed Extensions for C++
public __gc class Module
C++/CLI
public ref class Module

Remarks

Represents a value in the MibNodes.Modules hash table.

Inheritance Hierarchy

System.Object
Dart.Snmp.Module

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Module Members
Dart.Snmp Namespace


Module Class Members

[image]
PowerSNMP for .NET CF
Module Class Members
See Also Fields Send comments on this topic.
Dart.Snmp Namespace : Module Class

The following tables list the members exposed by Module.

Public Fields

 | Name | Description
public Field | ImportedModuleNames | Names imported into the module.
public Field | NodeNameDefinitions | Names defined within the module.
Top

See Also

Reference

Module Class
Dart.Snmp Namespace


Module Class Fields

[image]
PowerSNMP for .NET CF
Module Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : Module Class

"

For a list of all members of this type, see Module members.

"

Public Fields

 | Name | Description
public Field | ImportedModuleNames | Names imported into the module.
public Field | NodeNameDefinitions | Names defined within the module.
Top

See Also

Reference

Module Class
Dart.Snmp Namespace


ImportedModuleNames Field

[image]
PowerSNMP for .NET CF
ImportedModuleNames Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Module Class : ImportedModuleNames Field

Names imported into the module.

Syntax

Visual Basic (Declaration)
Public ImportedModuleNames As Dictionary(Of String,String)
Visual Basic (Usage) Copy Code
Dim instance As Module
Dim value As Dictionary(Of String,String)

value = instance.ImportedModuleNames

instance.ImportedModuleNames = value
C#
public Dictionary<string,string> ImportedModuleNames
Managed Extensions for C++
public: Dictionary<string*,string*>* ImportedModuleNames
C++/CLI
public:
Dictionary<String^,String^>^ ImportedModuleNames

Remarks

Use the module name as a key to the string name value.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Module Class
Module Members


NodeNameDefinitions Field

[image]
PowerSNMP for .NET CF
NodeNameDefinitions Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Module Class : NodeNameDefinitions Field

Names defined within the module.

Syntax

Visual Basic (Declaration)
Public NodeNameDefinitions As Dictionary(Of String,String)
Visual Basic (Usage) Copy Code
Dim instance As Module
Dim value As Dictionary(Of String,String)

value = instance.NodeNameDefinitions

instance.NodeNameDefinitions = value
C#
public Dictionary<string,string> NodeNameDefinitions
Managed Extensions for C++
public: Dictionary<string*,string*>* NodeNameDefinitions
C++/CLI
public:
Dictionary<String^,String^>^ NodeNameDefinitions

Remarks

Use the name as a key to its definition (e.g., "system 6").

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Module Class
Module Members


NotificationMessage Class

[image]
PowerSNMP for .NET CF
NotificationMessage Class
Members Example See Also Send comments on this topic.
Dart.Snmp Namespace : NotificationMessage Class

The NotificationMessage class is used by agents to notify managers of an event. It uses SNMP version 2/3 and is the functional equivalent of the TrapMessage used by SNMP version 1.

Object Model

NotificationMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class NotificationMessage
   Inherits StandardMessage
Visual Basic (Usage) Copy Code
Dim instance As NotificationMessage
C#
public class NotificationMessage : StandardMessage
Managed Extensions for C++
public __gc class NotificationMessage : public StandardMessage
C++/CLI
public ref class NotificationMessage : public StandardMessage

Example

The following example demonstrates receiving trap, notification and inform messages.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
  //Start listening for traps, notifications and informs
  manager1.Start(manager1_MessageReceived, null);
}

private void manager1_MessageReceived(Manager manager, MessageBase message, object state)
{
  //Marshal message to the UI thread using the Message event
  if (message is TrapMessage)
    manager.Marshal(new MessageBase[] { message }, "trap");
    else if (message is NotificationMessage)
    manager.Marshal(new MessageBase[] { message }, "notification");
  else if (message is InformMessage)
  {
    manager.Marshal(new MessageBase[] { message }, "inform");

    //Send response to inform message origin
    manager.Send(new ResponseMessage(message as InformMessage), message.Origin);
  }
}

private void manager1_Message(object sender, MessageEventArgs e)
{
  //Update interface according to message type received
  switch (e.UserState.ToString())
  {
    case "trap":
      TrapMessage trap = e.Messages[0] as TrapMessage;
      label1.Text = "Trap received with Enterprise(" + trap.Enterprise + "), Generic Type (" +
        trap.GenericTrap.ToString() + "), Specific Type(" + trap.SpecificTrap.ToString() + ")";
      break;
    case "notification":
      NotificationMessage notification = e.Messages[0] as NotificationMessage;
      label1.Text = "Notification received with OID (" + notification.Oid + ")";
      break;
    case "inform":
      InformMessage inform = e.Messages[0] as InformMessage;
      label1.Text = "Inform received with " + inform.Variables.Count.ToString() + " variable(s).";
      break;
  }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
  'Start listening for traps, notifications and informs
  manager1.Start(AddressOf manager1_MessageReceived, Nothing)
End Sub

Private Sub manager1_MessageReceived(ByVal manager As Manager, ByVal message As MessageBase, ByVal state As Object)
  'Marshal message to the UI thread using the Message event
  If TypeOf message Is TrapMessage Then
    manager.Marshal(New MessageBase() {message}, "trap")
  ElseIf TypeOf message Is NotificationMessage Then
    manager.Marshal(New MessageBase() {message}, "notification")
  ElseIf TypeOf message Is InformMessage Then
    manager.Marshal(New MessageBase() {message}, "inform")

    'Send response to inform message origin
    manager.Send(New ResponseMessage(TryCast(message, InformMessage)), message.Origin)
  End If
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As MessageEventArgs) Handles manager1.Message
  'Update interface according to message type received
  Select Case e.UserState.ToString()
    Case "trap"
      Dim trap As TrapMessage = TryCast(e.Messages(0), TrapMessage)
      label1.Text = "Trap received with Enterprise(" & trap.Enterprise & "), Generic Type (" & _
        trap.GenericTrap.ToString() & "), Specific Type(" & trap.SpecificTrap.ToString() & ")"
    Case "notification"
      Dim notification As NotificationMessage = TryCast(e.Messages(0), NotificationMessage)
      label1.Text = "Notification received with OID (" & notification.Oid & ")"
    Case "inform"
      Dim inform As InformMessage = TryCast(e.Messages(0), InformMessage)
      label1.Text = "Inform received with " & inform.Variables.Count.ToString() & " variable(s)."
  End Select
End Sub

Remarks

Three classes are included that specialize the NotificationMessage class to standard NOTIFICATION-OBJECTs that are defined in RFC 1907:

1. Dart.Snmp.Notification.coldStart

2. Dart.Snmp.Notification.warmStart

3. Dart.Snmp.Notification.authenticationFailure

The MibManager class can be used to add additional classes that derive from NotificationMessage.

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.NotificationMessage
Dart.Snmp.Notification.authenticationFailure
Dart.Snmp.Notification.coldStart
Dart.Snmp.Notification.warmStart

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NotificationMessage Members
Dart.Snmp Namespace


NotificationMessage Class Members

[image]
PowerSNMP for .NET CF
NotificationMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : NotificationMessage Class

The following tables list the members exposed by NotificationMessage.

Public Constructors

 | Name | Description
public Constructor | NotificationMessage Constructor | Initializes a new instance of the NotificationMessage class.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Description | Gets a description of the NotificationMessage.
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Oid | Gets the OID that the message pertains to.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SysUpTime | Gets the hundredths of a second since the agent sending the message was initialized.
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Overridden. Sets SysUpTime to MessageBase.SysUpTime before encoding the message.
Top

See Also

Reference

NotificationMessage Class
Dart.Snmp Namespace


NotificationMessage Constructor

[image]
PowerSNMP for .NET CF
NotificationMessage Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > NotificationMessage Class : NotificationMessage Constructor

oid
The Oid value to be carried.
description
A description of the notification provided by the source MIB.
Initializes a new instance of the NotificationMessage class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oid As String, _
   ByVal description As String _
)
Visual Basic (Usage) Copy Code
Dim oid As String
Dim description As String

Dim instance As New NotificationMessage(oid, description)
C#
public NotificationMessage(
   string oid,
   string description
)
Managed Extensions for C++
public: NotificationMessage(
   string* oid,
   string* description
)
C++/CLI
public:
NotificationMessage(
   String^ oid,
   String^ description
)

Parameters

oid
The Oid value to be carried.
description
A description of the notification provided by the source MIB.

Remarks

This constructor will create a version 2 message. When the message is encoded the first variable is an instance of a sysUpTime Variable (with the value initialized to MessageBase.SysUpTime) and the second variable is an instance of an snmpTrapOID Variable with the parameter oid as its value.

sysUpTime and snmpTrapOID are exposed as properties, and are not presented in MessageBase.Variables. Additional variables can be included as variables accessed through MessageBase.Variables.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NotificationMessage Class
NotificationMessage Members


NotificationMessage Class Methods

[image]
PowerSNMP for .NET CF
NotificationMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : NotificationMessage Class

"

For a list of all members of this type, see NotificationMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Overridden. Sets SysUpTime to MessageBase.SysUpTime before encoding the message.
Top

See Also

Reference

NotificationMessage Class
Dart.Snmp Namespace


Encode Method

[image]
PowerSNMP for .NET CF
Encode Method
See Also Send comments on this topic.
Dart.Snmp Namespace > NotificationMessage Class : Encode Method

Sets SysUpTime to MessageBase.SysUpTime before encoding the message.

Syntax

Visual Basic (Declaration)
Public Overrides Function Encode() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As NotificationMessage
Dim value() As Byte

value = instance.Encode()
C#
public override byte[] Encode()
Managed Extensions for C++
public: byte[]* Encode(); override
C++/CLI
public:
array<byte>^ Encode(); override

Return Value

A byte array with the encoded message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NotificationMessage Class
NotificationMessage Members


NotificationMessage Class Properties

[image]
PowerSNMP for .NET CF
NotificationMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : NotificationMessage Class

"

For a list of all members of this type, see NotificationMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Oid | Gets the OID that the message pertains to.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SysUpTime | Gets the hundredths of a second since the agent sending the message was initialized.
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

NotificationMessage Class
Dart.Snmp Namespace


Oid Property

[image]
PowerSNMP for .NET CF
Oid Property
See Also Send comments on this topic.
Dart.Snmp Namespace > NotificationMessage Class : Oid Property

Gets the OID that the message pertains to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Oid As String
Visual Basic (Usage) Copy Code
Dim instance As NotificationMessage
Dim value As String

value = instance.Oid
C#
public string Oid {get;}
Managed Extensions for C++
public: __property string* get_Oid();
C++/CLI
public:
property String^ Oid {
   String^ get();
}

Property Value

This value is initialized in the constructor.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NotificationMessage Class
NotificationMessage Members


SysUpTime Property

[image]
PowerSNMP for .NET CF
SysUpTime Property
See Also Send comments on this topic.
Dart.Snmp Namespace > NotificationMessage Class : SysUpTime Property

Gets the hundredths of a second since the agent sending the message was initialized.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SysUpTime As Long
Visual Basic (Usage) Copy Code
Dim instance As NotificationMessage
Dim value As Long

value = instance.SysUpTime
C#
public long SysUpTime {get;}
Managed Extensions for C++
public: __property long get_SysUpTime();
C++/CLI
public:
property int64 SysUpTime {
   int64 get();
}

Property Value

Initialized to 0 in the constructor, this value is updated to MessageBase.SysUpTime when TrapMessage.Encode is used. The Create method sets this property to the value in the encoded message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NotificationMessage Class
NotificationMessage Members


NotificationMessage Class Fields

[image]
PowerSNMP for .NET CF
NotificationMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : NotificationMessage Class

"

For a list of all members of this type, see NotificationMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Description | Gets a description of the NotificationMessage.
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

NotificationMessage Class
Dart.Snmp Namespace


Description Field

[image]
PowerSNMP for .NET CF
Description Field
See Also Send comments on this topic.
Dart.Snmp Namespace > NotificationMessage Class : Description Field

Gets a description of the NotificationMessage.

Syntax

Visual Basic (Declaration)
Public ReadOnly Description As String
Visual Basic (Usage) Copy Code
Dim instance As NotificationMessage
Dim value As String

value = instance.Description
C#
public readonly string Description
Managed Extensions for C++
public: readonly string* Description
C++/CLI
public:
readonly String^ Description

Property Value

This value is initialized in the constructor.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NotificationMessage Class
NotificationMessage Members


Passwords Class

[image]
PowerSNMP for .NET CF
Passwords Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : Passwords Class

Provides passwords used to authenticate and decrypt SNMP version 3 packets.

Object Model

Passwords Class

Syntax

Visual Basic (Declaration)
Public Class Passwords
Visual Basic (Usage) Copy Code
Dim instance As Passwords
C#
public class Passwords
Managed Extensions for C++
public __gc class Passwords
C++/CLI
public ref class Passwords

Remarks

A Username string is used as the key to lookup this Passwords object in AuthoritativeEngine.Users.

Inheritance Hierarchy

System.Object
Dart.Snmp.Passwords

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Passwords Members
Dart.Snmp Namespace


Passwords Class Members

[image]
PowerSNMP for .NET CF
Passwords Class Members
See Also Fields Send comments on this topic.
Dart.Snmp Namespace : Passwords Class

The following tables list the members exposed by Passwords.

Public Constructors

 | Name | Description
public Constructor | Passwords Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | AuthenticationPassword | Gets the authentication password initialized in the constructor.
public Field | AuthenticationProtocol | Returns the authentication protocol (hashing technique) to use.
public Field | PrivacyPassword | Gets the privacy password initialized in the constructor.
public Field | PrivacyProtocol | Gets the privacy protocol initialized in the constructor.
Top

See Also

Reference

Passwords Class
Dart.Snmp Namespace


Passwords Constructor

[image]
PowerSNMP for .NET CF
Passwords Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > Passwords Class : Passwords Constructor

Overload List

Overload | Description
Passwords Constructor(String,AuthenticationProtocol,String,PrivacyProtocol) | Initializes a new instance using authentication and privacy.
Passwords Constructor(String,AuthenticationProtocol) | Initializes a new instance using authentication and no privacy.
Passwords Constructor() | Initializes a new instance using neither authentication nor privacy.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Passwords Class
Passwords Members


Passwords Constructor(String,AuthenticationProtocol,String,PrivacyProtocol)

[image]
PowerSNMP for .NET CF
Passwords Constructor(String,AuthenticationProtocol,String,PrivacyProtocol)
See Also Send comments on this topic.
Dart.Snmp Namespace > Passwords Class > Passwords Constructor : Passwords Constructor(String,AuthenticationProtocol,String,PrivacyProtocol)

authenticationPassword
Either null or the value used by the manager. Used for packet authentication.
authenticationProtocol
Specifies the authentication hash to use.
privacyPassword
Either null or the value used by the manager. Used for packet privacy (decryption).
privacyProtocol
Specifies the encryption protocol to use.
Initializes a new instance using authentication and privacy.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal authenticationPassword As String, _
   ByVal authenticationProtocol As AuthenticationProtocol, _
   ByVal privacyPassword As String, _
   ByVal privacyProtocol As PrivacyProtocol _
)
Visual Basic (Usage) Copy Code
Dim authenticationPassword As String
Dim authenticationProtocol As AuthenticationProtocol
Dim privacyPassword As String
Dim privacyProtocol As PrivacyProtocol

Dim instance As New Passwords(authenticationPassword, authenticationProtocol, privacyPassword, privacyProtocol)
C#
public Passwords(
   string authenticationPassword,
   AuthenticationProtocol authenticationProtocol,
   string privacyPassword,
   PrivacyProtocol privacyProtocol
)
Managed Extensions for C++
public: Passwords(
   string* authenticationPassword,
   AuthenticationProtocol authenticationProtocol,
   string* privacyPassword,
   PrivacyProtocol privacyProtocol
)
C++/CLI
public:
Passwords(
   String^ authenticationPassword,
   AuthenticationProtocol authenticationProtocol,
   String^ privacyPassword,
   PrivacyProtocol privacyProtocol
)

Parameters

authenticationPassword
Either null or the value used by the manager. Used for packet authentication.
authenticationProtocol
Specifies the authentication hash to use.
privacyPassword
Either null or the value used by the manager. Used for packet privacy (decryption).
privacyProtocol
Specifies the encryption protocol to use.

Exceptions

Exception | Description
System.ArgumentException | A parameter is a string of 0 length, or authenticationPassword is null and privacyPassword is not.

Remarks

Instances of Passwords is added to AuthoritativeEngine.Users to enable SNMP version 3 authentication and privacy (decryption).

If privacyPassword in not null, then authenticationPassword must not be null.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Passwords Class
Passwords Members
Overload List


Passwords Constructor(String,AuthenticationProtocol)

[image]
PowerSNMP for .NET CF
Passwords Constructor(String,AuthenticationProtocol)
See Also Send comments on this topic.
Dart.Snmp Namespace > Passwords Class > Passwords Constructor : Passwords Constructor(String,AuthenticationProtocol)

authenticationPassword
Either null or the value used by the manager. Used for packet authentication.
authenticationProtocol
Specifies the authentication hash to use.
Initializes a new instance using authentication and no privacy.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal authenticationPassword As String, _
   ByVal authenticationProtocol As AuthenticationProtocol _
)
Visual Basic (Usage) Copy Code
Dim authenticationPassword As String
Dim authenticationProtocol As AuthenticationProtocol

Dim instance As New Passwords(authenticationPassword, authenticationProtocol)
C#
public Passwords(
   string authenticationPassword,
   AuthenticationProtocol authenticationProtocol
)
Managed Extensions for C++
public: Passwords(
   string* authenticationPassword,
   AuthenticationProtocol authenticationProtocol
)
C++/CLI
public:
Passwords(
   String^ authenticationPassword,
   AuthenticationProtocol authenticationProtocol
)

Parameters

authenticationPassword
Either null or the value used by the manager. Used for packet authentication.
authenticationProtocol
Specifies the authentication hash to use.

Exceptions

Exception | Description
System.ArgumentException | A parameter is a string of 0 length, or authenticationPassword is null and privacyPassword is not.

Remarks

Instances of Passwords is added to AuthoritativeEngine.Users to enable SNMP version 3 authentication and privacy (decryption).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Passwords Class
Passwords Members
Overload List


Passwords Constructor()

[image]
PowerSNMP for .NET CF
Passwords Constructor()
See Also Send comments on this topic.
Dart.Snmp Namespace > Passwords Class > Passwords Constructor : Passwords Constructor()

Initializes a new instance using neither authentication nor privacy.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Passwords()
C#
public Passwords()
Managed Extensions for C++
public: Passwords();
C++/CLI
public:
Passwords();

Exceptions

Exception | Description
System.ArgumentException | A parameter is a string of 0 length, or authenticationPassword is null and privacyPassword is not.

Remarks

Instances of Passwords is added to AuthoritativeEngine.Users to enable SNMP version 3 authentication and privacy (decryption).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Passwords Class
Passwords Members
Overload List


Passwords Class Fields

[image]
PowerSNMP for .NET CF
Passwords Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : Passwords Class

"

For a list of all members of this type, see Passwords members.

"

Public Fields

 | Name | Description
public Field | AuthenticationPassword | Gets the authentication password initialized in the constructor.
public Field | AuthenticationProtocol | Returns the authentication protocol (hashing technique) to use.
public Field | PrivacyPassword | Gets the privacy password initialized in the constructor.
public Field | PrivacyProtocol | Gets the privacy protocol initialized in the constructor.
Top

See Also

Reference

Passwords Class
Dart.Snmp Namespace


AuthenticationPassword Field

[image]
PowerSNMP for .NET CF
AuthenticationPassword Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Passwords Class : AuthenticationPassword Field

Gets the authentication password initialized in the constructor.

Syntax

Visual Basic (Declaration)
Public ReadOnly AuthenticationPassword As String
Visual Basic (Usage) Copy Code
Dim instance As Passwords
Dim value As String

value = instance.AuthenticationPassword
C#
public readonly string AuthenticationPassword
Managed Extensions for C++
public: readonly string* AuthenticationPassword
C++/CLI
public:
readonly String^ AuthenticationPassword

Property Value

Returns the string value used to authenticate the packet.

Remarks

This agent side property correlates to Security.AuthenticationPassword on the manager side. It should be the same value used by the sender of the packet when the authentication algorithm was used.

This property is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Passwords Class
Passwords Members


AuthenticationProtocol Field

[image]
PowerSNMP for .NET CF
AuthenticationProtocol Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Passwords Class : AuthenticationProtocol Field

Returns the authentication protocol (hashing technique) to use.

Syntax

Visual Basic (Declaration)
Public ReadOnly AuthenticationProtocol As AuthenticationProtocol
Visual Basic (Usage) Copy Code
Dim instance As Passwords
Dim value As AuthenticationProtocol

value = instance.AuthenticationProtocol
C#
public readonly AuthenticationProtocol AuthenticationProtocol
Managed Extensions for C++
public: readonly AuthenticationProtocol AuthenticationProtocol
C++/CLI
public:
readonly AuthenticationProtocol AuthenticationProtocol

Remarks

This property is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Passwords Class
Passwords Members


PrivacyPassword Field

[image]
PowerSNMP for .NET CF
PrivacyPassword Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Passwords Class : PrivacyPassword Field

Gets the privacy password initialized in the constructor.

Syntax

Visual Basic (Declaration)
Public ReadOnly PrivacyPassword As String
Visual Basic (Usage) Copy Code
Dim instance As Passwords
Dim value As String

value = instance.PrivacyPassword
C#
public readonly string PrivacyPassword
Managed Extensions for C++
public: readonly string* PrivacyPassword
C++/CLI
public:
readonly String^ PrivacyPassword

Property Value

Returns the string value used to decrypt the packet.

Remarks

This property is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Passwords Class
Passwords Members


PrivacyProtocol Field

[image]
PowerSNMP for .NET CF
PrivacyProtocol Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Passwords Class : PrivacyProtocol Field

Gets the privacy protocol initialized in the constructor.

Syntax

Visual Basic (Declaration)
Public ReadOnly PrivacyProtocol As PrivacyProtocol
Visual Basic (Usage) Copy Code
Dim instance As Passwords
Dim value As PrivacyProtocol

value = instance.PrivacyProtocol
C#
public readonly PrivacyProtocol PrivacyProtocol
Managed Extensions for C++
public: readonly PrivacyProtocol PrivacyProtocol
C++/CLI
public:
readonly PrivacyProtocol PrivacyProtocol

Remarks

This property is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Passwords Class
Passwords Members


ReportMessage Class

[image]
PowerSNMP for .NET CF
ReportMessage Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : ReportMessage Class

The ReportMessage class is used to send user-defined information.

Object Model

ReportMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class ReportMessage
   Inherits ResponseMessage
Visual Basic (Usage) Copy Code
Dim instance As ReportMessage
C#
public class ReportMessage : ResponseMessage
Managed Extensions for C++
public __gc class ReportMessage : public ResponseMessage
C++/CLI
public ref class ReportMessage : public ResponseMessage

Remarks

This message is used to send application-specific information. It is used internally as part of the SNMP version 3 security mechanism.

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.ResponseMessage
Dart.Snmp.ReportMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ReportMessage Members
Dart.Snmp Namespace


ReportMessage Class Members

[image]
PowerSNMP for .NET CF
ReportMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : ReportMessage Class

The following tables list the members exposed by ReportMessage.

Public Constructors

 | Name | Description
public Constructor | ReportMessage Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | ErrorIndex | Gets or sets the error index field that indicates which variable caused an error. (Inherited from Dart.Snmp.ResponseMessage)
public Property | ErrorStatus | Gets or sets the error status field that indicates the completeness of the response. (Inherited from Dart.Snmp.ResponseMessage)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

ReportMessage Class
Dart.Snmp Namespace


ReportMessage Constructor

[image]
PowerSNMP for .NET CF
ReportMessage Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > ReportMessage Class : ReportMessage Constructor

Overload List

Overload | Description
ReportMessage Constructor() | Initializes a new instance of the ReportMessage class.
ReportMessage Constructor(RequestMessage,VariableList) | Initializes a new instance of the ReportMessage class based upon the request provided.
ReportMessage Constructor(RequestMessage) | Initializes a new instance of the ReportMessage class based upon the request provided.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ReportMessage Class
ReportMessage Members


ReportMessage Constructor()

[image]
PowerSNMP for .NET CF
ReportMessage Constructor()
See Also Send comments on this topic.
Dart.Snmp Namespace > ReportMessage Class > ReportMessage Constructor : ReportMessage Constructor()

Initializes a new instance of the ReportMessage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ReportMessage()
C#
public ReportMessage()
Managed Extensions for C++
public: ReportMessage();
C++/CLI
public:
ReportMessage();

Remarks

ReportMessage derives from ResponseMessage.

This constructor will create an empty version 2 message. The application will typically use VariableCollection.Add to initialize the application-specific variables to be sent.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ReportMessage Class
ReportMessage Members
Overload List


ReportMessage Constructor(RequestMessage,VariableList)

[image]
PowerSNMP for .NET CF
ReportMessage Constructor(RequestMessage,VariableList)
See Also Send comments on this topic.
Dart.Snmp Namespace > ReportMessage Class > ReportMessage Constructor : ReportMessage Constructor(RequestMessage,VariableList)

request
The RequestMessage representing the request received from the SNMP manager.
agentMib
A sorted list of Variable objects (IID/Value pairs) that are used to build the ReportMessage.
Initializes a new instance of the ReportMessage class based upon the request provided.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal request As RequestMessage, _
   ByVal agentMib As VariableList _
)
Visual Basic (Usage) Copy Code
Dim request As RequestMessage
Dim agentMib As VariableList

Dim instance As New ReportMessage(request, agentMib)
C#
public ReportMessage(
   RequestMessage request,
   VariableList agentMib
)
Managed Extensions for C++
public: ReportMessage(
   RequestMessage* request,
   VariableList* agentMib
)
C++/CLI
public:
ReportMessage(
   RequestMessage^ request,
   VariableList^ agentMib
)

Parameters

request
The RequestMessage representing the request received from the SNMP manager.
agentMib
A sorted list of Variable objects (IID/Value pairs) that are used to build the ReportMessage.

Remarks

This constructor will create a ReportMessage with a matching MessageBase.Version, StandardMessage.Id, and StandardMessage.Security. All RequestMessage types are supported, including GetNextMessage and GetBulkMessage.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ReportMessage Class
ReportMessage Members
Overload List


ReportMessage Constructor(RequestMessage)

[image]
PowerSNMP for .NET CF
ReportMessage Constructor(RequestMessage)
See Also Send comments on this topic.
Dart.Snmp Namespace > ReportMessage Class > ReportMessage Constructor : ReportMessage Constructor(RequestMessage)

request
The RequestMessage representing the request received from the SNMP manager.
Initializes a new instance of the ReportMessage class based upon the request provided.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal request As RequestMessage _
)
Visual Basic (Usage) Copy Code
Dim request As RequestMessage

Dim instance As New ReportMessage(request)
C#
public ReportMessage(
   RequestMessage request
)
Managed Extensions for C++
public: ReportMessage(
   RequestMessage* request
)
C++/CLI
public:
ReportMessage(
   RequestMessage^ request
)

Parameters

request
The RequestMessage representing the request received from the SNMP manager.

Remarks

This constructor will create a ReportMessage with a matching MessageBase.Version, StandardMessage.Id, and StandardMessage.Security. All RequestMessage types are supported, including GetNextMessage and GetBulkMessage.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ReportMessage Class
ReportMessage Members
Overload List


RequestMessage Class

[image]
PowerSNMP for .NET CF
RequestMessage Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : RequestMessage Class

The RequestMessage class is the base class for all request messages: SetMessage, GetMessage, GetNextMessage, GetBulkMessage and InformMessage.

Object Model

RequestMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class RequestMessage
   Inherits StandardMessage
Visual Basic (Usage) Copy Code
Dim instance As RequestMessage
C#
public abstract class RequestMessage : StandardMessage
Managed Extensions for C++
public __gc abstract class RequestMessage : public StandardMessage
C++/CLI
public ref class RequestMessage abstract : public StandardMessage

Remarks

RequestMessage derives from StandardMessage.

Classes derived from RequestMessage are used to process requests that are typically sent from managers to agents.

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.RequestMessage
Dart.Snmp.GetBulkMessage
Dart.Snmp.GetMessage
Dart.Snmp.GetNextMessage
Dart.Snmp.InformMessage
Dart.Snmp.SetMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

RequestMessage Members
Dart.Snmp Namespace


RequestMessage Class Members

[image]
PowerSNMP for .NET CF
RequestMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : RequestMessage Class

The following tables list the members exposed by RequestMessage.

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

RequestMessage Class
Dart.Snmp Namespace


ResponseMessage Class

[image]
PowerSNMP for .NET CF
ResponseMessage Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : ResponseMessage Class

The ResponseMessage class is used to send information about IIDs from an SNMP agent to a manager .

Object Model

ResponseMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class ResponseMessage
   Inherits StandardMessage
Visual Basic (Usage) Copy Code
Dim instance As ResponseMessage
C#
public class ResponseMessage : StandardMessage
Managed Extensions for C++
public __gc class ResponseMessage : public StandardMessage
C++/CLI
public ref class ResponseMessage : public StandardMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.ResponseMessage
Dart.Snmp.ReportMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ResponseMessage Members
Dart.Snmp Namespace


ResponseMessage Class Members

[image]
PowerSNMP for .NET CF
ResponseMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : ResponseMessage Class

The following tables list the members exposed by ResponseMessage.

Public Constructors

 | Name | Description
public Constructor | ResponseMessage Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | ErrorIndex | Gets or sets the error index field that indicates which variable caused an error.
public Property | ErrorStatus | Gets or sets the error status field that indicates the completeness of the response.
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

ResponseMessage Class
Dart.Snmp Namespace


ResponseMessage Constructor

[image]
PowerSNMP for .NET CF
ResponseMessage Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > ResponseMessage Class : ResponseMessage Constructor

Overload List

Overload | Description
ResponseMessage Constructor() | Initializes a new instance of the GetNextMessage class.
ResponseMessage Constructor(RequestMessage,VariableList) | Initializes a new instance of the ResponseMessage class based upon the request and the variables provided.
ResponseMessage Constructor(InformMessage) | Initializes a new instance of the ResponseMessage class based upon the received InformMessage.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ResponseMessage Class
ResponseMessage Members


ResponseMessage Constructor()

[image]
PowerSNMP for .NET CF
ResponseMessage Constructor()
See Also Send comments on this topic.
Dart.Snmp Namespace > ResponseMessage Class > ResponseMessage Constructor : ResponseMessage Constructor()

Initializes a new instance of the GetNextMessage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ResponseMessage()
C#
public ResponseMessage()
Managed Extensions for C++
public: ResponseMessage();
C++/CLI
public:
ResponseMessage();

Remarks

An SNMP manager will use this constructor before adding Variable instances to MessageBase.Variables. The Manager component will use the Encode method to encode the message before sending, but the application can also use the Encode method to inspect the contents of the encoded message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ResponseMessage Class
ResponseMessage Members
Overload List


ResponseMessage Constructor(RequestMessage,VariableList)

[image]
PowerSNMP for .NET CF
ResponseMessage Constructor(RequestMessage,VariableList)
See Also Send comments on this topic.
Dart.Snmp Namespace > ResponseMessage Class > ResponseMessage Constructor : ResponseMessage Constructor(RequestMessage,VariableList)

request
The RequestMessage representing the request received from the SNMP manager.
agentMib
A sorted list of Variable objects (IID/Value pairs) that are used to build the ResponseMessage.
Initializes a new instance of the ResponseMessage class based upon the request and the variables provided.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal request As RequestMessage, _
   ByVal agentMib As VariableList _
)
Visual Basic (Usage) Copy Code
Dim request As RequestMessage
Dim agentMib As VariableList

Dim instance As New ResponseMessage(request, agentMib)
C#
public ResponseMessage(
   RequestMessage request,
   VariableList agentMib
)
Managed Extensions for C++
public: ResponseMessage(
   RequestMessage* request,
   VariableList* agentMib
)
C++/CLI
public:
ResponseMessage(
   RequestMessage^ request,
   VariableList^ agentMib
)

Parameters

request
The RequestMessage representing the request received from the SNMP manager.
agentMib
A sorted list of Variable objects (IID/Value pairs) that are used to build the ResponseMessage.

Exceptions

Exception | Description
System.ArgumentException | The request is not a SetMessage, GetMessage, GetNextMessage or BetBulkMessage type.
System.ArgumentNullException | The agentMib parameter is null.

Remarks

This constructor will create a ResponseMessage with a matching MessageBase.Version, StandardMessage.Id, and StandardMessage.Security. The agentMib is a sorted list of IID/Value pairs that are used to populate the MessageBase.Variables with IID/Value pairs. SetMessage, GetMessage, GetNextMessage and GetBulkMessage types are supported.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ResponseMessage Class
ResponseMessage Members
Overload List


ResponseMessage Constructor(InformMessage)

[image]
PowerSNMP for .NET CF
ResponseMessage Constructor(InformMessage)
See Also Send comments on this topic.
Dart.Snmp Namespace > ResponseMessage Class > ResponseMessage Constructor : ResponseMessage Constructor(InformMessage)

request
The InformMessage representing the request received from the SNMP manager.
Initializes a new instance of the ResponseMessage class based upon the received InformMessage.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal request As InformMessage _
)
Visual Basic (Usage) Copy Code
Dim request As InformMessage

Dim instance As New ResponseMessage(request)
C#
public ResponseMessage(
   InformMessage request
)
Managed Extensions for C++
public: ResponseMessage(
   InformMessage* request
)
C++/CLI
public:
ResponseMessage(
   InformMessage^ request
)

Parameters

request
The InformMessage representing the request received from the SNMP manager.

Remarks

This constructor will create a ResponseMessage with a matching MessageBase.Version, cref="MessageBase.Id"/>, and StandardMessage.Security. A copy of the Variables is made with empty values.

When a Manager receives an InformMessage, this constructor should be used to create the ResponseMessage that should be returned to the sending Manager.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ResponseMessage Class
ResponseMessage Members
Overload List


ResponseMessage Class Properties

[image]
PowerSNMP for .NET CF
ResponseMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : ResponseMessage Class

"

For a list of all members of this type, see ResponseMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | ErrorIndex | Gets or sets the error index field that indicates which variable caused an error.
public Property | ErrorStatus | Gets or sets the error status field that indicates the completeness of the response.
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

ResponseMessage Class
Dart.Snmp Namespace


ErrorIndex Property

[image]
PowerSNMP for .NET CF
ErrorIndex Property
See Also Send comments on this topic.
Dart.Snmp Namespace > ResponseMessage Class : ErrorIndex Property

Gets or sets the error index field that indicates which variable caused an error.

Syntax

Visual Basic (Declaration)
Public Property ErrorIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ResponseMessage
Dim value As Integer

instance.ErrorIndex = value

value = instance.ErrorIndex
C#
public int ErrorIndex {get; set;}
Managed Extensions for C++
public: __property int get_ErrorIndex();
public: __property void set_ErrorIndex(
   int value
);
C++/CLI
public:
property int ErrorIndex {
   int get();
   void set (    int value);
}

Property Value

A 0-based index that indicates which variable in MessageBase.Variables caused the error indicated by ErrorStatus.

Remarks

SNMP only provides error reporting for the first variable found with an error. Variable objects found before Variables[ResponseMessage.ErrorIndex] usually contain valid data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ResponseMessage Class
ResponseMessage Members


ErrorStatus Property

[image]
PowerSNMP for .NET CF
ErrorStatus Property
See Also Send comments on this topic.
Dart.Snmp Namespace > ResponseMessage Class : ErrorStatus Property

Gets or sets the error status field that indicates the completeness of the response.

Syntax

Visual Basic (Declaration)
Public Property ErrorStatus As ErrorStatus
Visual Basic (Usage) Copy Code
Dim instance As ResponseMessage
Dim value As ErrorStatus

instance.ErrorStatus = value

value = instance.ErrorStatus
C#
public ErrorStatus ErrorStatus {get; set;}
Managed Extensions for C++
public: __property ErrorStatus get_ErrorStatus();
public: __property void set_ErrorStatus(
   ErrorStatus value
);
C++/CLI
public:
property ErrorStatus ErrorStatus {
   ErrorStatus get();
   void set (    ErrorStatus value);
}

Property Value

An enumerated type that indicates the error associated with Variables[ResponseMessage.ErrorIndex].

Remarks

SNMP only provides error reporting for the first variable found with an error. Variable objects found before Variables[ResponseMessage.ErrorIndex] usually contain valid data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ResponseMessage Class
ResponseMessage Members


Security Class

[image]
PowerSNMP for .NET CF
Security Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : Security Class

This class controls Version 3 authentication and privacy procedures.

Object Model

Security Class

Syntax

Visual Basic (Declaration)
Public Class Security
Visual Basic (Usage) Copy Code
Dim instance As Security
C#
public class Security
Managed Extensions for C++
public __gc class Security
C++/CLI
public ref class Security

Inheritance Hierarchy

System.Object
Dart.Snmp.Security

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Members
Dart.Snmp Namespace


Security Class Members

[image]
PowerSNMP for .NET CF
Security Class Members
See Also Fields Send comments on this topic.
Dart.Snmp Namespace : Security Class

The following tables list the members exposed by Security.

Public Constructors

 | Name | Description
public Constructor | Security Constructor | Initializes a new instance of the Security class.
Top

Public Fields

 | Name | Description
public Field | AuthenticationPassword | Gets or sets the authentication password to be used in requests.
public Field | AuthenticationProtocol | Gets or sets the authentication protocol to be used in requests.
public Field | ContextId | Gets or sets the contextEngineId used in the SNMPv3 scoped PDU.
public Field | ContextName | Gets or sets the contextName used in the SNMPv3 scoped PDU.
public Field | EngineBoots | Gets or sets the EngineBoots used for SNMPv3 communications.
public Field | EngineId | Gets or sets the EngineId used for SNMPv3 communications.
public Field | EngineTime | Gets or sets the EngineTime used for SNMPv3 communications.
public Field | Id | Gets or sets the message identification field in the security header.
public Field | PrivacyPassword | Gets or sets the privacy password to be used in requests.
public Field | PrivacyProtocol | Gets or sets the privacy protocol to be used in requests.
public Field | Username | Gets or sets the username to be used in requests.
Top

See Also

Reference

Security Class
Dart.Snmp Namespace


Security Constructor

[image]
PowerSNMP for .NET CF
Security Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : Security Constructor

Initializes a new instance of the Security class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Security()
C#
public Security()
Managed Extensions for C++
public: Security();
C++/CLI
public:
Security();

Remarks

The Security class is used with Version 3 messages to provide message authentication and privacy. The Security object is not used or added to a message unless MessageBase.Version is SnmpVersion.Three. If a message to be sent is a Version 3 message, at a minimum you must set Username to a valid user name for the Agent you are sending requests to.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


Security Class Fields

[image]
PowerSNMP for .NET CF
Security Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : Security Class

"

For a list of all members of this type, see Security members.

"

Public Fields

 | Name | Description
public Field | AuthenticationPassword | Gets or sets the authentication password to be used in requests.
public Field | AuthenticationProtocol | Gets or sets the authentication protocol to be used in requests.
public Field | ContextId | Gets or sets the contextEngineId used in the SNMPv3 scoped PDU.
public Field | ContextName | Gets or sets the contextName used in the SNMPv3 scoped PDU.
public Field | EngineBoots | Gets or sets the EngineBoots used for SNMPv3 communications.
public Field | EngineId | Gets or sets the EngineId used for SNMPv3 communications.
public Field | EngineTime | Gets or sets the EngineTime used for SNMPv3 communications.
public Field | Id | Gets or sets the message identification field in the security header.
public Field | PrivacyPassword | Gets or sets the privacy password to be used in requests.
public Field | PrivacyProtocol | Gets or sets the privacy protocol to be used in requests.
public Field | Username | Gets or sets the username to be used in requests.
Top

See Also

Reference

Security Class
Dart.Snmp Namespace


AuthenticationPassword Field

[image]
PowerSNMP for .NET CF
AuthenticationPassword Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : AuthenticationPassword Field

Gets or sets the authentication password to be used in requests.

Syntax

Visual Basic (Declaration)
Public AuthenticationPassword As String
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As String

value = instance.AuthenticationPassword

instance.AuthenticationPassword = value
C#
public string AuthenticationPassword
Managed Extensions for C++
public: string* AuthenticationPassword
C++/CLI
public:
String^ AuthenticationPassword

Property Value

The authentication password to be used in a request.

Remarks

If AuthenticationPassword is not empty the encoded message will include a signature that the receiving agent can then use to verify that the message is unmodified from the time it was encoded.

If PrivacyPassword is not empty then AuthenticationPassword must not be empty or a SecurityException will be thrown.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


AuthenticationProtocol Field

[image]
PowerSNMP for .NET CF
AuthenticationProtocol Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : AuthenticationProtocol Field

Gets or sets the authentication protocol to be used in requests.

Syntax

Visual Basic (Declaration)
Public AuthenticationProtocol As AuthenticationProtocol
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As AuthenticationProtocol

value = instance.AuthenticationProtocol

instance.AuthenticationProtocol = value
C#
public AuthenticationProtocol AuthenticationProtocol
Managed Extensions for C++
public: AuthenticationProtocol AuthenticationProtocol
C++/CLI
public:
AuthenticationProtocol AuthenticationProtocol

Property Value

AuthenticationProtocol enum value to be used in requests.

Remarks

The AuthenticationProtocol is used to determine the algorithm for calculating the message signature of a request. The default value of AuthenticationProtocol.Md5 must be supported by all Version 3 agents. AuthenticationProtocol.Sha is supported by most Version 3 agents.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


ContextId Field

[image]
PowerSNMP for .NET CF
ContextId Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : ContextId Field

Gets or sets the contextEngineId used in the SNMPv3 scoped PDU.

Syntax

Visual Basic (Declaration)
Public ContextId As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value() As Byte

value = instance.ContextId

instance.ContextId = value
C#
public byte[] ContextId
Managed Extensions for C++
public: byte[]* ContextId
C++/CLI
public:
array<byte>^ ContextId

Property Value

Byte array

Remarks

If not set, encoding uses the Security.EngineId value for this field.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


ContextName Field

[image]
PowerSNMP for .NET CF
ContextName Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : ContextName Field

Gets or sets the contextName used in the SNMPv3 scoped PDU.

Syntax

Visual Basic (Declaration)
Public ContextName As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value() As Byte

value = instance.ContextName

instance.ContextName = value
C#
public byte[] ContextName
Managed Extensions for C++
public: byte[]* ContextName
C++/CLI
public:
array<byte>^ ContextName

Property Value

Byte array

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


EngineBoots Field

[image]
PowerSNMP for .NET CF
EngineBoots Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : EngineBoots Field

Gets or sets the EngineBoots used for SNMPv3 communications.

Syntax

Visual Basic (Declaration)
Public EngineBoots As Integer
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As Integer

value = instance.EngineBoots

instance.EngineBoots = value
C#
public int EngineBoots
Managed Extensions for C++
public: int EngineBoots
C++/CLI
public:
int EngineBoots

Property Value

Integer. The number of boots of the SNMP engine.

Remarks

If not set, encoding uses dynamic discovery technique to get remote EngineId, EngineTime and EngineBoots values.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


EngineId Field

[image]
PowerSNMP for .NET CF
EngineId Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : EngineId Field

Gets or sets the EngineId used for SNMPv3 communications.

Syntax

Visual Basic (Declaration)
Public EngineId As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value() As Byte

value = instance.EngineId

instance.EngineId = value
C#
public byte[] EngineId
Managed Extensions for C++
public: byte[]* EngineId
C++/CLI
public:
array<byte>^ EngineId

Property Value

Byte array

Remarks

If not set, encoding uses dynamic discovery technique to get remote EngineId, EngineTime and EngineBoots values.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


EngineTime Field

[image]
PowerSNMP for .NET CF
EngineTime Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : EngineTime Field

Gets or sets the EngineTime used for SNMPv3 communications.

Syntax

Visual Basic (Declaration)
Public EngineTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As Integer

value = instance.EngineTime

instance.EngineTime = value
C#
public int EngineTime
Managed Extensions for C++
public: int EngineTime
C++/CLI
public:
int EngineTime

Property Value

Integer. The number of seconds since EngineBoots last changed.

Remarks

If not set, encoding uses dynamic discovery technique to get remote EngineId, EngineTime and EngineBoots values.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


Id Field

[image]
PowerSNMP for .NET CF
Id Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : Id Field

Gets or sets the message identification field in the security header.

Syntax

Visual Basic (Declaration)
Public Id As Integer
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As Integer

value = instance.Id

instance.Id = value
C#
public int Id
Managed Extensions for C++
public: int Id
C++/CLI
public:
int Id

Property Value

An integer that can pair a version 3 ResponseMessage to a specific RequestMessage.

Remarks

The default constructor for any class derived from RequestMessage will automatically initialize this value to one higher than the previous. The first instance will have an Id of 1, the second an Id of 2, and so on.

All decoded messages return the value encoded in the message. Version 3 messages use this property in leau of StandardMessage.Id.

This property is unrelated to Variable.Id, which is either an OID or IID.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


PrivacyPassword Field

[image]
PowerSNMP for .NET CF
PrivacyPassword Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : PrivacyPassword Field

Gets or sets the privacy password to be used in requests.

Syntax

Visual Basic (Declaration)
Public PrivacyPassword As String
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As String

value = instance.PrivacyPassword

instance.PrivacyPassword = value
C#
public string PrivacyPassword
Managed Extensions for C++
public: string* PrivacyPassword
C++/CLI
public:
String^ PrivacyPassword

Property Value

The privacy password to be used in request.

Remarks

If PrivacyPassword is not empty the encoded message contents will encrypted. In this case AuthenticationPassword must not be empty or a SecurityException will be thrown.

If PrivacyPassword is empty and the Security.AuthenticationPassword is not empty then the message will only contain authentication information and no encryption will be performed on the message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


PrivacyProtocol Field

[image]
PowerSNMP for .NET CF
PrivacyProtocol Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : PrivacyProtocol Field

Gets or sets the privacy protocol to be used in requests.

Syntax

Visual Basic (Declaration)
Public PrivacyProtocol As PrivacyProtocol
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As PrivacyProtocol

value = instance.PrivacyProtocol

instance.PrivacyProtocol = value
C#
public PrivacyProtocol PrivacyProtocol
Managed Extensions for C++
public: PrivacyProtocol PrivacyProtocol
C++/CLI
public:
PrivacyProtocol PrivacyProtocol

Property Value

PrivacyProtocol enum value to be used in requests.

Remarks

The PrivacyProtocol is used to determine the algorithm for encrypting the message contents of a request. The default and only currently supported value of PrivacyProtocol.Des encrypts a message using DES encryption.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


Username Field

[image]
PowerSNMP for .NET CF
Username Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Security Class : Username Field

Gets or sets the username to be used in requests.

Syntax

Visual Basic (Declaration)
Public Username As String
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As String

value = instance.Username

instance.Username = value
C#
public string Username
Managed Extensions for C++
public: string* Username
C++/CLI
public:
String^ Username

Property Value

The Username to be used in requests.

Remarks

If a message to be sent is a Version 3 message, then Username must to set to a value known to the agent you are sending the request to. Otherwise a SecurityException will be thrown when the message is encoded for delivery over the network.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Security Class
Security Members


SecurityException Class

[image]
PowerSNMP for .NET CF
SecurityException Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : SecurityException Class

A SecurityException is thrown by the Manager when it is notified that a request failed to be authenticated by the agent.

Object Model

SecurityException Class

Syntax

Visual Basic (Declaration)
Public Class SecurityException
   Inherits System.ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As SecurityException
C#
public class SecurityException : System.ApplicationException
Managed Extensions for C++
public __gc class SecurityException : public System.ApplicationException
C++/CLI
public ref class SecurityException : public System.ApplicationException

Remarks

SecurityException.ErrorCode contains a value that represents a reason for the failure and System.Exception.Message contains a human readable error message. The original request that caused the exception can be examined using Request, while the message containing information about the failure is contained in SecurityException.Response.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Dart.Snmp.SecurityException

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SecurityException Members
Dart.Snmp Namespace


SecurityException Class Members

[image]
PowerSNMP for .NET CF
SecurityException Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : SecurityException Class

The following tables list the members exposed by SecurityException.

Public Fields

 | Name | Description
public Field | ErrorCode | Gets the SecurityErrorCode value that describes the reason for the exception.
public Field | Request |
public Field | Response | Gets the ReportMessage sent to the Manager notifying it of the authentication problem.
Top

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

SecurityException Class
Dart.Snmp Namespace


SecurityException Class Fields

[image]
PowerSNMP for .NET CF
SecurityException Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : SecurityException Class

"

For a list of all members of this type, see SecurityException members.

"

Public Fields

 | Name | Description
public Field | ErrorCode | Gets the SecurityErrorCode value that describes the reason for the exception.
public Field | Request |
public Field | Response | Gets the ReportMessage sent to the Manager notifying it of the authentication problem.
Top

See Also

Reference

SecurityException Class
Dart.Snmp Namespace


ErrorCode Field

[image]
PowerSNMP for .NET CF
ErrorCode Field
See Also Send comments on this topic.
Dart.Snmp Namespace > SecurityException Class : ErrorCode Field

Gets the SecurityErrorCode value that describes the reason for the exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly ErrorCode As SecurityErrorCode
Visual Basic (Usage) Copy Code
Dim instance As SecurityException
Dim value As SecurityErrorCode

value = instance.ErrorCode
C#
public readonly SecurityErrorCode ErrorCode
Managed Extensions for C++
public: readonly SecurityErrorCode ErrorCode
C++/CLI
public:
readonly SecurityErrorCode ErrorCode

Property Value

A SecurityErrorCode that describes the reason for the exception.

Remarks

This property is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SecurityException Class
SecurityException Members


Request Field

[image]
PowerSNMP for .NET CF
Request Field
See Also Send comments on this topic.
Dart.Snmp Namespace > SecurityException Class : Request Field

Syntax

Visual Basic (Declaration)
Public ReadOnly Request As RequestMessage
Visual Basic (Usage) Copy Code
Dim instance As SecurityException
Dim value As RequestMessage

value = instance.Request
C#
public readonly RequestMessage Request
Managed Extensions for C++
public: readonly RequestMessage* Request
C++/CLI
public:
readonly RequestMessage^ Request

Property Value

The RequestMessage sent to the agent.

Remarks

This property is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SecurityException Class
SecurityException Members


Response Field

[image]
PowerSNMP for .NET CF
Response Field
See Also Send comments on this topic.
Dart.Snmp Namespace > SecurityException Class : Response Field

Gets the ReportMessage sent to the Manager notifying it of the authentication problem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Response As ReportMessage
Visual Basic (Usage) Copy Code
Dim instance As SecurityException
Dim value As ReportMessage

value = instance.Response
C#
public readonly ReportMessage Response
Managed Extensions for C++
public: readonly ReportMessage* Response
C++/CLI
public:
readonly ReportMessage^ Response

Property Value

The ReportMessage sent to the Manager.

Remarks

The ReportMessage is used by the agent to relay the type of problem encountered while attempting to authenticate a message. Generally, SecurityException.ErrorCode is an interpretation of the ReportMessage. Use this property if additional information is available in the agent’s response, or if the SecurityException is unable to interpret the agent’s response.

This property is read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SecurityException Class
SecurityException Members


Sequence Class

[image]
PowerSNMP for .NET CF
Sequence Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : Sequence Class

A tagged type representing a sequence of tagged types.

Object Model

Sequence Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class Sequence
   Inherits TaggedType
Visual Basic (Usage) Copy Code
Dim instance As Sequence
C#
[DefaultMemberAttribute("Item")]
public class Sequence : TaggedType
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class Sequence : public TaggedType
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class Sequence : public TaggedType

Remarks

A tagged type representing a sequence of tagged types. ASN.1 Sequence Type: Universal and Constructed.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.Sequence
Dart.Snmp.SequenceOf
Dart.Snmp.SetOf
Dart.Snmp.Variable
Dart.Snmp.VariableCollection

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Sequence Members
Dart.Snmp Namespace


Sequence Class Members

[image]
PowerSNMP for .NET CF
Sequence Class Members
See Also Methods Send comments on this topic.
Dart.Snmp Namespace : Sequence Class

The following tables list the members exposed by Sequence.

Public Constructors

 | Name | Description
public Constructor | Sequence Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Sequence Class
Dart.Snmp Namespace


Sequence Constructor

[image]
PowerSNMP for .NET CF
Sequence Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > Sequence Class : Sequence Constructor

Overload List

Overload | Description
Sequence Constructor | Initializes a new empty instance of the Sequence class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Sequence Class
Sequence Members


Sequence Constructor

[image]
PowerSNMP for .NET CF
Sequence Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > Sequence Class : Sequence Constructor

Initializes a new empty instance of the Sequence class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Sequence()
C#
public Sequence()
Managed Extensions for C++
public: Sequence();
C++/CLI
public:
Sequence();

Remarks

Using applications will not normally manipulate this class. It provides common code for derived classes SequenceOf, SetOf, Variable and VariableCollection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Sequence Class
Sequence Members


Sequence Class Methods

[image]
PowerSNMP for .NET CF
Sequence Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : Sequence Class

"

For a list of all members of this type, see Sequence members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Sequence Class
Dart.Snmp Namespace


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp Namespace > Sequence Class : ToString Method

Converts the object to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Sequence
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that contains the comma separated concatenation of each element’s ToString value in the Sequence.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Sequence Class
Sequence Members


SequenceOf Class

[image]
PowerSNMP for .NET CF
SequenceOf Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : SequenceOf Class

A tagged type representing a sequence of tagged types that are ordered and of the same type.

Object Model

SequenceOf Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SequenceOf
   Inherits Sequence
Visual Basic (Usage) Copy Code
Dim instance As SequenceOf
C#
public sealed class SequenceOf : Sequence
Managed Extensions for C++
public __gc __sealed class SequenceOf : public Sequence
C++/CLI
public ref class SequenceOf sealed : public Sequence

Remarks

ASN.1: Like Sequence, but implies all the variable bindings are of the same type.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.Sequence
Dart.Snmp.SequenceOf

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SequenceOf Members
Dart.Snmp Namespace


SequenceOf Class Members

[image]
PowerSNMP for .NET CF
SequenceOf Class Members
See Also Methods Send comments on this topic.
Dart.Snmp Namespace : SequenceOf Class

The following tables list the members exposed by SequenceOf.

Public Constructors

 | Name | Description
public Constructor | SequenceOf Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

SequenceOf Class
Dart.Snmp Namespace


SequenceOf Constructor

[image]
PowerSNMP for .NET CF
SequenceOf Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > SequenceOf Class : SequenceOf Constructor

Overload List

Overload | Description
SequenceOf Constructor | Initializes a new empty instance of the SequenceOf class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SequenceOf Class
SequenceOf Members


SequenceOf Constructor

[image]
PowerSNMP for .NET CF
SequenceOf Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > SequenceOf Class : SequenceOf Constructor

Initializes a new empty instance of the SequenceOf class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SequenceOf()
C#
public SequenceOf()
Managed Extensions for C++
public: SequenceOf();
C++/CLI
public:
SequenceOf();

Remarks

An example is a MIB table entry definition, which uses this tagged type to describe multiple table rows that are ordered and of the same type.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SequenceOf Class
SequenceOf Members


SetMessage Class

[image]
PowerSNMP for .NET CF
SetMessage Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : SetMessage Class

The SetMessage class is used to send update information from an SNMP version 1/2/3 manager to an agent.

Object Model

SetMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class SetMessage
   Inherits RequestMessage
Visual Basic (Usage) Copy Code
Dim instance As SetMessage
C#
public class SetMessage : RequestMessage
Managed Extensions for C++
public __gc class SetMessage : public RequestMessage
C++/CLI
public ref class SetMessage : public RequestMessage

Remarks

SetMessage derives from StandardMessage.

Typically, only IIDs with Access.WriteOnly or Access.ReadWrite access may be updated using SetMessage.

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.RequestMessage
Dart.Snmp.SetMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SetMessage Members
Dart.Snmp Namespace


SetMessage Class Members

[image]
PowerSNMP for .NET CF
SetMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : SetMessage Class

The following tables list the members exposed by SetMessage.

Public Constructors

 | Name | Description
public Constructor | SetMessage Constructor | Initializes a new instance of the SetMessage class.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

SetMessage Class
Dart.Snmp Namespace


SetMessage Constructor

[image]
PowerSNMP for .NET CF
SetMessage Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > SetMessage Class : SetMessage Constructor

Initializes a new instance of the SetMessage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SetMessage()
C#
public SetMessage()
Managed Extensions for C++
public: SetMessage();
C++/CLI
public:
SetMessage();

Remarks

This constructor will create an empty version 1 message. The application will typically use VariableCollection.Add to initialize the message with variables to be sent.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SetMessage Class
SetMessage Members


SetOf Class

[image]
PowerSNMP for .NET CF
SetOf Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : SetOf Class

A tagged type representing a sequence of tagged types that are of the same type.

Object Model

SetOf Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SetOf
   Inherits Sequence
Visual Basic (Usage) Copy Code
Dim instance As SetOf
C#
public sealed class SetOf : Sequence
Managed Extensions for C++
public __gc __sealed class SetOf : public Sequence
C++/CLI
public ref class SetOf sealed : public Sequence

Remarks

ASN.1 Set Type. Like Sequence, Universal and Constructed.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.Sequence
Dart.Snmp.SetOf

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SetOf Members
Dart.Snmp Namespace


SetOf Class Members

[image]
PowerSNMP for .NET CF
SetOf Class Members
See Also Methods Send comments on this topic.
Dart.Snmp Namespace : SetOf Class

The following tables list the members exposed by SetOf.

Public Constructors

 | Name | Description
public Constructor | SetOf Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

SetOf Class
Dart.Snmp Namespace


SetOf Constructor

[image]
PowerSNMP for .NET CF
SetOf Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > SetOf Class : SetOf Constructor

Overload List

Overload | Description
SetOf Constructor | Initializes a new empty instance of the SetOf class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SetOf Class
SetOf Members


SetOf Constructor

[image]
PowerSNMP for .NET CF
SetOf Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > SetOf Class : SetOf Constructor

Initializes a new empty instance of the SetOf class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SetOf()
C#
public SetOf()
Managed Extensions for C++
public: SetOf();
C++/CLI
public:
SetOf();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SetOf Class
SetOf Members


SimpleTaggedType Class

[image]
PowerSNMP for .NET CF
SimpleTaggedType Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : SimpleTaggedType Class

The SimpleTaggedType class is the base class for all encoded value types in an SNMP message.

Object Model

SimpleTaggedType Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class SimpleTaggedType
   Inherits TaggedType
Visual Basic (Usage) Copy Code
Dim instance As SimpleTaggedType
C#
public abstract class SimpleTaggedType : TaggedType
Managed Extensions for C++
public __gc abstract class SimpleTaggedType : public TaggedType
C++/CLI
public ref class SimpleTaggedType abstract : public TaggedType

Remarks

The SimpleTaggedType class is derived from the TaggedType class and provides a basis for all derived objects used to represent values within a SNMP message.

Many classes derive from SimpleTaggedType:

1. The Counter class specializes the SimpleTaggedType class for SNMP values the represent 32 bit unsigned counter.

2. The Counter64 class specializes the SimpleTaggedType class for SNMP values that represent 64 bit unsigned counters.

3. The Empty class specializes the SimpleTaggedType class for SNMP values that represent Null value.

4. The EndOfMibView class specializes the SimpleTaggedType class for SNMP values used to signal no further values available in GetNext and GetBulk requests.

5. The Gauge class specializes the SimpleTaggedType class for SNMP values used to represent 32 bit signed values.

6. The Id class specializes the SimpleTaggedType class for SNMP values used to represent object id values.

7. The Integer class specializes the SimpleTaggedType class for SNMP values used to represent 32 bit signed values.

8. The IpAddress class specializes the SimpleTaggedType class for SNMP values used to represent Ip address values.

9. The NoSuchInstance class specializes the SimpleTaggedType class for SNMP values used in responses to signal the requested instance does not exist.

10. The NoSuchObject class specializes the SimpleTaggedType class for SNMP values used in responses to signal the requests object does not exist.

11. The Nsap class specializes the SimpleTaggedType class and should not be used in newly developed applications.

12. The OctetString class specializes the SimpleTaggedType class for SNMP values used to represent string values.

13. The Opaque class specializes the SimpleTaggedType class for SNMP values used to represent arbitrary lengths of byte value.

14. The TickTicks class specializes the SimpleTaggedType class for SNMP values used to represent non-negative counts of time in hundredths of a second.

15. The UInteger class specializes the SimpleTaggedType class for SNMP values used to represent 32 bit unsigned values.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Counter64
Dart.Snmp.SimpleType.Empty
Dart.Snmp.SimpleType.EndOfMibView
Dart.Snmp.SimpleType.Integer
Dart.Snmp.SimpleType.NoSuchInstance
Dart.Snmp.SimpleType.NoSuchObject
Dart.Snmp.SimpleType.Opaque
Dart.Snmp.SimpleType.UInteger

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SimpleTaggedType Members
Dart.Snmp Namespace


SimpleTaggedType Class Members

[image]
PowerSNMP for .NET CF
SimpleTaggedType Class Members
See Also Methods Send comments on this topic.
Dart.Snmp Namespace : SimpleTaggedType Class

The following tables list the members exposed by SimpleTaggedType.

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

SimpleTaggedType Class
Dart.Snmp Namespace


SnmpBase Class

[image]
PowerSNMP for .NET CF
SnmpBase Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : SnmpBase Class

SnmpBase is the base class used by Agent and Manager for common functionality.

Object Model

SnmpBase Class

Syntax

Visual Basic (Declaration)
Public Class SnmpBase
   Inherits Dart.Common.SocketBase
Visual Basic (Usage) Copy Code
Dim instance As SnmpBase
C#
public class SnmpBase : Dart.Common.SocketBase
Managed Extensions for C++
public __gc class SnmpBase : public Dart.Common.SocketBase
C++/CLI
public ref class SnmpBase : public Dart.Common.SocketBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Snmp.SnmpBase
Dart.Snmp.Agent
Dart.Snmp.Manager

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Members
Dart.Snmp Namespace


SnmpBase Class Members

[image]
PowerSNMP for .NET CF
SnmpBase Class Members
See Also Fields Properties Methods Events Send comments on this topic.
Dart.Snmp Namespace : SnmpBase Class

The following tables list the members exposed by SnmpBase.

Public Fields

 | Name | Description
public Field | AuthoritativeEngine | Used to store EngineId, EngineTime, and EngineBoot values used for SNMPv3 authentication.
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | LocalEndPoint | Used to specify the local address, port, and address family.
public Field | Mib | Gets the MibNodes object containing MIB definitions.
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | Close | Terminates Agent or Trap operation by releasing communication resources.
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals SNMP messages to the UI thread.
public Method | Send | Send a message to the SNMP manager specified.
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnMessage | Called on the UI thread when SnmpBase.Marshal is used.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Message | The Message event is raised when SnmpBase.Marshal is used.
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SnmpBase Class
Dart.Snmp Namespace


SnmpBase Class Methods

[image]
PowerSNMP for .NET CF
SnmpBase Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : SnmpBase Class

"

For a list of all members of this type, see SnmpBase members.

"

Public Methods

 | Name | Description
public Method | Close | Terminates Agent or Trap operation by releasing communication resources.
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals SNMP messages to the UI thread.
public Method | Send | Send a message to the SNMP manager specified.
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnMessage | Called on the UI thread when SnmpBase.Marshal is used.
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SnmpBase Class
Dart.Snmp Namespace


Close Method

[image]
PowerSNMP for .NET CF
Close Method
See Also Send comments on this topic.
Dart.Snmp Namespace > SnmpBase Class : Close Method

Terminates Agent or Trap operation by releasing communication resources.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As SnmpBase

instance.Close()
C#
public void Close()
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Remarks

The Socket property is null after Close is used.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Class
SnmpBase Members


Marshal Method

[image]
PowerSNMP for .NET CF
Marshal Method
See Also Send comments on this topic.
Dart.Snmp Namespace > SnmpBase Class : Marshal Method

Marshals SNMP messages to the UI thread.

Overload List

Overload | Description
Marshal(MessageBase[],Object) | Marshals SNMP messages to the UI thread.
Marshal(Exception) | Marshals an exception to the UI thread. (Inherited from Dart.Common.ComponentBase)
Marshal(Object) | Marshals user state information to the UI thread. (Inherited from Dart.Common.ComponentBase)

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Class
SnmpBase Members


Marshal(MessageBase[],Object) Method

[image]
PowerSNMP for .NET CF
Marshal(MessageBase[],Object) Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > SnmpBase Class > Marshal Method : Marshal(MessageBase[],Object) Method

messages
Message instances derived from MessageBase to be marshaled.
state
Additional information provided by the user.
Marshals SNMP messages to the UI thread.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal messages() As MessageBase, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As SnmpBase
Dim messages() As MessageBase
Dim state As Object

instance.Marshal(messages, state)
C#
public void Marshal(
   MessageBase[] messages,
   object state
)
Managed Extensions for C++
public: void Marshal(
   MessageBase*[]* messages,
   Object* state
)
C++/CLI
public:
void Marshal(
   array<MessageBase^>^ messages,
   Object^ state
)

Parameters

messages
Message instances derived from MessageBase to be marshaled.
state
Additional information provided by the user.

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Remarks

This method can be used to marshal messages from a worker thread to the UI thread for typical display purposes. It calls the OnMessage method on the UI thread, which raises the Message event.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Class
SnmpBase Members
Overload List


OnMessage Method

[image]
PowerSNMP for .NET CF
OnMessage Method
See Also Send comments on this topic.
Dart.Snmp Namespace > SnmpBase Class : OnMessage Method

e
Instance of arguments passing data for display in UI elements.
Called on the UI thread when SnmpBase.Marshal is used.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMessage( _
   ByVal e As MessageEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SnmpBase
Dim e As MessageEventArgs

instance.OnMessage(e)
C#
protected virtual void OnMessage(
   MessageEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMessage(
   MessageEventArgs* e
)
C++/CLI
protected:
virtual void OnMessage(
   MessageEventArgs^ e
)

Parameters

e
Instance of arguments passing data for display in UI elements.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Class
SnmpBase Members


Send Method

[image]
PowerSNMP for .NET CF
Send Method
See Also Example Send comments on this topic.
Dart.Snmp Namespace > SnmpBase Class : Send Method

message
An instance of a ResponseMessage, ReportMessage, TrapMessage or NotificationMessage.
remoteEndPoint
An IPEndPoint that specifies the network address of an SNMP manager. Usually used when replying to a RequestMessage received from a manager.
Send a message to the SNMP manager specified.

Syntax

Visual Basic (Declaration)
Public Function Send( _
   ByVal message As MessageBase, _
   ByVal remoteEndPoint As IPEndPoint _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SnmpBase
Dim message As MessageBase
Dim remoteEndPoint As IPEndPoint
Dim value As Integer

value = instance.Send(message, remoteEndPoint)
C#
public int Send(
   MessageBase message,
   IPEndPoint remoteEndPoint
)
Managed Extensions for C++
public: int Send(
   MessageBase* message,
   IPEndPoint* remoteEndPoint
)
C++/CLI
public:
int Send(
   MessageBase^ message,
   IPEndPoint^ remoteEndPoint
)

Parameters

message
An instance of a ResponseMessage, ReportMessage, TrapMessage or NotificationMessage.
remoteEndPoint
An IPEndPoint that specifies the network address of an SNMP manager. Usually used when replying to a RequestMessage received from a manager.

Exceptions

Exception | Description
System.Net.Sockets.SocketException | A problem occurred with network resources.
System.InvalidOperationException | The provided message parameter is not a ResponseMessage, ReportMessage, TrapMessage or NotificationMessage.

Example

The following example demonstrates starting a simple agent supporting a MIB variable.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Add variable to agent
    agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace");
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"));

    //Start listening for requests
    agent1.Start(agent1_MessageReceived, null);
}

private void agent1_MessageReceived(Agent agent, RequestMessage request, object state)
{
    //Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    'Add variable to agent
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"))

    'Start listening for requests
    agent1.Start(agent1_MessageReceived, Nothing)
End Sub

Private Sub agent1_MessageReceived(ByVal agent As Agent, ByVal request As RequestMessage, ByVal state As Object)
    'Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin)
End Sub

Remarks

The EncodedMessage property of the message is updated with the encoded message actually sent.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Class
SnmpBase Members


SnmpBase Class Fields

[image]
PowerSNMP for .NET CF
SnmpBase Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : SnmpBase Class

"

For a list of all members of this type, see SnmpBase members.

"

Public Fields

 | Name | Description
public Field | AuthoritativeEngine | Used to store EngineId, EngineTime, and EngineBoot values used for SNMPv3 authentication.
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | LocalEndPoint | Used to specify the local address, port, and address family.
public Field | Mib | Gets the MibNodes object containing MIB definitions.
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SnmpBase Class
Dart.Snmp Namespace


AuthoritativeEngine Field

[image]
PowerSNMP for .NET CF
AuthoritativeEngine Field
See Also Send comments on this topic.
Dart.Snmp Namespace > SnmpBase Class : AuthoritativeEngine Field

Used to store EngineId, EngineTime, and EngineBoot values used for SNMPv3 authentication.

Syntax

Visual Basic (Declaration)
Public ReadOnly AuthoritativeEngine As AuthoritativeEngine
Visual Basic (Usage) Copy Code
Dim instance As SnmpBase
Dim value As AuthoritativeEngine

value = instance.AuthoritativeEngine
C#
public readonly AuthoritativeEngine AuthoritativeEngine
Managed Extensions for C++
public: readonly AuthoritativeEngine* AuthoritativeEngine
C++/CLI
public:
readonly AuthoritativeEngine^ AuthoritativeEngine

Property Value

An AuthoritativeEngine instance.

Remarks

The Agent acts as an authoritative engine when it responds to Manager requests and initiates notifications.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Class
SnmpBase Members


LocalEndPoint Field

[image]
PowerSNMP for .NET CF
LocalEndPoint Field
See Also Send comments on this topic.
Dart.Snmp Namespace > SnmpBase Class : LocalEndPoint Field

Used to specify the local address, port, and address family.

Syntax

Visual Basic (Declaration)
Public LocalEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As SnmpBase
Dim value As IPEndPoint

value = instance.LocalEndPoint

instance.LocalEndPoint = value
C#
public IPEndPoint LocalEndPoint
Managed Extensions for C++
public: IPEndPoint* LocalEndPoint
C++/CLI
public:
IPEndPoint^ LocalEndPoint

Remarks

The default address is IPAddress.Any. The default port is 162 for the Manager and 161 for the Agent. The default address family is AddressFamily.Internetwork (only AddressFamily.Internetwork and AddressFamily.InternetworkV6 are supported).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Class
SnmpBase Members


Mib Field

[image]
PowerSNMP for .NET CF
Mib Field
See Also Send comments on this topic.
Dart.Snmp Namespace > SnmpBase Class : Mib Field

Gets the MibNodes object containing MIB definitions.

Syntax

Visual Basic (Declaration)
Public ReadOnly Mib As MibNodes
Visual Basic (Usage) Copy Code
Dim instance As SnmpBase
Dim value As MibNodes

value = instance.Mib
C#
public readonly MibNodes Mib
Managed Extensions for C++
public: readonly MibNodes* Mib
C++/CLI
public:
readonly MibNodes^ Mib

Remarks

This property is used during response message decoding to populate Variable.MibNode with a MibNode object containing a matching Variable.Id value.

Mib is initialized with objects from the intrinsic MibNode objects as well objects added with code or imported from external mib files.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Class
SnmpBase Members


SnmpBase Class Events

[image]
PowerSNMP for .NET CF
SnmpBase Class Events
See Also Send comments on this topic.
Dart.Snmp Namespace : SnmpBase Class

"

For a list of all members of this type, see SnmpBase members.

"

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Message | The Message event is raised when SnmpBase.Marshal is used.
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SnmpBase Class
Dart.Snmp Namespace


Message Event

[image]
PowerSNMP for .NET CF
Message Event
See Also Example Send comments on this topic.
Dart.Snmp Namespace > SnmpBase Class : Message Event

The Message event is raised when SnmpBase.Marshal is used.

Syntax

Visual Basic (Declaration)
Public Event Message As MessageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As SnmpBase
Dim handler As MessageEventHandler

AddHandler instance.Message, handler
C#
public event MessageEventHandler Message
Managed Extensions for C++
public: __event MessageEventHandler* Message
C++/CLI
public:
event MessageEventHandler^ Message

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Remarks

This method is raised on the UI thread so that the passed parameters may be displayed in UI controls.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SnmpBase Class
SnmpBase Members


StandardMessage Class

[image]
PowerSNMP for .NET CF
StandardMessage Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : StandardMessage Class

The StandardMessage Class is the base class for all SNMP messages except TrapMessage.

Object Model

StandardMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class StandardMessage
   Inherits MessageBase
Visual Basic (Usage) Copy Code
Dim instance As StandardMessage
C#
public abstract class StandardMessage : MessageBase
Managed Extensions for C++
public __gc abstract class StandardMessage : public MessageBase
C++/CLI
public ref class StandardMessage abstract : public MessageBase

Remarks

StandardMessage derives from MessageBase.

Two classes derive from StandardMessage:

1. The RequestMessage class specializes the StandardMessage class for SNMP requests that are generally sent by managers to agents.

2. The ResponseMessage class specializes the StandardMessage class for SNMP responses that are returned to managers from agents.

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.NotificationMessage
Dart.Snmp.RequestMessage
Dart.Snmp.ResponseMessage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

StandardMessage Members
Dart.Snmp Namespace


StandardMessage Class Members

[image]
PowerSNMP for .NET CF
StandardMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : StandardMessage Class

The following tables list the members exposed by StandardMessage.

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Overridden. Encodes all SNMP version 1/2/3 messages except for traps.
Top

See Also

Reference

StandardMessage Class
Dart.Snmp Namespace


StandardMessage Class Methods

[image]
PowerSNMP for .NET CF
StandardMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : StandardMessage Class

"

For a list of all members of this type, see StandardMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Overridden. Encodes all SNMP version 1/2/3 messages except for traps.
Top

See Also

Reference

StandardMessage Class
Dart.Snmp Namespace


Encode Method

[image]
PowerSNMP for .NET CF
Encode Method
See Also Send comments on this topic.
Dart.Snmp Namespace > StandardMessage Class : Encode Method

Encodes all SNMP version 1/2/3 messages except for traps.

Syntax

Visual Basic (Declaration)
Public Overrides Function Encode() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As StandardMessage
Dim value() As Byte

value = instance.Encode()
C#
public override byte[] Encode()
Managed Extensions for C++
public: byte[]* Encode(); override
C++/CLI
public:
array<byte>^ Encode(); override

Return Value

A byte array with the encoded message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

StandardMessage Class
StandardMessage Members


StandardMessage Class Properties

[image]
PowerSNMP for .NET CF
StandardMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : StandardMessage Class

"

For a list of all members of this type, see StandardMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

StandardMessage Class
Dart.Snmp Namespace


Id Property

[image]
PowerSNMP for .NET CF
Id Property
See Also Send comments on this topic.
Dart.Snmp Namespace > StandardMessage Class : Id Property

Gets or sets the request identification field in the message.

Syntax

Visual Basic (Declaration)
Public Property Id As Integer
Visual Basic (Usage) Copy Code
Dim instance As StandardMessage
Dim value As Integer

instance.Id = value

value = instance.Id
C#
public int Id {get; set;}
Managed Extensions for C++
public: __property int get_Id();
public: __property void set_Id(
   int value
);
C++/CLI
public:
property int Id {
   int get();
   void set (    int value);
}

Property Value

An integer that can pair a version 1 or 2 ResponseMessage to a specific RequestMessage.

Remarks

The default constructor for any class derived from RequestMessage will automatically initialize this value to one higher than the previous. The first instance will have an Id of 1, the second an Id of 2, and so on.

All decoded messages return the value encoded in the message. Version 1 and 2 messages use this property in leau of Security.Id.

This property is unrelated to Variable.Id, which is either an OID or IID.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

StandardMessage Class
StandardMessage Members


StandardMessage Class Fields

[image]
PowerSNMP for .NET CF
StandardMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : StandardMessage Class

"

For a list of all members of this type, see StandardMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

StandardMessage Class
Dart.Snmp Namespace


Security Field

[image]
PowerSNMP for .NET CF
Security Field
See Also Send comments on this topic.
Dart.Snmp Namespace > StandardMessage Class : Security Field

Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages.

Syntax

Visual Basic (Declaration)
Public Security As Security
Visual Basic (Usage) Copy Code
Dim instance As StandardMessage
Dim value As Security

value = instance.Security

instance.Security = value
C#
public Security Security
Managed Extensions for C++
public: Security* Security
C++/CLI
public:
Security^ Security

Property Value

The Security class provides support for SNMP version 3 message processing.

Remarks

Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

StandardMessage Class
StandardMessage Members


TableEventArgs Class

[image]
PowerSNMP for .NET CF
TableEventArgs Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : TableEventArgs Class

Provides data for the Table event.

Object Model

TableEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class TableEventArgs
   Inherits Dart.Common.UserStateEventArgs
Visual Basic (Usage) Copy Code
Dim instance As TableEventArgs
C#
public class TableEventArgs : Dart.Common.UserStateEventArgs
Managed Extensions for C++
public __gc class TableEventArgs : public Dart.Common.UserStateEventArgs
C++/CLI
public ref class TableEventArgs : public Dart.Common.UserStateEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Common.UserStateEventArgs
Dart.Snmp.TableEventArgs

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TableEventArgs Members
Dart.Snmp Namespace


TableEventArgs Class Members

[image]
PowerSNMP for .NET CF
TableEventArgs Class Members
See Also Fields Send comments on this topic.
Dart.Snmp Namespace : TableEventArgs Class

The following tables list the members exposed by TableEventArgs.

Public Fields

 | Name | Description
public Field | Oid | Gets the OID used to request the table of variables.
public Field | Table | Gets the table marshaled to the UI thread using Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object).
public Field | UserState | Gets the user information provided by the UserState event. (Inherited from Dart.Common.UserStateEventArgs)
Top

See Also

Reference

TableEventArgs Class
Dart.Snmp Namespace


TableEventArgs Class Fields

[image]
PowerSNMP for .NET CF
TableEventArgs Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : TableEventArgs Class

"

For a list of all members of this type, see TableEventArgs members.

"

Public Fields

 | Name | Description
public Field | Oid | Gets the OID used to request the table of variables.
public Field | Table | Gets the table marshaled to the UI thread using Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object).
public Field | UserState | Gets the user information provided by the UserState event. (Inherited from Dart.Common.UserStateEventArgs)
Top

See Also

Reference

TableEventArgs Class
Dart.Snmp Namespace


Oid Field

[image]
PowerSNMP for .NET CF
Oid Field
See Also Send comments on this topic.
Dart.Snmp Namespace > TableEventArgs Class : Oid Field

Gets the OID used to request the table of variables.

Syntax

Visual Basic (Declaration)
Public ReadOnly Oid As String
Visual Basic (Usage) Copy Code
Dim instance As TableEventArgs
Dim value As String

value = instance.Oid
C#
public readonly string Oid
Managed Extensions for C++
public: readonly string* Oid
C++/CLI
public:
readonly String^ Oid

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TableEventArgs Class
TableEventArgs Members


Table Field

[image]
PowerSNMP for .NET CF
Table Field
See Also Send comments on this topic.
Dart.Snmp Namespace > TableEventArgs Class : Table Field

Gets the table marshaled to the UI thread using Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object).

Syntax

Visual Basic (Declaration)
Public ReadOnly Table As Variable()
Visual Basic (Usage) Copy Code
Dim instance As TableEventArgs
Dim value() As Variable

value = instance.Table
C#
public readonly Variable[] Table
Managed Extensions for C++
public: readonly Variable*[]* Table
C++/CLI
public:
readonly array<Variable^>^ Table

Property Value

A two dimensional array of Variable objects representing the returned table.

Remarks

The returned Variable array is a two dimensional array. Use the System.Array.GetLength(System.Int32) method with a value of 0 to determine the number of rows in the returned table, or a value of 1 to determine the number of columns in the returned table.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TableEventArgs Class
TableEventArgs Members


TaggedType Class

[image]
PowerSNMP for .NET CF
TaggedType Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : TaggedType Class

The TaggedType class is the base class for the SimpleTaggedType class.

Object Model

TaggedType Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class TaggedType
Visual Basic (Usage) Copy Code
Dim instance As TaggedType
C#
public abstract class TaggedType
Managed Extensions for C++
public __gc abstract class TaggedType
C++/CLI
public ref class TaggedType abstract

Remarks

The TaggedType class provides a basis for all derived SimpleType objects use to represent values within a SNMP message.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.Sequence
Dart.Snmp.SimpleTaggedType

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TaggedType Members
Dart.Snmp Namespace


TaggedType Class Members

[image]
PowerSNMP for .NET CF
TaggedType Class Members
See Also Methods Send comments on this topic.
Dart.Snmp Namespace : TaggedType Class

The following tables list the members exposed by TaggedType.

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content.
Top

See Also

Reference

TaggedType Class
Dart.Snmp Namespace


TaggedType Class Methods

[image]
PowerSNMP for .NET CF
TaggedType Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : TaggedType Class

"

For a list of all members of this type, see TaggedType members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content.
Top

See Also

Reference

TaggedType Class
Dart.Snmp Namespace


Encode Method

[image]
PowerSNMP for .NET CF
Encode Method
See Also Send comments on this topic.
Dart.Snmp Namespace > TaggedType Class : Encode Method

Encode the object with no content. Overridden in derived classes that have content.

Overload List

Overload | Description
Encode() | Encode object and return as a byte array. Normally used to create an SNMP packet.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TaggedType Class
TaggedType Members


Encode() Method

[image]
PowerSNMP for .NET CF
Encode() Method
See Also Send comments on this topic.
Dart.Snmp Namespace > TaggedType Class : Encode() Method

Encode object and return as a byte array. Normally used to create an SNMP packet.

Syntax

Visual Basic (Declaration)
Public Function Encode() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As TaggedType
Dim value() As Byte

value = instance.Encode()
C#
public byte[] Encode()
Managed Extensions for C++
public: byte[]* Encode();
C++/CLI
public:
array<byte>^ Encode();

Return Value

Byte array

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TaggedType Class
TaggedType Members


TrapMessage Class

[image]
PowerSNMP for .NET CF
TrapMessage Class
Members Example See Also Send comments on this topic.
Dart.Snmp Namespace : TrapMessage Class

The TrapMessage class is used to send SNMP version 1 traps from an agent to a manager.

Object Model

TrapMessage ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class TrapMessage
   Inherits MessageBase
Visual Basic (Usage) Copy Code
Dim instance As TrapMessage
C#
public class TrapMessage : MessageBase
Managed Extensions for C++
public __gc class TrapMessage : public MessageBase
C++/CLI
public ref class TrapMessage : public MessageBase

Example

The following example demonstrates receiving trap, notification and inform messages.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
  //Start listening for traps, notifications and informs
  manager1.Start(manager1_MessageReceived, null);
}

private void manager1_MessageReceived(Manager manager, MessageBase message, object state)
{
  //Marshal message to the UI thread using the Message event
  if (message is TrapMessage)
    manager.Marshal(new MessageBase[] { message }, "trap");
    else if (message is NotificationMessage)
    manager.Marshal(new MessageBase[] { message }, "notification");
  else if (message is InformMessage)
  {
    manager.Marshal(new MessageBase[] { message }, "inform");

    //Send response to inform message origin
    manager.Send(new ResponseMessage(message as InformMessage), message.Origin);
  }
}

private void manager1_Message(object sender, MessageEventArgs e)
{
  //Update interface according to message type received
  switch (e.UserState.ToString())
  {
    case "trap":
      TrapMessage trap = e.Messages[0] as TrapMessage;
      label1.Text = "Trap received with Enterprise(" + trap.Enterprise + "), Generic Type (" +
        trap.GenericTrap.ToString() + "), Specific Type(" + trap.SpecificTrap.ToString() + ")";
      break;
    case "notification":
      NotificationMessage notification = e.Messages[0] as NotificationMessage;
      label1.Text = "Notification received with OID (" + notification.Oid + ")";
      break;
    case "inform":
      InformMessage inform = e.Messages[0] as InformMessage;
      label1.Text = "Inform received with " + inform.Variables.Count.ToString() + " variable(s).";
      break;
  }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
  'Start listening for traps, notifications and informs
  manager1.Start(AddressOf manager1_MessageReceived, Nothing)
End Sub

Private Sub manager1_MessageReceived(ByVal manager As Manager, ByVal message As MessageBase, ByVal state As Object)
  'Marshal message to the UI thread using the Message event
  If TypeOf message Is TrapMessage Then
    manager.Marshal(New MessageBase() {message}, "trap")
  ElseIf TypeOf message Is NotificationMessage Then
    manager.Marshal(New MessageBase() {message}, "notification")
  ElseIf TypeOf message Is InformMessage Then
    manager.Marshal(New MessageBase() {message}, "inform")

    'Send response to inform message origin
    manager.Send(New ResponseMessage(TryCast(message, InformMessage)), message.Origin)
  End If
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As MessageEventArgs) Handles manager1.Message
  'Update interface according to message type received
  Select Case e.UserState.ToString()
    Case "trap"
      Dim trap As TrapMessage = TryCast(e.Messages(0), TrapMessage)
      label1.Text = "Trap received with Enterprise(" & trap.Enterprise & "), Generic Type (" & _
        trap.GenericTrap.ToString() & "), Specific Type(" & trap.SpecificTrap.ToString() & ")"
    Case "notification"
      Dim notification As NotificationMessage = TryCast(e.Messages(0), NotificationMessage)
      label1.Text = "Notification received with OID (" & notification.Oid & ")"
    Case "inform"
      Dim inform As InformMessage = TryCast(e.Messages(0), InformMessage)
      label1.Text = "Inform received with " & inform.Variables.Count.ToString() & " variable(s)."
  End Select
End Sub

Remarks

TrapMessage derives from MessageBase.

Six classes are included that specialize the TrapMessage class to defined generic traps:

1. Dart.Snmp.Trap.coldStart

2. Dart.Snmp.Trap.warmStart

3. Dart.Snmp.Trap.linkDown

4. Dart.Snmp.Trap.linkUp

5. Dart.Snmp.Trap.authenticationFailure

6. Dart.Snmp.Trap.egpNeighborLoss

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.TrapMessage
Dart.Snmp.Trap.authenticationFailure
Dart.Snmp.Trap.coldStart
Dart.Snmp.Trap.egpNeighborLoss
Dart.Snmp.Trap.linkDown
Dart.Snmp.Trap.linkUp
Dart.Snmp.Trap.SpecificTrap
Dart.Snmp.Trap.warmStart

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TrapMessage Members
Dart.Snmp Namespace


TrapMessage Class Members

[image]
PowerSNMP for .NET CF
TrapMessage Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : TrapMessage Class

The following tables list the members exposed by TrapMessage.

Public Constructors

 | Name | Description
public Constructor | TrapMessage Constructor | Initializes a new instance of the TrapMessage class.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap.
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage.
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded.
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second.
public Property | Variables | Overridden. Gets or sets the VariableCollection that holds the variables.
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Overridden. Sets TrapMessage.SysUpTime to MessageBase.SysUpTime before encoding the message.
Top

See Also

Reference

TrapMessage Class
Dart.Snmp Namespace


TrapMessage Constructor

[image]
PowerSNMP for .NET CF
TrapMessage Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > TrapMessage Class : TrapMessage Constructor

genericTrap
Indicates the generic trap number to use when building the message.
specificTrap
If genericTrap is 6, then specificTrap indicates more detailed information.
enterprise
A string that initializes the enterprise field.
Initializes a new instance of the TrapMessage class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal genericTrap As Integer, _
   ByVal specificTrap As Integer, _
   ByVal enterprise As String _
)
Visual Basic (Usage) Copy Code
Dim genericTrap As Integer
Dim specificTrap As Integer
Dim enterprise As String

Dim instance As New TrapMessage(genericTrap, specificTrap, enterprise)
C#
public TrapMessage(
   int genericTrap,
   int specificTrap,
   string enterprise
)
Managed Extensions for C++
public: TrapMessage(
   int genericTrap,
   int specificTrap,
   string* enterprise
)
C++/CLI
public:
TrapMessage(
   int genericTrap,
   int specificTrap,
   String^ enterprise
)

Parameters

genericTrap
Indicates the generic trap number to use when building the message.
specificTrap
If genericTrap is 6, then specificTrap indicates more detailed information.
enterprise
A string that initializes the enterprise field.

Remarks

This constructor will create an empty version 1 message. The TrapMessage.SysUpTime property is initialized to 0 and is updated to the value found in MessageBase.SysUpTime when TrapMessage.Encode is used.

The agent initiating the trap should initialize AgentAddress.

The application can add additional information by adding variables to MessageBase.Variables.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TrapMessage Class
TrapMessage Members


TrapMessage Class Methods

[image]
PowerSNMP for .NET CF
TrapMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : TrapMessage Class

"

For a list of all members of this type, see TrapMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Overridden. Sets TrapMessage.SysUpTime to MessageBase.SysUpTime before encoding the message.
Top

See Also

Reference

TrapMessage Class
Dart.Snmp Namespace


Encode Method

[image]
PowerSNMP for .NET CF
Encode Method
See Also Send comments on this topic.
Dart.Snmp Namespace > TrapMessage Class : Encode Method

Sets TrapMessage.SysUpTime to MessageBase.SysUpTime before encoding the message.

Syntax

Visual Basic (Declaration)
Public Overrides Function Encode() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As TrapMessage
Dim value() As Byte

value = instance.Encode()
C#
public override byte[] Encode()
Managed Extensions for C++
public: byte[]* Encode(); override
C++/CLI
public:
array<byte>^ Encode(); override

Return Value

A byte array with the encoded message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TrapMessage Class
TrapMessage Members


TrapMessage Class Properties

[image]
PowerSNMP for .NET CF
TrapMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : TrapMessage Class

"

For a list of all members of this type, see TrapMessage members.

"

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap.
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage.
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded.
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second.
public Property | Variables | Overridden. Gets or sets the VariableCollection that holds the variables.
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

TrapMessage Class
Dart.Snmp Namespace


AgentAddress Property

[image]
PowerSNMP for .NET CF
AgentAddress Property
See Also Send comments on this topic.
Dart.Snmp Namespace > TrapMessage Class : AgentAddress Property

Gets or sets the address of the agent initiating the trap.

Syntax

Visual Basic (Declaration)
Public Property AgentAddress As String
Visual Basic (Usage) Copy Code
Dim instance As TrapMessage
Dim value As String

instance.AgentAddress = value

value = instance.AgentAddress
C#
public string AgentAddress {get; set;}
Managed Extensions for C++
public: __property string* get_AgentAddress();
public: __property void set_AgentAddress(
   string* value
);
C++/CLI
public:
property String^ AgentAddress {
   String^ get();
   void set (    String^ value);
}

Property Value

The address of the agent that initiated the trap, in dot notation (ww.xx.yy.zz).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TrapMessage Class
TrapMessage Members


Enterprise Property

[image]
PowerSNMP for .NET CF
Enterprise Property
See Also Send comments on this topic.
Dart.Snmp Namespace > TrapMessage Class : Enterprise Property

Gets the Enterprise OID associated with the TrapMessage.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Enterprise As String
Visual Basic (Usage) Copy Code
Dim instance As TrapMessage
Dim value As String

value = instance.Enterprise
C#
public string Enterprise {get;}
Managed Extensions for C++
public: __property string* get_Enterprise();
C++/CLI
public:
property String^ Enterprise {
   String^ get();
}

Property Value

Returns the Enterprise associated with the trap provided to the constructor.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TrapMessage Class
TrapMessage Members


GenericTrap Property

[image]
PowerSNMP for .NET CF
GenericTrap Property
See Also Send comments on this topic.
Dart.Snmp Namespace > TrapMessage Class : GenericTrap Property

Gets the generic trap as initialized in the constructor or when decoded.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GenericTrap As Integer
Visual Basic (Usage) Copy Code
Dim instance As TrapMessage
Dim value As Integer

value = instance.GenericTrap
C#
public int GenericTrap {get;}
Managed Extensions for C++
public: __property int get_GenericTrap();
C++/CLI
public:
property int GenericTrap {
   int get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TrapMessage Class
TrapMessage Members


SpecificTrap Property

[image]
PowerSNMP for .NET CF
SpecificTrap Property
See Also Send comments on this topic.
Dart.Snmp Namespace > TrapMessage Class : SpecificTrap Property

Gets the specific trap as initialized in the constructor or when decoded.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpecificTrap As Integer
Visual Basic (Usage) Copy Code
Dim instance As TrapMessage
Dim value As Integer

value = instance.SpecificTrap
C#
public int SpecificTrap {get;}
Managed Extensions for C++
public: __property int get_SpecificTrap();
C++/CLI
public:
property int SpecificTrap {
   int get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TrapMessage Class
TrapMessage Members


SysUpTime Property

[image]
PowerSNMP for .NET CF
SysUpTime Property
See Also Send comments on this topic.
Dart.Snmp Namespace > TrapMessage Class : SysUpTime Property

Gets the time since the agent was initialized in hundredths of a second.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property SysUpTime As Long
Visual Basic (Usage) Copy Code
Dim instance As TrapMessage
Dim value As Long

value = instance.SysUpTime
C#
public new long SysUpTime {get;}
Managed Extensions for C++
public: __property new long get_SysUpTime();
C++/CLI
public:
new property int64 SysUpTime {
   int64 get();
}

Property Value

Initialized to 0 in the constructor, this value is updated to MessageBase.SysUpTime when TrapMessage.Encode is used. MessageBase.Create sets this property to the value in the encoded message.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TrapMessage Class
TrapMessage Members


Variables Property

[image]
PowerSNMP for .NET CF
Variables Property
See Also Send comments on this topic.
Dart.Snmp Namespace > TrapMessage Class : Variables Property

Gets or sets the VariableCollection that holds the variables.

Syntax

Visual Basic (Declaration)
Public Overrides Property Variables As VariableCollection
Visual Basic (Usage) Copy Code
Dim instance As TrapMessage
Dim value As VariableCollection

instance.Variables = value

value = instance.Variables
C#
public override VariableCollection Variables {get; set;}
Managed Extensions for C++
public: __property VariableCollection* get_Variables() override;
public: __property void set_Variables(
   VariableCollection* value
) override;
C++/CLI
public:
property VariableCollection^ Variables {
   VariableCollection^ get() override;
   void set (    VariableCollection^ value) override;
}

Property Value

The contents of this property depends upon the kind of trap. Derived classes may provided properties that allow the application to get and set specific properties that map to a specific variable in this collection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TrapMessage Class
TrapMessage Members


Variable Class

[image]
PowerSNMP for .NET CF
Variable Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : Variable Class

A Sequence that contains an instance of the Id class and an instance of the SimpleTaggedType class.

Object Model

Variable ClassSimpleTaggedType Class

Syntax

Visual Basic (Declaration)
Public Class Variable
   Inherits Sequence
Visual Basic (Usage) Copy Code
Dim instance As Variable
C#
public class Variable : Sequence
Managed Extensions for C++
public __gc class Variable : public Sequence
C++/CLI
public ref class Variable : public Sequence

Remarks

Users will normally manipulate instances of this class, or of classes that derive from MibNode. Instances of this class are agregated as elements of the VariableCollection class.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.Sequence
Dart.Snmp.Variable

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Members
Dart.Snmp Namespace


Variable Class Members

[image]
PowerSNMP for .NET CF
Variable Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp Namespace : Variable Class

The following tables list the members exposed by Variable.

Public Constructors

 | Name | Description
public Constructor | Variable Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Definition | The MIB definition of the OID (object ID) corresponding to this IID (instance ID).
Top

Public Properties

 | Name | Description
public Property | Id | Gets the id of the variable.
public Property | Value | Gets or sets the value of the Variable.
public Property | ValueName | Gets the human readable identifier that represents the enumeration value of the variable.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | GetName | Get the name of the Variable if a Definition is present, otherwise returns the Id.
public Method | ToString | Gets a string version of the Variable.
Top

See Also

Reference

Variable Class
Dart.Snmp Namespace


Variable Constructor

[image]
PowerSNMP for .NET CF
Variable Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class : Variable Constructor

Overload List

Overload | Description
Variable Constructor(String,SimpleTaggedType) | Initializes a new instance of the Variable class.
Variable Constructor(String) | Initializes a new instance of the Variable class (typically for use with GetMessage, GetNextMessage or GetBulkMessage).
Variable Constructor(MibNode,String) | Initializes a new instance of the Variable class (typically for use with GetMessage, GetNextMessage or GetBulkMessage).
Variable Constructor(MibNode) | Initializes a new instance of the Variable class (typically for use with GetMessage, GetNextMessage or GetBulkMessage).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members


Variable Constructor(String,SimpleTaggedType)

[image]
PowerSNMP for .NET CF
Variable Constructor(String,SimpleTaggedType)
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class > Variable Constructor : Variable Constructor(String,SimpleTaggedType)

id
The IID, OID or OID segment assigned to Id.
value
A SimpleTaggedType object that is assigned to Value.
Initializes a new instance of the Variable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal id As String, _
   ByVal value As SimpleTaggedType _
)
Visual Basic (Usage) Copy Code
Dim id As String
Dim value As SimpleTaggedType

Dim instance As New Variable(id, value)
C#
public Variable(
   string id,
   SimpleTaggedType value
)
Managed Extensions for C++
public: Variable(
   string* id,
   SimpleTaggedType* value
)
C++/CLI
public:
Variable(
   String^ id,
   SimpleTaggedType^ value
)

Parameters

id
The IID, OID or OID segment assigned to Id.
value
A SimpleTaggedType object that is assigned to Value.

Remarks

A variable aggregates an instance id (IID) and a value. GetNextMessage, however, can use any OID or OID fragment for id, and will return the next IID found by the agent (in lexigraphical order) in the ResponseMessage.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members
Overload List


Variable Constructor(String)

[image]
PowerSNMP for .NET CF
Variable Constructor(String)
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class > Variable Constructor : Variable Constructor(String)

id
The IID, OID or OID fragment used to initialize Id.
Initializes a new instance of the Variable class (typically for use with GetMessage, GetNextMessage or GetBulkMessage).

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal id As String _
)
Visual Basic (Usage) Copy Code
Dim id As String

Dim instance As New Variable(id)
C#
public Variable(
   string id
)
Managed Extensions for C++
public: Variable(
   string* id
)
C++/CLI
public:
Variable(
   String^ id
)

Parameters

id
The IID, OID or OID fragment used to initialize Id.

Remarks

The Value property is initialized to an instance of SimpleType.Empty.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members
Overload List


Variable Constructor(MibNode,String)

[image]
PowerSNMP for .NET CF
Variable Constructor(MibNode,String)
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class > Variable Constructor : Variable Constructor(MibNode,String)

definition
The MibNode instance providing a definition for the Variable.
value
The value to be encoded (as a SimpleType).
Initializes a new instance of the Variable class (typically for use with GetMessage, GetNextMessage or GetBulkMessage).

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal definition As MibNode, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim definition As MibNode
Dim value As String

Dim instance As New Variable(definition, value)
C#
public Variable(
   MibNode definition,
   string value
)
Managed Extensions for C++
public: Variable(
   MibNode* definition,
   string* value
)
C++/CLI
public:
Variable(
   MibNode^ definition,
   String^ value
)

Parameters

definition
The MibNode instance providing a definition for the Variable.
value
The value to be encoded (as a SimpleType).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members
Overload List


Variable Constructor(MibNode)

[image]
PowerSNMP for .NET CF
Variable Constructor(MibNode)
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class > Variable Constructor : Variable Constructor(MibNode)

definition
The MibNode instance providing a definition for the Variable.
Initializes a new instance of the Variable class (typically for use with GetMessage, GetNextMessage or GetBulkMessage).

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal definition As MibNode _
)
Visual Basic (Usage) Copy Code
Dim definition As MibNode

Dim instance As New Variable(definition)
C#
public Variable(
   MibNode definition
)
Managed Extensions for C++
public: Variable(
   MibNode* definition
)
C++/CLI
public:
Variable(
   MibNode^ definition
)

Parameters

definition
The MibNode instance providing a definition for the Variable.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members
Overload List


Variable Class Methods

[image]
PowerSNMP for .NET CF
Variable Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : Variable Class

"

For a list of all members of this type, see Variable members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | GetName | Get the name of the Variable if a Definition is present, otherwise returns the Id.
public Method | ToString | Gets a string version of the Variable.
Top

See Also

Reference

Variable Class
Dart.Snmp Namespace


GetName Method

[image]
PowerSNMP for .NET CF
GetName Method
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class : GetName Method

Get the name of the Variable if a Definition is present, otherwise returns the Id.

Syntax

Visual Basic (Declaration)
Public Function GetName() As String
Visual Basic (Usage) Copy Code
Dim instance As Variable
Dim value As String

value = instance.GetName()
C#
public string GetName()
Managed Extensions for C++
public: string* GetName();
C++/CLI
public:
String^ GetName();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class : ToString Method

Gets a string version of the Variable.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Variable
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Remarks

The string is built using GetName() + ": " + Value.ToString().

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members


Variable Class Properties

[image]
PowerSNMP for .NET CF
Variable Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : Variable Class

"

For a list of all members of this type, see Variable members.

"

Public Properties

 | Name | Description
public Property | Id | Gets the id of the variable.
public Property | Value | Gets or sets the value of the Variable.
public Property | ValueName | Gets the human readable identifier that represents the enumeration value of the variable.
Top

See Also

Reference

Variable Class
Dart.Snmp Namespace


Id Property

[image]
PowerSNMP for .NET CF
Id Property
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class : Id Property

Gets the id of the variable.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As String
Visual Basic (Usage) Copy Code
Dim instance As Variable
Dim value As String

value = instance.Id
C#
public string Id {get;}
Managed Extensions for C++
public: __property string* get_Id();
C++/CLI
public:
property String^ Id {
   String^ get();
}

Property Value

Returns a string containing the Id value assigned to the Variable.

Remarks

This property is read-only, and can only be set in the constructor.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members


Value Property

[image]
PowerSNMP for .NET CF
Value Property
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class : Value Property

Gets or sets the value of the Variable.

Syntax

Visual Basic (Declaration)
Public Overridable Property Value As SimpleTaggedType
Visual Basic (Usage) Copy Code
Dim instance As Variable
Dim value As SimpleTaggedType

instance.Value = value

value = instance.Value
C#
public virtual SimpleTaggedType Value {get; set;}
Managed Extensions for C++
public: __property virtual SimpleTaggedType* get_Value();
public: __property virtual void set_Value(
   SimpleTaggedType* value
);
C++/CLI
public:
virtual property SimpleTaggedType^ Value {
   SimpleTaggedType^ get();
   void set (    SimpleTaggedType^ value);
}

Property Value

A SimpleTaggedType that contains the value of the Variable.

Remarks

It is the responsibility of either the user or derived classes to ensure the correct SimpleTaggedType is used for the Id specified.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members


ValueName Property

[image]
PowerSNMP for .NET CF
ValueName Property
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class : ValueName Property

Gets the human readable identifier that represents the enumeration value of the variable.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueName As String
Visual Basic (Usage) Copy Code
Dim instance As Variable
Dim value As String

value = instance.ValueName
C#
public string ValueName {get;}
Managed Extensions for C++
public: __property string* get_ValueName();
C++/CLI
public:
property String^ ValueName {
   String^ get();
}

Property Value

A string that contains the enumeration name of the Value

Remarks

Read-only. ValueName returns an empty string if the Variable does not represent an enumerated value or if the loaded MIB files do not contain a definition for the Variable OID value. If Value is not a valid enumeration value as defined in the MIB, the string “Invalid Enumeration Value” will be returned.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members


Variable Class Fields

[image]
PowerSNMP for .NET CF
Variable Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : Variable Class

"

For a list of all members of this type, see Variable members.

"

Public Fields

 | Name | Description
public Field | Definition | The MIB definition of the OID (object ID) corresponding to this IID (instance ID).
Top

See Also

Reference

Variable Class
Dart.Snmp Namespace


Definition Field

[image]
PowerSNMP for .NET CF
Definition Field
See Also Send comments on this topic.
Dart.Snmp Namespace > Variable Class : Definition Field

The MIB definition of the OID (object ID) corresponding to this IID (instance ID).

Syntax

Visual Basic (Declaration)
Public Definition As MibNode
Visual Basic (Usage) Copy Code
Dim instance As Variable
Dim value As MibNode

value = instance.Definition

instance.Definition = value
C#
public MibNode Definition
Managed Extensions for C++
public: MibNode* Definition
C++/CLI
public:
MibNode^ Definition

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Variable Class
Variable Members


VariableCollection Class

[image]
PowerSNMP for .NET CF
VariableCollection Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : VariableCollection Class

A Sequence that contains a collection of Variable objects.

Object Model

VariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class VariableCollection
   Inherits Sequence
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
C#
[DefaultMemberAttribute("Item")]
public class VariableCollection : Sequence
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class VariableCollection : public Sequence
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class VariableCollection : public Sequence

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.Sequence
Dart.Snmp.VariableCollection

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Members
Dart.Snmp Namespace


VariableCollection Class Members

[image]
PowerSNMP for .NET CF
VariableCollection Class Members
See Also Properties Methods Send comments on this topic.
Dart.Snmp Namespace : VariableCollection Class

The following tables list the members exposed by VariableCollection.

Public Constructors

 | Name | Description
public Constructor | VariableCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Count | Gets the number of variables in the collection.
public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
public Property | Item | Gets or sets the Variable at the specified index.
public Property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a Variable to the end of the collection.
public Method | Clear | Removes all Variable objects from the collection.
public Method | CopyTo | Copies the elements of the collection to a specified array.
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | GetEnumerator | Returns an enumerator that can iterate through the objects in the collection.
public Method | Insert | Adds a Variable to the collection at the specified index.
public Method | Remove | Removes the first occurrence of the provided variable from the collection.
Top

See Also

Reference

VariableCollection Class
Dart.Snmp Namespace


VariableCollection Constructor

[image]
PowerSNMP for .NET CF
VariableCollection Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : VariableCollection Constructor

Overload List

Overload | Description
VariableCollection Constructor | Initializes a new instance of the VariableCollection class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


VariableCollection Constructor

[image]
PowerSNMP for .NET CF
VariableCollection Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : VariableCollection Constructor

Initializes a new instance of the VariableCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New VariableCollection()
C#
public VariableCollection()
Managed Extensions for C++
public: VariableCollection();
C++/CLI
public:
VariableCollection();

Remarks

The VariableCollection class contains a collection of Variable objects.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


VariableCollection Class Methods

[image]
PowerSNMP for .NET CF
VariableCollection Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : VariableCollection Class

"

For a list of all members of this type, see VariableCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a Variable to the end of the collection.
public Method | Clear | Removes all Variable objects from the collection.
public Method | CopyTo | Copies the elements of the collection to a specified array.
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | GetEnumerator | Returns an enumerator that can iterate through the objects in the collection.
public Method | Insert | Adds a Variable to the collection at the specified index.
public Method | Remove | Removes the first occurrence of the provided variable from the collection.
Top

See Also

Reference

VariableCollection Class
Dart.Snmp Namespace


Add Method

[image]
PowerSNMP for .NET CF
Add Method
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : Add Method

Adds a Variable to the end of the collection.

Overload List

Overload | Description
Add(Variable) | Adds a Variable to the end of the collection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


Add(Variable) Method

[image]
PowerSNMP for .NET CF
Add(Variable) Method
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : Add(Variable) Method

variable
A Variable to add.
Adds a Variable to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal variable As Variable _
)
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
Dim variable As Variable

instance.Add(variable)
C#
public void Add(
   Variable variable
)
Managed Extensions for C++
public: void Add(
   Variable* variable
)
C++/CLI
public:
void Add(
   Variable^ variable
)

Parameters

variable
A Variable to add.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


Clear Method

[image]
PowerSNMP for .NET CF
Clear Method
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : Clear Method

Removes all Variable objects from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


CopyTo Method

[image]
PowerSNMP for .NET CF
CopyTo Method
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : CopyTo Method

array
The destination array.
arrayIndex
The index within the array to start copying.
Copies the elements of the collection to a specified array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
Dim array As Array
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   Array array,
   int arrayIndex
)
Managed Extensions for C++
public: void CopyTo(
   Array* array,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   Array^ array,
   int arrayIndex
)

Parameters

array
The destination array.
arrayIndex
The index within the array to start copying.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


GetEnumerator Method

[image]
PowerSNMP for .NET CF
GetEnumerator Method
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through the objects in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public virtual IEnumerator GetEnumerator()
Managed Extensions for C++
public: virtual IEnumerator* GetEnumerator();
C++/CLI
public:
virtual IEnumerator^ GetEnumerator();

Return Value

An IEnumerator for the collection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


Insert Method

[image]
PowerSNMP for .NET CF
Insert Method
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : Insert Method

index
The 0 based index where the Variable is to be inserted.
variable
A Variable to be inserted.
Adds a Variable to the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Insert( _
   ByVal index As Integer, _
   ByVal variable As Variable _
)
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
Dim index As Integer
Dim variable As Variable

instance.Insert(index, variable)
C#
public virtual void Insert(
   int index,
   Variable variable
)
Managed Extensions for C++
public: virtual void Insert(
   int index,
   Variable* variable
)
C++/CLI
public:
virtual void Insert(
   int index,
   Variable^ variable
)

Parameters

index
The 0 based index where the Variable is to be inserted.
variable
A Variable to be inserted.

Remarks

If index equals Count, the variable is appended to the list.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


Remove Method

[image]
PowerSNMP for .NET CF
Remove Method
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : Remove Method

variable
An instance of the Variable to remove.
Removes the first occurrence of the provided variable from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal variable As Variable _
)
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
Dim variable As Variable

instance.Remove(variable)
C#
public void Remove(
   Variable variable
)
Managed Extensions for C++
public: void Remove(
   Variable* variable
)
C++/CLI
public:
void Remove(
   Variable^ variable
)

Parameters

variable
An instance of the Variable to remove.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


VariableCollection Class Properties

[image]
PowerSNMP for .NET CF
VariableCollection Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : VariableCollection Class

"

For a list of all members of this type, see VariableCollection members.

"

Public Properties

 | Name | Description
public Property | Count | Gets the number of variables in the collection.
public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
public Property | Item | Gets or sets the Variable at the specified index.
public Property | SyncRoot | Gets an object that can be used to synchronize access to the ICollection.
Top

See Also

Reference

VariableCollection Class
Dart.Snmp Namespace


Count Property

[image]
PowerSNMP for .NET CF
Count Property
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : Count Property

Gets the number of variables in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
Dim value As Integer

value = instance.Count
C#
public virtual int Count {get;}
Managed Extensions for C++
public: __property virtual int get_Count();
C++/CLI
public:
virtual property int Count {
   int get();
}

Property Value

Returns the number of variables in the collection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


IsSynchronized Property

[image]
PowerSNMP for .NET CF
IsSynchronized Property
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : IsSynchronized Property

Gets a value indicating whether access to the ICollection is synchronized (thread safe).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


Item Property

[image]
PowerSNMP for .NET CF
Item Property
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : Item Property

index
The location within the collection.
Gets or sets the Variable at the specified index.

Syntax

Visual Basic (Declaration)
Public Overridable Shadows Default Property Item( _
   ByVal index As Integer _
) As Variable
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
Dim index As Integer
Dim value As Variable

instance.Item(index) = value

value = instance.Item(index)
C#
public virtual new Variable this(
   int index
) {get; set;}
Managed Extensions for C++
public: __property virtual new Variable* get_Item(
   int index
);
public: __property virtual new void set_Item(
   int index,
   Variable* value
);
C++/CLI
public:
virtual new property Variable^ default [int] {
   Variable^ get(intindex);
   void set (intindex, Variable^value);
}

Parameters

index
The location within the collection.

Property Value

The Variable at the specified location.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | Index is less than 0 or greater than .

Remarks

This function performs a linear search of all elements in the collection.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


SyncRoot Property

[image]
PowerSNMP for .NET CF
SyncRoot Property
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableCollection Class : SyncRoot Property

Gets an object that can be used to synchronize access to the ICollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As VariableCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableCollection Class
VariableCollection Members


VariableList Class

[image]
PowerSNMP for .NET CF
VariableList Class
Members See Also Send comments on this topic.
Dart.Snmp Namespace : VariableList Class

Used to hold the MIB data managed by the Agent.

Object Model

VariableList ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class VariableList
   Inherits System.Collections.Generic.SortedList(Of String,Variable)
Visual Basic (Usage) Copy Code
Dim instance As VariableList
C#
public class VariableList : System.Collections.Generic.SortedList<string,Variable>
Managed Extensions for C++
public __gc class VariableList : public System.Collections.Generic.SortedList<string,Variable>
C++/CLI
public ref class VariableList : public System.Collections.Generic.SortedList<String,Variable>

Remarks

The Agent class uses Agent.Variables to generate a response for each request it processes.

This collection is lexicographically sorted by instance id (IID); each IID must be unique. The IID is used as the key to lookup variables in the list.

Users should synchronize access from other threads by using the lock construct on the SyncRoot property.

Inheritance Hierarchy

System.Object
System.Collections.Generic.SortedList<TKey,TValue>
Dart.Snmp.VariableList

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableList Members
Dart.Snmp Namespace


VariableList Class Members

[image]
PowerSNMP for .NET CF
VariableList Class Members
See Also Properties Methods Send comments on this topic.
Dart.Snmp Namespace : VariableList Class

The following tables list the members exposed by VariableList.

Public Constructors

 | Name | Description
public Constructor | VariableList Constructor | Initializes a new instance of the VariableList class.
Top

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Comparer | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Count | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Item | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Keys | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Values | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
Top

Public Methods

 | Name | Description
public Method | Add | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | Clear | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | ContainsKey | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | ContainsValue | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | GetEnumerator | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | GetNext | Returns the next Variable after the specified id.
public Method | IndexOfKey | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | IndexOfValue | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | Remove | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | RemoveAt | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | TrimExcess | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | TryGetValue | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
Top

See Also

Reference

VariableList Class
Dart.Snmp Namespace


VariableList Constructor

[image]
PowerSNMP for .NET CF
VariableList Constructor
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableList Class : VariableList Constructor

Initializes a new instance of the VariableList class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New VariableList()
C#
public VariableList()
Managed Extensions for C++
public: VariableList();
C++/CLI
public:
VariableList();

Remarks

An application will not typically need to create a new SortedVariables object; Agent.Variables can be used directly.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableList Class
VariableList Members


VariableList Class Methods

[image]
PowerSNMP for .NET CF
VariableList Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : VariableList Class

"

For a list of all members of this type, see VariableList members.

"

Public Methods

 | Name | Description
public Method | Add | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | Clear | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | ContainsKey | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | ContainsValue | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | GetEnumerator | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | GetNext | Returns the next Variable after the specified id.
public Method | IndexOfKey | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | IndexOfValue | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | Remove | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | RemoveAt | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | TrimExcess | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Method | TryGetValue | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
Top

See Also

Reference

VariableList Class
Dart.Snmp Namespace


GetNext Method

[image]
PowerSNMP for .NET CF
GetNext Method
See Also Send comments on this topic.
Dart.Snmp Namespace > VariableList Class : GetNext Method

id
An object or instance id of the Variable immediately preceding the returned Variable.
Returns the next Variable after the specified id.

Syntax

Visual Basic (Declaration)
Public Function GetNext( _
   ByVal id As String _
) As Variable
Visual Basic (Usage) Copy Code
Dim instance As VariableList
Dim id As String
Dim value As Variable

value = instance.GetNext(id)
C#
public Variable GetNext(
   string id
)
Managed Extensions for C++
public: Variable* GetNext(
   string* id
)
C++/CLI
public:
Variable^ GetNext(
   String^ id
)

Parameters

id
An object or instance id of the Variable immediately preceding the returned Variable.

Return Value

The next Variable in the list, indexed by id.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

VariableList Class
VariableList Members


Access Enumeration

[image]
PowerSNMP for .NET CF
Access Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : Access Enumeration

Defines the operation allowed to a MibNode object.

Syntax

Visual Basic (Declaration)
Public Enum Access
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Access
C#
public enum Access : System.Enum
Managed Extensions for C++
__value public enum Access : public System.Enum
C++/CLI
public enum class Access : public System.Enum

Members

Member | Description
AccessibleForNotify | Value may be sent via trap notification only.
NotAccessible | Variable is not accessible for get/set operations.
ReadCreate | Variable is accessible for get/set/create operations.
ReadOnly | Variable is only accessible for get operations.
ReadWrite | Variable is accessible for get/set operations.
Uninitialized | The value has not been set.
WriteOnly | Variable is only accessible for set operations.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.Access

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


AuthenticationProtocol Enumeration

[image]
PowerSNMP for .NET CF
AuthenticationProtocol Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : AuthenticationProtocol Enumeration

Defines the algorithm to be used for Version 3 message authentication.

Syntax

Visual Basic (Declaration)
Public Enum AuthenticationProtocol
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AuthenticationProtocol
C#
public enum AuthenticationProtocol : System.Enum
Managed Extensions for C++
__value public enum AuthenticationProtocol : public System.Enum
C++/CLI
public enum class AuthenticationProtocol : public System.Enum

Members

Member | Description
Md5 | Selects the MD5 algorithm to perform message authentication.
None | No authentication is desired.
Sha | Selects the SHA-1 algorithm to perform message authentication. This is FIPS-140 compliant.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.AuthenticationProtocol

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


ErrorCode Enumeration

[image]
PowerSNMP for .NET CF
ErrorCode Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : ErrorCode Enumeration

Defines the possible ErrorCode values returned in DecodingException.

Syntax

Visual Basic (Declaration)
Public Enum ErrorCode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ErrorCode
C#
public enum ErrorCode : System.Enum
Managed Extensions for C++
__value public enum ErrorCode : public System.Enum
C++/CLI
public enum class ErrorCode : public System.Enum

Members

Member | Description
AuthenticationFailed | A problem with SNMPv3 security was encounted while decoding a message.
DecryptionFailed | An error occurred while decrypting a message.
IncompleteMessage | The buffer does not contain a complete message.
InvalidIdEncoding | An error occurred while decoding an IID or OID.
InvalidLength | The encoded length is not the expected size for the tagged type being decoded.
InvalidSecurityFlag | An invalid security flag was received within the context of an SNMP message.
TagNotSupported | An undefined tag value was decoded.
UnknownUsername | The Username in the packet, if any, is not in the AuthoritativeEngine.Users hashtable.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.ErrorCode

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


ErrorStatus Enumeration

[image]
PowerSNMP for .NET CF
ErrorStatus Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : ErrorStatus Enumeration

Defines the possible values returned in ResponseMessage.ErrorStatus

Syntax

Visual Basic (Declaration)
Public Enum ErrorStatus
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ErrorStatus
C#
public enum ErrorStatus : System.Enum
Managed Extensions for C++
__value public enum ErrorStatus : public System.Enum
C++/CLI
public enum class ErrorStatus : public System.Enum

Members

Member | Description
AuthorizationError | An authorization problem occurred.
BadValue | The value of a variable had a bad value.
CommitFailed | An attempt to set a variable failed.
GeneralError | An error with no specific ErrorStatus value occurred.
InconsistentName | A specified variable does not exist.
InconsistentValue | The value specified for a variable is valid but cannot be assigned at this time.
NoAccess | Access was denied to the variable for security reasons.
NoCreation | A variable does not exist and cannot be created.
NoSuchName | The requested variable was not found.
NotWritable | The variable is not accessible or cannot be written to.
ReadOnly | A set request was attempted for a read-only variable.
ResourceUnavailable | An unavailable resource caused a variable set to fail.
Success | No error.
TooBig | The size of the response is too big to send.
UndoFailed | An attempt to set one variable in a group failed, and the attempt to undo other successful sets failed.
WrongEncoding | The encoding for a variable binding was incorrect.
WrongLength | The length specified for a variable binding was incorrect.
WrongType | A variable type was incorrect.
WrongValue | The value of the variable was incorrect.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.ErrorStatus

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


Language Enumeration

[image]
PowerSNMP for .NET CF
Language Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : Language Enumeration

Defines the programming language used to output generated classes that derive from MibNode.

Syntax

Visual Basic (Declaration)
Public Enum Language
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Language
C#
public enum Language : System.Enum
Managed Extensions for C++
__value public enum Language : public System.Enum
C++/CLI
public enum class Language : public System.Enum

Members

Member | Description
Cpp | Selects C++ as the output code language.
CSharp | Selects C# as the output code language.
VisualBasic | Selects Visual Basic as the output code language.

Remarks

Pass the appropriate value into MibManager.GenerateCode to select the desired output code language.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.Language

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


NodeName Enumeration

[image]
PowerSNMP for .NET CF
NodeName Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : NodeName Enumeration

Defines the names of all the intrinsic MibNode names that can be used to lookup MibNode instances in the MibNodes dictionary.

Syntax

Visual Basic (Declaration)
Public Enum NodeName
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NodeName
C#
public enum NodeName : System.Enum
Managed Extensions for C++
__value public enum NodeName : public System.Enum
C++/CLI
public enum class NodeName : public System.Enum

Members

Member | Description
at |
atEntry |
atIfIndex |
atNetAddress |
atPhysAddress |
atTable |
authenticationFailure |
coldStart |
directory |
dod |
egp |
egpAs |
egpInErrors |
egpInMsgs |
egpNeighAddr |
egpNeighAs |
egpNeighborLoss |
egpNeighEntry |
egpNeighEventTrigger |
egpNeighInErrMsgs |
egpNeighInErrs |
egpNeighInMsgs |
egpNeighIntervalHello |
egpNeighIntervalPoll |
egpNeighMode |
egpNeighOutErrMsgs |
egpNeighOutErrs |
egpNeighOutMsgs |
egpNeighState |
egpNeighStateDowns |
egpNeighStateUps |
egpNeighTable |
egpOutErrors |
egpOutMsgs |
enterprises |
experimental |
icmp |
icmpInAddrMaskReps |
icmpInAddrMasks |
icmpInDestUnreachs |
icmpInEchoReps |
icmpInEchos |
icmpInErrors |
icmpInMsgs |
icmpInParmProbs |
icmpInRedirects |
icmpInSrcQuenchs |
icmpInTimeExcds |
icmpInTimestampReps |
icmpInTimestamps |
icmpOutAddrMaskReps |
icmpOutAddrMasks |
icmpOutDestUnreachs |
icmpOutEchoReps |
icmpOutEchos |
icmpOutErrors |
icmpOutMsgs |
icmpOutParmProbs |
icmpOutRedirects |
icmpOutSrcQuenchs |
icmpOutTimeExcds |
icmpOutTimestampReps |
icmpOutTimestamps |
ifAdminStatus |
ifDescr |
ifEntry |
ifIndex |
ifInDiscards |
ifInErrors |
ifInNUcastPkts |
ifInOctets |
ifInUcastPkts |
ifInUnknownProtos |
ifLastChange |
ifMtu |
ifNumber |
ifOperStatus |
ifOutDiscards |
ifOutErrors |
ifOutNUcastPkts |
ifOutOctets |
ifOutQLen |
ifOutUcastPkts |
ifPhysAddress |
ifSpecific |
ifSpeed |
ifTable |
ifType |
interfaces |
internet |
ip |
ipAddrEntry |
ipAddrTable |
ipAdEntAddr |
ipAdEntBcastAddr |
ipAdEntIfIndex |
ipAdEntNetMask |
ipAdEntReasmMaxSize |
ipDefaultTTL |
ipForwarding |
ipForwDatagrams |
ipFragCreates |
ipFragFails |
ipFragOKs |
ipInAddrErrors |
ipInDelivers |
ipInDiscards |
ipInHdrErrors |
ipInReceives |
ipInUnknownProtos |
ipNetToMediaEntry |
ipNetToMediaIfIndex |
ipNetToMediaNetAddress |
ipNetToMediaPhysAddress |
ipNetToMediaTable |
ipNetToMediaType |
ipOutDiscards |
ipOutNoRoutes |
ipOutRequests |
ipReasmFails |
ipReasmOKs |
ipReasmReqds |
ipReasmTimeout |
ipRouteAge |
ipRouteDest |
ipRouteEntry |
ipRouteIfIndex |
ipRouteInfo |
ipRouteMask |
ipRouteMetric1 |
ipRouteMetric2 |
ipRouteMetric3 |
ipRouteMetric4 |
ipRouteMetric5 |
ipRouteNextHop |
ipRouteProto |
ipRouteTable |
ipRouteType |
ipRoutingDiscards |
iso |
linkDown |
linkUp |
mgmt |
mib_2 |
org |
private |
rfc1157Domain |
rfc1157Proxy |
security |
snmp |
snmpBasicCompliance |
snmpBasicComplianceRev2 |
snmpBasicNotificationsGroup |
snmpCLNSDomain |
snmpCommunityGroup |
snmpCONSDomain |
snmpDDPDomain |
snmpDomains |
snmpEnableAuthenTraps |
snmpGroup |
snmpInASNParseErrs |
snmpInBadCommunityNames |
snmpInBadCommunityUses |
snmpInBadValues |
snmpInBadVersions |
snmpInGenErrs |
snmpInGetNexts |
snmpInGetRequests |
snmpInGetResponses |
snmpInNoSuchNames |
snmpInPkts |
snmpInReadOnlys |
snmpInSetRequests |
snmpInTooBigs |
snmpInTotalReqVars |
snmpInTotalSetVars |
snmpInTraps |
snmpIPXDomain |
snmpMIB |
snmpMIBCompliances |
snmpMIBConformance |
snmpMIBGroups |
snmpMIBObjects |
snmpModules |
snmpNotificationGroup |
snmpObsoleteGroup |
snmpOutBadValues |
snmpOutGenErrs |
snmpOutGetNexts |
snmpOutGetRequests |
snmpOutGetResponses |
snmpOutNoSuchNames |
snmpOutPkts |
snmpOutSetRequests |
snmpOutTooBigs |
snmpOutTraps |
snmpProxyDrops |
snmpProxys |
snmpSet |
snmpSetGroup |
snmpSetSerialNo |
snmpSilentDrops |
snmpTrap |
snmpTrapEnterprise |
snmpTrapOID |
snmpTraps |
snmpUDPDomain |
snmpV2 |
snmpv2tm |
snmpWarmStartNotificationGroup |
sysContact |
sysDescr |
sysLocation |
sysName |
sysObjectID |
sysORDescr |
sysOREntry |
sysORID |
sysORIndex |
sysORLastChange |
sysORTable |
sysORUpTime |
sysServices |
system |
systemGroup |
sysUpTime |
tcp |
tcpActiveOpens |
tcpAttemptFails |
tcpConnEntry |
tcpConnLocalAddress |
tcpConnLocalPort |
tcpConnRemAddress |
tcpConnRemPort |
tcpConnState |
tcpConnTable |
tcpCurrEstab |
tcpEstabResets |
tcpInErrs |
tcpInSegs |
tcpMaxConn |
tcpOutRsts |
tcpOutSegs |
tcpPassiveOpens |
tcpRetransSegs |
tcpRtoAlgorithm |
tcpRtoMax |
tcpRtoMin |
transmission |
udp |
udpEntry |
udpInDatagrams |
udpInErrors |
udpLocalAddress |
udpLocalPort |
udpNoPorts |
udpOutDatagrams |
udpTable |
warmStart |

Remarks

Use MibNodes[NodeName.iso.ToString()], for example, to reference an instance of the MibNode class that describes the "iso" MIB identifier.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.NodeName

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


PrivacyProtocol Enumeration

[image]
PowerSNMP for .NET CF
PrivacyProtocol Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : PrivacyProtocol Enumeration

Defines the algorithm to be used for Version 3 message encryption.

Syntax

Visual Basic (Declaration)
Public Enum PrivacyProtocol
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PrivacyProtocol
C#
public enum PrivacyProtocol : System.Enum
Managed Extensions for C++
__value public enum PrivacyProtocol : public System.Enum
C++/CLI
public enum class PrivacyProtocol : public System.Enum

Members

Member | Description
Aes128 | Selects the AES128 algorithm to perform message encryption.
Aes192 | Selects the AES192 algorithm to perform message encryption.
Aes256 | Selects the AES256 algorithm to perform message encryption.
Des | Selects the DES algorithm to perform message encryption.
None | No encryption/decryption is desired.
TripleDes | Selects the Triple DES algorithm to perform message encryption. This is FIPS-140 compliant.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.PrivacyProtocol

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


SecurityErrorCode Enumeration

[image]
PowerSNMP for .NET CF
SecurityErrorCode Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : SecurityErrorCode Enumeration

Defines the possible values of SecurityException.ErrorCode.

Syntax

Visual Basic (Declaration)
Public Enum SecurityErrorCode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SecurityErrorCode
C#
public enum SecurityErrorCode : System.Enum
Managed Extensions for C++
__value public enum SecurityErrorCode : public System.Enum
C++/CLI
public enum class SecurityErrorCode : public System.Enum

Members

Member | Description
AuthorizationFailed | Message authentication failed, likely due to an invalid AuthenticationPassword.
DiscoveryFailed | An error occurred while attempting to perform discovery on the Agent. Review SecurityException.Response for additional information.
InvalidUsername | The Username in the request was not known by the Agent.
NotInTimeWindow | The message was not in the Time Window allowed by the Agent.
PrivacyFailure | Message Privacy failed, likely due to an invalid PrivacyPassword.
UnknownEngineId | The Security.EngineId value was not correct for the Agent.
UnknownReportValue | The error value returned in the ReportMessage was unknown. Review SecurityException.Response for additional information.
Unsupported | The attempted operation is unsupported on the Agent.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.SecurityErrorCode

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


SnmpVersion Enumeration

[image]
PowerSNMP for .NET CF
SnmpVersion Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : SnmpVersion Enumeration

Defines the possible Version values in MessageBase.

Syntax

Visual Basic (Declaration)
Public Enum SnmpVersion
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SnmpVersion
C#
public enum SnmpVersion : System.Enum
Managed Extensions for C++
__value public enum SnmpVersion : public System.Enum
C++/CLI
public enum class SnmpVersion : public System.Enum

Members

Member | Description
One | Snmp Version 1.
Three | Snmp Version 3.
Two | Snmp Version 2c.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.SnmpVersion

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


Status Enumeration

[image]
PowerSNMP for .NET CF
Status Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : Status Enumeration

Defines the current implementation status of the MibNode object.

Syntax

Visual Basic (Declaration)
Public Enum Status
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Status
C#
public enum Status : System.Enum
Managed Extensions for C++
__value public enum Status : public System.Enum
C++/CLI
public enum class Status : public System.Enum

Members

Member | Description
Current | The variable is currently in use.
Deprecated | The variable has been replaced by another definition.
Mandatory | The Agent is required to implement the variable.
Obsolete | The variable is no longer used.
Optional | The Agent is not required to implement the variable.
Uninitialized | The value has not been set.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.Status

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


TrapName Enumeration

[image]
PowerSNMP for .NET CF
TrapName Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : TrapName Enumeration

Defines the names of all the intrinsic trap names that can be used to lookup MibTrap instances in the MibNodes.MibTraps dictionary.

Syntax

Visual Basic (Declaration)
Public Enum TrapName
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TrapName
C#
public enum TrapName : System.Enum
Managed Extensions for C++
__value public enum TrapName : public System.Enum
C++/CLI
public enum class TrapName : public System.Enum

Members

Member | Description
authenticationFailure |
coldStart |
egpNeighborLoss |
linkDown |
linkUp |
warmStart |

Remarks

Use MibTraps[TrapName.coldStart.ToString()], for example, to reference an instance of the MibTrap class that describes the "coldStart" MIB identifier.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.TrapName

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


Usage Enumeration

[image]
PowerSNMP for .NET CF
Usage Enumeration
See Also Send comments on this topic.
Dart.Snmp Namespace : Usage Enumeration

Indicates the Usage of each class derived from MibNode.

Syntax

Visual Basic (Declaration)
Public Enum Usage
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Usage
C#
public enum Usage : System.Enum
Managed Extensions for C++
__value public enum Usage : public System.Enum
C++/CLI
public enum class Usage : public System.Enum

Members

Member Description
Group

The MibNode is a OBJECT-GROUP or NOTIFICATION-GROUP.

The MibNode.Oid property returns the Object Identifier (OID) of the MibNode. When MibNode.Usage evaluates to Usage.Group, the Instance Identifier (IID) is generated by appending a ".0" to the OID.

MibNode objects of this type will normally have values for MibNode.Oid, MibNode.Usage, MibDefinition.Name, MibDefinition.Description, MibDefinition.Module, MibNode.Objects (if an OBJECT-GROUP) and MibNode.Notifications (if a NOTIFICATION-GROUP).

Identifier

The MibNode does not identify an object, but is a node that identifies a branch of the MIB tree.

The Oid property returns the Object Identifier (OID) of the MibNode, but no Instance Identifier (IID) exists for this node.

MibNode objects of this Usage will normally have values for MibNode.Oid, MibDefinition.Module and MibDefinition.Name.

Notification

The MibNode is a NOTIFICATION-TYPE.

The Oid property returns the Object Identifier (OID) of the MibNode. When Usage evaluates to Usage.Notification, the Instance Identifier (IID) of the object is generated by adding a ".0" suffix to the OID. This occurs automatically when a MibNode of this type is used in the constructor of a MibNode.

MibNode objects of this type will normally have values for MibNode.Oid, MibNode.Usage, MibNode.Status, MibDefinition.Description, MibDefinition.Name, MibDefinition.Module and MibNode.Objects.

Object

The MibNode is an OBJECT-TYPE, but is not a Usage.Table, Usage.TableEntry, or Usage.TableColumn.

The Oid property returns the Object Identifier (OID) of the MibNode. For nodes of this usage, the Instance Identifier (IID) of the scalar object is generated by adding a ".0" suffix to the OID. This occurs automatically when a MibNode of this type is used.

MibNode objects of this usage will normally have values for MibNode.Oid, MibNode.Usage, MibNode.Access, MibNode.Status, MibDefinition.Description, MibDefinition.Name, MibDefinition.Module and MibNode.ValueType.

Table

The MibNode is an OBJECT-TYPE that parsing has determined to be a table.

The Oid property returns the Object Identifier (OID) of the MibNode. When Usage evaluates to Usage.Table, Access is Access.NotAccessible, indicating the instance is not accessible.

MibNode objects of this type will normally have values for MibNode.Oid, MibNode.Usage, MibNode.Access, MibNode.Status, MibDefinition.Description, MibDefinition.Name, MibDefinition.Module and MibNode.ValueType.

TableColumn

The MibNode is an OBJECT-TYPE that parsing has determined to be a table column.

The Oid property returns the Object Identifier (OID) of the MibNode. When Usage evaluates to Usage.TableColumn, the Instance Identifier (IID) of the row of interest is generated by appending an indexer that is specific to the definition of the corresponding table entry (this may be computed by removing the trailing ".1" from the Oid of the table column).

MibNode objects of this type will normally have values for MibNode.Oid, MibNode.Usage, MibNode.Access, MibNode.Status, MibDefinition.Description, MibDefinition.Name, MibDefinition.Module and MibNode.ValueType.

TableEntry

The MibNode is an OBJECT-TYPE that parsing has determined to be a table entry that describes a row.

The Oid property returns the Object Identifier (OID) of the MibNode. When Usage evaluates to Usage.TableEntry, Access is Access.NotAccessible, indicating the instance is not accessible.

MibNode objects of this type will normally have values for MibNode.Oid, MibNode.Usage, MibNode.Access, MibNode.Status, MibDefinition.Description, MibDefinition.Name, MibNode.Index, MibDefinition.Module and MibNode.ValueType.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Snmp.Usage

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Dart.Snmp Namespace


AgentMessageReceived Delegate

[image]
PowerSNMP for .NET CF
AgentMessageReceived Delegate
See Also Example Send comments on this topic.
Dart.Snmp Namespace : AgentMessageReceived Delegate

agent
A reference to the Agent component being used.
request
The decoded request that was received.
state
User state information provided in the Agent.Start method.
Represents the method that will be called as each RequestMessage is received.

Syntax

Visual Basic (Declaration)
Public Delegate Sub AgentMessageReceived( _
   ByVal agent As Agent, _
   ByVal request As RequestMessage, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New AgentMessageReceived(AddressOf HandlerMethod)
C#
public delegate void AgentMessageReceived(
   Agent agent,
   RequestMessage request,
   object state
)
Managed Extensions for C++
public: __gc __delegate void AgentMessageReceived(
   Agent* agent,
   RequestMessage* request,
   Object* state
)
C++/CLI
public delegate void AgentMessageReceived(
   Agent^ agent,
   RequestMessage^ request,
   Object^ state
)

Parameters

agent
A reference to the Agent component being used.
request
The decoded request that was received.
state
User state information provided in the Agent.Start method.

Example

The following example demonstrates starting a simple agent supporting a MIB variable.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Add variable to agent
    agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace");
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"));

    //Start listening for requests
    agent1.Start(agent1_MessageReceived, null);
}

private void agent1_MessageReceived(Agent agent, RequestMessage request, object state)
{
    //Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
    'Add variable to agent
    agent1.Variables.Values.Add(agent1.Mib.CreateVariable(NodeName.sysContact, "Kara Thrace"))

    'Start listening for requests
    agent1.Start(agent1_MessageReceived, Nothing)
End Sub

Private Sub agent1_MessageReceived(ByVal agent As Agent, ByVal request As RequestMessage, ByVal state As Object)
    'Create and send a response whenever a request is received
    agent1.Send(agent1.CreateDefaultResponse(request), request.Origin)
End Sub

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

AgentMessageReceived Members
Dart.Snmp Namespace


ManagerMessageReceived Delegate

[image]
PowerSNMP for .NET CF
ManagerMessageReceived Delegate
See Also Example Send comments on this topic.
Dart.Snmp Namespace : ManagerMessageReceived Delegate

manager
A reference to the Manager component.
receivedMessage
The received message of type TrapMessage, NotificationMessage, or InformMessage.
state
User state information provided to ManagerMessageReceived.
Represents the method that will be called as asynchronous messages are received.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ManagerMessageReceived( _
   ByVal manager As Manager, _
   ByVal receivedMessage As MessageBase, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New ManagerMessageReceived(AddressOf HandlerMethod)
C#
public delegate void ManagerMessageReceived(
   Manager manager,
   MessageBase receivedMessage,
   object state
)
Managed Extensions for C++
public: __gc __delegate void ManagerMessageReceived(
   Manager* manager,
   MessageBase* receivedMessage,
   Object* state
)
C++/CLI
public delegate void ManagerMessageReceived(
   Manager^ manager,
   MessageBase^ receivedMessage,
   Object^ state
)

Parameters

manager
A reference to the Manager component.
receivedMessage
The received message of type TrapMessage, NotificationMessage, or InformMessage.
state
User state information provided to ManagerMessageReceived.

Example

The following example demonstrates receiving trap, notification and inform messages.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
  //Start listening for traps, notifications and informs
  manager1.Start(manager1_MessageReceived, null);
}

private void manager1_MessageReceived(Manager manager, MessageBase message, object state)
{
  //Marshal message to the UI thread using the Message event
  if (message is TrapMessage)
    manager.Marshal(new MessageBase[] { message }, "trap");
    else if (message is NotificationMessage)
    manager.Marshal(new MessageBase[] { message }, "notification");
  else if (message is InformMessage)
  {
    manager.Marshal(new MessageBase[] { message }, "inform");

    //Send response to inform message origin
    manager.Send(new ResponseMessage(message as InformMessage), message.Origin);
  }
}

private void manager1_Message(object sender, MessageEventArgs e)
{
  //Update interface according to message type received
  switch (e.UserState.ToString())
  {
    case "trap":
      TrapMessage trap = e.Messages[0] as TrapMessage;
      label1.Text = "Trap received with Enterprise(" + trap.Enterprise + "), Generic Type (" +
        trap.GenericTrap.ToString() + "), Specific Type(" + trap.SpecificTrap.ToString() + ")";
      break;
    case "notification":
      NotificationMessage notification = e.Messages[0] as NotificationMessage;
      label1.Text = "Notification received with OID (" + notification.Oid + ")";
      break;
    case "inform":
      InformMessage inform = e.Messages[0] as InformMessage;
      label1.Text = "Inform received with " + inform.Variables.Count.ToString() + " variable(s).";
      break;
  }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
  'Start listening for traps, notifications and informs
  manager1.Start(AddressOf manager1_MessageReceived, Nothing)
End Sub

Private Sub manager1_MessageReceived(ByVal manager As Manager, ByVal message As MessageBase, ByVal state As Object)
  'Marshal message to the UI thread using the Message event
  If TypeOf message Is TrapMessage Then
    manager.Marshal(New MessageBase() {message}, "trap")
  ElseIf TypeOf message Is NotificationMessage Then
    manager.Marshal(New MessageBase() {message}, "notification")
  ElseIf TypeOf message Is InformMessage Then
    manager.Marshal(New MessageBase() {message}, "inform")

    'Send response to inform message origin
    manager.Send(New ResponseMessage(TryCast(message, InformMessage)), message.Origin)
  End If
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As MessageEventArgs) Handles manager1.Message
  'Update interface according to message type received
  Select Case e.UserState.ToString()
    Case "trap"
      Dim trap As TrapMessage = TryCast(e.Messages(0), TrapMessage)
      label1.Text = "Trap received with Enterprise(" & trap.Enterprise & "), Generic Type (" & _
        trap.GenericTrap.ToString() & "), Specific Type(" & trap.SpecificTrap.ToString() & ")"
    Case "notification"
      Dim notification As NotificationMessage = TryCast(e.Messages(0), NotificationMessage)
      label1.Text = "Notification received with OID (" & notification.Oid & ")"
    Case "inform"
      Dim inform As InformMessage = TryCast(e.Messages(0), InformMessage)
      label1.Text = "Inform received with " & inform.Variables.Count.ToString() & " variable(s)."
  End Select
End Sub

Remarks

This method is called as each asynchronous message is received by the Manager. The user will normally construct a default message to be sent after receiving an InformMessage. No response is required for traps and notifications.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

ManagerMessageReceived Members
Dart.Snmp Namespace


MessageEventHandler Delegate

[image]
PowerSNMP for .NET CF
MessageEventHandler Delegate
See Also Send comments on this topic.
Dart.Snmp Namespace : MessageEventHandler Delegate

sender
The source of the event.
e
A MessageEventArgs that contains marshaled data.
Represents the method that will handle an event raised by the user calling SnmpBase.Marshal.

Syntax

Visual Basic (Declaration)
Public Delegate Sub MessageEventHandler( _
   ByVal sender As Object, _
   ByVal e As MessageEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New MessageEventHandler(AddressOf HandlerMethod)
C#
public delegate void MessageEventHandler(
   object sender,
   MessageEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void MessageEventHandler(
   Object* sender,
   MessageEventArgs* e
)
C++/CLI
public delegate void MessageEventHandler(
   Object^ sender,
   MessageEventArgs^ e
)

Parameters

sender
The source of the event.
e
A MessageEventArgs that contains marshaled data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

MessageEventHandler Members
Dart.Snmp Namespace


SlaveThreadStart Delegate

[image]
PowerSNMP for .NET CF
SlaveThreadStart Delegate
See Also Example Send comments on this topic.
Dart.Snmp Namespace : SlaveThreadStart Delegate

worker
A reference to the new ManagerSlave that does the work.
state
User state information provided in the SlaveThreadStart method.
Represents the method that will be called on a new worker thread.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SlaveThreadStart( _
   ByVal worker As ManagerSlave, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New SlaveThreadStart(AddressOf HandlerMethod)
C#
public delegate void SlaveThreadStart(
   ManagerSlave worker,
   object state
)
Managed Extensions for C++
public: __gc __delegate void SlaveThreadStart(
   ManagerSlave* worker,
   Object* state
)
C++/CLI
public delegate void SlaveThreadStart(
   ManagerSlave^ worker,
   Object^ state
)

Parameters

worker
A reference to the new ManagerSlave that does the work.
state
User state information provided in the SlaveThreadStart method.

Example

The following example demonstrates sending a Get request to an agent and receiving the response.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Create and send request on a worker thread
    manager1.Start(manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact));
}

private void manager1_SendGetRequest(Dart.Snmp.ManagerSlave slave, object state)
{
    //Create Get Request
    GetMessage request = new GetMessage();
    request.Community = "public";
    request.Version = SnmpVersion.One;
    request.Variables.Add(state as Variable);

    //Send request and get response
    ResponseMessage response = slave.GetResponse(request, myAgentAddress);

    //Marshal message to the UI thread using the Message event
    manager1.Marshal(new ResponseMessage[] { response }, null);
}

private void manager1_Message(object sender, Dart.Snmp.MessageEventArgs e)
{
    //Display info about the first variable in the response, and its value
    Variable var = e.Messages[0].Variables[0] as Variable;
    label1.Text = var.Definition.ToString() + var.Value.ToString();
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Create and send request on a worker thread
    manager1.Start(AddressOf manager1_SendGetRequest, manager1.Mib.CreateVariable(NodeName.sysContact))
End Sub

Private Sub manager1_SendGetRequest(ByVal slave As Dart.Snmp.ManagerSlave, ByVal state As Object)
    'Create Get Request
    Dim request As GetMessage = New GetMessage()
    request.Community = "public"
    request.Version = SnmpVersion.One
    request.Variables.Add(CType(IIf(TypeOf state Is Variable, state, Nothing), Variable))

    'Send request and get response
    Dim response As ResponseMessage = slave.GetResponse(request, myAgentAddress)

    'Marshal message to the UI thread using the Message event
    manager1.Marshal(New ResponseMessage() { response }, Nothing)
End Sub

Private Sub manager1_Message(ByVal sender As Object, ByVal e As Dart.Snmp.MessageEventArgs)
    'Display info about the first variable in the response, and its value
    Dim var As Variable = CType(IIf(TypeOf e.Messages(0).Variables(0) Is Variable, e.Messages(0).Variables(0), Nothing), Variable)
    label1.Text = var.Definition.ToString() & var.Value.ToString()
End Sub

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SlaveThreadStart Members
Dart.Snmp Namespace


TableEventHandler Delegate

[image]
PowerSNMP for .NET CF
TableEventHandler Delegate
See Also Send comments on this topic.
Dart.Snmp Namespace : TableEventHandler Delegate

sender
The source of the event.
e
A TableEventArgs that contains marshaled data.
Represents the method that will handle an event raised by the user calling Dart.Snmp.Manager.Marshal(System.String,Dart.Snmp.Variable[0:,0:],System.Object).

Syntax

Visual Basic (Declaration)
Public Delegate Sub TableEventHandler( _
   ByVal sender As Object, _
   ByVal e As TableEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TableEventHandler(AddressOf HandlerMethod)
C#
public delegate void TableEventHandler(
   object sender,
   TableEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void TableEventHandler(
   Object* sender,
   TableEventArgs* e
)
C++/CLI
public delegate void TableEventHandler(
   Object^ sender,
   TableEventArgs^ e
)

Parameters

sender
The source of the event.
e
A TableEventArgs that contains marshaled data.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TableEventHandler Members
Dart.Snmp Namespace


Dart.Snmp.Notification Namespace

Dart.Snmp.Notification Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Classes

 | Class | Description
Class | authenticationFailure | Creates a NotificationMessage that indicates an authentication failure.
Class | coldStart | Creates a NotificationMessage that indicates a cold start.
Class | warmStart | Creates a NotificationMessage that indicates a warm start.

See Also

Reference

Dart.Snmp.CF Assembly


authenticationFailure Class

[image]
PowerSNMP for .NET CF
authenticationFailure Class
Members See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : authenticationFailure Class

Creates a NotificationMessage that indicates an authentication failure.

Object Model

authenticationFailure ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class authenticationFailure
   Inherits Dart.Snmp.NotificationMessage
Visual Basic (Usage) Copy Code
Dim instance As authenticationFailure
C#
public class authenticationFailure : Dart.Snmp.NotificationMessage
Managed Extensions for C++
public __gc class authenticationFailure : public Dart.Snmp.NotificationMessage
C++/CLI
public ref class authenticationFailure : public Dart.Snmp.NotificationMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.NotificationMessage
Dart.Snmp.Notification.authenticationFailure

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

authenticationFailure Members
Dart.Snmp.Notification Namespace


authenticationFailure Class Members

[image]
PowerSNMP for .NET CF
authenticationFailure Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Notification Namespace : authenticationFailure Class

The following tables list the members exposed by authenticationFailure.

Public Constructors

 | Name | Description
public Constructor | authenticationFailure Constructor | Creates a NotificationMessage that indicates an authentication failure.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Description | Gets a description of the NotificationMessage. (Inherited from Dart.Snmp.NotificationMessage)
static (Shared in Visual Basic) | OidConst | The OID value that identifies the NotificationMessage.
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Oid | Gets the OID that the message pertains to. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SysUpTime | Gets the hundredths of a second since the agent sending the message was initialized. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

authenticationFailure Class
Dart.Snmp.Notification Namespace


authenticationFailure Constructor

[image]
PowerSNMP for .NET CF
authenticationFailure Constructor
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace > authenticationFailure Class : authenticationFailure Constructor

Creates a NotificationMessage that indicates an authentication failure.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New authenticationFailure()
C#
public authenticationFailure()
Managed Extensions for C++
public: authenticationFailure();
C++/CLI
public:
authenticationFailure();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

authenticationFailure Class
authenticationFailure Members


authenticationFailure Class Fields

[image]
PowerSNMP for .NET CF
authenticationFailure Class Fields
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : authenticationFailure Class

"

For a list of all members of this type, see authenticationFailure members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Description | Gets a description of the NotificationMessage. (Inherited from Dart.Snmp.NotificationMessage)
static (Shared in Visual Basic) | OidConst | The OID value that identifies the NotificationMessage.
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

authenticationFailure Class
Dart.Snmp.Notification Namespace


OidConst Field

[image]
PowerSNMP for .NET CF
OidConst Field
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace > authenticationFailure Class : OidConst Field

The OID value that identifies the NotificationMessage.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OidConst As String
Visual Basic (Usage) Copy Code
Dim value As String

value = authenticationFailure.OidConst
C#
public static readonly string OidConst
Managed Extensions for C++
public: static readonly string* OidConst
C++/CLI
public:
static readonly String^ OidConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

authenticationFailure Class
authenticationFailure Members


coldStart Class

[image]
PowerSNMP for .NET CF
coldStart Class
Members See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : coldStart Class

Creates a NotificationMessage that indicates a cold start.

Object Model

coldStart ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class coldStart
   Inherits Dart.Snmp.NotificationMessage
Visual Basic (Usage) Copy Code
Dim instance As coldStart
C#
public class coldStart : Dart.Snmp.NotificationMessage
Managed Extensions for C++
public __gc class coldStart : public Dart.Snmp.NotificationMessage
C++/CLI
public ref class coldStart : public Dart.Snmp.NotificationMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.NotificationMessage
Dart.Snmp.Notification.coldStart

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

coldStart Members
Dart.Snmp.Notification Namespace


coldStart Class Members

[image]
PowerSNMP for .NET CF
coldStart Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Notification Namespace : coldStart Class

The following tables list the members exposed by coldStart.

Public Constructors

 | Name | Description
public Constructor | coldStart Constructor | Creates a NotificationMessage that indicates a cold start.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Description | Gets a description of the NotificationMessage. (Inherited from Dart.Snmp.NotificationMessage)
static (Shared in Visual Basic) | OidConst | The OID value that identifies the NotificationMessage.
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Oid | Gets the OID that the message pertains to. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SysUpTime | Gets the hundredths of a second since the agent sending the message was initialized. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

coldStart Class
Dart.Snmp.Notification Namespace


coldStart Constructor

[image]
PowerSNMP for .NET CF
coldStart Constructor
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace > coldStart Class : coldStart Constructor

Creates a NotificationMessage that indicates a cold start.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New coldStart()
C#
public coldStart()
Managed Extensions for C++
public: coldStart();
C++/CLI
public:
coldStart();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

coldStart Class
coldStart Members


coldStart Class Fields

[image]
PowerSNMP for .NET CF
coldStart Class Fields
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : coldStart Class

"

For a list of all members of this type, see coldStart members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Description | Gets a description of the NotificationMessage. (Inherited from Dart.Snmp.NotificationMessage)
static (Shared in Visual Basic) | OidConst | The OID value that identifies the NotificationMessage.
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

coldStart Class
Dart.Snmp.Notification Namespace


OidConst Field

[image]
PowerSNMP for .NET CF
OidConst Field
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace > coldStart Class : OidConst Field

The OID value that identifies the NotificationMessage.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OidConst As String
Visual Basic (Usage) Copy Code
Dim value As String

value = coldStart.OidConst
C#
public static readonly string OidConst
Managed Extensions for C++
public: static readonly string* OidConst
C++/CLI
public:
static readonly String^ OidConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

coldStart Class
coldStart Members


warmStart Class

[image]
PowerSNMP for .NET CF
warmStart Class
Members See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : warmStart Class

Creates a NotificationMessage that indicates a warm start.

Object Model

warmStart ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class warmStart
   Inherits Dart.Snmp.NotificationMessage
Visual Basic (Usage) Copy Code
Dim instance As warmStart
C#
public class warmStart : Dart.Snmp.NotificationMessage
Managed Extensions for C++
public __gc class warmStart : public Dart.Snmp.NotificationMessage
C++/CLI
public ref class warmStart : public Dart.Snmp.NotificationMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.NotificationMessage
Dart.Snmp.Notification.warmStart

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

warmStart Members
Dart.Snmp.Notification Namespace


warmStart Class Members

[image]
PowerSNMP for .NET CF
warmStart Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Notification Namespace : warmStart Class

The following tables list the members exposed by warmStart.

Public Constructors

 | Name | Description
public Constructor | warmStart Constructor | Creates a NotificationMessage that indicates a warm start.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Description | Gets a description of the NotificationMessage. (Inherited from Dart.Snmp.NotificationMessage)
static (Shared in Visual Basic) | OidConst | The OID value that identifies the NotificationMessage.
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Oid | Gets the OID that the message pertains to. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SysUpTime | Gets the hundredths of a second since the agent sending the message was initialized. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

warmStart Class
Dart.Snmp.Notification Namespace


warmStart Constructor

[image]
PowerSNMP for .NET CF
warmStart Constructor
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace > warmStart Class : warmStart Constructor

Creates a NotificationMessage that indicates a warm start.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New warmStart()
C#
public warmStart()
Managed Extensions for C++
public: warmStart();
C++/CLI
public:
warmStart();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

warmStart Class
warmStart Members


warmStart Class Fields

[image]
PowerSNMP for .NET CF
warmStart Class Fields
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : warmStart Class

"

For a list of all members of this type, see warmStart members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Description | Gets a description of the NotificationMessage. (Inherited from Dart.Snmp.NotificationMessage)
static (Shared in Visual Basic) | OidConst | The OID value that identifies the NotificationMessage.
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

warmStart Class
Dart.Snmp.Notification Namespace


OidConst Field

[image]
PowerSNMP for .NET CF
OidConst Field
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace > warmStart Class : OidConst Field

The OID value that identifies the NotificationMessage.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OidConst As String
Visual Basic (Usage) Copy Code
Dim value As String

value = warmStart.OidConst
C#
public static readonly string OidConst
Managed Extensions for C++
public: static readonly string* OidConst
C++/CLI
public:
static readonly String^ OidConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

warmStart Class
warmStart Members


Dart.Snmp.SimpleType Namespace

Dart.Snmp.SimpleType Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Classes

 | Class | Description
Class | Counter | A tagged type representing an unsigned 32-bit integer that starts at 0, can only increase in value, and wraps back to 0 when it exceeds its maximum value.
Class | Counter64 | A tagged type representing an unsigned 64-bit integer that starts at 0, can only increase in value, and wraps back to 0 when it exceeds its maximum value.
Class | Empty | A tagged type representing a place-holder when no value is desired.
Class | EndOfMibView | A tagged type representing the fact that end of the MIB has been reached.
Class | Gauge | A tagged type representing an unsigned 32-bit integer that can increase or decrease in value, but does not wrap to 0 if the maximum value is exceeded.
Class | Id | A tagged type representing a MIB object (node represented as an OID) or instance (IID) in ASN.1 notation.
Class | Integer | A tagged type representing a signed 32-bit value.
Class | IpAddress | A tagged type representing an IP address.
Class | NoSuchInstance | A tagged type representing the fact that the agent does not manage an instance of the IID specified by the variable.
Class | NoSuchObject | A tagged type representing the fact that the agent has no knowledge of the OID specified by the variable.
Class | Nsap | An NSAP tagged type.
Class | OctetString | A tagged type supporting the capability to pass byte arrays or strings.
Class | Opaque | A tagged type supporting the capability to pass arbitrary binary data or structures.
Class | TimeTicks | A tagged type representing an unsigned 32-bit integer that counts the time in hundredths of a second since some reference epoch.
Class | UInteger | A tagged type representing an unsigned 32-bit integer.

See Also

Reference

Dart.Snmp.CF Assembly


Counter Class

[image]
PowerSNMP for .NET CF
Counter Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Counter Class

A tagged type representing an unsigned 32-bit integer that starts at 0, can only increase in value, and wraps back to 0 when it exceeds its maximum value.

Object Model

Counter Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Counter
   Inherits UInteger
Visual Basic (Usage) Copy Code
Dim instance As Counter
C#
public sealed class Counter : UInteger
Managed Extensions for C++
public __gc __sealed class Counter : public UInteger
C++/CLI
public ref class Counter sealed : public UInteger

Remarks

ASN.1 Counter32 Type. UInt32, Universal and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.UInteger
Dart.Snmp.SimpleType.Counter

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter Members
Dart.Snmp.SimpleType Namespace


Counter Class Members

[image]
PowerSNMP for .NET CF
Counter Class Members
See Also Properties Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Counter Class

The following tables list the members exposed by Counter.

Public Constructors

 | Name | Description
public Constructor | Counter Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Value | Gets the unsigned integer value associated with this object. (Inherited from Dart.Snmp.SimpleType.UInteger)
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

Counter Class
Dart.Snmp.SimpleType Namespace


Counter Constructor

[image]
PowerSNMP for .NET CF
Counter Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Counter Class : Counter Constructor

Overload List

Overload | Description
Counter Constructor(Int64) | Initializes a new instance of the Counter class.
Counter Constructor(String) | Initializes a new instance of the Counter class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter Class
Counter Members


Counter Constructor(Int64)

[image]
PowerSNMP for .NET CF
Counter Constructor(Int64)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Counter Class > Counter Constructor : Counter Constructor(Int64)

count
The initial value given to this object. An Int64 is used because UInt32 is not CLS-compliant.
Initializes a new instance of the Counter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal count As Long _
)
Visual Basic (Usage) Copy Code
Dim count As Long

Dim instance As New Counter(count)
C#
public Counter(
   long count
)
Managed Extensions for C++
public: Counter(
   long count
)
C++/CLI
public:
Counter(
   int64 count
)

Parameters

count
The initial value given to this object. An Int64 is used because UInt32 is not CLS-compliant.

Exceptions

Exception | Description
System.ArgumentNullException | count is a null reference.
System.FormatException | count does not consist of an optional sign followed by a sequence of digits.
System.OverflowException | count is less than UInt32.MinValue or greater than UInt.MaxValue.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter Class
Counter Members
Overload List


Counter Constructor(String)

[image]
PowerSNMP for .NET CF
Counter Constructor(String)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Counter Class > Counter Constructor : Counter Constructor(String)

count
The initial value given to this object in string form. This value is converted to a UInt32 value and assigned to the object.
Initializes a new instance of the Counter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal count As String _
)
Visual Basic (Usage) Copy Code
Dim count As String

Dim instance As New Counter(count)
C#
public Counter(
   string count
)
Managed Extensions for C++
public: Counter(
   string* count
)
C++/CLI
public:
Counter(
   String^ count
)

Parameters

count
The initial value given to this object in string form. This value is converted to a UInt32 value and assigned to the object.

Exceptions

Exception | Description
System.ArgumentNullException | count is a null reference.
System.FormatException | count does not consist of an optional sign followed by a sequence of digits.
System.OverflowException | count is less than UInt32.MinValue or greater than UInt.MaxValue.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter Class
Counter Members
Overload List


Counter64 Class

[image]
PowerSNMP for .NET CF
Counter64 Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Counter64 Class

A tagged type representing an unsigned 64-bit integer that starts at 0, can only increase in value, and wraps back to 0 when it exceeds its maximum value.

Object Model

Counter64 Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Counter64
   Inherits Dart.Snmp.SimpleTaggedType
Visual Basic (Usage) Copy Code
Dim instance As Counter64
C#
public sealed class Counter64 : Dart.Snmp.SimpleTaggedType
Managed Extensions for C++
public __gc __sealed class Counter64 : public Dart.Snmp.SimpleTaggedType
C++/CLI
public ref class Counter64 sealed : public Dart.Snmp.SimpleTaggedType

Remarks

ASN.1 Counter64 Type. UInt64, Universal and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Counter64

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter64 Members
Dart.Snmp.SimpleType Namespace


Counter64 Class Members

[image]
PowerSNMP for .NET CF
Counter64 Class Members
See Also Fields Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Counter64 Class

The following tables list the members exposed by Counter64.

Public Constructors

 | Name | Description
public Constructor | Counter64 Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Value | Gets the value associated with this object.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Counter64 Class
Dart.Snmp.SimpleType Namespace


Counter64 Constructor

[image]
PowerSNMP for .NET CF
Counter64 Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Counter64 Class : Counter64 Constructor

Overload List

Overload | Description
Counter64 Constructor(UInt64) | Initializes a new instance of the Counter64 class.
Counter64 Constructor(String) | Initializes a new instance of the Counter64 class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter64 Class
Counter64 Members


Counter64 Constructor(UInt64)

[image]
PowerSNMP for .NET CF
Counter64 Constructor(UInt64)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Counter64 Class > Counter64 Constructor : Counter64 Constructor(UInt64)

count
The initial value given to this object. Use the string constructor if UInt64 is not supported in your environment.
Initializes a new instance of the Counter64 class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal count As ULong _
)
Visual Basic (Usage) Copy Code
Dim count As ULong

Dim instance As New Counter64(count)
C#
public Counter64(
   ulong count
)
Managed Extensions for C++
public: Counter64(
   ulong count
)
C++/CLI
public:
Counter64(
   ulong count
)

Parameters

count
The initial value given to this object. Use the string constructor if UInt64 is not supported in your environment.

Exceptions

Exception | Description
System.ArgumentNullException | count is a null reference.
System.OverflowException | count is less UInt64.MinVal or greater than UInt64.MaxValue.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter64 Class
Counter64 Members
Overload List


Counter64 Constructor(String)

[image]
PowerSNMP for .NET CF
Counter64 Constructor(String)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Counter64 Class > Counter64 Constructor : Counter64 Constructor(String)

count
The initial value given to this object in string form. This value is converted to a UInt64 value and assigned to the object.
Initializes a new instance of the Counter64 class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal count As String _
)
Visual Basic (Usage) Copy Code
Dim count As String

Dim instance As New Counter64(count)
C#
public Counter64(
   string count
)
Managed Extensions for C++
public: Counter64(
   string* count
)
C++/CLI
public:
Counter64(
   String^ count
)

Parameters

count
The initial value given to this object in string form. This value is converted to a UInt64 value and assigned to the object.

Exceptions

Exception | Description
System.ArgumentNullException | count is a null reference.
System.FormatException | count does not consist of an optional sign followed by a sequence of digits.
System.OverflowException | count is less UInt64.MinVal or greater than UInt64.MaxValue.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter64 Class
Counter64 Members
Overload List


Counter64 Class Methods

[image]
PowerSNMP for .NET CF
Counter64 Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Counter64 Class

"

For a list of all members of this type, see Counter64 members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Counter64 Class
Dart.Snmp.SimpleType Namespace


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Counter64 Class : ToString Method

Converts the object to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Counter64
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter64 Class
Counter64 Members


Counter64 Class Fields

[image]
PowerSNMP for .NET CF
Counter64 Class Fields
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Counter64 Class

"

For a list of all members of this type, see Counter64 members.

"

Public Fields

 | Name | Description
public Field | Value | Gets the value associated with this object.
Top

See Also

Reference

Counter64 Class
Dart.Snmp.SimpleType Namespace


Value Field

[image]
PowerSNMP for .NET CF
Value Field
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Counter64 Class : Value Field

Gets the value associated with this object.

Syntax

Visual Basic (Declaration)
Public Value As ULong
Visual Basic (Usage) Copy Code
Dim instance As Counter64
Dim value As ULong

value = instance.Value

instance.Value = value
C#
public ulong Value
Managed Extensions for C++
public: ulong Value
C++/CLI
public:
ulong Value

Property Value

Returns the value assigned to this object.

Remarks

Read-only. Use the ToString method if UInt64 is not supported in your environment.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Counter64 Class
Counter64 Members


Empty Class

[image]
PowerSNMP for .NET CF
Empty Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Empty Class

A tagged type representing a place-holder when no value is desired.

Object Model

Empty Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Empty
   Inherits Dart.Snmp.SimpleTaggedType
Visual Basic (Usage) Copy Code
Dim instance As Empty
C#
public sealed class Empty : Dart.Snmp.SimpleTaggedType
Managed Extensions for C++
public __gc __sealed class Empty : public Dart.Snmp.SimpleTaggedType
C++/CLI
public ref class Empty sealed : public Dart.Snmp.SimpleTaggedType

Remarks

ASN.1 Null Type. Universal and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Empty

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Empty Members
Dart.Snmp.SimpleType Namespace


Empty Class Members

[image]
PowerSNMP for .NET CF
Empty Class Members
See Also Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Empty Class

The following tables list the members exposed by Empty.

Public Constructors

 | Name | Description
public Constructor | Empty Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Empty Class
Dart.Snmp.SimpleType Namespace


Empty Constructor

[image]
PowerSNMP for .NET CF
Empty Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Empty Class : Empty Constructor

Overload List

Overload | Description
Empty Constructor | Initializes a new instance of the Empty class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Empty Class
Empty Members


Empty Constructor

[image]
PowerSNMP for .NET CF
Empty Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Empty Class : Empty Constructor

Initializes a new instance of the Empty class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Empty()
C#
public Empty()
Managed Extensions for C++
public: Empty();
C++/CLI
public:
Empty();

Remarks

An instance of this class is used as Value when no value exists, such as when a GetMessage request is used to request a value of an IID.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Empty Class
Empty Members


Empty Class Methods

[image]
PowerSNMP for .NET CF
Empty Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Empty Class

"

For a list of all members of this type, see Empty members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Empty Class
Dart.Snmp.SimpleType Namespace


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Empty Class : ToString Method

Converts the object to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Empty
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Empty Class
Empty Members


EndOfMibView Class

[image]
PowerSNMP for .NET CF
EndOfMibView Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : EndOfMibView Class

A tagged type representing the fact that end of the MIB has been reached.

Object Model

EndOfMibView Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class EndOfMibView
   Inherits Dart.Snmp.SimpleTaggedType
Visual Basic (Usage) Copy Code
Dim instance As EndOfMibView
C#
public sealed class EndOfMibView : Dart.Snmp.SimpleTaggedType
Managed Extensions for C++
public __gc __sealed class EndOfMibView : public Dart.Snmp.SimpleTaggedType
C++/CLI
public ref class EndOfMibView sealed : public Dart.Snmp.SimpleTaggedType

Remarks

ASN.1 EndOfMibView Type. No value...reports the end of the mib, ContextSpecific and Primitive. The EndOfMibView value is returned only in Version 2 or greater messages in response to a GetNext or GetBulk request when there is no lexicographical successor to the provided variable ID.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.EndOfMibView

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

EndOfMibView Members
Dart.Snmp.SimpleType Namespace


EndOfMibView Class Members

[image]
PowerSNMP for .NET CF
EndOfMibView Class Members
See Also Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : EndOfMibView Class

The following tables list the members exposed by EndOfMibView.

Public Constructors

 | Name | Description
public Constructor | EndOfMibView Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

EndOfMibView Class
Dart.Snmp.SimpleType Namespace


EndOfMibView Constructor

[image]
PowerSNMP for .NET CF
EndOfMibView Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > EndOfMibView Class : EndOfMibView Constructor

Overload List

Overload | Description
EndOfMibView Constructor | Initializes a new instance of the EndOfMibView class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

EndOfMibView Class
EndOfMibView Members


EndOfMibView Constructor

[image]
PowerSNMP for .NET CF
EndOfMibView Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > EndOfMibView Class : EndOfMibView Constructor

Initializes a new instance of the EndOfMibView class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New EndOfMibView()
C#
public EndOfMibView()
Managed Extensions for C++
public: EndOfMibView();
C++/CLI
public:
EndOfMibView();

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

EndOfMibView Class
EndOfMibView Members


Gauge Class

[image]
PowerSNMP for .NET CF
Gauge Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Gauge Class

A tagged type representing an unsigned 32-bit integer that can increase or decrease in value, but does not wrap to 0 if the maximum value is exceeded.

Object Model

Gauge Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Gauge
   Inherits UInteger
Visual Basic (Usage) Copy Code
Dim instance As Gauge
C#
public sealed class Gauge : UInteger
Managed Extensions for C++
public __gc __sealed class Gauge : public UInteger
C++/CLI
public ref class Gauge sealed : public UInteger

Remarks

ASN.1 Gauge32 Type. Int32, Application and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.UInteger
Dart.Snmp.SimpleType.Gauge

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Gauge Members
Dart.Snmp.SimpleType Namespace


Gauge Class Members

[image]
PowerSNMP for .NET CF
Gauge Class Members
See Also Properties Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Gauge Class

The following tables list the members exposed by Gauge.

Public Constructors

 | Name | Description
public Constructor | Gauge Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Value | Gets the unsigned integer value associated with this object. (Inherited from Dart.Snmp.SimpleType.UInteger)
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

Gauge Class
Dart.Snmp.SimpleType Namespace


Gauge Constructor

[image]
PowerSNMP for .NET CF
Gauge Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Gauge Class : Gauge Constructor

Overload List

Overload | Description
Gauge Constructor(Int64) | Initializes a new instance of the Gauge class.
Gauge Constructor(String) | Initializes a new instance of the Gauge class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Gauge Class
Gauge Members


Gauge Constructor(Int64)

[image]
PowerSNMP for .NET CF
Gauge Constructor(Int64)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Gauge Class > Gauge Constructor : Gauge Constructor(Int64)

value
The initial value given to this object. An Int64 is used because UInt32 is not CLS-compliant.
Initializes a new instance of the Gauge class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As New Gauge(value)
C#
public Gauge(
   long value
)
Managed Extensions for C++
public: Gauge(
   long value
)
C++/CLI
public:
Gauge(
   int64 value
)

Parameters

value
The initial value given to this object. An Int64 is used because UInt32 is not CLS-compliant.

Exceptions

Exception | Description
System.ArgumentNullException | value is a null reference.
System.OverflowException | value is less than UInt32.MinValue or greater than UInt32.MaxValue.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Gauge Class
Gauge Members
Overload List


Gauge Constructor(String)

[image]
PowerSNMP for .NET CF
Gauge Constructor(String)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Gauge Class > Gauge Constructor : Gauge Constructor(String)

value
The initial value given to this object in string form. This value is converted to a UInt32 value and assigned to the object.
Initializes a new instance of the Gauge class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As New Gauge(value)
C#
public Gauge(
   string value
)
Managed Extensions for C++
public: Gauge(
   string* value
)
C++/CLI
public:
Gauge(
   String^ value
)

Parameters

value
The initial value given to this object in string form. This value is converted to a UInt32 value and assigned to the object.

Exceptions

Exception | Description
System.ArgumentNullException | value is a null reference.
System.FormatException | value does not consist of an optional sign followed by a sequence of digits.
System.OverflowException | value is less than UInt32.MinValue or greater than UInt32.MaxValue.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Gauge Class
Gauge Members
Overload List


Id Class

[image]
PowerSNMP for .NET CF
Id Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Id Class

A tagged type representing a MIB object (node represented as an OID) or instance (IID) in ASN.1 notation.

Object Model

Id Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Id
   Inherits Opaque
Visual Basic (Usage) Copy Code
Dim instance As Id
C#
public sealed class Id : Opaque
Managed Extensions for C++
public __gc __sealed class Id : public Opaque
C++/CLI
public ref class Id sealed : public Opaque

Remarks

Supports the capability to pass object and instance identifiers. IIDs, OIDs and OID segments can be used in variables in GetNextMessage and GetBulkMessage requests, but only specific IIDs may be used for GetMessage, SetMessage, InformMessage, TrapMessage, NotificationMessage and ResponseMessage.

ASN.1 Object ID Type. String, Universal and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Opaque
Dart.Snmp.SimpleType.Id

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Id Members
Dart.Snmp.SimpleType Namespace


Id Class Members

[image]
PowerSNMP for .NET CF
Id Class Members
See Also Fields Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Id Class

The following tables list the members exposed by Id.

Public Constructors

 | Name | Description
public Constructor | Id Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation. (Inherited from Dart.Snmp.SimpleType.Opaque)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Id Class
Dart.Snmp.SimpleType Namespace


Id Constructor

[image]
PowerSNMP for .NET CF
Id Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Id Class : Id Constructor

Overload List

Overload | Description
Id Constructor | Initializes a new instance of the Id class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Id Class
Id Members


Id Constructor

[image]
PowerSNMP for .NET CF
Id Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Id Class : Id Constructor

id
The initial value given to this object in string form.
Initializes a new instance of the Id class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal id As String _
)
Visual Basic (Usage) Copy Code
Dim id As String

Dim instance As New Id(id)
C#
public Id(
   string id
)
Managed Extensions for C++
public: Id(
   string* id
)
C++/CLI
public:
Id(
   String^ id
)

Parameters

id
The initial value given to this object in string form.

Exceptions

Exception | Description
System.ArgumentNullException | id is a null reference.
System.FormatException | id contains a dotted value that is not an optional sign followed by a sequence of digits.
System.OverflowException | id contains a dotted value that is less than UInt32.MinValue or greater than UInt32MaxValue

Remarks

The string value assigned to an Id object must be in the form n.n.n….n where n is an unsigned 32-bit integer.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Id Class
Id Members


Id Class Methods

[image]
PowerSNMP for .NET CF
Id Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Id Class

"

For a list of all members of this type, see Id members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation. (Inherited from Dart.Snmp.SimpleType.Opaque)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Id Class
Dart.Snmp.SimpleType Namespace


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Id Class : ToString Method

Converts the object to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Id
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Id Class
Id Members


Integer Class

[image]
PowerSNMP for .NET CF
Integer Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Integer Class

A tagged type representing a signed 32-bit value.

Object Model

Integer Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Integer
   Inherits Dart.Snmp.SimpleTaggedType
Visual Basic (Usage) Copy Code
Dim instance As Integer
C#
public sealed class Integer : Dart.Snmp.SimpleTaggedType
Managed Extensions for C++
public __gc __sealed class Integer : public Dart.Snmp.SimpleTaggedType
C++/CLI
public ref class Integer sealed : public Dart.Snmp.SimpleTaggedType

Remarks

ASN.1 Integer Type. Int32, Universal and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Integer

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Integer Members
Dart.Snmp.SimpleType Namespace


Integer Class Members

[image]
PowerSNMP for .NET CF
Integer Class Members
See Also Fields Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Integer Class

The following tables list the members exposed by Integer.

Public Constructors

 | Name | Description
public Constructor | Integer Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Value | Gets the integer value associated with this object.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Integer Class
Dart.Snmp.SimpleType Namespace


Integer Constructor

[image]
PowerSNMP for .NET CF
Integer Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Integer Class : Integer Constructor

Overload List

Overload | Description
Integer Constructor(String) | Initializes a new instance of the Integer class.
Integer Constructor(Int32) | Initializes a new instance of the Integer class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Integer Class
Integer Members


Integer Constructor(String)

[image]
PowerSNMP for .NET CF
Integer Constructor(String)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Integer Class > Integer Constructor : Integer Constructor(String)

value
The initial value given to this object in string form. Converted to an int and assigned to the object.
Initializes a new instance of the Integer class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As New Integer(value)
C#
public Integer(
   string value
)
Managed Extensions for C++
public: Integer(
   string* value
)
C++/CLI
public:
Integer(
   String^ value
)

Parameters

value
The initial value given to this object in string form. Converted to an int and assigned to the object.

Exceptions

Exception | Description
System.ArgumentNullException | value is a null reference.
System.FormatException | value does not consist of an option sign followed by a sequence of digits.
System.OverflowException | value is less than Int32.MinValue or greater than Int32.MaxValue.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Integer Class
Integer Members
Overload List


Integer Constructor(Int32)

[image]
PowerSNMP for .NET CF
Integer Constructor(Int32)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Integer Class > Integer Constructor : Integer Constructor(Int32)

value
The initial value given to this object.
Initializes a new instance of the Integer class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim value As Integer

Dim instance As New Integer(value)
C#
public Integer(
   int value
)
Managed Extensions for C++
public: Integer(
   int value
)
C++/CLI
public:
Integer(
   int value
)

Parameters

value
The initial value given to this object.

Exceptions

Exception | Description
System.ArgumentNullException | The value is a null reference
System.FormatException | The value does not consist of an option sign followed by a sequence of digits.
System.OverflowException | The value is less than Int32.MinValue or greater than Int32.MaxValue

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Integer Class
Integer Members
Overload List


Integer Class Methods

[image]
PowerSNMP for .NET CF
Integer Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Integer Class

"

For a list of all members of this type, see Integer members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

Integer Class
Dart.Snmp.SimpleType Namespace


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Integer Class : ToString Method

Converts the object to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Integer
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Integer Class
Integer Members


Integer Class Fields

[image]
PowerSNMP for .NET CF
Integer Class Fields
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Integer Class

"

For a list of all members of this type, see Integer members.

"

Public Fields

 | Name | Description
public Field | Value | Gets the integer value associated with this object.
Top

See Also

Reference

Integer Class
Dart.Snmp.SimpleType Namespace


Value Field

[image]
PowerSNMP for .NET CF
Value Field
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Integer Class : Value Field

Gets the integer value associated with this object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Value As Integer
Visual Basic (Usage) Copy Code
Dim instance As Integer
Dim value As Integer

value = instance.Value
C#
public readonly int Value
Managed Extensions for C++
public: readonly int Value
C++/CLI
public:
readonly int Value

Property Value

Returns the Int32 value assigned to this object when it was initialized.

Remarks

Read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Integer Class
Integer Members


IpAddress Class

[image]
PowerSNMP for .NET CF
IpAddress Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : IpAddress Class

A tagged type representing an IP address.

Object Model

IpAddress Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class IpAddress
   Inherits Opaque
Visual Basic (Usage) Copy Code
Dim instance As IpAddress
C#
public sealed class IpAddress : Opaque
Managed Extensions for C++
public __gc __sealed class IpAddress : public Opaque
C++/CLI
public ref class IpAddress sealed : public Opaque

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Opaque
Dart.Snmp.SimpleType.IpAddress

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

IpAddress Members
Dart.Snmp.SimpleType Namespace


IpAddress Class Members

[image]
PowerSNMP for .NET CF
IpAddress Class Members
See Also Fields Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : IpAddress Class

The following tables list the members exposed by IpAddress.

Public Constructors

 | Name | Description
public Constructor | IpAddress Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation. (Inherited from Dart.Snmp.SimpleType.Opaque)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

IpAddress Class
Dart.Snmp.SimpleType Namespace


IpAddress Constructor

[image]
PowerSNMP for .NET CF
IpAddress Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > IpAddress Class : IpAddress Constructor

Overload List

Overload | Description
IpAddress Constructor | Initializes a new instance of the IpAddress class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

IpAddress Class
IpAddress Members


IpAddress Constructor

[image]
PowerSNMP for .NET CF
IpAddress Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > IpAddress Class : IpAddress Constructor

address
The initial value given to this object in string form. This value it to be in the form of n.n.n.n when n is a value between 0 and 255.
Initializes a new instance of the IpAddress class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal address As String _
)
Visual Basic (Usage) Copy Code
Dim address As String

Dim instance As New IpAddress(address)
C#
public IpAddress(
   string address
)
Managed Extensions for C++
public: IpAddress(
   string* address
)
C++/CLI
public:
IpAddress(
   String^ address
)

Parameters

address
The initial value given to this object in string form. This value it to be in the form of n.n.n.n when n is a value between 0 and 255.

Exceptions

Exception | Description
System.ArgumentException | value is not in the form of n.n.n.n where n is a value between 0 and 255.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

IpAddress Class
IpAddress Members


IpAddress Class Methods

[image]
PowerSNMP for .NET CF
IpAddress Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : IpAddress Class

"

For a list of all members of this type, see IpAddress members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation. (Inherited from Dart.Snmp.SimpleType.Opaque)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

IpAddress Class
Dart.Snmp.SimpleType Namespace


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > IpAddress Class : ToString Method

Converts the object to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As IpAddress
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

IpAddress Class
IpAddress Members


NoSuchInstance Class

[image]
PowerSNMP for .NET CF
NoSuchInstance Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : NoSuchInstance Class

A tagged type representing the fact that the agent does not manage an instance of the IID specified by the variable.

Object Model

NoSuchInstance Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NoSuchInstance
   Inherits Dart.Snmp.SimpleTaggedType
Visual Basic (Usage) Copy Code
Dim instance As NoSuchInstance
C#
public sealed class NoSuchInstance : Dart.Snmp.SimpleTaggedType
Managed Extensions for C++
public __gc __sealed class NoSuchInstance : public Dart.Snmp.SimpleTaggedType
C++/CLI
public ref class NoSuchInstance sealed : public Dart.Snmp.SimpleTaggedType

Remarks

ASN.1 NoSuchInstance Type. No value...reports an error, ContextSpecific and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.NoSuchInstance

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NoSuchInstance Members
Dart.Snmp.SimpleType Namespace


NoSuchInstance Class Members

[image]
PowerSNMP for .NET CF
NoSuchInstance Class Members
See Also Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : NoSuchInstance Class

The following tables list the members exposed by NoSuchInstance.

Public Constructors

 | Name | Description
public Constructor | NoSuchInstance Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

NoSuchInstance Class
Dart.Snmp.SimpleType Namespace


NoSuchInstance Constructor

[image]
PowerSNMP for .NET CF
NoSuchInstance Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > NoSuchInstance Class : NoSuchInstance Constructor

Overload List

Overload | Description
NoSuchInstance Constructor | Initializes a new instance of the NoSuchInstance class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NoSuchInstance Class
NoSuchInstance Members


NoSuchInstance Constructor

[image]
PowerSNMP for .NET CF
NoSuchInstance Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > NoSuchInstance Class : NoSuchInstance Constructor

Initializes a new instance of the NoSuchInstance class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New NoSuchInstance()
C#
public NoSuchInstance()
Managed Extensions for C++
public: NoSuchInstance();
C++/CLI
public:
NoSuchInstance();

Remarks

The NoSuchInstance value is returned only in Version 2 or greater responses for those variables in which the agent is able to locate the requested OID, but does not manage the instance variable requested (the OID indicated by the provided IID is known, but the IID does not map to an existing instance specified by the IID).

This condition might occur when the OID maps to a valid table column, but no row exists for the specified index (suffix).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NoSuchInstance Class
NoSuchInstance Members


NoSuchObject Class

[image]
PowerSNMP for .NET CF
NoSuchObject Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : NoSuchObject Class

A tagged type representing the fact that the agent has no knowledge of the OID specified by the variable.

Object Model

NoSuchObject Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NoSuchObject
   Inherits Dart.Snmp.SimpleTaggedType
Visual Basic (Usage) Copy Code
Dim instance As NoSuchObject
C#
public sealed class NoSuchObject : Dart.Snmp.SimpleTaggedType
Managed Extensions for C++
public __gc __sealed class NoSuchObject : public Dart.Snmp.SimpleTaggedType
C++/CLI
public ref class NoSuchObject sealed : public Dart.Snmp.SimpleTaggedType

Remarks

ASN.1 NoSuchObject Type. No value...reports an error, ContextSpecific and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.NoSuchObject

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NoSuchObject Members
Dart.Snmp.SimpleType Namespace


NoSuchObject Class Members

[image]
PowerSNMP for .NET CF
NoSuchObject Class Members
See Also Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : NoSuchObject Class

The following tables list the members exposed by NoSuchObject.

Public Constructors

 | Name | Description
public Constructor | NoSuchObject Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

NoSuchObject Class
Dart.Snmp.SimpleType Namespace


NoSuchObject Constructor

[image]
PowerSNMP for .NET CF
NoSuchObject Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > NoSuchObject Class : NoSuchObject Constructor

Overload List

Overload | Description
NoSuchObject Constructor | Initializes a new instance of the NoSuchObject class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NoSuchObject Class
NoSuchObject Members


NoSuchObject Constructor

[image]
PowerSNMP for .NET CF
NoSuchObject Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > NoSuchObject Class : NoSuchObject Constructor

Initializes a new instance of the NoSuchObject class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New NoSuchObject()
C#
public NoSuchObject()
Managed Extensions for C++
public: NoSuchObject();
C++/CLI
public:
NoSuchObject();

Remarks

The NoSuchObject value is returned only in Version 2 or greater responses for those variables for which the agent is unable to locate the requested MIB node (the OID indicated by the provided IID is unknown).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

NoSuchObject Class
NoSuchObject Members


Nsap Class

[image]
PowerSNMP for .NET CF
Nsap Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Nsap Class

An NSAP tagged type.

Object Model

Nsap Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Nsap
   Inherits Opaque
Visual Basic (Usage) Copy Code
Dim instance As Nsap
C#
public sealed class Nsap : Opaque
Managed Extensions for C++
public __gc __sealed class Nsap : public Opaque
C++/CLI
public ref class Nsap sealed : public Opaque

Remarks

ASN.1 Nsap Type. String, Application and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Opaque
Dart.Snmp.SimpleType.Nsap

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Nsap Members
Dart.Snmp.SimpleType Namespace


Nsap Class Members

[image]
PowerSNMP for .NET CF
Nsap Class Members
See Also Fields Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Nsap Class

The following tables list the members exposed by Nsap.

Public Constructors

 | Name | Description
public Constructor | Nsap Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

See Also

Reference

Nsap Class
Dart.Snmp.SimpleType Namespace


Nsap Constructor

[image]
PowerSNMP for .NET CF
Nsap Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Nsap Class : Nsap Constructor

Overload List

Overload | Description
Nsap Constructor(Byte[]) | Initializes a new instance of the Nsap class.
Nsap Constructor(String) | Initializes a new instance of the Nsap class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Nsap Class
Nsap Members


Nsap Constructor(Byte[])

[image]
PowerSNMP for .NET CF
Nsap Constructor(Byte[])
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Nsap Class > Nsap Constructor : Nsap Constructor(Byte[])

nsap
The byte array assigned to this object.
Initializes a new instance of the Nsap class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal nsap() As Byte _
)
Visual Basic (Usage) Copy Code
Dim nsap() As Byte

Dim instance As New Nsap(nsap)
C#
public Nsap(
   byte[] nsap
)
Managed Extensions for C++
public: Nsap(
   byte[]* nsap
)
C++/CLI
public:
Nsap(
   array<byte>^ nsap
)

Parameters

nsap
The byte array assigned to this object.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Nsap Class
Nsap Members
Overload List


Nsap Constructor(String)

[image]
PowerSNMP for .NET CF
Nsap Constructor(String)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Nsap Class > Nsap Constructor : Nsap Constructor(String)

value
A string that is converted to a byte array using the system default encoding.
Initializes a new instance of the Nsap class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As New Nsap(value)
C#
public Nsap(
   string value
)
Managed Extensions for C++
public: Nsap(
   string* value
)
C++/CLI
public:
Nsap(
   String^ value
)

Parameters

value
A string that is converted to a byte array using the system default encoding.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Nsap Class
Nsap Members
Overload List


OctetString Class

[image]
PowerSNMP for .NET CF
OctetString Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : OctetString Class

A tagged type supporting the capability to pass byte arrays or strings.

Object Model

OctetString Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OctetString
   Inherits Opaque
Visual Basic (Usage) Copy Code
Dim instance As OctetString
C#
public sealed class OctetString : Opaque
Managed Extensions for C++
public __gc __sealed class OctetString : public Opaque
C++/CLI
public ref class OctetString sealed : public Opaque

Remarks

ASN.1 OctetString Type. Byte[], Universal and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Opaque
Dart.Snmp.SimpleType.OctetString

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OctetString Members
Dart.Snmp.SimpleType Namespace


OctetString Class Members

[image]
PowerSNMP for .NET CF
OctetString Class Members
See Also Fields Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : OctetString Class

The following tables list the members exposed by OctetString.

Public Constructors

 | Name | Description
public Constructor | OctetString Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

See Also

Reference

OctetString Class
Dart.Snmp.SimpleType Namespace


OctetString Constructor

[image]
PowerSNMP for .NET CF
OctetString Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > OctetString Class : OctetString Constructor

Overload List

Overload | Description
OctetString Constructor(Byte[]) | Initializes a new instance of the OctetString class.
OctetString Constructor(String) | Initializes a new instance of the OctetString class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OctetString Class
OctetString Members


OctetString Constructor(Byte[])

[image]
PowerSNMP for .NET CF
OctetString Constructor(Byte[])
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > OctetString Class > OctetString Constructor : OctetString Constructor(Byte[])

value
The byte array assigned to this object.
Initializes a new instance of the OctetString class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value() As Byte _
)
Visual Basic (Usage) Copy Code
Dim value() As Byte

Dim instance As New OctetString(value)
C#
public OctetString(
   byte[] value
)
Managed Extensions for C++
public: OctetString(
   byte[]* value
)
C++/CLI
public:
OctetString(
   array<byte>^ value
)

Parameters

value
The byte array assigned to this object.

Exceptions

Exception | Description
System.ArgumentNullException | The value is a null reference.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OctetString Class
OctetString Members
Overload List


OctetString Constructor(String)

[image]
PowerSNMP for .NET CF
OctetString Constructor(String)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > OctetString Class > OctetString Constructor : OctetString Constructor(String)

value
The initial value given to this object in string form. This value is converted to byte using the system default encoding.
Initializes a new instance of the OctetString class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As New OctetString(value)
C#
public OctetString(
   string value
)
Managed Extensions for C++
public: OctetString(
   string* value
)
C++/CLI
public:
OctetString(
   String^ value
)

Parameters

value
The initial value given to this object in string form. This value is converted to byte using the system default encoding.

Exceptions

Exception | Description
System.ArgumentNullException | The value is a null reference.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

OctetString Class
OctetString Members
Overload List


Opaque Class

[image]
PowerSNMP for .NET CF
Opaque Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Opaque Class

A tagged type supporting the capability to pass arbitrary binary data or structures.

Object Model

Opaque Class

Syntax

Visual Basic (Declaration)
Public Class Opaque
   Inherits Dart.Snmp.SimpleTaggedType
Visual Basic (Usage) Copy Code
Dim instance As Opaque
C#
public class Opaque : Dart.Snmp.SimpleTaggedType
Managed Extensions for C++
public __gc class Opaque : public Dart.Snmp.SimpleTaggedType
C++/CLI
public ref class Opaque : public Dart.Snmp.SimpleTaggedType

Remarks

ASN.1 Opaque Type. Byte[], Application and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Opaque
Dart.Snmp.SimpleType.Id
Dart.Snmp.SimpleType.IpAddress
Dart.Snmp.SimpleType.Nsap
Dart.Snmp.SimpleType.OctetString

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Opaque Members
Dart.Snmp.SimpleType Namespace


Opaque Class Members

[image]
PowerSNMP for .NET CF
Opaque Class Members
See Also Fields Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Opaque Class

The following tables list the members exposed by Opaque.

Public Constructors

 | Name | Description
public Constructor | Opaque Constructor | Overloaded.
Top

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Used for encoding bytes in Value.Buffer, and putting into buffer. Special case: A constructed sequence already has content types encoded into buffer. This is indicated by a null value for Value.Buffer, and a valid count provided by Value.Length. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation.
public Method | ToString | Converts the object to its string representation using the system default encoding.
Top

See Also

Reference

Opaque Class
Dart.Snmp.SimpleType Namespace


Opaque Constructor

[image]
PowerSNMP for .NET CF
Opaque Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Opaque Class : Opaque Constructor

Overload List

Overload | Description
Opaque Constructor(Byte[]) | Initializes a new instance of the Opaque class.
Opaque Constructor(String) | Initializes a new instance of the Opaque class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Opaque Class
Opaque Members


Opaque Constructor(Byte[])

[image]
PowerSNMP for .NET CF
Opaque Constructor(Byte[])
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Opaque Class > Opaque Constructor : Opaque Constructor(Byte[])

value
The byte array assigned to this object.
Initializes a new instance of the Opaque class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value() As Byte _
)
Visual Basic (Usage) Copy Code
Dim value() As Byte

Dim instance As New Opaque(value)
C#
public Opaque(
   byte[] value
)
Managed Extensions for C++
public: Opaque(
   byte[]* value
)
C++/CLI
public:
Opaque(
   array<byte>^ value
)

Parameters

value
The byte array assigned to this object.

Exceptions

Exception | Description
System.ArgumentNullException | value is a null reference.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Opaque Class
Opaque Members
Overload List


Opaque Constructor(String)

[image]
PowerSNMP for .NET CF
Opaque Constructor(String)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Opaque Class > Opaque Constructor : Opaque Constructor(String)

value
The initial value given to this object in string form. This value is converted to bytes using the system default encoding.
Initializes a new instance of the Opaque class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As New Opaque(value)
C#
public Opaque(
   string value
)
Managed Extensions for C++
public: Opaque(
   string* value
)
C++/CLI
public:
Opaque(
   String^ value
)

Parameters

value
The initial value given to this object in string form. This value is converted to bytes using the system default encoding.

Exceptions

Exception | Description
System.ArgumentNullException | value is a null reference.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Opaque Class
Opaque Members
Overload List


Opaque Class Methods

[image]
PowerSNMP for .NET CF
Opaque Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Opaque Class

"

For a list of all members of this type, see Opaque members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Used for encoding bytes in Value.Buffer, and putting into buffer. Special case: A constructed sequence already has content types encoded into buffer. This is indicated by a null value for Value.Buffer, and a valid count provided by Value.Length. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation.
public Method | ToString | Converts the object to its string representation using the system default encoding.
Top

See Also

Reference

Opaque Class
Dart.Snmp.SimpleType Namespace


ToHexString Method

[image]
PowerSNMP for .NET CF
ToHexString Method
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Opaque Class : ToHexString Method

delimiter
A string to use between each hex pair. May be null.
Converts the object to its hex string representation.

Syntax

Visual Basic (Declaration)
Public Function ToHexString( _
   ByVal delimiter As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Opaque
Dim delimiter As String
Dim value As String

value = instance.ToHexString(delimiter)
C#
public string ToHexString(
   string delimiter
)
Managed Extensions for C++
public: string* ToHexString(
   string* delimiter
)
C++/CLI
public:
String^ ToHexString(
   String^ delimiter
)

Parameters

delimiter
A string to use between each hex pair. May be null.

Remarks

Converts the object to its hex string representation. The string starts with the high 4 bits of the first element, followed by the low 4 bits of the first element, followed by the delimiter, and continues with each byte. Possible hex values are { '0', '1','2','3','4','5','6','7','8','9','a','b','c','d','e','f' }.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Opaque Class
Opaque Members


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Opaque Class : ToString Method

Converts the object to its string representation using the system default encoding.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Opaque
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Remarks

Converts the object to its string representation using the system default encoding.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Opaque Class
Opaque Members


Opaque Class Fields

[image]
PowerSNMP for .NET CF
Opaque Class Fields
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Opaque Class

"

For a list of all members of this type, see Opaque members.

"

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object.
Top

See Also

Reference

Opaque Class
Dart.Snmp.SimpleType Namespace


Value Field

[image]
PowerSNMP for .NET CF
Value Field
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > Opaque Class : Value Field

Gets the byte array associated with this object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Value As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Opaque
Dim value() As Byte

value = instance.Value
C#
public readonly byte[] Value
Managed Extensions for C++
public: readonly byte[]* Value
C++/CLI
public:
readonly array<byte>^ Value

Property Value

Returns the byte array assigned to this object at the time is was initialized.

Remarks

Read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

Opaque Class
Opaque Members


TimeTicks Class

[image]
PowerSNMP for .NET CF
TimeTicks Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : TimeTicks Class

A tagged type representing an unsigned 32-bit integer that counts the time in hundredths of a second since some reference epoch.

Object Model

TimeTicks Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TimeTicks
   Inherits UInteger
Visual Basic (Usage) Copy Code
Dim instance As TimeTicks
C#
public sealed class TimeTicks : UInteger
Managed Extensions for C++
public __gc __sealed class TimeTicks : public UInteger
C++/CLI
public ref class TimeTicks sealed : public UInteger

Remarks

ASN.1 TimeTicks Type. UInt32, Application and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.UInteger
Dart.Snmp.SimpleType.TimeTicks

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TimeTicks Members
Dart.Snmp.SimpleType Namespace


TimeTicks Class Members

[image]
PowerSNMP for .NET CF
TimeTicks Class Members
See Also Properties Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : TimeTicks Class

The following tables list the members exposed by TimeTicks.

Public Constructors

 | Name | Description
public Constructor | TimeTicks Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Value | Gets the unsigned integer value associated with this object. (Inherited from Dart.Snmp.SimpleType.UInteger)
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

TimeTicks Class
Dart.Snmp.SimpleType Namespace


TimeTicks Constructor

[image]
PowerSNMP for .NET CF
TimeTicks Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > TimeTicks Class : TimeTicks Constructor

Overload List

Overload | Description
TimeTicks Constructor(Int64) | Initializes a new instance of the TimeTicks class.
TimeTicks Constructor(String) | Initializes a new instance of the TimeTicks class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TimeTicks Class
TimeTicks Members


TimeTicks Constructor(Int64)

[image]
PowerSNMP for .NET CF
TimeTicks Constructor(Int64)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > TimeTicks Class > TimeTicks Constructor : TimeTicks Constructor(Int64)

ticks
The initial value given to this object. An Int64 is used because UInt32 is not CLS-compliant.
Initializes a new instance of the TimeTicks class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ticks As Long _
)
Visual Basic (Usage) Copy Code
Dim ticks As Long

Dim instance As New TimeTicks(ticks)
C#
public TimeTicks(
   long ticks
)
Managed Extensions for C++
public: TimeTicks(
   long ticks
)
C++/CLI
public:
TimeTicks(
   int64 ticks
)

Parameters

ticks
The initial value given to this object. An Int64 is used because UInt32 is not CLS-compliant.

Exceptions

Exception | Description
System.OverflowException | ticks is less than UInt32.MinValue or greater than UInt32.MaxValue.

Remarks

This class is typically used to represent the length of time a network entity has been active.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TimeTicks Class
TimeTicks Members
Overload List


TimeTicks Constructor(String)

[image]
PowerSNMP for .NET CF
TimeTicks Constructor(String)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > TimeTicks Class > TimeTicks Constructor : TimeTicks Constructor(String)

ticks
The initial value given to this object.
Initializes a new instance of the TimeTicks class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ticks As String _
)
Visual Basic (Usage) Copy Code
Dim ticks As String

Dim instance As New TimeTicks(ticks)
C#
public TimeTicks(
   string ticks
)
Managed Extensions for C++
public: TimeTicks(
   string* ticks
)
C++/CLI
public:
TimeTicks(
   String^ ticks
)

Parameters

ticks
The initial value given to this object.

Exceptions

Exception | Description
System.ArgumentNullException | ticks is a null reference.
System.OverflowException | ticks is less than UInt32.MinValue or greater than UInt32.MaxValue.

Remarks

This class is typically used to represent the length of time a network entity has been active.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

TimeTicks Class
TimeTicks Members
Overload List


UInteger Class

[image]
PowerSNMP for .NET CF
UInteger Class
Members See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : UInteger Class

A tagged type representing an unsigned 32-bit integer.

Object Model

UInteger Class

Syntax

Visual Basic (Declaration)
Public Class UInteger
   Inherits Dart.Snmp.SimpleTaggedType
Visual Basic (Usage) Copy Code
Dim instance As UInteger
C#
public class UInteger : Dart.Snmp.SimpleTaggedType
Managed Extensions for C++
public __gc class UInteger : public Dart.Snmp.SimpleTaggedType
C++/CLI
public ref class UInteger : public Dart.Snmp.SimpleTaggedType

Remarks

ASN.1 UInteger32 Type. UInt64, Universal and Primitive.

Inheritance Hierarchy

System.Object
Dart.Snmp.TaggedType
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.UInteger
Dart.Snmp.SimpleType.Counter
Dart.Snmp.SimpleType.Gauge
Dart.Snmp.SimpleType.TimeTicks

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UInteger Members
Dart.Snmp.SimpleType Namespace


UInteger Class Members

[image]
PowerSNMP for .NET CF
UInteger Class Members
See Also Properties Methods Send comments on this topic.
Dart.Snmp.SimpleType Namespace : UInteger Class

The following tables list the members exposed by UInteger.

Public Constructors

 | Name | Description
public Constructor | UInteger Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Value | Gets the unsigned integer value associated with this object.
Top

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

UInteger Class
Dart.Snmp.SimpleType Namespace


UInteger Constructor

[image]
PowerSNMP for .NET CF
UInteger Constructor
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > UInteger Class : UInteger Constructor

Overload List

Overload | Description
UInteger Constructor(Int64) | Initializes a new instance of the UInteger class.
UInteger Constructor(String) | Initializes a new instance of the UInteger class.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UInteger Class
UInteger Members


UInteger Constructor(Int64)

[image]
PowerSNMP for .NET CF
UInteger Constructor(Int64)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > UInteger Class > UInteger Constructor : UInteger Constructor(Int64)

value
The initial value given to this object. An Int64 is used because UInt32 is not CLS-compliant.
Initializes a new instance of the UInteger class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim value As Long

Dim instance As New UInteger(value)
C#
public UInteger(
   long value
)
Managed Extensions for C++
public: UInteger(
   long value
)
C++/CLI
public:
UInteger(
   int64 value
)

Parameters

value
The initial value given to this object. An Int64 is used because UInt32 is not CLS-compliant.

Exceptions

Exception | Description
System.ArgumentNullException | value is a null reference.
System.OverflowException | value is less than UInt32.MinValue or greater than UInt32.MaxValue.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UInteger Class
UInteger Members
Overload List


UInteger Constructor(String)

[image]
PowerSNMP for .NET CF
UInteger Constructor(String)
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > UInteger Class > UInteger Constructor : UInteger Constructor(String)

value
The initial value given to this object in string form. Converted to a UInt32 value and assigned to the object.
Initializes a new instance of the UInteger class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim value As String

Dim instance As New UInteger(value)
C#
public UInteger(
   string value
)
Managed Extensions for C++
public: UInteger(
   string* value
)
C++/CLI
public:
UInteger(
   String^ value
)

Parameters

value
The initial value given to this object in string form. Converted to a UInt32 value and assigned to the object.

Exceptions

Exception | Description
System.ArgumentNullException | value is a null reference.
System.OverflowException | value is less than UInt32.MinValue or greater than UInt32.MaxValue.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UInteger Class
UInteger Members
Overload List


UInteger Class Methods

[image]
PowerSNMP for .NET CF
UInteger Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : UInteger Class

"

For a list of all members of this type, see UInteger members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode object and return as a byte array. Normally used to create an SNMP packet. (Inherited from Dart.Snmp.TaggedType)
public Method | ToString | Converts the object to its string representation.
Top

See Also

Reference

UInteger Class
Dart.Snmp.SimpleType Namespace


ToString Method

[image]
PowerSNMP for .NET CF
ToString Method
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > UInteger Class : ToString Method

Converts the object to its string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As UInteger
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UInteger Class
UInteger Members


UInteger Class Properties

[image]
PowerSNMP for .NET CF
UInteger Class Properties
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : UInteger Class

"

For a list of all members of this type, see UInteger members.

"

Public Properties

 | Name | Description
public Property | Value | Gets the unsigned integer value associated with this object.
Top

See Also

Reference

UInteger Class
Dart.Snmp.SimpleType Namespace


Value Property

[image]
PowerSNMP for .NET CF
Value Property
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace > UInteger Class : Value Property

Gets the unsigned integer value associated with this object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Long
Visual Basic (Usage) Copy Code
Dim instance As UInteger
Dim value As Long

value = instance.Value
C#
public long Value {get;}
Managed Extensions for C++
public: __property long get_Value();
C++/CLI
public:
property int64 Value {
   int64 get();
}

Property Value

Returns the value assigned to the object at the time it was initialized. An Int64 is returned because UInt32 is not CLS-compliant.

Remarks

Read-only.

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

UInteger Class
UInteger Members


Dart.Snmp.Trap Namespace

Dart.Snmp.Trap Namespace
See Also Inheritance Hierarchy Send comments on this topic.

Classes

 | Class | Description
Class | authenticationFailure | Creates a TrapMessage that indicates an authentication failure.
Class | coldStart | Creates a TrapMessage that indicates a cold start.
Class | egpNeighborLoss | Creates a TrapMessage that indicates an EGP peer has been marked down.
Class | linkDown | Creates a TrapMessage that indicates a link is down.
Class | linkUp | Creates a TrapMessage that indicates a link is up.
Class | SpecificTrap | Creates a TrapMessage that indicates an extended specific trap.
Class | warmStart | Creates a TrapMessage that indicates a warm start.

See Also

Reference

Dart.Snmp.CF Assembly


authenticationFailure Class

[image]
PowerSNMP for .NET CF
authenticationFailure Class
Members See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : authenticationFailure Class

Creates a TrapMessage that indicates an authentication failure.

Object Model

authenticationFailure ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class authenticationFailure
   Inherits Dart.Snmp.TrapMessage
Visual Basic (Usage) Copy Code
Dim instance As authenticationFailure
C#
public class authenticationFailure : Dart.Snmp.TrapMessage
Managed Extensions for C++
public __gc class authenticationFailure : public Dart.Snmp.TrapMessage
C++/CLI
public ref class authenticationFailure : public Dart.Snmp.TrapMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.TrapMessage
Dart.Snmp.Trap.authenticationFailure

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

authenticationFailure Members
Dart.Snmp.Trap Namespace


authenticationFailure Class Members

[image]
PowerSNMP for .NET CF
authenticationFailure Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Trap Namespace : authenticationFailure Class

The following tables list the members exposed by authenticationFailure.

Public Constructors

 | Name | Description
public Constructor | authenticationFailure Constructor | Creates a TrapMessage that indicates an authentication failure.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

authenticationFailure Class
Dart.Snmp.Trap Namespace


authenticationFailure Constructor

[image]
PowerSNMP for .NET CF
authenticationFailure Constructor
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > authenticationFailure Class : authenticationFailure Constructor

enterpriseId
The id of the enterprise (usually the value of sysObjectID).
Creates a TrapMessage that indicates an authentication failure.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal enterpriseId As String _
)
Visual Basic (Usage) Copy Code
Dim enterpriseId As String

Dim instance As New authenticationFailure(enterpriseId)
C#
public authenticationFailure(
   string enterpriseId
)
Managed Extensions for C++
public: authenticationFailure(
   string* enterpriseId
)
C++/CLI
public:
authenticationFailure(
   String^ enterpriseId
)

Parameters

enterpriseId
The id of the enterprise (usually the value of sysObjectID).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

authenticationFailure Class
authenticationFailure Members


authenticationFailure Class Fields

[image]
PowerSNMP for .NET CF
authenticationFailure Class Fields
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : authenticationFailure Class

"

For a list of all members of this type, see authenticationFailure members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

authenticationFailure Class
Dart.Snmp.Trap Namespace


GenericTrapConst Field

[image]
PowerSNMP for .NET CF
GenericTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > authenticationFailure Class : GenericTrapConst Field

The value to use for the generic trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly GenericTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = authenticationFailure.GenericTrapConst
C#
public static readonly int GenericTrapConst
Managed Extensions for C++
public: static readonly int GenericTrapConst
C++/CLI
public:
static readonly int GenericTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

authenticationFailure Class
authenticationFailure Members


SpecificTrapConst Field

[image]
PowerSNMP for .NET CF
SpecificTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > authenticationFailure Class : SpecificTrapConst Field

The value to use for the specific trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SpecificTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = authenticationFailure.SpecificTrapConst
C#
public static readonly int SpecificTrapConst
Managed Extensions for C++
public: static readonly int SpecificTrapConst
C++/CLI
public:
static readonly int SpecificTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

authenticationFailure Class
authenticationFailure Members


coldStart Class

[image]
PowerSNMP for .NET CF
coldStart Class
Members See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : coldStart Class

Creates a TrapMessage that indicates a cold start.

Object Model

coldStart ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class coldStart
   Inherits Dart.Snmp.TrapMessage
Visual Basic (Usage) Copy Code
Dim instance As coldStart
C#
public class coldStart : Dart.Snmp.TrapMessage
Managed Extensions for C++
public __gc class coldStart : public Dart.Snmp.TrapMessage
C++/CLI
public ref class coldStart : public Dart.Snmp.TrapMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.TrapMessage
Dart.Snmp.Trap.coldStart

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

coldStart Members
Dart.Snmp.Trap Namespace


coldStart Class Members

[image]
PowerSNMP for .NET CF
coldStart Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Trap Namespace : coldStart Class

The following tables list the members exposed by coldStart.

Public Constructors

 | Name | Description
public Constructor | coldStart Constructor | Creates a TrapMessage that indicates a cold start.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

coldStart Class
Dart.Snmp.Trap Namespace


coldStart Constructor

[image]
PowerSNMP for .NET CF
coldStart Constructor
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > coldStart Class : coldStart Constructor

enterpriseId
The id of the enterprise (usually the value of sysObjectID).
Creates a TrapMessage that indicates a cold start.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal enterpriseId As String _
)
Visual Basic (Usage) Copy Code
Dim enterpriseId As String

Dim instance As New coldStart(enterpriseId)
C#
public coldStart(
   string enterpriseId
)
Managed Extensions for C++
public: coldStart(
   string* enterpriseId
)
C++/CLI
public:
coldStart(
   String^ enterpriseId
)

Parameters

enterpriseId
The id of the enterprise (usually the value of sysObjectID).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

coldStart Class
coldStart Members


coldStart Class Fields

[image]
PowerSNMP for .NET CF
coldStart Class Fields
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : coldStart Class

"

For a list of all members of this type, see coldStart members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

coldStart Class
Dart.Snmp.Trap Namespace


GenericTrapConst Field

[image]
PowerSNMP for .NET CF
GenericTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > coldStart Class : GenericTrapConst Field

The value to use for the generic trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly GenericTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = coldStart.GenericTrapConst
C#
public static readonly int GenericTrapConst
Managed Extensions for C++
public: static readonly int GenericTrapConst
C++/CLI
public:
static readonly int GenericTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

coldStart Class
coldStart Members


SpecificTrapConst Field

[image]
PowerSNMP for .NET CF
SpecificTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > coldStart Class : SpecificTrapConst Field

The value to use for the specific trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SpecificTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = coldStart.SpecificTrapConst
C#
public static readonly int SpecificTrapConst
Managed Extensions for C++
public: static readonly int SpecificTrapConst
C++/CLI
public:
static readonly int SpecificTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

coldStart Class
coldStart Members


egpNeighborLoss Class

[image]
PowerSNMP for .NET CF
egpNeighborLoss Class
Members See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : egpNeighborLoss Class

Creates a TrapMessage that indicates an EGP peer has been marked down.

Object Model

egpNeighborLoss ClassIpAddress ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class egpNeighborLoss
   Inherits Dart.Snmp.TrapMessage
Visual Basic (Usage) Copy Code
Dim instance As egpNeighborLoss
C#
public class egpNeighborLoss : Dart.Snmp.TrapMessage
Managed Extensions for C++
public __gc class egpNeighborLoss : public Dart.Snmp.TrapMessage
C++/CLI
public ref class egpNeighborLoss : public Dart.Snmp.TrapMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.TrapMessage
Dart.Snmp.Trap.egpNeighborLoss

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

egpNeighborLoss Members
Dart.Snmp.Trap Namespace


egpNeighborLoss Class Members

[image]
PowerSNMP for .NET CF
egpNeighborLoss Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Trap Namespace : egpNeighborLoss Class

The following tables list the members exposed by egpNeighborLoss.

Public Constructors

 | Name | Description
public Constructor | egpNeighborLoss Constructor | Creates a TrapMessage that indicates an EGP peer has been marked down.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | egpNeighAddr | Used to get or set the Dart.Snmp.SimpleType.IpAddress of the entity that has been marked down.
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

egpNeighborLoss Class
Dart.Snmp.Trap Namespace


egpNeighborLoss Constructor

[image]
PowerSNMP for .NET CF
egpNeighborLoss Constructor
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > egpNeighborLoss Class : egpNeighborLoss Constructor

enterpriseId
The id of the enterprise (usually the value of sysObjectID).
Creates a TrapMessage that indicates an EGP peer has been marked down.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal enterpriseId As String _
)
Visual Basic (Usage) Copy Code
Dim enterpriseId As String

Dim instance As New egpNeighborLoss(enterpriseId)
C#
public egpNeighborLoss(
   string enterpriseId
)
Managed Extensions for C++
public: egpNeighborLoss(
   string* enterpriseId
)
C++/CLI
public:
egpNeighborLoss(
   String^ enterpriseId
)

Parameters

enterpriseId
The id of the enterprise (usually the value of sysObjectID).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

egpNeighborLoss Class
egpNeighborLoss Members


egpNeighborLoss Class Properties

[image]
PowerSNMP for .NET CF
egpNeighborLoss Class Properties
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : egpNeighborLoss Class

"

For a list of all members of this type, see egpNeighborLoss members.

"

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | egpNeighAddr | Used to get or set the Dart.Snmp.SimpleType.IpAddress of the entity that has been marked down.
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

egpNeighborLoss Class
Dart.Snmp.Trap Namespace


egpNeighAddr Property

[image]
PowerSNMP for .NET CF
egpNeighAddr Property
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > egpNeighborLoss Class : egpNeighAddr Property

Used to get or set the Dart.Snmp.SimpleType.IpAddress of the entity that has been marked down.

Syntax

Visual Basic (Declaration)
Public Property egpNeighAddr As IpAddress
Visual Basic (Usage) Copy Code
Dim instance As egpNeighborLoss
Dim value As IpAddress

instance.egpNeighAddr = value

value = instance.egpNeighAddr
C#
public IpAddress egpNeighAddr {get; set;}
Managed Extensions for C++
public: __property IpAddress* get_egpNeighAddr();
public: __property void set_egpNeighAddr(
   IpAddress* value
);
C++/CLI
public:
property IpAddress^ egpNeighAddr {
   IpAddress^ get();
   void set (    IpAddress^ value);
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

egpNeighborLoss Class
egpNeighborLoss Members


egpNeighborLoss Class Fields

[image]
PowerSNMP for .NET CF
egpNeighborLoss Class Fields
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : egpNeighborLoss Class

"

For a list of all members of this type, see egpNeighborLoss members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

egpNeighborLoss Class
Dart.Snmp.Trap Namespace


GenericTrapConst Field

[image]
PowerSNMP for .NET CF
GenericTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > egpNeighborLoss Class : GenericTrapConst Field

The value to use for the generic trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly GenericTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = egpNeighborLoss.GenericTrapConst
C#
public static readonly int GenericTrapConst
Managed Extensions for C++
public: static readonly int GenericTrapConst
C++/CLI
public:
static readonly int GenericTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

egpNeighborLoss Class
egpNeighborLoss Members


SpecificTrapConst Field

[image]
PowerSNMP for .NET CF
SpecificTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > egpNeighborLoss Class : SpecificTrapConst Field

The value to use for the specific trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SpecificTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = egpNeighborLoss.SpecificTrapConst
C#
public static readonly int SpecificTrapConst
Managed Extensions for C++
public: static readonly int SpecificTrapConst
C++/CLI
public:
static readonly int SpecificTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

egpNeighborLoss Class
egpNeighborLoss Members


linkDown Class

[image]
PowerSNMP for .NET CF
linkDown Class
Members See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : linkDown Class

Creates a TrapMessage that indicates a link is down.

Object Model

linkDown ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class linkDown
   Inherits Dart.Snmp.TrapMessage
Visual Basic (Usage) Copy Code
Dim instance As linkDown
C#
public class linkDown : Dart.Snmp.TrapMessage
Managed Extensions for C++
public __gc class linkDown : public Dart.Snmp.TrapMessage
C++/CLI
public ref class linkDown : public Dart.Snmp.TrapMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.TrapMessage
Dart.Snmp.Trap.linkDown

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkDown Members
Dart.Snmp.Trap Namespace


linkDown Class Members

[image]
PowerSNMP for .NET CF
linkDown Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Trap Namespace : linkDown Class

The following tables list the members exposed by linkDown.

Public Constructors

 | Name | Description
public Constructor | linkDown Constructor | Creates a TrapMessage that indicates a link is down.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | ifIndex | The row index into the interface table.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

linkDown Class
Dart.Snmp.Trap Namespace


linkDown Constructor

[image]
PowerSNMP for .NET CF
linkDown Constructor
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > linkDown Class : linkDown Constructor

enterpriseId
The id of the enterprise (usually the value of sysObjectID).
Creates a TrapMessage that indicates a link is down.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal enterpriseId As String _
)
Visual Basic (Usage) Copy Code
Dim enterpriseId As String

Dim instance As New linkDown(enterpriseId)
C#
public linkDown(
   string enterpriseId
)
Managed Extensions for C++
public: linkDown(
   string* enterpriseId
)
C++/CLI
public:
linkDown(
   String^ enterpriseId
)

Parameters

enterpriseId
The id of the enterprise (usually the value of sysObjectID).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkDown Class
linkDown Members


linkDown Class Properties

[image]
PowerSNMP for .NET CF
linkDown Class Properties
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : linkDown Class

"

For a list of all members of this type, see linkDown members.

"

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | ifIndex | The row index into the interface table.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

linkDown Class
Dart.Snmp.Trap Namespace


ifIndex Property

[image]
PowerSNMP for .NET CF
ifIndex Property
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > linkDown Class : ifIndex Property

The row index into the interface table.

Syntax

Visual Basic (Declaration)
Public Property ifIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As linkDown
Dim value As Integer

instance.ifIndex = value

value = instance.ifIndex
C#
public int ifIndex {get; set;}
Managed Extensions for C++
public: __property int get_ifIndex();
public: __property void set_ifIndex(
   int value
);
C++/CLI
public:
property int ifIndex {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkDown Class
linkDown Members


linkDown Class Fields

[image]
PowerSNMP for .NET CF
linkDown Class Fields
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : linkDown Class

"

For a list of all members of this type, see linkDown members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

linkDown Class
Dart.Snmp.Trap Namespace


GenericTrapConst Field

[image]
PowerSNMP for .NET CF
GenericTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > linkDown Class : GenericTrapConst Field

The value to use for the generic trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly GenericTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = linkDown.GenericTrapConst
C#
public static readonly int GenericTrapConst
Managed Extensions for C++
public: static readonly int GenericTrapConst
C++/CLI
public:
static readonly int GenericTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkDown Class
linkDown Members


SpecificTrapConst Field

[image]
PowerSNMP for .NET CF
SpecificTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > linkDown Class : SpecificTrapConst Field

The value to use for the specific trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SpecificTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = linkDown.SpecificTrapConst
C#
public static readonly int SpecificTrapConst
Managed Extensions for C++
public: static readonly int SpecificTrapConst
C++/CLI
public:
static readonly int SpecificTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkDown Class
linkDown Members


linkUp Class

[image]
PowerSNMP for .NET CF
linkUp Class
Members See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : linkUp Class

Creates a TrapMessage that indicates a link is up.

Object Model

linkUp ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class linkUp
   Inherits Dart.Snmp.TrapMessage
Visual Basic (Usage) Copy Code
Dim instance As linkUp
C#
public class linkUp : Dart.Snmp.TrapMessage
Managed Extensions for C++
public __gc class linkUp : public Dart.Snmp.TrapMessage
C++/CLI
public ref class linkUp : public Dart.Snmp.TrapMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.TrapMessage
Dart.Snmp.Trap.linkUp

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkUp Members
Dart.Snmp.Trap Namespace


linkUp Class Members

[image]
PowerSNMP for .NET CF
linkUp Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Trap Namespace : linkUp Class

The following tables list the members exposed by linkUp.

Public Constructors

 | Name | Description
public Constructor | linkUp Constructor | Creates a TrapMessage that indicates a link is up.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | ifIndex | The row index into the interface table.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

linkUp Class
Dart.Snmp.Trap Namespace


linkUp Constructor

[image]
PowerSNMP for .NET CF
linkUp Constructor
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > linkUp Class : linkUp Constructor

enterpriseId
The id of the enterprise (usually the value of sysObjectID).
Creates a TrapMessage that indicates a link is up.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal enterpriseId As String _
)
Visual Basic (Usage) Copy Code
Dim enterpriseId As String

Dim instance As New linkUp(enterpriseId)
C#
public linkUp(
   string enterpriseId
)
Managed Extensions for C++
public: linkUp(
   string* enterpriseId
)
C++/CLI
public:
linkUp(
   String^ enterpriseId
)

Parameters

enterpriseId
The id of the enterprise (usually the value of sysObjectID).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkUp Class
linkUp Members


linkUp Class Properties

[image]
PowerSNMP for .NET CF
linkUp Class Properties
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : linkUp Class

"

For a list of all members of this type, see linkUp members.

"

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | ifIndex | The row index into the interface table.
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

linkUp Class
Dart.Snmp.Trap Namespace


ifIndex Property

[image]
PowerSNMP for .NET CF
ifIndex Property
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > linkUp Class : ifIndex Property

The row index into the interface table.

Syntax

Visual Basic (Declaration)
Public Property ifIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As linkUp
Dim value As Integer

instance.ifIndex = value

value = instance.ifIndex
C#
public int ifIndex {get; set;}
Managed Extensions for C++
public: __property int get_ifIndex();
public: __property void set_ifIndex(
   int value
);
C++/CLI
public:
property int ifIndex {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkUp Class
linkUp Members


linkUp Class Fields

[image]
PowerSNMP for .NET CF
linkUp Class Fields
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : linkUp Class

"

For a list of all members of this type, see linkUp members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

linkUp Class
Dart.Snmp.Trap Namespace


GenericTrapConst Field

[image]
PowerSNMP for .NET CF
GenericTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > linkUp Class : GenericTrapConst Field

The value to use for the generic trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly GenericTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = linkUp.GenericTrapConst
C#
public static readonly int GenericTrapConst
Managed Extensions for C++
public: static readonly int GenericTrapConst
C++/CLI
public:
static readonly int GenericTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkUp Class
linkUp Members


SpecificTrapConst Field

[image]
PowerSNMP for .NET CF
SpecificTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > linkUp Class : SpecificTrapConst Field

The value to use for the specific trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SpecificTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = linkUp.SpecificTrapConst
C#
public static readonly int SpecificTrapConst
Managed Extensions for C++
public: static readonly int SpecificTrapConst
C++/CLI
public:
static readonly int SpecificTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

linkUp Class
linkUp Members


SpecificTrap Class

[image]
PowerSNMP for .NET CF
SpecificTrap Class
Members See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : SpecificTrap Class

Creates a TrapMessage that indicates an extended specific trap.

Object Model

SpecificTrap ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class SpecificTrap
   Inherits Dart.Snmp.TrapMessage
Visual Basic (Usage) Copy Code
Dim instance As SpecificTrap
C#
public class SpecificTrap : Dart.Snmp.TrapMessage
Managed Extensions for C++
public __gc class SpecificTrap : public Dart.Snmp.TrapMessage
C++/CLI
public ref class SpecificTrap : public Dart.Snmp.TrapMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.TrapMessage
Dart.Snmp.Trap.SpecificTrap

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SpecificTrap Members
Dart.Snmp.Trap Namespace


SpecificTrap Class Members

[image]
PowerSNMP for .NET CF
SpecificTrap Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Trap Namespace : SpecificTrap Class

The following tables list the members exposed by SpecificTrap.

Public Constructors

 | Name | Description
public Constructor | SpecificTrap Constructor | Creates any specific trap. The user is responsible for creating any required variables.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

SpecificTrap Class
Dart.Snmp.Trap Namespace


SpecificTrap Constructor

[image]
PowerSNMP for .NET CF
SpecificTrap Constructor
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > SpecificTrap Class : SpecificTrap Constructor

specificTrap
A value, when combined with the enterprise ID, specifies a unique kind of trap.
enterpriseId
The id of the enterprise (usually the value of sysObjectID).
Creates any specific trap. The user is responsible for creating any required variables.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal specificTrap As Integer, _
   ByVal enterpriseId As String _
)
Visual Basic (Usage) Copy Code
Dim specificTrap As Integer
Dim enterpriseId As String

Dim instance As New SpecificTrap(specificTrap, enterpriseId)
C#
public SpecificTrap(
   int specificTrap,
   string enterpriseId
)
Managed Extensions for C++
public: SpecificTrap(
   int specificTrap,
   string* enterpriseId
)
C++/CLI
public:
SpecificTrap(
   int specificTrap,
   String^ enterpriseId
)

Parameters

specificTrap
A value, when combined with the enterprise ID, specifies a unique kind of trap.
enterpriseId
The id of the enterprise (usually the value of sysObjectID).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SpecificTrap Class
SpecificTrap Members


SpecificTrap Class Fields

[image]
PowerSNMP for .NET CF
SpecificTrap Class Fields
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : SpecificTrap Class

"

For a list of all members of this type, see SpecificTrap members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

SpecificTrap Class
Dart.Snmp.Trap Namespace


GenericTrapConst Field

[image]
PowerSNMP for .NET CF
GenericTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > SpecificTrap Class : GenericTrapConst Field

The value to use for the generic trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly GenericTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = SpecificTrap.GenericTrapConst
C#
public static readonly int GenericTrapConst
Managed Extensions for C++
public: static readonly int GenericTrapConst
C++/CLI
public:
static readonly int GenericTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

SpecificTrap Class
SpecificTrap Members


warmStart Class

[image]
PowerSNMP for .NET CF
warmStart Class
Members See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : warmStart Class

Creates a TrapMessage that indicates a warm start.

Object Model

warmStart ClassSegment ClassVariableCollection ClassVariable Class

Syntax

Visual Basic (Declaration)
Public Class warmStart
   Inherits Dart.Snmp.TrapMessage
Visual Basic (Usage) Copy Code
Dim instance As warmStart
C#
public class warmStart : Dart.Snmp.TrapMessage
Managed Extensions for C++
public __gc class warmStart : public Dart.Snmp.TrapMessage
C++/CLI
public ref class warmStart : public Dart.Snmp.TrapMessage

Inheritance Hierarchy

System.Object
Dart.Snmp.MessageBase
Dart.Snmp.TrapMessage
Dart.Snmp.Trap.warmStart

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

warmStart Members
Dart.Snmp.Trap Namespace


warmStart Class Members

[image]
PowerSNMP for .NET CF
warmStart Class Members
See Also Fields Properties Methods Send comments on this topic.
Dart.Snmp.Trap Namespace : warmStart Class

The following tables list the members exposed by warmStart.

Public Constructors

 | Name | Description
public Constructor | warmStart Constructor | Creates a TrapMessage that indicates a warm start.
Top

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

warmStart Class
Dart.Snmp.Trap Namespace


warmStart Constructor

[image]
PowerSNMP for .NET CF
warmStart Constructor
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > warmStart Class : warmStart Constructor

enterpriseId
The id of the enterprise (usually the value of sysObjectID).
Creates a TrapMessage that indicates a warm start.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal enterpriseId As String _
)
Visual Basic (Usage) Copy Code
Dim enterpriseId As String

Dim instance As New warmStart(enterpriseId)
C#
public warmStart(
   string enterpriseId
)
Managed Extensions for C++
public: warmStart(
   string* enterpriseId
)
C++/CLI
public:
warmStart(
   String^ enterpriseId
)

Parameters

enterpriseId
The id of the enterprise (usually the value of sysObjectID).

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

warmStart Class
warmStart Members


warmStart Class Fields

[image]
PowerSNMP for .NET CF
warmStart Class Fields
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : warmStart Class

"

For a list of all members of this type, see warmStart members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
static (Shared in Visual Basic) | GenericTrapConst | The value to use for the generic trap field of the PDU.
static (Shared in Visual Basic) | SpecificTrapConst | The value to use for the specific trap field of the PDU.
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

warmStart Class
Dart.Snmp.Trap Namespace


GenericTrapConst Field

[image]
PowerSNMP for .NET CF
GenericTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > warmStart Class : GenericTrapConst Field

The value to use for the generic trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly GenericTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = warmStart.GenericTrapConst
C#
public static readonly int GenericTrapConst
Managed Extensions for C++
public: static readonly int GenericTrapConst
C++/CLI
public:
static readonly int GenericTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

warmStart Class
warmStart Members


SpecificTrapConst Field

[image]
PowerSNMP for .NET CF
SpecificTrapConst Field
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace > warmStart Class : SpecificTrapConst Field

The value to use for the specific trap field of the PDU.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SpecificTrapConst As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = warmStart.SpecificTrapConst
C#
public static readonly int SpecificTrapConst
Managed Extensions for C++
public: static readonly int SpecificTrapConst
C++/CLI
public:
static readonly int SpecificTrapConst

Requirements

Target Platforms: Microsoft .NET Framework 2.0

See Also

Reference

warmStart Class
warmStart Members


AuthenticationException Class Methods

[image]
PowerSNMP for .NET CF
AuthenticationException Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : AuthenticationException Class

"

For a list of all members of this type, see AuthenticationException members.

"

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

AuthenticationException Class
Dart.Common Namespace


AuthenticationException Class Properties

[image]
PowerSNMP for .NET CF
AuthenticationException Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : AuthenticationException Class

"

For a list of all members of this type, see AuthenticationException members.

"

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

AuthenticationException Class
Dart.Common Namespace


DartLicenseException Class Methods

[image]
PowerSNMP for .NET CF
DartLicenseException Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : DartLicenseException Class

"

For a list of all members of this type, see DartLicenseException members.

"

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Common Namespace


DartLicenseException Class Properties

[image]
PowerSNMP for .NET CF
DartLicenseException Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : DartLicenseException Class

"

For a list of all members of this type, see DartLicenseException members.

"

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Common Namespace


LicenseException Class Methods

[image]
PowerSNMP for .NET CF
LicenseException Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : LicenseException Class

"

For a list of all members of this type, see LicenseException members.

"

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

LicenseException Class
Dart.Common Namespace


SocketBase Class Events

[image]
PowerSNMP for .NET CF
SocketBase Class Events
See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

"

For a list of all members of this type, see SocketBase members.

"

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


SocketBase Class Fields

[image]
PowerSNMP for .NET CF
SocketBase Class Fields
See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

"

For a list of all members of this type, see SocketBase members.

"

Public Fields

 | Name | Description
public Field | Encoding | Character encoding used by the component. (Inherited from Dart.Common.ComponentBase)
public Field | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


SocketBase Class Methods

[image]
PowerSNMP for .NET CF
SocketBase Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : SocketBase Class

"

For a list of all members of this type, see SocketBase members.

"

Public Methods

 | Name | Description
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Marshal | Overloaded. Marshals an exception to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Methods

 | Name | Description
protected Method | GetService | (Inherited from System.ComponentModel.Component)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | OnError | Raises the Error event. (Inherited from Dart.Common.ComponentBase)
protected Method | OnUserState | Raises the UserState event. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Common Namespace


UdpSocket Class Properties

[image]
PowerSNMP for .NET CF
UdpSocket Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : UdpSocket Class

"

For a list of all members of this type, see UdpSocket members.

"

Public Properties

 | Name | Description
public Property | AddressFamily | (Inherited from System.Net.Sockets.Socket)
public Property | Available | (Inherited from System.Net.Sockets.Socket)
public Property | Blocking | (Inherited from System.Net.Sockets.Socket)
public Property | Connected | (Inherited from System.Net.Sockets.Socket)
public Property | DontFragment | (Inherited from System.Net.Sockets.Socket)
public Property | EnableBroadcast | (Inherited from System.Net.Sockets.Socket)
public Property | ExclusiveAddressUse | (Inherited from System.Net.Sockets.Socket)
public Property | Handle | (Inherited from System.Net.Sockets.Socket)
public Property | IsBound | (Inherited from System.Net.Sockets.Socket)
public Property | LingerState | (Inherited from System.Net.Sockets.Socket)
public Property | LocalEndPoint | (Inherited from System.Net.Sockets.Socket)
public Property | MulticastLoopback | (Inherited from System.Net.Sockets.Socket)
public Property | NoDelay | (Inherited from System.Net.Sockets.Socket)
public Property | ProtocolType | (Inherited from System.Net.Sockets.Socket)
public Property | ReceiveBufferSize | (Inherited from System.Net.Sockets.Socket)
public Property | ReceiveTimeout | Gets or sets a value that specifies the milliseconds after which a synchronous Receive call will time out. (Inherited from System.Net.Sockets.Socket)
public Property | RemoteEndPoint | (Inherited from System.Net.Sockets.Socket)
public Property | SendBufferSize | (Inherited from System.Net.Sockets.Socket)
public Property | SendTimeout | (Inherited from System.Net.Sockets.Socket)
public Property | SocketType | (Inherited from System.Net.Sockets.Socket)
public Property | Ttl | (Inherited from System.Net.Sockets.Socket)
public Property | UseOnlyOverlappedIO | (Inherited from System.Net.Sockets.Socket)
Top

See Also

Reference

UdpSocket Class
Dart.Common Namespace


X509CertificateCollection Class Methods

[image]
PowerSNMP for .NET CF
X509CertificateCollection Class Methods
See Also Send comments on this topic.
Dart.Common Namespace : X509CertificateCollection Class

"

For a list of all members of this type, see X509CertificateCollection members.

"

Public Methods

 | Name | Description
public Method | Add | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | AddRange | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Clear | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Contains | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ConvertAll | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Exists | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Find | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindAll | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindLast | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ForEach | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | GetRange | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Insert | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | InsertRange | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Remove | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveAll | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveAt | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | RemoveRange | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | ToArray | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | TrimExcess | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Method | TrueForAll | (Inherited from System.Collections.Generic.List<X509Certificate>)
Top

See Also

Reference

X509CertificateCollection Class
Dart.Common Namespace


X509CertificateCollection Class Properties

[image]
PowerSNMP for .NET CF
X509CertificateCollection Class Properties
See Also Send comments on this topic.
Dart.Common Namespace : X509CertificateCollection Class

"

For a list of all members of this type, see X509CertificateCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Property | Count | (Inherited from System.Collections.Generic.List<X509Certificate>)
public Property | Item | (Inherited from System.Collections.Generic.List<X509Certificate>)
Top

See Also

Reference

X509CertificateCollection Class
Dart.Common Namespace


Dart.Common Namespace Inheritance Hierarchy

Dart.Common Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Inheritance Hierarchy

System.Object
Dart.Common.ComponentErrorEventArgs
Dart.Common.Segment
Dart.Common.X509Chain
Dart.Common.X509ChainPolicy
System.Collections.Generic.List<T>
Dart.Common.X509CertificateCollection
System.ComponentModel.Component
System.MarshalByRefObject
Dart.Common.ComponentBase
Dart.Common.SocketBase
Dart.Snmp.SnmpBase
Dart.Snmp.Agent
Dart.Snmp.Manager
System.EventArgs
Dart.Common.UserStateEventArgs
Dart.Snmp.MessageEventArgs
Dart.Snmp.TableEventArgs
System.Exception
Dart.Common.DartLicenseException
System.Net.Sockets.NetworkStream
System.IO.Stream
System.MarshalByRefObject
Dart.Common.NetworkStream
System.Net.Sockets.Socket
Dart.Common.UdpSocket
System.SystemException
System.Exception
Dart.Common.AuthenticationException
Dart.Common.LicenseException
System.ValueType
Dart.Common.X509ChainStatus

See Also

Reference

Dart.Snmp.CF Assembly


Agent Class Events

[image]
PowerSNMP for .NET CF
Agent Class Events
See Also Send comments on this topic.
Dart.Snmp Namespace : Agent Class

"

For a list of all members of this type, see Agent members.

"

Public Events

 | Name | Description
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | Error | Raised when Marshal is called by the user or an unhandled Exception is thrown in a worker thread created using the Start method. (Inherited from Dart.Common.ComponentBase)
public Event | Message | The Message event is raised when SnmpBase.Marshal is used. (Inherited from Dart.Snmp.SnmpBase)
public Event | UserState | Raised when user state information is marshaled. (Inherited from Dart.Common.ComponentBase)
Top

See Also

Reference

Agent Class
Dart.Snmp Namespace


Agent Class Properties

[image]
PowerSNMP for .NET CF
Agent Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : Agent Class

"

For a list of all members of this type, see Agent members.

"

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Agent Class
Dart.Snmp Namespace


DecodingException Class Methods

[image]
PowerSNMP for .NET CF
DecodingException Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : DecodingException Class

"

For a list of all members of this type, see DecodingException members.

"

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

DecodingException Class
Dart.Snmp Namespace


DecodingException Class Properties

[image]
PowerSNMP for .NET CF
DecodingException Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : DecodingException Class

"

For a list of all members of this type, see DecodingException members.

"

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

DecodingException Class
Dart.Snmp Namespace


GetBulkMessage Class Fields

[image]
PowerSNMP for .NET CF
GetBulkMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : GetBulkMessage Class

"

For a list of all members of this type, see GetBulkMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetBulkMessage Class
Dart.Snmp Namespace


GetBulkMessage Class Methods

[image]
PowerSNMP for .NET CF
GetBulkMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : GetBulkMessage Class

"

For a list of all members of this type, see GetBulkMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetBulkMessage Class
Dart.Snmp Namespace


GetMessage Class Fields

[image]
PowerSNMP for .NET CF
GetMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : GetMessage Class

"

For a list of all members of this type, see GetMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetMessage Class
Dart.Snmp Namespace


GetMessage Class Methods

[image]
PowerSNMP for .NET CF
GetMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : GetMessage Class

"

For a list of all members of this type, see GetMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetMessage Class
Dart.Snmp Namespace


GetMessage Class Properties

[image]
PowerSNMP for .NET CF
GetMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : GetMessage Class

"

For a list of all members of this type, see GetMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetMessage Class
Dart.Snmp Namespace


GetNextMessage Class Fields

[image]
PowerSNMP for .NET CF
GetNextMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : GetNextMessage Class

"

For a list of all members of this type, see GetNextMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetNextMessage Class
Dart.Snmp Namespace


GetNextMessage Class Methods

[image]
PowerSNMP for .NET CF
GetNextMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : GetNextMessage Class

"

For a list of all members of this type, see GetNextMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetNextMessage Class
Dart.Snmp Namespace


GetNextMessage Class Properties

[image]
PowerSNMP for .NET CF
GetNextMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : GetNextMessage Class

"

For a list of all members of this type, see GetNextMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

GetNextMessage Class
Dart.Snmp Namespace


InformMessage Class Fields

[image]
PowerSNMP for .NET CF
InformMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : InformMessage Class

"

For a list of all members of this type, see InformMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

InformMessage Class
Dart.Snmp Namespace


InformMessage Class Methods

[image]
PowerSNMP for .NET CF
InformMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : InformMessage Class

"

For a list of all members of this type, see InformMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

InformMessage Class
Dart.Snmp Namespace


InformMessage Class Properties

[image]
PowerSNMP for .NET CF
InformMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : InformMessage Class

"

For a list of all members of this type, see InformMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

InformMessage Class
Dart.Snmp Namespace


Manager Class Properties

[image]
PowerSNMP for .NET CF
Manager Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : Manager Class

"

For a list of all members of this type, see Manager members.

"

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

Manager Class
Dart.Snmp Namespace


MibNodes Class Properties

[image]
PowerSNMP for .NET CF
MibNodes Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : MibNodes Class

"

For a list of all members of this type, see MibNodes members.

"

Public Properties

 | Name | Description
public Property | Comparer | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Property | Count | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Property | Item | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Property | Keys | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
public Property | Values | (Inherited from System.Collections.Generic.Dictionary<String,MibNode>)
Top

See Also

Reference

MibNodes Class
Dart.Snmp Namespace


MibTraps Class Properties

[image]
PowerSNMP for .NET CF
MibTraps Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : MibTraps Class

"

For a list of all members of this type, see MibTraps members.

"

Public Properties

 | Name | Description
public Property | Comparer | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Property | Count | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Property | Item | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Property | Keys | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
public Property | Values | (Inherited from System.Collections.Generic.Dictionary<String,MibTrap>)
Top

See Also

Reference

MibTraps Class
Dart.Snmp Namespace


authenticationFailure Class Methods

[image]
PowerSNMP for .NET CF
authenticationFailure Class Methods
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : authenticationFailure Class

"

For a list of all members of this type, see authenticationFailure members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

authenticationFailure Class
Dart.Snmp.Notification Namespace


authenticationFailure Class Properties

[image]
PowerSNMP for .NET CF
authenticationFailure Class Properties
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : authenticationFailure Class

"

For a list of all members of this type, see authenticationFailure members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Oid | Gets the OID that the message pertains to. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SysUpTime | Gets the hundredths of a second since the agent sending the message was initialized. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

authenticationFailure Class
Dart.Snmp.Notification Namespace


coldStart Class Methods

[image]
PowerSNMP for .NET CF
coldStart Class Methods
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : coldStart Class

"

For a list of all members of this type, see coldStart members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

coldStart Class
Dart.Snmp.Notification Namespace


coldStart Class Properties

[image]
PowerSNMP for .NET CF
coldStart Class Properties
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : coldStart Class

"

For a list of all members of this type, see coldStart members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Oid | Gets the OID that the message pertains to. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SysUpTime | Gets the hundredths of a second since the agent sending the message was initialized. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

coldStart Class
Dart.Snmp.Notification Namespace


warmStart Class Methods

[image]
PowerSNMP for .NET CF
warmStart Class Methods
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : warmStart Class

"

For a list of all members of this type, see warmStart members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

warmStart Class
Dart.Snmp.Notification Namespace


warmStart Class Properties

[image]
PowerSNMP for .NET CF
warmStart Class Properties
See Also Send comments on this topic.
Dart.Snmp.Notification Namespace : warmStart Class

"

For a list of all members of this type, see warmStart members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Oid | Gets the OID that the message pertains to. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SysUpTime | Gets the hundredths of a second since the agent sending the message was initialized. (Inherited from Dart.Snmp.NotificationMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

warmStart Class
Dart.Snmp.Notification Namespace


Dart.Snmp.Notification Namespace Inheritance Hierarchy

Dart.Snmp.Notification Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Inheritance Hierarchy

System.Object
Dart.Snmp.NotificationMessage
Dart.Snmp.StandardMessage
Dart.Snmp.MessageBase
Dart.Snmp.Notification.authenticationFailure
Dart.Snmp.Notification.coldStart
Dart.Snmp.Notification.warmStart

See Also

Reference

Dart.Snmp.CF Assembly


ReportMessage Class Fields

[image]
PowerSNMP for .NET CF
ReportMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : ReportMessage Class

"

For a list of all members of this type, see ReportMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

ReportMessage Class
Dart.Snmp Namespace


ReportMessage Class Methods

[image]
PowerSNMP for .NET CF
ReportMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : ReportMessage Class

"

For a list of all members of this type, see ReportMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

ReportMessage Class
Dart.Snmp Namespace


ReportMessage Class Properties

[image]
PowerSNMP for .NET CF
ReportMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : ReportMessage Class

"

For a list of all members of this type, see ReportMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | ErrorIndex | Gets or sets the error index field that indicates which variable caused an error. (Inherited from Dart.Snmp.ResponseMessage)
public Property | ErrorStatus | Gets or sets the error status field that indicates the completeness of the response. (Inherited from Dart.Snmp.ResponseMessage)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

ReportMessage Class
Dart.Snmp Namespace


RequestMessage Class Fields

[image]
PowerSNMP for .NET CF
RequestMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : RequestMessage Class

"

For a list of all members of this type, see RequestMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

RequestMessage Class
Dart.Snmp Namespace


RequestMessage Class Methods

[image]
PowerSNMP for .NET CF
RequestMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : RequestMessage Class

"

For a list of all members of this type, see RequestMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

RequestMessage Class
Dart.Snmp Namespace


RequestMessage Class Properties

[image]
PowerSNMP for .NET CF
RequestMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : RequestMessage Class

"

For a list of all members of this type, see RequestMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

RequestMessage Class
Dart.Snmp Namespace


ResponseMessage Class Fields

[image]
PowerSNMP for .NET CF
ResponseMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : ResponseMessage Class

"

For a list of all members of this type, see ResponseMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

ResponseMessage Class
Dart.Snmp Namespace


ResponseMessage Class Methods

[image]
PowerSNMP for .NET CF
ResponseMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : ResponseMessage Class

"

For a list of all members of this type, see ResponseMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

ResponseMessage Class
Dart.Snmp Namespace


SecurityException Class Methods

[image]
PowerSNMP for .NET CF
SecurityException Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : SecurityException Class

"

For a list of all members of this type, see SecurityException members.

"

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

SecurityException Class
Dart.Snmp Namespace


SecurityException Class Properties

[image]
PowerSNMP for .NET CF
SecurityException Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : SecurityException Class

"

For a list of all members of this type, see SecurityException members.

"

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

SecurityException Class
Dart.Snmp Namespace


SequenceOf Class Methods

[image]
PowerSNMP for .NET CF
SequenceOf Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : SequenceOf Class

"

For a list of all members of this type, see SequenceOf members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

SequenceOf Class
Dart.Snmp Namespace


SetMessage Class Fields

[image]
PowerSNMP for .NET CF
SetMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : SetMessage Class

"

For a list of all members of this type, see SetMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Security | Gets or sets the Security instance to use for encoding/encrypting and decoding/decrypting SNMP version 3 messages. (Inherited from Dart.Snmp.StandardMessage)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

SetMessage Class
Dart.Snmp Namespace


SetMessage Class Methods

[image]
PowerSNMP for .NET CF
SetMessage Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : SetMessage Class

"

For a list of all members of this type, see SetMessage members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

SetMessage Class
Dart.Snmp Namespace


SetMessage Class Properties

[image]
PowerSNMP for .NET CF
SetMessage Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : SetMessage Class

"

For a list of all members of this type, see SetMessage members.

"

Public Properties

 | Name | Description
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Id | Gets or sets the request identification field in the message. (Inherited from Dart.Snmp.StandardMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

SetMessage Class
Dart.Snmp Namespace


SetOf Class Methods

[image]
PowerSNMP for .NET CF
SetOf Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : SetOf Class

"

For a list of all members of this type, see SetOf members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

SetOf Class
Dart.Snmp Namespace


SimpleTaggedType Class Methods

[image]
PowerSNMP for .NET CF
SimpleTaggedType Class Methods
See Also Send comments on this topic.
Dart.Snmp Namespace : SimpleTaggedType Class

"

For a list of all members of this type, see SimpleTaggedType members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

SimpleTaggedType Class
Dart.Snmp Namespace


Counter Class Methods

[image]
PowerSNMP for .NET CF
Counter Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Counter Class

"

For a list of all members of this type, see Counter members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

Counter Class
Dart.Snmp.SimpleType Namespace


Counter Class Properties

[image]
PowerSNMP for .NET CF
Counter Class Properties
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Counter Class

"

For a list of all members of this type, see Counter members.

"

Public Properties

 | Name | Description
public Property | Value | Gets the unsigned integer value associated with this object. (Inherited from Dart.Snmp.SimpleType.UInteger)
Top

See Also

Reference

Counter Class
Dart.Snmp.SimpleType Namespace


EndOfMibView Class Methods

[image]
PowerSNMP for .NET CF
EndOfMibView Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : EndOfMibView Class

"

For a list of all members of this type, see EndOfMibView members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

EndOfMibView Class
Dart.Snmp.SimpleType Namespace


Gauge Class Methods

[image]
PowerSNMP for .NET CF
Gauge Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Gauge Class

"

For a list of all members of this type, see Gauge members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

Gauge Class
Dart.Snmp.SimpleType Namespace


Gauge Class Properties

[image]
PowerSNMP for .NET CF
Gauge Class Properties
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Gauge Class

"

For a list of all members of this type, see Gauge members.

"

Public Properties

 | Name | Description
public Property | Value | Gets the unsigned integer value associated with this object. (Inherited from Dart.Snmp.SimpleType.UInteger)
Top

See Also

Reference

Gauge Class
Dart.Snmp.SimpleType Namespace


Id Class Fields

[image]
PowerSNMP for .NET CF
Id Class Fields
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Id Class

"

For a list of all members of this type, see Id members.

"

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

See Also

Reference

Id Class
Dart.Snmp.SimpleType Namespace


IpAddress Class Fields

[image]
PowerSNMP for .NET CF
IpAddress Class Fields
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : IpAddress Class

"

For a list of all members of this type, see IpAddress members.

"

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

See Also

Reference

IpAddress Class
Dart.Snmp.SimpleType Namespace


NoSuchInstance Class Methods

[image]
PowerSNMP for .NET CF
NoSuchInstance Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : NoSuchInstance Class

"

For a list of all members of this type, see NoSuchInstance members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

NoSuchInstance Class
Dart.Snmp.SimpleType Namespace


NoSuchObject Class Methods

[image]
PowerSNMP for .NET CF
NoSuchObject Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : NoSuchObject Class

"

For a list of all members of this type, see NoSuchObject members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

NoSuchObject Class
Dart.Snmp.SimpleType Namespace


Nsap Class Fields

[image]
PowerSNMP for .NET CF
Nsap Class Fields
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Nsap Class

"

For a list of all members of this type, see Nsap members.

"

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

See Also

Reference

Nsap Class
Dart.Snmp.SimpleType Namespace


Nsap Class Methods

[image]
PowerSNMP for .NET CF
Nsap Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : Nsap Class

"

For a list of all members of this type, see Nsap members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

See Also

Reference

Nsap Class
Dart.Snmp.SimpleType Namespace


OctetString Class Fields

[image]
PowerSNMP for .NET CF
OctetString Class Fields
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : OctetString Class

"

For a list of all members of this type, see OctetString members.

"

Public Fields

 | Name | Description
public Field | Value | Gets the byte array associated with this object. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

See Also

Reference

OctetString Class
Dart.Snmp.SimpleType Namespace


OctetString Class Methods

[image]
PowerSNMP for .NET CF
OctetString Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : OctetString Class

"

For a list of all members of this type, see OctetString members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
public Method | ToHexString | Converts the object to its hex string representation. (Inherited from Dart.Snmp.SimpleType.Opaque)
Top

See Also

Reference

OctetString Class
Dart.Snmp.SimpleType Namespace


TimeTicks Class Methods

[image]
PowerSNMP for .NET CF
TimeTicks Class Methods
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : TimeTicks Class

"

For a list of all members of this type, see TimeTicks members.

"

Public Methods

 | Name | Description
public Method | Encode | Overloaded. Encode the object with no content. Overridden in derived classes that have content. (Inherited from Dart.Snmp.TaggedType)
Top

See Also

Reference

TimeTicks Class
Dart.Snmp.SimpleType Namespace


TimeTicks Class Properties

[image]
PowerSNMP for .NET CF
TimeTicks Class Properties
See Also Send comments on this topic.
Dart.Snmp.SimpleType Namespace : TimeTicks Class

"

For a list of all members of this type, see TimeTicks members.

"

Public Properties

 | Name | Description
public Property | Value | Gets the unsigned integer value associated with this object. (Inherited from Dart.Snmp.SimpleType.UInteger)
Top

See Also

Reference

TimeTicks Class
Dart.Snmp.SimpleType Namespace


Dart.Snmp.SimpleType Namespace Inheritance Hierarchy

Dart.Snmp.SimpleType Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Inheritance Hierarchy

System.Object
Dart.Snmp.SimpleTaggedType
Dart.Snmp.TaggedType
Dart.Snmp.SimpleType.Counter64
Dart.Snmp.SimpleType.Empty
Dart.Snmp.SimpleType.EndOfMibView
Dart.Snmp.SimpleType.Integer
Dart.Snmp.SimpleType.NoSuchInstance
Dart.Snmp.SimpleType.NoSuchObject
Dart.Snmp.SimpleType.Opaque
Dart.Snmp.SimpleType.Id
Dart.Snmp.SimpleType.IpAddress
Dart.Snmp.SimpleType.Nsap
Dart.Snmp.SimpleType.OctetString
Dart.Snmp.SimpleType.UInteger
Dart.Snmp.SimpleType.Counter
Dart.Snmp.SimpleType.Gauge
Dart.Snmp.SimpleType.TimeTicks

See Also

Reference

Dart.Snmp.CF Assembly


SnmpBase Class Properties

[image]
PowerSNMP for .NET CF
SnmpBase Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : SnmpBase Class

"

For a list of all members of this type, see SnmpBase members.

"

Public Properties

 | Name | Description
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Common.SocketBase)
public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread. (Inherited from Dart.Common.ComponentBase)
Top

Protected Properties

 | Name | Description
protected Property | CanRaiseEvents | (Inherited from System.ComponentModel.Component)
protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
protected Property | Events | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SnmpBase Class
Dart.Snmp Namespace


authenticationFailure Class Methods

[image]
PowerSNMP for .NET CF
authenticationFailure Class Methods
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : authenticationFailure Class

"

For a list of all members of this type, see authenticationFailure members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

authenticationFailure Class
Dart.Snmp.Trap Namespace


authenticationFailure Class Properties

[image]
PowerSNMP for .NET CF
authenticationFailure Class Properties
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : authenticationFailure Class

"

For a list of all members of this type, see authenticationFailure members.

"

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

authenticationFailure Class
Dart.Snmp.Trap Namespace


coldStart Class Methods

[image]
PowerSNMP for .NET CF
coldStart Class Methods
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : coldStart Class

"

For a list of all members of this type, see coldStart members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

coldStart Class
Dart.Snmp.Trap Namespace


coldStart Class Properties

[image]
PowerSNMP for .NET CF
coldStart Class Properties
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : coldStart Class

"

For a list of all members of this type, see coldStart members.

"

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

coldStart Class
Dart.Snmp.Trap Namespace


egpNeighborLoss Class Methods

[image]
PowerSNMP for .NET CF
egpNeighborLoss Class Methods
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : egpNeighborLoss Class

"

For a list of all members of this type, see egpNeighborLoss members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

egpNeighborLoss Class
Dart.Snmp.Trap Namespace


linkDown Class Methods

[image]
PowerSNMP for .NET CF
linkDown Class Methods
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : linkDown Class

"

For a list of all members of this type, see linkDown members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

linkDown Class
Dart.Snmp.Trap Namespace


linkUp Class Methods

[image]
PowerSNMP for .NET CF
linkUp Class Methods
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : linkUp Class

"

For a list of all members of this type, see linkUp members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

linkUp Class
Dart.Snmp.Trap Namespace


SpecificTrap Class Methods

[image]
PowerSNMP for .NET CF
SpecificTrap Class Methods
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : SpecificTrap Class

"

For a list of all members of this type, see SpecificTrap members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

SpecificTrap Class
Dart.Snmp.Trap Namespace


SpecificTrap Class Properties

[image]
PowerSNMP for .NET CF
SpecificTrap Class Properties
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : SpecificTrap Class

"

For a list of all members of this type, see SpecificTrap members.

"

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

SpecificTrap Class
Dart.Snmp.Trap Namespace


warmStart Class Methods

[image]
PowerSNMP for .NET CF
warmStart Class Methods
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : warmStart Class

"

For a list of all members of this type, see warmStart members.

"

Public Methods

 | Name | Description
public Method | Encode | Encodes all SNMP version 1/2 messages. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

warmStart Class
Dart.Snmp.Trap Namespace


warmStart Class Properties

[image]
PowerSNMP for .NET CF
warmStart Class Properties
See Also Send comments on this topic.
Dart.Snmp.Trap Namespace : warmStart Class

"

For a list of all members of this type, see warmStart members.

"

Public Properties

 | Name | Description
public Property | AgentAddress | Gets or sets the address of the agent initiating the trap. (Inherited from Dart.Snmp.TrapMessage)
public Property | EncodedMessage | Returns the encoded message. (Inherited from Dart.Snmp.MessageBase)
public Property | Enterprise | Gets the Enterprise OID associated with the TrapMessage. (Inherited from Dart.Snmp.TrapMessage)
public Property | GenericTrap | Gets the generic trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | Origin | Gets a value that indicates the origin of a received message or can be set to hold the destination of a message. (Inherited from Dart.Snmp.MessageBase)
public Property | SpecificTrap | Gets the specific trap as initialized in the constructor or when decoded. (Inherited from Dart.Snmp.TrapMessage)
public Property | SysUpTime | Gets the time since the agent was initialized in hundredths of a second. (Inherited from Dart.Snmp.TrapMessage)
public Property | Variables | Gets or sets the VariableCollection containing the IDs and their associated values in the message. (Inherited from Dart.Snmp.MessageBase)
public Property | Version | Gets or sets the SNMP version used for encoding. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

warmStart Class
Dart.Snmp.Trap Namespace


Dart.Snmp.Trap Namespace Inheritance Hierarchy

Dart.Snmp.Trap Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Inheritance Hierarchy

System.Object
Dart.Snmp.TrapMessage
Dart.Snmp.MessageBase
Dart.Snmp.Trap.authenticationFailure
Dart.Snmp.Trap.coldStart
Dart.Snmp.Trap.egpNeighborLoss
Dart.Snmp.Trap.linkDown
Dart.Snmp.Trap.linkUp
Dart.Snmp.Trap.SpecificTrap
Dart.Snmp.Trap.warmStart

See Also

Reference

Dart.Snmp.CF Assembly


TrapMessage Class Fields

[image]
PowerSNMP for .NET CF
TrapMessage Class Fields
See Also Send comments on this topic.
Dart.Snmp Namespace : TrapMessage Class

"

For a list of all members of this type, see TrapMessage members.

"

Public Fields

 | Name | Description
public Field | Community | Gets or sets the community field in the message. (Inherited from Dart.Snmp.MessageBase)
public Field | Tag | Gets or sets a value that can store any associated object. (Inherited from Dart.Snmp.MessageBase)
Top

See Also

Reference

TrapMessage Class
Dart.Snmp Namespace


VariableList Class Properties

[image]
PowerSNMP for .NET CF
VariableList Class Properties
See Also Send comments on this topic.
Dart.Snmp Namespace : VariableList Class

"

For a list of all members of this type, see VariableList members.

"

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Comparer | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Count | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Item | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Keys | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
public Property | Values | (Inherited from System.Collections.Generic.SortedList<String,Variable>)
Top

See Also

Reference

VariableList Class
Dart.Snmp Namespace


Dart.Snmp Namespace Inheritance Hierarchy

Dart.Snmp Namespace Inheritance Hierarchy
See Also Send comments on this topic.

Inheritance Hierarchy

System.Object
Dart.Common.SocketBase
Dart.Common.ComponentBase
System.ComponentModel.Component
System.MarshalByRefObject
Dart.Snmp.SnmpBase
Dart.Snmp.Agent
Dart.Snmp.Manager
Dart.Common.UserStateEventArgs
System.EventArgs
Dart.Snmp.MessageEventArgs
Dart.Snmp.TableEventArgs
Dart.Snmp.AuthoritativeEngine
Dart.Snmp.DiscoveredEngine
Dart.Snmp.ManagerSlave
Dart.Snmp.MessageBase
Dart.Snmp.StandardMessage
Dart.Snmp.NotificationMessage
Dart.Snmp.Notification.authenticationFailure
Dart.Snmp.Notification.coldStart
Dart.Snmp.Notification.warmStart
Dart.Snmp.RequestMessage
Dart.Snmp.GetBulkMessage
Dart.Snmp.GetMessage
Dart.Snmp.GetNextMessage
Dart.Snmp.InformMessage
Dart.Snmp.SetMessage
Dart.Snmp.ResponseMessage
Dart.Snmp.ReportMessage
Dart.Snmp.TrapMessage
Dart.Snmp.Trap.authenticationFailure
Dart.Snmp.Trap.coldStart
Dart.Snmp.Trap.egpNeighborLoss
Dart.Snmp.Trap.linkDown
Dart.Snmp.Trap.linkUp
Dart.Snmp.Trap.SpecificTrap
Dart.Snmp.Trap.warmStart
Dart.Snmp.MibDefinition
Dart.Snmp.MibNode
Dart.Snmp.MibTrap
Dart.Snmp.Module
Dart.Snmp.Passwords
Dart.Snmp.Security
Dart.Snmp.TaggedType
Dart.Snmp.Sequence
Dart.Snmp.SequenceOf
Dart.Snmp.SetOf
Dart.Snmp.Variable
Dart.Snmp.VariableCollection
Dart.Snmp.SimpleTaggedType
Dart.Snmp.SimpleType.Counter64
Dart.Snmp.SimpleType.Empty
Dart.Snmp.SimpleType.EndOfMibView
Dart.Snmp.SimpleType.Integer
Dart.Snmp.SimpleType.NoSuchInstance
Dart.Snmp.SimpleType.NoSuchObject
Dart.Snmp.SimpleType.Opaque
Dart.Snmp.SimpleType.Id
Dart.Snmp.SimpleType.IpAddress
Dart.Snmp.SimpleType.Nsap
Dart.Snmp.SimpleType.OctetString
Dart.Snmp.SimpleType.UInteger
Dart.Snmp.SimpleType.Counter
Dart.Snmp.SimpleType.Gauge
Dart.Snmp.SimpleType.TimeTicks
System.ApplicationException
System.Exception
Dart.Snmp.DecodingException
Dart.Snmp.SecurityException
System.Collections.Generic.Dictionary<TKey,TValue>
Dart.Snmp.MibNodes
Dart.Snmp.MibTraps
System.Collections.Generic.SortedList<TKey,TValue>
Dart.Snmp.VariableList

See Also

Reference

Dart.Snmp.CF Assembly