PowerWEB File Upload for ASP.NET

Many web applications such as content management systems, online communities, and photo albums require users to upload files using a browser. With PowerWEB File Upload for ASP.NET, adding sophisticated file upload functionality to your solution has been simplified. Your applications can also provide automatic, interactive upload progress reporting and give your end-users the ability to cancel uploads in progress.

PowerWEB File Upload uses advanced Ajax techniques to transfer files from browser to web server, while actually minimizing server memory footprint. Typical HTTP file upload processes in ASP.NET require files to be uploaded and stored in memory before being exposed to the page cycle. File Upload allows you to stream files to disk, memory, or an open Stream for advanced applications such as direct file upload to an FTP server. Additionally, File Upload controls can be styled with custom fonts and images to seamlessly blend into your website design.

Key Features

  • Compatibility with ASP.NET 1.x, 2.0, and 3.0
  • Cross-browser support (IE7, Firefox, Safari)
  • Multiple file uploads
  • File uploads without issuing full page Postback
  • Progress bars and statistics for each upload operation
  • Low server memory footprint
  • Server events raised during upload operation
  • Direct streaming to memory, file, or open Streams
  • Customizable look and feel
  • Interoperability with all other PowerWEB products for producing richer user experience
  • Server object and event model

In PowerWEB File Upload for ASP.NET Documentation

Getting Started
Provides an overview of PowerWEB File Upload for ASP.NET and discusses such topics as distribution, licensing, and support.
Using the File Upload Controls
Discusses how to use the File Upload controls in your project.
Reference
Provides a language/syntax reference for PowerWEB File Upload for ASP.NET.
Samples
Describes the samples that are installed with PowerWEB File Upload for ASP.NET.

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Getting Started

PowerWEB File Upload for ASP.NET is a powerful set of server controls which make it possible to transfer files to the web server using any modern browser while displaying detailed progress information. Using File Upload reduces server memory consumption normally associated with standard HTTP upload techniques. File Upload also gives developers more control over progress reporting and real-time data streaming. Using advanced Ajax techniques, File Upload transfers files, displays inline progress bars and status messages, and raises server events, all without initiating full page Postbacks.

This topic provides information on general topics such as licensing, support, and deployment. For specific information and walkthroughs on the usage of the controls contained in PowerWEB File Upload for ASP.NET, see Using the File Upload Controls.

In This Section

Requirements
Discusses the requirements needed to use PowerWEB File Upload for ASP.NET.
License Registration
Provides step-by-step instructions on installing a license.
Trial Operation
Provides an overview on using PowerWEB for ASP.NET in trial mode.
Creating the 'licenses.licx' File
Discusses the required 'licenses.licx' file.
Deployment
Discusses the steps that are required to distribute an application in ASP.NET.
Support
Provides an overview of the support options that are available for this product.

Related Sections

Using the File Upload Controls
Discusses how to use the File Upload controls in your project.
Reference
Provides a language/syntax reference for PowerWEB File Upload for ASP.NET.
Samples
Describes the samples that are installed with PowerWEB File Upload for ASP.NET.

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Requirements

In order to use PowerWEB File Upload for ASP.NET you must have the following:

  • .NET Framework version 1.1, 2.0, or 3.0
  • Microsoft Visual Studio .NET 2003, 2005, or Visual Web Developer 2005
  • Internet Information Server (IIS) (recommended)

At runtime, PowerWEB File Upload supports the following browsers:

  • Microsoft Internet Explorer 7.x
  • Firefox 1.5.x, 2.x
  • Safari 2.x, 3.x

See Also

Reference

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


License Registration

Your PowerWEB License Agreement provides you with a single-seat development license and the right to distribute PowerWEB classes with NO ROYALTIES of any kind. Some PowerWEB classes are marked as licensed. This topic covers:
  • Trial Installation
  • Installing a Fully Licensed PowerWEB Product
  • Re-installing a PowerWEB Product
  • License Details
  • Troubleshooting Licensing

Trial Installation

Installing a PowerWEB product as a fully–functional trial involves running the trial setup program (available from www.dart.com). The trial will operate for 30 days after installation. Proceed to step 2 of Installing a Fully Licensed PowerWEB Product when you are ready to license the product.

See Trial Operation for more information.

Installing a Fully Licensed PowerWEB Product

Once you have downloaded the latest version, complete the following steps to register your PowerWEB product.

If you have Internet Access on your development machine, please follow these instructions:

  1. From the Start menu, select Programs, select PowerWEB, select the PowerWEB product you downloaded, and then click License Registration.
  2. In the Dart License Registration dialog box, click Install.
  3. Click the Online Registration button.
  4. Enter required information, including Serial Number, First Name, Last Name, and Organization.
  5. Click Next.
  6. Enter your Email Address, Purchased From, and Purchase Date information.
  7. Click Next.
  8. Verify that the information is correct, and then click Next.
  9. When the registration process is complete, click Exit. (Note: Clicking Done at this step displays your currently registered PowerWEB product. Click Exit to complete the registration process and close the dialog box.)

If you do not have Internet Access on your development machine, please follow these instructions:
  1. From the Start menu, select Programs, select PowerWEB, select the PowerWEB product you downloaded, and then click License Registration.
  2. In the Dart License Registration dialog box, click Install.
  3. Under Option 2, enter your serial number in the Serial # field.
  4. Write down the number in the Key field.
  5. On a machine that has Internet access, log on to the Dart registration page (http://www.dart.com/register/).
  6. Enter all required information. The Key is the number written down in Step 4.
  7. Click Submit. A seven-digit registration code should appear.
  8. Back on the development machine (the machine on which Steps 1-4 were completed), enter the seven-digit registration number obtained in Step 7.
  9. Click Add.
  10. Click Exit.

After either of the two registration procedures are complete, your PowerWEB product appears in the Registered Tools field at the top of the registration form. Make sure you recompile your application after you register the PowerWEB product.

Re-installing a PowerWEB Product

The Key provided by the Registration Program is derived from a system number that is changed when the C: drive is reformatted. If you reformat your hard disk and need to re-install your PowerWEB product, follow the steps in Installing a Fully Licensed PowerWEB Product. A new Registration Number will be generated.

License Details

When you insert a PowerWEB component into a project, most development environments verify that the class is licensed for development. The component will work if you correctly entered the PowerWEB product Serial Number. See Installing a Fully Licensed PowerWEB Product for more information. When you compile your application, the development environment requests this Serial Number and embeds it in the application. When users run your application, the application submits this Serial Number to the class and the Serial Number is checked for validity. If the Serial Number is correct, then the application runs. This verification process occurs automatically.

Troubleshooting Licensing

For help troubleshooting licensing issues, see www.dart.com/support/lictrouble.asp.

If you have any problems registering your license, please contact Dart at 315-339-8040.

See Also

Trial Operation | Creating the 'licenses.licx' File | Deployment

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Trial Operation

PowerTCP Trials are now separate installs that do not interfere with already installed licensed products. PowerTCP Trial dlls contain ".Trial" in their filenames. For example, the trial version of "Dart.PowerWEB.FileUpload.dll" is "Dart.PowerWEB.FileUpload.Trial.dll". For questions concerning trial operation, contact the Sales Department at sales@dart.com.

Trial Notification in Development Mode

A trial notification screen will appear when the component is added to a form, or when a Project using the component is first opened. It will then reappear once every hour or so.

Trial Notification During Run-Time

Trial components are fully-functional components. Applications compiled with trial components have a seven day lifespan. For the first three days, applications execute as if the trial component is licensed. In the remaining four days, applications show a trial reminder when started. After these four days (seven days since compilation), a trial expired message appears and applications no longer run.

The developer may Rebuild his Project at any time to reset the trial countdown.

The separate PowerTCP trial install will allow coexistence of licensed versions and trial versions of PowerTCP products. It is no longer necessary to uninstall a licensed product to test a newer trial version.

Once a licensed version is purchased, existing applications developed with trial dlls must be Rebuilt. Prior to Rebuilding, the trial dll should be replaced in References, and trial component(s) should be replaced on forms.

See License Installation for more information on product registration.

See Also

License Registration | Creating the 'licenses.licx' File | Deployment

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Creating the 'licenses.licx' File

When you create an Upload control by dragging it from the toolbox, a licenses.licx file is automatically created by Visual Studio. The following steps are only necessary if you are using PowerWEB File Upload for ASP.NET classes without having dragged the control onto a form, or are using an IDE other than Visual Studio .NET.

To create a licenses.licx file, use the following steps. All PowerWEB classes are licensed, but only Upload needs to be referenced in the licenses.licx file to use PowerWEB File Upload for ASP.NET.

  1. Start a new application in Visual Studio .NET and add the Upload control as a reference.
  2. In the Solution Explorer, right-click the project name, choose Add, then Add New Item.
  3. From the resulting dialog box, choose Text File and name the file "licenses.licx". Click Open.
  4. Type the following in the licenses.licx file:
Dart.PowerWEB.FileUpload.Upload, Dart.PowerWEB.FileUpload
  5. Save the file. You should now be able to compile and run a project that uses any PowerWEB FileUpload class.

All PowerWEB classes are licensed, and will operate correctly if the above entry is added to the licenses.licx file.

Important! Do not change the "Build Action" property of the licenses.licx file from its default value of "Embedded Resource."

Important! Any time changes are made to the license, the Project (not the Solution) must be rebuilt or license changes will not take effect.

See Also

License Registration | Trial Operation | Deployment

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Deployment

Deploying a Web application that uses the PowerWEB File Upload for ASP.NET controls is easy. Visual Studio users can simply Rebuild the Project (to insert the license) on the development machine (the licensed machine), and then XCOPY or FTP the application to the server.

While developing the following steps should have already been taken.

  1. If you are instantiating the component dynamically, be sure to include a licenses.licx file (see the "Creating The 'licenses.licx' File" topic for more information.
  2. If using Visual Studio, the following text is automatically added to Web.config. In other development environments you need to add this text to support dynamic script generation:
    <httpHandlers>
    <add verb="*" path="Dart.PowerWEB.FileUpload.GetResource.aspx"
    type="Dart.PowerWEB.FileUpload.ResourceHttpHandler,Dart.PowerWEB.FileUpload" />
</httpHandlers>
    This section should be placed in the configuration:system.web node in the Web.config file.
  3. If using Visual Studio, the following text is automatically added to Web.config. In other development environments you need to add this text to support PowerWEB CallbackManager Viewstate management:

<httpModules>
    <add name="FileUploadModule" type="Dart.PowerWEB.FileUpload.FileUploadModule,Dart.PowerWEB.FileUpload" />
    <add name="CallbackManager" type="Dart.PowerWEB.FileUpload.CallbackManager,Dart.PowerWEB.FileUpload" />
</httpModules>

    NOTE: When using other 3rd party HttpModules, or custom HttpModules, be sure to place the FileUpload and CallbackManager registrations first in the list and in the order seen above, otherwise file uploads may be interrupted or fail.

  4. A "\bin" subdirectory should be in your project's directory (many development environments create this automatically). For example, if the project is called LiveTest, you should have a directory structure with "LiveTest\bin".
  5. Check for "Dart.PowerWEB.FileUpload.dll" in the "\Bin" directory. Your development environment may have already put a copy there when you added FileUpload as a reference.

To deploy a licensed ASP.NET Web Application or Web Service, follow these steps.

  1. Compile the ASP.NET application on a licensed development machine.
  2. Copy the contents of the bin folder and the ASP.NET source files (such as .aspx files) to the server that will be hosting the application.
  3. Create a virtual directory pointing to the folder containing the Web Application or Web Service. Of course, you can always install directly to the "wwwroot" structure.

Note: It is not necessary for the deployment server to be licensed or to contain a copy of a license in its registry.

See Also

License Registration | Trial Operation | Creating the 'licenses.licx' File

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Support Options

Our mission at Dart is to deliver high quality Internet connectivity solutions to Internet application developers. Our goal is to supplement these solutions with timely support resources that can help at many different levels.

Related Links (you must have an active connection to the Internet to view these links).

Paid Support Options
Discusses the paid support options available.
Free Support Options
Provides access to free materials to help your development, including FAQS, online help files, tutorials, code snippets, online asp samples, and a free support forum.
Support Forum
Provides access to our support forum, monitored by our own development staff as time permits.
Dart Solutions
Discusses the custom development support offered by Dart Solutions.

See Also

Reference

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Using the File Upload Controls

PowerWEB File Upload for ASP.NET is a powerful set of browser-based upload tools which make developing robust web applications fast and easy. This topic provides a introductory walkthrough on the basic usage of the controls included in PowerWEB File Upload for ASP.NET.

In This Section

Using the Upload Control
Provides an introductory walkthrough in using the Upload control to upload files to the web server.
Using the UploadManager Control
Provides information regarding page-level configuration and upload behavior controlled by the UploadManager control.
Using the OpenFileDialog Control
Discusses use of the web-based OpenFileDialog control for selecting files with custom interface elements.
Using the ProgressPanel Control
Discusses use of the ProgressPanel control to display real-time upload progress data.
Advanced: Streaming File Data During an Upload
Discusses an advanced feature of the Upload control - working with and streaming file data during upload.
Frequently Asked Questions
Answers to the most common questions regarding File Upload.

Related Sections

Getting Started
Provides an overview of PowerWEB File Upload for ASP.NET and discusses such topics as distribution, licensing, and support.
Reference
Provides a language/syntax reference for PowerWEB File Upload for ASP.NET.
Samples
Describes the samples that are installed with PowerWEB File Upload for ASP.NET.

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Using the Upload Control

Classic HTTP file upload techniques are facilitated with the HTML <input type="file"> tag. Browsers render this element as a text box with adjoining "Browse..." button. When clicked, the button initiates a browser-controlled file dialog. Selecting a local file places the file path within the text box. With additional configuration, submitting the HTML form causes the local file to be posted to the server along with all other form fields. However, this basic technique comes with many limitations, most notably the inability to customize the presentastion and behavior of the control.

The Upload control enables ASP.NET developers to provide a customizable file upload interface that transcends the limitations of the basic HTML file upload element. This control is intended to be use within a WebForm wherever a user is expected to select one or more files to be uploaded to the server. There are two basic usage modes that the Upload control operates under, controlled by the AutoPostback property.

  • When the AutoPostback property is set to true, the Upload control will immediately begin the upload operation as soon as files are selected.
  • When the AutoPostback property is set to false, the upload operation will not begin until the WebForm is submitted.

Basic configuration

  1. Add the Upload control to the Visual Studio Toolbar. Unless the Visual Studio toolbar items have been customized, this step is already completed during product installation.
  2. Drag an instance of the Upload control onto the WebForm.
  3. Drag an instance of the UploadManager control onto the WebForm. This step is required. By default, files are uploaded to the web application directory. Global upload destination and behavior is configured within the UploadManager properties. For more information on the UploadManager control, see the help topic titled Using the UploadManager Control.
  4. Drag an instance of the ProgressPanel control onto the WebForm. This step is optional, but recommended for displaying real time upload progress information.
  5. If using the Upload control with AutoPostback set to false, drag a standard ASP.NET Button control onto the WebForm.
  6. Run the application. You should see the Upload control load and display as a text box accompanied by a "Browse..." button.
  7. Click the "Browse..." button of the Upload control. This will initiate an open file dialog, directing you to select files to upload.
  8. Select one or more files and click "Open"
  9. If AutoPostback is set to true, the upload will begin. If not, click the standard ASP.NET Button to begin the upload operation.

Customization

The Upload control can also be customized to take on the look and feel of your website. Using the various Appearance properties, you can hide the text box, use an image for the "Browse.." button, or even have the button appear as a standard HTML link. See below for some examples:

See Also

Using the UploadManager Control | Using the OpenFileDialog Control | Using the ProgressPanel Control | Streaming File Data | Frequently Asked Questions | Reference

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Using the UploadManager Control

The UploadManager is a non-visual web server control that is required when using the Upload, OpenFileDialog and ProgressPanel controls. Only one instance of the UploadManager can be used on a single webform. This control manages page-level upload behavior settings such as file upload destination, temporary upload directory, and raising of file upload events.

Upload Destinations

By combining the settings of the SavePath and TempPath properties, file upload destinations can be configured in one of three ways.

  • Streaming file data to a temporary file location
    Setting the TempPath and SavePath properties will cause a temporary file to be written to the TempPath. When completed, the temporary file is moved to the SavePath location. This is an ideal configuration when reserving the SavePath for completed files as cancelled or truncated files will not be moved to the SavePath.
  • Streaming file data directly to a final file location
    Setting only the SavePath property will cause files to be directly uploaded to the SavePath location.
  • Streaming file data to memory
    Clearing both TempPath and SavePath values will cause files to be uploaded to server memory and is the ideal configuration for automated, direct streaming operations are required. For more information on using this configuration, see the Streaming File Data topic.

Limiting Files

The UploadManager is also used for setting page-level limitations on which type and size of files can be uploaded. To do so, use the following propreties:

  • Extensions - This property determines the list of allowable file extensions. By default, all file extensions are allowed.
  • UploadManager.MaxFileSize - The maximum individual file size allowed (in kilobytes). Setting this property to 0 allows all file sizes up to the IIS limit of 4GB.
  • MaxRequestSize - The maximum request size allowed (in kilobytes). This is the request size which includes the file data along with additional form field data. Setting this to 0 allows all request sizes up to the IIS limit of 4GB.

Events

Unlike other standard ASP.NET controls, the PowerWEB File Upload controls work together, are managed by the UploadManager control, and raise their individual events through the UploadManager. This simplifies the management of all upload operations on a given WebForm, as well as makes PostBack-free file uploading possible. The following events are exposed by the UploadManager control:

  • FileUploadComplete - raised once for each file successfully uploaded
  • FileUploadFailed - raised once for each file unsuccessfully uploaded
  • UploadCancelled - raised once if a page-level upload operation is cancelled
  • UploadComplete - raised once after all individual files have been uploaded
  • UploadProgress - raised once at each interval defined by the PollingInterval property (in ms). This event is also used for examining and working with uploaded file data as it is being streamed to the server.

See Also

Using the Upload Control | Using the OpenFileDialog Control | Using the ProgressPanel Control | Streaming File Data | Frequently Asked Questions | Reference

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Using the OpenFileDialog Control

Under most conditions, using the Upload control to open a file dialog is acceptable. However, your user interface requirements or design may be better suited to a file dialog being presented as the result of other client-side events or actions. The OpenFileDialog control allows you to create a non-visual control that can trigger a file dialog and be attached to any WebControl on the form by specifying the control (ClientTriggerElement) and the event (ClientTriggerEvent) that will act as a trigger.

For example, if you wish to trigger a file dialog based on a user clicking an Image control, you would configure the OpenFileDialog as follows:

  1. Place an OpenFileDialog control on the WebForm and set the AutoPostback property to true
  2. Place an UploadManager control on the WebForm (required)
  3. Configure the UploadManager as desired
  4. Place a standard Image control on the WebForm and set the ImageUrl property
  5. Optionally place a ProgressPanel on the WebForm to display real time upload progress information
  6. Set the ClientTriggerElement property to the ID of the Image control, and set the ClientTriggerEvent to "onclick"
  7. Run the application. You should see only the Image control on the form. Clicking it will cause allow you to select files to upload.

Note: The OpenFileDialog control will only operate when the client browser supports the Flash 8.0 plugin or higher. If you cannot determine your end-user browser capabilities, it is recommended that you use the Upload control.

See Also

Using the Upload Control | Using the ProgressPanel Control | Streaming File Data | Frequently Asked Questions | Reference

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Using the ProgressPanel Control

The ProgressPanel control provides configurable real time, interactive statistics on file upload operations on a page. This control becomes visible when a file upload is initiated and displays individual file progress bars, upload speed, bytes transferred and more. The ProgressPanel also optionally displays a cancel button that can be used to interrupt a file upload operation in progress.

Customizing the ProgressPanel Look & Feel

The ProgressPanel control has many Appearance and Behavior properties that can be modified to suit your needs and integrate into your overall website design. By default, the ProgressPanel displays a status message, file progress bars, a cancel button, and various upload statistics. The following diagram enumerates the separate components of the ProgressPanel:

StatusText

During a file upload operation the ProgressPanel Status Text changes to reflect the current condition. Default messages for common conditions are set using the following properties:

  • StatusTextUploading - displayed during an upload operation
  • StatusTextComplete - displayed when all files are uploaded successfully
  • StatusTextFailed - displayed when one or more files fail to upload
  • StatusTextCancelled - displayed when an upload operation is cancelled client

Additionally, within any UploadManager event, if the StatusText property is set, the new value will be reflected in the browser. This is especially useful if you wish to display custom progress information.

Progress Bars

When a file begins uploading to the server, a new ProgressBar will be added to the ProgressPanel below the Status Text. The ProgressBar can be customized to take on a wide variety of appearances, including the use of images for background and foreground.

Cancel Button

If set to visible, the ProgressPanel Cancel button will be active during an upload operation and inactive at other times. Clicking the Cancel button interrupts the upload operation immediately. If a file upload is cancelled, any file data written to the server file system will remain. Handling the UploadCancelled event is a perfect opportunity to clean up temporary or incomplete files.

Setting the CancelButtonImageUrl and CancelButtonDisabledImageUrl properties will cause the Cancel button to use images instead of a standard Button control.

Upload Statistics

Various upload statistics are displayed during an upload operation below the Progress Bars and Cancel button. These statistics can be hidden or shown using the ShowFileCount, ShowUploadBytes, ShowUploadSpeed, ShowUploadTime properties.

Closing the ProgressPanel

When an upload operation completes or is cancelled, and the CloseBehavior property is set to AutoCloseOnComplete, the ProgressPanel will automatically close itself. If CloseBehavior is set to ManualCloseOnComplete, a "close" link is displayed to allow the user to close the ProgressPanel manually. If CloseBehavior is set to None, the panel will not close automatically and will not show the "close" link, but may still be closed within an UploadManager event using the Hide method.

See Also

Using the Upload Control | Using the UploadManager Control | Using the OpenFileDialog Control | Streaming File Data | Frequently Asked Questions | Reference

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Advanced: Streaming File Data During an Upload

A unique feature of PowerWEB File Upload is the ability to interact with and process file data during an upload operation. While not necessarily a feature that all users require, it makes possible solutions that perform tasks such as providing a seamless upload from client browser to a destination FTP server.

By default, the UploadManager is configured to stream file bytes directly to the server file system. This greatly reduces server overhead and limits the memory utilization to a small 50K buffer for each in-progress file upload. Traditional HTTP upload methods require that the entire file be loaded into server memory before it is made available to the ASP.NET page cycle.

If you handle the UploadProgress event, the UploadProgressEventArgs expose a Data property. This property is a byte array containing all bytes for a given file since the last UploadProgress event was fired. Once the byte array is accessed, it is removed from server memory so as to keep memory utilization to a minimum. Because it is possible for many files to use the same name, a UniqueID property is also exposed on the UploadProgressEventArgs to assist with synchronizing multiple uploads and reassembling byte arrays.

The following example code-behind demonstrates how to use these events and properties to directly place uploaded file data onto an open Stream. The full sample source code can be found in the sample project included with PowerWEB File Upload:

[Visual Basic]
'Requires Imports Dart.PowerWEB.FileUpload

Private Sub UploadManager1_UploadProgress(ByVal sender As Object, ByVal e As UploadProgressEventArgs) _
        Handles UploadManager1.UploadProgress
    Dim filename As String = e.FileName
    Dim id As String = e.UniqueID
    Dim bw As New System.IO.BinaryWriter(GetStream(id, "STREAMED." + filename))
    bw.Write(e.Data)
End Sub

Private Sub UploadManager1_FileUploadComplete(ByVal sender As Object, ByVal e As FileUploadEventArgs) _
        Handles UploadManager1.UploadComplete
    Dim s As System.IO.Stream = GetStream(e.PostedFile.UniqueID, e.PostedFile.FileName)
    If (Not s Is Nothing) Then s.Close()
End Sub

Private Function GetStream(ByVal id As String, ByVal filename As String) As System.IO.Stream
    Dim s As System.IO.Stream = CType(Session(ID), System.IO.Stream)
    If (s Is Nothing) Then
        s = New IO.FileStream(Server.MapPath("uploaded_files/" + filename), IO.FileMode.Create, _
                IO.FileAccess.ReadWrite, IO.FileShare.Read)
        Session(ID) = s
    End If
    Return s
End Function

[C#]
private void UploadManager1_UploadProgress(object sender, Dart.PowerWEB.FileUpload.UploadProgressEventArgs e)
{
    string filename = e.FileName;
    string id = e.UniqueID;
    System.IO.BinaryWriter bw = new System.IO.BinaryWriter(GetStream(id,"STREAMED." + filename));
    bw.Write(e.Data);
}

private void UploadManager1_FileUploadComplete(object sender, Dart.PowerWEB.FileUpload.FileUploadEventArgs e)
{
    System.IO.Stream s = GetStream(e.PostedFile.UniqueID,e.PostedFile.FileName);
    if (s != null) s.Close();
}

private System.IO.Stream GetStream(string id, string filename)
{
    System.IO.Stream s = (System.IO.Stream)Session[id];
    if (s == null)
    {
        s = new System.IO.FileStream(Server.MapPath("uploaded_files/" + filename), System.IO.FileMode.Create,
                System.IO.FileAccess.ReadWrite, System.IO.FileShare.Read);
        Session[id] = s;
    }
    return s;
}

See Also

Using the Upload Control | Using the UploadManager Control | Using the OpenFileDialog Control | Using the ProgressPanel Control | Frequently Asked Questions | Reference

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Frequently Asked Questions

Q: Can I change the look and feel of an Upload control or Progress Panel?
A: Yes! The Upload control exposes many Appearance properties that allow you to manipulate the look of the "browse" button and textbox. You can even use custom images so the Upload control can match your website design. The ProgressPanel can be extensively modified so that text, progress bars, and the cancel button are independently modified. At runtime you can even issue custom status messages so reporting progress to your end users is tailored to your application.

Q: Does File Upload use much server memory?
A: PowerWEB File Upload was designed to use very little server memory during a file upload operation. Typical HTTP file uploads using ASP.NET require the entire file get loaded into server memory before the page cycle is started. By default, File Upload is configured to stream files directly to disk, using only a small 50K memory buffer during the upload. However, if you choose to stream files to memory you can configure File Upload to do so. Using this method, you can periodically place uploaded bytes onto an open stream, effectively uploading file data from a client browser directly to a destination Stream object.
Q: I am using File Upload with my own custom HTTPModule and it no longer functions. Why is this?
A: In order to handle realtime upload progress as well as highly efficient streaming operations, PowerWEB File Upload uses an HttpModule to intercept file upload posts. This HttpModule must be registered first in your application's Web.Config file to allow it to handle file data before other modules interact with the HTTP Request. As long as the FileUploadModule is first in the list of registered HttpModules, your custom HttpModule should function properly and not interfere with the operation of File Upload.
Q: Is it possible to upload multiple files at the same time?
A: While PowerWEB File Upload allows for uploading multiple files within a single action, it is limited to physically posting one file at a time. While the product could have been designed to post files in parallel, the current web browser standards dictate that only two open connections should be maintained between a client and a server. File Upload uses one connection for uploading a file and another for polling the server for progress statistics.
Q: How do I handle exceptions that occur during a file upload, or during multiple file uploads?
A: Because of the asynchronous nature of uploading files with PowerWEB File Upload for ASP.NET, and because you may choose to continue with an upload process if one file within a group fails, exception handling is done through events on the UploadManager control.
The UploadManager control exposes a FileUploadFailed event that is fired once for each file that fails during an upload operation. The event has a single argument of type FileUploadExceptionEventArgs containing an FailedUpload field which describes the underlying exception as well as know details of the failed file.

See Also

Using the Upload Control | Using the UploadManager Control | Using the OpenFileDialog Control | Using the ProgressPanel Control | Streaming File Data | Reference

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Reference

PowerWEB File Upload for ASP.NET Reference

This section contains reference documentation for all of the objects and classes that comprise PowerWEB File Upload for ASP.NET. This section is intended solely for use as a class reference guide for use while building an application. It is not intended to give a "walkthrough" type description of usage. For a description of this type, see the higher-level topics.

In This Section

Dart.PowerWEB File Upload Namespace
Contains classes that support and enable integration of File Upload in .NET.

Related Sections

Getting Started
Provides an overview of PowerWEB File Upload for ASP.NET and discusses such topics as distribution, licensing, and support.
Using the File Upload Controls
Discusses how to use the File Upload controls in your project.
Samples
Describes the samples that are installed with PowerWEB File Upload for ASP.NET.

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


Dart.PowerWEB.FileUpload

Dart.PowerWEB.FileUpload Namespace

Namespace hierarchy

Classes

Class | Description
BaseStreamingModule | Summary description for SharedModule.
ButtonStyle |
CallbackManager | This class is not meant to be used by developers. It is the HTTPModule that coordinates and manages asynchronous callbacks.
CancelButtonStyle | Gets a System.Web.UI.WebControls.Style object representing the style that will be applied to the Cancel button.
FileUploadEventArgs | Provides data for the FileUploadComplete event.
FileUploadExceptionEventArgs | Provides data for the FileUploadFailed event.
FileUploadModule | This class is not meant to be used by developers.
KeyEventArgs | Provides data for the KeyDown, KeyPress or KeyUp event.
LocationEventArgs | Provides location data for any events that occur when a user clicks on a PowerWEB control.
OpenFileDialog | A dialog control for uploading files that can be attached to any web control on a form.
PostedFile | Information concerning a posted file, including its name, size and path.
ProgBarStyle | Gets a System.Web.UI.WebControls.Style object representing the style that will be applied to the progress bar.
ProgressPanel | A control for showing the progress of file transfers during an upload operation.
ResourceHttpHandler | Summary description for ResourceHttpHandler.
StatusStyle | Gets a System.Web.UI.WebControls.Style object representing the style that will be applied to the Status bar.
TextBoxStyle |
Upload | An enhanced control for uploading files to the server.
UploadCompleteEventArgs | Provides data for the UploadComplete event.
UploadException | An UploadException occurs when there is an error during an upload.
UploadManager | A control used to manage page-level file upload behavior.
UploadProgressEventArgs | Provides data for the UploadProgress event.

Interfaces

Interface | Description
ILiveControl | Provides an interface for PowerWEB controls.

Delegates

Delegate | Description
FileUploadEventHandler | The delegate used for the FileUploadComplete event.
FileUploadExceptionEventHandler | The delegate used for the FileUploadFailed event.
KeyEventHandler | The delegate for the Key event.
LocationEventHandler | The delegate for events that require location information.
UploadCompleteEventHandler | The delegate used for the UploadComplete event.
UploadProgressEventHandler | The delegate used for the UploadProgress event.

Enumerations

Enumeration | Description
BrowserType | Enumerates values which describe the Web browser in use.
ButtonAlign | Gets or sets the horizontal alignment of the button.
ButtonType | Specifies the button types for the Upload control.
CallbackType | Enumerates values which describe the type of callback mechanism in use.
CloseBehavior | Gets or sets the behavior of the progress panel after a file upload operation.
ErrorBehavior | Enumerates values which describe the behavior when an error condition occurs.
UploadType | The global type of upload method to use.
ViewStateCacheType |

Syntax based on .NET Framework version 1.1.
Documentation version 1.0.0.0.


BaseStreamingModule Class

Summary description for SharedModule.

For a list of all members of this type, see BaseStreamingModule Members.

System.Object
Dart.PowerWEB.FileUpload.BaseStreamingModule
Dart.PowerWEB.FileUpload.FileUploadModule

[Visual Basic]
MustInherit Public Class BaseStreamingModule
    Implements IHttpModule
[C#]
public abstract class BaseStreamingModule : IHttpModule
[C++]
public __gc __abstract class BaseStreamingModule : public IHttpModule
[JScript]
public  class BaseStreamingModule extends IHttpModule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

BaseStreamingModule Members | Dart.PowerWEB.FileUpload Namespace


BaseStreamingModule Members

BaseStreamingModule overview

Public Instance Constructors

BaseStreamingModule Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BaseStreamingModule Class | Dart.PowerWEB.FileUpload Namespace


BaseStreamingModule Constructor

[Visual Basic]
Public Sub New()
[C#]
public BaseStreamingModule();
[C++]
public: BaseStreamingModule();
[JScript]
public function BaseStreamingModule();

See Also

BaseStreamingModule Class | Dart.PowerWEB.FileUpload Namespace


BrowserType Enumeration

Enumerates values which describe the Web browser in use.

[Visual Basic]
Public Enum BrowserType
[C#]
public enum BrowserType
[C++]
public __value enum BrowserType
[JScript]
public enum BrowserType

Remarks

This enumeration is used by the BrowserType property.

Members

Member Name | Description
NotSet | The Web browser is not set.
Unsupported | An unsupported Web browser.
IE | The Internet Explorer Web browser.
Mozilla | The Mozilla Web browser.
IE5 | The Internet Explorer 5 Web browser.
IE5Mac | The Internet Explorer Web browser for Mac.
Opera | The Opera Web browser.
Konqueror | The Konqueror Web browser.
Galeon | The Galeon Web browser.
Netscape6 | Netscape 6, which requires special handling seperate than Netscape 7.
Safari | The Mac Safari Web browser.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


ButtonAlign Enumeration

Gets or sets the horizontal alignment of the button.

[Visual Basic]
Public Enum ButtonAlign
[C#]
public enum ButtonAlign
[C++]
public __value enum ButtonAlign
[JScript]
public enum ButtonAlign

Members

Member Name | Description
Left | The button is aligned to the left.
Right | The button is aligned to the right.
Center | The button is aligned to the center.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


ButtonStyle Class

For a list of all members of this type, see ButtonStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.FileUpload.ButtonStyle

[Visual Basic]
Public Class ButtonStyle
    Inherits Style
[C#]
public class ButtonStyle : Style
[C++]
public __gc class ButtonStyle : public Style
[JScript]
public class ButtonStyle extends Style

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

ButtonStyle Members | Dart.PowerWEB.FileUpload Namespace


ButtonStyle Members

ButtonStyle overview

Public Instance Constructors

ButtonStyle Constructor

Public Instance Properties

BackColor (inherited from Style) | Gets or sets the background color of the Web server control.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass | This property is not implemented for this class - configuration of control's visual elements must be done directly to ensure proper behavior at runtime.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from Style) | Gets or sets the width of the Web server control.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
CopyFrom (inherited from Style) | Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith (inherited from Style) | Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset (inherited from Style) | Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overridden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

ButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


ButtonStyle Constructor

[Visual Basic]
Public Sub New()
[C#]
public ButtonStyle();
[C++]
public: ButtonStyle();
[JScript]
public function ButtonStyle();

See Also

ButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


ButtonStyle Properties

The properties of the ButtonStyle class are listed below. For a complete list of ButtonStyle class members, see the ButtonStyle Members topic.

Public Instance Properties

BackColor (inherited from Style) | Gets or sets the background color of the Web server control.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass | This property is not implemented for this class - configuration of control's visual elements must be done directly to ensure proper behavior at runtime.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from Style) | Gets or sets the width of the Web server control.

See Also

ButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


CssClass Property

ButtonStyle.CssClass Property

This property is not implemented for this class - configuration of control's visual elements must be done directly to ensure proper behavior at runtime.

[Visual Basic]
Public Property CssClass As String
[C#]
public string CssClass { get; set; }
[C++]
public: __property String* get_CssClass();
public: __property void set_CssClass(String* );
[JScript]
public function get CssClass() : String
public function set CssClass(String);

See Also

ButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


ButtonType Enumeration

Specifies the button types for the Upload control.

[Visual Basic]
Public Enum ButtonType
[C#]
public enum ButtonType
[C++]
public __value enum ButtonType
[JScript]
public enum ButtonType

Remarks

Set ButtonImageUrl when using an ImageButton.

Members

Member Name | Description
LinkButton | The button is a LinkButton.
PushButton | The button is a PushButton.
ImageButton | The button is an ImageButton.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


CallbackManager Class

This class is not meant to be used by developers. It is the HTTPModule that coordinates and manages asynchronous callbacks.

For a list of all members of this type, see CallbackManager Members.

System.Object
Dart.PowerWEB.FileUpload.CallbackManager

[Visual Basic]
Public Class CallbackManager
    Implements IHttpModule
[C#]
public class CallbackManager : IHttpModule
[C++]
public __gc class CallbackManager : public IHttpModule
[JScript]
public class CallbackManager extends IHttpModule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

CallbackManager Members | Dart.PowerWEB.FileUpload Namespace


CallbackManager Members

CallbackManager overview

Public Instance Constructors

CallbackManager Constructor

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CallbackManager Class | Dart.PowerWEB.FileUpload Namespace


CallbackManager Constructor

[Visual Basic]
Public Sub New()
[C#]
public CallbackManager();
[C++]
public: CallbackManager();
[JScript]
public function CallbackManager();

See Also

CallbackManager Class | Dart.PowerWEB.FileUpload Namespace


CallbackManager Methods

The methods of the CallbackManager class are listed below. For a complete list of CallbackManager class members, see the CallbackManager Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CallbackManager Class | Dart.PowerWEB.FileUpload Namespace


Dispose Method

CallbackManager.Dispose Method

[Visual Basic]
Public Sub Dispose() _
    Implements IHttpModule.Dispose
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

Implements

IHttpModule.Dispose

See Also

CallbackManager Class | Dart.PowerWEB.FileUpload Namespace


Init Method

CallbackManager.Init Method

[Visual Basic]
Public Sub Init( _
   ByVal context As HttpApplication _
) _
    Implements IHttpModule.Init
[C#]
public void Init(
   HttpApplication context
);
[C++]
public: void Init(
   HttpApplication* context
);
[JScript]
public function Init(
   HttpApplication context
);

Parameters

context

Implements

IHttpModule.Init

See Also

CallbackManager Class | Dart.PowerWEB.FileUpload Namespace


CallbackType Enumeration

Enumerates values which describe the type of callback mechanism in use.

[Visual Basic]
Public Enum CallbackType
[C#]
public enum CallbackType
[C++]
public __value enum CallbackType
[JScript]
public enum CallbackType

Remarks

This enumeration is used by the Callback property.

Members

Member Name | Description
AutoDetect | The callback type to use is automatically detected.
XmlHttp | Callbacks performed with the XmlHttp object.
Flash | Callbacks performed with the Flash plugin.
IFrame | Callbacks performed with IFrame.
None | Postbacks are used in place of callbacks.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


CancelButtonStyle Class

Gets a System.Web.UI.WebControls.Style object representing the style that will be applied to the Cancel button.

For a list of all members of this type, see CancelButtonStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.FileUpload.CancelButtonStyle

[Visual Basic]
Public Class CancelButtonStyle
    Inherits Style
[C#]
public class CancelButtonStyle : Style
[C++]
public __gc class CancelButtonStyle : public Style
[JScript]
public class CancelButtonStyle extends Style

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

CancelButtonStyle Members | Dart.PowerWEB.FileUpload Namespace


CancelButtonStyle Members

CancelButtonStyle overview

Public Instance Constructors

CancelButtonStyle Overloaded. Initializes a new instance of the CancelButtonStyle class.

Public Instance Properties

BackColor (inherited from Style) | Gets or sets the background color of the Web server control.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
ButtonAlign | Gets or sets the horizontal alignment of the Cancel button.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from Style) | Gets or sets the CSS class rendered by the Web server control on the client.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Text | Text displayed on Cancel button.
Visible | Show or hide Cancel button.
Width (inherited from Style) | Gets or sets the width of the Web server control.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
CopyFrom (inherited from Style) | Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith (inherited from Style) | Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset (inherited from Style) | Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overridden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

CancelButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


CancelButtonStyle Constructor

Initializes a new instance of the CancelButtonStyle class.

Overload List

Initializes a new instance of the CancelButtonStyle class.

[Visual Basic] Public Sub New()
[C#] public CancelButtonStyle();
[C++] public: CancelButtonStyle();
[JScript] public function CancelButtonStyle();

Initializes a new instance of the CancelButtonStyle class with the specified state bag information.

[Visual Basic] Public Sub New(ByVal StateBag)
[C#] public CancelButtonStyle(StateBag);
[C++] public: CancelButtonStyle(StateBag*);
[JScript] public function CancelButtonStyle(StateBag);

See Also

CancelButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


CancelButtonStyle Constructor ()

Initializes a new instance of the CancelButtonStyle class.

[Visual Basic]
Public Sub New()
[C#]
public CancelButtonStyle();
[C++]
public: CancelButtonStyle();
[JScript]
public function CancelButtonStyle();

See Also

CancelButtonStyle Class | Dart.PowerWEB.FileUpload Namespace | CancelButtonStyle Constructor Overload List


CancelButtonStyle Constructor (StateBag)

Initializes a new instance of the CancelButtonStyle class with the specified state bag information.

[Visual Basic]
Public Sub New( _
   ByVal bag As StateBag _
)
[C#]
public CancelButtonStyle(
   StateBag bag
);
[C++]
public: CancelButtonStyle(
   StateBag* bag
);
[JScript]
public function CancelButtonStyle(
   StateBag bag
);

Parameters

bag
A System.Web.UI.StateBag that represents the state bag in which to store style information.

Remarks

Use this constructor to create a new instance of the CancelButtonStyle class using the System.Web.UI.StateBag specified by the bag parameter.

See Also

CancelButtonStyle Class | Dart.PowerWEB.FileUpload Namespace | CancelButtonStyle Constructor Overload List


CancelButtonStyle Properties

The properties of the CancelButtonStyle class are listed below. For a complete list of CancelButtonStyle class members, see the CancelButtonStyle Members topic.

Public Instance Properties

BackColor (inherited from Style) | Gets or sets the background color of the Web server control.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
ButtonAlign | Gets or sets the horizontal alignment of the Cancel button.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from Style) | Gets or sets the CSS class rendered by the Web server control on the client.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Text | Text displayed on Cancel button.
Visible | Show or hide Cancel button.
Width (inherited from Style) | Gets or sets the width of the Web server control.

See Also

CancelButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


ButtonAlign Property

CancelButtonStyle.ButtonAlign Property

Gets or sets the horizontal alignment of the Cancel button.

[Visual Basic]
Public Property ButtonAlign As ButtonAlign
[C#]
public ButtonAlign ButtonAlign { get; set; }
[C++]
public: __property ButtonAlign get_ButtonAlign();
public: __property void set_ButtonAlign(ButtonAlign );
[JScript]
public function get ButtonAlign() : ButtonAlign
public function set ButtonAlign(ButtonAlign);

See Also

CancelButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


Text Property

CancelButtonStyle.Text Property

Text displayed on Cancel button.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

The default value is an empty string.

See Also

CancelButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


Visible Property

CancelButtonStyle.Visible Property

Show or hide Cancel button.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible { get; set; }
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(bool );
[JScript]
public function get Visible() : bool
public function set Visible(bool);

Property Value

The default value is true.

See Also

CancelButtonStyle Class | Dart.PowerWEB.FileUpload Namespace


CloseBehavior Enumeration

Gets or sets the behavior of the progress panel after a file upload operation.

[Visual Basic]
Public Enum CloseBehavior
[C#]
public enum CloseBehavior
[C++]
public __value enum CloseBehavior
[JScript]
public enum CloseBehavior

Members

Member Name | Description
None | Remain open after upload completes or is cancelled.
ManualCloseOnComplete | Remain open after upload completes or is cancelled, but display a "close" button.
AutoCloseOnComplete | Automatically close after upload completes or is cancelled.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


ErrorBehavior Enumeration

Enumerates values which describe the behavior when an error condition occurs.

[Visual Basic]
Public Enum ErrorBehavior
[C#]
public enum ErrorBehavior
[C++]
public __value enum ErrorBehavior
[JScript]
public enum ErrorBehavior

Remarks

This enumeration is used by the ErrorBehavior property.

Members

Member Name | Description
ShowAlert | Show an alert box with the value of the ErrorMessage property.
ShowInBrowser | Show the exception in the browser.
Eat | Do not show the exception.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


FileUploadEventArgs Class

Provides data for the FileUploadComplete event.

For a list of all members of this type, see FileUploadEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.FileUpload.FileUploadEventArgs

[Visual Basic]
Public Class FileUploadEventArgs
    Inherits EventArgs
[C#]
public class FileUploadEventArgs : EventArgs
[C++]
public __gc class FileUploadEventArgs : public EventArgs
[JScript]
public class FileUploadEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

FileUploadEventArgs contains the PostedFile.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

FileUploadEventArgs Members | Dart.PowerWEB.FileUpload Namespace


FileUploadEventArgs Members

FileUploadEventArgs overview

Public Instance Constructors

FileUploadEventArgs Constructor Initializes a new instance of the FileUploadEventArgs class.

Public Instance Properties

PostedFile The PostedFile containing information about the uploaded file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileUploadEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FileUploadEventArgs Constructor

Initializes a new instance of the FileUploadEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal postedFile As PostedFile _
)
[C#]
public FileUploadEventArgs(
   PostedFile postedFile
);
[C++]
public: FileUploadEventArgs(
   PostedFile* postedFile
);
[JScript]
public function FileUploadEventArgs(
   PostedFile postedFile
);

See Also

FileUploadEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FileUploadEventArgs Properties

The properties of the FileUploadEventArgs class are listed below. For a complete list of FileUploadEventArgs class members, see the FileUploadEventArgs Members topic.

Public Instance Properties

PostedFile The PostedFile containing information about the uploaded file.

See Also

FileUploadEventArgs Class | Dart.PowerWEB.FileUpload Namespace


PostedFile Property

FileUploadEventArgs.PostedFile Property

The PostedFile containing information about the uploaded file.

[Visual Basic]
Public Property ReadOnly PostedFile As PostedFile
[C#]
public PostedFile PostedFile { get; }
[C++]
public: __property PostedFile* get_PostedFile();
[JScript]
public function get PostedFile() : PostedFile

See Also

FileUploadEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FileUploadEventHandler Delegate

The delegate used for the FileUploadComplete event.

[Visual Basic]
Public Delegate Function Sub  FileUploadEventHandler( _
   ByVal sender As Object, _
   ByVal e As FileUploadEventArgs _
)
[C#]
public delegate void FileUploadEventHandler(
   object sender,
   FileUploadEventArgs e
)
[C++]
public __gc __delegate void FileUploadEventHandler(
   Object* sender,
   FileUploadEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


FileUploadExceptionEventArgs Class

Provides data for the FileUploadFailed event.

For a list of all members of this type, see FileUploadExceptionEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.FileUpload.FileUploadExceptionEventArgs

[Visual Basic]
Public Class FileUploadExceptionEventArgs
    Inherits EventArgs
[C#]
public class FileUploadExceptionEventArgs : EventArgs
[C++]
public __gc class FileUploadExceptionEventArgs : public EventArgs
[JScript]
public class FileUploadExceptionEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

FileUploadExceptionEventArgs contains the UploadException that occurred.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

FileUploadExceptionEventArgs Members | Dart.PowerWEB.FileUpload Namespace


FileUploadExceptionEventArgs Members

FileUploadExceptionEventArgs overview

Public Instance Constructors

FileUploadExceptionEventArgs Constructor Initializes a new instance of the FileUploadExceptionEventArgs class.

Public Instance Properties

FailedUpload The UploadException that caused the failure.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileUploadExceptionEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FileUploadExceptionEventArgs Constructor

Initializes a new instance of the FileUploadExceptionEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal failedUpload As UploadException _
)
[C#]
public FileUploadExceptionEventArgs(
   UploadException failedUpload
);
[C++]
public: FileUploadExceptionEventArgs(
   UploadException* failedUpload
);
[JScript]
public function FileUploadExceptionEventArgs(
   UploadException failedUpload
);

See Also

FileUploadExceptionEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FileUploadExceptionEventArgs Properties

The properties of the FileUploadExceptionEventArgs class are listed below. For a complete list of FileUploadExceptionEventArgs class members, see the FileUploadExceptionEventArgs Members topic.

Public Instance Properties

FailedUpload The UploadException that caused the failure.

See Also

FileUploadExceptionEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FailedUpload Property

FileUploadExceptionEventArgs.FailedUpload Property

The UploadException that caused the failure.

[Visual Basic]
Public Property ReadOnly FailedUpload As UploadException
[C#]
public UploadException FailedUpload { get; }
[C++]
public: __property UploadException* get_FailedUpload();
[JScript]
public function get FailedUpload() : UploadException

See Also

FileUploadExceptionEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FileUploadExceptionEventHandler Delegate

The delegate used for the FileUploadFailed event.

[Visual Basic]
Public Delegate Function Sub  FileUploadExceptionEventHandler( _
   ByVal sender As Object, _
   ByVal e As FileUploadExceptionEventArgs _
)
[C#]
public delegate void FileUploadExceptionEventHandler(
   object sender,
   FileUploadExceptionEventArgs e
)
[C++]
public __gc __delegate void FileUploadExceptionEventHandler(
   Object* sender,
   FileUploadExceptionEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


FileUploadModule Class

This class is not meant to be used by developers.

For a list of all members of this type, see FileUploadModule Members.

System.Object
Dart.PowerWEB.FileUpload.BaseStreamingModule
Dart.PowerWEB.FileUpload.FileUploadModule

[Visual Basic]
Public Class FileUploadModule
    Inherits BaseStreamingModule
[C#]
public class FileUploadModule : BaseStreamingModule
[C++]
public __gc class FileUploadModule : public BaseStreamingModule
[JScript]
public class FileUploadModule extends BaseStreamingModule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

FileUploadModule Members | Dart.PowerWEB.FileUpload Namespace


FileUploadModule Members

FileUploadModule overview

Public Instance Constructors

FileUploadModule Constructor

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileUploadModule Class | Dart.PowerWEB.FileUpload Namespace


FileUploadModule Constructor

[Visual Basic]
Public Sub New()
[C#]
public FileUploadModule();
[C++]
public: FileUploadModule();
[JScript]
public function FileUploadModule();

See Also

FileUploadModule Class | Dart.PowerWEB.FileUpload Namespace


ILiveControl Interface

Provides an interface for PowerWEB controls.

For a list of all members of this type, see ILiveControl Members.

[Visual Basic]
Public Interface ILiveControl
[C#]
public interface ILiveControl
[C++]
public __gc __interface ILiveControl
[JScript]
public interface ILiveControl

Types that implement ILiveControl

Type | Description
OpenFileDialog | A dialog control for uploading files that can be attached to any web control on a form.
ProgressPanel | A control for showing the progress of file transfers during an upload operation.
Upload | An enhanced control for uploading files to the server.

Remarks

Implementing this interface enables a designer to add Live capabilities to a server control.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

ILiveControl Members | Dart.PowerWEB.FileUpload Namespace


ILiveControl Members

ILiveControl overview

Public Instance Properties

BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
DynamicValidation | Use to inject validation code into the initial Page render.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
Tag | Gets or sets a convertible object that contains data about the control.

Public Instance Methods

GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetViewState | Returns the ViewState object used to save and restore state.
Refresh | In a callback, updates the controls client-side representation.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


ILiveControl Properties

The properties of the ILiveControl interface are listed below. For a complete list of ILiveControl interface members, see the ILiveControl Members topic.

Public Instance Properties

BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
DynamicValidation | Use to inject validation code into the initial Page render.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
Tag | Gets or sets a convertible object that contains data about the control.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


BrowserType Property

ILiveControl.BrowserType Property

Gets or sets the type of browser as detected by the PowerWEB control.

[Visual Basic]
Property BrowserType As BrowserType
[C#]
BrowserType BrowserType { get; set; }
[C++]
__property BrowserType get_BrowserType();
__property void set_BrowserType(BrowserType );
[JScript]
function get BrowserType() : BrowserType
function set BrowserType(BrowserType);

Property Value

A BrowserType that represents the browser rendering the PowerWEB control.

Remarks

This property is set when the PowerWEB control is initialized, based on the user-agent header sent by the browser. BrowserType can also be set to override the detected value with a custom browser detection algorithm.

Note This property is global to all PowerWEB controls. Any change to an individual PowerWEB control will automatically be applied to all PowerWEB controls on the form. It is not possible to have PowerWEB controls with different BrowserType values on the same form.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


BufferedScript Property

ILiveControl.BufferedScript Property

Gets the client-side script which will be written to the response stream when the callback request is ended.

[Visual Basic]
Property ReadOnly BufferedScript As StringWriter
[C#]
StringWriter BufferedScript { get; }
[C++]
__property StringWriter* get_BufferedScript();
[JScript]
function get BufferedScript() : StringWriter

Property Value

A StringWriter object that contains buffered script for a callback response.

Remarks

Use the BufferedScript property to modify the client-side script to be sent in response to a callback.

For example, to dynamically change the flow of a label (from bottom to top instead of left to right):

LiveLabel1.BufferedScript.Write(LiveLabel1.GetScriptStyleReference() + ".writingMode = 'tb-rl';");

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


CallbackType Property

ILiveControl.CallbackType Property

Gets or sets the type of callbacks performed by the PowerWEB control.

[Visual Basic]
Property CallbackType As CallbackType
[C#]
CallbackType CallbackType { get; set; }
[C++]
__property CallbackType get_CallbackType();
__property void set_CallbackType(CallbackType );
[JScript]
function get CallbackType() : CallbackType
function set CallbackType(CallbackType);

Property Value

A CallbackType that represents the mechanism used for callbacks by the PowerWEB control.

Remarks

The optimal approach is CallbackType.XmlHttp. The first fallback approach is CallbackType.Flash. The final fallback is CallbackType.IFrame.

Defaults to CallbackType.AutoDetect. On the initial page load, CallbackType is set to the most appropriate value based on the browser type detected.

Set to override when auto-detection is insufficient. For example, if the browser has ActiveX turned off, XmlHttp and Flash will fail. However, the PowerWEB controls will not be aware of this, because this setting cannot be detected server-side. A developer can determine if ActiveX is off and set to IFRAME to provide a decent callback approach.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


Debug Property

ILiveControl.Debug Property

Set to true to display a debug window which displays callback data in real-time as it is set/received.

[Visual Basic]
Property Debug As Boolean
[C#]
bool Debug { get; set; }
[C++]
__property bool get_Debug();
__property void set_Debug(bool );
[JScript]
function get Debug() : bool
function set Debug(bool);

Property Value

true if a debug window is displayed when callback data is sent/received; false otherwise. The default value is false;

Remarks

This property is intended to be used by application developers to assist in diagnosis of application bugs. Set this property to true to see the JavaScript that is executed on the client-side as a result of the server-side interaction with the controls.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


DynamicValidation Property

ILiveControl.DynamicValidation Property

Use to inject validation code into the initial Page render.

[Visual Basic]
Property DynamicValidation As Boolean
[C#]
bool DynamicValidation { get; set; }
[C++]
__property bool get_DynamicValidation();
__property void set_DynamicValidation(bool );
[JScript]
function get DynamicValidation() : bool
function set DynamicValidation(bool);

Property Value

A bool determining whether or not validation code is rendered in initial Page load. The default value is false.

Remarks

Note, most scenarios do not require this property. Use this property only if (1) a control requiring validation is going to be created in a callback and (2) no other controls requiring validation are present on initial page load.

If a control requires validation, the code to perform this validation is set up in initial page load. This code includes a reference to an external script file, and a script block. However, if no control requiring validation is present on initial page load, but is created in a subsequent callback, validation is skipped because the validation script was not properly set up. Set this property to true on initial page load to create the validation script which can be used by any control created in subsequent callbacks.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


IsCallback Property

ILiveControl.IsCallback Property

Gets the callback state of the PowerWEB control.

[Visual Basic]
Property IsCallback As Boolean
[C#]
bool IsCallback { get; set; }
[C++]
__property bool get_IsCallback();
__property void set_IsCallback(bool );
[JScript]
function get IsCallback() : bool
function set IsCallback(bool);

Property Value

true if the PowerWEB control is currently in a callback state, false otherwise.

Remarks

Use the IsCallback property to differentiate between a postback and live callback.

Note This property is global to all PowerWEB controls.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


IsLive Property

ILiveControl.IsLive Property

Gets or sets whether a PowerWEB control updates itself in a callback.

[Visual Basic]
Property IsLive As Boolean
[C#]
bool IsLive { get; set; }
[C++]
__property bool get_IsLive();
__property void set_IsLive(bool );
[JScript]
function get IsLive() : bool
function set IsLive(bool);

Property Value

true if the PowerWEB control should update itself during a callback, false otherwise.

Remarks

Defaults to true. Set the IsLive property to false to prevent the PowerWEB control from updating itself during a callback, even if it is changed in code behind.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


Tag Property

ILiveControl.Tag Property

Gets or sets a convertible object that contains data about the control.

[Visual Basic]
Property Tag As Object
[C#]
object Tag { get; set; }
[C++]
__property Object* get_Tag();
__property void set_Tag(Object* );
[JScript]
function get Tag() : Object
function set Tag(Object);

Property Value

An object that implements the IConvertible interface and contains data about the PowerWEB control. The default is a null reference (Nothing in Visual Basic).

Remarks

Any type that implements IConvertible can be assigned to this property. If the Tag property is set through the Windows Forms designer, only text can be assigned.

Data contained within the Tag property persists across callbacks. A common use for the Tag property is to store data that is closely associated with the control.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


ILiveControl Methods

The methods of the ILiveControl interface are listed below. For a complete list of ILiveControl interface members, see the ILiveControl Members topic.

Public Instance Methods

GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetViewState | Returns the ViewState object used to save and restore state.
Refresh | In a callback, updates the controls client-side representation.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


GetScript Method

ILiveControl.GetScript Method

Returns all JavaScript buffered up as a result of setting control properties.

[Visual Basic]
Function GetScript() As String
[C#]
string GetScript();
[C++]
String* GetScript();
[JScript]
function GetScript(): String;

Remarks

Returns all JavaScript buffered up as a result of setting properties of controls on the form.

Note This is not intended for use by end-users.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


GetScriptObjectReference Method

ILiveControl.GetScriptObjectReference Method

Returns a client-side reference to the element.

[Visual Basic]
Function GetScriptObjectReference() As String
[C#]
string GetScriptObjectReference();
[C++]
String* GetScriptObjectReference();
[JScript]
function GetScriptObjectReference(): String;

Remarks

Returns a client-side reference to the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1")" (depending on the browser).

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


GetScriptStyleReference Method

ILiveControl.GetScriptStyleReference Method

Returns a client-side reference to the style object of the element.

[Visual Basic]
Function GetScriptStyleReference() As String
[C#]
string GetScriptStyleReference();
[C++]
String* GetScriptStyleReference();
[JScript]
function GetScriptStyleReference(): String;

Remarks

Returns a client-side reference to the style object of the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1").style" (depending on the browser).

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


GetViewState Method

ILiveControl.GetViewState Method

Returns the ViewState object used to save and restore state.

[Visual Basic]
Function GetViewState() As Object
[C#]
object GetViewState();
[C++]
Object* GetViewState();
[JScript]
function GetViewState(): Object;

Remarks

Returns the ViewState object used by PowerWEB controls to save and restore state.

Note This is not intended for use by end-users.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


Refresh Method

ILiveControl.Refresh Method

In a callback, updates the controls client-side representation.

[Visual Basic]
Sub Refresh()
[C#]
void Refresh();
[C++]
void Refresh();
[JScript]
function Refresh();

Remarks

When the request is an incoming callback, this method forces the control to update itself client-side (whether a change was detected within the control or not).

When the request is not an Ajax callback, this method has no effect.

See Also

ILiveControl Interface | Dart.PowerWEB.FileUpload Namespace


KeyEventArgs Class

Provides data for the KeyDown, KeyPress or KeyUp event.

For a list of all members of this type, see KeyEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.FileUpload.KeyEventArgs

[Visual Basic]
Public Class KeyEventArgs
    Inherits EventArgs
[C#]
public class KeyEventArgs : EventArgs
[C++]
public __gc class KeyEventArgs : public EventArgs
[JScript]
public class KeyEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A KeyEventArgs, which specifies the key the user pressed and whether any modifier keys (CTRL, ALT, and SHIFT) were pressed at the same time, is passed with each KeyDown, KeyPress or KeyUp event.

The KeyDown event occurs when the user presses any key. The KeyUp event occurs when the user releases the key. Duplicate KeyDown events occur each time the key repeats, if the key is held down, but only one KeyUp event is generated when the user releases the key. The KeyPress event also occurs when a key is depressed.

For information about the event model, see Events and Delegates.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

KeyEventArgs Members | Dart.PowerWEB.FileUpload Namespace


KeyEventArgs Members

KeyEventArgs overview

Public Instance Constructors

KeyEventArgs Overloaded. Initializes a new instance of the KeyEventArgs class.

Public Instance Properties

Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

KeyEventArgs Class | Dart.PowerWEB.FileUpload Namespace


KeyEventArgs Constructor

Initializes a new instance of KeyEventArgs.

Overload List

Initializes a new instance of KeyEventArgs.

[Visual Basic] Public Sub New()
[C#] public KeyEventArgs();
[C++] public: KeyEventArgs();
[JScript] public function KeyEventArgs();

Initializes a new instance of KeyEventArgs.

[Visual Basic] Public Sub New(ByVal Integer,ByVal Boolean,ByVal Boolean,ByVal Boolean)
[C#] public KeyEventArgs(int,bool,bool,bool);
[C++] public: KeyEventArgs(int,bool,bool,bool);
[JScript] public function KeyEventArgs(int,bool,bool,bool);

See Also

KeyEventArgs Class | Dart.PowerWEB.FileUpload Namespace


KeyEventArgs Constructor ()

Initializes a new instance of KeyEventArgs.

[Visual Basic]
Public Sub New()
[C#]
public KeyEventArgs();
[C++]
public: KeyEventArgs();
[JScript]
public function KeyEventArgs();

Remarks

The default constructor initializes a new instance of KeyEventArgs.

See Also

KeyEventArgs Class | Dart.PowerWEB.FileUpload Namespace | KeyEventArgs Constructor Overload List


KeyEventArgs Constructor (Int32, Boolean, Boolean, Boolean)

Initializes a new instance of KeyEventArgs.

[Visual Basic]
Public Sub New( _
   ByVal keyCode As Integer, _
   ByVal alt As Boolean, _
   ByVal control As Boolean, _
   ByVal shift As Boolean _
)
[C#]
public KeyEventArgs(
   int keyCode,
   bool alt,
   bool control,
   bool shift
);
[C++]
public: KeyEventArgs(
   int keyCode,
   bool alt,
   bool control,
   bool shift
);
[JScript]
public function KeyEventArgs(
   int keyCode,
   bool alt,
   bool control,
   bool shift
);

Remarks

The constructor initializes a new instance of KeyEventArgs with KeyCode, Alt, Control, Shift.

See Also

KeyEventArgs Class | Dart.PowerWEB.FileUpload Namespace | KeyEventArgs Constructor Overload List


KeyEventArgs Properties

The properties of the KeyEventArgs class are listed below. For a complete list of KeyEventArgs class members, see the KeyEventArgs Members topic.

Public Instance Properties

Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

See Also

KeyEventArgs Class | Dart.PowerWEB.FileUpload Namespace


Alt Property

KeyEventArgs.Alt Property

Gets a value indicating whether the ALT key was pressed.

[Visual Basic]
Public Property Alt As Boolean
[C#]
public bool Alt { get; set; }
[C++]
public: __property bool get_Alt();
public: __property void set_Alt(bool );
[JScript]
public function get Alt() : bool
public function set Alt(bool);

Property Value

true if the ALT key was pressed; otherwise, false.

Remarks

Use this property to determine if the ALT key was pressed during the PowerWEB control event.

See Also

KeyEventArgs Class | Dart.PowerWEB.FileUpload Namespace


Control Property

KeyEventArgs.Control Property

Gets a value indicating whether the CTRL key was pressed.

[Visual Basic]
Public Property Control As Boolean
[C#]
public bool Control { get; set; }
[C++]
public: __property bool get_Control();
public: __property void set_Control(bool );
[JScript]
public function get Control() : bool
public function set Control(bool);

Property Value

true if the CTRL key was pressed; otherwise, false.

Remarks

Use this property to determine if the CTRL key was pressed during the PowerWEB control event.

See Also

KeyEventArgs Class | Dart.PowerWEB.FileUpload Namespace


KeyCode Property

KeyEventArgs.KeyCode Property

Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.

[Visual Basic]
Public Property KeyCode As Integer
[C#]
public int KeyCode { get; set; }
[C++]
public: __property int get_KeyCode();
public: __property void set_KeyCode(int );
[JScript]
public function get KeyCode() : int
public function set KeyCode(int);

Property Value

A Keys value that is the key code for the event.

Remarks

Use this property to determine the key corresponding to PowerWEB control event.

See Also

KeyEventArgs Class | Dart.PowerWEB.FileUpload Namespace


Shift Property

KeyEventArgs.Shift Property

Gets a value indicating whether the SHIFT key was pressed.

[Visual Basic]
Public Property Shift As Boolean
[C#]
public bool Shift { get; set; }
[C++]
public: __property bool get_Shift();
public: __property void set_Shift(bool );
[JScript]
public function get Shift() : bool
public function set Shift(bool);

Property Value

true if the SHIFT key was pressed; otherwise, false.

Remarks

Use this property to determine if the SHIFT key was pressed during the PowerWEB control event.

See Also

KeyEventArgs Class | Dart.PowerWEB.FileUpload Namespace


KeyEventHandler Delegate

The delegate for the Key event.

[Visual Basic]
Public Delegate Function Sub  KeyEventHandler( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
)
[C#]
public delegate void KeyEventHandler(
   object sender,
   KeyEventArgs e
)
[C++]
public __gc __delegate void KeyEventHandler(
   Object* sender,
   KeyEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


LocationEventArgs Class

Provides location data for any events that occur when a user clicks on a PowerWEB control.

For a list of all members of this type, see LocationEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.FileUpload.LocationEventArgs

[Visual Basic]
Public Class LocationEventArgs
    Inherits EventArgs
[C#]
public class LocationEventArgs : EventArgs
[C++]
public __gc class LocationEventArgs : public EventArgs
[JScript]
public class LocationEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class passes the location on the page where a user clicked a PowerWEB control as x and y coordinates. You can then use event handlers to programmatically respond to the event based on the value of these coordinates.

Note The origin coordinates (0,0) are located at the upper left corner of the WebForm.

Raising an event invokes the event handler through a delegate. For more information, see Raising an Event.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

LocationEventArgs Members | Dart.PowerWEB.FileUpload Namespace


LocationEventArgs Members

LocationEventArgs overview

Public Instance Constructors

LocationEventArgs Overloaded. Initializes a new instance of the LocationEventArgs class.

Public Instance Properties

X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LocationEventArgs Class | Dart.PowerWEB.FileUpload Namespace


LocationEventArgs Constructor

Initializes a new instance of LocationEventArgs.

Overload List

Initializes a new instance of LocationEventArgs.

[Visual Basic] Public Sub New()
[C#] public LocationEventArgs();
[C++] public: LocationEventArgs();
[JScript] public function LocationEventArgs();

Initializes a new instance of LocationEventArgs.

[Visual Basic] Public Sub New(ByVal Unit,ByVal Unit)
[C#] public LocationEventArgs(Unit,Unit);
[C++] public: LocationEventArgs(Unit,Unit);
[JScript] public function LocationEventArgs(Unit,Unit);

See Also

LocationEventArgs Class | Dart.PowerWEB.FileUpload Namespace


LocationEventArgs Constructor ()

Initializes a new instance of LocationEventArgs.

[Visual Basic]
Public Sub New()
[C#]
public LocationEventArgs();
[C++]
public: LocationEventArgs();
[JScript]
public function LocationEventArgs();

Remarks

The default constructor initializes a new instance of LocationEventArgs.

See Also

LocationEventArgs Class | Dart.PowerWEB.FileUpload Namespace | LocationEventArgs Constructor Overload List


LocationEventArgs Constructor (Unit, Unit)

Initializes a new instance of LocationEventArgs.

[Visual Basic]
Public Sub New( _
   ByVal x As Unit, _
   ByVal y As Unit _
)
[C#]
public LocationEventArgs(
   Unit x,
   Unit y
);
[C++]
public: LocationEventArgs(
   Unit x,
   Unit y
);
[JScript]
public function LocationEventArgs(
   Unit x,
   Unit y
);

Remarks

The constructor initializes a new instance of LocationEventArgs with (X, Y) coordinates.

See Also

LocationEventArgs Class | Dart.PowerWEB.FileUpload Namespace | LocationEventArgs Constructor Overload List


LocationEventArgs Properties

The properties of the LocationEventArgs class are listed below. For a complete list of LocationEventArgs class members, see the LocationEventArgs Members topic.

Public Instance Properties

X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

See Also

LocationEventArgs Class | Dart.PowerWEB.FileUpload Namespace


X Property

LocationEventArgs.X Property

Gets or sets the x-coordinate of the WebForm when the mouse is clicked.

[Visual Basic]
Public Property X As Unit
[C#]
public Unit X { get; set; }
[C++]
public: __property Unit get_X();
public: __property void set_X(Unit );
[JScript]
public function get X() : Unit
public function set X(Unit);

Property Value

A Unit corresponding to the x-coordinate of the mouse click.

Remarks

Use this property with Y to determine the location of the mouse click.

See Also

LocationEventArgs Class | Dart.PowerWEB.FileUpload Namespace


Y Property

LocationEventArgs.Y Property

Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

[Visual Basic]
Public Property Y As Unit
[C#]
public Unit Y { get; set; }
[C++]
public: __property Unit get_Y();
public: __property void set_Y(Unit );
[JScript]
public function get Y() : Unit
public function set Y(Unit);

Property Value

A Unit corresponding to the y-coordinate of the mouse click.

Remarks

Use this property with X to determine the location of the mouse click.

See Also

LocationEventArgs Class | Dart.PowerWEB.FileUpload Namespace


LocationEventHandler Delegate

The delegate for events that require location information.

[Visual Basic]
Public Delegate Function Sub  LocationEventHandler( _
   ByVal sender As Object, _
   ByVal e As LocationEventArgs _
)
[C#]
public delegate void LocationEventHandler(
   object sender,
   LocationEventArgs e
)
[C++]
public __gc __delegate void LocationEventHandler(
   Object* sender,
   LocationEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


OpenFileDialog Class

A dialog control for uploading files that can be attached to any web control on a form.

For a list of all members of this type, see OpenFileDialog Members.

System.Object
System.Web.UI.Control
Dart.PowerWEB.FileUpload.OpenFileDialog

[Visual Basic]
Public Class OpenFileDialog
    Inherits Control
    Implements ILiveControl, IPostBackEventHandler
[C#]
public class OpenFileDialog : Control, ILiveControl, IPostBackEventHandler
[C++]
public __gc class OpenFileDialog : public Control, ILiveControl, IPostBackEventHandler
[JScript]
public class OpenFileDialog extends Control, ILiveControl, IPostBackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Use the OpenFileDialog when the look of the traditional Upload control is undesirable.

Note: Use of the OpenFileDialog requires the Flash 8.0 plugin or higher.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

OpenFileDialog Members | Dart.PowerWEB.FileUpload Namespace


OpenFileDialog Members

OpenFileDialog overview

Public Instance Constructors

OpenFileDialog Overloaded. Initializes a new instance of the OpenFileDialog class.

Public Instance Properties

AutoPostBack | When set to true, the control will immediately initiate an upload as soon as a file is selected within the file dialog.
BindingContainer (inherited from Control) |
Blocking | Gets or sets the blocking state of the control.
BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ClientTriggerElement | The ID of the element which will trigger a file dialog to be opened in the browser.
ClientTriggerEvent | The ClientTriggerElement's client-side event which will be used to trigger the file dialog.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
DynamicValidation | Use to inject validation code into the initial Page render.
EnableCallback | Gets or sets whether the control issues a callback.
Enabled | Gets or sets whether the server control is enabled or disabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ErrorBehavior | Gets or sets how errors are handled by the control.
ErrorMessage | Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.
FilterDescription | Text to display in file dialog when using Flash upload and custom FilterExtension setting.
FilterExtension | A semi-colon delimited list of file extensions to allow. For example, \"*.jpg;*.gif\".
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Tag | Gets or sets a convertible object that contains data about the control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll | Gets or sets which fields are posted to the server in a callback.
Visible | Overridden. Setting this property has no effect.
WaitElementID | Gets or sets the message ID of the HTML element to display a message during a pending callback.
WaitMessage | Gets or sets the message to display during a pending callback.

Public Instance Methods

DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference | Returns JavaScript that can be used to initiate a callback to the server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState | Returns the ViewState object used to save and restore state.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Refresh | In a callback, updates the controls client-side representation.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ShowDialog | Show the open file dialog.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


OpenFileDialog Constructor

Initializes a new instance of the OpenFileDialog control.

Overload List

Initializes a new instance of the OpenFileDialog control.

[Visual Basic] Public Sub New()
[C#] public OpenFileDialog();
[C++] public: OpenFileDialog();
[JScript] public function OpenFileDialog();

Initializes a new instance of the OpenFileDialog control.

[Visual Basic] Public Sub New(ByVal String)
[C#] public OpenFileDialog(string);
[C++] public: OpenFileDialog(String*);
[JScript] public function OpenFileDialog(String);

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


OpenFileDialog Constructor ()

Initializes a new instance of the OpenFileDialog control.

[Visual Basic]
Public Sub New()
[C#]
public OpenFileDialog();
[C++]
public: OpenFileDialog();
[JScript]
public function OpenFileDialog();

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace | OpenFileDialog Constructor Overload List


OpenFileDialog Constructor (String)

Initializes a new instance of the OpenFileDialog control.

[Visual Basic]
Public Sub New( _
   ByVal oemLK As String _
)
[C#]
public OpenFileDialog(
   string oemLK
);
[C++]
public: OpenFileDialog(
   String* oemLK
);
[JScript]
public function OpenFileDialog(
   String oemLK
);

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace | OpenFileDialog Constructor Overload List


OpenFileDialog Properties

The properties of the OpenFileDialog class are listed below. For a complete list of OpenFileDialog class members, see the OpenFileDialog Members topic.

Public Instance Properties

AutoPostBack | When set to true, the control will immediately initiate an upload as soon as a file is selected within the file dialog.
BindingContainer (inherited from Control) |
Blocking | Gets or sets the blocking state of the control.
BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
ClientTriggerElement | The ID of the element which will trigger a file dialog to be opened in the browser.
ClientTriggerEvent | The ClientTriggerElement's client-side event which will be used to trigger the file dialog.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
DynamicValidation | Use to inject validation code into the initial Page render.
EnableCallback | Gets or sets whether the control issues a callback.
Enabled | Gets or sets whether the server control is enabled or disabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ErrorBehavior | Gets or sets how errors are handled by the control.
ErrorMessage | Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.
FilterDescription | Text to display in file dialog when using Flash upload and custom FilterExtension setting.
FilterExtension | A semi-colon delimited list of file extensions to allow. For example, \"*.jpg;*.gif\".
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Tag | Gets or sets a convertible object that contains data about the control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll | Gets or sets which fields are posted to the server in a callback.
Visible | Overridden. Setting this property has no effect.
WaitElementID | Gets or sets the message ID of the HTML element to display a message during a pending callback.
WaitMessage | Gets or sets the message to display during a pending callback.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


AutoPostBack Property

OpenFileDialog.AutoPostBack Property

When set to true, the control will immediately initiate an upload as soon as a file is selected within the file dialog.

[Visual Basic]
Public Property AutoPostBack As Boolean
[C#]
public bool AutoPostBack { get; set; }
[C++]
public: __property bool get_AutoPostBack();
public: __property void set_AutoPostBack(bool );
[JScript]
public function get AutoPostBack() : bool
public function set AutoPostBack(bool);

Property Value

The default value is false.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


Blocking Property

OpenFileDialog.Blocking Property

Gets or sets the blocking state of the control.

[Visual Basic]
Public Property Blocking As Boolean
[C#]
public bool Blocking { get; set; }
[C++]
public: __property bool get_Blocking();
public: __property void set_Blocking(bool );
[JScript]
public function get Blocking() : bool
public function set Blocking(bool);

Property Value

true if other PowerWEB controls should be disabled while the PowerWEB control has a pending callback.

Remarks

Although callbacks always occur asynchronously, when this property is true, a simulated blocking will be used. The interface will be disabled and updated as busy when a callback is pending (although the code itself will not block).

Note Only PowerWEB controls will be blocked. The user will still be able to interact with non-PowerWEB controls.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


BrowserType Property

OpenFileDialog.BrowserType Property

Gets or sets the type of browser as detected by the PowerWEB control.

[Visual Basic]
Public Property BrowserType As BrowserType _
    Implements ILiveControl.BrowserType
[C#]
public BrowserType BrowserType { get; set; }
[C++]
public: __property BrowserType get_BrowserType();
public: __property void set_BrowserType(BrowserType );
[JScript]
public function get BrowserType() : BrowserType
public function set BrowserType(BrowserType);

Property Value

A BrowserType that represents the browser rendering the PowerWEB control.

Implements

ILiveControl.BrowserType

Remarks

This property is set when the PowerWEB control is initialized, based on the user-agent header sent by the browser. BrowserType can also be set to override the detected value with a custom browser detection algorithm.

Note This property is global to all PowerWEB controls. Any change to an individual PowerWEB control will automatically be applied to all PowerWEB controls on the form. It is not possible to have PowerWEB controls with different BrowserType values on the same form.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


BufferedScript Property

OpenFileDialog.BufferedScript Property

Gets the client-side script which will be written to the response stream when the callback request is ended.

[Visual Basic]
Public Property ReadOnly BufferedScript As StringWriter _
    Implements ILiveControl.BufferedScript
[C#]
public StringWriter BufferedScript { get; }
[C++]
public: __property StringWriter* get_BufferedScript();
[JScript]
public function get BufferedScript() : StringWriter

Property Value

A StringWriter object that contains buffered script for a callback response.

Implements

ILiveControl.BufferedScript

Remarks

Use the BufferedScript property to modify the client-side script to be sent in response to a callback.

For example, to dynamically change the flow of a label (from bottom to top instead of left to right):

LiveLabel1.BufferedScript.Write(LiveLabel1.GetScriptStyleReference() + ".writingMode = 'tb-rl';");

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


CallbackType Property

OpenFileDialog.CallbackType Property

Gets or sets the type of callbacks performed by the PowerWEB control.

[Visual Basic]
Public Property CallbackType As CallbackType _
    Implements ILiveControl.CallbackType
[C#]
public CallbackType CallbackType { get; set; }
[C++]
public: __property CallbackType get_CallbackType();
public: __property void set_CallbackType(CallbackType );
[JScript]
public function get CallbackType() : CallbackType
public function set CallbackType(CallbackType);

Property Value

A CallbackType that represents the mechanism used for callbacks by the PowerWEB control.

Implements

ILiveControl.CallbackType

Remarks

The optimal approach is CallbackType.XmlHttp. The first fallback approach is CallbackType.Flash. The final fallback is CallbackType.IFrame.

Defaults to CallbackType.AutoDetect. On the initial page load, CallbackType is set to the most appropriate value based on the browser type detected.

Set to override when auto-detection is insufficient. For example, if the browser has ActiveX turned off, XmlHttp and Flash will fail. However, the PowerWEB controls will not be aware of this, because this setting cannot be detected server-side. A developer can determine if ActiveX is off and set to IFRAME to provide a decent callback approach.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


ClientTriggerElement Property

OpenFileDialog.ClientTriggerElement Property

The ID of the element which will trigger a file dialog to be opened in the browser.

[Visual Basic]
Public Property ClientTriggerElement As String
[C#]
public string ClientTriggerElement { get; set; }
[C++]
public: __property String* get_ClientTriggerElement();
public: __property void set_ClientTriggerElement(String* );
[JScript]
public function get ClientTriggerElement() : String
public function set ClientTriggerElement(String);

Property Value

The default value is an empty string.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


ClientTriggerEvent Property

OpenFileDialog.ClientTriggerEvent Property

The ClientTriggerElement's client-side event which will be used to trigger the file dialog.

[Visual Basic]
Public Property ClientTriggerEvent As String
[C#]
public string ClientTriggerEvent { get; set; }
[C++]
public: __property String* get_ClientTriggerEvent();
public: __property void set_ClientTriggerEvent(String* );
[JScript]
public function get ClientTriggerEvent() : String
public function set ClientTriggerEvent(String);

Property Value

The default value is an empty string.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


Debug Property

OpenFileDialog.Debug Property

Set to true to display a debug window which displays callback data in real-time as it is set/received.

[Visual Basic]
Public Property Debug As Boolean _
    Implements ILiveControl.Debug
[C#]
public bool Debug { get; set; }
[C++]
public: __property bool get_Debug();
public: __property void set_Debug(bool );
[JScript]
public function get Debug() : bool
public function set Debug(bool);

Property Value

true if a debug window is displayed when callback data is sent/received; false otherwise. The default value is false;

Implements

ILiveControl.Debug

Remarks

This property is intended to be used by application developers to assist in diagnosis of application bugs. Set this property to true to see the JavaScript that is executed on the client-side as a result of the server-side interaction with the controls.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


DynamicValidation Property

OpenFileDialog.DynamicValidation Property

Use to inject validation code into the initial Page render.

[Visual Basic]
Public Property DynamicValidation As Boolean _
    Implements ILiveControl.DynamicValidation
[C#]
public bool DynamicValidation { get; set; }
[C++]
public: __property bool get_DynamicValidation();
public: __property void set_DynamicValidation(bool );
[JScript]
public function get DynamicValidation() : bool
public function set DynamicValidation(bool);

Property Value

A bool determining whether or not validation code is rendered in initial Page load. The default value is false.

Implements

ILiveControl.DynamicValidation

Remarks

Note, most scenarios do not require this property. Use this property only if (1) a control requiring validation is going to be created in a callback and (2) no other controls requiring validation are present on initial page load.

If a control requires validation, the code to perform this validation is set up in initial page load. This code includes a reference to an external script file, and a script block. However, if no control requiring validation is present on initial page load, but is created in a subsequent callback, validation is skipped because the validation script was not properly set up. Set this property to true on initial page load to create the validation script which can be used by any control created in subsequent callbacks.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


EnableCallback Property

OpenFileDialog.EnableCallback Property

Gets or sets whether the control issues a callback.

[Visual Basic]
Public Property EnableCallback As Boolean
[C#]
public bool EnableCallback { get; set; }
[C++]
public: __property bool get_EnableCallback();
public: __property void set_EnableCallback(bool );
[JScript]
public function get EnableCallback() : bool
public function set EnableCallback(bool);

Property Value

true if the PowerWEB control uses callbacks. When false, the PowerWEB control uses traditional postbacks.

Remarks

Set EnableCallback to true for the PowerWEB control to use callbacks, as opposed to traditional postbacks.

Set to false to force the control to behave like its non-live counterpart.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


Enabled Property

OpenFileDialog.Enabled Property

Gets or sets whether the server control is enabled or disabled.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled { get; set; }
[C++]
public: __property bool get_Enabled();
public: __property void set_Enabled(bool );
[JScript]
public function get Enabled() : bool
public function set Enabled(bool);

Property Value

The default value is true.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


ErrorBehavior Property

OpenFileDialog.ErrorBehavior Property

Gets or sets how errors are handled by the control.

[Visual Basic]
Public Property ErrorBehavior As ErrorBehavior
[C#]
public ErrorBehavior ErrorBehavior { get; set; }
[C++]
public: __property ErrorBehavior get_ErrorBehavior();
public: __property void set_ErrorBehavior(ErrorBehavior );
[JScript]
public function get ErrorBehavior() : ErrorBehavior
public function set ErrorBehavior(ErrorBehavior);

Property Value

An ErrorBehavior enumerated value. Defaults to ErrorBehavior.ShowInBrowser.

Remarks

Set ErrorBehavior to specify whether an exception raised by the PowerWEB control should cause an error page, an alert box, or no indication to appear.

If set to ErrorBehavior.ShowAlert, set the alert message using the ErrorMessage property.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


ErrorMessage Property

OpenFileDialog.ErrorMessage Property

Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.

[Visual Basic]
Public Property ErrorMessage As String
[C#]
public string ErrorMessage { get; set; }
[C++]
public: __property String* get_ErrorMessage();
public: __property void set_ErrorMessage(String* );
[JScript]
public function get ErrorMessage() : String
public function set ErrorMessage(String);

Property Value

A message to display when an error occurs.

Remarks

Set ErrorMessage to specify the contents of the Alert. Alternatively, set ErrorBehavior to ErrorBehavior.ShowInBrowser to see specific error information.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


FilterDescription Property

OpenFileDialog.FilterDescription Property

Text to display in file dialog when using Flash upload and custom FilterExtension setting.

[Visual Basic]
Public Property FilterDescription As String
[C#]
public string FilterDescription { get; set; }
[C++]
public: __property String* get_FilterDescription();
public: __property void set_FilterDescription(String* );
[JScript]
public function get FilterDescription() : String
public function set FilterDescription(String);

Property Value

The default value is "All Files (*.*)".

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


FilterExtension Property

OpenFileDialog.FilterExtension Property

A semi-colon delimited list of file extensions to allow. For example, \"*.jpg;*.gif\".

[Visual Basic]
Public Property FilterExtension As String
[C#]
public string FilterExtension { get; set; }
[C++]
public: __property String* get_FilterExtension();
public: __property void set_FilterExtension(String* );
[JScript]
public function get FilterExtension() : String
public function set FilterExtension(String);

Property Value

The default value is "*.*".

Remarks

When using Flash upload type, this filter will be enforced in the file dialog.

When using IFrame upload type, this will be globally enforced on the server according to the Extensions property of the UploadManager control.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


IsCallback Property

OpenFileDialog.IsCallback Property

Gets the callback state of the PowerWEB control.

[Visual Basic]
Public Property IsCallback As Boolean _
    Implements ILiveControl.IsCallback
[C#]
public bool IsCallback { get; set; }
[C++]
public: __property bool get_IsCallback();
public: __property void set_IsCallback(bool );
[JScript]
public function get IsCallback() : bool
public function set IsCallback(bool);

Property Value

true if the PowerWEB control is currently in a callback state, false otherwise.

Implements

ILiveControl.IsCallback

Remarks

Use the IsCallback property to differentiate between a postback and live callback.

Note This property is global to all PowerWEB controls.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


IsLive Property

OpenFileDialog.IsLive Property

Gets or sets whether a PowerWEB control updates itself in a callback.

[Visual Basic]
Public Property IsLive As Boolean _
    Implements ILiveControl.IsLive
[C#]
public bool IsLive { get; set; }
[C++]
public: __property bool get_IsLive();
public: __property void set_IsLive(bool );
[JScript]
public function get IsLive() : bool
public function set IsLive(bool);

Property Value

true if the PowerWEB control should update itself during a callback, false otherwise.

Implements

ILiveControl.IsLive

Remarks

Defaults to true. Set the IsLive property to false to prevent the PowerWEB control from updating itself during a callback, even if it is changed in code behind.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


Tag Property

OpenFileDialog.Tag Property

Gets or sets a convertible object that contains data about the control.

[Visual Basic]
Public Property Tag As Object _
    Implements ILiveControl.Tag
[C#]
public object Tag { get; set; }
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(Object* );
[JScript]
public function get Tag() : Object
public function set Tag(Object);

Property Value

An object that implements the IConvertible interface and contains data about the PowerWEB control. The default is a null reference (Nothing in Visual Basic).

Implements

ILiveControl.Tag

Remarks

Any type that implements IConvertible can be assigned to this property. If the Tag property is set through the Windows Forms designer, only text can be assigned.

Data contained within the Tag property persists across callbacks. A common use for the Tag property is to store data that is closely associated with the control.

Example

The following example demonstrates using a LiveTimer to periodically update a LiveControl.

[Visual Basic]
'In this example, A LiveTimer periodically updates the color of a LiveLabel
'It also demonstrates using the Tag property to persist information over callbacks

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    If (Not Me.IsPostBack) Then
        'Set default values for the label
        LiveLabel1.BorderWidth = New Unit(4)
        LiveLabel1.BorderColor = Color.Red
        LiveLabel1.ForeColor = Color.Red

        'Use the Tag property to keep track of color index
        LiveLabel1.Tag = 0
        LiveLabel1.Text = "This Message will change color every few seconds"

        'Start the Timer.  It will fire a Tick event every 2 seconds
        LiveTimer1.Interval = 2000
        LiveTimer1.Start()
    End If
End Sub

Private Sub LiveTimer1_Tick(ByVal sender As Object, ByVal e As System.EventArgs) Handles LiveTimer1.Tick
    Dim color As Color = color.Red

    'Add 1 to the color index
    Dim index As Integer = Convert.ToInt16(LiveLabel1.Tag) + 1
    LiveLabel1.Tag = index Mod 6  'mod 6 - cycle 0 to 6
    Select Case (index)
    Case 0
        color = color.Red
        Case 1
        color = color.Orange
        Case 2
        color = color.Yellow
        Case 3
        color = color.Green
        Case 4
        color = color.Blue
        Case 5
        color = color.Purple
    End Select

    'Update the LiveLabel's Color
    LiveLabel1.BorderColor = color
    LiveLabel1.ForeColor = color
End Sub

[C#]
//In this example, A LiveTimer periodically updates the color of a LiveLabel
//It also demonstrates using the Tag property to persist information over callbacks

private void Page_Load(object sender, System.EventArgs e)
{
    if (!this.IsPostBack)
    {
        //Set default values for the label
        LiveLabel1.BorderWidth = 4;
        LiveLabel1.BorderColor = Color.Red;
        LiveLabel1.ForeColor = Color.Red;

        //Use the Tag property to keep track of color index
        LiveLabel1.Tag = 0;
        LiveLabel1.Text = "This Message will change colors every few seconds!";

        //Start the Timer.  It will fire a Tick event every 2 seconds
        LiveTimer1.Interval = 2000;
        LiveTimer1.Start();
    }
}

private void LiveTimer1_Tick(object sender, System.EventArgs e)
{
    Color color = Color.Red;

    //Add 1 to the color index
    int index = Convert.ToInt16(LiveLabel1.Tag) + 1;
    LiveLabel1.Tag = index%6;  //mod 6 - cycle 0 to 6
    switch (index)
    {
        case 0:
            color = Color.Red;
            break;
        case 1:
            color = Color.Orange;
            break;
        case 2:
            color = Color.Yellow;
            break;
        case 3:
            color = Color.Green;
            break;
        case 4:
            color = Color.Blue;
            break;
        case 5:
            color = Color.Purple;
            break;
    }

    //Update the LiveLabel's Color
    LiveLabel1.BorderColor = color;
    LiveLabel1.ForeColor = color;
}

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


UpdateAll Property

OpenFileDialog.UpdateAll Property

Gets or sets which fields are posted to the server in a callback.

[Visual Basic]
Public Property UpdateAll As Boolean
[C#]
public bool UpdateAll { get; set; }
[C++]
public: __property bool get_UpdateAll();
public: __property void set_UpdateAll(bool );
[JScript]
public function get UpdateAll() : bool
public function set UpdateAll(bool);

Property Value

If true, all values for all client-side form elements are posted to the server. If false, only the value for the callback element is posted to the server. The default value is true.

Remarks

If true, all values for all client-side form elements are posted to the server. If false, only the value for the callback element is posted to the server. This can be used to highly optimize performance depending on the application. For example, if an application has a lot of form fields with a Timer raising a periodic callback, the callback lag may be signifigant, as the script has to loop through all of the form fields to get the client-side value. However, this may not be necessary. Often, you may only need to raise a callback, and don't need the values for form fields. In this case set this property to false, and the callback will execute much faster.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


Visible Property

OpenFileDialog.Visible Property

Setting this property has no effect.

[Visual Basic]
Overrides Public Property Visible As Boolean
[C#]
public override bool Visible { get; set; }
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(bool );
[JScript]
public override function get Visible() : bool
public override function set Visible(bool);

Property Value

Defaults to true.

Remarks

OpenFileDialog is not a visible control, so setting this property has no effect. To show an OpenFileDialog, use ShowDialog.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


WaitElementID Property

OpenFileDialog.WaitElementID Property

Gets or sets the message ID of the HTML element to display a message during a pending callback.

[Visual Basic]
Public Property WaitElementID As String
[C#]
public string WaitElementID { get; set; }
[C++]
public: __property String* get_WaitElementID();
public: __property void set_WaitElementID(String* );
[JScript]
public function get WaitElementID() : String
public function set WaitElementID(String);

Property Value

The ID of an HTML element, such as a Label, that will display a message during pending callbacks.

Remarks

Use in conjunction with the WaitMessage property.

Set WaitElementID to specify the ID of the control that will display the WaitMessage during a pending callback.

Typical usage would be for immediately displaying a message (such as "Processing..") to the user during lengthy callbacks (due to network traffic or server side processing).

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


WaitMessage Property

OpenFileDialog.WaitMessage Property

Gets or sets the message to display during a pending callback.

[Visual Basic]
Public Property WaitMessage As String
[C#]
public string WaitMessage { get; set; }
[C++]
public: __property String* get_WaitMessage();
public: __property void set_WaitMessage(String* );
[JScript]
public function get WaitMessage() : String
public function set WaitMessage(String);

Property Value

The message displayed during pending callbacks.

Remarks

Use in conjunction with the WaitElementID property.

Set WaitMessage to specify the message displayed by the WaitElementID control during a pending callback.

Typical usage would be for immediately displaying a message (such as "Processing...") to the user during lengthy callbacks (due to network traffic or server side processing).

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


OpenFileDialog Methods

The methods of the OpenFileDialog class are listed below. For a complete list of OpenFileDialog class members, see the OpenFileDialog Members topic.

Public Instance Methods

DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference | Returns JavaScript that can be used to initiate a callback to the server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState | Returns the ViewState object used to save and restore state.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Refresh | In a callback, updates the controls client-side representation.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ShowDialog | Show the open file dialog.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


GetCallbackEventReference Method

OpenFileDialog.GetCallbackEventReference Method

Returns JavaScript that can be used to initiate a callback to the server.

[Visual Basic]
Public Function GetCallbackEventReference( _
   ByVal eventName As String, _
   ByVal argument As String _
) As String
[C#]
public string GetCallbackEventReference(
   string eventName,
   string argument
);
[C++]
public: String* GetCallbackEventReference(
   String* eventName,
   String* argument
);
[JScript]
public function GetCallbackEventReference(
   String eventName,
   String argument
): String;

Parameters

eventName
The event corresponding to the callback.
argument
The event arguments for the callback.

Remarks

Returns JavaScript that can be used to initiate a callback to the server.

The settings of the PowerWEB control (blocking, errorhandling, etc) are automatically taken into account.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


GetScript Method

OpenFileDialog.GetScript Method

Returns all JavaScript buffered up as a result of setting control properties.

[Visual Basic]
Public Function GetScript() _
    Implements ILiveControl.GetScript As String
[C#]
public string GetScript();
[C++]
public: String* GetScript();
[JScript]
public function GetScript(): String;

Implements

ILiveControl.GetScript

Remarks

Returns all JavaScript buffered up as a result of setting properties of controls on the form.

Note This is not intended for use by end-users.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


GetScriptObjectReference Method

OpenFileDialog.GetScriptObjectReference Method

Returns a client-side reference to the element.

[Visual Basic]
Public Function GetScriptObjectReference() _
    Implements ILiveControl.GetScriptObjectReference As String
[C#]
public string GetScriptObjectReference();
[C++]
public: String* GetScriptObjectReference();
[JScript]
public function GetScriptObjectReference(): String;

Implements

ILiveControl.GetScriptObjectReference

Remarks

Returns a client-side reference to the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1")" (depending on the browser).

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


GetScriptStyleReference Method

OpenFileDialog.GetScriptStyleReference Method

Returns a client-side reference to the style object of the element.

[Visual Basic]
Public Function GetScriptStyleReference() _
    Implements ILiveControl.GetScriptStyleReference As String
[C#]
public string GetScriptStyleReference();
[C++]
public: String* GetScriptStyleReference();
[JScript]
public function GetScriptStyleReference(): String;

Implements

ILiveControl.GetScriptStyleReference

Remarks

Returns a client-side reference to the style object of the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1").style" (depending on the browser).

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


GetViewState Method

OpenFileDialog.GetViewState Method

Returns the ViewState object used to save and restore state.

[Visual Basic]
Public Function GetViewState() _
    Implements ILiveControl.GetViewState As Object
[C#]
public object GetViewState();
[C++]
public: Object* GetViewState();
[JScript]
public function GetViewState(): Object;

Implements

ILiveControl.GetViewState

Remarks

Returns the ViewState object used by PowerWEB controls to save and restore state.

Note This is not intended for use by end-users.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


Refresh Method

OpenFileDialog.Refresh Method

In a callback, updates the controls client-side representation.

[Visual Basic]
Public Sub Refresh() _
    Implements ILiveControl.Refresh
[C#]
public void Refresh();
[C++]
public: void Refresh();
[JScript]
public function Refresh();

Implements

ILiveControl.Refresh

Remarks

When the request is an incoming callback, this method forces the control to update itself client-side (whether a change was detected within the control or not).

When the request is not an Ajax callback, this method has no effect.

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


ShowDialog Method

OpenFileDialog.ShowDialog Method

Show the open file dialog.

[Visual Basic]
Public Sub ShowDialog()
[C#]
public void ShowDialog();
[C++]
public: void ShowDialog();
[JScript]
public function ShowDialog();

See Also

OpenFileDialog Class | Dart.PowerWEB.FileUpload Namespace


PostedFile Class

Information concerning a posted file, including its name, size and path.

For a list of all members of this type, see PostedFile Members.

System.Object
Dart.PowerWEB.FileUpload.PostedFile

[Visual Basic]
Public Class PostedFile
[C#]
public class PostedFile
[C++]
public __gc class PostedFile
[JScript]
public class PostedFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

PostedFile Members | Dart.PowerWEB.FileUpload Namespace


PostedFile Members

PostedFile overview

Public Instance Constructors

PostedFile Constructor Initializes a new instance of the PostedFile control.

Public Instance Properties

BytesUploaded | The number of bytes uploaded thus far.
ControlID | The ID of the control used to upload the PostedFile.
FileName | The name of the posted file.
FileSize | The size of the posted file.
SavedFilePath | The path of the posted file on the server.
TempFilePath | The temporary path of the posted file during the upload.
UniqueID | A unique identifier for a posted file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


PostedFile Constructor

Initializes a new instance of the PostedFile control.

[Visual Basic]
Public Sub New( _
   ByVal fileName As String, _
   ByVal savedFilePath As String, _
   ByVal tempFilePath As String, _
   ByVal uniqueID As String, _
   ByVal fileSize As Integer, _
   ByVal bytesUploaded As Integer, _
   ByVal controlID As String _
)
[C#]
public PostedFile(
   string fileName,
   string savedFilePath,
   string tempFilePath,
   string uniqueID,
   int fileSize,
   int bytesUploaded,
   string controlID
);
[C++]
public: PostedFile(
   String* fileName,
   String* savedFilePath,
   String* tempFilePath,
   String* uniqueID,
   int fileSize,
   int bytesUploaded,
   String* controlID
);
[JScript]
public function PostedFile(
   String fileName,
   String savedFilePath,
   String tempFilePath,
   String uniqueID,
   int fileSize,
   int bytesUploaded,
   String controlID
);

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


PostedFile Properties

The properties of the PostedFile class are listed below. For a complete list of PostedFile class members, see the PostedFile Members topic.

Public Instance Properties

BytesUploaded | The number of bytes uploaded thus far.
ControlID | The ID of the control used to upload the PostedFile.
FileName | The name of the posted file.
FileSize | The size of the posted file.
SavedFilePath | The path of the posted file on the server.
TempFilePath | The temporary path of the posted file during the upload.
UniqueID | A unique identifier for a posted file.

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


BytesUploaded Property

PostedFile.BytesUploaded Property

The number of bytes uploaded thus far.

[Visual Basic]
Public Property ReadOnly BytesUploaded As Integer
[C#]
public int BytesUploaded { get; }
[C++]
public: __property int get_BytesUploaded();
[JScript]
public function get BytesUploaded() : int

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


ControlID Property

PostedFile.ControlID Property

The ID of the control used to upload the PostedFile.

[Visual Basic]
Public Property ReadOnly ControlID As String
[C#]
public string ControlID { get; }
[C++]
public: __property String* get_ControlID();
[JScript]
public function get ControlID() : String

Remarks

Primarily, this property is used within events to determine which Control the file is associated with.

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


FileName Property

PostedFile.FileName Property

The name of the posted file.

[Visual Basic]
Public Property ReadOnly FileName As String
[C#]
public string FileName { get; }
[C++]
public: __property String* get_FileName();
[JScript]
public function get FileName() : String

Remarks

This is the name of the file as it was on the client. If a file with the same name already exists on the server, it will be renamed with a unique integer extension. For example, if the file "test.jpg" and "test.jpg.1" exists on the server, an uploaded file "test.jpg" will be saved as "test.jpg.2". The unique filename is available in SavedFilePath.

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


FileSize Property

PostedFile.FileSize Property

The size of the posted file.

[Visual Basic]
Public Property ReadOnly FileSize As Integer
[C#]
public int FileSize { get; }
[C++]
public: __property int get_FileSize();
[JScript]
public function get FileSize() : int

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


SavedFilePath Property

PostedFile.SavedFilePath Property

The path of the posted file on the server.

[Visual Basic]
Public Property ReadOnly SavedFilePath As String
[C#]
public string SavedFilePath { get; }
[C++]
public: __property String* get_SavedFilePath();
[JScript]
public function get SavedFilePath() : String

Remarks

This is the path and name of the file as it was saved on the server. If a file with the same FileName already exists on the server, it will be renamed with a unique integer extension. For example, if the file "test.jpg" and "test.jpg.1" exists on the server, an uploaded file "test.jpg" will be saved as "test.jpg.2". This property reports the unique filename, while FileName contains the original filename.

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


TempFilePath Property

PostedFile.TempFilePath Property

The temporary path of the posted file during the upload.

[Visual Basic]
Public Property ReadOnly TempFilePath As String
[C#]
public string TempFilePath { get; }
[C++]
public: __property String* get_TempFilePath();
[JScript]
public function get TempFilePath() : String

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


UniqueID Property

PostedFile.UniqueID Property

A unique identifier for a posted file.

[Visual Basic]
Public Property ReadOnly UniqueID As String
[C#]
public string UniqueID { get; }
[C++]
public: __property String* get_UniqueID();
[JScript]
public function get UniqueID() : String

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


ProgBarStyle Class

Gets a System.Web.UI.WebControls.Style object representing the style that will be applied to the progress bar.

For a list of all members of this type, see ProgBarStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.FileUpload.ProgBarStyle

[Visual Basic]
Public Class ProgBarStyle
    Inherits Style
[C#]
public class ProgBarStyle : Style
[C++]
public __gc class ProgBarStyle : public Style
[JScript]
public class ProgBarStyle extends Style

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

ProgBarStyle Members | Dart.PowerWEB.FileUpload Namespace


ProgBarStyle Members

ProgBarStyle overview

Public Instance Constructors

ProgBarStyle Constructor Initializes a new instance of the ProgBarStyle class.

Public Instance Properties

BackColor | Background color used within a progress bar, indicating incomplete portion of file upload.
BarColor | Color used within a progress bar, indicating completed portion of file upload.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from Style) | Gets or sets the CSS class rendered by the Web server control on the client.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from Style) | Gets or sets the width of the Web server control.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
CopyFrom (inherited from Style) | Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith (inherited from Style) | Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset (inherited from Style) | Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overridden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

ProgBarStyle Class | Dart.PowerWEB.FileUpload Namespace


ProgBarStyle Constructor

Initializes a new instance of the ProgBarStyle class.

[Visual Basic]
Public Sub New()
[C#]
public ProgBarStyle();
[C++]
public: ProgBarStyle();
[JScript]
public function ProgBarStyle();

See Also

ProgBarStyle Class | Dart.PowerWEB.FileUpload Namespace


ProgBarStyle Properties

The properties of the ProgBarStyle class are listed below. For a complete list of ProgBarStyle class members, see the ProgBarStyle Members topic.

Public Instance Properties

BackColor | Background color used within a progress bar, indicating incomplete portion of file upload.
BarColor | Color used within a progress bar, indicating completed portion of file upload.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from Style) | Gets or sets the CSS class rendered by the Web server control on the client.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from Style) | Gets or sets the width of the Web server control.

See Also

ProgBarStyle Class | Dart.PowerWEB.FileUpload Namespace


BackColor Property

ProgBarStyle.BackColor Property

Background color used within a progress bar, indicating incomplete portion of file upload.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor { get; set; }
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(Color );
[JScript]
public function get BackColor() : Color
public function set BackColor(Color);

See Also

ProgBarStyle Class | Dart.PowerWEB.FileUpload Namespace


BarColor Property

ProgBarStyle.BarColor Property

Color used within a progress bar, indicating completed portion of file upload.

[Visual Basic]
Public Property BarColor As Color
[C#]
public Color BarColor { get; set; }
[C++]
public: __property Color get_BarColor();
public: __property void set_BarColor(Color );
[JScript]
public function get BarColor() : Color
public function set BarColor(Color);

See Also

ProgBarStyle Class | Dart.PowerWEB.FileUpload Namespace


ProgressPanel Class

A control for showing the progress of file transfers during an upload operation.

For a list of all members of this type, see ProgressPanel Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.FileUpload.ProgressPanel

[Visual Basic]
Public Class ProgressPanel
    Inherits WebControl
    Implements ILiveControl
[C#]
public class ProgressPanel : WebControl, ILiveControl
[C++]
public __gc class ProgressPanel : public WebControl, ILiveControl
[JScript]
public class ProgressPanel extends WebControl, ILiveControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The UploadManager is required for use of the ProgressPanel.

Each uploaded file will have its own bar in the panel.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

ProgressPanel Members | Dart.PowerWEB.FileUpload Namespace


ProgressPanel Members

ProgressPanel overview

Public Instance Constructors

ProgressPanel Overloaded. Initializes a new instance of the ProgressPanel class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BackgroundImageUrl | Background image to display within the ProgressPanel.
BindingContainer (inherited from Control) |
Blocking | Gets or sets the blocking state of the control.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
CancelButtonDisabledImageUrl | Image to use for the inactive Cancel button in place of a standard HTML button.
CancelButtonImageUrl | Image to use for the active Cancel button in place of a standard HTML button.
CancelButtonStyle | Style settings for ProgressPanel Cancel button.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
CloseBehavior | Gets or sets the behavior of the ProgressPanel when upload has completed.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
DynamicValidation | Use to inject validation code into the initial Page render.
EnableCallback | Gets or sets whether the control issues a callback.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ErrorBehavior | Gets or sets how errors are handled by the control.
ErrorMessage | Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
Left | Gets or sets the left position of the PowerWEB control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
ProgressBarBackImageUrl | Background image used within a progress bar, indicating incomplete portion of file upload.
ProgressBarImageUrl | Image used within a progress bar, indicating completed portion of file upload.
ProgressBarStyle | Defines all visual aspects of an individual File Progress Bar.
ShowFileCount | Display a counter indicating total files in upload and number of uploaded files.
ShowStatusText | Display a status message defined by the StatusText property.
ShowUploadBytes | Display the total number of bytes along with number of bytes transferred.
ShowUploadSpeed | Display the estimated data transfer rate.
ShowUploadTime | Display elapsed time and estimated time remaining.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
StatusStyle | Style applied to ProgressPanel Caption.
StatusText | The current status text displayed.
StatusTextCancelled | Status text displayed when an upload is cancelled.
StatusTextComplete | Status text displayed when an upload has completed.
StatusTextFailed | Status text displayed when an upload has failed.
StatusTextUploading | Status text displayed when an upload is in progress.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
Tag | Gets or sets a convertible object that contains data about the control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Top | Gets or sets the top position of the PowerWEB control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll | Gets or sets which fields are posted to the server in a callback.
Visible | Overridden. Gets or sets a value indicating whether the PowerWEB control is visible.
WaitElementID | Gets or sets the message ID of the HTML element to display a message during a pending callback.
WaitMessage | Gets or sets the message to display during a pending callback.
Width | Overridden. Gets or sets the width of the progress panel.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference | Returns JavaScript that can be used to initiate a callback to the server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState | Returns the ViewState object used to save and restore state.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide | Overloaded. Hide the progress panel.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh | In a callback, updates the controls client-side representation.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
Show | Overloaded. Show the progress panel.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ContextMenuChanged | Occurs when the right button of the PowerWEB control is clicked.
DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
DoubleClick | Occurs when the control is double-clicked.
GotFocus | Occurs when the PowerWEB control gains focus.
HelpRequested | Occurs when F1 is pressed while the control has focus.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
KeyDown | Occurs when a key is down while the control has focus.
KeyPress | Occurs when a key is pressed while the control has focus.
KeyUp | Occurs when a key is released while the control has focus.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
LocationClick | Occurs when the PowerWEB control is clicked, providing location data.
LostFocus | Occurs when the PowerWEB control loses focus.
MouseDown | Occurs when the mouse buttons are pressed while the PowerWEB control has focus.
MouseEnter | Occurs when the mouse pointer enters the PowerWEB control.
MouseLeave | Occurs when the mouse pointer leaves the PowerWEB control.
MouseUp | Occurs when the mouse buttons are released while the PowerWEB control has focus.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ProgressPanel Constructor

Initializes a new instance of the ProgressPanel control.

Overload List

Initializes a new instance of the ProgressPanel control.

[Visual Basic] Public Sub New()
[C#] public ProgressPanel();
[C++] public: ProgressPanel();
[JScript] public function ProgressPanel();

Initializes a new instance of the ProgressPanel control.

[Visual Basic] Public Sub New(ByVal String)
[C#] public ProgressPanel(string);
[C++] public: ProgressPanel(String*);
[JScript] public function ProgressPanel(String);

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ProgressPanel Constructor ()

Initializes a new instance of the ProgressPanel control.

[Visual Basic]
Public Sub New()
[C#]
public ProgressPanel();
[C++]
public: ProgressPanel();
[JScript]
public function ProgressPanel();

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace | ProgressPanel Constructor Overload List


ProgressPanel Constructor (String)

Initializes a new instance of the ProgressPanel control.

[Visual Basic]
Public Sub New( _
   ByVal oemLK As String _
)
[C#]
public ProgressPanel(
   string oemLK
);
[C++]
public: ProgressPanel(
   String* oemLK
);
[JScript]
public function ProgressPanel(
   String oemLK
);

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace | ProgressPanel Constructor Overload List


ProgressPanel Properties

The properties of the ProgressPanel class are listed below. For a complete list of ProgressPanel class members, see the ProgressPanel Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BackgroundImageUrl | Background image to display within the ProgressPanel.
BindingContainer (inherited from Control) |
Blocking | Gets or sets the blocking state of the control.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
CancelButtonDisabledImageUrl | Image to use for the inactive Cancel button in place of a standard HTML button.
CancelButtonImageUrl | Image to use for the active Cancel button in place of a standard HTML button.
CancelButtonStyle | Style settings for ProgressPanel Cancel button.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
CloseBehavior | Gets or sets the behavior of the ProgressPanel when upload has completed.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
DynamicValidation | Use to inject validation code into the initial Page render.
EnableCallback | Gets or sets whether the control issues a callback.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ErrorBehavior | Gets or sets how errors are handled by the control.
ErrorMessage | Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from WebControl) | Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
Left | Gets or sets the left position of the PowerWEB control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
ProgressBarBackImageUrl | Background image used within a progress bar, indicating incomplete portion of file upload.
ProgressBarImageUrl | Image used within a progress bar, indicating completed portion of file upload.
ProgressBarStyle | Defines all visual aspects of an individual File Progress Bar.
ShowFileCount | Display a counter indicating total files in upload and number of uploaded files.
ShowStatusText | Display a status message defined by the StatusText property.
ShowUploadBytes | Display the total number of bytes along with number of bytes transferred.
ShowUploadSpeed | Display the estimated data transfer rate.
ShowUploadTime | Display elapsed time and estimated time remaining.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
StatusStyle | Style applied to ProgressPanel Caption.
StatusText | The current status text displayed.
StatusTextCancelled | Status text displayed when an upload is cancelled.
StatusTextComplete | Status text displayed when an upload has completed.
StatusTextFailed | Status text displayed when an upload has failed.
StatusTextUploading | Status text displayed when an upload is in progress.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
Tag | Gets or sets a convertible object that contains data about the control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Top | Gets or sets the top position of the PowerWEB control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll | Gets or sets which fields are posted to the server in a callback.
Visible | Overridden. Gets or sets a value indicating whether the PowerWEB control is visible.
WaitElementID | Gets or sets the message ID of the HTML element to display a message during a pending callback.
WaitMessage | Gets or sets the message to display during a pending callback.
Width | Overridden. Gets or sets the width of the progress panel.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


BackgroundImageUrl Property

ProgressPanel.BackgroundImageUrl Property

Background image to display within the ProgressPanel.

[Visual Basic]
Overridable Public Property BackgroundImageUrl As String
[C#]
public virtual string BackgroundImageUrl { get; set; }
[C++]
public: virtual __property String* get_BackgroundImageUrl();
public: virtual __property void set_BackgroundImageUrl(String* );
[JScript]
public virtual function get BackgroundImageUrl() : String
public virtual function set BackgroundImageUrl(String);

Property Value

The default value is an empty string.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Blocking Property

ProgressPanel.Blocking Property

Gets or sets the blocking state of the control.

[Visual Basic]
Public Property Blocking As Boolean
[C#]
public bool Blocking { get; set; }
[C++]
public: __property bool get_Blocking();
public: __property void set_Blocking(bool );
[JScript]
public function get Blocking() : bool
public function set Blocking(bool);

Property Value

true if other PowerWEB controls should be disabled while the PowerWEB control has a pending callback.

Remarks

Although callbacks always occur asynchronously, when this property is true, a simulated blocking will be used. The interface will be disabled and updated as busy when a callback is pending (although the code itself will not block).

Note Only PowerWEB controls will be blocked. The user will still be able to interact with non-PowerWEB controls.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


BrowserType Property

ProgressPanel.BrowserType Property

Gets or sets the type of browser as detected by the PowerWEB control.

[Visual Basic]
Public Property BrowserType As BrowserType _
    Implements ILiveControl.BrowserType
[C#]
public BrowserType BrowserType { get; set; }
[C++]
public: __property BrowserType get_BrowserType();
public: __property void set_BrowserType(BrowserType );
[JScript]
public function get BrowserType() : BrowserType
public function set BrowserType(BrowserType);

Property Value

A BrowserType that represents the browser rendering the PowerWEB control.

Implements

ILiveControl.BrowserType

Remarks

This property is set when the PowerWEB control is initialized, based on the user-agent header sent by the browser. BrowserType can also be set to override the detected value with a custom browser detection algorithm.

Note This property is global to all PowerWEB controls. Any change to an individual PowerWEB control will automatically be applied to all PowerWEB controls on the form. It is not possible to have PowerWEB controls with different BrowserType values on the same form.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


BufferedScript Property

ProgressPanel.BufferedScript Property

Gets the client-side script which will be written to the response stream when the callback request is ended.

[Visual Basic]
Public Property ReadOnly BufferedScript As StringWriter _
    Implements ILiveControl.BufferedScript
[C#]
public StringWriter BufferedScript { get; }
[C++]
public: __property StringWriter* get_BufferedScript();
[JScript]
public function get BufferedScript() : StringWriter

Property Value

A StringWriter object that contains buffered script for a callback response.

Implements

ILiveControl.BufferedScript

Remarks

Use the BufferedScript property to modify the client-side script to be sent in response to a callback.

For example, to dynamically change the flow of a label (from bottom to top instead of left to right):

LiveLabel1.BufferedScript.Write(LiveLabel1.GetScriptStyleReference() + ".writingMode = 'tb-rl';");

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


CallbackType Property

ProgressPanel.CallbackType Property

Gets or sets the type of callbacks performed by the PowerWEB control.

[Visual Basic]
Public Property CallbackType As CallbackType _
    Implements ILiveControl.CallbackType
[C#]
public CallbackType CallbackType { get; set; }
[C++]
public: __property CallbackType get_CallbackType();
public: __property void set_CallbackType(CallbackType );
[JScript]
public function get CallbackType() : CallbackType
public function set CallbackType(CallbackType);

Property Value

A CallbackType that represents the mechanism used for callbacks by the PowerWEB control.

Implements

ILiveControl.CallbackType

Remarks

The optimal approach is CallbackType.XmlHttp. The first fallback approach is CallbackType.Flash. The final fallback is CallbackType.IFrame.

Defaults to CallbackType.AutoDetect. On the initial page load, CallbackType is set to the most appropriate value based on the browser type detected.

Set to override when auto-detection is insufficient. For example, if the browser has ActiveX turned off, XmlHttp and Flash will fail. However, the PowerWEB controls will not be aware of this, because this setting cannot be detected server-side. A developer can determine if ActiveX is off and set to IFRAME to provide a decent callback approach.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


CancelButtonDisabledImageUrl Property

ProgressPanel.CancelButtonDisabledImageUrl Property

Image to use for the inactive Cancel button in place of a standard HTML button.

[Visual Basic]
Public Property CancelButtonDisabledImageUrl As String
[C#]
public string CancelButtonDisabledImageUrl { get; set; }
[C++]
public: __property String* get_CancelButtonDisabledImageUrl();
public: __property void set_CancelButtonDisabledImageUrl(String* );
[JScript]
public function get CancelButtonDisabledImageUrl() : String
public function set CancelButtonDisabledImageUrl(String);

Property Value

The default value is an empty string.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


CancelButtonImageUrl Property

ProgressPanel.CancelButtonImageUrl Property

Image to use for the active Cancel button in place of a standard HTML button.

[Visual Basic]
Public Property CancelButtonImageUrl As String
[C#]
public string CancelButtonImageUrl { get; set; }
[C++]
public: __property String* get_CancelButtonImageUrl();
public: __property void set_CancelButtonImageUrl(String* );
[JScript]
public function get CancelButtonImageUrl() : String
public function set CancelButtonImageUrl(String);

Property Value

The default value is an empty string.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


CancelButtonStyle Property

ProgressPanel.CancelButtonStyle Property

Style settings for ProgressPanel Cancel button.

[Visual Basic]
Public Property ReadOnly CancelButtonStyle As CancelButtonStyle
[C#]
public CancelButtonStyle CancelButtonStyle { get; }
[C++]
public: __property CancelButtonStyle* get_CancelButtonStyle();
[JScript]
public function get CancelButtonStyle() : CancelButtonStyle

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


CloseBehavior Property

ProgressPanel.CloseBehavior Property

Gets or sets the behavior of the ProgressPanel when upload has completed.

[Visual Basic]
Public Property CloseBehavior As CloseBehavior
[C#]
public CloseBehavior CloseBehavior { get; set; }
[C++]
public: __property CloseBehavior get_CloseBehavior();
public: __property void set_CloseBehavior(CloseBehavior );
[JScript]
public function get CloseBehavior() : CloseBehavior
public function set CloseBehavior(CloseBehavior);

Remarks

The default value is CloseBehavior.None.

When set to CloseBehavior.ManualCloseOnComplete, a 'close' button will be displayed when an upload is cancelled or completed.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Debug Property

ProgressPanel.Debug Property

Set to true to display a debug window which displays callback data in real-time as it is set/received.

[Visual Basic]
Public Property Debug As Boolean _
    Implements ILiveControl.Debug
[C#]
public bool Debug { get; set; }
[C++]
public: __property bool get_Debug();
public: __property void set_Debug(bool );
[JScript]
public function get Debug() : bool
public function set Debug(bool);

Property Value

true if a debug window is displayed when callback data is sent/received; false otherwise. The default value is false;

Implements

ILiveControl.Debug

Remarks

This property is intended to be used by application developers to assist in diagnosis of application bugs. Set this property to true to see the JavaScript that is executed on the client-side as a result of the server-side interaction with the controls.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


DynamicValidation Property

ProgressPanel.DynamicValidation Property

Use to inject validation code into the initial Page render.

[Visual Basic]
Public Property DynamicValidation As Boolean _
    Implements ILiveControl.DynamicValidation
[C#]
public bool DynamicValidation { get; set; }
[C++]
public: __property bool get_DynamicValidation();
public: __property void set_DynamicValidation(bool );
[JScript]
public function get DynamicValidation() : bool
public function set DynamicValidation(bool);

Property Value

A bool determining whether or not validation code is rendered in initial Page load. The default value is false.

Implements

ILiveControl.DynamicValidation

Remarks

Note, most scenarios do not require this property. Use this property only if (1) a control requiring validation is going to be created in a callback and (2) no other controls requiring validation are present on initial page load.

If a control requires validation, the code to perform this validation is set up in initial page load. This code includes a reference to an external script file, and a script block. However, if no control requiring validation is present on initial page load, but is created in a subsequent callback, validation is skipped because the validation script was not properly set up. Set this property to true on initial page load to create the validation script which can be used by any control created in subsequent callbacks.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


EnableCallback Property

ProgressPanel.EnableCallback Property

Gets or sets whether the control issues a callback.

[Visual Basic]
Public Property EnableCallback As Boolean
[C#]
public bool EnableCallback { get; set; }
[C++]
public: __property bool get_EnableCallback();
public: __property void set_EnableCallback(bool );
[JScript]
public function get EnableCallback() : bool
public function set EnableCallback(bool);

Property Value

true if the PowerWEB control uses callbacks. When false, the PowerWEB control uses traditional postbacks.

Remarks

Set EnableCallback to true for the PowerWEB control to use callbacks, as opposed to traditional postbacks.

Set to false to force the control to behave like its non-live counterpart.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ErrorBehavior Property

ProgressPanel.ErrorBehavior Property

Gets or sets how errors are handled by the control.

[Visual Basic]
Public Property ErrorBehavior As ErrorBehavior
[C#]
public ErrorBehavior ErrorBehavior { get; set; }
[C++]
public: __property ErrorBehavior get_ErrorBehavior();
public: __property void set_ErrorBehavior(ErrorBehavior );
[JScript]
public function get ErrorBehavior() : ErrorBehavior
public function set ErrorBehavior(ErrorBehavior);

Property Value

An ErrorBehavior enumerated value. Defaults to ErrorBehavior.ShowInBrowser.

Remarks

Set ErrorBehavior to specify whether an exception raised by the PowerWEB control should cause an error page, an alert box, or no indication to appear.

If set to ErrorBehavior.ShowAlert, set the alert message using the ErrorMessage property.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ErrorMessage Property

ProgressPanel.ErrorMessage Property

Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.

[Visual Basic]
Public Property ErrorMessage As String
[C#]
public string ErrorMessage { get; set; }
[C++]
public: __property String* get_ErrorMessage();
public: __property void set_ErrorMessage(String* );
[JScript]
public function get ErrorMessage() : String
public function set ErrorMessage(String);

Property Value

A message to display when an error occurs.

Remarks

Set ErrorMessage to specify the contents of the Alert. Alternatively, set ErrorBehavior to ErrorBehavior.ShowInBrowser to see specific error information.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


IsCallback Property

ProgressPanel.IsCallback Property

Gets the callback state of the PowerWEB control.

[Visual Basic]
Public Property IsCallback As Boolean _
    Implements ILiveControl.IsCallback
[C#]
public bool IsCallback { get; set; }
[C++]
public: __property bool get_IsCallback();
public: __property void set_IsCallback(bool );
[JScript]
public function get IsCallback() : bool
public function set IsCallback(bool);

Property Value

true if the PowerWEB control is currently in a callback state, false otherwise.

Implements

ILiveControl.IsCallback

Remarks

Use the IsCallback property to differentiate between a postback and live callback.

Note This property is global to all PowerWEB controls.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


IsLive Property

ProgressPanel.IsLive Property

Gets or sets whether a PowerWEB control updates itself in a callback.

[Visual Basic]
Public Property IsLive As Boolean _
    Implements ILiveControl.IsLive
[C#]
public bool IsLive { get; set; }
[C++]
public: __property bool get_IsLive();
public: __property void set_IsLive(bool );
[JScript]
public function get IsLive() : bool
public function set IsLive(bool);

Property Value

true if the PowerWEB control should update itself during a callback, false otherwise.

Implements

ILiveControl.IsLive

Remarks

Defaults to true. Set the IsLive property to false to prevent the PowerWEB control from updating itself during a callback, even if it is changed in code behind.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Left Property

ProgressPanel.Left Property

Gets or sets the left position of the PowerWEB control.

[Visual Basic]
Public Property Left As Unit
[C#]
public Unit Left { get; set; }
[C++]
public: __property Unit get_Left();
public: __property void set_Left(Unit );
[JScript]
public function get Left() : Unit
public function set Left(Unit);

Property Value

A Unit that represents the left position of the control. The default is Unit.Empty.

Remarks

Use the Left property to specify the left position of the PowerWEB control. If both Left and Top are Unit.Empty (the default), relative positioning is used. If either Left or Top are not Unit.Empty, absolute positioning is used.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ProgressBarBackImageUrl Property

ProgressPanel.ProgressBarBackImageUrl Property

Background image used within a progress bar, indicating incomplete portion of file upload.

[Visual Basic]
Overridable Public Property ProgressBarBackImageUrl As String
[C#]
public virtual string ProgressBarBackImageUrl { get; set; }
[C++]
public: virtual __property String* get_ProgressBarBackImageUrl();
public: virtual __property void set_ProgressBarBackImageUrl(String* );
[JScript]
public virtual function get ProgressBarBackImageUrl() : String
public virtual function set ProgressBarBackImageUrl(String);

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ProgressBarImageUrl Property

ProgressPanel.ProgressBarImageUrl Property

Image used within a progress bar, indicating completed portion of file upload.

[Visual Basic]
Overridable Public Property ProgressBarImageUrl As String
[C#]
public virtual string ProgressBarImageUrl { get; set; }
[C++]
public: virtual __property String* get_ProgressBarImageUrl();
public: virtual __property void set_ProgressBarImageUrl(String* );
[JScript]
public virtual function get ProgressBarImageUrl() : String
public virtual function set ProgressBarImageUrl(String);

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ProgressBarStyle Property

ProgressPanel.ProgressBarStyle Property

Defines all visual aspects of an individual File Progress Bar.

[Visual Basic]
Public Property ReadOnly ProgressBarStyle As ProgBarStyle
[C#]
public ProgBarStyle ProgressBarStyle { get; }
[C++]
public: __property ProgBarStyle* get_ProgressBarStyle();
[JScript]
public function get ProgressBarStyle() : ProgBarStyle

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ShowFileCount Property

ProgressPanel.ShowFileCount Property

Display a counter indicating total files in upload and number of uploaded files.

[Visual Basic]
Public Property ShowFileCount As Boolean
[C#]
public bool ShowFileCount { get; set; }
[C++]
public: __property bool get_ShowFileCount();
public: __property void set_ShowFileCount(bool );
[JScript]
public function get ShowFileCount() : bool
public function set ShowFileCount(bool);

Property Value

The default value is true.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ShowStatusText Property

ProgressPanel.ShowStatusText Property

Display a status message defined by the StatusText property.

[Visual Basic]
Public Property ShowStatusText As Boolean
[C#]
public bool ShowStatusText { get; set; }
[C++]
public: __property bool get_ShowStatusText();
public: __property void set_ShowStatusText(bool );
[JScript]
public function get ShowStatusText() : bool
public function set ShowStatusText(bool);

Property Value

The default value is true.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ShowUploadBytes Property

ProgressPanel.ShowUploadBytes Property

Display the total number of bytes along with number of bytes transferred.

[Visual Basic]
Public Property ShowUploadBytes As Boolean
[C#]
public bool ShowUploadBytes { get; set; }
[C++]
public: __property bool get_ShowUploadBytes();
public: __property void set_ShowUploadBytes(bool );
[JScript]
public function get ShowUploadBytes() : bool
public function set ShowUploadBytes(bool);

Property Value

The default value is true.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ShowUploadSpeed Property

ProgressPanel.ShowUploadSpeed Property

Display the estimated data transfer rate.

[Visual Basic]
Public Property ShowUploadSpeed As Boolean
[C#]
public bool ShowUploadSpeed { get; set; }
[C++]
public: __property bool get_ShowUploadSpeed();
public: __property void set_ShowUploadSpeed(bool );
[JScript]
public function get ShowUploadSpeed() : bool
public function set ShowUploadSpeed(bool);

Property Value

The default value is true.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ShowUploadTime Property

ProgressPanel.ShowUploadTime Property

Display elapsed time and estimated time remaining.

[Visual Basic]
Public Property ShowUploadTime As Boolean
[C#]
public bool ShowUploadTime { get; set; }
[C++]
public: __property bool get_ShowUploadTime();
public: __property void set_ShowUploadTime(bool );
[JScript]
public function get ShowUploadTime() : bool
public function set ShowUploadTime(bool);

Property Value

The default value is true.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


StatusStyle Property

ProgressPanel.StatusStyle Property

Style applied to ProgressPanel Caption.

[Visual Basic]
Overridable Public Property ReadOnly StatusStyle As StatusStyle
[C#]
public virtual StatusStyle StatusStyle { get; }
[C++]
public: virtual __property StatusStyle* get_StatusStyle();
[JScript]
public virtual function get StatusStyle() : StatusStyle

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


StatusText Property

ProgressPanel.StatusText Property

The current status text displayed.

[Visual Basic]
Public Property StatusText As String
[C#]
public string StatusText { get; set; }
[C++]
public: __property String* get_StatusText();
public: __property void set_StatusText(String* );
[JScript]
public function get StatusText() : String
public function set StatusText(String);

Property Value

The default value is an empty string.

Remarks

Set this property at run-time to display custom status messages.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


StatusTextCancelled Property

ProgressPanel.StatusTextCancelled Property

Status text displayed when an upload is cancelled.

[Visual Basic]
Public Property StatusTextCancelled As String
[C#]
public string StatusTextCancelled { get; set; }
[C++]
public: __property String* get_StatusTextCancelled();
public: __property void set_StatusTextCancelled(String* );
[JScript]
public function get StatusTextCancelled() : String
public function set StatusTextCancelled(String);

Property Value

The default value is "Upload cancelled.".

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


StatusTextComplete Property

ProgressPanel.StatusTextComplete Property

Status text displayed when an upload has completed.

[Visual Basic]
Public Property StatusTextComplete As String
[C#]
public string StatusTextComplete { get; set; }
[C++]
public: __property String* get_StatusTextComplete();
public: __property void set_StatusTextComplete(String* );
[JScript]
public function get StatusTextComplete() : String
public function set StatusTextComplete(String);

Property Value

The default value is "Upload complete.".

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


StatusTextFailed Property

ProgressPanel.StatusTextFailed Property

Status text displayed when an upload has failed.

[Visual Basic]
Public Property StatusTextFailed As String
[C#]
public string StatusTextFailed { get; set; }
[C++]
public: __property String* get_StatusTextFailed();
public: __property void set_StatusTextFailed(String* );
[JScript]
public function get StatusTextFailed() : String
public function set StatusTextFailed(String);

Property Value

The default value is "Upload failed.".

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


StatusTextUploading Property

ProgressPanel.StatusTextUploading Property

Status text displayed when an upload is in progress.

[Visual Basic]
Public Property StatusTextUploading As String
[C#]
public string StatusTextUploading { get; set; }
[C++]
public: __property String* get_StatusTextUploading();
public: __property void set_StatusTextUploading(String* );
[JScript]
public function get StatusTextUploading() : String
public function set StatusTextUploading(String);

Property Value

The default value is "Uploading...".

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Tag Property

ProgressPanel.Tag Property

Gets or sets a convertible object that contains data about the control.

[Visual Basic]
Public Property Tag As Object _
    Implements ILiveControl.Tag
[C#]
public object Tag { get; set; }
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(Object* );
[JScript]
public function get Tag() : Object
public function set Tag(Object);

Property Value

An object that implements the IConvertible interface and contains data about the PowerWEB control. The default is a null reference (Nothing in Visual Basic).

Implements

ILiveControl.Tag

Remarks

Any type that implements IConvertible can be assigned to this property. If the Tag property is set through the Windows Forms designer, only text can be assigned.

Data contained within the Tag property persists across callbacks. A common use for the Tag property is to store data that is closely associated with the control.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Top Property

ProgressPanel.Top Property

Gets or sets the top position of the PowerWEB control.

[Visual Basic]
Public Property Top As Unit
[C#]
public Unit Top { get; set; }
[C++]
public: __property Unit get_Top();
public: __property void set_Top(Unit );
[JScript]
public function get Top() : Unit
public function set Top(Unit);

Property Value

A Unit that represents the top position of the control. The default is Unit.Empty.

Remarks

Use the Top property to specify the top position of the PowerWEB control. If both Left and Top are Unit.Empty (the default), relative positioning is used. If either Left or Top are not Unit.Empty, absolute positioning is used.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


UpdateAll Property

ProgressPanel.UpdateAll Property

Gets or sets which fields are posted to the server in a callback.

[Visual Basic]
Public Property UpdateAll As Boolean
[C#]
public bool UpdateAll { get; set; }
[C++]
public: __property bool get_UpdateAll();
public: __property void set_UpdateAll(bool );
[JScript]
public function get UpdateAll() : bool
public function set UpdateAll(bool);

Property Value

If true, all values for all client-side form elements are posted to the server. If false, only the value for the callback element is posted to the server. The default value is true.

Remarks

If true, all values for all client-side form elements are posted to the server. If false, only the value for the callback element is posted to the server. This can be used to highly optimize performance depending on the application. For example, if an application has a lot of form fields with a Timer raising a periodic callback, the callback lag may be signifigant, as the script has to loop through all of the form fields to get the client-side value. However, this may not be necessary. Often, you may only need to raise a callback, and don't need the values for form fields. In this case set this property to false, and the callback will execute much faster.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Visible Property

ProgressPanel.Visible Property

Gets or sets a value indicating whether the PowerWEB control is visible.

[Visual Basic]
Overrides Public Property Visible As Boolean
[C#]
public override bool Visible { get; set; }
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(bool );
[JScript]
public override function get Visible() : bool
public override function set Visible(bool);

Property Value

true if the control is visible on the page; otherwise false. The default is true.

Remarks

Use the Visible property to specify or determine whether a control is visible. When set to false, the control is rendered, but is hidden.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


WaitElementID Property

ProgressPanel.WaitElementID Property

Gets or sets the message ID of the HTML element to display a message during a pending callback.

[Visual Basic]
Public Property WaitElementID As String
[C#]
public string WaitElementID { get; set; }
[C++]
public: __property String* get_WaitElementID();
public: __property void set_WaitElementID(String* );
[JScript]
public function get WaitElementID() : String
public function set WaitElementID(String);

Property Value

The ID of an HTML element, such as a Label, that will display a message during pending callbacks.

Remarks

Use in conjunction with the WaitMessage property.

Set WaitElementID to specify the ID of the control that will display the WaitMessage during a pending callback.

Typical usage would be for immediately displaying a message (such as "Processing..") to the user during lengthy callbacks (due to network traffic or server side processing).

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


WaitMessage Property

ProgressPanel.WaitMessage Property

Gets or sets the message to display during a pending callback.

[Visual Basic]
Public Property WaitMessage As String
[C#]
public string WaitMessage { get; set; }
[C++]
public: __property String* get_WaitMessage();
public: __property void set_WaitMessage(String* );
[JScript]
public function get WaitMessage() : String
public function set WaitMessage(String);

Property Value

The message displayed during pending callbacks.

Remarks

Use in conjunction with the WaitElementID property.

Set WaitMessage to specify the message displayed by the WaitElementID control during a pending callback.

Typical usage would be for immediately displaying a message (such as "Processing...") to the user during lengthy callbacks (due to network traffic or server side processing).

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Width Property

ProgressPanel.Width Property

Gets or sets the width of the progress panel.

[Visual Basic]
Overrides Public Property Width As Unit
[C#]
public override Unit Width { get; set; }
[C++]
public: __property Unit get_Width();
public: __property void set_Width(Unit );
[JScript]
public override function get Width() : Unit
public override function set Width(Unit);

Property Value

The default value is 300px.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ProgressPanel Methods

The methods of the ProgressPanel class are listed below. For a complete list of ProgressPanel class members, see the ProgressPanel Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference | Returns JavaScript that can be used to initiate a callback to the server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState | Returns the ViewState object used to save and restore state.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
Hide | Overloaded. Hide the progress panel.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh | In a callback, updates the controls client-side representation.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag (inherited from WebControl) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
Show | Overloaded. Show the progress panel.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


GetCallbackEventReference Method

ProgressPanel.GetCallbackEventReference Method

Returns JavaScript that can be used to initiate a callback to the server.

[Visual Basic]
Public Function GetCallbackEventReference( _
   ByVal eventName As String, _
   ByVal argument As String _
) As String
[C#]
public string GetCallbackEventReference(
   string eventName,
   string argument
);
[C++]
public: String* GetCallbackEventReference(
   String* eventName,
   String* argument
);
[JScript]
public function GetCallbackEventReference(
   String eventName,
   String argument
): String;

Parameters

eventName
The event corresponding to the callback.
argument
The event arguments for the callback.

Remarks

Returns JavaScript that can be used to initiate a callback to the server.

The settings of the PowerWEB control (blocking, errorhandling, etc) are automatically taken into account.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


GetScript Method

ProgressPanel.GetScript Method

Returns all JavaScript buffered up as a result of setting control properties.

[Visual Basic]
Public Function GetScript() _
    Implements ILiveControl.GetScript As String
[C#]
public string GetScript();
[C++]
public: String* GetScript();
[JScript]
public function GetScript(): String;

Implements

ILiveControl.GetScript

Remarks

Returns all JavaScript buffered up as a result of setting properties of controls on the form.

Note This is not intended for use by end-users.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


GetScriptObjectReference Method

ProgressPanel.GetScriptObjectReference Method

Returns a client-side reference to the element.

[Visual Basic]
Public Function GetScriptObjectReference() _
    Implements ILiveControl.GetScriptObjectReference As String
[C#]
public string GetScriptObjectReference();
[C++]
public: String* GetScriptObjectReference();
[JScript]
public function GetScriptObjectReference(): String;

Implements

ILiveControl.GetScriptObjectReference

Remarks

Returns a client-side reference to the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1")" (depending on the browser).

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


GetScriptStyleReference Method

ProgressPanel.GetScriptStyleReference Method

Returns a client-side reference to the style object of the element.

[Visual Basic]
Public Function GetScriptStyleReference() _
    Implements ILiveControl.GetScriptStyleReference As String
[C#]
public string GetScriptStyleReference();
[C++]
public: String* GetScriptStyleReference();
[JScript]
public function GetScriptStyleReference(): String;

Implements

ILiveControl.GetScriptStyleReference

Remarks

Returns a client-side reference to the style object of the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1").style" (depending on the browser).

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


GetViewState Method

ProgressPanel.GetViewState Method

Returns the ViewState object used to save and restore state.

[Visual Basic]
Public Function GetViewState() _
    Implements ILiveControl.GetViewState As Object
[C#]
public object GetViewState();
[C++]
public: Object* GetViewState();
[JScript]
public function GetViewState(): Object;

Implements

ILiveControl.GetViewState

Remarks

Returns the ViewState object used by PowerWEB controls to save and restore state.

Note This is not intended for use by end-users.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Hide Method

ProgressPanel.Hide Method

Hide the progress panel.

Overload List

Hide the progress panel.

[Visual Basic] Public Sub Hide()
[C#] public void Hide();
[C++] public: void Hide();
[JScript] public function Hide();

Hide the progress panel after a delay when uploads have completed.

[Visual Basic] Public Sub Hide(ByVal Integer)
[C#] public void Hide(int);
[C++] public: void Hide(int);
[JScript] public function Hide(int);

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Hide Method ()

ProgressPanel.Hide Method ()

Hide the progress panel.

[Visual Basic]
Public Sub Hide()
[C#]
public void Hide();
[C++]
public: void Hide();
[JScript]
public function Hide();

Remarks

Default Upload behavior is for the progress panel to be hidden automatically after uploads have completed.

In custom solutions, or if CloseOnComplete is CloseBehavior.None, Hide can be called from within a callback to close the panel.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace | ProgressPanel.Hide Overload List


Hide Method (Int32)

ProgressPanel.Hide Method (Int32)

Hide the progress panel after a delay when uploads have completed.

[Visual Basic]
Public Sub Hide( _
   ByVal delay As Integer _
)
[C#]
public void Hide(
   int delay
);
[C++]
public: void Hide(
   int delay
);
[JScript]
public function Hide(
   int delay
);

Parameters

delay
Integer (in milliseconds) to delay hiding the progress panel after uploads have completed.

Remarks

Default Upload behavior is for the progress panel to be hidden automatically after uploads have completed.

In custom solutions, or if CloseOnComplete is CloseBehavior.None, Hide can be called from within a callback to close the panel.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace | ProgressPanel.Hide Overload List


Refresh Method

ProgressPanel.Refresh Method

In a callback, updates the controls client-side representation.

[Visual Basic]
Public Sub Refresh() _
    Implements ILiveControl.Refresh
[C#]
public void Refresh();
[C++]
public: void Refresh();
[JScript]
public function Refresh();

Implements

ILiveControl.Refresh

Remarks

When the request is an incoming callback, this method forces the control to update itself client-side (whether a change was detected within the control or not).

When the request is not an Ajax callback, this method has no effect.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Show Method

ProgressPanel.Show Method

Show the progress panel.

Overload List

Show the progress panel.

[Visual Basic] Public Sub Show()
[C#] public void Show();
[C++] public: void Show();
[JScript] public function Show();

Show the progress panel with a delay before starting uploads.

[Visual Basic] Public Sub Show(ByVal Integer)
[C#] public void Show(int);
[C++] public: void Show(int);
[JScript] public function Show(int);

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Show Method ()

ProgressPanel.Show Method ()

Show the progress panel.

[Visual Basic]
Public Sub Show()
[C#]
public void Show();
[C++]
public: void Show();
[JScript]
public function Show();

Remarks

Default Upload behavior is for the progress panel to be shown automatically. Call Show in custom solutions in which the progress panel is shown within a callback.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace | ProgressPanel.Show Overload List


Show Method (Int32)

ProgressPanel.Show Method (Int32)

Show the progress panel with a delay before starting uploads.

[Visual Basic]
Public Sub Show( _
   ByVal delay As Integer _
)
[C#]
public void Show(
   int delay
);
[C++]
public: void Show(
   int delay
);
[JScript]
public function Show(
   int delay
);

Parameters

delay
Integer (in milliseconds) to delay after showing the progress panel.

Remarks

Default Upload behavior is for the progress panel to be shown automatically. Call Show in custom solutions in which the progress panel is shown within a callback.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace | ProgressPanel.Show Overload List


ProgressPanel Events

The events of the ProgressPanel class are listed below. For a complete list of ProgressPanel class members, see the ProgressPanel Members topic.

Public Instance Events

ContextMenuChanged | Occurs when the right button of the PowerWEB control is clicked.
DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
DoubleClick | Occurs when the control is double-clicked.
GotFocus | Occurs when the PowerWEB control gains focus.
HelpRequested | Occurs when F1 is pressed while the control has focus.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
KeyDown | Occurs when a key is down while the control has focus.
KeyPress | Occurs when a key is pressed while the control has focus.
KeyUp | Occurs when a key is released while the control has focus.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
LocationClick | Occurs when the PowerWEB control is clicked, providing location data.
LostFocus | Occurs when the PowerWEB control loses focus.
MouseDown | Occurs when the mouse buttons are pressed while the PowerWEB control has focus.
MouseEnter | Occurs when the mouse pointer enters the PowerWEB control.
MouseLeave | Occurs when the mouse pointer leaves the PowerWEB control.
MouseUp | Occurs when the mouse buttons are released while the PowerWEB control has focus.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ContextMenuChanged Event

ProgressPanel.ContextMenuChanged Event

Occurs when the right button of the PowerWEB control is clicked.

[Visual Basic]
Public Event ContextMenuChanged As LocationEventHandler
[C#]
public event LocationEventHandler ContextMenuChanged;
[C++]
public: __event LocationEventHandler* ContextMenuChanged;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The ContextMenuChanged event fires when the right button is clicked. This event is the equivalent of the Click event for the left button.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


DoubleClick Event

ProgressPanel.DoubleClick Event

Occurs when the control is double-clicked.

[Visual Basic]
Public Event DoubleClick As LocationEventHandler
[C#]
public event LocationEventHandler DoubleClick;
[C++]
public: __event LocationEventHandler* DoubleClick;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The DoubleClick event fires when the control is double-clicked.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


GotFocus Event

ProgressPanel.GotFocus Event

Occurs when the PowerWEB control gains focus.

[Visual Basic]
Public Event GotFocus As EventHandler
[C#]
public event EventHandler GotFocus;
[C++]
public: __event EventHandler* GotFocus;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The GotFocus event fires when the PowerWEB control gains focus. LostFocus fires when the PowerWEB control loses focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


HelpRequested Event

ProgressPanel.HelpRequested Event

Occurs when F1 is pressed while the control has focus.

[Visual Basic]
Public Event HelpRequested As LocationEventHandler
[C#]
public event LocationEventHandler HelpRequested;
[C++]
public: __event LocationEventHandler* HelpRequested;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The HelpRequested event fires when F1 is pressed while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


KeyDown Event

ProgressPanel.KeyDown Event

Occurs when a key is down while the control has focus.

[Visual Basic]
Public Event KeyDown As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown;
[C++]
public: __event KeyEventHandler* KeyDown;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Remarks

The KeyDown event fires when a key is down while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


KeyPress Event

ProgressPanel.KeyPress Event

Occurs when a key is pressed while the control has focus.

[Visual Basic]
Public Event KeyPress As KeyEventHandler
[C#]
public event KeyEventHandler KeyPress;
[C++]
public: __event KeyEventHandler* KeyPress;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Remarks

The KeyPress event fires when a key is pressed while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


KeyUp Event

ProgressPanel.KeyUp Event

Occurs when a key is released while the control has focus.

[Visual Basic]
Public Event KeyUp As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp;
[C++]
public: __event KeyEventHandler* KeyUp;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Remarks

The KeyUp event fires when a key is released while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


LocationClick Event

ProgressPanel.LocationClick Event

Occurs when the PowerWEB control is clicked, providing location data.

[Visual Basic]
Public Event LocationClick As LocationEventHandler
[C#]
public event LocationEventHandler LocationClick;
[C++]
public: __event LocationEventHandler* LocationClick;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The LocationClick event fires when the PowerWEB control is clicked, providing Top and Left location data.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


LostFocus Event

ProgressPanel.LostFocus Event

Occurs when the PowerWEB control loses focus.

[Visual Basic]
Public Event LostFocus As EventHandler
[C#]
public event EventHandler LostFocus;
[C++]
public: __event EventHandler* LostFocus;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The LostFocus event fires when the PowerWEB control loses focus. GotFocus fires when the PowerWEB control gains focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


MouseDown Event

ProgressPanel.MouseDown Event

Occurs when the mouse buttons are pressed while the PowerWEB control has focus.

[Visual Basic]
Public Event MouseDown As LocationEventHandler
[C#]
public event LocationEventHandler MouseDown;
[C++]
public: __event LocationEventHandler* MouseDown;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseDown event fires when any button is pressed.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


MouseEnter Event

ProgressPanel.MouseEnter Event

Occurs when the mouse pointer enters the PowerWEB control.

[Visual Basic]
Public Event MouseEnter As LocationEventHandler
[C#]
public event LocationEventHandler MouseEnter;
[C++]
public: __event LocationEventHandler* MouseEnter;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseEnter event fires when the mouse pointer enters the PowerWEB control. MouseLeave will fire when the mouse pointer leaves the control.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


MouseLeave Event

ProgressPanel.MouseLeave Event

Occurs when the mouse pointer leaves the PowerWEB control.

[Visual Basic]
Public Event MouseLeave As LocationEventHandler
[C#]
public event LocationEventHandler MouseLeave;
[C++]
public: __event LocationEventHandler* MouseLeave;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseLeave event fires when the mouse pointer leaves the PowerWEB control. MouseEnter will fire when the mouse pointer enters the control.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


MouseUp Event

ProgressPanel.MouseUp Event

Occurs when the mouse buttons are released while the PowerWEB control has focus.

[Visual Basic]
Public Event MouseUp As LocationEventHandler
[C#]
public event LocationEventHandler MouseUp;
[C++]
public: __event LocationEventHandler* MouseUp;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseUp event fires when any button is released.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


ResourceHttpHandler Class

Summary description for ResourceHttpHandler.

For a list of all members of this type, see ResourceHttpHandler Members.

System.Object
Dart.PowerWEB.FileUpload.ResourceHttpHandler

[Visual Basic]
Public Class ResourceHttpHandler
    Implements IHttpHandler
[C#]
public class ResourceHttpHandler : IHttpHandler
[C++]
public __gc class ResourceHttpHandler : public IHttpHandler
[JScript]
public class ResourceHttpHandler extends IHttpHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

ResourceHttpHandler Members | Dart.PowerWEB.FileUpload Namespace


ResourceHttpHandler Members

ResourceHttpHandler overview

Public Instance Constructors

ResourceHttpHandler Constructor Initializes a new instance of the ResourceHttpHandler class.

Public Instance Properties

IsReusable This property is used to indicate that the object instance can be used by other requests. It always returns true.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRequest | Load the resource specified in the query string and return it as the HTTP response.
ReadBinaryResource | Read a binary resource such as an image in from the stream. Since the size of the resource cannot be obtained, it is read in a block at a time until the end of the stream is reached.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceHttpHandler Class | Dart.PowerWEB.FileUpload Namespace


ResourceHttpHandler Constructor

Initializes a new instance of the ResourceHttpHandler class.

[Visual Basic]
Public Sub New()
[C#]
public ResourceHttpHandler();
[C++]
public: ResourceHttpHandler();
[JScript]
public function ResourceHttpHandler();

See Also

ResourceHttpHandler Class | Dart.PowerWEB.FileUpload Namespace


ResourceHttpHandler Properties

The properties of the ResourceHttpHandler class are listed below. For a complete list of ResourceHttpHandler class members, see the ResourceHttpHandler Members topic.

Public Instance Properties

IsReusable This property is used to indicate that the object instance can be used by other requests. It always returns true.

See Also

ResourceHttpHandler Class | Dart.PowerWEB.FileUpload Namespace


IsReusable Property

ResourceHttpHandler.IsReusable Property

This property is used to indicate that the object instance can be used by other requests. It always returns true.

[Visual Basic]
Public Property ReadOnly IsReusable As Boolean _
    Implements IHttpHandler.IsReusable
[C#]
public bool IsReusable { get; }
[C++]
public: __property bool get_IsReusable();
[JScript]
public function get IsReusable() : bool

Implements

IHttpHandler.IsReusable

See Also

ResourceHttpHandler Class | Dart.PowerWEB.FileUpload Namespace


ResourceHttpHandler Methods

The methods of the ResourceHttpHandler class are listed below. For a complete list of ResourceHttpHandler class members, see the ResourceHttpHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRequest | Load the resource specified in the query string and return it as the HTTP response.
ReadBinaryResource | Read a binary resource such as an image in from the stream. Since the size of the resource cannot be obtained, it is read in a block at a time until the end of the stream is reached.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceHttpHandler Class | Dart.PowerWEB.FileUpload Namespace


ProcessRequest Method

ResourceHttpHandler.ProcessRequest Method

Load the resource specified in the query string and return it as the HTTP response.

[Visual Basic]
Public Sub ProcessRequest( _
   ByVal hc As HttpContext _
) _
    Implements IHttpHandler.ProcessRequest
[C#]
public void ProcessRequest(
   HttpContext hc
);
[C++]
public: void ProcessRequest(
   HttpContext* hc
);
[JScript]
public function ProcessRequest(
   HttpContext hc
);

Parameters

hc
The context object for the request

Implements

IHttpHandler.ProcessRequest

See Also

ResourceHttpHandler Class | Dart.PowerWEB.FileUpload Namespace


ReadBinaryResource Method

ResourceHttpHandler.ReadBinaryResource Method

Read a binary resource such as an image in from the stream. Since the size of the resource cannot be obtained, it is read in a block at a time until the end of the stream is reached.

[Visual Basic]
Public Sub ReadBinaryResource( _
   ByVal sIn As Stream, _
   ByRef byBuffer As Byte(), _
   ByRef nLen As Integer _
)
[C#]
public void ReadBinaryResource(
   Stream sIn,
   out byte[] byBuffer,
   out int nLen
);
[C++]
public: void ReadBinaryResource(
   Stream* sIn,
   * char byBuffer __gc[],
   * int nLen
);
[JScript]
public function ReadBinaryResource(
   Stream sIn,
   Byte[] byBuffer,
   int nLen
);

Parameters

sIn
The stream from which to read the resource
byBuffer
An out parameter to receive the resource bytes
nLen
An out parameter to receive the resource length

See Also

ResourceHttpHandler Class | Dart.PowerWEB.FileUpload Namespace


StatusStyle Class

Gets a System.Web.UI.WebControls.Style object representing the style that will be applied to the Status bar.

For a list of all members of this type, see StatusStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.FileUpload.StatusStyle

[Visual Basic]
Public Class StatusStyle
    Inherits Style
[C#]
public class StatusStyle : Style
[C++]
public __gc class StatusStyle : public Style
[JScript]
public class StatusStyle extends Style

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

StatusStyle Members | Dart.PowerWEB.FileUpload Namespace


StatusStyle Members

StatusStyle overview

Public Instance Constructors

StatusStyle Constructor Initializes a new instance of the StatusStyle class.

Public Instance Properties

BackColor (inherited from Style) | Gets or sets the background color of the Web server control.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from Style) | Gets or sets the CSS class rendered by the Web server control on the client.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TextAlign | Gets or sets the horizontal alignment of the status text.
Width | Gets or sets the status width.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
CopyFrom (inherited from Style) | Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith (inherited from Style) | Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset (inherited from Style) | Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overridden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

StatusStyle Class | Dart.PowerWEB.FileUpload Namespace


StatusStyle Constructor

Initializes a new instance of the StatusStyle class.

[Visual Basic]
Public Sub New()
[C#]
public StatusStyle();
[C++]
public: StatusStyle();
[JScript]
public function StatusStyle();

See Also

StatusStyle Class | Dart.PowerWEB.FileUpload Namespace


StatusStyle Properties

The properties of the StatusStyle class are listed below. For a complete list of StatusStyle class members, see the StatusStyle Members topic.

Public Instance Properties

BackColor (inherited from Style) | Gets or sets the background color of the Web server control.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass (inherited from Style) | Gets or sets the CSS class rendered by the Web server control on the client.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TextAlign | Gets or sets the horizontal alignment of the status text.
Width | Gets or sets the status width.

See Also

StatusStyle Class | Dart.PowerWEB.FileUpload Namespace


TextAlign Property

StatusStyle.TextAlign Property

Gets or sets the horizontal alignment of the status text.

[Visual Basic]
Public Property TextAlign As HorizontalAlign
[C#]
public HorizontalAlign TextAlign { get; set; }
[C++]
public: __property HorizontalAlign get_TextAlign();
public: __property void set_TextAlign(HorizontalAlign );
[JScript]
public function get TextAlign() : HorizontalAlign
public function set TextAlign(HorizontalAlign);

Property Value

The default value is HorizontalAlign.NotSet.

See Also

StatusStyle Class | Dart.PowerWEB.FileUpload Namespace


Width Property

StatusStyle.Width Property

Gets or sets the status width.

[Visual Basic]
Public Property Width As Unit
[C#]
public Unit Width { get; set; }
[C++]
public: __property Unit get_Width();
public: __property void set_Width(Unit );
[JScript]
public function get Width() : Unit
public function set Width(Unit);

Property Value

The default value is 100%.

See Also

StatusStyle Class | Dart.PowerWEB.FileUpload Namespace


TextBoxStyle Class

For a list of all members of this type, see TextBoxStyle Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.UI.WebControls.Style
Dart.PowerWEB.FileUpload.TextBoxStyle

[Visual Basic]
Public Class TextBoxStyle
    Inherits Style
[C#]
public class TextBoxStyle : Style
[C++]
public __gc class TextBoxStyle : public Style
[JScript]
public class TextBoxStyle extends Style

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

TextBoxStyle Members | Dart.PowerWEB.FileUpload Namespace


TextBoxStyle Members

TextBoxStyle overview

Public Instance Constructors

TextBoxStyle Constructor

Public Instance Properties

BackColor (inherited from Style) | Gets or sets the background color of the Web server control.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass | This property is not implemented for this class - configuration of control's visual elements must be done directly to ensure proper behavior at runtime.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from Style) | Gets or sets the width of the Web server control.

Public Instance Methods

AddAttributesToRender (inherited from Style) | Overloaded. Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.
CopyFrom (inherited from Style) | Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith (inherited from Style) | Combines the style properties of the specified Style with the instance of the Style class that this method is called from.
Reset (inherited from Style) | Removes any defined style elements from the state bag.
ToString (inherited from Style) | Overridden.

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

See Also

TextBoxStyle Class | Dart.PowerWEB.FileUpload Namespace


TextBoxStyle Constructor

[Visual Basic]
Public Sub New()
[C#]
public TextBoxStyle();
[C++]
public: TextBoxStyle();
[JScript]
public function TextBoxStyle();

See Also

TextBoxStyle Class | Dart.PowerWEB.FileUpload Namespace


TextBoxStyle Properties

The properties of the TextBoxStyle class are listed below. For a complete list of TextBoxStyle class members, see the TextBoxStyle Members topic.

Public Instance Properties

BackColor (inherited from Style) | Gets or sets the background color of the Web server control.
BorderColor (inherited from Style) | Gets or sets the border color of the Web server control.
BorderStyle (inherited from Style) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from Style) | Gets or sets the border width of the Web server control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CssClass | This property is not implemented for this class - configuration of control's visual elements must be done directly to ensure proper behavior at runtime.
Font (inherited from Style) | Gets the font properties associated with the Web server control.
ForeColor (inherited from Style) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height (inherited from Style) | Gets or sets the height of the Web server control.
Site (inherited from Component) | Gets or sets the ISite of the Component.
Width (inherited from Style) | Gets or sets the width of the Web server control.

See Also

TextBoxStyle Class | Dart.PowerWEB.FileUpload Namespace


CssClass Property

TextBoxStyle.CssClass Property

This property is not implemented for this class - configuration of control's visual elements must be done directly to ensure proper behavior at runtime.

[Visual Basic]
Public Property CssClass As String
[C#]
public string CssClass { get; set; }
[C++]
public: __property String* get_CssClass();
public: __property void set_CssClass(String* );
[JScript]
public function get CssClass() : String
public function set CssClass(String);

See Also

TextBoxStyle Class | Dart.PowerWEB.FileUpload Namespace


Upload Class

An enhanced control for uploading files to the server.

For a list of all members of this type, see Upload Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.FileUpload.Upload

[Visual Basic]
Public Class Upload
    Inherits WebControl
    Implements ILiveControl, IPostBackEventHandler
[C#]
public class Upload : WebControl, ILiveControl, IPostBackEventHandler
[C++]
public __gc class Upload : public WebControl, ILiveControl, IPostBackEventHandler
[JScript]
public class Upload extends WebControl, ILiveControl, IPostBackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Set Upload.AutoPostback to true for uploads to begin immediately after files are selected. Set the property to false to require a form submission.

Use of the Upload control requires the presence of an UploadManager control on the webform. Set the UploadManager properties to configure file upload behavior.

Use the ProgressPanel to display information on uploads as they happen.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Upload Members | Dart.PowerWEB.FileUpload Namespace


Upload Members

Upload overview

Public Instance Constructors

Upload Overloaded. Initializes a new instance of the Upload class.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
AutoPostBack | When true, the control will immediately initiate an upload as soon as a file is selected within the file dialog.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) |
Blocking | Gets or sets the blocking state of the control.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
ButtonImageUrl | Image to use for the Browse button in place of a standard HTML button.
ButtonStyle | Enables configuration of the Upload select button.
ButtonType | Defines the type of button to display for selecting files.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
DynamicValidation | Use to inject validation code into the initial Page render.
EnableCallback | Gets or sets whether the control issues a callback.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ErrorBehavior | Gets or sets how errors are handled by the control.
ErrorMessage | Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.
FilterDescription | Text to display in file dialog when using Flash upload and custom FilterExtension setting.
FilterExtension | A semi-colon delimited list of file extensions to allow. For example, \"*.jpg;*.gif\".
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height | Overridden. Gets or sets the height of the Upload control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
Left | Gets or sets the left position of the PowerWEB control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
ShowTextBox | When set to false, the Upload control will simply appear as a button.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
Tag | Gets or sets a convertible object that contains data about the control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | The text displayed on the Upload control's Button.
TextBoxStyle | Enables configuration of the Upload textbox.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Top | Gets or sets the top position of the PowerWEB control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll | Gets or sets which fields are posted to the server in a callback.
Visible | Overridden. Gets or sets a value indicating whether the PowerWEB control is visible.
WaitElementID | Gets or sets the message ID of the HTML element to display a message during a pending callback.
WaitMessage | Gets or sets the message to display during a pending callback.
Width | Overridden. Gets or sets the width of the Upload control.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference | Returns JavaScript that can be used to initiate a callback to the server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState | Returns the ViewState object used to save and restore state.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh | In a callback, updates the controls client-side representation.
RenderBeginTag | Overridden. Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag | Overridden. Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ContextMenuChanged | Occurs when the right button of the PowerWEB control is clicked.
DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
DoubleClick | Occurs when the control is double-clicked.
GotFocus | Occurs when the PowerWEB control gains focus.
HelpRequested | Occurs when F1 is pressed while the control has focus.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
KeyDown | Occurs when a key is down while the control has focus.
KeyPress | Occurs when a key is pressed while the control has focus.
KeyUp | Occurs when a key is released while the control has focus.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
LocationClick | Occurs when the PowerWEB control is clicked, providing location data.
LostFocus | Occurs when the PowerWEB control loses focus.
MouseDown | Occurs when the mouse buttons are pressed while the PowerWEB control has focus.
MouseEnter | Occurs when the mouse pointer enters the PowerWEB control.
MouseLeave | Occurs when the mouse pointer leaves the PowerWEB control.
MouseUp | Occurs when the mouse buttons are released while the PowerWEB control has focus.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Upload Constructor

Initializes a new instance of the Upload control.

Overload List

Initializes a new instance of the Upload control.

[Visual Basic] Public Sub New()
[C#] public Upload();
[C++] public: Upload();
[JScript] public function Upload();

Initializes a new instance of the Upload control.

[Visual Basic] Public Sub New(ByVal String)
[C#] public Upload(string);
[C++] public: Upload(String*);
[JScript] public function Upload(String);

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Upload Constructor ()

Initializes a new instance of the Upload control.

[Visual Basic]
Public Sub New()
[C#]
public Upload();
[C++]
public: Upload();
[JScript]
public function Upload();

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace | Upload Constructor Overload List


Upload Constructor (String)

Initializes a new instance of the Upload control.

[Visual Basic]
Public Sub New( _
   ByVal oemLK As String _
)
[C#]
public Upload(
   string oemLK
);
[C++]
public: Upload(
   String* oemLK
);
[JScript]
public function Upload(
   String oemLK
);

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace | Upload Constructor Overload List


Upload Properties

The properties of the Upload class are listed below. For a complete list of Upload class members, see the Upload Members topic.

Public Instance Properties

AccessKey (inherited from WebControl) | Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
AutoPostBack | When true, the control will immediately initiate an upload as soon as a file is selected within the file dialog.
BackColor (inherited from WebControl) | Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) |
Blocking | Gets or sets the blocking state of the control.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
ButtonImageUrl | Image to use for the Browse button in place of a standard HTML button.
ButtonStyle | Enables configuration of the Upload select button.
ButtonType | Defines the type of button to display for selecting files.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
DynamicValidation | Use to inject validation code into the initial Page render.
EnableCallback | Gets or sets whether the control issues a callback.
Enabled (inherited from WebControl) | Gets or sets a value indicating whether the Web server control is enabled.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
ErrorBehavior | Gets or sets how errors are handled by the control.
ErrorMessage | Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.
FilterDescription | Text to display in file dialog when using Flash upload and custom FilterExtension setting.
FilterExtension | A semi-colon delimited list of file extensions to allow. For example, \"*.jpg;*.gif\".
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Height | Overridden. Gets or sets the height of the Upload control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
Left | Gets or sets the left position of the PowerWEB control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
ShowTextBox | When set to false, the Upload control will simply appear as a button.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex (inherited from WebControl) | Gets or sets the tab index of the Web server control.
Tag | Gets or sets a convertible object that contains data about the control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
Text | The text displayed on the Upload control's Button.
TextBoxStyle | Enables configuration of the Upload textbox.
ToolTip (inherited from WebControl) | Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Top | Gets or sets the top position of the PowerWEB control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll | Gets or sets which fields are posted to the server in a callback.
Visible | Overridden. Gets or sets a value indicating whether the PowerWEB control is visible.
WaitElementID | Gets or sets the message ID of the HTML element to display a message during a pending callback.
WaitMessage | Gets or sets the message to display during a pending callback.
Width | Overridden. Gets or sets the width of the Upload control.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


AutoPostBack Property

Upload.AutoPostBack Property

When true, the control will immediately initiate an upload as soon as a file is selected within the file dialog.

[Visual Basic]
Public Property AutoPostBack As Boolean
[C#]
public bool AutoPostBack { get; set; }
[C++]
public: __property bool get_AutoPostBack();
public: __property void set_AutoPostBack(bool );
[JScript]
public function get AutoPostBack() : bool
public function set AutoPostBack(bool);

Property Value

The default value is true.

Remarks

If false, the form must be submitted for the upload to occur.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Blocking Property

Upload.Blocking Property

Gets or sets the blocking state of the control.

[Visual Basic]
Public Property Blocking As Boolean
[C#]
public bool Blocking { get; set; }
[C++]
public: __property bool get_Blocking();
public: __property void set_Blocking(bool );
[JScript]
public function get Blocking() : bool
public function set Blocking(bool);

Property Value

true if other PowerWEB controls should be disabled while the PowerWEB control has a pending callback.

Remarks

Although callbacks always occur asynchronously, when this property is true, a simulated blocking will be used. The interface will be disabled and updated as busy when a callback is pending (although the code itself will not block).

Note Only PowerWEB controls will be blocked. The user will still be able to interact with non-PowerWEB controls.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


BrowserType Property

Upload.BrowserType Property

Gets or sets the type of browser as detected by the PowerWEB control.

[Visual Basic]
Public Property BrowserType As BrowserType _
    Implements ILiveControl.BrowserType
[C#]
public BrowserType BrowserType { get; set; }
[C++]
public: __property BrowserType get_BrowserType();
public: __property void set_BrowserType(BrowserType );
[JScript]
public function get BrowserType() : BrowserType
public function set BrowserType(BrowserType);

Property Value

A BrowserType that represents the browser rendering the PowerWEB control.

Implements

ILiveControl.BrowserType

Remarks

This property is set when the PowerWEB control is initialized, based on the user-agent header sent by the browser. BrowserType can also be set to override the detected value with a custom browser detection algorithm.

Note This property is global to all PowerWEB controls. Any change to an individual PowerWEB control will automatically be applied to all PowerWEB controls on the form. It is not possible to have PowerWEB controls with different BrowserType values on the same form.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


BufferedScript Property

Upload.BufferedScript Property

Gets the client-side script which will be written to the response stream when the callback request is ended.

[Visual Basic]
Public Property ReadOnly BufferedScript As StringWriter _
    Implements ILiveControl.BufferedScript
[C#]
public StringWriter BufferedScript { get; }
[C++]
public: __property StringWriter* get_BufferedScript();
[JScript]
public function get BufferedScript() : StringWriter

Property Value

A StringWriter object that contains buffered script for a callback response.

Implements

ILiveControl.BufferedScript

Remarks

Use the BufferedScript property to modify the client-side script to be sent in response to a callback.

For example, to dynamically change the flow of a label (from bottom to top instead of left to right):

LiveLabel1.BufferedScript.Write(LiveLabel1.GetScriptStyleReference() + ".writingMode = 'tb-rl';");

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


ButtonImageUrl Property

Upload.ButtonImageUrl Property

Image to use for the Browse button in place of a standard HTML button.

[Visual Basic]
Public Property ButtonImageUrl As String
[C#]
public string ButtonImageUrl { get; set; }
[C++]
public: __property String* get_ButtonImageUrl();
public: __property void set_ButtonImageUrl(String* );
[JScript]
public function get ButtonImageUrl() : String
public function set ButtonImageUrl(String);

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


ButtonStyle Property

Upload.ButtonStyle Property

Enables configuration of the Upload select button.

[Visual Basic]
Public Property ReadOnly ButtonStyle As ButtonStyle
[C#]
public ButtonStyle ButtonStyle { get; }
[C++]
public: __property ButtonStyle* get_ButtonStyle();
[JScript]
public function get ButtonStyle() : ButtonStyle

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


ButtonType Property

Upload.ButtonType Property

Defines the type of button to display for selecting files.

[Visual Basic]
Public Property ButtonType As ButtonType
[C#]
public ButtonType ButtonType { get; set; }
[C++]
public: __property ButtonType get_ButtonType();
public: __property void set_ButtonType(ButtonType );
[JScript]
public function get ButtonType() : ButtonType
public function set ButtonType(ButtonType);

Remarks

ButtonType can be either a PushButton, ImageButton, or LinkButton. When using an ImageButton, the ButtonImageUrl property must be defined.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


CallbackType Property

Upload.CallbackType Property

Gets or sets the type of callbacks performed by the PowerWEB control.

[Visual Basic]
Public Property CallbackType As CallbackType _
    Implements ILiveControl.CallbackType
[C#]
public CallbackType CallbackType { get; set; }
[C++]
public: __property CallbackType get_CallbackType();
public: __property void set_CallbackType(CallbackType );
[JScript]
public function get CallbackType() : CallbackType
public function set CallbackType(CallbackType);

Property Value

A CallbackType that represents the mechanism used for callbacks by the PowerWEB control.

Implements

ILiveControl.CallbackType

Remarks

The optimal approach is CallbackType.XmlHttp. The first fallback approach is CallbackType.Flash. The final fallback is CallbackType.IFrame.

Defaults to CallbackType.AutoDetect. On the initial page load, CallbackType is set to the most appropriate value based on the browser type detected.

Set to override when auto-detection is insufficient. For example, if the browser has ActiveX turned off, XmlHttp and Flash will fail. However, the PowerWEB controls will not be aware of this, because this setting cannot be detected server-side. A developer can determine if ActiveX is off and set to IFRAME to provide a decent callback approach.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Debug Property

Upload.Debug Property

Set to true to display a debug window which displays callback data in real-time as it is set/received.

[Visual Basic]
Public Property Debug As Boolean _
    Implements ILiveControl.Debug
[C#]
public bool Debug { get; set; }
[C++]
public: __property bool get_Debug();
public: __property void set_Debug(bool );
[JScript]
public function get Debug() : bool
public function set Debug(bool);

Property Value

true if a debug window is displayed when callback data is sent/received; false otherwise. The default value is false;

Implements

ILiveControl.Debug

Remarks

This property is intended to be used by application developers to assist in diagnosis of application bugs. Set this property to true to see the JavaScript that is executed on the client-side as a result of the server-side interaction with the controls.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


DynamicValidation Property

Upload.DynamicValidation Property

Use to inject validation code into the initial Page render.

[Visual Basic]
Public Property DynamicValidation As Boolean _
    Implements ILiveControl.DynamicValidation
[C#]
public bool DynamicValidation { get; set; }
[C++]
public: __property bool get_DynamicValidation();
public: __property void set_DynamicValidation(bool );
[JScript]
public function get DynamicValidation() : bool
public function set DynamicValidation(bool);

Property Value

A bool determining whether or not validation code is rendered in initial Page load. The default value is false.

Implements

ILiveControl.DynamicValidation

Remarks

Note, most scenarios do not require this property. Use this property only if (1) a control requiring validation is going to be created in a callback and (2) no other controls requiring validation are present on initial page load.

If a control requires validation, the code to perform this validation is set up in initial page load. This code includes a reference to an external script file, and a script block. However, if no control requiring validation is present on initial page load, but is created in a subsequent callback, validation is skipped because the validation script was not properly set up. Set this property to true on initial page load to create the validation script which can be used by any control created in subsequent callbacks.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


EnableCallback Property

Upload.EnableCallback Property

Gets or sets whether the control issues a callback.

[Visual Basic]
Public Property EnableCallback As Boolean
[C#]
public bool EnableCallback { get; set; }
[C++]
public: __property bool get_EnableCallback();
public: __property void set_EnableCallback(bool );
[JScript]
public function get EnableCallback() : bool
public function set EnableCallback(bool);

Property Value

true if the PowerWEB control uses callbacks. When false, the PowerWEB control uses traditional postbacks.

Remarks

Set EnableCallback to true for the PowerWEB control to use callbacks, as opposed to traditional postbacks.

Set to false to force the control to behave like its non-live counterpart.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


ErrorBehavior Property

Upload.ErrorBehavior Property

Gets or sets how errors are handled by the control.

[Visual Basic]
Public Property ErrorBehavior As ErrorBehavior
[C#]
public ErrorBehavior ErrorBehavior { get; set; }
[C++]
public: __property ErrorBehavior get_ErrorBehavior();
public: __property void set_ErrorBehavior(ErrorBehavior );
[JScript]
public function get ErrorBehavior() : ErrorBehavior
public function set ErrorBehavior(ErrorBehavior);

Property Value

An ErrorBehavior enumerated value. Defaults to ErrorBehavior.ShowInBrowser.

Remarks

Set ErrorBehavior to specify whether an exception raised by the PowerWEB control should cause an error page, an alert box, or no indication to appear.

If set to ErrorBehavior.ShowAlert, set the alert message using the ErrorMessage property.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


ErrorMessage Property

Upload.ErrorMessage Property

Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.

[Visual Basic]
Public Property ErrorMessage As String
[C#]
public string ErrorMessage { get; set; }
[C++]
public: __property String* get_ErrorMessage();
public: __property void set_ErrorMessage(String* );
[JScript]
public function get ErrorMessage() : String
public function set ErrorMessage(String);

Property Value

A message to display when an error occurs.

Remarks

Set ErrorMessage to specify the contents of the Alert. Alternatively, set ErrorBehavior to ErrorBehavior.ShowInBrowser to see specific error information.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


FilterDescription Property

Upload.FilterDescription Property

Text to display in file dialog when using Flash upload and custom FilterExtension setting.

[Visual Basic]
Public Property FilterDescription As String
[C#]
public string FilterDescription { get; set; }
[C++]
public: __property String* get_FilterDescription();
public: __property void set_FilterDescription(String* );
[JScript]
public function get FilterDescription() : String
public function set FilterDescription(String);

Property Value

The default value is "All Files (*.*)".

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


FilterExtension Property

Upload.FilterExtension Property

A semi-colon delimited list of file extensions to allow. For example, \"*.jpg;*.gif\".

[Visual Basic]
Public Property FilterExtension As String
[C#]
public string FilterExtension { get; set; }
[C++]
public: __property String* get_FilterExtension();
public: __property void set_FilterExtension(String* );
[JScript]
public function get FilterExtension() : String
public function set FilterExtension(String);

Property Value

The default value is "*.*".

Remarks

When using Flash upload type, this filter will be enforced in the file dialog.

When using IFrame upload type, this will be globally enforced on the server according to the Extensions property of the UploadManager control.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Height Property

Upload.Height Property

Gets or sets the height of the Upload control.

[Visual Basic]
Overrides Public Property Height As Unit
[C#]
public override Unit Height { get; set; }
[C++]
public: __property Unit get_Height();
public: __property void set_Height(Unit );
[JScript]
public override function get Height() : Unit
public override function set Height(Unit);

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


IsCallback Property

Upload.IsCallback Property

Gets the callback state of the PowerWEB control.

[Visual Basic]
Public Property IsCallback As Boolean _
    Implements ILiveControl.IsCallback
[C#]
public bool IsCallback { get; set; }
[C++]
public: __property bool get_IsCallback();
public: __property void set_IsCallback(bool );
[JScript]
public function get IsCallback() : bool
public function set IsCallback(bool);

Property Value

true if the PowerWEB control is currently in a callback state, false otherwise.

Implements

ILiveControl.IsCallback

Remarks

Use the IsCallback property to differentiate between a postback and live callback.

Note This property is global to all PowerWEB controls.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


IsLive Property

Upload.IsLive Property

Gets or sets whether a PowerWEB control updates itself in a callback.

[Visual Basic]
Public Property IsLive As Boolean _
    Implements ILiveControl.IsLive
[C#]
public bool IsLive { get; set; }
[C++]
public: __property bool get_IsLive();
public: __property void set_IsLive(bool );
[JScript]
public function get IsLive() : bool
public function set IsLive(bool);

Property Value

true if the PowerWEB control should update itself during a callback, false otherwise.

Implements

ILiveControl.IsLive

Remarks

Defaults to true. Set the IsLive property to false to prevent the PowerWEB control from updating itself during a callback, even if it is changed in code behind.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Left Property

Upload.Left Property

Gets or sets the left position of the PowerWEB control.

[Visual Basic]
Public Property Left As Unit
[C#]
public Unit Left { get; set; }
[C++]
public: __property Unit get_Left();
public: __property void set_Left(Unit );
[JScript]
public function get Left() : Unit
public function set Left(Unit);

Property Value

A Unit that represents the left position of the control. The default is Unit.Empty.

Remarks

Use the Left property to specify the left position of the PowerWEB control. If both Left and Top are Unit.Empty (the default), relative positioning is used. If either Left or Top are not Unit.Empty, absolute positioning is used.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


ShowTextBox Property

Upload.ShowTextBox Property

When set to false, the Upload control will simply appear as a button.

[Visual Basic]
Public Property ShowTextBox As Boolean
[C#]
public bool ShowTextBox { get; set; }
[C++]
public: __property bool get_ShowTextBox();
public: __property void set_ShowTextBox(bool );
[JScript]
public function get ShowTextBox() : bool
public function set ShowTextBox(bool);

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Tag Property

Upload.Tag Property

Gets or sets a convertible object that contains data about the control.

[Visual Basic]
Public Property Tag As Object _
    Implements ILiveControl.Tag
[C#]
public object Tag { get; set; }
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(Object* );
[JScript]
public function get Tag() : Object
public function set Tag(Object);

Property Value

An object that implements the IConvertible interface and contains data about the PowerWEB control. The default is a null reference (Nothing in Visual Basic).

Implements

ILiveControl.Tag

Remarks

Any type that implements IConvertible can be assigned to this property. If the Tag property is set through the Windows Forms designer, only text can be assigned.

Data contained within the Tag property persists across callbacks. A common use for the Tag property is to store data that is closely associated with the control.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Text Property

Upload.Text Property

The text displayed on the Upload control's Button.

[Visual Basic]
Public Property Text As String
[C#]
public string Text { get; set; }
[C++]
public: __property String* get_Text();
public: __property void set_Text(String* );
[JScript]
public function get Text() : String
public function set Text(String);

Property Value

The default value is "Browse...".

Remarks

When using a ButtonType of ImageButton, this text is used for the 'alt' attribute of the image defined by ButtonImageUrl.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


TextBoxStyle Property

Upload.TextBoxStyle Property

Enables configuration of the Upload textbox.

[Visual Basic]
Public Property ReadOnly TextBoxStyle As Style
[C#]
public Style TextBoxStyle { get; }
[C++]
public: __property Style* get_TextBoxStyle();
[JScript]
public function get TextBoxStyle() : Style

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Top Property

Upload.Top Property

Gets or sets the top position of the PowerWEB control.

[Visual Basic]
Public Property Top As Unit
[C#]
public Unit Top { get; set; }
[C++]
public: __property Unit get_Top();
public: __property void set_Top(Unit );
[JScript]
public function get Top() : Unit
public function set Top(Unit);

Property Value

A Unit that represents the top position of the control. The default is Unit.Empty.

Remarks

Use the Top property to specify the top position of the PowerWEB control. If both Left and Top are Unit.Empty (the default), relative positioning is used. If either Left or Top are not Unit.Empty, absolute positioning is used.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


UpdateAll Property

Upload.UpdateAll Property

Gets or sets which fields are posted to the server in a callback.

[Visual Basic]
Public Property UpdateAll As Boolean
[C#]
public bool UpdateAll { get; set; }
[C++]
public: __property bool get_UpdateAll();
public: __property void set_UpdateAll(bool );
[JScript]
public function get UpdateAll() : bool
public function set UpdateAll(bool);

Property Value

If true, all values for all client-side form elements are posted to the server. If false, only the value for the callback element is posted to the server. The default value is true.

Remarks

If true, all values for all client-side form elements are posted to the server. If false, only the value for the callback element is posted to the server. This can be used to highly optimize performance depending on the application. For example, if an application has a lot of form fields with a Timer raising a periodic callback, the callback lag may be signifigant, as the script has to loop through all of the form fields to get the client-side value. However, this may not be necessary. Often, you may only need to raise a callback, and don't need the values for form fields. In this case set this property to false, and the callback will execute much faster.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Visible Property

Upload.Visible Property

Gets or sets a value indicating whether the PowerWEB control is visible.

[Visual Basic]
Overrides Public Property Visible As Boolean
[C#]
public override bool Visible { get; set; }
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(bool );
[JScript]
public override function get Visible() : bool
public override function set Visible(bool);

Property Value

true if the control is visible on the page; otherwise false. The default is true.

Remarks

Use the Visible property to specify or determine whether a control is visible. When set to false, the control is rendered, but is hidden.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


WaitElementID Property

Upload.WaitElementID Property

Gets or sets the message ID of the HTML element to display a message during a pending callback.

[Visual Basic]
Public Property WaitElementID As String
[C#]
public string WaitElementID { get; set; }
[C++]
public: __property String* get_WaitElementID();
public: __property void set_WaitElementID(String* );
[JScript]
public function get WaitElementID() : String
public function set WaitElementID(String);

Property Value

The ID of an HTML element, such as a Label, that will display a message during pending callbacks.

Remarks

Use in conjunction with the WaitMessage property.

Set WaitElementID to specify the ID of the control that will display the WaitMessage during a pending callback.

Typical usage would be for immediately displaying a message (such as "Processing..") to the user during lengthy callbacks (due to network traffic or server side processing).

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


WaitMessage Property

Upload.WaitMessage Property

Gets or sets the message to display during a pending callback.

[Visual Basic]
Public Property WaitMessage As String
[C#]
public string WaitMessage { get; set; }
[C++]
public: __property String* get_WaitMessage();
public: __property void set_WaitMessage(String* );
[JScript]
public function get WaitMessage() : String
public function set WaitMessage(String);

Property Value

The message displayed during pending callbacks.

Remarks

Use in conjunction with the WaitElementID property.

Set WaitMessage to specify the message displayed by the WaitElementID control during a pending callback.

Typical usage would be for immediately displaying a message (such as "Processing...") to the user during lengthy callbacks (due to network traffic or server side processing).

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Width Property

Upload.Width Property

Gets or sets the width of the Upload control.

[Visual Basic]
Overrides Public Property Width As Unit
[C#]
public override Unit Width { get; set; }
[C++]
public: __property Unit get_Width();
public: __property void set_Width(Unit );
[JScript]
public override function get Width() : Unit
public override function set Width(Unit);

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Upload Methods

The methods of the Upload class are listed below. For a complete list of Upload class members, see the Upload Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference | Returns JavaScript that can be used to initiate a callback to the server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState | Returns the ViewState object used to save and restore state.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
Refresh | In a callback, updates the controls client-side representation.
RenderBeginTag | Overridden. Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag | Overridden. Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


GetCallbackEventReference Method

Upload.GetCallbackEventReference Method

Returns JavaScript that can be used to initiate a callback to the server.

[Visual Basic]
Public Function GetCallbackEventReference( _
   ByVal eventName As String, _
   ByVal argument As String _
) As String
[C#]
public string GetCallbackEventReference(
   string eventName,
   string argument
);
[C++]
public: String* GetCallbackEventReference(
   String* eventName,
   String* argument
);
[JScript]
public function GetCallbackEventReference(
   String eventName,
   String argument
): String;

Parameters

eventName
The event corresponding to the callback.
argument
The event arguments for the callback.

Remarks

Returns JavaScript that can be used to initiate a callback to the server.

The settings of the PowerWEB control (blocking, errorhandling, etc) are automatically taken into account.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


GetScript Method

Upload.GetScript Method

Returns all JavaScript buffered up as a result of setting control properties.

[Visual Basic]
Public Function GetScript() _
    Implements ILiveControl.GetScript As String
[C#]
public string GetScript();
[C++]
public: String* GetScript();
[JScript]
public function GetScript(): String;

Implements

ILiveControl.GetScript

Remarks

Returns all JavaScript buffered up as a result of setting properties of controls on the form.

Note This is not intended for use by end-users.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


GetScriptObjectReference Method

Upload.GetScriptObjectReference Method

Returns a client-side reference to the element.

[Visual Basic]
Public Function GetScriptObjectReference() _
    Implements ILiveControl.GetScriptObjectReference As String
[C#]
public string GetScriptObjectReference();
[C++]
public: String* GetScriptObjectReference();
[JScript]
public function GetScriptObjectReference(): String;

Implements

ILiveControl.GetScriptObjectReference

Remarks

Returns a client-side reference to the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1")" (depending on the browser).

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


GetScriptStyleReference Method

Upload.GetScriptStyleReference Method

Returns a client-side reference to the style object of the element.

[Visual Basic]
Public Function GetScriptStyleReference() _
    Implements ILiveControl.GetScriptStyleReference As String
[C#]
public string GetScriptStyleReference();
[C++]
public: String* GetScriptStyleReference();
[JScript]
public function GetScriptStyleReference(): String;

Implements

ILiveControl.GetScriptStyleReference

Remarks

Returns a client-side reference to the style object of the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1").style" (depending on the browser).

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


GetViewState Method

Upload.GetViewState Method

Returns the ViewState object used to save and restore state.

[Visual Basic]
Public Function GetViewState() _
    Implements ILiveControl.GetViewState As Object
[C#]
public object GetViewState();
[C++]
public: Object* GetViewState();
[JScript]
public function GetViewState(): Object;

Implements

ILiveControl.GetViewState

Remarks

Returns the ViewState object used by PowerWEB controls to save and restore state.

Note This is not intended for use by end-users.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Refresh Method

Upload.Refresh Method

In a callback, updates the controls client-side representation.

[Visual Basic]
Public Sub Refresh() _
    Implements ILiveControl.Refresh
[C#]
public void Refresh();
[C++]
public: void Refresh();
[JScript]
public function Refresh();

Implements

ILiveControl.Refresh

Remarks

When the request is an incoming callback, this method forces the control to update itself client-side (whether a change was detected within the control or not).

When the request is not an Ajax callback, this method has no effect.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


RenderBeginTag Method

Upload.RenderBeginTag Method

Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.

[Visual Basic]
Overrides Public Sub RenderBeginTag( _
   ByVal writer As HtmlTextWriter _
)
[C#]
public override void RenderBeginTag(
   HtmlTextWriter writer
);
[C++]
public: void RenderBeginTag(
   HtmlTextWriter* writer
);
[JScript]
public override function RenderBeginTag(
   HtmlTextWriter writer
);

Remarks

This is made public so other controls can render multiple controls in between the opening and closing tags of a Web server control. This method is not intended to be used from within your code.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


RenderEndTag Method

Upload.RenderEndTag Method

Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers.

[Visual Basic]
Overrides Public Sub RenderEndTag( _
   ByVal writer As HtmlTextWriter _
)
[C#]
public override void RenderEndTag(
   HtmlTextWriter writer
);
[C++]
public: void RenderEndTag(
   HtmlTextWriter* writer
);
[JScript]
public override function RenderEndTag(
   HtmlTextWriter writer
);

Parameters

writer
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.

Remarks

This is made public so other controls can render multiple controls in between the opening and closing tags of a Web server control.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


Upload Events

The events of the Upload class are listed below. For a complete list of Upload class members, see the Upload Members topic.

Public Instance Events

ContextMenuChanged | Occurs when the right button of the PowerWEB control is clicked.
DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
DoubleClick | Occurs when the control is double-clicked.
GotFocus | Occurs when the PowerWEB control gains focus.
HelpRequested | Occurs when F1 is pressed while the control has focus.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
KeyDown | Occurs when a key is down while the control has focus.
KeyPress | Occurs when a key is pressed while the control has focus.
KeyUp | Occurs when a key is released while the control has focus.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
LocationClick | Occurs when the PowerWEB control is clicked, providing location data.
LostFocus | Occurs when the PowerWEB control loses focus.
MouseDown | Occurs when the mouse buttons are pressed while the PowerWEB control has focus.
MouseEnter | Occurs when the mouse pointer enters the PowerWEB control.
MouseLeave | Occurs when the mouse pointer leaves the PowerWEB control.
MouseUp | Occurs when the mouse buttons are released while the PowerWEB control has focus.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


ContextMenuChanged Event

Upload.ContextMenuChanged Event

Occurs when the right button of the PowerWEB control is clicked.

[Visual Basic]
Public Event ContextMenuChanged As LocationEventHandler
[C#]
public event LocationEventHandler ContextMenuChanged;
[C++]
public: __event LocationEventHandler* ContextMenuChanged;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The ContextMenuChanged event fires when the right button is clicked. This event is the equivalent of the Click event for the left button.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


DoubleClick Event

Upload.DoubleClick Event

Occurs when the control is double-clicked.

[Visual Basic]
Public Event DoubleClick As LocationEventHandler
[C#]
public event LocationEventHandler DoubleClick;
[C++]
public: __event LocationEventHandler* DoubleClick;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The DoubleClick event fires when the control is double-clicked.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


GotFocus Event

Upload.GotFocus Event

Occurs when the PowerWEB control gains focus.

[Visual Basic]
Public Event GotFocus As EventHandler
[C#]
public event EventHandler GotFocus;
[C++]
public: __event EventHandler* GotFocus;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The GotFocus event fires when the PowerWEB control gains focus. LostFocus fires when the PowerWEB control loses focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


HelpRequested Event

Upload.HelpRequested Event

Occurs when F1 is pressed while the control has focus.

[Visual Basic]
Public Event HelpRequested As LocationEventHandler
[C#]
public event LocationEventHandler HelpRequested;
[C++]
public: __event LocationEventHandler* HelpRequested;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The HelpRequested event fires when F1 is pressed while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


KeyDown Event

Upload.KeyDown Event

Occurs when a key is down while the control has focus.

[Visual Basic]
Public Event KeyDown As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown;
[C++]
public: __event KeyEventHandler* KeyDown;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Remarks

The KeyDown event fires when a key is down while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


KeyPress Event

Upload.KeyPress Event

Occurs when a key is pressed while the control has focus.

[Visual Basic]
Public Event KeyPress As KeyEventHandler
[C#]
public event KeyEventHandler KeyPress;
[C++]
public: __event KeyEventHandler* KeyPress;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Remarks

The KeyPress event fires when a key is pressed while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


KeyUp Event

Upload.KeyUp Event

Occurs when a key is released while the control has focus.

[Visual Basic]
Public Event KeyUp As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp;
[C++]
public: __event KeyEventHandler* KeyUp;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Remarks

The KeyUp event fires when a key is released while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


LocationClick Event

Upload.LocationClick Event

Occurs when the PowerWEB control is clicked, providing location data.

[Visual Basic]
Public Event LocationClick As LocationEventHandler
[C#]
public event LocationEventHandler LocationClick;
[C++]
public: __event LocationEventHandler* LocationClick;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The LocationClick event fires when the PowerWEB control is clicked, providing Top and Left location data.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


LostFocus Event

Upload.LostFocus Event

Occurs when the PowerWEB control loses focus.

[Visual Basic]
Public Event LostFocus As EventHandler
[C#]
public event EventHandler LostFocus;
[C++]
public: __event EventHandler* LostFocus;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The LostFocus event fires when the PowerWEB control loses focus. GotFocus fires when the PowerWEB control gains focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


MouseDown Event

Upload.MouseDown Event

Occurs when the mouse buttons are pressed while the PowerWEB control has focus.

[Visual Basic]
Public Event MouseDown As LocationEventHandler
[C#]
public event LocationEventHandler MouseDown;
[C++]
public: __event LocationEventHandler* MouseDown;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseDown event fires when any button is pressed.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


MouseEnter Event

Upload.MouseEnter Event

Occurs when the mouse pointer enters the PowerWEB control.

[Visual Basic]
Public Event MouseEnter As LocationEventHandler
[C#]
public event LocationEventHandler MouseEnter;
[C++]
public: __event LocationEventHandler* MouseEnter;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseEnter event fires when the mouse pointer enters the PowerWEB control. MouseLeave will fire when the mouse pointer leaves the control.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


MouseLeave Event

Upload.MouseLeave Event

Occurs when the mouse pointer leaves the PowerWEB control.

[Visual Basic]
Public Event MouseLeave As LocationEventHandler
[C#]
public event LocationEventHandler MouseLeave;
[C++]
public: __event LocationEventHandler* MouseLeave;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseLeave event fires when the mouse pointer leaves the PowerWEB control. MouseEnter will fire when the mouse pointer enters the control.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


MouseUp Event

Upload.MouseUp Event

Occurs when the mouse buttons are released while the PowerWEB control has focus.

[Visual Basic]
Public Event MouseUp As LocationEventHandler
[C#]
public event LocationEventHandler MouseUp;
[C++]
public: __event LocationEventHandler* MouseUp;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseUp event fires when any button is released.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Upload Class | Dart.PowerWEB.FileUpload Namespace


UploadCompleteEventArgs Class

Provides data for the UploadComplete event.

For a list of all members of this type, see UploadCompleteEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.FileUpload.UploadCompleteEventArgs

[Visual Basic]
Public Class UploadCompleteEventArgs
    Inherits EventArgs
[C#]
public class UploadCompleteEventArgs : EventArgs
[C++]
public __gc class UploadCompleteEventArgs : public EventArgs
[JScript]
public class UploadCompleteEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

UploadCompleteEventArgs contains information concerning all the transfers attempted in the upload operation.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

UploadCompleteEventArgs Members | Dart.PowerWEB.FileUpload Namespace


UploadCompleteEventArgs Members

UploadCompleteEventArgs overview

Public Instance Constructors

UploadCompleteEventArgs Constructor Initializes a new instance of the UploadCompleteEventArgs class.

Public Instance Properties

AverageTransferSpeed | The average transfer speed of the upload operation.
BytesTransferred | The total bytes transferred during the upload operation.
ElapsedTime | The elapsed time for the upload operation.
FailedUploads | A list of files that failed to upload.
Files | A list of files that were successfully uploaded.
RequestSize | The size of the Post message requesting the upload.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UploadCompleteEventArgs Class | Dart.PowerWEB.FileUpload Namespace


UploadCompleteEventArgs Constructor

Initializes a new instance of the UploadCompleteEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal files As ArrayList, _
   ByVal failedUploads As ArrayList, _
   ByVal averageTransferSpeed As Double, _
   ByVal requestSize As Integer, _
   ByVal elapsedTime As TimeSpan, _
   ByVal bytesTransferred As Integer _
)
[C#]
public UploadCompleteEventArgs(
   ArrayList files,
   ArrayList failedUploads,
   double averageTransferSpeed,
   int requestSize,
   TimeSpan elapsedTime,
   int bytesTransferred
);
[C++]
public: UploadCompleteEventArgs(
   ArrayList* files,
   ArrayList* failedUploads,
   double averageTransferSpeed,
   int requestSize,
   TimeSpan elapsedTime,
   int bytesTransferred
);
[JScript]
public function UploadCompleteEventArgs(
   ArrayList files,
   ArrayList failedUploads,
   double averageTransferSpeed,
   int requestSize,
   TimeSpan elapsedTime,
   int bytesTransferred
);

See Also

UploadCompleteEventArgs Class | Dart.PowerWEB.FileUpload Namespace


UploadCompleteEventArgs Properties

The properties of the UploadCompleteEventArgs class are listed below. For a complete list of UploadCompleteEventArgs class members, see the UploadCompleteEventArgs Members topic.

Public Instance Properties

AverageTransferSpeed | The average transfer speed of the upload operation.
BytesTransferred | The total bytes transferred during the upload operation.
ElapsedTime | The elapsed time for the upload operation.
FailedUploads | A list of files that failed to upload.
Files | A list of files that were successfully uploaded.
RequestSize | The size of the Post message requesting the upload.

See Also

UploadCompleteEventArgs Class | Dart.PowerWEB.FileUpload Namespace


AverageTransferSpeed Property

UploadCompleteEventArgs.AverageTransferSpeed Property

The average transfer speed of the upload operation.

[Visual Basic]
Public Property ReadOnly AverageTransferSpeed As Double
[C#]
public double AverageTransferSpeed { get; }
[C++]
public: __property double get_AverageTransferSpeed();
[JScript]
public function get AverageTransferSpeed() : double

See Also

UploadCompleteEventArgs Class | Dart.PowerWEB.FileUpload Namespace


BytesTransferred Property

UploadCompleteEventArgs.BytesTransferred Property

The total bytes transferred during the upload operation.

[Visual Basic]
Public Property ReadOnly BytesTransferred As Integer
[C#]
public int BytesTransferred { get; }
[C++]
public: __property int get_BytesTransferred();
[JScript]
public function get BytesTransferred() : int

See Also

UploadCompleteEventArgs Class | Dart.PowerWEB.FileUpload Namespace


ElapsedTime Property

UploadCompleteEventArgs.ElapsedTime Property

The elapsed time for the upload operation.

[Visual Basic]
Public Property ReadOnly ElapsedTime As TimeSpan
[C#]
public TimeSpan ElapsedTime { get; }
[C++]
public: __property TimeSpan get_ElapsedTime();
[JScript]
public function get ElapsedTime() : TimeSpan

See Also

UploadCompleteEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FailedUploads Property

UploadCompleteEventArgs.FailedUploads Property

A list of files that failed to upload.

[Visual Basic]
Public Property ReadOnly FailedUploads As UploadException()
[C#]
public UploadException[] FailedUploads { get; }
[C++]
public: __property UploadException* get_FailedUploads() __gc[];
[JScript]
public function get FailedUploads() : UploadException[]

See Also

UploadCompleteEventArgs Class | Dart.PowerWEB.FileUpload Namespace


Files Property

UploadCompleteEventArgs.Files Property

A list of files that were successfully uploaded.

[Visual Basic]
Public Property ReadOnly Files As PostedFile()
[C#]
public PostedFile[] Files { get; }
[C++]
public: __property PostedFile* get_Files() __gc[];
[JScript]
public function get Files() : PostedFile[]

See Also

UploadCompleteEventArgs Class | Dart.PowerWEB.FileUpload Namespace


RequestSize Property

UploadCompleteEventArgs.RequestSize Property

The size of the Post message requesting the upload.

[Visual Basic]
Public Property ReadOnly RequestSize As Integer
[C#]
public int RequestSize { get; }
[C++]
public: __property int get_RequestSize();
[JScript]
public function get RequestSize() : int

See Also

UploadCompleteEventArgs Class | Dart.PowerWEB.FileUpload Namespace


UploadCompleteEventHandler Delegate

The delegate used for the UploadComplete event.

[Visual Basic]
Public Delegate Function Sub  UploadCompleteEventHandler( _
   ByVal sender As Object, _
   ByVal e As UploadCompleteEventArgs _
)
[C#]
public delegate void UploadCompleteEventHandler(
   object sender,
   UploadCompleteEventArgs e
)
[C++]
public __gc __delegate void UploadCompleteEventHandler(
   Object* sender,
   UploadCompleteEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


UploadException Class

An UploadException occurs when there is an error during an upload.

For a list of all members of this type, see UploadException Members.

System.Object
System.Exception
Dart.PowerWEB.FileUpload.UploadException

[Visual Basic]
Public Class UploadException
    Inherits Exception
[C#]
public class UploadException : Exception
[C++]
public __gc class UploadException : public Exception
[JScript]
public class UploadException extends Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The UploadException contains the exception itself as well as information concerning the file that caused the exception.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

UploadException Members | Dart.PowerWEB.FileUpload Namespace


UploadException Members

UploadException overview

Public Instance Constructors

UploadException Constructor Initializes a new instance of the UploadException class.

Public Instance Properties

FailedFile | The file that caused the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Overridden. Creates and returns a string representation of the current exception.

See Also

UploadException Class | Dart.PowerWEB.FileUpload Namespace


UploadException Constructor

Initializes a new instance of the UploadException class.

[Visual Basic]
Public Sub New( _
   ByVal failedFile As PostedFile, _
   ByVal pipelineException As Exception _
)
[C#]
public UploadException(
   PostedFile failedFile,
   Exception pipelineException
);
[C++]
public: UploadException(
   PostedFile* failedFile,
   Exception* pipelineException
);
[JScript]
public function UploadException(
   PostedFile failedFile,
   Exception pipelineException
);

See Also

UploadException Class | Dart.PowerWEB.FileUpload Namespace


UploadException Properties

The properties of the UploadException class are listed below. For a complete list of UploadException class members, see the UploadException Members topic.

Public Instance Properties

FailedFile | The file that caused the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

See Also

UploadException Class | Dart.PowerWEB.FileUpload Namespace


FailedFile Property

UploadException.FailedFile Property

The file that caused the exception.

[Visual Basic]
Public Property ReadOnly FailedFile As PostedFile
[C#]
public PostedFile FailedFile { get; }
[C++]
public: __property PostedFile* get_FailedFile();
[JScript]
public function get FailedFile() : PostedFile

See Also

UploadException Class | Dart.PowerWEB.FileUpload Namespace


UploadManager Class

A control used to manage page-level file upload behavior.

For a list of all members of this type, see UploadManager Members.

System.Object
System.Web.UI.Control
Dart.PowerWEB.FileUpload.UploadManager

[Visual Basic]
Public Class UploadManager
    Inherits Control
    Implements IPostBackEventHandler
[C#]
public class UploadManager : Control, IPostBackEventHandler
[C++]
public __gc class UploadManager : public Control, IPostBackEventHandler
[JScript]
public class UploadManager extends Control, IPostBackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The presence of an UploadManager on a webform is a requirement for using the Upload, OpenFileDialog and ProgressPanel controls.

Only one instance of the UploadManager can be on a webform.

Configure the SavePath and TempPath properties to set upload destinations.

Set the Extensions, MaxFileSize and MaxRequestSize properties to place limits on uploaded files.

All upload events are raised by the UploadManager.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

UploadManager Members | Dart.PowerWEB.FileUpload Namespace


UploadManager Members

UploadManager overview

Public Instance Constructors

UploadManager Overloaded. Initializes a new instance of the UploadManager class.

Public Instance Properties

BindingContainer (inherited from Control) |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Extensions | A collection of file extensions to globally allow. For example, 'jpg' or 'gif'.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
MaxFileSize | The maximum individual file size allowed (in kilobytes).
MaxRequestSize | The maximum total request size allowed (in kilobytes) when multiple files are uploaded.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PollingInterval | The polling interval (in milliseconds) used to raise file upload progress events.
SavePath | The location where files are saved when uploads are completed.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
TempPath | The location where file data is temporarily saved during the upload process.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UploadType | The global type of upload method to use.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.

Public Instance Methods

DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
RaisePostBackEvent | Enables the UploadManager to process events raised when a form is posted to the server.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
FileUploadComplete | Event raised when an individual file upload has completed.
FileUploadFailed | Event raised when an individual file upload has failed.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.
UploadCancelled | Event raised when an upload operation is cancelled.
UploadComplete | Event raised when an upload operation has completed.
UploadProgress | Event raised during an upload operation at each interval defined by the PollingInterval property.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


UploadManager Constructor

Initializes a new instance of the UploadManager control.

Overload List

Initializes a new instance of the UploadManager control.

[Visual Basic] Public Sub New()
[C#] public UploadManager();
[C++] public: UploadManager();
[JScript] public function UploadManager();

Initializes a new instance of the UploadManager control.

[Visual Basic] Public Sub New(ByVal String)
[C#] public UploadManager(string);
[C++] public: UploadManager(String*);
[JScript] public function UploadManager(String);

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


UploadManager Constructor ()

Initializes a new instance of the UploadManager control.

[Visual Basic]
Public Sub New()
[C#]
public UploadManager();
[C++]
public: UploadManager();
[JScript]
public function UploadManager();

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace | UploadManager Constructor Overload List


UploadManager Constructor (String)

Initializes a new instance of the UploadManager control.

[Visual Basic]
Public Sub New( _
   ByVal oemLK As String _
)
[C#]
public UploadManager(
   string oemLK
);
[C++]
public: UploadManager(
   String* oemLK
);
[JScript]
public function UploadManager(
   String oemLK
);

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace | UploadManager Constructor Overload List


UploadManager Properties

The properties of the UploadManager class are listed below. For a complete list of UploadManager class members, see the UploadManager Members topic.

Public Instance Properties

BindingContainer (inherited from Control) |
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
Extensions | A collection of file extensions to globally allow. For example, 'jpg' or 'gif'.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
MaxFileSize | The maximum individual file size allowed (in kilobytes).
MaxRequestSize | The maximum total request size allowed (in kilobytes) when multiple files are uploaded.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
PollingInterval | The polling interval (in milliseconds) used to raise file upload progress events.
SavePath | The location where files are saved when uploads are completed.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
TempPath | The location where file data is temporarily saved during the upload process.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UploadType | The global type of upload method to use.
Visible (inherited from Control) | Gets or sets a value that indicates whether a server control is rendered as UI on the page.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


Extensions Property

UploadManager.Extensions Property

A collection of file extensions to globally allow. For example, 'jpg' or 'gif'.

[Visual Basic]
Public Property Extensions As String()
[C#]
public string[] Extensions { get; set; }
[C++]
public: __property String* get_Extensions() __gc[];
public: __property void set_Extensions(String*  __gc[]);
[JScript]
public function get Extensions() : String[]
public function set Extensions(String[]);

Remarks

When using Flash upload type, this filter will be enforced by the file dialog as defined by the FilterExtension property of the Upload and OpenFileDialog controls.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


MaxFileSize Property

UploadManager.MaxFileSize Property

The maximum individual file size allowed (in kilobytes).

[Visual Basic]
Public Property MaxFileSize As Integer
[C#]
public int MaxFileSize { get; set; }
[C++]
public: __property int get_MaxFileSize();
public: __property void set_MaxFileSize(int );
[JScript]
public function get MaxFileSize() : int
public function set MaxFileSize(int);

Property Value

The default value is 0.

Remarks

When set to 0, all file sizes are allowed, up to the limit imposed by ASP.NET.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


MaxRequestSize Property

UploadManager.MaxRequestSize Property

The maximum total request size allowed (in kilobytes) when multiple files are uploaded.

[Visual Basic]
Public Property MaxRequestSize As Integer
[C#]
public int MaxRequestSize { get; set; }
[C++]
public: __property int get_MaxRequestSize();
public: __property void set_MaxRequestSize(int );
[JScript]
public function get MaxRequestSize() : int
public function set MaxRequestSize(int);

Property Value

The default value is 0.

Remarks

When set to 0, all request sizes are allowed, up to the limit imposed by ASP.NET.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


PollingInterval Property

UploadManager.PollingInterval Property

The polling interval (in milliseconds) used to raise file upload progress events.

[Visual Basic]
Public Property PollingInterval As Integer
[C#]
public int PollingInterval { get; set; }
[C++]
public: __property int get_PollingInterval();
public: __property void set_PollingInterval(int );
[JScript]
public function get PollingInterval() : int
public function set PollingInterval(int);

Property Value

The default value is 1000.

Remarks

This interval also determines how often ProgressPanels are updated in the browser.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


SavePath Property

UploadManager.SavePath Property

The location where files are saved when uploads are completed.

[Visual Basic]
Public Property SavePath As String
[C#]
public string SavePath { get; set; }
[C++]
public: __property String* get_SavePath();
public: __property void set_SavePath(String* );
[JScript]
public function get SavePath() : String
public function set SavePath(String);

Property Value

The default value is "~".

Remarks

If the TempPath property is not set, files will be uploaded directly to the SavePath.

To stream data to memory, set the SavePath and the TempPath to empty strings.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


TempPath Property

UploadManager.TempPath Property

The location where file data is temporarily saved during the upload process.

[Visual Basic]
Public Property TempPath As String
[C#]
public string TempPath { get; set; }
[C++]
public: __property String* get_TempPath();
public: __property void set_TempPath(String* );
[JScript]
public function get TempPath() : String
public function set TempPath(String);

Property Value

The default value is "".

Remarks

Set the TempPath to have file data saved to a temporary location before moving to the SavePath upon completion.

To stream data to memory, set the SavePath and the TempPath to empty strings.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


UploadType Property

UploadManager.UploadType Property

The global type of upload method to use.

[Visual Basic]
Public Property UploadType As UploadType
[C#]
public UploadType UploadType { get; set; }
[C++]
public: __property UploadType get_UploadType();
public: __property void set_UploadType(UploadType );
[JScript]
public function get UploadType() : UploadType
public function set UploadType(UploadType);

Remarks

Autodetect - determines browser capabilities and chooses the most appropriate method (Flash or IFrame).\r\nFlash - uses an enhanced file dialog facilitated by a Flash object.

Frame - uses a standard IFrame technique to provide upload functionality without requiring the Flash plugin.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


UploadManager Methods

The methods of the UploadManager class are listed below. For a complete list of UploadManager class members, see the UploadManager Members topic.

Public Instance Methods

DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
RaisePostBackEvent | Enables the UploadManager to process events raised when a form is posted to the server.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


RaisePostBackEvent Method

UploadManager.RaisePostBackEvent Method

Enables the UploadManager to process events raised when a form is posted to the server.

[Visual Basic]
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As String _
) _
    Implements IPostBackEventHandler.RaisePostBackEvent
[C#]
public void RaisePostBackEvent(
   string eventArgument
);
[C++]
public: void RaisePostBackEvent(
   String* eventArgument
);
[JScript]
public function RaisePostBackEvent(
   String eventArgument
);

Implements

IPostBackEventHandler.RaisePostBackEvent

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


UploadManager Events

The events of the UploadManager class are listed below. For a complete list of UploadManager class members, see the UploadManager Members topic.

Public Instance Events

DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
FileUploadComplete | Event raised when an individual file upload has completed.
FileUploadFailed | Event raised when an individual file upload has failed.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.
UploadCancelled | Event raised when an upload operation is cancelled.
UploadComplete | Event raised when an upload operation has completed.
UploadProgress | Event raised during an upload operation at each interval defined by the PollingInterval property.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


FileUploadComplete Event

UploadManager.FileUploadComplete Event

Event raised when an individual file upload has completed.

[Visual Basic]
Public Event FileUploadComplete As FileUploadEventHandler
[C#]
public event FileUploadEventHandler FileUploadComplete;
[C++]
public: __event FileUploadEventHandler* FileUploadComplete;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type FileUploadEventArgs containing data related to this event. The following FileUploadEventArgs property provides information specific to this event.

Property | Description
PostedFile | The PostedFile containing information about the uploaded file.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


FileUploadFailed Event

UploadManager.FileUploadFailed Event

Event raised when an individual file upload has failed.

[Visual Basic]
Public Event FileUploadFailed As FileUploadExceptionEventHandler
[C#]
public event FileUploadExceptionEventHandler FileUploadFailed;
[C++]
public: __event FileUploadExceptionEventHandler* FileUploadFailed;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type FileUploadExceptionEventArgs containing data related to this event. The following FileUploadExceptionEventArgs property provides information specific to this event.

Property | Description
FailedUpload | The UploadException that caused the failure.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


UploadCancelled Event

UploadManager.UploadCancelled Event

Event raised when an upload operation is cancelled.

[Visual Basic]
Public Event UploadCancelled As EventHandler
[C#]
public event EventHandler UploadCancelled;
[C++]
public: __event EventHandler* UploadCancelled;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


UploadComplete Event

UploadManager.UploadComplete Event

Event raised when an upload operation has completed.

[Visual Basic]
Public Event UploadComplete As UploadCompleteEventHandler
[C#]
public event UploadCompleteEventHandler UploadComplete;
[C++]
public: __event UploadCompleteEventHandler* UploadComplete;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type UploadCompleteEventArgs containing data related to this event. The following UploadCompleteEventArgs properties provide information specific to this event.

Property | Description
AverageTransferSpeed | The average transfer speed of the upload operation.
BytesTransferred | The total bytes transferred during the upload operation.
ElapsedTime | The elapsed time for the upload operation.
FailedUploads | A list of files that failed to upload.
Files | A list of files that were successfully uploaded.
RequestSize | The size of the Post message requesting the upload.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


UploadProgress Event

UploadManager.UploadProgress Event

Event raised during an upload operation at each interval defined by the PollingInterval property.

[Visual Basic]
Public Event UploadProgress As UploadProgressEventHandler
[C#]
public event UploadProgressEventHandler UploadProgress;
[C++]
public: __event UploadProgressEventHandler* UploadProgress;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type UploadProgressEventArgs containing data related to this event. The following UploadProgressEventArgs properties provide information specific to this event.

Property | Description
AverageTransferSpeed | The average transfer speed for the upload operation.
BytesTransferred | The total number of bytes that have been transferred during the upload operation.
CurrentTransferSpeed | The current transfer speed of the upload operation.
Data | The newly uploaded data for the currently transferring file.
ElapsedTime | The elapsed time for the upload operation.
EstimatedRemainingTime | The estimated time remaining for the upload operation.
FileBytesUploaded | The number of bytes transferred thus far for the current file.
FileName | The name of the currently transferring file.
FilesInRequest | The number of files requested to be uploaded.
FileSize | The size of the currently transferring file.
FilesTransferred | The number of files that have been completely transferred.
RequestSize | The size of the Post message requesting the upload operation.
UniqueID | An unique identifier for the currently transferring file.

See Also

UploadManager Class | Dart.PowerWEB.FileUpload Namespace


UploadProgressEventArgs Class

Provides data for the UploadProgress event.

For a list of all members of this type, see UploadProgressEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.FileUpload.UploadProgressEventArgs

[Visual Basic]
Public Class UploadProgressEventArgs
    Inherits EventArgs
[C#]
public class UploadProgressEventArgs : EventArgs
[C++]
public __gc class UploadProgressEventArgs : public EventArgs
[JScript]
public class UploadProgressEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

UploadProgressEventArgs contains information concerning the progress of the upload operation, including the currently transferring file, and the operation as a whole.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

UploadProgressEventArgs Members | Dart.PowerWEB.FileUpload Namespace


UploadProgressEventArgs Members

UploadProgressEventArgs overview

Public Instance Constructors

UploadProgressEventArgs Constructor Initializes a new instance of the Upload ProgressEventArgs class.

Public Instance Properties

AverageTransferSpeed | The average transfer speed for the upload operation.
BytesTransferred | The total number of bytes that have been transferred during the upload operation.
CurrentTransferSpeed | The current transfer speed of the upload operation.
Data | The newly uploaded data for the currently transferring file.
ElapsedTime | The elapsed time for the upload operation.
EstimatedRemainingTime | The estimated time remaining for the upload operation.
FileBytesUploaded | The number of bytes transferred thus far for the current file.
FileName | The name of the currently transferring file.
FilesInRequest | The number of files requested to be uploaded.
FileSize | The size of the currently transferring file.
FilesTransferred | The number of files that have been completely transferred.
RequestSize | The size of the Post message requesting the upload operation.
UniqueID | An unique identifier for the currently transferring file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


UploadProgressEventArgs Constructor

Initializes a new instance of the Upload ProgressEventArgs class.

[Visual Basic]
Public Sub New( _
   ByVal filesInRequest As Integer, _
   ByVal filesTransferred As Integer, _
   ByVal elapsedTime As TimeSpan, _
   ByVal estimatedRemainingTime As TimeSpan, _
   ByVal requestSize As Integer, _
   ByVal bytesTransferred As Integer, _
   ByVal data As Byte(), _
   ByVal averageTransferSpeed As Double, _
   ByVal fileName As String, _
   ByVal uniqueID As String, _
   ByVal fileSize As Integer, _
   ByVal fileBytesUploaded As Integer _
)
[C#]
public UploadProgressEventArgs(
   int filesInRequest,
   int filesTransferred,
   TimeSpan elapsedTime,
   TimeSpan estimatedRemainingTime,
   int requestSize,
   int bytesTransferred,
   byte[] data,
   double averageTransferSpeed,
   string fileName,
   string uniqueID,
   int fileSize,
   int fileBytesUploaded
);
[C++]
public: UploadProgressEventArgs(
   int filesInRequest,
   int filesTransferred,
   TimeSpan elapsedTime,
   TimeSpan estimatedRemainingTime,
   int requestSize,
   int bytesTransferred,
   char data __gc[],
   double averageTransferSpeed,
   String* fileName,
   String* uniqueID,
   int fileSize,
   int fileBytesUploaded
);
[JScript]
public function UploadProgressEventArgs(
   int filesInRequest,
   int filesTransferred,
   TimeSpan elapsedTime,
   TimeSpan estimatedRemainingTime,
   int requestSize,
   int bytesTransferred,
   Byte[] data,
   double averageTransferSpeed,
   String fileName,
   String uniqueID,
   int fileSize,
   int fileBytesUploaded
);

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


UploadProgressEventArgs Properties

The properties of the UploadProgressEventArgs class are listed below. For a complete list of UploadProgressEventArgs class members, see the UploadProgressEventArgs Members topic.

Public Instance Properties

AverageTransferSpeed | The average transfer speed for the upload operation.
BytesTransferred | The total number of bytes that have been transferred during the upload operation.
CurrentTransferSpeed | The current transfer speed of the upload operation.
Data | The newly uploaded data for the currently transferring file.
ElapsedTime | The elapsed time for the upload operation.
EstimatedRemainingTime | The estimated time remaining for the upload operation.
FileBytesUploaded | The number of bytes transferred thus far for the current file.
FileName | The name of the currently transferring file.
FilesInRequest | The number of files requested to be uploaded.
FileSize | The size of the currently transferring file.
FilesTransferred | The number of files that have been completely transferred.
RequestSize | The size of the Post message requesting the upload operation.
UniqueID | An unique identifier for the currently transferring file.

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


AverageTransferSpeed Property

UploadProgressEventArgs.AverageTransferSpeed Property

The average transfer speed for the upload operation.

[Visual Basic]
Public Property ReadOnly AverageTransferSpeed As Double
[C#]
public double AverageTransferSpeed { get; }
[C++]
public: __property double get_AverageTransferSpeed();
[JScript]
public function get AverageTransferSpeed() : double

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


BytesTransferred Property

UploadProgressEventArgs.BytesTransferred Property

The total number of bytes that have been transferred during the upload operation.

[Visual Basic]
Public Property ReadOnly BytesTransferred As Integer
[C#]
public int BytesTransferred { get; }
[C++]
public: __property int get_BytesTransferred();
[JScript]
public function get BytesTransferred() : int

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


CurrentTransferSpeed Property

UploadProgressEventArgs.CurrentTransferSpeed Property

The current transfer speed of the upload operation.

[Visual Basic]
Public Property ReadOnly CurrentTransferSpeed As Double
[C#]
public double CurrentTransferSpeed { get; }
[C++]
public: __property double get_CurrentTransferSpeed();
[JScript]
public function get CurrentTransferSpeed() : double

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


Data Property

UploadProgressEventArgs.Data Property

The newly uploaded data for the currently transferring file.

[Visual Basic]
Public Property ReadOnly Data As Byte()
[C#]
public byte[] Data { get; }
[C++]
public: __property char get_Data() __gc[];
[JScript]
public function get Data() : Byte[]

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


ElapsedTime Property

UploadProgressEventArgs.ElapsedTime Property

The elapsed time for the upload operation.

[Visual Basic]
Public Property ReadOnly ElapsedTime As TimeSpan
[C#]
public TimeSpan ElapsedTime { get; }
[C++]
public: __property TimeSpan get_ElapsedTime();
[JScript]
public function get ElapsedTime() : TimeSpan

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


EstimatedRemainingTime Property

UploadProgressEventArgs.EstimatedRemainingTime Property

The estimated time remaining for the upload operation.

[Visual Basic]
Public Property ReadOnly EstimatedRemainingTime As TimeSpan
[C#]
public TimeSpan EstimatedRemainingTime { get; }
[C++]
public: __property TimeSpan get_EstimatedRemainingTime();
[JScript]
public function get EstimatedRemainingTime() : TimeSpan

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FileBytesUploaded Property

UploadProgressEventArgs.FileBytesUploaded Property

The number of bytes transferred thus far for the current file.

[Visual Basic]
Public Property ReadOnly FileBytesUploaded As Integer
[C#]
public int FileBytesUploaded { get; }
[C++]
public: __property int get_FileBytesUploaded();
[JScript]
public function get FileBytesUploaded() : int

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FileName Property

UploadProgressEventArgs.FileName Property

The name of the currently transferring file.

[Visual Basic]
Public Property ReadOnly FileName As String
[C#]
public string FileName { get; }
[C++]
public: __property String* get_FileName();
[JScript]
public function get FileName() : String

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FilesInRequest Property

UploadProgressEventArgs.FilesInRequest Property

The number of files requested to be uploaded.

[Visual Basic]
Public Property ReadOnly FilesInRequest As Integer
[C#]
public int FilesInRequest { get; }
[C++]
public: __property int get_FilesInRequest();
[JScript]
public function get FilesInRequest() : int

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FileSize Property

UploadProgressEventArgs.FileSize Property

The size of the currently transferring file.

[Visual Basic]
Public Property ReadOnly FileSize As Integer
[C#]
public int FileSize { get; }
[C++]
public: __property int get_FileSize();
[JScript]
public function get FileSize() : int

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


FilesTransferred Property

UploadProgressEventArgs.FilesTransferred Property

The number of files that have been completely transferred.

[Visual Basic]
Public Property ReadOnly FilesTransferred As Integer
[C#]
public int FilesTransferred { get; }
[C++]
public: __property int get_FilesTransferred();
[JScript]
public function get FilesTransferred() : int

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


RequestSize Property

UploadProgressEventArgs.RequestSize Property

The size of the Post message requesting the upload operation.

[Visual Basic]
Public Property ReadOnly RequestSize As Integer
[C#]
public int RequestSize { get; }
[C++]
public: __property int get_RequestSize();
[JScript]
public function get RequestSize() : int

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


UniqueID Property

UploadProgressEventArgs.UniqueID Property

An unique identifier for the currently transferring file.

[Visual Basic]
Public Property ReadOnly UniqueID As String
[C#]
public string UniqueID { get; }
[C++]
public: __property String* get_UniqueID();
[JScript]
public function get UniqueID() : String

See Also

UploadProgressEventArgs Class | Dart.PowerWEB.FileUpload Namespace


UploadProgressEventHandler Delegate

The delegate used for the UploadProgress event.

[Visual Basic]
Public Delegate Function Sub  UploadProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As UploadProgressEventArgs _
)
[C#]
public delegate void UploadProgressEventHandler(
   object sender,
   UploadProgressEventArgs e
)
[C++]
public __gc __delegate void UploadProgressEventHandler(
   Object* sender,
   UploadProgressEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


UploadType Enumeration

The global type of upload method to use.

[Visual Basic]
Public Enum UploadType
[C#]
public enum UploadType
[C++]
public __value enum UploadType
[JScript]
public enum UploadType

Remarks

For AutoDetect, Flash is used if supported.

Members

Member Name | Description
AutoDetect | Determines browser capabilities and chooses the most appropriate method (Flash or IFrame).
IFrame | Uses a standard IFrame technique to provide upload functionality without requiring the Flash plugin.
Flash | Uses an enhanced file dialog facilitated by a Flash object.

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


ViewStateCacheType Enumeration

[Visual Basic]
Public Enum ViewStateCacheType
[C#]
public enum ViewStateCacheType
[C++]
public __value enum ViewStateCacheType
[JScript]
public enum ViewStateCacheType

Members

Member Name | Description
None |
Enabled |
Ordered |

Requirements

Namespace: Dart.PowerWEB.FileUpload

Assembly: Dart.PowerWEB.FileUpload (in Dart.PowerWEB.FileUpload.dll)

See Also

Dart.PowerWEB.FileUpload Namespace


Samples

The following samples are full applications which demonstrate usage of PowerWEB File Upload for ASP.NET. The default directory for sample applications is:

[PersonalFolder]\Dart Sample Applications\PowerWEB\File Upload for ASP.NET

The following table shows the samples for this release.

Sample | Description | Environments
Simple Upload with Progress | A basic sample demonstrating the use of the Upload control, using Autopostback to immediately transfer files upon selection. | C# and VB ASP.NET Applications in VS.NET 2003 and 2005
Multiple Upload Controls | A basic sample demonstrating the use of the multiple Upload controls, triggering file upload from form submittal. | C# and VB ASP.NET Applications in VS.NET 2003 and 2005
Additional Form Fields | A demonstration of how file upload can be used within a WebForm to transfer files as well as custom form field data. | C# and VB ASP.NET Applications in VS.NET 2003 and 2005
OpenFileDialog | A demonstration of using the OpenFileDialog control within a WebForm. | C# and VB ASP.NET Applications in VS.NET 2003 and 2005
Streaming Data | Using progress events, see how you can send file data to an open Stream while it is being uploaded. | C# and VB ASP.NET Applications in VS.NET 2003 and 2005

Related Sections

Getting Started
Provides an overview of PowerWEB File Upload for ASP.NET and discusses such topics as distribution, licensing, and support.
Using the File Upload Controls
Discusses how to use the File Upload controls in your project.
Reference
Provides a language/syntax reference for PowerWEB File Upload for ASP.NET.

Send comments on this topic.

© 2007 Dart Communications. All rights reserved.


ClientFilePath Property

PostedFile.ClientFilePath Property

The local client path of the posted file.

[Visual Basic]
Public Property ReadOnly ClientFilePath As String
[C#]
public string ClientFilePath { get; }
[C++]
public: __property String* get_ClientFilePath();
[JScript]
public function get ClientFilePath() : String

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


DataStream Property

PostedFile.DataStream Property

The posted file's data stream.

[Visual Basic]
Public Property ReadOnly DataStream As Stream
[C#]
public Stream DataStream { get; }
[C++]
public: __property Stream* get_DataStream();
[JScript]
public function get DataStream() : Stream

See Also

PostedFile Class | Dart.PowerWEB.FileUpload Namespace


CloseOnComplete Property

ProgressPanel.CloseOnComplete Property

Automatically close ProgressPanel when upload has completed.

[Visual Basic]
Public Property CloseOnComplete As Boolean
[C#]
public bool CloseOnComplete { get; set; }
[C++]
public: __property bool get_CloseOnComplete();
public: __property void set_CloseOnComplete(bool );
[JScript]
public function get CloseOnComplete() : bool
public function set CloseOnComplete(bool);

Remarks

The default value is false.

When set to false, a 'close' link will be displayed when an upload is cancelled or completed.

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


Height Property

ProgressPanel.Height Property

Gets or sets the height of the progress panel.

[Visual Basic]
Overrides Public Property Height As Unit
[C#]
public override Unit Height { get; set; }
[C++]
public: __property Unit get_Height();
public: __property void set_Height(Unit );
[JScript]
public override function get Height() : Unit
public override function set Height(Unit);

See Also

ProgressPanel Class | Dart.PowerWEB.FileUpload Namespace


PipelineException Property

UploadException.PipelineException Property

The exception raised when attempting to transfer the FailedFile.

[Visual Basic]
Public Property ReadOnly PipelineException As Exception
[C#]
public Exception PipelineException { get; }
[C++]
public: __property Exception* get_PipelineException();
[JScript]
public function get PipelineException() : Exception

See Also

UploadException Class | Dart.PowerWEB.FileUpload Namespace


Dart.PowerWEB.FileUploadHierarchy

Dart.PowerWEB.FileUpload Hierarchy

System.Object
Dart.PowerWEB.FileUpload.BaseStreamingModule ---- System.Web.IHttpModule
Dart.PowerWEB.FileUpload.FileUploadModule
Dart.PowerWEB.FileUpload.CallbackManager ---- System.Web.IHttpModule
Dart.PowerWEB.FileUpload.ILiveControl
Dart.PowerWEB.FileUpload.PostedFile
Dart.PowerWEB.FileUpload.ResourceHttpHandler ---- System.Web.IHttpHandler
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Dart.PowerWEB.FileUpload.FileUploadEventHandler
Dart.PowerWEB.FileUpload.FileUploadExceptionEventHandler
Dart.PowerWEB.FileUpload.KeyEventHandler
Dart.PowerWEB.FileUpload.LocationEventHandler
Dart.PowerWEB.FileUpload.UploadCompleteEventHandler
Dart.PowerWEB.FileUpload.UploadProgressEventHandler
System.EventArgs
Dart.PowerWEB.FileUpload.FileUploadEventArgs
Dart.PowerWEB.FileUpload.FileUploadExceptionEventArgs
Dart.PowerWEB.FileUpload.KeyEventArgs
Dart.PowerWEB.FileUpload.LocationEventArgs
Dart.PowerWEB.FileUpload.UploadCompleteEventArgs
Dart.PowerWEB.FileUpload.UploadProgressEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
Dart.PowerWEB.FileUpload.UploadException
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Web.UI.WebControls.Style ---- System.Web.UI.IStateManager
Dart.PowerWEB.FileUpload.ButtonStyle
Dart.PowerWEB.FileUpload.CancelButtonStyle
Dart.PowerWEB.FileUpload.ProgBarStyle
Dart.PowerWEB.FileUpload.StatusStyle
Dart.PowerWEB.FileUpload.TextBoxStyle
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Dart.PowerWEB.FileUpload.BrowserType
Dart.PowerWEB.FileUpload.ButtonAlign
Dart.PowerWEB.FileUpload.ButtonType
Dart.PowerWEB.FileUpload.CallbackType
Dart.PowerWEB.FileUpload.CloseBehavior
Dart.PowerWEB.FileUpload.ErrorBehavior
Dart.PowerWEB.FileUpload.UploadType
Dart.PowerWEB.FileUpload.ViewStateCacheType
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IParserAccessor
Dart.PowerWEB.FileUpload.OpenFileDialog ---- Dart.PowerWEB.FileUpload.ILiveControl, System.Web.UI.IPostBackEventHandler
Dart.PowerWEB.FileUpload.UploadManager ---- System.Web.UI.IPostBackEventHandler
System.Web.UI.WebControls.WebControl ---- System.Web.UI.IAttributeAccessor
Dart.PowerWEB.FileUpload.ProgressPanel ---- Dart.PowerWEB.FileUpload.ILiveControl
Dart.PowerWEB.FileUpload.Upload ---- Dart.PowerWEB.FileUpload.ILiveControl, System.Web.UI.IPostBackEventHandler

See Also

Dart.PowerWEB.FileUpload Namespace