PowerWEB Zoom for ASP.NET

Until now, displaying high resolution images in a web application required plugins or complex scripting. With PowerWEB Zoom for ASP.NET, all of this has changed. Functionality like zooming into minute image details and smoothly panning across thousands of pixels is all instantly available.

PowerWEB Zoom is an Ajax-enabled image viewer that supercharges large photos without requiring new development skills or any manual photo manipulation. ASP.NET developers can focus on creating rich applications and Zoom handles the difficult tasks of image manipulation and delivery.

Key Features

  • Compatibility with ASP.NET 1.x and 2.0
  • Cross-browser support
  • Interactive image panning and zooming
  • Intuitive interface and on-screen tools such as a Zoom Slider, Compass Navigator, Magnifier and Thumbnail
  • Configurable keyboard shortcuts for all controls
  • On-demand delivery of image data
  • On-demand image scaling and rendering
  • Configurable render quality modes
  • Interoperability with all other PowerWEB products for producing richer user experience
  • Server object and event model
  • Client-Side API for additional integration and customization options

In PowerWEB Zoom for ASP.NET Documentation

Getting Started
Provides an overview of PowerWEB Zoom for ASP.NET and discusses such topics as distribution, licensing, and support.
Using the Zoom Control
Discusses how to use the Zoom control to display a high-res image in a browser.
Reference
Provides a language/syntax reference for PowerWEB Zoom for ASP.NET.
Samples
Describes the samples that are installed with PowerWEB Zoom for ASP.NET.

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Getting Started

PowerWEB Zoom for ASP.NET is a powerful image viewing and manipulation tool which makes it easy and fast to download and view high-res images in any modern browser. This topic provides information on general topics such as licensing, support, and deployment. For specific information and walkthroughs on the usage of the Zoom control contained in PowerWEB Zoom for ASP.NET, see Using the Zoom Control.

In This Section

Requirements
Discusses the requirements needed to use PowerWEB Zoom for ASP.NET.
License Registration
Provides step-by-step instructions on installing a license.
Trial Operation
Provides an overview on using PowerWEB for ASP.NET in trial mode.
Creating the 'licenses.licx' File
Discusses the required 'licenses.licx' file.
Deployment
Discusses the steps that are required to distribute an application in ASP.NET.
Support
Provides an overview of the support options that are available for this product.

Related Sections

Using the Zoom Control
Discusses how to use the Zoom control to display a high-res image in a browser.
Reference
Provides a language/syntax reference for PowerWEB Zoom for ASP.NET.
Samples
Describes the samples that are installed with PowerWEB Zoom for ASP.NET.

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Requirements

In order to use PowerWEB Zoom for ASP.NET you must have the following:

  • .NET Framework version 1, 1.1 or 2.
  • Microsoft Visual Studio .NET (recommended)
  • Internet Information Server (IIS) (recommended)

See Also

Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


License Registration

Your PowerWEB License Agreement provides you with a single-seat development license and the right to distribute PowerWEB classes with NO ROYALTIES of any kind. Some PowerWEB classes are marked as licensed. This topic covers:
  • Trial Installation
  • Installing a Fully Licensed PowerWEB Product
  • Re-installing a PowerWEB Product
  • License Details
  • Troubleshooting Licensing

Trial Installation

Installing a PowerWEB product as a fully–functional trial involves running the trial setup program (available from www.dart.com). The trial will operate for 30 days after installation. Proceed to step 2 of Installing a Fully Licensed PowerWEB Product when you are ready to license the product.

See Trial Operation for more information.

Installing a Fully Licensed PowerWEB Product

Once you have downloaded the latest version, complete the following steps to register your PowerWEB product.

If you have Internet Access on your development machine, please follow these instructions:

  1. From the Start menu, select Programs, select PowerWEB, select the PowerWEB product you downloaded, and then click License Registration.
  2. In the Dart License Registration dialog box, click Install.
  3. Click the Online Registration button.
  4. Enter required information, including Serial Number, First Name, Last Name, and Organization.
  5. Click Next.
  6. Enter your Email Address, Purchased From, and Purchase Date information.
  7. Click Next.
  8. Verify that the information is correct, and then click Next.
  9. When the registration process is complete, click Exit. (Note: Clicking Done at this step displays your currently registered PowerWEB product. Click Exit to complete the registration process and close the dialog box.)

If you do not have Internet Access on your development machine, please follow these instructions:
  1. From the Start menu, select Programs, select PowerWEB, select the PowerWEB product you downloaded, and then click License Registration.
  2. In the Dart License Registration dialog box, click Install.
  3. Under Option 2, enter your serial number in the Serial # field.
  4. Write down the number in the Key field.
  5. On a machine that has Internet access, log on to the Dart registration page (http://www.dart.com/register/).
  6. Enter all required information. The Key is the number written down in Step 4.
  7. Click Submit. A seven-digit registration code should appear.
  8. Back on the development machine (the machine on which Steps 1-4 were completed), enter the seven-digit registration number obtained in Step 7.
  9. Click Add.
  10. Click Exit.

After either of the two registration procedures are complete, your PowerWEB product appears in the Registered Tools field at the top of the registration form. Make sure you recompile your application after you register the PowerWEB product.

Re-installing a PowerWEB Product

The Key provided by the Registration Program is derived from a system number that is changed when the C: drive is reformatted. If you reformat your hard disk and need to re-install your PowerWEB product, follow the steps in Installing a Fully Licensed PowerWEB Product. A new Registration Number will be generated.

License Details

When you insert a PowerWEB component into a project, most development environments verify that the class is licensed for development. The component will work if you correctly entered the PowerWEB product Serial Number. See Installing a Fully Licensed PowerWEB Product for more information. When you compile your application, the development environment requests this Serial Number and embeds it in the application. When users run your application, the application submits this Serial Number to the class and the Serial Number is checked for validity. If the Serial Number is correct, then the application runs. This verification process occurs automatically.

Troubleshooting Licensing

For help troubleshooting licensing issues, see www.dart.com/support/lictrouble.asp.

If you have any problems registering your license, please contact Dart at 315-339-8040.

See Also

Trial Operation | Creating the 'licenses.licx' File | Deployment

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Trial Operation

During the Trial Period

An installed PowerWEB Trial operates as a fully–functional trial for up to 30 days. During this time, the product behaves as if it is fully licensed.

After the Trial Period

Once the trial period has expired, the licensed controls no longer function, and an expiration message appears.

If more time is needed to evaluate the product, please contact the Sales Department at sales@dart.com.

See License Installation for more information on product registration.

See Also

License Registration | Creating the 'licenses.licx' File | Deployment

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Creating the 'licenses.licx' File

When you create a Zoom control by dragging it from the toolbox, a licenses.licx file is automatically created by Visual Studio. The following steps are only necessary if you are using PowerWEB Zoom for ASP.NET classes without having dragged the control onto a form, or are using an IDE other than Visual Studio .NET.

To create a licenses.licx file, use the following steps. All PowerWEB classes are licensed, but only Zoom needs to be referenced in the licenses.licx file to use PowerWEB Zoom for ASP.NET.

  1. Start a new application in Visual Studio .NET and add the Zoom control as a reference.
  2. In the Solution Explorer, right-click the project name, choose Add, then Add New Item.
  3. From the resulting dialog box, choose Text File and name the file "licenses.licx". Click Open.
  4. Type the following in the licenses.licx file:
Dart.PowerWEB.Zoom.Zoom, Dart.PowerWEB.Zoom
  5. Save the file. You should now be able to compile and run a project that uses any PowerWEB Zoom class.

All PowerWEB classes are licensed, and will operate correctly if the above entry is added to the licenses.licx file.

Important! Do not change the "Build Action" property of the licenses.licx file from its default value of "Embedded Resource."

Important! Any time changes are made to the license, the Project (not the Solution) must be rebuilt or license changes will not take effect.

See Also

License Registration | Trial Operation | Deployment

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Deployment

Deploying a Web application that uses the PowerWEB Zoom control for ASP.NET is easy. Visual Studio users can simply Rebuild the Project (to insert the license) on the development machine (the licensed machine), and then XCOPY or FTP the application to the server.

While developing the following steps should have already been taken.

  1. If you are instantiating the component dynamically, be sure to include a licenses.licx file (see the "Creating The 'licenses.licx' File" topic for more information.
  2. If using Visual Studio, the following text is automatically added to Web.config. In other development environments you need to add this text to support dynamic script generation:
    <httpHandlers>
    <add verb="*" path="Dart.PowerWEB.Zoom.GetResource.aspx"
    type="Dart.PowerWEB.Zoom.ResourceHttpHandler,Dart.PowerWEB.Zoom" />
</httpHandlers>
    This section should be placed in the configuration:system.web node in the Web.config file.
  3. If using Visual Studio, the following text is automatically added to Web.config. In other development environments you need to add this text to support PowerWEB CallbackManager Viewstate management:

<httpModules>
    <add name="CallbackManager" type="Dart.PowerWEB.Zoom.CallbackManager,Dart.PowerWEB.Zoom" />
</httpModules>

    If the Project includes other PowerWEB references, the CallbackManager from another PowerWEB product may alternatively be used.

    See Viewstate Management Techniques for more information on the Callback Manager.

  4. A "\bin" subdirectory should be in your project's directory (many development environments create this automatically). For example, if the project is called LiveTest, you should have a directory structure with "LiveTest\bin".
  5. Check for "Dart.PowerWEB.Zoom.dll" in the "\Bin" directory. Your development environment may have already put a copy there when you added Zoom as a reference.

To deploy a licensed ASP.NET Web Application or Web Service, follow these steps.

  1. Compile the ASP.NET application on a licensed development machine.
  2. Copy the contents of the bin folder and the ASP.NET source files (such as .aspx files) to the server that will be hosting the application.
  3. Create a virtual directory pointing to the folder containing the Web Application or Web Service. Of course, you can always install directly to the "wwwroot" structure.

Note: It is not necessary for the deployment server to be licensed or to contain a copy of a license in its registry.

See Also

License Registration | Trial Operation | Creating the 'licenses.licx' File

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Support Options

Our mission at Dart is to deliver high quality Internet connectivity solutions to Internet application developers. Our goal is to supplement these solutions with timely support resources that can help at many different levels.

Related Links (you must have an active connection to the Internet to view these links).

Paid Support Options
Discusses the paid support options available.
Free Support Options
Provides access to free materials to help your development, including FAQS, online help files, tutorials, code snippets, online asp samples, and a free support forum.
Support Forum
Provides access to our support forum, monitored by our own development staff as time permits.
Dart Solutions
Discusses the custom development support offered by Dart Solutions.

See Also

Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Using the Zoom Control

PowerWEB Zoom for ASP.NET is a powerful image viewing and manipulation tool which makes it easy and fast to download and view high-res images in any modern browser. This topic provides a introductory walkthrough on the basic usage of PowerWEB Zoom for ASP.NET and addresses performance issues you may run across.

In This Section

Basic Configuration and Usage
Provides an introductory walkthrough in using the Zoom control to display both static and dynamic images.
Dynamic Manipulation
Describes the techniques used to dynamically update the Zoom control.
Performance Considerations
Discusses many performance issues you may run across during development and steps to address these issues.
Viewstate Management Techniques
Discusses techniques for managing Viewstate.

Related Sections

Getting Started
Provides an overview of PowerWEB Zoom for ASP.NET and discusses such topics as distribution, licensing, and support.
Reference
Provides a language/syntax reference for PowerWEB Zoom for ASP.NET.
Samples
Describes the samples that are installed with PowerWEB Zoom for ASP.NET.

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Basic Configuration and Usage

There are two scenarios to consider when creating a PowerWEB Zoom for ASP.NET application:

  1. Displaying a static image (the displayed image will never or rarely change). This is the simplest scenario.
  2. Displaying a dynamic image (the image displayed will frequently change). One possibility is displaying images from a database.

Displaying a static image

To display a static image, use the following steps. These steps assume usage of VS.NET, but simply by examining the server tags produced (shown at the end) these steps are easily portable to other editing environments.

  1. Add the Zoom control to the Toolbar.
  2. Drag an instance of the Zoom control onto the form, setting the desired Width and Height for the control.
  3. In the Properties Explorer, find the SourceImage property and click the ellipsis to open the file dialog. Browse for a file on your hard drive. When set, the SourceImage will be copied to the TileDirectory and prepared for use.
  4. Run the application. You should see the Zoom control load and display the image. At this point, you can pan or zoom the image using one of the navigation widgets or keyboard shortcuts.

If you examine the .aspx source, you will see server tags similar to the following. Non-VS.NET users can simply paste this code directly into the source of your .aspx page (along with the appropriate Register directive to register the tag prefix).

<cc1:Zoom id="Zoom1" runat="server" Height="500" Width="500" SourceImage="C:\MyImages\High-Res.JPG"></cc1:Zoom>

Continue to use the Properties Explorer to modify any desired properties of the displayed images. For instance, you can set EnableZoomSlider to false to hide the slider, or set NavigationPosition = DockPosition.TopRight to move the navigation widgets from the bottom-left to the upper-right.

In addition to the UI manipulation possible, you can dynamically pan/zoom the image as needed using server code. See the Dynamic Manipulation topic for more info.

Displaying a dynamic image

To display a dynamic image, use the following steps. These steps assume an image has been read from a database and the image data is contained in a byte array.

  1. Add the Zoom control to the Toolbar.
  2. Drag an instance of the Zoom control onto the form, setting the desired Width and Height for the control.
  3. In your code behind, add the following code to load the image into the TileDirectory and set the image as the current image to display:
[C#]
// Copy the image into the working TileDirectory folder.
Zoom1.LoadImage(myImageBytes, “myfile.jpg”);
// Set the image as the current image to display.
Zoom1.SourceImage = “myfile.jpg”;

See Also

Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Dynamic Manipulation

The Zoom control was designed to be manipulated via an Ajax callback simply by setting the properties or calling the methods of the control. This manipulation can occur as a result of one of two actions:

  1. A callback issued by the Zoom control itself (via the Zoom.AutoupdateInterval property)
  2. A callback issued from a PowerWEB LiveControl (see http://www.dart.com/powerweb/livecontrols.asp) for more information and a free trial download.

Dynamically updating the control by using the AutoUpdateInterval property

The AutoUpdateInterval property is used to periodically “poll” the server for new information, providing the developer to update the control as needed. By default the AutoUpdateInterval property is -1, meaning no polling occurs. To actively poll for new information, use the following steps: (this example simply moves the control to a random location with each poll).

1. Follow the steps in Basic Usage and Configuration to add a Zoom control and set the SourceImage.

2. Implement an event-handler for the AutoUpdate event.

3. In the Page_Load event, set up the AutoUpdateInterval.

[C#]
if(!Page.IsPostBack)
{
// Go to a 75% zoom level
    Zoom1.Z = 75;

    // Poll the server every 5 seconds.
    Zoom1.AutoUpdateInterval = 5000;
}

4. In the AutoUpdate event, implement the random movement code.

[C#]
private void Zoom1_AutoUpdate(object sender, System.EventArgs e)
{
// Get random x/y coords
    int x = new Random().Next(0, Zoom1.ZoomLevelWidth);
    int y = new Random().Next(0, Zoom1.ZoomLevelHeight);

    // move the control with animation.
    Zoom1.BeginMoveTo(x, y, 10, 10);
}

5. Compile and run the application. You should see the image periodically pan to a new location on it’s own.

Dynamically updating the control using a PowerWEB LiveControl

This example assumes you have downloaded and installed a trial kit of PowerWEB LiveControls for ASP.NET from http://www.dart.com/powerweb/livecontrols.asp. Four buttons are going to be added to the webform to toggle the four navigation widgets visibility.

1. Follow the steps in Basic Usage and Configuration to add a Zoom control and set the SourceImage.

2. Based on these steps, add the LiveButton (included in the LiveControls installation) to the Toolbar and add 4 instances of the LiveButton to the webform.

3. Set the text on each of the LiveButtons to “toggle slider”, “toggle compass”, “toggle magnifier”, and “toggle thumbnail”.

4. Implement the Click event for each LiveButton.

5. In the appropriate LiveButton Click event, toggle the corresponding widget like so:

[C#]
private void LiveButton1_Click(object sender, System.EventArgs e)
{
    Zoom1.EnableZoomSlider = !Zoom1.EnableZoomSlider;
}

private void LiveButton2_Click(object sender, System.EventArgs e)
{
    Zoom1.EnableCompass = !Zoom1.EnableCompass;
}

private void LiveButton3_Click(object sender, System.EventArgs e)
{
    Zoom1.EnableMagnifier = !Zoom1.EnableMagnifier;
}

private void LiveButton4_Click(object sender, System.EventArgs e)
{
    Zoom1.EnableThumbnail = !Zoom1.EnableThumbnail.
}

See Also

Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Performance Considerations

Due to the potential for loading/processing very large images, performance must be considered and tweaked for each scenario. There are 3 areas in which the Zoom control’s performance must be considered.

  1. Server memory use
  2. Network bandwidth use
  3. Client-Side UI responsiveness

By default, the Zoom control is set to be optimal for the majority of scenarios. However, if you notice below-expectation performance in one of the three areas above, follow the instructions below to tweak the settings. Be wary though, that potentially the setting which will greatly improve one of these three areas could impact another of the areas negatively, so some iterative testing may be required to find the right mix.

Improving server memory use

By default, the Zoom control uses image memory caching techniques to reduce the load time associated with reading files from disk. As a result, images can be processed and split into tiles much faster, but at the expense of server memory.

To improve server memory:

  • Reduce (or completely disable by setting to -1) the CacheTime property. This will cause the processing time to be longer, but will free up memory.
  • Lower the output quality of the image tiles by setting Quality to a lower value.
  • Resize the source images to a smaller size/resolution if they are excessively large.

Improving network bandwidth use

The Zoom control is a huge improvement over standard image display techniques in terms of bandwidth consumption, as only the portions of the image that are needed are sent to the client. However, if you wish to further reduce network bandwidth use, you can employ the following techniques:

  • Reduce the Height and Width of the control, thereby reducing the amount of image tiles needed client-side.
  • Reduce the AutoUpdateInterval property, if used, decreasing the HTTP communication between client and server.
  • Reduce the Quality, decreasing the size of the output image.
  • Use a lower BufferRingWidth value, decreasing the amount of preloaded image tiles.

Improving client-side UI responsiveness

As a general rule, client-side performance is improved by reducing the number of DOM objects that need to be created. The following techniques are helpful:

  • Reduce the Height and Width of the control, thereby reducing the amount of image tiles needed client-side.
  • Use a lower BufferRingWidth value, decreasing the amount of preloaded image tiles.
  • Use a higher TileSize, decreasing the amount of tiles that need to be created.

See Also

Viewstate Management Techniques | Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Viewstate Management Techniques

State management when using PowerWEB Zoom may require special emphasis. Since the application has Windows-style response to interface interactions, and provides controls associated with Windows apps, it is quite easy to forget that the communication between client and server still uses the HTTP protocol, and is therefore stateless.

As with other ASP.NET controls, PowerWEB Zoom requires "ViewState" techniques to carry forth control state from one request to the next. By default, Zoom stores ViewState in the application's Cache object, which has a number of benefits. ViewState will no longer be round-tripped with each callback, greatly reducing bandwidth requirements and accelerating client-side rendering operations. The difference will be most noticeable in complex pages with many controls.

Each page's viewstate data is stored with a default timeout of 20 minutes. This value can be altered by adding the following key to the appSettings node in the application's web.config file:

<add key="Dart.PowerWEB.Zoom.ViewStateCacheTimeout" value="20" />

The value should be set to the number of minutes before expiration. It is recommended that this timeout be equal to or greater than the setting used for the application's Session timeout. If the ViewState cache expires while the session remains active, an exception will occur if the page is manipulated:

"The server viewstate cache has timed out. The application was unable to successfully recover state. To address this exception, modify your web.config to use client-side viewstate caching, or to extend the server cache timeout value."

To disable the ViewState cache mechanism and to force the encoded data to be round-tripped in each callback, add the following key to the appSettings node in the application's web.config file:

<add key="Dart.PowerWEB.Zoom.ViewStateCacheEnabled" value="false" />

If you would like to implement a custom ViewState persistence mechanism, you may override Page.LoadPageStateFromPersistenceMedium and Page.SavePageStateToPersistenceMedium to store and retrieve ViewState information in a custom manner (for example, using a database or file system):

protected override object LoadPageStateFromPersistenceMedium()
{
    //add code to return the saved ViewState object
}

protected override void SavePageStateToPersistenceMedium(object viewState)
{
    //add code to store the saved ViewState object
}

See Also

Performance Considerations | Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Reference

PowerWEB Zoom for ASP.NET Reference

This section contains reference documentation for all of the objects and classes that comprise PowerWEB Zoom for ASP.NET. This section is intended solely for use as a class reference guide for use while building an application. It is not intended to give a "walkthrough" type description of usage. For a description of this type, see the higher-level topics.

In This Section

Dart.PowerWEB Zoom Namespace
Contains classes that support and enable integration of SNMP in .NET.
Client-Side Reference
Describes client-side JavaScript functions that are used by PowerWEB Zoom for ASP.NET.

Related Sections

Getting Started
Provides an overview of PowerWEB Zoom for ASP.NET and discusses such topics as distribution, licensing, and support.
Using the Zoom Control
Discusses how to use the Zoom control to display a high-res image in a browser.
Samples
Describes the samples that are installed with PowerWEB Zoom for ASP.NET.

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Dart.PowerWEB.Zoom

Dart.PowerWEB.Zoom Namespace

Namespace hierarchy

Classes

Class | Description
CallbackManager | This class is not meant to be used by developers.
KeyEventArgs | Provides data for the KeyDown, KeyPress or KeyUp event.
LocationEventArgs | Provides location data for any events that occur when a user clicks on a PowerWEB control.
ResourceHttpHandler | Summary description for ResourceHttpHandler.
Zoom | Provides cross-browser image panning and zooming functionality.

Delegates

Delegate | Description
KeyEventHandler | The delegate for the Key event.
LocationEventHandler | The delegate for events that require location information.

Enumerations

Enumeration | Description
BrowserType | Enumerates values which describe the Web browser in use.
CallbackType | Enumerates values which describe the type of callback mechanism in use.
DialogType | Enumerates values which describe types of JavaScript message box.
DockPosition | Enumerates the positions of the navigation widgets.
ErrorBehavior | Enumerates values which describe the behavior when an error condition occurs.
LayoutType | Enumerates the layout types of the navigation widgets.
SkinType | Enumerates the look-and-feel of the navigation elements.

Syntax based on .NET Framework version 1.1.
Documentation version 1.0.0.0.


BrowserType Enumeration

Enumerates values which describe the Web browser in use.

[Visual Basic]
Public Enum BrowserType
[C#]
public enum BrowserType
[C++]
public __value enum BrowserType
[JScript]
public enum BrowserType

Remarks

This enumeration is used by the BrowserType property.

Members

Member Name | Description
NotSet | The Web browser is not set.
Unsupported | An unsupported Web browser.
IE | The Internet Explorer Web browser.
Mozilla | The Mozilla Web browser.
IE5 | The Internet Explorer 5 Web browser.
IE5Mac | The Internet Explorer Web browser for Mac.
Opera | The Opera Web browser.
Konqueror | The Konqueror Web browser.
Galeon | The Galeon Web browser.
Netscape6 | Netscape 6, which requires special handling seperate than Netscape 7.
OperaXmlHttp | The Opera XmlHttp-capable Web browser.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Dart.PowerWEB.Zoom Namespace


CallbackManager Class

This class is not meant to be used by developers.

For a list of all members of this type, see CallbackManager Members.

System.Object
Dart.PowerWEB.Zoom.CallbackManager

[Visual Basic]
Public Class CallbackManager
    Implements IHttpModule
[C#]
public class CallbackManager : IHttpModule
[C++]
public __gc class CallbackManager : public IHttpModule
[JScript]
public class CallbackManager extends IHttpModule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

CallbackManager Members | Dart.PowerWEB.Zoom Namespace


CallbackManager Members

CallbackManager overview

Public Instance Constructors

CallbackManager Constructor

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CallbackManager Class | Dart.PowerWEB.Zoom Namespace


CallbackManager Constructor

[Visual Basic]
Public Sub New()
[C#]
public CallbackManager();
[C++]
public: CallbackManager();
[JScript]
public function CallbackManager();

See Also

CallbackManager Class | Dart.PowerWEB.Zoom Namespace


CallbackManager Methods

The methods of the CallbackManager class are listed below. For a complete list of CallbackManager class members, see the CallbackManager Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Init |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CallbackManager Class | Dart.PowerWEB.Zoom Namespace


Dispose Method

CallbackManager.Dispose Method

[Visual Basic]
Public Sub Dispose() _
    Implements IHttpModule.Dispose
[C#]
public void Dispose();
[C++]
public: void Dispose();
[JScript]
public function Dispose();

Implements

IHttpModule.Dispose

See Also

CallbackManager Class | Dart.PowerWEB.Zoom Namespace


Init Method

CallbackManager.Init Method

[Visual Basic]
Public Sub Init( _
   ByVal context As HttpApplication _
) _
    Implements IHttpModule.Init
[C#]
public void Init(
   HttpApplication context
);
[C++]
public: void Init(
   HttpApplication* context
);
[JScript]
public function Init(
   HttpApplication context
);

Parameters

context

Implements

IHttpModule.Init

See Also

CallbackManager Class | Dart.PowerWEB.Zoom Namespace


CallbackType Enumeration

Enumerates values which describe the type of callback mechanism in use.

[Visual Basic]
Public Enum CallbackType
[C#]
public enum CallbackType
[C++]
public __value enum CallbackType
[JScript]
public enum CallbackType

Remarks

This enumeration is used by the Callback property.

Members

Member Name | Description
AutoDetect | The callback type to use is automatically detected.
XmlHttp | Callbacks performed with the XmlHttp object.
Flash | Callbacks performed with the Flash plugin.
IFrame | Callbacks performed with IFrame.
None | Postbacks are used in place of callbacks.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Dart.PowerWEB.Zoom Namespace


DialogType Enumeration

Enumerates values which describe types of JavaScript message box.

[Visual Basic]
Public Enum DialogType
[C#]
public enum DialogType
[C++]
public __value enum DialogType
[JScript]
public enum DialogType

Remarks

This enumeration is used as a parameter of the LiveMessageBox control.

Members

Member Name | Description
Alert | Show an alert box (a message with an OK button).
Prompt | Show a prompt box (a message with OK and Cancel buttons, and an input field).
Confirm | Show a confirm box (a message with OK and Cancel buttons).

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Dart.PowerWEB.Zoom Namespace


DockPosition Enumeration

Enumerates the positions of the navigation widgets.

[Visual Basic]
Public Enum DockPosition
[C#]
public enum DockPosition
[C++]
public __value enum DockPosition
[JScript]
public enum DockPosition

Members

Member Name | Description
TopLeft | Navigation widgets are positioned at the top-left of the control.
TopCenter | Navigation widgets are positioned at the top-center of the control.
TopRight | Navigation widgets are positioned at the top-right of the control.
MiddleLeft | Navigation widgets are positioned at the middle-left of the control.
Middle | Navigation widgets are positioned in the middle of the control.
MiddleRight | Navigation widgets are positioned at the middle-right of the control.
BottomLeft | Navigation widgets are positioned at the bottom-left of the control.
BottomCenter | Navigation widgets are positioned at the bottom-center of the control.
BottomRight | Navigation widgets are positioned at the bottom-right of the control.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Dart.PowerWEB.Zoom Namespace


ErrorBehavior Enumeration

Enumerates values which describe the behavior when an error condition occurs.

[Visual Basic]
Public Enum ErrorBehavior
[C#]
public enum ErrorBehavior
[C++]
public __value enum ErrorBehavior
[JScript]
public enum ErrorBehavior

Remarks

This enumeration is used by the ErrorBehavior property.

Members

Member Name | Description
ShowAlert | Show an alert box with the value of the ErrorMessage property.
ShowInBrowser | Show the exception in the browser.
Eat | Do not show the exception.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Dart.PowerWEB.Zoom Namespace


KeyEventArgs Class

Provides data for the KeyDown, KeyPress or KeyUp event.

For a list of all members of this type, see KeyEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.Zoom.KeyEventArgs

[Visual Basic]
Public Class KeyEventArgs
    Inherits EventArgs
[C#]
public class KeyEventArgs : EventArgs
[C++]
public __gc class KeyEventArgs : public EventArgs
[JScript]
public class KeyEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

A KeyEventArgs, which specifies the key the user pressed and whether any modifier keys (CTRL, ALT, and SHIFT) were pressed at the same time, is passed with each KeyDown, KeyPress or KeyUp event.

The KeyDown event occurs when the user presses any key. The KeyUp event occurs when the user releases the key. Duplicate KeyDown events occur each time the key repeats, if the key is held down, but only one KeyUp event is generated when the user releases the key. The KeyPress event also occurs when a key is depressed.

For information about the event model, see Events and Delegates.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

KeyEventArgs Members | Dart.PowerWEB.Zoom Namespace


KeyEventArgs Members

KeyEventArgs overview

Public Instance Constructors

KeyEventArgs Overloaded. Initializes a new instance of the KeyEventArgs class.

Public Instance Properties

Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

KeyEventArgs Class | Dart.PowerWEB.Zoom Namespace


KeyEventArgs Constructor

Initializes a new instance of KeyEventArgs.

Overload List

Initializes a new instance of KeyEventArgs.

[Visual Basic] Public Sub New()
[C#] public KeyEventArgs();
[C++] public: KeyEventArgs();
[JScript] public function KeyEventArgs();

Initializes a new instance of KeyEventArgs.

[Visual Basic] Public Sub New(ByVal Integer,ByVal Boolean,ByVal Boolean,ByVal Boolean)
[C#] public KeyEventArgs(int,bool,bool,bool);
[C++] public: KeyEventArgs(int,bool,bool,bool);
[JScript] public function KeyEventArgs(int,bool,bool,bool);

See Also

KeyEventArgs Class | Dart.PowerWEB.Zoom Namespace


KeyEventArgs Constructor ()

Initializes a new instance of KeyEventArgs.

[Visual Basic]
Public Sub New()
[C#]
public KeyEventArgs();
[C++]
public: KeyEventArgs();
[JScript]
public function KeyEventArgs();

Remarks

The default constructor initializes a new instance of KeyEventArgs.

See Also

KeyEventArgs Class | Dart.PowerWEB.Zoom Namespace | KeyEventArgs Constructor Overload List


KeyEventArgs Constructor (Int32, Boolean, Boolean, Boolean)

Initializes a new instance of KeyEventArgs.

[Visual Basic]
Public Sub New( _
   ByVal keyCode As Integer, _
   ByVal alt As Boolean, _
   ByVal control As Boolean, _
   ByVal shift As Boolean _
)
[C#]
public KeyEventArgs(
   int keyCode,
   bool alt,
   bool control,
   bool shift
);
[C++]
public: KeyEventArgs(
   int keyCode,
   bool alt,
   bool control,
   bool shift
);
[JScript]
public function KeyEventArgs(
   int keyCode,
   bool alt,
   bool control,
   bool shift
);

Remarks

The constructor initializes a new instance of KeyEventArgs with KeyCode, Alt, Control, Shift.

See Also

KeyEventArgs Class | Dart.PowerWEB.Zoom Namespace | KeyEventArgs Constructor Overload List


KeyEventArgs Properties

The properties of the KeyEventArgs class are listed below. For a complete list of KeyEventArgs class members, see the KeyEventArgs Members topic.

Public Instance Properties

Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

See Also

KeyEventArgs Class | Dart.PowerWEB.Zoom Namespace


Alt Property

KeyEventArgs.Alt Property

Gets a value indicating whether the ALT key was pressed.

[Visual Basic]
Public Property Alt As Boolean
[C#]
public bool Alt { get; set; }
[C++]
public: __property bool get_Alt();
public: __property void set_Alt(bool );
[JScript]
public function get Alt() : bool
public function set Alt(bool);

Property Value

true if the ALT key was pressed; otherwise, false.

Remarks

Use this property to determine if the ALT key was pressed during the PowerWEB control event.

See Also

KeyEventArgs Class | Dart.PowerWEB.Zoom Namespace


Control Property

KeyEventArgs.Control Property

Gets a value indicating whether the CTRL key was pressed.

[Visual Basic]
Public Property Control As Boolean
[C#]
public bool Control { get; set; }
[C++]
public: __property bool get_Control();
public: __property void set_Control(bool );
[JScript]
public function get Control() : bool
public function set Control(bool);

Property Value

true if the CTRL key was pressed; otherwise, false.

Remarks

Use this property to determine if the CTRL key was pressed during the PowerWEB control event.

See Also

KeyEventArgs Class | Dart.PowerWEB.Zoom Namespace


KeyCode Property

KeyEventArgs.KeyCode Property

Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.

[Visual Basic]
Public Property KeyCode As Integer
[C#]
public int KeyCode { get; set; }
[C++]
public: __property int get_KeyCode();
public: __property void set_KeyCode(int );
[JScript]
public function get KeyCode() : int
public function set KeyCode(int);

Property Value

A Keys value that is the key code for the event.

Remarks

Use this property to determine the key corresponding to PowerWEB control event.

See Also

KeyEventArgs Class | Dart.PowerWEB.Zoom Namespace


Shift Property

KeyEventArgs.Shift Property

Gets a value indicating whether the SHIFT key was pressed.

[Visual Basic]
Public Property Shift As Boolean
[C#]
public bool Shift { get; set; }
[C++]
public: __property bool get_Shift();
public: __property void set_Shift(bool );
[JScript]
public function get Shift() : bool
public function set Shift(bool);

Property Value

true if the SHIFT key was pressed; otherwise, false.

Remarks

Use this property to determine if the SHIFT key was pressed during the PowerWEB control event.

See Also

KeyEventArgs Class | Dart.PowerWEB.Zoom Namespace


KeyEventHandler Delegate

The delegate for the Key event.

[Visual Basic]
Public Delegate Function Sub  KeyEventHandler( _
   ByVal sender As Object, _
   ByVal e As KeyEventArgs _
)
[C#]
public delegate void KeyEventHandler(
   object sender,
   KeyEventArgs e
)
[C++]
public __gc __delegate void KeyEventHandler(
   Object* sender,
   KeyEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Dart.PowerWEB.Zoom Namespace


LayoutType Enumeration

Enumerates the layout types of the navigation widgets.

[Visual Basic]
Public Enum LayoutType
[C#]
public enum LayoutType
[C++]
public __value enum LayoutType
[JScript]
public enum LayoutType

Members

Member Name | Description
Horizontal | Navigation widgets are arranged horizontally.
Vertical | Navigation widgets are arranged vertically.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Dart.PowerWEB.Zoom Namespace


LocationEventArgs Class

Provides location data for any events that occur when a user clicks on a PowerWEB control.

For a list of all members of this type, see LocationEventArgs Members.

System.Object
System.EventArgs
Dart.PowerWEB.Zoom.LocationEventArgs

[Visual Basic]
Public Class LocationEventArgs
    Inherits EventArgs
[C#]
public class LocationEventArgs : EventArgs
[C++]
public __gc class LocationEventArgs : public EventArgs
[JScript]
public class LocationEventArgs extends EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class passes the location on the page where a user clicked a PowerWEB control as x and y coordinates. You can then use event handlers to programmatically respond to the event based on the value of these coordinates.

Note The origin coordinates (0,0) are located at the upper left corner of the WebForm.

Raising an event invokes the event handler through a delegate. For more information, see Raising an Event.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

LocationEventArgs Members | Dart.PowerWEB.Zoom Namespace


LocationEventArgs Members

LocationEventArgs overview

Public Instance Constructors

LocationEventArgs Overloaded. Initializes a new instance of the LocationEventArgs class.

Public Instance Properties

X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LocationEventArgs Class | Dart.PowerWEB.Zoom Namespace


LocationEventArgs Constructor

Initializes a new instance of LocationEventArgs.

Overload List

Initializes a new instance of LocationEventArgs.

[Visual Basic] Public Sub New()
[C#] public LocationEventArgs();
[C++] public: LocationEventArgs();
[JScript] public function LocationEventArgs();

Initializes a new instance of LocationEventArgs.

[Visual Basic] Public Sub New(ByVal Unit,ByVal Unit)
[C#] public LocationEventArgs(Unit,Unit);
[C++] public: LocationEventArgs(Unit,Unit);
[JScript] public function LocationEventArgs(Unit,Unit);

See Also

LocationEventArgs Class | Dart.PowerWEB.Zoom Namespace


LocationEventArgs Constructor ()

Initializes a new instance of LocationEventArgs.

[Visual Basic]
Public Sub New()
[C#]
public LocationEventArgs();
[C++]
public: LocationEventArgs();
[JScript]
public function LocationEventArgs();

Remarks

The default constructor initializes a new instance of LocationEventArgs.

See Also

LocationEventArgs Class | Dart.PowerWEB.Zoom Namespace | LocationEventArgs Constructor Overload List


LocationEventArgs Constructor (Unit, Unit)

Initializes a new instance of LocationEventArgs.

[Visual Basic]
Public Sub New( _
   ByVal x As Unit, _
   ByVal y As Unit _
)
[C#]
public LocationEventArgs(
   Unit x,
   Unit y
);
[C++]
public: LocationEventArgs(
   Unit x,
   Unit y
);
[JScript]
public function LocationEventArgs(
   Unit x,
   Unit y
);

Remarks

The constructor initializes a new instance of LocationEventArgs with (X, Y) coordinates.

See Also

LocationEventArgs Class | Dart.PowerWEB.Zoom Namespace | LocationEventArgs Constructor Overload List


LocationEventArgs Properties

The properties of the LocationEventArgs class are listed below. For a complete list of LocationEventArgs class members, see the LocationEventArgs Members topic.

Public Instance Properties

X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

See Also

LocationEventArgs Class | Dart.PowerWEB.Zoom Namespace


X Property

LocationEventArgs.X Property

Gets or sets the x-coordinate of the WebForm when the mouse is clicked.

[Visual Basic]
Public Property X As Unit
[C#]
public Unit X { get; set; }
[C++]
public: __property Unit get_X();
public: __property void set_X(Unit );
[JScript]
public function get X() : Unit
public function set X(Unit);

Property Value

A Unit corresponding to the x-coordinate of the mouse click.

Remarks

Use this property with Y to determine the location of the mouse click.

See Also

LocationEventArgs Class | Dart.PowerWEB.Zoom Namespace


Y Property

LocationEventArgs.Y Property

Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

[Visual Basic]
Public Property Y As Unit
[C#]
public Unit Y { get; set; }
[C++]
public: __property Unit get_Y();
public: __property void set_Y(Unit );
[JScript]
public function get Y() : Unit
public function set Y(Unit);

Property Value

A Unit corresponding to the y-coordinate of the mouse click.

Remarks

Use this property with X to determine the location of the mouse click.

See Also

LocationEventArgs Class | Dart.PowerWEB.Zoom Namespace


LocationEventHandler Delegate

The delegate for events that require location information.

[Visual Basic]
Public Delegate Function Sub  LocationEventHandler( _
   ByVal sender As Object, _
   ByVal e As LocationEventArgs _
)
[C#]
public delegate void LocationEventHandler(
   object sender,
   LocationEventArgs e
)
[C++]
public __gc __delegate void LocationEventHandler(
   Object* sender,
   LocationEventArgs* e
)

[JScript] In JScript, you can use the delegates defined by a type, but you cannot define your own.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Dart.PowerWEB.Zoom Namespace


ResourceHttpHandler Class

Summary description for ResourceHttpHandler.

For a list of all members of this type, see ResourceHttpHandler Members.

System.Object
Dart.PowerWEB.Zoom.ResourceHttpHandler

[Visual Basic]
Public Class ResourceHttpHandler
    Implements IHttpHandler
[C#]
public class ResourceHttpHandler : IHttpHandler
[C++]
public __gc class ResourceHttpHandler : public IHttpHandler
[JScript]
public class ResourceHttpHandler extends IHttpHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

ResourceHttpHandler Members | Dart.PowerWEB.Zoom Namespace


ResourceHttpHandler Members

ResourceHttpHandler overview

Public Instance Constructors

ResourceHttpHandler Constructor Initializes a new instance of the ResourceHttpHandler class.

Public Instance Properties

IsReusable This property is used to indicate that the object instance can be used by other requests. It always returns true.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRequest | Load the resource specified in the query string and return it as the HTTP response.
ReadBinaryResource | Read a binary resource such as an image in from the stream. Since the size of the resource cannot be obtained, it is read in a block at a time until the end of the stream is reached.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceHttpHandler Class | Dart.PowerWEB.Zoom Namespace


ResourceHttpHandler Constructor

Initializes a new instance of the ResourceHttpHandler class.

[Visual Basic]
Public Sub New()
[C#]
public ResourceHttpHandler();
[C++]
public: ResourceHttpHandler();
[JScript]
public function ResourceHttpHandler();

See Also

ResourceHttpHandler Class | Dart.PowerWEB.Zoom Namespace


ResourceHttpHandler Properties

The properties of the ResourceHttpHandler class are listed below. For a complete list of ResourceHttpHandler class members, see the ResourceHttpHandler Members topic.

Public Instance Properties

IsReusable This property is used to indicate that the object instance can be used by other requests. It always returns true.

See Also

ResourceHttpHandler Class | Dart.PowerWEB.Zoom Namespace


IsReusable Property

ResourceHttpHandler.IsReusable Property

This property is used to indicate that the object instance can be used by other requests. It always returns true.

[Visual Basic]
Public Property ReadOnly IsReusable As Boolean _
    Implements IHttpHandler.IsReusable
[C#]
public bool IsReusable { get; }
[C++]
public: __property bool get_IsReusable();
[JScript]
public function get IsReusable() : bool

Implements

IHttpHandler.IsReusable

See Also

ResourceHttpHandler Class | Dart.PowerWEB.Zoom Namespace


ResourceHttpHandler Methods

The methods of the ResourceHttpHandler class are listed below. For a complete list of ResourceHttpHandler class members, see the ResourceHttpHandler Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ProcessRequest | Load the resource specified in the query string and return it as the HTTP response.
ReadBinaryResource | Read a binary resource such as an image in from the stream. Since the size of the resource cannot be obtained, it is read in a block at a time until the end of the stream is reached.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceHttpHandler Class | Dart.PowerWEB.Zoom Namespace


ProcessRequest Method

ResourceHttpHandler.ProcessRequest Method

Load the resource specified in the query string and return it as the HTTP response.

[Visual Basic]
Public Sub ProcessRequest( _
   ByVal hc As HttpContext _
) _
    Implements IHttpHandler.ProcessRequest
[C#]
public void ProcessRequest(
   HttpContext hc
);
[C++]
public: void ProcessRequest(
   HttpContext* hc
);
[JScript]
public function ProcessRequest(
   HttpContext hc
);

Parameters

hc
The context object for the request

Implements

IHttpHandler.ProcessRequest

See Also

ResourceHttpHandler Class | Dart.PowerWEB.Zoom Namespace


ReadBinaryResource Method

ResourceHttpHandler.ReadBinaryResource Method

Read a binary resource such as an image in from the stream. Since the size of the resource cannot be obtained, it is read in a block at a time until the end of the stream is reached.

[Visual Basic]
Public Sub ReadBinaryResource( _
   ByVal sIn As Stream, _
   ByRef byBuffer As Byte(), _
   ByRef nLen As Integer _
)
[C#]
public void ReadBinaryResource(
   Stream sIn,
   out byte[] byBuffer,
   out int nLen
);
[C++]
public: void ReadBinaryResource(
   Stream* sIn,
   * char byBuffer __gc[],
   * int nLen
);
[JScript]
public function ReadBinaryResource(
   Stream sIn,
   Byte[] byBuffer,
   int nLen
);

Parameters

sIn
The stream from which to read the resource
byBuffer
An out parameter to receive the resource bytes
nLen
An out parameter to receive the resource length

See Also

ResourceHttpHandler Class | Dart.PowerWEB.Zoom Namespace


SkinType Enumeration

Enumerates the look-and-feel of the navigation elements.

[Visual Basic]
Public Enum SkinType
[C#]
public enum SkinType
[C++]
public __value enum SkinType
[JScript]
public enum SkinType

Members

Member Name | Description
Standard | Standard look-and-feel.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Dart.PowerWEB.Zoom Namespace


Zoom Class

Provides cross-browser image panning and zooming functionality.

For a list of all members of this type, see Zoom Members.

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Dart.PowerWEB.Zoom.Zoom

[Visual Basic]
Public Class Zoom
    Inherits WebControl
    Implements IPostBackEventHandler, IPostBackDataHandler
[C#]
public class Zoom : WebControl, IPostBackEventHandler, IPostBackDataHandler
[C++]
public __gc class Zoom : public WebControl, IPostBackEventHandler, IPostBackDataHandler
[JScript]
public class Zoom extends WebControl, IPostBackEventHandler, IPostBackDataHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Use the Zoom control to provide cross-browser image panning and zooming functionality. Using "load on demand" techniques (powered by Ajax communication) reduces the image load time and increases the UI responsiveness. The source image is split into smaller image tiles which are resized and loaded as needed.

Simply drag a Zoom control onto a webform to instantiate. Images can be loaded into the control one of two ways. To load a static image, simply set the SourceImage property in the designer. To load dynamic images, use the LoadImage method in code-behind.

Requirements

Namespace: Dart.PowerWEB.Zoom

Assembly: Dart.PowerWEB.Zoom (in Dart.PowerWEB.Zoom.dll)

See Also

Zoom Members | Dart.PowerWEB.Zoom Namespace


Zoom Members

Zoom overview

Public Instance Constructors

Zoom Overloaded. Initializes a new instance of the Zoom class.

Public Instance Properties

AccessKey | Overridden. Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
AutoUpdateInterval | Gets/sets a value which controls automatic "polling" behavior of the Zoom control.
BackColor | Overridden. Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) |
Blocking | Gets or sets the blocking state of the control.
BookmarkUrl | Gets/sets a string which provides control state.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
BufferRingWidth | Gets/sets a value which determines how many non-visible tiles are preloaded.
CacheTime | Gets/sets a value (in minutes) which determines how long source images are cached.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
EnableCallback | Gets or sets whether the control issues a callback.
EnableCompass | Gets/sets a value which determines if the navigation compass is displayed.
Enabled | Overridden. Gets or sets a value indicating whether the Web server control is enabled.
EnableMagnifier | Gets/sets a value which determines if the magnifying glass is displayed.
EnableThumbnail | Gets/sets a value which determines if the thumbnail is displayed.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
EnableZoomSlider | Gets/sets a value which determines if the zoom slider is displayed.
ErrorBehavior | Gets or sets how errors are handled by the control.
ErrorMessage | Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Format | Gets/sets an ImageFormat value specifying the output image format.
Height | Overridden. Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
InterpolationMode | Gets/sets the algorithm used when the source image is scaled.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
Left | Gets or sets the left position of the PowerWEB control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
NavigationLayout | Gets/sets the layout used for the navigation elements.
NavigationPosition | Gets/sets the position used for the navigation elements.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
PanDownShortcut | Gets/sets he keyboard shortcut for panning down.
PanLeftShortcut | Gets/sets the keyboard shortcut for panning left.
PanRightShortcut | Gets/sets the keyboard shortcut for panning right.
PanUpShortcut | Gets/sets the keyboard shortcut for panning up.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Quality | Gets/sets a value which determines the output quality of the image.
ShowGridlines | Gets/sets a value which determines if gridlines are displayed.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
SkinType | Gets/sets a value which determines which navigation skin is displayed.
SnapToGrid | Gets/sets a value which determines if the control snaps to the gridlines after moving.
SourceHeight | Gets the height of the source image.
SourceImage | Gets/sets the name of the source image to display in the Zoom control.
SourceWidth | Gets the width of the source image.
StopOnEdge | Gets/sets whether or not panning is allowed past the natural edge of the image.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex | Overridden. Gets or sets the tab index of the Web server control.
Tag | Gets or sets a convertible object that contains data about the control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ThumbnailFrameStyle | Gets a Style object which is used to modify the draggable frame displayed within the thumbnail image.
ThumbnailHeight | Gets/sets the height of the thumbnail image.
ThumbnailWidth | Gets/sets the width of the thumbnail image.
TileDirectory | The directory in which tiles will be created.
TileSize | Gets/sets a value specifying each tile's height/width.
ToggleMagnifierShortcut | Gets/sets the keyboard shortcut for toggling the magnifying glass.
ToolTip | Overridden. Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Top | Gets or sets the top position of the PowerWEB control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll | Gets or sets which fields are posted to the server in a callback.
Visible | Overridden. Gets or sets a value indicating whether the PowerWEB control is visible.
WaitElementID | Gets or sets the message ID of the HTML element to display a message during a pending callback.
WaitMessage | Gets or sets the message to display during a pending callback.
Width | Overridden. Gets or sets the width of the Web server control.
X | Gets/sets the X position of the image inside the Zoom control.
Y | Gets/sets the Y position of the image inside the Zoom control.
Z | Gets/sets the Z (zoom level) value of the image inside the Zoom control.
ZoomInShortcut | Gets/sets the keyboard shortcut for zooming in.
ZoomLevelHeight | Gets the height of the source image resized for the current Z value.
ZoomLevelWidth | Gets the width of the source image resized for the current Z value.
ZoomOutShortcut | Gets/sets the keyboard shortcut for zooming out.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
BeginMoveTo | Overloaded. Immediately reposition the image displayed in the Zoom control to the specified X/Y coordinate.
BeginPan | Overloaded. Slides the image displayed in the Zoom control in the direction of the specified angle.
ClearTiles | Overloaded. Clear all created tiles for all images in the project.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference | Returns JavaScript that can be used to initiate a callback to the server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState | Returns the ViewState object used to save and restore state.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadImage | Overloaded. Loads an array of bytes into the Zoom control.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag | Overridden. Renders the HTML closing tag of the control into the specified writer.
Reset | Resets the Zoom control to the initial X/Y/Z position.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
StopMove | Stops any current panning movement.
ToString (inherited from Object) | Returns a String that represents the current Object.
ZoomIn | Overloaded. Zoom in one level.
ZoomOut | Overloaded. Zoom out one level.

Public Instance Events

AutoUpdate | Raised periodically in the interval specified by Zoom.AutoUpdateInterval.
ContextMenuChanged | Occurs when the right button of the PowerWEB control is clicked.
DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
DoubleClick | Occurs when the control is double-clicked.
EndMoveTo | Raised when a moving operation completes.
EndPan | Raised when a panning operation completes.
GotFocus | Occurs when the PowerWEB control gains focus.
HelpRequested | Occurs when F1 is pressed while the control has focus.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
KeyDown | Occurs when a key is down while the control has focus.
KeyPress | Occurs when a key is pressed while the control has focus.
KeyUp | Occurs when a key is released while the control has focus.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
LocationClick | Occurs when the PowerWEB control is clicked, providing location data.
LostFocus | Occurs when the PowerWEB control loses focus.
MouseDown | Occurs when the mouse buttons are pressed while the PowerWEB control has focus.
MouseEnter | Occurs when the mouse pointer enters the PowerWEB control.
MouseLeave | Occurs when the mouse pointer leaves the PowerWEB control.
MouseUp | Occurs when the mouse buttons are released while the PowerWEB control has focus.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.
ZoomChanged | Raised when the value of Z is changed by a zooming operation.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Zoom Constructor

Initializes a new instance of the Zoom control.

Overload List

Initializes a new instance of the Zoom control.

[Visual Basic] Public Sub New()
[C#] public Zoom();
[C++] public: Zoom();
[JScript] public function Zoom();

Initializes a new instance of the Zoom control.

[Visual Basic] Public Sub New(ByVal String)
[C#] public Zoom(string);
[C++] public: Zoom(String*);
[JScript] public function Zoom(String);

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Zoom Constructor ()

Initializes a new instance of the Zoom control.

[Visual Basic]
Public Sub New()
[C#]
public Zoom();
[C++]
public: Zoom();
[JScript]
public function Zoom();

Remarks

The default constructor initializes the Zoom control with default settings.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom Constructor Overload List


Zoom Constructor (String)

Initializes a new instance of the Zoom control.

[Visual Basic]
Public Sub New( _
   ByVal oemLK As String _
)
[C#]
public Zoom(
   string oemLK
);
[C++]
public: Zoom(
   String* oemLK
);
[JScript]
public function Zoom(
   String oemLK
);

Remarks

The default constructor initializes the Zoom control with default settings.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom Constructor Overload List


Zoom Properties

The properties of the Zoom class are listed below. For a complete list of Zoom class members, see the Zoom Members topic.

Public Instance Properties

AccessKey | Overridden. Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.
Attributes (inherited from WebControl) | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control.
AutoUpdateInterval | Gets/sets a value which controls automatic "polling" behavior of the Zoom control.
BackColor | Overridden. Gets or sets the background color of the Web server control.
BindingContainer (inherited from Control) |
Blocking | Gets or sets the blocking state of the control.
BookmarkUrl | Gets/sets a string which provides control state.
BorderColor (inherited from WebControl) | Gets or sets the border color of the Web control.
BorderStyle (inherited from WebControl) | Gets or sets the border style of the Web server control.
BorderWidth (inherited from WebControl) | Gets or sets the border width of the Web server control.
BrowserType | Gets or sets the type of browser as detected by the PowerWEB control.
BufferedScript | Gets the client-side script which will be written to the response stream when the callback request is ended.
BufferRingWidth | Gets/sets a value which determines how many non-visible tiles are preloaded.
CacheTime | Gets/sets a value (in minutes) which determines how long source images are cached.
CallbackType | Gets or sets the type of callbacks performed by the PowerWEB control.
ClientID (inherited from Control) | Gets the server control identifier generated by ASP.NET.
Controls (inherited from Control) | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy.
ControlStyle (inherited from WebControl) | Gets the style of the Web server control. This property is used primarily by control developers.
ControlStyleCreated (inherited from WebControl) | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers.
CssClass (inherited from WebControl) | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client.
Debug | Set to true to display a debug window which displays callback data in real-time as it is set/received.
EnableCallback | Gets or sets whether the control issues a callback.
EnableCompass | Gets/sets a value which determines if the navigation compass is displayed.
Enabled | Overridden. Gets or sets a value indicating whether the Web server control is enabled.
EnableMagnifier | Gets/sets a value which determines if the magnifying glass is displayed.
EnableThumbnail | Gets/sets a value which determines if the thumbnail is displayed.
EnableViewState (inherited from Control) | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client.
EnableZoomSlider | Gets/sets a value which determines if the zoom slider is displayed.
ErrorBehavior | Gets or sets how errors are handled by the control.
ErrorMessage | Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.
Font (inherited from WebControl) | Gets the font properties associated with the Web server control.
ForeColor (inherited from WebControl) | Gets or sets the foreground color (typically the color of the text) of the Web server control.
Format | Gets/sets an ImageFormat value specifying the output image format.
Height | Overridden. Gets or sets the height of the Web server control.
ID (inherited from Control) | Gets or sets the programmatic identifier assigned to the server control.
InterpolationMode | Gets/sets the algorithm used when the source image is scaled.
IsCallback | Gets the callback state of the PowerWEB control.
IsLive | Gets or sets whether a PowerWEB control updates itself in a callback.
Left | Gets or sets the left position of the PowerWEB control.
NamingContainer (inherited from Control) | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value.
NavigationLayout | Gets/sets the layout used for the navigation elements.
NavigationPosition | Gets/sets the position used for the navigation elements.
Page (inherited from Control) | Gets a reference to the Page instance that contains the server control.
PanDownShortcut | Gets/sets he keyboard shortcut for panning down.
PanLeftShortcut | Gets/sets the keyboard shortcut for panning left.
PanRightShortcut | Gets/sets the keyboard shortcut for panning right.
PanUpShortcut | Gets/sets the keyboard shortcut for panning up.
Parent (inherited from Control) | Gets a reference to the server control's parent control in the page control hierarchy.
Quality | Gets/sets a value which determines the output quality of the image.
ShowGridlines | Gets/sets a value which determines if gridlines are displayed.
Site (inherited from Control) | Gets information about the Web site to which the server control belongs.
SkinType | Gets/sets a value which determines which navigation skin is displayed.
SnapToGrid | Gets/sets a value which determines if the control snaps to the gridlines after moving.
SourceHeight | Gets the height of the source image.
SourceImage | Gets/sets the name of the source image to display in the Zoom control.
SourceWidth | Gets the width of the source image.
StopOnEdge | Gets/sets whether or not panning is allowed past the natural edge of the image.
Style (inherited from WebControl) | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control.
TabIndex | Overridden. Gets or sets the tab index of the Web server control.
Tag | Gets or sets a convertible object that contains data about the control.
TemplateSourceDirectory (inherited from Control) | Gets the virtual directory of the Page or UserControl that contains the current server control.
ThumbnailFrameStyle | Gets a Style object which is used to modify the draggable frame displayed within the thumbnail image.
ThumbnailHeight | Gets/sets the height of the thumbnail image.
ThumbnailWidth | Gets/sets the width of the thumbnail image.
TileDirectory | The directory in which tiles will be created.
TileSize | Gets/sets a value specifying each tile's height/width.
ToggleMagnifierShortcut | Gets/sets the keyboard shortcut for toggling the magnifying glass.
ToolTip | Overridden. Gets or sets the text displayed when the mouse pointer hovers over the Web server control.
Top | Gets or sets the top position of the PowerWEB control.
UniqueID (inherited from Control) | Gets the unique, hierarchically-qualified identifier for the server control.
UpdateAll | Gets or sets which fields are posted to the server in a callback.
Visible | Overridden. Gets or sets a value indicating whether the PowerWEB control is visible.
WaitElementID | Gets or sets the message ID of the HTML element to display a message during a pending callback.
WaitMessage | Gets or sets the message to display during a pending callback.
Width | Overridden. Gets or sets the width of the Web server control.
X | Gets/sets the X position of the image inside the Zoom control.
Y | Gets/sets the Y position of the image inside the Zoom control.
Z | Gets/sets the Z (zoom level) value of the image inside the Zoom control.
ZoomInShortcut | Gets/sets the keyboard shortcut for zooming in.
ZoomLevelHeight | Gets the height of the source image resized for the current Z value.
ZoomLevelWidth | Gets the width of the source image resized for the current Z value.
ZoomOutShortcut | Gets/sets the keyboard shortcut for zooming out.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


AccessKey Property

Zoom.AccessKey Property

Gets or sets the access key (underlined letter) that allows you to quickly navigate to the Web server control.

[Visual Basic]
Overrides Public Property AccessKey As String
[C#]
public override string AccessKey { get; set; }
[C++]
public: __property String* get_AccessKey();
public: __property void set_AccessKey(String* );
[JScript]
public override function get AccessKey() : String
public override function set AccessKey(String);

Remarks

This member is functionally equivalent to System.Web.UI.WebControls.WebControl.AccessKey.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


AutoUpdateInterval Property

Zoom.AutoUpdateInterval Property

Gets/sets a value which controls automatic "polling" behavior of the Zoom control.

[Visual Basic]
Public Property AutoUpdateInterval As Integer
[C#]
public int AutoUpdateInterval { get; set; }
[C++]
public: __property int get_AutoUpdateInterval();
public: __property void set_AutoUpdateInterval(int );
[JScript]
public function get AutoUpdateInterval() : int
public function set AutoUpdateInterval(int);

Property Value

An integer specifying how often (in milliseconds) to poll the server for new data. The default value is -1 (meaning no polling occurs).

Remarks

The AutoUpdate event provides an opportunity to poll the server for new information and to update the Zoom control as needed with new data. The default value of AutoUpdateInterval is -1, meaning the control will not poll the server for new information. The polling is performed transparently using Ajax techniques so the client UI is not disrupted.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


BackColor Property

Zoom.BackColor Property

Gets or sets the background color of the Web server control.

[Visual Basic]
Overrides Public Property BackColor As Color
[C#]
public override Color BackColor { get; set; }
[C++]
public: __property Color get_BackColor();
public: __property void set_BackColor(Color );
[JScript]
public override function get BackColor() : Color
public override function set BackColor(Color);

Remarks

This member is functionally equivalent to System.Web.UI.Webcontrols.WebControl.BackColor.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Blocking Property

Zoom.Blocking Property

Gets or sets the blocking state of the control.

[Visual Basic]
Public Property Blocking As Boolean
[C#]
public bool Blocking { get; set; }
[C++]
public: __property bool get_Blocking();
public: __property void set_Blocking(bool );
[JScript]
public function get Blocking() : bool
public function set Blocking(bool);

Property Value

true if other PowerWEB controls should be disabled while the PowerWEB control has a pending callback.

Remarks

Although callbacks always occur asynchronously, when this property is true, a simulated blocking will be used. The interface will be disabled and updated as busy when a callback is pending (although the code itself will not block).

Note Only PowerWEB controls will be blocked. The user will still be able to interact with non-PowerWEB controls.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


BookmarkUrl Property

Zoom.BookmarkUrl Property

Gets/sets a string which provides control state.

[Visual Basic]
Public Property BookmarkUrl As String
[C#]
public string BookmarkUrl { get; set; }
[C++]
public: __property String* get_BookmarkUrl();
public: __property void set_BookmarkUrl(String* );
[JScript]
public function get BookmarkUrl() : String
public function set BookmarkUrl(String);

Property Value

A string containing control state information.

Remarks

This method provides a url string containing control state. This is useful for providing a url to the user which can be used to view an image at a particular X, Y, and Z coordinate. When this property is set to a valid string, the string will be parsed for control values to restore.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


BrowserType Property

Zoom.BrowserType Property

Gets or sets the type of browser as detected by the PowerWEB control.

[Visual Basic]
Public Property BrowserType As BrowserType
[C#]
public BrowserType BrowserType { get; set; }
[C++]
public: __property BrowserType get_BrowserType();
public: __property void set_BrowserType(BrowserType );
[JScript]
public function get BrowserType() : BrowserType
public function set BrowserType(BrowserType);

Property Value

A BrowserType that represents the browser rendering the PowerWEB control.

Remarks

This property is set when the PowerWEB control is initialized, based on the user-agent header sent by the browser. BrowserType can also be set to override the detected value with a custom browser detection algorithm.

Note This property is global to all PowerWEB controls. Any change to an individual PowerWEB control will automatically be applied to all PowerWEB controls on the form. It is not possible to have PowerWEB controls with different BrowserType values on the same form.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


BufferedScript Property

Zoom.BufferedScript Property

Gets the client-side script which will be written to the response stream when the callback request is ended.

[Visual Basic]
Public Property ReadOnly BufferedScript As StringWriter
[C#]
public StringWriter BufferedScript { get; }
[C++]
public: __property StringWriter* get_BufferedScript();
[JScript]
public function get BufferedScript() : StringWriter

Property Value

A StringWriter object that contains buffered script for a callback response.

Remarks

Use the BufferedScript property to modify the client-side script to be sent in response to a callback.

For example, to dynamically change the flow of a label (from bottom to top instead of left to right):

LiveLabel1.BufferedScript.Write(LiveLabel1.GetScriptStyleReference() + ".writingMode = 'tb-rl';");

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


BufferRingWidth Property

Zoom.BufferRingWidth Property

Gets/sets a value which determines how many non-visible tiles are preloaded.

[Visual Basic]
Public Property BufferRingWidth As Integer
[C#]
public int BufferRingWidth { get; set; }
[C++]
public: __property int get_BufferRingWidth();
public: __property void set_BufferRingWidth(int );
[JScript]
public function get BufferRingWidth() : int
public function set BufferRingWidth(int);

Property Value

An integer specifying how many "rings" of buffer tiles to preload. The default value is 1.

Remarks

The buffer ring is the ring of preloaded tiles outside of the visible rectangle of already loaded tiles. Preloading some tiles can help with the UI responsiveness.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


CacheTime Property

Zoom.CacheTime Property

Gets/sets a value (in minutes) which determines how long source images are cached.

[Visual Basic]
Public Property CacheTime As Integer
[C#]
public int CacheTime { get; set; }
[C++]
public: __property int get_CacheTime();
public: __property void set_CacheTime(int );
[JScript]
public function get CacheTime() : int
public function set CacheTime(int);

Property Value

An integer specifying the number of minutes to cache an image. The default value is 5.

Remarks

Caching source images can greatly increase the speed at which tiles are created. However, excessive caching may consume enough server memory to degrade performance in other areas. The default value (5 minutes) provides a good balance, keeping the image in cache long enough to provide a speed benefit while (in most cases) removing it before memory consumption becomes an issue. Set this property to -1 to turn of image caching completely. In this scenario, the image will always be stored/retrieved from the hard disk.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


CallbackType Property

Zoom.CallbackType Property

Gets or sets the type of callbacks performed by the PowerWEB control.

[Visual Basic]
Public Property CallbackType As CallbackType
[C#]
public CallbackType CallbackType { get; set; }
[C++]
public: __property CallbackType get_CallbackType();
public: __property void set_CallbackType(CallbackType );
[JScript]
public function get CallbackType() : CallbackType
public function set CallbackType(CallbackType);

Property Value

A CallbackType that represents the mechanism used for callbacks by the PowerWEB control.

Remarks

The optimal approach is CallbackType.XmlHttp. The first fallback approach is CallbackType.Flash. The final fallback is CallbackType.IFrame.

Defaults to CallbackType.AutoDetect. On the initial page load, CallbackType is set to the most appropriate value based on the browser type detected.

Set to override when auto-detection is insufficient. For example, if the browser has ActiveX turned off, XmlHttp and Flash will fail. However, the PowerWEB controls will not be aware of this, because this setting cannot be detected server-side. A developer can determine if ActiveX is off and set to IFRAME to provide a decent callback approach.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Debug Property

Zoom.Debug Property

Set to true to display a debug window which displays callback data in real-time as it is set/received.

[Visual Basic]
Public Property Debug As Boolean
[C#]
public bool Debug { get; set; }
[C++]
public: __property bool get_Debug();
public: __property void set_Debug(bool );
[JScript]
public function get Debug() : bool
public function set Debug(bool);

Property Value

true if a debug window is displayed when callback data is sent/received; false otherwise. The default value is false;

Remarks

This property is intended to be used by application developers to assist in diagnosis of application bugs. Set this property to true to see the JavaScript that is executed on the client-side as a result of the server-side interaction with the controls.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


EnableCallback Property

Zoom.EnableCallback Property

Gets or sets whether the control issues a callback.

[Visual Basic]
Public Property EnableCallback As Boolean
[C#]
public bool EnableCallback { get; set; }
[C++]
public: __property bool get_EnableCallback();
public: __property void set_EnableCallback(bool );
[JScript]
public function get EnableCallback() : bool
public function set EnableCallback(bool);

Property Value

true if the PowerWEB control uses callbacks. When false, the PowerWEB control uses traditional postbacks.

Remarks

Set EnableCallback to true for the PowerWEB control to use callbacks, as opposed to traditional postbacks.

Set to false to force the control to behave like its non-live counterpart.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


EnableCompass Property

Zoom.EnableCompass Property

Gets/sets a value which determines if the navigation compass is displayed.

[Visual Basic]
Public Property EnableCompass As Boolean
[C#]
public bool EnableCompass { get; set; }
[C++]
public: __property bool get_EnableCompass();
public: __property void set_EnableCompass(bool );
[JScript]
public function get EnableCompass() : bool
public function set EnableCompass(bool);

Property Value

A boolean specifying if the compass is displayed. The default value is true.

Remarks

The navigation compass can be used to pan the image in any direction. By default it is displayed, but can be turned off by setting this property to false.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Enabled Property

Zoom.Enabled Property

Gets or sets a value indicating whether the Web server control is enabled.

[Visual Basic]
Overrides Public Property Enabled As Boolean
[C#]
public override bool Enabled { get; set; }
[C++]
public: __property bool get_Enabled();
public: __property void set_Enabled(bool );
[JScript]
public override function get Enabled() : bool
public override function set Enabled(bool);

Remarks

This member is functionally equivalent to System.Web.UI.WebControls.WebControl.Enabled.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


EnableMagnifier Property

Zoom.EnableMagnifier Property

Gets/sets a value which determines if the magnifying glass is displayed.

[Visual Basic]
Public Property EnableMagnifier As Boolean
[C#]
public bool EnableMagnifier { get; set; }
[C++]
public: __property bool get_EnableMagnifier();
public: __property void set_EnableMagnifier(bool );
[JScript]
public function get EnableMagnifier() : bool
public function set EnableMagnifier(bool);

Property Value

A boolean specifying if the magnifying glass is displayed. The default value is true.

Remarks

The magnifying glass is used to enlarge a highlighted area of the image. By default it is displayed, but can be turned off by setting this property to false.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


EnableThumbnail Property

Zoom.EnableThumbnail Property

Gets/sets a value which determines if the thumbnail is displayed.

[Visual Basic]
Public Property EnableThumbnail As Boolean
[C#]
public bool EnableThumbnail { get; set; }
[C++]
public: __property bool get_EnableThumbnail();
public: __property void set_EnableThumbnail(bool );
[JScript]
public function get EnableThumbnail() : bool
public function set EnableThumbnail(bool);

Property Value

A boolean specifying if the thumbnail is displayed. The default value is true.

Remarks

The thumbnail displays a scaled down version of the entire image that can also be used for navigation. By default it is displayed, but can be turned off by setting this property to false. The thumbnail dimensions can be controlled via the ThumbnailWidth and the ThumbnailHeight.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


EnableZoomSlider Property

Zoom.EnableZoomSlider Property

Gets/sets a value which determines if the zoom slider is displayed.

[Visual Basic]
Public Property EnableZoomSlider As Boolean
[C#]
public bool EnableZoomSlider { get; set; }
[C++]
public: __property bool get_EnableZoomSlider();
public: __property void set_EnableZoomSlider(bool );
[JScript]
public function get EnableZoomSlider() : bool
public function set EnableZoomSlider(bool);

Property Value

A boolean specifying if the zoom slider is displayed. The default value is true.

Remarks

The zoom slider is used to zoom in/zoom out of the image. By default it is displayed, but can be turned off by setting this property to false.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ErrorBehavior Property

Zoom.ErrorBehavior Property

Gets or sets how errors are handled by the control.

[Visual Basic]
Public Property ErrorBehavior As ErrorBehavior
[C#]
public ErrorBehavior ErrorBehavior { get; set; }
[C++]
public: __property ErrorBehavior get_ErrorBehavior();
public: __property void set_ErrorBehavior(ErrorBehavior );
[JScript]
public function get ErrorBehavior() : ErrorBehavior
public function set ErrorBehavior(ErrorBehavior);

Property Value

An ErrorBehavior enumerated value. Defaults to ErrorBehavior.ShowInBrowser.

Remarks

Set ErrorBehavior to specify whether an exception raised by the PowerWEB control should cause an error page, an alert box, or no indication to appear.

If set to ErrorBehavior.ShowAlert, set the alert message using the ErrorMessage property.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ErrorMessage Property

Zoom.ErrorMessage Property

Gets or sets the message that is displayed if an error occurs and ErrorBehavior is ErrorBehavior.ShowAlert.

[Visual Basic]
Public Property ErrorMessage As String
[C#]
public string ErrorMessage { get; set; }
[C++]
public: __property String* get_ErrorMessage();
public: __property void set_ErrorMessage(String* );
[JScript]
public function get ErrorMessage() : String
public function set ErrorMessage(String);

Property Value

A message to display when an error occurs.

Remarks

Set ErrorMessage to specify the contents of the Alert. Alternatively, set ErrorBehavior to ErrorBehavior.ShowInBrowser to see specific error information.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Format Property

Zoom.Format Property

Gets/sets an ImageFormat value specifying the output image format.

[Visual Basic]
Public Property Format As ImageFormat
[C#]
public ImageFormat Format { get; set; }
[C++]
public: __property ImageFormat* get_Format();
public: __property void set_Format(ImageFormat* );
[JScript]
public function get Format() : ImageFormat
public function set Format(ImageFormat);

Property Value

An ImageFormat value. The default value is ImageFormat.Jpeg.

Remarks

All created images (image tiles, thumbnail, resized images, etc) are created in the file format specified by this property.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Height Property

Zoom.Height Property

Gets or sets the height of the Web server control.

[Visual Basic]
Overrides Public Property Height As Unit
[C#]
public override Unit Height { get; set; }
[C++]
public: __property Unit get_Height();
public: __property void set_Height(Unit );
[JScript]
public override function get Height() : Unit
public override function set Height(Unit);

Remarks

This member is functionally equivalent to System.Web.UI.WebControls.WebControl.Height.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


InterpolationMode Property

Zoom.InterpolationMode Property

Gets/sets the algorithm used when the source image is scaled.

[Visual Basic]
Public Property InterpolationMode As InterpolationMode
[C#]
public InterpolationMode InterpolationMode { get; set; }
[C++]
public: __property InterpolationMode get_InterpolationMode();
public: __property void set_InterpolationMode(InterpolationMode );
[JScript]
public function get InterpolationMode() : InterpolationMode
public function set InterpolationMode(InterpolationMode);

Property Value

An InterpolationMode value. The default value is InterpolationMode.Default.

Remarks

When images are stretched or shrinked, the control must determine how new pixels are created or how existing pixels are merged. The algorithm used affects the output quality and processing time required.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


IsCallback Property

Zoom.IsCallback Property

Gets the callback state of the PowerWEB control.

[Visual Basic]
Public Property IsCallback As Boolean
[C#]
public bool IsCallback { get; set; }
[C++]
public: __property bool get_IsCallback();
public: __property void set_IsCallback(bool );
[JScript]
public function get IsCallback() : bool
public function set IsCallback(bool);

Property Value

true if the PowerWEB control is currently in a callback state, false otherwise.

Remarks

Use the IsCallback property to differentiate between a postback and live callback.

Note This property is global to all PowerWEB controls.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


IsLive Property

Zoom.IsLive Property

Gets or sets whether a PowerWEB control updates itself in a callback.

[Visual Basic]
Public Property IsLive As Boolean
[C#]
public bool IsLive { get; set; }
[C++]
public: __property bool get_IsLive();
public: __property void set_IsLive(bool );
[JScript]
public function get IsLive() : bool
public function set IsLive(bool);

Property Value

true if the PowerWEB control should update itself during a callback, false otherwise.

Remarks

Defaults to true. Set the IsLive property to false to prevent the PowerWEB control from updating itself during a callback, even if it is changed in code behind.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Left Property

Zoom.Left Property

Gets or sets the left position of the PowerWEB control.

[Visual Basic]
Public Property Left As Unit
[C#]
public Unit Left { get; set; }
[C++]
public: __property Unit get_Left();
public: __property void set_Left(Unit );
[JScript]
public function get Left() : Unit
public function set Left(Unit);

Property Value

A Unit that represents the left position of the control. The default is Unit.Empty.

Remarks

Use the Left property to specify the left position of the PowerWEB control. If both Left and Top are Unit.Empty (the default), relative positioning is used. If either Left or Top are not Unit.Empty, absolute positioning is used.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


NavigationLayout Property

Zoom.NavigationLayout Property

Gets/sets the layout used for the navigation elements.

[Visual Basic]
Public Property NavigationLayout As LayoutType
[C#]
public LayoutType NavigationLayout { get; set; }
[C++]
public: __property LayoutType get_NavigationLayout();
public: __property void set_NavigationLayout(LayoutType );
[JScript]
public function get NavigationLayout() : LayoutType
public function set NavigationLayout(LayoutType);

Property Value

A LayoutType value. The default value is LayoutType.Horizontal.

Remarks

The navigation elements can either be oriented horizontally or vertically.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


NavigationPosition Property

Zoom.NavigationPosition Property

Gets/sets the position used for the navigation elements.

[Visual Basic]
Public Property NavigationPosition As DockPosition
[C#]
public DockPosition NavigationPosition { get; set; }
[C++]
public: __property DockPosition get_NavigationPosition();
public: __property void set_NavigationPosition(DockPosition );
[JScript]
public function get NavigationPosition() : DockPosition
public function set NavigationPosition(DockPosition);

Property Value

A DockPosition value. The default value is DockPosition.BottomLeft.

Remarks

The navigation elements can be positioned horizontally at the left, middle, or right and vertically at the top, middle, or bottom, or any combination of these.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


PanDownShortcut Property

Zoom.PanDownShortcut Property

Gets/sets he keyboard shortcut for panning down.

[Visual Basic]
Public Property PanDownShortcut As Char
[C#]
public char PanDownShortcut { get; set; }
[C++]
public: __property wchar_t get_PanDownShortcut();
public: __property void set_PanDownShortcut(wchar_t );
[JScript]
public function get PanDownShortcut() : char
public function set PanDownShortcut(char);

Property Value

char value 40 (down arrow)

Remarks

Press and hold the shortcut key to move in the specified direction and release to stop. Panning keyboard keys can also be combined. For example, holding down both the down and right shortcut keys will cause the image to move to the bottom-right.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


PanLeftShortcut Property

Zoom.PanLeftShortcut Property

Gets/sets the keyboard shortcut for panning left.

[Visual Basic]
Public Property PanLeftShortcut As Char
[C#]
public char PanLeftShortcut { get; set; }
[C++]
public: __property wchar_t get_PanLeftShortcut();
public: __property void set_PanLeftShortcut(wchar_t );
[JScript]
public function get PanLeftShortcut() : char
public function set PanLeftShortcut(char);

Property Value

char value 37 (left arrow)

Remarks

Press and hold the shortcut key to move in the specified direction and release to stop. Panning keyboard keys can also be combined. For example, holding down both the down and right shortcut keys will cause the image to move to the bottom-right.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


PanRightShortcut Property

Zoom.PanRightShortcut Property

Gets/sets the keyboard shortcut for panning right.

[Visual Basic]
Public Property PanRightShortcut As Char
[C#]
public char PanRightShortcut { get; set; }
[C++]
public: __property wchar_t get_PanRightShortcut();
public: __property void set_PanRightShortcut(wchar_t );
[JScript]
public function get PanRightShortcut() : char
public function set PanRightShortcut(char);

Property Value

char value 39 (right arrow)

Remarks

Press and hold the shortcut key to move in the specified direction and release to stop. Panning keyboard keys can also be combined. For example, holding down both the down and right shortcut keys will cause the image to move to the bottom-right.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


PanUpShortcut Property

Zoom.PanUpShortcut Property

Gets/sets the keyboard shortcut for panning up.

[Visual Basic]
Public Property PanUpShortcut As Char
[C#]
public char PanUpShortcut { get; set; }
[C++]
public: __property wchar_t get_PanUpShortcut();
public: __property void set_PanUpShortcut(wchar_t );
[JScript]
public function get PanUpShortcut() : char
public function set PanUpShortcut(char);

Property Value

char value 38 (up arrow)

Remarks

Press and hold the shortcut key to move in the specified direction and release to stop. Panning keyboard keys can also be combined. For example, holding down both the down and right shortcut keys will cause the image to move to the bottom-right.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Quality Property

Zoom.Quality Property

Gets/sets a value which determines the output quality of the image.

[Visual Basic]
Public Property Quality As Integer
[C#]
public int Quality { get; set; }
[C++]
public: __property int get_Quality();
public: __property void set_Quality(int );
[JScript]
public function get Quality() : int
public function set Quality(int);

Property Value

An integer specifying the quality. The default value is 60.

Remarks

Increasing this value will increase the display quality of the image at the expense of processing time/file size.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ShowGridlines Property

Zoom.ShowGridlines Property

Gets/sets a value which determines if gridlines are displayed.

[Visual Basic]
Public Property ShowGridlines As Boolean
[C#]
public bool ShowGridlines { get; set; }
[C++]
public: __property bool get_ShowGridlines();
public: __property void set_ShowGridlines(bool );
[JScript]
public function get ShowGridlines() : bool
public function set ShowGridlines(bool);

Property Value

A boolean which determines if gridlines are displayed. The default value is false.

Remarks

Turn this on to display gridlines at the borders of each individual image tile.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


SkinType Property

Zoom.SkinType Property

Gets/sets a value which determines which navigation skin is displayed.

[Visual Basic]
Public Property SkinType As SkinType
[C#]
public SkinType SkinType { get; set; }
[C++]
public: __property SkinType get_SkinType();
public: __property void set_SkinType(SkinType );
[JScript]
public function get SkinType() : SkinType
public function set SkinType(SkinType);

Property Value

A SkinType value. The default value is SkinType.Standard.

Remarks

The skin type affects the look and feel of the navigation elements of the Zoom control.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


SnapToGrid Property

Zoom.SnapToGrid Property

Gets/sets a value which determines if the control snaps to the gridlines after moving.

[Visual Basic]
Public Property SnapToGrid As Boolean
[C#]
public bool SnapToGrid { get; set; }
[C++]
public: __property bool get_SnapToGrid();
public: __property void set_SnapToGrid(bool );
[JScript]
public function get SnapToGrid() : bool
public function set SnapToGrid(bool);

Property Value

A boolean which determines if the control snaps to the gridlines. The default value is false.

Remarks

If SnapToGrid is true, after a panning operation completes the image will be repositioned on the nearest image tile border.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


SourceHeight Property

Zoom.SourceHeight Property

Gets the height of the source image.

[Visual Basic]
Public Property ReadOnly SourceHeight As Integer
[C#]
public int SourceHeight { get; }
[C++]
public: __property int get_SourceHeight();
[JScript]
public function get SourceHeight() : int

Property Value

Gets the height of the source image.

Remarks

After an image is loaded (either by setting SourceImage or by calling LoadImage) this property returns the height of the source image.

This property differs from ZoomLevelHeight in that this property returns the raw source image height, and ZoomLevelHeight returns the height for the image resized for the current Z setting.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


SourceImage Property

Zoom.SourceImage Property

Gets/sets the name of the source image to display in the Zoom control.

[Visual Basic]
Public Property SourceImage As String
[C#]
public string SourceImage { get; set; }
[C++]
public: __property String* get_SourceImage();
public: __property void set_SourceImage(String* );
[JScript]
public function get SourceImage() : String
public function set SourceImage(String);

Property Value

A string value specifying the name of the source image.

Remarks

This property can be used one of two ways. A full file path can be provided, in which case the image will be copied into TileDirectory and prepared for use by the Zoom control. Also, a name of a file already existing in TileDirectory can be provided (to an image already existing in that directory, perhaps copied over by using LoadImage or by a previous setting of SourceImage) and the Zoom control will use that image as the source image (if found).

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


SourceWidth Property

Zoom.SourceWidth Property

Gets the width of the source image.

[Visual Basic]
Public Property ReadOnly SourceWidth As Integer
[C#]
public int SourceWidth { get; }
[C++]
public: __property int get_SourceWidth();
[JScript]
public function get SourceWidth() : int

Property Value

Gets the width of the source image.

Remarks

After an image is loaded (either by setting SourceImage or by calling LoadImage) this property returns the width of the source image.

This property differs from ZoomLevelHeight in that this property returns the raw source image height, and ZoomLevelHeight returns the height for the image resized for the current Z setting.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


StopOnEdge Property

Zoom.StopOnEdge Property

Gets/sets whether or not panning is allowed past the natural edge of the image.

[Visual Basic]
Public Property StopOnEdge As Boolean
[C#]
public bool StopOnEdge { get; set; }
[C++]
public: __property bool get_StopOnEdge();
public: __property void set_StopOnEdge(bool );
[JScript]
public function get StopOnEdge() : bool
public function set StopOnEdge(bool);

Property Value

A boolean value specifying whether or not panning is allowed once the natural edge of the image is reached. The default value is true.

Remarks

By default, when panning, once the edge of the image is reached panning in that direction stops. If this property is set to false, panning is allowed infinitely in any direction.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


TabIndex Property

Zoom.TabIndex Property

Gets or sets the tab index of the Web server control.

[Visual Basic]
Overrides Public Property TabIndex As Short
[C#]
public override short TabIndex { get; set; }
[C++]
public: __property short get_TabIndex();
public: __property void set_TabIndex(short );
[JScript]
public override function get TabIndex() : short
public override function set TabIndex(short);

Remarks

This member is functionally equivalent to System.Web.UI.WebControls.WebControlClass.TabIndex.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | The specified tab index is not between -32768 and 32767.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Tag Property

Zoom.Tag Property

Gets or sets a convertible object that contains data about the control.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag { get; set; }
[C++]
public: __property Object* get_Tag();
public: __property void set_Tag(Object* );
[JScript]
public function get Tag() : Object
public function set Tag(Object);

Property Value

An object that implements the IConvertible interface and contains data about the PowerWEB control. The default is a null reference (Nothing in Visual Basic).

Remarks

Any type that implements IConvertible can be assigned to this property. If the Tag property is set through the Windows Forms designer, only text can be assigned.

Data contained within the Tag property persists across callbacks. A common use for the Tag property is to store data that is closely associated with the control.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ThumbnailFrameStyle Property

Zoom.ThumbnailFrameStyle Property

Gets a Style object which is used to modify the draggable frame displayed within the thumbnail image.

[Visual Basic]
Public Property ReadOnly ThumbnailFrameStyle As Style
[C#]
public Style ThumbnailFrameStyle { get; }
[C++]
public: __property Style* get_ThumbnailFrameStyle();
[JScript]
public function get ThumbnailFrameStyle() : Style

Property Value

A Style object.

Remarks

Use this property to modify the border color, width, and style of the thumbnail frame. Some properties of this object (such as the font-related properties, size-related properties, etc.) have no effect in this context.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ThumbnailHeight Property

Zoom.ThumbnailHeight Property

Gets/sets the height of the thumbnail image.

[Visual Basic]
Public Property ThumbnailHeight As Unit
[C#]
public Unit ThumbnailHeight { get; set; }
[C++]
public: __property Unit get_ThumbnailHeight();
public: __property void set_ThumbnailHeight(Unit );
[JScript]
public function get ThumbnailHeight() : Unit
public function set ThumbnailHeight(Unit);

Property Value

An integer specifying the height of the thumbnail image. The default value is 0, meaning it is autoset.

Remarks

To have this property autoset by the zoom control, leave it to it's default value of 0 and it will be automatically set by the Zoom control when an image is loaded. This value can be overridden with a custom value.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ThumbnailWidth Property

Zoom.ThumbnailWidth Property

Gets/sets the width of the thumbnail image.

[Visual Basic]
Public Property ThumbnailWidth As Unit
[C#]
public Unit ThumbnailWidth { get; set; }
[C++]
public: __property Unit get_ThumbnailWidth();
public: __property void set_ThumbnailWidth(Unit );
[JScript]
public function get ThumbnailWidth() : Unit
public function set ThumbnailWidth(Unit);

Property Value

An integer specifying the width of the thumbnail image. The default value is 0, meaning it is autoset.

Remarks

To have this property autoset by the zoom control, leave it to it's default value of 0 and it will be automatically set by the Zoom control when an image is loaded. This value can be overridden with a custom value.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


TileDirectory Property

Zoom.TileDirectory Property

The directory in which tiles will be created.

[Visual Basic]
Public Property TileDirectory As String
[C#]
public string TileDirectory { get; set; }
[C++]
public: __property String* get_TileDirectory();
public: __property void set_TileDirectory(String* );
[JScript]
public function get TileDirectory() : String
public function set TileDirectory(String);

Remarks

By default, the Zoom control will create a directory called "PWZoomTiles" in the root directory of your web application. Within this directory all image tiles and other images will be saved.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


TileSize Property

Zoom.TileSize Property

Gets/sets a value specifying each tile's height/width.

[Visual Basic]
Public Property TileSize As Integer
[C#]
public int TileSize { get; set; }
[C++]
public: __property int get_TileSize();
public: __property void set_TileSize(int );
[JScript]
public function get TileSize() : int
public function set TileSize(int);

Property Value

An integer specifying the height/width of tiles. The default value is 150.

Remarks

This property can be tweaked for optimal performance. Typically, a larger tile size results in faster UI response but a slower load time.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ToggleMagnifierShortcut Property

Zoom.ToggleMagnifierShortcut Property

Gets/sets the keyboard shortcut for toggling the magnifying glass.

[Visual Basic]
Public Property ToggleMagnifierShortcut As Char
[C#]
public char ToggleMagnifierShortcut { get; set; }
[C++]
public: __property wchar_t get_ToggleMagnifierShortcut();
public: __property void set_ToggleMagnifierShortcut(wchar_t );
[JScript]
public function get ToggleMagnifierShortcut() : char
public function set ToggleMagnifierShortcut(char);

Property Value

char value 77 ('m')

Remarks

Press this key once to display the magnifying glass. Press it again to hide the magnifying glass. If EnableMagnifier is false this property has no effect.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ToolTip Property

Zoom.ToolTip Property

Gets or sets the text displayed when the mouse pointer hovers over the Web server control.

[Visual Basic]
Overrides Public Property ToolTip As String
[C#]
public override string ToolTip { get; set; }
[C++]
public: __property String* get_ToolTip();
public: __property void set_ToolTip(String* );
[JScript]
public override function get ToolTip() : String
public override function set ToolTip(String);

Remarks

This member is functionally equivalent to System.Web.UI.WebControls.WebControlClass.ToolTip.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Top Property

Zoom.Top Property

Gets or sets the top position of the PowerWEB control.

[Visual Basic]
Public Property Top As Unit
[C#]
public Unit Top { get; set; }
[C++]
public: __property Unit get_Top();
public: __property void set_Top(Unit );
[JScript]
public function get Top() : Unit
public function set Top(Unit);

Property Value

A Unit that represents the top position of the control. The default is Unit.Empty.

Remarks

Use the Top property to specify the top position of the PowerWEB control. If both Left and Top are Unit.Empty (the default), relative positioning is used. If either Left or Top are not Unit.Empty, absolute positioning is used.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


UpdateAll Property

Zoom.UpdateAll Property

Gets or sets which fields are posted to the server in a callback.

[Visual Basic]
Public Property UpdateAll As Boolean
[C#]
public bool UpdateAll { get; set; }
[C++]
public: __property bool get_UpdateAll();
public: __property void set_UpdateAll(bool );
[JScript]
public function get UpdateAll() : bool
public function set UpdateAll(bool);

Property Value

If true, all values for all client-side form elements are posted to the server. If false, only the value for the callback element is posted to the server. The default value is true.

Remarks

If true, all values for all client-side form elements are posted to the server. If false, only the value for the callback element is posted to the server. This can be used to highly optimize performance depending on the application. For example, if an application has a lot of form fields with a Timer raising a periodic callback, the callback lag may be signifigant, as the script has to loop through all of the form fields to get the client-side value. However, this may not be necessary. Often, you may only need to raise a callback, and don't need the values for form fields. In this case set this property to false, and the callback will execute much faster.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Visible Property

Zoom.Visible Property

Gets or sets a value indicating whether the PowerWEB control is visible.

[Visual Basic]
Overrides Public Property Visible As Boolean
[C#]
public override bool Visible { get; set; }
[C++]
public: __property bool get_Visible();
public: __property void set_Visible(bool );
[JScript]
public override function get Visible() : bool
public override function set Visible(bool);

Property Value

true if the control is visible on the page; otherwise false. The default is true.

Remarks

Use the Visible property to specify or determine whether a control is visible. When set to false, the control is rendered, but is hidden.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


WaitElementID Property

Zoom.WaitElementID Property

Gets or sets the message ID of the HTML element to display a message during a pending callback.

[Visual Basic]
Public Property WaitElementID As String
[C#]
public string WaitElementID { get; set; }
[C++]
public: __property String* get_WaitElementID();
public: __property void set_WaitElementID(String* );
[JScript]
public function get WaitElementID() : String
public function set WaitElementID(String);

Property Value

The ID of an HTML element, such as a Label, that will display a message during pending callbacks.

Remarks

Use in conjunction with the WaitMessage property.

Set WaitElementID to specify the ID of the control that will display the WaitMessage during a pending callback.

Typical usage would be for immediately displaying a message (such as "Processing..") to the user during lengthy callbacks (due to network traffic or server side processing).

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


WaitMessage Property

Zoom.WaitMessage Property

Gets or sets the message to display during a pending callback.

[Visual Basic]
Public Property WaitMessage As String
[C#]
public string WaitMessage { get; set; }
[C++]
public: __property String* get_WaitMessage();
public: __property void set_WaitMessage(String* );
[JScript]
public function get WaitMessage() : String
public function set WaitMessage(String);

Property Value

The message displayed during pending callbacks.

Remarks

Use in conjunction with the WaitElementID property.

Set WaitMessage to specify the message displayed by the WaitElementID control during a pending callback.

Typical usage would be for immediately displaying a message (such as "Processing...") to the user during lengthy callbacks (due to network traffic or server side processing).

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Width Property

Zoom.Width Property

Gets or sets the width of the Web server control.

[Visual Basic]
Overrides Public Property Width As Unit
[C#]
public override Unit Width { get; set; }
[C++]
public: __property Unit get_Width();
public: __property void set_Width(Unit );
[JScript]
public override function get Width() : Unit
public override function set Width(Unit);

Remarks

This member is functionally equivalent to System.Web.UI.WebControls.WebControlClass.Width.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


X Property

Zoom.X Property

Gets/sets the X position of the image inside the Zoom control.

[Visual Basic]
Public Property X As Integer
[C#]
public int X { get; set; }
[C++]
public: __property int get_X();
public: __property void set_X(int );
[JScript]
public function get X() : int
public function set X(int);

Property Value

An integer specifying the X position. The default value is 0.

Remarks

By default, the image will be docked to the upper left corner. Set the X property to offset the image horizontally. In addition, when the user pans around the image client side (thus changing the X/Y position) the X property will be automatically updated with the new values with each trip to the server.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Y Property

Zoom.Y Property

Gets/sets the Y position of the image inside the Zoom control.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y { get; set; }
[C++]
public: __property int get_Y();
public: __property void set_Y(int );
[JScript]
public function get Y() : int
public function set Y(int);

Property Value

An integer specifying the Y position. The default value is 0.

Remarks

By default, the image will be docked to the upper left corner. Set the Y property to offset the image vertically. In addition, when the user pans around the image client side (thus changing the X/Y position) the Y property will be automatically updated with the new values with each trip to the server.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Z Property

Zoom.Z Property

Gets/sets the Z (zoom level) value of the image inside the Zoom control.

[Visual Basic]
Public Property Z As Integer
[C#]
public int Z { get; set; }
[C++]
public: __property int get_Z();
public: __property void set_Z(int );
[JScript]
public function get Z() : int
public function set Z(int);

Property Value

An integer specifying the Z value. The default value is 0.

Remarks

By default (Zoom.Z=0), the image will be loaded so it fits completely inside the Zoom control. In addition, when the user zooms the image client side (thus changing the zoom level) the Z property will be automatically updated with the new values with each trip to the server.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ZoomInShortcut Property

Zoom.ZoomInShortcut Property

Gets/sets the keyboard shortcut for zooming in.

[Visual Basic]
Public Property ZoomInShortcut As Char
[C#]
public char ZoomInShortcut { get; set; }
[C++]
public: __property wchar_t get_ZoomInShortcut();
public: __property void set_ZoomInShortcut(wchar_t );
[JScript]
public function get ZoomInShortcut() : char
public function set ZoomInShortcut(char);

Property Value

char value 190 ('>')

Remarks

Press this key to zoom in one "level" closer. If the current zoom level is 100% this property has no effect.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ZoomLevelHeight Property

Zoom.ZoomLevelHeight Property

Gets the height of the source image resized for the current Z value.

[Visual Basic]
Public Property ReadOnly ZoomLevelHeight As Integer
[C#]
public int ZoomLevelHeight { get; }
[C++]
public: __property int get_ZoomLevelHeight();
[JScript]
public function get ZoomLevelHeight() : int

Property Value

Gets the height of the source image resized for the current Z value.

Remarks

After an image is loaded (either by setting SourceImage or by calling LoadImage) this property returns the height of the source image resized for the current Z value.

This property differs from SourceHeight in that this property returns returns the height for the image resized for the current Z setting and SourceHeight returns the raw source image height.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ZoomLevelWidth Property

Zoom.ZoomLevelWidth Property

Gets the width of the source image resized for the current Z value.

[Visual Basic]
Public Property ReadOnly ZoomLevelWidth As Integer
[C#]
public int ZoomLevelWidth { get; }
[C++]
public: __property int get_ZoomLevelWidth();
[JScript]
public function get ZoomLevelWidth() : int

Property Value

Gets the width of the source image resized for the current Z value.

Remarks

After an image is loaded (either by setting SourceImage or by calling LoadImage) this property returns the width of the source image resized for the current Z value.

This property differs from SourceWidth in that this property returns returns the width for the image resized for the current Z setting and SourceWidth returns the raw source image width.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ZoomOutShortcut Property

Zoom.ZoomOutShortcut Property

Gets/sets the keyboard shortcut for zooming out.

[Visual Basic]
Public Property ZoomOutShortcut As Char
[C#]
public char ZoomOutShortcut { get; set; }
[C++]
public: __property wchar_t get_ZoomOutShortcut();
public: __property void set_ZoomOutShortcut(wchar_t );
[JScript]
public function get ZoomOutShortcut() : char
public function set ZoomOutShortcut(char);

Property Value

char value 188 ('<')

Remarks

Press this key to zoom out one "level" further. If the current zoom level is 0% this property has no effect.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Zoom Methods

The methods of the Zoom class are listed below. For a complete list of Zoom class members, see the Zoom Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers.
BeginMoveTo | Overloaded. Immediately reposition the image displayed in the Zoom control to the specified X/Y coordinate.
BeginPan | Overloaded. Slides the image displayed in the Zoom control in the direction of the specified angle.
ClearTiles | Overloaded. Clear all created tiles for all images in the project.
CopyBaseAttributes (inherited from WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers.
DataBind (inherited from Control) | Binds a data source to the invoked server control and all its child controls.
Dispose (inherited from Control) | Enables a server control to perform final clean up before it is released from memory.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) | Searches the current naming container for a server control with the specified id parameter.
GetCallbackEventReference | Returns JavaScript that can be used to initiate a callback to the server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetScript | Returns all JavaScript buffered up as a result of setting control properties.
GetScriptObjectReference | Returns a client-side reference to the element.
GetScriptStyleReference | Returns a client-side reference to the style object of the element.
GetType (inherited from Object) | Gets the Type of the current instance.
GetViewState | Returns the ViewState object used to save and restore state.
HasControls (inherited from Control) | Determines if the server control contains any child controls.
LoadImage | Overloaded. Loads an array of bytes into the Zoom control.
MergeStyle (inherited from WebControl) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers.
RenderBeginTag (inherited from WebControl) | Renders the HTML opening tag of the control into the specified writer. This method is used primarily by control developers.
RenderControl (inherited from Control) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
RenderEndTag | Overridden. Renders the HTML closing tag of the control into the specified writer.
Reset | Resets the Zoom control to the initial X/Y/Z position.
ResolveUrl (inherited from Control) | Converts a URL into one that is usable on the requesting client.
SetRenderMethodDelegate (inherited from Control) |
StopMove | Stops any current panning movement.
ToString (inherited from Object) | Returns a String that represents the current Object.
ZoomIn | Overloaded. Zoom in one level.
ZoomOut | Overloaded. Zoom out one level.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


BeginMoveTo Method

Zoom.BeginMoveTo Method

Immediately reposition the image displayed in the Zoom control to the specified X/Y coordinate.

Overload List

Immediately reposition the image displayed in the Zoom control to the specified X/Y coordinate.

[Visual Basic] Public Sub BeginMoveTo(ByVal Integer,ByVal Integer)
[C#] public void BeginMoveTo(int,int);
[C++] public: void BeginMoveTo(int,int);
[JScript] public function BeginMoveTo(int,int);

Slide the image displayed in the Zoom control to the specified X/Y coordinate.

[Visual Basic] Public Sub BeginMoveTo(ByVal Integer,ByVal Integer,ByVal Integer)
[C#] public void BeginMoveTo(int,int,int);
[C++] public: void BeginMoveTo(int,int,int);
[JScript] public function BeginMoveTo(int,int,int);

Slide the image displayed in the Zoom control to the specified X/Y coordinate with acceleration/deceleration.

[Visual Basic] Public Sub BeginMoveTo(ByVal Integer,ByVal Integer,ByVal Integer,ByVal Integer)
[C#] public void BeginMoveTo(int,int,int,int);
[C++] public: void BeginMoveTo(int,int,int,int);
[JScript] public function BeginMoveTo(int,int,int,int);

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


BeginMoveTo Method (Int32, Int32)

Zoom.BeginMoveTo Method (Int32, Int32)

Immediately reposition the image displayed in the Zoom control to the specified X/Y coordinate.

[Visual Basic]
Public Sub BeginMoveTo( _
   ByVal x As Integer, _
   ByVal y As Integer _
)
[C#]
public void BeginMoveTo(
   int x,
   int y
);
[C++]
public: void BeginMoveTo(
   int x,
   int y
);
[JScript]
public function BeginMoveTo(
   int x,
   int y
);

Parameters

x
The new X value of the repositioned image.
y
The new Y value of the repositioned image.

Remarks

Use this overload of BeginMoveTo to immediately move the image to a new X/Y location. This method occurs without "movement animation" (the displayed image tiles are simply replaced with new image tiles).

This method was intended to be used within a Callback as a result of either an AutoUpdate or in conjunction with Dart PowerWEB LiveControls. Executing this method in a standard PostBack will have no effect.

When repositioning is complete the EndMoveTo event is raised.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.BeginMoveTo Overload List


BeginMoveTo Method (Int32, Int32, Int32)

Zoom.BeginMoveTo Method (Int32, Int32, Int32)

Slide the image displayed in the Zoom control to the specified X/Y coordinate.

[Visual Basic]
Public Sub BeginMoveTo( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal speed As Integer _
)
[C#]
public void BeginMoveTo(
   int x,
   int y,
   int speed
);
[C++]
public: void BeginMoveTo(
   int x,
   int y,
   int speed
);
[JScript]
public function BeginMoveTo(
   int x,
   int y,
   int speed
);

Parameters

x
The new X value of the repositioned image.
y
The new Y value of the repositioned image.
speed
The speed at which the slide movement occurs.

Remarks

Use this overload of BeginMoveTo to pan the image to a new X/Y location at a constant speed.

This method was intended to be used within a Callback as a result of either an AutoUpdate or in conjunction with Dart PowerWEB LiveControls. Executing this method in a standard PostBack will have no effect.

When repositioning is complete the EndMoveTo event is raised. To stop movement prematurely, use the StopMove method.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.BeginMoveTo Overload List


BeginMoveTo Method (Int32, Int32, Int32, Int32)

Zoom.BeginMoveTo Method (Int32, Int32, Int32, Int32)

Slide the image displayed in the Zoom control to the specified X/Y coordinate with acceleration/deceleration.

[Visual Basic]
Public Sub BeginMoveTo( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal speed As Integer, _
   ByVal acceleration As Integer _
)
[C#]
public void BeginMoveTo(
   int x,
   int y,
   int speed,
   int acceleration
);
[C++]
public: void BeginMoveTo(
   int x,
   int y,
   int speed,
   int acceleration
);
[JScript]
public function BeginMoveTo(
   int x,
   int y,
   int speed,
   int acceleration
);

Parameters

x
The new X value of the repositioned image.
y
The new Y value of the repositioned image.
speed
The speed at which the slide movement occurs.
acceleration
The speed at which the movement of the image goes from 0 to speed.

Remarks

Use this overload of BeginMoveTo to pan the image to a new X/Y location with acceleration/deceleration. The speed parameter refers to the top speed achieved during the slide. The acceleration parameter specifies how quickly the movement speed increases from 0 to speed.

This method was intended to be used within a Callback as a result of either an AutoUpdate or in conjunction with Dart PowerWEB LiveControls. Executing this method in a standard PostBack will have no effect.

When repositioning is complete the EndMoveTo event is raised. To stop movement prematurely, use the StopMove method.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.BeginMoveTo Overload List


BeginPan Method

Zoom.BeginPan Method

Slides the image displayed in the Zoom control in the direction of the specified angle.

Overload List

Slides the image displayed in the Zoom control in the direction of the specified angle.

[Visual Basic] Public Sub BeginPan(ByVal Integer)
[C#] public void BeginPan(int);
[C++] public: void BeginPan(int);
[JScript] public function BeginPan(int);

Slides the image displayed in the Zoom control in the direction of the specified angle at the provided speed.

[Visual Basic] Public Sub BeginPan(ByVal Integer,ByVal Integer)
[C#] public void BeginPan(int,int);
[C++] public: void BeginPan(int,int);
[JScript] public function BeginPan(int,int);

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


BeginPan Method (Int32)

Zoom.BeginPan Method (Int32)

Slides the image displayed in the Zoom control in the direction of the specified angle.

[Visual Basic]
Public Sub BeginPan( _
   ByVal angle As Integer _
)
[C#]
public void BeginPan(
   int angle
);
[C++]
public: void BeginPan(
   int angle
);
[JScript]
public function BeginPan(
   int angle
);

Parameters

angle
The angle at which the image pans.

Remarks

The BeginPan method pans the image in the direction of the specified angle until either the border of the image is reached or the StopMove method is called. This overload of BeginPan occurs at a default speed of 10.

This method was intended to be used within a Callback as a result of either an AutoUpdate or in conjunction with Dart PowerWEB LiveControls. Executing this method in a standard PostBack will have no effect.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.BeginPan Overload List


BeginPan Method (Int32, Int32)

Zoom.BeginPan Method (Int32, Int32)

Slides the image displayed in the Zoom control in the direction of the specified angle at the provided speed.

[Visual Basic]
Public Sub BeginPan( _
   ByVal angle As Integer, _
   ByVal speed As Integer _
)
[C#]
public void BeginPan(
   int angle,
   int speed
);
[C++]
public: void BeginPan(
   int angle,
   int speed
);
[JScript]
public function BeginPan(
   int angle,
   int speed
);

Parameters

angle
The angle at which the image pans.
speed
The speed at which the pan movement occurs.

Remarks

The BeginPan method pans the image at the specified angle until either the border of the image is reached or the StopMove method is called.

This method was intended to be used within a Callback as a result of either an AutoUpdate or in conjunction with Dart PowerWEB LiveControls. Executing this method in a standard PostBack will have no effect.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.BeginPan Overload List


ClearTiles Method

Zoom.ClearTiles Method

Clear all created tiles for all images in the project.

Overload List

Clear all created tiles for all images in the project.

[Visual Basic] Public Sub ClearTiles()
[C#] public void ClearTiles();
[C++] public: void ClearTiles();
[JScript] public function ClearTiles();

Clear all created tiles for the specified SourceImage.

[Visual Basic] Public Sub ClearTiles(ByVal String)
[C#] public void ClearTiles(string);
[C++] public: void ClearTiles(String*);
[JScript] public function ClearTiles(String);

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ClearTiles Method ()

Zoom.ClearTiles Method ()

Clear all created tiles for all images in the project.

[Visual Basic]
Public Sub ClearTiles()
[C#]
public void ClearTiles();
[C++]
public: void ClearTiles();
[JScript]
public function ClearTiles();

Remarks

By default, in an effort to optimize speed and memory consumption, the Zoom control only creates new tiles when needed. If a particular zoom level of tiles already exists, tiles will not be recreated. However, there may be scenarios where you would like to force recreation of the tiles (for instance, if the source image periodically changes). When called, the ClearTiles method deletes all created tiles contained in the TileDirectory for the current project (typically the "pwzoomtiles" directory in the project root) and removes instances of the tiles stored in the cache. The next time the Zoom control attempts to load the image, it will need to create a new level of tiles for the source image,

The default ClearTiles deletes all tiles for all SourceImages. To delete tiles for a particular SourceImage, use ClearTiles(string).

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.ClearTiles Overload List


ClearTiles Method (String)

Zoom.ClearTiles Method (String)

Clear all created tiles for the specified SourceImage.

[Visual Basic]
Public Sub ClearTiles( _
   ByVal sourceImagename As String _
)
[C#]
public void ClearTiles(
   string sourceImagename
);
[C++]
public: void ClearTiles(
   String* sourceImagename
);
[JScript]
public function ClearTiles(
   String sourceImagename
);

Parameters

sourceImagename
The image name (corresponding to the SourceImage property) to delete.

Remarks

By default, in an effort to optimize speed and memory consumption, the Zoom control only creates new tiles when needed. If a particular zoom level of tiles already exists, tiles will not be recreated. However, there may be scenarios where you would like to force recreation of the tiles (for instance, if the source image periodically changes). When called, the ClearTiles(string) method deletes all created tiles for the specified SourceImage contained in the TileDirectory for the current project (typically the "pwzoomtiles" directory in the project root) and removes instances of the tiles stored in the cache. The next time the Zoom control attempts to load the image, it will need to create a new level of tiles for the source image,

The default ClearTiles deletes only tiles for the specified SourceImage. To delete all tiles for all SourceImages, use ClearTiles().

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.ClearTiles Overload List


GetCallbackEventReference Method

Zoom.GetCallbackEventReference Method

Returns JavaScript that can be used to initiate a callback to the server.

[Visual Basic]
Public Function GetCallbackEventReference( _
   ByVal eventName As String, _
   ByVal argument As String _
) As String
[C#]
public string GetCallbackEventReference(
   string eventName,
   string argument
);
[C++]
public: String* GetCallbackEventReference(
   String* eventName,
   String* argument
);
[JScript]
public function GetCallbackEventReference(
   String eventName,
   String argument
): String;

Parameters

eventName
The event corresponding to the callback.
argument
The event arguments for the callback.

Remarks

Returns JavaScript that can be used to initiate a callback to the server.

The settings of the PowerWEB control (blocking, errorhandling, etc) are automatically taken into account.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


GetScript Method

Zoom.GetScript Method

Returns all JavaScript buffered up as a result of setting control properties.

[Visual Basic]
Public Function GetScript() As String
[C#]
public string GetScript();
[C++]
public: String* GetScript();
[JScript]
public function GetScript(): String;

Remarks

Returns all JavaScript buffered up as a result of setting properties of controls on the form.

Note This is not intended for use by end-users.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


GetScriptObjectReference Method

Zoom.GetScriptObjectReference Method

Returns a client-side reference to the element.

[Visual Basic]
Public Function GetScriptObjectReference() As String
[C#]
public string GetScriptObjectReference();
[C++]
public: String* GetScriptObjectReference();
[JScript]
public function GetScriptObjectReference(): String;

Remarks

Returns a client-side reference to the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1")" (depending on the browser).

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


GetScriptStyleReference Method

Zoom.GetScriptStyleReference Method

Returns a client-side reference to the style object of the element.

[Visual Basic]
Public Function GetScriptStyleReference() As String
[C#]
public string GetScriptStyleReference();
[C++]
public: String* GetScriptStyleReference();
[JScript]
public function GetScriptStyleReference(): String;

Remarks

Returns a client-side reference to the style object of the element corresponding to the PowerWEB control.

For example, if the PowerWEB control is LiveButton1, it would return "pwObj("LiveButton1").style" (depending on the browser).

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


GetViewState Method

Zoom.GetViewState Method

Returns the ViewState object used to save and restore state.

[Visual Basic]
Public Function GetViewState() As Object
[C#]
public object GetViewState();
[C++]
public: Object* GetViewState();
[JScript]
public function GetViewState(): Object;

Remarks

Returns the ViewState object used by PowerWEB controls to save and restore state.

Note This is not intended for use by end-users.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


LoadImage Method

Zoom.LoadImage Method

Loads an array of bytes into the Zoom control.

Overload List

Loads an array of bytes into the Zoom control.

[Visual Basic] Public Sub LoadImage(ByVal Byte(),ByVal String)
[C#] public void LoadImage(byte[],string);
[C++] public: void LoadImage(char __gc[],String*);
[JScript] public function LoadImage(Byte[],String);

Loads a FileStream containing image data into the Zoom control.

[Visual Basic] Public Sub LoadImage(ByVal FileStream)
[C#] public void LoadImage(FileStream);
[C++] public: void LoadImage(FileStream*);
[JScript] public function LoadImage(FileStream);

Loads a Stream containing image data into the Zoom control.

[Visual Basic] Public Sub LoadImage(ByVal Stream,ByVal String)
[C#] public void LoadImage(Stream,string);
[C++] public: void LoadImage(Stream*,String*);
[JScript] public function LoadImage(Stream,String);

Loads a image file into the Zoom control.

[Visual Basic] Public Sub LoadImage(ByVal String)
[C#] public void LoadImage(string);
[C++] public: void LoadImage(String*);
[JScript] public function LoadImage(String);

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


LoadImage Method (Byte[], String)

Zoom.LoadImage Method (Byte[], String)

Loads an array of bytes into the Zoom control.

[Visual Basic]
Public Sub LoadImage( _
   ByVal data As Byte(), _
   ByVal name As String _
)
[C#]
public void LoadImage(
   byte[] data,
   string name
);
[C++]
public: void LoadImage(
   char data __gc[],
   String* name
);
[JScript]
public function LoadImage(
   Byte[] data,
   String name
);

Parameters

data
A byte array containing image data.
name
A string specifying the name to provide the image when saved to TileDirectory.

Remarks

Use this overload of LoadImage to load image bytes into the Zoom control. The image is stored in the directory specified by TileDirectory and prepared for splitting/resizing as needed by the Zoom control. The data parameter must contain valid image data. The name parameter specifies a name to provide to the image when saved to TileDirectory. This is a useful overload for loading images from a database.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.LoadImage Overload List


LoadImage Method (FileStream)

Zoom.LoadImage Method (FileStream)

Loads a FileStream containing image data into the Zoom control.

[Visual Basic]
Public Sub LoadImage( _
   ByVal data As FileStream _
)
[C#]
public void LoadImage(
   FileStream data
);
[C++]
public: void LoadImage(
   FileStream* data
);
[JScript]
public function LoadImage(
   FileStream data
);

Parameters

data
A FileStream object containing image data.

Remarks

Use this overload of LoadImage to load a FileStream containing image data into the Zoom control. The image is stored in the directory specified by TileDirectory and prepared for splitting/resizing as needed by the Zoom control. The data parameter must contain valid image data.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.LoadImage Overload List


LoadImage Method (Stream, String)

Zoom.LoadImage Method (Stream, String)

Loads a Stream containing image data into the Zoom control.

[Visual Basic]
Public Sub LoadImage( _
   ByVal data As Stream, _
   ByVal name As String _
)
[C#]
public void LoadImage(
   Stream data,
   string name
);
[C++]
public: void LoadImage(
   Stream* data,
   String* name
);
[JScript]
public function LoadImage(
   Stream data,
   String name
);

Parameters

data
A Stream object containing image data.
name
A string specifying the name to provide the image when saved to TileDirectory.

Remarks

Use this overload of LoadImage to load a data Stream containing image data into the Zoom control. The image is stored in the directory specified by TileDirectory and prepared for splitting/resizing as needed by the Zoom control. The data parameter must contain valid image data. The name parameter specifies a name to provide to the image when saved to TileDirectory. This is a useful overload for loading images from a database.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.LoadImage Overload List


LoadImage Method (String)

Zoom.LoadImage Method (String)

Loads a image file into the Zoom control.

[Visual Basic]
Public Sub LoadImage( _
   ByVal imagePath As String _
)
[C#]
public void LoadImage(
   string imagePath
);
[C++]
public: void LoadImage(
   String* imagePath
);
[JScript]
public function LoadImage(
   String imagePath
);

Parameters

imagePath
The filepath of the image to load.

Remarks

This overload of LoadImage provides a easier-to-use shortcut to the Zoom.LoadImage(FileStream) method.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.LoadImage Overload List


RenderEndTag Method

Zoom.RenderEndTag Method

Renders the HTML closing tag of the control into the specified writer.

[Visual Basic]
Overrides Public Sub RenderEndTag( _
   ByVal output As HtmlTextWriter _
)
[C#]
public override void RenderEndTag(
   HtmlTextWriter output
);
[C++]
public: void RenderEndTag(
   HtmlTextWriter* output
);
[JScript]
public override function RenderEndTag(
   HtmlTextWriter output
);

Parameters

output
A HtmlTextWriter that represents the output stream to render HTML content on the client.

Remarks

This is made public so other controls can render multiple controls in between the opening and closing tags of a Web server control.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Reset Method

Zoom.Reset Method

Resets the Zoom control to the initial X/Y/Z position.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();
[C++]
public: void Reset();
[JScript]
public function Reset();

Remarks

This method provides an easy-to-use method for resetting the control to it's initial position.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


StopMove Method

Zoom.StopMove Method

Stops any current panning movement.

[Visual Basic]
Public Sub StopMove()
[C#]
public void StopMove();
[C++]
public: void StopMove();
[JScript]
public function StopMove();

Remarks

Use this method to stop any currently processing movement started by BeginMoveTo or BeginPan.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ZoomIn Method

Zoom.ZoomIn Method

Zoom in one level.

Overload List

Zoom in one level.

[Visual Basic] Public Sub ZoomIn()
[C#] public void ZoomIn();
[C++] public: void ZoomIn();
[JScript] public function ZoomIn();

Zoom in to the specified percentage.

[Visual Basic] Public Sub ZoomIn(ByVal Integer)
[C#] public void ZoomIn(int);
[C++] public: void ZoomIn(int);
[JScript] public function ZoomIn(int);

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ZoomIn Method ()

Zoom.ZoomIn Method ()

Zoom in one level.

[Visual Basic]
Public Sub ZoomIn()
[C#]
public void ZoomIn();
[C++]
public: void ZoomIn();
[JScript]
public function ZoomIn();

Remarks

This method zooms in one level. If the zoom level is already 100%, this method has no effect. The new zoom level is accessable via the Z property.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.ZoomIn Overload List


ZoomIn Method (Int32)

Zoom.ZoomIn Method (Int32)

Zoom in to the specified percentage.

[Visual Basic]
Public Sub ZoomIn( _
   ByVal percentage As Integer _
)
[C#]
public void ZoomIn(
   int percentage
);
[C++]
public: void ZoomIn(
   int percentage
);
[JScript]
public function ZoomIn(
   int percentage
);

Parameters

percentage
The percentage to zoom to.

Remarks

This method zooms in to the specified percentage. The maximum value for percentage is 100. The new zoom level is accessable via the Z property.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.ZoomIn Overload List


ZoomOut Method

Zoom.ZoomOut Method

Zoom out one level.

Overload List

Zoom out one level.

[Visual Basic] Public Sub ZoomOut()
[C#] public void ZoomOut();
[C++] public: void ZoomOut();
[JScript] public function ZoomOut();

Zoom out to the specified percentage.

[Visual Basic] Public Sub ZoomOut(ByVal Integer)
[C#] public void ZoomOut(int);
[C++] public: void ZoomOut(int);
[JScript] public function ZoomOut(int);

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ZoomOut Method ()

Zoom.ZoomOut Method ()

Zoom out one level.

[Visual Basic]
Public Sub ZoomOut()
[C#]
public void ZoomOut();
[C++]
public: void ZoomOut();
[JScript]
public function ZoomOut();

Remarks

This method zooms out one level. If the zoom level is already 0%, this method has no effect. The new zoom level is accessable via the Z property.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.ZoomOut Overload List


ZoomOut Method (Int32)

Zoom.ZoomOut Method (Int32)

Zoom out to the specified percentage.

[Visual Basic]
Public Sub ZoomOut( _
   ByVal percentage As Integer _
)
[C#]
public void ZoomOut(
   int percentage
);
[C++]
public: void ZoomOut(
   int percentage
);
[JScript]
public function ZoomOut(
   int percentage
);

Parameters

percentage
The percentage to zoom to. The new zoom level is accessable via the Z property.

Remarks

This method zooms out to the specified percentage. The minimum value for percentage is 0 (meaning the image completely fits inside the Zoom control).

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace | Zoom.ZoomOut Overload List


Zoom Events

The events of the Zoom class are listed below. For a complete list of Zoom class members, see the Zoom Members topic.

Public Instance Events

AutoUpdate | Raised periodically in the interval specified by Zoom.AutoUpdateInterval.
ContextMenuChanged | Occurs when the right button of the PowerWEB control is clicked.
DataBinding (inherited from Control) | Occurs when the server control binds to a data source.
Disposed (inherited from Control) | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested.
DoubleClick | Occurs when the control is double-clicked.
EndMoveTo | Raised when a moving operation completes.
EndPan | Raised when a panning operation completes.
GotFocus | Occurs when the PowerWEB control gains focus.
HelpRequested | Occurs when F1 is pressed while the control has focus.
Init (inherited from Control) | Occurs when the server control is initialized, which is the first step in the its lifecycle.
KeyDown | Occurs when a key is down while the control has focus.
KeyPress | Occurs when a key is pressed while the control has focus.
KeyUp | Occurs when a key is released while the control has focus.
Load (inherited from Control) | Occurs when the server control is loaded into the Page object.
LocationClick | Occurs when the PowerWEB control is clicked, providing location data.
LostFocus | Occurs when the PowerWEB control loses focus.
MouseDown | Occurs when the mouse buttons are pressed while the PowerWEB control has focus.
MouseEnter | Occurs when the mouse pointer enters the PowerWEB control.
MouseLeave | Occurs when the mouse pointer leaves the PowerWEB control.
MouseUp | Occurs when the mouse buttons are released while the PowerWEB control has focus.
PreRender (inherited from Control) | Occurs when the server control is about to render to its containing Page object.
Unload (inherited from Control) | Occurs when the server control is unloaded from memory.
ZoomChanged | Raised when the value of Z is changed by a zooming operation.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


AutoUpdate Event

Zoom.AutoUpdate Event

Raised periodically in the interval specified by AutoUpdateInterval.

[Visual Basic]
Public Event AutoUpdate As EventHandler
[C#]
public event EventHandler AutoUpdate;
[C++]
public: __event EventHandler* AutoUpdate;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The AutoUpdate event can be used to poll the server for new data and update the Zoom control accordingly. The interval of this polling behavior is determined by the AutoUpdateInterval property. By default the AutoUpdateInterval is -1, which means that no polling occurs.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ContextMenuChanged Event

Zoom.ContextMenuChanged Event

Occurs when the right button of the PowerWEB control is clicked.

[Visual Basic]
Public Event ContextMenuChanged As LocationEventHandler
[C#]
public event LocationEventHandler ContextMenuChanged;
[C++]
public: __event LocationEventHandler* ContextMenuChanged;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The ContextMenuChanged event fires when the right button is clicked. This event is the equivalent of the Click event for the left button.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


DoubleClick Event

Zoom.DoubleClick Event

Occurs when the control is double-clicked.

[Visual Basic]
Public Event DoubleClick As LocationEventHandler
[C#]
public event LocationEventHandler DoubleClick;
[C++]
public: __event LocationEventHandler* DoubleClick;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The DoubleClick event fires when the control is double-clicked.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


EndMoveTo Event

Zoom.EndMoveTo Event

Raised when a moving operation completes.

[Visual Basic]
Public Event EndMoveTo As EventHandler
[C#]
public event EventHandler EndMoveTo;
[C++]
public: __event EventHandler* EndMoveTo;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The BeginMoveTo method starts a moving operation, which may take several seconds to complete (also, the user can initiate a moving operation client-side). Once complete, the control will raise the EndMoveTo event, notifying the user.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


EndPan Event

Zoom.EndPan Event

Raised when a panning operation completes.

[Visual Basic]
Public Event EndPan As EventHandler
[C#]
public event EventHandler EndPan;
[C++]
public: __event EventHandler* EndPan;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

When the user completes a client-side panning operation, this event is raised, notifying the user.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


GotFocus Event

Zoom.GotFocus Event

Occurs when the PowerWEB control gains focus.

[Visual Basic]
Public Event GotFocus As EventHandler
[C#]
public event EventHandler GotFocus;
[C++]
public: __event EventHandler* GotFocus;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The GotFocus event fires when the PowerWEB control gains focus. LostFocus fires when the PowerWEB control loses focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


HelpRequested Event

Zoom.HelpRequested Event

Occurs when F1 is pressed while the control has focus.

[Visual Basic]
Public Event HelpRequested As LocationEventHandler
[C#]
public event LocationEventHandler HelpRequested;
[C++]
public: __event LocationEventHandler* HelpRequested;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The HelpRequested event fires when F1 is pressed while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


KeyDown Event

Zoom.KeyDown Event

Occurs when a key is down while the control has focus.

[Visual Basic]
Public Event KeyDown As KeyEventHandler
[C#]
public event KeyEventHandler KeyDown;
[C++]
public: __event KeyEventHandler* KeyDown;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Remarks

The KeyDown event fires when a key is down while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


KeyPress Event

Zoom.KeyPress Event

Occurs when a key is pressed while the control has focus.

[Visual Basic]
Public Event KeyPress As KeyEventHandler
[C#]
public event KeyEventHandler KeyPress;
[C++]
public: __event KeyEventHandler* KeyPress;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Remarks

The KeyPress event fires when a key is pressed while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


KeyUp Event

Zoom.KeyUp Event

Occurs when a key is released while the control has focus.

[Visual Basic]
Public Event KeyUp As KeyEventHandler
[C#]
public event KeyEventHandler KeyUp;
[C++]
public: __event KeyEventHandler* KeyUp;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyEventArgs.KeyDown, KeyEventArgs.KeyPress or KeyEventArgs.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Remarks

The KeyUp event fires when a key is released while the control has focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


LocationClick Event

Zoom.LocationClick Event

Occurs when the PowerWEB control is clicked, providing location data.

[Visual Basic]
Public Event LocationClick As LocationEventHandler
[C#]
public event LocationEventHandler LocationClick;
[C++]
public: __event LocationEventHandler* LocationClick;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The LocationClick event fires when the PowerWEB control is clicked, providing Top and Left location data.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


LostFocus Event

Zoom.LostFocus Event

Occurs when the PowerWEB control loses focus.

[Visual Basic]
Public Event LostFocus As EventHandler
[C#]
public event EventHandler LostFocus;
[C++]
public: __event EventHandler* LostFocus;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The LostFocus event fires when the PowerWEB control loses focus. GotFocus fires when the PowerWEB control gains focus.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


MouseDown Event

Zoom.MouseDown Event

Occurs when the mouse buttons are pressed while the PowerWEB control has focus.

[Visual Basic]
Public Event MouseDown As LocationEventHandler
[C#]
public event LocationEventHandler MouseDown;
[C++]
public: __event LocationEventHandler* MouseDown;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseDown event fires when any button is pressed.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


MouseEnter Event

Zoom.MouseEnter Event

Occurs when the mouse pointer enters the PowerWEB control.

[Visual Basic]
Public Event MouseEnter As LocationEventHandler
[C#]
public event LocationEventHandler MouseEnter;
[C++]
public: __event LocationEventHandler* MouseEnter;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseEnter event fires when the mouse pointer enters the PowerWEB control. MouseLeave will fire when the mouse pointer leaves the control.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


MouseLeave Event

Zoom.MouseLeave Event

Occurs when the mouse pointer leaves the PowerWEB control.

[Visual Basic]
Public Event MouseLeave As LocationEventHandler
[C#]
public event LocationEventHandler MouseLeave;
[C++]
public: __event LocationEventHandler* MouseLeave;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseLeave event fires when the mouse pointer leaves the PowerWEB control. MouseEnter will fire when the mouse pointer enters the control.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


MouseUp Event

Zoom.MouseUp Event

Occurs when the mouse buttons are released while the PowerWEB control has focus.

[Visual Basic]
Public Event MouseUp As LocationEventHandler
[C#]
public event LocationEventHandler MouseUp;
[C++]
public: __event LocationEventHandler* MouseUp;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Event Data

The event handler receives an argument of type LocationEventArgs containing data related to this event. The following LocationEventArgs properties provide information specific to this event.

Property | Description
X | Gets or sets the x-coordinate of the WebForm when the mouse is clicked.
Y | Gets or sets the y-coordinate of the WebForm when the mouse is clicked.

Remarks

The MouseUp event fires when any button is released.

Example

The following example demonstrates PowerWEB events not found in other Server controls.

[Visual Basic]
'In this example, events fire as the user interacts with a PowerWEB Control
'These events are not found in non-PowerWEB Server controls
'When an event is raised, a PowerWEB control updates with a message

Private Sub PowerWEBControl1_ContextMenuChanged(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.ContextMenuChanged
    PowerWEBControl1.Text = "You pressed the right button"
End Sub

Private Sub PowerWEBControl1_DoubleClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.DoubleClick
    PowerWEBControl1.Text = "That was a nice double-click"
End Sub

Private Sub PowerWEBControl1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.GotFocus
    PowerWEBControl1.Text = "I am focused"
End Sub

Private Sub PowerWEBControl1_HelpRequested(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.HelpRequested
    PowerWEBControl1.Text = "You pressed F1  Need some help?"
End Sub

Private Sub PowerWEBControl1_KeyDown(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyDown
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down"
End Sub

Private Sub PowerWEBControl1_KeyPress(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyPress
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed"
End Sub

Private Sub PowerWEBControl1_KeyUp(ByVal sender As Object, ByVal e As KeyEventArgs) Handles PowerWEBControl1.KeyUp
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up"
End Sub

Private Sub PowerWEBControl1_LocationClick(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.LocationClick
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")"
End Sub

Private Sub PowerWEBControl1_LostFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles PowerWEBControl1.LostFocus
    PowerWEBControl1.Text = "I'm losing focus"
End Sub

Private Sub PowerWEBControl1_MouseDown(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseDown
    PowerWEBControl1.Text = "Down goes the mouse button"
End Sub

Private Sub PowerWEBControl1_MouseEnter(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseEnter
    PowerWEBControl1.Text = "That tickles"
End Sub

Private Sub PowerWEBControl1_MouseLeave(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseLeave
    PowerWEBControl1.Text = "Come back"
End Sub

Private Sub PowerWEBControl1_MouseUp(ByVal sender As Object, ByVal e As LocationEventArgs) Handles PowerWEBControl1.MouseUp
    PowerWEBControl1.Text = "Up goes the mouse button"
End Sub

[C#]
//In this example, events fire as the user interacts with a PowerWEB Control
//These events are not found in non-PowerWEB Server controls
//When an event is raised, a PowerWEB control updates with a message

private void PowerWEBControl1_ContextMenuChanged(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed the right button!";
}

private void PowerWEBControl1_DoubleClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That was a nice double-click!";
}

private void PowerWEBControl1_GotFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I am focused!";
}

private void PowerWEBControl1_HelpRequested(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "You pressed F1!  Need some help?";
}

private void PowerWEBControl1_KeyDown(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone down!";
}

private void PowerWEBControl1_KeyPress(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has been pressed!";
}

private void PowerWEBControl1_KeyUp(object sender, KeyEventArgs e)
{
    PowerWEBControl1.Text = "The " + Convert.ToChar(e.KeyCode).ToString() + " key has gone up!";
}

private void PowerWEBControl1_LocationClick(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "The button was pressed at (" + e.X.ToString() + "," + e.Y.ToString() + ")!";
}

private void PowerWEBControl1_LostFocus(object sender, System.EventArgs e)
{
    PowerWEBControl1.Text = "I'm losing focus!";
}

private void PowerWEBControl1_MouseDown(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Down goes the mouse button!";
}

private void PowerWEBControl1_MouseEnter(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "That tickles!";
}

private void PowerWEBControl1_MouseLeave(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Come back!";
}

private void PowerWEBControl1_MouseUp(object sender, LocationEventArgs e)
{
    PowerWEBControl1.Text = "Up goes the mouse button!";
}

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


ZoomChanged Event

Zoom.ZoomChanged Event

Raised when the value of Z is changed by a zooming operation.

[Visual Basic]
Public Event ZoomChanged As EventHandler
[C#]
public event EventHandler ZoomChanged;
[C++]
public: __event EventHandler* ZoomChanged;

[JScript] In JScript, you can use the events defined by a type, but you cannot define your own.

Remarks

The user can change the zoom level several ways client-side (changing the zoom slider position, using the zoom-in/zoom-out keyboard shortcuts). In addition, the ZoomIn and ZoomOut methods can initiate a zoom operation. These operations could change the value of Z, in which case this event will be raised.

See Also

Zoom Class | Dart.PowerWEB.Zoom Namespace


Client-Side Reference

The Client-Side API exposes many of the JavaScript functions used by the Zoom control.

See Also

Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


pwCurZoom Property

Contains a reference to the client-size pwZoom object with focus.

[JavaScript]
pwCurZoom

Remarks

If there are multiple instances of the Zoom control on a webform, this will contain a reference to the last control to get "moused-over." If there is only a single instance, this will always contain a reference to that instance.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


pwObj Method

Returns a JavaScript object reference corresponding with the provided elementID.

[JavaScript]
objElement = pwObj(elementId)

Parameters

elementId
The ID attribute of the HTML element.

Return Value

The object reference referring to the element with the specified ID, or null if no element is found.

Remarks

This method resolves an ID to an object, taking browser discrepancies into account.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


pwzGetElementLeft Method

Returns the actual left coordinate of the provided element.

[JavaScript]
value = pwzGetElementLeft(elementId)

Parameters

elementId
The ID attribute of the HTML element, or an object reference to the HTML element itself.

Return Value

The value of the element's actual left coordinate.

Remarks

This method takes nested HTML elements into account, as well as positioning.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


pwzGetElementTop Method

Returns the actual top coordinate of the provided element.

[JavaScript]
value = pwzGetElementTop(elementId)

Parameters

elementId
The ID attribute of the HTML element, or an object reference to the HTML element itself.

Return Value

The value of the element's actual top coordinate.

Remarks

This method takes nested HTML elements into account, as well as positioning.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


pwAfterCallback Event

Raised when a callback completes and returns from the server.

[JavaScript]
pwAfterCallback

Remarks

To implement this event, create a JavaScript function called "pwAfterCallback." This function will be automatically called once a callback returns. If this function does not exist, this event is simply ignored.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


pwBeforeCallback Event

Raised before any callback is sent.

[JavaScript]
pwBeforeCallback

Remarks

To implement this event, create a JavaScript function called "pwBeforeCallback." This function will be automatically called before a callback is sent. If this function does not exist, this event is simply ignored.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


pwZoom Object

Client-Side representation of the Zoom control.

[JavaScript]
pwZoom

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


container Property

Gets a reference to the HTML element which contains all of the image tiles.

[JavaScript]
container

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


parentContainer Property

Gets a reference to the HTML element which contains the container. This is the topmost container in the pwZoom hierarchy.

[JavaScript]
parentContainer

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


tiles Property

Gets an array which contains the created image tile objects.

[JavaScript]
pwCurPopup

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


coast Method

Pans the image at the provided angle and speed.

[JavaScript]
value = coast(angle, speed)

Parameters

angle
The degree (0-360) to pan the image.
speed
The speed at which panning occurs.

Remarks

Movement will occur indefinitely until the edge of the image is reached or until pwZoom.stop() is called.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


getX Method

Returns the current X coordinate of the image.

[JavaScript]
value = getX()

Return Value

The current X coordinate of the image.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


getZ Method

Returns the current Z coordinate of the image.

[JavaScript]
value = getZ()

Return Value

The current Z coordinate of the image.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


getY Method

Returns the current Y coordinate of the image.

[JavaScript]
value = getY()

Return Value

The current Y coordinate of the image.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


hideProgressIcon Method

If progress icon is displayed on the current pwZoom object, this method hides it. If it is not displayed, this method has no effect.

[JavaScript]
hideProgressIcon()

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


performZoom Method

Zoom immediately (without animation) to the specified x, y, z coordinate.

[JavaScript]
value = performZoom(z, x, y)
value = performZoom(z)

Parameters

z
The Z (zoom level) coordinate of the image.
x
The Y (top) coordinate of the image.
y
The X (left) coordinate of the image.

Remarks

Note that the Z coordinate is the first parameter.

To zoom at the current position, use the overload with only the z parameter.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


repositionBy Method

Immediately change (without animation) by the values provided.

[JavaScript]
value = repositionBy(x, y)

Parameters

x
The X (left) coordinate to add to the current X coordinate of the image.
y
The Y (top) coordinate to add to the current Y coordinate of the image.

Remarks

If the values provided are pwZoom.repositionBy(5, 0), the image will be moved right 5 pixels, and down 0 pixels.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


repositionTo Method

Immediately reposition (without animation) to the specified X/Y coordinates.

[JavaScript]
value = repositionTo(x, y)

Parameters

x
The new X (left) coordinate where the image will be repositioned to.
y
The new Y (top) coordinate where the image will be repositioned to.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


showProgressIcon Method

Shows the progress icon in the middle of the current pwZoom object.

[JavaScript]
showProgressIcon()

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


slide Method

Slide (pan to a new location) with animation.

[JavaScript]
value = slide(x, y, speed, ease)

Parameters

x
The X (left) coordinate of the image.
y
The Y (top) coordinate of the image.
speed
The top speed achieved during the movement.
ease
Provides acceleration/deceleration.

Remarks

If speed is null, the image is moved without animation. If ease is null, the image is moved at a constant speed.

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


stop Method

Stops any ongoing panning movement.

[JavaScript]
stop()

See Also

Client-Side Reference | Server-Side Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Samples

The following samples are full applications which demonstrate usage of PowerWEB Zoom for ASP.NET. The default directory for sample applications is C:\Program Files\PowerWEB\Zoom\Samples (where the install drive letter is C:\).

The following table shows the samples for this release and their default install locations.

Sample | Language | Location
Configurator | C# ASP.NET Application VB ASP.NET Application | C:\Program Files\PowerWEB\Zoom\Samples\ZoomConfigurator\VS2002\CSharp C:\Program Files\PowerWEB\Zoom\Samples\ZoomConfigurator\VS2005\CSharp C:\Program Files\PowerWEB\Zoom\Samples\ZoomConfigurator\VS2002\VB C:\Program Files\PowerWEB\Zoom\Samples\ZoomConfigurator\VS2005\VB
Product Catalog | C# ASP.NET Application VB ASP.NET Application | C:\Program Files\PowerWEB\Zoom\Samples\ZoomProductCatalog\VS2002\CSharp C:\Program Files\PowerWEB\Zoom\Samples\ZoomProductCatalog\VS2005\CSharp C:\Program Files\PowerWEB\Zoom\Samples\ZoomProductCatalog\VS2002\VB C:\Program Files\PowerWEB\Zoom\Samples\ZoomProductCatalog\VS2005\VB
'Points of Interest' | C# ASP.NET Application VB ASP.NET Application | C:\Program Files\PowerWEB\Zoom\Samples\ZoomPointsOfInterest\VS2002\CSharp C:\Program Files\PowerWEB\Zoom\Samples\ZoomPointsOfInterest\VS2005\CSharp C:\Program Files\PowerWEB\Zoom\Samples\ZoomPointsOfInterest\VS2002\VB C:\Program Files\PowerWEB\Zoom\Samples\ZoomPointsOfInterest\VS2005\VB

Related Sections

Getting Started
Provides an overview of PowerWEB Zoom for ASP.NET and discusses such topics as distribution, licensing, and support.
Using the Zoom Control
Discusses how to use the Zoom control to display a high-res image in a browser.
Reference
Provides a language/syntax reference for PowerWEB Zoom for ASP.NET.

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Configurator Sample

In this sample the user can interactively set many of the Zoom control’s properties. The sample demonstrates how the control can be configured or optimized for the particular image for the best quality and performance.

Requirements

Components: Dart.PowerWEB.Zoom.dll

Location

C:\Program Files\PowerWEB\Zoom\Samples\ZoomConfigurator\VS2002\CSharp

C:\Program Files\PowerWEB\Zoom\Samples\ZoomConfigurator\VS2005\CSharp

--or--

C:\Program Files\PowerWEB\Zoom\Samples\ZoomConfigurator\VS2002\VB

C:\Program Files\PowerWEB\Zoom\Samples\ZoomConfigurator\VS2005\VB

See Also

Samples |PowerWEB Zoom for ASP.NET Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Product Catalog Sample

In this sample application PowerWEB Zoom is used to display products as they would appear in an online storefront. This sample demonstrates how a single control can be re-used on an ASP.NET WebForm and generate image data on-demand.

Requirements

Components: Dart.PowerWEB.Zoom.dll

Location

C:\Program Files\PowerWEB\Zoom\Samples\ZoomProductCatalog\VS2002\CSharp

C:\Program Files\PowerWEB\Zoom\Samples\ZoomProductCatalog\VS2005\CSharp

--or--

C:\Program Files\PowerWEB\Zoom\Samples\ZoomProductCatalog\VS2002\VB

C:\Program Files\PowerWEB\Zoom\Samples\ZoomProductCatalog\VS2005\VB

See Also

Samples |PowerWEB Zoom for ASP.NET Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Points of Interest Sample

'Points of Interest' Sample

This sample application combines the client-side API and server-side properties to store a series of coordinates to be later recalled for repositioning the Zoom control’s view.

Requirements

Components: Dart.PowerWEB.Zoom.dll

Location

C:\Program Files\PowerWEB\Zoom\Samples\ZoomPointsOfInterest\VS2002\CSharp

C:\Program Files\PowerWEB\Zoom\Samples\ZoomPointsOfInterest\VS2005\CSharp

--or--

C:\Program Files\PowerWEB\Zoom\Samples\ZoomPointsOfInterest\VS2002\VB

C:\Program Files\PowerWEB\Zoom\Samples\ZoomPointsOfInterest\VS2005\VB

See Also

Samples |PowerWEB Zoom for ASP.NET Reference

Send comments on this topic.

© 2006 Dart Communications. All rights reserved.


Dart.PowerWEB.ZoomHierarchy

Dart.PowerWEB.Zoom Hierarchy

System.Object
Dart.PowerWEB.Zoom.CallbackManager ---- System.Web.IHttpModule
Dart.PowerWEB.Zoom.ResourceHttpHandler ---- System.Web.IHttpHandler
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Dart.PowerWEB.Zoom.KeyEventHandler
Dart.PowerWEB.Zoom.LocationEventHandler
System.EventArgs
Dart.PowerWEB.Zoom.KeyEventArgs
Dart.PowerWEB.Zoom.LocationEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Dart.PowerWEB.Zoom.BrowserType
Dart.PowerWEB.Zoom.CallbackType
Dart.PowerWEB.Zoom.DialogType
Dart.PowerWEB.Zoom.DockPosition
Dart.PowerWEB.Zoom.ErrorBehavior
Dart.PowerWEB.Zoom.LayoutType
Dart.PowerWEB.Zoom.SkinType
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IParserAccessor
System.Web.UI.WebControls.WebControl ---- System.Web.UI.IAttributeAccessor
Dart.PowerWEB.Zoom.Zoom ---- System.Web.UI.IPostBackDataHandler, System.Web.UI.IPostBackEventHandler

See Also

Dart.PowerWEB.Zoom Namespace


Adding a Zoom Control to a WebForm in VS.NET

Although PowerWEB Zoom for ASP.NET can be used in your preferred environment on any machine that has the .NET Framework installed, the recommended method is to use the Visual Studio .NET environment.

NOTE If you copy and paste a Zoom control from one form to another in the designer, be sure to add the <%@ Register %> directive to your page.

To add a Zoom control to a WebForm within Visual Studio .NET, use the following steps:

  1. Create a project as described in Creating A Project.
  2. Add the Zoom control to the form. To do this, right-click on the ToolBox and choose Customize ToolBox. If the ToolBox is not visible, navigate to the View menu and choose ToolBox

  3. From the resulting dialog box, choose the .NET Framework Components tab, and then scroll until you find the Zoom control (see the screen shot below). Check the checkbox next to it and select OK.

  4. Click the Zoom control icon on the ToolBox, and "drag" an instance of it onto the design surface that represents a WebForm. The Visual Studio .NET environment will automatically create and instantiate an instance of the control.
  5. Make a quick application to test. Just navigate to the Debug menu and choose Start The app will compile and execute. You should see Internet Explorer (or your other browser) launch with the Zoom control.

See Also

Reference | Advanced Topics

Send comments on this topic.

©2006 Dart Communications. All rights reserved.


Creating A New Project in VS.NET

The following steps provide a walkthrough to create a project in Visual Studio.NET. Although PowerWEB Zoom for ASP.NET can be used in your preferred environment on any machine that has the .NET Framework installed, the recommended method is to use the Visual Studio .NET environment.

To create a project in Visual Studio .NET, use the following steps:

  1. Start Visual Studio .NET.
  2. From the File menu, choose New, and then choose Project.
  3. From the resulting dialog box, choose either Visual C# Projects or Visual Basic Projects and then choose ASP.NET Web Application. Specify a name and a location for the project, and then click OK.

  4. After these steps have been completed, the project is created. In this scenario the project files will be in the Inetpub directory which is most often found as C:\Inetpub\wwwroot\WebApplication1.

See Also

Reference | Advanced Topics

Send comments on this topic.

©2006 Dart Communications. All rights reserved.