PowerTCP Emulation for .NET
See Also Send comments on this topic

Glossary Item Box

Welcome!

Welcome and thank you for choosing PowerTCP Emulation for .NET. You have selected what we feel is the most sophisticated and complete .NET VT Emulation package available on the market. We know you have a choice in software vendors and we will do our best to exceed your expectations.

Overview

PowerTCP Emulation for .NET 4 fills the VT Emulation, Telnet and remote access communication gaps in the .NET Framework by providing a VT display and stream-based Telnet communication that can be plugged into any Framework 2.0, 3.0. 3.5, 4.0 or 4.5 application. This latest version of the venerable PowerTCP product line gets a new design that leverages the power of the latest .NET environments to provide the most advanced Internet Communications controls and components available.

Some of the features include:

  • VT52, VT100, VT220, VT320 terminal support
  • Key mapping simplified with a specialized KeyDown event
  • Screen scraping functions for extracting text from the display and scroll buffer
  • Display customization with numerous options
  • International character, including double-wide Unicode support
  • Graphic characters fully supported for all fonts
  • Comprehensive style information for every cell in the display
  • TrueType font and ClearType smoothing support
  • Automatic HTML conversion of scraped text
  • Powerful printing capabilities, including auto-print
  • SetStream option performs sends and receives automatically

The Emulation for .NET product also includes Telnet, Rexec, Rsh and Rlogin communication components. Features include:

  • Auto-option negotiation with easy configuration options
  • Secure SSL Telnet support
  • Blocking reads that wait for defined delimiters, specifically designed for scripting applications
  • Logging event for easy debugging and session logging
  • Proxy support
  • A Start method for multi-threaded applications
  • Marshal methods for cross-thread marshaling support

About Us

Quality!

Dart Communications, located in upstate New York, has been designing and developing Internet communication components since 1994. More than a decade later, PowerTCP, PowerSNMP and PowerWEB for ASP.NET are International bestsellers to small businesses, consultants, and Fortune 500 companies.

Each targeted protocol is extensively researched by Dart and each product is tested and supported by consistent processes and customer feedback. Developers using our products can focus on creating the unique features they require rather than wasting weeks on research and unnecessary code writing.

Added Value

Dart Communications is committed to creating products that are of high quality, flexible, and easily implemented into a project. This process means maintaining meticulous documentation and a readily available support staff. In addition, Dart consistently processes feedback and requests, using this information for new product and feature development.

Dart's development team is also available for custom development projects relating to their product line. A customer may lack the time or background to complete a particular project as needed. Dart's team will draw on their protocol knowledge and experience to supply a quality solution within the timeframe required.

Expertise

Building components is about reliability. Developers need products that can stand up to use, that work as intended, and that go beyond original expectations. Our research tells us that users often change the scope of a project once it is underway. PowerTCP products are designed to scale to those increased expectations. To give you time to evaluate this claim prior to purchase, Dart supplies a fully functional trial for all of its products. See for yourself how a component can have both high-level functionality for quick and easy solutions, and also provide a low-level interface for customization.

In today's world, software developers are routinely asked to produce solutions using unfamiliar technologies, with little time allowed for research. When Internet Communications is part of your project, consider leveraging Dart's proven components to connect, encode, compress, encrypt and transfer data. Our goal is to help you build applications that work the first time, every time.

See Also

Reference
Rexec Component
Rlogin Component
Rsh Component
Telnet Component
Vt Control

Documentation Version 4.7
© 2016 Dart Communications. All Rights Reserved.


Getting Started

Getting Started
See Also Send comments on this topic

Glossary Item Box

We highly recommend the user read this documentation and examine the sample applications included in the distribution in order to become familiar with the Emulation for .NET classes. For the most basic quick-start, create a new Windows Application project in Visual Studio, and see the Code Examples page for accessible examples to try.

Show Sample Applications

All samples include C#, VB.NET and VC++/CLI versions. A PowerShell sample is also available.

Sample Name | Description
Automated Client | Demonstrates execution of an automated application using Telnet.
Telnet Client | Demonstrates a user-interactive Telnet client where sending and receiving data is automatically handled by using the the Vt control's SetStream method with the Telnet component's GetStream method.
Telnet Client (Independent Data Source) | Demonstrates a user-interactive Telnet client using an autonomous data source (in this case, the included Telnet component).
Rexec Client | Demonstrates execution of a command using Rexec.
Rlogin Client | Demonstrates a user-interactive Rlogin client.
Rsh Client | Demonstrates execution of a command using Rsh.
Screen Scraping | Demonstrates how to scrape the contents of the VT display.
Telnet Automated Console | Demonstrates use of Telnet in a console application.
Screen Scraping Web | Demonstrates how to scrape the contents of the VT display on a web page.
Telnet Automated Web | Demonstrates use of Telnet on a web page.

Download the Emulation for .NET Sample Applications

Show Support Options

Our mission at Dart is to deliver high quality Internet connectivity solutions to Internet application developers. Our goal is to supplement these solutions with timely support resources that can help at many different levels.

You must have an active connection to the Internet to view these links.

Paid Support Options
Discusses the paid support options available.
Free Support Options
Provides access to free materials to help your development, including FAQS, online help files, tutorials, code snippets, online asp samples, and a free support forum.
Support Forum
Provides access to our support forum, monitored by our own development staff as time permits.
Dart Solutions
Discusses the custom development support offered by Dart Solutions.

Show Authenticode Signing

Dart installation executables are authenticode signed with a "Dart Communications" digital certificate to ensure against tampering during distribution.

Dart dlls included in the installation bin directory are .NET strong name signed, but not authenticode signed. These dlls are used by the sample applications and typically referenced in users' products.

For those users who require dlls signed by the author company (for example, for Windows logo compliance), dlls that have been signed with the "Dart Communications" digital certificate are also included in the product. These dlls are contained in the "Signed Distributables" sub-folder under the installation bin folder.

In accordance with the End-User Licensing Agreement, pre-compiled Dart dlls may NOT be signed with a user's own certificate. However, for users who wish to independently sign these dlls, Dart offers Enterprise licenses which allow for this. Please contact sales@dart.com for more information.

Show Requirements

Target Platforms: Microsoft .NET Framework 2.0 SP1

See Also

Rexec Component
Rlogin Component
Rsh Component
Telnet Component
Vt Control


Licensing and Trial Operation

Licensing and Trial Operation
See Also Send comments on this topic

Glossary Item Box

Show Application Licensing

The licenses.licx File

All Dart classes require a licenses.licx file in the executing assembly’s project, containing an entry for each licensed class. Without the licenses.licx, a runtime license will not be generated and compiled into the assembly, and a license exception will be thrown at runtime.

When a licensed control or component is added to a project using the Visual Studio designer, a licenses.licx file will be automatically generated if one does not already exist, and an entry for the class added.

When developing an assembly with no design surface such as a console application, or when instantiating a licensed class in code, the licenses.licx file must be added manually. If a licenses.licx file is not present in the project, add a new text file named "licenses.licx" to the project (not the solution) from the Solution Explorer. Add a single line to the licenses.licx that includes the fully-specified class name and the assembly name, separated by a comma. For example:

Dart.Emulation.Vt, Dart.Emulation

Web Site Projects

Web Site projects include an App_Licenses.dll that must be rebuilt when changes are made to the licenses.licx file or when migrating from trial to licensed operation. The App_Licenses.dll can be rebuilt by right-clicking on the licenses.licx file in the Solution Explorer and selecting the "Rebuild Runtime Licenses" option.

Powershell and other Scripting Environments

Because PowerShell does not execute compiled code and its scripts are generally modifiable by end users, a development or trial license is required on any machine executing scripts. If an environment other than PowerShell is being used or another distribution method is desired, please contact support@dart.com for additional options.

Other Development Environments

For compilation environments that do not recognize the licenses.licx file, a license resource may be generated with the .NET or MONO lc.exe utility on a licensed machine and added to the project as an embedded resource, or linked during compilation using the appropriate resource switch. For specific instructions, check with the environment's manufacturer.

Show Development Platform Licensing

Trial Operation

Dart components include a 30-day introductory trial period. With the exception of trial messages and trial runtime license expiration exceptions, runtime trial operation is the same as licensed operation.

A 7-day runtime license will be embedded in assemblies compiled during the trial period. After 7 days, Dart classes will throw an exception and the assembly will no longer function. The 7-day runtime license can be reset within the 30-day trial period by recompiling the project.

A trial installation can be licensed by purchasing and activating a Product Key.

Licensed Operation

A Developer License is required to compile licensed assemblies. A valid Product Key is required to generate a Developer License. Each Developer License is machine and version specific; major and minor version increments (for example, 4.0, 4.1 and 5.0) require separate Product Keys and Developer Licenses, build and revision do not.

Product and license upgrades are available through the Customer Center to developers with an active subscription.

Obtaining a Developer License

Run the included license activation utility from the Activate PowerTCP Emulation for .NET 4.7 shortcut in the product's Start Menu program group. The utility will guide you through the registration and activation process. Once complete, the Developer License file will be emailed to you. Copy the dartlic file attached to the email to the following location:

Program Files (x86) \ Dart \ PowerTCP Emulation for .NET \ 4.7 \ bin

This location is also accessible from the 'Binaries Folder' shortcut in the product's Start Menu program group.

Note: On UAC-enabled operating systems, the dartlic file may need to be saved to a non-UAC-protected location before copying it to the aforementioned location.

If Internet access is not available on the development machine, the activation utility provides a URL for activating the license on a machine with Internet access so that the Developer License can be retrieved and copied to the development machine.

Note: All licensing messages and exceptions are logged to the Application Event Log with "Dart Components" as the event source. If the "Dart Components" event source could not be created, messages are logged under the ".NET Components" event source. The Application Event Log can be examined for licensing messages and exceptions in situations where message boxes cannot be displayed or no GUI is present.

Show Deployment

Dart components support xcopy deployment and do not require any files other than the component dll and compiled project assemblies.

See Also

Rexec Component
Rlogin Component
Rsh Component
Telnet Component
Vt Control


Code Examples

Code Examples
See Also Send comments on this topic

Glossary Item Box

The following lists direct links to pages in this help file that contain easy-to-follow code examples.

Using the Start method to execute code without blocking the UI

Marshaling data to the UI thread

Mapping a string to a key

Printing the screen or a portion of the screen

Examining properties of a cell in the display

Writing data to the display

Executing an automated session

Setting options for automatic option negotiation

Authenticating a server's certificate

Reading on a worker thread

Logging data sent and received using the Log event

Changing ANSI colors

See Also

Rexec Component
Rlogin Component
Rsh Component
Telnet Component
Vt Control


Designed for Modern Applications

Designed for Modern Applications
See Also Send comments on this topic

Glossary Item Box

PowerTCP Emulation for .NET exposes a modern multi-threaded design with technical advantages over competing products.

Async Methods

The async methods (BeginXXX) seen in competing products reflect an antiquated single-threaded design model that denies the benefits of multi-threaded power. Please read on to see how PowerTCP Emulation for .NET delivers multi-threaded power to your application without adding the complexity that is often associated with multi-threading techniques.

Operation on the client side of the client/server model is inherently command driven, so Emulation for .NET provides a simple Start(delegate) method that executes the body of your delegate on a worker thread. This straight-forward concept provides a flexible technique for using PowerTCP in any application environment.

This design eliminates the need for BeginXXX methods and EndXXX events. There is a clean interface with one method for each function and several advantages are immediately realized:

Efficiency. Methods are designed to efficiently block on socket receive operations (the thread sleeps until bytes are received). This results in the most robust and efficient design possible.

Reusable code. Your delegate(s) can be used in applications both with and without a UI. It is no longer necessary to use BeginFoo for Windows Forms applications, and (the blocking) Foo for services, web applications and console applications.

Lower life-cycle cost. Code is written sequentially because there is no UI message pump to consider. It is not necessary to write code for numerous event handlers. Your code is self-documenting, easier to debug and maintain, and has a lower life-cycle cost.

Easy-to-implement parallel operation. Worker threads are easily spawned, supporting intensively parallel operations. Alternatively, serial operation is easily implemented by using just one thread. Flexibility of design is key.

No more state machine. It is not necessary to track state in event handlers. Take the simple case where the following sequence takes place:

  • Receive data R1
  • Send data S1
  • Receive data R2
  • Send data S2

Using BeginXXX, an event is raised when data is received and a state machine is required (if R1 is received then send S1, else if R2 is received then send S2). Using a single worker thread, the operation is coded in simple, declarative steps (Receive R1, Send S1, Receive R2, Send S2).

No More Pseudo-Blocking

Competing products use "pseudo-blocking" to process UI events while the method blocks. Without pseudo-blocking overhead methods are faster and more efficient. Also, re-entrancy problems (caused when UI messages are processes while a communication method is in progress) are no longer possible.

Developing Applications Without a UI

Developing console applications, web applications, services and other applications without a UI is as easy as ever. Sequential code performs efficiently. If parallel operation is desired, Start(delegate) can be used to execute code in any delegate body in parallel.

Developing Applications With a UI

Developing Windows Forms applications is now just as easy as writing applications without a UI. One method (the delegate) can be used in both types of applications. The only difference is that a UI app uses Start(delegate) to spawn a worker thread upon which the method executes, and any data needed by the UI must be marshaled to the UI thread. To this end, PowerTCP components include Start() and Marshal() convenience methods.

The Start Method

Use the Start method to execute one or more functions on a new worker thread, so the UI is not blocked during operation. The syntax for this method is simple (C# and VB code snippets follow):

C# Copy Code
telnet1.Start(myBlockingFunction, myObject); //Can also be called without passing an object

private void myBlockingFunction(object myObject)
{
   ...
}
Visual Basic Copy Code
telnet1.Start(AddressOf myBlockingFunction, myObject)  'Can also be called without passing an object

Private Sub myBlockingFunction(ByVal myObject As Object)
   ...
End Sub

Marshaling Data

It is often necessary to pass information from a worker thread to update an element on the UI thread. Use the Marshal method for this purpose. Each Marshal overload is paired with an event that is raised on the UI thread. For example (C# and VB code snippets follow):

C# Copy Code
//Read data, marshal to the UI thread
byte [] buffer = new byte [1024];
telnet1.Marshal(telnet1.Read(buffer), "", null);

private void telnet1_Data(object sender, DataEventArgs e)
{
    //Display received data
    //This event is raised on the UI thread
    displayData(e.Data);
}
Visual Basic Copy Code
'Read data, marshal to the UI thread
Dim buffer(1023) As Byte
telnet1.Marshal(telnet1.Read(buffer), "", Nothing)

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs)
    'Display received data
    'This event is raised on the UI thread
    displayData(e.Data)
End Sub

Typical Use

The developer wants to execute a series of functions without interfering with the user-interface. A button, textbox, and the PowerTCP component are added to the form. Pressing the button will initiate a telnet session with communication displayed in the textbox. The automateSession function, which can be reused in a non-UI application, is passed to Start and executes on a worker thread (C# and VB code snippets follow).

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Event handlers were added in the designer
    //Start the process on a worker thread so the UI is not blocked
    telnet1.Start(automateSession, null);
}

private void automateSession(object notUsed)
{
    //This function executes on a worker thread
    try
    {
        //Connect
        telnet1.Connect("myServer");

        //Login to the server, marshal data to the UI thread
        Data data = telnet1.Login(new Credentials("myUsername", "myPassword", "$"));
        telnet1.Marshal(data, "", null);

        //Send a list command
        telnet1.Write("ls -la\r");//Wait for prompt, marshal data to the UI thread
        telnet1.Marshal(telnet1.ReadToDelimiter("$"), "", null);

        //Send an exit command; server will close the connection
        telnet1.Write("exit\r");

        //Read any remaining data before the shutdown
        telnet1.Marshal(telnet1.ReadToEnd(), "", null);
    }
    catch (Exception ex)
    {
        //Report errors to the UI thread
        telnet1.Marshal(ex);
    }
}

private void telnet1_Data(object sender, DataEventArgs e)
{
    //Add data received to the textbox
    textBox1.AppendText(e.Data.ToString());
}

private void telnet1_Error(object sender, ErrorEventArgs e)
{
    //Add error messages to the textbox
    textBox1.AppendText(e.GetException().Message);
}

private void telnet1_StateChanged(object sender, EventArgs e)
{
    //Change appearance of textbox when connected
    textBox1.BackColor = (telnet.State == ConnectionState.Closed)
        ? SystemColors.ControlDark
        : SystemColors.ControlLight;
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Event handlers were added in the designer
    'Start the process on a worker thread so the UI is not blocked
    telnet1.Start(AddressOf automateSession, Nothing)
End Sub

Private Sub automateSession(ByVal notUsed As Object)
    'This function executes on a worker thread
    Try
        'Connect
        telnet1.Connect("myServer")

        'Login to the server, marshal data to the UI thread
        Dim data As Data = telnet1.Login(New Credentials("myUsername", "myPassword", "$"))
        telnet1.Marshal(data, "", Nothing)

        'Send a list command
        telnet1.Write("ls -la" & vbCr) 'Wait for prompt, marshal data to the UI thread
        telnet1.Marshal(telnet1.ReadToDelimiter("$"), "", Nothing)

        'Send an exit command; server will close the connection
        telnet1.Write("exit" & vbCr)

        'Read any remaining data before the shutdown
        telnet1.Marshal(telnet1.ReadToEnd(), "", Nothing)
    Catch ex As Exception
        'Report errors to the UI thread
        telnet1.Marshal(ex)
    End Try
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs)
    'Add data received to the textbox
    textBox1.AppendText(e.Data.ToString())
End Sub

Private Sub telnet1_Error(ByVal sender As Object, ByVal e As ErrorEventArgs)
    'Add error messages to the textbox
    textBox1.AppendText(e.GetException().Message)
End Sub

Private Sub telnet1_StateChanged(ByVal sender As Object, ByVal e As EventArgs) Handles telnet1.StateChanged
    'Change appearance of textbox when connected
    If (telnet1.State = ConnectionState.Closed) Then
        textBox1.BackColor = SystemColors.ControlDark
    Else
        textBox1.BackColor = SystemColors.ControlLight
    End If
End Sub

In the second example, the developer wants to receive data whenever it is available, but again, without interfering with the ongoing processes of the application. Event handlers (not shown) are implemented as in the first example (C# and VB code snippets follow).

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   //Start the process on a worker thread (no state info passed in)
   telnet1.Start(receiveData, null);
}

private void receiveData(object notUsed)
{
   //This function executes on a worker thread
   try
   {
       //Connect to the server, marshal data to the UI thread
       telnet1.Connect("myServer");

       //Receive data when it is sent by the remote host
       byte[] buffer = new byte[1024];
       while (telnet1.State == ConnectionState.Connected)
           telnet1.Marshal(telnet1.Read(buffer), "", null);
   }
   catch (Exception ex)
   {
       //Report errors to the UI thread
       telnet1.Marshal(ex);
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs) Handles button1.Click
   'Start the process on a worker thread (no state info passed in)
   telnet1.Start(AddressOf receiveData, Nothing)
End Sub

Private Sub receiveData(ByVal notUsed As Object)
   'This function executes on a worker thread
   Try
      'Connect and login to the server, marshal data to the UI thread
      telnet1.Connect("myServer")

      'Receive data when it is sent by the remote host
      Dim buffer() As Byte = New Byte(1023){}
      Do While telnet.State = ConnectionState.Connected
         telnet1.Marshal(telnet1.Read(buffer), "", Nothing)
      Loop
   Catch ex As Exception
      'Report errors to the UI thread
      telnet1.Marshal(ex)
   End Try
End Sub

See Also

Rexec Component
Rlogin Component
Rsh Component
Telnet Component
Vt Control


MVC Design in Applications

MVC Design in Applications
See Also Send comments on this topic

Glossary Item Box

Extending the Model-View-Controller Design Philosophy to Applications

One feature of the new version 4 components is the ease with which applications can be developed using a Model-View-Controller (MVC) design. MVC is a design philosophy that isolates application business logic from the user interface. The following white paper offers a detailed discussion of this design and its application to the PowerTCP and PowerSNMP components:

http://www.dart.com/articles_mvc.aspx

MVC design has been incorporated into some of the more sophisticated PowerTCP and PowerSNMP sample applications, providing two key benefits:

Separation of protocol logic from the user interface

Encapsulating protocol logic in a class separates it from any user interface, providing clean code that can be reused in other projects, with other interfaces.

The Telnet Client sample provides a nice demonstration of this separation. The sample implements a TelnetModel class where all code pertaining to communication logic - connecting, receiving sending - resides. The telnet functionality can easily be extended or modified without affecting the UI. This class can easily be reused in other applications, with other interfaces. In addition, encapsulating the data and logic pertaining only to telnet functions provides a cleaner project that is easier to digest and maintain.

Simplified storage of runtime state information

Saving runtime state information and persisting this information when the application is terminated is a key feature of many applications. Model classes can be used to facilitate this.

Again, the Telnet Client sample is a typical example.

First, the sample's TelnetModel class provides properties for storing runtime data, including session data, security settings, and whether the application should echo data received. This class provides a "ground truth" for the state of the application, instead of the interface itself holding this information. The interface provides a means for updating the model, but is itself "dumb." Also, the encapsulated data can be easily passed to objects such as Settings and Connection forms, which are implemented as interfaces for updating the information contained within the model.

Second, as a serializable class, the model provides a means for easily persisting settings when the application is terminated. In the past, PowerTCP and PowerSNMP samples dedicated large chunks of code for saving and loading application settings, usually in the registry. PowerTCP 4 components have taken a different approach, focusing instead on providing help for serialization. This includes helper functions for Serializing and Deserializing objects to and from streams, as well as providing state information in serializable objects that can be easily stored. The TelnetModel class stores several such objects, including TelnetSession (LocalEndPoint, RemoteEndPoint and Proxy information), and ClientSecurity (TargetHost, Certificates, Protocol, etc).

The sample applications are available as an option during the product installation, and can also be downloaded by clicking on the "Download Samples" link in the Start Menu.

See Also

Reference
Rexec Component
Rlogin Component
Rsh Component
Telnet Component
Vt Control


PowerTCP in Partial Trust Environments

PowerTCP in Partial Trust Environments
Send comments on this topic

Glossary Item Box

Partial Trust

Partial Trust environments such as shared hosting in ASP.NET limit access to potentially harmful .NET framework classes and methods. Because of this, some additional configuration is required in order to use Dart's components in these restricted environments. When developing a system service, console application, windows forms application, or web application that will run with Full Trust, no additional configuration is necessary.

Background

The Windows API can access system services that a system administrator may not want to expose. For example, a web hosting service may not want hosted code to access the file system. Microsoft calls limiting such access “Code Access Security”, well-documented in the MSDN article Using Code Access Security with ASP.NET.

Dart assemblies are marked with the 'AllowPartiallyTrustedCallers' assembly attribute for use in Partial Trust Environments. Using Dart's components in a Partial Trust environment requires additional configuration such as installing the component dll into the GAC or creating a custom security policy.

Installation into the GAC

When a Dart assembly is installed into the GAC, the component is granted full trust and asserts the required permissions at runtime so that no custom Security Policy is required. This is the preferred technique for using Dart components in Partial Trust environments.

Custom Security Policies

Security policy files are used to define a permission set that applications running under them can be granted. Under ASP.NET the web.config file can be used to specify which Security Policy should be used. Custom Security Policy files can be used to explicitly grant permissions that are required by the application and its references. However, some .NET Framework features are restricted regardless of Security Policy settings and will typically result in System.Security.SecurityException when used. Because of this, some components may have limited functionality in partial trust environments; if full functionality is required then the Dart component must be installed into the GAC.

Defining a Custom Security Policy

A custom Security Policy should only be used if an application using a Dart component is not run in Full Trust or the Dart component's assembly is not installed into the GAC.

Note: Version numbers mentioned in the following instructions reflect the version of the .NET Framework that permissions are being requested for; if .NET 2.0 is targeted then the appropriate version number should be substituted.

To define a custom Security Policy:

  1. Copy and paste the default web_mediumtrust.config file located at C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\web_mediumtrust.config
  2. Rename the copied config file, ex: web_mediumtrust_custom.config

  3. Add the SocketPermission class definition to the SecurityClasses section:

    <SecurityClass
        Name="SocketPermission"
        Description="System.Net.SocketPermission, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

  4. Add SocketPermission to the ASP.NET NamedPermissionSet section:

    <Ipermission
         class="SocketPermission"
         version="1"
         Unrestricted="true" />

  5. Add the UnmanagedCode flag to the SecurityPermision definition:

    <Ipermission
         class="SecurityPermission"
         version="1"
         Flags="UnmanagedCode, Execution, ControlThread, ControlPrincipal, RemotingConfiguration" />

  6. Save the file

Configuring the Security Policy in web.config

To direct an ASP.NET application to use medium trust add the following to the system.web section:

<trust level="Medium"/>

To use a custom Security Policy, add the following to the system.web section:

<securityPolicy>
     <trustLevel name="CustomMedium" policyFile="C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\web_mediumtrust_custom.config" />
</securityPolicy>
<trust level="CustomMedium"/>

Alternatively, an assembly that requires full trust can be added to the application's web.config securityPolicy section:

<securityPolicy>
   <fullTrustAssemblies>
     <add assemblyName="Dart.Snmp" version="4.7.0.0" publicKey="00240000048000009400000006020000002400005253413100040000010001003fc01cbb4168cbdbb48a763283bd3a3e48dba81e06c4179db0bf20ba775a188f5c06c7bc1d7f39c22d63a04e3c16b424da9174dc28a019097458bcbea3e0e5184854a07382e3329cf82ce6004731b25eb7b9d56d9682df5606806b894974d0d42b960a2498a756f38904a1cac14e41a9b5debb62276e94e37934d5f1cc9838dd"/>
   </fullTrustAssemblies>
</securityPolicy>

Update the assemblyName, version and publicKey as needed for the product in use. To extract the public key from an assembly, use the 'sn' utility with the '-Tp' option from the Visual Studio command prompt.


Emulation Overview

Emulation Overview
See Also Send comments on this topic

Glossary Item Box

This topic discusses basic concepts related to VT Emulation. See the Assembly Overview for more information on PowerTCP Emulation for .NET use.

Keymapping

The Vt control uses a default key mapping that is close to the keyboard layout of a VT terminal. For example, the PF1 key on the VT is the top left key on the numeric keypad, so the NUMLOCK key on the PC numeric keypad is mapped to the PF1 function key. The following table summarizes the default keyboard mappings:

VT Key | PC Key
Find | INSERT
InsertHere | HOME
Remove | PAGE UP
Select | DELETE
PrevScreen | END
NextScreen | PAGE DOWN
PF1 | NUMLOCK
PF2 | / (on numeric keypad)
PF3 | · (on numeric keypad)
PF4 | - (on numeric keypad)
, (comma) | + (on numeric keypad)
- (minus) | + (on numeric keypad)
Enter | ENTER (on numeric keypad)
F6–F10 (w/ Shift for user-defined keys) | F6 through F10 (w/ CTRL for user-defined keys)
F11–F20 (w/ Shift for user-defined keys) | SHIFT+F through Shift+F10 (w/ CTRL for user-defined keys)
Help | F11
Do | F12

To modify these default mappings, set the Handled argument in the KeyDown event handler to true (preventing further key events) and send substitute data directly out the communications channel. See the KeyDown help page for a detailed example. To easily generate the bytes that represent the various keys, use the VtKey enumeration with Vt.MapVtKey().

Detailed VT Cell.Character String Tables

The following tables list character strings generated by the VT. The reader may wish to obtain more complete programming information directly from Digital Equipment Corporation. To use the below tables with our component: for example, F6 is defined as "CSI 1 7 ~", in order to send this to a server under 8-bit mode, Telnet.Send("\x9b" + "17~"), or generate the bytes using Vt.MapVtKey().

Control Sequence | 7-bit Mode | 8-bit Mode
ESC | 0x1b | 0x1b
CSI | ESC [ | 0x9b
SS3 | ESC O | 0x8f

VT/IBM Main Keypad Function Keys | Code Transmitted
BACKSPACE | DEL character
TAB | HT character
RETURN | CR or CRLF depending upon the NewLine property
CTRL, Lock, SHIFT | Does not send a code
SPACEBAR | SP character

VT Edit Key | IBM Edit Key | VT 220/320 Code | VT 100/52 Code
Find | INSERT | CSI 1 ~ | None
Insert Here | HOME | CSI 2 ~ | None
Remove | PAGE UP | CSI 3 ~ | None
Select | DELETE | CSI 4 ~ | None
Prev Screen | END | CSI 5 ~ | None
Next Screen | PAGE DOWN | CSI 6 ~ | None

VT/IBM Cursor Keys | VT100/220/320 Code Normal Cursor Key Mode | VT100/220/320 Code Application Cursor Key Mode | VT52 Code Normal Cursor Key Mode | VT52 Code Application Cursor Key Mode
UP ARROW | CSI A | SS3 A | ESC A | ESC A
DOWN ARROW | CSI B | SS3 B | ESC B | ESC B
RIGHT ARROW | CSI C | SS3 C | ESC C | ESC C
LEFT ARROW | CSI D | SS3 D | ESC D | ESC D

VT Aux Keypad | IBM Aux KeyPad | VT100/220/ 320 Code Numeric Keypad Mode | VT100/220/ 320 Code Application Keypad Mode | VT52 Code Numeric Keypad Mode | VT52 Code Application Keypad Mode
0 | 0 | 0 | SS3 p | 0 | ESC ? p
 | 1 | 1 | SS3 q | 1 | ESC ? q
 | 2 | 2 | SS3 r | 2 | ESC ? r
 | 3 | 3 | SS3 s | 3 | ESC ? s
 | 4 | 4 | SS3 t | 4 | ESC ? t
 | 5 | 5 | SS3 u | 5 | ESC ? u
 | 6 | 6 | SS3 v | 6 | ESC ? v
 | 7 | 7 | SS3 w | 7 | ESC ? w
 | 8 | 8 | SS3 x | 8 | ESC ? x
 | 9 | 9 | SS3 y | 9 | ESC ? y
- | Ctrl + "+" | - (minus) | SS3 m | - | ESC ? m
, | + | , (comma) | SS3 l | , | ESC ? l
. | . | . (period) | SS3 n | . | ESC ? n
Enter | Enter | CR or CR/LF | SS3 M | CR or CR/LF | ESC ? M
PF1 | NumLock | SS3 P | SS3 P | ESC P | ESC P
PF2 | / | SS3 Q | SS3 Q | ESC Q | ESC Q
PF3 |  | SS3 R | SS3 R | ESC R | ESC R
PF4 | - | SS3 S | SS3 S | ESC S | ESC S

VT Function Keys | IBM Function Keys | VT220/320 Code | VT100/52 Code
Hold Screen | F1 | (none) | (none)
Print Screen | F2 | (none) | (none)
Set-up | F3 | (none) | (none)
Data/Talk | F4 | (none) | (none)
Break | F5 | (none) | (none)
F6 | F6 | CSI 1 7 ~ | (none)
F7 | F7 | CSI 1 8 ~ | (none)
F8 | F8 | CSI 1 9 ~ | (none)
F9 | F9 | CSI 2 0 ~ | (none)
F10 | F10 | CSI 2 1 ~ | (none)
F11 (ESC) | <shift> F1 | CSI 2 3 ~ | ESC
F12 (BS) | <shift> F2 | CSI 2 4 ~ | BS
F13 (LF) | <shift> F3 | CSI 2 5 ~ | LF
F14 | <shift> F4 | CSI 2 6 ~ | (none)
Help | F11 | CSI 2 8 ~ | (none)
Do | F12 | CSI 2 9 ~ | (none)
F17 | <shift> F7 | CSI 3 1 ~ | (none)
F18 | <shift> F8 | CSI 3 2 ~ | (none)
F19 | <shift> F9 | CSI 3 3 ~ | (none)
F20 | <shift> F10 | CSI 3 4 ~ | (none)

Screen Scraping

Screen scraping is the act of reading data from a terminal display so that it may be used programatically. VT data is decorated with escape character sequences that define visual representation (font color, style, etc.). Often data must be extracted from these sequences, and PowerTCP Emulation for .NET provides several mechanisms for doing so.

Data written to the Vt control (for example, during a Telnet session), is available for scraping. The Vt control includes three methods for scraping the display - ScrapeText, ScrapeHtml and ScrapeCells. Each of these methods includes two overloads; one with offset and count parameters, and one with row, column and count parameters. These parameters are 0-based.

ScrapeText simply returns data without escape characters.

ScrapeHtml returns HTML data without escape characters. Escape sequences are substituted for HTML tags where appropriate.

ScrapeCells returns an array of Cell objects. Each Cell object contains character, colors and style information.

Dynamically create the Vt control in code when the visible display is not required.

Resizing

Resizing techniques can be used to ensure that the contents of the visible window are displayed at all times. There are two resizing scenarios. First, the display is resized to accommodate the selected font. Second, the font is resized to accommodate the size of the display.

Set the Height and Width of the Vt control's Size property to resize the display when the font changes. Alternatively, if the Vt control is docked to a container, set the container's Height and Width. In the following example, the control is docked to a form and resized (C# and VB code snippets follow):

C# Copy Code

private void doResize()
{
    //Resize form based on size of font
    this.Height = (vt1.Rows * vt1.CellSize.Height) + vt1.Padding.Top +
       (this.Height - vt1.Height);
    this.Width = (vt1.Columns * vt1.CellSize.Width) + vt1.Padding.Horizontal +
       SystemInformation.VerticalScrollBarWidth + (this.Width - vt1.Width);
}

Visual Basic Copy Code

Private Sub doResize()
    'Resize form based on size of font
    Me.Height = (vt1.Rows * vt1.CellSize.Height) + vt1.Padding.Top + _
        (Me.Height - vt1.Height)
    Me.Width = (vt1.Columns * vt1.CellSize.Width) + vt1.Padding.Horizontal + _
        SystemInformation.VerticalScrollBarWidth + (Me.Width - vt1.Width)
End Sub

To resize the font when the size of the display changes, set the Font property in the control's Resize event handler. For example (C# and VB code snippets follow):

C# Copy Code

private void vt1_Resize(object sender, EventArgs e)
{
   //Adjust the Font Size when the display height is resized
   if (mnuOptionsAutoResize.Checked)
   {
      Graphics g = CreateGraphics();
      float cellSize = ((vt1.Size.Height - vt1.Padding.Vertical) / vt1.Rows);
      float fontSize = 6; //min font size
      SizeF s = new SizeF();
      do
      {
         fontSize += (float).25;
         Font f = new Font(vt1.Font.Name, fontSize, vt1.Font.Style);
         s = g.MeasureString("w", f, 1000, StringFormat.GenericTypographic);
      } while (s.Height + 1.5 > cellSize);
      vt1.Font = new Font(vt1.Font.Name, fontSize, vt1.Font.Style);
      vt1.AutoScrollRowPosition = vt1.BufferRows + vt1.Rows;
   }
}

Visual Basic Copy Code

Private Sub vt1_Resize(ByVal sender As Object, ByVal e As EventArgs)
    'Adjust the Font Size when the display height is resized
    If mnuOptionsAutoResize.Checked Then
        Dim g As Graphics = CreateGraphics()
        Dim cellSize As Single = ((vt1.Size.Height - vt1.Padding.Vertical) / vt1.Rows)
        Dim fontSize As Single = 6 'min font size
        Dim s As SizeF = New SizeF()
        Do
            fontSize += CSng(0.25)
            Dim f As Font = New Font(vt1.Font.Name, fontSize, vt1.Font.Style)
            s = g.MeasureString("w", f, 1000, StringFormat.GenericTypographic)
        Loop While s.Height + 1.5 < cellSize
        vt1.Font = New Font(vt1.Font.Name, fontSize, vt1.Font.Style)
        vt1.AutoScrollRowPosition = vt1.BufferRows + vt1.Rows;
    End If
End Sub

See Also

Reference
Rexec Component
Rlogin Component
Rsh Component
Telnet Component
Vt Control


Telnet Protocol Overview

Telnet Protocol Overview
See Also Send comments on this topic

Glossary Item Box

The following information provides a basic understanding of the TELNET protocol and related concepts. See the Assembly Overview for information on using the classes in this library.

Protocol Overview

TELNET (Telecommunications Network Protocol) is a data communications protocol that provides a set of rules for communication between computers. Telnet communication is the same for all systems and therefore works between different types of computers and operating systems. Many host systems support Telnet, and it is often used for remote login where one computer is accessed from another. A typical Telnet application would use the protocol to move data between a terminal emulator and a UNIX server (host).

Telnet is mainly used for online terminal communications - the user logs in to remote machines and issue commands as if he were actually at these machines. Telnet can also be used to access remote databases, control other computers, distribute work among multiple systems, and remotely execute many applications.

Telnet is built upon TCP and provides additional features that make it an upper-layer protocol. Typically, a terminal sends commands to a host, and the host responds with messages or data. For example, a user may type "help" and the remote host may respond with "Type a command to get help on."

Telnet provides option negotiation as a means for establishing conventions between two machines. During a session, either host may send the other a command to request or volunteer a specific option. For example, the echo option may be negotiated.

Telnet Connections

Connections are made to a port and host name or address. Most Telnet connections are made to the standard port 23. All computers on a network have a distinguishing IP address. Standard IPv4 addresses have the following same format:

nnn.nnn.nnn.nnn

where each nnn is a number from 0 to 255 (except for the first octet, which may be from 0 to 247). This means an IPv4 address is 32bits long, allowing nearly 2^32 unique values. A typical IP address might be 129.229.1.2.

PowerTCP provides full support for IPv6. IPv6 was established as the next generation Internet protocol, in order to greatly increase the number of available IP addresses. IPv6 addresses have the following hexadecimal format:

xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx

where each xxxx is a hex value from 0000 to FFFF (0 to 65535). An IPv6 address is 128bits long, allowing 2^128 unique values. A typical address might be fe80::211:d800:97:c915. Note that "::" indicates a consecutive group of 0 values.

Most networks also support computer names, where the network will translate a name (such as "server3") into an IP address.

Network Virtual Terminal

The Network Virtual Terminal (NVT) is a Telnet concept used to represent both hosts in a connection. The NVT is an imaginary character-based device with a keyboard and a printer (input and output). Incoming data goes to the printer, and input from the keyboard goes to the other end of the Telnet connection. Both ends of a Telnet connection must support the NVT.

The NVT supports the 7-bit character set known as NVT ASCII. NVT ASCII is the same as normal ASCII text, except that only 7 bits represent the character. The eighth high bit of the byte must be set to 0. In NVT ASCII, an end of line is represented by a two-character sequence CR, LF (carriage return, line-feed).

Both ends of a Telnet connection map their own terminal device characteristics to and from the NVT. For example, a program must change all 8-bit ASCII characters to the NVT character set. The NVT is intended to strike a balance between being overly restrictive (not providing some computers a rich enough vocabulary for mapping into their local character sets) and being overly inclusive (penalizing users with modest terminals).

Please refer to RFC 854 for more information on the NVT.

Binary Data

PowerTCP provides full support for binary data transmission. The following basic Telnet encoding rules are applied when sending:

  1. Every byte of value 255 (IAC) is doubled up into a two-byte (255, 255) value.
  2. Every byte of value 13 (CR) not followed by a byte of value 10 (LF) is transformed into a two-byte (13, 0) value.

For all data received, the reciprocal transformation takes place within the Telnet component. This mechanism, established by RFC 854, enables the transmission of 8-bit binary data over a single Telnet channel.

There is also a TransmitBinary option that can be easily set using the Binary property of the Telnet component. When set to RequestOn, the TransmitBinary option is negotiated for both directions. When in this mode, a naked CR is not padded with a following NULL when data is sent. When data is received, any CR NULL encountered is used unaltered. All other padding (such as the doubling of IAC bytes) remains the same.

Option Negotiation

Option negotiation is the process by which two computers agree on the features they will or will not provide. Each computer may send and respond to commands. A typical option negotiation session may occur as follows (although over 40 different options might be negotiated):

Computer A | Computer B
1. I will echo back what you send to me. |
 | 2. OK, Do echo back what I send to you.
3. Do suppress go–aheads. |
 | 4. No, I won't suppress go–aheads.

Either machine may initiate option negotiation. One machine may request that the other machine support or not support an option, or inform the machine that it will or won't support an option. The other may then respond that it will or won't support an option, or request that the other computer support or not support an option. The following table describes the four option negotiation commands:

Command | Description
WILL | The sender wants to support the option
WONT | The sender will not support the option
DO | The sender wants the receiver to support the option
DONT | The sender wants the receiver to not support the option

The different pairs of commands and responding commands follow:

Command | Response | Option Used
WILL I will support this option | DO I do support this option | Yes
WILL I will support this option | DONT No, don't support it | No
WONT I won't support this option | DONT OK, don't support it | No
DO Do support this option | WILL OK, I will support it | Yes
DO Do support this option | WONT No, I won't support it | No
DONT Don't support this option | WONT OK, I won't support it | No

Note If a machine does not want an option supported (WONT/DONT), the other machine must comply, responding with a DONT or WONT.

Telnet also provides suboption negotiation—negotiating details about a specific option. An example is the "terminal type" option. For both computers to decide to support the same terminal type, instead of using a different option for each individual terminal type, a suboption is negotiated. A typical suboption negotiation is shown below:

Computer A | Computer B
1. I will support different terminal types. |
 | 2. OK, Do support different terminal types.
3. OK, send your terminal type suboption. |
 | 4. My terminal type suboption is "IBMPC".

Option negotiation and suboption negotiation makes Telnet very flexible and adaptable to many different terminal configurations. Refer to the applicable RFCs for more information on Telnet and Telnet option negotiation.

See Also

Reference
Rexec Component
Rlogin Component
Rsh Component
Telnet Component
Vt Control


Security Implementation

Security Implementation
Send comments on this topic

Glossary Item Box

Client Security

AuthenticateAsClient() is used by client components to perform authentication after connecting to a server. For our Tcp component, this must be called directly, while for our application-layer protocol components, it will be called automatically after the connection is established when SSL is enabled.

When AuthenticateAsClient() is called (either directly, or through top-level methods that will utilize it), two things may occur:

The server presents a certificate:

This will raise the RemoteCertificateValidationCallback specified by Tcp.Session.Security.ValidationCallback. This callback must be in the format:

C# Copy Code
using System.Net.Security;
using System.Security.Cryptography.X509Certificates;
bool RemoteCertificateValidation(
    Object sender,
    X509Certificate remoteCertificate,
    X509Chain chain,
    SslPolicyErrors sslPolicyErrors)
{
    ...
}
Visual Basic Copy Code
Imports System.Net.Security
Imports System.Security.Cryptography.X509Certificates
Function RemoteCertificateValidation( _
    ByVal sender As Object, _
    ByVal remoteCertificate As X509Certificate, _
    ByVal chain As X509Chain, _
    ByVal sslPolicyErrors As SslPolicyErrors) As Boolean
    ...
End Function

Return true to accept the certificate, and false to refuse it. A value other than SslPolicyErrors.None for sslPolicyErrors indicates an issue with the certificate that the server presented. A flag of SslPolicyErrors.RemoteCertificateChainErrors indicates that chain.ChainStatus should be checked; enumerate through chain.ChainStatus, and check the value of chain.ChainStatus[index].Status for additional details.

During authentication, the remote certificate's common name (CN) (usually the server's fully qualified domain name) is compared to the value of ClientSecurity.TargetHost. If the values do not match, sslPolicyErrors will contain the SslPolicyErrors.RemoteCertificateNameMismatch flag. When ClientSecurity.TargetHost is left empty, Tcp.Session.RemoteEndPoint.HostNameOrAddress will be used instead.

The server requests a certificate:

AuthenticateAsClient() first checks if Tcp.Session.Security.SelectionCallback is null. If it is not null, that LocalCertificateSelectionCallback will be raised. This callback must be in the format:

C# Copy Code
using System.Security.Cryptography.X509Certificates;
X509Certificate LocalCertificateSelection(
    Object sender,
    string targetHost,
    X509CertificateCollection localCertificates,
    X509Certificate remoteCertificate,
    string[] acceptableIssuers)
{
    ...
}
Visual Basic Copy Code
Imports System.Security.Cryptography.X509Certificates
Function LocalCertificateSelection( _
    ByVal sender As Object, _
    ByVal targetHost As String, _
    ByVal localCertificates As X509CertificateCollection, _
    ByVal remoteCertificate As X509Certificate, _
    ByVal acceptableIssuers() As String) As X509Certificate
    ...
End Function

Return a certificate within the callback, and that certificate will be used for authentication. Certificates may be accessed from the certificate store with the System.Security.Cryptography.X509Certificates.X509Store class:

C# Copy Code
using System.Security.Cryptography.X509Certificates;
//The X509Store constructor overloads may be used to access different certificate stores
X509Store certificateStore = new X509Store();
certificateStore.Open(OpenFlags.ReadOnly);
X509Certificate2 cert = certificateStore.Certificates[0];
Visual Basic Copy Code
Imports System.Security.Cryptography.X509Certificates
'The X509Store constructor overloads may be used to access different certificate stores
Dim certificateStore As New X509Store()
certificateStore.Open(OpenFlags.ReadOnly)
Dim cert As X509Certificate2 = certificateStore.Certificates(0)

For a demonstration of selecting a certificate from the certificate store interactively, please see the CertificateListForm included with our samples.

If Tcp.Session.Security.SelectionCallback is null, AuthenticateAsClient() will examine Tcp.Session.Security.Certificates for a valid certificate; the first certificate in the collection that passes Microsoft's validation checks will be used for authentication.

Server Security

For our server component, Tcp.AuthenticateAsServer(ServerSecurity) may be called after the client connects. ServerSecurity.ValidationCallback is identical to the client ValidationCallback, and will be raised when the client presents a certificate.

Set the ServerSecurity.Certificate property to specify the certificate to use for authentication.

Security Protocol

The security protocol used will be automatically negotiated; to specify the protocols available for negotiation, Security.Protocols may be set to any combination of the SslProtocols enumeration.

Explicit/Implicit

Explicit security means that the initial connection to the server is not encrypted. After connecting, a command such as STARTTLS or STLS is sent by the client to the server per the protocol, and a secure connection is negotiated. Because explicit security is initiated after the STARTTLS command is sent, servers are able to accept explicit connections on the same port that accepts non-secure connections.

Implicit security means that the client and server will negotiate a secure connection when the connection is established. Because of this, a port is typically dedicated for implicit connections.

Explicit/Implicit implementation is protocol-specific; application-layer protocols such as Ftp, Imap, Smtp and Pop implement it, while upper-layer protocols such as Tcp and Udp do not. The method of encryption may be configured on our components with a property on Session.Security. The property's name may vary between components, but will always start with 'Encrypt'; for Ftp, this property is Session.Security.EncryptControl, and for our Email components, Session.Security.Encrypt.


Manage Certificates with MMC

Manage Certificates with MMC
Send comments on this topic

Glossary Item Box

This document explains how to use the Microsoft Management Console (MMC) to import and export SSL Certificates. This is only one use for the MMC. Please see the MMC Documentation for more info.

Note: This document assumes the existing certificate is functional on the machine where the exporting takes place.

Start the MMC

The Microsoft Management Console (MMC) is part of Windows 2000 and later. It does not exist in NT or 9x. You may be able to do similar functions using IE, but IE versions vary so it will not be discussed here.

To start the MMC:

  1. Start -> Run -> MMC
  2. Choose File | Add/Remove Snap-in ...
  3. Click Add
  4. Select Certificates from the list and click the Add button
  5. Choose Computer account
  6. Choose Local Computer
  7. Click Close
  8. Click OK
  9. Repeat steps 2-8, substituting 'My user account' in step 5 and skipping step 6
  10. Choose File | Save As ... and save the settings to an .MSC file

In the future you can skip these steps by double-clicking the MSC file or by choosing the MSC from the history under the File menu.

Export an Existing Certificate

Follow these steps to save a certificate to a file. The file can then be used to import the certificate to another machine.

To export an existing certificate:

  1. Start the MMC by following the steps above or by clicking the MSC file saved previously
  2. Locate the Certificate that you wish to export. Certificates are using installed under the Personal ("MY") store in either the Local Machine or Current User stores
  3. Right Click on the certificate and choose All Tasks | Export
  4. Click Next
  5. Check 'Yes, export the private key' (If it's grayed out, the certificate can't be moved to another machine)
  6. Click Next
  7. Leave the Default setting at "Enable Strong Protection"
  8. Click Next
  9. Choose a password and click next
  10. Save the PFX file using a filename
  11. Click Next and you should see the "Completing the Certificate Export Wizard" screen
  12. Click Finish and you are done

The file you just saved can now be moved to another machine.

Import a Certificate

Follow these steps to move a certificate from one machine to another.

To import an existing certificate:

  1. Start the MMC by following the steps above or by clicking the MSC file saved previously
  2. Choose the store that you want to import to (EXAMPLE: Local Computer -> Personal)
  3. Right Click on the store and choose All Tasks | Import
  4. Click Next
  5. Browse to the PFX file that was previously saved
  6. Click Next
  7. Enter the password. If you want to allow the certificate to be exported again, check 'Mark this key as exportable'
  8. Click Next
  9. Check 'Place all certificates in the following store'
  10. Click Browse
  11. Check 'Show physical stores'
  12. Choose 'Personal' to store to the Current User store or 'Personal -> Registry' to store to the Local Machine store
  13. Click OK
  14. Click Finish

The certificate is now usable. However, unless the CA is already trusted (which is the case for major Certificate providers), users will be notified that the certificate itself is not trusted. To resolve this, go to the Website of the Certificate Authority that originally issued the certificate to obtain the CA's root certificate.

Note about importing certificates: PowerTCP requires that a certificate be properly imported into a valid Microsoft Certificate Store. If a certificate was created from a non-MS source (such as OpenSSL) , please be sure to export the certificate properly before importing it into an MS Certificate store. Check the help for whatever SSL system you are using for more information.


Dart.Emulation Namespace

Dart.Emulation Namespace
See Also Inheritance Hierarchy Send comments on this topic

Glossary Item Box

Classes

 | Class | Description
Class | AnsiColor | Provides fine control of display colors. Includes eight "normal" and eight "bold" (aka "bright" or "light") colors.
Class | ClientSecurity | Holds the configuration used to establish an SSL client session.
Class | CommandEventArgs | Contains Telnet command event data.
Class | ComponentBase | Base class for PowerTCP Components.
Class | Credentials | Provides a holder for parameters used to login to a remote host.
Class | DartLicenseException | The base class for all Dart component license exceptions.
Class | Data | Encapsulates data read or written.
Class | DataEventArgs | Provides data for reporting events.
Class | DataException | Thrown when the expected data could not be read.
Class | ErrorEventArgs | Provides data for the Error event.
Class | IPEndPoint | Allows user to specify a range of IPEndPoints for local binding. Also resolves hostnames and saves them for future use.
Class | KeyPressEventArgs | Provides data for the KeyPress event.
Class | Option | Encapsulates a Telnet option.
Class | OptionCollection | A collection of Option objects.
Class | OptionEventArgs | Contains option event data.
Class | ProtocolException | Thrown when an upper-layer protocol like FTP, SMTP or POP3 receives a negative response from the server.
Class | Proxy | Describes the server proxy, if any, to connect to.
Class | PtyBase | This class provides support for interactive on-line terminal access using controls derived from TextBoxBase.
Class | Rexec | The Rexec component enables use of the remote execution protocol within any .NET application.
Class | Rlogin | The Rlogin component enables use of the remote login protocol within any .NET application.
Class | Rsh | The Rsh component enables use of the remote shell protocol within any .NET application.
Class | Security | Holds the configuration used to establish an SSL session.
Class | Segment | Used to describe a byte[] segment that holds data.
Class | Selection | Contains methods and properties that control the display of selected cells as well as getting the text and attributes of those cells.
Class | Session | Holds the configuration common to UDP and TCP.
Class | SocketBase | Base class for PowerTCP Components.
Class | SocketOption | Contains socket options that may be set by TCP and UDP sockets. These options are automatically applied to the connection used.
Class | TcpBase | Base class for components utilizing protocols built upon the TCP protocol.
Class | TcpSession | Holds the configuration used by TCP.
Class | TcpSocketOption | Contains socket options that may be set by TCP sockets.
Class | Telnet | The Telnet component enables use of the Telnet protocol within any .NET application.
Class | UserStateEventArgs | Provides data for ComponentBase.UserState. Base class for EventArgs that have Message and UserState properties.
Class | Vt | Represents a terminal emulator used to display VT formatted data.
Class | VtKeyEventArgs | Provides data for the KeyDown event.

Structures

 | Structure | Description
Structure | Cell | Represents a single cell (occupied by a single character) on the Vt control.

Delegates

 | Delegate | Description
Delegate | TcpAsyncCallback | References the method to invoke on an IO completion thread when the corresponding asynchronous operation completes.

Enumerations

 | Enumeration | Description
Enumeration | AnsiColor.AnsiStyle | Enumeration of ANSI color schemes used by popular applications.
Enumeration | Command | Enumerates the TELNET protocol commands that can be sent.
Enumeration | ConnectionState | Enumerates the possible values of the connection state.
Enumeration | CursorKeys | Enumerates the values of the CursorKeys property. The cursor keys can be set up to provide ANSI cursor control or application control.
Enumeration | CursorStyle | Enumerates the values of the CursorStyle property.
Enumeration | DataDirection | Enumerates the direction of data flow.
Enumeration | KeyPad | Enumerates the values of the KeyPad property. The keypad can generate numeric values or application-specific values.
Enumeration | NationalCharSet | Enumerates the National Replacement Character Sets available for use by the Vt.NationalCharSet property.
Enumeration | NationalCharSetMode | Enumerates the modes available for the Vt.NationalCharSetMode property.
Enumeration | NewLine | Enumerates the end-of-line sequences sent to the host in response to an EOL character (ENTER key). Used by the NewLine property.
Enumeration | OptionCode | Enumerates the supported Telnet options.
Enumeration | OptionState | Enumerates the current state of an Option object.
Enumeration | PrintType | Enumerates the printing types used by the Vt control.
Enumeration | ProxyType | Enumerates the provided proxy support that can be used.
Enumeration | Scroll | Enumerates the values of the Vt.ScrollType property. The display screen can perform smooth scrolling or jump scrolling.
Enumeration | SelectionMode | Enumerates the values of the SelectionMode property.
Enumeration | Styles | Enumerates the styles for a cell. Used by the Cell.Styles property.
Enumeration | TerminalType | Enumerates the values of the TerminalType property.
Enumeration | VtKey | Enumerates non-printable VT characters, and keys that are sent to the server with escape sequences.

See Also

Reference

Dart.Emulation Assembly


AnsiColor Class

[image]
PowerTCP Emulation for .NET
AnsiColor Class
Members Example See Also Send comments on this topic
Dart.Emulation Namespace : AnsiColor Class

Glossary Item Box

Provides fine control of display colors. Includes eight "normal" and eight "bold" (aka "bright" or "light") colors.

Object Model

AnsiColor Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class AnsiColor
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
C#
[Serializable()]
public class AnsiColor
Managed Extensions for C++
[Serializable()]
public __gc class AnsiColor
C++/CLI
[Serializable()]
public ref class AnsiColor

Remarks

Set Style to use a pre-defined color scheme. Setting individual colors will automatically set Style to AnsiStyle.Custom.

Example

The following example demonstrates how set normal colors as an intensity percentage of bold colors.
C# Copy Code
private void updateColors(Vt vt, int intensity)
{
    //Update colors to a specified intensity (0-100).
    //0 is black and 100 is the bold color.
    int val = ((255 * intensity) / 100);
    vt.AnsiColor.BlackBold = Color.Gray;
    vt.AnsiColor.RedBold = Color.Red;
    vt.AnsiColor.GreenBold = Color.Lime;
    vt.AnsiColor.YellowBold = Color.Yellow;
    vt.AnsiColor.BlueBold = Color.Blue;
    vt.AnsiColor.MagentaBold = Color.Magenta;
    vt.AnsiColor.CyanBold = Color.Cyan;
    vt.AnsiColor.WhiteBold = Color.White;
    vt.AnsiColor.Black = Color.Black;
    vt.AnsiColor.Red = Color.FromArgb(val, 0, 0);
    vt.AnsiColor.Green = Color.FromArgb(0, val, 0);
    vt.AnsiColor.Yellow = Color.FromArgb(val, val, 0);
    vt.AnsiColor.Blue = Color.FromArgb(0, 0, val);
    vt.AnsiColor.Magenta = Color.FromArgb(val, 0, val);
    vt.AnsiColor.Cyan = Color.FromArgb(0, val, val);
    vt.AnsiColor.White = Color.FromArgb(val, val, val);
    vt.Refresh();
}
Visual Basic Copy Code
Private Sub updateColors(ByVal vt As Vt, ByVal intensity As Integer)
    'Update colors to a specified intensity (0-100).
    '0 is black and 100 is the bold color.
    Dim val As Integer = ((255 * intensity) / 100)
    vt.AnsiColor.BlackBold = Color.Gray
    vt.AnsiColor.RedBold = Color.Red
    vt.AnsiColor.GreenBold = Color.Lime
    vt.AnsiColor.YellowBold = Color.Yellow
    vt.AnsiColor.BlueBold = Color.Blue
    vt.AnsiColor.MagentaBold = Color.Magenta
    vt.AnsiColor.CyanBold = Color.Cyan
    vt.AnsiColor.WhiteBold = Color.White
    vt.AnsiColor.Black = Color.Black
    vt.AnsiColor.Red = Color.FromArgb(val, 0, 0)
    vt.AnsiColor.Green = Color.FromArgb(0, val, 0)
    vt.AnsiColor.Yellow = Color.FromArgb(val, val, 0)
    vt.AnsiColor.Blue = Color.FromArgb(0, 0, val)
    vt.AnsiColor.Magenta = Color.FromArgb(val, 0, val)
    vt.AnsiColor.Cyan = Color.FromArgb(0, val, val)
    vt.AnsiColor.White = Color.FromArgb(val, val, val)
    vt.Refresh()
End Sub

Inheritance Hierarchy

System.Object
Dart.Emulation.AnsiColor

See Also

Reference

AnsiColor Members
Dart.Emulation Namespace


AnsiColor Class Members

[image]
PowerTCP Emulation for .NET
AnsiColor Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : AnsiColor Class

Glossary Item Box

The following tables list the members exposed by AnsiColor.

Public Properties

 | Name | Description
Public Property | Black | Specifies the color to use for ANSI black.
Public Property | BlackBold | Specifies the color to use for ANSI light black.
Public Property | Blue | Specifies the color to use for ANSI blue.
Public Property | BlueBold | Specifies the color to use for ANSI bright blue.
Public Property | Cyan | Specifies the color to use for ANSI cyan.
Public Property | CyanBold | Specifies the color to use for ANSI bright cyan.
Public Property | Green | Specifies the color to use for ANSI green.
Public Property | GreenBold | Specifies the color to use for ANSI bright green.
Public Property | Magenta | Specifies the color to use for ANSI magenta.
Public Property | MagentaBold | Specifies the color to use for ANSI bright magenta.
Public Property | Red | Specifies the color to use for ANSI red.
Public Property | RedBold | Specifies the color to use for ANSI bright red.
Public Property | Style | ANSI color scheme used by the display. May be customized or based on other popular applications.
Public Property | White | Specifies the color to use for ANSI white.
Public Property | WhiteBold | Specifies the color to use for ANSI bright white.
Public Property | Yellow | Specifies the color to use for ANSI yellow/brown.
Public Property | YellowBold | Specifies the color to use for ANSI bright yellow/brown.
Top

See Also

Reference

AnsiColor Class
Dart.Emulation Namespace


AnsiColor Class Properties

[image]
PowerTCP Emulation for .NET
AnsiColor Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : AnsiColor Class

Glossary Item Box

For a list of all members of this type, see AnsiColor members.

Public Properties

 | Name | Description
Public Property | Black | Specifies the color to use for ANSI black.
Public Property | BlackBold | Specifies the color to use for ANSI light black.
Public Property | Blue | Specifies the color to use for ANSI blue.
Public Property | BlueBold | Specifies the color to use for ANSI bright blue.
Public Property | Cyan | Specifies the color to use for ANSI cyan.
Public Property | CyanBold | Specifies the color to use for ANSI bright cyan.
Public Property | Green | Specifies the color to use for ANSI green.
Public Property | GreenBold | Specifies the color to use for ANSI bright green.
Public Property | Magenta | Specifies the color to use for ANSI magenta.
Public Property | MagentaBold | Specifies the color to use for ANSI bright magenta.
Public Property | Red | Specifies the color to use for ANSI red.
Public Property | RedBold | Specifies the color to use for ANSI bright red.
Public Property | Style | ANSI color scheme used by the display. May be customized or based on other popular applications.
Public Property | White | Specifies the color to use for ANSI white.
Public Property | WhiteBold | Specifies the color to use for ANSI bright white.
Public Property | Yellow | Specifies the color to use for ANSI yellow/brown.
Public Property | YellowBold | Specifies the color to use for ANSI bright yellow/brown.
Top

See Also

Reference

AnsiColor Class
Dart.Emulation Namespace


Black Property

[image]
PowerTCP Emulation for .NET
Black Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : Black Property

Glossary Item Box

Specifies the color to use for ANSI black.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Black As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.Black = value

value = instance.Black
C#
[DefaultValue()]
public Color Black {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_Black();
public: __property void set_Black(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color Black {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


BlackBold Property

[image]
PowerTCP Emulation for .NET
BlackBold Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : BlackBold Property

Glossary Item Box

Specifies the color to use for ANSI light black.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property BlackBold As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.BlackBold = value

value = instance.BlackBold
C#
[DefaultValue()]
public Color BlackBold {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_BlackBold();
public: __property void set_BlackBold(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color BlackBold {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


Blue Property

[image]
PowerTCP Emulation for .NET
Blue Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : Blue Property

Glossary Item Box

Specifies the color to use for ANSI blue.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Blue As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.Blue = value

value = instance.Blue
C#
[DefaultValue()]
public Color Blue {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_Blue();
public: __property void set_Blue(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color Blue {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


BlueBold Property

[image]
PowerTCP Emulation for .NET
BlueBold Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : BlueBold Property

Glossary Item Box

Specifies the color to use for ANSI bright blue.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property BlueBold As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.BlueBold = value

value = instance.BlueBold
C#
[DefaultValue()]
public Color BlueBold {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_BlueBold();
public: __property void set_BlueBold(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color BlueBold {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


Cyan Property

[image]
PowerTCP Emulation for .NET
Cyan Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : Cyan Property

Glossary Item Box

Specifies the color to use for ANSI cyan.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Cyan As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.Cyan = value

value = instance.Cyan
C#
[DefaultValue()]
public Color Cyan {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_Cyan();
public: __property void set_Cyan(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color Cyan {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


CyanBold Property

[image]
PowerTCP Emulation for .NET
CyanBold Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : CyanBold Property

Glossary Item Box

Specifies the color to use for ANSI bright cyan.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CyanBold As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.CyanBold = value

value = instance.CyanBold
C#
[DefaultValue()]
public Color CyanBold {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_CyanBold();
public: __property void set_CyanBold(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color CyanBold {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


Green Property

[image]
PowerTCP Emulation for .NET
Green Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : Green Property

Glossary Item Box

Specifies the color to use for ANSI green.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Green As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.Green = value

value = instance.Green
C#
[DefaultValue()]
public Color Green {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_Green();
public: __property void set_Green(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color Green {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


GreenBold Property

[image]
PowerTCP Emulation for .NET
GreenBold Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : GreenBold Property

Glossary Item Box

Specifies the color to use for ANSI bright green.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property GreenBold As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.GreenBold = value

value = instance.GreenBold
C#
[DefaultValue()]
public Color GreenBold {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_GreenBold();
public: __property void set_GreenBold(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color GreenBold {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


Magenta Property

[image]
PowerTCP Emulation for .NET
Magenta Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : Magenta Property

Glossary Item Box

Specifies the color to use for ANSI magenta.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Magenta As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.Magenta = value

value = instance.Magenta
C#
[DefaultValue()]
public Color Magenta {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_Magenta();
public: __property void set_Magenta(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color Magenta {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


MagentaBold Property

[image]
PowerTCP Emulation for .NET
MagentaBold Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : MagentaBold Property

Glossary Item Box

Specifies the color to use for ANSI bright magenta.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property MagentaBold As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.MagentaBold = value

value = instance.MagentaBold
C#
[DefaultValue()]
public Color MagentaBold {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_MagentaBold();
public: __property void set_MagentaBold(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color MagentaBold {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


Red Property

[image]
PowerTCP Emulation for .NET
Red Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : Red Property

Glossary Item Box

Specifies the color to use for ANSI red.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Red As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.Red = value

value = instance.Red
C#
[DefaultValue()]
public Color Red {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_Red();
public: __property void set_Red(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color Red {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


RedBold Property

[image]
PowerTCP Emulation for .NET
RedBold Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : RedBold Property

Glossary Item Box

Specifies the color to use for ANSI bright red.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property RedBold As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.RedBold = value

value = instance.RedBold
C#
[DefaultValue()]
public Color RedBold {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_RedBold();
public: __property void set_RedBold(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color RedBold {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


Style Property

[image]
PowerTCP Emulation for .NET
Style Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : Style Property

Glossary Item Box

ANSI color scheme used by the display. May be customized or based on other popular applications.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Style As AnsiColor.AnsiStyle
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As AnsiColor.AnsiStyle

instance.Style = value

value = instance.Style
C#
[DefaultValue()]
public AnsiColor.AnsiStyle Style {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property AnsiColor.AnsiStyle get_Style();
public: __property void set_Style(
   AnsiColor.AnsiStyle value
);
C++/CLI
[DefaultValue()]
public:
property AnsiColor.AnsiStyle Style {
   AnsiColor.AnsiStyle get();
   void set (    AnsiColor.AnsiStyle value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


White Property

[image]
PowerTCP Emulation for .NET
White Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : White Property

Glossary Item Box

Specifies the color to use for ANSI white.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property White As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.White = value

value = instance.White
C#
[DefaultValue()]
public Color White {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_White();
public: __property void set_White(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color White {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


WhiteBold Property

[image]
PowerTCP Emulation for .NET
WhiteBold Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : WhiteBold Property

Glossary Item Box

Specifies the color to use for ANSI bright white.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property WhiteBold As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.WhiteBold = value

value = instance.WhiteBold
C#
[DefaultValue()]
public Color WhiteBold {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_WhiteBold();
public: __property void set_WhiteBold(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color WhiteBold {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


Yellow Property

[image]
PowerTCP Emulation for .NET
Yellow Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : Yellow Property

Glossary Item Box

Specifies the color to use for ANSI yellow/brown.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Yellow As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.Yellow = value

value = instance.Yellow
C#
[DefaultValue()]
public Color Yellow {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_Yellow();
public: __property void set_Yellow(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color Yellow {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


YellowBold Property

[image]
PowerTCP Emulation for .NET
YellowBold Property
See Also Send comments on this topic
Dart.Emulation Namespace > AnsiColor Class : YellowBold Property

Glossary Item Box

Specifies the color to use for ANSI bright yellow/brown.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property YellowBold As Color
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor
Dim value As Color

instance.YellowBold = value

value = instance.YellowBold
C#
[DefaultValue()]
public Color YellowBold {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_YellowBold();
public: __property void set_YellowBold(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color YellowBold {
   Color get();
   void set (    Color value);
}

See Also

Reference

AnsiColor Class
AnsiColor Members


ClientSecurity Class

[image]
PowerTCP Emulation for .NET
ClientSecurity Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : ClientSecurity Class

Glossary Item Box

Holds the configuration used to establish an SSL client session.

Object Model

ClientSecurity Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class ClientSecurity
   Inherits Security
Visual Basic (Usage) Copy Code
Dim instance As ClientSecurity
C#
[Serializable()]
public class ClientSecurity : Security
Managed Extensions for C++
[Serializable()]
public __gc class ClientSecurity : public Security
C++/CLI
[Serializable()]
public ref class ClientSecurity : public Security

Inheritance Hierarchy

System.Object
Dart.Emulation.Security
Dart.Emulation.ClientSecurity

See Also

Reference

ClientSecurity Members
Dart.Emulation Namespace


ClientSecurity Class Members

[image]
PowerTCP Emulation for .NET
ClientSecurity Class Members
See Also Fields Properties Send comments on this topic
Dart.Emulation Namespace : ClientSecurity Class

Glossary Item Box

The following tables list the members exposed by ClientSecurity.

Public Constructors

 | Name | Description
Public Constructor | ClientSecurity Constructor | The default constructor for ClientSecurity
Top

Public Fields

 | Name | Description
Public Field | SelectionCallback | The delegate that executes to permit selection of a cient certificate.
Public Field | ValidationCallback | The delegate that executes after the server provides its certificate to the client. (Inherited from Dart.Emulation.Security)
Top

Public Properties

 | Name | Description
Public Property | Certificates | Gets or sets a collection of client certificates to use during authentication.
Public Property | CheckCertificateRevocation | Indicates whether the certificate revocation list is checked during authentication. (Inherited from Dart.Emulation.Security)
Public Property | Protocols | Gets or sets the SSLProtocols available. (Inherited from Dart.Emulation.Security)
Public Property | TargetHost | Gets or sets the remote host to be authenticated.
Top

See Also

Reference

ClientSecurity Class
Dart.Emulation Namespace


ClientSecurity Constructor

[image]
PowerTCP Emulation for .NET
ClientSecurity Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > ClientSecurity Class : ClientSecurity Constructor

Glossary Item Box

The default constructor for ClientSecurity

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ClientSecurity()
C#
public ClientSecurity()
Managed Extensions for C++
public: ClientSecurity();
C++/CLI
public:
ClientSecurity();

See Also

Reference

ClientSecurity Class
ClientSecurity Members


ClientSecurity Class Properties

[image]
PowerTCP Emulation for .NET
ClientSecurity Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : ClientSecurity Class

Glossary Item Box

For a list of all members of this type, see ClientSecurity members.

Public Properties

 | Name | Description
Public Property | Certificates | Gets or sets a collection of client certificates to use during authentication.
Public Property | CheckCertificateRevocation | Indicates whether the certificate revocation list is checked during authentication. (Inherited from Dart.Emulation.Security)
Public Property | Protocols | Gets or sets the SSLProtocols available. (Inherited from Dart.Emulation.Security)
Public Property | TargetHost | Gets or sets the remote host to be authenticated.
Top

See Also

Reference

ClientSecurity Class
Dart.Emulation Namespace


Certificates Property

[image]
PowerTCP Emulation for .NET
Certificates Property
See Also Send comments on this topic
Dart.Emulation Namespace > ClientSecurity Class : Certificates Property

Glossary Item Box

Gets or sets a collection of client certificates to use during authentication.

Syntax

Visual Basic (Declaration)
Public Property Certificates As X509CertificateCollection
Visual Basic (Usage) Copy Code
Dim instance As ClientSecurity
Dim value As X509CertificateCollection

instance.Certificates = value

value = instance.Certificates
C#
public X509CertificateCollection Certificates {get; set;}
Managed Extensions for C++
public: __property X509CertificateCollection* get_Certificates();
public: __property void set_Certificates(
   X509CertificateCollection* value
);
C++/CLI
public:
property X509CertificateCollection^ Certificates {
   X509CertificateCollection^ get();
   void set (    X509CertificateCollection^ value);
}

Remarks

If SelectionCallback is not null, the certificate chosen in the delegate will supercede any certificate present in this collection.

The first certificate in this collection that passes Microsoft's validation checks will be used during authentication.

See Also

Reference

ClientSecurity Class
ClientSecurity Members


TargetHost Property

[image]
PowerTCP Emulation for .NET
TargetHost Property
See Also Send comments on this topic
Dart.Emulation Namespace > ClientSecurity Class : TargetHost Property

Glossary Item Box

Gets or sets the remote host to be authenticated.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TargetHost As String
Visual Basic (Usage) Copy Code
Dim instance As ClientSecurity
Dim value As String

instance.TargetHost = value

value = instance.TargetHost
C#
[DefaultValue()]
public string TargetHost {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property string* get_TargetHost();
public: __property void set_TargetHost(
   string* value
);
C++/CLI
[DefaultValue()]
public:
property String^ TargetHost {
   String^ get();
   void set (    String^ value);
}

Remarks

Used internally as the first parameter for SslStream.AuthenticateAsClient(), it will typically match the common name of the server-side certificate. .NET also uses this value to maintain an internal cache of SSL sessions that can be re-used.

If left empty, the value of the configured RemoteEndPoint.HostNameOrAddress will be used for authentication.

See Also

Reference

ClientSecurity Class
ClientSecurity Members


ClientSecurity Class Fields

[image]
PowerTCP Emulation for .NET
ClientSecurity Class Fields
See Also Send comments on this topic
Dart.Emulation Namespace : ClientSecurity Class

Glossary Item Box

For a list of all members of this type, see ClientSecurity members.

Public Fields

 | Name | Description
Public Field | SelectionCallback | The delegate that executes to permit selection of a cient certificate.
Public Field | ValidationCallback | The delegate that executes after the server provides its certificate to the client. (Inherited from Dart.Emulation.Security)
Top

See Also

Reference

ClientSecurity Class
Dart.Emulation Namespace


SelectionCallback Field

[image]
PowerTCP Emulation for .NET
SelectionCallback Field
See Also Send comments on this topic
Dart.Emulation Namespace > ClientSecurity Class : SelectionCallback Field

Glossary Item Box

The delegate that executes to permit selection of a cient certificate.

Syntax

Visual Basic (Declaration)
Public SelectionCallback As LocalCertificateSelectionCallback
Visual Basic (Usage) Copy Code
Dim instance As ClientSecurity
Dim value As LocalCertificateSelectionCallback

value = instance.SelectionCallback

instance.SelectionCallback = value
C#
public LocalCertificateSelectionCallback SelectionCallback
Managed Extensions for C++
public: LocalCertificateSelectionCallback* SelectionCallback
C++/CLI
public:
LocalCertificateSelectionCallback^ SelectionCallback

Remarks

If null, the Certificates collection will be examined for a valid certifiate.

The certificate returned in this delegate will supercede any certificate present in the Certificates collection.

See Also

Reference

ClientSecurity Class
ClientSecurity Members


CommandEventArgs Class

[image]
PowerTCP Emulation for .NET
CommandEventArgs Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : CommandEventArgs Class

Glossary Item Box

Contains Telnet command event data.

Object Model

CommandEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class CommandEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
C#
public class CommandEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class CommandEventArgs : public System.EventArgs
C++/CLI
public ref class CommandEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Emulation.CommandEventArgs

See Also

Reference

CommandEventArgs Members
Dart.Emulation Namespace


CommandEventArgs Class Members

[image]
PowerTCP Emulation for .NET
CommandEventArgs Class Members
See Also Properties Methods Send comments on this topic
Dart.Emulation Namespace : CommandEventArgs Class

Glossary Item Box

The following tables list the members exposed by CommandEventArgs.

Public Properties

 | Name | Description
Public Property | Command | The command sent by the remote host.
Public Property | OptionCode | The option pertaining to the received command.
Public Property | SubOption | Suboption pertaining to the received command.
Top

Public Methods

 | Name | Description
Public Method | ToString | A readable string representing the command.
Top

See Also

Reference

CommandEventArgs Class
Dart.Emulation Namespace


CommandEventArgs Class Methods

[image]
PowerTCP Emulation for .NET
CommandEventArgs Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : CommandEventArgs Class

Glossary Item Box

For a list of all members of this type, see CommandEventArgs members.

Public Methods

 | Name | Description
Public Method | ToString | A readable string representing the command.
Top

See Also

Reference

CommandEventArgs Class
Dart.Emulation Namespace


ToString Method

[image]
PowerTCP Emulation for .NET
ToString Method
See Also Send comments on this topic
Dart.Emulation Namespace > CommandEventArgs Class : ToString Method

Glossary Item Box

A readable string representing the command.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string containing the command, option and suboption.

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


CommandEventArgs Class Properties

[image]
PowerTCP Emulation for .NET
CommandEventArgs Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : CommandEventArgs Class

Glossary Item Box

For a list of all members of this type, see CommandEventArgs members.

Public Properties

 | Name | Description
Public Property | Command | The command sent by the remote host.
Public Property | OptionCode | The option pertaining to the received command.
Public Property | SubOption | Suboption pertaining to the received command.
Top

See Also

Reference

CommandEventArgs Class
Dart.Emulation Namespace


Command Property

[image]
PowerTCP Emulation for .NET
Command Property
See Also Send comments on this topic
Dart.Emulation Namespace > CommandEventArgs Class : Command Property

Glossary Item Box

The command sent by the remote host.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Command As Command
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value As Command

value = instance.Command
C#
public Command Command {get;}
Managed Extensions for C++
public: __property Command get_Command();
C++/CLI
public:
property Command Command {
   Command get();
}

Remarks

This property represents the command sent by the remote host. For example, if the command from the server was a DO ECHO command (asking the client to enable echoing), this property will be set to Command.Do.

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


OptionCode Property

[image]
PowerTCP Emulation for .NET
OptionCode Property
See Also Send comments on this topic
Dart.Emulation Namespace > CommandEventArgs Class : OptionCode Property

Glossary Item Box

The option pertaining to the received command.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OptionCode As OptionCode
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value As OptionCode

value = instance.OptionCode
C#
public OptionCode OptionCode {get;}
Managed Extensions for C++
public: __property OptionCode get_OptionCode();
C++/CLI
public:
property OptionCode OptionCode {
   OptionCode get();
}

Remarks

This property represents the option to which the command pertains. For example, if the command from the server was a DO ECHO command (asking the client to enable echoing) this property would be set to OptionCode.Echo.

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


SubOption Property

[image]
PowerTCP Emulation for .NET
SubOption Property
See Also Send comments on this topic
Dart.Emulation Namespace > CommandEventArgs Class : SubOption Property

Glossary Item Box

Suboption pertaining to the received command.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SubOption As Byte()
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value() As Byte

value = instance.SubOption
C#
public byte[] SubOption {get;}
Managed Extensions for C++
public: __property byte[]* get_SubOption();
C++/CLI
public:
property array<byte>^ SubOption {
   array<byte>^ get();
}

Property Value

A byte array containing formatted data associated with the option.

Remarks

This property contains optional suboption data. Suboption usage is specific to a limited number of options. For the exact format of the suboption data, refer to the RFC that documents the option in question.

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


ComponentBase Class

[image]
PowerTCP Emulation for .NET
ComponentBase Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : ComponentBase Class

Glossary Item Box

Base class for PowerTCP Components.

Object Model

ComponentBase Class

Syntax

Visual Basic (Declaration)
Public Class ComponentBase
   Inherits System.ComponentModel.Component
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
C#
public class ComponentBase : System.ComponentModel.Component
Managed Extensions for C++
public __gc class ComponentBase : public System.ComponentModel.Component
C++/CLI
public ref class ComponentBase : public System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Emulation.ComponentBase
Dart.Emulation.SocketBase

See Also

Reference

ComponentBase Members
Dart.Emulation Namespace


ComponentBase Class Members

[image]
PowerTCP Emulation for .NET
ComponentBase Class Members
See Also Properties Methods Events Send comments on this topic
Dart.Emulation Namespace : ComponentBase Class

Glossary Item Box

The following tables list the members exposed by ComponentBase.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events).
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use.
Public Property | Tag | Gets or sets an object that stores any user data.
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object.
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals a string and/or object to the UI thread and raises the UserState event.
Public Method | Serialize | Serialize an object to the provided destination stream.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start.
Public Event | UserState | Raised when Marshal(String,Object) is used.
Top

See Also

Reference

ComponentBase Class
Dart.Emulation Namespace


ComponentBase Class Methods

[image]
PowerTCP Emulation for .NET
ComponentBase Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : ComponentBase Class

Glossary Item Box

For a list of all members of this type, see ComponentBase members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object.
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals a string and/or object to the UI thread and raises the UserState event.
Public Method | Serialize | Serialize an object to the provided destination stream.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ComponentBase Class
Dart.Emulation Namespace


Deserialize Method

[image]
PowerTCP Emulation for .NET
Deserialize Method
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class : Deserialize Method

serializedObject
A stream containing the serialized data to deserialize.

Glossary Item Box

Deserialize a previously serialized object.

Syntax

Visual Basic (Declaration)
Public Function Deserialize( _
   ByVal serializedObject As Stream _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim serializedObject As Stream
Dim value As Object

value = instance.Deserialize(serializedObject)
C#
public object Deserialize(
   Stream serializedObject
)
Managed Extensions for C++
public: Object* Deserialize(
   Stream* serializedObject
)
C++/CLI
public:
Object^ Deserialize(
   Stream^ serializedObject
)

Parameters

serializedObject
A stream containing the serialized data to deserialize.

Return Value

The deserialized object.

Remarks

Provides a simple mechanism for restoring a previously serialized state. For example, the state (all runtime parameters) of a Session object could be saved. The provided serializedObject is read from its current position.

See Also

Reference

ComponentBase Class
ComponentBase Members


Marshal Method

[image]
PowerTCP Emulation for .NET
Marshal Method
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class : Marshal Method

Glossary Item Box

Marshals a string and/or object to the UI thread and raises the UserState event.

Overload List

Overload | Description
Marshal(String,Object) | Marshals a string and/or object to the UI thread and raises the UserState event.
Marshal(Exception) | Marshals an exception to the UI thread and raises the Error event.

See Also

Reference

ComponentBase Class
ComponentBase Members


Marshal(String,Object) Method

[image]
PowerTCP Emulation for .NET
Marshal(String,Object) Method
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class > Marshal Method : Marshal(String,Object) Method

message
Message to pass into the UserState event.
state
Object to pass to the UserState event; can be null.

Glossary Item Box

Marshals a string and/or object to the UI thread and raises the UserState event.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal message As String, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim message As String
Dim state As Object

instance.Marshal(message, state)
C#
public void Marshal(
   string message,
   object state
)
Managed Extensions for C++
public: void Marshal(
   string* message,
   Object* state
)
C++/CLI
public:
void Marshal(
   String^ message,
   Object^ state
)

Parameters

message
Message to pass into the UserState event.
state
Object to pass to the UserState event; can be null.

Remarks

Used to marshal a string and/or object from a worker thread to the UI thread for typical display purposes. It calls OnUserState, which raises the UserState event.

See the SynchronizingObject property for information on updating UI controls in your event handler. Internally, SynchronizingObject.BeginInvoke is used to marshal data when the SynchronizingObject is not null, and Delegate.DynamicInvoke is used when SynchronizingObject is null. This method is provided for convenience; the developer may use alternative methods for marshaling data as required.

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


Marshal(Exception) Method

[image]
PowerTCP Emulation for .NET
Marshal(Exception) Method
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class > Marshal Method : Marshal(Exception) Method

exception
The Exception to be marshaled.

Glossary Item Box

Marshals an exception to the UI thread and raises the Error event.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim exception As Exception

instance.Marshal(exception)
C#
public void Marshal(
   Exception exception
)
Managed Extensions for C++
public: void Marshal(
   Exception* exception
)
C++/CLI
public:
void Marshal(
   Exception^ exception
)

Parameters

exception
The Exception to be marshaled.

Remarks

Used to marshal exceptions from a worker thread to the UI thread for typical display purposes. It calls OnError, which raises the Error event.

When Start is used, unhandled exceptions generated on worker threads are marshaled to the UI thread by this method.

See the SynchronizingObject property for information on updating UI controls in your event handler. Internally, SynchronizingObject.BeginInvoke is used to marshal data when the SynchronizingObject is not null, and Delegate.DynamicInvoke is used when SynchronizingObject is null. This method is provided for convenience; the developer may use alternative methods for marshaling data as required.

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


Serialize Method

[image]
PowerTCP Emulation for .NET
Serialize Method
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class : Serialize Method

objectToSerialize
Object to serialize.
destination
Stream destination for the serialized data.

Glossary Item Box

Serialize an object to the provided destination stream.

Syntax

Visual Basic (Declaration)
Public Sub Serialize( _
   ByVal objectToSerialize As Object, _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim objectToSerialize As Object
Dim destination As Stream

instance.Serialize(objectToSerialize, destination)
C#
public void Serialize(
   object objectToSerialize,
   Stream destination
)
Managed Extensions for C++
public: void Serialize(
   Object* objectToSerialize,
   Stream* destination
)
C++/CLI
public:
void Serialize(
   Object^ objectToSerialize,
   Stream^ destination
)

Parameters

objectToSerialize
Object to serialize.
destination
Stream destination for the serialized data.

Remarks

Can be used at runtime to persist the state of an object. For example, all runtime parameters of a Session object could be saved.

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Properties

[image]
PowerTCP Emulation for .NET
ComponentBase Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : ComponentBase Class

Glossary Item Box

For a list of all members of this type, see ComponentBase members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events).
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use.
Public Property | Tag | Gets or sets an object that stores any user data.
Top

See Also

Reference

ComponentBase Class
Dart.Emulation Namespace


Encoding Property

[image]
PowerTCP Emulation for .NET
Encoding Property
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class : Encoding Property

Glossary Item Box

Character encoding used by the component.

Syntax

Visual Basic (Declaration)
Public Overridable Property Encoding As Encoding
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Encoding

instance.Encoding = value

value = instance.Encoding
C#
public virtual Encoding Encoding {get; set;}
Managed Extensions for C++
public: __property virtual Encoding* get_Encoding();
public: __property virtual void set_Encoding(
   Encoding* value
);
C++/CLI
public:
virtual property Encoding^ Encoding {
   Encoding^ get();
   void set (    Encoding^ value);
}

See Also

Reference

ComponentBase Class
ComponentBase Members


SynchronizingObject Property

[image]
PowerTCP Emulation for .NET
SynchronizingObject Property
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class : SynchronizingObject Property

Glossary Item Box

Gets or sets the object used to marshal data to the UI thread (for raising events).

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SynchronizingObject As ISynchronizeInvoke
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As ISynchronizeInvoke

instance.SynchronizingObject = value

value = instance.SynchronizingObject
C#
[DefaultValue()]
public ISynchronizeInvoke SynchronizingObject {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property ISynchronizeInvoke* get_SynchronizingObject();
public: __property void set_SynchronizingObject(
   ISynchronizeInvoke* value
);
C++/CLI
[DefaultValue()]
public:
property ISynchronizeInvoke^ SynchronizingObject {
   ISynchronizeInvoke^ get();
   void set (    ISynchronizeInvoke^ value);
}

Remarks

This property determines the thread on which the component's event handlers are raised. If set to a UI control, events are raised on the UI thread. If null, events are raised on the current thread.

This property is automatically set to the containing control when used in the Windows Forms designer. When a derived class is dynamically created this property must be set if marshaling to the UI thread is desired.

See Also

Reference

ComponentBase Class
ComponentBase Members


SyncRoot Property

[image]
PowerTCP Emulation for .NET
SyncRoot Property
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class : SyncRoot Property

Glossary Item Box

Gets an object that is used to synchronize access to the upper layer protocol in use.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Remarks

Upper layer protocols typically send a command and wait for it to complete. Use of this object in a C# "lock" statement can allow your code to wait until any ongoing command has completed.

See Also

Reference

ComponentBase Class
ComponentBase Members


Tag Property

[image]
PowerTCP Emulation for .NET
Tag Property
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class : Tag Property

Glossary Item Box

Gets or sets an object that stores any user data.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[DefaultValue()]
public object Tag {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[DefaultValue()]
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Events

[image]
PowerTCP Emulation for .NET
ComponentBase Class Events
See Also Send comments on this topic
Dart.Emulation Namespace : ComponentBase Class

Glossary Item Box

For a list of all members of this type, see ComponentBase members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start.
Public Event | UserState | Raised when Marshal(String,Object) is used.
Top

See Also

Reference

ComponentBase Class
Dart.Emulation Namespace


Error Event

[image]
PowerTCP Emulation for .NET
Error Event
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class : Error Event

Glossary Item Box

Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start.

Syntax

Visual Basic (Declaration)
Public Event Error As EventHandler(Of ErrorEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim handler As EventHandler(Of ErrorEventArgs)

AddHandler instance.Error, handler
C#
public event EventHandler<ErrorEventArgs> Error
Managed Extensions for C++
public: __event EventHandler<ErrorEventArgs*>* Error
C++/CLI
public:
event EventHandler<ErrorEventArgs^>^ Error

Remarks

See the SynchronizingObject property for information on updating UI controls in your event handler.

See Also

Reference

ComponentBase Class
ComponentBase Members


UserState Event

[image]
PowerTCP Emulation for .NET
UserState Event
See Also Send comments on this topic
Dart.Emulation Namespace > ComponentBase Class : UserState Event

Glossary Item Box

Raised when Marshal(String,Object) is used.

Syntax

Visual Basic (Declaration)
Public Event UserState As EventHandler(Of UserStateEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim handler As EventHandler(Of UserStateEventArgs)

AddHandler instance.UserState, handler
C#
public event EventHandler<UserStateEventArgs> UserState
Managed Extensions for C++
public: __event EventHandler<UserStateEventArgs*>* UserState
C++/CLI
public:
event EventHandler<UserStateEventArgs^>^ UserState

Event Data

The event handler receives an argument of type UserStateEventArgs containing data related to this event. The following UserStateEventArgs properties provide information specific to this event.

Property | Description
Message | Returns the message argument provided by the Marshal method.
UserState | Returns the user state argument provided by the Marshal method.

Remarks

See the SynchronizingObject property for information on updating UI controls in your event handler.

See Also

Reference

ComponentBase Class
ComponentBase Members


Credentials Class

[image]
PowerTCP Emulation for .NET
Credentials Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Credentials Class

Glossary Item Box

Provides a holder for parameters used to login to a remote host.

Object Model

Credentials Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class Credentials
Visual Basic (Usage) Copy Code
Dim instance As Credentials
C#
[Serializable()]
public class Credentials
Managed Extensions for C++
[Serializable()]
public __gc class Credentials
C++/CLI
[Serializable()]
public ref class Credentials

Inheritance Hierarchy

System.Object
Dart.Emulation.Credentials

See Also

Reference

Credentials Members
Dart.Emulation Namespace


Credentials Class Members

[image]
PowerTCP Emulation for .NET
Credentials Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : Credentials Class

Glossary Item Box

The following tables list the members exposed by Credentials.

Public Constructors

 | Name | Description
Public Constructor | Credentials Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CommandPrompt | Defines the command prompt to look for after login. An empty string indicates the Login should return immediately.
Public Property | Password | Defines the password used during login.
Public Property | PasswordPrompt | Defines the password prompt to look for after login.
Public Property | PromptTimeout | Defines the timeout period while waiting for prompts to be read.
Public Property | Username | Defines the username used during login.
Public Property | UsernamePrompt | Defines the username prompt to look for during login.
Top

See Also

Reference

Credentials Class
Dart.Emulation Namespace


Credentials Constructor

[image]
PowerTCP Emulation for .NET
Credentials Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Credentials Class : Credentials Constructor

Glossary Item Box

Overload List

Overload | Description
Credentials Constructor() | Default constructor for Credentials.
Credentials Constructor(String,String,String) | Constructor for Credentials with username, password and command prompt parameters.

See Also

Reference

Credentials Class
Credentials Members


Credentials Constructor()

[image]
PowerTCP Emulation for .NET
Credentials Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > Credentials Class > Credentials Constructor : Credentials Constructor()

Glossary Item Box

Default constructor for Credentials.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Credentials()
C#
public Credentials()
Managed Extensions for C++
public: Credentials();
C++/CLI
public:
Credentials();

See Also

Reference

Credentials Class
Credentials Members
Overload List


Credentials Constructor(String,String,String)

[image]
PowerTCP Emulation for .NET
Credentials Constructor(String,String,String)
See Also Send comments on this topic
Dart.Emulation Namespace > Credentials Class > Credentials Constructor : Credentials Constructor(String,String,String)

username
The username used during login.
password
The password used during login.
commandPrompt
The command prompt to look for after login.

Glossary Item Box

Constructor for Credentials with username, password and command prompt parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal username As String, _
   ByVal password As String, _
   ByVal commandPrompt As String _
)
Visual Basic (Usage) Copy Code
Dim username As String
Dim password As String
Dim commandPrompt As String

Dim instance As New Credentials(username, password, commandPrompt)
C#
public Credentials(
   string username,
   string password,
   string commandPrompt
)
Managed Extensions for C++
public: Credentials(
   string* username,
   string* password,
   string* commandPrompt
)
C++/CLI
public:
Credentials(
   String^ username,
   String^ password,
   String^ commandPrompt
)

Parameters

username
The username used during login.
password
The password used during login.
commandPrompt
The command prompt to look for after login.

See Also

Reference

Credentials Class
Credentials Members
Overload List


Credentials Class Properties

[image]
PowerTCP Emulation for .NET
Credentials Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Credentials Class

Glossary Item Box

For a list of all members of this type, see Credentials members.

Public Properties

 | Name | Description
Public Property | CommandPrompt | Defines the command prompt to look for after login. An empty string indicates the Login should return immediately.
Public Property | Password | Defines the password used during login.
Public Property | PasswordPrompt | Defines the password prompt to look for after login.
Public Property | PromptTimeout | Defines the timeout period while waiting for prompts to be read.
Public Property | Username | Defines the username used during login.
Public Property | UsernamePrompt | Defines the username prompt to look for during login.
Top

See Also

Reference

Credentials Class
Dart.Emulation Namespace


CommandPrompt Property

[image]
PowerTCP Emulation for .NET
CommandPrompt Property
See Also Send comments on this topic
Dart.Emulation Namespace > Credentials Class : CommandPrompt Property

Glossary Item Box

Defines the command prompt to look for after login. An empty string indicates the Login should return immediately.

Syntax

Visual Basic (Declaration)
Public Property CommandPrompt As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.CommandPrompt = value

value = instance.CommandPrompt
C#
public string CommandPrompt {get; set;}
Managed Extensions for C++
public: __property string* get_CommandPrompt();
public: __property void set_CommandPrompt(
   string* value
);
C++/CLI
public:
property String^ CommandPrompt {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


Password Property

[image]
PowerTCP Emulation for .NET
Password Property
See Also Send comments on this topic
Dart.Emulation Namespace > Credentials Class : Password Property

Glossary Item Box

Defines the password used during login.

Syntax

Visual Basic (Declaration)
Public Property Password As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.Password = value

value = instance.Password
C#
public string Password {get; set;}
Managed Extensions for C++
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
C++/CLI
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


PasswordPrompt Property

[image]
PowerTCP Emulation for .NET
PasswordPrompt Property
See Also Send comments on this topic
Dart.Emulation Namespace > Credentials Class : PasswordPrompt Property

Glossary Item Box

Defines the password prompt to look for after login.

Syntax

Visual Basic (Declaration)
Public Property PasswordPrompt As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.PasswordPrompt = value

value = instance.PasswordPrompt
C#
public string PasswordPrompt {get; set;}
Managed Extensions for C++
public: __property string* get_PasswordPrompt();
public: __property void set_PasswordPrompt(
   string* value
);
C++/CLI
public:
property String^ PasswordPrompt {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


PromptTimeout Property

[image]
PowerTCP Emulation for .NET
PromptTimeout Property
See Also Send comments on this topic
Dart.Emulation Namespace > Credentials Class : PromptTimeout Property

Glossary Item Box

Defines the timeout period while waiting for prompts to be read.

Syntax

Visual Basic (Declaration)
Public Property PromptTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As Integer

instance.PromptTimeout = value

value = instance.PromptTimeout
C#
public int PromptTimeout {get; set;}
Managed Extensions for C++
public: __property int get_PromptTimeout();
public: __property void set_PromptTimeout(
   int value
);
C++/CLI
public:
property int PromptTimeout {
   int get();
   void set (    int value);
}

Property Value

The default value is 6000 (ms).

Remarks

This property overrides SocketOption.ReceiveTimeout during the Login call.

See Also

Reference

Credentials Class
Credentials Members


Username Property

[image]
PowerTCP Emulation for .NET
Username Property
See Also Send comments on this topic
Dart.Emulation Namespace > Credentials Class : Username Property

Glossary Item Box

Defines the username used during login.

Syntax

Visual Basic (Declaration)
Public Property Username As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.Username = value

value = instance.Username
C#
public string Username {get; set;}
Managed Extensions for C++
public: __property string* get_Username();
public: __property void set_Username(
   string* value
);
C++/CLI
public:
property String^ Username {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


UsernamePrompt Property

[image]
PowerTCP Emulation for .NET
UsernamePrompt Property
See Also Send comments on this topic
Dart.Emulation Namespace > Credentials Class : UsernamePrompt Property

Glossary Item Box

Defines the username prompt to look for during login.

Syntax

Visual Basic (Declaration)
Public Property UsernamePrompt As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.UsernamePrompt = value

value = instance.UsernamePrompt
C#
public string UsernamePrompt {get; set;}
Managed Extensions for C++
public: __property string* get_UsernamePrompt();
public: __property void set_UsernamePrompt(
   string* value
);
C++/CLI
public:
property String^ UsernamePrompt {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


DartLicenseException Class

[image]
PowerTCP Emulation for .NET
DartLicenseException Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : DartLicenseException Class

Glossary Item Box

The base class for all Dart component license exceptions.

Object Model

DartLicenseException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class DartLicenseException
   Inherits System.Exception
Visual Basic (Usage) Copy Code
Dim instance As DartLicenseException
C#
[Serializable()]
public class DartLicenseException : System.Exception
Managed Extensions for C++
[Serializable()]
public __gc class DartLicenseException : public System.Exception
C++/CLI
[Serializable()]
public ref class DartLicenseException : public System.Exception

Remarks

Use the DartLicenseException class to catch runtime licensing exceptions. These exceptions are thrown at component creation time and during access of select properties or methods. The Message property will provide a description of the specific licensing problem encountered. The InnerException property should also be examined for additional details.

Inheritance Hierarchy

System.Object
System.Exception
Dart.Emulation.DartLicenseException

See Also

Reference

DartLicenseException Members
Dart.Emulation Namespace


DartLicenseException Class Members

[image]
PowerTCP Emulation for .NET
DartLicenseException Class Members
See Also Properties Methods Send comments on this topic
Dart.Emulation Namespace : DartLicenseException Class

Glossary Item Box

The following tables list the members exposed by DartLicenseException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Emulation Namespace


Data Class

[image]
PowerTCP Emulation for .NET
Data Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Data Class

Glossary Item Box

Encapsulates data read or written.

Object Model

Data Class

Syntax

Visual Basic (Declaration)
Public Class Data
   Inherits Segment
Visual Basic (Usage) Copy Code
Dim instance As Data
C#
public class Data : Segment
Managed Extensions for C++
public __gc class Data : public Segment
C++/CLI
public ref class Data : public Segment

Inheritance Hierarchy

System.Object
Dart.Emulation.Segment
Dart.Emulation.Data

See Also

Reference

Data Members
Dart.Emulation Namespace


Data Class Members

[image]
PowerTCP Emulation for .NET
Data Class Members
See Also Properties Methods Send comments on this topic
Dart.Emulation Namespace : Data Class

Glossary Item Box

The following tables list the members exposed by Data.

Public Properties

 | Name | Description
Public Property | Buffer | Gets the buffer that holds data. (Inherited from Dart.Emulation.Segment)
Public Property | Count | Byte count of data. (Inherited from Dart.Emulation.Segment)
Public Property | Delimiter | Gets the delimiter byte array used by TcpBase.ReadToDelimiter.
Public Property | Direction | Indicates whether data is inbound or outbound.
Public Property | Encoding | Gets the character encoding used by the object.
Public Property | Offset | The offset into the buffer where the data starts. (Inherited from Dart.Emulation.Segment)
Top

Public Methods

 | Name | Description
Public Method | ToString | Gets the data as a decoded string.
Top

See Also

Reference

Data Class
Dart.Emulation Namespace


Data Class Methods

[image]
PowerTCP Emulation for .NET
Data Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : Data Class

Glossary Item Box

For a list of all members of this type, see Data members.

Public Methods

 | Name | Description
Public Method | ToString | Gets the data as a decoded string.
Top

See Also

Reference

Data Class
Dart.Emulation Namespace


ToString Method

[image]
PowerTCP Emulation for .NET
ToString Method
See Also Send comments on this topic
Dart.Emulation Namespace > Data Class : ToString Method

Glossary Item Box

Gets the data as a decoded string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The System.Buffer decoded into a string using Encoding.

See Also

Reference

Data Class
Data Members


Data Class Properties

[image]
PowerTCP Emulation for .NET
Data Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Data Class

Glossary Item Box

For a list of all members of this type, see Data members.

Public Properties

 | Name | Description
Public Property | Buffer | Gets the buffer that holds data. (Inherited from Dart.Emulation.Segment)
Public Property | Count | Byte count of data. (Inherited from Dart.Emulation.Segment)
Public Property | Delimiter | Gets the delimiter byte array used by TcpBase.ReadToDelimiter.
Public Property | Direction | Indicates whether data is inbound or outbound.
Public Property | Encoding | Gets the character encoding used by the object.
Public Property | Offset | The offset into the buffer where the data starts. (Inherited from Dart.Emulation.Segment)
Top

See Also

Reference

Data Class
Dart.Emulation Namespace


Delimiter Property

[image]
PowerTCP Emulation for .NET
Delimiter Property
See Also Send comments on this topic
Dart.Emulation Namespace > Data Class : Delimiter Property

Glossary Item Box

Gets the delimiter byte array used by TcpBase.ReadToDelimiter.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delimiter As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value() As Byte

value = instance.Delimiter
C#
public byte[] Delimiter {get;}
Managed Extensions for C++
public: __property byte[]* get_Delimiter();
C++/CLI
public:
property array<byte>^ Delimiter {
   array<byte>^ get();
}

Property Value

Null if no delimiter was used or no delimiter was found. Otherwise, the delimiter byte array.

See Also

Reference

Data Class
Data Members


Direction Property

[image]
PowerTCP Emulation for .NET
Direction Property
See Also Send comments on this topic
Dart.Emulation Namespace > Data Class : Direction Property

Glossary Item Box

Indicates whether data is inbound or outbound.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Direction As DataDirection
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As DataDirection

value = instance.Direction
C#
public DataDirection Direction {get;}
Managed Extensions for C++
public: __property DataDirection get_Direction();
C++/CLI
public:
property DataDirection Direction {
   DataDirection get();
}

See Also

Reference

Data Class
Data Members


Encoding Property

[image]
PowerTCP Emulation for .NET
Encoding Property
See Also Send comments on this topic
Dart.Emulation Namespace > Data Class : Encoding Property

Glossary Item Box

Gets the character encoding used by the object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Encoding As Encoding
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As Encoding

value = instance.Encoding
C#
public Encoding Encoding {get;}
Managed Extensions for C++
public: __property Encoding* get_Encoding();
C++/CLI
public:
property Encoding^ Encoding {
   Encoding^ get();
}

See Also

Reference

Data Class
Data Members


DataEventArgs Class

[image]
PowerTCP Emulation for .NET
DataEventArgs Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : DataEventArgs Class

Glossary Item Box

Provides data for reporting events.

Object Model

DataEventArgs ClassData Class

Syntax

Visual Basic (Declaration)
Public Class DataEventArgs
   Inherits UserStateEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataEventArgs
C#
public class DataEventArgs : UserStateEventArgs
Managed Extensions for C++
public __gc class DataEventArgs : public UserStateEventArgs
C++/CLI
public ref class DataEventArgs : public UserStateEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Emulation.UserStateEventArgs
Dart.Emulation.DataEventArgs

See Also

Reference

DataEventArgs Members
Dart.Emulation Namespace


DataEventArgs Class Members

[image]
PowerTCP Emulation for .NET
DataEventArgs Class Members
See Also Properties Methods Send comments on this topic
Dart.Emulation Namespace : DataEventArgs Class

Glossary Item Box

The following tables list the members exposed by DataEventArgs.

Public Properties

 | Name | Description
Public Property | Data | Gets data provided by Data and Log events.
Public Property | Message | Returns the message argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)
Public Property | UserState | Returns the user state argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)
Top

Public Methods

 | Name | Description
Public Method | ToString | Gets the Data property as a decoded string.
Top

See Also

Reference

DataEventArgs Class
Dart.Emulation Namespace


DataEventArgs Class Methods

[image]
PowerTCP Emulation for .NET
DataEventArgs Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : DataEventArgs Class

Glossary Item Box

For a list of all members of this type, see DataEventArgs members.

Public Methods

 | Name | Description
Public Method | ToString | Gets the Data property as a decoded string.
Top

See Also

Reference

DataEventArgs Class
Dart.Emulation Namespace


ToString Method

[image]
PowerTCP Emulation for .NET
ToString Method
See Also Send comments on this topic
Dart.Emulation Namespace > DataEventArgs Class : ToString Method

Glossary Item Box

Gets the Data property as a decoded string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataEventArgs
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The Data.Buffer decoded into a string using the Data.Encoding specified.

See Also

Reference

DataEventArgs Class
DataEventArgs Members


DataEventArgs Class Properties

[image]
PowerTCP Emulation for .NET
DataEventArgs Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : DataEventArgs Class

Glossary Item Box

For a list of all members of this type, see DataEventArgs members.

Public Properties

 | Name | Description
Public Property | Data | Gets data provided by Data and Log events.
Public Property | Message | Returns the message argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)
Public Property | UserState | Returns the user state argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)
Top

See Also

Reference

DataEventArgs Class
Dart.Emulation Namespace


Data Property

[image]
PowerTCP Emulation for .NET
Data Property
See Also Send comments on this topic
Dart.Emulation Namespace > DataEventArgs Class : Data Property

Glossary Item Box

Gets data provided by Data and Log events.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Data
Visual Basic (Usage) Copy Code
Dim instance As DataEventArgs
Dim value As Data

value = instance.Data
C#
public Data Data {get;}
Managed Extensions for C++
public: __property Data* get_Data();
C++/CLI
public:
property Data^ Data {
   Data^ get();
}

See Also

Reference

DataEventArgs Class
DataEventArgs Members


DataException Class

[image]
PowerTCP Emulation for .NET
DataException Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : DataException Class

Glossary Item Box

Thrown when the expected data could not be read.

Object Model

DataException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class DataException
   Inherits System.ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As DataException
C#
[Serializable()]
public class DataException : System.ApplicationException
Managed Extensions for C++
[Serializable()]
public __gc class DataException : public System.ApplicationException
C++/CLI
[Serializable()]
public ref class DataException : public System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Dart.Emulation.DataException

See Also

Reference

DataException Members
Dart.Emulation Namespace


DataException Class Members

[image]
PowerTCP Emulation for .NET
DataException Class Members
See Also Fields Properties Methods Send comments on this topic
Dart.Emulation Namespace : DataException Class

Glossary Item Box

The following tables list the members exposed by DataException.

Public Fields

 | Name | Description
Public Field | DataRead | Data read from the socket before a failure generated this exception.
Top

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

DataException Class
Dart.Emulation Namespace


DataException Class Fields

[image]
PowerTCP Emulation for .NET
DataException Class Fields
See Also Send comments on this topic
Dart.Emulation Namespace : DataException Class

Glossary Item Box

For a list of all members of this type, see DataException members.

Public Fields

 | Name | Description
Public Field | DataRead | Data read from the socket before a failure generated this exception.
Top

See Also

Reference

DataException Class
Dart.Emulation Namespace


DataRead Field

[image]
PowerTCP Emulation for .NET
DataRead Field
See Also Send comments on this topic
Dart.Emulation Namespace > DataException Class : DataRead Field

Glossary Item Box

Data read from the socket before a failure generated this exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly DataRead As Data
Visual Basic (Usage) Copy Code
Dim instance As DataException
Dim value As Data

value = instance.DataRead
C#
public readonly Data DataRead
Managed Extensions for C++
public: readonly Data* DataRead
C++/CLI
public:
readonly Data^ DataRead

See Also

Reference

DataException Class
DataException Members


ErrorEventArgs Class

[image]
PowerTCP Emulation for .NET
ErrorEventArgs Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : ErrorEventArgs Class

Glossary Item Box

Provides data for the Error event.

Object Model

ErrorEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ErrorEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ErrorEventArgs
C#
public class ErrorEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class ErrorEventArgs : public System.EventArgs
C++/CLI
public ref class ErrorEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Emulation.ErrorEventArgs

See Also

Reference

ErrorEventArgs Members
Dart.Emulation Namespace


ErrorEventArgs Class Members

[image]
PowerTCP Emulation for .NET
ErrorEventArgs Class Members
See Also Methods Send comments on this topic
Dart.Emulation Namespace : ErrorEventArgs Class

Glossary Item Box

The following tables list the members exposed by ErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ErrorEventArgs Constructor | Save an exception within this class.
Top

Public Methods

 | Name | Description
Public Method | GetException | Returns the Exception marshaled to the UI thread.
Top

See Also

Reference

ErrorEventArgs Class
Dart.Emulation Namespace


ErrorEventArgs Constructor

[image]
PowerTCP Emulation for .NET
ErrorEventArgs Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > ErrorEventArgs Class : ErrorEventArgs Constructor

exception
Exception to save.

Glossary Item Box

Save an exception within this class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim exception As Exception

Dim instance As New ErrorEventArgs(exception)
C#
public ErrorEventArgs(
   Exception exception
)
Managed Extensions for C++
public: ErrorEventArgs(
   Exception* exception
)
C++/CLI
public:
ErrorEventArgs(
   Exception^ exception
)

Parameters

exception
Exception to save.

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


ErrorEventArgs Class Methods

[image]
PowerTCP Emulation for .NET
ErrorEventArgs Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : ErrorEventArgs Class

Glossary Item Box

For a list of all members of this type, see ErrorEventArgs members.

Public Methods

 | Name | Description
Public Method | GetException | Returns the Exception marshaled to the UI thread.
Top

See Also

Reference

ErrorEventArgs Class
Dart.Emulation Namespace


GetException Method

[image]
PowerTCP Emulation for .NET
GetException Method
See Also Send comments on this topic
Dart.Emulation Namespace > ErrorEventArgs Class : GetException Method

Glossary Item Box

Returns the Exception marshaled to the UI thread.

Syntax

Visual Basic (Declaration)
Public Function GetException() As Exception
Visual Basic (Usage) Copy Code
Dim instance As ErrorEventArgs
Dim value As Exception

value = instance.GetException()
C#
public Exception GetException()
Managed Extensions for C++
public: Exception* GetException();
C++/CLI
public:
Exception^ GetException();

Return Value

Exception

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


IPEndPoint Class

[image]
PowerTCP Emulation for .NET
IPEndPoint Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : IPEndPoint Class

Glossary Item Box

Allows user to specify a range of IPEndPoints for local binding. Also resolves hostnames and saves them for future use.

Object Model

IPEndPoint Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class IPEndPoint
   Inherits System.Net.IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
C#
[Serializable()]
public class IPEndPoint : System.Net.IPEndPoint
Managed Extensions for C++
[Serializable()]
public __gc class IPEndPoint : public System.Net.IPEndPoint
C++/CLI
[Serializable()]
public ref class IPEndPoint : public System.Net.IPEndPoint

Inheritance Hierarchy

System.Object
System.Net.EndPoint
System.Net.IPEndPoint
Dart.Emulation.IPEndPoint

See Also

Reference

IPEndPoint Members
Dart.Emulation Namespace


IPEndPoint Class Members

[image]
PowerTCP Emulation for .NET
IPEndPoint Class Members
See Also Fields Properties Methods Send comments on this topic
Dart.Emulation Namespace : IPEndPoint Class

Glossary Item Box

The following tables list the members exposed by IPEndPoint.

Public Constructors

 | Name | Description
Public Constructor | IPEndPoint Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Range | The socket will be bound to a port between IPEndPoint.Port and (IPEndPoint.Port + Range), inclusive.
Top

Public Properties

 | Name | Description
Public Property | Address | Gets or sets the address of the endpoint.
Public Property | AddressFamily | (Inherited from System.Net.IPEndPoint)
Public Property | HostNameOrAddress | Gets or sets the host name or address resolved to create this IPEndPoint. Also performs a DNS resolution.
Public Property | HostNameOrAddressColonPort | The host name or address used to create this IPEndPoint with ":port" appended.
Public Property | Port | Gets or sets the port number of the endpoint.
Top

Public Methods

 | Name | Description
Public Method | Create | (Inherited from System.Net.IPEndPoint)
Public Method | Equals | (Inherited from System.Net.IPEndPoint)
Public Method | GetHashCode | (Inherited from System.Net.IPEndPoint)
Public Method | Serialize | (Inherited from System.Net.IPEndPoint)
Public Method | ToString | (Inherited from System.Net.IPEndPoint)
Top

See Also

Reference

IPEndPoint Class
Dart.Emulation Namespace


IPEndPoint Constructor

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class : IPEndPoint Constructor

Glossary Item Box

Overload List

Overload | Description
IPEndPoint Constructor() | Creates an IPEndPoint using IPAddress.Any and an ephemeral port (0).
IPEndPoint Constructor(AddressFamily) | Creates an IPEndPoint using IPAddress.Any or IPAddress.IPv6Any and an ephemeral port (0).
IPEndPoint Constructor(IPAddress,Int32) | Creates an IPEndPoint using a specified IPAddress and port.
IPEndPoint Constructor(IPAddress,Int32,Int32) | Creates an IPEndPoint using an IPAddress, port, and port range.
IPEndPoint Constructor(String) | Creates an IPEndPoint using a hostname or address, and port 0.
IPEndPoint Constructor(String,Int32) | Creates an IPEndPoint using a hostname or address, and port.
IPEndPoint Constructor(String,AddressFamily,Int32) | Creates an IPEndPoint using a hostname or address, port, and AddressFamily.
IPEndPoint Constructor(String,AddressFamily,Int32,Int32) | Creates an IPEndPoint using a hostname or address, address family, port and range.
IPEndPoint Constructor(String,String,Int32,Int32) | Creates an IPEndPoint using a hostname or address, address, port and range.

See Also

Reference

IPEndPoint Class
IPEndPoint Members


IPEndPoint Constructor()

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor()

Glossary Item Box

Creates an IPEndPoint using IPAddress.Any and an ephemeral port (0).

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New IPEndPoint()
C#
public IPEndPoint()
Managed Extensions for C++
public: IPEndPoint();
C++/CLI
public:
IPEndPoint();

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(AddressFamily)

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor(AddressFamily)
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(AddressFamily)

addressFamily
AddressFamily to match.

Glossary Item Box

Creates an IPEndPoint using IPAddress.Any or IPAddress.IPv6Any and an ephemeral port (0).

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal addressFamily As AddressFamily _
)
Visual Basic (Usage) Copy Code
Dim addressFamily As AddressFamily

Dim instance As New IPEndPoint(addressFamily)
C#
public IPEndPoint(
   AddressFamily addressFamily
)
Managed Extensions for C++
public: IPEndPoint(
   AddressFamily addressFamily
)
C++/CLI
public:
IPEndPoint(
   AddressFamily addressFamily
)

Parameters

addressFamily
AddressFamily to match.

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(IPAddress,Int32)

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor(IPAddress,Int32)
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(IPAddress,Int32)

address
An IPv4 or IPv6 address.
port
The port to bind to.

Glossary Item Box

Creates an IPEndPoint using a specified IPAddress and port.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal address As IPAddress, _
   ByVal port As Integer _
)
Visual Basic (Usage) Copy Code
Dim address As IPAddress
Dim port As Integer

Dim instance As New IPEndPoint(address, port)
C#
public IPEndPoint(
   IPAddress address,
   int port
)
Managed Extensions for C++
public: IPEndPoint(
   IPAddress* address,
   int port
)
C++/CLI
public:
IPEndPoint(
   IPAddress^ address,
   int port
)

Parameters

address
An IPv4 or IPv6 address.
port
The port to bind to.

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(IPAddress,Int32,Int32)

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor(IPAddress,Int32,Int32)
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(IPAddress,Int32,Int32)

address
An IPv4 or IPv6 address.
port
The port to bind to.
range
The range of ports, starting at port, to attempt to bind to.

Glossary Item Box

Creates an IPEndPoint using an IPAddress, port, and port range.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal address As IPAddress, _
   ByVal port As Integer, _
   ByVal range As Integer _
)
Visual Basic (Usage) Copy Code
Dim address As IPAddress
Dim port As Integer
Dim range As Integer

Dim instance As New IPEndPoint(address, port, range)
C#
public IPEndPoint(
   IPAddress address,
   int port,
   int range
)
Managed Extensions for C++
public: IPEndPoint(
   IPAddress* address,
   int port,
   int range
)
C++/CLI
public:
IPEndPoint(
   IPAddress^ address,
   int port,
   int range
)

Parameters

address
An IPv4 or IPv6 address.
port
The port to bind to.
range
The range of ports, starting at port, to attempt to bind to.

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String)

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor(String)
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String)

hostNameOrAddress
A hostname or an IPv4 or IPv6 address. Empty string resolves to the first local IPv4 network interface.

Glossary Item Box

Creates an IPEndPoint using a hostname or address, and port 0.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String

Dim instance As New IPEndPoint(hostNameOrAddress)
C#
public IPEndPoint(
   string hostNameOrAddress
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress
A hostname or an IPv4 or IPv6 address. Empty string resolves to the first local IPv4 network interface.

Remarks

The hostNameOrAddress parameter is limited to 126 characters in pre-4.0 versions of the .NET Framework, and 255 characters in versions 4.0 and higher.

If hostNameOrAddress is a hostname, resolves to the IPv4 address.

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String,Int32)

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor(String,Int32)
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String,Int32)

hostNameOrAddress
A hostname or an IPv4 or IPv6 address. Empty string resolves to the first local IPv4 network interface.
port
The port to bind to.

Glossary Item Box

Creates an IPEndPoint using a hostname or address, and port.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String, _
   ByVal port As Integer _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String
Dim port As Integer

Dim instance As New IPEndPoint(hostNameOrAddress, port)
C#
public IPEndPoint(
   string hostNameOrAddress,
   int port
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress,
   int port
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress,
   int port
)

Parameters

hostNameOrAddress
A hostname or an IPv4 or IPv6 address. Empty string resolves to the first local IPv4 network interface.
port
The port to bind to.

Remarks

The hostNameOrAddress parameter is limited to 126 characters in pre-4.0 versions of the .NET Framework, and 255 characters in versions 4.0 and higher.

If hostNameOrAddress is a hostname, resolves to the IPv4 address.

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String,AddressFamily,Int32)

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor(String,AddressFamily,Int32)
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String,AddressFamily,Int32)

hostNameOrAddress
A hostname or string address. Empty string resolves to the first local network interface in the specified AddressFamily.
addressFamily
The System.Net.Sockets.AddressFamily to match if resolving a hostname.
port
The port to bind to.

Glossary Item Box

Creates an IPEndPoint using a hostname or address, port, and AddressFamily.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String, _
   ByVal addressFamily As AddressFamily, _
   ByVal port As Integer _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String
Dim addressFamily As AddressFamily
Dim port As Integer

Dim instance As New IPEndPoint(hostNameOrAddress, addressFamily, port)
C#
public IPEndPoint(
   string hostNameOrAddress,
   AddressFamily addressFamily,
   int port
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress,
   AddressFamily addressFamily,
   int port
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress,
   AddressFamily addressFamily,
   int port
)

Parameters

hostNameOrAddress
A hostname or string address. Empty string resolves to the first local network interface in the specified AddressFamily.
addressFamily
The System.Net.Sockets.AddressFamily to match if resolving a hostname.
port
The port to bind to.

Remarks

The hostNameOrAddress parameter is limited to 126 characters in pre-4.0 versions of the .NET Framework, and 255 characters in versions 4.0 and higher.

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String,AddressFamily,Int32,Int32)

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor(String,AddressFamily,Int32,Int32)
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String,AddressFamily,Int32,Int32)

hostNameOrAddress
A hostname or string address. Empty string resolves to the first local network interface in the specified AddressFamily.
addressFamily
The AddressFamily to match if resolving a hostname.
port
The port to bind to.
range
The range of ports, starting at port, to attempt to bind to.

Glossary Item Box

Creates an IPEndPoint using a hostname or address, address family, port and range.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String, _
   ByVal addressFamily As AddressFamily, _
   ByVal port As Integer, _
   ByVal range As Integer _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String
Dim addressFamily As AddressFamily
Dim port As Integer
Dim range As Integer

Dim instance As New IPEndPoint(hostNameOrAddress, addressFamily, port, range)
C#
public IPEndPoint(
   string hostNameOrAddress,
   AddressFamily addressFamily,
   int port,
   int range
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress,
   AddressFamily addressFamily,
   int port,
   int range
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress,
   AddressFamily addressFamily,
   int port,
   int range
)

Parameters

hostNameOrAddress
A hostname or string address. Empty string resolves to the first local network interface in the specified AddressFamily.
addressFamily
The AddressFamily to match if resolving a hostname.
port
The port to bind to.
range
The range of ports, starting at port, to attempt to bind to.

Remarks

The socket will try to bind to the specified port. Upon failure, it will try with each successive port up to (port + range), until successful. An Exception is raised if all binding attempts fail.

The hostNameOrAddress parameter is limited to 126 characters in pre-4.0 versions of the .NET Framework, and 255 characters in versions 4.0 and higher.

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String,String,Int32,Int32)

[image]
PowerTCP Emulation for .NET
IPEndPoint Constructor(String,String,Int32,Int32)
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String,String,Int32,Int32)

hostNameOrAddress
A hostname or string address.
address
The IPAddress in string notation.
port
The port to bind to.
range
The range of ports, starting at port, to attempt to bind to.

Glossary Item Box

Creates an IPEndPoint using a hostname or address, address, port and range.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String, _
   ByVal address As String, _
   ByVal port As Integer, _
   ByVal range As Integer _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String
Dim address As String
Dim port As Integer
Dim range As Integer

Dim instance As New IPEndPoint(hostNameOrAddress, address, port, range)
C#
public IPEndPoint(
   string hostNameOrAddress,
   string address,
   int port,
   int range
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress,
   string* address,
   int port,
   int range
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress,
   String^ address,
   int port,
   int range
)

Parameters

hostNameOrAddress
A hostname or string address.
address
The IPAddress in string notation.
port
The port to bind to.
range
The range of ports, starting at port, to attempt to bind to.

Remarks

This constructor is typically used to serialize the IPEndPoint and does not resolve hostNameOrAddress. The hostname can be needed for some proxies.

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Class Properties

[image]
PowerTCP Emulation for .NET
IPEndPoint Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : IPEndPoint Class

Glossary Item Box

For a list of all members of this type, see IPEndPoint members.

Public Properties

 | Name | Description
Public Property | Address | Gets or sets the address of the endpoint.
Public Property | AddressFamily | (Inherited from System.Net.IPEndPoint)
Public Property | HostNameOrAddress | Gets or sets the host name or address resolved to create this IPEndPoint. Also performs a DNS resolution.
Public Property | HostNameOrAddressColonPort | The host name or address used to create this IPEndPoint with ":port" appended.
Public Property | Port | Gets or sets the port number of the endpoint.
Top

See Also

Reference

IPEndPoint Class
Dart.Emulation Namespace


Address Property

[image]
PowerTCP Emulation for .NET
Address Property
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class : Address Property

Glossary Item Box

Gets or sets the address of the endpoint.

Syntax

Visual Basic (Declaration)
Public Shadows Property Address As IPAddress
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As IPAddress

instance.Address = value

value = instance.Address
C#
public new IPAddress Address {get; set;}
Managed Extensions for C++
public: __property new IPAddress* get_Address();
public: __property new void set_Address(
   IPAddress* value
);
C++/CLI
public:
new property IPAddress^ Address {
   IPAddress^ get();
   void set (    IPAddress^ value);
}

See Also

Reference

IPEndPoint Class
IPEndPoint Members


HostNameOrAddress Property

[image]
PowerTCP Emulation for .NET
HostNameOrAddress Property
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class : HostNameOrAddress Property

Glossary Item Box

Gets or sets the host name or address resolved to create this IPEndPoint. Also performs a DNS resolution.

Syntax

Visual Basic (Declaration)
Public Property HostNameOrAddress As String
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As String

instance.HostNameOrAddress = value

value = instance.HostNameOrAddress
C#
public string HostNameOrAddress {get; set;}
Managed Extensions for C++
public: __property string* get_HostNameOrAddress();
public: __property void set_HostNameOrAddress(
   string* value
);
C++/CLI
public:
property String^ HostNameOrAddress {
   String^ get();
   void set (    String^ value);
}

Remarks

The value of this property is limited to 126 characters in pre-4.0 versions of the .NET Framework, and 255 characters in versions 4.0 and higher. IDN encoding is performed for DNS resolution if a non-ASCII hostname is provided.

See Also

Reference

IPEndPoint Class
IPEndPoint Members


HostNameOrAddressColonPort Property

[image]
PowerTCP Emulation for .NET
HostNameOrAddressColonPort Property
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class : HostNameOrAddressColonPort Property

Glossary Item Box

The host name or address used to create this IPEndPoint with ":port" appended.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HostNameOrAddressColonPort As String
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As String

value = instance.HostNameOrAddressColonPort
C#
public string HostNameOrAddressColonPort {get;}
Managed Extensions for C++
public: __property string* get_HostNameOrAddressColonPort();
C++/CLI
public:
property String^ HostNameOrAddressColonPort {
   String^ get();
}

Remarks

If HostNameOrAddress is an IPv6 address, the format includes square brackets as follows: [xx:yy...zz]:port.

See Also

Reference

IPEndPoint Class
IPEndPoint Members


Port Property

[image]
PowerTCP Emulation for .NET
Port Property
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class : Port Property

Glossary Item Box

Gets or sets the port number of the endpoint.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Shadows Property Port As Integer
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As Integer

instance.Port = value

value = instance.Port
C#
[DefaultValue()]
public new int Port {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property new int get_Port();
public: __property new void set_Port(
   int value
);
C++/CLI
[DefaultValue()]
public:
new property int Port {
   int get();
   void set (    int value);
}

See Also

Reference

IPEndPoint Class
IPEndPoint Members


IPEndPoint Class Fields

[image]
PowerTCP Emulation for .NET
IPEndPoint Class Fields
See Also Send comments on this topic
Dart.Emulation Namespace : IPEndPoint Class

Glossary Item Box

For a list of all members of this type, see IPEndPoint members.

Public Fields

 | Name | Description
Public Field | Range | The socket will be bound to a port between IPEndPoint.Port and (IPEndPoint.Port + Range), inclusive.
Top

See Also

Reference

IPEndPoint Class
Dart.Emulation Namespace


Range Field

[image]
PowerTCP Emulation for .NET
Range Field
See Also Send comments on this topic
Dart.Emulation Namespace > IPEndPoint Class : Range Field

Glossary Item Box

The socket will be bound to a port between IPEndPoint.Port and (IPEndPoint.Port + Range), inclusive.

Syntax

Visual Basic (Declaration)
Public Range As Integer
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As Integer

value = instance.Range

instance.Range = value
C#
public int Range
Managed Extensions for C++
public: int Range
C++/CLI
public:
int Range

See Also

Reference

IPEndPoint Class
IPEndPoint Members


KeyPressEventArgs Class

[image]
PowerTCP Emulation for .NET
KeyPressEventArgs Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : KeyPressEventArgs Class

Glossary Item Box

Provides data for the KeyPress event.

Object Model

KeyPressEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class KeyPressEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As KeyPressEventArgs
C#
public class KeyPressEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class KeyPressEventArgs : public System.EventArgs
C++/CLI
public ref class KeyPressEventArgs : public System.EventArgs

Remarks

The KeyPressEventArgs specify the data that was generated as the result of a key press. Often this will simply be the byte representation of the character that was pressed. However, some single key presses can result in multiple character representations (as a result of internal mapping). You can access the data generated as the result of a key press via the Bytes property.

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Emulation.KeyPressEventArgs

See Also

Reference

KeyPressEventArgs Members
Dart.Emulation Namespace


KeyPressEventArgs Class Members

[image]
PowerTCP Emulation for .NET
KeyPressEventArgs Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : KeyPressEventArgs Class

Glossary Item Box

The following tables list the members exposed by KeyPressEventArgs.

Public Constructors

 | Name | Description
Public Constructor | KeyPressEventArgs Constructor | Initializes a new instance of DataEventArgs.
Top

Public Properties

 | Name | Description
Public Property | Bytes | Returns the data that was generated as the result of a key press.
Top

See Also

Reference

KeyPressEventArgs Class
Dart.Emulation Namespace


KeyPressEventArgs Constructor

[image]
PowerTCP Emulation for .NET
KeyPressEventArgs Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > KeyPressEventArgs Class : KeyPressEventArgs Constructor

b
Byte[] representation of the key pressed.

Glossary Item Box

Initializes a new instance of DataEventArgs.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal b() As Byte _
)
Visual Basic (Usage) Copy Code
Dim b() As Byte

Dim instance As New KeyPressEventArgs(b)
C#
public KeyPressEventArgs(
   byte[] b
)
Managed Extensions for C++
public: KeyPressEventArgs(
   byte[]* b
)
C++/CLI
public:
KeyPressEventArgs(
   array<byte>^ b
)

Parameters

b
Byte[] representation of the key pressed.

See Also

Reference

KeyPressEventArgs Class
KeyPressEventArgs Members


KeyPressEventArgs Class Properties

[image]
PowerTCP Emulation for .NET
KeyPressEventArgs Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : KeyPressEventArgs Class

Glossary Item Box

For a list of all members of this type, see KeyPressEventArgs members.

Public Properties

 | Name | Description
Public Property | Bytes | Returns the data that was generated as the result of a key press.
Top

See Also

Reference

KeyPressEventArgs Class
Dart.Emulation Namespace


Bytes Property

[image]
PowerTCP Emulation for .NET
Bytes Property
See Also Send comments on this topic
Dart.Emulation Namespace > KeyPressEventArgs Class : Bytes Property

Glossary Item Box

Returns the data that was generated as the result of a key press.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bytes As Byte()
Visual Basic (Usage) Copy Code
Dim instance As KeyPressEventArgs
Dim value() As Byte

value = instance.Bytes
C#
public byte[] Bytes {get;}
Managed Extensions for C++
public: __property byte[]* get_Bytes();
C++/CLI
public:
property array<byte>^ Bytes {
   array<byte>^ get();
}

Remarks

Often the data generated by a key press will simply be the byte representation of the character that was pressed. However, some single key presses can result in multiple character representations (as a result of internal mapping). You can access the data generated as the result of a key press via the this property.

See Also

Reference

KeyPressEventArgs Class
KeyPressEventArgs Members


Option Class

[image]
PowerTCP Emulation for .NET
Option Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Option Class

Glossary Item Box

Encapsulates a Telnet option.

Object Model

Option Class

Syntax

Visual Basic (Declaration)
Public Class Option
Visual Basic (Usage) Copy Code
Dim instance As Option
C#
public class Option
Managed Extensions for C++
public __gc class Option
C++/CLI
public ref class Option

Remarks

The Telnet protocol allows for option negotiation to provide advanced capabilities to the default NVT (Network Virtual Terminal). Both client and server can request to enable or disable options. Both hosts can accept or deny requests as well. The Option object represents an option.

To add a Telnet option, create a new Option object, and add it to the ClientOptions or ServerOptions collection. Adding the Option to Telnet.ClientOptions causes the Telnet component to send a WILL or WONT command to the server concerning the option. Adding the Option to Telnet.ServerOptions causes the Telnet component to sent a DO or DONT command to the server concerning the option. The State can either be set to OptionState.RequestOn (to use the option by requesting it), or OptionState.Allow (to use the option if the remote host requests it). To not use an option, either do not add it to a OptionCollection, or, if already present, remove it. After option negotiation occurs, check the State property to see if the option was negotiated successfully (OptionState.On) or negotiated unsuccessfully (OptionState.Off).

Inheritance Hierarchy

System.Object
Dart.Emulation.Option

See Also

Reference

Option Members
Dart.Emulation Namespace


Option Class Members

[image]
PowerTCP Emulation for .NET
Option Class Members
See Also Properties Methods Send comments on this topic
Dart.Emulation Namespace : Option Class

Glossary Item Box

The following tables list the members exposed by Option.

Public Constructors

 | Name | Description
Public Constructor | Option Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Code | Gets or sets the code of the option to use.
Public Property | State | Gets or sets the current state of the Option.
Public Property | SubOption | Gets or sets the suboption information for options.
Top

Public Methods

 | Name | Description
Public Method | Reset | Reinitializes the Option.State for a new connection.
Top

See Also

Reference

Option Class
Dart.Emulation Namespace


Option Constructor

[image]
PowerTCP Emulation for .NET
Option Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class : Option Constructor

Glossary Item Box

Overload List

Overload | Description
Option Constructor() | Initializes a new instance of Option.
Option Constructor(OptionCode) | Initializes a new instance of Option.
Option Constructor(OptionCode,OptionState) | Initializes a new instance of Option.
Option Constructor(OptionCode,Byte[]) | Initializes a new instance of Option.
Option Constructor(OptionCode,Byte[],OptionState) | Initializes a new instance of Option.
Option Constructor(Byte[],Int32,Int32) | Initializes a new instance of Option.

See Also

Reference

Option Class
Option Members


Option Constructor()

[image]
PowerTCP Emulation for .NET
Option Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class > Option Constructor : Option Constructor()

Glossary Item Box

Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Option()
C#
public Option()
Managed Extensions for C++
public: Option();
C++/CLI
public:
Option();

Remarks

This constructor creates a new instance of Option with the State set to OptionState.Off.

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode)

[image]
PowerTCP Emulation for .NET
Option Constructor(OptionCode)
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class > Option Constructor : Option Constructor(OptionCode)

code
The option code.

Glossary Item Box

Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode

Dim instance As New Option(code)
C#
public Option(
   OptionCode code
)
Managed Extensions for C++
public: Option(
   OptionCode code
)
C++/CLI
public:
Option(
   OptionCode code
)

Parameters

code
The option code.

Remarks

This constructor creates a new instance of Option, with Code set to the value of code and State set to OptionState.Off.

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode,OptionState)

[image]
PowerTCP Emulation for .NET
Option Constructor(OptionCode,OptionState)
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class > Option Constructor : Option Constructor(OptionCode,OptionState)

code
The option code.
state
The option state.

Glossary Item Box

Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode, _
   ByVal state As OptionState _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode
Dim state As OptionState

Dim instance As New Option(code, state)
C#
public Option(
   OptionCode code,
   OptionState state
)
Managed Extensions for C++
public: Option(
   OptionCode code,
   OptionState state
)
C++/CLI
public:
Option(
   OptionCode code,
   OptionState state
)

Parameters

code
The option code.
state
The option state.

Remarks

This constructor creates a new instance of Option, with Code and State set.

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode,Byte[])

[image]
PowerTCP Emulation for .NET
Option Constructor(OptionCode,Byte[])
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class > Option Constructor : Option Constructor(OptionCode,Byte[])

code
The option code.
subOption
The option suboption.

Glossary Item Box

Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode, _
   ByVal subOption() As Byte _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode
Dim subOption() As Byte

Dim instance As New Option(code, subOption)
C#
public Option(
   OptionCode code,
   byte[] subOption
)
Managed Extensions for C++
public: Option(
   OptionCode code,
   byte[]* subOption
)
C++/CLI
public:
Option(
   OptionCode code,
   array<byte>^ subOption
)

Parameters

code
The option code.
subOption
The option suboption.

Remarks

This constructor creates a new instance of Option, with Code set to the value of code, SubOption set to the value of subOption and State set to OptionState.Off.

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode,Byte[],OptionState)

[image]
PowerTCP Emulation for .NET
Option Constructor(OptionCode,Byte[],OptionState)
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class > Option Constructor : Option Constructor(OptionCode,Byte[],OptionState)

code
The option code.
subOption
The option suboption.
state
The option state.

Glossary Item Box

Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode, _
   ByVal subOption() As Byte, _
   ByVal state As OptionState _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode
Dim subOption() As Byte
Dim state As OptionState

Dim instance As New Option(code, subOption, state)
C#
public Option(
   OptionCode code,
   byte[] subOption,
   OptionState state
)
Managed Extensions for C++
public: Option(
   OptionCode code,
   byte[]* subOption,
   OptionState state
)
C++/CLI
public:
Option(
   OptionCode code,
   array<byte>^ subOption,
   OptionState state
)

Parameters

code
The option code.
subOption
The option suboption.
state
The option state.

Remarks

This constructor creates a new instance of Option, with Code, SubOption and State set.

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(Byte[],Int32,Int32)

[image]
PowerTCP Emulation for .NET
Option Constructor(Byte[],Int32,Int32)
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class > Option Constructor : Option Constructor(Byte[],Int32,Int32)

buffer
Contains option data.
offset
Contains the offset into buffer.
count
Contains the option data count.

Glossary Item Box

Initializes a new instance of Option.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

Dim instance As New Option(buffer, offset, count)
C#
public Option(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Option(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Option(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
Contains option data.
offset
Contains the offset into buffer.
count
Contains the option data count.

Remarks

This constructor creates a new instance of Option with State set to OptionState.Off.

See Also

Reference

Option Class
Option Members
Overload List


Option Class Methods

[image]
PowerTCP Emulation for .NET
Option Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : Option Class

Glossary Item Box

For a list of all members of this type, see Option members.

Public Methods

 | Name | Description
Public Method | Reset | Reinitializes the Option.State for a new connection.
Top

See Also

Reference

Option Class
Dart.Emulation Namespace


Reset Method

[image]
PowerTCP Emulation for .NET
Reset Method
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class : Reset Method

Glossary Item Box

Reinitializes the Option.State for a new connection.

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As Option

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Remarks

This method causes the State property of the Option object to revert back to its original state. If the Option.State was OptionState.RequestOff, it is set to OptionState.Off.

See Also

Reference

Option Class
Option Members


Option Class Properties

[image]
PowerTCP Emulation for .NET
Option Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Option Class

Glossary Item Box

For a list of all members of this type, see Option members.

Public Properties

 | Name | Description
Public Property | Code | Gets or sets the code of the option to use.
Public Property | State | Gets or sets the current state of the Option.
Public Property | SubOption | Gets or sets the suboption information for options.
Top

See Also

Reference

Option Class
Dart.Emulation Namespace


Code Property

[image]
PowerTCP Emulation for .NET
Code Property
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class : Code Property

Glossary Item Box

Gets or sets the code of the option to use.

Syntax

Visual Basic (Declaration)
Public Property Code As OptionCode
Visual Basic (Usage) Copy Code
Dim instance As Option
Dim value As OptionCode

instance.Code = value

value = instance.Code
C#
public OptionCode Code {get; set;}
Managed Extensions for C++
public: __property OptionCode get_Code();
public: __property void set_Code(
   OptionCode value
);
C++/CLI
public:
property OptionCode Code {
   OptionCode get();
   void set (    OptionCode value);
}

Property Value

An OptionCode value representing the code for the option.

Remarks

This property will reflect one of the defined Telnet option code values represented by the OptionCode enumeration. For information about each option, please see the appropriate RFC for that option.

See Also

Reference

Option Class
Option Members


State Property

[image]
PowerTCP Emulation for .NET
State Property
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class : State Property

Glossary Item Box

Gets or sets the current state of the Option.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property State As OptionState
Visual Basic (Usage) Copy Code
Dim instance As Option
Dim value As OptionState

instance.State = value

value = instance.State
C#
[DefaultValue()]
public OptionState State {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property OptionState get_State();
public: __property void set_State(
   OptionState value
);
C++/CLI
[DefaultValue()]
public:
property OptionState State {
   OptionState get();
   void set (    OptionState value);
}

Property Value

An OptionState value representing the current state of the Option.

Remarks

Option negotiation with PowerTCP Telnet for .NET can be broken down into three general states:

State 1 - Setting the option:

Any requested options must be added to either the ClientOptions or ServerOptions collections. Any options added to these collections are part of the automatic option negotiation. When adding new options to the collection:

  • Set to OptionState.RequestOn to request the option (default value).
  • Set to OptionState.Allow to enable the option if the remote host requests it.
  • Remove Options from the collection to respond negatively to server requests.

State 2 - Requesting the option:

Option negotiation is typically handled internally by the Telnet component when a new connection occurs. During this time, Code is OptionCode.Waiting, indicating a request has been sent but a response has not yet been received.

State 3 - Negotiation complete:

After option negotiation has completed, check Option.Code to see the negotiation results. It should be one of two values:

  • OptionCode.Off if the option is not used.
  • OptionCode.On if the option is used.

See Also

Reference

Option Class
Option Members


SubOption Property

[image]
PowerTCP Emulation for .NET
SubOption Property
See Also Send comments on this topic
Dart.Emulation Namespace > Option Class : SubOption Property

Glossary Item Box

Gets or sets the suboption information for options.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SubOption As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Option
Dim value() As Byte

instance.SubOption = value

value = instance.SubOption
C#
[DefaultValue()]
public byte[] SubOption {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property byte[]* get_SubOption();
public: __property void set_SubOption(
   byte[]* value
);
C++/CLI
[DefaultValue()]
public:
property array<byte>^ SubOption {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

Property Value

A byte array representing the suboption information.

Remarks

Some options require addition suboption information. Set this property to a byte array representing the suboption data. The formatting of the data in the byte array will vary depending on the option. See the appropriate RFC for the option to determine how to format the data.

Popular suboptions are encapsulated by high level properties for ease of use. Examples include TerminalType and WindowSize.

See Also

Reference

Option Class
Option Members


OptionCollection Class

[image]
PowerTCP Emulation for .NET
OptionCollection Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : OptionCollection Class

Glossary Item Box

A collection of Option objects.

Object Model

OptionCollection ClassOption Class

Syntax

Visual Basic (Declaration)
Public Class OptionCollection
   Inherits System.Collections.Generic.List(Of Option)
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
C#
public class OptionCollection : System.Collections.Generic.List<Option>
Managed Extensions for C++
public __gc class OptionCollection : public System.Collections.Generic.List<Option>
C++/CLI
public ref class OptionCollection : public System.Collections.Generic.List<Option>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
Dart.Emulation.OptionCollection

See Also

Reference

OptionCollection Members
Dart.Emulation Namespace


OptionCollection Class Members

[image]
PowerTCP Emulation for .NET
OptionCollection Class Members
See Also Properties Methods Send comments on this topic
Dart.Emulation Namespace : OptionCollection Class

Glossary Item Box

The following tables list the members exposed by OptionCollection.

Public Constructors

 | Name | Description
Public Constructor | OptionCollection Constructor | Initializes an instance of the OptionCollection object.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Option>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Option>)
Public Property | Item | (Inherited from System.Collections.Generic.List<Option>)
Public Property | TransmitBinary | Gets a value indicating if the "TRANSMIT-BINARY" option was negotiated for the OptionCollection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a new Option to the OptionCollection object.
Public Method | AddRange | Overloaded. Adds an array of Option objects to the OptionCollection.
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Option>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Option>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Option>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Option>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Option>)
Public Method | Find | Overloaded. Returns the Option object which matches the specified code.
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Option>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<Option>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Option>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Option>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Option>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Option>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Option>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Option>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Option>)
Top

See Also

Reference

OptionCollection Class
Dart.Emulation Namespace


OptionCollection Constructor

[image]
PowerTCP Emulation for .NET
OptionCollection Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > OptionCollection Class : OptionCollection Constructor

Glossary Item Box

Initializes an instance of the OptionCollection object.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New OptionCollection()
C#
public OptionCollection()
Managed Extensions for C++
public: OptionCollection();
C++/CLI
public:
OptionCollection();

See Also

Reference

OptionCollection Class
OptionCollection Members


OptionCollection Class Methods

[image]
PowerTCP Emulation for .NET
OptionCollection Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : OptionCollection Class

Glossary Item Box

For a list of all members of this type, see OptionCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a new Option to the OptionCollection object.
Public Method | AddRange | Overloaded. Adds an array of Option objects to the OptionCollection.
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Option>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Option>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Option>)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List<Option>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Option>)
Public Method | Find | Overloaded. Returns the Option object which matches the specified code.
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Option>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<Option>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Option>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Option>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Option>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Option>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Option>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Option>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Option>)
Top

See Also

Reference

OptionCollection Class
Dart.Emulation Namespace


Add Method

[image]
PowerTCP Emulation for .NET
Add Method
See Also Send comments on this topic
Dart.Emulation Namespace > OptionCollection Class : Add Method

value
The Option to add to the OptionCollection object.

Glossary Item Box

Adds a new Option to the OptionCollection object.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Add( _
   ByVal value As Option _
)
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim value As Option

instance.Add(value)
C#
public new void Add(
   Option value
)
Managed Extensions for C++
public: new void Add(
   Option* value
)
C++/CLI
public:
new void Add(
   Option^ value
)

Parameters

value
The Option to add to the OptionCollection object.

Remarks

Use this method to add a new Option to the OptionCollection, to ensure it is used during option negotiation.

If an existing item has the same Code as the new option, the existing item is removed to prevent duplication.

See Also

Reference

OptionCollection Class
OptionCollection Members


AddRange Method

[image]
PowerTCP Emulation for .NET
AddRange Method
See Also Send comments on this topic
Dart.Emulation Namespace > OptionCollection Class : AddRange Method

Glossary Item Box

Adds an array of Option objects to the OptionCollection.

Overload List

Overload | Description
AddRange(Option[]) | Adds an array of Option objects to the OptionCollection.
AddRange(IEnumerable{Option}) | (Inherited from System.Collections.Generic.List<Option>)

See Also

Reference

OptionCollection Class
OptionCollection Members


AddRange(Option[]) Method

[image]
PowerTCP Emulation for .NET
AddRange(Option[]) Method
See Also Send comments on this topic
Dart.Emulation Namespace > OptionCollection Class > AddRange Method : AddRange(Option[]) Method

items
The array of Option objects to add to the OptionCollection.

Glossary Item Box

Adds an array of Option objects to the OptionCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items() As Option _
)
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim items() As Option

instance.AddRange(items)
C#
public void AddRange(
   Option[] items
)
Managed Extensions for C++
public: void AddRange(
   Option*[]* items
)
C++/CLI
public:
void AddRange(
   array<Option^>^ items
)

Parameters

items
The array of Option objects to add to the OptionCollection.

Remarks

Use this method to add an array of Options to the OptionCollection, to ensure they are used during option negotiation.

If an existing item has the same Code as the new option, the existing item is removed to prevent duplication.

See Also

Reference

OptionCollection Class
OptionCollection Members
Overload List


Find Method

[image]
PowerTCP Emulation for .NET
Find Method
See Also Send comments on this topic
Dart.Emulation Namespace > OptionCollection Class : Find Method

Glossary Item Box

Returns the Option object which matches the specified code.

Overload List

Overload | Description
Find(OptionCode) | Returns the Option object which matches the specified code.
Find(Predicate{Option}) | (Inherited from System.Collections.Generic.List<Option>)

See Also

Reference

OptionCollection Class
OptionCollection Members


Find(OptionCode) Method

[image]
PowerTCP Emulation for .NET
Find(OptionCode) Method
See Also Send comments on this topic
Dart.Emulation Namespace > OptionCollection Class > Find Method : Find(OptionCode) Method

code
The OptionCode of the option to find.

Glossary Item Box

Returns the Option object which matches the specified code.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal code As OptionCode _
) As Option
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim code As OptionCode
Dim value As Option

value = instance.Find(code)
C#
public Option Find(
   OptionCode code
)
Managed Extensions for C++
public: Option* Find(
   OptionCode code
)
C++/CLI
public:
Option^ Find(
   OptionCode code
)

Parameters

code
The OptionCode of the option to find.

Return Value

The Option which matches the specified code.

See Also

Reference

OptionCollection Class
OptionCollection Members
Overload List


OptionCollection Class Properties

[image]
PowerTCP Emulation for .NET
OptionCollection Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : OptionCollection Class

Glossary Item Box

For a list of all members of this type, see OptionCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Option>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Option>)
Public Property | Item | (Inherited from System.Collections.Generic.List<Option>)
Public Property | TransmitBinary | Gets a value indicating if the "TRANSMIT-BINARY" option was negotiated for the OptionCollection.
Top

See Also

Reference

OptionCollection Class
Dart.Emulation Namespace


TransmitBinary Property

[image]
PowerTCP Emulation for .NET
TransmitBinary Property
See Also Send comments on this topic
Dart.Emulation Namespace > OptionCollection Class : TransmitBinary Property

Glossary Item Box

Gets a value indicating if the "TRANSMIT-BINARY" option was negotiated for the OptionCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TransmitBinary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim value As Boolean

value = instance.TransmitBinary
C#
public bool TransmitBinary {get;}
Managed Extensions for C++
public: __property bool get_TransmitBinary();
C++/CLI
public:
property bool TransmitBinary {
   bool get();
}

Property Value

A boolean which determines if the TRANSMIT-BINARY option has been negotiated.

Remarks

Setting the Binary property to true will cause the Telnet component to attempt to negotiate the "TRANSMIT-BINARY" option for both ClientOptions and ServerOptions. Check this property for both these collections after option negotiation has completed to determine if negotiation was successful.

See Also

Reference

OptionCollection Class
OptionCollection Members


OptionEventArgs Class

[image]
PowerTCP Emulation for .NET
OptionEventArgs Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : OptionEventArgs Class

Glossary Item Box

Contains option event data.

Object Model

OptionEventArgs ClassOption Class

Syntax

Visual Basic (Declaration)
Public Class OptionEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As OptionEventArgs
C#
public class OptionEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class OptionEventArgs : public System.EventArgs
C++/CLI
public ref class OptionEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Emulation.OptionEventArgs

See Also

Reference

OptionEventArgs Members
Dart.Emulation Namespace


OptionEventArgs Class Members

[image]
PowerTCP Emulation for .NET
OptionEventArgs Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : OptionEventArgs Class

Glossary Item Box

The following tables list the members exposed by OptionEventArgs.

Public Properties

 | Name | Description
Public Property | Option | The updated option causing the event.
Top

See Also

Reference

OptionEventArgs Class
Dart.Emulation Namespace


OptionEventArgs Class Properties

[image]
PowerTCP Emulation for .NET
OptionEventArgs Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : OptionEventArgs Class

Glossary Item Box

For a list of all members of this type, see OptionEventArgs members.

Public Properties

 | Name | Description
Public Property | Option | The updated option causing the event.
Top

See Also

Reference

OptionEventArgs Class
Dart.Emulation Namespace


Option Property

[image]
PowerTCP Emulation for .NET
Option Property
See Also Send comments on this topic
Dart.Emulation Namespace > OptionEventArgs Class : Option Property

Glossary Item Box

The updated option causing the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Option As Option
Visual Basic (Usage) Copy Code
Dim instance As OptionEventArgs
Dim value As Option

value = instance.Option
C#
public Option Option {get;}
Managed Extensions for C++
public: __property Option* get_Option();
C++/CLI
public:
property Option^ Option {
   Option^ get();
}

See Also

Reference

OptionEventArgs Class
OptionEventArgs Members


ProtocolException Class

[image]
PowerTCP Emulation for .NET
ProtocolException Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : ProtocolException Class

Glossary Item Box

Thrown when an upper-layer protocol like FTP, SMTP or POP3 receives a negative response from the server.

Object Model

ProtocolException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class ProtocolException
   Inherits System.ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As ProtocolException
C#
[Serializable()]
public class ProtocolException : System.ApplicationException
Managed Extensions for C++
[Serializable()]
public __gc class ProtocolException : public System.ApplicationException
C++/CLI
[Serializable()]
public ref class ProtocolException : public System.ApplicationException

Remarks

This exception is thrown when a server response is negative. For example, if an FTP server returned a "500" respose (indicating a syntax error) to a sent command.

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Dart.Emulation.ProtocolException

See Also

Reference

ProtocolException Members
Dart.Emulation Namespace


ProtocolException Class Members

[image]
PowerTCP Emulation for .NET
ProtocolException Class Members
See Also Properties Methods Send comments on this topic
Dart.Emulation Namespace : ProtocolException Class

Glossary Item Box

The following tables list the members exposed by ProtocolException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ProtocolException Class
Dart.Emulation Namespace


Proxy Class

[image]
PowerTCP Emulation for .NET
Proxy Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Proxy Class

Glossary Item Box

Describes the server proxy, if any, to connect to.

Object Model

Proxy ClassIPEndPoint Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class Proxy
Visual Basic (Usage) Copy Code
Dim instance As Proxy
C#
[Serializable()]
public class Proxy
Managed Extensions for C++
[Serializable()]
public __gc class Proxy
C++/CLI
[Serializable()]
public ref class Proxy

Inheritance Hierarchy

System.Object
Dart.Emulation.Proxy

See Also

Reference

Proxy Members
Dart.Emulation Namespace


Proxy Class Members

[image]
PowerTCP Emulation for .NET
Proxy Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : Proxy Class

Glossary Item Box

The following tables list the members exposed by Proxy.

Public Constructors

 | Name | Description
Public Constructor | Proxy Constructor | The default constructor for Proxy
Top

Public Properties

 | Name | Description
Public Property | Password | The password to send to the server proxy. Not used for Socks4.
Public Property | RemoteEndPoint | IPEndPoint of the server proxy to connect to.
Public Property | Type | The ProxyType desired.
Public Property | Username | The username to send to the server proxy.
Top

See Also

Reference

Proxy Class
Dart.Emulation Namespace


Proxy Constructor

[image]
PowerTCP Emulation for .NET
Proxy Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Proxy Class : Proxy Constructor

Glossary Item Box

The default constructor for Proxy

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Proxy()
C#
public Proxy()
Managed Extensions for C++
public: Proxy();
C++/CLI
public:
Proxy();

See Also

Reference

Proxy Class
Proxy Members


Proxy Class Properties

[image]
PowerTCP Emulation for .NET
Proxy Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Proxy Class

Glossary Item Box

For a list of all members of this type, see Proxy members.

Public Properties

 | Name | Description
Public Property | Password | The password to send to the server proxy. Not used for Socks4.
Public Property | RemoteEndPoint | IPEndPoint of the server proxy to connect to.
Public Property | Type | The ProxyType desired.
Public Property | Username | The username to send to the server proxy.
Top

See Also

Reference

Proxy Class
Dart.Emulation Namespace


Password Property

[image]
PowerTCP Emulation for .NET
Password Property
See Also Send comments on this topic
Dart.Emulation Namespace > Proxy Class : Password Property

Glossary Item Box

The password to send to the server proxy. Not used for Socks4.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Password As String
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As String

instance.Password = value

value = instance.Password
C#
[DefaultValue()]
public string Password {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
C++/CLI
[DefaultValue()]
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Proxy Class
Proxy Members


RemoteEndPoint Property

[image]
PowerTCP Emulation for .NET
RemoteEndPoint Property
See Also Send comments on this topic
Dart.Emulation Namespace > Proxy Class : RemoteEndPoint Property

Glossary Item Box

IPEndPoint of the server proxy to connect to.

Syntax

Visual Basic (Declaration)
Public Property RemoteEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As IPEndPoint

instance.RemoteEndPoint = value

value = instance.RemoteEndPoint
C#
public IPEndPoint RemoteEndPoint {get; set;}
Managed Extensions for C++
public: __property IPEndPoint* get_RemoteEndPoint();
public: __property void set_RemoteEndPoint(
   IPEndPoint* value
);
C++/CLI
public:
property IPEndPoint^ RemoteEndPoint {
   IPEndPoint^ get();
   void set (    IPEndPoint^ value);
}

See Also

Reference

Proxy Class
Proxy Members


Type Property

[image]
PowerTCP Emulation for .NET
Type Property
See Also Send comments on this topic
Dart.Emulation Namespace > Proxy Class : Type Property

Glossary Item Box

The ProxyType desired.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Type As ProxyType
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As ProxyType

instance.Type = value

value = instance.Type
C#
[DefaultValue()]
public ProxyType Type {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property ProxyType get_Type();
public: __property void set_Type(
   ProxyType value
);
C++/CLI
[DefaultValue()]
public:
property ProxyType Type {
   ProxyType get();
   void set (    ProxyType value);
}

See Also

Reference

Proxy Class
Proxy Members


Username Property

[image]
PowerTCP Emulation for .NET
Username Property
See Also Send comments on this topic
Dart.Emulation Namespace > Proxy Class : Username Property

Glossary Item Box

The username to send to the server proxy.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Username As String
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As String

instance.Username = value

value = instance.Username
C#
[DefaultValue()]
public string Username {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property string* get_Username();
public: __property void set_Username(
   string* value
);
C++/CLI
[DefaultValue()]
public:
property String^ Username {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Proxy Class
Proxy Members


PtyBase Class

[image]
PowerTCP Emulation for .NET
PtyBase Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : PtyBase Class

Glossary Item Box

This class provides support for interactive on-line terminal access using controls derived from TextBoxBase.

Object Model

PtyBase ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class PtyBase
   Inherits TcpBase
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
C#
public class PtyBase : TcpBase
Managed Extensions for C++
public __gc class PtyBase : public TcpBase
C++/CLI
public ref class PtyBase : public TcpBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Emulation.ComponentBase
Dart.Emulation.SocketBase
Dart.Emulation.TcpBase
Dart.Emulation.PtyBase
Dart.Emulation.Rlogin
Dart.Emulation.Telnet

See Also

Reference

PtyBase Members
Dart.Emulation Namespace


PtyBase Class Members

[image]
PowerTCP Emulation for .NET
PtyBase Class Members
See Also Properties Methods Events Send comments on this topic
Dart.Emulation Namespace : PtyBase Class

Glossary Item Box

The following tables list the members exposed by PtyBase.

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | Set to true if the Pty property is used and a CR should be converted to a CRLF for sending.
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | LocalEcho | Set to true if the Pty property is used and keystrokes should be displayed in the textbox.
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support.
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Emulation.TcpBase)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

Public Events

 | Name | Description
Public Event | Data | Raised when TcpBase.Marshal is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Emulation Namespace


PtyBase Class Properties

[image]
PowerTCP Emulation for .NET
PtyBase Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : PtyBase Class

Glossary Item Box

For a list of all members of this type, see PtyBase members.

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | Set to true if the Pty property is used and a CR should be converted to a CRLF for sending.
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | LocalEcho | Set to true if the Pty property is used and keystrokes should be displayed in the textbox.
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support.
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Emulation Namespace


CRLF Property

[image]
PowerTCP Emulation for .NET
CRLF Property
See Also Send comments on this topic
Dart.Emulation Namespace > PtyBase Class : CRLF Property

Glossary Item Box

Set to true if the Pty property is used and a CR should be converted to a CRLF for sending.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CRLF As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
Dim value As Boolean

instance.CRLF = value

value = instance.CRLF
C#
[DefaultValue()]
public bool CRLF {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_CRLF();
public: __property void set_CRLF(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool CRLF {
   bool get();
   void set (    bool value);
}

Remarks

This property controls the behavior of the TextBox assigned to the Pty property. For example, the Echo protocol echoes back any sent character. Since as textbox requires a CRLF, set this property to true so that a CRLF will be generated when the return key is pressed. Defaults to false.

See Also

Reference

PtyBase Class
PtyBase Members


LocalEcho Property

[image]
PowerTCP Emulation for .NET
LocalEcho Property
See Also Send comments on this topic
Dart.Emulation Namespace > PtyBase Class : LocalEcho Property

Glossary Item Box

Set to true if the Pty property is used and keystrokes should be displayed in the textbox.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property LocalEcho As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
Dim value As Boolean

instance.LocalEcho = value

value = instance.LocalEcho
C#
[DefaultValue()]
public bool LocalEcho {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_LocalEcho();
public: __property void set_LocalEcho(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool LocalEcho {
   bool get();
   void set (    bool value);
}

Remarks

This property controls the behavior of the TextBox assigned to the Pty property. For example, the Pop protocol does not echo sent characters to the screen. Set this property to true to see the characters being sent to the Pop server. Defaults to false.

See Also

Reference

PtyBase Class
PtyBase Members


Pty Property

[image]
PowerTCP Emulation for .NET
Pty Property
See Also Send comments on this topic
Dart.Emulation Namespace > PtyBase Class : Pty Property

Glossary Item Box

Gets or sets a display control to use for automatic pseudo terminal support.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Pty As TextBoxBase
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
Dim value As TextBoxBase

instance.Pty = value

value = instance.Pty
C#
[DefaultValue()]
public TextBoxBase Pty {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property TextBoxBase* get_Pty();
public: __property void set_Pty(
   TextBoxBase* value
);
C++/CLI
[DefaultValue()]
public:
property TextBoxBase^ Pty {
   TextBoxBase^ get();
   void set (    TextBoxBase^ value);
}

Remarks

Set this property to a control derived from TextBoxBase and call Connect to start an online session. Data received from the host will be displayed, and keyboard input will automatically be sent to the remote host.

The Multiline property on the Pty control is set to true. You may wish to set the Font property to a fixed-width font and set the Wordwrap property to false. Also, if the SynchronizingObject is null, it will be set to the Pty control.

These properties can be changed from their default values after this property is set.

See Also

Reference

PtyBase Class
PtyBase Members


Rexec Class

[image]
PowerTCP Emulation for .NET
Rexec Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Rexec Class

Glossary Item Box

The Rexec component enables use of the remote execution protocol within any .NET application.

Object Model

Rexec ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Rexec
   Inherits TcpBase
Visual Basic (Usage) Copy Code
Dim instance As Rexec
C#
public class Rexec : TcpBase
Managed Extensions for C++
public __gc class Rexec : public TcpBase
C++/CLI
public ref class Rexec : public TcpBase

Remarks

Use the Rexec component to execute a command on a remote host (typically a UNIX host). To use the Rexec component, call one of the Connect methods to connect, then call Execute to execute the command, and then use one of the Read methods to read the results of the command.

Rexec and Rsh perform the same task using different authentication techniques. Rsh requires static information be added to .rhosts and/or hosts.equiv, whereas Rexec simply uses dynamic username/password information for authentication.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Emulation.ComponentBase
Dart.Emulation.SocketBase
Dart.Emulation.TcpBase
Dart.Emulation.Rexec

See Also

Reference

Rexec Members
Dart.Emulation Namespace


Rexec Class Members

[image]
PowerTCP Emulation for .NET
Rexec Class Members
See Also Fields Properties Methods Events Send comments on this topic
Dart.Emulation Namespace : Rexec Class

Glossary Item Box

The following tables list the members exposed by Rexec.

Public Constructors

 | Name | Description
Public Constructor | Rexec Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultPort | The "well-known" default port 512 for Rexec.
Top

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Overloaded. Connects to a Rexec server.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Execute | Executes a command on the remote host.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Emulation.TcpBase)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Start | Starts a worker thread on which the specified delegate function executes.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

Public Events

 | Name | Description
Public Event | Data | Raised when TcpBase.Marshal is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Emulation Namespace


Rexec Constructor

[image]
PowerTCP Emulation for .NET
Rexec Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Rexec Class : Rexec Constructor

Glossary Item Box

Overload List

Overload | Description
Rexec Constructor() | Initializes a new instance of the Rexec component.
Rexec Constructor(IContainer) | Initializes a new instance of the Rexec component.

See Also

Reference

Rexec Class
Rexec Members


Rexec Constructor()

[image]
PowerTCP Emulation for .NET
Rexec Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > Rexec Class > Rexec Constructor : Rexec Constructor()

Glossary Item Box

Initializes a new instance of the Rexec component.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rexec()
C#
public Rexec()
Managed Extensions for C++
public: Rexec();
C++/CLI
public:
Rexec();

See Also

Reference

Rexec Class
Rexec Members
Overload List


Rexec Constructor(IContainer)

[image]
PowerTCP Emulation for .NET
Rexec Constructor(IContainer)
See Also Send comments on this topic
Dart.Emulation Namespace > Rexec Class > Rexec Constructor : Rexec Constructor(IContainer)

container
The container to which the Rexec component is added.

Glossary Item Box

Initializes a new instance of the Rexec component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Rexec(container)
C#
public Rexec(
   IContainer container
)
Managed Extensions for C++
public: Rexec(
   IContainer* container
)
C++/CLI
public:
Rexec(
   IContainer^ container
)

Parameters

container
The container to which the Rexec component is added.

See Also

Reference

Rexec Class
Rexec Members
Overload List


Rexec Class Methods

[image]
PowerTCP Emulation for .NET
Rexec Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : Rexec Class

Glossary Item Box

For a list of all members of this type, see Rexec members.

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Overloaded. Connects to a Rexec server.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Execute | Executes a command on the remote host.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Emulation.TcpBase)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Start | Starts a worker thread on which the specified delegate function executes.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

See Also

Reference

Rexec Class
Dart.Emulation Namespace


Connect Method

[image]
PowerTCP Emulation for .NET
Connect Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rexec Class : Connect Method

Glossary Item Box

Connects to a Rexec server.

Overload List

Overload | Description
Connect(String) | Connects to a Rexec server.
Connect | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)

See Also

Reference

Rexec Class
Rexec Members


Connect(String) Method

[image]
PowerTCP Emulation for .NET
Connect(String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rexec Class > Connect Method : Connect(String) Method

hostNameOrAddress
The remote host name or address to connect to.

Glossary Item Box

Connects to a Rexec server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rexec
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
)
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress
The remote host name or address to connect to.

Remarks

This method attempts to connect to the remote host on the default port of 512.

Use Connect(TcpSession) to connect to a server on an alternative port.

See Also

Reference

Rexec Class
Rexec Members
Overload List


Execute Method

[image]
PowerTCP Emulation for .NET
Execute Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rexec Class : Execute Method

username
The login name of the user account.
password
The password of the user account.
command
The command to execute.

Glossary Item Box

Executes a command on the remote host.

Syntax

Visual Basic (Declaration)
Public Sub Execute( _
   ByVal username As String, _
   ByVal password As String, _
   ByVal command As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rexec
Dim username As String
Dim password As String
Dim command As String

instance.Execute(username, password, command)
C#
public void Execute(
   string username,
   string password,
   string command
)
Managed Extensions for C++
public: void Execute(
   string* username,
   string* password,
   string* command
)
C++/CLI
public:
void Execute(
   String^ username,
   String^ password,
   String^ command
)

Parameters

username
The login name of the user account.
password
The password of the user account.
command
The command to execute.

Remarks

Use the Connect method to first connect to the remote host on the well-known port of 512. Then use Execute to authenticate using username and password and execute the command specified by command.

Use one of the Read methods to get the server's output.

When the server responds to a REXEC command, the first byte received indicates success/failure (0 for success, 1 for failure). When using the Rexec component, if the first byte is a 1 (meaning failure) an IOException is thrown. The Exception.Message will contain the response from the server without the first byte.

See Also

Reference

Rexec Class
Rexec Members


Start Method

[image]
PowerTCP Emulation for .NET
Start Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Rexec Class : Start Method

worker
WaitCallback delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Glossary Item Box

Starts a worker thread on which the specified delegate function executes.

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As WaitCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rexec
Dim worker As WaitCallback
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   WaitCallback worker,
   object state
)
Managed Extensions for C++
public: void Start(
   WaitCallback* worker,
   Object* state
)
C++/CLI
public:
void Start(
   WaitCallback^ worker,
   Object^ state
)

Parameters

worker
WaitCallback delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Remarks

This method provides an easy means for executing blocking functions on a worker thread. Applications with a UI thread should use this technique to execute processes (like Connect and Read) that can block the UI thread.

The state parameter can be null for cases in which no state information needs to be passed to the worker delegate function.

Unhandled exceptions occurring on the worker thread will be caught and reported in the Error event.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data to the UI.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Receive data on a separate thread
    myComponent.Start(receiveData, null);
}

private void receiveData(object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (myComponent.State != ConnectionState.Closed)
        myComponent.Marshal(myComponent.Read(buffer, 0, 1024), "", null);
}

private void myComponent_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.AppendText(e.Data.ToString());
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    'Receive data on a separate thread
    myComponent.Start(AddressOf receiveData, Nothing)
End Sub

Private Sub receiveData(ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023) {}
    Do While myComponent.State <> ConnectionState.Closed
        myComponent.Marshal(myComponent.Read(buffer, 0, 1024), "", Nothing)
    Loop
End Sub

Private Sub myComponent_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles myComponent.Data
    'Whenever data is received, display it
    textDisplay.AppendText(e.Data.ToString())
End Sub

See Also

Reference

Rexec Class
Rexec Members


Rexec Class Fields

[image]
PowerTCP Emulation for .NET
Rexec Class Fields
See Also Send comments on this topic
Dart.Emulation Namespace : Rexec Class

Glossary Item Box

For a list of all members of this type, see Rexec members.

Public Fields

 | Name | Description
Public Field | DefaultPort | The "well-known" default port 512 for Rexec.
Top

See Also

Reference

Rexec Class
Dart.Emulation Namespace


DefaultPort Field

[image]
PowerTCP Emulation for .NET
DefaultPort Field
See Also Send comments on this topic
Dart.Emulation Namespace > Rexec Class : DefaultPort Field

Glossary Item Box

The "well-known" default port 512 for Rexec.

Syntax

Visual Basic (Declaration)
Public Const DefaultPort As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = Rexec.DefaultPort
C#
public const int DefaultPort
Managed Extensions for C++
public: const int DefaultPort
C++/CLI
public:
const int DefaultPort

See Also

Reference

Rexec Class
Rexec Members


Rlogin Class

[image]
PowerTCP Emulation for .NET
Rlogin Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Rlogin Class

Glossary Item Box

The Rlogin component enables use of the remote login protocol within any .NET application.

Object Model

Rlogin ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Rlogin
   Inherits PtyBase
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
C#
public class Rlogin : PtyBase
Managed Extensions for C++
public __gc class Rlogin : public PtyBase
C++/CLI
public ref class Rlogin : public PtyBase

Remarks

Use the Rlogin component to login to a remote host (typically a UNIX host). To use the Rlogin component, call the Connect and Login methods, passing in the appropriate parameters. Once connected, send commands to the remote host by using Write; receive data from the remote host using Read.

Rlogin is similar to Telnet, but has less complexity. Rlogin does not support telnet option negotiation, but does support the window size construct. Set the DisplayCharacters and DisplayPixels properties and the appropriate window size response is sent when the server requests this information.

Rlogin requires authorization for the local host running the application. To do this, add the appropriate entries to the hosts.equiv or .rhosts files located on the remote host. These files enable login from other machines and users. The hosts.equiv file is a system file containing names of remote hosts authorized to execute the remote protocol. If not authorized in this file, the remote host looks for the .rhosts file located in the user's account on the remote host. The .rhosts file contains lines of host names and login names paired together. If the remote hosts .rhosts file lacks an entry for the client, the server will request an interactive login, like Telnet.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Emulation.ComponentBase
Dart.Emulation.SocketBase
Dart.Emulation.TcpBase
Dart.Emulation.PtyBase
Dart.Emulation.Rlogin

See Also

Reference

Rlogin Members
Dart.Emulation Namespace


Rlogin Class Members

[image]
PowerTCP Emulation for .NET
Rlogin Class Members
See Also Fields Properties Methods Events Send comments on this topic
Dart.Emulation Namespace : Rlogin Class

Glossary Item Box

The following tables list the members exposed by Rlogin.

Public Constructors

 | Name | Description
Public Constructor | Rlogin Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultPort | The "well-known" default port 513 for Rlogin.
Top

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | Set to true if the Pty property is used and a CR should be converted to a CRLF for sending. (Inherited from Dart.Emulation.PtyBase)
Public Property | DisplayCharacters | Gets or sets a value representing the number of columns and rows sent to the host during login.
Public Property | DisplayPixels | Gets or sets the size of the display sent to the remote host during login.
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | LocalEcho | Set to true if the Pty property is used and keystrokes should be displayed in the textbox. (Inherited from Dart.Emulation.PtyBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support. (Inherited from Dart.Emulation.PtyBase)
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Public Property | TerminalTypeSpeed | Gets or sets the terminal type and speed.
Top

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Overloaded. Connects to an Rlogin server.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Emulation.TcpBase)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Login | Overloaded. Log into an Rlogin server.
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Start | Starts a worker thread on which the specified delegate function executes.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

Public Events

 | Name | Description
Public Event | Data | Raised when TcpBase.Marshal is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Rlogin Class
Dart.Emulation Namespace


Rlogin Constructor

[image]
PowerTCP Emulation for .NET
Rlogin Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class : Rlogin Constructor

Glossary Item Box

Overload List

Overload | Description
Rlogin Constructor() | Initializes a new instance of the Rlogin component.
Rlogin Constructor(IContainer) | Initializes a new instance of the Rlogin component.

See Also

Reference

Rlogin Class
Rlogin Members


Rlogin Constructor()

[image]
PowerTCP Emulation for .NET
Rlogin Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class > Rlogin Constructor : Rlogin Constructor()

Glossary Item Box

Initializes a new instance of the Rlogin component.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rlogin()
C#
public Rlogin()
Managed Extensions for C++
public: Rlogin();
C++/CLI
public:
Rlogin();

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Rlogin Constructor(IContainer)

[image]
PowerTCP Emulation for .NET
Rlogin Constructor(IContainer)
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class > Rlogin Constructor : Rlogin Constructor(IContainer)

container
The container to which the Rlogin component is added.

Glossary Item Box

Initializes a new instance of the Rlogin component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Rlogin(container)
C#
public Rlogin(
   IContainer container
)
Managed Extensions for C++
public: Rlogin(
   IContainer* container
)
C++/CLI
public:
Rlogin(
   IContainer^ container
)

Parameters

container
The container to which the Rlogin component is added.

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Rlogin Class Methods

[image]
PowerTCP Emulation for .NET
Rlogin Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : Rlogin Class

Glossary Item Box

For a list of all members of this type, see Rlogin members.

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Overloaded. Connects to an Rlogin server.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Emulation.TcpBase)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Login | Overloaded. Log into an Rlogin server.
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Start | Starts a worker thread on which the specified delegate function executes.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

See Also

Reference

Rlogin Class
Dart.Emulation Namespace


Connect Method

[image]
PowerTCP Emulation for .NET
Connect Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class : Connect Method

Glossary Item Box

Connects to an Rlogin server.

Overload List

Overload | Description
Connect(String) | Connects to an Rlogin server.
Connect | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)

See Also

Reference

Rlogin Class
Rlogin Members


Connect(String) Method

[image]
PowerTCP Emulation for .NET
Connect(String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class > Connect Method : Connect(String) Method

hostNameOrAddress
The remote host name or address to connect to.

Glossary Item Box

Connects to an Rlogin server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
)
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress
The remote host name or address to connect to.

Remarks

This method attempts to connect to the remote host on the default port of 513.

Since the rlogin and rsh protocols require a local port between 512 and 1023 (inclusively), this library attempts to bind to an open local port within this range. This feature allows you to use this protocol hundreds of times without running out of local ports.

Use Connect(TcpSession) to connect to a server on an alternative port, or specify the local endpoint.

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Login Method

[image]
PowerTCP Emulation for .NET
Login Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class : Login Method

Glossary Item Box

Log into an Rlogin server.

Overload List

Overload | Description
Login(String) | Log into an Rlogin server.
Login(String,String) | Log into an Rlogin server.

See Also

Reference

Rlogin Class
Rlogin Members


Login(String) Method

[image]
PowerTCP Emulation for .NET
Login(String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class > Login Method : Login(String) Method

username
The username sent during login.

Glossary Item Box

Log into an Rlogin server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Login( _
   ByVal username As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim username As String

instance.Login(username)
C#
public void Login(
   string username
)
Managed Extensions for C++
public: void Login(
   string* username
)
C++/CLI
public:
void Login(
   String^ username
)

Parameters

username
The username sent during login.

Remarks

This method should be used after the Connect method completes successfully.

The username is the login name of the user as known on the server.

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Login(String,String) Method

[image]
PowerTCP Emulation for .NET
Login(String,String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class > Login Method : Login(String,String) Method

username
The username sent during login.
clientUsername
Login name of the user on the client host.

Glossary Item Box

Log into an Rlogin server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Login( _
   ByVal username As String, _
   ByVal clientUsername As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim username As String
Dim clientUsername As String

instance.Login(username, clientUsername)
C#
public void Login(
   string username,
   string clientUsername
)
Managed Extensions for C++
public: void Login(
   string* username,
   string* clientUsername
)
C++/CLI
public:
void Login(
   String^ username,
   String^ clientUsername
)

Parameters

username
The username sent during login.
clientUsername
Login name of the user on the client host.

Remarks

This method should be used after the Connect method completes successfully.

The username is the login name of the user as known on the server. The clientUsername may be used if the client username differs from the server username.

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Start Method

[image]
PowerTCP Emulation for .NET
Start Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Rlogin Class : Start Method

worker
WaitCallback delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Glossary Item Box

Starts a worker thread on which the specified delegate function executes.

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As WaitCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim worker As WaitCallback
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   WaitCallback worker,
   object state
)
Managed Extensions for C++
public: void Start(
   WaitCallback* worker,
   Object* state
)
C++/CLI
public:
void Start(
   WaitCallback^ worker,
   Object^ state
)

Parameters

worker
WaitCallback delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Remarks

This method provides an easy means for executing blocking functions on a worker thread. Applications with a UI thread should use this technique to execute processes (like Connect and Read) that can block the UI thread.

The state parameter can be null for cases in which no state information needs to be passed to the worker delegate function.

Unhandled exceptions occurring on the worker thread will be caught and reported in the Error event.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data to the UI.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Receive data on a separate thread
    myComponent.Start(receiveData, null);
}

private void receiveData(object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (myComponent.State != ConnectionState.Closed)
        myComponent.Marshal(myComponent.Read(buffer, 0, 1024), "", null);
}

private void myComponent_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.AppendText(e.Data.ToString());
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    'Receive data on a separate thread
    myComponent.Start(AddressOf receiveData, Nothing)
End Sub

Private Sub receiveData(ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023) {}
    Do While myComponent.State <> ConnectionState.Closed
        myComponent.Marshal(myComponent.Read(buffer, 0, 1024), "", Nothing)
    Loop
End Sub

Private Sub myComponent_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles myComponent.Data
    'Whenever data is received, display it
    textDisplay.AppendText(e.Data.ToString())
End Sub

See Also

Reference

Rlogin Class
Rlogin Members


Rlogin Class Properties

[image]
PowerTCP Emulation for .NET
Rlogin Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Rlogin Class

Glossary Item Box

For a list of all members of this type, see Rlogin members.

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | Set to true if the Pty property is used and a CR should be converted to a CRLF for sending. (Inherited from Dart.Emulation.PtyBase)
Public Property | DisplayCharacters | Gets or sets a value representing the number of columns and rows sent to the host during login.
Public Property | DisplayPixels | Gets or sets the size of the display sent to the remote host during login.
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | LocalEcho | Set to true if the Pty property is used and keystrokes should be displayed in the textbox. (Inherited from Dart.Emulation.PtyBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support. (Inherited from Dart.Emulation.PtyBase)
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Public Property | TerminalTypeSpeed | Gets or sets the terminal type and speed.
Top

See Also

Reference

Rlogin Class
Dart.Emulation Namespace


DisplayCharacters Property

[image]
PowerTCP Emulation for .NET
DisplayCharacters Property
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class : DisplayCharacters Property

Glossary Item Box

Gets or sets a value representing the number of columns and rows sent to the host during login.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DisplayCharacters As Size
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim value As Size

instance.DisplayCharacters = value

value = instance.DisplayCharacters
C#
[DefaultValue()]
public Size DisplayCharacters {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Size get_DisplayCharacters();
public: __property void set_DisplayCharacters(
   Size value
);
C++/CLI
[DefaultValue()]
public:
property Size DisplayCharacters {
   Size get();
   void set (    Size value);
}

Property Value

A Size object representing character display information. Defaults to (72, 24).

Remarks

When using the Rlogin protocol, the remote host may request window size information. The Rlogin component will reply with the value of this property and the Rlogin.DisplayPixels property.

Height represents the number of character rows (defaults to 24). Width represents the number of characters per row (defaults to 72).

See Also

Reference

Rlogin Class
Rlogin Members


DisplayPixels Property

[image]
PowerTCP Emulation for .NET
DisplayPixels Property
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class : DisplayPixels Property

Glossary Item Box

Gets or sets the size of the display sent to the remote host during login.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DisplayPixels As Size
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim value As Size

instance.DisplayPixels = value

value = instance.DisplayPixels
C#
[DefaultValue()]
public Size DisplayPixels {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Size get_DisplayPixels();
public: __property void set_DisplayPixels(
   Size value
);
C++/CLI
[DefaultValue()]
public:
property Size DisplayPixels {
   Size get();
   void set (    Size value);
}

Property Value

A Size object representing the pixel size of the display. Defaults to (640, 480).

Remarks

When using the Rlogin protocol, the remote host may request window size information. The Rlogin component will reply with the value of the DisplayCharacters property and this property.

Height represents number of client window pixels in the Y direction (defaults to 640). Width represents number of client window pixels in the X direction (defaults to 480).

See Also

Reference

Rlogin Class
Rlogin Members


TerminalTypeSpeed Property

[image]
PowerTCP Emulation for .NET
TerminalTypeSpeed Property
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class : TerminalTypeSpeed Property

Glossary Item Box

Gets or sets the terminal type and speed.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TerminalTypeSpeed As String
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim value As String

instance.TerminalTypeSpeed = value

value = instance.TerminalTypeSpeed
C#
[DefaultValue()]
public string TerminalTypeSpeed {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property string* get_TerminalTypeSpeed();
public: __property void set_TerminalTypeSpeed(
   string* value
);
C++/CLI
[DefaultValue()]
public:
property String^ TerminalTypeSpeed {
   String^ get();
   void set (    String^ value);
}

Property Value

A string representing the terminal type and speed. Defaults to "vt320/19200".

Remarks

The Rlogin protocol dictates that client terminal type and terminal speed is sent to the remote host during login. Set this property before logging in.

The format for this string is [terminal type]/[terminal speed]. For example, "vt320/19200".

See Also

Reference

Rlogin Class
Rlogin Members


Rlogin Class Fields

[image]
PowerTCP Emulation for .NET
Rlogin Class Fields
See Also Send comments on this topic
Dart.Emulation Namespace : Rlogin Class

Glossary Item Box

For a list of all members of this type, see Rlogin members.

Public Fields

 | Name | Description
Public Field | DefaultPort | The "well-known" default port 513 for Rlogin.
Top

See Also

Reference

Rlogin Class
Dart.Emulation Namespace


DefaultPort Field

[image]
PowerTCP Emulation for .NET
DefaultPort Field
See Also Send comments on this topic
Dart.Emulation Namespace > Rlogin Class : DefaultPort Field

Glossary Item Box

The "well-known" default port 513 for Rlogin.

Syntax

Visual Basic (Declaration)
Public Const DefaultPort As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = Rlogin.DefaultPort
C#
public const int DefaultPort
Managed Extensions for C++
public: const int DefaultPort
C++/CLI
public:
const int DefaultPort

See Also

Reference

Rlogin Class
Rlogin Members


Rsh Class

[image]
PowerTCP Emulation for .NET
Rsh Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Rsh Class

Glossary Item Box

The Rsh component enables use of the remote shell protocol within any .NET application.

Object Model

Rsh ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Rsh
   Inherits TcpBase
Visual Basic (Usage) Copy Code
Dim instance As Rsh
C#
public class Rsh : TcpBase
Managed Extensions for C++
public __gc class Rsh : public TcpBase
C++/CLI
public ref class Rsh : public TcpBase

Remarks

Use the Rsh component to execute a command on a remote host (typically a UNIX host). To use the Rsh component, call Connect to connect, call one of the Execute methods to execute the command, and then use one of the Read methods to read the results of the command.

Rexec and Rsh perform the same task using different authentication techniques. Rsh requires static information be added to .rhosts and/or hosts.equiv, whereas Rexec simply uses dynamic username/password information for authentication.

Using Rsh requires authorization for the local host running the application. To do this, add the appropriate entries to the hosts.equiv or .rhosts files located on the remote host. These files enable login from other machines and users. The hosts.equiv file is a system file containing names of remote hosts authorized to execute the remote protocol. If not authorized in this file, the remote host looks for the .rhosts file located in the user's account on the remote host. The .rhosts file contains lines of host names and login names paired together. Your local host with login name is authorized if found in this file.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Emulation.ComponentBase
Dart.Emulation.SocketBase
Dart.Emulation.TcpBase
Dart.Emulation.Rsh

See Also

Reference

Rsh Members
Dart.Emulation Namespace


Rsh Class Members

[image]
PowerTCP Emulation for .NET
Rsh Class Members
See Also Fields Properties Methods Events Send comments on this topic
Dart.Emulation Namespace : Rsh Class

Glossary Item Box

The following tables list the members exposed by Rsh.

Public Constructors

 | Name | Description
Public Constructor | Rsh Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultPort | The "well-known" default port 514 for Rsh.
Top

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Overloaded. Connects to an Rsh server.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Execute | Overloaded. Execute a command on the Rsh server.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Emulation.TcpBase)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Start | Starts a worker thread on which the specified delegate function executes.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

Public Events

 | Name | Description
Public Event | Data | Raised when TcpBase.Marshal is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Emulation Namespace


Rsh Constructor

[image]
PowerTCP Emulation for .NET
Rsh Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Rsh Class : Rsh Constructor

Glossary Item Box

Overload List

Overload | Description
Rsh Constructor() | Initializes a new instance of the Rsh component.
Rsh Constructor(IContainer) | Initializes a new instance of the Rsh component.

See Also

Reference

Rsh Class
Rsh Members


Rsh Constructor()

[image]
PowerTCP Emulation for .NET
Rsh Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > Rsh Class > Rsh Constructor : Rsh Constructor()

Glossary Item Box

Initializes a new instance of the Rsh component.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rsh()
C#
public Rsh()
Managed Extensions for C++
public: Rsh();
C++/CLI
public:
Rsh();

See Also

Reference

Rsh Class
Rsh Members
Overload List


Rsh Constructor(IContainer)

[image]
PowerTCP Emulation for .NET
Rsh Constructor(IContainer)
See Also Send comments on this topic
Dart.Emulation Namespace > Rsh Class > Rsh Constructor : Rsh Constructor(IContainer)

container
The container to which the Rsh component is added.

Glossary Item Box

Initializes a new instance of the Rsh component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Rsh(container)
C#
public Rsh(
   IContainer container
)
Managed Extensions for C++
public: Rsh(
   IContainer* container
)
C++/CLI
public:
Rsh(
   IContainer^ container
)

Parameters

container
The container to which the Rsh component is added.

See Also

Reference

Rsh Class
Rsh Members
Overload List


Rsh Class Methods

[image]
PowerTCP Emulation for .NET
Rsh Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : Rsh Class

Glossary Item Box

For a list of all members of this type, see Rsh members.

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Overloaded. Connects to an Rsh server.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Execute | Overloaded. Execute a command on the Rsh server.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Emulation.TcpBase)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Start | Starts a worker thread on which the specified delegate function executes.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

See Also

Reference

Rsh Class
Dart.Emulation Namespace


Connect Method

[image]
PowerTCP Emulation for .NET
Connect Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rsh Class : Connect Method

Glossary Item Box

Connects to an Rsh server.

Overload List

Overload | Description
Connect(String) | Connects to an Rsh server.
Connect | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)

See Also

Reference

Rsh Class
Rsh Members


Connect(String) Method

[image]
PowerTCP Emulation for .NET
Connect(String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rsh Class > Connect Method : Connect(String) Method

hostNameOrAddress
The remote host name or address to connect to.

Glossary Item Box

Connects to an Rsh server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
)
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress
The remote host name or address to connect to.

Remarks

This method attempts to connect to the remote host on the default port of 514.

Since the rlogin and rsh protocols require a local port between 512 and 1023 (inclusively), this library attempts to bind to an open local port within this range. This feature allows you to use this protocol hundreds of times without running out of local ports.

Use Connect(TcpSession) to connect to a server on an alternative port, or specify the local endpoint.

See Also

Reference

Rsh Class
Rsh Members
Overload List


Execute Method

[image]
PowerTCP Emulation for .NET
Execute Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rsh Class : Execute Method

Glossary Item Box

Execute a command on the Rsh server.

Overload List

Overload | Description
Execute(String,String) | Execute a command on the Rsh server.
Execute(String,String,String) | Execute a command on the Rsh server.

See Also

Reference

Rsh Class
Rsh Members


Execute(String,String) Method

[image]
PowerTCP Emulation for .NET
Execute(String,String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rsh Class > Execute Method : Execute(String,String) Method

username
The login name of the user account.
command
The command to execute.

Glossary Item Box

Execute a command on the Rsh server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Execute( _
   ByVal username As String, _
   ByVal command As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim username As String
Dim command As String

instance.Execute(username, command)
C#
public void Execute(
   string username,
   string command
)
Managed Extensions for C++
public: void Execute(
   string* username,
   string* command
)
C++/CLI
public:
void Execute(
   String^ username,
   String^ command
)

Parameters

username
The login name of the user account.
command
The command to execute.

Remarks

This method executes the command specified by command. A Read method should be used to get the results.

See Also

Reference

Rsh Class
Rsh Members
Overload List


Execute(String,String,String) Method

[image]
PowerTCP Emulation for .NET
Execute(String,String,String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Rsh Class > Execute Method : Execute(String,String,String) Method

username
The login name of the user as known to the server.
command
The command to execute.
clientUsername
Login name of the user on the client host.

Glossary Item Box

Execute a command on the Rsh server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Execute( _
   ByVal username As String, _
   ByVal command As String, _
   ByVal clientUsername As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim username As String
Dim command As String
Dim clientUsername As String

instance.Execute(username, command, clientUsername)
C#
public void Execute(
   string username,
   string command,
   string clientUsername
)
Managed Extensions for C++
public: void Execute(
   string* username,
   string* command,
   string* clientUsername
)
C++/CLI
public:
void Execute(
   String^ username,
   String^ command,
   String^ clientUsername
)

Parameters

username
The login name of the user as known to the server.
command
The command to execute.
clientUsername
Login name of the user on the client host.

Remarks

This method executes the command specified by command. A Read method should be used to get the results.

The username is the login name of the user as known on the server. The clientUsername may be used if the client username differs from the server username.

Use Connect(TcpSession) to connect to a port other than 514.

See Also

Reference

Rsh Class
Rsh Members
Overload List


Start Method

[image]
PowerTCP Emulation for .NET
Start Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Rsh Class : Start Method

worker
WaitCallback delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Glossary Item Box

Starts a worker thread on which the specified delegate function executes.

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As WaitCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim worker As WaitCallback
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   WaitCallback worker,
   object state
)
Managed Extensions for C++
public: void Start(
   WaitCallback* worker,
   Object* state
)
C++/CLI
public:
void Start(
   WaitCallback^ worker,
   Object^ state
)

Parameters

worker
WaitCallback delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Remarks

This method provides an easy means for executing blocking functions on a worker thread. Applications with a UI thread should use this technique to execute processes (like Connect and Read) that can block the UI thread.

The state parameter can be null when no state information needs to be passed to the worker delegate function.

Unhandled exceptions thrown on the worker thread are reported by the Error event.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data to the UI.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Receive data on a separate thread
    myComponent.Start(receiveData, null);
}

private void receiveData(object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (myComponent.State != ConnectionState.Closed)
        myComponent.Marshal(myComponent.Read(buffer, 0, 1024), "", null);
}

private void myComponent_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.AppendText(e.Data.ToString());
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    'Receive data on a separate thread
    myComponent.Start(AddressOf receiveData, Nothing)
End Sub

Private Sub receiveData(ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023) {}
    Do While myComponent.State <> ConnectionState.Closed
        myComponent.Marshal(myComponent.Read(buffer, 0, 1024), "", Nothing)
    Loop
End Sub

Private Sub myComponent_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles myComponent.Data
    'Whenever data is received, display it
    textDisplay.AppendText(e.Data.ToString())
End Sub

See Also

Reference

Rsh Class
Rsh Members


Rsh Class Fields

[image]
PowerTCP Emulation for .NET
Rsh Class Fields
See Also Send comments on this topic
Dart.Emulation Namespace : Rsh Class

Glossary Item Box

For a list of all members of this type, see Rsh members.

Public Fields

 | Name | Description
Public Field | DefaultPort | The "well-known" default port 514 for Rsh.
Top

See Also

Reference

Rsh Class
Dart.Emulation Namespace


DefaultPort Field

[image]
PowerTCP Emulation for .NET
DefaultPort Field
See Also Send comments on this topic
Dart.Emulation Namespace > Rsh Class : DefaultPort Field

Glossary Item Box

The "well-known" default port 514 for Rsh.

Syntax

Visual Basic (Declaration)
Public Const DefaultPort As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = Rsh.DefaultPort
C#
public const int DefaultPort
Managed Extensions for C++
public: const int DefaultPort
C++/CLI
public:
const int DefaultPort

See Also

Reference

Rsh Class
Rsh Members


Security Class

[image]
PowerTCP Emulation for .NET
Security Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Security Class

Glossary Item Box

Holds the configuration used to establish an SSL session.

Object Model

Security Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class Security
Visual Basic (Usage) Copy Code
Dim instance As Security
C#
[Serializable()]
public class Security
Managed Extensions for C++
[Serializable()]
public __gc class Security
C++/CLI
[Serializable()]
public ref class Security

Inheritance Hierarchy

System.Object
Dart.Emulation.Security
Dart.Emulation.ClientSecurity

See Also

Reference

Security Members
Dart.Emulation Namespace


Security Class Members

[image]
PowerTCP Emulation for .NET
Security Class Members
See Also Fields Properties Send comments on this topic
Dart.Emulation Namespace : Security Class

Glossary Item Box

The following tables list the members exposed by Security.

Public Constructors

 | Name | Description
Public Constructor | Security Constructor | The default constructor for Security
Top

Public Fields

 | Name | Description
Public Field | ValidationCallback | The delegate that executes after the server provides its certificate to the client.
Top

Public Properties

 | Name | Description
Public Property | CheckCertificateRevocation | Indicates whether the certificate revocation list is checked during authentication.
Public Property | Protocols | Gets or sets the SSLProtocols available.
Top

See Also

Reference

Security Class
Dart.Emulation Namespace


Security Constructor

[image]
PowerTCP Emulation for .NET
Security Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Security Class : Security Constructor

Glossary Item Box

The default constructor for Security

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Security()
C#
public Security()
Managed Extensions for C++
public: Security();
C++/CLI
public:
Security();

See Also

Reference

Security Class
Security Members


Security Class Properties

[image]
PowerTCP Emulation for .NET
Security Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Security Class

Glossary Item Box

For a list of all members of this type, see Security members.

Public Properties

 | Name | Description
Public Property | CheckCertificateRevocation | Indicates whether the certificate revocation list is checked during authentication.
Public Property | Protocols | Gets or sets the SSLProtocols available.
Top

See Also

Reference

Security Class
Dart.Emulation Namespace


CheckCertificateRevocation Property

[image]
PowerTCP Emulation for .NET
CheckCertificateRevocation Property
See Also Send comments on this topic
Dart.Emulation Namespace > Security Class : CheckCertificateRevocation Property

Glossary Item Box

Indicates whether the certificate revocation list is checked during authentication.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CheckCertificateRevocation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As Boolean

instance.CheckCertificateRevocation = value

value = instance.CheckCertificateRevocation
C#
[DefaultValue()]
public bool CheckCertificateRevocation {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_CheckCertificateRevocation();
public: __property void set_CheckCertificateRevocation(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool CheckCertificateRevocation {
   bool get();
   void set (    bool value);
}

See Also

Reference

Security Class
Security Members


Protocols Property

[image]
PowerTCP Emulation for .NET
Protocols Property
See Also Send comments on this topic
Dart.Emulation Namespace > Security Class : Protocols Property

Glossary Item Box

Gets or sets the SSLProtocols available.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Protocols As SslProtocols
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As SslProtocols

instance.Protocols = value

value = instance.Protocols
C#
[DefaultValue()]
public SslProtocols Protocols {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property SslProtocols get_Protocols();
public: __property void set_Protocols(
   SslProtocols value
);
C++/CLI
[DefaultValue()]
public:
property SslProtocols Protocols {
   SslProtocols get();
   void set (    SslProtocols value);
}

See Also

Reference

Security Class
Security Members


Security Class Fields

[image]
PowerTCP Emulation for .NET
Security Class Fields
See Also Send comments on this topic
Dart.Emulation Namespace : Security Class

Glossary Item Box

For a list of all members of this type, see Security members.

Public Fields

 | Name | Description
Public Field | ValidationCallback | The delegate that executes after the server provides its certificate to the client.
Top

See Also

Reference

Security Class
Dart.Emulation Namespace


ValidationCallback Field

[image]
PowerTCP Emulation for .NET
ValidationCallback Field
See Also Send comments on this topic
Dart.Emulation Namespace > Security Class : ValidationCallback Field

Glossary Item Box

The delegate that executes after the server provides its certificate to the client.

Syntax

Visual Basic (Declaration)
Public ValidationCallback As RemoteCertificateValidationCallback
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As RemoteCertificateValidationCallback

value = instance.ValidationCallback

instance.ValidationCallback = value
C#
public RemoteCertificateValidationCallback ValidationCallback
Managed Extensions for C++
public: RemoteCertificateValidationCallback* ValidationCallback
C++/CLI
public:
RemoteCertificateValidationCallback^ ValidationCallback

See Also

Reference

Security Class
Security Members


Segment Class

[image]
PowerTCP Emulation for .NET
Segment Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Segment Class

Glossary Item Box

Used to describe a byte[] segment that holds data.

Object Model

Segment Class

Syntax

Visual Basic (Declaration)
Public Class Segment
Visual Basic (Usage) Copy Code
Dim instance As Segment
C#
public class Segment
Managed Extensions for C++
public __gc class Segment
C++/CLI
public ref class Segment

Inheritance Hierarchy

System.Object
Dart.Emulation.Segment
Dart.Emulation.Data

See Also

Reference

Segment Members
Dart.Emulation Namespace


Segment Class Members

[image]
PowerTCP Emulation for .NET
Segment Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : Segment Class

Glossary Item Box

The following tables list the members exposed by Segment.

Public Constructors

 | Name | Description
Public Constructor | Segment Constructor | Used to create a Segment object that holds a buffer of data.
Top

Public Properties

 | Name | Description
Public Property | Buffer | Gets the buffer that holds data.
Public Property | Count | Byte count of data.
Public Property | Offset | The offset into the buffer where the data starts.
Top

See Also

Reference

Segment Class
Dart.Emulation Namespace


Segment Constructor

[image]
PowerTCP Emulation for .NET
Segment Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Segment Class : Segment Constructor

buffer
Byte[] containing data.
offset
Offset into the buffer where the data starts.
count
Byte count of data.

Glossary Item Box

Used to create a Segment object that holds a buffer of data.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

Dim instance As New Segment(buffer, offset, count)
C#
public Segment(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Segment(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Segment(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
Byte[] containing data.
offset
Offset into the buffer where the data starts.
count
Byte count of data.

See Also

Reference

Segment Class
Segment Members


Segment Class Properties

[image]
PowerTCP Emulation for .NET
Segment Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Segment Class

Glossary Item Box

For a list of all members of this type, see Segment members.

Public Properties

 | Name | Description
Public Property | Buffer | Gets the buffer that holds data.
Public Property | Count | Byte count of data.
Public Property | Offset | The offset into the buffer where the data starts.
Top

See Also

Reference

Segment Class
Dart.Emulation Namespace


Buffer Property

[image]
PowerTCP Emulation for .NET
Buffer Property
See Also Send comments on this topic
Dart.Emulation Namespace > Segment Class : Buffer Property

Glossary Item Box

Gets the buffer that holds data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Buffer As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Segment
Dim value() As Byte

value = instance.Buffer
C#
public byte[] Buffer {get;}
Managed Extensions for C++
public: __property byte[]* get_Buffer();
C++/CLI
public:
property array<byte>^ Buffer {
   array<byte>^ get();
}

See Also

Reference

Segment Class
Segment Members


Count Property

[image]
PowerTCP Emulation for .NET
Count Property
See Also Send comments on this topic
Dart.Emulation Namespace > Segment Class : Count Property

Glossary Item Box

Byte count of data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Segment
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

See Also

Reference

Segment Class
Segment Members


Offset Property

[image]
PowerTCP Emulation for .NET
Offset Property
See Also Send comments on this topic
Dart.Emulation Namespace > Segment Class : Offset Property

Glossary Item Box

The offset into the buffer where the data starts.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Offset As Integer
Visual Basic (Usage) Copy Code
Dim instance As Segment
Dim value As Integer

value = instance.Offset
C#
public int Offset {get;}
Managed Extensions for C++
public: __property int get_Offset();
C++/CLI
public:
property int Offset {
   int get();
}

See Also

Reference

Segment Class
Segment Members


Selection Class

[image]
PowerTCP Emulation for .NET
Selection Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Selection Class

Glossary Item Box

Contains methods and properties that control the display of selected cells as well as getting the text and attributes of those cells.

Object Model

Selection Class

Syntax

Visual Basic (Declaration)
Public Class Selection
Visual Basic (Usage) Copy Code
Dim instance As Selection
C#
public class Selection
Managed Extensions for C++
public __gc class Selection
C++/CLI
public ref class Selection

Inheritance Hierarchy

System.Object
Dart.Emulation.Selection

See Also

Reference

Selection Members
Dart.Emulation Namespace


Selection Class Members

[image]
PowerTCP Emulation for .NET
Selection Class Members
See Also Properties Methods Send comments on this topic
Dart.Emulation Namespace : Selection Class

Glossary Item Box

The following tables list the members exposed by Selection.

Public Properties

 | Name | Description
Public Property | Enabled | Returns true when cells are selected. Can be set programatically to enable a selection after Start and End are set.
Public Property | End | Gets or sets the ending cell of the characters currently selected.
Public Property | Mode | Gets or sets the selection mode used.
Public Property | Start | Gets or sets the starting cell of the characters currently selected.
Public Property | Text | Gets the currently selected text.
Top

Public Methods

 | Name | Description
Public Method | Print | Sends a copy of the currently selected text to the printer.
Top

See Also

Reference

Selection Class
Dart.Emulation Namespace


Selection Class Methods

[image]
PowerTCP Emulation for .NET
Selection Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : Selection Class

Glossary Item Box

For a list of all members of this type, see Selection members.

Public Methods

 | Name | Description
Public Method | Print | Sends a copy of the currently selected text to the printer.
Top

See Also

Reference

Selection Class
Dart.Emulation Namespace


Print Method

[image]
PowerTCP Emulation for .NET
Print Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Selection Class : Print Method

Glossary Item Box

Sends a copy of the currently selected text to the printer.

Syntax

Visual Basic (Declaration)
Public Sub Print()
Visual Basic (Usage) Copy Code
Dim instance As Selection

instance.Print()
C#
public void Print()
Managed Extensions for C++
public: void Print();
C++/CLI
public:
void Print();

Remarks

See the Vt.Printer property for information on selecting the output printer.

The print font will be the closest available match to the display font.

Unicode character printing is fully supported.

Example

The following example demonstrates how to print the display.
C# Copy Code
private string printScreen(bool useSelectedText)
{
    //Select display window to print and return
    vt1.Selection.Start = new Point(vt1.BufferRows, 0);
    vt1.Selection.End = new Point(vt1.BufferRows + vt1.Rows, vt1.Columns);

    //No difference in this case (when the entire display is selected)
    if (useSelectedText)
        vt1.Selection.Print();
    else
        vt1.PrintScreen();

    return vt1.Selection.Text;
}
Visual Basic Copy Code
Private Function printScreen(ByVal useSelectedText As Boolean) As String
    'Select display window to print and return
    vt1.Selection.Start = New Point(vt1.BufferRows, 0)
    vt1.Selection.End = New Point(vt1.BufferRows + vt1.Rows, vt1.Columns)

    'No difference in this case (when the entire display is selected)
    If useSelectedText Then
        vt1.Selection.Print()
    Else
        vt1.PrintScreen()
    End If

    Return vt1.Selection.Text
End Function

See Also

Reference

Selection Class
Selection Members


Selection Class Properties

[image]
PowerTCP Emulation for .NET
Selection Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Selection Class

Glossary Item Box

For a list of all members of this type, see Selection members.

Public Properties

 | Name | Description
Public Property | Enabled | Returns true when cells are selected. Can be set programatically to enable a selection after Start and End are set.
Public Property | End | Gets or sets the ending cell of the characters currently selected.
Public Property | Mode | Gets or sets the selection mode used.
Public Property | Start | Gets or sets the starting cell of the characters currently selected.
Public Property | Text | Gets the currently selected text.
Top

See Also

Reference

Selection Class
Dart.Emulation Namespace


Enabled Property

[image]
PowerTCP Emulation for .NET
Enabled Property
See Also Send comments on this topic
Dart.Emulation Namespace > Selection Class : Enabled Property

Glossary Item Box

Returns true when cells are selected. Can be set programatically to enable a selection after Start and End are set.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Selection
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
public bool Enabled {get; set;}
Managed Extensions for C++
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
C++/CLI
public:
property bool Enabled {
   bool get();
   void set (    bool value);
}

See Also

Reference

Selection Class
Selection Members


End Property

[image]
PowerTCP Emulation for .NET
End Property
See Also Example Send comments on this topic
Dart.Emulation Namespace > Selection Class : End Property

Glossary Item Box

Gets or sets the ending cell of the characters currently selected.

Syntax

Visual Basic (Declaration)
Public Property End As Point
Visual Basic (Usage) Copy Code
Dim instance As Selection
Dim value As Point

instance.End = value

value = instance.End
C#
public Point End {get; set;}
Managed Extensions for C++
public: __property Point get_End();
public: __property void set_End(
   Point value
);
C++/CLI
public:
property Point End {
   Point get();
   void set (    Point value);
}

Property Value

A Point specifying the last character selected. The default value is (-1, -1) (no selection).

Remarks

This property can index into the scrollback buffer, so if Vt.BufferRows is 72, the Point (0, 72) would be used to specify the first column in the first row of the screen buffer.

Example

The following example demonstrates how to print the display.
C# Copy Code
private string printScreen(bool useSelectedText)
{
    //Select display window to print and return
    vt1.Selection.Start = new Point(vt1.BufferRows, 0);
    vt1.Selection.End = new Point(vt1.BufferRows + vt1.Rows, vt1.Columns);

    //No difference in this case (when the entire display is selected)
    if (useSelectedText)
        vt1.Selection.Print();
    else
        vt1.PrintScreen();

    return vt1.Selection.Text;
}
Visual Basic Copy Code
Private Function printScreen(ByVal useSelectedText As Boolean) As String
    'Select display window to print and return
    vt1.Selection.Start = New Point(vt1.BufferRows, 0)
    vt1.Selection.End = New Point(vt1.BufferRows + vt1.Rows, vt1.Columns)

    'No difference in this case (when the entire display is selected)
    If useSelectedText Then
        vt1.Selection.Print()
    Else
        vt1.PrintScreen()
    End If

    Return vt1.Selection.Text
End Function

See Also

Reference

Selection Class
Selection Members


Mode Property

[image]
PowerTCP Emulation for .NET
Mode Property
See Also Send comments on this topic
Dart.Emulation Namespace > Selection Class : Mode Property

Glossary Item Box

Gets or sets the selection mode used.

Syntax

Visual Basic (Declaration)
Public Property Mode As SelectionMode
Visual Basic (Usage) Copy Code
Dim instance As Selection
Dim value As SelectionMode

instance.Mode = value

value = instance.Mode
C#
public SelectionMode Mode {get; set;}
Managed Extensions for C++
public: __property SelectionMode get_Mode();
public: __property void set_Mode(
   SelectionMode value
);
C++/CLI
public:
property SelectionMode Mode {
   SelectionMode get();
   void set (    SelectionMode value);
}

See Also

Reference

Selection Class
Selection Members


Start Property

[image]
PowerTCP Emulation for .NET
Start Property
See Also Example Send comments on this topic
Dart.Emulation Namespace > Selection Class : Start Property

Glossary Item Box

Gets or sets the starting cell of the characters currently selected.

Syntax

Visual Basic (Declaration)
Public Property Start As Point
Visual Basic (Usage) Copy Code
Dim instance As Selection
Dim value As Point

instance.Start = value

value = instance.Start
C#
public Point Start {get; set;}
Managed Extensions for C++
public: __property Point get_Start();
public: __property void set_Start(
   Point value
);
C++/CLI
public:
property Point Start {
   Point get();
   void set (    Point value);
}

Property Value

A Point specifying the first character selected. The default value is (-1, -1) (no selection).

Remarks

This property can index into the scrollback buffer, so if Vt.BufferRows is 72, the Point (0, 72) would be used to specify the first column in the first row of the screen buffer.

Example

The following example demonstrates how to print the display.
C# Copy Code
private string printScreen(bool useSelectedText)
{
    //Select display window to print and return
    vt1.Selection.Start = new Point(vt1.BufferRows, 0);
    vt1.Selection.End = new Point(vt1.BufferRows + vt1.Rows, vt1.Columns);

    //No difference in this case (when the entire display is selected)
    if (useSelectedText)
        vt1.Selection.Print();
    else
        vt1.PrintScreen();

    return vt1.Selection.Text;
}
Visual Basic Copy Code
Private Function printScreen(ByVal useSelectedText As Boolean) As String
    'Select display window to print and return
    vt1.Selection.Start = New Point(vt1.BufferRows, 0)
    vt1.Selection.End = New Point(vt1.BufferRows + vt1.Rows, vt1.Columns)

    'No difference in this case (when the entire display is selected)
    If useSelectedText Then
        vt1.Selection.Print()
    Else
        vt1.PrintScreen()
    End If

    Return vt1.Selection.Text
End Function

See Also

Reference

Selection Class
Selection Members


Text Property

[image]
PowerTCP Emulation for .NET
Text Property
See Also Example Send comments on this topic
Dart.Emulation Namespace > Selection Class : Text Property

Glossary Item Box

Gets the currently selected text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As Selection
Dim value As String

value = instance.Text
C#
public string Text {get;}
Managed Extensions for C++
public: __property string* get_Text();
C++/CLI
public:
property String^ Text {
   String^ get();
}

Property Value

A string containing the text on the Vt window that is selected. A Cr/Lf combination is used to separate rows.

Remarks

If no text is selected, this property will return an empty string.

Example

The following example demonstrates how to print the display.
C# Copy Code
private string printScreen(bool useSelectedText)
{
    //Select display window to print and return
    vt1.Selection.Start = new Point(vt1.BufferRows, 0);
    vt1.Selection.End = new Point(vt1.BufferRows + vt1.Rows, vt1.Columns);

    //No difference in this case (when the entire display is selected)
    if (useSelectedText)
        vt1.Selection.Print();
    else
        vt1.PrintScreen();

    return vt1.Selection.Text;
}
Visual Basic Copy Code
Private Function printScreen(ByVal useSelectedText As Boolean) As String
    'Select display window to print and return
    vt1.Selection.Start = New Point(vt1.BufferRows, 0)
    vt1.Selection.End = New Point(vt1.BufferRows + vt1.Rows, vt1.Columns)

    'No difference in this case (when the entire display is selected)
    If useSelectedText Then
        vt1.Selection.Print()
    Else
        vt1.PrintScreen()
    End If

    Return vt1.Selection.Text
End Function

See Also

Reference

Selection Class
Selection Members


Session Class

[image]
PowerTCP Emulation for .NET
Session Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Session Class

Glossary Item Box

Holds the configuration common to UDP and TCP.

Object Model

Session ClassIPEndPoint ClassIPEndPoint Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class Session
Visual Basic (Usage) Copy Code
Dim instance As Session
C#
[Serializable()]
public class Session
Managed Extensions for C++
[Serializable()]
public __gc class Session
C++/CLI
[Serializable()]
public ref class Session

Inheritance Hierarchy

System.Object
Dart.Emulation.Session
Dart.Emulation.TcpSession

See Also

Reference

Session Members
Dart.Emulation Namespace


Session Class Members

[image]
PowerTCP Emulation for .NET
Session Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : Session Class

Glossary Item Box

The following tables list the members exposed by Session.

Public Constructors

 | Name | Description
Public Constructor | Session Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | LocalEndPoint | EndPoint to bind to locally.
Public Property | RemoteEndPoint | EndPoint of the remote host to connect to.
Top

See Also

Reference

Session Class
Dart.Emulation Namespace


Session Constructor

[image]
PowerTCP Emulation for .NET
Session Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Session Class : Session Constructor

Glossary Item Box

Overload List

Overload | Description
Session Constructor() | Default constructor for Session.
Session Constructor(IPEndPoint) | Constructor for Session with a Remote IPEndPoint parameter.

See Also

Reference

Session Class
Session Members


Session Constructor()

[image]
PowerTCP Emulation for .NET
Session Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > Session Class > Session Constructor : Session Constructor()

Glossary Item Box

Default constructor for Session.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Session()
C#
public Session()
Managed Extensions for C++
public: Session();
C++/CLI
public:
Session();

See Also

Reference

Session Class
Session Members
Overload List


Session Constructor(IPEndPoint)

[image]
PowerTCP Emulation for .NET
Session Constructor(IPEndPoint)
See Also Send comments on this topic
Dart.Emulation Namespace > Session Class > Session Constructor : Session Constructor(IPEndPoint)

remoteEP
The remote IPEndPoint to connect to.

Glossary Item Box

Constructor for Session with a Remote IPEndPoint parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal remoteEP As IPEndPoint _
)
Visual Basic (Usage) Copy Code
Dim remoteEP As IPEndPoint

Dim instance As New Session(remoteEP)
C#
public Session(
   IPEndPoint remoteEP
)
Managed Extensions for C++
public: Session(
   IPEndPoint* remoteEP
)
C++/CLI
public:
Session(
   IPEndPoint^ remoteEP
)

Parameters

remoteEP
The remote IPEndPoint to connect to.

See Also

Reference

Session Class
Session Members
Overload List


Session Class Properties

[image]
PowerTCP Emulation for .NET
Session Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Session Class

Glossary Item Box

For a list of all members of this type, see Session members.

Public Properties

 | Name | Description
Public Property | LocalEndPoint | EndPoint to bind to locally.
Public Property | RemoteEndPoint | EndPoint of the remote host to connect to.
Top

See Also

Reference

Session Class
Dart.Emulation Namespace


LocalEndPoint Property

[image]
PowerTCP Emulation for .NET
LocalEndPoint Property
See Also Send comments on this topic
Dart.Emulation Namespace > Session Class : LocalEndPoint Property

Glossary Item Box

EndPoint to bind to locally.

Syntax

Visual Basic (Declaration)
Public Property LocalEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As Session
Dim value As IPEndPoint

instance.LocalEndPoint = value

value = instance.LocalEndPoint
C#
public IPEndPoint LocalEndPoint {get; set;}
Managed Extensions for C++
public: __property IPEndPoint* get_LocalEndPoint();
public: __property void set_LocalEndPoint(
   IPEndPoint* value
);
C++/CLI
public:
property IPEndPoint^ LocalEndPoint {
   IPEndPoint^ get();
   void set (    IPEndPoint^ value);
}

Remarks

Use this property to control the use of IPv4/IPv6, the IP interface to bind to (for multi-homed hosts), and the port or port-range to use. Defaults to AddressFamily.InterNetworkV4, IPAddress.Any, and a port selected by the system (ephemeral port 0).

To use AddressFamily.InterNetworkV6, create a new IPEndPoint that specifies this AddressFamily. A Socket will be created that can connect to both IPv4 and IPv6 hosts. This is called a "dual stack", allowing clients to connect to both IPv4 and IPv6 servers, and allowing servers to accept connections from both IPv4 and IPv6 clients.

If IPEndPoint.Any is not desired, specify the hostname or address in the constructor.

If a random ephemeral port is not desired, specify the port or range in the constructor.

See Also

Reference

Session Class
Session Members


RemoteEndPoint Property

[image]
PowerTCP Emulation for .NET
RemoteEndPoint Property
See Also Send comments on this topic
Dart.Emulation Namespace > Session Class : RemoteEndPoint Property

Glossary Item Box

EndPoint of the remote host to connect to.

Syntax

Visual Basic (Declaration)
Public Property RemoteEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As Session
Dim value As IPEndPoint

instance.RemoteEndPoint = value

value = instance.RemoteEndPoint
C#
public IPEndPoint RemoteEndPoint {get; set;}
Managed Extensions for C++
public: __property IPEndPoint* get_RemoteEndPoint();
public: __property void set_RemoteEndPoint(
   IPEndPoint* value
);
C++/CLI
public:
property IPEndPoint^ RemoteEndPoint {
   IPEndPoint^ get();
   void set (    IPEndPoint^ value);
}

See Also

Reference

Session Class
Session Members


SocketBase Class

[image]
PowerTCP Emulation for .NET
SocketBase Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : SocketBase Class

Glossary Item Box

Base class for PowerTCP Components.

Object Model

SocketBase Class

Syntax

Visual Basic (Declaration)
Public Class SocketBase
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As SocketBase
C#
public class SocketBase : ComponentBase
Managed Extensions for C++
public __gc class SocketBase : public ComponentBase
C++/CLI
public ref class SocketBase : public ComponentBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Emulation.ComponentBase
Dart.Emulation.SocketBase
Dart.Emulation.TcpBase

See Also

Reference

SocketBase Members
Dart.Emulation Namespace


SocketBase Class Members

[image]
PowerTCP Emulation for .NET
SocketBase Class Members
See Also Properties Methods Events Send comments on this topic
Dart.Emulation Namespace : SocketBase Class

Glossary Item Box

The following tables list the members exposed by SocketBase.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications.
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals a string and/or object to the UI thread and raises the UserState event. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Emulation Namespace


SocketBase Class Properties

[image]
PowerTCP Emulation for .NET
SocketBase Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : SocketBase Class

Glossary Item Box

For a list of all members of this type, see SocketBase members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications.
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Emulation Namespace


Socket Property

[image]
PowerTCP Emulation for .NET
Socket Property
See Also Send comments on this topic
Dart.Emulation Namespace > SocketBase Class : Socket Property

Glossary Item Box

Gets the socket used by the component for communications.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Socket As Socket
Visual Basic (Usage) Copy Code
Dim instance As SocketBase
Dim value As Socket

value = instance.Socket
C#
public Socket Socket {get;}
Managed Extensions for C++
public: __property Socket* get_Socket();
C++/CLI
public:
property Socket^ Socket {
   Socket^ get();
}

Property Value

The Socket used for UDP or TCP communications. Returns null when not in use.

See Also

Reference

SocketBase Class
SocketBase Members


SocketOption Class

[image]
PowerTCP Emulation for .NET
SocketOption Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : SocketOption Class

Glossary Item Box

Contains socket options that may be set by TCP and UDP sockets. These options are automatically applied to the connection used.

Object Model

SocketOption Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class SocketOption
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
C#
[Serializable()]
public class SocketOption
Managed Extensions for C++
[Serializable()]
public __gc class SocketOption
C++/CLI
[Serializable()]
public ref class SocketOption

Inheritance Hierarchy

System.Object
Dart.Emulation.SocketOption
Dart.Emulation.TcpSocketOption

See Also

Reference

SocketOption Members
Dart.Emulation Namespace


SocketOption Class Members

[image]
PowerTCP Emulation for .NET
SocketOption Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : SocketOption Class

Glossary Item Box

The following tables list the members exposed by SocketOption.

Public Properties

 | Name | Description
Public Property | ExclusiveAddressUse | When set to true, forbids multiple socket bindings to the same address. Set this value to true to ensure you have exclusive use of the local endpoint. Socket.ExclusiveAddressUse is set to this value before Socket.Bind is used.
Public Property | ReceiveBufferSize | Gets or sets a value that specifies the size of the system receive buffer.
Public Property | ReceiveTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket.Receive call will time out.
Public Property | ReuseAddress | When set to true, allows multiple socket bindings to the same address. Set this value to true to allow multiple sockets to bind to the same local address.
Public Property | SendBufferSize | Gets or sets a value that specifies the size of the system send buffer.
Public Property | SendTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out.
Top

See Also

Reference

SocketOption Class
Dart.Emulation Namespace


SocketOption Class Properties

[image]
PowerTCP Emulation for .NET
SocketOption Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : SocketOption Class

Glossary Item Box

For a list of all members of this type, see SocketOption members.

Public Properties

 | Name | Description
Public Property | ExclusiveAddressUse | When set to true, forbids multiple socket bindings to the same address. Set this value to true to ensure you have exclusive use of the local endpoint. Socket.ExclusiveAddressUse is set to this value before Socket.Bind is used.
Public Property | ReceiveBufferSize | Gets or sets a value that specifies the size of the system receive buffer.
Public Property | ReceiveTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket.Receive call will time out.
Public Property | ReuseAddress | When set to true, allows multiple socket bindings to the same address. Set this value to true to allow multiple sockets to bind to the same local address.
Public Property | SendBufferSize | Gets or sets a value that specifies the size of the system send buffer.
Public Property | SendTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out.
Top

See Also

Reference

SocketOption Class
Dart.Emulation Namespace


ExclusiveAddressUse Property

[image]
PowerTCP Emulation for .NET
ExclusiveAddressUse Property
See Also Send comments on this topic
Dart.Emulation Namespace > SocketOption Class : ExclusiveAddressUse Property

Glossary Item Box

When set to true, forbids multiple socket bindings to the same address. Set this value to true to ensure you have exclusive use of the local endpoint. Socket.ExclusiveAddressUse is set to this value before Socket.Bind is used.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ExclusiveAddressUse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Boolean

instance.ExclusiveAddressUse = value

value = instance.ExclusiveAddressUse
C#
[DefaultValue()]
public bool ExclusiveAddressUse {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_ExclusiveAddressUse();
public: __property void set_ExclusiveAddressUse(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool ExclusiveAddressUse {
   bool get();
   void set (    bool value);
}

Remarks

Set this value to true to ensure you have exclusive use of the local endpoint. Socket.ExclusiveAddressUse is set to this value before Socket.Bind is used.

See Also

Reference

SocketOption Class
SocketOption Members


ReceiveBufferSize Property

[image]
PowerTCP Emulation for .NET
ReceiveBufferSize Property
See Also Send comments on this topic
Dart.Emulation Namespace > SocketOption Class : ReceiveBufferSize Property

Glossary Item Box

Gets or sets a value that specifies the size of the system receive buffer.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ReceiveBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.ReceiveBufferSize = value

value = instance.ReceiveBufferSize
C#
[DefaultValue()]
public int ReceiveBufferSize {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_ReceiveBufferSize();
public: __property void set_ReceiveBufferSize(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int ReceiveBufferSize {
   int get();
   void set (    int value);
}

Property Value

An integer with a default value of 32786.

Remarks

Increasing the buffer size may help performance when transferring large amounts of data, or when high bandwidth, high latency connections (such as a satellite broadband provider) are used.

The value cannot be changed on CF devices.

See Also

Reference

SocketOption Class
SocketOption Members


ReceiveTimeout Property

[image]
PowerTCP Emulation for .NET
ReceiveTimeout Property
See Also Send comments on this topic
Dart.Emulation Namespace > SocketOption Class : ReceiveTimeout Property

Glossary Item Box

Gets or sets a value that specifies the amount of time after which the underlying Socket.Receive call will time out.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property ReceiveTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[DefaultValue()]
public virtual int ReceiveTimeout {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property virtual int get_ReceiveTimeout();
public: __property virtual void set_ReceiveTimeout(
   int value
);
C++/CLI
[DefaultValue()]
public:
virtual property int ReceiveTimeout {
   int get();
   void set (    int value);
}

Property Value

The time-out value in milliseconds. The default value is 0, which indicates an infinite time-out period.

Remarks

A value of 0 or -1 indicates an infinite time-out period.

See Also

Reference

SocketOption Class
SocketOption Members


ReuseAddress Property

[image]
PowerTCP Emulation for .NET
ReuseAddress Property
See Also Send comments on this topic
Dart.Emulation Namespace > SocketOption Class : ReuseAddress Property

Glossary Item Box

When set to true, allows multiple socket bindings to the same address. Set this value to true to allow multiple sockets to bind to the same local address.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ReuseAddress As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Boolean

instance.ReuseAddress = value

value = instance.ReuseAddress
C#
[DefaultValue()]
public bool ReuseAddress {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_ReuseAddress();
public: __property void set_ReuseAddress(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool ReuseAddress {
   bool get();
   void set (    bool value);
}

Remarks

Set this value to true to allow multiple sockets to bind to the same local address.

See Also

Reference

SocketOption Class
SocketOption Members


SendBufferSize Property

[image]
PowerTCP Emulation for .NET
SendBufferSize Property
See Also Send comments on this topic
Dart.Emulation Namespace > SocketOption Class : SendBufferSize Property

Glossary Item Box

Gets or sets a value that specifies the size of the system send buffer.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SendBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.SendBufferSize = value

value = instance.SendBufferSize
C#
[DefaultValue()]
public int SendBufferSize {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_SendBufferSize();
public: __property void set_SendBufferSize(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int SendBufferSize {
   int get();
   void set (    int value);
}

Property Value

An integer with a default value of 8192.

Remarks

Increasing the buffer size may help performance when transferring large amounts of data, or when high bandwidth, high latency connections (such as a satellite broadband provider) are used.

See Also

Reference

SocketOption Class
SocketOption Members


SendTimeout Property

[image]
PowerTCP Emulation for .NET
SendTimeout Property
See Also Send comments on this topic
Dart.Emulation Namespace > SocketOption Class : SendTimeout Property

Glossary Item Box

Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SendTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.SendTimeout = value

value = instance.SendTimeout
C#
[DefaultValue()]
public int SendTimeout {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_SendTimeout();
public: __property void set_SendTimeout(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int SendTimeout {
   int get();
   void set (    int value);
}

Property Value

The time-out value in milliseconds. The default value is 0, which indicates an infinite time-out period.

Remarks

Values between 1 and 499 will be changed to 500, as 500 is the minimum positive value. Values of 0 and -1 indicate an infinite time-out period.

This option has no affect on CF devices (the Write method will not time out).

See Also

Reference

SocketOption Class
SocketOption Members


TcpBase Class

[image]
PowerTCP Emulation for .NET
TcpBase Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : TcpBase Class

Glossary Item Box

Base class for components utilizing protocols built upon the TCP protocol.

Object Model

TcpBase ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class TcpBase
   Inherits SocketBase
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
C#
public class TcpBase : SocketBase
Managed Extensions for C++
public __gc class TcpBase : public SocketBase
C++/CLI
public ref class TcpBase : public SocketBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Emulation.ComponentBase
Dart.Emulation.SocketBase
Dart.Emulation.TcpBase
Dart.Emulation.PtyBase
Dart.Emulation.Rexec
Dart.Emulation.Rsh

See Also

Reference

TcpBase Members
Dart.Emulation Namespace


TcpBase Class Members

[image]
PowerTCP Emulation for .NET
TcpBase Class Members
See Also Properties Methods Events Send comments on this topic
Dart.Emulation Namespace : TcpBase Class

Glossary Item Box

The following tables list the members exposed by TcpBase.

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed.
Public Property | ConnectTime | Returns the DateTime the connection was established.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called.
Public Property | RemoteEndPoint | Gets the remote address and port of the connection.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase.
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called.
Public Property | State | Gets the status of the connection as of the last socket operation.
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection.
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection.
Public Method | Close | Gracefully closes the connection.
Public Method | Connect | Connect to a server using the configuration specified by session.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals data to the UI thread.
Public Method | Read | Overloaded. Receives data from the remote host.
Public Method | ReadAsync | Start an asynchronous read on the socket.
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed.
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed.
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown.
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host.
Public Method | WriteAsync | Start an asynchronous write on the socket.
Top

Public Events

 | Name | Description
Public Event | Data | Raised when Marshal(Data,String,Object) is used.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written.
Public Event | StateChanged | Raised when the value of the State property changes.
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Emulation Namespace


TcpBase Class Methods

[image]
PowerTCP Emulation for .NET
TcpBase Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : TcpBase Class

Glossary Item Box

For a list of all members of this type, see TcpBase members.

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection.
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection.
Public Method | Close | Gracefully closes the connection.
Public Method | Connect | Connect to a server using the configuration specified by session.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals data to the UI thread.
Public Method | Read | Overloaded. Receives data from the remote host.
Public Method | ReadAsync | Start an asynchronous read on the socket.
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed.
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed.
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown.
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host.
Public Method | WriteAsync | Start an asynchronous write on the socket.
Top

See Also

Reference

TcpBase Class
Dart.Emulation Namespace


Abort Method

[image]
PowerTCP Emulation for .NET
Abort Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Abort Method

Glossary Item Box

Performs a hard close of the connection.

Syntax

Visual Basic (Declaration)
Public Sub Abort()
Visual Basic (Usage) Copy Code
Dim instance As TcpBase

instance.Abort()
C#
public void Abort()
Managed Extensions for C++
public: void Abort();
C++/CLI
public:
void Abort();

Remarks

This method resets the connection and immediately clears the socket state.

See Also

Reference

TcpBase Class
TcpBase Members


AuthenticateAsClient Method

[image]
PowerTCP Emulation for .NET
AuthenticateAsClient Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : AuthenticateAsClient Method

Glossary Item Box

Authenticates the server when establishing a secure connection.

Overload List

Overload | Description
AuthenticateAsClient(ClientSecurity) | Authenticates the server when establishing a secure connection.
AuthenticateAsClient(TcpSession) | Authenticates the server when establishing a secure connection.

See Also

Reference

TcpBase Class
TcpBase Members


AuthenticateAsClient(ClientSecurity) Method

[image]
PowerTCP Emulation for .NET
AuthenticateAsClient(ClientSecurity) Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > AuthenticateAsClient Method : AuthenticateAsClient(ClientSecurity) Method

security
Security parameters used during authentication.

Glossary Item Box

Authenticates the server when establishing a secure connection.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Use AuthenticeAsClient(Session) instead.")>
<SecuritySafeCriticalAttribute()>
Public Overloads Sub AuthenticateAsClient( _
   ByVal security As ClientSecurity _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim security As ClientSecurity

instance.AuthenticateAsClient(security)
C#
[Obsolete("Use AuthenticeAsClient(Session) instead.")]
[SecuritySafeCritical()]
public void AuthenticateAsClient(
   ClientSecurity security
)
Managed Extensions for C++
[Obsolete("Use AuthenticeAsClient(Session) instead.")]
[SecuritySafeCritical()]
public: void AuthenticateAsClient(
   ClientSecurity* security
)
C++/CLI
[Obsolete("Use AuthenticeAsClient(Session) instead.")]
[SecuritySafeCritical()]
public:
void AuthenticateAsClient(
   ClientSecurity^ security
)

Parameters

security
Security parameters used during authentication.

Remarks

The security.TargetHost should match the server certificate name. If authentication fails, an AuthenticationException will occur.

To accept or reject a certificate "on-the-fly" implement a Security.ValidationCallback function.

To select a client certificate "on-the-fly" implement a ClientSecurity.SelectionCallback function.

Example

This example demonstrates the AuthenticateAsClient call, the callback that prompts for a local certificate, and the callback that executes when a certificate is received.
C# Copy Code
using System.Net.Security;
using System.Security.Authentication;
using System.Security.Cryptography.X509Certificates;

/// <summary>
/// Establishes SSL with the provided Tcp object. Typically called immediately after connecting to the server (implicit)
/// or after a command such as STARTTLS is sent to the server (explicit).
/// </summary>
/// <param name="myComponent">Object to establish SSL with</param>
/// <param name="serverHostName">The name of the server</param>
/// <param name="protocols">Protocols the client will accept</param>
/// <param name="checkRevocation">Check certificate revocation list during authentication</param>
private void authenticateTcp(Tcp myComponent, string serverHostName, SslProtocols protocols, bool checkRevocation)
{
    //Specify configuration and certificate callback function, and authenticate server
    ClientSecurity security = new ClientSecurity();
    security.TargetHost = serverHostName;
    security.Protocols = protocols;
    security.CheckCertificateRevocation = checkRevocation;
    security.ValidationCallback = certificateReceived;
    security.SelectionCallback = selectLocalCertificate;
    myComponent.AuthenticateAsClient(security);
}

/// <summary>
/// Prompts the user to select a certificate for SSL authentication.
/// </summary>
/// <remarks>
/// This snippet assumes the presence of the Dart Test Certificate in the user's 'My' certificate store.
/// The Dart Test Certificate may be installed from the component's Start Menu program group.
/// For a UI-based certificate selection, please see the CertificateListForm included with our
/// WinForms samples.
/// </remarks>
/// <param name="targetHost">The host server specified by the client.</param>
/// <param name="localCertificates">A reference to ClientSecurity.Certificates</param>
/// <param name="remoteCertificate">The certificate used to authenticate the remote party.</param>
/// <param name="acceptableIssuers">A String array of certificate issuers acceptable to the remote party.</param>
/// <returns>An X509Certificate to use for establishing the SSL connection.</returns>
private X509Certificate selectLocalCertificate(Object sender, string targetHost,
    X509CertificateCollection localCertificates, X509Certificate remoteCertificate, string[] acceptableIssuers)
{
    //Try to find the Dart Test Certificate
    X509Store certificateStore = new X509Store(StoreName.My);
    certificateStore.Open(OpenFlags.ReadOnly);
    foreach (X509Certificate2 cert in certificateStore.Certificates)
        if (cert.GetNameInfo(X509NameType.SimpleName, true) == "DartdomCA")
        {
            certificateStore.Close();
            return cert;
        }
    //Certificate not found, return null
    return null;
}

/// <summary>
/// Presents the server's certificate for validation.
/// </summary>
/// <param name="certificate">The certificate presented by the server</param>
/// <param name="chain">The chain of certificate authorities associated with the remote certificate</param>
/// <param name="sslPolicyErrors">One or more errors associated with the server's certificate</param>
/// <returns>A Boolean value that specifies whether the presented certificate is accepted for authentication</returns>
private bool certificateReceived(object sender, X509Certificate certificate, X509Chain chain, SslPolicyErrors sslPolicyErrors)
{
    //Accept certificate if it passed standard validation.
    if (sslPolicyErrors == SslPolicyErrors.None)
        return true;

    string msg = "The server could not be validated for the following reason(s):";

    if ((sslPolicyErrors & SslPolicyErrors.RemoteCertificateNotAvailable) == SslPolicyErrors.RemoteCertificateNotAvailable)
        msg += Environment.NewLine + "    -The server did not present a certificate.";
    else
    {
        if ((sslPolicyErrors & SslPolicyErrors.RemoteCertificateNameMismatch) == SslPolicyErrors.RemoteCertificateNameMismatch)
            msg += Environment.NewLine + "    -Certificate name mismatch.";
        if ((sslPolicyErrors & SslPolicyErrors.RemoteCertificateChainErrors) == SslPolicyErrors.RemoteCertificateChainErrors)
        {
            msg += Environment.NewLine + "    -Certificate chain errors:" + Environment.NewLine;

            foreach (X509ChainStatus item in chain.ChainStatus)
                msg += "    --" + item.StatusInformation;
        }
    }

    //Prompt to override security check
    msg += Environment.NewLine + "Override security check?";
    if (MessageBox.Show(msg, "Security Alert: Server could not be validated", MessageBoxButtons.YesNo, MessageBoxIcon.Exclamation) == DialogResult.Yes)
        return true;
    else
        return false;
}
Visual Basic Copy Code
Imports System.Net.Security
Imports System.Security.Authentication
Imports System.Security.Cryptography.X509Certificates

''' <summary>
''' Establishes SSL with the provided Tcp object. Typically called immediately after connecting to the server (implicit)
''' or after a command such as STARTTLS is sent to the server (explicit).
''' </summary>
''' <param name="myComponent">Object to establish SSL with</param>
''' <param name="serverHostName">The name of the server</param>
''' <param name="protocols">Protocols the client will accept</param>
''' <param name="checkRevocation">Check certificate revocation list during authentication</param>
Private Sub authenticateTcp(ByVal myComponent As Tcp, ByVal serverHostName As String, ByVal protocols As SslProtocols, ByVal checkRevocation As Boolean)
    'Specify configuration and certificate callback function, and authenticate server
    Dim security As New ClientSecurity()
    security.TargetHost = serverHostName
    security.Protocols = protocols
    security.CheckCertificateRevocation = checkRevocation
    security.ValidationCallback = AddressOf certificateReceived
    security.SelectionCallback = AddressOf selectLocalCertificate
    myComponent.AuthenticateAsClient(security)
End Sub

''' <summary>
''' Prompts the user to select a certificate for SSL authentication.
''' </summary>
''' <remarks>
''' This snippet assumes the presence of the Dart Test Certificate in the user's 'My' certificate store.
''' The Dart Test Certificate may be installed from the component's Start Menu program group.
''' For a UI-based certificate selection, please see the CertificateListForm included with our
''' WinForms samples.
''' </remarks>
''' <param name="targetHost">The host server specified by the client.</param>
''' <param name="localCertificates">A reference to ClientSecurity.Certificates</param>
''' <param name="remoteCertificate">The certificate used to authenticate the remote party.</param>
''' <param name="acceptableIssuers">A String array of certificate issuers acceptable to the remote party.</param>
''' <returns>An X509Certificate to use for establishing the SSL connection.</returns>
Private Function selectLocalCertificate(ByVal sender As Object, ByVal targetHost As String, ByVal localCertificates As X509CertificateCollection, ByVal remoteCertificate As X509Certificate, ByVal acceptableIssuers() As String) As X509Certificate
    'Try to find the Dart Test Certificate
    Dim certificateStore As New X509Store(StoreName.My)
    certificateStore.Open(OpenFlags.ReadOnly)
    For Each cert As X509Certificate2 In certificateStore.Certificates
        If cert.GetNameInfo(X509NameType.SimpleName, True) = "DartdomCA" Then
            certificateStore.Close()
            Return cert
        End If
    Next cert
    'Certificate not found, return null
    Return Nothing
End Function

''' <summary>
''' Presents the server's certificate for validation.
''' </summary>
''' <param name="certificate">The certificate presented by the server</param>
''' <param name="chain">The chain of certificate authorities associated with the remote certificate</param>
''' <param name="sslPolicyErrors">One or more errors associated with the server's certificate</param>
''' <returns>A Boolean value that specifies whether the presented certificate is accepted for authentication</returns>
Private Function certificateReceived(ByVal sender As Object, ByVal certificate As X509Certificate, ByVal chain As X509Chain, ByVal sslPolicyErrors As SslPolicyErrors) As Boolean
    'Accept certificate if it passed standard validation.
    If sslPolicyErrors = System.Net.Security.SslPolicyErrors.None Then
        Return True
    End If

    Dim msg As String = "The server could not be validated for the following reason(s):"

    If (sslPolicyErrors And System.Net.Security.SslPolicyErrors.RemoteCertificateNotAvailable) = System.Net.Security.SslPolicyErrors.RemoteCertificateNotAvailable Then
        msg &= Environment.NewLine & "    -The server did not present a certificate."
    Else
        If (sslPolicyErrors And System.Net.Security.SslPolicyErrors.RemoteCertificateNameMismatch) = System.Net.Security.SslPolicyErrors.RemoteCertificateNameMismatch Then
            msg &= Environment.NewLine & "    -Certificate name mismatch."
        End If
        If (sslPolicyErrors And System.Net.Security.SslPolicyErrors.RemoteCertificateChainErrors) = System.Net.Security.SslPolicyErrors.RemoteCertificateChainErrors Then
            msg &= Environment.NewLine & "    -Certificate chain errors:" & Environment.NewLine

            For Each item As X509ChainStatus In chain.ChainStatus
                msg &= "    --" & item.StatusInformation
            Next item
        End If
    End If

    'Prompt to override security check
    msg &= Environment.NewLine & "Override security check?"
    If MessageBox.Show(msg, "Security Alert: Server could not be validated", MessageBoxButtons.YesNo, MessageBoxIcon.Exclamation) = System.Windows.Forms.DialogResult.Yes Then
        Return True
    Else
        Return False
    End If
End Function

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


AuthenticateAsClient(TcpSession) Method

[image]
PowerTCP Emulation for .NET
AuthenticateAsClient(TcpSession) Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > AuthenticateAsClient Method : AuthenticateAsClient(TcpSession) Method

session
Session parameters used during authentication.

Glossary Item Box

Authenticates the server when establishing a secure connection.

Syntax

Visual Basic (Declaration)
<SecuritySafeCriticalAttribute()>
Public Overloads Sub AuthenticateAsClient( _
   ByVal session As TcpSession _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim session As TcpSession

instance.AuthenticateAsClient(session)
C#
[SecuritySafeCritical()]
public void AuthenticateAsClient(
   TcpSession session
)
Managed Extensions for C++
[SecuritySafeCritical()]
public: void AuthenticateAsClient(
   TcpSession* session
)
C++/CLI
[SecuritySafeCritical()]
public:
void AuthenticateAsClient(
   TcpSession^ session
)

Parameters

session
Session parameters used during authentication.

Remarks

Uses Session.RemoteEndPoint, TcpSession.Proxy and TcpSession.Security to specify Security.ValidationCallback, SelectionCallback, ClientSecurity.TargetHost, Certificates, Security.Protocols, and Security.CheckCertificateRevocation.

If session.Security.TargetHost is not specifed, then session.RemoteEndPoint.HostNameOrAddress will be used instead. session.Security.TargetHost should match the server certificate name. If authentication fails, an AuthenticationException will occur.

To accept or reject a certificate "on-the-fly" implement a Security.ValidationCallback function.

To select a client certificate "on-the-fly" implement a ClientSecurity.SelectionCallback function.

Example

This example demonstrates the AuthenticateAsClient call, the callback that prompts for a local certificate, and the callback that executes when a certificate is received.
C# Copy Code
using System.Net.Security;
using System.Security.Authentication;
using System.Security.Cryptography.X509Certificates;

/// <summary>
/// Establishes SSL with the provided Tcp object. Typically called immediately after connecting to the server (implicit)
/// or after a command such as STARTTLS is sent to the server (explicit).
/// </summary>
/// <param name="myComponent">Object to establish SSL with</param>
/// <param name="serverHostName">The name of the server</param>
/// <param name="protocols">Protocols the client will accept</param>
/// <param name="checkRevocation">Check certificate revocation list during authentication</param>
private void authenticateTcp(Tcp myComponent, string serverHostName, SslProtocols protocols, bool checkRevocation)
{
    //Specify configuration and certificate callback function, and authenticate server
    ClientSecurity security = new ClientSecurity();
    security.TargetHost = serverHostName;
    security.Protocols = protocols;
    security.CheckCertificateRevocation = checkRevocation;
    security.ValidationCallback = certificateReceived;
    security.SelectionCallback = selectLocalCertificate;
    myComponent.AuthenticateAsClient(security);
}

/// <summary>
/// Prompts the user to select a certificate for SSL authentication.
/// </summary>
/// <remarks>
/// This snippet assumes the presence of the Dart Test Certificate in the user's 'My' certificate store.
/// The Dart Test Certificate may be installed from the component's Start Menu program group.
/// For a UI-based certificate selection, please see the CertificateListForm included with our
/// WinForms samples.
/// </remarks>
/// <param name="targetHost">The host server specified by the client.</param>
/// <param name="localCertificates">A reference to ClientSecurity.Certificates</param>
/// <param name="remoteCertificate">The certificate used to authenticate the remote party.</param>
/// <param name="acceptableIssuers">A String array of certificate issuers acceptable to the remote party.</param>
/// <returns>An X509Certificate to use for establishing the SSL connection.</returns>
private X509Certificate selectLocalCertificate(Object sender, string targetHost,
    X509CertificateCollection localCertificates, X509Certificate remoteCertificate, string[] acceptableIssuers)
{
    //Try to find the Dart Test Certificate
    X509Store certificateStore = new X509Store(StoreName.My);
    certificateStore.Open(OpenFlags.ReadOnly);
    foreach (X509Certificate2 cert in certificateStore.Certificates)
        if (cert.GetNameInfo(X509NameType.SimpleName, true) == "DartdomCA")
        {
            certificateStore.Close();
            return cert;
        }
    //Certificate not found, return null
    return null;
}

/// <summary>
/// Presents the server's certificate for validation.
/// </summary>
/// <param name="certificate">The certificate presented by the server</param>
/// <param name="chain">The chain of certificate authorities associated with the remote certificate</param>
/// <param name="sslPolicyErrors">One or more errors associated with the server's certificate</param>
/// <returns>A Boolean value that specifies whether the presented certificate is accepted for authentication</returns>
private bool certificateReceived(object sender, X509Certificate certificate, X509Chain chain, SslPolicyErrors sslPolicyErrors)
{
    //Accept certificate if it passed standard validation.
    if (sslPolicyErrors == SslPolicyErrors.None)
        return true;

    string msg = "The server could not be validated for the following reason(s):";

    if ((sslPolicyErrors & SslPolicyErrors.RemoteCertificateNotAvailable) == SslPolicyErrors.RemoteCertificateNotAvailable)
        msg += Environment.NewLine + "    -The server did not present a certificate.";
    else
    {
        if ((sslPolicyErrors & SslPolicyErrors.RemoteCertificateNameMismatch) == SslPolicyErrors.RemoteCertificateNameMismatch)
            msg += Environment.NewLine + "    -Certificate name mismatch.";
        if ((sslPolicyErrors & SslPolicyErrors.RemoteCertificateChainErrors) == SslPolicyErrors.RemoteCertificateChainErrors)
        {
            msg += Environment.NewLine + "    -Certificate chain errors:" + Environment.NewLine;

            foreach (X509ChainStatus item in chain.ChainStatus)
                msg += "    --" + item.StatusInformation;
        }
    }

    //Prompt to override security check
    msg += Environment.NewLine + "Override security check?";
    if (MessageBox.Show(msg, "Security Alert: Server could not be validated", MessageBoxButtons.YesNo, MessageBoxIcon.Exclamation) == DialogResult.Yes)
        return true;
    else
        return false;
}
Visual Basic Copy Code
Imports System.Net.Security
Imports System.Security.Authentication
Imports System.Security.Cryptography.X509Certificates

''' <summary>
''' Establishes SSL with the provided Tcp object. Typically called immediately after connecting to the server (implicit)
''' or after a command such as STARTTLS is sent to the server (explicit).
''' </summary>
''' <param name="myComponent">Object to establish SSL with</param>
''' <param name="serverHostName">The name of the server</param>
''' <param name="protocols">Protocols the client will accept</param>
''' <param name="checkRevocation">Check certificate revocation list during authentication</param>
Private Sub authenticateTcp(ByVal myComponent As Tcp, ByVal serverHostName As String, ByVal protocols As SslProtocols, ByVal checkRevocation As Boolean)
    'Specify configuration and certificate callback function, and authenticate server
    Dim security As New ClientSecurity()
    security.TargetHost = serverHostName
    security.Protocols = protocols
    security.CheckCertificateRevocation = checkRevocation
    security.ValidationCallback = AddressOf certificateReceived
    security.SelectionCallback = AddressOf selectLocalCertificate
    myComponent.AuthenticateAsClient(security)
End Sub

''' <summary>
''' Prompts the user to select a certificate for SSL authentication.
''' </summary>
''' <remarks>
''' This snippet assumes the presence of the Dart Test Certificate in the user's 'My' certificate store.
''' The Dart Test Certificate may be installed from the component's Start Menu program group.
''' For a UI-based certificate selection, please see the CertificateListForm included with our
''' WinForms samples.
''' </remarks>
''' <param name="targetHost">The host server specified by the client.</param>
''' <param name="localCertificates">A reference to ClientSecurity.Certificates</param>
''' <param name="remoteCertificate">The certificate used to authenticate the remote party.</param>
''' <param name="acceptableIssuers">A String array of certificate issuers acceptable to the remote party.</param>
''' <returns>An X509Certificate to use for establishing the SSL connection.</returns>
Private Function selectLocalCertificate(ByVal sender As Object, ByVal targetHost As String, ByVal localCertificates As X509CertificateCollection, ByVal remoteCertificate As X509Certificate, ByVal acceptableIssuers() As String) As X509Certificate
    'Try to find the Dart Test Certificate
    Dim certificateStore As New X509Store(StoreName.My)
    certificateStore.Open(OpenFlags.ReadOnly)
    For Each cert As X509Certificate2 In certificateStore.Certificates
        If cert.GetNameInfo(X509NameType.SimpleName, True) = "DartdomCA" Then
            certificateStore.Close()
            Return cert
        End If
    Next cert
    'Certificate not found, return null
    Return Nothing
End Function

''' <summary>
''' Presents the server's certificate for validation.
''' </summary>
''' <param name="certificate">The certificate presented by the server</param>
''' <param name="chain">The chain of certificate authorities associated with the remote certificate</param>
''' <param name="sslPolicyErrors">One or more errors associated with the server's certificate</param>
''' <returns>A Boolean value that specifies whether the presented certificate is accepted for authentication</returns>
Private Function certificateReceived(ByVal sender As Object, ByVal certificate As X509Certificate, ByVal chain As X509Chain, ByVal sslPolicyErrors As SslPolicyErrors) As Boolean
    'Accept certificate if it passed standard validation.
    If sslPolicyErrors = System.Net.Security.SslPolicyErrors.None Then
        Return True
    End If

    Dim msg As String = "The server could not be validated for the following reason(s):"

    If (sslPolicyErrors And System.Net.Security.SslPolicyErrors.RemoteCertificateNotAvailable) = System.Net.Security.SslPolicyErrors.RemoteCertificateNotAvailable Then
        msg &= Environment.NewLine & "    -The server did not present a certificate."
    Else
        If (sslPolicyErrors And System.Net.Security.SslPolicyErrors.RemoteCertificateNameMismatch) = System.Net.Security.SslPolicyErrors.RemoteCertificateNameMismatch Then
            msg &= Environment.NewLine & "    -Certificate name mismatch."
        End If
        If (sslPolicyErrors And System.Net.Security.SslPolicyErrors.RemoteCertificateChainErrors) = System.Net.Security.SslPolicyErrors.RemoteCertificateChainErrors Then
            msg &= Environment.NewLine & "    -Certificate chain errors:" & Environment.NewLine

            For Each item As X509ChainStatus In chain.ChainStatus
                msg &= "    --" & item.StatusInformation
            Next item
        End If
    End If

    'Prompt to override security check
    msg &= Environment.NewLine & "Override security check?"
    If MessageBox.Show(msg, "Security Alert: Server could not be validated", MessageBoxButtons.YesNo, MessageBoxIcon.Exclamation) = System.Windows.Forms.DialogResult.Yes Then
        Return True
    Else
        Return False
    End If
End Function

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Close() Method

[image]
PowerTCP Emulation for .NET
Close() Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Close() Method

Glossary Item Box

Gracefully closes the connection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As TcpBase

instance.Close()
C#
public virtual void Close()
Managed Extensions for C++
public: virtual void Close();
C++/CLI
public:
virtual void Close();

Remarks

This method enters a normal TIME_WAIT state after the connection is closed.

See Also

Reference

TcpBase Class
TcpBase Members


Connect Method

[image]
PowerTCP Emulation for .NET
Connect Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Connect Method

session
Used to specify the local and remote endpoints, and proxy configuration.

Glossary Item Box

Connect to a server using the configuration specified by session.

Syntax

Visual Basic (Declaration)
Public Sub Connect( _
   ByVal session As TcpSession _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim session As TcpSession

instance.Connect(session)
C#
public void Connect(
   TcpSession session
)
Managed Extensions for C++
public: void Connect(
   TcpSession* session
)
C++/CLI
public:
void Connect(
   TcpSession^ session
)

Parameters

session
Used to specify the local and remote endpoints, and proxy configuration.

See Also

Reference

TcpBase Class
TcpBase Members


ConnectAsync Method

[image]
PowerTCP Emulation for .NET
ConnectAsync Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : ConnectAsync Method

session
Used to specify the local and remote endpoints, and proxy configuration.
callback
A TcpAsyncCallback delegate referencing the method to invoke on an IO completion thread when the operation completes.
state
Object to pass into the callback method when the operation completes; can be null.

Glossary Item Box

Connect to a server using the configuration specified by session.

Syntax

Visual Basic (Declaration)
Public Sub ConnectAsync( _
   ByVal session As TcpSession, _
   ByVal callback As TcpAsyncCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim session As TcpSession
Dim callback As TcpAsyncCallback
Dim state As Object

instance.ConnectAsync(session, callback, state)
C#
public void ConnectAsync(
   TcpSession session,
   TcpAsyncCallback callback,
   object state
)
Managed Extensions for C++
public: void ConnectAsync(
   TcpSession* session,
   TcpAsyncCallback* callback,
   Object* state
)
C++/CLI
public:
void ConnectAsync(
   TcpSession^ session,
   TcpAsyncCallback^ callback,
   Object^ state
)

Parameters

session
Used to specify the local and remote endpoints, and proxy configuration.
callback
A TcpAsyncCallback delegate referencing the method to invoke on an IO completion thread when the operation completes.
state
Object to pass into the callback method when the operation completes; can be null.

See Also

Reference

TcpBase Class
TcpBase Members


GetStream Method

[image]
PowerTCP Emulation for .NET
GetStream Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : GetStream Method

Glossary Item Box

Provides access to the underlying Stream.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Stream

value = instance.GetStream()
C#
public virtual Stream GetStream()
Managed Extensions for C++
public: virtual Stream* GetStream();
C++/CLI
public:
virtual Stream^ GetStream();

Return Value

The underlying Stream object used by the component.

Remarks

Derived classes can override this method to provide a stream that implements an upper-layer protocol.

See Also

Reference

TcpBase Class
TcpBase Members


Marshal Method

[image]
PowerTCP Emulation for .NET
Marshal Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Marshal Method

Glossary Item Box

Marshals data to the UI thread.

Overload List

Overload | Description
Marshal(Data,String,Object) | Marshals data to the UI thread.
Marshal(String,Object) | Marshals a string and/or object to the UI thread and raises the UserState event. (Inherited from Dart.Emulation.ComponentBase)
Marshal(Exception) | Marshals an exception to the UI thread and raises the Error event. (Inherited from Dart.Emulation.ComponentBase)

See Also

Reference

TcpBase Class
TcpBase Members


Marshal(Data,String,Object) Method

[image]
PowerTCP Emulation for .NET
Marshal(Data,String,Object) Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > Marshal Method : Marshal(Data,String,Object) Method

data
Data to be marshaled.
message
Text message to be marshaled.
state
State information to be marshaled.

Glossary Item Box

Marshals data to the UI thread.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal data As Data, _
   ByVal message As String, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim data As Data
Dim message As String
Dim state As Object

instance.Marshal(data, message, state)
C#
public void Marshal(
   Data data,
   string message,
   object state
)
Managed Extensions for C++
public: void Marshal(
   Data* data,
   string* message,
   Object* state
)
C++/CLI
public:
void Marshal(
   Data^ data,
   String^ message,
   Object^ state
)

Parameters

data
Data to be marshaled.
message
Text message to be marshaled.
state
State information to be marshaled.

Remarks

This method is used to marshal data from a worker thread to the UI thread for typical display purposes. It calls the OnData method, which raises the Data event.

See the SynchronizingObject property for information on updating UI controls in your event handler.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data to the UI.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    myComponent.Start(readLoopWorker, null);
}

private void readLoopWorker(object state)
{
    byte[] buffer = new byte[1024];
    Data data = myComponent.Read(buffer);
    while (data != null)
    {
        myComponent.Marshal(data, "", null);
        data = myComponent.Read(buffer);
    }
    myComponent.Close();
}

void myComponent_Data(object sender, Dart.Sockets.DataEventArgs e)
{
    textBox1.AppendText(e.Data.ToString());
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    myComponent.Start(AddressOf readLoopWorker, Nothing)
End Sub

Private Sub readLoopWorker(ByVal state As Object)
    Dim buffer(1023) As Byte
    Dim data As Data = myComponent.Read(buffer)
    Do While data IsNot Nothing
        myComponent.Marshal(data, "", Nothing)
        data = myComponent.Read(buffer)
    Loop
    myComponent.Close()
End Sub

Private Sub myComponent_Data(ByVal sender As Object, ByVal e As Dart.Sockets.DataEventArgs)
    textBox1.AppendText(e.Data.ToString())
End Sub

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Read Method

[image]
PowerTCP Emulation for .NET
Read Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Read Method

Glossary Item Box

Receives data from the remote host.

Overload List

Overload | Description
Read(Byte[],Int32,Int32) | Receives data from the remote host.
Read(Byte[]) | Receives data from the remote host.

See Also

Reference

TcpBase Class
TcpBase Members


Read(Byte[],Int32,Int32) Method

[image]
PowerTCP Emulation for .NET
Read(Byte[],Int32,Int32) Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > Read Method : Read(Byte[],Int32,Int32) Method

buffer
The byte array used to store the received data.
offset
The position in the buffer to store the data.
count
The maximum number of bytes to receive.

Glossary Item Box

Receives data from the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Data

value = instance.Read(buffer, offset, count)
C#
public Data Read(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Data* Read(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Data^ Read(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
The byte array used to store the received data.
offset
The position in the buffer to store the data.
count
The maximum number of bytes to receive.

Return Value

A Data object encapsulating the received data. Returns null if the socket is closed.

Remarks

This method performs a single socket read, blocking until at least one byte is read, up to as much data as is available on the socket, count bytes, or buffer.Length, whichever is lowest. A SocketException indicating SocketError.Timeout will not result in the socket being closed; other SocketExceptions are fatal and the socket is automatically closed by the class.

The ReceiveTimeout property controls how long this method will block before throwing a Timeout exception.

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Read(Byte[]) Method

[image]
PowerTCP Emulation for .NET
Read(Byte[]) Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > Read Method : Read(Byte[]) Method

buffer
The byte array used to store the received data.

Glossary Item Box

Receives data from the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Function Read( _
   ByVal buffer() As Byte _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim value As Data

value = instance.Read(buffer)
C#
public Data Read(
   byte[] buffer
)
Managed Extensions for C++
public: Data* Read(
   byte[]* buffer
)
C++/CLI
public:
Data^ Read(
   array<byte>^ buffer
)

Parameters

buffer
The byte array used to store the received data.

Return Value

A Data object encapsulating the received data. Returns null if the socket is closed.

Remarks

This method performs a single socket read, blocking until at least one byte is read, up to as much data as is available on the socket or buffer.Length, whichever is lowest.

This method will block until data is available or the ReceiveTimeout has expired.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data to the UI.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    myComponent.Start(readLoopWorker, null);
}

private void readLoopWorker(object state)
{
    byte[] buffer = new byte[1024];
    Data data = myComponent.Read(buffer);
    while (data != null)
    {
        myComponent.Marshal(data, "", null);
        data = myComponent.Read(buffer);
    }
    myComponent.Close();
}

void myComponent_Data(object sender, Dart.Sockets.DataEventArgs e)
{
    textBox1.AppendText(e.Data.ToString());
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    myComponent.Start(AddressOf readLoopWorker, Nothing)
End Sub

Private Sub readLoopWorker(ByVal state As Object)
    Dim buffer(1023) As Byte
    Dim data As Data = myComponent.Read(buffer)
    Do While data IsNot Nothing
        myComponent.Marshal(data, "", Nothing)
        data = myComponent.Read(buffer)
    Loop
    myComponent.Close()
End Sub

Private Sub myComponent_Data(ByVal sender As Object, ByVal e As Dart.Sockets.DataEventArgs)
    textBox1.AppendText(e.Data.ToString())
End Sub

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadAsync Method

[image]
PowerTCP Emulation for .NET
ReadAsync Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : ReadAsync Method

buffer
The byte array used to store the received data.
offset
The position in the buffer to store the data.
count
The maximum number of bytes to receive.
callback
A TcpAsyncCallback delegate referencing the method to invoke on an IO completion thread when the operation completes.
state
Object to pass into the callback method when the operation completes; can be null.

Glossary Item Box

Start an asynchronous read on the socket.

Syntax

Visual Basic (Declaration)
Public Sub ReadAsync( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As TcpAsyncCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As TcpAsyncCallback
Dim state As Object

instance.ReadAsync(buffer, offset, count, callback, state)
C#
public void ReadAsync(
   byte[] buffer,
   int offset,
   int count,
   TcpAsyncCallback callback,
   object state
)
Managed Extensions for C++
public: void ReadAsync(
   byte[]* buffer,
   int offset,
   int count,
   TcpAsyncCallback* callback,
   Object* state
)
C++/CLI
public:
void ReadAsync(
   array<byte>^ buffer,
   int offset,
   int count,
   TcpAsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
The byte array used to store the received data.
offset
The position in the buffer to store the data.
count
The maximum number of bytes to receive.
callback
A TcpAsyncCallback delegate referencing the method to invoke on an IO completion thread when the operation completes.
state
Object to pass into the callback method when the operation completes; can be null.

Remarks

The TCP component is typically used by making blocking calls on a worker (non-UI) thread. This technique keeps development simple as there is no need for saving state information, but does require a dedicated thread for each connection. If a dedicated worker thread for each socket is not scalable enough, such as in server applications, developers can instead use the Async methods which utilize IO completion ports. The Async methods do not require a dedicated worker thread for each connection, and the specified callback is invoked on an IO completion thread when the operation completes. This is the best way to create a high-performance server without using dedicated worker threads.

See Also

Reference

TcpBase Class
TcpBase Members


ReadToCount Method

[image]
PowerTCP Emulation for .NET
ReadToCount Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : ReadToCount Method

buffer
The byte array used to store the received data.
offset
The position in the buffer to store the data.
count
The number of byte to read.

Glossary Item Box

Read until count bytes are read, an exception is thrown, or the connection is closed.

Syntax

Visual Basic (Declaration)
Public Function ReadToCount( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Data

value = instance.ReadToCount(buffer, offset, count)
C#
public Data ReadToCount(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Data* ReadToCount(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Data^ ReadToCount(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
The byte array used to store the received data.
offset
The position in the buffer to store the data.
count
The number of byte to read.

Return Value

A Data object encapsulating the received data.

Exceptions

Exception | Description
DataException | Count bytes could not be read. The DataException.DataRead property contains any data received before the failure occurred.

Remarks

If a DataException is thrown, the DataException.DataRead property contains any data received prior to the exception.

See Also

Reference

TcpBase Class
TcpBase Members


ReadToDelimiter Method

[image]
PowerTCP Emulation for .NET
ReadToDelimiter Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : ReadToDelimiter Method

Glossary Item Box

Read until the delimiter is found, an exception is thrown, or the connection is closed.

Overload List

Overload | Description
ReadToDelimiter(String) | Read until the delimiter is found, an exception is thrown, or the connection is closed.
ReadToDelimiter(Byte[]) | Read until the delimiter is found, an exception is thrown, or the connection is closed.
ReadToDelimiter(String[]) | Read until a delimiter is found, an exception is thrown, or the connection is closed.
ReadToDelimiter(List<Byte[]>) | Read until a delimiter is found, an exception is thrown, or the connection is closed.

See Also

Reference

TcpBase Class
TcpBase Members


ReadToDelimiter(String) Method

[image]
PowerTCP Emulation for .NET
ReadToDelimiter(String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > ReadToDelimiter Method : ReadToDelimiter(String) Method

delimiter
A delimiter to search for.

Glossary Item Box

Read until the delimiter is found, an exception is thrown, or the connection is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDelimiter( _
   ByVal delimiter As String _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiter As String
Dim value As Data

value = instance.ReadToDelimiter(delimiter)
C#
public Data ReadToDelimiter(
   string delimiter
)
Managed Extensions for C++
public: Data* ReadToDelimiter(
   string* delimiter
)
C++/CLI
public:
Data^ ReadToDelimiter(
   String^ delimiter
)

Parameters

delimiter
A delimiter to search for.

Return Value

A Data object encapsulating the received data.

Exceptions

Exception | Description
DataException | The delimiter was not found. The DataException.DataRead property contains any data received before the failure occurred.

Remarks

This method blocks until the delimiter is found, an exception is thrown, or the server closes the connection. The value of Data.Delimiter is set to the found delimiter, if any.

If a DataException is thrown, the DataException.DataRead property contains any data received prior to the exception.

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadToDelimiter(Byte[]) Method

[image]
PowerTCP Emulation for .NET
ReadToDelimiter(Byte[]) Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > ReadToDelimiter Method : ReadToDelimiter(Byte[]) Method

delimiter
The delimiter to search for.

Glossary Item Box

Read until the delimiter is found, an exception is thrown, or the connection is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDelimiter( _
   ByVal delimiter() As Byte _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiter() As Byte
Dim value As Data

value = instance.ReadToDelimiter(delimiter)
C#
public Data ReadToDelimiter(
   byte[] delimiter
)
Managed Extensions for C++
public: Data* ReadToDelimiter(
   byte[]* delimiter
)
C++/CLI
public:
Data^ ReadToDelimiter(
   array<byte>^ delimiter
)

Parameters

delimiter
The delimiter to search for.

Return Value

A Data object encapsulating the received data.

Exceptions

Exception | Description
DataException | The delimiter was not found. The DataException.DataRead property contains any data received before the failure occurred.

Remarks

This method blocks until the delimiter is found, an exception is thrown, or the server closes the connection. The value of Data.Delimiter is set to the found delimiter, if any.

If a DataException is thrown, the DataException.DataRead property contains any data received prior to the exception.

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadToDelimiter(String[]) Method

[image]
PowerTCP Emulation for .NET
ReadToDelimiter(String[]) Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > ReadToDelimiter Method : ReadToDelimiter(String[]) Method

delimiters
An array of delimiters to search for.

Glossary Item Box

Read until a delimiter is found, an exception is thrown, or the connection is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDelimiter( _
   ByVal delimiters() As String _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiters() As String
Dim value As Data

value = instance.ReadToDelimiter(delimiters)
C#
public Data ReadToDelimiter(
   string[] delimiters
)
Managed Extensions for C++
public: Data* ReadToDelimiter(
   string*[]* delimiters
)
C++/CLI
public:
Data^ ReadToDelimiter(
   array<String^>^ delimiters
)

Parameters

delimiters
An array of delimiters to search for.

Return Value

Data object encapsulating the received data.

Exceptions

Exception | Description
DataException | The delimiter was not found. The DataException.DataRead property contains any data received before the failure occurred.

Remarks

This method blocks until a delimiter is found, an exception is thrown, or the server closes the connection. The value of Data.Delimiter is set to the found delimiter, if any.

If a DataException is thrown, the DataException.DataRead property contains any data received prior to the exception.

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadToDelimiter(List<Byte[]>) Method

[image]
PowerTCP Emulation for .NET
ReadToDelimiter(List<Byte[]>) Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > ReadToDelimiter Method : ReadToDelimiter(List<Byte[]>) Method

delimiters
A list of delimiters to search for.

Glossary Item Box

Read until a delimiter is found, an exception is thrown, or the connection is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDelimiter( _
   ByVal delimiters As List(Of Byte()) _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiters As List(Of Byte())
Dim value As Data

value = instance.ReadToDelimiter(delimiters)
C#
public Data ReadToDelimiter(
   List<byte[]> delimiters
)
Managed Extensions for C++
public: Data* ReadToDelimiter(
   List<byte[]>* delimiters
)
C++/CLI
public:
Data^ ReadToDelimiter(
   List<array<byte>>^ delimiters
)

Parameters

delimiters
A list of delimiters to search for.

Return Value

A Data object encapsulating the received data.

Exceptions

Exception | Description
DataException | The delimiter was not found. The DataException.DataRead property contains any data received before the failure occurred.

Remarks

This method blocks until a delimiter is found, an exception is thrown, or the server closes the connection. The value of Data.Delimiter is set to the found delimiter, if any.

If a DataException is thrown, the DataException.DataRead property contains any data received prior to the exception.

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadToEnd Method

[image]
PowerTCP Emulation for .NET
ReadToEnd Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : ReadToEnd Method

Glossary Item Box

Read until the connection is closed or an exception is thrown.

Syntax

Visual Basic (Declaration)
Public Function ReadToEnd() As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Data

value = instance.ReadToEnd()
C#
public Data ReadToEnd()
Managed Extensions for C++
public: Data* ReadToEnd();
C++/CLI
public:
Data^ ReadToEnd();

Return Value

A Data object encapsulating the received data. Returns null if the socket is closed.

Exceptions

Exception | Description
DataException | A failure occurred before the normal end of stream was found. The DataException.DataRead property contains any data received before the failure occurred.

Remarks

If a DataException is thrown, the DataException.DataRead property contains any data received prior to the exception.

See Also

Reference

TcpBase Class
TcpBase Members


ShutdownSsl Method

[image]
PowerTCP Emulation for .NET
ShutdownSsl Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : ShutdownSsl Method

Glossary Item Box

Signals the remote host to shutdown the SSL connection.

Syntax

Visual Basic (Declaration)
Public Sub ShutdownSsl()
Visual Basic (Usage) Copy Code
Dim instance As TcpBase

instance.ShutdownSsl()
C#
public void ShutdownSsl()
Managed Extensions for C++
public: void ShutdownSsl();
C++/CLI
public:
void ShutdownSsl();

Remarks

This method provides a means for switching a secure connection to a non-secure connection.

See Also

Reference

TcpBase Class
TcpBase Members


Write Method

[image]
PowerTCP Emulation for .NET
Write Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Write Method

Glossary Item Box

Sends data to the remote host.

Overload List

Overload | Description
Write(Byte[]) | Sends data to the remote host.
Write(String) | Sends data to the remote host.
Write(Byte[],Int32,Int32) | Sends data to the remote host.

See Also

Reference

TcpBase Class
TcpBase Members


Write(Byte[]) Method

[image]
PowerTCP Emulation for .NET
Write(Byte[]) Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > Write Method : Write(Byte[]) Method

buffer
Byte array of data to send.

Glossary Item Box

Sends data to the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Function Write( _
   ByVal buffer() As Byte _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim value As Data

value = instance.Write(buffer)
C#
public Data Write(
   byte[] buffer
)
Managed Extensions for C++
public: Data* Write(
   byte[]* buffer
)
C++/CLI
public:
Data^ Write(
   array<byte>^ buffer
)

Parameters

buffer
Byte array of data to send.

Return Value

A Data object encapsulating the sent data. Returns null if the socket is closed.

Remarks

This method synchronously sends data to the remote host over an existing connection. It will block until a buffer is available to accept the data or SocketOption.SendTimeout has expired.

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Write(String) Method

[image]
PowerTCP Emulation for .NET
Write(String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > Write Method : Write(String) Method

data
String of data to send.

Glossary Item Box

Sends data to the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Function Write( _
   ByVal data As String _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim data As String
Dim value As Data

value = instance.Write(data)
C#
public Data Write(
   string data
)
Managed Extensions for C++
public: Data* Write(
   string* data
)
C++/CLI
public:
Data^ Write(
   String^ data
)

Parameters

data
String of data to send.

Return Value

A Data object encapsulating the sent data. Returns null if the socket is closed.

Remarks

This method synchronously sends data to the remote host over an existing connection. It will block until a buffer is available to accept the data or SocketOption.SendTimeout has expired.

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Write(Byte[],Int32,Int32) Method

[image]
PowerTCP Emulation for .NET
Write(Byte[],Int32,Int32) Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class > Write Method : Write(Byte[],Int32,Int32) Method

buffer
Byte array of data to send.
offset
The position in the data buffer at which to begin sending data.
count
The number of bytes to send.

Glossary Item Box

Sends data to the remote host.

Syntax

Visual Basic (Declaration)
Public Overloads Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Data

value = instance.Write(buffer, offset, count)
C#
public Data Write(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Data* Write(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Data^ Write(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
Byte array of data to send.
offset
The position in the data buffer at which to begin sending data.
count
The number of bytes to send.

Return Value

A Data object encapsulating the sent data. Returns null if the socket is closed.

Remarks

This method synchronously sends data to the remote host over an existing connection. It will block until a buffer is available to accept the data or SocketOption.SendTimeout has expired.

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


WriteAsync Method

[image]
PowerTCP Emulation for .NET
WriteAsync Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : WriteAsync Method

buffer
The byte array containing data to be written.
offset
The position in the buffer to start writing data from.
count
The number of bytes to write.
callback
A TcpAsyncCallback delegate referencing the method to invoke on an IO completion thread when the operation completes.
state
Object to pass into the callback method when the operation completes; can be null.

Glossary Item Box

Start an asynchronous write on the socket.

Syntax

Visual Basic (Declaration)
Public Sub WriteAsync( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As TcpAsyncCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As TcpAsyncCallback
Dim state As Object

instance.WriteAsync(buffer, offset, count, callback, state)
C#
public void WriteAsync(
   byte[] buffer,
   int offset,
   int count,
   TcpAsyncCallback callback,
   object state
)
Managed Extensions for C++
public: void WriteAsync(
   byte[]* buffer,
   int offset,
   int count,
   TcpAsyncCallback* callback,
   Object* state
)
C++/CLI
public:
void WriteAsync(
   array<byte>^ buffer,
   int offset,
   int count,
   TcpAsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
The byte array containing data to be written.
offset
The position in the buffer to start writing data from.
count
The number of bytes to write.
callback
A TcpAsyncCallback delegate referencing the method to invoke on an IO completion thread when the operation completes.
state
Object to pass into the callback method when the operation completes; can be null.

Remarks

The TCP component is typically used by making blocking calls on a worker (non-UI) thread. This technique keeps development simple as there is no need for saving state information, but requires a dedicated thread for each connection. If a dedicated worker thread for each socket is not scalable enough, such as in server applications, developers can use Async methods which utilize IO completion ports. Async methods do not require a dedicated worker thread for each connection, and the specified callback is invoked on an IO completion thread when the operation completes. This is the best way to create a scalable, high-performance server.

See Also

Reference

TcpBase Class
TcpBase Members


TcpBase Class Properties

[image]
PowerTCP Emulation for .NET
TcpBase Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : TcpBase Class

Glossary Item Box

For a list of all members of this type, see TcpBase members.

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed.
Public Property | ConnectTime | Returns the DateTime the connection was established.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called.
Public Property | RemoteEndPoint | Gets the remote address and port of the connection.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase.
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called.
Public Property | State | Gets the status of the connection as of the last socket operation.
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Emulation Namespace


CloseTime Property

[image]
PowerTCP Emulation for .NET
CloseTime Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : CloseTime Property

Glossary Item Box

Returns the DateTime the connection was closed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CloseTime As Date
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Date

value = instance.CloseTime
C#
public DateTime CloseTime {get;}
Managed Extensions for C++
public: __property DateTime get_CloseTime();
C++/CLI
public:
property DateTime CloseTime {
   DateTime get();
}

See Also

Reference

TcpBase Class
TcpBase Members


ConnectTime Property

[image]
PowerTCP Emulation for .NET
ConnectTime Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : ConnectTime Property

Glossary Item Box

Returns the DateTime the connection was established.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConnectTime As Date
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Date

value = instance.ConnectTime
C#
public DateTime ConnectTime {get;}
Managed Extensions for C++
public: __property DateTime get_ConnectTime();
C++/CLI
public:
property DateTime ConnectTime {
   DateTime get();
}

See Also

Reference

TcpBase Class
TcpBase Members


NetworkStream Property

[image]
PowerTCP Emulation for .NET
NetworkStream Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : NetworkStream Property

Glossary Item Box

Returns the NetworkStream object created when Connect() is called.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkStream As NetworkStream
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As NetworkStream

value = instance.NetworkStream
C#
public NetworkStream NetworkStream {get;}
Managed Extensions for C++
public: __property NetworkStream* get_NetworkStream();
C++/CLI
public:
property NetworkStream^ NetworkStream {
   NetworkStream^ get();
}

Remarks

Returns null when no TCP connection exists.

See Also

Reference

TcpBase Class
TcpBase Members


RemoteEndPoint Property

[image]
PowerTCP Emulation for .NET
RemoteEndPoint Property
See Also Example Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : RemoteEndPoint Property

Glossary Item Box

Gets the remote address and port of the connection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RemoteEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As IPEndPoint

value = instance.RemoteEndPoint
C#
public IPEndPoint RemoteEndPoint {get;}
Managed Extensions for C++
public: __property IPEndPoint* get_RemoteEndPoint();
C++/CLI
public:
property IPEndPoint^ RemoteEndPoint {
   IPEndPoint^ get();
}

Property Value

The Socket.RemoteEndPoint. This value persists after the connection is closed.

Example

This example demonstrates using the StateChanged event and State property to update the UI.
C# Copy Code
private void myComponent_StateChanged(object sender, EventArgs e)
{
    if (myComponent.State == ConnectionState.Closed)
        this.Text = "Not Connected";
    else if (myComponent.State == ConnectionState.Connected)
        this.Text = "Connected to " + myComponent.RemoteEndPoint.ToString();
    else
        this.Text = "Securely connected to " + myComponent.RemoteEndPoint.ToString();
}
Visual Basic Copy Code
Private Sub myComponent_StateChanged(ByVal sender As Object, ByVal e As EventArgs)
    If myComponent.State = ConnectionState.Closed Then
        Me.Text = "Not Connected"
    ElseIf myComponent.State = ConnectionState.Connected Then
        Me.Text = "Connected to " & myComponent.RemoteEndPoint.ToString()
    Else
        Me.Text = "Securely connected to " & myComponent.RemoteEndPoint.ToString()
    End If
End Sub

See Also

Reference

TcpBase Class
TcpBase Members


SocketOption Property

[image]
PowerTCP Emulation for .NET
SocketOption Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : SocketOption Property

Glossary Item Box

Gets and sets the socket options for classes derived from TcpBase.

Syntax

Visual Basic (Declaration)
Public Property SocketOption As TcpSocketOption
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As TcpSocketOption

instance.SocketOption = value

value = instance.SocketOption
C#
public TcpSocketOption SocketOption {get; set;}
Managed Extensions for C++
public: __property TcpSocketOption* get_SocketOption();
public: __property void set_SocketOption(
   TcpSocketOption* value
);
C++/CLI
public:
property TcpSocketOption^ SocketOption {
   TcpSocketOption^ get();
   void set (    TcpSocketOption^ value);
}

See Also

Reference

TcpBase Class
TcpBase Members


SslStream Property

[image]
PowerTCP Emulation for .NET
SslStream Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : SslStream Property

Glossary Item Box

Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SslStream As SslStream
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As SslStream

value = instance.SslStream
C#
public SslStream SslStream {get;}
Managed Extensions for C++
public: __property SslStream* get_SslStream();
C++/CLI
public:
property SslStream^ SslStream {
   SslStream^ get();
}

Remarks

Returns null when no secure connection exists.

See Also

Reference

TcpBase Class
TcpBase Members


State Property

[image]
PowerTCP Emulation for .NET
State Property
See Also Example Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : State Property

Glossary Item Box

Gets the status of the connection as of the last socket operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As ConnectionState
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As ConnectionState

value = instance.State
C#
public ConnectionState State {get;}
Managed Extensions for C++
public: __property ConnectionState get_State();
C++/CLI
public:
property ConnectionState State {
   ConnectionState get();
}

Example

This example demonstrates using the StateChanged event and State property to update the UI.
C# Copy Code
private void myComponent_StateChanged(object sender, EventArgs e)
{
    if (myComponent.State == ConnectionState.Closed)
        this.Text = "Not Connected";
    else if (myComponent.State == ConnectionState.Connected)
        this.Text = "Connected to " + myComponent.RemoteEndPoint.ToString();
    else
        this.Text = "Securely connected to " + myComponent.RemoteEndPoint.ToString();
}
Visual Basic Copy Code
Private Sub myComponent_StateChanged(ByVal sender As Object, ByVal e As EventArgs)
    If myComponent.State = ConnectionState.Closed Then
        Me.Text = "Not Connected"
    ElseIf myComponent.State = ConnectionState.Connected Then
        Me.Text = "Connected to " & myComponent.RemoteEndPoint.ToString()
    Else
        Me.Text = "Securely connected to " & myComponent.RemoteEndPoint.ToString()
    End If
End Sub

See Also

Reference

TcpBase Class
TcpBase Members


TcpBase Class Events

[image]
PowerTCP Emulation for .NET
TcpBase Class Events
See Also Send comments on this topic
Dart.Emulation Namespace : TcpBase Class

Glossary Item Box

For a list of all members of this type, see TcpBase members.

Public Events

 | Name | Description
Public Event | Data | Raised when Marshal(Data,String,Object) is used.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written.
Public Event | StateChanged | Raised when the value of the State property changes.
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Emulation Namespace


Data Event

[image]
PowerTCP Emulation for .NET
Data Event
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Data Event

Glossary Item Box

Raised when Marshal(Data,String,Object) is used.

Syntax

Visual Basic (Declaration)
Public Event Data As EventHandler(Of DataEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim handler As EventHandler(Of DataEventArgs)

AddHandler instance.Data, handler
C#
public event EventHandler<DataEventArgs> Data
Managed Extensions for C++
public: __event EventHandler<DataEventArgs*>* Data
C++/CLI
public:
event EventHandler<DataEventArgs^>^ Data

Event Data

The event handler receives an argument of type DataEventArgs containing data related to this event. The following DataEventArgs properties provide information specific to this event.

Property | Description
Data | Gets data provided by Data and Log events.
Message | Returns the message argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)
UserState | Returns the user state argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)

Remarks

See the SynchronizingObject property for information on updating UI controls in your event handler.

See Also

Reference

TcpBase Class
TcpBase Members


Log Event

[image]
PowerTCP Emulation for .NET
Log Event
See Also Example Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Log Event

Glossary Item Box

Raised when data is read or written.

Syntax

Visual Basic (Declaration)
Public Event Log As EventHandler(Of DataEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim handler As EventHandler(Of DataEventArgs)

AddHandler instance.Log, handler
C#
public event EventHandler<DataEventArgs> Log
Managed Extensions for C++
public: __event EventHandler<DataEventArgs*>* Log
C++/CLI
public:
event EventHandler<DataEventArgs^>^ Log

Event Data

The event handler receives an argument of type DataEventArgs containing data related to this event. The following DataEventArgs properties provide information specific to this event.

Property | Description
Data | Gets data provided by Data and Log events.
Message | Returns the message argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)
UserState | Returns the user state argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)

Remarks

The handler must be added before connecting. See the SynchronizingObject property for information on updating UI controls in your event handler.

Example

This example demonstrates logging sent and received data to a textbox.
C# Copy Code
private void myComponent_Log(object sender, DataEventArgs e)
{
    string prompt = (e.Data.Direction == DataDirection.In) ? "Recv: " : "Sent: ";
    textBox1.AppendText(prompt + e.Data.ToString() + Environment.NewLine);
}
Visual Basic Copy Code
Private Sub myComponent_Log(ByVal sender As Object, ByVal e As DataEventArgs)
    Dim prompt As String = If(e.Data.Direction = DataDirection.In, "Recv: ", "Sent: ")
    textBox1.AppendText(prompt & e.Data.ToString() & Environment.NewLine)
End Sub

See Also

Reference

TcpBase Class
TcpBase Members


StateChanged Event

[image]
PowerTCP Emulation for .NET
StateChanged Event
See Also Example Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : StateChanged Event

Glossary Item Box

Raised when the value of the State property changes.

Syntax

Visual Basic (Declaration)
Public Event StateChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim handler As EventHandler

AddHandler instance.StateChanged, handler
C#
public event EventHandler StateChanged
Managed Extensions for C++
public: __event EventHandler* StateChanged
C++/CLI
public:
event EventHandler^ StateChanged

Remarks

See the SynchronizingObject property for information on updating UI controls in your event handler.

This event can be raised during a Read call if the remote host closes the connection. In this scenario, a form should not be disposed of within this event handler if the Dart component was created on the form (this includes calling Form.Close if Form.Show was used to show it). Instead, the component can be created elsewhere and passed to the form, or the form can be disposed of after the posted Read returns.

Example

This example demonstrates using the StateChanged event and State property to update the UI.
C# Copy Code
private void myComponent_StateChanged(object sender, EventArgs e)
{
    if (myComponent.State == ConnectionState.Closed)
        this.Text = "Not Connected";
    else if (myComponent.State == ConnectionState.Connected)
        this.Text = "Connected to " + myComponent.RemoteEndPoint.ToString();
    else
        this.Text = "Securely connected to " + myComponent.RemoteEndPoint.ToString();
}
Visual Basic Copy Code
Private Sub myComponent_StateChanged(ByVal sender As Object, ByVal e As EventArgs)
    If myComponent.State = ConnectionState.Closed Then
        Me.Text = "Not Connected"
    ElseIf myComponent.State = ConnectionState.Connected Then
        Me.Text = "Connected to " & myComponent.RemoteEndPoint.ToString()
    Else
        Me.Text = "Securely connected to " & myComponent.RemoteEndPoint.ToString()
    End If
End Sub

See Also

Reference

TcpBase Class
TcpBase Members


TcpSession Class

[image]
PowerTCP Emulation for .NET
TcpSession Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : TcpSession Class

Glossary Item Box

Holds the configuration used by TCP.

Object Model

TcpSession ClassIPEndPoint ClassProxy ClassIPEndPoint ClassClientSecurity Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class TcpSession
   Inherits Session
Visual Basic (Usage) Copy Code
Dim instance As TcpSession
C#
[Serializable()]
public class TcpSession : Session
Managed Extensions for C++
[Serializable()]
public __gc class TcpSession : public Session
C++/CLI
[Serializable()]
public ref class TcpSession : public Session

Inheritance Hierarchy

System.Object
Dart.Emulation.Session
Dart.Emulation.TcpSession

See Also

Reference

TcpSession Members
Dart.Emulation Namespace


TcpSession Class Members

[image]
PowerTCP Emulation for .NET
TcpSession Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : TcpSession Class

Glossary Item Box

The following tables list the members exposed by TcpSession.

Public Constructors

 | Name | Description
Public Constructor | TcpSession Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ConnectTimeout | Gets or sets a value that specifies the amount of time (in milliseconds) after which a call to TcpBase.Connect will time out.
Public Property | LocalEndPoint | EndPoint to bind to locally. (Inherited from Dart.Emulation.Session)
Public Property | Proxy | Defines the optional server proxy configuration.
Public Property | RemoteEndPoint | EndPoint of the remote host to connect to. (Inherited from Dart.Emulation.Session)
Public Property | Security | Specifies the client-side SSL options. See the ClientSecurity class for more information.
Top

See Also

Reference

TcpSession Class
Dart.Emulation Namespace


TcpSession Constructor

[image]
PowerTCP Emulation for .NET
TcpSession Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSession Class : TcpSession Constructor

Glossary Item Box

Overload List

Overload | Description
TcpSession Constructor() | Default constructor for TcpSession.
TcpSession Constructor(IPEndPoint) | Constructor for TcpSession with a Remote IPEndPoint parameter.

See Also

Reference

TcpSession Class
TcpSession Members


TcpSession Constructor()

[image]
PowerTCP Emulation for .NET
TcpSession Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSession Class > TcpSession Constructor : TcpSession Constructor()

Glossary Item Box

Default constructor for TcpSession.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TcpSession()
C#
public TcpSession()
Managed Extensions for C++
public: TcpSession();
C++/CLI
public:
TcpSession();

See Also

Reference

TcpSession Class
TcpSession Members
Overload List


TcpSession Constructor(IPEndPoint)

[image]
PowerTCP Emulation for .NET
TcpSession Constructor(IPEndPoint)
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSession Class > TcpSession Constructor : TcpSession Constructor(IPEndPoint)

remoteEP
The remote IPEndPoint to connect to.

Glossary Item Box

Constructor for TcpSession with a Remote IPEndPoint parameter.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal remoteEP As IPEndPoint _
)
Visual Basic (Usage) Copy Code
Dim remoteEP As IPEndPoint

Dim instance As New TcpSession(remoteEP)
C#
public TcpSession(
   IPEndPoint remoteEP
)
Managed Extensions for C++
public: TcpSession(
   IPEndPoint* remoteEP
)
C++/CLI
public:
TcpSession(
   IPEndPoint^ remoteEP
)

Parameters

remoteEP
The remote IPEndPoint to connect to.

See Also

Reference

TcpSession Class
TcpSession Members
Overload List


TcpSession Class Properties

[image]
PowerTCP Emulation for .NET
TcpSession Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : TcpSession Class

Glossary Item Box

For a list of all members of this type, see TcpSession members.

Public Properties

 | Name | Description
Public Property | ConnectTimeout | Gets or sets a value that specifies the amount of time (in milliseconds) after which a call to TcpBase.Connect will time out.
Public Property | LocalEndPoint | EndPoint to bind to locally. (Inherited from Dart.Emulation.Session)
Public Property | Proxy | Defines the optional server proxy configuration.
Public Property | RemoteEndPoint | EndPoint of the remote host to connect to. (Inherited from Dart.Emulation.Session)
Public Property | Security | Specifies the client-side SSL options. See the ClientSecurity class for more information.
Top

See Also

Reference

TcpSession Class
Dart.Emulation Namespace


ConnectTimeout Property

[image]
PowerTCP Emulation for .NET
ConnectTimeout Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSession Class : ConnectTimeout Property

Glossary Item Box

Gets or sets a value that specifies the amount of time (in milliseconds) after which a call to TcpBase.Connect will time out.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ConnectTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As TcpSession
Dim value As Integer

instance.ConnectTimeout = value

value = instance.ConnectTimeout
C#
[DefaultValue()]
public int ConnectTimeout {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_ConnectTimeout();
public: __property void set_ConnectTimeout(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int ConnectTimeout {
   int get();
   void set (    int value);
}

Property Value

The timeout value in milliseconds. The default value is -1, which defers to the system timeout.

Remarks

This property is used to cancel a connect request early; it does not override the system-level connect timeout.

See Also

Reference

TcpSession Class
TcpSession Members


Proxy Property

[image]
PowerTCP Emulation for .NET
Proxy Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSession Class : Proxy Property

Glossary Item Box

Defines the optional server proxy configuration.

Syntax

Visual Basic (Declaration)
Public Property Proxy As Proxy
Visual Basic (Usage) Copy Code
Dim instance As TcpSession
Dim value As Proxy

instance.Proxy = value

value = instance.Proxy
C#
public Proxy Proxy {get; set;}
Managed Extensions for C++
public: __property Proxy* get_Proxy();
public: __property void set_Proxy(
   Proxy* value
);
C++/CLI
public:
property Proxy^ Proxy {
   Proxy^ get();
   void set (    Proxy^ value);
}

Remarks

Use this property to define the server proxy configuration.

See Also

Reference

TcpSession Class
TcpSession Members


Security Property

[image]
PowerTCP Emulation for .NET
Security Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSession Class : Security Property

Glossary Item Box

Specifies the client-side SSL options. See the ClientSecurity class for more information.

Syntax

Visual Basic (Declaration)
Public Property Security As ClientSecurity
Visual Basic (Usage) Copy Code
Dim instance As TcpSession
Dim value As ClientSecurity

instance.Security = value

value = instance.Security
C#
public ClientSecurity Security {get; set;}
Managed Extensions for C++
public: __property ClientSecurity* get_Security();
public: __property void set_Security(
   ClientSecurity* value
);
C++/CLI
public:
property ClientSecurity^ Security {
   ClientSecurity^ get();
   void set (    ClientSecurity^ value);
}

Property Value

ClientSecurity

See Also

Reference

TcpSession Class
TcpSession Members


TcpSocketOption Class

[image]
PowerTCP Emulation for .NET
TcpSocketOption Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : TcpSocketOption Class

Glossary Item Box

Contains socket options that may be set by TCP sockets.

Object Model

TcpSocketOption Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class TcpSocketOption
   Inherits SocketOption
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
C#
[Serializable()]
public class TcpSocketOption : SocketOption
Managed Extensions for C++
[Serializable()]
public __gc class TcpSocketOption : public SocketOption
C++/CLI
[Serializable()]
public ref class TcpSocketOption : public SocketOption

Inheritance Hierarchy

System.Object
Dart.Emulation.SocketOption
Dart.Emulation.TcpSocketOption

See Also

Reference

TcpSocketOption Members
Dart.Emulation Namespace


TcpSocketOption Class Members

[image]
PowerTCP Emulation for .NET
TcpSocketOption Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : TcpSocketOption Class

Glossary Item Box

The following tables list the members exposed by TcpSocketOption.

Public Properties

 | Name | Description
Public Property | ExclusiveAddressUse | When set to true, forbids multiple socket bindings to the same address. Set this value to true to ensure you have exclusive use of the local endpoint. Socket.ExclusiveAddressUse is set to this value before Socket.Bind is used. (Inherited from Dart.Emulation.SocketOption)
Public Property | KeepAliveInterval | The time in milliseconds between retransmission of keepalives once the KeepAliveTime has expired.
Public Property | KeepAliveTime | The connection idle time in milliseconds before TCP will begin sending keepalives.
Public Property | NoDelay | Gets or sets a value that disables the use of Nagle's algorithm so that data is sent immediately.
Public Property | OutOfBandInline | Gets or sets a value that indicates whether out-of-band (urgent) data is read as normal in-line data.
Public Property | ReceiveBufferSize | Gets or sets a value that specifies the size of the system receive buffer. (Inherited from Dart.Emulation.SocketOption)
Public Property | ReceiveTimeout | Overridden. Gets or sets a value that specifies the amount of time after which the underlying TCP Socket.Receive call will time out.
Public Property | ReuseAddress | When set to true, allows multiple socket bindings to the same address. Set this value to true to allow multiple sockets to bind to the same local address. (Inherited from Dart.Emulation.SocketOption)
Public Property | SendBufferSize | Gets or sets a value that specifies the size of the system send buffer. (Inherited from Dart.Emulation.SocketOption)
Public Property | SendTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out. (Inherited from Dart.Emulation.SocketOption)
Top

See Also

Reference

TcpSocketOption Class
Dart.Emulation Namespace


TcpSocketOption Class Properties

[image]
PowerTCP Emulation for .NET
TcpSocketOption Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : TcpSocketOption Class

Glossary Item Box

For a list of all members of this type, see TcpSocketOption members.

Public Properties

 | Name | Description
Public Property | ExclusiveAddressUse | When set to true, forbids multiple socket bindings to the same address. Set this value to true to ensure you have exclusive use of the local endpoint. Socket.ExclusiveAddressUse is set to this value before Socket.Bind is used. (Inherited from Dart.Emulation.SocketOption)
Public Property | KeepAliveInterval | The time in milliseconds between retransmission of keepalives once the KeepAliveTime has expired.
Public Property | KeepAliveTime | The connection idle time in milliseconds before TCP will begin sending keepalives.
Public Property | NoDelay | Gets or sets a value that disables the use of Nagle's algorithm so that data is sent immediately.
Public Property | OutOfBandInline | Gets or sets a value that indicates whether out-of-band (urgent) data is read as normal in-line data.
Public Property | ReceiveBufferSize | Gets or sets a value that specifies the size of the system receive buffer. (Inherited from Dart.Emulation.SocketOption)
Public Property | ReceiveTimeout | Overridden. Gets or sets a value that specifies the amount of time after which the underlying TCP Socket.Receive call will time out.
Public Property | ReuseAddress | When set to true, allows multiple socket bindings to the same address. Set this value to true to allow multiple sockets to bind to the same local address. (Inherited from Dart.Emulation.SocketOption)
Public Property | SendBufferSize | Gets or sets a value that specifies the size of the system send buffer. (Inherited from Dart.Emulation.SocketOption)
Public Property | SendTimeout | Gets or sets a value that specifies the amount of time after which the underlying Socket Send call will time out. (Inherited from Dart.Emulation.SocketOption)
Top

See Also

Reference

TcpSocketOption Class
Dart.Emulation Namespace


KeepAliveInterval Property

[image]
PowerTCP Emulation for .NET
KeepAliveInterval Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSocketOption Class : KeepAliveInterval Property

Glossary Item Box

The time in milliseconds between retransmission of keepalives once the KeepAliveTime has expired.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property KeepAliveInterval As Integer
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Integer

instance.KeepAliveInterval = value

value = instance.KeepAliveInterval
C#
[DefaultValue()]
public int KeepAliveInterval {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_KeepAliveInterval();
public: __property void set_KeepAliveInterval(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int KeepAliveInterval {
   int get();
   void set (    int value);
}

Remarks

Once KeepAliveTime has expired, keepalives are sent every KeepAliveInterval milliseconds until a response is received, up to the maximum established by TcpMaxDataRetransmissions (OS-level configuration) before the connection is terminated. The default is 1000 (1 sec).

This property is not implemented in MONO.

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


KeepAliveTime Property

[image]
PowerTCP Emulation for .NET
KeepAliveTime Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSocketOption Class : KeepAliveTime Property

Glossary Item Box

The connection idle time in milliseconds before TCP will begin sending keepalives.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property KeepAliveTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Integer

instance.KeepAliveTime = value

value = instance.KeepAliveTime
C#
[DefaultValue()]
public int KeepAliveTime {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_KeepAliveTime();
public: __property void set_KeepAliveTime(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int KeepAliveTime {
   int get();
   void set (    int value);
}

Remarks

Set to 0 to disable keepalives. Defaults to 7,200,000 (2 hours).

This property is not implemented in MONO.

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


NoDelay Property

[image]
PowerTCP Emulation for .NET
NoDelay Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSocketOption Class : NoDelay Property

Glossary Item Box

Gets or sets a value that disables the use of Nagle's algorithm so that data is sent immediately.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property NoDelay As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Boolean

instance.NoDelay = value

value = instance.NoDelay
C#
[DefaultValue()]
public bool NoDelay {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_NoDelay();
public: __property void set_NoDelay(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool NoDelay {
   bool get();
   void set (    bool value);
}

Property Value

False if Nagle's algorithm is used; otherwise true. The default value is false.

Remarks

When small pieces of data (such as single bytes) are send many times consecutively, inefficient packets can be sent with one byte of useful data and 40 bytes of header information. Nagle's algorithm specifies that this type of data should be automatically concatenated and sent in a single packet. When true, Nagle's algorithm is defeated and data is immediately sent in a dedicated packet. When false, Nagle's algorithm is used and consecutive Socket Send calls might send data in a single (more efficient) packet.

Setting this property to true may result in a speed optimization (because packets are sent immediately, without having to wait to see if Send is called again). Setting this property to false results in data being transmitted more efficiently.

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


OutOfBandInline Property

[image]
PowerTCP Emulation for .NET
OutOfBandInline Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSocketOption Class : OutOfBandInline Property

Glossary Item Box

Gets or sets a value that indicates whether out-of-band (urgent) data is read as normal in-line data.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property OutOfBandInline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Boolean

instance.OutOfBandInline = value

value = instance.OutOfBandInline
C#
[DefaultValue()]
public bool OutOfBandInline {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_OutOfBandInline();
public: __property void set_OutOfBandInline(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool OutOfBandInline {
   bool get();
   void set (    bool value);
}

Property Value

True if urgent data is to be read as normal in-line data, otherwise false. The default value is false.

Remarks

When the "urgent" socket flag is set, the packet contains data that should be acted upon before "non-urgent" data. Setting this property to true will cause this urgent data to be read in-line. To minimize interoperability problems, developers are advised not to use out-of-band data unless it is required to interoperate with an existing service.

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


ReceiveTimeout Property

[image]
PowerTCP Emulation for .NET
ReceiveTimeout Property
See Also Send comments on this topic
Dart.Emulation Namespace > TcpSocketOption Class : ReceiveTimeout Property

Glossary Item Box

Gets or sets a value that specifies the amount of time after which the underlying TCP Socket.Receive call will time out.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overrides Property ReceiveTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Integer

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[DefaultValue()]
public override int ReceiveTimeout {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_ReceiveTimeout() override;
public: __property void set_ReceiveTimeout(
   int value
) override;
C++/CLI
[DefaultValue()]
public:
property int ReceiveTimeout {
   int get() override;
   void set (    int value) override;
}

Property Value

The time-out value in milliseconds. The default value is 0, which indicates an infinite time-out period.

Remarks

Values between 1 and 499 will be changed to 500, as 500 is the minimum positive value. A value of 0 or -1 indicates an infinite time-out period.

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


Telnet Class

[image]
PowerTCP Emulation for .NET
Telnet Class
Members Example See Also Send comments on this topic
Dart.Emulation Namespace : Telnet Class

Glossary Item Box

The Telnet component enables use of the Telnet protocol within any .NET application.

Object Model

Telnet ClassOptionCollection ClassOption ClassOptionCollection ClassOption ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Telnet
   Inherits PtyBase
Visual Basic (Usage) Copy Code
Dim instance As Telnet
C#
public class Telnet : PtyBase
Managed Extensions for C++
public __gc class Telnet : public PtyBase
C++/CLI
public ref class Telnet : public PtyBase

Remarks

The Telnet component establishes and manages Telnet-level streams of data. Methods for establishing connections, handling option negotiation, and sending and receiving data greatly simplify Telnet communications for the user, while still providing many options for advanced customization. Secure SSL connections, asynchronous use, and advanced option negotiation are all fully supported.

The Telnet component can optionally be bound to a display for easy user-interactive development.

Using the Telnet Component

The Telnet component's clean interface provides clear, straight-forward use. All methods calls are blocking calls, making programming an intuitive step-by-step process. Functions can be passed to the Start method, to execute on independent threads, without blocking the user interface. Marshaling data from these threads is very convenient using the Marshal method. See the Asynchronous Operation page for more information on this topic.

  • Connecting: To connect to a host, use the Connect method. Once connected, establish a secure connection using AuthenticateAsClient.

  • Default option negotiation: The Telnet component uses a default option negotiation sequence which occurs automatically after login. To add or remove options to negotiate, modify the ClientOptions and ServerOptions collections appropriately. The ClientOptionChanged and ServerOptionChanged events fire when the state of an option changes.

  • Customized option negotiation: Manual option negotiation is also possible. Use the SendOption call to send option commands, and and the CommandReceived event to examine server responses.

  • Sending Data: Once a connection is established, send data using the Write method, which includes overloads for sending data as byte arrays or as strings.

  • Receiving Data: Receive data using the Read method. This method returns a Data object containing data read off the data stream. Data in this object can easily be converted to a string using its ToString method. The Read method includes overloads for reading until a specified delimiter is found. A set of delimiters can also be specified for situations in which one of several responses may be received. Marshal data to the Data event by calling the Marshal method.

  • Sending commands: Use SendCommand to send any non-option control command to the host.

Binding the Telnet Component to a Display

Set the Pty (pseudo terminal) property to bind the Telnet component to a display control derived from TextBoxBase (such as a standard TextBox), and call Connect to establish a connection to the specified host. Once connected, keystrokes will be sent automatically, and data received will appear in the text area.

Example

The following example demonstrates execution of an automated session using the Telnet component.
C# Copy Code
private Telnet telnet1;

private void button1_Click(object sender, EventArgs e)
{
    //Dynamically create an instance of the Telnet component
    //The component can also be dragged onto a form, so that the
    //properties and event handlers can be managed in the designer
    telnet1 = new Telnet();

    //Events should fire on the UI thread
    telnet1.SynchronizingObject = this;

    //Add event handlers
    telnet1.Data += new EventHandler<DataEventArgs>(telnet1_Data);
    telnet1.Error += new EventHandler<ErrorEventArgs>(telnet1_Error);
    telnet1.StateChanged += new EventHandler(telnet1_StateChanged);

    //Start the process on a worker thread
    telnet1.Start(automateSession, null);
}

private void automateSession(object notUsed)
{
    //This function executes on a worker thread, providing multi-threaded, asynchronous operation
    try
    {
        //Connect to the server
        telnet1.Connect("myServer");

        //Login and marshal data to the UI thread
        telnet1.Marshal(telnet1.Login(new Credentials("myUsername", "myPassword", "$")), "", null);

        //Send a list command
        telnet1.Write("ls -la\r");

        //Wait for prompt, marshal data to the UI thread
        telnet1.Marshal(telnet1.ReadToDelimiter("$"), "", null);

        //Send an exit command; server will close the connection
        telnet1.Write("exit\r");

        //Read any remaining data before the shutdown
        telnet1.Marshal(telnet1.ReadToEnd(), "", null);
    }
    catch (Exception ex)
    {
        //Report errors to the UI thread
        telnet1.Marshal(ex);
    }
}

void telnet1_Data(object sender, DataEventArgs e)
{
    //Add data received to the textbox
    textBox1.AppendText(e.Data.ToString());
}

void telnet1_Error(object sender, ErrorEventArgs e)
{
    //Add error messages to the textbox
    textBox1.AppendText(e.GetException().Message);
}

void telnet1_StateChanged(object sender, EventArgs e)
{
    //Change appearance of textbox when connected
    textBox1.BackColor = (telnet1.State == ConnectionState.Closed)
    ? SystemColors.ControlDark
    : SystemColors.ControlLight;
}
Visual Basic Copy Code
Private telnet1 As Telnet

Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Dynamically create an instance of the Telnet component
    'The component can also be dragged onto a form, so that the
    'properties and event handlers can be managed in the designer
    telnet1 = New Telnet()

    'Events should fire on the UI thread
    telnet1.SynchronizingObject = Me

    'Add event handlers
    AddHandler telnet1.Data, AddressOf telnet1_Data
    AddHandler telnet1.Error, AddressOf telnet1_Error
    AddHandler telnet1.StateChanged, AddressOf telnet1_StateChanged

    'Start the process on a worker thread
    telnet1.Start(AddressOf automateSession, Nothing)
End Sub

Private Sub automateSession(ByVal notUsed As Object)
    'This function executes on a worker thread, providing multi-threaded, asynchronous operation
    Try
        'Connect to the server
        telnet1.Connect("myServer")

        'Login and marshal data to the UI thread
        telnet1.Marshal(telnet1.Login(New Credentials("myUsername", "myPassword", "$")), "", Nothing)

        'Send a list command
        telnet1.Write("ls -la" & Constants.vbCr)

        'Wait for prompt, marshal data to the UI thread
        telnet1.Marshal(telnet1.ReadToDelimiter("$"), "", Nothing)

        'Send an exit command; server will close the connection
        telnet1.Write("exit" & Constants.vbCr)

        'Read any remaining data before the shutdown
        telnet1.Marshal(telnet1.ReadToEnd(), "", Nothing)
    Catch ex As Exception
        'Report errors to the UI thread
        telnet1.Marshal(ex)
    End Try
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs)
    'Add data received to the textbox
    textBox1.AppendText(e.Data.ToString())
End Sub

Private Sub telnet1_Error(ByVal sender As Object, ByVal e As ErrorEventArgs)
    'Add error messages to the textbox
    textBox1.AppendText(e.GetException().Message)
End Sub

Private Sub telnet1_StateChanged(ByVal sender As Object, ByVal e As EventArgs)
    'Change appearance of textbox when connected
    textBox1.BackColor = If((telnet1.State = ConnectionState.Closed), SystemColors.ControlDark, SystemColors.ControlLight)
End Sub

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Emulation.ComponentBase
Dart.Emulation.SocketBase
Dart.Emulation.TcpBase
Dart.Emulation.PtyBase
Dart.Emulation.Telnet

See Also

Reference

Telnet Members
Dart.Emulation Namespace


Telnet Class Members

[image]
PowerTCP Emulation for .NET
Telnet Class Members
See Also Fields Properties Methods Events Send comments on this topic
Dart.Emulation Namespace : Telnet Class

Glossary Item Box

The following tables list the members exposed by Telnet.

Public Constructors

 | Name | Description
Public Constructor | Telnet Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultPort | The "well-known" default port 23 for Rsh operations.
Top

Public Properties

 | Name | Description
Public Property | Binary | Gets or sets the state of the Telnet Transmit-Binary option.
Public Property | ClientOptions | Gets a collection of desired client options.
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | Set to true if the Pty property is used and a CR should be converted to a CRLF for sending. (Inherited from Dart.Emulation.PtyBase)
Public Property | Echo | Gets or sets the state of the Telnet Echo option.
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | LocalEcho | Set to true if the Pty property is used and keystrokes should be displayed in the textbox. (Inherited from Dart.Emulation.PtyBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support. (Inherited from Dart.Emulation.PtyBase)
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | ServerOptions | Gets a collection of desired server options.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Public Property | TerminalType | Gets or sets the terminal type used for the Telnet TerminalType option.
Public Property | WindowSize | Gets or sets the window-size used for the Telnet WindowSize option.
Top

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Overloaded. Connects to a Telnet server.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Overridden. Provides access to the underlying Stream.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Login | Logs into a telnet server using properties found in the settings parameter.
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Refresh | Negotiates Telnet options that have been added to the ClientOptions and ServerOptions collections.
Public Method | SendCommand | Sends a Telnet (non-option) command to the server.
Public Method | SendOption | Sends a Telnet option to the server.
Public Method | SendSubOption | Sends a suboption request or response to the server.
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Start | Starts a worker thread on which the specified delegate function executes.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

Public Events

 | Name | Description
Public Event | ClientOptionChanged | Raised when a client Telnet option has changed state (WILL or WONT confirmed).
Public Event | CommandReceived | Raised when a Telnet command is received from the server.
Public Event | Data | Raised when Marshal(Data,String,Object) is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | ServerOptionChanged | Raised when a server Telnet option has changed state (DO or DONT confirmed).
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Telnet Class
Dart.Emulation Namespace


Telnet Constructor

[image]
PowerTCP Emulation for .NET
Telnet Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : Telnet Constructor

Glossary Item Box

Overload List

Overload | Description
Telnet Constructor() | Initializes a new instance of the Telnet component.
Telnet Constructor(IContainer) | Initializes a new instance of the Telnet component.

See Also

Reference

Telnet Class
Telnet Members


Telnet Constructor()

[image]
PowerTCP Emulation for .NET
Telnet Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class > Telnet Constructor : Telnet Constructor()

Glossary Item Box

Initializes a new instance of the Telnet component.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Telnet()
C#
public Telnet()
Managed Extensions for C++
public: Telnet();
C++/CLI
public:
Telnet();

See Also

Reference

Telnet Class
Telnet Members
Overload List


Telnet Constructor(IContainer)

[image]
PowerTCP Emulation for .NET
Telnet Constructor(IContainer)
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class > Telnet Constructor : Telnet Constructor(IContainer)

container

Glossary Item Box

Initializes a new instance of the Telnet component.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Telnet(container)
C#
public Telnet(
   IContainer container
)
Managed Extensions for C++
public: Telnet(
   IContainer* container
)
C++/CLI
public:
Telnet(
   IContainer^ container
)

Parameters

container

See Also

Reference

Telnet Class
Telnet Members
Overload List


Telnet Class Methods

[image]
PowerTCP Emulation for .NET
Telnet Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : Telnet Class

Glossary Item Box

For a list of all members of this type, see Telnet members.

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Overloaded. Connects to a Telnet server.
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Overridden. Provides access to the underlying Stream.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Login | Logs into a telnet server using properties found in the settings parameter.
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Refresh | Negotiates Telnet options that have been added to the ClientOptions and ServerOptions collections.
Public Method | SendCommand | Sends a Telnet (non-option) command to the server.
Public Method | SendOption | Sends a Telnet option to the server.
Public Method | SendSubOption | Sends a suboption request or response to the server.
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Start | Starts a worker thread on which the specified delegate function executes.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

See Also

Reference

Telnet Class
Dart.Emulation Namespace


Connect Method

[image]
PowerTCP Emulation for .NET
Connect Method
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : Connect Method

Glossary Item Box

Connects to a Telnet server.

Overload List

Overload | Description
Connect(String) | Connects to a Telnet server.
Connect | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)

See Also

Reference

Telnet Class
Telnet Members


Connect(String) Method

[image]
PowerTCP Emulation for .NET
Connect(String) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class > Connect Method : Connect(String) Method

hostNameOrAddress
The remote host name or address to connect to.

Glossary Item Box

Connects to a Telnet server.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
)
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress
The remote host name or address to connect to.

Remarks

This method attempts to connect to the remote host at the default port of 23.

Use alternative Connect overloads to connect to a port other than 513.

See Also

Reference

Telnet Class
Telnet Members
Overload List


GetStream Method

[image]
PowerTCP Emulation for .NET
GetStream Method
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : GetStream Method

Glossary Item Box

Provides access to the underlying Stream.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As Stream

value = instance.GetStream()
C#
public override Stream GetStream()
Managed Extensions for C++
public: Stream* GetStream(); override
C++/CLI
public:
Stream^ GetStream(); override

Return Value

The underlying Stream object used by the component.

Remarks

If a connection is not established, operations on the stream will result in null reference exceptions.

See Also

Reference

Telnet Class
Telnet Members


Login(Credentials) Method

[image]
PowerTCP Emulation for .NET
Login(Credentials) Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Telnet Class : Login(Credentials) Method

credentials
Credentials including username, password and command prompt.

Glossary Item Box

Logs into a telnet server using properties found in the settings parameter.

Syntax

Visual Basic (Declaration)
Public Function Login( _
   ByVal credentials As Credentials _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim credentials As Credentials
Dim value As Data

value = instance.Login(credentials)
C#
public Data Login(
   Credentials credentials
)
Managed Extensions for C++
public: Data* Login(
   Credentials* credentials
)
C++/CLI
public:
Data^ Login(
   Credentials^ credentials
)

Parameters

credentials
Credentials including username, password and command prompt.

Return Value

A Data object containing the data received during the login.

Remarks

For an established connection, this function will send Credentials.Username and Credentials.Password after receiving login prompts. It will then read the data sent by the remote host up to the Credentials.CommandPrompt.

The return value contains a record of all data received during this process. A return value with no data typically indicates that the server closed the connection.

This method blocks until the login process completes successfully, the server does not respond with an expected prompt within six seconds, or the server closes the connection.

A DataException will be thrown if the password or login prompt is not provided by the server within the timeout period specified, or if any other exception occurs. Examine the DataException.DataRead property for data read up to the exception, and the InnerException for the exception wrapped by DataException. An exception will NOT be thrown if a timeout occurs waiting for the command prompt. Instead, the method will return and the Data.Delimiter will be null. Note that a successful login with an incorrectly specified command prompt will result in the method blocking for the timeout period before returning with the actual prompt, manifesting in a perceived delay. An incorrect password could result in a similar delay.

Example

The following example demonstrates execution of an automated session using the Telnet component.
C# Copy Code
private Telnet telnet1;

private void button1_Click(object sender, EventArgs e)
{
    //Dynamically create an instance of the Telnet component
    //The component can also be dragged onto a form, so that the
    //properties and event handlers can be managed in the designer
    telnet1 = new Telnet();

    //Events should fire on the UI thread
    telnet1.SynchronizingObject = this;

    //Add event handlers
    telnet1.Data += new EventHandler<DataEventArgs>(telnet1_Data);
    telnet1.Error += new EventHandler<ErrorEventArgs>(telnet1_Error);
    telnet1.StateChanged += new EventHandler(telnet1_StateChanged);

    //Start the process on a worker thread
    telnet1.Start(automateSession, null);
}

private void automateSession(object notUsed)
{
    //This function executes on a worker thread, providing multi-threaded, asynchronous operation
    try
    {
        //Connect to the server
        telnet1.Connect("myServer");

        //Login and marshal data to the UI thread
        telnet1.Marshal(telnet1.Login(new Credentials("myUsername", "myPassword", "$")), "", null);

        //Send a list command
        telnet1.Write("ls -la\r");

        //Wait for prompt, marshal data to the UI thread
        telnet1.Marshal(telnet1.ReadToDelimiter("$"), "", null);

        //Send an exit command; server will close the connection
        telnet1.Write("exit\r");

        //Read any remaining data before the shutdown
        telnet1.Marshal(telnet1.ReadToEnd(), "", null);
    }
    catch (Exception ex)
    {
        //Report errors to the UI thread
        telnet1.Marshal(ex);
    }
}

void telnet1_Data(object sender, DataEventArgs e)
{
    //Add data received to the textbox
    textBox1.AppendText(e.Data.ToString());
}

void telnet1_Error(object sender, ErrorEventArgs e)
{
    //Add error messages to the textbox
    textBox1.AppendText(e.GetException().Message);
}

void telnet1_StateChanged(object sender, EventArgs e)
{
    //Change appearance of textbox when connected
    textBox1.BackColor = (telnet1.State == ConnectionState.Closed)
    ? SystemColors.ControlDark
    : SystemColors.ControlLight;
}
Visual Basic Copy Code
Private telnet1 As Telnet

Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    'Dynamically create an instance of the Telnet component
    'The component can also be dragged onto a form, so that the
    'properties and event handlers can be managed in the designer
    telnet1 = New Telnet()

    'Events should fire on the UI thread
    telnet1.SynchronizingObject = Me

    'Add event handlers
    AddHandler telnet1.Data, AddressOf telnet1_Data
    AddHandler telnet1.Error, AddressOf telnet1_Error
    AddHandler telnet1.StateChanged, AddressOf telnet1_StateChanged

    'Start the process on a worker thread
    telnet1.Start(AddressOf automateSession, Nothing)
End Sub

Private Sub automateSession(ByVal notUsed As Object)
    'This function executes on a worker thread, providing multi-threaded, asynchronous operation
    Try
        'Connect to the server
        telnet1.Connect("myServer")

        'Login and marshal data to the UI thread
        telnet1.Marshal(telnet1.Login(New Credentials("myUsername", "myPassword", "$")), "", Nothing)

        'Send a list command
        telnet1.Write("ls -la" & Constants.vbCr)

        'Wait for prompt, marshal data to the UI thread
        telnet1.Marshal(telnet1.ReadToDelimiter("$"), "", Nothing)

        'Send an exit command; server will close the connection
        telnet1.Write("exit" & Constants.vbCr)

        'Read any remaining data before the shutdown
        telnet1.Marshal(telnet1.ReadToEnd(), "", Nothing)
    Catch ex As Exception
        'Report errors to the UI thread
        telnet1.Marshal(ex)
    End Try
End Sub

Private Sub telnet1_Data(ByVal sender As Object, ByVal e As DataEventArgs)
    'Add data received to the textbox
    textBox1.AppendText(e.Data.ToString())
End Sub

Private Sub telnet1_Error(ByVal sender As Object, ByVal e As ErrorEventArgs)
    'Add error messages to the textbox
    textBox1.AppendText(e.GetException().Message)
End Sub

Private Sub telnet1_StateChanged(ByVal sender As Object, ByVal e As EventArgs)
    'Change appearance of textbox when connected
    textBox1.BackColor = If((telnet1.State = ConnectionState.Closed), SystemColors.ControlDark, SystemColors.ControlLight)
End Sub

See Also

Reference

Telnet Class
Telnet Members


Refresh Method

[image]
PowerTCP Emulation for .NET
Refresh Method
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : Refresh Method

Glossary Item Box

Negotiates Telnet options that have been added to the ClientOptions and ServerOptions collections.

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As Telnet

instance.Refresh()
C#
public void Refresh()
Managed Extensions for C++
public: void Refresh();
C++/CLI
public:
void Refresh();

Remarks

This method performs option negotiation for any non-negotiated option. Requests for all options set to OptionState.RequestOff or OptionState.RequestOn are sent to the server. The Telnet component automatically executes this method when performing option negotiation.

See Also

Reference

Telnet Class
Telnet Members


SendCommand Method

[image]
PowerTCP Emulation for .NET
SendCommand Method
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : SendCommand Method

command
The command to send.

Glossary Item Box

Sends a Telnet (non-option) command to the server.

Syntax

Visual Basic (Declaration)
Public Function SendCommand( _
   ByVal command As Command _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim command As Command
Dim value() As Byte

value = instance.SendCommand(command)
C#
public byte[] SendCommand(
   Command command
)
Managed Extensions for C++
public: byte[]* SendCommand(
   Command command
)
C++/CLI
public:
array<byte>^ SendCommand(
   Command command
)

Parameters

command
The command to send.

Return Value

A byte array containing the bytes sent.

Remarks

Telnet control functions are commands which represent functions that are implemented on most servers. For example, most servers provide an "IP" function that permits the user to interrupt or abort a process.

See Command for a list of control functions.

For manual option negotiation, use SendOption.

See Also

Reference

Telnet Class
Telnet Members


SendOption Method

[image]
PowerTCP Emulation for .NET
SendOption Method
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : SendOption Method

command
The command to send with the option.
code
The option to negotiate.

Glossary Item Box

Sends a Telnet option to the server.

Syntax

Visual Basic (Declaration)
Public Function SendOption( _
   ByVal command As Command, _
   ByVal code As OptionCode _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim command As Command
Dim code As OptionCode
Dim value() As Byte

value = instance.SendOption(command, code)
C#
public byte[] SendOption(
   Command command,
   OptionCode code
)
Managed Extensions for C++
public: byte[]* SendOption(
   Command command,
   OptionCode code
)
C++/CLI
public:
array<byte>^ SendOption(
   Command command,
   OptionCode code
)

Parameters

command
The command to send with the option.
code
The option to negotiate.

Remarks

Option negotiation typically occurs automatically by the Telnet component. Using this method will disable the automatic negotiation. Once disabled, all options must be negotiated manually.

To manually negotiate options:

  1. Clear both ClientOptions and ServerOptions.
  2. Use SendOption from within the CommandReceived event in response to commands from the server.

See Also

Reference

Telnet Class
Telnet Members


SendSubOption Method

[image]
PowerTCP Emulation for .NET
SendSubOption Method
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : SendSubOption Method

code
The option pertaining to the suboption.
subOption
The suboption to negotiate.

Glossary Item Box

Sends a suboption request or response to the server.

Syntax

Visual Basic (Declaration)
Public Function SendSubOption( _
   ByVal code As OptionCode, _
   ByVal subOption() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim code As OptionCode
Dim subOption() As Byte
Dim value() As Byte

value = instance.SendSubOption(code, subOption)
C#
public byte[] SendSubOption(
   OptionCode code,
   byte[] subOption
)
Managed Extensions for C++
public: byte[]* SendSubOption(
   OptionCode code,
   byte[]* subOption
)
C++/CLI
public:
array<byte>^ SendSubOption(
   OptionCode code,
   array<byte>^ subOption
)

Parameters

code
The option pertaining to the suboption.
subOption
The suboption to negotiate.

Return Value

The bytes sent to the remote host.

Remarks

Option megotiation typically occurs automatically by the Telnet component. Suboption data is sent by the Telnet component when a new option (containing the appropriate suboption data) is added to either ClientOptions or ServerOptions. Only use this method if automatic option negotiation is not used.

See Also

Reference

Telnet Class
Telnet Members


Start Method

[image]
PowerTCP Emulation for .NET
Start Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Telnet Class : Start Method

worker
WaitCallback delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Glossary Item Box

Starts a worker thread on which the specified delegate function executes.

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As WaitCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim worker As WaitCallback
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   WaitCallback worker,
   object state
)
Managed Extensions for C++
public: void Start(
   WaitCallback* worker,
   Object* state
)
C++/CLI
public:
void Start(
   WaitCallback^ worker,
   Object^ state
)

Parameters

worker
WaitCallback delegate specifying the function to execute.
state
Information to pass to the worker delegate function; can be null.

Remarks

This method provides an easy means for executing blocking functions on a worker thread. Applications with a UI thread should use this technique to execute processes (like Connect and Read) that can block the UI thread.

The state parameter can be null for cases in which no state information needs to be passed to the worker delegate function.

Unhandled exceptions occurring on the worker thread will be caught and reported in the Error event.

Example

This example demonstrates execution of a looping Read on a worker thread, and marshaling the data to the UI.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
    //Receive data on a separate thread
    myComponent.Start(receiveData, null);
}

private void receiveData(object notUsed)
{
    //Receive data when it is sent by the remote host
    byte[] buffer = new byte[1024];
    while (myComponent.State != ConnectionState.Closed)
        myComponent.Marshal(myComponent.Read(buffer, 0, 1024), "", null);
}

private void myComponent_Data(object sender, DataEventArgs e)
{
    //Whenever data is received, display it
    textDisplay.AppendText(e.Data.ToString());
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    'Receive data on a separate thread
    myComponent.Start(AddressOf receiveData, Nothing)
End Sub

Private Sub receiveData(ByVal notUsed As Object)
    'Receive data when it is sent by the remote host
    Dim buffer() As Byte = New Byte(1023) {}
    Do While myComponent.State <> ConnectionState.Closed
        myComponent.Marshal(myComponent.Read(buffer, 0, 1024), "", Nothing)
    Loop
End Sub

Private Sub myComponent_Data(ByVal sender As Object, ByVal e As DataEventArgs) Handles myComponent.Data
    'Whenever data is received, display it
    textDisplay.AppendText(e.Data.ToString())
End Sub

See Also

Reference

Telnet Class
Telnet Members


Telnet Class Properties

[image]
PowerTCP Emulation for .NET
Telnet Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Telnet Class

Glossary Item Box

For a list of all members of this type, see Telnet members.

Public Properties

 | Name | Description
Public Property | Binary | Gets or sets the state of the Telnet Transmit-Binary option.
Public Property | ClientOptions | Gets a collection of desired client options.
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | Set to true if the Pty property is used and a CR should be converted to a CRLF for sending. (Inherited from Dart.Emulation.PtyBase)
Public Property | Echo | Gets or sets the state of the Telnet Echo option.
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | LocalEcho | Set to true if the Pty property is used and keystrokes should be displayed in the textbox. (Inherited from Dart.Emulation.PtyBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | Pty | Gets or sets a display control to use for automatic pseudo terminal support. (Inherited from Dart.Emulation.PtyBase)
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | ServerOptions | Gets a collection of desired server options.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Public Property | TerminalType | Gets or sets the terminal type used for the Telnet TerminalType option.
Public Property | WindowSize | Gets or sets the window-size used for the Telnet WindowSize option.
Top

See Also

Reference

Telnet Class
Dart.Emulation Namespace


Binary Property

[image]
PowerTCP Emulation for .NET
Binary Property
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : Binary Property

Glossary Item Box

Gets or sets the state of the Telnet Transmit-Binary option.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Binary As OptionState
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionState

instance.Binary = value

value = instance.Binary
C#
[DefaultValue()]
public OptionState Binary {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property OptionState get_Binary();
public: __property void set_Binary(
   OptionState value
);
C++/CLI
[DefaultValue()]
public:
property OptionState Binary {
   OptionState get();
   void set (    OptionState value);
}

Property Value

An OptionState with a default value of Off.

Remarks

Setting this property adds an option to both ClientOptions and ServerOptions.

To determine negotiation success, check both ClientOptions and ServerOptions. If State is OptionState.On for both, negotiation was successful.

The TRANSMIT-BINARY option is used to send data without padding naked CR characters with NULL. When enabled, naked CR bytes (A CR not followed by a LF) are transmitted without adding a NULL after the CR, and are received without stripping the NULL from CR/NULL sequences found.

See Also

Reference

Telnet Class
Telnet Members


ClientOptions Property

[image]
PowerTCP Emulation for .NET
ClientOptions Property
See Also Example Send comments on this topic
Dart.Emulation Namespace > Telnet Class : ClientOptions Property

Glossary Item Box

Gets a collection of desired client options.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientOptions As OptionCollection
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionCollection

value = instance.ClientOptions
C#
public OptionCollection ClientOptions {get;}
Managed Extensions for C++
public: __property OptionCollection* get_ClientOptions();
C++/CLI
public:
property OptionCollection^ ClientOptions {
   OptionCollection^ get();
}

Remarks

The client will send a WILL command for the options within the collection.

Example

The following example demonstrates how to set options for automatic option negotiation.
C# Copy Code
if (telnet1.RemoteEndPoint.Port == 23)
{
    //Standard telnet port, add standard telnet options
    telnet1.ClientOptions.Add(new Option(OptionCode.SuppressGoAheads, null, OptionState.RequestOn));
    telnet1.ClientOptions.Add(new Option(OptionCode.WindowSize,
        new Byte[] { ((Byte)(0)), ((Byte)(80)), ((Byte)(0)), ((Byte)(24)) }, OptionState.RequestOn));
    telnet1.ClientOptions.Add(new Option(OptionCode.TerminalType,
        new System.Byte[] { ((Byte)(0)), ((Byte)(116)), ((Byte)(116)), ((Byte)(121)) }, OptionState.RequestOn));

    telnet1.ServerOptions.Add(new Option(OptionCode.SuppressGoAheads, null, OptionState.RequestOn));
    telnet1.ServerOptions.Add(new Option(OptionCode.Echo, null, OptionState.RequestOn));
    telnet1.ServerOptions.Add(new Option(OptionCode.OutputPageSize, null, OptionState.RequestOn));
}
else
{
    //Non-standard telnet port, do not send telnet options
    telnet1.ClientOptions.Clear();
    telnet1.ServerOptions.Clear();
}
Visual Basic Copy Code
If telnet1.RemoteEndPoint.Port = 23 Then
    'Standard telnet port, add standart telnet options
    telnet1.ClientOptions.Add(New [Option](OptionCode.SuppressGoAheads, Nothing, OptionState.RequestOn))
    telnet1.ClientOptions.Add(New [Option](OptionCode.WindowSize, _
        New System.Byte() { (CByte(0)), (CByte(80)), (CByte(0)), (CByte(24)) }, OptionState.RequestOn))
    telnet1.ClientOptions.Add(New [Option](OptionCode.TerminalType, _
        New System.Byte() { (CByte(0)), (CByte(116)), (CByte(116)), (CByte(121)) }, OptionState.RequestOn))

    telnet1.ServerOptions.Add(New [Option](OptionCode.SuppressGoAheads, Nothing, OptionState.RequestOn))
    telnet1.ServerOptions.Add(New [Option](OptionCode.Echo, Nothing, OptionState.RequestOn))
    telnet1.ServerOptions.Add(New [Option](OptionCode.OutputPageSize, Nothing, OptionState.RequestOn))
Else
    'Non-standard telnet port, do not send telnet options
    telnet1.ClientOptions.Clear()
    telnet1.ServerOptions.Clear()
End If

See Also

Reference

Telnet Class
Telnet Members


Echo Property

[image]
PowerTCP Emulation for .NET
Echo Property
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : Echo Property

Glossary Item Box

Gets or sets the state of the Telnet Echo option.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Echo As OptionState
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionState

instance.Echo = value

value = instance.Echo
C#
[DefaultValue()]
public OptionState Echo {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property OptionState get_Echo();
public: __property void set_Echo(
   OptionState value
);
C++/CLI
[DefaultValue()]
public:
property OptionState Echo {
   OptionState get();
   void set (    OptionState value);
}

Property Value

An OptionState with a default value of RequestOn.

Remarks

When on, the remote host will echo all Telnet data it receives back to the client.

See Also

Reference

Telnet Class
Telnet Members


ServerOptions Property

[image]
PowerTCP Emulation for .NET
ServerOptions Property
See Also Example Send comments on this topic
Dart.Emulation Namespace > Telnet Class : ServerOptions Property

Glossary Item Box

Gets a collection of desired server options.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerOptions As OptionCollection
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionCollection

value = instance.ServerOptions
C#
public OptionCollection ServerOptions {get;}
Managed Extensions for C++
public: __property OptionCollection* get_ServerOptions();
C++/CLI
public:
property OptionCollection^ ServerOptions {
   OptionCollection^ get();
}

Remarks

The client will send a DO command for the options within the collection.

Example

The following example demonstrates how to set options for automatic option negotiation.
C# Copy Code
if (telnet1.RemoteEndPoint.Port == 23)
{
    //Standard telnet port, add standard telnet options
    telnet1.ClientOptions.Add(new Option(OptionCode.SuppressGoAheads, null, OptionState.RequestOn));
    telnet1.ClientOptions.Add(new Option(OptionCode.WindowSize,
        new Byte[] { ((Byte)(0)), ((Byte)(80)), ((Byte)(0)), ((Byte)(24)) }, OptionState.RequestOn));
    telnet1.ClientOptions.Add(new Option(OptionCode.TerminalType,
        new System.Byte[] { ((Byte)(0)), ((Byte)(116)), ((Byte)(116)), ((Byte)(121)) }, OptionState.RequestOn));

    telnet1.ServerOptions.Add(new Option(OptionCode.SuppressGoAheads, null, OptionState.RequestOn));
    telnet1.ServerOptions.Add(new Option(OptionCode.Echo, null, OptionState.RequestOn));
    telnet1.ServerOptions.Add(new Option(OptionCode.OutputPageSize, null, OptionState.RequestOn));
}
else
{
    //Non-standard telnet port, do not send telnet options
    telnet1.ClientOptions.Clear();
    telnet1.ServerOptions.Clear();
}
Visual Basic Copy Code
If telnet1.RemoteEndPoint.Port = 23 Then
    'Standard telnet port, add standart telnet options
    telnet1.ClientOptions.Add(New [Option](OptionCode.SuppressGoAheads, Nothing, OptionState.RequestOn))
    telnet1.ClientOptions.Add(New [Option](OptionCode.WindowSize, _
        New System.Byte() { (CByte(0)), (CByte(80)), (CByte(0)), (CByte(24)) }, OptionState.RequestOn))
    telnet1.ClientOptions.Add(New [Option](OptionCode.TerminalType, _
        New System.Byte() { (CByte(0)), (CByte(116)), (CByte(116)), (CByte(121)) }, OptionState.RequestOn))

    telnet1.ServerOptions.Add(New [Option](OptionCode.SuppressGoAheads, Nothing, OptionState.RequestOn))
    telnet1.ServerOptions.Add(New [Option](OptionCode.Echo, Nothing, OptionState.RequestOn))
    telnet1.ServerOptions.Add(New [Option](OptionCode.OutputPageSize, Nothing, OptionState.RequestOn))
Else
    'Non-standard telnet port, do not send telnet options
    telnet1.ClientOptions.Clear()
    telnet1.ServerOptions.Clear()
End If

See Also

Reference

Telnet Class
Telnet Members


TerminalType Property

[image]
PowerTCP Emulation for .NET
TerminalType Property
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : TerminalType Property

Glossary Item Box

Gets or sets the terminal type used for the Telnet TerminalType option.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TerminalType As String
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As String

instance.TerminalType = value

value = instance.TerminalType
C#
[DefaultValue()]
public string TerminalType {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property string* get_TerminalType();
public: __property void set_TerminalType(
   string* value
);
C++/CLI
[DefaultValue()]
public:
property String^ TerminalType {
   String^ get();
   void set (    String^ value);
}

Property Value

tty

See Also

Reference

Telnet Class
Telnet Members


WindowSize Property

[image]
PowerTCP Emulation for .NET
WindowSize Property
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : WindowSize Property

Glossary Item Box

Gets or sets the window-size used for the Telnet WindowSize option.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property WindowSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As Size

instance.WindowSize = value

value = instance.WindowSize
C#
[DefaultValue()]
public Size WindowSize {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Size get_WindowSize();
public: __property void set_WindowSize(
   Size value
);
C++/CLI
[DefaultValue()]
public:
property Size WindowSize {
   Size get();
   void set (    Size value);
}

Property Value

A Size object with default Width and Height values of 80 and 24.

See Also

Reference

Telnet Class
Telnet Members


Telnet Class Fields

[image]
PowerTCP Emulation for .NET
Telnet Class Fields
See Also Send comments on this topic
Dart.Emulation Namespace : Telnet Class

Glossary Item Box

For a list of all members of this type, see Telnet members.

Public Fields

 | Name | Description
Public Field | DefaultPort | The "well-known" default port 23 for Rsh operations.
Top

See Also

Reference

Telnet Class
Dart.Emulation Namespace


DefaultPort Field

[image]
PowerTCP Emulation for .NET
DefaultPort Field
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : DefaultPort Field

Glossary Item Box

The "well-known" default port 23 for Rsh operations.

Syntax

Visual Basic (Declaration)
Public Const DefaultPort As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = Telnet.DefaultPort
C#
public const int DefaultPort
Managed Extensions for C++
public: const int DefaultPort
C++/CLI
public:
const int DefaultPort

See Also

Reference

Telnet Class
Telnet Members


Telnet Class Events

[image]
PowerTCP Emulation for .NET
Telnet Class Events
See Also Send comments on this topic
Dart.Emulation Namespace : Telnet Class

Glossary Item Box

For a list of all members of this type, see Telnet members.

Public Events

 | Name | Description
Public Event | ClientOptionChanged | Raised when a client Telnet option has changed state (WILL or WONT confirmed).
Public Event | CommandReceived | Raised when a Telnet command is received from the server.
Public Event | Data | Raised when Marshal(Data,String,Object) is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | ServerOptionChanged | Raised when a server Telnet option has changed state (DO or DONT confirmed).
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Telnet Class
Dart.Emulation Namespace


ClientOptionChanged Event

[image]
PowerTCP Emulation for .NET
ClientOptionChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : ClientOptionChanged Event

Glossary Item Box

Raised when a client Telnet option has changed state (WILL or WONT confirmed).

Syntax

Visual Basic (Declaration)
Public Event ClientOptionChanged As EventHandler(Of OptionEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim handler As EventHandler(Of OptionEventArgs)

AddHandler instance.ClientOptionChanged, handler
C#
public event EventHandler<OptionEventArgs> ClientOptionChanged
Managed Extensions for C++
public: __event EventHandler<OptionEventArgs*>* ClientOptionChanged
C++/CLI
public:
event EventHandler<OptionEventArgs^>^ ClientOptionChanged

Event Data

The event handler receives an argument of type OptionEventArgs containing data related to this event. The following OptionEventArgs properties provide information specific to this event.

Property | Description
Option | The updated option causing the event.

See Also

Reference

Telnet Class
Telnet Members


CommandReceived Event

[image]
PowerTCP Emulation for .NET
CommandReceived Event
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : CommandReceived Event

Glossary Item Box

Raised when a Telnet command is received from the server.

Syntax

Visual Basic (Declaration)
Public Event CommandReceived As EventHandler(Of CommandEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim handler As EventHandler(Of CommandEventArgs)

AddHandler instance.CommandReceived, handler
C#
public event EventHandler<CommandEventArgs> CommandReceived
Managed Extensions for C++
public: __event EventHandler<CommandEventArgs*>* CommandReceived
C++/CLI
public:
event EventHandler<CommandEventArgs^>^ CommandReceived

Event Data

The event handler receives an argument of type CommandEventArgs containing data related to this event. The following CommandEventArgs properties provide information specific to this event.

Property | Description
Command | The command sent by the remote host.
OptionCode | The option pertaining to the received command.
SubOption | Suboption pertaining to the received command.

Remarks

A CommandEventArgs object containing information required to handle the command is provided to the event handler. For example, CommandEventArgs.Command contains the Command sent from the server.

If a reply is sent to the server using SendOption from within the event handler, it is assumed option negotiation will be handled by the developer and automatic option negotiation is turned off.

This event is not marshaled to the UI thread, even if the SynchronizingObject is set.

See Also

Reference

Telnet Class
Telnet Members


ServerOptionChanged Event

[image]
PowerTCP Emulation for .NET
ServerOptionChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : ServerOptionChanged Event

Glossary Item Box

Raised when a server Telnet option has changed state (DO or DONT confirmed).

Syntax

Visual Basic (Declaration)
Public Event ServerOptionChanged As EventHandler(Of OptionEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim handler As EventHandler(Of OptionEventArgs)

AddHandler instance.ServerOptionChanged, handler
C#
public event EventHandler<OptionEventArgs> ServerOptionChanged
Managed Extensions for C++
public: __event EventHandler<OptionEventArgs*>* ServerOptionChanged
C++/CLI
public:
event EventHandler<OptionEventArgs^>^ ServerOptionChanged

Event Data

The event handler receives an argument of type OptionEventArgs containing data related to this event. The following OptionEventArgs properties provide information specific to this event.

Property | Description
Option | The updated option causing the event.

See Also

Reference

Telnet Class
Telnet Members


UserStateEventArgs Class

[image]
PowerTCP Emulation for .NET
UserStateEventArgs Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : UserStateEventArgs Class

Glossary Item Box

Provides data for ComponentBase.UserState. Base class for EventArgs that have Message and UserState properties.

Object Model

UserStateEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class UserStateEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
C#
public class UserStateEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class UserStateEventArgs : public System.EventArgs
C++/CLI
public ref class UserStateEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Emulation.UserStateEventArgs
Dart.Emulation.DataEventArgs

See Also

Reference

UserStateEventArgs Members
Dart.Emulation Namespace


UserStateEventArgs Class Members

[image]
PowerTCP Emulation for .NET
UserStateEventArgs Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : UserStateEventArgs Class

Glossary Item Box

The following tables list the members exposed by UserStateEventArgs.

Public Properties

 | Name | Description
Public Property | Message | Returns the message argument provided by the Marshal method.
Public Property | UserState | Returns the user state argument provided by the Marshal method.
Top

See Also

Reference

UserStateEventArgs Class
Dart.Emulation Namespace


UserStateEventArgs Class Properties

[image]
PowerTCP Emulation for .NET
UserStateEventArgs Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : UserStateEventArgs Class

Glossary Item Box

For a list of all members of this type, see UserStateEventArgs members.

Public Properties

 | Name | Description
Public Property | Message | Returns the message argument provided by the Marshal method.
Public Property | UserState | Returns the user state argument provided by the Marshal method.
Top

See Also

Reference

UserStateEventArgs Class
Dart.Emulation Namespace


Message Property

[image]
PowerTCP Emulation for .NET
Message Property
See Also Send comments on this topic
Dart.Emulation Namespace > UserStateEventArgs Class : Message Property

Glossary Item Box

Returns the message argument provided by the Marshal method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
Dim value As String

value = instance.Message
C#
public string Message {get;}
Managed Extensions for C++
public: __property string* get_Message();
C++/CLI
public:
property String^ Message {
   String^ get();
}

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members


UserState Property

[image]
PowerTCP Emulation for .NET
UserState Property
See Also Send comments on this topic
Dart.Emulation Namespace > UserStateEventArgs Class : UserState Property

Glossary Item Box

Returns the user state argument provided by the Marshal method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserState As Object
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
Dim value As Object

value = instance.UserState
C#
public object UserState {get;}
Managed Extensions for C++
public: __property Object* get_UserState();
C++/CLI
public:
property Object^ UserState {
   Object^ get();
}

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members


Vt Class

[image]
PowerTCP Emulation for .NET
Vt Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : Vt Class

Glossary Item Box

Represents a terminal emulator used to display VT formatted data.

Object Model

Vt ClassAnsiColor Class

Syntax

Visual Basic (Declaration)
Public Class Vt
   Inherits System.Windows.Forms.ScrollableControl
Visual Basic (Usage) Copy Code
Dim instance As Vt
C#
public class Vt : System.Windows.Forms.ScrollableControl
Managed Extensions for C++
public __gc class Vt : public System.Windows.Forms.ScrollableControl
C++/CLI
public ref class Vt : public System.Windows.Forms.ScrollableControl

Remarks

Use the Vt control to process data received from a host application and targeted for a VT terminal. By streaming this data into a Vt control, you can either:

  • Display it to the user (like most emulation products).
  • Screen scrape it and format the text into a custom report of your own design.

If you do not first process the data with a Vt control, you are left with a stream of data containing numerous escape codes. The Vt control provides terminal emulation as defined by Digital Equipment Corporation for their VT data terminals. It differs from other controls like TCP and Telnet since it is used for data display and formatting, not communications. VT52, VT100, VT220, and VT320 emulation is supported. Each emulation contains formatting rules (escape codes) for interpreting incoming data. For example, one sequence may dictate that the display screen be filled with spaces, while another directs the cursor to a specified location. DEC developed the VT escape codes for their VT terminals, which contained a screen, keyboard, printer port, and an RS-232 connection for connecting to the host. By performing this same functionality in software using high-speed LAN connectivity, the Vt control provides a faster display screen, flexible keyboard mapping, and printing to the Windows default printer; a big improvement over previous hardware devices.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
Dart.Emulation.Vt

See Also

Reference

Vt Members
Dart.Emulation Namespace


Vt Class Members

[image]
PowerTCP Emulation for .NET
Vt Class Members
See Also Fields Properties Methods Events Send comments on this topic
Dart.Emulation Namespace : Vt Class

Glossary Item Box

The following tables list the members exposed by Vt.

Public Constructors

 | Name | Description
Public Constructor | Vt Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Selection | Gets a Selection instance that is used to control the display of selected cells as well as getting the text and attributes of those cells.
Top

Public Properties

 | Name | Description
Public Property | AcceptTabs | Gets or sets whether to retain focus when the tab key is used.
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AnsiColor | Provides fine control of display colors. Includes eight "normal" and eight "bold" (aka "bright" or "light") colors.
Public Property | Answer | Gets or sets a string expression to be sent by the control whenever an ENQ is received.
Public Property | AutoRepeat | Gets or sets a value that determines whether depressed keys generate more than one character.
Public Property | AutoScroll | Overridden. Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin.
Public Property | AutoScrollMinSize | Gets or sets the size of the AutoScrollMinSize property.
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollRowPosition | Sets or gets the vertical scrolling position using a row index.
Public Property | AutoWrap | Gets or sets a value that indicates whether display text stops at the last column or wraps to the next line when a line contains more data than can fit on one row.
Public Property | BackColor | Overridden. Gets or sets the background color for the control.
Public Property | BackColorErase | Gets or sets the value that determines the background color when cells are erased, deleted, or inserted.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control.
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration.
Public Property | Bell | Gets or sets a value that determines whether an audio bell is enabled.
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | BlinkIntensity | Gets or sets the "brightness" of blinking text.
Public Property | BoldColor | Gets or sets the color of bold/bright text.
Public Property | BoldNegativeColor | Gets or sets the color of bold/bright text when fore/back is inverted.
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | BufferRows | Gets the number of rows currently stored in the scrollback buffer.
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | CellSize | Gets or sets the size of a cell.
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | Columns | Gets or sets the number of columns used by the Vt window screen.
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Overridden. Gets or sets the mouse cursor used.
Public Property | CursorColor | Gets or sets the color used for the text cursor.
Public Property | CursorKeys | Gets or sets a value that determines whether the cursor keys send ANSI cursor control sequences (up, down, left, right) or application control sequences.
Public Property | CursorPosition | Gets or sets the current text cursor position on the Vt contol.
Public Property | CursorStyle | Gets or sets a value which indicates the cursor style.
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Encoding | Gets or sets a value which indicates the encoding to use when sending or receiving multibyte data.
Public Property | EnhancedScrollback | Gets or sets a value that indicates if the VT Control is using enhanced scrollback buffer capturing.
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | Overridden. Gets or sets the font used in the display of the control.
Public Property | ForeColor | Overridden. Gets or sets the foreground color for the control.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | Inverse | Gets or sets a value that determines whether the foreground and background colors are switched.
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | KeyPad | Gets or sets a value that determines whether the keypad sends ASCII characters or escape sequences.
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | LocalEcho | Gets or sets a value which controls whether or not key presses are displayed on the Vt window.
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls.
Public Property | MaxBufferRows | Gets or sets the maximum number of rows to store in the scrollback buffer.
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | NationalCharSet | Gets or sets the National Replacement Character Set for use in VT220 7-bit or VT320 7-bit emulation modes to display special characters that normally require 8-bit emulation mode.
Public Property | NationalCharSetMode | Indicates whether the National Replacement Character Set specified by the NationalCharSet property or the standard ASCII character set will be used when rendering text.
Public Property | NewLine | Gets or sets the end-of-line character sequence to use.
Public Property | NormalIntensity | Gets or sets the "brightness" of normal text.
Public Property | Padding | Gets or sets a Padding object which determines the amount of "buffer" space around the Vt text.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | Print | Gets or sets a PrintType specifying how printing should occur.
Public Property | Printer | Gets or sets a value that indicates name of the printer to be used for printing operations.
Public Property | PrintPassThrough | Gets or sets whether to bypass printer drivers and write directly to printer when in Controller mode.
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | Rows | Gets or sets the number of rows used by the Vt window screen.
Public Property | ScrollType | Gets or sets a value that determines whether to use jump scrolling or smooth scrolling in the display screen.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | StatusLine | Gets or sets a string that populates a reverse-video status bar at the bottom of the screen display.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | Tabs | Gets or sets a list of comma-delimited tab positions.
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | TerminalType | Gets or sets the terminal type to emulate.
Public Property | TextRenderingHint | Gets or sets the TextRenderingHint that the VT component will use to render glyphs.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Clears the scrollback buffer and all rows in the display screen.
Public Method | ClientToCells | Given a Rectangle of the control, find all the cells contained within.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
static (Shared in Visual Basic) | MapVtKey | Returns the relevant escape sequence or character for the specified vtKey and terminalType.
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PrintCursorLine | Sends a copy of the line the cursor is currently on to the printer.
Public Method | PrintScreen | Sends a copy of the display screen to the printer.
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrapeCells | Retrieves information about the cells in the specified range.
Public Method | ScrapeHtml | Returns an HTML representation of the VT data.
Public Method | ScrapeText | Retrieves text (minus escape characters) from the Vt display.
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetCapture | Save subsequently written data to the provided stream.
Public Method | SetStream | Overloaded. Specifies the stream to be used by the Vt control in auto send/receive mode.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Write | Overloaded. Displays data contained within a byte array in the Vt window and interprets all escape sequences.
Top

Public Events

 | Name | Description
Public Event | AutoRepeatChanged | Raised when the host sends an instruction which changes the value of the AutoRepeat property.
Public Event | AutoWrapChanged | Raised when the host sends an instruction which changes the value of the AutoWrap property.
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CursorKeysChanged | Raised when the host sends an instruction which changes the value of the CursorKeys property.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Error | Raised when there is an exception while reading from, or writing to, the Stream passed to SetStream(Stream).
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | InverseChanged | Raised when the host sends an instruction which changes the value of the Inverse property.
Public Event | KeyDown | Raised when the user presses a key.
Public Event | KeyPadChanged | Raised when the host sends an instruction which changes the value of the KeyPad property.
Public Event | KeyPress | Raised when the user presses a key.
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Line | Raised when the cursor in the VT changes rows as the result of a new line.
Public Event | LocalEchoChanged | Raised when the host sends an instruction which changes the value of the LocalEcho property.
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Log | Raised when data is read or written.
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | NationalCharSetModeChanged | Raised when the host sends an instruction which changes the value of the NationalCharSetMode property.
Public Event | NewLineChanged | Raised when the host sends an instruction which changes the value of the NewLine property.
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | PrintChanged | Raised when the host sends an instruction which changes the value of the Print property.
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ScreenSizeChanged | Raised when the host sends an instruction which changes the value of the Columns property.
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | ScrollTypeChanged | Raised when the host sends an instruction which changes the value of the ScrollType property.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabsChanged | Raised when the host sends an instruction which changes the value of the Tabs property.
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TerminalTypeChanged | Raised when the host sends an instruction which changes the value of the TerminalType property.
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

Vt Class
Dart.Emulation Namespace


Vt Constructor

[image]
PowerTCP Emulation for .NET
Vt Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Vt Constructor

Glossary Item Box

Overload List

Overload | Description
Vt Constructor(IContainer) | Initializes a new instance of Vt.
Vt Constructor() | Initializes a new instance of Vt.

See Also

Reference

Vt Class
Vt Members


Vt Constructor(IContainer)

[image]
PowerTCP Emulation for .NET
Vt Constructor(IContainer)
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class > Vt Constructor : Vt Constructor(IContainer)

container
The IContainer which contains the object.

Glossary Item Box

Initializes a new instance of Vt.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Vt(container)
C#
public Vt(
   IContainer container
)
Managed Extensions for C++
public: Vt(
   IContainer* container
)
C++/CLI
public:
Vt(
   IContainer^ container
)

Parameters

container
The IContainer which contains the object.

See Also

Reference

Vt Class
Vt Members
Overload List


Vt Constructor()

[image]
PowerTCP Emulation for .NET
Vt Constructor()
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class > Vt Constructor : Vt Constructor()

Glossary Item Box

Initializes a new instance of Vt.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Vt()
C#
public Vt()
Managed Extensions for C++
public: Vt();
C++/CLI
public:
Vt();

See Also

Reference

Vt Class
Vt Members
Overload List


Vt Class Methods

[image]
PowerTCP Emulation for .NET
Vt Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : Vt Class

Glossary Item Box

For a list of all members of this type, see Vt members.

Public Methods

 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Clear | Clears the scrollback buffer and all rows in the display screen.
Public Method | ClientToCells | Given a Rectangle of the control, find all the cells contained within.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
static (Shared in Visual Basic) | MapVtKey | Returns the relevant escape sequence or character for the specified vtKey and terminalType.
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PrintCursorLine | Sends a copy of the line the cursor is currently on to the printer.
Public Method | PrintScreen | Sends a copy of the display screen to the printer.
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrapeCells | Retrieves information about the cells in the specified range.
Public Method | ScrapeHtml | Returns an HTML representation of the VT data.
Public Method | ScrapeText | Retrieves text (minus escape characters) from the Vt display.
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetCapture | Save subsequently written data to the provided stream.
Public Method | SetStream | Overloaded. Specifies the stream to be used by the Vt control in auto send/receive mode.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Write | Overloaded. Displays data contained within a byte array in the Vt window and interprets all escape sequences.
Top

See Also

Reference

Vt Class
Dart.Emulation Namespace


Clear Method

[image]
PowerTCP Emulation for .NET
Clear Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Clear Method

Glossary Item Box

Clears the scrollback buffer and all rows in the display screen.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As Vt

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Remarks

The scrollback buffer and the display screen is filled with space characters.

See Also

Reference

Vt Class
Vt Members


ClientToCells Method

[image]
PowerTCP Emulation for .NET
ClientToCells Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : ClientToCells Method

client
A Rectangle in client coordinates.

Glossary Item Box

Given a Rectangle of the control, find all the cells contained within.

Syntax

Visual Basic (Declaration)
Public Function ClientToCells( _
   ByVal client As Rectangle _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim client As Rectangle
Dim value As Rectangle

value = instance.ClientToCells(client)
C#
public Rectangle ClientToCells(
   Rectangle client
)
Managed Extensions for C++
public: Rectangle ClientToCells(
   Rectangle client
)
C++/CLI
public:
Rectangle ClientToCells(
   Rectangle client
)

Parameters

client
A Rectangle in client coordinates.

Return Value

A Rectangle in cell coordinates. Row 0 is the first row in the scrollback buffer, or the first row in the screen if there is no scrollback buffer.

Remarks

The Rectangle properties Left, Top, Right, Bottom are used as "inclusive." This makes Width 0 when Left is equal to Right.

See Also

Reference

Vt Class
Vt Members


MapVtKey Method

[image]
PowerTCP Emulation for .NET
MapVtKey Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : MapVtKey Method

vtKey
VtKey to return the escape sequence or character for.
terminalType
TerminalType to return the escape sequence for.
cursorKeysMode
Used for VtKey.Up Down Left and Right. Ignored for all other VtKeys.

Glossary Item Box

Returns the relevant escape sequence or character for the specified vtKey and terminalType.

Syntax

Visual Basic (Declaration)
Public Shared Function MapVtKey( _
   ByVal vtKey As VtKey, _
   ByVal terminalType As TerminalType, _
   ByVal cursorKeysMode As CursorKeys _
) As Byte()
Visual Basic (Usage) Copy Code
Dim vtKey As VtKey
Dim terminalType As TerminalType
Dim cursorKeysMode As CursorKeys
Dim value() As Byte

value = Vt.MapVtKey(vtKey, terminalType, cursorKeysMode)
C#
public static byte[] MapVtKey(
   VtKey vtKey,
   TerminalType terminalType,
   CursorKeys cursorKeysMode
)
Managed Extensions for C++
public: static byte[]* MapVtKey(
   VtKey vtKey,
   TerminalType terminalType,
   CursorKeys cursorKeysMode
)
C++/CLI
public:
static array<byte>^ MapVtKey(
   VtKey vtKey,
   TerminalType terminalType,
   CursorKeys cursorKeysMode
)

Parameters

vtKey
VtKey to return the escape sequence or character for.
terminalType
TerminalType to return the escape sequence for.
cursorKeysMode
Used for VtKey.Up Down Left and Right. Ignored for all other VtKeys.

Return Value

An escape sequence or character that represents the vtKey under the terminalType.

Remarks

The value of Vt.TerminalType is typically used for terminalType, and the value of Vt.CursorKeys is typically used for cursorKeysMode.

Returns null if the vtKey is not available for the specified terminalType. See the 'Emulation Overview' top-level topic for more information.

See Also

Reference

Vt Class
Vt Members


PrintCursorLine Method

[image]
PowerTCP Emulation for .NET
PrintCursorLine Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : PrintCursorLine Method

Glossary Item Box

Sends a copy of the line the cursor is currently on to the printer.

Syntax

Visual Basic (Declaration)
Public Sub PrintCursorLine()
Visual Basic (Usage) Copy Code
Dim instance As Vt

instance.PrintCursorLine()
C#
public void PrintCursorLine()
Managed Extensions for C++
public: void PrintCursorLine();
C++/CLI
public:
void PrintCursorLine();

Remarks

See the Printer property for information on selecting the output printer.

The print font will be the closest available match to the display font.

Unicode character printing is fully supported.

See Also

Reference

Vt Class
Vt Members


PrintScreen Method

[image]
PowerTCP Emulation for .NET
PrintScreen Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Vt Class : PrintScreen Method

Glossary Item Box

Sends a copy of the display screen to the printer.

Syntax

Visual Basic (Declaration)
Public Sub PrintScreen()
Visual Basic (Usage) Copy Code
Dim instance As Vt

instance.PrintScreen()
C#
public void PrintScreen()
Managed Extensions for C++
public: void PrintScreen();
C++/CLI
public:
void PrintScreen();

Remarks

See the Printer property for information on selecting the output printer.

The print font will be the closest available match to the display font.

Unicode character printing is fully supported.

Example

The following example demonstrates how to print the display.
C# Copy Code
private string printScreen(bool useSelectedText)
{
    //Select display window to print and return
    vt1.Selection.Start = new Point(vt1.BufferRows, 0);
    vt1.Selection.End = new Point(vt1.BufferRows + vt1.Rows, vt1.Columns);

    //No difference in this case (when the entire display is selected)
    if (useSelectedText)
        vt1.Selection.Print();
    else
        vt1.PrintScreen();

    return vt1.Selection.Text;
}
Visual Basic Copy Code
Private Function printScreen(ByVal useSelectedText As Boolean) As String
    'Select display window to print and return
    vt1.Selection.Start = New Point(vt1.BufferRows, 0)
    vt1.Selection.End = New Point(vt1.BufferRows + vt1.Rows, vt1.Columns)

    'No difference in this case (when the entire display is selected)
    If useSelectedText Then
        vt1.Selection.Print()
    Else
        vt1.PrintScreen()
    End If

    Return vt1.Selection.Text
End Function

See Also

Reference

Vt Class
Vt Members


ScrapeCells Method

[image]
PowerTCP Emulation for .NET
ScrapeCells Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Vt Class : ScrapeCells Method

start
Column/row of first cell, 0-relative, inclusive.
end
Column/row of last cell, 0-relative, inclusive.
mode
The SelectionMode to use.

Glossary Item Box

Retrieves information about the cells in the specified range.

Syntax

Visual Basic (Declaration)
Public Function ScrapeCells( _
   ByVal start As Point, _
   ByVal end As Point, _
   ByVal mode As SelectionMode _
) As Cell()
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim start As Point
Dim end As Point
Dim mode As SelectionMode
Dim value() As Cell

value = instance.ScrapeCells(start, end, mode)
C#
public Cell[] ScrapeCells(
   Point start,
   Point end,
   SelectionMode mode
)
Managed Extensions for C++
public: Cell[]* ScrapeCells(
   Point start,
   Point end,
   SelectionMode mode
)
C++/CLI
public:
array<Cell>^ ScrapeCells(
   Point start,
   Point end,
   SelectionMode mode
)

Parameters

start
Column/row of first cell, 0-relative, inclusive.
end
Column/row of last cell, 0-relative, inclusive.
mode
The SelectionMode to use.

Return Value

An array of Cell objects, describing each cell in the specified range.

Remarks

Use this method to retrieve an array of Cell objects. Use the Cell object to discover information about the cell, such as its character, formatting, etc. If no cells are selected, this method returns an array of length 0.

Note that the row values are relative to the start of the scrollback buffer. Two cells are included at the end of each row containing a \r (13) and \l (10), respectively.

Example

The following example demonstrates how to get information about a cell in the display.
C# Copy Code
private string getCellInfo(Point start, Point end, Dart.Emulation.SelectionMode mode)
{
    //Scrape the cell.  The useOffset param specifies which overload to use
    Cell[] cells = vt1.ScrapeCells(start, end, mode);

    //Display info about the cell
    string info = "Character: " + cells[0].Character.ToString() + "\r\n";
    info += "Raw Character: " + cells[0].RawCharacter.ToString() + "\r\n";
    info += "Background color: " + cells[0].BackColor.ToString() + "\r\n";
    info += "Foreground color: " + cells[0].ForeColor.ToString() + "\r\n";
    info += "Styles: " + cells[0].Styles.ToString();
    return info;
}
Visual Basic Copy Code
Private Function getCellInfo(ByVal start As Point, ByVal [end] As Point, ByVal mode As Dart.Emulation.SelectionMode) As String
    'Scrape the cell.  The useOffset param specifies which overload to use
    Dim cells() As Cell = vt1.ScrapeCells(start, [end], mode)

    'Display info about the cell
    Dim info As String = "Character: " & cells(0).Character.ToString() & Constants.vbCrLf
    info &= "Raw Character: " & cells(0).RawCharacter.ToString() & Constants.vbCrLf
    info &= "Background color: " & cells(0).BackColor.ToString() & Constants.vbCrLf
    info &= "Foreground color: " & cells(0).ForeColor.ToString() & Constants.vbCrLf
    info &= "Styles: " & cells(0).Styles.ToString()
    Return info
End Function

See Also

Reference

Vt Class
Vt Members


ScrapeHtml Method

[image]
PowerTCP Emulation for .NET
ScrapeHtml Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : ScrapeHtml Method

start
Column/row of first cell, 0-relative, inclusive.
end
Column/row of last cell, 0-relative, inclusive.
mode
The SelectionMode to use.

Glossary Item Box

Returns an HTML representation of the VT data.

Syntax

Visual Basic (Declaration)
Public Function ScrapeHtml( _
   ByVal start As Point, _
   ByVal end As Point, _
   ByVal mode As SelectionMode _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim start As Point
Dim end As Point
Dim mode As SelectionMode
Dim value As String

value = instance.ScrapeHtml(start, end, mode)
C#
public string ScrapeHtml(
   Point start,
   Point end,
   SelectionMode mode
)
Managed Extensions for C++
public: string* ScrapeHtml(
   Point start,
   Point end,
   SelectionMode mode
)
C++/CLI
public:
String^ ScrapeHtml(
   Point start,
   Point end,
   SelectionMode mode
)

Parameters

start
Column/row of first cell, 0-relative, inclusive.
end
Column/row of last cell, 0-relative, inclusive.
mode
The SelectionMode to use.

Return Value

This method attempts to convert the VT data into an HTML representation. This is achieved by converting VT escape sequences into HTML tags. For example, if the Vt control detects that a character is bolded using VT escape sequences, these sequences are removed and replaced with the HTML <B> tag.

Remarks

An empty string is returned if no cells are selected.

See Also

Reference

Vt Class
Vt Members


ScrapeText Method

[image]
PowerTCP Emulation for .NET
ScrapeText Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : ScrapeText Method

start
Column/row of first cell, 0-relative, inclusive.
end
Column/row of last cell, 0-relative, inclusive.
mode
The SelectionMode to use.

Glossary Item Box

Retrieves text (minus escape characters) from the Vt display.

Syntax

Visual Basic (Declaration)
Public Function ScrapeText( _
   ByVal start As Point, _
   ByVal end As Point, _
   ByVal mode As SelectionMode _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim start As Point
Dim end As Point
Dim mode As SelectionMode
Dim value As String

value = instance.ScrapeText(start, end, mode)
C#
public string ScrapeText(
   Point start,
   Point end,
   SelectionMode mode
)
Managed Extensions for C++
public: string* ScrapeText(
   Point start,
   Point end,
   SelectionMode mode
)
C++/CLI
public:
String^ ScrapeText(
   Point start,
   Point end,
   SelectionMode mode
)

Parameters

start
Column/row of first cell, 0-relative, inclusive.
end
Column/row of last cell, 0-relative, inclusive.
mode
The SelectionMode to use.

Return Value

A string representation of the scraped characters.

Remarks

This method retrieves all of the text between the specifed Points, removing all escape characters. An empty string is returned if no cells are selected.

Note that the row values are relative to the start of the scrollback buffer. A CrLf pair separates each row.

See Also

Reference

Vt Class
Vt Members


SetCapture Method

[image]
PowerTCP Emulation for .NET
SetCapture Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : SetCapture Method

destinationStream
The destination stream for the captured data.

Glossary Item Box

Save subsequently written data to the provided stream.

Syntax

Visual Basic (Declaration)
Public Sub SetCapture( _
   ByVal destinationStream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim destinationStream As Stream

instance.SetCapture(destinationStream)
C#
public void SetCapture(
   Stream destinationStream
)
Managed Extensions for C++
public: void SetCapture(
   Stream* destinationStream
)
C++/CLI
public:
void SetCapture(
   Stream^ destinationStream
)

Parameters

destinationStream
The destination stream for the captured data.

Remarks

This method can be used to easily create a log of data written to the Vt window. This is especially useful when using SetStream(Stream).

See Also

Reference

Vt Class
Vt Members


SetStream Method

[image]
PowerTCP Emulation for .NET
SetStream Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : SetStream Method

Glossary Item Box

Specifies the stream to be used by the Vt control in auto send/receive mode.

Overload List

Overload | Description
SetStream(Stream,Int32,ThreadPriority) | Specifies the stream to be used by the Vt control in auto send/receive mode.
SetStream(Stream) | Specifies the stream to be used by the Vt control in auto send/receive mode.

See Also

Reference

Vt Class
Vt Members


SetStream(Stream,Int32,ThreadPriority) Method

[image]
PowerTCP Emulation for .NET
SetStream(Stream,Int32,ThreadPriority) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class > SetStream Method : SetStream(Stream,Int32,ThreadPriority) Method

stream
The System.IO.Stream to be used.
bufferSize
The buffer size to use when reading from the stream.
threadPriority
The priority of the thread on which data is read from the stream.

Glossary Item Box

Specifies the stream to be used by the Vt control in auto send/receive mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetStream( _
   ByVal stream As Stream, _
   ByVal bufferSize As Integer, _
   ByVal threadPriority As ThreadPriority _
)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim stream As Stream
Dim bufferSize As Integer
Dim threadPriority As ThreadPriority

instance.SetStream(stream, bufferSize, threadPriority)
C#
public void SetStream(
   Stream stream,
   int bufferSize,
   ThreadPriority threadPriority
)
Managed Extensions for C++
public: void SetStream(
   Stream* stream,
   int bufferSize,
   ThreadPriority threadPriority
)
C++/CLI
public:
void SetStream(
   Stream^ stream,
   int bufferSize,
   ThreadPriority threadPriority
)

Parameters

stream
The System.IO.Stream to be used.
bufferSize
The buffer size to use when reading from the stream.
threadPriority
The priority of the thread on which data is read from the stream.

Remarks

Although the Vt control can work with data from any source (file, memory, etc.) its most common usage is displaying data received over an Internet connection. This method provides automatic reading/writing from/to any System.IO.Stream.

A connection must be established with the remote host prior to calling this method. Once called, any data received is automatically displayed in the Vt window. Any key presses on the Vt window are automatically sent over the established connection.

Typical use would be to use Telnet.GetStream or Rlogin.GetStream with this method.

Note that when SetStream is called, a previously passed in stream will be set to null.

See Also

Reference

Vt Class
Vt Members
Overload List


SetStream(Stream) Method

[image]
PowerTCP Emulation for .NET
SetStream(Stream) Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class > SetStream Method : SetStream(Stream) Method

stream
The System.IO.Stream to be used.

Glossary Item Box

Specifies the stream to be used by the Vt control in auto send/receive mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetStream( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim stream As Stream

instance.SetStream(stream)
C#
public void SetStream(
   Stream stream
)
Managed Extensions for C++
public: void SetStream(
   Stream* stream
)
C++/CLI
public:
void SetStream(
   Stream^ stream
)

Parameters

stream
The System.IO.Stream to be used.

Remarks

Although the Vt control can work with data from any source (file, memory, etc.) its most common usage is displaying data received over an Internet connection. This method provides automatic reading/writing from/to any System.IO.Stream.

A connection must be established with the remote host prior to calling this method. Once called, any data received is automatically displayed in the Vt window. Any key presses on the Vt window are automatically sent over the established connection.

Typical use would be to use Telnet.GetStream or Rlogin.GetStream with this method.

This method uses a default buffer size of 1024 and ThreadPriority.Lowest. Use SetStream(Stream,Int32,ThreadPriority) to specify an alternative buffer size or thread priority.

See Also

Reference

Vt Class
Vt Members
Overload List


Write Method

[image]
PowerTCP Emulation for .NET
Write Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Write Method

Glossary Item Box

Displays data contained within a byte array in the Vt window and interprets all escape sequences.

Overload List

Overload | Description
Write(Byte[]) | Displays data contained within a byte array in the Vt window and interprets all escape sequences.
Write(String) | Displays data contained within a string in the Vt window and interprets all escape sequences.
Write(Byte[],Int32,Int32) | Displays data contained within a byte array in the Vt window and interprets all escape sequences.

See Also

Reference

Vt Class
Vt Members


Write(Byte[]) Method

[image]
PowerTCP Emulation for .NET
Write(Byte[]) Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Vt Class > Write Method : Write(Byte[]) Method

data
The data to display.

Glossary Item Box

Displays data contained within a byte array in the Vt window and interprets all escape sequences.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Write( _
   ByVal data() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim data() As Byte

instance.Write(data)
C#
public void Write(
   byte[] data
)
Managed Extensions for C++
public: void Write(
   byte[]* data
)
C++/CLI
public:
void Write(
   array<byte>^ data
)

Parameters

data
The data to display.

Remarks

Use this method to process data received from a host, or VT formatted data from a file or other data source. The control interprets and displays the data using the terminal type specified in the TerminalType property.

When Encoding is set to a value other than Encoding.ASCII (default), the byte array is interpreted as multibyte characters.

Example

The following example demonstrates how to get information about a cell in the display.
C# Copy Code
private void writeToDisplay(System.IO.MemoryStream stream)
{
    //Read data into a byte array
    stream.Position = 0;
    byte[] data = new byte[stream.Length];
    stream.Read(data, 0, (int)stream.Length);

    //Write a byte array
    vt1.Write(data);

    //Write a byte array with offset and count
    vt1.Write(data, 0, data.Length);

    //Write a string
    vt1.Write(System.Text.Encoding.Default.GetString(data, 0, data.Length));
}
Visual Basic Copy Code
Private Sub writeToDisplay(ByVal stream As System.IO.MemoryStream)
    'Read data into a byte array
    stream.Position = 0
    Dim data() As Byte = New Byte(stream.Length - 1){}
    stream.Read(data, 0, CInt(Fix(stream.Length)))

    'Write a byte array
    vt1.Write(data)

    'Write a byte array with offset and count
    vt1.Write(data, 0, data.Length)

    'Write a string
    vt1.Write(System.Text.Encoding.Default.GetString(data, 0, data.Length))
End Sub

See Also

Reference

Vt Class
Vt Members
Overload List


Write(String) Method

[image]
PowerTCP Emulation for .NET
Write(String) Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Vt Class > Write Method : Write(String) Method

data
The data to display.

Glossary Item Box

Displays data contained within a string in the Vt window and interprets all escape sequences.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Write( _
   ByVal data As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim data As String

instance.Write(data)
C#
public void Write(
   string data
)
Managed Extensions for C++
public: void Write(
   string* data
)
C++/CLI
public:
void Write(
   String^ data
)

Parameters

data
The data to display.

Remarks

Use this overload to process data received from a host, or VT formatted data from a file or other data source when no encoding is required.

Example

The following example demonstrates how to get information about a cell in the display.
C# Copy Code
private void writeToDisplay(System.IO.MemoryStream stream)
{
    //Read data into a byte array
    stream.Position = 0;
    byte[] data = new byte[stream.Length];
    stream.Read(data, 0, (int)stream.Length);

    //Write a byte array
    vt1.Write(data);

    //Write a byte array with offset and count
    vt1.Write(data, 0, data.Length);

    //Write a string
    vt1.Write(System.Text.Encoding.Default.GetString(data, 0, data.Length));
}
Visual Basic Copy Code
Private Sub writeToDisplay(ByVal stream As System.IO.MemoryStream)
    'Read data into a byte array
    stream.Position = 0
    Dim data() As Byte = New Byte(stream.Length - 1){}
    stream.Read(data, 0, CInt(Fix(stream.Length)))

    'Write a byte array
    vt1.Write(data)

    'Write a byte array with offset and count
    vt1.Write(data, 0, data.Length)

    'Write a string
    vt1.Write(System.Text.Encoding.Default.GetString(data, 0, data.Length))
End Sub

See Also

Reference

Vt Class
Vt Members
Overload List


Write(Byte[],Int32,Int32) Method

[image]
PowerTCP Emulation for .NET
Write(Byte[],Int32,Int32) Method
See Also Example Send comments on this topic
Dart.Emulation Namespace > Vt Class > Write Method : Write(Byte[],Int32,Int32) Method

data
The data to display.
offset
The location in the array to start writing from.
count
The count of bytes to display.

Glossary Item Box

Displays data contained within a byte array in the Vt window and interprets all escape sequences.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Write( _
   ByVal data() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim data() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(data, offset, count)
C#
public void Write(
   byte[] data,
   int offset,
   int count
)
Managed Extensions for C++
public: void Write(
   byte[]* data,
   int offset,
   int count
)
C++/CLI
public:
void Write(
   array<byte>^ data,
   int offset,
   int count
)

Parameters

data
The data to display.
offset
The location in the array to start writing from.
count
The count of bytes to display.

Remarks

Use this method to process data received from a host, or VT formatted data from a file or other data source. The control interprets and displays the data using the terminal type specified in the TerminalType property.

When Encoding is set to a value other than Encoding.ASCII (default), the byte array is interpreted as multibyte characters.

Example

The following example demonstrates how to get information about a cell in the display.
C# Copy Code
private void writeToDisplay(System.IO.MemoryStream stream)
{
    //Read data into a byte array
    stream.Position = 0;
    byte[] data = new byte[stream.Length];
    stream.Read(data, 0, (int)stream.Length);

    //Write a byte array
    vt1.Write(data);

    //Write a byte array with offset and count
    vt1.Write(data, 0, data.Length);

    //Write a string
    vt1.Write(System.Text.Encoding.Default.GetString(data, 0, data.Length));
}
Visual Basic Copy Code
Private Sub writeToDisplay(ByVal stream As System.IO.MemoryStream)
    'Read data into a byte array
    stream.Position = 0
    Dim data() As Byte = New Byte(stream.Length - 1){}
    stream.Read(data, 0, CInt(Fix(stream.Length)))

    'Write a byte array
    vt1.Write(data)

    'Write a byte array with offset and count
    vt1.Write(data, 0, data.Length)

    'Write a string
    vt1.Write(System.Text.Encoding.Default.GetString(data, 0, data.Length))
End Sub

See Also

Reference

Vt Class
Vt Members
Overload List


Vt Class Properties

[image]
PowerTCP Emulation for .NET
Vt Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Vt Class

Glossary Item Box

For a list of all members of this type, see Vt members.

Public Properties

 | Name | Description
Public Property | AcceptTabs | Gets or sets whether to retain focus when the tab key is used.
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AnsiColor | Provides fine control of display colors. Includes eight "normal" and eight "bold" (aka "bright" or "light") colors.
Public Property | Answer | Gets or sets a string expression to be sent by the control whenever an ENQ is received.
Public Property | AutoRepeat | Gets or sets a value that determines whether depressed keys generate more than one character.
Public Property | AutoScroll | Overridden. Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin.
Public Property | AutoScrollMinSize | Gets or sets the size of the AutoScrollMinSize property.
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollRowPosition | Sets or gets the vertical scrolling position using a row index.
Public Property | AutoWrap | Gets or sets a value that indicates whether display text stops at the last column or wraps to the next line when a line contains more data than can fit on one row.
Public Property | BackColor | Overridden. Gets or sets the background color for the control.
Public Property | BackColorErase | Gets or sets the value that determines the background color when cells are erased, deleted, or inserted.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control.
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration.
Public Property | Bell | Gets or sets a value that determines whether an audio bell is enabled.
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | BlinkIntensity | Gets or sets the "brightness" of blinking text.
Public Property | BoldColor | Gets or sets the color of bold/bright text.
Public Property | BoldNegativeColor | Gets or sets the color of bold/bright text when fore/back is inverted.
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | BufferRows | Gets the number of rows currently stored in the scrollback buffer.
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | CellSize | Gets or sets the size of a cell.
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | Columns | Gets or sets the number of columns used by the Vt window screen.
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Overridden. Gets or sets the mouse cursor used.
Public Property | CursorColor | Gets or sets the color used for the text cursor.
Public Property | CursorKeys | Gets or sets a value that determines whether the cursor keys send ANSI cursor control sequences (up, down, left, right) or application control sequences.
Public Property | CursorPosition | Gets or sets the current text cursor position on the Vt contol.
Public Property | CursorStyle | Gets or sets a value which indicates the cursor style.
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Encoding | Gets or sets a value which indicates the encoding to use when sending or receiving multibyte data.
Public Property | EnhancedScrollback | Gets or sets a value that indicates if the VT Control is using enhanced scrollback buffer capturing.
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | Overridden. Gets or sets the font used in the display of the control.
Public Property | ForeColor | Overridden. Gets or sets the foreground color for the control.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | Inverse | Gets or sets a value that determines whether the foreground and background colors are switched.
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | KeyPad | Gets or sets a value that determines whether the keypad sends ASCII characters or escape sequences.
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | LocalEcho | Gets or sets a value which controls whether or not key presses are displayed on the Vt window.
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls.
Public Property | MaxBufferRows | Gets or sets the maximum number of rows to store in the scrollback buffer.
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | NationalCharSet | Gets or sets the National Replacement Character Set for use in VT220 7-bit or VT320 7-bit emulation modes to display special characters that normally require 8-bit emulation mode.
Public Property | NationalCharSetMode | Indicates whether the National Replacement Character Set specified by the NationalCharSet property or the standard ASCII character set will be used when rendering text.
Public Property | NewLine | Gets or sets the end-of-line character sequence to use.
Public Property | NormalIntensity | Gets or sets the "brightness" of normal text.
Public Property | Padding | Gets or sets a Padding object which determines the amount of "buffer" space around the Vt text.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | Print | Gets or sets a PrintType specifying how printing should occur.
Public Property | Printer | Gets or sets a value that indicates name of the printer to be used for printing operations.
Public Property | PrintPassThrough | Gets or sets whether to bypass printer drivers and write directly to printer when in Controller mode.
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | Rows | Gets or sets the number of rows used by the Vt window screen.
Public Property | ScrollType | Gets or sets a value that determines whether to use jump scrolling or smooth scrolling in the display screen.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | StatusLine | Gets or sets a string that populates a reverse-video status bar at the bottom of the screen display.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | Tabs | Gets or sets a list of comma-delimited tab positions.
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | TerminalType | Gets or sets the terminal type to emulate.
Public Property | TextRenderingHint | Gets or sets the TextRenderingHint that the VT component will use to render glyphs.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

Vt Class
Dart.Emulation Namespace


AcceptTabs Property

[image]
PowerTCP Emulation for .NET
AcceptTabs Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AcceptTabs Property

Glossary Item Box

Gets or sets whether to retain focus when the tab key is used.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property AcceptTabs As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.AcceptTabs = value

value = instance.AcceptTabs
C#
[DefaultValue()]
public bool AcceptTabs {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_AcceptTabs();
public: __property void set_AcceptTabs(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool AcceptTabs {
   bool get();
   void set (    bool value);
}

Property Value

true if the Vt control should retain focus when the tab key is pressed; false if the tab key should cause the focus to shift to the next control in the tab index. The default value is true.

See Also

Reference

Vt Class
Vt Members


AllowDrop Property

[image]
PowerTCP Emulation for .NET
AllowDrop Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AllowDrop Property

Glossary Item Box

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Declaration)
Public Shadows Property AllowDrop As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public new bool AllowDrop {get; set;}
Managed Extensions for C++
public: __property new bool get_AllowDrop();
public: __property new void set_AllowDrop(
   bool value
);
C++/CLI
public:
new property bool AllowDrop {
   bool get();
   void set (    bool value);
}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

See Also

Reference

Vt Class
Vt Members


AnsiColor Property

[image]
PowerTCP Emulation for .NET
AnsiColor Property
See Also Example Send comments on this topic
Dart.Emulation Namespace > Vt Class : AnsiColor Property

Glossary Item Box

Provides fine control of display colors. Includes eight "normal" and eight "bold" (aka "bright" or "light") colors.

Syntax

Visual Basic (Declaration)
Public Property AnsiColor As AnsiColor
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As AnsiColor

instance.AnsiColor = value

value = instance.AnsiColor
C#
public AnsiColor AnsiColor {get; set;}
Managed Extensions for C++
public: __property AnsiColor* get_AnsiColor();
public: __property void set_AnsiColor(
   AnsiColor* value
);
C++/CLI
public:
property AnsiColor^ AnsiColor {
   AnsiColor^ get();
   void set (    AnsiColor^ value);
}

Example

The following example demonstrates how set normal colors as an intensity percentage of bold colors.
C# Copy Code
private void updateColors(Vt vt, int intensity)
{
    //Update colors to a specified intensity (0-100).
    //0 is black and 100 is the bold color.
    int val = ((255 * intensity) / 100);
    vt.AnsiColor.BlackBold = Color.Gray;
    vt.AnsiColor.RedBold = Color.Red;
    vt.AnsiColor.GreenBold = Color.Lime;
    vt.AnsiColor.YellowBold = Color.Yellow;
    vt.AnsiColor.BlueBold = Color.Blue;
    vt.AnsiColor.MagentaBold = Color.Magenta;
    vt.AnsiColor.CyanBold = Color.Cyan;
    vt.AnsiColor.WhiteBold = Color.White;
    vt.AnsiColor.Black = Color.Black;
    vt.AnsiColor.Red = Color.FromArgb(val, 0, 0);
    vt.AnsiColor.Green = Color.FromArgb(0, val, 0);
    vt.AnsiColor.Yellow = Color.FromArgb(val, val, 0);
    vt.AnsiColor.Blue = Color.FromArgb(0, 0, val);
    vt.AnsiColor.Magenta = Color.FromArgb(val, 0, val);
    vt.AnsiColor.Cyan = Color.FromArgb(0, val, val);
    vt.AnsiColor.White = Color.FromArgb(val, val, val);
    vt.Refresh();
}
Visual Basic Copy Code
Private Sub updateColors(ByVal vt As Vt, ByVal intensity As Integer)
    'Update colors to a specified intensity (0-100).
    '0 is black and 100 is the bold color.
    Dim val As Integer = ((255 * intensity) / 100)
    vt.AnsiColor.BlackBold = Color.Gray
    vt.AnsiColor.RedBold = Color.Red
    vt.AnsiColor.GreenBold = Color.Lime
    vt.AnsiColor.YellowBold = Color.Yellow
    vt.AnsiColor.BlueBold = Color.Blue
    vt.AnsiColor.MagentaBold = Color.Magenta
    vt.AnsiColor.CyanBold = Color.Cyan
    vt.AnsiColor.WhiteBold = Color.White
    vt.AnsiColor.Black = Color.Black
    vt.AnsiColor.Red = Color.FromArgb(val, 0, 0)
    vt.AnsiColor.Green = Color.FromArgb(0, val, 0)
    vt.AnsiColor.Yellow = Color.FromArgb(val, val, 0)
    vt.AnsiColor.Blue = Color.FromArgb(0, 0, val)
    vt.AnsiColor.Magenta = Color.FromArgb(val, 0, val)
    vt.AnsiColor.Cyan = Color.FromArgb(0, val, val)
    vt.AnsiColor.White = Color.FromArgb(val, val, val)
    vt.Refresh()
End Sub

See Also

Reference

Vt Class
Vt Members


Answer Property

[image]
PowerTCP Emulation for .NET
Answer Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Answer Property

Glossary Item Box

Gets or sets a string expression to be sent by the control whenever an ENQ is received.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Answer As String
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As String

instance.Answer = value

value = instance.Answer
C#
[DefaultValue()]
public string Answer {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property string* get_Answer();
public: __property void set_Answer(
   string* value
);
C++/CLI
[DefaultValue()]
public:
property String^ Answer {
   String^ get();
   void set (    String^ value);
}

Property Value

A string representing the data to send when an ENQ request is received.

Remarks

A server may send an ENQ command to a client, requesting a response. The value of this property is sent as the response. This property defaults to an empty string, meaning no response is sent to an ENQ request.

See Also

Reference

Vt Class
Vt Members


AutoRepeat Property

[image]
PowerTCP Emulation for .NET
AutoRepeat Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AutoRepeat Property

Glossary Item Box

Gets or sets a value that determines whether depressed keys generate more than one character.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property AutoRepeat As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.AutoRepeat = value

value = instance.AutoRepeat
C#
[DefaultValue()]
public bool AutoRepeat {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_AutoRepeat();
public: __property void set_AutoRepeat(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool AutoRepeat {
   bool get();
   void set (    bool value);
}

Property Value

True if a depressed key should generate more than one character; false if a depressed key should only generate one character. The default value is true.

Remarks

When set to false, only a single character is generated when a key is depressed; otherwise, multiple characters are generated until the key is released.

If data is received from the host which causes this property to change, the AutoRepeatChanged event is raised.

See Also

Reference

Vt Class
Vt Members


AutoScroll Property

[image]
PowerTCP Emulation for .NET
AutoScroll Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AutoScroll Property

Glossary Item Box

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overrides Property AutoScroll As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
[DefaultValue()]
public override bool AutoScroll {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_AutoScroll() override;
public: __property void set_AutoScroll(
   bool value
) override;
C++/CLI
[DefaultValue()]
public:
property bool AutoScroll {
   bool get() override;
   void set (    bool value) override;
}

Remarks

See System.Windows.Forms.ScrollableControl.AutoScroll.

See Also

Reference

Vt Class
Vt Members


AutoScrollMargin Property

[image]
PowerTCP Emulation for .NET
AutoScrollMargin Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AutoScrollMargin Property

Glossary Item Box

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Shadows Property AutoScrollMargin As Size
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Size

instance.AutoScrollMargin = value

value = instance.AutoScrollMargin
C#
[DefaultValue()]
public new Size AutoScrollMargin {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property new Size get_AutoScrollMargin();
public: __property new void set_AutoScrollMargin(
   Size value
);
C++/CLI
[DefaultValue()]
public:
new property Size AutoScrollMargin {
   Size get();
   void set (    Size value);
}

Remarks

See System.Windows.Forms.ScrollableControl.AutoScrollMargin.

See Also

Reference

Vt Class
Vt Members


AutoScrollMinSize Property

[image]
PowerTCP Emulation for .NET
AutoScrollMinSize Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AutoScrollMinSize Property

Glossary Item Box

Gets or sets the size of the AutoScrollMinSize property.

Syntax

Visual Basic (Declaration)
Public Shadows Property AutoScrollMinSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Size

instance.AutoScrollMinSize = value

value = instance.AutoScrollMinSize
C#
public new Size AutoScrollMinSize {get; set;}
Managed Extensions for C++
public: __property new Size get_AutoScrollMinSize();
public: __property new void set_AutoScrollMinSize(
   Size value
);
C++/CLI
public:
new property Size AutoScrollMinSize {
   Size get();
   void set (    Size value);
}

Remarks

See System.Windows.Forms.ScrollableControl.AutoScrollMinSize.

See Also

Reference

Vt Class
Vt Members


AutoScrollRowPosition Property

[image]
PowerTCP Emulation for .NET
AutoScrollRowPosition Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AutoScrollRowPosition Property

Glossary Item Box

Sets or gets the vertical scrolling position using a row index.

Syntax

Visual Basic (Declaration)
Public Property AutoScrollRowPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Integer

instance.AutoScrollRowPosition = value

value = instance.AutoScrollRowPosition
C#
public int AutoScrollRowPosition {get; set;}
Managed Extensions for C++
public: __property int get_AutoScrollRowPosition();
public: __property void set_AutoScrollRowPosition(
   int value
);
C++/CLI
public:
property int AutoScrollRowPosition {
   int get();
   void set (    int value);
}

Remarks

The scrollback buffer is taken into account so that this value is between 0 and BufferRows. Runtime only.

See Also

Reference

Vt Class
Vt Members


AutoWrap Property

[image]
PowerTCP Emulation for .NET
AutoWrap Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AutoWrap Property

Glossary Item Box

Gets or sets a value that indicates whether display text stops at the last column or wraps to the next line when a line contains more data than can fit on one row.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property AutoWrap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.AutoWrap = value

value = instance.AutoWrap
C#
[DefaultValue()]
public bool AutoWrap {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_AutoWrap();
public: __property void set_AutoWrap(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool AutoWrap {
   bool get();
   void set (    bool value);
}

Property Value

true if text should wrap when a line contains more data then can fit on a row; false otherwise. The default value is false.

Remarks

If data is received from the host which causes this property to change, the AutoWrapChanged event is raised.

See Also

Reference

Vt Class
Vt Members


BackColor Property

[image]
PowerTCP Emulation for .NET
BackColor Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : BackColor Property

Glossary Item Box

Gets or sets the background color for the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overrides Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
[DefaultValue()]
public override Color BackColor {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_BackColor() override;
public: __property void set_BackColor(
   Color value
) override;
C++/CLI
[DefaultValue()]
public:
property Color BackColor {
   Color get() override;
   void set (    Color value) override;
}

Property Value

A System.Drawing.Color value.

Remarks

This property defaults to Color.Black.

See Also

Reference

Vt Class
Vt Members


BackColorErase Property

[image]
PowerTCP Emulation for .NET
BackColorErase Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : BackColorErase Property

Glossary Item Box

Gets or sets the value that determines the background color when cells are erased, deleted, or inserted.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property BackColorErase As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.BackColorErase = value

value = instance.BackColorErase
C#
[DefaultValue()]
public bool BackColorErase {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_BackColorErase();
public: __property void set_BackColorErase(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool BackColorErase {
   bool get();
   void set (    bool value);
}

Remarks

The SGR command can be used by the host to set a background color. By default, this color will be used for coloring cells when they are erased or made blank by an insert or delete operation. Sometimes, however, you may not want the current SGR background color to be used as the default background color when an erasure is commanded. Set this value to false if you do not want the current SGR background color to supercede the BackColor property when cells are erased.

See Also

Reference

Vt Class
Vt Members


BackgroundImage Property

[image]
PowerTCP Emulation for .NET
BackgroundImage Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : BackgroundImage Property

Glossary Item Box

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
Public Shadows Property BackgroundImage As Image
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public new Image BackgroundImage {get; set;}
Managed Extensions for C++
public: __property new Image* get_BackgroundImage();
public: __property new void set_BackgroundImage(
   Image* value
);
C++/CLI
public:
new property Image^ BackgroundImage {
   Image^ get();
   void set (    Image^ value);
}

See Also

Reference

Vt Class
Vt Members


BackgroundImageLayout Property

[image]
PowerTCP Emulation for .NET
BackgroundImageLayout Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : BackgroundImageLayout Property

Glossary Item Box

Gets or sets the background image layout as defined in the ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
Public Shadows Property BackgroundImageLayout As ImageLayout
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
public new ImageLayout BackgroundImageLayout {get; set;}
Managed Extensions for C++
public: __property new ImageLayout get_BackgroundImageLayout();
public: __property new void set_BackgroundImageLayout(
   ImageLayout value
);
C++/CLI
public:
new property ImageLayout BackgroundImageLayout {
   ImageLayout get();
   void set (    ImageLayout value);
}

See Also

Reference

Vt Class
Vt Members


Bell Property

[image]
PowerTCP Emulation for .NET
Bell Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Bell Property

Glossary Item Box

Gets or sets a value that determines whether an audio bell is enabled.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Bell As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.Bell = value

value = instance.Bell
C#
[DefaultValue()]
public bool Bell {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_Bell();
public: __property void set_Bell(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool Bell {
   bool get();
   void set (    bool value);
}

Property Value

true if the BEL character should cause the bell to sound; false otherwise. The default value is true.

Remarks

The ASCII BEL character causes the system bell to sound. Such actions as attempting to scroll past the scroll range also cause the bell to sound.

See Also

Reference

Vt Class
Vt Members


BlinkIntensity Property

[image]
PowerTCP Emulation for .NET
BlinkIntensity Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : BlinkIntensity Property

Glossary Item Box

Gets or sets the "brightness" of blinking text.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property BlinkIntensity As Integer
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Integer

instance.BlinkIntensity = value

value = instance.BlinkIntensity
C#
[DefaultValue()]
public int BlinkIntensity {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_BlinkIntensity();
public: __property void set_BlinkIntensity(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int BlinkIntensity {
   int get();
   void set (    int value);
}

Property Value

An integer representing the intensity of blinking text. The default value is 0.

Remarks

The valid range is 0 to 100. When set to 0, text will go off and on during the blink cycle. When set to 100 blinking is effectively "turned off". When set to a value in the middle, blinking text will appear dimmer than usual.

See Also

Reference

Vt Class
Vt Members


BoldColor Property

[image]
PowerTCP Emulation for .NET
BoldColor Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : BoldColor Property

Glossary Item Box

Gets or sets the color of bold/bright text.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property BoldColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Color

instance.BoldColor = value

value = instance.BoldColor
C#
[DefaultValue()]
public Color BoldColor {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_BoldColor();
public: __property void set_BoldColor(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color BoldColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value specifying the color of bold/bright text.

Remarks

The default value is lime (R=0, G=255, B=0).

See Also

Reference

Vt Class
Vt Members


BoldNegativeColor Property

[image]
PowerTCP Emulation for .NET
BoldNegativeColor Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : BoldNegativeColor Property

Glossary Item Box

Gets or sets the color of bold/bright text when fore/back is inverted.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property BoldNegativeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Color

instance.BoldNegativeColor = value

value = instance.BoldNegativeColor
C#
[DefaultValue()]
public Color BoldNegativeColor {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_BoldNegativeColor();
public: __property void set_BoldNegativeColor(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color BoldNegativeColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value specifying the color of bold/bright text when fore/back is inverted.

Remarks

The default value is Color.Green.

See Also

Reference

Vt Class
Vt Members


BufferRows Property

[image]
PowerTCP Emulation for .NET
BufferRows Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : BufferRows Property

Glossary Item Box

Gets the number of rows currently stored in the scrollback buffer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BufferRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Integer

value = instance.BufferRows
C#
public int BufferRows {get;}
Managed Extensions for C++
public: __property int get_BufferRows();
C++/CLI
public:
property int BufferRows {
   int get();
}

Property Value

An integer specifying the number of rows currently stored in the scrollback buffer.

Remarks

This property dynamically reports the number of rows in the current scrollback buffer.

See Also

Reference

Vt Class
Vt Members


CellSize Property

[image]
PowerTCP Emulation for .NET
CellSize Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : CellSize Property

Glossary Item Box

Gets or sets the size of a cell.

Syntax

Visual Basic (Declaration)
Public Property CellSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Size

instance.CellSize = value

value = instance.CellSize
C#
public Size CellSize {get; set;}
Managed Extensions for C++
public: __property Size get_CellSize();
public: __property void set_CellSize(
   Size value
);
C++/CLI
public:
property Size CellSize {
   Size get();
   void set (    Size value);
}

Property Value

A Size value reflecting the size of a cell.

Remarks

The Vt control is comprised of a "grid" of cells; each cell contains one character. All cells have the same dimensions as determined by the size of the font.

This property can be used to perform resize calculations (for example, if the size of the font is changed, the size of the Vt control can be changed).

This property can be set programatically at runtime. To reset to the default, reset the Font property.

See Also

Reference

Vt Class
Vt Members


Columns Property

[image]
PowerTCP Emulation for .NET
Columns Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Columns Property

Glossary Item Box

Gets or sets the number of columns used by the Vt window screen.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Columns As Integer
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Integer

instance.Columns = value

value = instance.Columns
C#
[DefaultValue()]
public int Columns {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_Columns();
public: __property void set_Columns(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int Columns {
   int get();
   void set (    int value);
}

Property Value

An integer.

Remarks

Values from 1 to Int32.MaxValue are supported. Defaults to 80.

If data is received from the host which causes this property to change, the ScreenSizeChanged event is raised.

See Also

Reference

Vt Class
Vt Members


Cursor Property

[image]
PowerTCP Emulation for .NET
Cursor Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Cursor Property

Glossary Item Box

Gets or sets the mouse cursor used.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overrides Property Cursor As Cursor
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
C#
[DefaultValue()]
public override Cursor Cursor {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Cursor* get_Cursor() override;
public: __property void set_Cursor(
   Cursor* value
) override;
C++/CLI
[DefaultValue()]
public:
property Cursor^ Cursor {
   Cursor^ get() override;
   void set (    Cursor^ value) override;
}

See Also

Reference

Vt Class
Vt Members


CursorColor Property

[image]
PowerTCP Emulation for .NET
CursorColor Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : CursorColor Property

Glossary Item Box

Gets or sets the color used for the text cursor.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CursorColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Color

instance.CursorColor = value

value = instance.CursorColor
C#
[DefaultValue()]
public Color CursorColor {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_CursorColor();
public: __property void set_CursorColor(
   Color value
);
C++/CLI
[DefaultValue()]
public:
property Color CursorColor {
   Color get();
   void set (    Color value);
}

Property Value

A System.Drawing.Color value.

Remarks

Defaults to RGB (229, 229, 229), the default value of ForeColor. This property can be set to Color.Empty to perform a complete color inversion.

If set to Color.Transparent, the cursor will be invisible.

If BackColor is Color.Transparent, the color is the result of an XOR operation between the background image color and this property.

See Also

Reference

Vt Class
Vt Members


CursorKeys Property

[image]
PowerTCP Emulation for .NET
CursorKeys Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : CursorKeys Property

Glossary Item Box

Gets or sets a value that determines whether the cursor keys send ANSI cursor control sequences (up, down, left, right) or application control sequences.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CursorKeys As CursorKeys
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As CursorKeys

instance.CursorKeys = value

value = instance.CursorKeys
C#
[DefaultValue()]
public CursorKeys CursorKeys {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property CursorKeys get_CursorKeys();
public: __property void set_CursorKeys(
   CursorKeys value
);
C++/CLI
[DefaultValue()]
public:
property CursorKeys CursorKeys {
   CursorKeys get();
   void set (    CursorKeys value);
}

Property Value

A CursorKeys value. The default value is CursorKeys.Normal.

Remarks

If data is received from the host which causes this property to change, the CursorKeysChanged event is raised.

See Also

Reference

Vt Class
Vt Members


CursorPosition Property

[image]
PowerTCP Emulation for .NET
CursorPosition Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : CursorPosition Property

Glossary Item Box

Gets or sets the current text cursor position on the Vt contol.

Syntax

Visual Basic (Declaration)
Public Property CursorPosition As Point
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Point

instance.CursorPosition = value

value = instance.CursorPosition
C#
public Point CursorPosition {get; set;}
Managed Extensions for C++
public: __property Point get_CursorPosition();
public: __property void set_CursorPosition(
   Point value
);
C++/CLI
public:
property Point CursorPosition {
   Point get();
   void set (    Point value);
}

Property Value

A Point value specifying the current text cursor position.

See Also

Reference

Vt Class
Vt Members


CursorStyle Property

[image]
PowerTCP Emulation for .NET
CursorStyle Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : CursorStyle Property

Glossary Item Box

Gets or sets a value which indicates the cursor style.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CursorStyle As CursorStyle
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As CursorStyle

instance.CursorStyle = value

value = instance.CursorStyle
C#
[DefaultValue()]
public CursorStyle CursorStyle {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property CursorStyle get_CursorStyle();
public: __property void set_CursorStyle(
   CursorStyle value
);
C++/CLI
[DefaultValue()]
public:
property CursorStyle CursorStyle {
   CursorStyle get();
   void set (    CursorStyle value);
}

Property Value

A CursorStyle value. The default value is CursorStyle.Block.

See Also

Reference

Vt Class
Vt Members


Encoding Property

[image]
PowerTCP Emulation for .NET
Encoding Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Encoding Property

Glossary Item Box

Gets or sets a value which indicates the encoding to use when sending or receiving multibyte data.

Syntax

Visual Basic (Declaration)
Public Property Encoding As Encoding
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Encoding

instance.Encoding = value

value = instance.Encoding
C#
public Encoding Encoding {get; set;}
Managed Extensions for C++
public: __property Encoding* get_Encoding();
public: __property void set_Encoding(
   Encoding* value
);
C++/CLI
public:
property Encoding^ Encoding {
   Encoding^ get();
   void set (    Encoding^ value);
}

Property Value

A System.Text.Encoding value. The default is Encoding.ASCII, which indicates no encoding.

Remarks

When a value other than Encoding.ASCII is used, the Write(Byte[]) method (except the string overload) will decode multibyte data using this encoding. This property provides for the displaying of any Unicode character.

No decoding is attempted when Encoding is set to the default Encoding.ASCII value. Instead, 7- or 8-bit values are used directly.

A remote host may encode characters as multibyte representations. To decode these characters, the display must know what encoding was used; this is where the Encoding property comes into play. With the appropriate Encoding setting, data will be decoded to a sequence of unicode values. When a font supporting the character set is used, the correct visual representations (glyphs) of these unicode characters will be displayed.

See Also

Reference

Vt Class
Vt Members


EnhancedScrollback Property

[image]
PowerTCP Emulation for .NET
EnhancedScrollback Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : EnhancedScrollback Property

Glossary Item Box

Gets or sets a value that indicates if the VT Control is using enhanced scrollback buffer capturing.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property EnhancedScrollback As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.EnhancedScrollback = value

value = instance.EnhancedScrollback
C#
[DefaultValue()]
public bool EnhancedScrollback {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_EnhancedScrollback();
public: __property void set_EnhancedScrollback(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool EnhancedScrollback {
   bool get();
   void set (    bool value);
}

Property Value

A boolean value specifying if enhanced scrollback buffering is in use.

Remarks

The default value is false. Normally only lines that are pushed off the top of the screen due to line-feeds are added to the scrollback buffer. When EnhancedScrollback is enabled, areas of the screen that are cleared or erased are also added to the scrollback buffer.

See Also

Reference

Vt Class
Vt Members


Font Property

[image]
PowerTCP Emulation for .NET
Font Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Font Property

Glossary Item Box

Gets or sets the font used in the display of the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overrides Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Font

instance.Font = value

value = instance.Font
C#
[DefaultValue()]
public override Font Font {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Font* get_Font() override;
public: __property void set_Font(
   Font* value
) override;
C++/CLI
[DefaultValue()]
public:
property Font^ Font {
   Font^ get() override;
   void set (    Font^ value) override;
}

Property Value

A System.Drawing.Font object.

Remarks

The default value is 10-point Lucida Console font.

When the Encoding property is set to something other than the default value of Encoding.ASCII, this property should be set to a font (including "script") that can display the anticipated character set.

Font should be set to a fixed-width font. Variable width fonts will not display well due to the cell-based nature of the VT display. Wider characters will extend into neighbor cells, while cells with slimmer characters will include large areas of empty space.

See Also

Reference

Vt Class
Vt Members


ForeColor Property

[image]
PowerTCP Emulation for .NET
ForeColor Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : ForeColor Property

Glossary Item Box

Gets or sets the foreground color for the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overrides Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
[DefaultValue()]
public override Color ForeColor {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Color get_ForeColor() override;
public: __property void set_ForeColor(
   Color value
) override;
C++/CLI
[DefaultValue()]
public:
property Color ForeColor {
   Color get() override;
   void set (    Color value) override;
}

Property Value

A System.Drawing.Color value.

Remarks

This property defaults to light gray (RGB: 229, 229, 229).

See Also

Reference

Vt Class
Vt Members


Inverse Property

[image]
PowerTCP Emulation for .NET
Inverse Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Inverse Property

Glossary Item Box

Gets or sets a value that determines whether the foreground and background colors are switched.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Inverse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.Inverse = value

value = instance.Inverse
C#
[DefaultValue()]
public bool Inverse {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_Inverse();
public: __property void set_Inverse(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool Inverse {
   bool get();
   void set (    bool value);
}

Property Value

true if the foreground and background colors should be switched; false otherwise. The default value is false.

Remarks

The ForeColor property sets the foreground color, and the BackColor property sets the background color.

If data is received from the host which causes this property to change, the InverseChanged event is raised.

See Also

Reference

Vt Class
Vt Members


KeyPad Property

[image]
PowerTCP Emulation for .NET
KeyPad Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : KeyPad Property

Glossary Item Box

Gets or sets a value that determines whether the keypad sends ASCII characters or escape sequences.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property KeyPad As KeyPad
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As KeyPad

instance.KeyPad = value

value = instance.KeyPad
C#
[DefaultValue()]
public KeyPad KeyPad {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property KeyPad get_KeyPad();
public: __property void set_KeyPad(
   KeyPad value
);
C++/CLI
[DefaultValue()]
public:
property KeyPad KeyPad {
   KeyPad get();
   void set (    KeyPad value);
}

Property Value

A KeyPad value. The default value is KeyPad.Numeric.

Remarks

ASCII character codes correspond to the numeric characters on the keys. Escape sequences are used by some applications.

If data is received from the host which causes this property to change, the KeyPadChanged event is raised.

See Also

Reference

Vt Class
Vt Members


LocalEcho Property

[image]
PowerTCP Emulation for .NET
LocalEcho Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : LocalEcho Property

Glossary Item Box

Gets or sets a value which controls whether or not key presses are displayed on the Vt window.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property LocalEcho As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.LocalEcho = value

value = instance.LocalEcho
C#
[DefaultValue()]
public bool LocalEcho {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_LocalEcho();
public: __property void set_LocalEcho(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool LocalEcho {
   bool get();
   void set (    bool value);
}

Property Value

true if key presses should be displayed on the Vt window; false otherwise. The default value is false.

Remarks

Often, remote hosts will echo sent characters back to the user. If the Vt control is used with LocalEcho set to true, this will result in a "doubling" of characters (i.e., typing "a" will actually display "aa" on the Vt window). Set LocalEcho to false and only one character will be displayed (the "echoed" one received from the remote host). If the remote host does not echo sent characters back, set this property to true to display the character when the key is pressed.

If data is received from the host which causes this property to change, the LocalEchoChanged event is raised.

See Also

Reference

Vt Class
Vt Members


Margin Property

[image]
PowerTCP Emulation for .NET
Margin Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Margin Property

Glossary Item Box

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
Public Shadows Property Margin As Padding
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Padding

instance.Margin = value

value = instance.Margin
C#
public new Padding Margin {get; set;}
Managed Extensions for C++
public: __property new Padding get_Margin();
public: __property new void set_Margin(
   Padding value
);
C++/CLI
public:
new property Padding Margin {
   Padding get();
   void set (    Padding value);
}

See Also

Reference

Vt Class
Vt Members


MaxBufferRows Property

[image]
PowerTCP Emulation for .NET
MaxBufferRows Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : MaxBufferRows Property

Glossary Item Box

Gets or sets the maximum number of rows to store in the scrollback buffer.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property MaxBufferRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Integer

instance.MaxBufferRows = value

value = instance.MaxBufferRows
C#
[DefaultValue()]
public int MaxBufferRows {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_MaxBufferRows();
public: __property void set_MaxBufferRows(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int MaxBufferRows {
   int get();
   void set (    int value);
}

Property Value

An integer specifying the maximum number of rows to store in the scrollback buffer.

Remarks

The default value is 72, which means by default the Vt control will store a maximum of 72 rows of data that have "scrolled" off the screen. As rows "scroll" off the screen they are added to the scrollback buffer dynamically, BufferRows reports the current number of rows stored in the buffer. Set this property to 0 to disable the scrollback buffer.

See Also

Reference

Vt Class
Vt Members


NationalCharSet Property

[image]
PowerTCP Emulation for .NET
NationalCharSet Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : NationalCharSet Property

Glossary Item Box

Gets or sets the National Replacement Character Set for use in VT220 7-bit or VT320 7-bit emulation modes to display special characters that normally require 8-bit emulation mode.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property NationalCharSet As NationalCharSet
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As NationalCharSet

instance.NationalCharSet = value

value = instance.NationalCharSet
C#
[DefaultValue()]
public NationalCharSet NationalCharSet {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property NationalCharSet get_NationalCharSet();
public: __property void set_NationalCharSet(
   NationalCharSet value
);
C++/CLI
[DefaultValue()]
public:
property NationalCharSet NationalCharSet {
   NationalCharSet get();
   void set (    NationalCharSet value);
}

Property Value

A NationalCharSet value.

Remarks

The default value is NationalCharSet.Ascii.

This property designates which National Replacement Character (NRC) Set should should be used when the NationalCharSetMode property is set to NationalCharSetMode.National.

See Also

Reference

Vt Class
Vt Members


NationalCharSetMode Property

[image]
PowerTCP Emulation for .NET
NationalCharSetMode Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : NationalCharSetMode Property

Glossary Item Box

Indicates whether the National Replacement Character Set specified by the NationalCharSet property or the standard ASCII character set will be used when rendering text.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property NationalCharSetMode As NationalCharSetMode
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As NationalCharSetMode

instance.NationalCharSetMode = value

value = instance.NationalCharSetMode
C#
[DefaultValue()]
public NationalCharSetMode NationalCharSetMode {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property NationalCharSetMode get_NationalCharSetMode();
public: __property void set_NationalCharSetMode(
   NationalCharSetMode value
);
C++/CLI
[DefaultValue()]
public:
property NationalCharSetMode NationalCharSetMode {
   NationalCharSetMode get();
   void set (    NationalCharSetMode value);
}

Property Value

A NationalCharSetMode value.

Remarks

The default value is NationalCharSetMode.MultiNational.

When the value of this property is NationalCharSetMode.Multinational, ASCII will be used to render 7-bit characters and ISO Latin-1 Supplemental will be used to render 8-bit chracters.

When the value of this property is NationalCharSetMode.National, the National Replacement Character Set specified by the NationalCharSet property will be used to render 7-bit characters.

If data is received from the host which causes this property to change, the NationalCharSetModeChanged event is raised.

See Also

Reference

Vt Class
Vt Members


NewLine Property

[image]
PowerTCP Emulation for .NET
NewLine Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : NewLine Property

Glossary Item Box

Gets or sets the end-of-line character sequence to use.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property NewLine As NewLine
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As NewLine

instance.NewLine = value

value = instance.NewLine
C#
[DefaultValue()]
public NewLine NewLine {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property NewLine get_NewLine();
public: __property void set_NewLine(
   NewLine value
);
C++/CLI
[DefaultValue()]
public:
property NewLine NewLine {
   NewLine get();
   void set (    NewLine value);
}

Property Value

A NewLine value. The default value is NewLine.Cr.

Remarks

This property determines if either a single CR or CR/LF combination is used as a line terminator.

If data is received from the host which causes this property to change, the NewLineChanged event is raised.

See Also

Reference

Vt Class
Vt Members


NormalIntensity Property

[image]
PowerTCP Emulation for .NET
NormalIntensity Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : NormalIntensity Property

Glossary Item Box

Gets or sets the "brightness" of normal text.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute(Message="Use the AnsiColor property instead.", IsError=True)>
<DefaultValueAttribute()>
Public Property NormalIntensity As Integer
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Integer

instance.NormalIntensity = value

value = instance.NormalIntensity
C#
[Obsolete(Message="Use the AnsiColor property instead.", IsError=true)]
[DefaultValue()]
public int NormalIntensity {get; set;}
Managed Extensions for C++
[Obsolete(Message="Use the AnsiColor property instead.", IsError=true)]
[DefaultValue()]
public: __property int get_NormalIntensity();
public: __property void set_NormalIntensity(
   int value
);
C++/CLI
[Obsolete(Message="Use the AnsiColor property instead.", IsError=true)]
[DefaultValue()]
public:
property int NormalIntensity {
   int get();
   void set (    int value);
}

Property Value

An integer specifying the "brightness" level. The default value is 75.

Remarks

The valid range is 0 to 100.

See Also

Reference

Vt Class
Vt Members


Padding Property

[image]
PowerTCP Emulation for .NET
Padding Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Padding Property

Glossary Item Box

Gets or sets a Padding object which determines the amount of "buffer" space around the Vt text.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Shadows Property Padding As Padding
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Padding

instance.Padding = value

value = instance.Padding
C#
[DefaultValue()]
public new Padding Padding {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property new Padding get_Padding();
public: __property new void set_Padding(
   Padding value
);
C++/CLI
[DefaultValue()]
public:
new property Padding Padding {
   Padding get();
   void set (    Padding value);
}

Property Value

A System.Windows.Forms.Padding object.

See Also

Reference

Vt Class
Vt Members


Print Property

[image]
PowerTCP Emulation for .NET
Print Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Print Property

Glossary Item Box

Gets or sets a PrintType specifying how printing should occur.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Print As PrintType
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As PrintType

instance.Print = value

value = instance.Print
C#
[DefaultValue()]
public PrintType Print {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property PrintType get_Print();
public: __property void set_Print(
   PrintType value
);
C++/CLI
[DefaultValue()]
public:
property PrintType Print {
   PrintType get();
   void set (    PrintType value);
}

Property Value

A PrintType value. The default value is PrintType.Off.

Remarks

When using the default value of PrintType.Off, printing occurs by explicitly calling the Vt print functions (PrintScreen, Selection.Print, and PrintCursorLine). Set this property to PrintType.Auto or PrintType.Controller to print data automatically as data is received.

If data is received from the host which causes this property to change, the PrintChanged event is raised.

The print font will be the closest available match to the display font.

Unicode character printing is fully supported.

See Also

Reference

Vt Class
Vt Members


Printer Property

[image]
PowerTCP Emulation for .NET
Printer Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Printer Property

Glossary Item Box

Gets or sets a value that indicates name of the printer to be used for printing operations.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Printer As String
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As String

instance.Printer = value

value = instance.Printer
C#
[DefaultValue()]
public string Printer {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property string* get_Printer();
public: __property void set_Printer(
   string* value
);
C++/CLI
[DefaultValue()]
public:
property String^ Printer {
   String^ get();
   void set (    String^ value);
}

Property Value

A string value specifying the name of the printer to be used.

Remarks

The default value is "default", to indicate the default system printer should be used. Set this value to the name of a printer (as displayed in the Printer Common Dialog Box) to specify a printer by name. If this value is set to an empty string, the user will be prompted to select a printer each time a printing operation is started.

See Also

Reference

Vt Class
Vt Members


PrintPassThrough Property

[image]
PowerTCP Emulation for .NET
PrintPassThrough Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : PrintPassThrough Property

Glossary Item Box

Gets or sets whether to bypass printer drivers and write directly to printer when in Controller mode.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property PrintPassThrough As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.PrintPassThrough = value

value = instance.PrintPassThrough
C#
[DefaultValue()]
public bool PrintPassThrough {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property bool get_PrintPassThrough();
public: __property void set_PrintPassThrough(
   bool value
);
C++/CLI
[DefaultValue()]
public:
property bool PrintPassThrough {
   bool get();
   void set (    bool value);
}

Property Value

true if the Vt control should send all bytes to directly to the printer. Useful when controlling the printer via escape sequences is desired. false if the Vt control should use the printer driver to handle printing. The default value is false.

See Also

Reference

Vt Class
Vt Members


RightToLeft Property

[image]
PowerTCP Emulation for .NET
RightToLeft Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : RightToLeft Property

Glossary Item Box

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
Public Shadows Property RightToLeft As RightToLeft
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
public new RightToLeft RightToLeft {get; set;}
Managed Extensions for C++
public: __property new RightToLeft get_RightToLeft();
public: __property new void set_RightToLeft(
   RightToLeft value
);
C++/CLI
public:
new property RightToLeft RightToLeft {
   RightToLeft get();
   void set (    RightToLeft value);
}

See Also

Reference

Vt Class
Vt Members


Rows Property

[image]
PowerTCP Emulation for .NET
Rows Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Rows Property

Glossary Item Box

Gets or sets the number of rows used by the Vt window screen.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Rows As Integer
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Integer

instance.Rows = value

value = instance.Rows
C#
[DefaultValue()]
public int Rows {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property int get_Rows();
public: __property void set_Rows(
   int value
);
C++/CLI
[DefaultValue()]
public:
property int Rows {
   int get();
   void set (    int value);
}

Property Value

An integer.

Remarks

Values from 1 to Int32.MaxValue are supported. Defaults to 24.

If data is received from the host which causes this property to change, the ScreenSizeChanged event is raised.

See Also

Reference

Vt Class
Vt Members


ScrollType Property

[image]
PowerTCP Emulation for .NET
ScrollType Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : ScrollType Property

Glossary Item Box

Gets or sets a value that determines whether to use jump scrolling or smooth scrolling in the display screen.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ScrollType As Scroll
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Scroll

instance.ScrollType = value

value = instance.ScrollType
C#
[DefaultValue()]
public Scroll ScrollType {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property Scroll get_ScrollType();
public: __property void set_ScrollType(
   Scroll value
);
C++/CLI
[DefaultValue()]
public:
property Scroll ScrollType {
   Scroll get();
   void set (    Scroll value);
}

Property Value

A Scroll value. The default value is Scroll.Smooth.

Remarks

Jump scrolling displays new lines as fast as they are received causing lines to jump when data is received at a high rate. Smooth scrolling limits the rate at which new lines appear on the screen resulting in smother data display, even when data is received at a high rate.

If data is received from the host which causes this property to change, the ScrollTypeChanged event is raised.

See Also

Reference

Vt Class
Vt Members


StatusLine Property

[image]
PowerTCP Emulation for .NET
StatusLine Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : StatusLine Property

Glossary Item Box

Gets or sets a string that populates a reverse-video status bar at the bottom of the screen display.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property StatusLine As String
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As String

instance.StatusLine = value

value = instance.StatusLine
C#
[DefaultValue()]
public string StatusLine {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property string* get_StatusLine();
public: __property void set_StatusLine(
   string* value
);
C++/CLI
[DefaultValue()]
public:
property String^ StatusLine {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that sets and returns the text in the status bar. The default value is "" (no status line is displayed.

Remarks

If the TermType property is vt100 or above the using application can set it to any value. Escape sequences can be used to set display attibutes (such as color).

If the TermType property is be vt320_7 or above the host can enable this line and populate it with infomation.

See Also

Reference

Vt Class
Vt Members


Tabs Property

[image]
PowerTCP Emulation for .NET
Tabs Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Tabs Property

Glossary Item Box

Gets or sets a list of comma-delimited tab positions.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Tabs As String
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As String

instance.Tabs = value

value = instance.Tabs
C#
[DefaultValue()]
public string Tabs {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property string* get_Tabs();
public: __property void set_Tabs(
   string* value
);
C++/CLI
[DefaultValue()]
public:
property String^ Tabs {
   String^ get();
   void set (    String^ value);
}

Property Value

A string containing the comma-delimited tab positions. The default value is "7,15,23,31,39,47,55,63,71,79,87,95,103,111,119,127".

Remarks

If data is received from the host which causes this property to change, the TabsChanged event is raised.

See Also

Reference

Vt Class
Vt Members


TerminalType Property

[image]
PowerTCP Emulation for .NET
TerminalType Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : TerminalType Property

Glossary Item Box

Gets or sets the terminal type to emulate.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TerminalType As TerminalType
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As TerminalType

instance.TerminalType = value

value = instance.TerminalType
C#
[DefaultValue()]
public TerminalType TerminalType {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property TerminalType get_TerminalType();
public: __property void set_TerminalType(
   TerminalType value
);
C++/CLI
[DefaultValue()]
public:
property TerminalType TerminalType {
   TerminalType get();
   void set (    TerminalType value);
}

Property Value

A TerminalType value. The default value is TerminalType.Vt370_7.

Remarks

Escape sequences are interpreted using the terminal type specified in this property.

If data is received from the host which causes this property to change, the TerminalTypeChanged event is raised.

See Also

Reference

Vt Class
Vt Members


TextRenderingHint Property

[image]
PowerTCP Emulation for .NET
TextRenderingHint Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : TextRenderingHint Property

Glossary Item Box

Gets or sets the TextRenderingHint that the VT component will use to render glyphs.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TextRenderingHint As TextRenderingHint
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As TextRenderingHint

instance.TextRenderingHint = value

value = instance.TextRenderingHint
C#
[DefaultValue()]
public TextRenderingHint TextRenderingHint {get; set;}
Managed Extensions for C++
[DefaultValue()]
public: __property TextRenderingHint get_TextRenderingHint();
public: __property void set_TextRenderingHint(
   TextRenderingHint value
);
C++/CLI
[DefaultValue()]
public:
property TextRenderingHint TextRenderingHint {
   TextRenderingHint get();
   void set (    TextRenderingHint value);
}

Property Value

A System.Drawing.Text.TextRenderingHint value. The default value is System.Drawing.Text.TextRenderingHint.ClearTypeGridFit.

Remarks

This property effects the quality of the glyphs rendered. Speed and performance are increased as quality is decreased.

>

See Also

Reference

Vt Class
Vt Members


UseWaitCursor Property

[image]
PowerTCP Emulation for .NET
UseWaitCursor Property
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : UseWaitCursor Property

Glossary Item Box

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Declaration)
Public Shadows Property UseWaitCursor As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
public new bool UseWaitCursor {get; set;}
Managed Extensions for C++
public: __property new bool get_UseWaitCursor();
public: __property new void set_UseWaitCursor(
   bool value
);
C++/CLI
public:
new property bool UseWaitCursor {
   bool get();
   void set (    bool value);
}

See Also

Reference

Vt Class
Vt Members


Vt Class Fields

[image]
PowerTCP Emulation for .NET
Vt Class Fields
See Also Send comments on this topic
Dart.Emulation Namespace : Vt Class

Glossary Item Box

For a list of all members of this type, see Vt members.

Public Fields

 | Name | Description
Public Field | Selection | Gets a Selection instance that is used to control the display of selected cells as well as getting the text and attributes of those cells.
Top

See Also

Reference

Vt Class
Dart.Emulation Namespace


Selection Field

[image]
PowerTCP Emulation for .NET
Selection Field
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Selection Field

Glossary Item Box

Gets a Selection instance that is used to control the display of selected cells as well as getting the text and attributes of those cells.

Syntax

Visual Basic (Declaration)
Public ReadOnly Selection As Selection
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim value As Selection

value = instance.Selection
C#
public readonly Selection Selection
Managed Extensions for C++
public: readonly Selection* Selection
C++/CLI
public:
readonly Selection^ Selection

See Also

Reference

Vt Class
Vt Members


Vt Class Events

[image]
PowerTCP Emulation for .NET
Vt Class Events
See Also Send comments on this topic
Dart.Emulation Namespace : Vt Class

Glossary Item Box

For a list of all members of this type, see Vt members.

Public Events

 | Name | Description
Public Event | AutoRepeatChanged | Raised when the host sends an instruction which changes the value of the AutoRepeat property.
Public Event | AutoWrapChanged | Raised when the host sends an instruction which changes the value of the AutoWrap property.
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CursorKeysChanged | Raised when the host sends an instruction which changes the value of the CursorKeys property.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Error | Raised when there is an exception while reading from, or writing to, the Stream passed to SetStream(Stream).
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | InverseChanged | Raised when the host sends an instruction which changes the value of the Inverse property.
Public Event | KeyDown | Raised when the user presses a key.
Public Event | KeyPadChanged | Raised when the host sends an instruction which changes the value of the KeyPad property.
Public Event | KeyPress | Raised when the user presses a key.
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Line | Raised when the cursor in the VT changes rows as the result of a new line.
Public Event | LocalEchoChanged | Raised when the host sends an instruction which changes the value of the LocalEcho property.
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Log | Raised when data is read or written.
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | NationalCharSetModeChanged | Raised when the host sends an instruction which changes the value of the NationalCharSetMode property.
Public Event | NewLineChanged | Raised when the host sends an instruction which changes the value of the NewLine property.
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | PrintChanged | Raised when the host sends an instruction which changes the value of the Print property.
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ScreenSizeChanged | Raised when the host sends an instruction which changes the value of the Columns property.
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | ScrollTypeChanged | Raised when the host sends an instruction which changes the value of the ScrollType property.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabsChanged | Raised when the host sends an instruction which changes the value of the Tabs property.
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TerminalTypeChanged | Raised when the host sends an instruction which changes the value of the TerminalType property.
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

Vt Class
Dart.Emulation Namespace


AutoRepeatChanged Event

[image]
PowerTCP Emulation for .NET
AutoRepeatChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AutoRepeatChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the AutoRepeat property.

Syntax

Visual Basic (Declaration)
Public Event AutoRepeatChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.AutoRepeatChanged, handler
C#
public event EventHandler AutoRepeatChanged
Managed Extensions for C++
public: __event EventHandler* AutoRepeatChanged
C++/CLI
public:
event EventHandler^ AutoRepeatChanged

Remarks

When the Vt control receives an instruction to change the value of the AutoRepeat property, the Vt control first changes the value of this property, then raises the AutoRepeatChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


AutoWrapChanged Event

[image]
PowerTCP Emulation for .NET
AutoWrapChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : AutoWrapChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the AutoWrap property.

Syntax

Visual Basic (Declaration)
Public Event AutoWrapChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.AutoWrapChanged, handler
C#
public event EventHandler AutoWrapChanged
Managed Extensions for C++
public: __event EventHandler* AutoWrapChanged
C++/CLI
public:
event EventHandler^ AutoWrapChanged

Remarks

When the Vt control receives an instruction to change the value of the AutoWrap property, the Vt control first changes the value of this property, then raises the AutoWrapChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


CursorKeysChanged Event

[image]
PowerTCP Emulation for .NET
CursorKeysChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : CursorKeysChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the CursorKeys property.

Syntax

Visual Basic (Declaration)
Public Event CursorKeysChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.CursorKeysChanged, handler
C#
public event EventHandler CursorKeysChanged
Managed Extensions for C++
public: __event EventHandler* CursorKeysChanged
C++/CLI
public:
event EventHandler^ CursorKeysChanged

Remarks

When the Vt control receives an instruction to change the value of the CursorKeys property, the Vt control first changes the value of this property, then raises the CursorKeysChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


Error Event

[image]
PowerTCP Emulation for .NET
Error Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Error Event

Glossary Item Box

Raised when there is an exception while reading from, or writing to, the Stream passed to SetStream(Stream).

Syntax

Visual Basic (Declaration)
Public Event Error As EventHandler(Of ErrorEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler(Of ErrorEventArgs)

AddHandler instance.Error, handler
C#
public event EventHandler<ErrorEventArgs> Error
Managed Extensions for C++
public: __event EventHandler<ErrorEventArgs*>* Error
C++/CLI
public:
event EventHandler<ErrorEventArgs^>^ Error

See Also

Reference

Vt Class
Vt Members


InverseChanged Event

[image]
PowerTCP Emulation for .NET
InverseChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : InverseChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the Inverse property.

Syntax

Visual Basic (Declaration)
Public Event InverseChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.InverseChanged, handler
C#
public event EventHandler InverseChanged
Managed Extensions for C++
public: __event EventHandler* InverseChanged
C++/CLI
public:
event EventHandler^ InverseChanged

Remarks

When the Vt control receives an instruction to change the value of the Inverse property, the Vt control first changes the value of this property, then raises the InverseChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


KeyDown Event

[image]
PowerTCP Emulation for .NET
KeyDown Event
See Also Example Send comments on this topic
Dart.Emulation Namespace > Vt Class : KeyDown Event

Glossary Item Box

Raised when the user presses a key.

Syntax

Visual Basic (Declaration)
Public Shadows Event KeyDown As EventHandler(Of VtKeyEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler(Of VtKeyEventArgs)

AddHandler instance.KeyDown, handler
C#
public new event EventHandler<VtKeyEventArgs> KeyDown
Managed Extensions for C++
public: new __event EventHandler<VtKeyEventArgs*>* KeyDown
C++/CLI
public:
new event EventHandler<VtKeyEventArgs^>^ KeyDown

Event Data

The event handler receives an argument of type VtKeyEventArgs containing data related to this event. The following VtKeyEventArgs properties provide information specific to this event.

Property | Description
Alt | (Inherited from System.Windows.Forms.KeyEventArgs)
Control | (Inherited from System.Windows.Forms.KeyEventArgs)
Extended | Returns true when the generating key is on an extended part of the keyboard.
Handled | (Inherited from System.Windows.Forms.KeyEventArgs)
KeyCode | (Inherited from System.Windows.Forms.KeyEventArgs)
KeyData | (Inherited from System.Windows.Forms.KeyEventArgs)
KeyValue | (Inherited from System.Windows.Forms.KeyEventArgs)
Modifiers | (Inherited from System.Windows.Forms.KeyEventArgs)
Shift | (Inherited from System.Windows.Forms.KeyEventArgs)
SuppressKeyPress | (Inherited from System.Windows.Forms.KeyEventArgs)

Remarks

The KeyDown event is raised when a key is pressed and before the KeyPress event is raised. This event is useful for performing keymapping (mapping individual keys to any arbitrary character sequence). To do this, simply set e.Handled to true (notifying the Vt control that the key down was handled so the Vt control does not raise the KeyPress event) and send your own substituted character sequence.

Example

In the following example, the string "Hello World!" is mapped to Ctrl-H.
C# Copy Code
private void vt1_KeyDown(object sender, Dart.Emulation.VtKeyEventArgs e)
{
    //If there is a telnet connection
    if (telnet1.State != ConnectionState.Closed)
    {
        //Send substitute string when Control-H pressed
        if (e.Control && e.KeyCode == Keys.H)
        {
            e.Handled = true; //prevent other key events
            telnet1.Write("Hello World!");
        }
    }
}
Visual Basic Copy Code
Private Sub vt1_KeyDown(ByVal sender As Object, ByVal e As Dart.Emulation.VtKeyEventArgs)
    'If there is a telnet connection
    If telnet1.State <> ConnectionState.Closed Then
        'Send substitute string when Control-H pressed
        If e.Control AndAlso e.KeyCode = Keys.H Then
            e.Handled = True 'prevent other key events
            telnet1.Write("Hello World!")
        End If
    End If
End Sub

See Also

Reference

Vt Class
Vt Members


KeyPadChanged Event

[image]
PowerTCP Emulation for .NET
KeyPadChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : KeyPadChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the KeyPad property.

Syntax

Visual Basic (Declaration)
Public Event KeyPadChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.KeyPadChanged, handler
C#
public event EventHandler KeyPadChanged
Managed Extensions for C++
public: __event EventHandler* KeyPadChanged
C++/CLI
public:
event EventHandler^ KeyPadChanged

Remarks

When the Vt control receives an instruction to change the value of the KeyPad property, the Vt control first changes the value of this property, then raises the KeyPadChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


KeyPress Event

[image]
PowerTCP Emulation for .NET
KeyPress Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : KeyPress Event

Glossary Item Box

Raised when the user presses a key.

Syntax

Visual Basic (Declaration)
Public Shadows Event KeyPress As EventHandler(Of KeyPressEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler(Of KeyPressEventArgs)

AddHandler instance.KeyPress, handler
C#
public new event EventHandler<KeyPressEventArgs> KeyPress
Managed Extensions for C++
public: new __event EventHandler<KeyPressEventArgs*>* KeyPress
C++/CLI
public:
new event EventHandler<KeyPressEventArgs^>^ KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Bytes | Returns the data that was generated as the result of a key press.

Remarks

The KeyPress event is raised when a key is pressed after the KeyDown event is raised. Within this event it is possible for a keypress to generate multiple bytes. ASCII characters are normally presented as a single byte, whereas function keys and others may generate byte arrays of greater length.

See Also

Reference

Vt Class
Vt Members


Line Event

[image]
PowerTCP Emulation for .NET
Line Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Line Event

Glossary Item Box

Raised when the cursor in the VT changes rows as the result of a new line.

Syntax

Visual Basic (Declaration)
Public Event Line As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.Line, handler
C#
public event EventHandler Line
Managed Extensions for C++
public: __event EventHandler* Line
C++/CLI
public:
event EventHandler^ Line

Remarks

This event is useful for taking some action (such as capturing data to a file) for each new line displayed on the VT window.

See Also

Reference

Vt Class
Vt Members


LocalEchoChanged Event

[image]
PowerTCP Emulation for .NET
LocalEchoChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : LocalEchoChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the LocalEcho property.

Syntax

Visual Basic (Declaration)
Public Event LocalEchoChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.LocalEchoChanged, handler
C#
public event EventHandler LocalEchoChanged
Managed Extensions for C++
public: __event EventHandler* LocalEchoChanged
C++/CLI
public:
event EventHandler^ LocalEchoChanged

Remarks

When the Vt control receives an instruction to change the value of the LocalEcho property, the Vt control first changes the value of this property, then raises the LocalEchoChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


Log Event

[image]
PowerTCP Emulation for .NET
Log Event
See Also Example Send comments on this topic
Dart.Emulation Namespace > Vt Class : Log Event

Glossary Item Box

Raised when data is read or written.

Syntax

Visual Basic (Declaration)
Public Event Log As EventHandler(Of DataEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler(Of DataEventArgs)

AddHandler instance.Log, handler
C#
public event EventHandler<DataEventArgs> Log
Managed Extensions for C++
public: __event EventHandler<DataEventArgs*>* Log
C++/CLI
public:
event EventHandler<DataEventArgs^>^ Log

Event Data

The event handler receives an argument of type DataEventArgs containing data related to this event. The following DataEventArgs properties provide information specific to this event.

Property | Description
Data | Gets data provided by Data and Log events.
Message | Returns the message argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)
UserState | Returns the user state argument provided by the Marshal method. (Inherited from Dart.Emulation.UserStateEventArgs)

Remarks

The handler must be added before connecting. See the SynchronizingObject property for information on updating UI controls in your event handler.

Example

This example demonstrates logging sent and received data to a textbox.
C# Copy Code
private void myComponent_Log(object sender, DataEventArgs e)
{
    string prompt = (e.Data.Direction == DataDirection.In) ? "Recv: " : "Sent: ";
    textBox1.AppendText(prompt + e.Data.ToString() + Environment.NewLine);
}
Visual Basic Copy Code
Private Sub myComponent_Log(ByVal sender As Object, ByVal e As DataEventArgs)
    Dim prompt As String = If(e.Data.Direction = DataDirection.In, "Recv: ", "Sent: ")
    textBox1.AppendText(prompt & e.Data.ToString() & Environment.NewLine)
End Sub

See Also

Reference

Vt Class
Vt Members


NationalCharSetModeChanged Event

[image]
PowerTCP Emulation for .NET
NationalCharSetModeChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : NationalCharSetModeChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the NationalCharSetMode property.

Syntax

Visual Basic (Declaration)
Public Event NationalCharSetModeChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.NationalCharSetModeChanged, handler
C#
public event EventHandler NationalCharSetModeChanged
Managed Extensions for C++
public: __event EventHandler* NationalCharSetModeChanged
C++/CLI
public:
event EventHandler^ NationalCharSetModeChanged

Remarks

When the Vt control receives an instruction to change the value of the NationalCharSetMode property, the Vt control first changes its value, then raises the NationalCharSetModeChanged event. To override this change, implement this event and set the property to the desired value when the event is raised.

See Also

Reference

Vt Class
Vt Members


NewLineChanged Event

[image]
PowerTCP Emulation for .NET
NewLineChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : NewLineChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the NewLine property.

Syntax

Visual Basic (Declaration)
Public Event NewLineChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.NewLineChanged, handler
C#
public event EventHandler NewLineChanged
Managed Extensions for C++
public: __event EventHandler* NewLineChanged
C++/CLI
public:
event EventHandler^ NewLineChanged

Remarks

When the Vt control receives an instruction to change the value of the NewLine property, the Vt control first changes the value of this property, then raises the NewLineChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


PrintChanged Event

[image]
PowerTCP Emulation for .NET
PrintChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : PrintChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the Print property.

Syntax

Visual Basic (Declaration)
Public Event PrintChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.PrintChanged, handler
C#
public event EventHandler PrintChanged
Managed Extensions for C++
public: __event EventHandler* PrintChanged
C++/CLI
public:
event EventHandler^ PrintChanged

Remarks

When the Vt control receives an instruction to change the value of the Print property, the Vt control first changes the value of this property, then raises the PrintChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


ScreenSizeChanged Event

[image]
PowerTCP Emulation for .NET
ScreenSizeChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : ScreenSizeChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the Columns property.

Syntax

Visual Basic (Declaration)
Public Event ScreenSizeChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.ScreenSizeChanged, handler
C#
public event EventHandler ScreenSizeChanged
Managed Extensions for C++
public: __event EventHandler* ScreenSizeChanged
C++/CLI
public:
event EventHandler^ ScreenSizeChanged

Remarks

When the Vt control receives an instruction to change the value of the Rows or Columns, the Vt control first changes the value of this property, then raises the ScreenSizeChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


ScrollTypeChanged Event

[image]
PowerTCP Emulation for .NET
ScrollTypeChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : ScrollTypeChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the ScrollType property.

Syntax

Visual Basic (Declaration)
Public Event ScrollTypeChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.ScrollTypeChanged, handler
C#
public event EventHandler ScrollTypeChanged
Managed Extensions for C++
public: __event EventHandler* ScrollTypeChanged
C++/CLI
public:
event EventHandler^ ScrollTypeChanged

Remarks

When the Vt control receives an instruction to change the value of the ScrollType property, the Vt control first changes the value of this property, then raises the ScrollTypeChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


TabsChanged Event

[image]
PowerTCP Emulation for .NET
TabsChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : TabsChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the Tabs property.

Syntax

Visual Basic (Declaration)
Public Event TabsChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.TabsChanged, handler
C#
public event EventHandler TabsChanged
Managed Extensions for C++
public: __event EventHandler* TabsChanged
C++/CLI
public:
event EventHandler^ TabsChanged

Remarks

When the Vt control receives an instruction to change the value of the Tabs property, the Vt control first changes the value of this property, then raises the TabsChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


TerminalTypeChanged Event

[image]
PowerTCP Emulation for .NET
TerminalTypeChanged Event
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : TerminalTypeChanged Event

Glossary Item Box

Raised when the host sends an instruction which changes the value of the TerminalType property.

Syntax

Visual Basic (Declaration)
Public Event TerminalTypeChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Vt
Dim handler As EventHandler

AddHandler instance.TerminalTypeChanged, handler
C#
public event EventHandler TerminalTypeChanged
Managed Extensions for C++
public: __event EventHandler* TerminalTypeChanged
C++/CLI
public:
event EventHandler^ TerminalTypeChanged

Remarks

When the Vt control receives an instruction to change the value of the TerminalType property, the Vt control first changes the value of this property, then raises the TerminalTypeChanged event. To override this change, simply implement this event and set the property when the event is raised.

See Also

Reference

Vt Class
Vt Members


VtKeyEventArgs Class

[image]
PowerTCP Emulation for .NET
VtKeyEventArgs Class
Members See Also Send comments on this topic
Dart.Emulation Namespace : VtKeyEventArgs Class

Glossary Item Box

Provides data for the KeyDown event.

Object Model

VtKeyEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class VtKeyEventArgs
   Inherits System.Windows.Forms.KeyEventArgs
Visual Basic (Usage) Copy Code
Dim instance As VtKeyEventArgs
C#
public class VtKeyEventArgs : System.Windows.Forms.KeyEventArgs
Managed Extensions for C++
public __gc class VtKeyEventArgs : public System.Windows.Forms.KeyEventArgs
C++/CLI
public ref class VtKeyEventArgs : public System.Windows.Forms.KeyEventArgs

Remarks

VtKeyEventArgs extends KeyEventArgs to include an Extended property.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.KeyEventArgs
Dart.Emulation.VtKeyEventArgs

See Also

Reference

VtKeyEventArgs Members
Dart.Emulation Namespace


VtKeyEventArgs Class Members

[image]
PowerTCP Emulation for .NET
VtKeyEventArgs Class Members
See Also Properties Send comments on this topic
Dart.Emulation Namespace : VtKeyEventArgs Class

Glossary Item Box

The following tables list the members exposed by VtKeyEventArgs.

Public Constructors

 | Name | Description
Public Constructor | VtKeyEventArgs Constructor | Initializes a new instance of VtKeyEventArgs.
Top

Public Properties

 | Name | Description
Public Property | Alt | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | Control | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | Extended | Returns true when the generating key is on an extended part of the keyboard.
Public Property | Handled | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | KeyCode | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | KeyData | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | KeyValue | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | Modifiers | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | Shift | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | SuppressKeyPress | (Inherited from System.Windows.Forms.KeyEventArgs)
Top

See Also

Reference

VtKeyEventArgs Class
Dart.Emulation Namespace


VtKeyEventArgs Constructor

[image]
PowerTCP Emulation for .NET
VtKeyEventArgs Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > VtKeyEventArgs Class : VtKeyEventArgs Constructor

ex
Indicates whether the key is part of the extended keyboard.
keyData
Data for the pressed key.

Glossary Item Box

Initializes a new instance of VtKeyEventArgs.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ex As Boolean, _
   ByVal keyData As Keys _
)
Visual Basic (Usage) Copy Code
Dim ex As Boolean
Dim keyData As Keys

Dim instance As New VtKeyEventArgs(ex, keyData)
C#
public VtKeyEventArgs(
   bool ex,
   Keys keyData
)
Managed Extensions for C++
public: VtKeyEventArgs(
   bool ex,
   Keys keyData
)
C++/CLI
public:
VtKeyEventArgs(
   bool ex,
   Keys keyData
)

Parameters

ex
Indicates whether the key is part of the extended keyboard.
keyData
Data for the pressed key.

See Also

Reference

VtKeyEventArgs Class
VtKeyEventArgs Members


VtKeyEventArgs Class Properties

[image]
PowerTCP Emulation for .NET
VtKeyEventArgs Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : VtKeyEventArgs Class

Glossary Item Box

For a list of all members of this type, see VtKeyEventArgs members.

Public Properties

 | Name | Description
Public Property | Alt | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | Control | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | Extended | Returns true when the generating key is on an extended part of the keyboard.
Public Property | Handled | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | KeyCode | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | KeyData | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | KeyValue | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | Modifiers | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | Shift | (Inherited from System.Windows.Forms.KeyEventArgs)
Public Property | SuppressKeyPress | (Inherited from System.Windows.Forms.KeyEventArgs)
Top

See Also

Reference

VtKeyEventArgs Class
Dart.Emulation Namespace


Extended Property

[image]
PowerTCP Emulation for .NET
Extended Property
See Also Send comments on this topic
Dart.Emulation Namespace > VtKeyEventArgs Class : Extended Property

Glossary Item Box

Returns true when the generating key is on an extended part of the keyboard.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Extended As Boolean
Visual Basic (Usage) Copy Code
Dim instance As VtKeyEventArgs
Dim value As Boolean

value = instance.Extended
C#
public bool Extended {get;}
Managed Extensions for C++
public: __property bool get_Extended();
C++/CLI
public:
property bool Extended {
   bool get();
}

See Also

Reference

VtKeyEventArgs Class
VtKeyEventArgs Members


AnsiColor.AnsiStyle Enumeration

[image]
PowerTCP Emulation for .NET
AnsiColor.AnsiStyle Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : AnsiColor.AnsiStyle Enumeration

Glossary Item Box

Enumeration of ANSI color schemes used by popular applications.

Syntax

Visual Basic (Declaration)
Public Enum AnsiColor.AnsiStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AnsiColor.AnsiStyle
C#
public enum AnsiColor.AnsiStyle : System.Enum
Managed Extensions for C++
__value public enum AnsiColor.AnsiStyle : public System.Enum
C++/CLI
public enum class AnsiColor.AnsiStyle : public System.Enum

Members

Member | Description
Custom | Value when all colors do not match the colors of any of the other enumerated values.
Default | XBold (bright) colors are full intensity RGB and normal colors are 75% intensity of their corresponding bold colors.
Html | Standard colors used in web pages.
Microsoft | Colors used by Microsoft command-line Telnet.
Putty | Colors used by the PuTTY emulator.
Vga | Standard VGA colors.
X11 | Standard colors used by X Window System version 11.
Xterm | Colors used by the X Windows emulator.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.AnsiColor.AnsiStyle

See Also

Reference

Dart.Emulation Namespace


Command Enumeration

[image]
PowerTCP Emulation for .NET
Command Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : Command Enumeration

Glossary Item Box

Enumerates the TELNET protocol commands that can be sent.

Syntax

Visual Basic (Declaration)
Public Enum Command
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Command
C#
public enum Command : System.Enum
Managed Extensions for C++
__value public enum Command : public System.Enum
C++/CLI
public enum class Command : public System.Enum

Members

Member | Description
AO | 245 Abort output. Invokes a function on the recipient to stop sending output data while continuing the current process.
Ayt | 246 Are you there. Invokes a function on the recipient to provide printable evidence that it is still up and running.
Brk | 243 Break. Indicates the "Break" key on the recipient host was hit.
DM | 242 Data stream portion of a Synch. If the sender is sending Urgent data, this notifies the recipient to resume normal processing.
Do | 253 Used during option negotiation. Indicates the request that the other party perform, or confirmation that you are expecting the other party to perform, the indicated option.
Dont | 254 Used during option negotiation. Indicates the demand that the other party stop performing, or confirmation that you are no longer expecting the other party to perform, the indicated option.
EC | 247 Erase character. Invokes a function on the recipient to "delete" the preceding undeleted character from the incoming stream of data.
EL | 248 Erase line. Invokes a function on the recipient to "delete" the preceding undeleted line from the incoming stream of data.
GA | 249 Go ahead. Typically is suppressed.
Iac | 255 Interpret As Command byte (255). Tells the recipient to interpret the next byte as a command.
IP | 244 Interrupt process. Invokes a function on the recipient to suspend, interrupt, abort, or terminate a user process.
Nop | 241 No operation.
SB | 250 Used during option negotiation to establish/provide data for a suboption. Indicates what follows is subnegotiation of the indicated option.
SE | 240 Marks the end of subnegotiation parameters.
Will | 251 Used during option negotiation. Indicates the desire to begin performing, or confirmation that you are now performing, the indicated option.
Wont | 252 Used during option negotiation. Indicates the refusal to perform, or continue performing, the indicated option.

Remarks

The Telnet protocol uses "in-band" signaling to send commands. A special byte, the Interpret As Command (Iac) byte, is sent to instruct the receiver to interpret the next byte as a command. Telnet commands can fall under several categories. Some commands are used solely during option negotiation (DO, DONT, WILL, WONT) to help establish options that both client and server will use. Other commands represent control functions (Ayt, Brk, Nop, etc) used to emit a particular response from the server.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.Command

See Also

Reference

Dart.Emulation Namespace


ConnectionState Enumeration

[image]
PowerTCP Emulation for .NET
ConnectionState Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : ConnectionState Enumeration

Glossary Item Box

Enumerates the possible values of the connection state.

Syntax

Visual Basic (Declaration)
Public Enum ConnectionState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ConnectionState
C#
public enum ConnectionState : System.Enum
Managed Extensions for C++
__value public enum ConnectionState : public System.Enum
C++/CLI
public enum class ConnectionState : public System.Enum

Members

Member | Description
Closed | The connection is closed.
Connected | The TCP connection is established but not secure.
ConnectedAndSecure | The connection is connected and secure.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.ConnectionState

See Also

Reference

Dart.Emulation Namespace


CursorKeys Enumeration

[image]
PowerTCP Emulation for .NET
CursorKeys Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : CursorKeys Enumeration

Glossary Item Box

Enumerates the values of the CursorKeys property. The cursor keys can be set up to provide ANSI cursor control or application control.

Syntax

Visual Basic (Declaration)
Public Enum CursorKeys
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CursorKeys
C#
public enum CursorKeys : System.Enum
Managed Extensions for C++
__value public enum CursorKeys : public System.Enum
C++/CLI
public enum class CursorKeys : public System.Enum

Members

Member | Description
Application | Cursor keys generate application control sequences.
Normal | Cursor keys generate ANSI cursor control sequences to represent Up, Down, Left, and Right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.CursorKeys

See Also

Reference

Dart.Emulation Namespace


CursorStyle Enumeration

[image]
PowerTCP Emulation for .NET
CursorStyle Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : CursorStyle Enumeration

Glossary Item Box

Enumerates the values of the CursorStyle property.

Syntax

Visual Basic (Declaration)
Public Enum CursorStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CursorStyle
C#
public enum CursorStyle : System.Enum
Managed Extensions for C++
__value public enum CursorStyle : public System.Enum
C++/CLI
public enum class CursorStyle : public System.Enum

Members

Member | Description
Bar | Use a vertical line cursor.
Block | Use a cursor that covers the entire cell block.
Invisible | Don't show any cursor.
Underline | Use an underline cursor.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.CursorStyle

See Also

Reference

Dart.Emulation Namespace


DataDirection Enumeration

[image]
PowerTCP Emulation for .NET
DataDirection Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : DataDirection Enumeration

Glossary Item Box

Enumerates the direction of data flow.

Syntax

Visual Basic (Declaration)
Public Enum DataDirection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DataDirection
C#
public enum DataDirection : System.Enum
Managed Extensions for C++
__value public enum DataDirection : public System.Enum
C++/CLI
public enum class DataDirection : public System.Enum

Members

Member | Description
In | Data was received (using the Read method).
Out | Data was sent (using the Write method).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.DataDirection

See Also

Reference

Dart.Emulation Namespace


KeyPad Enumeration

[image]
PowerTCP Emulation for .NET
KeyPad Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : KeyPad Enumeration

Glossary Item Box

Enumerates the values of the KeyPad property. The keypad can generate numeric values or application-specific values.

Syntax

Visual Basic (Declaration)
Public Enum KeyPad
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As KeyPad
C#
public enum KeyPad : System.Enum
Managed Extensions for C++
__value public enum KeyPad : public System.Enum
C++/CLI
public enum class KeyPad : public System.Enum

Members

Member | Description
Application | Keypad keys generate application specific values.
Numeric | Keypad keys generate numeric values.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.KeyPad

See Also

Reference

Dart.Emulation Namespace


NationalCharSet Enumeration

[image]
PowerTCP Emulation for .NET
NationalCharSet Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : NationalCharSet Enumeration

Glossary Item Box

Enumerates the National Replacement Character Sets available for use by the Vt.NationalCharSet property.

Syntax

Visual Basic (Declaration)
Public Enum NationalCharSet
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NationalCharSet
C#
public enum NationalCharSet : System.Enum
Managed Extensions for C++
__value public enum NationalCharSet : public System.Enum
C++/CLI
public enum class NationalCharSet : public System.Enum

Members

Member | Description
Ascii | ASCII mode (Multinational mode even if NationalCharSetMode is set to National).
British | British character set.
Dutch | Dutch character set.
Finnish | Finnish character set.
French | French character set.
FrenchCanadian | French Canadian character set.
German | German character set.
Italian | Italian character set.
NorwegianDanish | Norwegian Danish character set.
Portuguese | Portuguese character set.
Spanish | Spanish character set.
Swedish | Swedish character set.
Swiss | Swiss character set.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.NationalCharSet

See Also

Reference

Dart.Emulation Namespace


NationalCharSetMode Enumeration

[image]
PowerTCP Emulation for .NET
NationalCharSetMode Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : NationalCharSetMode Enumeration

Glossary Item Box

Enumerates the modes available for the Vt.NationalCharSetMode property.

Syntax

Visual Basic (Declaration)
Public Enum NationalCharSetMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NationalCharSetMode
C#
public enum NationalCharSetMode : System.Enum
Managed Extensions for C++
__value public enum NationalCharSetMode : public System.Enum
C++/CLI
public enum class NationalCharSetMode : public System.Enum

Members

Member | Description
Multinational | The standard ASCII character set will be used when rendering text.
National | The character set from the NationalCharSet property will be used when rendering text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.NationalCharSetMode

See Also

Reference

Dart.Emulation Namespace


NewLine Enumeration

[image]
PowerTCP Emulation for .NET
NewLine Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : NewLine Enumeration

Glossary Item Box

Enumerates the end-of-line sequences sent to the host in response to an EOL character (ENTER key). Used by the NewLine property.

Syntax

Visual Basic (Declaration)
Public Enum NewLine
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NewLine
C#
public enum NewLine : System.Enum
Managed Extensions for C++
__value public enum NewLine : public System.Enum
C++/CLI
public enum class NewLine : public System.Enum

Members

Member | Description
Cr | CR only (ASCII 13).
CrLf | CR/LF combination (ASCII 13 and ASCII 10).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.NewLine

See Also

Reference

Dart.Emulation Namespace


OptionCode Enumeration

[image]
PowerTCP Emulation for .NET
OptionCode Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : OptionCode Enumeration

Glossary Item Box

Enumerates the supported Telnet options.

Syntax

Visual Basic (Declaration)
Public Enum OptionCode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As OptionCode
C#
public enum OptionCode : System.Enum
Managed Extensions for C++
__value public enum OptionCode : public System.Enum
C++/CLI
public enum class OptionCode : public System.Enum

Members

Member | Description
ApproxMessageSize | 4 Approx Message Size Negotiation option.
Authentication | 37 Authentication option. Used to request or confirm that the host is willing to send authentication information. See RFC 1416, RFC 2941, RFC 2942, RFC 2943, and RFC 2951 for more information.
ByteMacro | 19 Byte-Macro option. Used to request or confirm that macro bytes may be used in place of certain strings. See RFC 735 for more information.
CharacterSet | 42 CHARSET option. Used to request or confirm that character set information can be passed between hosts. See RFC 2066 for more information.
ComPort | 44 Com Port Control option. See RFC 2217 for more information.
DataEntryTerminal | 20 Data Entry Terminal option. Used to request or agree to send or receive commands to control the Data Entry Terminal. See RFC 732 or RFC 1043 for more information.
Echo | 1 ECHO option. Used to request or confirm that characters received are echoed back to the NVT. See RFC 857 for more information.
EncryptionOption | 38 Data Encryption option. Used to request or confirm that the host is willing to send/receive encrypted data. See RFC 2946 for more information.
EndOfRecord | 25 END-OF-RECORD option. Used to request or confirm that the EOR character can be used when sending data to delimit blocks of data or records. See RFC 885 for more information.
Environment | 36 Environment option. Used to request or confirm that environment information can be passed between hosts. See RFC 1408 for more information.
ExtendedAscii | 17 EXTENDED-ASCII option. Used to request or confirm that extended ASCII may be transmitted. See RFC 698 for more information.
ExtendedOptionsList | 255 EXOPL, Extended-Options-List option.
ForwardX | 49 FORWARD_X option.
Kermit | 47 Kermit option. Used to request or confirm the communication can use the Kermit protocol. See RFC 2840 for more information.
LineMode | 34 Linemode option. Used to request or confirm that linemode is used. See RFC 1184 for more information.
Logout | 18 LOGOUT option. Used to request or confirm that the other client is forcibly logged off at the end. See RFC 727 for more information.
NewEnvironment | 39 Environment option. Used to request or confirm that environment information can be passed between hosts. See RFC 1572 for more information.
None | -1 No option specified.
OutputCarriageReturnDisp | 10 Negotiate About Output Carriage-Return Disposition option. See RFC 652 for more information.
OutputFormfeedDisp | 13 Negotiate About Output Formfeed Disposition option. See RFC 655 for more information.
OutputHorizontalTabDisp | 12 Negotiate About Output Horizontal Tab Disposition option. See RFC 654 for more information.
OutputHorizontalTabstops | 11 Negotiate About Output Horizontal Tabstops option. See RFC 653 for more information.
OutputLinefeedDisp | 16 Negotiate About Output Linefeed Disposition option. See RFC 658 for more information.
OutputLineWidth | 8 Output Line Width option.
OutputMarking | 27 Output Marking Telnet option. Designed to allow a Server to send a banner to a User so that this banner would be displayed on the screen independently of the application software running in the Server. See RFC 933 for more information.
OutputPageSize | 9 Output Page Size option.
OutputVerticalTabDisp | 15 Negotiate About Output Vertical Tab Disposition option. See RFC 657 for more information.
OutputVerticalTabstops | 14 Negotiate About Vertical Tabstops option. See RFC 656 for more information.
PragmaHeartbeat | 140 TELOPT PRAGMA HEARTBEAT option.
PragmaLogon | 138 TELOPT PRAGMA LOGON option.
Regime3270 | 29 3270 Regime option. Used to request or confirm that 3270 Regimes be supported. See RFC 1041 for more information.
RemoteControlledTransAndEcho | 7 Remote Controlled Transmission and Echoing Telnet option. See RFC 563 and RFC 726 for more information.
RemoteSerialPort | 43 RSP option. Telnet remote serial port.
SendLocation | 23 SEND-LOCATION option. Used to request or confirm that the user can send their location to the Telnet server. See RFC 779 for more information.
SendUrl | 48 SEND-URL option.
SspiLogon | 139 TELOPT SSPI LOGON option.
StartTls | 46 Start TLS option.
Status | 5 STATUS option. Used to request or confirm the receiver's current option status. See RFC 859 for more information.
SupDup | 21 SUPDUP option. See RFC 734 or RFC 736 for more information.
SupDupOutput | 22 SUPDUP-Output option. See RFC 749 for more information.
SuppressGoAheads | 3 SUPPRESS-GO-AHEAD option. Used to request or confirm that the GO-AHEAD is not sent. See RFC 858 for more information.
SuppressLocalEcho | 45 Suppress local echo option.
TacacsUserIdentification | 26 TACACS User Identification Telnet option. Designed to facilitate double login avoidance for communication between TAC hosts. See RFC 927 for more information.
TerminalLocation | 28 Terminal Location Number option. Used to request or confirm usage of a TTYLOC. See RFC 946 for more information.
TerminalSpeed | 32 Terminal Speed option. Used to request or confirm that terminal speed information can be sent in a suboption. See RFC 1079 for more information.
TerminalType | 24 TERMINAL-TYPE option. Used to request or confirm that terminal-type is sent in a subsequent suboption. See RFC 1091 for more information.
TimingMark | 6 TIMING-MARK option. Used to request or or send a TIMING-MARK echo, used for synchronization. See RFC 860 for more information.
TN3270E | 40 TN3270 option. Used to request or confirm that 3270 device family enhancements can be used. See RFC 2355 for more information.
ToggleFlowControl | 33 Remote Flow Control option. Used to request or confirm that flow control can be used. See RFC 1372 for more information.
TransmitBinary | 0 TRANSMIT-BINARY option. Used to request or confirm that received data is to be interpreted as 8 bits of binary data. See RFC 856 for more information.
WindowSize | 31 Negotiate About Window Size option. Used by a client to request if they can convey window size to a server. See RFC 1073 for more information.
X3Pad | 30 X.3 Pad option. See RFC 1035 for more information.
Xauth | 41 XAUTH option.
XDisplayLocation | 35 X Display Location option. Used to request or confirm that the X display location of the client can be sent to the server. See RFC 1096 for more information.

Remarks

The Telnet protocol defines a framework from which both sides of a Telnet connection can negotiate options, enhancing the NVT. For information on a particular value, please consult the RFC for the option.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.OptionCode

See Also

Reference

Dart.Emulation Namespace


OptionState Enumeration

[image]
PowerTCP Emulation for .NET
OptionState Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : OptionState Enumeration

Glossary Item Box

Enumerates the current state of an Option object.

Syntax

Visual Basic (Declaration)
Public Enum OptionState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As OptionState
C#
public enum OptionState : System.Enum
Managed Extensions for C++
__value public enum OptionState : public System.Enum
C++/CLI
public enum class OptionState : public System.Enum

Members

Member | Description
Allow |
Off |
On |
RequestOff |
RequestOn |
Waiting |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.OptionState

See Also

Reference

Dart.Emulation Namespace


PrintType Enumeration

[image]
PowerTCP Emulation for .NET
PrintType Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : PrintType Enumeration

Glossary Item Box

Enumerates the printing types used by the Vt control.

Syntax

Visual Basic (Declaration)
Public Enum PrintType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PrintType
C#
public enum PrintType : System.Enum
Managed Extensions for C++
__value public enum PrintType : public System.Enum
C++/CLI
public enum class PrintType : public System.Enum

Members

Member | Description
Auto | Printing occurs line by line as data terminated with a line terminator is received from the host. Received data is displayed on the Vt display.
Controller | Printing occurs line by line as data terminated with a line terminator is received from the host. Received data is not displayed on the Vt display.
Off | No automatic printing. Printing must be done explicitly by calling Vt.PrintScreen, Selection.Print, or Vt.PrintCursorLine.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.PrintType

See Also

Reference

Dart.Emulation Namespace


ProxyType Enumeration

[image]
PowerTCP Emulation for .NET
ProxyType Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : ProxyType Enumeration

Glossary Item Box

Enumerates the provided proxy support that can be used.

Syntax

Visual Basic (Declaration)
Public Enum ProxyType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ProxyType
C#
public enum ProxyType : System.Enum
Managed Extensions for C++
__value public enum ProxyType : public System.Enum
C++/CLI
public enum class ProxyType : public System.Enum

Members

Member | Description
Http | An HTTP server proxy is to be used.
None | No server proxy is to be used.
Socks4 | A SOCKS4 server proxy is to be used.
Socks5 | A SOCKS5 server proxy is to be used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.ProxyType

See Also

Reference

Dart.Emulation Namespace


Scroll Enumeration

[image]
PowerTCP Emulation for .NET
Scroll Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : Scroll Enumeration

Glossary Item Box

Enumerates the values of the Vt.ScrollType property. The display screen can perform smooth scrolling or jump scrolling.

Syntax

Visual Basic (Declaration)
Public Enum Scroll
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Scroll
C#
public enum Scroll : System.Enum
Managed Extensions for C++
__value public enum Scroll : public System.Enum
C++/CLI
public enum class Scroll : public System.Enum

Members

Member | Description
Jump | Scrolling uses jump scrolling (scrolls line by line).
Smooth | Scrolling uses smooth scrolling.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.Scroll

See Also

Reference

Dart.Emulation Namespace


SelectionMode Enumeration

[image]
PowerTCP Emulation for .NET
SelectionMode Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : SelectionMode Enumeration

Glossary Item Box

Enumerates the values of the SelectionMode property.

Syntax

Visual Basic (Declaration)
Public Enum SelectionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SelectionMode
C#
public enum SelectionMode : System.Enum
Managed Extensions for C++
__value public enum SelectionMode : public System.Enum
C++/CLI
public enum class SelectionMode : public System.Enum

Members

Member | Description
Block | Selection of text is done in a block method.
Standard | Selection of text is done using the standard windows textbox method.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.SelectionMode

See Also

Reference

Dart.Emulation Namespace


Styles Enumeration

[image]
PowerTCP Emulation for .NET
Styles Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : Styles Enumeration

Glossary Item Box

Enumerates the styles for a cell. Used by the Cell.Styles property.

Syntax

Visual Basic (Declaration)
Public Enum Styles
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Styles
C#
public enum Styles : System.Enum
Managed Extensions for C++
__value public enum Styles : public System.Enum
C++/CLI
public enum class Styles : public System.Enum

Members

Member | Description
Blink | 4 Character is set to blink.
Bold | 2 Character color is bolded.
DoubleHighBottom | 64 Bottom half of double-height character is displayed.
DoubleHighTop | 32 Top half of double-height character is displayed.
DoubleWide | 16 Character is twice as wide as normal and occupies 2 cells.
Inverse | 1 Foreground and background colors are reversed.
Normal | 0 No style applied, normal character style.
SpecialGraphic | 128 Character is a special graphic.
Underline | 8 Character is underlined.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.Styles

See Also

Reference

Dart.Emulation Namespace


TerminalType Enumeration

[image]
PowerTCP Emulation for .NET
TerminalType Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : TerminalType Enumeration

Glossary Item Box

Enumerates the values of the TerminalType property.

Syntax

Visual Basic (Declaration)
Public Enum TerminalType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As TerminalType
C#
public enum TerminalType : System.Enum
Managed Extensions for C++
__value public enum TerminalType : public System.Enum
C++/CLI
public enum class TerminalType : public System.Enum

Members

Member | Description
Tty | 1 No emulation.
Vt100 | 3 VT100 terminal emulation.
Vt220_7 | 4 VT220 terminal emulation, 7-bit only.
Vt220_8 | 5 VT220 terminal emulation, 8-bit.
Vt320_7 | 45 VT320 terminal emulation, 7-bit only.
Vt320_8 | 46 VT320 terminal emulation, 8-bit.
Vt52 | 2 VT52 terminal emulation.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.TerminalType

See Also

Reference

Dart.Emulation Namespace


VtKey Enumeration

[image]
PowerTCP Emulation for .NET
VtKey Enumeration
See Also Send comments on this topic
Dart.Emulation Namespace : VtKey Enumeration

Glossary Item Box

Enumerates non-printable VT characters, and keys that are sent to the server with escape sequences.

Syntax

Visual Basic (Declaration)
Public Enum VtKey
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As VtKey
C#
public enum VtKey : System.Enum
Managed Extensions for C++
__value public enum VtKey : public System.Enum
C++/CLI
public enum class VtKey : public System.Enum

Members

Member | Description
CSI | The CSI character.
Del | The Del or <X] key.
Do | The Do key. Equivalent to VtKeys.F16.
Down | The Down Arrow key.
ESC | The ESC character.
F10 | The F10 key.
F11 | The F11 or ESC key.
F12 | The F12 or BS (Backspace) key.
F13 | The F13 or LF (Line Feed) key.
F14 | The F14 key.
F15 | The F15 key. Equivalent to VtKeys.Help.
F16 | The F16 key. Equivalent to VtKeys.Do.
F17 | The F17 key.
F18 | The F18 key.
F19 | The F19 key.
F20 | The F20 key.
F6 | The F6 key.
F7 | The F7 key.
F8 | The F8 key.
F9 | The F9 key.
Find | The Find key.
Help | The Help key. Equivalent to VtKeys.F15.
InsertHere | The Insert Here key.
Left | The Left Arrow key.
NextScreen | The Next Screen key.
Numpad0 | The 0 key on the numeric keypad.
Numpad1 | The 1 key on the numeric keypad.
Numpad2 | The 2 key on the numeric keypad.
Numpad3 | The 3 key on the numeric keypad.
Numpad4 | The 4 key on the numeric keypad.
Numpad5 | The 5 key on the numeric keypad.
Numpad6 | The 6 key on the numeric keypad.
Numpad7 | The 7 key on the numeric keypad.
Numpad8 | The 8 key on the numeric keypad.
Numpad9 | The 9 key on the numeric keypad.
NumpadAdd | The add or comma key on the numeric keypad. Equivalent to VtKeys.NumpadComma.
NumpadComma | The comma or add key on the numeric keypad. Equivalent to VtKeys.NumpadAdd.
NumpadEnter | The enter key on the numeric keypad.
NumpadMinus | The minus key on the numeric keypad.
NumpadPeriod | The period key on the numeric keypad.
PF1 | The PF1 key.
PF2 | The PF2 key.
PF3 | The PF3 key.
PF4 | The PF4 key.
PrevScreen | The Prev Screen key.
Remove | The Remove key.
Right | The Right Arrow key.
Select | The Select key.
SS3 | The SS3 character.
Tab | The Tab key.
Up | The Up Arrow key.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Emulation.VtKey

See Also

Reference

Dart.Emulation Namespace


Cell Structure

[image]
PowerTCP Emulation for .NET
Cell Structure
Members Example See Also Send comments on this topic
Dart.Emulation Namespace : Cell Structure

Glossary Item Box

Represents a single cell (occupied by a single character) on the Vt control.

Object Model

Cell Structure

Syntax

Visual Basic (Declaration)
Public Structure Cell
   Inherits System.ValueType
Visual Basic (Usage) Copy Code
Dim instance As Cell
C#
public struct Cell : System.ValueType
Managed Extensions for C++
public __value struct Cell : public System.ValueType
C++/CLI
public value class Cell : public System.ValueType

Remarks

The Vt.ScrapeCells method returns an array of Cell objects for the specified range. Examine the properties of these objects to determining the formatting of each cell. For example, if ScrapeCells is used to scrape the entire contents of the Vt control:

Cell[] cells = Vt.ScrapeCells(new Point(0,0), new Point(Vt.BufferRows + vt.Rows - 1, vt1.Columns - 1), Dart.Emulation.SelectionMode.Standard);

Then cells[0].Character will return the first character contained on the Vt control, cells[0].Styles will return the styles applied to the object, etc.

Example

The following example demonstrates how to get information about a cell in the display.
C# Copy Code
private string getCellInfo(Point start, Point end, Dart.Emulation.SelectionMode mode)
{
    //Scrape the cell.  The useOffset param specifies which overload to use
    Cell[] cells = vt1.ScrapeCells(start, end, mode);

    //Display info about the cell
    string info = "Character: " + cells[0].Character.ToString() + "\r\n";
    info += "Raw Character: " + cells[0].RawCharacter.ToString() + "\r\n";
    info += "Background color: " + cells[0].BackColor.ToString() + "\r\n";
    info += "Foreground color: " + cells[0].ForeColor.ToString() + "\r\n";
    info += "Styles: " + cells[0].Styles.ToString();
    return info;
}
Visual Basic Copy Code
Private Function getCellInfo(ByVal start As Point, ByVal [end] As Point, ByVal mode As Dart.Emulation.SelectionMode) As String
    'Scrape the cell.  The useOffset param specifies which overload to use
    Dim cells() As Cell = vt1.ScrapeCells(start, [end], mode)

    'Display info about the cell
    Dim info As String = "Character: " & cells(0).Character.ToString() & Constants.vbCrLf
    info &= "Raw Character: " & cells(0).RawCharacter.ToString() & Constants.vbCrLf
    info &= "Background color: " & cells(0).BackColor.ToString() & Constants.vbCrLf
    info &= "Foreground color: " & cells(0).ForeColor.ToString() & Constants.vbCrLf
    info &= "Styles: " & cells(0).Styles.ToString()
    Return info
End Function

Inheritance Hierarchy

System.Object
System.ValueType
Dart.Emulation.Cell

See Also

Reference

Cell Members
Dart.Emulation Namespace


Cell Structure Members

[image]
PowerTCP Emulation for .NET
Cell Structure Members
See Also Properties Methods Send comments on this topic
Dart.Emulation Namespace : Cell Structure

Glossary Item Box

The following tables list the members exposed by Cell.

Public Constructors

 | Name | Description
Public Constructor | Cell Constructor | Initialize a new instance of Cell.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Returns the background color for the cell.
Public Property | Character | Returns the character within the cell.
Public Property | ForeColor | Returns the foreground color for the cell.
Public Property | RawCharacter | Returns the unconverted character within the cell.
Public Property | Styles | Returns Styles values representing the styles applied to the cell.
Top

Public Methods

 | Name | Description
Public Method | ToString | Returns the cell character as a string.
Top

See Also

Reference

Cell Structure
Dart.Emulation Namespace


Cell Constructor

[image]
PowerTCP Emulation for .NET
Cell Constructor
See Also Send comments on this topic
Dart.Emulation Namespace > Cell Structure : Cell Constructor

character
The character in the cell.
style
The styles applied to the cell.
backColor
The background color of the cell.
foreColor
The foreground color of the cell.

Glossary Item Box

Initialize a new instance of Cell.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal character As Char, _
   ByVal style As Styles, _
   ByVal backColor As Color, _
   ByVal foreColor As Color _
)
Visual Basic (Usage) Copy Code
Dim character As Char
Dim style As Styles
Dim backColor As Color
Dim foreColor As Color

Dim instance As New Cell(character, style, backColor, foreColor)
C#
public Cell(
   char character,
   Styles style,
   Color backColor,
   Color foreColor
)
Managed Extensions for C++
public: Cell(
   char character,
   Styles style,
   Color backColor,
   Color foreColor
)
C++/CLI
public:
Cell(
   char character,
   Styles style,
   Color backColor,
   Color foreColor
)

Parameters

character
The character in the cell.
style
The styles applied to the cell.
backColor
The background color of the cell.
foreColor
The foreground color of the cell.

See Also

Reference

Cell Structure
Cell Members


Cell Structure Methods

[image]
PowerTCP Emulation for .NET
Cell Structure Methods
See Also Send comments on this topic
Dart.Emulation Namespace : Cell Structure

Glossary Item Box

For a list of all members of this type, see Cell members.

Public Methods

 | Name | Description
Public Method | ToString | Returns the cell character as a string.
Top

See Also

Reference

Cell Structure
Dart.Emulation Namespace


ToString Method

[image]
PowerTCP Emulation for .NET
ToString Method
See Also Send comments on this topic
Dart.Emulation Namespace > Cell Structure : ToString Method

Glossary Item Box

Returns the cell character as a string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

The Character as a string.

See Also

Reference

Cell Structure
Cell Members


Cell Structure Properties

[image]
PowerTCP Emulation for .NET
Cell Structure Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Cell Structure

Glossary Item Box

For a list of all members of this type, see Cell members.

Public Properties

 | Name | Description
Public Property | BackColor | Returns the background color for the cell.
Public Property | Character | Returns the character within the cell.
Public Property | ForeColor | Returns the foreground color for the cell.
Public Property | RawCharacter | Returns the unconverted character within the cell.
Public Property | Styles | Returns Styles values representing the styles applied to the cell.
Top

See Also

Reference

Cell Structure
Dart.Emulation Namespace


BackColor Property

[image]
PowerTCP Emulation for .NET
BackColor Property
See Also Send comments on this topic
Dart.Emulation Namespace > Cell Structure : BackColor Property

Glossary Item Box

Returns the background color for the cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Color

value = instance.BackColor
C#
public Color BackColor {get;}
Managed Extensions for C++
public: __property Color get_BackColor();
C++/CLI
public:
property Color BackColor {
   Color get();
}

Property Value

A System.Drawing.Color value specifying the background color for the cell.

Remarks

If no background color is specified for the cell, this property will return Color.Empty.

See Also

Reference

Cell Structure
Cell Members


Character Property

[image]
PowerTCP Emulation for .NET
Character Property
See Also Send comments on this topic
Dart.Emulation Namespace > Cell Structure : Character Property

Glossary Item Box

Returns the character within the cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Character As Char
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Char

value = instance.Character
C#
public char Character {get;}
Managed Extensions for C++
public: __property char get_Character();
C++/CLI
public:
property char Character {
   char get();
}

Remarks

If the character is a special graphics character (in which case Styles will return the SpecialCharacters flag) a conversion may take place on the character before returning it. For the unconverted character, see the RawCharacter property.

See Also

Reference

Cell Structure
Cell Members


ForeColor Property

[image]
PowerTCP Emulation for .NET
ForeColor Property
See Also Send comments on this topic
Dart.Emulation Namespace > Cell Structure : ForeColor Property

Glossary Item Box

Returns the foreground color for the cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Color

value = instance.ForeColor
C#
public Color ForeColor {get;}
Managed Extensions for C++
public: __property Color get_ForeColor();
C++/CLI
public:
property Color ForeColor {
   Color get();
}

Property Value

A System.Drawing.Color value specifying the foreground color for the cell.

Remarks

If no foreground color is specified for the cell, this property will return Color.Empty.

See Also

Reference

Cell Structure
Cell Members


RawCharacter Property

[image]
PowerTCP Emulation for .NET
RawCharacter Property
See Also Send comments on this topic
Dart.Emulation Namespace > Cell Structure : RawCharacter Property

Glossary Item Box

Returns the unconverted character within the cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RawCharacter As Char
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Char

value = instance.RawCharacter
C#
public char RawCharacter {get;}
Managed Extensions for C++
public: __property char get_RawCharacter();
C++/CLI
public:
property char RawCharacter {
   char get();
}

Remarks

While the Character property may perform a conversion on characters if the special graphics style is applied to the character, this property always returns the character unconverted.

See Also

Reference

Cell Structure
Cell Members


Styles Property

[image]
PowerTCP Emulation for .NET
Styles Property
See Also Send comments on this topic
Dart.Emulation Namespace > Cell Structure : Styles Property

Glossary Item Box

Returns Styles values representing the styles applied to the cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Styles As Styles
Visual Basic (Usage) Copy Code
Dim instance As Cell
Dim value As Styles

value = instance.Styles
C#
public Styles Styles {get;}
Managed Extensions for C++
public: __property Styles get_Styles();
C++/CLI
public:
property Styles Styles {
   Styles get();
}

Property Value

One or several Styles values specifying the styles applied to the cell.

Remarks

If no style is applied to the cell, this property will return Style.Normal. If multiple styles are applied to the cell, this property will return the flag combination of the Styles. For example, if Styles returns 6, the cell has both Style.Bold (2) and Style.Blink(4) applied. Use ToString to return the values as a comma-delimited list.

See Also

Reference

Cell Structure
Cell Members


TcpAsyncCallback Delegate

[image]
PowerTCP Emulation for .NET
TcpAsyncCallback Delegate
See Also Send comments on this topic
Dart.Emulation Namespace : TcpAsyncCallback Delegate

tcp
The TcpBase object that initiated the asynchronous operation.
data
The Data object containing received/sent data. Null for connect operations or if the socket is closed.
exception
Populated if the operation threw an exception, otherwise null.
state
State object passed into the asynchronous call.

Glossary Item Box

References the method to invoke on an IO completion thread when the corresponding asynchronous operation completes.

Syntax

Visual Basic (Declaration)
Public Delegate Sub TcpAsyncCallback( _
   ByVal tcp As TcpBase, _
   ByVal data As Data, _
   ByVal exception As Exception, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New TcpAsyncCallback(AddressOf HandlerMethod)
C#
public delegate void TcpAsyncCallback(
   TcpBase tcp,
   Data data,
   Exception exception,
   object state
)
Managed Extensions for C++
public: __gc __delegate void TcpAsyncCallback(
   TcpBase* tcp,
   Data* data,
   Exception* exception,
   Object* state
)
C++/CLI
public delegate void TcpAsyncCallback(
   TcpBase^ tcp,
   Data^ data,
   Exception^ exception,
   Object^ state
)

Parameters

tcp
The TcpBase object that initiated the asynchronous operation.
data
The Data object containing received/sent data. Null for connect operations or if the socket is closed.
exception
Populated if the operation threw an exception, otherwise null.
state
State object passed into the asynchronous call.

See Also

Reference

TcpAsyncCallback Members
Dart.Emulation Namespace


Assembly Overview

Dart.Emulation Assembly
See Also Send comments on this topic

Glossary Item Box

Namespaces

Namespace | Description
Dart.Emulation |


Getting Started - PowerTCP Emulation for .NET

Getting Started
Send comments on this topic

Glossary Item Box


Introduction - PowerTCP Emulation for .NET

Introduction
Send comments on this topic

Glossary Item Box


DartLicenseException Class Methods

[image]
PowerTCP Emulation for .NET
DartLicenseException Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : DartLicenseException Class

Glossary Item Box

For a list of all members of this type, see DartLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Emulation Namespace


DartLicenseException Class Properties

[image]
PowerTCP Emulation for .NET
DartLicenseException Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : DartLicenseException Class

Glossary Item Box

For a list of all members of this type, see DartLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Emulation Namespace


DataException Class Methods

[image]
PowerTCP Emulation for .NET
DataException Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : DataException Class

Glossary Item Box

For a list of all members of this type, see DataException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

DataException Class
Dart.Emulation Namespace


DataException Class Properties

[image]
PowerTCP Emulation for .NET
DataException Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : DataException Class

Glossary Item Box

For a list of all members of this type, see DataException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

DataException Class
Dart.Emulation Namespace


IPEndPoint Class Methods

[image]
PowerTCP Emulation for .NET
IPEndPoint Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : IPEndPoint Class

Glossary Item Box

For a list of all members of this type, see IPEndPoint members.

Public Methods

 | Name | Description
Public Method | Create | (Inherited from System.Net.IPEndPoint)
Public Method | Equals | (Inherited from System.Net.IPEndPoint)
Public Method | GetHashCode | (Inherited from System.Net.IPEndPoint)
Public Method | Serialize | (Inherited from System.Net.IPEndPoint)
Public Method | ToString | (Inherited from System.Net.IPEndPoint)
Top

See Also

Reference

IPEndPoint Class
Dart.Emulation Namespace


ProtocolException Class Methods

[image]
PowerTCP Emulation for .NET
ProtocolException Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : ProtocolException Class

Glossary Item Box

For a list of all members of this type, see ProtocolException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top

See Also

Reference

ProtocolException Class
Dart.Emulation Namespace


ProtocolException Class Properties

[image]
PowerTCP Emulation for .NET
ProtocolException Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : ProtocolException Class

Glossary Item Box

For a list of all members of this type, see ProtocolException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top

See Also

Reference

ProtocolException Class
Dart.Emulation Namespace


PtyBase Class Events

[image]
PowerTCP Emulation for .NET
PtyBase Class Events
See Also Send comments on this topic
Dart.Emulation Namespace : PtyBase Class

Glossary Item Box

For a list of all members of this type, see PtyBase members.

Public Events

 | Name | Description
Public Event | Data | Raised when TcpBase.Marshal is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Emulation Namespace


PtyBase Class Methods

[image]
PowerTCP Emulation for .NET
PtyBase Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : PtyBase Class

Glossary Item Box

For a list of all members of this type, see PtyBase members.

Public Methods

 | Name | Description
Public Method | Abort | Performs a hard close of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. Authenticates the server when establishing a secure connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Close | Gracefully closes the connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | Connect | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | ConnectAsync | Connect to a server using the configuration specified by session. (Inherited from Dart.Emulation.TcpBase)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Provides access to the underlying Stream. (Inherited from Dart.Emulation.TcpBase)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals data to the UI thread. (Inherited from Dart.Emulation.TcpBase)
Public Method | Read | Overloaded. Receives data from the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadAsync | Start an asynchronous read on the socket. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToCount | Read until count bytes are read, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToDelimiter | Overloaded. Read until the delimiter is found, an exception is thrown, or the connection is closed. (Inherited from Dart.Emulation.TcpBase)
Public Method | ReadToEnd | Read until the connection is closed or an exception is thrown. (Inherited from Dart.Emulation.TcpBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ShutdownSsl | Signals the remote host to shutdown the SSL connection. (Inherited from Dart.Emulation.TcpBase)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. Sends data to the remote host. (Inherited from Dart.Emulation.TcpBase)
Public Method | WriteAsync | Start an asynchronous write on the socket. (Inherited from Dart.Emulation.TcpBase)
Top

See Also

Reference

PtyBase Class
Dart.Emulation Namespace


Rexec Class Events

[image]
PowerTCP Emulation for .NET
Rexec Class Events
See Also Send comments on this topic
Dart.Emulation Namespace : Rexec Class

Glossary Item Box

For a list of all members of this type, see Rexec members.

Public Events

 | Name | Description
Public Event | Data | Raised when TcpBase.Marshal is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Emulation Namespace


Rexec Class Properties

[image]
PowerTCP Emulation for .NET
Rexec Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Rexec Class

Glossary Item Box

For a list of all members of this type, see Rexec members.

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Emulation Namespace


Rlogin Class Events

[image]
PowerTCP Emulation for .NET
Rlogin Class Events
See Also Send comments on this topic
Dart.Emulation Namespace : Rlogin Class

Glossary Item Box

For a list of all members of this type, see Rlogin members.

Public Events

 | Name | Description
Public Event | Data | Raised when TcpBase.Marshal is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Rlogin Class
Dart.Emulation Namespace


Rsh Class Events

[image]
PowerTCP Emulation for .NET
Rsh Class Events
See Also Send comments on this topic
Dart.Emulation Namespace : Rsh Class

Glossary Item Box

For a list of all members of this type, see Rsh members.

Public Events

 | Name | Description
Public Event | Data | Raised when TcpBase.Marshal is used. (Inherited from Dart.Emulation.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | Log | Raised when data is read or written. (Inherited from Dart.Emulation.TcpBase)
Public Event | StateChanged | Raised when the value of the State property changes. (Inherited from Dart.Emulation.TcpBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Emulation Namespace


Rsh Class Properties

[image]
PowerTCP Emulation for .NET
Rsh Class Properties
See Also Send comments on this topic
Dart.Emulation Namespace : Rsh Class

Glossary Item Box

For a list of all members of this type, see Rsh members.

Public Properties

 | Name | Description
Public Property | CloseTime | Returns the DateTime the connection was closed. (Inherited from Dart.Emulation.TcpBase)
Public Property | ConnectTime | Returns the DateTime the connection was established. (Inherited from Dart.Emulation.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Character encoding used by the component. (Inherited from Dart.Emulation.ComponentBase)
Public Property | NetworkStream | Returns the NetworkStream object created when Connect() is called. (Inherited from Dart.Emulation.TcpBase)
Public Property | RemoteEndPoint | Gets the remote address and port of the connection. (Inherited from Dart.Emulation.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | Gets the socket used by the component for communications. (Inherited from Dart.Emulation.SocketBase)
Public Property | SocketOption | Gets and sets the socket options for classes derived from TcpBase. (Inherited from Dart.Emulation.TcpBase)
Public Property | SslStream | Returns the SslStream object created when AuthenticateAsClient or AuthenticateAsServer are called. (Inherited from Dart.Emulation.TcpBase)
Public Property | State | Gets the status of the connection as of the last socket operation. (Inherited from Dart.Emulation.TcpBase)
Public Property | SynchronizingObject | Gets or sets the object used to marshal data to the UI thread (for raising events). (Inherited from Dart.Emulation.ComponentBase)
Public Property | SyncRoot | Gets an object that is used to synchronize access to the upper layer protocol in use. (Inherited from Dart.Emulation.ComponentBase)
Public Property | Tag | Gets or sets an object that stores any user data. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Emulation Namespace


SocketBase Class Events

[image]
PowerTCP Emulation for .NET
SocketBase Class Events
See Also Send comments on this topic
Dart.Emulation Namespace : SocketBase Class

Glossary Item Box

For a list of all members of this type, see SocketBase members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | Raised when Marshal(Exception) is used or an unhandled Exception is thrown in a worker thread created using Start. (Inherited from Dart.Emulation.ComponentBase)
Public Event | UserState | Raised when Marshal(String,Object) is used. (Inherited from Dart.Emulation.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Emulation Namespace


SocketBase Class Methods

[image]
PowerTCP Emulation for .NET
SocketBase Class Methods
See Also Send comments on this topic
Dart.Emulation Namespace : SocketBase Class

Glossary Item Box

For a list of all members of this type, see SocketBase members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Deserialize | Deserialize a previously serialized object. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. Marshals a string and/or object to the UI thread and raises the UserState event. (Inherited from Dart.Emulation.ComponentBase)
Public Method | Serialize | Serialize an object to the provided destination stream. (Inherited from Dart.Emulation.ComponentBase)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SocketBase Class
Dart.Emulation Namespace


Dispose Method

[image]
PowerTCP Emulation for .NET
Dispose Method
See Also Send comments on this topic
Dart.Emulation Namespace > SocketBase Class : Dispose Method

Glossary Item Box

Disposes of SocketBase and its associated resources.

Overload List

Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)

See Also

Reference

SocketBase Class
SocketBase Members


Close Method

[image]
PowerTCP Emulation for .NET
Close Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Close Method

Glossary Item Box

Gracefully closes the connection.

Overload List

Overload | Description
Close | Gracefully closes the connection.

See Also

Reference

TcpBase Class
TcpBase Members


Dispose Method

[image]
PowerTCP Emulation for .NET
Dispose Method
See Also Send comments on this topic
Dart.Emulation Namespace > TcpBase Class : Dispose Method

Glossary Item Box

Disposes of TcpBase and its associated resources.

Overload List

Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)

See Also

Reference

TcpBase Class
TcpBase Members


Login Method

[image]
PowerTCP Emulation for .NET
Login Method
See Also Send comments on this topic
Dart.Emulation Namespace > Telnet Class : Login Method

Glossary Item Box

Logs into a telnet server using properties found in the settings parameter.

Overload List

Overload | Description
Login | Logs into a telnet server using properties found in the settings parameter.

See Also

Reference

Telnet Class
Telnet Members


Dispose Method

[image]
PowerTCP Emulation for .NET
Dispose Method
See Also Send comments on this topic
Dart.Emulation Namespace > Vt Class : Dispose Method

Glossary Item Box

Override this member to release resources.

Overload List

Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)

See Also

Reference

Vt Class
Vt Members


Dart.Emulation Namespace Inheritance Hierarchy

Dart.Emulation Namespace Inheritance Hierarchy
See Also Send comments on this topic

Glossary Item Box

Inheritance Hierarchy

System.Object
Dart.Emulation.AnsiColor
Dart.Emulation.Credentials
Dart.Emulation.Option
Dart.Emulation.Proxy
Dart.Emulation.Security
Dart.Emulation.ClientSecurity
Dart.Emulation.Segment
Dart.Emulation.Data
Dart.Emulation.Selection
Dart.Emulation.Session
Dart.Emulation.TcpSession
Dart.Emulation.SocketOption
Dart.Emulation.TcpSocketOption
System.Collections.Generic.List<T>
Dart.Emulation.OptionCollection
System.EventArgs
Dart.Emulation.CommandEventArgs
Dart.Emulation.ErrorEventArgs
Dart.Emulation.KeyPressEventArgs
Dart.Emulation.OptionEventArgs
Dart.Emulation.UserStateEventArgs
Dart.Emulation.DataEventArgs
System.Windows.Forms.KeyEventArgs
Dart.Emulation.VtKeyEventArgs
System.Exception
Dart.Emulation.DartLicenseException
System.ApplicationException
Dart.Emulation.DataException
Dart.Emulation.ProtocolException
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Emulation.ComponentBase
Dart.Emulation.SocketBase
Dart.Emulation.TcpBase
Dart.Emulation.PtyBase
Dart.Emulation.Rlogin
Dart.Emulation.Telnet
Dart.Emulation.Rexec
Dart.Emulation.Rsh
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
Dart.Emulation.Vt
System.Net.EndPoint
System.Net.IPEndPoint
Dart.Emulation.IPEndPoint
System.ValueType
Dart.Emulation.Cell

See Also

Reference

Dart.Emulation Assembly