PowerTCP Telnet for .NET
See Also Send comments on this topic

Glossary Item Box

Welcome!

Welcome and thank you for choosing PowerTCP Telnet for .NET. You have selected what we feel is the most sophisticated and complete .NET Telnet package available on the market. We know you have a choice in software vendors and we will do our best to exceed your expectations.

Overview

PowerTCP Telnet for .NET fills the Telnet and remote access communication gap in the .NET Framework by providing stream-based Telnet communication that can be plugged into any application that targets .NET Framework 4.5+or .NET Standard 2.0 compatible environments, as documented here. This latest version of the venerable PowerTCP product line gets a new design that leverages the power of the latest .NET environments to provide the most advanced Internet Communications components available.

Some of the features include:

  • Auto-login capabilities
  • Auto-option negotiation with easy configuration options
  • Secure SSL/TLS Telnet support
  • Blocking reads that wait for defined delimiters, specifically designed for scripting applications
  • PTY property binds a TextBox to the Telnet component as a ready-made interface for interactive online communications
  • Logging event for easy debugging and session logging
  • Proxy support
  • Includes Rexec, Rsh and Rlogin components in addition to Telnet
  • A Start method for multi-threaded applications
  • Marshal methods for cross-thread marshaling support

About Us

Quality!

Dart Communications, located in upstate New York, has been designing and developing Internet communication components since 1994. Almost 2 decades later, PowerTCP, PowerSNMP and PowerWEB for ASP.NET are International bestsellers to small businesses, consultants, and Fortune 500 companies.

Each targeted protocol is extensively researched by Dart and each product is tested and supported by consistent processes and customer feedback. Developers using our products can focus on creating the unique features they require rather than wasting weeks on research and unnecessary code writing.

Added Value

Dart Communications is committed to creating products that are of high quality, flexible, and easily implemented into a project. This process means maintaining meticulous documentation and a readily available support staff. In addition, Dart consistently processes feedback and requests, using this information for new product and feature development.

Dart's development team is also available for custom development projects relating to their product line. A customer may lack the time or background to complete a particular project as needed. Dart's team will draw on their protocol knowledge and experience to supply a quality solution within the time frame required.

Expertise

Building components is about reliability. Developers need products that can stand up to use, that work as intended, and that go beyond original expectations. Our research tells us that users often change the scope of a project once it is underway. PowerTCP products are designed to scale to those increased expectations. To give you time to evaluate this claim prior to purchase, Dart supplies a fully functional trial for all of its products. See for yourself how a component can have both high-level functionality for quick and easy solutions, and also provide a low-level interface for customization.

In today's world, software developers are routinely asked to produce solutions using unfamiliar technologies, with little time allowed for research. When Internet Communications is part of your project, consider leveraging Dart's proven components to connect, encode, compress, encrypt and transfer data. Our goal is to help you build applications that work the first time, every time.

See Also

Reference
Rexec Component
Rlogin Component
Rsh Component
Telnet Component

Documentation Version 6.1
© 2023 Dart Communications. All Rights Reserved.


Getting Started

Getting Started
See Also Send comments on this topic

Glossary Item Box

We recommend the user read this documentation and examine the sample applications included in the distribution to become familiar with the Telnet for .NET classes. For the most basic quick-start, create a new Windows Application project in Visual Studio and refer to the Code Examples page for accessible examples to try.

Show Sample Applications

All samples include C#, VB.NET and VC++/CLI versions. A PowerShell sample is also available.

Sample | Description
Automated Client | Demonstrates execution of an automated scripting application using Telnet.
Rexec Client | Demonstrates execution of a command using Rexec.
Rlogin Client | Demonstrates a user-interactive Rlogin client.
Rsh Client | Demonstrates execution of a command using Rsh.
Telnet Client | Demonstrates a user-interactive Telnet client.
Telnet Automated Console | Demonstrates use of Telnet in a console application.
Telnet PTY Client | Demonstrates use of the %Pty:Dart.Telnet~Dart.Common.PtyBase~Pty% feature, which adds a TextBox interface to the Telnet component.
Telnet Automated Web | Demonstrates use of Telnet on a web page.

Download the Telnet for .NET Sample Applications

Show Support Options

Our mission is to deliver high quality Internet connectivity solutions to Internet application developers. Our goal is to supplement these solutions with timely support resources that can help at many different levels.

You must have an active connection to the Internet to view these links.

Paid Support Options
Discusses the paid support options available.
Free Support Options
Provides access to free materials to help your development, including FAQS, online help files, tutorials, code snippets, online asp samples, and a free support forum.
Support Forum
Provides access to our support forum, monitored by our own development staff as time permits.
Dart Solutions
Discusses the custom development support offered by Dart Solutions.

Show Authenticode Signing

Dart installation executables are authenticode signed with a "Dart Communications" digital certificate to ensure against tampering during distribution.

Dart dlls included in the installation bin directory are .NET strong name signed, but not authenticode signed. These dlls are used by the sample applications and typically referenced in users' products.

For those users who require dlls signed by the author company (for example, for Windows logo compliance), dlls that have been signed with the "Dart Communications" digital certificate are also included in the product. These dlls are contained in the "Signed Distributables" sub-folder under the installation bin folder.

In accordance with the End-User Licensing Agreement, pre-compiled Dart dlls may NOT be signed with a user's own certificate. However, for users who wish to independently sign these dlls, Dart offers OEM licensing which allow for this. Please contact sales@dart.com for more information.

Show Requirements

Target Platforms: Microsoft .NET Framework 4.5, .NET Standard 2.0

See Also

Rexec Component
Rlogin Component
Rsh Component
Telnet Component


What's Included

What's Included
Send comments on this topic

Glossary Item Box

Dart provides product assemblies that target .NET Framework 4.5 (compatible with .NET Framework 4.5-4.8.1) and .NET Standard 2.0 (compatible with environments that support .NET Standard 2.0 as documented here).

Included assemblies:

  • Dart.Telnet.dll. Dart's licensed product assembly.

When installing PowerTCP Telnet for .NET via Nuget, these assemblies are stored in Nuget’s global package cache by default.

When installing PowerTCP Telnet for .NET via Windows installer, these assemblies are stored in:

  • C:\Program Files (x86)\Dart\PowerTCP\6.1\bin\net45\
  • C:\Program Files (x86)\Dart\PowerTCP\6.1\bin\netstandard2.0\

Sample Visual Studio projects are included in the Windows installation. Nuget users can download the samples here.

Please contact support if you need to target legacy .NET Framework versions.


Trial Operation

Trial Operation
Send comments on this topic

Glossary Item Box

Dart provides a free 30-day trial license so you can develop apps that will operate during that period.

With the exception of trial runtime license expiration, trial operation is the same as licensed operation.

If no 30-day trial license is present one will be created automatically. When an application is run on a machine with a trial license, a trial runtime license will be generated and will have "Trial" in its name to differentiate it from a normal runtime license. For Example a trial runtime license would have the following name:
Dart.Telnet.Trial.Lic

Do not distribute a trial runtime license. To ensure your product is properly licensed for distribution, please see License Activation.


License Activation

License Activation
Send comments on this topic

Glossary Item Box

Product license activation is necessary to generate a runtime license for distribution. A license can be activated in one of two ways:

  • The Dart License Manager utility automatically runs at the end of the Windows installation process or can be run later from the product installation directory. It can be used to activate either a 30-day trial or to fully license the product.
  • Alternatively, use the dotnet-dartlicense .NET tool:
  1. Install the tool from the Developer Command Prompt: “dotnet tool install -g dotnet-dartlicense” (the tool will automatically download from nuget.org and be installed globally)
  2. At the Developer Command Prompt, interactively execute “dartlicense”
  3. Select option 1 and enter your PRoduct Key.

Created license files are stored using Environment.SpecialFolder.LocalApplicationData which has a specific mapping for each operating system. On Windows it maps to:

%LocalAppData%\Dart Communications

Users can view this file to confirm trial expiration date or their activated Product Key.


Code Examples

Code Examples
See Also Send comments on this topic

Glossary Item Box

The following lists direct links to pages in this help file that contain easy-to-follow code examples.

Using the Start method to execute code without blocking the UI

Marshaling data to the UI thread

Executing an automated session

Setting options for automatic option negotiation

Authenticating a server's certificate

Reading on a worker thread

Logging data sent and received using the Log event

See Also

Rexec Component
Rlogin Component
Rsh Component
Telnet Component


Telnet Protocol Overview

Telnet Protocol Overview
See Also Send comments on this topic

Glossary Item Box

The following information provides a basic explanation of the TELNET protocol and related concepts. See the Assembly Overview for information on using the classes in this library.

Protocol Overview

TELNET (Telecommunications Network Protocol) is a data communications protocol that provides a set of rules for communication between computers. Telnet communication is the same for all systems and therefore works between different types of computers and operating systems. Many host systems support Telnet, and it is often used for remote login where one computer is accessed from another. A typical Telnet application would use the protocol to move data between a terminal emulator and a UNIX server (host).

Telnet is mainly used for online terminal communications - the user logs in to remote machines and issue commands as if he were actually at these machines. Telnet can also be used to access remote databases, control other computers, distribute work among multiple systems, and remotely execute many applications.

Telnet is built upon TCP and provides additional features that make it an upper-layer protocol. Typically, a terminal sends commands to a host, and the host responds with messages or data. For example, a user may type "help" and the remote host may respond with "Type a command to get help on."

Telnet provides option negotiation as a means for establishing conventions between two machines. During a session, either host may send the other a command to request or volunteer a specific option. For example, the echo option may be negotiated.

Telnet Connections

Connections are made to a port and host name or address. Most Telnet connections are made to the standard port 23. All computers on a network have a distinguishing IP address. Standard IPv4 addresses have the following same format:

nnn.nnn.nnn.nnn

where each nnn is a number from 0 to 255 (except for the first octet, which may be from 0 to 247). This means an IPv4 address is 32bits long, allowing nearly 2^32 unique values. A typical IP address might be 129.229.1.2.

PowerTCP provides full support for IPv6. IPv6 was established as the next generation Internet protocol, in order to greatly increase the number of available IP addresses. IPv6 addresses have the following hexadecimal format:

xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx

where each xxxx is a hex value from 0000 to FFFF (0 to 65535). An IPv6 address is 128bits long, allowing 2^128 unique values. A typical address might be fe80::211:d800:97:c915. Note that "::" indicates a consecutive group of 0 values.

Most networks also support computer names, where the network will translate a name (such as "server3") into an IP address.

Network Virtual Terminal

The Network Virtual Terminal (NVT) is a Telnet concept used to represent both hosts in a connection. The NVT is an imaginary character-based device with a keyboard and a printer (input and output). Incoming data goes to the printer, and input from the keyboard goes to the other end of the Telnet connection. Both ends of a Telnet connection must support the NVT.

The NVT supports the 7-bit character set known as NVT ASCII. NVT ASCII is the same as normal ASCII text, except that only 7 bits represent the character. The eighth high bit of the byte must be set to 0. In NVT ASCII, an end of line is represented by a two-character sequence CR, LF (carriage return, line-feed).

Both ends of a Telnet connection map their own terminal device characteristics to and from the NVT. For example, a program must change all 8-bit ASCII characters to the NVT character set. The NVT is intended to strike a balance between being overly restrictive (not providing some computers a rich enough vocabulary for mapping into their local character sets) and being overly inclusive (penalizing users with modest terminals).

Please refer to RFC 854 for more information on the NVT.

Binary Data

PowerTCP provides full support for binary data transmission. The following basic Telnet encoding rules are applied when sending:

  1. Every byte of value 255 (IAC) is doubled up into a two-byte (255, 255) value.
  2. Every byte of value 13 (CR) not followed by a byte of value 10 (LF) is transformed into a two-byte (13, 0) value.

For all data received, the reciprocal transformation takes place within the Telnet component. This mechanism, established by RFC 854, enables the transmission of 8-bit binary data over a single Telnet channel.

There is also a TransmitBinary option that can be easily set using the Binary property of the Telnet component. When set to RequestOn, the TransmitBinary option is negotiated for both directions. When in this mode, a naked CR is not padded with a following NULL when data is sent. When data is received, any CR NULL encountered is used unaltered. All other padding (such as the doubling of IAC bytes) remains the same.

Option Negotiation

Option negotiation is the process by which two computers agree on the features they will or will not provide. Each computer may send and respond to commands. A typical option negotiation session may occur as follows (although over 40 different options might be negotiated):

Computer A | Computer B
1. I will echo back what you send to me. |
 | 2. OK, Do echo back what I send to you.
3. Do suppress go–aheads. |
 | 4. No, I won't suppress go–aheads.

Either machine may initiate option negotiation. One machine may request that the other machine support or not support an option, or inform the machine that it will or won't support an option. The other may then respond that it will or won't support an option, or request that the other computer support or not support an option. The following table describes the four option negotiation commands:

Command | Description
WILL | The sender wants to support the option
WONT | The sender will not support the option
DO | The sender wants the receiver to support the option
DONT | The sender wants the receiver to not support the option

The different pairs of commands and responding commands follow:

Command | Response | Option Used
WILL I will support this option | DO I do support this option | Yes
WILL I will support this option | DONT No, don't support it | No
WONT I won't support this option | DONT OK, don't support it | No
DO Do support this option | WILL OK, I will support it | Yes
DO Do support this option | WONT No, I won't support it | No
DONT Don't support this option | WONT OK, I won't support it | No

Note If a machine does not want an option supported (WONT/DONT), the other machine must comply, responding with a DONT or WONT.

Telnet also provides suboption negotiation—negotiating details about a specific option. An example is the "terminal type" option. For both computers to decide to support the same terminal type, instead of using a different option for each individual terminal type, a suboption is negotiated. A typical suboption negotiation is shown below:

Computer A | Computer B
1. I will support different terminal types. |
 | 2. OK, Do support different terminal types.
3. OK, send your terminal type suboption. |
 | 4. My terminal type suboption is "IBMPC".

Option negotiation and suboption negotiation makes Telnet very flexible and adaptable to many different terminal configurations. Refer to the applicable RFCs for more information on Telnet and Telnet option negotiation.

See Also

Reference
Rexec Component
Rlogin Component
Rsh Component
Telnet Component


Dart.Telnet Namespace

Dart.Telnet Namespace
See Also Inheritance Hierarchy Send comments on this topic

Glossary Item Box

Classes

 | Class | Description
Class | BaseEventArgs |
Class | ClientSecurity |
Class | CommandEventArgs |
Class | ComponentBase |
Class | Credentials |
Class | DartLicenseException |
Class | Data |
Class | DataEventArgs |
Class | DataException |
Class | Datagram |
Class | ErrorEventArgs |
Class | IPEndPoint |
Class | License |
Class | Option |
Class | OptionCollection |
Class | OptionEventArgs |
Class | ProtocolException |
Class | Proxy |
Class | PtyBase |
Class | Rexec |
Class | Rlogin |
Class | Rsh |
Class | Security |
Class | Segment |
Class | Session |
Class | SocketBase |
Class | SocketOption |
Class | TcpBase |
Class | TcpSession |
Class | TcpSocketOption |
Class | Telnet |
Class | UserStateEventArgs |

Delegates

 | Delegate | Description
Delegate | TcpAsyncCallback |

Enumerations

 | Enumeration | Description
Enumeration | Command |
Enumeration | ConnectionState |
Enumeration | DataDirection |
Enumeration | OptionCode |
Enumeration | OptionState |
Enumeration | ProxyType |

See Also

Reference

Dart.Telnet Assembly


BaseEventArgs Class

[image]
PowerTCP Telnet for .NET
BaseEventArgs Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : BaseEventArgs Class

Glossary Item Box

Object Model

BaseEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class BaseEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As BaseEventArgs
C#
public class BaseEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class BaseEventArgs : public System.EventArgs
C++/CLI
public ref class BaseEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Telnet.BaseEventArgs

See Also

Reference

BaseEventArgs Members
Dart.Telnet Namespace


BaseEventArgs Class Members

[image]
PowerTCP Telnet for .NET
BaseEventArgs Class Members
See Also Send comments on this topic
Dart.Telnet Namespace : BaseEventArgs Class

Glossary Item Box

The following tables list the members exposed by BaseEventArgs.

Public Constructors

 | Name | Description
Public Constructor | BaseEventArgs Constructor |
Top

See Also

Reference

BaseEventArgs Class
Dart.Telnet Namespace


BaseEventArgs Constructor

[image]
PowerTCP Telnet for .NET
BaseEventArgs Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > BaseEventArgs Class : BaseEventArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New BaseEventArgs()
C#
public BaseEventArgs()
Managed Extensions for C++
public: BaseEventArgs();
C++/CLI
public:
BaseEventArgs();

See Also

Reference

BaseEventArgs Class
BaseEventArgs Members


ClientSecurity Class

[image]
PowerTCP Telnet for .NET
ClientSecurity Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : ClientSecurity Class

Glossary Item Box

Object Model

ClientSecurity Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class ClientSecurity
   Inherits Security
Visual Basic (Usage) Copy Code
Dim instance As ClientSecurity
C#
[Serializable()]
public class ClientSecurity : Security
Managed Extensions for C++
[Serializable()]
public __gc class ClientSecurity : public Security
C++/CLI
[Serializable()]
public ref class ClientSecurity : public Security

Inheritance Hierarchy

System.Object
Dart.Telnet.Security
Dart.Telnet.ClientSecurity

See Also

Reference

ClientSecurity Members
Dart.Telnet Namespace


ClientSecurity Class Members

[image]
PowerTCP Telnet for .NET
ClientSecurity Class Members
See Also Fields Properties Send comments on this topic
Dart.Telnet Namespace : ClientSecurity Class

Glossary Item Box

The following tables list the members exposed by ClientSecurity.

Public Constructors

 | Name | Description
Public Constructor | ClientSecurity Constructor |
Top

Public Fields

 | Name | Description
Public Field | SelectionCallback |
Public Field | ValidationCallback | (Inherited from Dart.Telnet.Security)
Top

Public Properties

 | Name | Description
Public Property | Certificates |
Public Property | CheckCertificateRevocation | (Inherited from Dart.Telnet.Security)
Public Property | Protocols | (Inherited from Dart.Telnet.Security)
Public Property | TargetHost |
Top

See Also

Reference

ClientSecurity Class
Dart.Telnet Namespace


ClientSecurity Constructor

[image]
PowerTCP Telnet for .NET
ClientSecurity Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > ClientSecurity Class : ClientSecurity Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ClientSecurity()
C#
public ClientSecurity()
Managed Extensions for C++
public: ClientSecurity();
C++/CLI
public:
ClientSecurity();

See Also

Reference

ClientSecurity Class
ClientSecurity Members


ClientSecurity Class Properties

[image]
PowerTCP Telnet for .NET
ClientSecurity Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : ClientSecurity Class

Glossary Item Box

For a list of all members of this type, see ClientSecurity members.

Public Properties

 | Name | Description
Public Property | Certificates |
Public Property | CheckCertificateRevocation | (Inherited from Dart.Telnet.Security)
Public Property | Protocols | (Inherited from Dart.Telnet.Security)
Public Property | TargetHost |
Top

See Also

Reference

ClientSecurity Class
Dart.Telnet Namespace


Certificates Property

[image]
PowerTCP Telnet for .NET
Certificates Property
See Also Send comments on this topic
Dart.Telnet Namespace > ClientSecurity Class : Certificates Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Certificates As X509CertificateCollection
Visual Basic (Usage) Copy Code
Dim instance As ClientSecurity
Dim value As X509CertificateCollection

instance.Certificates = value

value = instance.Certificates
C#
public X509CertificateCollection Certificates {get; set;}
Managed Extensions for C++
public: __property X509CertificateCollection* get_Certificates();
public: __property void set_Certificates(
   X509CertificateCollection* value
);
C++/CLI
public:
property X509CertificateCollection^ Certificates {
   X509CertificateCollection^ get();
   void set (    X509CertificateCollection^ value);
}

See Also

Reference

ClientSecurity Class
ClientSecurity Members


TargetHost Property

[image]
PowerTCP Telnet for .NET
TargetHost Property
See Also Send comments on this topic
Dart.Telnet Namespace > ClientSecurity Class : TargetHost Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("")>
Public Property TargetHost As String
Visual Basic (Usage) Copy Code
Dim instance As ClientSecurity
Dim value As String

instance.TargetHost = value

value = instance.TargetHost
C#
[DefaultValue("")]
public string TargetHost {get; set;}
Managed Extensions for C++
[DefaultValue("")]
public: __property string* get_TargetHost();
public: __property void set_TargetHost(
   string* value
);
C++/CLI
[DefaultValue("")]
public:
property String^ TargetHost {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

ClientSecurity Class
ClientSecurity Members


ClientSecurity Class Fields

[image]
PowerTCP Telnet for .NET
ClientSecurity Class Fields
See Also Send comments on this topic
Dart.Telnet Namespace : ClientSecurity Class

Glossary Item Box

For a list of all members of this type, see ClientSecurity members.

Public Fields

 | Name | Description
Public Field | SelectionCallback |
Public Field | ValidationCallback | (Inherited from Dart.Telnet.Security)
Top

See Also

Reference

ClientSecurity Class
Dart.Telnet Namespace


SelectionCallback Field

[image]
PowerTCP Telnet for .NET
SelectionCallback Field
See Also Send comments on this topic
Dart.Telnet Namespace > ClientSecurity Class : SelectionCallback Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public SelectionCallback As LocalCertificateSelectionCallback
Visual Basic (Usage) Copy Code
Dim instance As ClientSecurity
Dim value As LocalCertificateSelectionCallback

value = instance.SelectionCallback

instance.SelectionCallback = value
C#
public LocalCertificateSelectionCallback SelectionCallback
Managed Extensions for C++
public: LocalCertificateSelectionCallback* SelectionCallback
C++/CLI
public:
LocalCertificateSelectionCallback^ SelectionCallback

See Also

Reference

ClientSecurity Class
ClientSecurity Members


CommandEventArgs Class

[image]
PowerTCP Telnet for .NET
CommandEventArgs Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : CommandEventArgs Class

Glossary Item Box

Object Model

CommandEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class CommandEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
C#
public class CommandEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class CommandEventArgs : public System.EventArgs
C++/CLI
public ref class CommandEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Telnet.CommandEventArgs

See Also

Reference

CommandEventArgs Members
Dart.Telnet Namespace


CommandEventArgs Class Members

[image]
PowerTCP Telnet for .NET
CommandEventArgs Class Members
See Also Properties Methods Send comments on this topic
Dart.Telnet Namespace : CommandEventArgs Class

Glossary Item Box

The following tables list the members exposed by CommandEventArgs.

Public Properties

 | Name | Description
Public Property | Command |
Public Property | OptionCode |
Public Property | SubOption |
Top

Public Methods

 | Name | Description
Public Method | ToString |
Top

See Also

Reference

CommandEventArgs Class
Dart.Telnet Namespace


CommandEventArgs Class Methods

[image]
PowerTCP Telnet for .NET
CommandEventArgs Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : CommandEventArgs Class

Glossary Item Box

For a list of all members of this type, see CommandEventArgs members.

Public Methods

 | Name | Description
Public Method | ToString |
Top

See Also

Reference

CommandEventArgs Class
Dart.Telnet Namespace


ToString Method

[image]
PowerTCP Telnet for .NET
ToString Method
See Also Send comments on this topic
Dart.Telnet Namespace > CommandEventArgs Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


CommandEventArgs Class Properties

[image]
PowerTCP Telnet for .NET
CommandEventArgs Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : CommandEventArgs Class

Glossary Item Box

For a list of all members of this type, see CommandEventArgs members.

Public Properties

 | Name | Description
Public Property | Command |
Public Property | OptionCode |
Public Property | SubOption |
Top

See Also

Reference

CommandEventArgs Class
Dart.Telnet Namespace


Command Property

[image]
PowerTCP Telnet for .NET
Command Property
See Also Send comments on this topic
Dart.Telnet Namespace > CommandEventArgs Class : Command Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Command As Command
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value As Command

value = instance.Command
C#
public Command Command {get;}
Managed Extensions for C++
public: __property Command get_Command();
C++/CLI
public:
property Command Command {
   Command get();
}

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


OptionCode Property

[image]
PowerTCP Telnet for .NET
OptionCode Property
See Also Send comments on this topic
Dart.Telnet Namespace > CommandEventArgs Class : OptionCode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OptionCode As OptionCode
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value As OptionCode

value = instance.OptionCode
C#
public OptionCode OptionCode {get;}
Managed Extensions for C++
public: __property OptionCode get_OptionCode();
C++/CLI
public:
property OptionCode OptionCode {
   OptionCode get();
}

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


SubOption Property

[image]
PowerTCP Telnet for .NET
SubOption Property
See Also Send comments on this topic
Dart.Telnet Namespace > CommandEventArgs Class : SubOption Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SubOption As Byte()
Visual Basic (Usage) Copy Code
Dim instance As CommandEventArgs
Dim value() As Byte

value = instance.SubOption
C#
public byte[] SubOption {get;}
Managed Extensions for C++
public: __property byte[]* get_SubOption();
C++/CLI
public:
property array<byte>^ SubOption {
   array<byte>^ get();
}

See Also

Reference

CommandEventArgs Class
CommandEventArgs Members


ComponentBase Class

[image]
PowerTCP Telnet for .NET
ComponentBase Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : ComponentBase Class

Glossary Item Box

Object Model

ComponentBase Class

Syntax

Visual Basic (Declaration)
Public Class ComponentBase
   Inherits System.ComponentModel.Component
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
C#
public class ComponentBase : System.ComponentModel.Component
Managed Extensions for C++
public __gc class ComponentBase : public System.ComponentModel.Component
C++/CLI
public ref class ComponentBase : public System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Telnet.ComponentBase
Dart.Telnet.SocketBase

See Also

Reference

ComponentBase Members
Dart.Telnet Namespace


ComponentBase Class Members

[image]
PowerTCP Telnet for .NET
ComponentBase Class Members
See Also Properties Methods Events Send comments on this topic
Dart.Telnet Namespace : ComponentBase Class

Glossary Item Box

The following tables list the members exposed by ComponentBase.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding |
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SynchronizingObject |
Public Property | SyncRoot |
Public Property | Tag |
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error |
Public Event | UserState |
Top

See Also

Reference

ComponentBase Class
Dart.Telnet Namespace


ComponentBase Class Methods

[image]
PowerTCP Telnet for .NET
ComponentBase Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : ComponentBase Class

Glossary Item Box

For a list of all members of this type, see ComponentBase members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

ComponentBase Class
Dart.Telnet Namespace


Marshal Method

[image]
PowerTCP Telnet for .NET
Marshal Method
See Also Send comments on this topic
Dart.Telnet Namespace > ComponentBase Class : Marshal Method

Glossary Item Box

Overload List

Overload | Description
Marshal(String,Object) |
Marshal(Exception) |

See Also

Reference

ComponentBase Class
ComponentBase Members


Marshal(String,Object) Method

[image]
PowerTCP Telnet for .NET
Marshal(String,Object) Method
See Also Send comments on this topic
Dart.Telnet Namespace > ComponentBase Class > Marshal Method : Marshal(String,Object) Method

message
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal message As String, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim message As String
Dim state As Object

instance.Marshal(message, state)
C#
public void Marshal(
   string message,
   object state
)
Managed Extensions for C++
public: void Marshal(
   string* message,
   Object* state
)
C++/CLI
public:
void Marshal(
   String^ message,
   Object^ state
)

Parameters

message
state

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


Marshal(Exception) Method

[image]
PowerTCP Telnet for .NET
Marshal(Exception) Method
See Also Send comments on this topic
Dart.Telnet Namespace > ComponentBase Class > Marshal Method : Marshal(Exception) Method

exception

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim exception As Exception

instance.Marshal(exception)
C#
public void Marshal(
   Exception exception
)
Managed Extensions for C++
public: void Marshal(
   Exception* exception
)
C++/CLI
public:
void Marshal(
   Exception^ exception
)

Parameters

exception

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


ComponentBase Class Properties

[image]
PowerTCP Telnet for .NET
ComponentBase Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : ComponentBase Class

Glossary Item Box

For a list of all members of this type, see ComponentBase members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding |
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SynchronizingObject |
Public Property | SyncRoot |
Public Property | Tag |
Top

See Also

Reference

ComponentBase Class
Dart.Telnet Namespace


Encoding Property

[image]
PowerTCP Telnet for .NET
Encoding Property
See Also Send comments on this topic
Dart.Telnet Namespace > ComponentBase Class : Encoding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Encoding As Encoding
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Encoding

instance.Encoding = value

value = instance.Encoding
C#
public virtual Encoding Encoding {get; set;}
Managed Extensions for C++
public: __property virtual Encoding* get_Encoding();
public: __property virtual void set_Encoding(
   Encoding* value
);
C++/CLI
public:
virtual property Encoding^ Encoding {
   Encoding^ get();
   void set (    Encoding^ value);
}

See Also

Reference

ComponentBase Class
ComponentBase Members


SynchronizingObject Property

[image]
PowerTCP Telnet for .NET
SynchronizingObject Property
See Also Send comments on this topic
Dart.Telnet Namespace > ComponentBase Class : SynchronizingObject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("")>
Public Property SynchronizingObject As ISynchronizeInvoke
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As ISynchronizeInvoke

instance.SynchronizingObject = value

value = instance.SynchronizingObject
C#
[DefaultValue("")]
public ISynchronizeInvoke SynchronizingObject {get; set;}
Managed Extensions for C++
[DefaultValue("")]
public: __property ISynchronizeInvoke* get_SynchronizingObject();
public: __property void set_SynchronizingObject(
   ISynchronizeInvoke* value
);
C++/CLI
[DefaultValue("")]
public:
property ISynchronizeInvoke^ SynchronizingObject {
   ISynchronizeInvoke^ get();
   void set (    ISynchronizeInvoke^ value);
}

See Also

Reference

ComponentBase Class
ComponentBase Members


SyncRoot Property

[image]
PowerTCP Telnet for .NET
SyncRoot Property
See Also Send comments on this topic
Dart.Telnet Namespace > ComponentBase Class : SyncRoot Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

See Also

Reference

ComponentBase Class
ComponentBase Members


Tag Property

[image]
PowerTCP Telnet for .NET
Tag Property
See Also Send comments on this topic
Dart.Telnet Namespace > ComponentBase Class : Tag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("")>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[DefaultValue("")]
public object Tag {get; set;}
Managed Extensions for C++
[DefaultValue("")]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[DefaultValue("")]
public:
property Object^ Tag {
   Object^ get();
   void set (    Object^ value);
}

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Events

[image]
PowerTCP Telnet for .NET
ComponentBase Class Events
See Also Send comments on this topic
Dart.Telnet Namespace : ComponentBase Class

Glossary Item Box

For a list of all members of this type, see ComponentBase members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error |
Public Event | UserState |
Top

See Also

Reference

ComponentBase Class
Dart.Telnet Namespace


Error Event

[image]
PowerTCP Telnet for .NET
Error Event
See Also Send comments on this topic
Dart.Telnet Namespace > ComponentBase Class : Error Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Error As EventHandler(Of ErrorEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim handler As EventHandler(Of ErrorEventArgs)

AddHandler instance.Error, handler
C#
public event EventHandler<ErrorEventArgs> Error
Managed Extensions for C++
public: __event EventHandler<ErrorEventArgs*>* Error
C++/CLI
public:
event EventHandler<ErrorEventArgs^>^ Error

See Also

Reference

ComponentBase Class
ComponentBase Members


UserState Event

[image]
PowerTCP Telnet for .NET
UserState Event
See Also Send comments on this topic
Dart.Telnet Namespace > ComponentBase Class : UserState Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event UserState As EventHandler(Of UserStateEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim handler As EventHandler(Of UserStateEventArgs)

AddHandler instance.UserState, handler
C#
public event EventHandler<UserStateEventArgs> UserState
Managed Extensions for C++
public: __event EventHandler<UserStateEventArgs*>* UserState
C++/CLI
public:
event EventHandler<UserStateEventArgs^>^ UserState

Event Data

The event handler receives an argument of type UserStateEventArgs containing data related to this event. The following UserStateEventArgs properties provide information specific to this event.

Property | Description
Message |
UserState |

See Also

Reference

ComponentBase Class
ComponentBase Members


Credentials Class

[image]
PowerTCP Telnet for .NET
Credentials Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Credentials Class

Glossary Item Box

Object Model

Credentials Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class Credentials
Visual Basic (Usage) Copy Code
Dim instance As Credentials
C#
[Serializable()]
public class Credentials
Managed Extensions for C++
[Serializable()]
public __gc class Credentials
C++/CLI
[Serializable()]
public ref class Credentials

Inheritance Hierarchy

System.Object
Dart.Telnet.Credentials

See Also

Reference

Credentials Members
Dart.Telnet Namespace


Credentials Class Members

[image]
PowerTCP Telnet for .NET
Credentials Class Members
See Also Properties Send comments on this topic
Dart.Telnet Namespace : Credentials Class

Glossary Item Box

The following tables list the members exposed by Credentials.

Public Constructors

 | Name | Description
Public Constructor | Credentials Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CommandPrompt |
Public Property | Password |
Public Property | PasswordPrompt |
Public Property | PromptTimeout |
Public Property | Username |
Public Property | UsernamePrompt |
Top

See Also

Reference

Credentials Class
Dart.Telnet Namespace


Credentials Constructor

[image]
PowerTCP Telnet for .NET
Credentials Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Credentials Class : Credentials Constructor

Glossary Item Box

Overload List

Overload | Description
Credentials Constructor() |
Credentials Constructor(String,String,String) |

See Also

Reference

Credentials Class
Credentials Members


Credentials Constructor()

[image]
PowerTCP Telnet for .NET
Credentials Constructor()
See Also Send comments on this topic
Dart.Telnet Namespace > Credentials Class > Credentials Constructor : Credentials Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Credentials()
C#
public Credentials()
Managed Extensions for C++
public: Credentials();
C++/CLI
public:
Credentials();

See Also

Reference

Credentials Class
Credentials Members
Overload List


Credentials Constructor(String,String,String)

[image]
PowerTCP Telnet for .NET
Credentials Constructor(String,String,String)
See Also Send comments on this topic
Dart.Telnet Namespace > Credentials Class > Credentials Constructor : Credentials Constructor(String,String,String)

username
password
commandPrompt

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal username As String, _
   ByVal password As String, _
   ByVal commandPrompt As String _
)
Visual Basic (Usage) Copy Code
Dim username As String
Dim password As String
Dim commandPrompt As String

Dim instance As New Credentials(username, password, commandPrompt)
C#
public Credentials(
   string username,
   string password,
   string commandPrompt
)
Managed Extensions for C++
public: Credentials(
   string* username,
   string* password,
   string* commandPrompt
)
C++/CLI
public:
Credentials(
   String^ username,
   String^ password,
   String^ commandPrompt
)

Parameters

username
password
commandPrompt

See Also

Reference

Credentials Class
Credentials Members
Overload List


Credentials Class Properties

[image]
PowerTCP Telnet for .NET
Credentials Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Credentials Class

Glossary Item Box

For a list of all members of this type, see Credentials members.

Public Properties

 | Name | Description
Public Property | CommandPrompt |
Public Property | Password |
Public Property | PasswordPrompt |
Public Property | PromptTimeout |
Public Property | Username |
Public Property | UsernamePrompt |
Top

See Also

Reference

Credentials Class
Dart.Telnet Namespace


CommandPrompt Property

[image]
PowerTCP Telnet for .NET
CommandPrompt Property
See Also Send comments on this topic
Dart.Telnet Namespace > Credentials Class : CommandPrompt Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CommandPrompt As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.CommandPrompt = value

value = instance.CommandPrompt
C#
public string CommandPrompt {get; set;}
Managed Extensions for C++
public: __property string* get_CommandPrompt();
public: __property void set_CommandPrompt(
   string* value
);
C++/CLI
public:
property String^ CommandPrompt {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


Password Property

[image]
PowerTCP Telnet for .NET
Password Property
See Also Send comments on this topic
Dart.Telnet Namespace > Credentials Class : Password Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Password As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.Password = value

value = instance.Password
C#
public string Password {get; set;}
Managed Extensions for C++
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
C++/CLI
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


PasswordPrompt Property

[image]
PowerTCP Telnet for .NET
PasswordPrompt Property
See Also Send comments on this topic
Dart.Telnet Namespace > Credentials Class : PasswordPrompt Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PasswordPrompt As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.PasswordPrompt = value

value = instance.PasswordPrompt
C#
public string PasswordPrompt {get; set;}
Managed Extensions for C++
public: __property string* get_PasswordPrompt();
public: __property void set_PasswordPrompt(
   string* value
);
C++/CLI
public:
property String^ PasswordPrompt {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


PromptTimeout Property

[image]
PowerTCP Telnet for .NET
PromptTimeout Property
See Also Send comments on this topic
Dart.Telnet Namespace > Credentials Class : PromptTimeout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property PromptTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As Integer

instance.PromptTimeout = value

value = instance.PromptTimeout
C#
public int PromptTimeout {get; set;}
Managed Extensions for C++
public: __property int get_PromptTimeout();
public: __property void set_PromptTimeout(
   int value
);
C++/CLI
public:
property int PromptTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Credentials Class
Credentials Members


Username Property

[image]
PowerTCP Telnet for .NET
Username Property
See Also Send comments on this topic
Dart.Telnet Namespace > Credentials Class : Username Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Username As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.Username = value

value = instance.Username
C#
public string Username {get; set;}
Managed Extensions for C++
public: __property string* get_Username();
public: __property void set_Username(
   string* value
);
C++/CLI
public:
property String^ Username {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


UsernamePrompt Property

[image]
PowerTCP Telnet for .NET
UsernamePrompt Property
See Also Send comments on this topic
Dart.Telnet Namespace > Credentials Class : UsernamePrompt Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property UsernamePrompt As String
Visual Basic (Usage) Copy Code
Dim instance As Credentials
Dim value As String

instance.UsernamePrompt = value

value = instance.UsernamePrompt
C#
public string UsernamePrompt {get; set;}
Managed Extensions for C++
public: __property string* get_UsernamePrompt();
public: __property void set_UsernamePrompt(
   string* value
);
C++/CLI
public:
property String^ UsernamePrompt {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Credentials Class
Credentials Members


DartLicenseException Class

[image]
PowerTCP Telnet for .NET
DartLicenseException Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : DartLicenseException Class

Glossary Item Box

Object Model

DartLicenseException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class DartLicenseException
   Inherits System.Exception
Visual Basic (Usage) Copy Code
Dim instance As DartLicenseException
C#
[Serializable()]
public class DartLicenseException : System.Exception
Managed Extensions for C++
[Serializable()]
public __gc class DartLicenseException : public System.Exception
C++/CLI
[Serializable()]
public ref class DartLicenseException : public System.Exception

Inheritance Hierarchy

System.Object
System.Exception
Dart.Telnet.DartLicenseException

See Also

Reference

DartLicenseException Members
Dart.Telnet Namespace


DartLicenseException Class Members

[image]
PowerTCP Telnet for .NET
DartLicenseException Class Members
See Also Properties Methods Send comments on this topic
Dart.Telnet Namespace : DartLicenseException Class

Glossary Item Box

The following tables list the members exposed by DartLicenseException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Telnet Namespace


Data Class

[image]
PowerTCP Telnet for .NET
Data Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Data Class

Glossary Item Box

Object Model

Data Class

Syntax

Visual Basic (Declaration)
Public Class Data
   Inherits Segment
Visual Basic (Usage) Copy Code
Dim instance As Data
C#
public class Data : Segment
Managed Extensions for C++
public __gc class Data : public Segment
C++/CLI
public ref class Data : public Segment

Inheritance Hierarchy

System.Object
Dart.Telnet.Segment
Dart.Telnet.Data
Dart.Telnet.Datagram

See Also

Reference

Data Members
Dart.Telnet Namespace


Data Class Members

[image]
PowerTCP Telnet for .NET
Data Class Members
See Also Properties Methods Send comments on this topic
Dart.Telnet Namespace : Data Class

Glossary Item Box

The following tables list the members exposed by Data.

Public Properties

 | Name | Description
Public Property | Buffer | (Inherited from Dart.Telnet.Segment)
Public Property | Count | (Inherited from Dart.Telnet.Segment)
Public Property | Delimiter |
Public Property | Direction |
Public Property | Encoding |
Public Property | Offset | (Inherited from Dart.Telnet.Segment)
Top

Public Methods

 | Name | Description
Public Method | ToString |
Top

See Also

Reference

Data Class
Dart.Telnet Namespace


Data Class Methods

[image]
PowerTCP Telnet for .NET
Data Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : Data Class

Glossary Item Box

For a list of all members of this type, see Data members.

Public Methods

 | Name | Description
Public Method | ToString |
Top

See Also

Reference

Data Class
Dart.Telnet Namespace


ToString Method

[image]
PowerTCP Telnet for .NET
ToString Method
See Also Send comments on this topic
Dart.Telnet Namespace > Data Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

See Also

Reference

Data Class
Data Members


Data Class Properties

[image]
PowerTCP Telnet for .NET
Data Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Data Class

Glossary Item Box

For a list of all members of this type, see Data members.

Public Properties

 | Name | Description
Public Property | Buffer | (Inherited from Dart.Telnet.Segment)
Public Property | Count | (Inherited from Dart.Telnet.Segment)
Public Property | Delimiter |
Public Property | Direction |
Public Property | Encoding |
Public Property | Offset | (Inherited from Dart.Telnet.Segment)
Top

See Also

Reference

Data Class
Dart.Telnet Namespace


Delimiter Property

[image]
PowerTCP Telnet for .NET
Delimiter Property
See Also Send comments on this topic
Dart.Telnet Namespace > Data Class : Delimiter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delimiter As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value() As Byte

value = instance.Delimiter
C#
public byte[] Delimiter {get;}
Managed Extensions for C++
public: __property byte[]* get_Delimiter();
C++/CLI
public:
property array<byte>^ Delimiter {
   array<byte>^ get();
}

See Also

Reference

Data Class
Data Members


Direction Property

[image]
PowerTCP Telnet for .NET
Direction Property
See Also Send comments on this topic
Dart.Telnet Namespace > Data Class : Direction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Direction As DataDirection
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As DataDirection

value = instance.Direction
C#
public DataDirection Direction {get;}
Managed Extensions for C++
public: __property DataDirection get_Direction();
C++/CLI
public:
property DataDirection Direction {
   DataDirection get();
}

See Also

Reference

Data Class
Data Members


Encoding Property

[image]
PowerTCP Telnet for .NET
Encoding Property
See Also Send comments on this topic
Dart.Telnet Namespace > Data Class : Encoding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Encoding As Encoding
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As Encoding

value = instance.Encoding
C#
public Encoding Encoding {get;}
Managed Extensions for C++
public: __property Encoding* get_Encoding();
C++/CLI
public:
property Encoding^ Encoding {
   Encoding^ get();
}

See Also

Reference

Data Class
Data Members


DataEventArgs Class

[image]
PowerTCP Telnet for .NET
DataEventArgs Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : DataEventArgs Class

Glossary Item Box

Object Model

DataEventArgs ClassData Class

Syntax

Visual Basic (Declaration)
Public Class DataEventArgs
   Inherits UserStateEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataEventArgs
C#
public class DataEventArgs : UserStateEventArgs
Managed Extensions for C++
public __gc class DataEventArgs : public UserStateEventArgs
C++/CLI
public ref class DataEventArgs : public UserStateEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Telnet.UserStateEventArgs
Dart.Telnet.DataEventArgs

See Also

Reference

DataEventArgs Members
Dart.Telnet Namespace


DataEventArgs Class Members

[image]
PowerTCP Telnet for .NET
DataEventArgs Class Members
See Also Properties Methods Send comments on this topic
Dart.Telnet Namespace : DataEventArgs Class

Glossary Item Box

The following tables list the members exposed by DataEventArgs.

Public Properties

 | Name | Description
Public Property | Data |
Public Property | Message | (Inherited from Dart.Telnet.UserStateEventArgs)
Public Property | UserState | (Inherited from Dart.Telnet.UserStateEventArgs)
Top

Public Methods

 | Name | Description
Public Method | ToString |
Top

See Also

Reference

DataEventArgs Class
Dart.Telnet Namespace


DataEventArgs Class Methods

[image]
PowerTCP Telnet for .NET
DataEventArgs Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : DataEventArgs Class

Glossary Item Box

For a list of all members of this type, see DataEventArgs members.

Public Methods

 | Name | Description
Public Method | ToString |
Top

See Also

Reference

DataEventArgs Class
Dart.Telnet Namespace


ToString Method

[image]
PowerTCP Telnet for .NET
ToString Method
See Also Send comments on this topic
Dart.Telnet Namespace > DataEventArgs Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataEventArgs
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

See Also

Reference

DataEventArgs Class
DataEventArgs Members


DataEventArgs Class Properties

[image]
PowerTCP Telnet for .NET
DataEventArgs Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : DataEventArgs Class

Glossary Item Box

For a list of all members of this type, see DataEventArgs members.

Public Properties

 | Name | Description
Public Property | Data |
Public Property | Message | (Inherited from Dart.Telnet.UserStateEventArgs)
Public Property | UserState | (Inherited from Dart.Telnet.UserStateEventArgs)
Top

See Also

Reference

DataEventArgs Class
Dart.Telnet Namespace


Data Property

[image]
PowerTCP Telnet for .NET
Data Property
See Also Send comments on this topic
Dart.Telnet Namespace > DataEventArgs Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Data
Visual Basic (Usage) Copy Code
Dim instance As DataEventArgs
Dim value As Data

value = instance.Data
C#
public Data Data {get;}
Managed Extensions for C++
public: __property Data* get_Data();
C++/CLI
public:
property Data^ Data {
   Data^ get();
}

See Also

Reference

DataEventArgs Class
DataEventArgs Members


DataException Class

[image]
PowerTCP Telnet for .NET
DataException Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : DataException Class

Glossary Item Box

Object Model

DataException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class DataException
   Inherits System.ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As DataException
C#
[Serializable()]
public class DataException : System.ApplicationException
Managed Extensions for C++
[Serializable()]
public __gc class DataException : public System.ApplicationException
C++/CLI
[Serializable()]
public ref class DataException : public System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Dart.Telnet.DataException

See Also

Reference

DataException Members
Dart.Telnet Namespace


DataException Class Members

[image]
PowerTCP Telnet for .NET
DataException Class Members
See Also Fields Properties Methods Send comments on this topic
Dart.Telnet Namespace : DataException Class

Glossary Item Box

The following tables list the members exposed by DataException.

Public Fields

 | Name | Description
Public Field | DataRead |
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DataException Class
Dart.Telnet Namespace


DataException Class Fields

[image]
PowerTCP Telnet for .NET
DataException Class Fields
See Also Send comments on this topic
Dart.Telnet Namespace : DataException Class

Glossary Item Box

For a list of all members of this type, see DataException members.

Public Fields

 | Name | Description
Public Field | DataRead |
Top

See Also

Reference

DataException Class
Dart.Telnet Namespace


DataRead Field

[image]
PowerTCP Telnet for .NET
DataRead Field
See Also Send comments on this topic
Dart.Telnet Namespace > DataException Class : DataRead Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly DataRead As Data
Visual Basic (Usage) Copy Code
Dim instance As DataException
Dim value As Data

value = instance.DataRead
C#
public readonly Data DataRead
Managed Extensions for C++
public: readonly Data* DataRead
C++/CLI
public:
readonly Data^ DataRead

See Also

Reference

DataException Class
DataException Members


Datagram Class

[image]
PowerTCP Telnet for .NET
Datagram Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Datagram Class

Glossary Item Box

Object Model

Datagram Class

Syntax

Visual Basic (Declaration)
Public Class Datagram
   Inherits Data
Visual Basic (Usage) Copy Code
Dim instance As Datagram
C#
public class Datagram : Data
Managed Extensions for C++
public __gc class Datagram : public Data
C++/CLI
public ref class Datagram : public Data

Inheritance Hierarchy

System.Object
Dart.Telnet.Segment
Dart.Telnet.Data
Dart.Telnet.Datagram

See Also

Reference

Datagram Members
Dart.Telnet Namespace


Datagram Class Members

[image]
PowerTCP Telnet for .NET
Datagram Class Members
See Also Fields Properties Methods Send comments on this topic
Dart.Telnet Namespace : Datagram Class

Glossary Item Box

The following tables list the members exposed by Datagram.

Public Fields

 | Name | Description
Public Field | Origin |
Top

Public Properties

 | Name | Description
Public Property | Buffer | (Inherited from Dart.Telnet.Segment)
Public Property | Count | (Inherited from Dart.Telnet.Segment)
Public Property | Delimiter | (Inherited from Dart.Telnet.Data)
Public Property | Direction | (Inherited from Dart.Telnet.Data)
Public Property | Encoding | (Inherited from Dart.Telnet.Data)
Public Property | Offset | (Inherited from Dart.Telnet.Segment)
Top

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from Dart.Telnet.Data)
Top

See Also

Reference

Datagram Class
Dart.Telnet Namespace


Datagram Class Fields

[image]
PowerTCP Telnet for .NET
Datagram Class Fields
See Also Send comments on this topic
Dart.Telnet Namespace : Datagram Class

Glossary Item Box

For a list of all members of this type, see Datagram members.

Public Fields

 | Name | Description
Public Field | Origin |
Top

See Also

Reference

Datagram Class
Dart.Telnet Namespace


Origin Field

[image]
PowerTCP Telnet for .NET
Origin Field
See Also Send comments on this topic
Dart.Telnet Namespace > Datagram Class : Origin Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Origin As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As Datagram
Dim value As IPEndPoint

value = instance.Origin
C#
public readonly IPEndPoint Origin
Managed Extensions for C++
public: readonly IPEndPoint* Origin
C++/CLI
public:
readonly IPEndPoint^ Origin

See Also

Reference

Datagram Class
Datagram Members


ErrorEventArgs Class

[image]
PowerTCP Telnet for .NET
ErrorEventArgs Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : ErrorEventArgs Class

Glossary Item Box

Object Model

ErrorEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ErrorEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ErrorEventArgs
C#
public class ErrorEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class ErrorEventArgs : public System.EventArgs
C++/CLI
public ref class ErrorEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Telnet.ErrorEventArgs

See Also

Reference

ErrorEventArgs Members
Dart.Telnet Namespace


ErrorEventArgs Class Members

[image]
PowerTCP Telnet for .NET
ErrorEventArgs Class Members
See Also Methods Send comments on this topic
Dart.Telnet Namespace : ErrorEventArgs Class

Glossary Item Box

The following tables list the members exposed by ErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ErrorEventArgs Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetException |
Top

See Also

Reference

ErrorEventArgs Class
Dart.Telnet Namespace


ErrorEventArgs Constructor

[image]
PowerTCP Telnet for .NET
ErrorEventArgs Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > ErrorEventArgs Class : ErrorEventArgs Constructor

exception

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim exception As Exception

Dim instance As New ErrorEventArgs(exception)
C#
public ErrorEventArgs(
   Exception exception
)
Managed Extensions for C++
public: ErrorEventArgs(
   Exception* exception
)
C++/CLI
public:
ErrorEventArgs(
   Exception^ exception
)

Parameters

exception

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


ErrorEventArgs Class Methods

[image]
PowerTCP Telnet for .NET
ErrorEventArgs Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : ErrorEventArgs Class

Glossary Item Box

For a list of all members of this type, see ErrorEventArgs members.

Public Methods

 | Name | Description
Public Method | GetException |
Top

See Also

Reference

ErrorEventArgs Class
Dart.Telnet Namespace


GetException Method

[image]
PowerTCP Telnet for .NET
GetException Method
See Also Send comments on this topic
Dart.Telnet Namespace > ErrorEventArgs Class : GetException Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetException() As Exception
Visual Basic (Usage) Copy Code
Dim instance As ErrorEventArgs
Dim value As Exception

value = instance.GetException()
C#
public Exception GetException()
Managed Extensions for C++
public: Exception* GetException();
C++/CLI
public:
Exception^ GetException();

See Also

Reference

ErrorEventArgs Class
ErrorEventArgs Members


IPEndPoint Class

[image]
PowerTCP Telnet for .NET
IPEndPoint Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : IPEndPoint Class

Glossary Item Box

Object Model

IPEndPoint Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class IPEndPoint
   Inherits System.Net.IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
C#
[Serializable()]
public class IPEndPoint : System.Net.IPEndPoint
Managed Extensions for C++
[Serializable()]
public __gc class IPEndPoint : public System.Net.IPEndPoint
C++/CLI
[Serializable()]
public ref class IPEndPoint : public System.Net.IPEndPoint

Inheritance Hierarchy

System.Object
System.Net.EndPoint
System.Net.IPEndPoint
Dart.Telnet.IPEndPoint

See Also

Reference

IPEndPoint Members
Dart.Telnet Namespace


IPEndPoint Class Members

[image]
PowerTCP Telnet for .NET
IPEndPoint Class Members
See Also Fields Properties Methods Send comments on this topic
Dart.Telnet Namespace : IPEndPoint Class

Glossary Item Box

The following tables list the members exposed by IPEndPoint.

Public Constructors

 | Name | Description
Public Constructor | IPEndPoint Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | Range |
Top

Public Properties

 | Name | Description
Public Property | Address |
Public Property | AddressFamily | (Inherited from System.Net.IPEndPoint)
Public Property | HostNameOrAddress |
Public Property | HostNameOrAddressColonPort |
Public Property | Port |
Top

Public Methods

 | Name | Description
Public Method | Create | (Inherited from System.Net.IPEndPoint)
Public Method | Equals | (Inherited from System.Net.IPEndPoint)
Public Method | GetHashCode | (Inherited from System.Net.IPEndPoint)
Public Method | GetSchema |
Public Method | ReadXml |
Public Method | Serialize | (Inherited from System.Net.IPEndPoint)
Public Method | ToString | (Inherited from System.Net.IPEndPoint)
Public Method | WriteXml |
Top

See Also

Reference

IPEndPoint Class
Dart.Telnet Namespace


IPEndPoint Constructor

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class : IPEndPoint Constructor

Glossary Item Box

Overload List

Overload | Description
IPEndPoint Constructor() |
IPEndPoint Constructor(AddressFamily) |
IPEndPoint Constructor(IPAddress,Int32) |
IPEndPoint Constructor(IPAddress,Int32,Int32) |
IPEndPoint Constructor(String) |
IPEndPoint Constructor(String,Int32) |
IPEndPoint Constructor(String,AddressFamily,Int32) |
IPEndPoint Constructor(String,AddressFamily,Int32,Int32) |
IPEndPoint Constructor(String,String,Int32,Int32) |

See Also

Reference

IPEndPoint Class
IPEndPoint Members


IPEndPoint Constructor()

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor()
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New IPEndPoint()
C#
public IPEndPoint()
Managed Extensions for C++
public: IPEndPoint();
C++/CLI
public:
IPEndPoint();

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(AddressFamily)

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor(AddressFamily)
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(AddressFamily)

addressFamily

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal addressFamily As AddressFamily _
)
Visual Basic (Usage) Copy Code
Dim addressFamily As AddressFamily

Dim instance As New IPEndPoint(addressFamily)
C#
public IPEndPoint(
   AddressFamily addressFamily
)
Managed Extensions for C++
public: IPEndPoint(
   AddressFamily addressFamily
)
C++/CLI
public:
IPEndPoint(
   AddressFamily addressFamily
)

Parameters

addressFamily

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(IPAddress,Int32)

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor(IPAddress,Int32)
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(IPAddress,Int32)

address
port

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal address As IPAddress, _
   ByVal port As Integer _
)
Visual Basic (Usage) Copy Code
Dim address As IPAddress
Dim port As Integer

Dim instance As New IPEndPoint(address, port)
C#
public IPEndPoint(
   IPAddress address,
   int port
)
Managed Extensions for C++
public: IPEndPoint(
   IPAddress* address,
   int port
)
C++/CLI
public:
IPEndPoint(
   IPAddress^ address,
   int port
)

Parameters

address
port

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(IPAddress,Int32,Int32)

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor(IPAddress,Int32,Int32)
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(IPAddress,Int32,Int32)

address
port
range

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal address As IPAddress, _
   ByVal port As Integer, _
   ByVal range As Integer _
)
Visual Basic (Usage) Copy Code
Dim address As IPAddress
Dim port As Integer
Dim range As Integer

Dim instance As New IPEndPoint(address, port, range)
C#
public IPEndPoint(
   IPAddress address,
   int port,
   int range
)
Managed Extensions for C++
public: IPEndPoint(
   IPAddress* address,
   int port,
   int range
)
C++/CLI
public:
IPEndPoint(
   IPAddress^ address,
   int port,
   int range
)

Parameters

address
port
range

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String)

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor(String)
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String)

hostNameOrAddress

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String

Dim instance As New IPEndPoint(hostNameOrAddress)
C#
public IPEndPoint(
   string hostNameOrAddress
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String,Int32)

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor(String,Int32)
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String,Int32)

hostNameOrAddress
port

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String, _
   ByVal port As Integer _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String
Dim port As Integer

Dim instance As New IPEndPoint(hostNameOrAddress, port)
C#
public IPEndPoint(
   string hostNameOrAddress,
   int port
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress,
   int port
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress,
   int port
)

Parameters

hostNameOrAddress
port

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String,AddressFamily,Int32)

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor(String,AddressFamily,Int32)
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String,AddressFamily,Int32)

hostNameOrAddress
addressFamily
port

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String, _
   ByVal addressFamily As AddressFamily, _
   ByVal port As Integer _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String
Dim addressFamily As AddressFamily
Dim port As Integer

Dim instance As New IPEndPoint(hostNameOrAddress, addressFamily, port)
C#
public IPEndPoint(
   string hostNameOrAddress,
   AddressFamily addressFamily,
   int port
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress,
   AddressFamily addressFamily,
   int port
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress,
   AddressFamily addressFamily,
   int port
)

Parameters

hostNameOrAddress
addressFamily
port

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String,AddressFamily,Int32,Int32)

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor(String,AddressFamily,Int32,Int32)
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String,AddressFamily,Int32,Int32)

hostNameOrAddress
addressFamily
port
range

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String, _
   ByVal addressFamily As AddressFamily, _
   ByVal port As Integer, _
   ByVal range As Integer _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String
Dim addressFamily As AddressFamily
Dim port As Integer
Dim range As Integer

Dim instance As New IPEndPoint(hostNameOrAddress, addressFamily, port, range)
C#
public IPEndPoint(
   string hostNameOrAddress,
   AddressFamily addressFamily,
   int port,
   int range
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress,
   AddressFamily addressFamily,
   int port,
   int range
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress,
   AddressFamily addressFamily,
   int port,
   int range
)

Parameters

hostNameOrAddress
addressFamily
port
range

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Constructor(String,String,Int32,Int32)

[image]
PowerTCP Telnet for .NET
IPEndPoint Constructor(String,String,Int32,Int32)
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class > IPEndPoint Constructor : IPEndPoint Constructor(String,String,Int32,Int32)

hostNameOrAddress
address
port
range

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal hostNameOrAddress As String, _
   ByVal address As String, _
   ByVal port As Integer, _
   ByVal range As Integer _
)
Visual Basic (Usage) Copy Code
Dim hostNameOrAddress As String
Dim address As String
Dim port As Integer
Dim range As Integer

Dim instance As New IPEndPoint(hostNameOrAddress, address, port, range)
C#
public IPEndPoint(
   string hostNameOrAddress,
   string address,
   int port,
   int range
)
Managed Extensions for C++
public: IPEndPoint(
   string* hostNameOrAddress,
   string* address,
   int port,
   int range
)
C++/CLI
public:
IPEndPoint(
   String^ hostNameOrAddress,
   String^ address,
   int port,
   int range
)

Parameters

hostNameOrAddress
address
port
range

See Also

Reference

IPEndPoint Class
IPEndPoint Members
Overload List


IPEndPoint Class Methods

[image]
PowerTCP Telnet for .NET
IPEndPoint Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : IPEndPoint Class

Glossary Item Box

For a list of all members of this type, see IPEndPoint members.

Public Methods

 | Name | Description
Public Method | Create | (Inherited from System.Net.IPEndPoint)
Public Method | Equals | (Inherited from System.Net.IPEndPoint)
Public Method | GetHashCode | (Inherited from System.Net.IPEndPoint)
Public Method | GetSchema |
Public Method | ReadXml |
Public Method | Serialize | (Inherited from System.Net.IPEndPoint)
Public Method | ToString | (Inherited from System.Net.IPEndPoint)
Public Method | WriteXml |
Top

See Also

Reference

IPEndPoint Class
Dart.Telnet Namespace


GetSchema Method

[image]
PowerTCP Telnet for .NET
GetSchema Method
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class : GetSchema Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetSchema() As XmlSchema
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As XmlSchema

value = instance.GetSchema()
C#
public XmlSchema GetSchema()
Managed Extensions for C++
public: XmlSchema* GetSchema();
C++/CLI
public:
XmlSchema^ GetSchema();

See Also

Reference

IPEndPoint Class
IPEndPoint Members


ReadXml Method

[image]
PowerTCP Telnet for .NET
ReadXml Method
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class : ReadXml Method

reader

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ReadXml( _
   ByVal reader As XmlReader _
)
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim reader As XmlReader

instance.ReadXml(reader)
C#
public void ReadXml(
   XmlReader reader
)
Managed Extensions for C++
public: void ReadXml(
   XmlReader* reader
)
C++/CLI
public:
void ReadXml(
   XmlReader^ reader
)

Parameters

reader

See Also

Reference

IPEndPoint Class
IPEndPoint Members


WriteXml Method

[image]
PowerTCP Telnet for .NET
WriteXml Method
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class : WriteXml Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub WriteXml( _
   ByVal writer As XmlWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim writer As XmlWriter

instance.WriteXml(writer)
C#
public void WriteXml(
   XmlWriter writer
)
Managed Extensions for C++
public: void WriteXml(
   XmlWriter* writer
)
C++/CLI
public:
void WriteXml(
   XmlWriter^ writer
)

Parameters

writer

See Also

Reference

IPEndPoint Class
IPEndPoint Members


IPEndPoint Class Properties

[image]
PowerTCP Telnet for .NET
IPEndPoint Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : IPEndPoint Class

Glossary Item Box

For a list of all members of this type, see IPEndPoint members.

Public Properties

 | Name | Description
Public Property | Address |
Public Property | AddressFamily | (Inherited from System.Net.IPEndPoint)
Public Property | HostNameOrAddress |
Public Property | HostNameOrAddressColonPort |
Public Property | Port |
Top

See Also

Reference

IPEndPoint Class
Dart.Telnet Namespace


Address Property

[image]
PowerTCP Telnet for .NET
Address Property
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class : Address Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Property Address As IPAddress
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As IPAddress

instance.Address = value

value = instance.Address
C#
public new IPAddress Address {get; set;}
Managed Extensions for C++
public: __property new IPAddress* get_Address();
public: __property new void set_Address(
   IPAddress* value
);
C++/CLI
public:
new property IPAddress^ Address {
   IPAddress^ get();
   void set (    IPAddress^ value);
}

See Also

Reference

IPEndPoint Class
IPEndPoint Members


HostNameOrAddress Property

[image]
PowerTCP Telnet for .NET
HostNameOrAddress Property
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class : HostNameOrAddress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HostNameOrAddress As String
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As String

instance.HostNameOrAddress = value

value = instance.HostNameOrAddress
C#
public string HostNameOrAddress {get; set;}
Managed Extensions for C++
public: __property string* get_HostNameOrAddress();
public: __property void set_HostNameOrAddress(
   string* value
);
C++/CLI
public:
property String^ HostNameOrAddress {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

IPEndPoint Class
IPEndPoint Members


HostNameOrAddressColonPort Property

[image]
PowerTCP Telnet for .NET
HostNameOrAddressColonPort Property
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class : HostNameOrAddressColonPort Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HostNameOrAddressColonPort As String
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As String

value = instance.HostNameOrAddressColonPort
C#
public string HostNameOrAddressColonPort {get;}
Managed Extensions for C++
public: __property string* get_HostNameOrAddressColonPort();
C++/CLI
public:
property String^ HostNameOrAddressColonPort {
   String^ get();
}

See Also

Reference

IPEndPoint Class
IPEndPoint Members


Port Property

[image]
PowerTCP Telnet for .NET
Port Property
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class : Port Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(0)>
Public Shadows Property Port As Integer
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As Integer

instance.Port = value

value = instance.Port
C#
[DefaultValue(0)]
public new int Port {get; set;}
Managed Extensions for C++
[DefaultValue(0)]
public: __property new int get_Port();
public: __property new void set_Port(
   int value
);
C++/CLI
[DefaultValue(0)]
public:
new property int Port {
   int get();
   void set (    int value);
}

See Also

Reference

IPEndPoint Class
IPEndPoint Members


IPEndPoint Class Fields

[image]
PowerTCP Telnet for .NET
IPEndPoint Class Fields
See Also Send comments on this topic
Dart.Telnet Namespace : IPEndPoint Class

Glossary Item Box

For a list of all members of this type, see IPEndPoint members.

Public Fields

 | Name | Description
Public Field | Range |
Top

See Also

Reference

IPEndPoint Class
Dart.Telnet Namespace


Range Field

[image]
PowerTCP Telnet for .NET
Range Field
See Also Send comments on this topic
Dart.Telnet Namespace > IPEndPoint Class : Range Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Range As Integer
Visual Basic (Usage) Copy Code
Dim instance As IPEndPoint
Dim value As Integer

value = instance.Range

instance.Range = value
C#
public int Range
Managed Extensions for C++
public: int Range
C++/CLI
public:
int Range

See Also

Reference

IPEndPoint Class
IPEndPoint Members


License Class

[image]
PowerTCP Telnet for .NET
License Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : License Class

Glossary Item Box

Object Model

License Class

Syntax

Visual Basic (Declaration)
Public Class License
Visual Basic (Usage) Copy Code
Dim instance As License
C#
public class License
Managed Extensions for C++
public __gc class License
C++/CLI
public ref class License

Inheritance Hierarchy

System.Object
Dart.Telnet.License

See Also

Reference

License Members
Dart.Telnet Namespace


License Class Members

[image]
PowerTCP Telnet for .NET
License Class Members
See Also Methods Send comments on this topic
Dart.Telnet Namespace : License Class

Glossary Item Box

The following tables list the members exposed by License.

Public Constructors

 | Name | Description
Public Constructor | License Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
static (Shared in Visual Basic) | Set |
Top

See Also

Reference

License Class
Dart.Telnet Namespace


License Constructor

[image]
PowerTCP Telnet for .NET
License Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > License Class : License Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New License()
C#
public License()
Managed Extensions for C++
public: License();
C++/CLI
public:
License();

See Also

Reference

License Class
License Members


License Class Methods

[image]
PowerTCP Telnet for .NET
License Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : License Class

Glossary Item Box

For a list of all members of this type, see License members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create |
static (Shared in Visual Basic) | Set |
Top

See Also

Reference

License Class
Dart.Telnet Namespace


Create Method

[image]
PowerTCP Telnet for .NET
Create Method
See Also Send comments on this topic
Dart.Telnet Namespace > License Class : Create Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function Create() As String
Visual Basic (Usage) Copy Code
Dim value As String

value = License.Create()
C#
public static string Create()
Managed Extensions for C++
public: static string* Create();
C++/CLI
public:
static String^ Create();

See Also

Reference

License Class
License Members


Set Method

[image]
PowerTCP Telnet for .NET
Set Method
See Also Send comments on this topic
Dart.Telnet Namespace > License Class : Set Method

runtimeLicense

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub Set( _
   ByVal runtimeLicense As String _
)
Visual Basic (Usage) Copy Code
Dim runtimeLicense As String

License.Set(runtimeLicense)
C#
public static void Set(
   string runtimeLicense
)
Managed Extensions for C++
public: static void Set(
   string* runtimeLicense
)
C++/CLI
public:
static void Set(
   String^ runtimeLicense
)

Parameters

runtimeLicense

See Also

Reference

License Class
License Members


Option Class

[image]
PowerTCP Telnet for .NET
Option Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Option Class

Glossary Item Box

Object Model

Option Class

Syntax

Visual Basic (Declaration)
Public Class Option
Visual Basic (Usage) Copy Code
Dim instance As Option
C#
public class Option
Managed Extensions for C++
public __gc class Option
C++/CLI
public ref class Option

Inheritance Hierarchy

System.Object
Dart.Telnet.Option

See Also

Reference

Option Members
Dart.Telnet Namespace


Option Class Members

[image]
PowerTCP Telnet for .NET
Option Class Members
See Also Properties Methods Send comments on this topic
Dart.Telnet Namespace : Option Class

Glossary Item Box

The following tables list the members exposed by Option.

Public Constructors

 | Name | Description
Public Constructor | Option Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Code |
Public Property | State |
Public Property | SubOption |
Top

Public Methods

 | Name | Description
Public Method | Reset |
Top

See Also

Reference

Option Class
Dart.Telnet Namespace


Option Constructor

[image]
PowerTCP Telnet for .NET
Option Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class : Option Constructor

Glossary Item Box

Overload List

Overload | Description
Option Constructor() |
Option Constructor(OptionCode) |
Option Constructor(OptionCode,OptionState) |
Option Constructor(OptionCode,Byte[]) |
Option Constructor(OptionCode,Byte[],OptionState) |
Option Constructor(Byte[],Int32,Int32) |

See Also

Reference

Option Class
Option Members


Option Constructor()

[image]
PowerTCP Telnet for .NET
Option Constructor()
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Option()
C#
public Option()
Managed Extensions for C++
public: Option();
C++/CLI
public:
Option();

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode)

[image]
PowerTCP Telnet for .NET
Option Constructor(OptionCode)
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(OptionCode)

code

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode

Dim instance As New Option(code)
C#
public Option(
   OptionCode code
)
Managed Extensions for C++
public: Option(
   OptionCode code
)
C++/CLI
public:
Option(
   OptionCode code
)

Parameters

code

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode,OptionState)

[image]
PowerTCP Telnet for .NET
Option Constructor(OptionCode,OptionState)
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(OptionCode,OptionState)

code
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode, _
   ByVal state As OptionState _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode
Dim state As OptionState

Dim instance As New Option(code, state)
C#
public Option(
   OptionCode code,
   OptionState state
)
Managed Extensions for C++
public: Option(
   OptionCode code,
   OptionState state
)
C++/CLI
public:
Option(
   OptionCode code,
   OptionState state
)

Parameters

code
state

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode,Byte[])

[image]
PowerTCP Telnet for .NET
Option Constructor(OptionCode,Byte[])
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(OptionCode,Byte[])

code
subOption

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode, _
   ByVal subOption() As Byte _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode
Dim subOption() As Byte

Dim instance As New Option(code, subOption)
C#
public Option(
   OptionCode code,
   byte[] subOption
)
Managed Extensions for C++
public: Option(
   OptionCode code,
   byte[]* subOption
)
C++/CLI
public:
Option(
   OptionCode code,
   array<byte>^ subOption
)

Parameters

code
subOption

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(OptionCode,Byte[],OptionState)

[image]
PowerTCP Telnet for .NET
Option Constructor(OptionCode,Byte[],OptionState)
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(OptionCode,Byte[],OptionState)

code
subOption
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal code As OptionCode, _
   ByVal subOption() As Byte, _
   ByVal state As OptionState _
)
Visual Basic (Usage) Copy Code
Dim code As OptionCode
Dim subOption() As Byte
Dim state As OptionState

Dim instance As New Option(code, subOption, state)
C#
public Option(
   OptionCode code,
   byte[] subOption,
   OptionState state
)
Managed Extensions for C++
public: Option(
   OptionCode code,
   byte[]* subOption,
   OptionState state
)
C++/CLI
public:
Option(
   OptionCode code,
   array<byte>^ subOption,
   OptionState state
)

Parameters

code
subOption
state

See Also

Reference

Option Class
Option Members
Overload List


Option Constructor(Byte[],Int32,Int32)

[image]
PowerTCP Telnet for .NET
Option Constructor(Byte[],Int32,Int32)
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class > Option Constructor : Option Constructor(Byte[],Int32,Int32)

buffer
offset
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

Dim instance As New Option(buffer, offset, count)
C#
public Option(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Option(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Option(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
offset
count

See Also

Reference

Option Class
Option Members
Overload List


Option Class Methods

[image]
PowerTCP Telnet for .NET
Option Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : Option Class

Glossary Item Box

For a list of all members of this type, see Option members.

Public Methods

 | Name | Description
Public Method | Reset |
Top

See Also

Reference

Option Class
Dart.Telnet Namespace


Reset Method

[image]
PowerTCP Telnet for .NET
Reset Method
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As Option

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

See Also

Reference

Option Class
Option Members


Option Class Properties

[image]
PowerTCP Telnet for .NET
Option Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Option Class

Glossary Item Box

For a list of all members of this type, see Option members.

Public Properties

 | Name | Description
Public Property | Code |
Public Property | State |
Public Property | SubOption |
Top

See Also

Reference

Option Class
Dart.Telnet Namespace


Code Property

[image]
PowerTCP Telnet for .NET
Code Property
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class : Code Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Code As OptionCode
Visual Basic (Usage) Copy Code
Dim instance As Option
Dim value As OptionCode

instance.Code = value

value = instance.Code
C#
public OptionCode Code {get; set;}
Managed Extensions for C++
public: __property OptionCode get_Code();
public: __property void set_Code(
   OptionCode value
);
C++/CLI
public:
property OptionCode Code {
   OptionCode get();
   void set (    OptionCode value);
}

See Also

Reference

Option Class
Option Members


State Property

[image]
PowerTCP Telnet for .NET
State Property
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class : State Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(Mono.Cecil.CustomAttributeArgument)>
Public Property State As OptionState
Visual Basic (Usage) Copy Code
Dim instance As Option
Dim value As OptionState

instance.State = value

value = instance.State
C#
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public OptionState State {get; set;}
Managed Extensions for C++
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public: __property OptionState get_State();
public: __property void set_State(
   OptionState value
);
C++/CLI
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public:
property OptionState State {
   OptionState get();
   void set (    OptionState value);
}

See Also

Reference

Option Class
Option Members


SubOption Property

[image]
PowerTCP Telnet for .NET
SubOption Property
See Also Send comments on this topic
Dart.Telnet Namespace > Option Class : SubOption Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("")>
Public Property SubOption As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Option
Dim value() As Byte

instance.SubOption = value

value = instance.SubOption
C#
[DefaultValue("")]
public byte[] SubOption {get; set;}
Managed Extensions for C++
[DefaultValue("")]
public: __property byte[]* get_SubOption();
public: __property void set_SubOption(
   byte[][]* value
);
C++/CLI
[DefaultValue("")]
public:
property array<byte>^ SubOption {
   array<byte>^ get();
   void set (    array<byte>^ value);
}

See Also

Reference

Option Class
Option Members


OptionCollection Class

[image]
PowerTCP Telnet for .NET
OptionCollection Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : OptionCollection Class

Glossary Item Box

Object Model

OptionCollection ClassOption Class

Syntax

Visual Basic (Declaration)
Public Class OptionCollection
   Inherits System.Collections.Generic.List(Of Option)
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
C#
public class OptionCollection : System.Collections.Generic.List<Option>
Managed Extensions for C++
public __gc class OptionCollection : public System.Collections.Generic.List<Option>
C++/CLI
public ref class OptionCollection : public System.Collections.Generic.List<Option>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
Dart.Telnet.OptionCollection

See Also

Reference

OptionCollection Members
Dart.Telnet Namespace


OptionCollection Class Members

[image]
PowerTCP Telnet for .NET
OptionCollection Class Members
See Also Properties Methods Send comments on this topic
Dart.Telnet Namespace : OptionCollection Class

Glossary Item Box

The following tables list the members exposed by OptionCollection.

Public Constructors

 | Name | Description
Public Constructor | OptionCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<Option>)
Public Property | Count | Gets the number of elements contained in the List. (Inherited from System.Collections.Generic.List<Option>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<Option>)
Public Property | TransmitBinary |
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the List.
Public Method | AsReadOnly | Returns a read-only ReadOnlyCollection wrapper for the current collection. (Inherited from System.Collections.Generic.List<Option>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<Option>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Find | Overloaded. Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List.
Public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<Option>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<Option>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<Option>)
Public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<Option>)
Public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Top

See Also

Reference

OptionCollection Class
Dart.Telnet Namespace


OptionCollection Constructor

[image]
PowerTCP Telnet for .NET
OptionCollection Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > OptionCollection Class : OptionCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New OptionCollection()
C#
public OptionCollection()
Managed Extensions for C++
public: OptionCollection();
C++/CLI
public:
OptionCollection();

See Also

Reference

OptionCollection Class
OptionCollection Members


OptionCollection Class Methods

[image]
PowerTCP Telnet for .NET
OptionCollection Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : OptionCollection Class

Glossary Item Box

For a list of all members of this type, see OptionCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddRange | Overloaded. Adds the elements of the specified collection to the end of the List.
Public Method | AsReadOnly | Returns a read-only ReadOnlyCollection wrapper for the current collection. (Inherited from System.Collections.Generic.List<Option>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Clear | Removes all elements from the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Contains | Determines whether an element is in the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ConvertAll | Converts the elements in the current List to another type, and returns a list containing the converted elements. (Inherited from System.Collections.Generic.List<Option>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Exists | Determines whether the List contains elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Find | Overloaded. Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List.
Public Method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ForEach | Performs the specified action on each element of the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | GetEnumerator | Returns an enumerator that iterates through the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | GetRange | Creates a shallow copy of a range of elements in the source List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Insert | Inserts an element into the List at the specified index. (Inherited from System.Collections.Generic.List<Option>)
Public Method | InsertRange | Inserts the elements of a collection into the List at the specified index. (Inherited from System.Collections.Generic.List<Option>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Remove | Removes the first occurrence of a specific object from the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveAt | Removes the element at the specified index of the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | RemoveRange | Removes a range of elements from the List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire List. (Inherited from System.Collections.Generic.List<Option>)
Public Method | Sort | Overloaded. Sorts the elements in the entire List using the default comparer. (Inherited from System.Collections.Generic.List<Option>)
Public Method | ToArray | Copies the elements of the List to a new array. (Inherited from System.Collections.Generic.List<Option>)
Public Method | TrimExcess | Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value. (Inherited from System.Collections.Generic.List<Option>)
Public Method | TrueForAll | Determines whether every element in the List matches the conditions defined by the specified predicate. (Inherited from System.Collections.Generic.List<Option>)
Top

See Also

Reference

OptionCollection Class
Dart.Telnet Namespace


Add Method

[image]
PowerTCP Telnet for .NET
Add Method
See Also Send comments on this topic
Dart.Telnet Namespace > OptionCollection Class : Add Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Sub Add( _
   ByVal value As Option _
)
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim value As Option

instance.Add(value)
C#
public new void Add(
   Option value
)
Managed Extensions for C++
public: new void Add(
   Option* value
)
C++/CLI
public:
new void Add(
   Option^ value
)

Parameters

value

See Also

Reference

OptionCollection Class
OptionCollection Members


AddRange Method

[image]
PowerTCP Telnet for .NET
AddRange Method
See Also Send comments on this topic
Dart.Telnet Namespace > OptionCollection Class : AddRange Method

Glossary Item Box

Adds the elements of the specified collection to the end of the List.

Overload List

Overload | Description
AddRange(Option[]) |
AddRange(IEnumerable{Option}) | Adds the elements of the specified collection to the end of the List. (Inherited from System.Collections.Generic.List<Option>)

See Also

Reference

OptionCollection Class
OptionCollection Members


AddRange(Option[]) Method

[image]
PowerTCP Telnet for .NET
AddRange(Option[]) Method
See Also Send comments on this topic
Dart.Telnet Namespace > OptionCollection Class > AddRange Method : AddRange(Option[]) Method

items

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal items() As Option _
)
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim items() As Option

instance.AddRange(items)
C#
public void AddRange(
   Option[] items
)
Managed Extensions for C++
public: void AddRange(
   Option*[]* items
)
C++/CLI
public:
void AddRange(
   array<Option^>^ items
)

Parameters

items

See Also

Reference

OptionCollection Class
OptionCollection Members
Overload List


Find Method

[image]
PowerTCP Telnet for .NET
Find Method
See Also Send comments on this topic
Dart.Telnet Namespace > OptionCollection Class : Find Method

Glossary Item Box

Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List.

Overload List

Overload | Description
Find(OptionCode) |
Find(Predicate{Option}) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List. (Inherited from System.Collections.Generic.List<Option>)

See Also

Reference

OptionCollection Class
OptionCollection Members


Find(OptionCode) Method

[image]
PowerTCP Telnet for .NET
Find(OptionCode) Method
See Also Send comments on this topic
Dart.Telnet Namespace > OptionCollection Class > Find Method : Find(OptionCode) Method

code

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal code As OptionCode _
) As Option
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim code As OptionCode
Dim value As Option

value = instance.Find(code)
C#
public Option Find(
   OptionCode code
)
Managed Extensions for C++
public: Option* Find(
   OptionCode code
)
C++/CLI
public:
Option^ Find(
   OptionCode code
)

Parameters

code

See Also

Reference

OptionCollection Class
OptionCollection Members
Overload List


OptionCollection Class Properties

[image]
PowerTCP Telnet for .NET
OptionCollection Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : OptionCollection Class

Glossary Item Box

For a list of all members of this type, see OptionCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from System.Collections.Generic.List<Option>)
Public Property | Count | Gets the number of elements contained in the List. (Inherited from System.Collections.Generic.List<Option>)
Public Property | Item | Gets or sets the element at the specified index. (Inherited from System.Collections.Generic.List<Option>)
Public Property | TransmitBinary |
Top

See Also

Reference

OptionCollection Class
Dart.Telnet Namespace


TransmitBinary Property

[image]
PowerTCP Telnet for .NET
TransmitBinary Property
See Also Send comments on this topic
Dart.Telnet Namespace > OptionCollection Class : TransmitBinary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TransmitBinary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OptionCollection
Dim value As Boolean

value = instance.TransmitBinary
C#
public bool TransmitBinary {get;}
Managed Extensions for C++
public: __property bool get_TransmitBinary();
C++/CLI
public:
property bool TransmitBinary {
   bool get();
}

See Also

Reference

OptionCollection Class
OptionCollection Members


OptionEventArgs Class

[image]
PowerTCP Telnet for .NET
OptionEventArgs Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : OptionEventArgs Class

Glossary Item Box

Object Model

OptionEventArgs ClassOption Class

Syntax

Visual Basic (Declaration)
Public Class OptionEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As OptionEventArgs
C#
public class OptionEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class OptionEventArgs : public System.EventArgs
C++/CLI
public ref class OptionEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Telnet.OptionEventArgs

See Also

Reference

OptionEventArgs Members
Dart.Telnet Namespace


OptionEventArgs Class Members

[image]
PowerTCP Telnet for .NET
OptionEventArgs Class Members
See Also Properties Send comments on this topic
Dart.Telnet Namespace : OptionEventArgs Class

Glossary Item Box

The following tables list the members exposed by OptionEventArgs.

Public Properties

 | Name | Description
Public Property | Option |
Top

See Also

Reference

OptionEventArgs Class
Dart.Telnet Namespace


OptionEventArgs Class Properties

[image]
PowerTCP Telnet for .NET
OptionEventArgs Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : OptionEventArgs Class

Glossary Item Box

For a list of all members of this type, see OptionEventArgs members.

Public Properties

 | Name | Description
Public Property | Option |
Top

See Also

Reference

OptionEventArgs Class
Dart.Telnet Namespace


Option Property

[image]
PowerTCP Telnet for .NET
Option Property
See Also Send comments on this topic
Dart.Telnet Namespace > OptionEventArgs Class : Option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Option As Option
Visual Basic (Usage) Copy Code
Dim instance As OptionEventArgs
Dim value As Option

value = instance.Option
C#
public Option Option {get;}
Managed Extensions for C++
public: __property Option* get_Option();
C++/CLI
public:
property Option^ Option {
   Option^ get();
}

See Also

Reference

OptionEventArgs Class
OptionEventArgs Members


ProtocolException Class

[image]
PowerTCP Telnet for .NET
ProtocolException Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : ProtocolException Class

Glossary Item Box

Object Model

ProtocolException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class ProtocolException
   Inherits System.ApplicationException
Visual Basic (Usage) Copy Code
Dim instance As ProtocolException
C#
[Serializable()]
public class ProtocolException : System.ApplicationException
Managed Extensions for C++
[Serializable()]
public __gc class ProtocolException : public System.ApplicationException
C++/CLI
[Serializable()]
public ref class ProtocolException : public System.ApplicationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
Dart.Telnet.ProtocolException

See Also

Reference

ProtocolException Members
Dart.Telnet Namespace


ProtocolException Class Members

[image]
PowerTCP Telnet for .NET
ProtocolException Class Members
See Also Properties Methods Send comments on this topic
Dart.Telnet Namespace : ProtocolException Class

Glossary Item Box

The following tables list the members exposed by ProtocolException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ProtocolException Class
Dart.Telnet Namespace


Proxy Class

[image]
PowerTCP Telnet for .NET
Proxy Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Proxy Class

Glossary Item Box

Object Model

Proxy ClassIPEndPoint Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class Proxy
Visual Basic (Usage) Copy Code
Dim instance As Proxy
C#
[Serializable()]
public class Proxy
Managed Extensions for C++
[Serializable()]
public __gc class Proxy
C++/CLI
[Serializable()]
public ref class Proxy

Inheritance Hierarchy

System.Object
Dart.Telnet.Proxy

See Also

Reference

Proxy Members
Dart.Telnet Namespace


Proxy Class Members

[image]
PowerTCP Telnet for .NET
Proxy Class Members
See Also Properties Send comments on this topic
Dart.Telnet Namespace : Proxy Class

Glossary Item Box

The following tables list the members exposed by Proxy.

Public Constructors

 | Name | Description
Public Constructor | Proxy Constructor |
Top

Public Properties

 | Name | Description
Public Property | Password |
Public Property | RemoteEndPoint |
Public Property | Type |
Public Property | Username |
Top

See Also

Reference

Proxy Class
Dart.Telnet Namespace


Proxy Constructor

[image]
PowerTCP Telnet for .NET
Proxy Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Proxy Class : Proxy Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Proxy()
C#
public Proxy()
Managed Extensions for C++
public: Proxy();
C++/CLI
public:
Proxy();

See Also

Reference

Proxy Class
Proxy Members


Proxy Class Properties

[image]
PowerTCP Telnet for .NET
Proxy Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Proxy Class

Glossary Item Box

For a list of all members of this type, see Proxy members.

Public Properties

 | Name | Description
Public Property | Password |
Public Property | RemoteEndPoint |
Public Property | Type |
Public Property | Username |
Top

See Also

Reference

Proxy Class
Dart.Telnet Namespace


Password Property

[image]
PowerTCP Telnet for .NET
Password Property
See Also Send comments on this topic
Dart.Telnet Namespace > Proxy Class : Password Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("")>
Public Property Password As String
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As String

instance.Password = value

value = instance.Password
C#
[DefaultValue("")]
public string Password {get; set;}
Managed Extensions for C++
[DefaultValue("")]
public: __property string* get_Password();
public: __property void set_Password(
   string* value
);
C++/CLI
[DefaultValue("")]
public:
property String^ Password {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Proxy Class
Proxy Members


RemoteEndPoint Property

[image]
PowerTCP Telnet for .NET
RemoteEndPoint Property
See Also Send comments on this topic
Dart.Telnet Namespace > Proxy Class : RemoteEndPoint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RemoteEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As IPEndPoint

instance.RemoteEndPoint = value

value = instance.RemoteEndPoint
C#
public IPEndPoint RemoteEndPoint {get; set;}
Managed Extensions for C++
public: __property IPEndPoint* get_RemoteEndPoint();
public: __property void set_RemoteEndPoint(
   IPEndPoint* value
);
C++/CLI
public:
property IPEndPoint^ RemoteEndPoint {
   IPEndPoint^ get();
   void set (    IPEndPoint^ value);
}

See Also

Reference

Proxy Class
Proxy Members


Type Property

[image]
PowerTCP Telnet for .NET
Type Property
See Also Send comments on this topic
Dart.Telnet Namespace > Proxy Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(Mono.Cecil.CustomAttributeArgument)>
Public Property Type As ProxyType
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As ProxyType

instance.Type = value

value = instance.Type
C#
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public ProxyType Type {get; set;}
Managed Extensions for C++
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public: __property ProxyType get_Type();
public: __property void set_Type(
   ProxyType value
);
C++/CLI
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public:
property ProxyType Type {
   ProxyType get();
   void set (    ProxyType value);
}

See Also

Reference

Proxy Class
Proxy Members


Username Property

[image]
PowerTCP Telnet for .NET
Username Property
See Also Send comments on this topic
Dart.Telnet Namespace > Proxy Class : Username Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("")>
Public Property Username As String
Visual Basic (Usage) Copy Code
Dim instance As Proxy
Dim value As String

instance.Username = value

value = instance.Username
C#
[DefaultValue("")]
public string Username {get; set;}
Managed Extensions for C++
[DefaultValue("")]
public: __property string* get_Username();
public: __property void set_Username(
   string* value
);
C++/CLI
[DefaultValue("")]
public:
property String^ Username {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Proxy Class
Proxy Members


PtyBase Class

[image]
PowerTCP Telnet for .NET
PtyBase Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : PtyBase Class

Glossary Item Box

Object Model

PtyBase ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class PtyBase
   Inherits TcpBase
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
C#
public class PtyBase : TcpBase
Managed Extensions for C++
public __gc class PtyBase : public TcpBase
C++/CLI
public ref class PtyBase : public TcpBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Telnet.ComponentBase
Dart.Telnet.SocketBase
Dart.Telnet.TcpBase
Dart.Telnet.PtyBase
Dart.Telnet.Rlogin
Dart.Telnet.Telnet

See Also

Reference

PtyBase Members
Dart.Telnet Namespace


PtyBase Class Members

[image]
PowerTCP Telnet for .NET
PtyBase Class Members
See Also Properties Methods Events Send comments on this topic
Dart.Telnet Namespace : PtyBase Class

Glossary Item Box

The following tables list the members exposed by PtyBase.

Public Properties

 | Name | Description
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF |
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | LocalEcho |
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | Pty |
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | (Inherited from Dart.Telnet.TcpBase)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

Public Events

 | Name | Description
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Telnet Namespace


PtyBase Class Properties

[image]
PowerTCP Telnet for .NET
PtyBase Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : PtyBase Class

Glossary Item Box

For a list of all members of this type, see PtyBase members.

Public Properties

 | Name | Description
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF |
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | LocalEcho |
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | Pty |
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Telnet Namespace


CRLF Property

[image]
PowerTCP Telnet for .NET
CRLF Property
See Also Send comments on this topic
Dart.Telnet Namespace > PtyBase Class : CRLF Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(False)>
Public Property CRLF As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
Dim value As Boolean

instance.CRLF = value

value = instance.CRLF
C#
[DefaultValue(false)]
public bool CRLF {get; set;}
Managed Extensions for C++
[DefaultValue(false)]
public: __property bool get_CRLF();
public: __property void set_CRLF(
   bool value
);
C++/CLI
[DefaultValue(false)]
public:
property bool CRLF {
   bool get();
   void set (    bool value);
}

See Also

Reference

PtyBase Class
PtyBase Members


LocalEcho Property

[image]
PowerTCP Telnet for .NET
LocalEcho Property
See Also Send comments on this topic
Dart.Telnet Namespace > PtyBase Class : LocalEcho Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(False)>
Public Property LocalEcho As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
Dim value As Boolean

instance.LocalEcho = value

value = instance.LocalEcho
C#
[DefaultValue(false)]
public bool LocalEcho {get; set;}
Managed Extensions for C++
[DefaultValue(false)]
public: __property bool get_LocalEcho();
public: __property void set_LocalEcho(
   bool value
);
C++/CLI
[DefaultValue(false)]
public:
property bool LocalEcho {
   bool get();
   void set (    bool value);
}

See Also

Reference

PtyBase Class
PtyBase Members


Pty Property

[image]
PowerTCP Telnet for .NET
Pty Property
See Also Send comments on this topic
Dart.Telnet Namespace > PtyBase Class : Pty Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("")>
Public Property Pty As TextBoxBase
Visual Basic (Usage) Copy Code
Dim instance As PtyBase
Dim value As TextBoxBase

instance.Pty = value

value = instance.Pty
C#
[DefaultValue("")]
public TextBoxBase Pty {get; set;}
Managed Extensions for C++
[DefaultValue("")]
public: __property TextBoxBase* get_Pty();
public: __property void set_Pty(
   TextBoxBase* value
);
C++/CLI
[DefaultValue("")]
public:
property TextBoxBase^ Pty {
   TextBoxBase^ get();
   void set (    TextBoxBase^ value);
}

See Also

Reference

PtyBase Class
PtyBase Members


Rexec Class

[image]
PowerTCP Telnet for .NET
Rexec Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Rexec Class

Glossary Item Box

Object Model

Rexec ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Rexec
   Inherits TcpBase
Visual Basic (Usage) Copy Code
Dim instance As Rexec
C#
public class Rexec : TcpBase
Managed Extensions for C++
public __gc class Rexec : public TcpBase
C++/CLI
public ref class Rexec : public TcpBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Telnet.ComponentBase
Dart.Telnet.SocketBase
Dart.Telnet.TcpBase
Dart.Telnet.Rexec

See Also

Reference

Rexec Members
Dart.Telnet Namespace


Rexec Class Members

[image]
PowerTCP Telnet for .NET
Rexec Class Members
See Also Fields Properties Methods Events Send comments on this topic
Dart.Telnet Namespace : Rexec Class

Glossary Item Box

The following tables list the members exposed by Rexec.

Public Constructors

 | Name | Description
Public Constructor | Rexec Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultPort |
Top

Public Properties

 | Name | Description
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | Overloaded.
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Execute |
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | (Inherited from Dart.Telnet.TcpBase)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | Start |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

Public Events

 | Name | Description
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


Rexec Constructor

[image]
PowerTCP Telnet for .NET
Rexec Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Rexec Class : Rexec Constructor

Glossary Item Box

Overload List

Overload | Description
Rexec Constructor() |
Rexec Constructor(IContainer) |

See Also

Reference

Rexec Class
Rexec Members


Rexec Constructor()

[image]
PowerTCP Telnet for .NET
Rexec Constructor()
See Also Send comments on this topic
Dart.Telnet Namespace > Rexec Class > Rexec Constructor : Rexec Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rexec()
C#
public Rexec()
Managed Extensions for C++
public: Rexec();
C++/CLI
public:
Rexec();

See Also

Reference

Rexec Class
Rexec Members
Overload List


Rexec Constructor(IContainer)

[image]
PowerTCP Telnet for .NET
Rexec Constructor(IContainer)
See Also Send comments on this topic
Dart.Telnet Namespace > Rexec Class > Rexec Constructor : Rexec Constructor(IContainer)

container

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Rexec(container)
C#
public Rexec(
   IContainer container
)
Managed Extensions for C++
public: Rexec(
   IContainer* container
)
C++/CLI
public:
Rexec(
   IContainer^ container
)

Parameters

container

See Also

Reference

Rexec Class
Rexec Members
Overload List


Rexec Class Methods

[image]
PowerTCP Telnet for .NET
Rexec Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : Rexec Class

Glossary Item Box

For a list of all members of this type, see Rexec members.

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | Overloaded.
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Execute |
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | (Inherited from Dart.Telnet.TcpBase)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | Start |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


Connect Method

[image]
PowerTCP Telnet for .NET
Connect Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rexec Class : Connect Method

Glossary Item Box

Overload List

Overload | Description
Connect(String) |
Connect | (Inherited from Dart.Telnet.TcpBase)

See Also

Reference

Rexec Class
Rexec Members


Connect(String) Method

[image]
PowerTCP Telnet for .NET
Connect(String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rexec Class > Connect Method : Connect(String) Method

hostNameOrAddress

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rexec
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
)
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress

See Also

Reference

Rexec Class
Rexec Members
Overload List


Execute Method

[image]
PowerTCP Telnet for .NET
Execute Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rexec Class : Execute Method

username
password
command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Execute( _
   ByVal username As String, _
   ByVal password As String, _
   ByVal command As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rexec
Dim username As String
Dim password As String
Dim command As String

instance.Execute(username, password, command)
C#
public void Execute(
   string username,
   string password,
   string command
)
Managed Extensions for C++
public: void Execute(
   string* username,
   string* password,
   string* command
)
C++/CLI
public:
void Execute(
   String^ username,
   String^ password,
   String^ command
)

Parameters

username
password
command

See Also

Reference

Rexec Class
Rexec Members


Start Method

[image]
PowerTCP Telnet for .NET
Start Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rexec Class : Start Method

worker
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As WaitCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rexec
Dim worker As WaitCallback
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   WaitCallback worker,
   object state
)
Managed Extensions for C++
public: void Start(
   WaitCallback* worker,
   Object* state
)
C++/CLI
public:
void Start(
   WaitCallback^ worker,
   Object^ state
)

Parameters

worker
state

See Also

Reference

Rexec Class
Rexec Members


Rexec Class Fields

[image]
PowerTCP Telnet for .NET
Rexec Class Fields
See Also Send comments on this topic
Dart.Telnet Namespace : Rexec Class

Glossary Item Box

For a list of all members of this type, see Rexec members.

Public Fields

 | Name | Description
Public Field | DefaultPort |
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


DefaultPort Field

[image]
PowerTCP Telnet for .NET
DefaultPort Field
See Also Send comments on this topic
Dart.Telnet Namespace > Rexec Class : DefaultPort Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const DefaultPort As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = Rexec.DefaultPort
C#
public const int DefaultPort
Managed Extensions for C++
public: const int DefaultPort
C++/CLI
public:
const int DefaultPort

See Also

Reference

Rexec Class
Rexec Members


Rlogin Class

[image]
PowerTCP Telnet for .NET
Rlogin Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Rlogin Class

Glossary Item Box

Object Model

Rlogin ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Rlogin
   Inherits PtyBase
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
C#
public class Rlogin : PtyBase
Managed Extensions for C++
public __gc class Rlogin : public PtyBase
C++/CLI
public ref class Rlogin : public PtyBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Telnet.ComponentBase
Dart.Telnet.SocketBase
Dart.Telnet.TcpBase
Dart.Telnet.PtyBase
Dart.Telnet.Rlogin

See Also

Reference

Rlogin Members
Dart.Telnet Namespace


Rlogin Class Members

[image]
PowerTCP Telnet for .NET
Rlogin Class Members
See Also Fields Properties Methods Events Send comments on this topic
Dart.Telnet Namespace : Rlogin Class

Glossary Item Box

The following tables list the members exposed by Rlogin.

Public Constructors

 | Name | Description
Public Constructor | Rlogin Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultPort |
Top

Public Properties

 | Name | Description
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | (Inherited from Dart.Telnet.PtyBase)
Public Property | DisplayCharacters |
Public Property | DisplayPixels |
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | LocalEcho | (Inherited from Dart.Telnet.PtyBase)
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | Pty | (Inherited from Dart.Telnet.PtyBase)
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Public Property | TerminalTypeSpeed |
Top

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | Overloaded.
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | (Inherited from Dart.Telnet.TcpBase)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Login | Overloaded.
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | Start |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

Public Events

 | Name | Description
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


Rlogin Constructor

[image]
PowerTCP Telnet for .NET
Rlogin Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class : Rlogin Constructor

Glossary Item Box

Overload List

Overload | Description
Rlogin Constructor() |
Rlogin Constructor(IContainer) |

See Also

Reference

Rlogin Class
Rlogin Members


Rlogin Constructor()

[image]
PowerTCP Telnet for .NET
Rlogin Constructor()
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class > Rlogin Constructor : Rlogin Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rlogin()
C#
public Rlogin()
Managed Extensions for C++
public: Rlogin();
C++/CLI
public:
Rlogin();

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Rlogin Constructor(IContainer)

[image]
PowerTCP Telnet for .NET
Rlogin Constructor(IContainer)
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class > Rlogin Constructor : Rlogin Constructor(IContainer)

container

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Rlogin(container)
C#
public Rlogin(
   IContainer container
)
Managed Extensions for C++
public: Rlogin(
   IContainer* container
)
C++/CLI
public:
Rlogin(
   IContainer^ container
)

Parameters

container

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Rlogin Class Methods

[image]
PowerTCP Telnet for .NET
Rlogin Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : Rlogin Class

Glossary Item Box

For a list of all members of this type, see Rlogin members.

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | Overloaded.
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | (Inherited from Dart.Telnet.TcpBase)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Login | Overloaded.
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | Start |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


Connect Method

[image]
PowerTCP Telnet for .NET
Connect Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class : Connect Method

Glossary Item Box

Overload List

Overload | Description
Connect(String) |
Connect | (Inherited from Dart.Telnet.TcpBase)

See Also

Reference

Rlogin Class
Rlogin Members


Connect(String) Method

[image]
PowerTCP Telnet for .NET
Connect(String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class > Connect Method : Connect(String) Method

hostNameOrAddress

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
)
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Login Method

[image]
PowerTCP Telnet for .NET
Login Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class : Login Method

Glossary Item Box

Overload List

Overload | Description
Login(String) |
Login(String,String) |

See Also

Reference

Rlogin Class
Rlogin Members


Login(String) Method

[image]
PowerTCP Telnet for .NET
Login(String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class > Login Method : Login(String) Method

username

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Login( _
   ByVal username As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim username As String

instance.Login(username)
C#
public void Login(
   string username
)
Managed Extensions for C++
public: void Login(
   string* username
)
C++/CLI
public:
void Login(
   String^ username
)

Parameters

username

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Login(String,String) Method

[image]
PowerTCP Telnet for .NET
Login(String,String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class > Login Method : Login(String,String) Method

username
clientUsername

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Login( _
   ByVal username As String, _
   ByVal clientUsername As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim username As String
Dim clientUsername As String

instance.Login(username, clientUsername)
C#
public void Login(
   string username,
   string clientUsername
)
Managed Extensions for C++
public: void Login(
   string* username,
   string* clientUsername
)
C++/CLI
public:
void Login(
   String^ username,
   String^ clientUsername
)

Parameters

username
clientUsername

See Also

Reference

Rlogin Class
Rlogin Members
Overload List


Start Method

[image]
PowerTCP Telnet for .NET
Start Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class : Start Method

worker
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As WaitCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim worker As WaitCallback
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   WaitCallback worker,
   object state
)
Managed Extensions for C++
public: void Start(
   WaitCallback* worker,
   Object* state
)
C++/CLI
public:
void Start(
   WaitCallback^ worker,
   Object^ state
)

Parameters

worker
state

See Also

Reference

Rlogin Class
Rlogin Members


Rlogin Class Properties

[image]
PowerTCP Telnet for .NET
Rlogin Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Rlogin Class

Glossary Item Box

For a list of all members of this type, see Rlogin members.

Public Properties

 | Name | Description
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | (Inherited from Dart.Telnet.PtyBase)
Public Property | DisplayCharacters |
Public Property | DisplayPixels |
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | LocalEcho | (Inherited from Dart.Telnet.PtyBase)
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | Pty | (Inherited from Dart.Telnet.PtyBase)
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Public Property | TerminalTypeSpeed |
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


DisplayCharacters Property

[image]
PowerTCP Telnet for .NET
DisplayCharacters Property
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class : DisplayCharacters Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(System.Drawing.Size, "72,24")>
Public Property DisplayCharacters As Size
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim value As Size

instance.DisplayCharacters = value

value = instance.DisplayCharacters
C#
[DefaultValue(System.Drawing.Size, "72,24")]
public Size DisplayCharacters {get; set;}
Managed Extensions for C++
[DefaultValue(System.Drawing.Size, "72,24")]
public: __property Size get_DisplayCharacters();
public: __property void set_DisplayCharacters(
   Size value
);
C++/CLI
[DefaultValue(System.Drawing.Size, "72,24")]
public:
property Size DisplayCharacters {
   Size get();
   void set (    Size value);
}

See Also

Reference

Rlogin Class
Rlogin Members


DisplayPixels Property

[image]
PowerTCP Telnet for .NET
DisplayPixels Property
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class : DisplayPixels Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(System.Drawing.Size, "640,480")>
Public Property DisplayPixels As Size
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim value As Size

instance.DisplayPixels = value

value = instance.DisplayPixels
C#
[DefaultValue(System.Drawing.Size, "640,480")]
public Size DisplayPixels {get; set;}
Managed Extensions for C++
[DefaultValue(System.Drawing.Size, "640,480")]
public: __property Size get_DisplayPixels();
public: __property void set_DisplayPixels(
   Size value
);
C++/CLI
[DefaultValue(System.Drawing.Size, "640,480")]
public:
property Size DisplayPixels {
   Size get();
   void set (    Size value);
}

See Also

Reference

Rlogin Class
Rlogin Members


TerminalTypeSpeed Property

[image]
PowerTCP Telnet for .NET
TerminalTypeSpeed Property
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class : TerminalTypeSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("vt320/19200")>
Public Property TerminalTypeSpeed As String
Visual Basic (Usage) Copy Code
Dim instance As Rlogin
Dim value As String

instance.TerminalTypeSpeed = value

value = instance.TerminalTypeSpeed
C#
[DefaultValue("vt320/19200")]
public string TerminalTypeSpeed {get; set;}
Managed Extensions for C++
[DefaultValue("vt320/19200")]
public: __property string* get_TerminalTypeSpeed();
public: __property void set_TerminalTypeSpeed(
   string* value
);
C++/CLI
[DefaultValue("vt320/19200")]
public:
property String^ TerminalTypeSpeed {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Rlogin Class
Rlogin Members


Rlogin Class Fields

[image]
PowerTCP Telnet for .NET
Rlogin Class Fields
See Also Send comments on this topic
Dart.Telnet Namespace : Rlogin Class

Glossary Item Box

For a list of all members of this type, see Rlogin members.

Public Fields

 | Name | Description
Public Field | DefaultPort |
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


DefaultPort Field

[image]
PowerTCP Telnet for .NET
DefaultPort Field
See Also Send comments on this topic
Dart.Telnet Namespace > Rlogin Class : DefaultPort Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const DefaultPort As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = Rlogin.DefaultPort
C#
public const int DefaultPort
Managed Extensions for C++
public: const int DefaultPort
C++/CLI
public:
const int DefaultPort

See Also

Reference

Rlogin Class
Rlogin Members


Rsh Class

[image]
PowerTCP Telnet for .NET
Rsh Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Rsh Class

Glossary Item Box

Object Model

Rsh ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Rsh
   Inherits TcpBase
Visual Basic (Usage) Copy Code
Dim instance As Rsh
C#
public class Rsh : TcpBase
Managed Extensions for C++
public __gc class Rsh : public TcpBase
C++/CLI
public ref class Rsh : public TcpBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Telnet.ComponentBase
Dart.Telnet.SocketBase
Dart.Telnet.TcpBase
Dart.Telnet.Rsh

See Also

Reference

Rsh Members
Dart.Telnet Namespace


Rsh Class Members

[image]
PowerTCP Telnet for .NET
Rsh Class Members
See Also Fields Properties Methods Events Send comments on this topic
Dart.Telnet Namespace : Rsh Class

Glossary Item Box

The following tables list the members exposed by Rsh.

Public Constructors

 | Name | Description
Public Constructor | Rsh Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultPort |
Top

Public Properties

 | Name | Description
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | Overloaded.
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Execute | Overloaded.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | (Inherited from Dart.Telnet.TcpBase)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | Start |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

Public Events

 | Name | Description
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


Rsh Constructor

[image]
PowerTCP Telnet for .NET
Rsh Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class : Rsh Constructor

Glossary Item Box

Overload List

Overload | Description
Rsh Constructor() |
Rsh Constructor(IContainer) |

See Also

Reference

Rsh Class
Rsh Members


Rsh Constructor()

[image]
PowerTCP Telnet for .NET
Rsh Constructor()
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class > Rsh Constructor : Rsh Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Rsh()
C#
public Rsh()
Managed Extensions for C++
public: Rsh();
C++/CLI
public:
Rsh();

See Also

Reference

Rsh Class
Rsh Members
Overload List


Rsh Constructor(IContainer)

[image]
PowerTCP Telnet for .NET
Rsh Constructor(IContainer)
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class > Rsh Constructor : Rsh Constructor(IContainer)

container

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Rsh(container)
C#
public Rsh(
   IContainer container
)
Managed Extensions for C++
public: Rsh(
   IContainer* container
)
C++/CLI
public:
Rsh(
   IContainer^ container
)

Parameters

container

See Also

Reference

Rsh Class
Rsh Members
Overload List


Rsh Class Methods

[image]
PowerTCP Telnet for .NET
Rsh Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : Rsh Class

Glossary Item Box

For a list of all members of this type, see Rsh members.

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | Overloaded.
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Execute | Overloaded.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | (Inherited from Dart.Telnet.TcpBase)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | Start |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


Connect Method

[image]
PowerTCP Telnet for .NET
Connect Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class : Connect Method

Glossary Item Box

Overload List

Overload | Description
Connect(String) |
Connect | (Inherited from Dart.Telnet.TcpBase)

See Also

Reference

Rsh Class
Rsh Members


Connect(String) Method

[image]
PowerTCP Telnet for .NET
Connect(String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class > Connect Method : Connect(String) Method

hostNameOrAddress

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
)
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress

See Also

Reference

Rsh Class
Rsh Members
Overload List


Execute Method

[image]
PowerTCP Telnet for .NET
Execute Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class : Execute Method

Glossary Item Box

Overload List

Overload | Description
Execute(String,String) |
Execute(String,String,String) |

See Also

Reference

Rsh Class
Rsh Members


Execute(String,String) Method

[image]
PowerTCP Telnet for .NET
Execute(String,String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class > Execute Method : Execute(String,String) Method

username
command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Execute( _
   ByVal username As String, _
   ByVal command As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim username As String
Dim command As String

instance.Execute(username, command)
C#
public void Execute(
   string username,
   string command
)
Managed Extensions for C++
public: void Execute(
   string* username,
   string* command
)
C++/CLI
public:
void Execute(
   String^ username,
   String^ command
)

Parameters

username
command

See Also

Reference

Rsh Class
Rsh Members
Overload List


Execute(String,String,String) Method

[image]
PowerTCP Telnet for .NET
Execute(String,String,String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class > Execute Method : Execute(String,String,String) Method

username
command
clientUsername

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Execute( _
   ByVal username As String, _
   ByVal command As String, _
   ByVal clientUsername As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim username As String
Dim command As String
Dim clientUsername As String

instance.Execute(username, command, clientUsername)
C#
public void Execute(
   string username,
   string command,
   string clientUsername
)
Managed Extensions for C++
public: void Execute(
   string* username,
   string* command,
   string* clientUsername
)
C++/CLI
public:
void Execute(
   String^ username,
   String^ command,
   String^ clientUsername
)

Parameters

username
command
clientUsername

See Also

Reference

Rsh Class
Rsh Members
Overload List


Start Method

[image]
PowerTCP Telnet for .NET
Start Method
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class : Start Method

worker
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As WaitCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Rsh
Dim worker As WaitCallback
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   WaitCallback worker,
   object state
)
Managed Extensions for C++
public: void Start(
   WaitCallback* worker,
   Object* state
)
C++/CLI
public:
void Start(
   WaitCallback^ worker,
   Object^ state
)

Parameters

worker
state

See Also

Reference

Rsh Class
Rsh Members


Rsh Class Fields

[image]
PowerTCP Telnet for .NET
Rsh Class Fields
See Also Send comments on this topic
Dart.Telnet Namespace : Rsh Class

Glossary Item Box

For a list of all members of this type, see Rsh members.

Public Fields

 | Name | Description
Public Field | DefaultPort |
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


DefaultPort Field

[image]
PowerTCP Telnet for .NET
DefaultPort Field
See Also Send comments on this topic
Dart.Telnet Namespace > Rsh Class : DefaultPort Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const DefaultPort As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = Rsh.DefaultPort
C#
public const int DefaultPort
Managed Extensions for C++
public: const int DefaultPort
C++/CLI
public:
const int DefaultPort

See Also

Reference

Rsh Class
Rsh Members


Security Class

[image]
PowerTCP Telnet for .NET
Security Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Security Class

Glossary Item Box

Object Model

Security Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class Security
Visual Basic (Usage) Copy Code
Dim instance As Security
C#
[Serializable()]
public class Security
Managed Extensions for C++
[Serializable()]
public __gc class Security
C++/CLI
[Serializable()]
public ref class Security

Inheritance Hierarchy

System.Object
Dart.Telnet.Security
Dart.Telnet.ClientSecurity

See Also

Reference

Security Members
Dart.Telnet Namespace


Security Class Members

[image]
PowerTCP Telnet for .NET
Security Class Members
See Also Fields Properties Send comments on this topic
Dart.Telnet Namespace : Security Class

Glossary Item Box

The following tables list the members exposed by Security.

Public Constructors

 | Name | Description
Public Constructor | Security Constructor |
Top

Public Fields

 | Name | Description
Public Field | ValidationCallback |
Top

Public Properties

 | Name | Description
Public Property | CheckCertificateRevocation |
Public Property | Protocols |
Top

See Also

Reference

Security Class
Dart.Telnet Namespace


Security Constructor

[image]
PowerTCP Telnet for .NET
Security Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Security Class : Security Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Security()
C#
public Security()
Managed Extensions for C++
public: Security();
C++/CLI
public:
Security();

See Also

Reference

Security Class
Security Members


Security Class Properties

[image]
PowerTCP Telnet for .NET
Security Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Security Class

Glossary Item Box

For a list of all members of this type, see Security members.

Public Properties

 | Name | Description
Public Property | CheckCertificateRevocation |
Public Property | Protocols |
Top

See Also

Reference

Security Class
Dart.Telnet Namespace


CheckCertificateRevocation Property

[image]
PowerTCP Telnet for .NET
CheckCertificateRevocation Property
See Also Send comments on this topic
Dart.Telnet Namespace > Security Class : CheckCertificateRevocation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(False)>
Public Property CheckCertificateRevocation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As Boolean

instance.CheckCertificateRevocation = value

value = instance.CheckCertificateRevocation
C#
[DefaultValue(false)]
public bool CheckCertificateRevocation {get; set;}
Managed Extensions for C++
[DefaultValue(false)]
public: __property bool get_CheckCertificateRevocation();
public: __property void set_CheckCertificateRevocation(
   bool value
);
C++/CLI
[DefaultValue(false)]
public:
property bool CheckCertificateRevocation {
   bool get();
   void set (    bool value);
}

See Also

Reference

Security Class
Security Members


Protocols Property

[image]
PowerTCP Telnet for .NET
Protocols Property
See Also Send comments on this topic
Dart.Telnet Namespace > Security Class : Protocols Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(Mono.Cecil.CustomAttributeArgument)>
Public Property Protocols As SslProtocols
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As SslProtocols

instance.Protocols = value

value = instance.Protocols
C#
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public SslProtocols Protocols {get; set;}
Managed Extensions for C++
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public: __property SslProtocols get_Protocols();
public: __property void set_Protocols(
   SslProtocols value
);
C++/CLI
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public:
property SslProtocols Protocols {
   SslProtocols get();
   void set (    SslProtocols value);
}

See Also

Reference

Security Class
Security Members


Security Class Fields

[image]
PowerTCP Telnet for .NET
Security Class Fields
See Also Send comments on this topic
Dart.Telnet Namespace : Security Class

Glossary Item Box

For a list of all members of this type, see Security members.

Public Fields

 | Name | Description
Public Field | ValidationCallback |
Top

See Also

Reference

Security Class
Dart.Telnet Namespace


ValidationCallback Field

[image]
PowerTCP Telnet for .NET
ValidationCallback Field
See Also Send comments on this topic
Dart.Telnet Namespace > Security Class : ValidationCallback Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ValidationCallback As RemoteCertificateValidationCallback
Visual Basic (Usage) Copy Code
Dim instance As Security
Dim value As RemoteCertificateValidationCallback

value = instance.ValidationCallback

instance.ValidationCallback = value
C#
public RemoteCertificateValidationCallback ValidationCallback
Managed Extensions for C++
public: RemoteCertificateValidationCallback* ValidationCallback
C++/CLI
public:
RemoteCertificateValidationCallback^ ValidationCallback

See Also

Reference

Security Class
Security Members


Segment Class

[image]
PowerTCP Telnet for .NET
Segment Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Segment Class

Glossary Item Box

Object Model

Segment Class

Syntax

Visual Basic (Declaration)
Public Class Segment
Visual Basic (Usage) Copy Code
Dim instance As Segment
C#
public class Segment
Managed Extensions for C++
public __gc class Segment
C++/CLI
public ref class Segment

Inheritance Hierarchy

System.Object
Dart.Telnet.Segment
Dart.Telnet.Data

See Also

Reference

Segment Members
Dart.Telnet Namespace


Segment Class Members

[image]
PowerTCP Telnet for .NET
Segment Class Members
See Also Properties Send comments on this topic
Dart.Telnet Namespace : Segment Class

Glossary Item Box

The following tables list the members exposed by Segment.

Public Constructors

 | Name | Description
Public Constructor | Segment Constructor |
Top

Public Properties

 | Name | Description
Public Property | Buffer |
Public Property | Count |
Public Property | Offset |
Top

See Also

Reference

Segment Class
Dart.Telnet Namespace


Segment Constructor

[image]
PowerTCP Telnet for .NET
Segment Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Segment Class : Segment Constructor

buffer
offset
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

Dim instance As New Segment(buffer, offset, count)
C#
public Segment(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Segment(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Segment(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
offset
count

See Also

Reference

Segment Class
Segment Members


Segment Class Properties

[image]
PowerTCP Telnet for .NET
Segment Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Segment Class

Glossary Item Box

For a list of all members of this type, see Segment members.

Public Properties

 | Name | Description
Public Property | Buffer |
Public Property | Count |
Public Property | Offset |
Top

See Also

Reference

Segment Class
Dart.Telnet Namespace


Buffer Property

[image]
PowerTCP Telnet for .NET
Buffer Property
See Also Send comments on this topic
Dart.Telnet Namespace > Segment Class : Buffer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Buffer As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Segment
Dim value() As Byte

value = instance.Buffer
C#
public byte[] Buffer {get;}
Managed Extensions for C++
public: __property byte[]* get_Buffer();
C++/CLI
public:
property array<byte>^ Buffer {
   array<byte>^ get();
}

See Also

Reference

Segment Class
Segment Members


Count Property

[image]
PowerTCP Telnet for .NET
Count Property
See Also Send comments on this topic
Dart.Telnet Namespace > Segment Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Segment
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

See Also

Reference

Segment Class
Segment Members


Offset Property

[image]
PowerTCP Telnet for .NET
Offset Property
See Also Send comments on this topic
Dart.Telnet Namespace > Segment Class : Offset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Offset As Integer
Visual Basic (Usage) Copy Code
Dim instance As Segment
Dim value As Integer

value = instance.Offset
C#
public int Offset {get;}
Managed Extensions for C++
public: __property int get_Offset();
C++/CLI
public:
property int Offset {
   int get();
}

See Also

Reference

Segment Class
Segment Members


Session Class

[image]
PowerTCP Telnet for .NET
Session Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Session Class

Glossary Item Box

Object Model

Session ClassIPEndPoint ClassIPEndPoint Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class Session
Visual Basic (Usage) Copy Code
Dim instance As Session
C#
[Serializable()]
public class Session
Managed Extensions for C++
[Serializable()]
public __gc class Session
C++/CLI
[Serializable()]
public ref class Session

Inheritance Hierarchy

System.Object
Dart.Telnet.Session
Dart.Telnet.TcpSession

See Also

Reference

Session Members
Dart.Telnet Namespace


Session Class Members

[image]
PowerTCP Telnet for .NET
Session Class Members
See Also Properties Send comments on this topic
Dart.Telnet Namespace : Session Class

Glossary Item Box

The following tables list the members exposed by Session.

Public Constructors

 | Name | Description
Public Constructor | Session Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | LocalEndPoint |
Public Property | RemoteEndPoint |
Top

See Also

Reference

Session Class
Dart.Telnet Namespace


Session Constructor

[image]
PowerTCP Telnet for .NET
Session Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Session Class : Session Constructor

Glossary Item Box

Overload List

Overload | Description
Session Constructor() |
Session Constructor(IPEndPoint) |

See Also

Reference

Session Class
Session Members


Session Constructor()

[image]
PowerTCP Telnet for .NET
Session Constructor()
See Also Send comments on this topic
Dart.Telnet Namespace > Session Class > Session Constructor : Session Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Session()
C#
public Session()
Managed Extensions for C++
public: Session();
C++/CLI
public:
Session();

See Also

Reference

Session Class
Session Members
Overload List


Session Constructor(IPEndPoint)

[image]
PowerTCP Telnet for .NET
Session Constructor(IPEndPoint)
See Also Send comments on this topic
Dart.Telnet Namespace > Session Class > Session Constructor : Session Constructor(IPEndPoint)

remoteEP

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal remoteEP As IPEndPoint _
)
Visual Basic (Usage) Copy Code
Dim remoteEP As IPEndPoint

Dim instance As New Session(remoteEP)
C#
public Session(
   IPEndPoint remoteEP
)
Managed Extensions for C++
public: Session(
   IPEndPoint* remoteEP
)
C++/CLI
public:
Session(
   IPEndPoint^ remoteEP
)

Parameters

remoteEP

See Also

Reference

Session Class
Session Members
Overload List


Session Class Properties

[image]
PowerTCP Telnet for .NET
Session Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Session Class

Glossary Item Box

For a list of all members of this type, see Session members.

Public Properties

 | Name | Description
Public Property | LocalEndPoint |
Public Property | RemoteEndPoint |
Top

See Also

Reference

Session Class
Dart.Telnet Namespace


LocalEndPoint Property

[image]
PowerTCP Telnet for .NET
LocalEndPoint Property
See Also Send comments on this topic
Dart.Telnet Namespace > Session Class : LocalEndPoint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LocalEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As Session
Dim value As IPEndPoint

instance.LocalEndPoint = value

value = instance.LocalEndPoint
C#
public IPEndPoint LocalEndPoint {get; set;}
Managed Extensions for C++
public: __property IPEndPoint* get_LocalEndPoint();
public: __property void set_LocalEndPoint(
   IPEndPoint* value
);
C++/CLI
public:
property IPEndPoint^ LocalEndPoint {
   IPEndPoint^ get();
   void set (    IPEndPoint^ value);
}

See Also

Reference

Session Class
Session Members


RemoteEndPoint Property

[image]
PowerTCP Telnet for .NET
RemoteEndPoint Property
See Also Send comments on this topic
Dart.Telnet Namespace > Session Class : RemoteEndPoint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RemoteEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As Session
Dim value As IPEndPoint

instance.RemoteEndPoint = value

value = instance.RemoteEndPoint
C#
public IPEndPoint RemoteEndPoint {get; set;}
Managed Extensions for C++
public: __property IPEndPoint* get_RemoteEndPoint();
public: __property void set_RemoteEndPoint(
   IPEndPoint* value
);
C++/CLI
public:
property IPEndPoint^ RemoteEndPoint {
   IPEndPoint^ get();
   void set (    IPEndPoint^ value);
}

See Also

Reference

Session Class
Session Members


SocketBase Class

[image]
PowerTCP Telnet for .NET
SocketBase Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : SocketBase Class

Glossary Item Box

Object Model

SocketBase Class

Syntax

Visual Basic (Declaration)
Public Class SocketBase
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As SocketBase
C#
public class SocketBase : ComponentBase
Managed Extensions for C++
public __gc class SocketBase : public ComponentBase
C++/CLI
public ref class SocketBase : public ComponentBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Telnet.ComponentBase
Dart.Telnet.SocketBase
Dart.Telnet.TcpBase

See Also

Reference

SocketBase Members
Dart.Telnet Namespace


SocketBase Class Members

[image]
PowerTCP Telnet for .NET
SocketBase Class Members
See Also Properties Methods Events Send comments on this topic
Dart.Telnet Namespace : SocketBase Class

Glossary Item Box

The following tables list the members exposed by SocketBase.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket |
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.ComponentBase)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Telnet Namespace


SocketBase Class Properties

[image]
PowerTCP Telnet for .NET
SocketBase Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : SocketBase Class

Glossary Item Box

For a list of all members of this type, see SocketBase members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket |
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Telnet Namespace


Socket Property

[image]
PowerTCP Telnet for .NET
Socket Property
See Also Send comments on this topic
Dart.Telnet Namespace > SocketBase Class : Socket Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Socket As Socket
Visual Basic (Usage) Copy Code
Dim instance As SocketBase
Dim value As Socket

value = instance.Socket
C#
public Socket Socket {get;}
Managed Extensions for C++
public: __property Socket* get_Socket();
C++/CLI
public:
property Socket^ Socket {
   Socket^ get();
}

See Also

Reference

SocketBase Class
SocketBase Members


SocketOption Class

[image]
PowerTCP Telnet for .NET
SocketOption Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : SocketOption Class

Glossary Item Box

Object Model

SocketOption Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class SocketOption
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
C#
[Serializable()]
public class SocketOption
Managed Extensions for C++
[Serializable()]
public __gc class SocketOption
C++/CLI
[Serializable()]
public ref class SocketOption

Inheritance Hierarchy

System.Object
Dart.Telnet.SocketOption
Dart.Telnet.TcpSocketOption

See Also

Reference

SocketOption Members
Dart.Telnet Namespace


SocketOption Class Members

[image]
PowerTCP Telnet for .NET
SocketOption Class Members
See Also Properties Send comments on this topic
Dart.Telnet Namespace : SocketOption Class

Glossary Item Box

The following tables list the members exposed by SocketOption.

Public Properties

 | Name | Description
Public Property | ExclusiveAddressUse |
Public Property | ReceiveBufferSize |
Public Property | ReceiveTimeout |
Public Property | ReuseAddress |
Public Property | SendBufferSize |
Public Property | SendTimeout |
Top

See Also

Reference

SocketOption Class
Dart.Telnet Namespace


SocketOption Class Properties

[image]
PowerTCP Telnet for .NET
SocketOption Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : SocketOption Class

Glossary Item Box

For a list of all members of this type, see SocketOption members.

Public Properties

 | Name | Description
Public Property | ExclusiveAddressUse |
Public Property | ReceiveBufferSize |
Public Property | ReceiveTimeout |
Public Property | ReuseAddress |
Public Property | SendBufferSize |
Public Property | SendTimeout |
Top

See Also

Reference

SocketOption Class
Dart.Telnet Namespace


ExclusiveAddressUse Property

[image]
PowerTCP Telnet for .NET
ExclusiveAddressUse Property
See Also Send comments on this topic
Dart.Telnet Namespace > SocketOption Class : ExclusiveAddressUse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(False)>
Public Property ExclusiveAddressUse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Boolean

instance.ExclusiveAddressUse = value

value = instance.ExclusiveAddressUse
C#
[DefaultValue(false)]
public bool ExclusiveAddressUse {get; set;}
Managed Extensions for C++
[DefaultValue(false)]
public: __property bool get_ExclusiveAddressUse();
public: __property void set_ExclusiveAddressUse(
   bool value
);
C++/CLI
[DefaultValue(false)]
public:
property bool ExclusiveAddressUse {
   bool get();
   void set (    bool value);
}

See Also

Reference

SocketOption Class
SocketOption Members


ReceiveBufferSize Property

[image]
PowerTCP Telnet for .NET
ReceiveBufferSize Property
See Also Send comments on this topic
Dart.Telnet Namespace > SocketOption Class : ReceiveBufferSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(32768)>
Public Property ReceiveBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.ReceiveBufferSize = value

value = instance.ReceiveBufferSize
C#
[DefaultValue(32768)]
public int ReceiveBufferSize {get; set;}
Managed Extensions for C++
[DefaultValue(32768)]
public: __property int get_ReceiveBufferSize();
public: __property void set_ReceiveBufferSize(
   int value
);
C++/CLI
[DefaultValue(32768)]
public:
property int ReceiveBufferSize {
   int get();
   void set (    int value);
}

See Also

Reference

SocketOption Class
SocketOption Members


ReceiveTimeout Property

[image]
PowerTCP Telnet for .NET
ReceiveTimeout Property
See Also Send comments on this topic
Dart.Telnet Namespace > SocketOption Class : ReceiveTimeout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(0)>
Public Overridable Property ReceiveTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[DefaultValue(0)]
public virtual int ReceiveTimeout {get; set;}
Managed Extensions for C++
[DefaultValue(0)]
public: __property virtual int get_ReceiveTimeout();
public: __property virtual void set_ReceiveTimeout(
   int value
);
C++/CLI
[DefaultValue(0)]
public:
virtual property int ReceiveTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

SocketOption Class
SocketOption Members


ReuseAddress Property

[image]
PowerTCP Telnet for .NET
ReuseAddress Property
See Also Send comments on this topic
Dart.Telnet Namespace > SocketOption Class : ReuseAddress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(False)>
Public Property ReuseAddress As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Boolean

instance.ReuseAddress = value

value = instance.ReuseAddress
C#
[DefaultValue(false)]
public bool ReuseAddress {get; set;}
Managed Extensions for C++
[DefaultValue(false)]
public: __property bool get_ReuseAddress();
public: __property void set_ReuseAddress(
   bool value
);
C++/CLI
[DefaultValue(false)]
public:
property bool ReuseAddress {
   bool get();
   void set (    bool value);
}

See Also

Reference

SocketOption Class
SocketOption Members


SendBufferSize Property

[image]
PowerTCP Telnet for .NET
SendBufferSize Property
See Also Send comments on this topic
Dart.Telnet Namespace > SocketOption Class : SendBufferSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(8192)>
Public Property SendBufferSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.SendBufferSize = value

value = instance.SendBufferSize
C#
[DefaultValue(8192)]
public int SendBufferSize {get; set;}
Managed Extensions for C++
[DefaultValue(8192)]
public: __property int get_SendBufferSize();
public: __property void set_SendBufferSize(
   int value
);
C++/CLI
[DefaultValue(8192)]
public:
property int SendBufferSize {
   int get();
   void set (    int value);
}

See Also

Reference

SocketOption Class
SocketOption Members


SendTimeout Property

[image]
PowerTCP Telnet for .NET
SendTimeout Property
See Also Send comments on this topic
Dart.Telnet Namespace > SocketOption Class : SendTimeout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(0)>
Public Property SendTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As SocketOption
Dim value As Integer

instance.SendTimeout = value

value = instance.SendTimeout
C#
[DefaultValue(0)]
public int SendTimeout {get; set;}
Managed Extensions for C++
[DefaultValue(0)]
public: __property int get_SendTimeout();
public: __property void set_SendTimeout(
   int value
);
C++/CLI
[DefaultValue(0)]
public:
property int SendTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

SocketOption Class
SocketOption Members


TcpBase Class

[image]
PowerTCP Telnet for .NET
TcpBase Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : TcpBase Class

Glossary Item Box

Object Model

TcpBase ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class TcpBase
   Inherits SocketBase
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
C#
public class TcpBase : SocketBase
Managed Extensions for C++
public __gc class TcpBase : public SocketBase
C++/CLI
public ref class TcpBase : public SocketBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Telnet.ComponentBase
Dart.Telnet.SocketBase
Dart.Telnet.TcpBase
Dart.Telnet.PtyBase
Dart.Telnet.Rexec
Dart.Telnet.Rsh

See Also

Reference

TcpBase Members
Dart.Telnet Namespace


TcpBase Class Members

[image]
PowerTCP Telnet for .NET
TcpBase Class Members
See Also Properties Methods Events Send comments on this topic
Dart.Telnet Namespace : TcpBase Class

Glossary Item Box

The following tables list the members exposed by TcpBase.

Public Properties

 | Name | Description
Public Property | CloseTime |
Public Property | ConnectTime |
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | NetworkStream |
Public Property | RemoteEndPoint |
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption |
Public Property | SslStream |
Public Property | State |
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Abort |
Public Method | AuthenticateAsClient | Overloaded.
Public Method | AuthenticateAsClientTaskAsync | Overloaded.
Public Method | Close |
Public Method | Connect |
Public Method | ConnectAsync |
Public Method | ConnectTaskAsync |
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream |
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded.
Public Method | Read | Overloaded.
Public Method | ReadAsync |
Public Method | ReadTaskAsync |
Public Method | ReadToCount |
Public Method | ReadToDelimiter | Overloaded.
Public Method | ReadToEnd |
Public Method | ShutdownSsl |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded.
Public Method | WriteAsync |
Public Method | WriteTaskAsync |
Top

Public Events

 | Name | Description
Public Event | Data |
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log |
Public Event | StateChanged |
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Telnet Namespace


TcpBase Class Methods

[image]
PowerTCP Telnet for .NET
TcpBase Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : TcpBase Class

Glossary Item Box

For a list of all members of this type, see TcpBase members.

Public Methods

 | Name | Description
Public Method | Abort |
Public Method | AuthenticateAsClient | Overloaded.
Public Method | AuthenticateAsClientTaskAsync | Overloaded.
Public Method | Close |
Public Method | Connect |
Public Method | ConnectAsync |
Public Method | ConnectTaskAsync |
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream |
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded.
Public Method | Read | Overloaded.
Public Method | ReadAsync |
Public Method | ReadTaskAsync |
Public Method | ReadToCount |
Public Method | ReadToDelimiter | Overloaded.
Public Method | ReadToEnd |
Public Method | ShutdownSsl |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded.
Public Method | WriteAsync |
Public Method | WriteTaskAsync |
Top

See Also

Reference

TcpBase Class
Dart.Telnet Namespace


Abort Method

[image]
PowerTCP Telnet for .NET
Abort Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Abort Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Abort()
Visual Basic (Usage) Copy Code
Dim instance As TcpBase

instance.Abort()
C#
public void Abort()
Managed Extensions for C++
public: void Abort();
C++/CLI
public:
void Abort();

See Also

Reference

TcpBase Class
TcpBase Members


AuthenticateAsClient Method

[image]
PowerTCP Telnet for .NET
AuthenticateAsClient Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : AuthenticateAsClient Method

Glossary Item Box

Overload List

Overload | Description
AuthenticateAsClient(ClientSecurity) |
AuthenticateAsClient(TcpSession) |

See Also

Reference

TcpBase Class
TcpBase Members


AuthenticateAsClient(ClientSecurity) Method

[image]
PowerTCP Telnet for .NET
AuthenticateAsClient(ClientSecurity) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > AuthenticateAsClient Method : AuthenticateAsClient(ClientSecurity) Method

security

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SecuritySafeCriticalAttribute()>
<ObsoleteAttribute("Use AuthenticateAsClient(TcpSession) instead.")>
Public Overloads Sub AuthenticateAsClient( _
   ByVal security As ClientSecurity _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim security As ClientSecurity

instance.AuthenticateAsClient(security)
C#
[SecuritySafeCritical()]
[Obsolete("Use AuthenticateAsClient(TcpSession) instead.")]
public void AuthenticateAsClient(
   ClientSecurity security
)
Managed Extensions for C++
[SecuritySafeCritical()]
[Obsolete("Use AuthenticateAsClient(TcpSession) instead.")]
public: void AuthenticateAsClient(
   ClientSecurity* security
)
C++/CLI
[SecuritySafeCritical()]
[Obsolete("Use AuthenticateAsClient(TcpSession) instead.")]
public:
void AuthenticateAsClient(
   ClientSecurity^ security
)

Parameters

security

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


AuthenticateAsClient(TcpSession) Method

[image]
PowerTCP Telnet for .NET
AuthenticateAsClient(TcpSession) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > AuthenticateAsClient Method : AuthenticateAsClient(TcpSession) Method

session

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SecuritySafeCriticalAttribute()>
Public Overloads Sub AuthenticateAsClient( _
   ByVal session As TcpSession _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim session As TcpSession

instance.AuthenticateAsClient(session)
C#
[SecuritySafeCritical()]
public void AuthenticateAsClient(
   TcpSession session
)
Managed Extensions for C++
[SecuritySafeCritical()]
public: void AuthenticateAsClient(
   TcpSession* session
)
C++/CLI
[SecuritySafeCritical()]
public:
void AuthenticateAsClient(
   TcpSession^ session
)

Parameters

session

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


AuthenticateAsClientTaskAsync Method

[image]
PowerTCP Telnet for .NET
AuthenticateAsClientTaskAsync Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : AuthenticateAsClientTaskAsync Method

Glossary Item Box

Overload List

Overload | Description
AuthenticateAsClientTaskAsync(ClientSecurity) |
AuthenticateAsClientTaskAsync(TcpSession) |

See Also

Reference

TcpBase Class
TcpBase Members


AuthenticateAsClientTaskAsync(ClientSecurity) Method

[image]
PowerTCP Telnet for .NET
AuthenticateAsClientTaskAsync(ClientSecurity) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > AuthenticateAsClientTaskAsync Method : AuthenticateAsClientTaskAsync(ClientSecurity) Method

security

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SecuritySafeCriticalAttribute()>
<ObsoleteAttribute("Use AuthenticateAsClientTaskAsync(TcpSession) instead.")>
Public Overloads Function AuthenticateAsClientTaskAsync( _
   ByVal security As ClientSecurity _
) As Task
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim security As ClientSecurity
Dim value As Task

value = instance.AuthenticateAsClientTaskAsync(security)
C#
[SecuritySafeCritical()]
[Obsolete("Use AuthenticateAsClientTaskAsync(TcpSession) instead.")]
public Task AuthenticateAsClientTaskAsync(
   ClientSecurity security
)
Managed Extensions for C++
[SecuritySafeCritical()]
[Obsolete("Use AuthenticateAsClientTaskAsync(TcpSession) instead.")]
public: Task* AuthenticateAsClientTaskAsync(
   ClientSecurity* security
)
C++/CLI
[SecuritySafeCritical()]
[Obsolete("Use AuthenticateAsClientTaskAsync(TcpSession) instead.")]
public:
Task^ AuthenticateAsClientTaskAsync(
   ClientSecurity^ security
)

Parameters

security

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


AuthenticateAsClientTaskAsync(TcpSession) Method

[image]
PowerTCP Telnet for .NET
AuthenticateAsClientTaskAsync(TcpSession) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > AuthenticateAsClientTaskAsync Method : AuthenticateAsClientTaskAsync(TcpSession) Method

session

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SecuritySafeCriticalAttribute()>
Public Overloads Function AuthenticateAsClientTaskAsync( _
   ByVal session As TcpSession _
) As Task
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim session As TcpSession
Dim value As Task

value = instance.AuthenticateAsClientTaskAsync(session)
C#
[SecuritySafeCritical()]
public Task AuthenticateAsClientTaskAsync(
   TcpSession session
)
Managed Extensions for C++
[SecuritySafeCritical()]
public: Task* AuthenticateAsClientTaskAsync(
   TcpSession* session
)
C++/CLI
[SecuritySafeCritical()]
public:
Task^ AuthenticateAsClientTaskAsync(
   TcpSession^ session
)

Parameters

session

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Close() Method

[image]
PowerTCP Telnet for .NET
Close() Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Close() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As TcpBase

instance.Close()
C#
public virtual void Close()
Managed Extensions for C++
public: virtual void Close();
C++/CLI
public:
virtual void Close();

See Also

Reference

TcpBase Class
TcpBase Members


Connect Method

[image]
PowerTCP Telnet for .NET
Connect Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Connect Method

session

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Connect( _
   ByVal session As TcpSession _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim session As TcpSession

instance.Connect(session)
C#
public void Connect(
   TcpSession session
)
Managed Extensions for C++
public: void Connect(
   TcpSession* session
)
C++/CLI
public:
void Connect(
   TcpSession^ session
)

Parameters

session

See Also

Reference

TcpBase Class
TcpBase Members


ConnectAsync Method

[image]
PowerTCP Telnet for .NET
ConnectAsync Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : ConnectAsync Method

session
callback
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ConnectAsync( _
   ByVal session As TcpSession, _
   ByVal callback As TcpAsyncCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim session As TcpSession
Dim callback As TcpAsyncCallback
Dim state As Object

instance.ConnectAsync(session, callback, state)
C#
public void ConnectAsync(
   TcpSession session,
   TcpAsyncCallback callback,
   object state
)
Managed Extensions for C++
public: void ConnectAsync(
   TcpSession* session,
   TcpAsyncCallback* callback,
   Object* state
)
C++/CLI
public:
void ConnectAsync(
   TcpSession^ session,
   TcpAsyncCallback^ callback,
   Object^ state
)

Parameters

session
callback
state

See Also

Reference

TcpBase Class
TcpBase Members


ConnectTaskAsync Method

[image]
PowerTCP Telnet for .NET
ConnectTaskAsync Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : ConnectTaskAsync Method

session

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ConnectTaskAsync( _
   ByVal session As TcpSession _
) As Task
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim session As TcpSession
Dim value As Task

value = instance.ConnectTaskAsync(session)
C#
public Task ConnectTaskAsync(
   TcpSession session
)
Managed Extensions for C++
public: Task* ConnectTaskAsync(
   TcpSession* session
)
C++/CLI
public:
Task^ ConnectTaskAsync(
   TcpSession^ session
)

Parameters

session

See Also

Reference

TcpBase Class
TcpBase Members


GetStream Method

[image]
PowerTCP Telnet for .NET
GetStream Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : GetStream Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Stream

value = instance.GetStream()
C#
public virtual Stream GetStream()
Managed Extensions for C++
public: virtual Stream* GetStream();
C++/CLI
public:
virtual Stream^ GetStream();

See Also

Reference

TcpBase Class
TcpBase Members


Marshal Method

[image]
PowerTCP Telnet for .NET
Marshal Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Marshal Method

Glossary Item Box

Overload List

Overload | Description
Marshal(Data,String,Object) |
Marshal(String,Object) | (Inherited from Dart.Telnet.ComponentBase)
Marshal(Exception) | (Inherited from Dart.Telnet.ComponentBase)

See Also

Reference

TcpBase Class
TcpBase Members


Marshal(Data,String,Object) Method

[image]
PowerTCP Telnet for .NET
Marshal(Data,String,Object) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > Marshal Method : Marshal(Data,String,Object) Method

data
message
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Marshal( _
   ByVal data As Data, _
   ByVal message As String, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim data As Data
Dim message As String
Dim state As Object

instance.Marshal(data, message, state)
C#
public void Marshal(
   Data data,
   string message,
   object state
)
Managed Extensions for C++
public: void Marshal(
   Data* data,
   string* message,
   Object* state
)
C++/CLI
public:
void Marshal(
   Data^ data,
   String^ message,
   Object^ state
)

Parameters

data
message
state

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Read Method

[image]
PowerTCP Telnet for .NET
Read Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Read Method

Glossary Item Box

Overload List

Overload | Description
Read(Byte[],Int32,Int32) |
Read(Byte[]) |

See Also

Reference

TcpBase Class
TcpBase Members


Read(Byte[],Int32,Int32) Method

[image]
PowerTCP Telnet for .NET
Read(Byte[],Int32,Int32) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > Read Method : Read(Byte[],Int32,Int32) Method

buffer
offset
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Data

value = instance.Read(buffer, offset, count)
C#
public Data Read(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Data* Read(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Data^ Read(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
offset
count

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Read(Byte[]) Method

[image]
PowerTCP Telnet for .NET
Read(Byte[]) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > Read Method : Read(Byte[]) Method

buffer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Read( _
   ByVal buffer() As Byte _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim value As Data

value = instance.Read(buffer)
C#
public Data Read(
   byte[] buffer
)
Managed Extensions for C++
public: Data* Read(
   byte[]* buffer
)
C++/CLI
public:
Data^ Read(
   array<byte>^ buffer
)

Parameters

buffer

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadAsync Method

[image]
PowerTCP Telnet for .NET
ReadAsync Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : ReadAsync Method

buffer
offset
count
callback
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ReadAsync( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As TcpAsyncCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As TcpAsyncCallback
Dim state As Object

instance.ReadAsync(buffer, offset, count, callback, state)
C#
public void ReadAsync(
   byte[] buffer,
   int offset,
   int count,
   TcpAsyncCallback callback,
   object state
)
Managed Extensions for C++
public: void ReadAsync(
   byte[]* buffer,
   int offset,
   int count,
   TcpAsyncCallback* callback,
   Object* state
)
C++/CLI
public:
void ReadAsync(
   array<byte>^ buffer,
   int offset,
   int count,
   TcpAsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

TcpBase Class
TcpBase Members


ReadTaskAsync Method

[image]
PowerTCP Telnet for .NET
ReadTaskAsync Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : ReadTaskAsync Method

buffer
offset
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadTaskAsync( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Task(Of Data)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Task(Of Data)

value = instance.ReadTaskAsync(buffer, offset, count)
C#
public Task<Data> ReadTaskAsync(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Task<Data*>* ReadTaskAsync(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Task<Data^>^ ReadTaskAsync(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
offset
count

See Also

Reference

TcpBase Class
TcpBase Members


ReadToCount Method

[image]
PowerTCP Telnet for .NET
ReadToCount Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : ReadToCount Method

buffer
offset
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadToCount( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Data

value = instance.ReadToCount(buffer, offset, count)
C#
public Data ReadToCount(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Data* ReadToCount(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Data^ ReadToCount(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
offset
count

See Also

Reference

TcpBase Class
TcpBase Members


ReadToDelimiter Method

[image]
PowerTCP Telnet for .NET
ReadToDelimiter Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : ReadToDelimiter Method

Glossary Item Box

Overload List

Overload | Description
ReadToDelimiter(String) |
ReadToDelimiter(Byte[]) |
ReadToDelimiter(String[]) |
ReadToDelimiter(List<Byte[]>) |

See Also

Reference

TcpBase Class
TcpBase Members


ReadToDelimiter(String) Method

[image]
PowerTCP Telnet for .NET
ReadToDelimiter(String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > ReadToDelimiter Method : ReadToDelimiter(String) Method

delimiter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDelimiter( _
   ByVal delimiter As String _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiter As String
Dim value As Data

value = instance.ReadToDelimiter(delimiter)
C#
public Data ReadToDelimiter(
   string delimiter
)
Managed Extensions for C++
public: Data* ReadToDelimiter(
   string* delimiter
)
C++/CLI
public:
Data^ ReadToDelimiter(
   String^ delimiter
)

Parameters

delimiter

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadToDelimiter(Byte[]) Method

[image]
PowerTCP Telnet for .NET
ReadToDelimiter(Byte[]) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > ReadToDelimiter Method : ReadToDelimiter(Byte[]) Method

delimiter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDelimiter( _
   ByVal delimiter() As Byte _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiter() As Byte
Dim value As Data

value = instance.ReadToDelimiter(delimiter)
C#
public Data ReadToDelimiter(
   byte[] delimiter
)
Managed Extensions for C++
public: Data* ReadToDelimiter(
   byte[]* delimiter
)
C++/CLI
public:
Data^ ReadToDelimiter(
   array<byte>^ delimiter
)

Parameters

delimiter

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadToDelimiter(String[]) Method

[image]
PowerTCP Telnet for .NET
ReadToDelimiter(String[]) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > ReadToDelimiter Method : ReadToDelimiter(String[]) Method

delimiters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDelimiter( _
   ByVal delimiters() As String _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiters() As String
Dim value As Data

value = instance.ReadToDelimiter(delimiters)
C#
public Data ReadToDelimiter(
   string[] delimiters
)
Managed Extensions for C++
public: Data* ReadToDelimiter(
   string*[]* delimiters
)
C++/CLI
public:
Data^ ReadToDelimiter(
   array<String^>^ delimiters
)

Parameters

delimiters

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadToDelimiter(List<Byte[]>) Method

[image]
PowerTCP Telnet for .NET
ReadToDelimiter(List<Byte[]>) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > ReadToDelimiter Method : ReadToDelimiter(List<Byte[]>) Method

delimiters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ReadToDelimiter( _
   ByVal delimiters As List(Of Byte()) _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim delimiters As List(Of Byte())
Dim value As Data

value = instance.ReadToDelimiter(delimiters)
C#
public Data ReadToDelimiter(
   List<byte[]> delimiters
)
Managed Extensions for C++
public: Data* ReadToDelimiter(
   List<byte[]>* delimiters
)
C++/CLI
public:
Data^ ReadToDelimiter(
   List<array<byte>>^ delimiters
)

Parameters

delimiters

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


ReadToEnd Method

[image]
PowerTCP Telnet for .NET
ReadToEnd Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : ReadToEnd Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadToEnd() As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Data

value = instance.ReadToEnd()
C#
public Data ReadToEnd()
Managed Extensions for C++
public: Data* ReadToEnd();
C++/CLI
public:
Data^ ReadToEnd();

See Also

Reference

TcpBase Class
TcpBase Members


ShutdownSsl Method

[image]
PowerTCP Telnet for .NET
ShutdownSsl Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : ShutdownSsl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ShutdownSsl()
Visual Basic (Usage) Copy Code
Dim instance As TcpBase

instance.ShutdownSsl()
C#
public void ShutdownSsl()
Managed Extensions for C++
public: void ShutdownSsl();
C++/CLI
public:
void ShutdownSsl();

See Also

Reference

TcpBase Class
TcpBase Members


Write Method

[image]
PowerTCP Telnet for .NET
Write Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Write Method

Glossary Item Box

Overload List

Overload | Description
Write(Byte[]) |
Write(String) |
Write(Byte[],Int32,Int32) |

See Also

Reference

TcpBase Class
TcpBase Members


Write(Byte[]) Method

[image]
PowerTCP Telnet for .NET
Write(Byte[]) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > Write Method : Write(Byte[]) Method

buffer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Write( _
   ByVal buffer() As Byte _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim value As Data

value = instance.Write(buffer)
C#
public Data Write(
   byte[] buffer
)
Managed Extensions for C++
public: Data* Write(
   byte[]* buffer
)
C++/CLI
public:
Data^ Write(
   array<byte>^ buffer
)

Parameters

buffer

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Write(String) Method

[image]
PowerTCP Telnet for .NET
Write(String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > Write Method : Write(String) Method

data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Write( _
   ByVal data As String _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim data As String
Dim value As Data

value = instance.Write(data)
C#
public Data Write(
   string data
)
Managed Extensions for C++
public: Data* Write(
   string* data
)
C++/CLI
public:
Data^ Write(
   String^ data
)

Parameters

data

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


Write(Byte[],Int32,Int32) Method

[image]
PowerTCP Telnet for .NET
Write(Byte[],Int32,Int32) Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class > Write Method : Write(Byte[],Int32,Int32) Method

buffer
offset
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Data

value = instance.Write(buffer, offset, count)
C#
public Data Write(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Data* Write(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Data^ Write(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
offset
count

See Also

Reference

TcpBase Class
TcpBase Members
Overload List


WriteAsync Method

[image]
PowerTCP Telnet for .NET
WriteAsync Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : WriteAsync Method

buffer
offset
count
callback
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub WriteAsync( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As TcpAsyncCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As TcpAsyncCallback
Dim state As Object

instance.WriteAsync(buffer, offset, count, callback, state)
C#
public void WriteAsync(
   byte[] buffer,
   int offset,
   int count,
   TcpAsyncCallback callback,
   object state
)
Managed Extensions for C++
public: void WriteAsync(
   byte[]* buffer,
   int offset,
   int count,
   TcpAsyncCallback* callback,
   Object* state
)
C++/CLI
public:
void WriteAsync(
   array<byte>^ buffer,
   int offset,
   int count,
   TcpAsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

TcpBase Class
TcpBase Members


WriteTaskAsync Method

[image]
PowerTCP Telnet for .NET
WriteTaskAsync Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : WriteTaskAsync Method

buffer
offset
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function WriteTaskAsync( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Task(Of Data)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Task(Of Data)

value = instance.WriteTaskAsync(buffer, offset, count)
C#
public Task<Data> WriteTaskAsync(
   byte[] buffer,
   int offset,
   int count
)
Managed Extensions for C++
public: Task<Data*>* WriteTaskAsync(
   byte[]* buffer,
   int offset,
   int count
)
C++/CLI
public:
Task<Data^>^ WriteTaskAsync(
   array<byte>^ buffer,
   int offset,
   int count
)

Parameters

buffer
offset
count

See Also

Reference

TcpBase Class
TcpBase Members


TcpBase Class Properties

[image]
PowerTCP Telnet for .NET
TcpBase Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : TcpBase Class

Glossary Item Box

For a list of all members of this type, see TcpBase members.

Public Properties

 | Name | Description
Public Property | CloseTime |
Public Property | ConnectTime |
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | NetworkStream |
Public Property | RemoteEndPoint |
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption |
Public Property | SslStream |
Public Property | State |
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Telnet Namespace


CloseTime Property

[image]
PowerTCP Telnet for .NET
CloseTime Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : CloseTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CloseTime As Date
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Date

value = instance.CloseTime
C#
public DateTime CloseTime {get;}
Managed Extensions for C++
public: __property DateTime get_CloseTime();
C++/CLI
public:
property DateTime CloseTime {
   DateTime get();
}

See Also

Reference

TcpBase Class
TcpBase Members


ConnectTime Property

[image]
PowerTCP Telnet for .NET
ConnectTime Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : ConnectTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConnectTime As Date
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As Date

value = instance.ConnectTime
C#
public DateTime ConnectTime {get;}
Managed Extensions for C++
public: __property DateTime get_ConnectTime();
C++/CLI
public:
property DateTime ConnectTime {
   DateTime get();
}

See Also

Reference

TcpBase Class
TcpBase Members


NetworkStream Property

[image]
PowerTCP Telnet for .NET
NetworkStream Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : NetworkStream Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkStream As NetworkStream
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As NetworkStream

value = instance.NetworkStream
C#
public NetworkStream NetworkStream {get;}
Managed Extensions for C++
public: __property NetworkStream* get_NetworkStream();
C++/CLI
public:
property NetworkStream^ NetworkStream {
   NetworkStream^ get();
}

See Also

Reference

TcpBase Class
TcpBase Members


RemoteEndPoint Property

[image]
PowerTCP Telnet for .NET
RemoteEndPoint Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : RemoteEndPoint Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RemoteEndPoint As IPEndPoint
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As IPEndPoint

value = instance.RemoteEndPoint
C#
public IPEndPoint RemoteEndPoint {get;}
Managed Extensions for C++
public: __property IPEndPoint* get_RemoteEndPoint();
C++/CLI
public:
property IPEndPoint^ RemoteEndPoint {
   IPEndPoint^ get();
}

See Also

Reference

TcpBase Class
TcpBase Members


SocketOption Property

[image]
PowerTCP Telnet for .NET
SocketOption Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : SocketOption Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SocketOption As TcpSocketOption
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As TcpSocketOption

instance.SocketOption = value

value = instance.SocketOption
C#
public TcpSocketOption SocketOption {get; set;}
Managed Extensions for C++
public: __property TcpSocketOption* get_SocketOption();
public: __property void set_SocketOption(
   TcpSocketOption* value
);
C++/CLI
public:
property TcpSocketOption^ SocketOption {
   TcpSocketOption^ get();
   void set (    TcpSocketOption^ value);
}

See Also

Reference

TcpBase Class
TcpBase Members


SslStream Property

[image]
PowerTCP Telnet for .NET
SslStream Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : SslStream Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SslStream As SslStream
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As SslStream

value = instance.SslStream
C#
public SslStream SslStream {get;}
Managed Extensions for C++
public: __property SslStream* get_SslStream();
C++/CLI
public:
property SslStream^ SslStream {
   SslStream^ get();
}

See Also

Reference

TcpBase Class
TcpBase Members


State Property

[image]
PowerTCP Telnet for .NET
State Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : State Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As ConnectionState
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim value As ConnectionState

value = instance.State
C#
public ConnectionState State {get;}
Managed Extensions for C++
public: __property ConnectionState get_State();
C++/CLI
public:
property ConnectionState State {
   ConnectionState get();
}

See Also

Reference

TcpBase Class
TcpBase Members


TcpBase Class Events

[image]
PowerTCP Telnet for .NET
TcpBase Class Events
See Also Send comments on this topic
Dart.Telnet Namespace : TcpBase Class

Glossary Item Box

For a list of all members of this type, see TcpBase members.

Public Events

 | Name | Description
Public Event | Data |
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log |
Public Event | StateChanged |
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

TcpBase Class
Dart.Telnet Namespace


Data Event

[image]
PowerTCP Telnet for .NET
Data Event
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Data Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Data As EventHandler(Of DataEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim handler As EventHandler(Of DataEventArgs)

AddHandler instance.Data, handler
C#
public event EventHandler<DataEventArgs> Data
Managed Extensions for C++
public: __event EventHandler<DataEventArgs*>* Data
C++/CLI
public:
event EventHandler<DataEventArgs^>^ Data

Event Data

The event handler receives an argument of type DataEventArgs containing data related to this event. The following DataEventArgs properties provide information specific to this event.

Property | Description
Data |
Message | (Inherited from Dart.Telnet.UserStateEventArgs)
UserState | (Inherited from Dart.Telnet.UserStateEventArgs)

See Also

Reference

TcpBase Class
TcpBase Members


Log Event

[image]
PowerTCP Telnet for .NET
Log Event
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Log Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Log As EventHandler(Of DataEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim handler As EventHandler(Of DataEventArgs)

AddHandler instance.Log, handler
C#
public event EventHandler<DataEventArgs> Log
Managed Extensions for C++
public: __event EventHandler<DataEventArgs*>* Log
C++/CLI
public:
event EventHandler<DataEventArgs^>^ Log

Event Data

The event handler receives an argument of type DataEventArgs containing data related to this event. The following DataEventArgs properties provide information specific to this event.

Property | Description
Data |
Message | (Inherited from Dart.Telnet.UserStateEventArgs)
UserState | (Inherited from Dart.Telnet.UserStateEventArgs)

See Also

Reference

TcpBase Class
TcpBase Members


StateChanged Event

[image]
PowerTCP Telnet for .NET
StateChanged Event
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : StateChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event StateChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As TcpBase
Dim handler As EventHandler

AddHandler instance.StateChanged, handler
C#
public event EventHandler StateChanged
Managed Extensions for C++
public: __event EventHandler* StateChanged
C++/CLI
public:
event EventHandler^ StateChanged

See Also

Reference

TcpBase Class
TcpBase Members


TcpSession Class

[image]
PowerTCP Telnet for .NET
TcpSession Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : TcpSession Class

Glossary Item Box

Object Model

TcpSession ClassIPEndPoint ClassProxy ClassIPEndPoint ClassClientSecurity Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class TcpSession
   Inherits Session
Visual Basic (Usage) Copy Code
Dim instance As TcpSession
C#
[Serializable()]
public class TcpSession : Session
Managed Extensions for C++
[Serializable()]
public __gc class TcpSession : public Session
C++/CLI
[Serializable()]
public ref class TcpSession : public Session

Inheritance Hierarchy

System.Object
Dart.Telnet.Session
Dart.Telnet.TcpSession

See Also

Reference

TcpSession Members
Dart.Telnet Namespace


TcpSession Class Members

[image]
PowerTCP Telnet for .NET
TcpSession Class Members
See Also Properties Send comments on this topic
Dart.Telnet Namespace : TcpSession Class

Glossary Item Box

The following tables list the members exposed by TcpSession.

Public Constructors

 | Name | Description
Public Constructor | TcpSession Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ConnectTimeout |
Public Property | LocalEndPoint | (Inherited from Dart.Telnet.Session)
Public Property | Proxy |
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.Session)
Public Property | Security |
Top

See Also

Reference

TcpSession Class
Dart.Telnet Namespace


TcpSession Constructor

[image]
PowerTCP Telnet for .NET
TcpSession Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSession Class : TcpSession Constructor

Glossary Item Box

Overload List

Overload | Description
TcpSession Constructor() |
TcpSession Constructor(IPEndPoint) |

See Also

Reference

TcpSession Class
TcpSession Members


TcpSession Constructor()

[image]
PowerTCP Telnet for .NET
TcpSession Constructor()
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSession Class > TcpSession Constructor : TcpSession Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New TcpSession()
C#
public TcpSession()
Managed Extensions for C++
public: TcpSession();
C++/CLI
public:
TcpSession();

See Also

Reference

TcpSession Class
TcpSession Members
Overload List


TcpSession Constructor(IPEndPoint)

[image]
PowerTCP Telnet for .NET
TcpSession Constructor(IPEndPoint)
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSession Class > TcpSession Constructor : TcpSession Constructor(IPEndPoint)

remoteEP

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal remoteEP As IPEndPoint _
)
Visual Basic (Usage) Copy Code
Dim remoteEP As IPEndPoint

Dim instance As New TcpSession(remoteEP)
C#
public TcpSession(
   IPEndPoint remoteEP
)
Managed Extensions for C++
public: TcpSession(
   IPEndPoint* remoteEP
)
C++/CLI
public:
TcpSession(
   IPEndPoint^ remoteEP
)

Parameters

remoteEP

See Also

Reference

TcpSession Class
TcpSession Members
Overload List


TcpSession Class Properties

[image]
PowerTCP Telnet for .NET
TcpSession Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : TcpSession Class

Glossary Item Box

For a list of all members of this type, see TcpSession members.

Public Properties

 | Name | Description
Public Property | ConnectTimeout |
Public Property | LocalEndPoint | (Inherited from Dart.Telnet.Session)
Public Property | Proxy |
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.Session)
Public Property | Security |
Top

See Also

Reference

TcpSession Class
Dart.Telnet Namespace


ConnectTimeout Property

[image]
PowerTCP Telnet for .NET
ConnectTimeout Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSession Class : ConnectTimeout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(-1)>
Public Property ConnectTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As TcpSession
Dim value As Integer

instance.ConnectTimeout = value

value = instance.ConnectTimeout
C#
[DefaultValue(-1)]
public int ConnectTimeout {get; set;}
Managed Extensions for C++
[DefaultValue(-1)]
public: __property int get_ConnectTimeout();
public: __property void set_ConnectTimeout(
   int value
);
C++/CLI
[DefaultValue(-1)]
public:
property int ConnectTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

TcpSession Class
TcpSession Members


Proxy Property

[image]
PowerTCP Telnet for .NET
Proxy Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSession Class : Proxy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Proxy As Proxy
Visual Basic (Usage) Copy Code
Dim instance As TcpSession
Dim value As Proxy

instance.Proxy = value

value = instance.Proxy
C#
public Proxy Proxy {get; set;}
Managed Extensions for C++
public: __property Proxy* get_Proxy();
public: __property void set_Proxy(
   Proxy* value
);
C++/CLI
public:
property Proxy^ Proxy {
   Proxy^ get();
   void set (    Proxy^ value);
}

See Also

Reference

TcpSession Class
TcpSession Members


Security Property

[image]
PowerTCP Telnet for .NET
Security Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSession Class : Security Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Security As ClientSecurity
Visual Basic (Usage) Copy Code
Dim instance As TcpSession
Dim value As ClientSecurity

instance.Security = value

value = instance.Security
C#
public ClientSecurity Security {get; set;}
Managed Extensions for C++
public: __property ClientSecurity* get_Security();
public: __property void set_Security(
   ClientSecurity* value
);
C++/CLI
public:
property ClientSecurity^ Security {
   ClientSecurity^ get();
   void set (    ClientSecurity^ value);
}

See Also

Reference

TcpSession Class
TcpSession Members


TcpSocketOption Class

[image]
PowerTCP Telnet for .NET
TcpSocketOption Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : TcpSocketOption Class

Glossary Item Box

Object Model

TcpSocketOption Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class TcpSocketOption
   Inherits SocketOption
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
C#
[Serializable()]
public class TcpSocketOption : SocketOption
Managed Extensions for C++
[Serializable()]
public __gc class TcpSocketOption : public SocketOption
C++/CLI
[Serializable()]
public ref class TcpSocketOption : public SocketOption

Inheritance Hierarchy

System.Object
Dart.Telnet.SocketOption
Dart.Telnet.TcpSocketOption

See Also

Reference

TcpSocketOption Members
Dart.Telnet Namespace


TcpSocketOption Class Members

[image]
PowerTCP Telnet for .NET
TcpSocketOption Class Members
See Also Properties Send comments on this topic
Dart.Telnet Namespace : TcpSocketOption Class

Glossary Item Box

The following tables list the members exposed by TcpSocketOption.

Public Properties

 | Name | Description
Public Property | ExclusiveAddressUse | (Inherited from Dart.Telnet.SocketOption)
Public Property | KeepAliveInterval |
Public Property | KeepAliveTime |
Public Property | NoDelay |
Public Property | OutOfBandInline |
Public Property | ReceiveBufferSize | (Inherited from Dart.Telnet.SocketOption)
Public Property | ReceiveTimeout | Overridden.
Public Property | ReuseAddress | (Inherited from Dart.Telnet.SocketOption)
Public Property | SendBufferSize | (Inherited from Dart.Telnet.SocketOption)
Public Property | SendTimeout | (Inherited from Dart.Telnet.SocketOption)
Top

See Also

Reference

TcpSocketOption Class
Dart.Telnet Namespace


TcpSocketOption Class Properties

[image]
PowerTCP Telnet for .NET
TcpSocketOption Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : TcpSocketOption Class

Glossary Item Box

For a list of all members of this type, see TcpSocketOption members.

Public Properties

 | Name | Description
Public Property | ExclusiveAddressUse | (Inherited from Dart.Telnet.SocketOption)
Public Property | KeepAliveInterval |
Public Property | KeepAliveTime |
Public Property | NoDelay |
Public Property | OutOfBandInline |
Public Property | ReceiveBufferSize | (Inherited from Dart.Telnet.SocketOption)
Public Property | ReceiveTimeout | Overridden.
Public Property | ReuseAddress | (Inherited from Dart.Telnet.SocketOption)
Public Property | SendBufferSize | (Inherited from Dart.Telnet.SocketOption)
Public Property | SendTimeout | (Inherited from Dart.Telnet.SocketOption)
Top

See Also

Reference

TcpSocketOption Class
Dart.Telnet Namespace


KeepAliveInterval Property

[image]
PowerTCP Telnet for .NET
KeepAliveInterval Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSocketOption Class : KeepAliveInterval Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(1000)>
Public Property KeepAliveInterval As Integer
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Integer

instance.KeepAliveInterval = value

value = instance.KeepAliveInterval
C#
[DefaultValue(1000)]
public int KeepAliveInterval {get; set;}
Managed Extensions for C++
[DefaultValue(1000)]
public: __property int get_KeepAliveInterval();
public: __property void set_KeepAliveInterval(
   int value
);
C++/CLI
[DefaultValue(1000)]
public:
property int KeepAliveInterval {
   int get();
   void set (    int value);
}

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


KeepAliveTime Property

[image]
PowerTCP Telnet for .NET
KeepAliveTime Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSocketOption Class : KeepAliveTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(7200000)>
Public Property KeepAliveTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Integer

instance.KeepAliveTime = value

value = instance.KeepAliveTime
C#
[DefaultValue(7200000)]
public int KeepAliveTime {get; set;}
Managed Extensions for C++
[DefaultValue(7200000)]
public: __property int get_KeepAliveTime();
public: __property void set_KeepAliveTime(
   int value
);
C++/CLI
[DefaultValue(7200000)]
public:
property int KeepAliveTime {
   int get();
   void set (    int value);
}

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


NoDelay Property

[image]
PowerTCP Telnet for .NET
NoDelay Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSocketOption Class : NoDelay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(False)>
Public Property NoDelay As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Boolean

instance.NoDelay = value

value = instance.NoDelay
C#
[DefaultValue(false)]
public bool NoDelay {get; set;}
Managed Extensions for C++
[DefaultValue(false)]
public: __property bool get_NoDelay();
public: __property void set_NoDelay(
   bool value
);
C++/CLI
[DefaultValue(false)]
public:
property bool NoDelay {
   bool get();
   void set (    bool value);
}

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


OutOfBandInline Property

[image]
PowerTCP Telnet for .NET
OutOfBandInline Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSocketOption Class : OutOfBandInline Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(False)>
Public Property OutOfBandInline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Boolean

instance.OutOfBandInline = value

value = instance.OutOfBandInline
C#
[DefaultValue(false)]
public bool OutOfBandInline {get; set;}
Managed Extensions for C++
[DefaultValue(false)]
public: __property bool get_OutOfBandInline();
public: __property void set_OutOfBandInline(
   bool value
);
C++/CLI
[DefaultValue(false)]
public:
property bool OutOfBandInline {
   bool get();
   void set (    bool value);
}

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


ReceiveTimeout Property

[image]
PowerTCP Telnet for .NET
ReceiveTimeout Property
See Also Send comments on this topic
Dart.Telnet Namespace > TcpSocketOption Class : ReceiveTimeout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(0)>
Public Overrides Property ReceiveTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As TcpSocketOption
Dim value As Integer

instance.ReceiveTimeout = value

value = instance.ReceiveTimeout
C#
[DefaultValue(0)]
public override int ReceiveTimeout {get; set;}
Managed Extensions for C++
[DefaultValue(0)]
public: __property int get_ReceiveTimeout() override;
public: __property void set_ReceiveTimeout(
   int value
) override;
C++/CLI
[DefaultValue(0)]
public:
property int ReceiveTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

TcpSocketOption Class
TcpSocketOption Members


Telnet Class

[image]
PowerTCP Telnet for .NET
Telnet Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : Telnet Class

Glossary Item Box

Object Model

Telnet ClassOptionCollection ClassOption ClassOptionCollection ClassOption ClassTcpSocketOption Class

Syntax

Visual Basic (Declaration)
Public Class Telnet
   Inherits PtyBase
Visual Basic (Usage) Copy Code
Dim instance As Telnet
C#
public class Telnet : PtyBase
Managed Extensions for C++
public __gc class Telnet : public PtyBase
C++/CLI
public ref class Telnet : public PtyBase

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Telnet.ComponentBase
Dart.Telnet.SocketBase
Dart.Telnet.TcpBase
Dart.Telnet.PtyBase
Dart.Telnet.Telnet

See Also

Reference

Telnet Members
Dart.Telnet Namespace


Telnet Class Members

[image]
PowerTCP Telnet for .NET
Telnet Class Members
See Also Fields Properties Methods Events Send comments on this topic
Dart.Telnet Namespace : Telnet Class

Glossary Item Box

The following tables list the members exposed by Telnet.

Public Constructors

 | Name | Description
Public Constructor | Telnet Constructor | Overloaded.
Top

Public Fields

 | Name | Description
Public Field | DefaultPort |
Top

Public Properties

 | Name | Description
Public Property | Binary |
Public Property | ClientOptions |
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | (Inherited from Dart.Telnet.PtyBase)
Public Property | Echo |
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | LocalEcho | (Inherited from Dart.Telnet.PtyBase)
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | Pty | (Inherited from Dart.Telnet.PtyBase)
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | ServerOptions |
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Public Property | TerminalType |
Public Property | WindowSize |
Top

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | Overloaded.
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Overridden.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Login |
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | Refresh |
Public Method | SendCommand |
Public Method | SendOption |
Public Method | SendSubOption |
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | Start |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

Public Events

 | Name | Description
Public Event | ClientOptionChanged |
Public Event | CommandReceived |
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | ServerOptionChanged |
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


Telnet Constructor

[image]
PowerTCP Telnet for .NET
Telnet Constructor
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : Telnet Constructor

Glossary Item Box

Overload List

Overload | Description
Telnet Constructor() |
Telnet Constructor(IContainer) |

See Also

Reference

Telnet Class
Telnet Members


Telnet Constructor()

[image]
PowerTCP Telnet for .NET
Telnet Constructor()
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class > Telnet Constructor : Telnet Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Telnet()
C#
public Telnet()
Managed Extensions for C++
public: Telnet();
C++/CLI
public:
Telnet();

See Also

Reference

Telnet Class
Telnet Members
Overload List


Telnet Constructor(IContainer)

[image]
PowerTCP Telnet for .NET
Telnet Constructor(IContainer)
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class > Telnet Constructor : Telnet Constructor(IContainer)

container

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As New Telnet(container)
C#
public Telnet(
   IContainer container
)
Managed Extensions for C++
public: Telnet(
   IContainer* container
)
C++/CLI
public:
Telnet(
   IContainer^ container
)

Parameters

container

See Also

Reference

Telnet Class
Telnet Members
Overload List


Telnet Class Methods

[image]
PowerTCP Telnet for .NET
Telnet Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : Telnet Class

Glossary Item Box

For a list of all members of this type, see Telnet members.

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | Overloaded.
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | Overridden.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Login |
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | Refresh |
Public Method | SendCommand |
Public Method | SendOption |
Public Method | SendSubOption |
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | Start |
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


Connect Method

[image]
PowerTCP Telnet for .NET
Connect Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : Connect Method

Glossary Item Box

Overload List

Overload | Description
Connect(String) |
Connect | (Inherited from Dart.Telnet.TcpBase)

See Also

Reference

Telnet Class
Telnet Members


Connect(String) Method

[image]
PowerTCP Telnet for .NET
Connect(String) Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class > Connect Method : Connect(String) Method

hostNameOrAddress

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Connect( _
   ByVal hostNameOrAddress As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim hostNameOrAddress As String

instance.Connect(hostNameOrAddress)
C#
public void Connect(
   string hostNameOrAddress
)
Managed Extensions for C++
public: void Connect(
   string* hostNameOrAddress
)
C++/CLI
public:
void Connect(
   String^ hostNameOrAddress
)

Parameters

hostNameOrAddress

See Also

Reference

Telnet Class
Telnet Members
Overload List


GetStream Method

[image]
PowerTCP Telnet for .NET
GetStream Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : GetStream Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function GetStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As Stream

value = instance.GetStream()
C#
public override Stream GetStream()
Managed Extensions for C++
public: Stream* GetStream(); override
C++/CLI
public:
Stream^ GetStream(); override

See Also

Reference

Telnet Class
Telnet Members


Login(Credentials) Method

[image]
PowerTCP Telnet for .NET
Login(Credentials) Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : Login(Credentials) Method

credentials

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Login( _
   ByVal credentials As Credentials _
) As Data
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim credentials As Credentials
Dim value As Data

value = instance.Login(credentials)
C#
public Data Login(
   Credentials credentials
)
Managed Extensions for C++
public: Data* Login(
   Credentials* credentials
)
C++/CLI
public:
Data^ Login(
   Credentials^ credentials
)

Parameters

credentials

See Also

Reference

Telnet Class
Telnet Members


Refresh Method

[image]
PowerTCP Telnet for .NET
Refresh Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : Refresh Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As Telnet

instance.Refresh()
C#
public void Refresh()
Managed Extensions for C++
public: void Refresh();
C++/CLI
public:
void Refresh();

See Also

Reference

Telnet Class
Telnet Members


SendCommand Method

[image]
PowerTCP Telnet for .NET
SendCommand Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : SendCommand Method

command

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SendCommand( _
   ByVal command As Command _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim command As Command
Dim value() As Byte

value = instance.SendCommand(command)
C#
public byte[] SendCommand(
   Command command
)
Managed Extensions for C++
public: byte[]* SendCommand(
   Command command
)
C++/CLI
public:
array<byte>^ SendCommand(
   Command command
)

Parameters

command

See Also

Reference

Telnet Class
Telnet Members


SendOption Method

[image]
PowerTCP Telnet for .NET
SendOption Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : SendOption Method

command
code

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SendOption( _
   ByVal command As Command, _
   ByVal code As OptionCode _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim command As Command
Dim code As OptionCode
Dim value() As Byte

value = instance.SendOption(command, code)
C#
public byte[] SendOption(
   Command command,
   OptionCode code
)
Managed Extensions for C++
public: byte[]* SendOption(
   Command command,
   OptionCode code
)
C++/CLI
public:
array<byte>^ SendOption(
   Command command,
   OptionCode code
)

Parameters

command
code

See Also

Reference

Telnet Class
Telnet Members


SendSubOption Method

[image]
PowerTCP Telnet for .NET
SendSubOption Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : SendSubOption Method

code
subOption

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SendSubOption( _
   ByVal code As OptionCode, _
   ByVal subOption() As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim code As OptionCode
Dim subOption() As Byte
Dim value() As Byte

value = instance.SendSubOption(code, subOption)
C#
public byte[] SendSubOption(
   OptionCode code,
   byte[] subOption
)
Managed Extensions for C++
public: byte[]* SendSubOption(
   OptionCode code,
   byte[]* subOption
)
C++/CLI
public:
array<byte>^ SendSubOption(
   OptionCode code,
   array<byte>^ subOption
)

Parameters

code
subOption

See Also

Reference

Telnet Class
Telnet Members


Start Method

[image]
PowerTCP Telnet for .NET
Start Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : Start Method

worker
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Start( _
   ByVal worker As WaitCallback, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim worker As WaitCallback
Dim state As Object

instance.Start(worker, state)
C#
public void Start(
   WaitCallback worker,
   object state
)
Managed Extensions for C++
public: void Start(
   WaitCallback* worker,
   Object* state
)
C++/CLI
public:
void Start(
   WaitCallback^ worker,
   Object^ state
)

Parameters

worker
state

See Also

Reference

Telnet Class
Telnet Members


Telnet Class Properties

[image]
PowerTCP Telnet for .NET
Telnet Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Telnet Class

Glossary Item Box

For a list of all members of this type, see Telnet members.

Public Properties

 | Name | Description
Public Property | Binary |
Public Property | ClientOptions |
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CRLF | (Inherited from Dart.Telnet.PtyBase)
Public Property | Echo |
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | LocalEcho | (Inherited from Dart.Telnet.PtyBase)
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | Pty | (Inherited from Dart.Telnet.PtyBase)
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | ServerOptions |
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Public Property | TerminalType |
Public Property | WindowSize |
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


Binary Property

[image]
PowerTCP Telnet for .NET
Binary Property
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : Binary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(Mono.Cecil.CustomAttributeArgument)>
Public Property Binary As OptionState
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionState

instance.Binary = value

value = instance.Binary
C#
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public OptionState Binary {get; set;}
Managed Extensions for C++
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public: __property OptionState get_Binary();
public: __property void set_Binary(
   OptionState value
);
C++/CLI
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public:
property OptionState Binary {
   OptionState get();
   void set (    OptionState value);
}

See Also

Reference

Telnet Class
Telnet Members


ClientOptions Property

[image]
PowerTCP Telnet for .NET
ClientOptions Property
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : ClientOptions Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientOptions As OptionCollection
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionCollection

value = instance.ClientOptions
C#
public OptionCollection ClientOptions {get;}
Managed Extensions for C++
public: __property OptionCollection* get_ClientOptions();
C++/CLI
public:
property OptionCollection^ ClientOptions {
   OptionCollection^ get();
}

See Also

Reference

Telnet Class
Telnet Members


Echo Property

[image]
PowerTCP Telnet for .NET
Echo Property
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : Echo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(Mono.Cecil.CustomAttributeArgument)>
Public Property Echo As OptionState
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionState

instance.Echo = value

value = instance.Echo
C#
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public OptionState Echo {get; set;}
Managed Extensions for C++
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public: __property OptionState get_Echo();
public: __property void set_Echo(
   OptionState value
);
C++/CLI
[DefaultValue(Mono.Cecil.CustomAttributeArgument)]
public:
property OptionState Echo {
   OptionState get();
   void set (    OptionState value);
}

See Also

Reference

Telnet Class
Telnet Members


ServerOptions Property

[image]
PowerTCP Telnet for .NET
ServerOptions Property
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : ServerOptions Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerOptions As OptionCollection
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As OptionCollection

value = instance.ServerOptions
C#
public OptionCollection ServerOptions {get;}
Managed Extensions for C++
public: __property OptionCollection* get_ServerOptions();
C++/CLI
public:
property OptionCollection^ ServerOptions {
   OptionCollection^ get();
}

See Also

Reference

Telnet Class
Telnet Members


TerminalType Property

[image]
PowerTCP Telnet for .NET
TerminalType Property
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : TerminalType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("tty")>
Public Property TerminalType As String
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As String

instance.TerminalType = value

value = instance.TerminalType
C#
[DefaultValue("tty")]
public string TerminalType {get; set;}
Managed Extensions for C++
[DefaultValue("tty")]
public: __property string* get_TerminalType();
public: __property void set_TerminalType(
   string* value
);
C++/CLI
[DefaultValue("tty")]
public:
property String^ TerminalType {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

Telnet Class
Telnet Members


WindowSize Property

[image]
PowerTCP Telnet for .NET
WindowSize Property
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : WindowSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(System.Drawing.Size, "80,24")>
Public Property WindowSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim value As Size

instance.WindowSize = value

value = instance.WindowSize
C#
[DefaultValue(System.Drawing.Size, "80,24")]
public Size WindowSize {get; set;}
Managed Extensions for C++
[DefaultValue(System.Drawing.Size, "80,24")]
public: __property Size get_WindowSize();
public: __property void set_WindowSize(
   Size value
);
C++/CLI
[DefaultValue(System.Drawing.Size, "80,24")]
public:
property Size WindowSize {
   Size get();
   void set (    Size value);
}

See Also

Reference

Telnet Class
Telnet Members


Telnet Class Fields

[image]
PowerTCP Telnet for .NET
Telnet Class Fields
See Also Send comments on this topic
Dart.Telnet Namespace : Telnet Class

Glossary Item Box

For a list of all members of this type, see Telnet members.

Public Fields

 | Name | Description
Public Field | DefaultPort |
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


DefaultPort Field

[image]
PowerTCP Telnet for .NET
DefaultPort Field
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : DefaultPort Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const DefaultPort As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = Telnet.DefaultPort
C#
public const int DefaultPort
Managed Extensions for C++
public: const int DefaultPort
C++/CLI
public:
const int DefaultPort

See Also

Reference

Telnet Class
Telnet Members


Telnet Class Events

[image]
PowerTCP Telnet for .NET
Telnet Class Events
See Also Send comments on this topic
Dart.Telnet Namespace : Telnet Class

Glossary Item Box

For a list of all members of this type, see Telnet members.

Public Events

 | Name | Description
Public Event | ClientOptionChanged |
Public Event | CommandReceived |
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | ServerOptionChanged |
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Telnet Class
Dart.Telnet Namespace


ClientOptionChanged Event

[image]
PowerTCP Telnet for .NET
ClientOptionChanged Event
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : ClientOptionChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event ClientOptionChanged As EventHandler(Of OptionEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim handler As EventHandler(Of OptionEventArgs)

AddHandler instance.ClientOptionChanged, handler
C#
public event EventHandler<OptionEventArgs> ClientOptionChanged
Managed Extensions for C++
public: __event EventHandler<OptionEventArgs*>* ClientOptionChanged
C++/CLI
public:
event EventHandler<OptionEventArgs^>^ ClientOptionChanged

Event Data

The event handler receives an argument of type OptionEventArgs containing data related to this event. The following OptionEventArgs properties provide information specific to this event.

Property | Description
Option |

See Also

Reference

Telnet Class
Telnet Members


CommandReceived Event

[image]
PowerTCP Telnet for .NET
CommandReceived Event
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : CommandReceived Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event CommandReceived As EventHandler(Of CommandEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim handler As EventHandler(Of CommandEventArgs)

AddHandler instance.CommandReceived, handler
C#
public event EventHandler<CommandEventArgs> CommandReceived
Managed Extensions for C++
public: __event EventHandler<CommandEventArgs*>* CommandReceived
C++/CLI
public:
event EventHandler<CommandEventArgs^>^ CommandReceived

Event Data

The event handler receives an argument of type CommandEventArgs containing data related to this event. The following CommandEventArgs properties provide information specific to this event.

Property | Description
Command |
OptionCode |
SubOption |

See Also

Reference

Telnet Class
Telnet Members


ServerOptionChanged Event

[image]
PowerTCP Telnet for .NET
ServerOptionChanged Event
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : ServerOptionChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event ServerOptionChanged As EventHandler(Of OptionEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As Telnet
Dim handler As EventHandler(Of OptionEventArgs)

AddHandler instance.ServerOptionChanged, handler
C#
public event EventHandler<OptionEventArgs> ServerOptionChanged
Managed Extensions for C++
public: __event EventHandler<OptionEventArgs*>* ServerOptionChanged
C++/CLI
public:
event EventHandler<OptionEventArgs^>^ ServerOptionChanged

Event Data

The event handler receives an argument of type OptionEventArgs containing data related to this event. The following OptionEventArgs properties provide information specific to this event.

Property | Description
Option |

See Also

Reference

Telnet Class
Telnet Members


UserStateEventArgs Class

[image]
PowerTCP Telnet for .NET
UserStateEventArgs Class
Members See Also Send comments on this topic
Dart.Telnet Namespace : UserStateEventArgs Class

Glossary Item Box

Object Model

UserStateEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class UserStateEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
C#
public class UserStateEventArgs : System.EventArgs
Managed Extensions for C++
public __gc class UserStateEventArgs : public System.EventArgs
C++/CLI
public ref class UserStateEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dart.Telnet.UserStateEventArgs
Dart.Telnet.DataEventArgs

See Also

Reference

UserStateEventArgs Members
Dart.Telnet Namespace


UserStateEventArgs Class Members

[image]
PowerTCP Telnet for .NET
UserStateEventArgs Class Members
See Also Properties Send comments on this topic
Dart.Telnet Namespace : UserStateEventArgs Class

Glossary Item Box

The following tables list the members exposed by UserStateEventArgs.

Public Properties

 | Name | Description
Public Property | Message |
Public Property | UserState |
Top

See Also

Reference

UserStateEventArgs Class
Dart.Telnet Namespace


UserStateEventArgs Class Properties

[image]
PowerTCP Telnet for .NET
UserStateEventArgs Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : UserStateEventArgs Class

Glossary Item Box

For a list of all members of this type, see UserStateEventArgs members.

Public Properties

 | Name | Description
Public Property | Message |
Public Property | UserState |
Top

See Also

Reference

UserStateEventArgs Class
Dart.Telnet Namespace


Message Property

[image]
PowerTCP Telnet for .NET
Message Property
See Also Send comments on this topic
Dart.Telnet Namespace > UserStateEventArgs Class : Message Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
Dim value As String

value = instance.Message
C#
public string Message {get;}
Managed Extensions for C++
public: __property string* get_Message();
C++/CLI
public:
property String^ Message {
   String^ get();
}

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members


UserState Property

[image]
PowerTCP Telnet for .NET
UserState Property
See Also Send comments on this topic
Dart.Telnet Namespace > UserStateEventArgs Class : UserState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserState As Object
Visual Basic (Usage) Copy Code
Dim instance As UserStateEventArgs
Dim value As Object

value = instance.UserState
C#
public object UserState {get;}
Managed Extensions for C++
public: __property Object* get_UserState();
C++/CLI
public:
property Object^ UserState {
   Object^ get();
}

See Also

Reference

UserStateEventArgs Class
UserStateEventArgs Members


Command Enumeration

[image]
PowerTCP Telnet for .NET
Command Enumeration
See Also Send comments on this topic
Dart.Telnet Namespace : Command Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum Command
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As Command
C#
public enum Command : System.Enum
Managed Extensions for C++
__value public enum Command : public System.Enum
C++/CLI
public enum class Command : public System.Enum

Members

Member | Description
AO |
Ayt |
Brk |
DM |
Do |
Dont |
EC |
EL |
GA |
Iac |
IP |
Nop |
SB |
SE |
Will |
Wont |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Telnet.Command

See Also

Reference

Dart.Telnet Namespace


ConnectionState Enumeration

[image]
PowerTCP Telnet for .NET
ConnectionState Enumeration
See Also Send comments on this topic
Dart.Telnet Namespace : ConnectionState Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ConnectionState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ConnectionState
C#
public enum ConnectionState : System.Enum
Managed Extensions for C++
__value public enum ConnectionState : public System.Enum
C++/CLI
public enum class ConnectionState : public System.Enum

Members

Member | Description
Closed |
Connected |
ConnectedAndSecure |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Telnet.ConnectionState

See Also

Reference

Dart.Telnet Namespace


DataDirection Enumeration

[image]
PowerTCP Telnet for .NET
DataDirection Enumeration
See Also Send comments on this topic
Dart.Telnet Namespace : DataDirection Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum DataDirection
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As DataDirection
C#
public enum DataDirection : System.Enum
Managed Extensions for C++
__value public enum DataDirection : public System.Enum
C++/CLI
public enum class DataDirection : public System.Enum

Members

Member | Description
In |
Out |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Telnet.DataDirection

See Also

Reference

Dart.Telnet Namespace


OptionCode Enumeration

[image]
PowerTCP Telnet for .NET
OptionCode Enumeration
See Also Send comments on this topic
Dart.Telnet Namespace : OptionCode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum OptionCode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As OptionCode
C#
public enum OptionCode : System.Enum
Managed Extensions for C++
__value public enum OptionCode : public System.Enum
C++/CLI
public enum class OptionCode : public System.Enum

Members

Member | Description
ApproxMessageSize |
Authentication |
ByteMacro |
CharacterSet |
ComPort |
DataEntryTerminal |
Echo |
EncryptionOption |
EndOfRecord |
Environment |
ExtendedAscii |
ExtendedOptionsList |
ForwardX |
Kermit |
LineMode |
Logout |
NewEnvironment |
None |
OutputCarriageReturnDisp |
OutputFormfeedDisp |
OutputHorizontalTabDisp |
OutputHorizontalTabstops |
OutputLinefeedDisp |
OutputLineWidth |
OutputMarking |
OutputPageSize |
OutputVerticalTabDisp |
OutputVerticalTabstops |
PragmaHeartbeat |
PragmaLogon |
Regime3270 |
RemoteControlledTransAndEcho |
RemoteSerialPort |
SendLocation |
SendUrl |
SspiLogon |
StartTls |
Status |
SupDup |
SupDupOutput |
SuppressGoAheads |
SuppressLocalEcho |
TacacsUserIdentification |
TerminalLocation |
TerminalSpeed |
TerminalType |
TimingMark |
TN3270E |
ToggleFlowControl |
TransmitBinary |
WindowSize |
X3Pad |
Xauth |
XDisplayLocation |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Telnet.OptionCode

See Also

Reference

Dart.Telnet Namespace


OptionState Enumeration

[image]
PowerTCP Telnet for .NET
OptionState Enumeration
See Also Send comments on this topic
Dart.Telnet Namespace : OptionState Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum OptionState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As OptionState
C#
public enum OptionState : System.Enum
Managed Extensions for C++
__value public enum OptionState : public System.Enum
C++/CLI
public enum class OptionState : public System.Enum

Members

Member | Description
Allow |
Off |
On |
RequestOff |
RequestOn |
Waiting |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Telnet.OptionState

See Also

Reference

Dart.Telnet Namespace


ProxyType Enumeration

[image]
PowerTCP Telnet for .NET
ProxyType Enumeration
See Also Send comments on this topic
Dart.Telnet Namespace : ProxyType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum ProxyType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ProxyType
C#
public enum ProxyType : System.Enum
Managed Extensions for C++
__value public enum ProxyType : public System.Enum
C++/CLI
public enum class ProxyType : public System.Enum

Members

Member | Description
Http |
None |
Socks4 |
Socks5 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dart.Telnet.ProxyType

See Also

Reference

Dart.Telnet Namespace


TcpAsyncCallback Delegate

[image]
PowerTCP Telnet for .NET
TcpAsyncCallback Delegate
See Also Send comments on this topic
Dart.Telnet Namespace : TcpAsyncCallback Delegate

tcp
data
exception
state

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub TcpAsyncCallback( _
   ByVal tcp As TcpBase, _
   ByVal data As Data, _
   ByVal exception As Exception, _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New TcpAsyncCallback(AddressOf HandlerMethod)
C#
public delegate void TcpAsyncCallback(
   TcpBase tcp,
   Data data,
   Exception exception,
   object state
)
Managed Extensions for C++
public: __gc __delegate void TcpAsyncCallback(
   TcpBase* tcp,
   Data* data,
   Exception* exception,
   Object* state
)
C++/CLI
public delegate void TcpAsyncCallback(
   TcpBase^ tcp,
   Data^ data,
   Exception^ exception,
   Object^ state
)

Parameters

tcp
data
exception
state

See Also

Reference

TcpAsyncCallback Members
Dart.Telnet Namespace


Assembly Overview

Dart.Telnet Assembly
See Also Send comments on this topic

Glossary Item Box

Namespaces

Namespace | Description
Dart.Telnet |


Getting Started - PowerTCP Telnet for .NET

Getting Started
Send comments on this topic

Glossary Item Box


Introduction - PowerTCP Telnet for .NET

Introduction
Send comments on this topic

Glossary Item Box


DartLicenseException Class Methods

[image]
PowerTCP Telnet for .NET
DartLicenseException Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : DartLicenseException Class

Glossary Item Box

For a list of all members of this type, see DartLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Telnet Namespace


DartLicenseException Class Properties

[image]
PowerTCP Telnet for .NET
DartLicenseException Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : DartLicenseException Class

Glossary Item Box

For a list of all members of this type, see DartLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DartLicenseException Class
Dart.Telnet Namespace


DataException Class Methods

[image]
PowerTCP Telnet for .NET
DataException Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : DataException Class

Glossary Item Box

For a list of all members of this type, see DataException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DataException Class
Dart.Telnet Namespace


DataException Class Properties

[image]
PowerTCP Telnet for .NET
DataException Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : DataException Class

Glossary Item Box

For a list of all members of this type, see DataException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DataException Class
Dart.Telnet Namespace


Datagram Class Methods

[image]
PowerTCP Telnet for .NET
Datagram Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : Datagram Class

Glossary Item Box

For a list of all members of this type, see Datagram members.

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from Dart.Telnet.Data)
Top

See Also

Reference

Datagram Class
Dart.Telnet Namespace


Datagram Class Properties

[image]
PowerTCP Telnet for .NET
Datagram Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Datagram Class

Glossary Item Box

For a list of all members of this type, see Datagram members.

Public Properties

 | Name | Description
Public Property | Buffer | (Inherited from Dart.Telnet.Segment)
Public Property | Count | (Inherited from Dart.Telnet.Segment)
Public Property | Delimiter | (Inherited from Dart.Telnet.Data)
Public Property | Direction | (Inherited from Dart.Telnet.Data)
Public Property | Encoding | (Inherited from Dart.Telnet.Data)
Public Property | Offset | (Inherited from Dart.Telnet.Segment)
Top

See Also

Reference

Datagram Class
Dart.Telnet Namespace


ProtocolException Class Methods

[image]
PowerTCP Telnet for .NET
ProtocolException Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : ProtocolException Class

Glossary Item Box

For a list of all members of this type, see ProtocolException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ProtocolException Class
Dart.Telnet Namespace


ProtocolException Class Properties

[image]
PowerTCP Telnet for .NET
ProtocolException Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : ProtocolException Class

Glossary Item Box

For a list of all members of this type, see ProtocolException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

ProtocolException Class
Dart.Telnet Namespace


PtyBase Class Events

[image]
PowerTCP Telnet for .NET
PtyBase Class Events
See Also Send comments on this topic
Dart.Telnet Namespace : PtyBase Class

Glossary Item Box

For a list of all members of this type, see PtyBase members.

Public Events

 | Name | Description
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

PtyBase Class
Dart.Telnet Namespace


PtyBase Class Methods

[image]
PowerTCP Telnet for .NET
PtyBase Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : PtyBase Class

Glossary Item Box

For a list of all members of this type, see PtyBase members.

Public Methods

 | Name | Description
Public Method | Abort | (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClient | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | AuthenticateAsClientTaskAsync | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Close | (Inherited from Dart.Telnet.TcpBase)
Public Method | Connect | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ConnectTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetStream | (Inherited from Dart.Telnet.TcpBase)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | Read | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToCount | (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToDelimiter | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | ReadToEnd | (Inherited from Dart.Telnet.TcpBase)
Public Method | ShutdownSsl | (Inherited from Dart.Telnet.TcpBase)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Write | Overloaded. (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteAsync | (Inherited from Dart.Telnet.TcpBase)
Public Method | WriteTaskAsync | (Inherited from Dart.Telnet.TcpBase)
Top

See Also

Reference

PtyBase Class
Dart.Telnet Namespace


Rexec Class Events

[image]
PowerTCP Telnet for .NET
Rexec Class Events
See Also Send comments on this topic
Dart.Telnet Namespace : Rexec Class

Glossary Item Box

For a list of all members of this type, see Rexec members.

Public Events

 | Name | Description
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


Rexec Class Properties

[image]
PowerTCP Telnet for .NET
Rexec Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Rexec Class

Glossary Item Box

For a list of all members of this type, see Rexec members.

Public Properties

 | Name | Description
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Rexec Class
Dart.Telnet Namespace


Rlogin Class Events

[image]
PowerTCP Telnet for .NET
Rlogin Class Events
See Also Send comments on this topic
Dart.Telnet Namespace : Rlogin Class

Glossary Item Box

For a list of all members of this type, see Rlogin members.

Public Events

 | Name | Description
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Rlogin Class
Dart.Telnet Namespace


Rsh Class Events

[image]
PowerTCP Telnet for .NET
Rsh Class Events
See Also Send comments on this topic
Dart.Telnet Namespace : Rsh Class

Glossary Item Box

For a list of all members of this type, see Rsh members.

Public Events

 | Name | Description
Public Event | Data | (Inherited from Dart.Telnet.TcpBase)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | Log | (Inherited from Dart.Telnet.TcpBase)
Public Event | StateChanged | (Inherited from Dart.Telnet.TcpBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


Rsh Class Properties

[image]
PowerTCP Telnet for .NET
Rsh Class Properties
See Also Send comments on this topic
Dart.Telnet Namespace : Rsh Class

Glossary Item Box

For a list of all members of this type, see Rsh members.

Public Properties

 | Name | Description
Public Property | CloseTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | ConnectTime | (Inherited from Dart.Telnet.TcpBase)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | (Inherited from Dart.Telnet.ComponentBase)
Public Property | NetworkStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | RemoteEndPoint | (Inherited from Dart.Telnet.TcpBase)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Socket | (Inherited from Dart.Telnet.SocketBase)
Public Property | SocketOption | (Inherited from Dart.Telnet.TcpBase)
Public Property | SslStream | (Inherited from Dart.Telnet.TcpBase)
Public Property | State | (Inherited from Dart.Telnet.TcpBase)
Public Property | SynchronizingObject | (Inherited from Dart.Telnet.ComponentBase)
Public Property | SyncRoot | (Inherited from Dart.Telnet.ComponentBase)
Public Property | Tag | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

Rsh Class
Dart.Telnet Namespace


SocketBase Class Events

[image]
PowerTCP Telnet for .NET
SocketBase Class Events
See Also Send comments on this topic
Dart.Telnet Namespace : SocketBase Class

Glossary Item Box

For a list of all members of this type, see SocketBase members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | Error | (Inherited from Dart.Telnet.ComponentBase)
Public Event | UserState | (Inherited from Dart.Telnet.ComponentBase)
Top

See Also

Reference

SocketBase Class
Dart.Telnet Namespace


SocketBase Class Methods

[image]
PowerTCP Telnet for .NET
SocketBase Class Methods
See Also Send comments on this topic
Dart.Telnet Namespace : SocketBase Class

Glossary Item Box

For a list of all members of this type, see SocketBase members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Marshal | Overloaded. (Inherited from Dart.Telnet.ComponentBase)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

SocketBase Class
Dart.Telnet Namespace


Dispose Method

[image]
PowerTCP Telnet for .NET
Dispose Method
See Also Send comments on this topic
Dart.Telnet Namespace > SocketBase Class : Dispose Method

Glossary Item Box

Overload List

Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)

See Also

Reference

SocketBase Class
SocketBase Members


Close Method

[image]
PowerTCP Telnet for .NET
Close Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Close Method

Glossary Item Box

Overload List

Overload | Description
Close |

See Also

Reference

TcpBase Class
TcpBase Members


Dispose Method

[image]
PowerTCP Telnet for .NET
Dispose Method
See Also Send comments on this topic
Dart.Telnet Namespace > TcpBase Class : Dispose Method

Glossary Item Box

Overload List

Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)

See Also

Reference

TcpBase Class
TcpBase Members


Login Method

[image]
PowerTCP Telnet for .NET
Login Method
See Also Send comments on this topic
Dart.Telnet Namespace > Telnet Class : Login Method

Glossary Item Box

Overload List

Overload | Description
Login |

See Also

Reference

Telnet Class
Telnet Members


Dart.Telnet Namespace Inheritance Hierarchy

Dart.Telnet Namespace Inheritance Hierarchy
See Also Send comments on this topic

Glossary Item Box

Inheritance Hierarchy

System.Object
Dart.Telnet.Credentials
Dart.Telnet.License
Dart.Telnet.Option
Dart.Telnet.Proxy
Dart.Telnet.Security
Dart.Telnet.ClientSecurity
Dart.Telnet.Segment
Dart.Telnet.Data
Dart.Telnet.Datagram
Dart.Telnet.Session
Dart.Telnet.TcpSession
Dart.Telnet.SocketOption
Dart.Telnet.TcpSocketOption
System.Collections.Generic.List<T>
Dart.Telnet.OptionCollection
System.EventArgs
Dart.Telnet.BaseEventArgs
Dart.Telnet.CommandEventArgs
Dart.Telnet.ErrorEventArgs
Dart.Telnet.OptionEventArgs
Dart.Telnet.UserStateEventArgs
Dart.Telnet.DataEventArgs
System.Exception
Dart.Telnet.DartLicenseException
System.ApplicationException
Dart.Telnet.DataException
Dart.Telnet.ProtocolException
System.MarshalByRefObject
System.ComponentModel.Component
Dart.Telnet.ComponentBase
Dart.Telnet.SocketBase
Dart.Telnet.TcpBase
Dart.Telnet.PtyBase
Dart.Telnet.Rlogin
Dart.Telnet.Telnet
Dart.Telnet.Rexec
Dart.Telnet.Rsh
System.Net.EndPoint
System.Net.IPEndPoint
Dart.Telnet.IPEndPoint

See Also

Reference

Dart.Telnet Assembly


.NET Framework Runtime Licensing

.NET Framework Runtime Licensing
Send comments on this topic

Glossary Item Box

First, ensure a license is activated (see License Activation).

For projects targeting .NET Framework 4.5-4.8.1 (using the .NET 4.5 Framework assembly), users can choose between the newer .NET Standard Licensing technique (see .NET Standard Runtime Licensing) or the legacy .licx technique described here.

A licenses.licx file is required in the top level executing assembly’s project, containing an entry for each licensed class (only one is necessary for each Dart assembly). When a licensed component is added to a project using the Visual Studio designer, a licenses.licx file is automatically generated if one does not already exist, and an entry for the class is added.

When developing an assembly with no design surface such as a console application, or when instantiating a licensed class in code, the licenses.licx file must be added manually. If a licenses.licx file is not present in the project, add a new text file named "licenses.licx" to the top level project (not the solution) from the Solution Explorer. Add a single line to the licenses.licx that includes the fully-specified class name and the assembly name, separated by a comma. If using multiple Dart product assemblies, each entry should appear on its own line. For example:

Dart.Telnet.Telnet, Dart.Telnet

The license compiler, lc.exe, will then create a licenses resource and embed it into the compiled application where it is validated at runtime.

Web Site projects include an App_Licenses.dll that must be rebuilt when changes are made to the licenses.licx file or when migrating from trial to licensed operation. The App_Licenses.dll can be rebuilt by right-clicking on the licenses.licx file in the Solution Explorer and selecting the "Rebuild Runtime Licenses" option.

If a library using a Dart component is developed for use in another top level, executing assembly project, then that top level project must include the licenses.licx file. If embedding a license resource in the consuming application is not possible then an Extended Distribution License Product Key is needed. Purchase may be required. Please contact sales@dart.com for more information.


.NET Standard Runtime Licensing

.NET Standard Runtime Licensing
Send comments on this topic

Glossary Item Box

First, ensure a license is activated (see License Activation).

Standard licensing is used if .NET Framework licensing is not (see .NET Framework Runtime Licensing). If you are transitioning a project away from using the legacy licenses.licx technique but targeting Dart .NET Framework assemblies, the licenses.licx file should be removed from the project or Dart component entries removed from the licenses.licx file. If you are upgrading from a previous version, you will need to remove existing references to License.Set() from your code or update them as described in step 4 below.

To generate a runtime license for your application:

  1. With an activated license present, run your application so that a licensed component’s constructor is called (or call Dart.Telnet.License.Create() when your application starts).
  2. The runtime license is created and saved to Dart.Telnet.lic beside Dart.Telnet.dll in the output directory. The runtime license is bound to the application’s assembly name and should be distributed with your application.
  3. If Dart.Telnet.License.Create() was used, remove it from your code.
  4. If distributing Dart.Telnet.lic is undesirable (when using a build server, for example, or to minimize the size of your distribution), then a runtime license string can be used instead:
    1. Use any text editor to open the Dart.Telnet.lic file located in the output directory.
    2. Copy the runtime license string from the first line.
    3. In your application's code, paste the runtime license string in between the quotes of License.Set, as follows:
      Dart.Telnet.License.Set("RuntimeLicenseString");

If desired, you can create a runtime license for your intermediate assembly so it can be used in any application:

  1. Obtain an Extended Distribution Product Key from Dart and activate it. (Purchase may be required.)
  2. Follow the steps above, using Dart.Telnet.License.Create() in step 1.