%%ItemTitle%%

dbiSchedule WPF Send comments on this topic.
Introduction

Glossary Item Box

Solutions Schedule for WPF - bring full featured Resource scheduling, planning, and Gantt style Drag 'n Drop resource management to your end users quickly. From desktop to mobile computing platforms, Solutions Schedule for WPF extends enterprise resource management, scheduling and optimization.
Introduction Page Image
Industry proven component software solutions - Extending the Visual Studio Developer Experience
Custom Time Bar Styles | Interactive Time Bars | Snap to guide lines
Custom Time Types | Line Item Formatting | Text in Time Bars
Dead Zones | Map Area | Time Bar Conflicts
Direct Edit | Milestone Markers | Time Bar Images
Drag 'n Drop Scheduling | Multi Column Resource List | Time Bar Linking
Edit Mode Toolbar | Owner Drawn Time Bars | Vertical Movement
Guide Lines | Printed Schedules | Undo / Redo
Horizontal Movement | Schedule Notes |

© dbi Technologies Inc. All Rights Reserved.


%%ItemTitle%%

Dbi.WpfControl.dbiSchedule Namespace
See Also Inheritance Hierarchy
dbiScheduleWPF Assembly : Dbi.WpfControl.dbiSchedule Namespace
Multi-Resource Scheduling control namespace for WPF

Classes

Class | Description
AfterGuideLineInsertedEventArgs | Provides data for the AfterGuideLineInserted Event
AfterGuideLineMovedEventArgs | Provides data for the AfterGuideLineMoved Event
AfterGuideLineRemovedEventArgs | Provides data for the AfterGuideLineRemoved Event
AfterPrintEventArgs | Provides data for the AfterPrint Event
AfterTimeBarInsertedEventArgs | Provides data for the AfterTimeBarInserted Event
AfterTimeBarLinkedEventArgs | Provides data for the AfterTimeBarLinked Event
AfterTimeBarMovedEventArgs | Provides data for the AfterTimeBarMoved Event
AfterTimeBarRemovedEventArgs | Provides data for the AfterTimeBarRemoved Event
AfterTimeBarSizedEventArgs | Provides data for the AfterTimeBarSized Event
AfterTimeBarSplitEventArgs | Provides data for the AfterTimeBarSplit Event
AfterTimeBarUnlinkedEventArgs | Provides data for the AfterTimeBarUnlinked Event
BeforeGuideLineInsertEventArgs | Provides data for the BeforeGuideLineInsert Event
BeforeGuideLineMoveEventArgs | Provides data for the BeforeGuideLineMove Event
BeforeGuideLineRemoveEventArgs | Provides data for the BeforeGuideLineRemove Event
BeforePrintEventArgs | Provides data for the BeforePrint Event
BeforeTimeBarInsertEventArgs | Provides data for the BeforeTimeBarInsert Event
BeforeTimeBarLinkEventArgs | Provides data for the BeforeTimeBarLink Event
BeforeTimeBarMoveEventArgs | Provides data for the BeforeTimeBarMove Event
BeforeTimeBarRemoveEventArgs | Provides data for the BeforeTimeBarRemove Event
BeforeTimeBarSelectEventArgs | Provides data for the BeforeTimeBarSelect Event
BeforeTimeBarSizeEventArgs | Provides data for the BeforeTimeBarSize Event
BeforeTimeBarSplitEventArgs | Provides data for the BeforeTimeBarSplit Event
BeforeTimeBarUnlinkEventArgs | Provides data for the BeforeTimeBarUnlink Event
BeforeToolTipsEventArgs | Provides data for the BeforeToolTips Event
ColumnHeaderClickEventArgs | Provides data for the ColumnHeaderClick Event
ControlErrorEventArgs | Provides data for the ControlError Event
dbiColumnItem | Provides the properties for defining columns.
dbiColumnItemCollection | A collection used to store dbiColumnItems
dbiCustomArea | Provides properties for defining custom areas.
dbiCustomAreaCollection | The collection of custom areas
dbiGuideLine | Provides the properties for defining a GuideLine
dbiGuideLineCollection | The collection of guidelines.
dbiHistoryItem | Provides the properties for defining a dbiHistoryItem
dbiLinkItem | Provides properties for defining a link item.
dbiLinkItemCollection | The collection of link items
dbiListCell | Provides the properties for defining Cells in the list.
dbiListCellCollection | The collection of list cells
dbiListItem | Provides the properties for defining items in the list
dbiListItemCollection | The collection of list items
dbiScheduleNote | Provides properties for defining a schedule note
dbiScheduleNoteCollection | The collection of schedule notes
dbiScheduleObject | Provides properties for defining schedules
dbiScheduleObjectCollection | The collection of schedule objects
dbiScheduleWPF | Provides properties/methods/events for a multi-resource schedule
dbiTimeBarCollection | The collection of time bars
dbiTimeBarItem | Provides properties for defining a time bar
DeadZoneDropEventArgs | Provides data for the DeadZoneDrop Event
EditModeChangedEventArgs | Provides data for the EditModeChanged Event
FirstDrawEventArgs | Provides data for the FirstDraw Event
GuideLineClickEventArgs | Provides data for the GuideLineClick Event
GuideLineMoveEventArgs | Provides data for the GuideLineMove Event
HistoryChangeEventArgs | Provides data for the HistoryChange Event
ItemMouseOverEventArgs | Provides data for the ItemMouseOver Event
LineArrowClickEventArgs | Provides data for the LineArrowClick Event
LineArrowMouseOverEventArgs | Provides data for the LineArrowMouseOver Event
ListItemClickEventArgs | Provides data for the ListItemClick Event
NoteClickEventArgs | Provides data for the NoteClick Event
PrintProgressEventArgs | Provides data for the PrintProgress Event
RedoActionEventArgs | Provides data for the RedoAction Event
ScheduleClickEventArgs | Provides data for the ScheduleClick Event
ScheduleMouseMoveEventArgs | Provides data for the ScheduleMouseMove Event
TimeBarClickEventArgs | Provides data for the TimeBarClick Event
TimeBarSizingEventArgs | Provides data for the TimeBarSizing Event
UndoActionEventArgs | Provides data for the UndoAction Event
UserDrawnBarAfterEventArgs | Provides data for the UserDrawnBarAfter Event
UserDrawnBarBeforeEventArgs | Provides data for the UserDrawnBarBefore Event
UserDrawnLineAfterEventArgs | Provides data for the UserDrawnLineAfter Event
UserDrawnLineBeforeEventArgs | Provides data for the UserDrawnLineBefore Event
ValuePointEventArgs | Provides data for the ValuePoint Event

Delegates

Delegate | Description
dbiScheduleWPF.AfterGuideLineInsertedHandler | Represents the method that handles the AfterGuideLineInserted Event
dbiScheduleWPF.AfterGuideLineMovedHandler | Represents the method that handles the AfterGuideLineMoved Event
dbiScheduleWPF.AfterGuideLineRemovedHandler | Represents the method that handles the AfterGuideLineRemoved Event
dbiScheduleWPF.AfterPrintHandler | Represents the method that handles the AfterPrint Event
dbiScheduleWPF.AfterTimeBarInsertedHandler | Represents the method that handles the AfterTimeBarInserted Event
dbiScheduleWPF.AfterTimeBarLinkedHandler | Represents the method that handles the AfterTimeBarLinked Event
dbiScheduleWPF.AfterTimeBarMovedHandler | Represents the method that handles the AfterTimeBarMoved Event
dbiScheduleWPF.AfterTimeBarRemovedHandler | Represents the method that handles the AfterTimeBarRemoved Event
dbiScheduleWPF.AfterTimeBarSizedHandler | Represents the method that handles the AfterTimeBarSized Event
dbiScheduleWPF.AfterTimeBarSplitHandler | Represents the method that handles the AfterTimeBarSplit Event
dbiScheduleWPF.AfterTimeBarUnlinkedHandler | Represents the method that handles the AfterTimeBarUnlinked Event
dbiScheduleWPF.BeforeGuideLineInsertHandler | Represents the method that handles the BeforeGuideLineInsert Event
dbiScheduleWPF.BeforeGuideLineMoveHandler | Represents the method that handles the BeforeGuideLineMove Event
dbiScheduleWPF.BeforeGuideLineRemoveHandler | Represents the method that handles the BeforeGuideLineRemove Event
dbiScheduleWPF.BeforePrintHandler | Represents the method that handles the BeforePrint Event
dbiScheduleWPF.BeforeTimeBarInsertHandler | Represents the method that handles the BeforeTimeBarInsert Event
dbiScheduleWPF.BeforeTimeBarLinkHandler | Represents the method that handles the BeforeTimeBarLink Event
dbiScheduleWPF.BeforeTimeBarMoveHandler | Represents the method that handles the BeforeTimeBarMove Event
dbiScheduleWPF.BeforeTimeBarRemoveHandler | Represents the method that handles the BeforeTimeBarRemove Event
dbiScheduleWPF.BeforeTimeBarSelectHandler | Represents the method that handles the BeforeTimeBarSelect Event
dbiScheduleWPF.BeforeTimeBarSizeHandler | Represents the method that handles the BeforeTimeBarSize Event
dbiScheduleWPF.BeforeTimeBarSplitHandler | Represents the method that handles the BeforeTimeBarSplit Event
dbiScheduleWPF.BeforeTimeBarUnlinkHandler | Represents the method that handles the BeforeTimeBarUnlink Event
dbiScheduleWPF.BeforeToolTipsHandler | Represents the method that handles the BeforeToolTips Event
dbiScheduleWPF.ColumnHeaderClickHandler | Represents the method that handles the ColumnHeaderClick Event
dbiScheduleWPF.ControlErrorHandler | Represents the method that handles the ControlError Event
dbiScheduleWPF.DeadZoneDropHandler | Represents the method that handles the DeadZoneDrop Event
dbiScheduleWPF.EditModeChangedHandler | Represents the method that handles the EditModeChanged Event
dbiScheduleWPF.FirstDrawHandler | Represents the method that handles the FirstDraw Event
dbiScheduleWPF.GuideLineClickHandler | Represents the method that handles the GuideLineClick Event
dbiScheduleWPF.GuideLineMoveHandler | Represents the method that handles the GuideLineMove Event
dbiScheduleWPF.HistoryChangeHandler | Represents the method that handles the HistoryChange Event
dbiScheduleWPF.ItemMouseOverHandler | Represents the method that handles the ItemMouseOver Event
dbiScheduleWPF.LineArrowClickHandler | Represents the method that handles the LineArrowClick Event
dbiScheduleWPF.LineArrowMouseOverHandler | Represents the method that handles the LineArrowMouseOver Event
dbiScheduleWPF.ListItemClickHandler | Represents the method that handles the ListItemClick Event
dbiScheduleWPF.NoteClickHandler | Represents the method that handles the NoteClick Event
dbiScheduleWPF.PrintProgressHandler | Represents the method that handles the PrintProgress Event
dbiScheduleWPF.RedoActionHandler | Represents the method that handles the RedoAction Event
dbiScheduleWPF.ScheduleClickHandler | Represents the method that handles the ScheduleClick Event
dbiScheduleWPF.ScheduleMouseMoveHandler | Represents the method that handles the ScheduleMouseMove Event
dbiScheduleWPF.TimeBarClickHandler | Represents the method that handles the TimeBarClick Event
dbiScheduleWPF.TimeBarSizingHandler | Represents the method that handles the TimeBarSizing Event
dbiScheduleWPF.UndoActionHandler | Represents the method that handles the UndoAction Event
dbiScheduleWPF.UserDrawnBarAfterHandler | Represents the method that handles the UserDrawnBarAfter Event
dbiScheduleWPF.UserDrawnBarBeforeHandler | Represents the method that handles the UserDrawnBarBefore Event
dbiScheduleWPF.UserDrawnLineAfterHandler | Represents the method that handles the UserDrawnLineAfter Event
dbiScheduleWPF.UserDrawnLineBeforeHandler | Represents the method that handles the UserDrawnLineBefore Event
dbiScheduleWPF.ValuePointHandler | Represents the method that handles the ValuePoint Event

Enumerations

Enumeration | Description
dbiColumnItem.enumSortBy | Specifies the value type to perform a sort on
dbiHistoryItem.enumActionType | Specifies the type of Undo/Redo action added to the HistoryCollection.
dbiLinkItem.enumLinkDirection | Specifies the direction of a link.
dbiLinkItem.enumLinkType | Specifies the type of link to display.
enumAlignment | Specifies the horizontal alignment.
enumBarTextAlign | Specifies the position of the primary text of a Timebar.
enumBrushType | Specifies the pre-built Gradient brush style.
enumControlStyle | Preset styles and property values to assign to the control.
enumEditMode | Specifies the editmode for the control
enumFirstDayOfWeek | Specifies the first day of the week in the ruler.
enumGuideImagePosition | Specifies the ZOrder of the Guide Image in relation to the ruler text.
enumGuideLinePosition | Specifies the ZOrder of the GuideLine in relation to the TimeBars in the Schedule.
enumImageAlignment | Specifies the horizontal alignment for the image
enumLineArrowDirection | Specifies which direction on the schedule, the LineArrow is pointing.
enumLineArrowPosition | Specifies how the LineArrow is shown inside the Schedule, in relation to the other objects.
enumLineArrowType | Specifices th type of LineArrows to display
enumListType | Determines how the ListItems will be drawn.
enumMonthFormat | Specifies how the monthly ruler is displayed.
enumNotesPosition | Specifies how the ScheduleNotes are shown inside the Schedule, in relation to the other objects.
enumRulerAlign | Specifies the alignment of the ruler text in a schedule.
enumScheduleArea | Specifies a location inside the control.
enumScheduleHeaderPosition | Specifies the ZOrder of ListItems marked as headers, in the schedule portion of the control, in relation to the customareas and time lines.
enumSnapToDivisions | Specifies how the mouse will snap to the divisions in the schedule.
enumSortDirection | Determines the directions of the sort.
enumTimeType | Specifies the type of unit to display in the rules.
enumTipsType | Specifies the type of tool tip to display.
enumYearFormat | Specifies how the yearly ruler is displayed.

See Also

Reference

dbiScheduleWPF Assembly


%%PageItemTitle%%

AfterGuideLineInsertedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterGuideLineInsertedEventArgs Class

Provides data for the AfterGuideLineInserted Event

Object Model

AfterGuideLineInsertedEventArgs ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineInsertedEventArgs
C#
public class AfterGuideLineInsertedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterGuideLineInsertedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineInsertedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterGuideLineInsertedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterGuideLineInsertedEventArgs Class

"

The following tables list the members exposed by AfterGuideLineInsertedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterGuideLineInsertedEventArgs Constructor | Initialize a new instance of the class
Top

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was inserted.
public Property | LineIndex | The zero-based index of the dbiGuideLine in the dbiGuideLineCollection.
public Property | LineTime | The date/time value for the dbiGuideLine
Top

See Also

Reference

AfterGuideLineInsertedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterGuideLineInsertedEventArgs Constructor
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineInsertedEventArgs Class : AfterGuideLineInsertedEventArgs Constructor

Initialize a new instance of the class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterGuideLineInsertedEventArgs()
C#
public AfterGuideLineInsertedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineInsertedEventArgs Class
AfterGuideLineInsertedEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterGuideLineInsertedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterGuideLineInsertedEventArgs Class

"

For a list of all members of this type, see AfterGuideLineInsertedEventArgs members.

"

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was inserted.
public Property | LineIndex | The zero-based index of the dbiGuideLine in the dbiGuideLineCollection.
public Property | LineTime | The date/time value for the dbiGuideLine
Top

See Also

Reference

AfterGuideLineInsertedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineInsertedEventArgs Class : GuideLine Property

The dbiGuideLine that was inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineInsertedEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineInsertedEventArgs Class
AfterGuideLineInsertedEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineInsertedEventArgs Class : LineIndex Property

The zero-based index of the dbiGuideLine in the dbiGuideLineCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineInsertedEventArgs
Dim value As Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public int LineIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineInsertedEventArgs Class
AfterGuideLineInsertedEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineInsertedEventArgs Class : LineTime Property

The date/time value for the dbiGuideLine

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineInsertedEventArgs
Dim value As Date

instance.LineTime = value

value = instance.LineTime
C#
public DateTime LineTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineInsertedEventArgs Class
AfterGuideLineInsertedEventArgs Members


%%PageItemTitle%%

AfterGuideLineMovedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterGuideLineMovedEventArgs Class

Provides data for the AfterGuideLineMoved Event

Object Model

AfterGuideLineMovedEventArgs ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineMovedEventArgs
C#
public class AfterGuideLineMovedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterGuideLineMovedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineMovedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterGuideLineMovedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterGuideLineMovedEventArgs Class

"

The following tables list the members exposed by AfterGuideLineMovedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterGuideLineMovedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was moved.
public Property | LineIndex | The zero-based index of the dbiGuideLine in the dbiGuideLineCollection.
public Property | LineTime | The date/time value for the dbiGuideLine.
Top

See Also

Reference

AfterGuideLineMovedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterGuideLineMovedEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineMovedEventArgs Class : AfterGuideLineMovedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterGuideLineMovedEventArgs()
C#
public AfterGuideLineMovedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineMovedEventArgs Class
AfterGuideLineMovedEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterGuideLineMovedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterGuideLineMovedEventArgs Class

"

For a list of all members of this type, see AfterGuideLineMovedEventArgs members.

"

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was moved.
public Property | LineIndex | The zero-based index of the dbiGuideLine in the dbiGuideLineCollection.
public Property | LineTime | The date/time value for the dbiGuideLine.
Top

See Also

Reference

AfterGuideLineMovedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineMovedEventArgs Class : GuideLine Property

The dbiGuideLine that was moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineMovedEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineMovedEventArgs Class
AfterGuideLineMovedEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineMovedEventArgs Class : LineIndex Property

The zero-based index of the dbiGuideLine in the dbiGuideLineCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineMovedEventArgs
Dim value As Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public int LineIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineMovedEventArgs Class
AfterGuideLineMovedEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineMovedEventArgs Class : LineTime Property

The date/time value for the dbiGuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineMovedEventArgs
Dim value As Date

instance.LineTime = value

value = instance.LineTime
C#
public DateTime LineTime {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineMovedEventArgs Class
AfterGuideLineMovedEventArgs Members


%%PageItemTitle%%

AfterGuideLineRemovedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterGuideLineRemovedEventArgs Class

Provides data for the AfterGuideLineRemoved Event

Object Model

AfterGuideLineRemovedEventArgs ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineRemovedEventArgs
C#
public class AfterGuideLineRemovedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterGuideLineRemovedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineRemovedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterGuideLineRemovedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterGuideLineRemovedEventArgs Class

"

The following tables list the members exposed by AfterGuideLineRemovedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterGuideLineRemovedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was removed.
public Property | LineIndex | The zero-based index of the dbiGuideLine in the dbiGuideLineCollection
Top

See Also

Reference

AfterGuideLineRemovedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterGuideLineRemovedEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineRemovedEventArgs Class : AfterGuideLineRemovedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterGuideLineRemovedEventArgs()
C#
public AfterGuideLineRemovedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineRemovedEventArgs Class
AfterGuideLineRemovedEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterGuideLineRemovedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterGuideLineRemovedEventArgs Class

"

For a list of all members of this type, see AfterGuideLineRemovedEventArgs members.

"

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was removed.
public Property | LineIndex | The zero-based index of the dbiGuideLine in the dbiGuideLineCollection
Top

See Also

Reference

AfterGuideLineRemovedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineRemovedEventArgs Class : GuideLine Property

The dbiGuideLine that was removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineRemovedEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineRemovedEventArgs Class
AfterGuideLineRemovedEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterGuideLineRemovedEventArgs Class : LineIndex Property

The zero-based index of the dbiGuideLine in the dbiGuideLineCollection

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineRemovedEventArgs
Dim value As Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public int LineIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterGuideLineRemovedEventArgs Class
AfterGuideLineRemovedEventArgs Members


%%PageItemTitle%%

AfterPrintEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterPrintEventArgs Class

Provides data for the AfterPrint Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterPrintEventArgs
C#
public class AfterPrintEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterPrintEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterPrintEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterPrintEventArgs Class Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterPrintEventArgs Class

"

The following tables list the members exposed by AfterPrintEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterPrintEventArgs Constructor | Initializes a new instance of the class.
Top

See Also

Reference

AfterPrintEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterPrintEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterPrintEventArgs Class : AfterPrintEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterPrintEventArgs()
C#
public AfterPrintEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterPrintEventArgs Class
AfterPrintEventArgs Members


%%PageItemTitle%%

AfterTimeBarInsertedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarInsertedEventArgs Class

Provides data for the AfterTimeBarInserted Event

Object Model

AfterTimeBarInsertedEventArgs ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarInsertedEventArgs
C#
public class AfterTimeBarInsertedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarInsertedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarInsertedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarInsertedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarInsertedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarInsertedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarInsertedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the inserted Timebar.
public Property | ListItem | The dbiListItem containing the TimeBar after it was inserted.
public Property | TimeBarItem | The dbiTimeBarItem after it has been inserted.
Top

See Also

Reference

AfterTimeBarInsertedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterTimeBarInsertedEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarInsertedEventArgs Class : AfterTimeBarInsertedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarInsertedEventArgs()
C#
public AfterTimeBarInsertedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarInsertedEventArgs Class
AfterTimeBarInsertedEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterTimeBarInsertedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarInsertedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarInsertedEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the inserted Timebar.
public Property | ListItem | The dbiListItem containing the TimeBar after it was inserted.
public Property | TimeBarItem | The dbiTimeBarItem after it has been inserted.
Top

See Also

Reference

AfterTimeBarInsertedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarInsertedEventArgs Class : BarIndex Property

The zero-based index value of the inserted Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarInsertedEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarInsertedEventArgs Class
AfterTimeBarInsertedEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarInsertedEventArgs Class : ListItem Property

The dbiListItem containing the TimeBar after it was inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarInsertedEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Property Value

dbiListItem

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarInsertedEventArgs Class
AfterTimeBarInsertedEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarInsertedEventArgs Class : TimeBarItem Property

The dbiTimeBarItem after it has been inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarInsertedEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarInsertedEventArgs Class
AfterTimeBarInsertedEventArgs Members


%%PageItemTitle%%

AfterTimeBarLinkedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarLinkedEventArgs Class

Provides data for the AfterTimeBarLinked Event

Object Model

AfterTimeBarLinkedEventArgs ClassdbiLinkItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarLinkedEventArgs
C#
public class AfterTimeBarLinkedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarLinkedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarLinkedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarLinkedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarLinkedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarLinkedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarLinkedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Link | The dbiLinkItem that was created.
Top

See Also

Reference

AfterTimeBarLinkedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterTimeBarLinkedEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarLinkedEventArgs Class : AfterTimeBarLinkedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarLinkedEventArgs()
C#
public AfterTimeBarLinkedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarLinkedEventArgs Class
AfterTimeBarLinkedEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterTimeBarLinkedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarLinkedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarLinkedEventArgs members.

"

Public Properties

 | Name | Description
public Property | Link | The dbiLinkItem that was created.
Top

See Also

Reference

AfterTimeBarLinkedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Link Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarLinkedEventArgs Class : Link Property

The dbiLinkItem that was created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarLinkedEventArgs
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarLinkedEventArgs Class
AfterTimeBarLinkedEventArgs Members


%%PageItemTitle%%

AfterTimeBarMovedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarMovedEventArgs Class

Provides data for the AfterTimeBarMoved Event

Object Model

AfterTimeBarMovedEventArgs ClassdbiListItem ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
C#
public class AfterTimeBarMovedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarMovedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarMovedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarMovedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarMovedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarMovedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarMovedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | ListItemFrom | The dbiListItem containing the timebar before it was moved.
public Property | ListItemTo | The dbiListItem containing the timebar after it has been moved.
public Property | TimeBarItem | The timebar that was moved.
public Property | Vertical | Determines if the timebar moved vertically.
Top

See Also

Reference

AfterTimeBarMovedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterTimeBarMovedEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarMovedEventArgs Class : AfterTimeBarMovedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarMovedEventArgs()
C#
public AfterTimeBarMovedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterTimeBarMovedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarMovedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarMovedEventArgs members.

"

Public Properties

 | Name | Description
public Property | ListItemFrom | The dbiListItem containing the timebar before it was moved.
public Property | ListItemTo | The dbiListItem containing the timebar after it has been moved.
public Property | TimeBarItem | The timebar that was moved.
public Property | Vertical | Determines if the timebar moved vertically.
Top

See Also

Reference

AfterTimeBarMovedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ListItemFrom Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarMovedEventArgs Class : ListItemFrom Property

The dbiListItem containing the timebar before it was moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
Dim value As dbiListItem

instance.ListItemFrom = value

value = instance.ListItemFrom
C#
public dbiListItem ListItemFrom {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%%

ListItemTo Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarMovedEventArgs Class : ListItemTo Property

The dbiListItem containing the timebar after it has been moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
Dim value As dbiListItem

instance.ListItemTo = value

value = instance.ListItemTo
C#
public dbiListItem ListItemTo {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarMovedEventArgs Class : TimeBarItem Property

The timebar that was moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%%

Vertical Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarMovedEventArgs Class : Vertical Property

Determines if the timebar moved vertically.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
Dim value As Boolean

instance.Vertical = value

value = instance.Vertical
C#
public bool Vertical {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%%

AfterTimeBarRemovedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarRemovedEventArgs Class

Provides data for the AfterTimeBarRemoved Event

Object Model

AfterTimeBarRemovedEventArgs ClassdbiListItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarRemovedEventArgs
C#
public class AfterTimeBarRemovedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarRemovedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarRemovedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarRemovedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarRemovedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarRemovedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarRemovedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar that was removed.
public Property | ListItem | The dbiListItem containing the timebar before it was removed.
Top

See Also

Reference

AfterTimeBarRemovedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterTimeBarRemovedEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarRemovedEventArgs Class : AfterTimeBarRemovedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarRemovedEventArgs()
C#
public AfterTimeBarRemovedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarRemovedEventArgs Class
AfterTimeBarRemovedEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterTimeBarRemovedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarRemovedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarRemovedEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar that was removed.
public Property | ListItem | The dbiListItem containing the timebar before it was removed.
Top

See Also

Reference

AfterTimeBarRemovedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarRemovedEventArgs Class : BarIndex Property

The zero-based index value of the Timebar that was removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarRemovedEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarRemovedEventArgs Class
AfterTimeBarRemovedEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarRemovedEventArgs Class : ListItem Property

The dbiListItem containing the timebar before it was removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarRemovedEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarRemovedEventArgs Class
AfterTimeBarRemovedEventArgs Members


%%PageItemTitle%%

AfterTimeBarSizedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarSizedEventArgs Class

Provides data for the AfterTimeBarSized Event

Object Model

AfterTimeBarSizedEventArgs ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSizedEventArgs
C#
public class AfterTimeBarSizedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarSizedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSizedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarSizedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarSizedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarSizedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarSizedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar that was resized.
public Property | ListItem | The dbiListItem that contains the resized timebar.
public Property | TimeBarItem | The timebar that was resized.
Top

See Also

Reference

AfterTimeBarSizedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterTimeBarSizedEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarSizedEventArgs Class : AfterTimeBarSizedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarSizedEventArgs()
C#
public AfterTimeBarSizedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSizedEventArgs Class
AfterTimeBarSizedEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterTimeBarSizedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarSizedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarSizedEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar that was resized.
public Property | ListItem | The dbiListItem that contains the resized timebar.
public Property | TimeBarItem | The timebar that was resized.
Top

See Also

Reference

AfterTimeBarSizedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarSizedEventArgs Class : BarIndex Property

The zero-based index value of the Timebar that was resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSizedEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSizedEventArgs Class
AfterTimeBarSizedEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarSizedEventArgs Class : ListItem Property

The dbiListItem that contains the resized timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSizedEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSizedEventArgs Class
AfterTimeBarSizedEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarSizedEventArgs Class : TimeBarItem Property

The timebar that was resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSizedEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSizedEventArgs Class
AfterTimeBarSizedEventArgs Members


%%PageItemTitle%%

AfterTimeBarSplitEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarSplitEventArgs Class

Provides data for the AfterTimeBarSplit Event

Object Model

AfterTimeBarSplitEventArgs ClassdbiListItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSplitEventArgs
C#
public class AfterTimeBarSplitEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarSplitEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSplitEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarSplitEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarSplitEventArgs Class

"

The following tables list the members exposed by AfterTimeBarSplitEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarSplitEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | ListItem | The dbiListItem that contains the newly split timebars
public Property | TimeBarNew | The newly created timebar
public Property | TimeBarOld | The original exisiting timebar
Top

See Also

Reference

AfterTimeBarSplitEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterTimeBarSplitEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarSplitEventArgs Class : AfterTimeBarSplitEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarSplitEventArgs()
C#
public AfterTimeBarSplitEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSplitEventArgs Class
AfterTimeBarSplitEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterTimeBarSplitEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarSplitEventArgs Class

"

For a list of all members of this type, see AfterTimeBarSplitEventArgs members.

"

Public Properties

 | Name | Description
public Property | ListItem | The dbiListItem that contains the newly split timebars
public Property | TimeBarNew | The newly created timebar
public Property | TimeBarOld | The original exisiting timebar
Top

See Also

Reference

AfterTimeBarSplitEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarSplitEventArgs Class : ListItem Property

The dbiListItem that contains the newly split timebars

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSplitEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSplitEventArgs Class
AfterTimeBarSplitEventArgs Members


%%PageItemTitle%%

TimeBarNew Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarSplitEventArgs Class : TimeBarNew Property

The newly created timebar

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSplitEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarNew = value

value = instance.TimeBarNew
C#
public dbiTimeBarItem TimeBarNew {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSplitEventArgs Class
AfterTimeBarSplitEventArgs Members


%%PageItemTitle%%

TimeBarOld Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarSplitEventArgs Class : TimeBarOld Property

The original exisiting timebar

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSplitEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarOld = value

value = instance.TimeBarOld
C#
public dbiTimeBarItem TimeBarOld {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarSplitEventArgs Class
AfterTimeBarSplitEventArgs Members


%%PageItemTitle%%

AfterTimeBarUnlinkedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarUnlinkedEventArgs Class

Provides data for the AfterTimeBarUnlinked Event

Object Model

AfterTimeBarUnlinkedEventArgs ClassdbiLinkItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarUnlinkedEventArgs
C#
public class AfterTimeBarUnlinkedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarUnlinkedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarUnlinkedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarUnlinkedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarUnlinkedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarUnlinkedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarUnlinkedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Link | The dbiLinkItem that was removed from two timebars.
Top

See Also

Reference

AfterTimeBarUnlinkedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterTimeBarUnlinkedEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarUnlinkedEventArgs Class : AfterTimeBarUnlinkedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarUnlinkedEventArgs()
C#
public AfterTimeBarUnlinkedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarUnlinkedEventArgs Class
AfterTimeBarUnlinkedEventArgs Members


%%PageItemTitle%% $$Properties$$

AfterTimeBarUnlinkedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : AfterTimeBarUnlinkedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarUnlinkedEventArgs members.

"

Public Properties

 | Name | Description
public Property | Link | The dbiLinkItem that was removed from two timebars.
Top

See Also

Reference

AfterTimeBarUnlinkedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Link Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > AfterTimeBarUnlinkedEventArgs Class : Link Property

The dbiLinkItem that was removed from two timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarUnlinkedEventArgs
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

AfterTimeBarUnlinkedEventArgs Class
AfterTimeBarUnlinkedEventArgs Members


%%PageItemTitle%%

BeforeGuideLineInsertEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeGuideLineInsertEventArgs Class

Provides data for the BeforeGuideLineInsert Event

Object Model

BeforeGuideLineInsertEventArgs ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
C#
public class BeforeGuideLineInsertEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeGuideLineInsertEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineInsertEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeGuideLineInsertEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeGuideLineInsertEventArgs Class

"

The following tables list the members exposed by BeforeGuideLineInsertEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeGuideLineInsertEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowInsert | Determines if the GuideLine can be inserted.
public Property | GuideLine | The dbiGuideLine that is being inserted
public Property | LineTime | The DateTime value for the new dbiGuideLine.
Top

See Also

Reference

BeforeGuideLineInsertEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeGuideLineInsertEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineInsertEventArgs Class : BeforeGuideLineInsertEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeGuideLineInsertEventArgs()
C#
public BeforeGuideLineInsertEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeGuideLineInsertEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeGuideLineInsertEventArgs Class

"

For a list of all members of this type, see BeforeGuideLineInsertEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowInsert | Determines if the GuideLine can be inserted.
public Property | GuideLine | The dbiGuideLine that is being inserted
public Property | LineTime | The DateTime value for the new dbiGuideLine.
Top

See Also

Reference

BeforeGuideLineInsertEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowInsert Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineInsertEventArgs Class : AllowInsert Property

Determines if the GuideLine can be inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
Dim value As Boolean

instance.AllowInsert = value

value = instance.AllowInsert
C#
public bool AllowInsert {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineInsertEventArgs Class : GuideLine Property

The dbiGuideLine that is being inserted

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineInsertEventArgs Class : LineTime Property

The DateTime value for the new dbiGuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
Dim value As Date

instance.LineTime = value

value = instance.LineTime
C#
public DateTime LineTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%%

BeforeGuideLineMoveEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeGuideLineMoveEventArgs Class

Provides data for the BeforeGuideLineMove Event

Object Model

BeforeGuideLineMoveEventArgs ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
C#
public class BeforeGuideLineMoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeGuideLineMoveEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineMoveEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeGuideLineMoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeGuideLineMoveEventArgs Class

"

The following tables list the members exposed by BeforeGuideLineMoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeGuideLineMoveEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowMove | Determines if the GuideLine can be moved.
public Property | GuideLine | The GuideLine that is being moved.
public Property | InDeadZone | Indicates if the move puts the GuideLine in conflict with a deadzone.
public Property | LineIndex | The zero-based index of the GuideLine being moved.
public Property | LineTime | The DateTime value the GuideLine is moving to.
Top

See Also

Reference

BeforeGuideLineMoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeGuideLineMoveEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineMoveEventArgs Class : BeforeGuideLineMoveEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeGuideLineMoveEventArgs()
C#
public BeforeGuideLineMoveEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeGuideLineMoveEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeGuideLineMoveEventArgs Class

"

For a list of all members of this type, see BeforeGuideLineMoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowMove | Determines if the GuideLine can be moved.
public Property | GuideLine | The GuideLine that is being moved.
public Property | InDeadZone | Indicates if the move puts the GuideLine in conflict with a deadzone.
public Property | LineIndex | The zero-based index of the GuideLine being moved.
public Property | LineTime | The DateTime value the GuideLine is moving to.
Top

See Also

Reference

BeforeGuideLineMoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowMove Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineMoveEventArgs Class : AllowMove Property

Determines if the GuideLine can be moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As Boolean

instance.AllowMove = value

value = instance.AllowMove
C#
public bool AllowMove {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineMoveEventArgs Class : GuideLine Property

The GuideLine that is being moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

InDeadZone Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineMoveEventArgs Class : InDeadZone Property

Indicates if the move puts the GuideLine in conflict with a deadzone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As Boolean

instance.InDeadZone = value

value = instance.InDeadZone
C#
public bool InDeadZone {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineMoveEventArgs Class : LineIndex Property

The zero-based index of the GuideLine being moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public int LineIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineMoveEventArgs Class : LineTime Property

The DateTime value the GuideLine is moving to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As Date

instance.LineTime = value

value = instance.LineTime
C#
public DateTime LineTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

BeforeGuideLineRemoveEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeGuideLineRemoveEventArgs Class

Provides data for the BeforeGuideLineRemove Event

Object Model

BeforeGuideLineRemoveEventArgs ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
C#
public class BeforeGuideLineRemoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeGuideLineRemoveEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineRemoveEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeGuideLineRemoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeGuideLineRemoveEventArgs Class

"

The following tables list the members exposed by BeforeGuideLineRemoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeGuideLineRemoveEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowRemoval | Determines if the GuideLine can be removed.
public Property | GuideLine | The GuideLine to remove
public Property | LineIndex | The zero-based index of the GuideLine to be removed.
public Property | LineTime | The original time of the guideline before removal.
Top

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeGuideLineRemoveEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineRemoveEventArgs Class : BeforeGuideLineRemoveEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeGuideLineRemoveEventArgs()
C#
public BeforeGuideLineRemoveEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeGuideLineRemoveEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeGuideLineRemoveEventArgs Class

"

For a list of all members of this type, see BeforeGuideLineRemoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowRemoval | Determines if the GuideLine can be removed.
public Property | GuideLine | The GuideLine to remove
public Property | LineIndex | The zero-based index of the GuideLine to be removed.
public Property | LineTime | The original time of the guideline before removal.
Top

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowRemoval Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineRemoveEventArgs Class : AllowRemoval Property

Determines if the GuideLine can be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
Dim value As Boolean

instance.AllowRemoval = value

value = instance.AllowRemoval
C#
public bool AllowRemoval {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineRemoveEventArgs Class : GuideLine Property

The GuideLine to remove

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineRemoveEventArgs Class : LineIndex Property

The zero-based index of the GuideLine to be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
Dim value As Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public int LineIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeGuideLineRemoveEventArgs Class : LineTime Property

The original time of the guideline before removal.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
Dim value As Date

instance.LineTime = value

value = instance.LineTime
C#
public DateTime LineTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

BeforePrintEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforePrintEventArgs Class

Provides data for the BeforePrint Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforePrintEventArgs
C#
public class BeforePrintEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforePrintEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforePrintEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforePrintEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforePrintEventArgs Class

"

The following tables list the members exposed by BeforePrintEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforePrintEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Pages | The number of pages that will be printed.
Top

See Also

Reference

BeforePrintEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforePrintEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforePrintEventArgs Class : BeforePrintEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforePrintEventArgs()
C#
public BeforePrintEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforePrintEventArgs Class
BeforePrintEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforePrintEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforePrintEventArgs Class

"

For a list of all members of this type, see BeforePrintEventArgs members.

"

Public Properties

 | Name | Description
public Property | Pages | The number of pages that will be printed.
Top

See Also

Reference

BeforePrintEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Pages Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforePrintEventArgs Class : Pages Property

The number of pages that will be printed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforePrintEventArgs
Dim value As Integer

instance.Pages = value

value = instance.Pages
C#
public int Pages {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforePrintEventArgs Class
BeforePrintEventArgs Members


%%PageItemTitle%%

BeforeTimeBarInsertEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarInsertEventArgs Class

Provides data for the BeforeTimeBarInsert Event

Object Model

BeforeTimeBarInsertEventArgs ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarInsertEventArgs
C#
public class BeforeTimeBarInsertEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarInsertEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarInsertEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarInsertEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarInsertEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarInsertEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarInsertEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowInsert | Determines if the timebar can be inserted
public Property | ListItem | The dbiListItem the timebar is being inserted to.
public Property | TimeBarItem | The timebar being inserted.
Top

See Also

Reference

BeforeTimeBarInsertEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeTimeBarInsertEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarInsertEventArgs Class : BeforeTimeBarInsertEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarInsertEventArgs()
C#
public BeforeTimeBarInsertEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarInsertEventArgs Class
BeforeTimeBarInsertEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeTimeBarInsertEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarInsertEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarInsertEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowInsert | Determines if the timebar can be inserted
public Property | ListItem | The dbiListItem the timebar is being inserted to.
public Property | TimeBarItem | The timebar being inserted.
Top

See Also

Reference

BeforeTimeBarInsertEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowInsert Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarInsertEventArgs Class : AllowInsert Property

Determines if the timebar can be inserted

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarInsertEventArgs
Dim value As Boolean

instance.AllowInsert = value

value = instance.AllowInsert
C#
public bool AllowInsert {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarInsertEventArgs Class
BeforeTimeBarInsertEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarInsertEventArgs Class : ListItem Property

The dbiListItem the timebar is being inserted to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarInsertEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarInsertEventArgs Class
BeforeTimeBarInsertEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarInsertEventArgs Class : TimeBarItem Property

The timebar being inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarInsertEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarInsertEventArgs Class
BeforeTimeBarInsertEventArgs Members


%%PageItemTitle%%

BeforeTimeBarLinkEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarLinkEventArgs Class

Provides data for the BeforeTimeBarLink Event

Object Model

BeforeTimeBarLinkEventArgs ClassdbiLinkItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarLinkEventArgs
C#
public class BeforeTimeBarLinkEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarLinkEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarLinkEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarLinkEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarLinkEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarLinkEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarLinkEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowLink | Determines if the timebars can be linked
public Property | Link | The dbiLinkItem that will link the two timebars.
Top

See Also

Reference

BeforeTimeBarLinkEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeTimeBarLinkEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarLinkEventArgs Class : BeforeTimeBarLinkEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarLinkEventArgs()
C#
public BeforeTimeBarLinkEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarLinkEventArgs Class
BeforeTimeBarLinkEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeTimeBarLinkEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarLinkEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarLinkEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowLink | Determines if the timebars can be linked
public Property | Link | The dbiLinkItem that will link the two timebars.
Top

See Also

Reference

BeforeTimeBarLinkEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowLink Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarLinkEventArgs Class : AllowLink Property

Determines if the timebars can be linked

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarLinkEventArgs
Dim value As Boolean

instance.AllowLink = value

value = instance.AllowLink
C#
public bool AllowLink {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarLinkEventArgs Class
BeforeTimeBarLinkEventArgs Members


%%PageItemTitle%%

Link Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarLinkEventArgs Class : Link Property

The dbiLinkItem that will link the two timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarLinkEventArgs
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarLinkEventArgs Class
BeforeTimeBarLinkEventArgs Members


%%PageItemTitle%%

BeforeTimeBarMoveEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarMoveEventArgs Class

Provides data for the BeforeTimeBarMove Event

Object Model

BeforeTimeBarMoveEventArgs ClassdbiListItem ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
C#
public class BeforeTimeBarMoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarMoveEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarMoveEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarMoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarMoveEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarMoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarMoveEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowMove | Determines if the timebar can be moved.
public Property | End | The new end DateTime for the timebar.
public Property | ListItemFrom | The dbiListItem containing the timebar before it is moved.
public Property | ListItemTo | The dbiListItem containing the timebar afetr it is moved.
public Property | Start | The new start DateTime for the timebar.
public Property | TimeBarItem | The dbiTimeBarItem before it is moved.
public Property | Vertical | Determines if the timebar is being moved vertically.
Top

See Also

Reference

BeforeTimeBarMoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeTimeBarMoveEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarMoveEventArgs Class : BeforeTimeBarMoveEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarMoveEventArgs()
C#
public BeforeTimeBarMoveEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeTimeBarMoveEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarMoveEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarMoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowMove | Determines if the timebar can be moved.
public Property | End | The new end DateTime for the timebar.
public Property | ListItemFrom | The dbiListItem containing the timebar before it is moved.
public Property | ListItemTo | The dbiListItem containing the timebar afetr it is moved.
public Property | Start | The new start DateTime for the timebar.
public Property | TimeBarItem | The dbiTimeBarItem before it is moved.
public Property | Vertical | Determines if the timebar is being moved vertically.
Top

See Also

Reference

BeforeTimeBarMoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowMove Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarMoveEventArgs Class : AllowMove Property

Determines if the timebar can be moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As Boolean

instance.AllowMove = value

value = instance.AllowMove
C#
public bool AllowMove {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarMoveEventArgs Class : End Property

The new end DateTime for the timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As Date

instance.End = value

value = instance.End
C#
public DateTime End {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

ListItemFrom Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarMoveEventArgs Class : ListItemFrom Property

The dbiListItem containing the timebar before it is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As dbiListItem

instance.ListItemFrom = value

value = instance.ListItemFrom
C#
public dbiListItem ListItemFrom {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

ListItemTo Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarMoveEventArgs Class : ListItemTo Property

The dbiListItem containing the timebar afetr it is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As dbiListItem

instance.ListItemTo = value

value = instance.ListItemTo
C#
public dbiListItem ListItemTo {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarMoveEventArgs Class : Start Property

The new start DateTime for the timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As Date

instance.Start = value

value = instance.Start
C#
public DateTime Start {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarMoveEventArgs Class : TimeBarItem Property

The dbiTimeBarItem before it is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

Vertical Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarMoveEventArgs Class : Vertical Property

Determines if the timebar is being moved vertically.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As Boolean

instance.Vertical = value

value = instance.Vertical
C#
public bool Vertical {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

BeforeTimeBarRemoveEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarRemoveEventArgs Class

Provides data for the BeforeTimeBarRemove Event

Object Model

BeforeTimeBarRemoveEventArgs ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
C#
public class BeforeTimeBarRemoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarRemoveEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarRemoveEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarRemoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarRemoveEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarRemoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarRemoveEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowRemoval | Determines if the Timebar can be removed.
public Property | BarIndex | The zero-based index value of the Timebar to be removed.
public Property | ListItem | The dbiListItem containing the timebar to be removed.
public Property | TimeBarItem | The timebar to be removed.
Top

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeTimeBarRemoveEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarRemoveEventArgs Class : BeforeTimeBarRemoveEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarRemoveEventArgs()
C#
public BeforeTimeBarRemoveEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeTimeBarRemoveEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarRemoveEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarRemoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowRemoval | Determines if the Timebar can be removed.
public Property | BarIndex | The zero-based index value of the Timebar to be removed.
public Property | ListItem | The dbiListItem containing the timebar to be removed.
public Property | TimeBarItem | The timebar to be removed.
Top

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowRemoval Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarRemoveEventArgs Class : AllowRemoval Property

Determines if the Timebar can be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
Dim value As Boolean

instance.AllowRemoval = value

value = instance.AllowRemoval
C#
public bool AllowRemoval {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarRemoveEventArgs Class : BarIndex Property

The zero-based index value of the Timebar to be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarRemoveEventArgs Class : ListItem Property

The dbiListItem containing the timebar to be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarRemoveEventArgs Class : TimeBarItem Property

The timebar to be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%%

BeforeTimeBarSelectEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarSelectEventArgs Class

Provides data for the BeforeTimeBarSelect Event

Object Model

BeforeTimeBarSelectEventArgs ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
C#
public class BeforeTimeBarSelectEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarSelectEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSelectEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarSelectEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarSelectEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarSelectEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarSelectEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowSelect | Determines if the timebar can be selected.
public Property | BarIndex | The zero-based index value of the Timebar being selected.
public Property | ListItem | The dbiListItem that contains the timebar before it is selected.
public Property | TimeBarItem | The timebar before it is selected.
Top

See Also

Reference

BeforeTimeBarSelectEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeTimeBarSelectEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSelectEventArgs Class : BeforeTimeBarSelectEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarSelectEventArgs()
C#
public BeforeTimeBarSelectEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeTimeBarSelectEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarSelectEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarSelectEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowSelect | Determines if the timebar can be selected.
public Property | BarIndex | The zero-based index value of the Timebar being selected.
public Property | ListItem | The dbiListItem that contains the timebar before it is selected.
public Property | TimeBarItem | The timebar before it is selected.
Top

See Also

Reference

BeforeTimeBarSelectEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowSelect Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSelectEventArgs Class : AllowSelect Property

Determines if the timebar can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
Dim value As Boolean

instance.AllowSelect = value

value = instance.AllowSelect
C#
public bool AllowSelect {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSelectEventArgs Class : BarIndex Property

The zero-based index value of the Timebar being selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSelectEventArgs Class : ListItem Property

The dbiListItem that contains the timebar before it is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSelectEventArgs Class : TimeBarItem Property

The timebar before it is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%%

BeforeTimeBarSizeEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarSizeEventArgs Class

Provides data for the BeforeTimeBarSize Event

Object Model

BeforeTimeBarSizeEventArgs ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
C#
public class BeforeTimeBarSizeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarSizeEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSizeEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarSizeEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarSizeEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarSizeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarSizeEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowSize | Determines if the Timebar can be sized.
public Property | BarIndex | The zero-based index value of the Timebar to be sized.
public Property | End | The new end DateTime for the Timebar.
public Property | ListItem | The dbiListITem containg the timebar being sized.
public Property | Start | The new start DateTime for the Timebar.
public Property | TimeBarItem | The timebar before it is sized.
Top

See Also

Reference

BeforeTimeBarSizeEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeTimeBarSizeEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSizeEventArgs Class : BeforeTimeBarSizeEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarSizeEventArgs()
C#
public BeforeTimeBarSizeEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeTimeBarSizeEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarSizeEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarSizeEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowSize | Determines if the Timebar can be sized.
public Property | BarIndex | The zero-based index value of the Timebar to be sized.
public Property | End | The new end DateTime for the Timebar.
public Property | ListItem | The dbiListITem containg the timebar being sized.
public Property | Start | The new start DateTime for the Timebar.
public Property | TimeBarItem | The timebar before it is sized.
Top

See Also

Reference

BeforeTimeBarSizeEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSizeEventArgs Class : AllowSize Property

Determines if the Timebar can be sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As Boolean

instance.AllowSize = value

value = instance.AllowSize
C#
public bool AllowSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSizeEventArgs Class : BarIndex Property

The zero-based index value of the Timebar to be sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSizeEventArgs Class : End Property

The new end DateTime for the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As Date

instance.End = value

value = instance.End
C#
public DateTime End {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSizeEventArgs Class : ListItem Property

The dbiListITem containg the timebar being sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSizeEventArgs Class : Start Property

The new start DateTime for the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As Date

instance.Start = value

value = instance.Start
C#
public DateTime Start {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSizeEventArgs Class : TimeBarItem Property

The timebar before it is sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

BeforeTimeBarSplitEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarSplitEventArgs Class

Provides data for the BeforeTimeBarSplit Event

Object Model

BeforeTimeBarSplitEventArgs ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
C#
public class BeforeTimeBarSplitEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarSplitEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSplitEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarSplitEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarSplitEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarSplitEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarSplitEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowSplit | Determines if the Timebar can be split.
public Property | BarIndex | The zero-based index value of the Timebar to be split.
public Property | ListItem | The dbiListItem that contains the timebar that is being split.
public Property | SplitAt | The DateTime value where the split will occur.
public Property | TimeBarItem | The timebar that will be split.
Top

See Also

Reference

BeforeTimeBarSplitEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeTimeBarSplitEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSplitEventArgs Class : BeforeTimeBarSplitEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarSplitEventArgs()
C#
public BeforeTimeBarSplitEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeTimeBarSplitEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarSplitEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarSplitEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowSplit | Determines if the Timebar can be split.
public Property | BarIndex | The zero-based index value of the Timebar to be split.
public Property | ListItem | The dbiListItem that contains the timebar that is being split.
public Property | SplitAt | The DateTime value where the split will occur.
public Property | TimeBarItem | The timebar that will be split.
Top

See Also

Reference

BeforeTimeBarSplitEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowSplit Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSplitEventArgs Class : AllowSplit Property

Determines if the Timebar can be split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As Boolean

instance.AllowSplit = value

value = instance.AllowSplit
C#
public bool AllowSplit {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSplitEventArgs Class : BarIndex Property

The zero-based index value of the Timebar to be split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSplitEventArgs Class : ListItem Property

The dbiListItem that contains the timebar that is being split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

SplitAt Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSplitEventArgs Class : SplitAt Property

The DateTime value where the split will occur.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As Date

instance.SplitAt = value

value = instance.SplitAt
C#
public DateTime SplitAt {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarSplitEventArgs Class : TimeBarItem Property

The timebar that will be split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

BeforeTimeBarUnlinkEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarUnlinkEventArgs Class

Provides data for the BeforeTimeBarUnlink Event

Object Model

BeforeTimeBarUnlinkEventArgs ClassdbiLinkItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnlinkEventArgs
C#
public class BeforeTimeBarUnlinkEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarUnlinkEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarUnlinkEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarUnlinkEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarUnlinkEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarUnlinkEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarUnlinkEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowUnlink | Determines if the dbiLinkItem can be removed.
public Property | Link | The dbiLinkItem to remove.
Top

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeTimeBarUnlinkEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarUnlinkEventArgs Class : BeforeTimeBarUnlinkEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarUnlinkEventArgs()
C#
public BeforeTimeBarUnlinkEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
BeforeTimeBarUnlinkEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeTimeBarUnlinkEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeTimeBarUnlinkEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarUnlinkEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowUnlink | Determines if the dbiLinkItem can be removed.
public Property | Link | The dbiLinkItem to remove.
Top

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AllowUnlink Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarUnlinkEventArgs Class : AllowUnlink Property

Determines if the dbiLinkItem can be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnlinkEventArgs
Dim value As Boolean

instance.AllowUnlink = value

value = instance.AllowUnlink
C#
public bool AllowUnlink {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
BeforeTimeBarUnlinkEventArgs Members


%%PageItemTitle%%

Link Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeTimeBarUnlinkEventArgs Class : Link Property

The dbiLinkItem to remove.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnlinkEventArgs
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
BeforeTimeBarUnlinkEventArgs Members


%%PageItemTitle%%

BeforeToolTipsEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeToolTipsEventArgs Class

Provides data for the BeforeToolTips Event

Object Model

BeforeToolTipsEventArgs ClassdbiListItem ClassdbiScheduleNote ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
C#
public class BeforeToolTipsEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.BeforeToolTipsEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeToolTipsEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

BeforeToolTipsEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeToolTipsEventArgs Class

"

The following tables list the members exposed by BeforeToolTipsEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeToolTipsEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Display | Determines if the tool tip will be displayed.
public Property | ListItem | The dbiListItem containing the timebar or schedule note displaying the tooltip.
public Property | ScheduleNote | The schedule note displaying the tooltip.
public Property | ScrollValue | The position of th vertical scrollbar.
public Property | Text | The text to display in the tooltip.
public Property | TimeBar | The timebar displaying the tooltip.
public Property | TipsType | The type of tooltip being displayed.
Top

See Also

Reference

BeforeToolTipsEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BeforeToolTipsEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeToolTipsEventArgs Class : BeforeToolTipsEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeToolTipsEventArgs()
C#
public BeforeToolTipsEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%% $$Properties$$

BeforeToolTipsEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : BeforeToolTipsEventArgs Class

"

For a list of all members of this type, see BeforeToolTipsEventArgs members.

"

Public Properties

 | Name | Description
public Property | Display | Determines if the tool tip will be displayed.
public Property | ListItem | The dbiListItem containing the timebar or schedule note displaying the tooltip.
public Property | ScheduleNote | The schedule note displaying the tooltip.
public Property | ScrollValue | The position of th vertical scrollbar.
public Property | Text | The text to display in the tooltip.
public Property | TimeBar | The timebar displaying the tooltip.
public Property | TipsType | The type of tooltip being displayed.
Top

See Also

Reference

BeforeToolTipsEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Display Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeToolTipsEventArgs Class : Display Property

Determines if the tool tip will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As Boolean

instance.Display = value

value = instance.Display
C#
public bool Display {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeToolTipsEventArgs Class : ListItem Property

The dbiListItem containing the timebar or schedule note displaying the tooltip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

ScheduleNote Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeToolTipsEventArgs Class : ScheduleNote Property

The schedule note displaying the tooltip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As dbiScheduleNote

instance.ScheduleNote = value

value = instance.ScheduleNote
C#
public dbiScheduleNote ScheduleNote {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

ScrollValue Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeToolTipsEventArgs Class : ScrollValue Property

The position of th vertical scrollbar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As Integer

instance.ScrollValue = value

value = instance.ScrollValue
C#
public int ScrollValue {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeToolTipsEventArgs Class : Text Property

The text to display in the tooltip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

TimeBar Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeToolTipsEventArgs Class : TimeBar Property

The timebar displaying the tooltip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As dbiTimeBarItem

instance.TimeBar = value

value = instance.TimeBar
C#
public dbiTimeBarItem TimeBar {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

TipsType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > BeforeToolTipsEventArgs Class : TipsType Property

The type of tooltip being displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As enumTipsType

instance.TipsType = value

value = instance.TipsType
C#
public enumTipsType TipsType {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

ColumnHeaderClickEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ColumnHeaderClickEventArgs Class

Provides data for the ColumnHeaderClick Event

Object Model

ColumnHeaderClickEventArgs ClassdbiColumnItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderClickEventArgs
C#
public class ColumnHeaderClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.ColumnHeaderClickEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ColumnHeaderClickEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

ColumnHeaderClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ColumnHeaderClickEventArgs Class

"

The following tables list the members exposed by ColumnHeaderClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ColumnHeaderClickEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Button | The mouse button that clicked the header.
public Property | Column | The column item that had its header clicked.
public Property | ColumnIndex | The zero-based index value of the column item that had its header clicked.
public Property | MouseEvent | The MouseEvent arguments related to the click.
Top

See Also

Reference

ColumnHeaderClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ColumnHeaderClickEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ColumnHeaderClickEventArgs Class : ColumnHeaderClickEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ColumnHeaderClickEventArgs()
C#
public ColumnHeaderClickEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ColumnHeaderClickEventArgs Class
ColumnHeaderClickEventArgs Members


%%PageItemTitle%% $$Properties$$

ColumnHeaderClickEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ColumnHeaderClickEventArgs Class

"

For a list of all members of this type, see ColumnHeaderClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The mouse button that clicked the header.
public Property | Column | The column item that had its header clicked.
public Property | ColumnIndex | The zero-based index value of the column item that had its header clicked.
public Property | MouseEvent | The MouseEvent arguments related to the click.
Top

See Also

Reference

ColumnHeaderClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Button Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ColumnHeaderClickEventArgs Class : Button Property

The mouse button that clicked the header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderClickEventArgs
Dim value As MouseButton

instance.Button = value

value = instance.Button
C#
public MouseButton Button {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ColumnHeaderClickEventArgs Class
ColumnHeaderClickEventArgs Members


%%PageItemTitle%%

Column Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ColumnHeaderClickEventArgs Class : Column Property

The column item that had its header clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderClickEventArgs
Dim value As dbiColumnItem

instance.Column = value

value = instance.Column
C#
public dbiColumnItem Column {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ColumnHeaderClickEventArgs Class
ColumnHeaderClickEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ColumnHeaderClickEventArgs Class : ColumnIndex Property

The zero-based index value of the column item that had its header clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderClickEventArgs
Dim value As Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public int ColumnIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ColumnHeaderClickEventArgs Class
ColumnHeaderClickEventArgs Members


%%PageItemTitle%%

MouseEvent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ColumnHeaderClickEventArgs Class : MouseEvent Property

The MouseEvent arguments related to the click.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderClickEventArgs
Dim value As MouseButtonEventArgs

instance.MouseEvent = value

value = instance.MouseEvent
C#
public MouseButtonEventArgs MouseEvent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ColumnHeaderClickEventArgs Class
ColumnHeaderClickEventArgs Members


%%PageItemTitle%%

ControlErrorEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ControlErrorEventArgs Class

Provides data for the ControlError Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ControlErrorEventArgs
C#
public class ControlErrorEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.ControlErrorEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ControlErrorEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

ControlErrorEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ControlErrorEventArgs Class

"

The following tables list the members exposed by ControlErrorEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ControlErrorEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Error | The ID number of the error which has occurred.
public Property | Message | The description of the error which has occurred.
Top

See Also

Reference

ControlErrorEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ControlErrorEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ControlErrorEventArgs Class : ControlErrorEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ControlErrorEventArgs()
C#
public ControlErrorEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ControlErrorEventArgs Class
ControlErrorEventArgs Members


%%PageItemTitle%% $$Properties$$

ControlErrorEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ControlErrorEventArgs Class

"

For a list of all members of this type, see ControlErrorEventArgs members.

"

Public Properties

 | Name | Description
public Property | Error | The ID number of the error which has occurred.
public Property | Message | The description of the error which has occurred.
Top

See Also

Reference

ControlErrorEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Error Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ControlErrorEventArgs Class : Error Property

The ID number of the error which has occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ControlErrorEventArgs
Dim value As Integer

instance.Error = value

value = instance.Error
C#
public int Error {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ControlErrorEventArgs Class
ControlErrorEventArgs Members


%%PageItemTitle%%

Message Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ControlErrorEventArgs Class : Message Property

The description of the error which has occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ControlErrorEventArgs
Dim value As String

instance.Message = value

value = instance.Message
C#
public string Message {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ControlErrorEventArgs Class
ControlErrorEventArgs Members


%%PageItemTitle%%

dbiColumnItem Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItem Class

Provides the properties for defining columns.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
C#
public class dbiColumnItem : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiColumnItem

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiColumnItem Class Members
See Also Fields Properties Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItem Class

"

The following tables list the members exposed by dbiColumnItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiColumnItem Constructor | Overloaded. Initializes a new instance of the class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | ForegroundProperty | Identifies the DependencyProperty for the Foreground Property
static (Shared in Visual Basic) | ImageAlignProperty | Identifies the DependencyProperty for the ImageAlign Property
static (Shared in Visual Basic) | ImageIndexProperty | Identifies the DependencyProperty for the ImageIndex Property
static (Shared in Visual Basic) | ListBackgroundProperty | Identifies the DependencyProperty for the ListBackground Property
static (Shared in Visual Basic) | ListForegroundProperty | Identifies the DependencyProperty for the ListForeground Property
static (Shared in Visual Basic) | ListImageAlignProperty | Identifies the DependencyProperty for the ListImageAlign Property
static (Shared in Visual Basic) | ListTextAlignProperty | Identifies the DependencyProperty for the ListTextAlign Property
static (Shared in Visual Basic) | LockWidthProperty | Identifies the DependencyProperty for the LockWidth Property
static (Shared in Visual Basic) | SortByProperty | Identifies the DependencyProperty for the SortBy Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TextAlignProperty | Identifies the DependencyProperty for the TextAlign Property
static (Shared in Visual Basic) | TextProperty | Identifies the DependencyProperty for the Text Property
static (Shared in Visual Basic) | VisibleProperty | Identifies the DependencyProperty for the Visible Property
static (Shared in Visual Basic) | WidthProperty | Identifies the DependencyProperty for the Width Property
Top

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the column header.
public Property | Foreground | Gets or sets the brush used to paint the text or foreground of the column header.
public Property | ImageAlign | Gets or sets the image alignment for the column header.
public Property | ImageIndex | Gets or sets the image index for the column header.
public Property | ListBackground | Gets or sets the brush used to paint the background of the list area under the column.
public Property | ListForeground | Gets or sets the brush used to paint the text or foreground of the list area under the column.
public Property | ListImageAlign | Gets or sets the text alignment for the list items in the list area below the column.
public Property | ListTextAlign | Gets or sets the text alignment for the text items in the list area below the column.
public Property | LockWidth | Gets or sets whether the width of the column is locked.
public Property | SortBy | Gets or sets the data type used to sort the items in the column.
public Property | Tag | Gets or sets a tag or object for the object.
public Property | Text | Gets or sets the text of the column header.
public Property | TextAlign | Gets or sets the text alignment for the text in the column header.
public Property | Visible | Gets or sets whether the column will be visible.
public Property | Width | Gets or sets the width of the column.
Top

See Also

Reference

dbiColumnItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiColumnItem Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : dbiColumnItem Constructor

Initializes a new instance of the class.

Overload List

Overload | Description
dbiColumnItem Constructor() | Initializes a new instance of the dbiColumnItem class.
dbiColumnItem Constructor(String) | Initializes a new instance of the dbiColumnItem class setting the Text Property to the string parameter.
dbiColumnItem Constructor(String,Int32) | Initializes a new instance of the dbiColumnItem class with the Text Property set to the value of the string parameter and the Width Property set to the int32 parameter.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

dbiColumnItem Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class > dbiColumnItem Constructor : dbiColumnItem Constructor()

Initializes a new instance of the dbiColumnItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiColumnItem()
C#
public dbiColumnItem()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

dbiColumnItem Constructor(String)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class > dbiColumnItem Constructor : dbiColumnItem Constructor(String)

strText
Value to use for Text Property.
Initializes a new instance of the dbiColumnItem class setting the Text Property to the string parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As New dbiColumnItem(strText)
C#
public dbiColumnItem(
   string strText
)

Parameters

strText
Value to use for Text Property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

dbiColumnItem Constructor(String,Int32)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class > dbiColumnItem Constructor : dbiColumnItem Constructor(String,Int32)

strText
Value to use for the Text Property
nWidth
Value to use for the Width Property
Initializes a new instance of the dbiColumnItem class with the Text Property set to the value of the string parameter and the Width Property set to the int32 parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As String
Dim nWidth As Integer

Dim instance As New dbiColumnItem(strText, nWidth)
C#
public dbiColumnItem(
   string strText,
   int nWidth
)

Parameters

strText
Value to use for the Text Property
nWidth
Value to use for the Width Property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%% $$Properties$$

dbiColumnItem Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItem Class

"

For a list of all members of this type, see dbiColumnItem members.

"

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the column header.
public Property | Foreground | Gets or sets the brush used to paint the text or foreground of the column header.
public Property | ImageAlign | Gets or sets the image alignment for the column header.
public Property | ImageIndex | Gets or sets the image index for the column header.
public Property | ListBackground | Gets or sets the brush used to paint the background of the list area under the column.
public Property | ListForeground | Gets or sets the brush used to paint the text or foreground of the list area under the column.
public Property | ListImageAlign | Gets or sets the text alignment for the list items in the list area below the column.
public Property | ListTextAlign | Gets or sets the text alignment for the text items in the list area below the column.
public Property | LockWidth | Gets or sets whether the width of the column is locked.
public Property | SortBy | Gets or sets the data type used to sort the items in the column.
public Property | Tag | Gets or sets a tag or object for the object.
public Property | Text | Gets or sets the text of the column header.
public Property | TextAlign | Gets or sets the text alignment for the text in the column header.
public Property | Visible | Gets or sets whether the column will be visible.
public Property | Width | Gets or sets the width of the column.
Top

See Also

Reference

dbiColumnItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Background Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : Background Property

Gets or sets the brush used to paint the background of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Brush

instance.Background = value

value = instance.Background
C#
public Brush Background {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Foreground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : Foreground Property

Gets or sets the brush used to paint the text or foreground of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Brush

instance.Foreground = value

value = instance.Foreground
C#
public Brush Foreground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ImageAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ImageAlign Property

Gets or sets the image alignment for the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As enumAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
public enumAlignment ImageAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ImageIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ImageIndex Property

Gets or sets the image index for the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public int ImageIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ListBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ListBackground Property

Gets or sets the brush used to paint the background of the list area under the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Brush

instance.ListBackground = value

value = instance.ListBackground
C#
public Brush ListBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ListForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ListForeground Property

Gets or sets the brush used to paint the text or foreground of the list area under the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Brush

instance.ListForeground = value

value = instance.ListForeground
C#
public Brush ListForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ListImageAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ListImageAlign Property

Gets or sets the text alignment for the list items in the list area below the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As enumAlignment

instance.ListImageAlign = value

value = instance.ListImageAlign
C#
public enumAlignment ListImageAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ListTextAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ListTextAlign Property

Gets or sets the text alignment for the text items in the list area below the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As enumAlignment

instance.ListTextAlign = value

value = instance.ListTextAlign
C#
public enumAlignment ListTextAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

LockWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : LockWidth Property

Gets or sets whether the width of the column is locked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Boolean

instance.LockWidth = value

value = instance.LockWidth
C#
public bool LockWidth {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

SortBy Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : SortBy Property

Gets or sets the data type used to sort the items in the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As dbiColumnItem.enumSortBy

instance.SortBy = value

value = instance.SortBy
C#
public dbiColumnItem.enumSortBy SortBy {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : Tag Property

Gets or sets a tag or object for the object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
public object Tag {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : Text Property

Gets or sets the text of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

TextAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : TextAlign Property

Gets or sets the text alignment for the text in the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As enumAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
public enumAlignment TextAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Visible Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : Visible Property

Gets or sets whether the column will be visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
public bool Visible {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Width Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : Width Property

Gets or sets the width of the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public int Width {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%% $$Fields$$

dbiColumnItem Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItem Class

"

For a list of all members of this type, see dbiColumnItem members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | ForegroundProperty | Identifies the DependencyProperty for the Foreground Property
static (Shared in Visual Basic) | ImageAlignProperty | Identifies the DependencyProperty for the ImageAlign Property
static (Shared in Visual Basic) | ImageIndexProperty | Identifies the DependencyProperty for the ImageIndex Property
static (Shared in Visual Basic) | ListBackgroundProperty | Identifies the DependencyProperty for the ListBackground Property
static (Shared in Visual Basic) | ListForegroundProperty | Identifies the DependencyProperty for the ListForeground Property
static (Shared in Visual Basic) | ListImageAlignProperty | Identifies the DependencyProperty for the ListImageAlign Property
static (Shared in Visual Basic) | ListTextAlignProperty | Identifies the DependencyProperty for the ListTextAlign Property
static (Shared in Visual Basic) | LockWidthProperty | Identifies the DependencyProperty for the LockWidth Property
static (Shared in Visual Basic) | SortByProperty | Identifies the DependencyProperty for the SortBy Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TextAlignProperty | Identifies the DependencyProperty for the TextAlign Property
static (Shared in Visual Basic) | TextProperty | Identifies the DependencyProperty for the Text Property
static (Shared in Visual Basic) | VisibleProperty | Identifies the DependencyProperty for the Visible Property
static (Shared in Visual Basic) | WidthProperty | Identifies the DependencyProperty for the Width Property
Top

See Also

Reference

dbiColumnItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : BackgroundProperty Field

Identifies the DependencyProperty for the Background Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.BackgroundProperty
C#
public static readonly DependencyProperty BackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ForegroundProperty Field

Identifies the DependencyProperty for the Foreground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.ForegroundProperty
C#
public static readonly DependencyProperty ForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ImageAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ImageAlignProperty Field

Identifies the DependencyProperty for the ImageAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.ImageAlignProperty
C#
public static readonly DependencyProperty ImageAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ImageIndexProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ImageIndexProperty Field

Identifies the DependencyProperty for the ImageIndex Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.ImageIndexProperty
C#
public static readonly DependencyProperty ImageIndexProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ListBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ListBackgroundProperty Field

Identifies the DependencyProperty for the ListBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.ListBackgroundProperty
C#
public static readonly DependencyProperty ListBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ListForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ListForegroundProperty Field

Identifies the DependencyProperty for the ListForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.ListForegroundProperty
C#
public static readonly DependencyProperty ListForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ListImageAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ListImageAlignProperty Field

Identifies the DependencyProperty for the ListImageAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.ListImageAlignProperty
C#
public static readonly DependencyProperty ListImageAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ListTextAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ListTextAlignProperty Field

Identifies the DependencyProperty for the ListTextAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.ListTextAlignProperty
C#
public static readonly DependencyProperty ListTextAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

LockWidthProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : LockWidthProperty Field

Identifies the DependencyProperty for the LockWidth Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.LockWidthProperty
C#
public static readonly DependencyProperty LockWidthProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

SortByProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : SortByProperty Field

Identifies the DependencyProperty for the SortBy Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.SortByProperty
C#
public static readonly DependencyProperty SortByProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

TagProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : TagProperty Field

Identifies the DependencyProperty for the Tag Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.TagProperty
C#
public static readonly DependencyProperty TagProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

TextAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : TextAlignProperty Field

Identifies the DependencyProperty for the TextAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.TextAlignProperty
C#
public static readonly DependencyProperty TextAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

TextProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : TextProperty Field

Identifies the DependencyProperty for the Text Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.TextProperty
C#
public static readonly DependencyProperty TextProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

VisibleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : VisibleProperty Field

Identifies the DependencyProperty for the Visible Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.VisibleProperty
C#
public static readonly DependencyProperty VisibleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

WidthProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : WidthProperty Field

Identifies the DependencyProperty for the Width Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiColumnItem.WidthProperty
C#
public static readonly DependencyProperty WidthProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

dbiColumnItemCollection Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItemCollection Class

A collection used to store dbiColumnItems

Object Model

dbiColumnItemCollection ClassdbiColumnItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
C#
[DefaultMemberAttribute("Item")]
public class dbiColumnItemCollection : System.Collections.ObjectModel.ObservableCollection<dbiColumnItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiColumnItemCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiColumnItemCollection Class Members
See Also Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItemCollection Class

"

The following tables list the members exposed by dbiColumnItemCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiColumnItemCollection Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object at the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection. This overload will create a new dbiColumnItem, based on the supplied parameter, and insert it in to the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiColumnItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiColumnItemCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : dbiColumnItemCollection Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiColumnItemCollection()
C#
public dbiColumnItemCollection()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%% $$Methods$$

dbiColumnItemCollection Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItemCollection Class

"

For a list of all members of this type, see dbiColumnItemCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object at the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection. This overload will create a new dbiColumnItem, based on the supplied parameter, and insert it in to the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiColumnItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Add Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : Add Method

Adds an object at the end of the collection

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(String) | Adds an object to the end of the collection. This overload will create a new dbiColumnItem, based on the supplied parameter, and add it to the collection.
Add(String,Int32) | Adds an object to the end of the collection. This overload will create a new dbiColumnItem, based on the supplied parameters, and add it to the collection.
Add(dbiColumnItem) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

Add() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection

instance.Add()
C#
public void Add()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members
Overload List


%%PageItemTitle%%

Add(String) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class > Add Method : Add(String) Method

strText
The text to assign to the column
Adds an object to the end of the collection. This overload will create a new dbiColumnItem, based on the supplied parameter, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim strText As String

instance.Add(strText)
C#
public void Add(
   string strText
)

Parameters

strText
The text to assign to the column

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members
Overload List


%%PageItemTitle%%

Add(String,Int32) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class > Add Method : Add(String,Int32) Method

strText
The text to assign to the column
nWidth
The width to assign to the column
Adds an object to the end of the collection. This overload will create a new dbiColumnItem, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim strText As String
Dim nWidth As Integer

instance.Add(strText, nWidth)
C#
public void Add(
   string strText,
   int nWidth
)

Parameters

strText
The text to assign to the column
nWidth
The width to assign to the column

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members
Overload List


%%PageItemTitle%%

Add(dbiColumnItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class > Add Method : Add(dbiColumnItem) Method

obj
Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim obj As dbiColumnItem

instance.Add(obj)
C#
public new void Add(
   dbiColumnItem obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : IndexOf Method

obj
The dbiColumnItem to find the index value for
Gets the 0 based index of the first occurence of an object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim obj As dbiColumnItem
Dim value As Integer

value = instance.IndexOf(obj)
C#
public new int IndexOf(
   dbiColumnItem obj
)

Parameters

obj
The dbiColumnItem to find the index value for

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : Insert Method

Inserts an object into the collection. This overload will create a new dbiColumnItem, based on the supplied parameter, and insert it in to the collection.

Overload List

Overload | Description
Insert(Int32,String) | Inserts an object into the collection. This overload will create a new dbiColumnItem, based on the supplied parameter, and insert it in to the collection.
Insert(Int32,String,Int32) | Inserts an object into the collection. This overload will create a new dbiColumnItem, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,dbiColumnItem) | Inserts an object into the collection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

Insert(Int32,String) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class > Insert Method : Insert(Int32,String) Method

nIndex
The zero-based index to insert the new dbiColumnItem before
strText
The text to assign the new dbiColumnItem to be inserted
Inserts an object into the collection. This overload will create a new dbiColumnItem, based on the supplied parameter, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim nIndex As Integer
Dim strText As String

instance.Insert(nIndex, strText)
C#
public void Insert(
   int nIndex,
   string strText
)

Parameters

nIndex
The zero-based index to insert the new dbiColumnItem before
strText
The text to assign the new dbiColumnItem to be inserted

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,String,Int32) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class > Insert Method : Insert(Int32,String,Int32) Method

nIndex
The zero-based index to insert the new dbiColumnItem before
strText
The text to assign the new dbiColumnItem to be inserted
nWidth
The width to assign the new dbiColumnItem to be inserted
Inserts an object into the collection. This overload will create a new dbiColumnItem, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim nIndex As Integer
Dim strText As String
Dim nWidth As Integer

instance.Insert(nIndex, strText, nWidth)
C#
public void Insert(
   int nIndex,
   string strText,
   int nWidth
)

Parameters

nIndex
The zero-based index to insert the new dbiColumnItem before
strText
The text to assign the new dbiColumnItem to be inserted
nWidth
The width to assign the new dbiColumnItem to be inserted

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,dbiColumnItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class > Insert Method : Insert(Int32,dbiColumnItem) Method

nIndex
The zero-based index to insert the new dbiColumnItem before
obj
The dbiColumnItem to insert
Inserts an object into the collection

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim nIndex As Integer
Dim obj As dbiColumnItem

instance.Insert(nIndex, obj)
C#
public new void Insert(
   int nIndex,
   dbiColumnItem obj
)

Parameters

nIndex
The zero-based index to insert the new dbiColumnItem before
obj
The dbiColumnItem to insert

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : Remove Method

obj
the dbiColumnItem to remove from the collection
Removes the first occurence of a specific object from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim obj As dbiColumnItem

instance.Remove(obj)
C#
public new void Remove(
   dbiColumnItem obj
)

Parameters

obj
the dbiColumnItem to remove from the collection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : RemoveAt Method

nIndex
The zero-based index to remove the object at
Removes the object at the specified index of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim nIndex As Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   int nIndex
)

Parameters

nIndex
The zero-based index to remove the object at

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%% $$Properties$$

dbiColumnItemCollection Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItemCollection Class

"

For a list of all members of this type, see dbiColumnItemCollection members.

"

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

See Also

Reference

dbiColumnItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Item Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : Item Property

nIndex
The zero-based index of the object in the collection.
Get or set a particular object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim nIndex As Integer
Dim value As dbiColumnItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiColumnItem this[
   int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the object in the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

dbiCustomArea Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomArea Class

Provides properties for defining custom areas.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
C#
public class dbiCustomArea : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiCustomArea

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiCustomArea Class Members
See Also Fields Properties Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomArea Class

"

The following tables list the members exposed by dbiCustomArea.

"

Public Constructors

 | Name | Description
public Constructor | dbiCustomArea Constructor | Overloaded. Initializes a new instance of the class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | DailyProperty | Identifies the DependencyProperty for the Daily Property
static (Shared in Visual Basic) | DeadZoneProperty | Identifies the DependencyProperty for the DeadZone Property
static (Shared in Visual Basic) | EndProperty | Identifies the DependencyProperty for the End Property
static (Shared in Visual Basic) | StartProperty | Identifies the DependencyProperty for the Start Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
Top

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the area.
public Property | Daily | Gets or sets the whether the area is repeated on a daily basis.
public Property | DeadZone | Gets or sets the whether the area is considered a dead zone.
public Property | End | Gets or sets the ending date and time of the area.
public Property | Start | Gets or sets the starting date and time of the area.
public Property | Tag | Gets or sets a tag or object for the object.
Top

See Also

Reference

dbiCustomArea Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiCustomArea Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : dbiCustomArea Constructor

Initializes a new instance of the class.

Overload List

Overload | Description
dbiCustomArea Constructor() | Initializes a new instance of the dbiCustomArea class.
dbiCustomArea Constructor(DateTime,DateTime,Brush) | Initializes a new instance of the dbiCustomArea class.
dbiCustomArea Constructor(DateTime,DateTime,Brush,Boolean) | Initializes a new instance of the dbiCustomArea class.
dbiCustomArea Constructor(DateTime,DateTime,Boolean) | Initializes a new instance of the dbiCustomArea class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

dbiCustomArea Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class > dbiCustomArea Constructor : dbiCustomArea Constructor()

Initializes a new instance of the dbiCustomArea class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiCustomArea()
C#
public dbiCustomArea()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

dbiCustomArea Constructor(DateTime,DateTime,Brush)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class > dbiCustomArea Constructor : dbiCustomArea Constructor(DateTime,DateTime,Brush)

dtStart
The start DateTime of the new custom area
dtEnd
The end DateTime of the new custom area
brBrush
The brush to paint the new custom area
Initializes a new instance of the dbiCustomArea class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As Date
Dim dtEnd As Date
Dim brBrush As Brush

Dim instance As New dbiCustomArea(dtStart, dtEnd, brBrush)
C#
public dbiCustomArea(
   DateTime dtStart,
   DateTime dtEnd,
   Brush brBrush
)

Parameters

dtStart
The start DateTime of the new custom area
dtEnd
The end DateTime of the new custom area
brBrush
The brush to paint the new custom area

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

dbiCustomArea Constructor(DateTime,DateTime,Brush,Boolean)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class > dbiCustomArea Constructor : dbiCustomArea Constructor(DateTime,DateTime,Brush,Boolean)

dtStart
The start DateTime of the new custom area
dtEnd
The end DateTIme of the new custom area
brBrush
The brush to paint the new custom area
bDeadZone
Indicates if the new custom area is a dead zone
Initializes a new instance of the dbiCustomArea class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As Date
Dim dtEnd As Date
Dim brBrush As Brush
Dim bDeadZone As Boolean

Dim instance As New dbiCustomArea(dtStart, dtEnd, brBrush, bDeadZone)
C#
public dbiCustomArea(
   DateTime dtStart,
   DateTime dtEnd,
   Brush brBrush,
   bool bDeadZone
)

Parameters

dtStart
The start DateTime of the new custom area
dtEnd
The end DateTIme of the new custom area
brBrush
The brush to paint the new custom area
bDeadZone
Indicates if the new custom area is a dead zone

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

dbiCustomArea Constructor(DateTime,DateTime,Boolean)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class > dbiCustomArea Constructor : dbiCustomArea Constructor(DateTime,DateTime,Boolean)

dtStart
The start DateTime of the new custom area
dtEnd
The end DateTime of the new custom area
bDeadZone
Indicates if the new custom area is a dead zone
Initializes a new instance of the dbiCustomArea class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As Date
Dim dtEnd As Date
Dim bDeadZone As Boolean

Dim instance As New dbiCustomArea(dtStart, dtEnd, bDeadZone)
C#
public dbiCustomArea(
   DateTime dtStart,
   DateTime dtEnd,
   bool bDeadZone
)

Parameters

dtStart
The start DateTime of the new custom area
dtEnd
The end DateTime of the new custom area
bDeadZone
Indicates if the new custom area is a dead zone

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%% $$Properties$$

dbiCustomArea Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomArea Class

"

For a list of all members of this type, see dbiCustomArea members.

"

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the area.
public Property | Daily | Gets or sets the whether the area is repeated on a daily basis.
public Property | DeadZone | Gets or sets the whether the area is considered a dead zone.
public Property | End | Gets or sets the ending date and time of the area.
public Property | Start | Gets or sets the starting date and time of the area.
public Property | Tag | Gets or sets a tag or object for the object.
Top

See Also

Reference

dbiCustomArea Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Background Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : Background Property

Gets or sets the brush used to paint the background of the area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Brush

instance.Background = value

value = instance.Background
C#
public Brush Background {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

Daily Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : Daily Property

Gets or sets the whether the area is repeated on a daily basis.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Boolean

instance.Daily = value

value = instance.Daily
C#
public bool Daily {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

DeadZone Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : DeadZone Property

Gets or sets the whether the area is considered a dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Boolean

instance.DeadZone = value

value = instance.DeadZone
C#
public bool DeadZone {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : End Property

Gets or sets the ending date and time of the area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Date

instance.End = value

value = instance.End
C#
[TypeConverterAttribute("., dbiScheduleWPF, Version=2.5.0.0, Culture=neutral, PublicKeyToken=0e75c9c0bb3bd0d4")]
public DateTime End {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : Start Property

Gets or sets the starting date and time of the area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Date

instance.Start = value

value = instance.Start
C#
[TypeConverterAttribute("., dbiScheduleWPF, Version=2.5.0.0, Culture=neutral, PublicKeyToken=0e75c9c0bb3bd0d4")]
public DateTime Start {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : Tag Property

Gets or sets a tag or object for the object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
public object Tag {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%% $$Fields$$

dbiCustomArea Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomArea Class

"

For a list of all members of this type, see dbiCustomArea members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | DailyProperty | Identifies the DependencyProperty for the Daily Property
static (Shared in Visual Basic) | DeadZoneProperty | Identifies the DependencyProperty for the DeadZone Property
static (Shared in Visual Basic) | EndProperty | Identifies the DependencyProperty for the End Property
static (Shared in Visual Basic) | StartProperty | Identifies the DependencyProperty for the Start Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
Top

See Also

Reference

dbiCustomArea Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : BackgroundProperty Field

Identifies the DependencyProperty for the Background Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiCustomArea.BackgroundProperty
C#
public static readonly DependencyProperty BackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

DailyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : DailyProperty Field

Identifies the DependencyProperty for the Daily Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiCustomArea.DailyProperty
C#
public static readonly DependencyProperty DailyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

DeadZoneProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : DeadZoneProperty Field

Identifies the DependencyProperty for the DeadZone Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiCustomArea.DeadZoneProperty
C#
public static readonly DependencyProperty DeadZoneProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

EndProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : EndProperty Field

Identifies the DependencyProperty for the End Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiCustomArea.EndProperty
C#
public static readonly DependencyProperty EndProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

StartProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : StartProperty Field

Identifies the DependencyProperty for the Start Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiCustomArea.StartProperty
C#
public static readonly DependencyProperty StartProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

TagProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : TagProperty Field

Identifies the DependencyProperty for the Tag Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiCustomArea.TagProperty
C#
public static readonly DependencyProperty TagProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

dbiCustomAreaCollection Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomAreaCollection Class

The collection of custom areas

Object Model

dbiCustomAreaCollection ClassdbiCustomArea Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
C#
[DefaultMemberAttribute("Item")]
public class dbiCustomAreaCollection : System.Collections.ObjectModel.ObservableCollection<dbiCustomArea>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiCustomAreaCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiCustomAreaCollection Class Members
See Also Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomAreaCollection Class

"

The following tables list the members exposed by dbiCustomAreaCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiCustomAreaCollection Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiCustomAreaCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiCustomAreaCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : dbiCustomAreaCollection Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiCustomAreaCollection()
C#
public dbiCustomAreaCollection()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%% $$Methods$$

dbiCustomAreaCollection Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomAreaCollection Class

"

For a list of all members of this type, see dbiCustomAreaCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiCustomAreaCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Add Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : Add Method

Adds an object to the end of the collection

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(DateTime,DateTime,Brush) | Adds an object to the end of the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and add it to the collection.
Add(DateTime,DateTime,Brush,Boolean) | Adds an object to the end of the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and add it to the collection.
Add(DateTime,DateTime,Boolean) | Adds an object to the end of the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and add it to the collection.
Add(dbiCustomArea) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Add() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection

instance.Add()
C#
public void Add()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members
Overload List


%%PageItemTitle%%

Add(DateTime,DateTime,Brush) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class > Add Method : Add(DateTime,DateTime,Brush) Method

dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
brBrush
The brush to paint the background of the new custom area.
Adds an object to the end of the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim dtStart As Date
Dim dtEnd As Date
Dim brBrush As Brush

instance.Add(dtStart, dtEnd, brBrush)
C#
public void Add(
   DateTime dtStart,
   DateTime dtEnd,
   Brush brBrush
)

Parameters

dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
brBrush
The brush to paint the background of the new custom area.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members
Overload List


%%PageItemTitle%%

Add(DateTime,DateTime,Brush,Boolean) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class > Add Method : Add(DateTime,DateTime,Brush,Boolean) Method

dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
brBrush
The brush to paint the background of the new custom area.
bDeadZone
Indicates if the new custom area is a dead zone
Adds an object to the end of the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim dtStart As Date
Dim dtEnd As Date
Dim brBrush As Brush
Dim bDeadZone As Boolean

instance.Add(dtStart, dtEnd, brBrush, bDeadZone)
C#
public void Add(
   DateTime dtStart,
   DateTime dtEnd,
   Brush brBrush,
   bool bDeadZone
)

Parameters

dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
brBrush
The brush to paint the background of the new custom area.
bDeadZone
Indicates if the new custom area is a dead zone

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members
Overload List


%%PageItemTitle%%

Add(DateTime,DateTime,Boolean) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class > Add Method : Add(DateTime,DateTime,Boolean) Method

dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
bDeadZone
Indicates if the new custom area is a dead zone
Adds an object to the end of the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim dtStart As Date
Dim dtEnd As Date
Dim bDeadZone As Boolean

instance.Add(dtStart, dtEnd, bDeadZone)
C#
public void Add(
   DateTime dtStart,
   DateTime dtEnd,
   bool bDeadZone
)

Parameters

dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
bDeadZone
Indicates if the new custom area is a dead zone

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members
Overload List


%%PageItemTitle%%

Add(dbiCustomArea) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class > Add Method : Add(dbiCustomArea) Method

obj
Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim obj As dbiCustomArea

instance.Add(obj)
C#
public new void Add(
   dbiCustomArea obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : IndexOf Method

obj
The dbiCustomArea to find the index value for.
Gets the 0 based index of the first occurence of an object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim obj As dbiCustomArea
Dim value As Integer

value = instance.IndexOf(obj)
C#
public new int IndexOf(
   dbiCustomArea obj
)

Parameters

obj
The dbiCustomArea to find the index value for.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : Insert Method

Inserts an object into the collection

Overload List

Overload | Description
Insert(Int32,DateTime,DateTime,Brush) | Inserts an object into the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,DateTime,DateTime,Brush,Boolean) | Inserts an object into the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,DateTime,DateTime,Boolean) | Inserts an object into the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,dbiCustomArea) | Inserts an object into the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Insert(Int32,DateTime,DateTime,Brush) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class > Insert Method : Insert(Int32,DateTime,DateTime,Brush) Method

nIndex
The zero-based index value to insert the new dbiCustomArea before.
dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
brBrush
The brush to paint the background of the new custom area.
Inserts an object into the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim nIndex As Integer
Dim dtStart As Date
Dim dtEnd As Date
Dim brBrush As Brush

instance.Insert(nIndex, dtStart, dtEnd, brBrush)
C#
public void Insert(
   int nIndex,
   DateTime dtStart,
   DateTime dtEnd,
   Brush brBrush
)

Parameters

nIndex
The zero-based index value to insert the new dbiCustomArea before.
dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
brBrush
The brush to paint the background of the new custom area.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,DateTime,DateTime,Brush,Boolean) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class > Insert Method : Insert(Int32,DateTime,DateTime,Brush,Boolean) Method

nIndex
The zero-based index value to insert the new dbiCustomArea before.
dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
brBrush
The brush to paint the background of the new custom area.
bDeadZone
Indicates if the new custom area is a dead zone
Inserts an object into the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim nIndex As Integer
Dim dtStart As Date
Dim dtEnd As Date
Dim brBrush As Brush
Dim bDeadZone As Boolean

instance.Insert(nIndex, dtStart, dtEnd, brBrush, bDeadZone)
C#
public void Insert(
   int nIndex,
   DateTime dtStart,
   DateTime dtEnd,
   Brush brBrush,
   bool bDeadZone
)

Parameters

nIndex
The zero-based index value to insert the new dbiCustomArea before.
dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
brBrush
The brush to paint the background of the new custom area.
bDeadZone
Indicates if the new custom area is a dead zone

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,DateTime,DateTime,Boolean) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class > Insert Method : Insert(Int32,DateTime,DateTime,Boolean) Method

nIndex
The zero-based index value to insert the new dbiCustomArea before.
dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
bDeadZone
Indicates if the new custom area is a dead zone
Inserts an object into the collection. This overload will create a new dbiCustomArea, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim nIndex As Integer
Dim dtStart As Date
Dim dtEnd As Date
Dim bDeadZone As Boolean

instance.Insert(nIndex, dtStart, dtEnd, bDeadZone)
C#
public void Insert(
   int nIndex,
   DateTime dtStart,
   DateTime dtEnd,
   bool bDeadZone
)

Parameters

nIndex
The zero-based index value to insert the new dbiCustomArea before.
dtStart
The start DateTime of the new custom area.
dtEnd
The end DateTime of the new custom area.
bDeadZone
Indicates if the new custom area is a dead zone

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,dbiCustomArea) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class > Insert Method : Insert(Int32,dbiCustomArea) Method

nIndex
The zero-based index value to insert the new dbiCustomArea before.
obj
The dbiCustomArea to insert.
Inserts an object into the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim nIndex As Integer
Dim obj As dbiCustomArea

instance.Insert(nIndex, obj)
C#
public new void Insert(
   int nIndex,
   dbiCustomArea obj
)

Parameters

nIndex
The zero-based index value to insert the new dbiCustomArea before.
obj
The dbiCustomArea to insert.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : Remove Method

obj
The dbiCustomArea to remove.
Removes the first occurence of a specific object from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim obj As dbiCustomArea

instance.Remove(obj)
C#
public new void Remove(
   dbiCustomArea obj
)

Parameters

obj
The dbiCustomArea to remove.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : RemoveAt Method

nIndex
The zero-based index to remove the object at.
Removes the object at the specified index of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim nIndex As Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   int nIndex
)

Parameters

nIndex
The zero-based index to remove the object at.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%% $$Properties$$

dbiCustomAreaCollection Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomAreaCollection Class

"

For a list of all members of this type, see dbiCustomAreaCollection members.

"

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

See Also

Reference

dbiCustomAreaCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Item Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : Item Property

nIndex
Get or set a particular object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim nIndex As Integer
Dim value As dbiCustomArea

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiCustomArea this[
   int nIndex
]; {get; set;}

Parameters

nIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

dbiGuideLine Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLine Class

Provides the properties for defining a GuideLine

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
C#
public class dbiGuideLine : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiGuideLine

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiGuideLine Class Members
See Also Fields Properties Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLine Class

"

The following tables list the members exposed by dbiGuideLine.

"

Public Constructors

 | Name | Description
public Constructor | dbiGuideLine Constructor | Overloaded. Initializes a new instance of the dbiGuideLine class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ImageIndexProperty | Identifies the DependencyProperty for the ImageIndex Property
static (Shared in Visual Basic) | ImageXOffsetProperty | Identifies the DependencyProperty for the ImageXOffset Property
static (Shared in Visual Basic) | ImageYOffsetProperty | Identifies the DependencyProperty for the ImageYOffset Property
static (Shared in Visual Basic) | LineTimeProperty | Identifies the DependencyProperty for the LineTime Property
static (Shared in Visual Basic) | LockedProperty | Identifies the DependencyProperty for the Locked Property
static (Shared in Visual Basic) | StrokeProperty | Identifies the DependencyProperty for the Stroke Property
static (Shared in Visual Basic) | StrokeThicknessProperty | Identifies the DependencyProperty for the StrokeThickness Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
Top

Public Properties

 | Name | Description
public Property | ImageIndex | The zero-based index value of the image to use for the GuideLine in the ruler area.
public Property | ImageXOffset | Determines the horizontal offset used to calculate the position of a guide line image.
public Property | ImageYOffset | Determines the vertical offset used to calculate the position of a guide line image.
public Property | LineTime | Gets or sets the DateTime of the GuideLine.
public Property | Locked | Determines if the GuideLine can be moved with the mouse.
public Property | Stroke | Gets or set the stroke of the line.
public Property | StrokeThickness | Gets or set the stroke thickness of the line.
public Property | Tag | Gets or sets a tag or object for the object.
Top

See Also

Reference

dbiGuideLine Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiGuideLine Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : dbiGuideLine Constructor

Initializes a new instance of the dbiGuideLine class.

Overload List

Overload | Description
dbiGuideLine Constructor() | Initializes a new instance of the dbiGuideLine class.
dbiGuideLine Constructor(DateTime) | Initializes a new instance of the dbiGuideLine class setting the LineTime property to the datetime parameter.
dbiGuideLine Constructor(dbiGuideLine) | Initializes a new instance of the dbiGuideLine class based on an existing dbiGuideLine object.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

dbiGuideLine Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class > dbiGuideLine Constructor : dbiGuideLine Constructor()

Initializes a new instance of the dbiGuideLine class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiGuideLine()
C#
public dbiGuideLine()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%%

dbiGuideLine Constructor(DateTime)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class > dbiGuideLine Constructor : dbiGuideLine Constructor(DateTime)

dtTime
The date/time where the GuideLine will appear.
Initializes a new instance of the dbiGuideLine class setting the LineTime property to the datetime parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim dtTime As Date

Dim instance As New dbiGuideLine(dtTime)
C#
public dbiGuideLine(
   DateTime dtTime
)

Parameters

dtTime
The date/time where the GuideLine will appear.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%%

dbiGuideLine Constructor(dbiGuideLine)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class > dbiGuideLine Constructor : dbiGuideLine Constructor(dbiGuideLine)

objLine
The exisiting dbiGuideLine to use as a base
Initializes a new instance of the dbiGuideLine class based on an existing dbiGuideLine object.

Syntax

Visual Basic (Usage) Copy Code
Dim objLine As dbiGuideLine

Dim instance As New dbiGuideLine(objLine)
C#
public dbiGuideLine(
   dbiGuideLine objLine
)

Parameters

objLine
The exisiting dbiGuideLine to use as a base

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%% $$Properties$$

dbiGuideLine Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLine Class

"

For a list of all members of this type, see dbiGuideLine members.

"

Public Properties

 | Name | Description
public Property | ImageIndex | The zero-based index value of the image to use for the GuideLine in the ruler area.
public Property | ImageXOffset | Determines the horizontal offset used to calculate the position of a guide line image.
public Property | ImageYOffset | Determines the vertical offset used to calculate the position of a guide line image.
public Property | LineTime | Gets or sets the DateTime of the GuideLine.
public Property | Locked | Determines if the GuideLine can be moved with the mouse.
public Property | Stroke | Gets or set the stroke of the line.
public Property | StrokeThickness | Gets or set the stroke thickness of the line.
public Property | Tag | Gets or sets a tag or object for the object.
Top

See Also

Reference

dbiGuideLine Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ImageIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : ImageIndex Property

The zero-based index value of the image to use for the GuideLine in the ruler area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public int ImageIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

ImageXOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : ImageXOffset Property

Determines the horizontal offset used to calculate the position of a guide line image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Integer

instance.ImageXOffset = value

value = instance.ImageXOffset
C#
public int ImageXOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

ImageYOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : ImageYOffset Property

Determines the vertical offset used to calculate the position of a guide line image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Integer

instance.ImageYOffset = value

value = instance.ImageYOffset
C#
public int ImageYOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : LineTime Property

Gets or sets the DateTime of the GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Date

instance.LineTime = value

value = instance.LineTime
C#
[TypeConverterAttribute("., dbiScheduleWPF, Version=2.5.0.0, Culture=neutral, PublicKeyToken=0e75c9c0bb3bd0d4")]
public DateTime LineTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

Locked Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : Locked Property

Determines if the GuideLine can be moved with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Boolean

instance.Locked = value

value = instance.Locked
C#
public bool Locked {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

Stroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : Stroke Property

Gets or set the stroke of the line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Brush

instance.Stroke = value

value = instance.Stroke
C#
public Brush Stroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

StrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : StrokeThickness Property

Gets or set the stroke thickness of the line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Double

instance.StrokeThickness = value

value = instance.StrokeThickness
C#
public double StrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : Tag Property

Gets or sets a tag or object for the object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
public object Tag {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%% $$Fields$$

dbiGuideLine Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLine Class

"

For a list of all members of this type, see dbiGuideLine members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ImageIndexProperty | Identifies the DependencyProperty for the ImageIndex Property
static (Shared in Visual Basic) | ImageXOffsetProperty | Identifies the DependencyProperty for the ImageXOffset Property
static (Shared in Visual Basic) | ImageYOffsetProperty | Identifies the DependencyProperty for the ImageYOffset Property
static (Shared in Visual Basic) | LineTimeProperty | Identifies the DependencyProperty for the LineTime Property
static (Shared in Visual Basic) | LockedProperty | Identifies the DependencyProperty for the Locked Property
static (Shared in Visual Basic) | StrokeProperty | Identifies the DependencyProperty for the Stroke Property
static (Shared in Visual Basic) | StrokeThicknessProperty | Identifies the DependencyProperty for the StrokeThickness Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
Top

See Also

Reference

dbiGuideLine Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ImageIndexProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : ImageIndexProperty Field

Identifies the DependencyProperty for the ImageIndex Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiGuideLine.ImageIndexProperty
C#
public static readonly DependencyProperty ImageIndexProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

ImageXOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : ImageXOffsetProperty Field

Identifies the DependencyProperty for the ImageXOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiGuideLine.ImageXOffsetProperty
C#
public static readonly DependencyProperty ImageXOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

ImageYOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : ImageYOffsetProperty Field

Identifies the DependencyProperty for the ImageYOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiGuideLine.ImageYOffsetProperty
C#
public static readonly DependencyProperty ImageYOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

LineTimeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : LineTimeProperty Field

Identifies the DependencyProperty for the LineTime Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiGuideLine.LineTimeProperty
C#
public static readonly DependencyProperty LineTimeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

LockedProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : LockedProperty Field

Identifies the DependencyProperty for the Locked Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiGuideLine.LockedProperty
C#
public static readonly DependencyProperty LockedProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

StrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : StrokeProperty Field

Identifies the DependencyProperty for the Stroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiGuideLine.StrokeProperty
C#
public static readonly DependencyProperty StrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

StrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : StrokeThicknessProperty Field

Identifies the DependencyProperty for the StrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiGuideLine.StrokeThicknessProperty
C#
public static readonly DependencyProperty StrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

TagProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : TagProperty Field

Identifies the DependencyProperty for the Tag Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiGuideLine.TagProperty
C#
public static readonly DependencyProperty TagProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

dbiGuideLineCollection Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLineCollection Class

The collection of guidelines.

Object Model

dbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
C#
[DefaultMemberAttribute("Item")]
public class dbiGuideLineCollection : System.Collections.ObjectModel.ObservableCollection<dbiGuideLine>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiGuideLineCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiGuideLineCollection Class Members
See Also Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLineCollection Class

"

The following tables list the members exposed by dbiGuideLineCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiGuideLineCollection Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiGuideLineCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiGuideLineCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : dbiGuideLineCollection Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiGuideLineCollection()
C#
public dbiGuideLineCollection()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%% $$Methods$$

dbiGuideLineCollection Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLineCollection Class

"

For a list of all members of this type, see dbiGuideLineCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiGuideLineCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Add Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : Add Method

Adds an object to the end of the collection

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(DateTime) | Adds an object to the end of the collection. This overload will create a new dbiGuideLine, based on the supplied parameter, and add it to the collection.
Add(dbiGuideLine) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Add() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection

instance.Add()
C#
public void Add()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members
Overload List


%%PageItemTitle%%

Add(DateTime) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class > Add Method : Add(DateTime) Method

dtLineTime
The DateTime for the new GuideLine.
Adds an object to the end of the collection. This overload will create a new dbiGuideLine, based on the supplied parameter, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim dtLineTime As Date

instance.Add(dtLineTime)
C#
public void Add(
   DateTime dtLineTime
)

Parameters

dtLineTime
The DateTime for the new GuideLine.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members
Overload List


%%PageItemTitle%%

Add(dbiGuideLine) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class > Add Method : Add(dbiGuideLine) Method

obj
The dbiGuideLine to add to the end of the collection.
Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim obj As dbiGuideLine

instance.Add(obj)
C#
public new void Add(
   dbiGuideLine obj
)

Parameters

obj
The dbiGuideLine to add to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : IndexOf Method

obj
The dbiGuideLine to find the index value for
Gets the 0 based index of the first occurence of an object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim obj As dbiGuideLine
Dim value As Integer

value = instance.IndexOf(obj)
C#
public new int IndexOf(
   dbiGuideLine obj
)

Parameters

obj
The dbiGuideLine to find the index value for

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : Insert Method

Inserts an object into the collection

Overload List

Overload | Description
Insert(Int32,DateTime) | Inserts an object into the collection. This overload will create a new dbiGuideLine, based on the supplied parameter, and insert it in to the collection.
Insert(Int32,dbiGuideLine) | Inserts an object into the collection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Insert(Int32,DateTime) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class > Insert Method : Insert(Int32,DateTime) Method

nIndex

The zero-based index to insert the new dbiGuideLine before

dtLineTime
The DateTime value for the new Guide Line.
Inserts an object into the collection. This overload will create a new dbiGuideLine, based on the supplied parameter, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim nIndex As Integer
Dim dtLineTime As Date

instance.Insert(nIndex, dtLineTime)
C#
public void Insert(
   int nIndex,
   DateTime dtLineTime
)

Parameters

nIndex

The zero-based index to insert the new dbiGuideLine before

dtLineTime
The DateTime value for the new Guide Line.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,dbiGuideLine) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class > Insert Method : Insert(Int32,dbiGuideLine) Method

nIndex

The zero-based index to insert the new dbiGuideLine before

obj
The dbiGuideLine to be inserted.
Inserts an object into the collection

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim nIndex As Integer
Dim obj As dbiGuideLine

instance.Insert(nIndex, obj)
C#
public new void Insert(
   int nIndex,
   dbiGuideLine obj
)

Parameters

nIndex

The zero-based index to insert the new dbiGuideLine before

obj
The dbiGuideLine to be inserted.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : Remove Method

obj
The dbiGuideLine to remove from the collection.
Removes the first occurence of a specific object from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim obj As dbiGuideLine

instance.Remove(obj)
C#
public new void Remove(
   dbiGuideLine obj
)

Parameters

obj
The dbiGuideLine to remove from the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : RemoveAt Method

nIndex
The zero-based index to remove the object at.
Removes the object at the specified index of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim nIndex As Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   int nIndex
)

Parameters

nIndex
The zero-based index to remove the object at.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%% $$Properties$$

dbiGuideLineCollection Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLineCollection Class

"

For a list of all members of this type, see dbiGuideLineCollection members.

"

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

See Also

Reference

dbiGuideLineCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Item Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : Item Property

nIndex
The zero-based index of the object in the collection.
Get or set a particular object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim nIndex As Integer
Dim value As dbiGuideLine

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiGuideLine this[
   int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the object in the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

dbiHistoryItem Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiHistoryItem Class

Provides the properties for defining a dbiHistoryItem

Object Model

dbiHistoryItem ClassdbiLinkItem ClassdbiListItem ClassdbiListItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
C#
public class dbiHistoryItem

Inheritance Hierarchy

System.Object
Dbi.WpfControl.dbiSchedule.dbiHistoryItem

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiHistoryItem Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiHistoryItem Class

"

The following tables list the members exposed by dbiHistoryItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiHistoryItem Constructor | Overloaded. Initializes a new instance of the dbiHistoryItem class
Top

Public Properties

 | Name | Description
public Property | ActionType | Determines the type of action that is taking place.
public Property | BarIndex | Gets or sets the index of the Timebar where the action is occuring.
public Property | End | The end date and time of the Timebar before the action has been performed.
public Property | Group | Gets or sets an internal number to identify the sequence where the action takes place.
public Property | Link | Gets the dbiLinkItem which was added to or removed from the schedule.
public Property | ListItem | The original dbiListItem the action was performed on.
public Property | ListItemTo | The dbiListItem a Timebar has been vertically moved to.
public Property | Start | The start date and time of the Timebar before the action has been performed.
public Property | TimeBar | The original dbiTimeBarItem the action was performed on.
public Property | TimeBarTo | The dbiTimeBarItem after it has been moved vertically.
Top

See Also

Reference

dbiHistoryItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiHistoryItem Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : dbiHistoryItem Constructor

Initializes a new instance of the dbiHistoryItem class

Overload List

Overload | Description
dbiHistoryItem Constructor() | Initializes a new instance of the dbiHistoryItem class
dbiHistoryItem Constructor(Int32,enumActionType) | Initializes a new instance of the dbiHistoryItem class

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

dbiHistoryItem Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class > dbiHistoryItem Constructor : dbiHistoryItem Constructor()

Initializes a new instance of the dbiHistoryItem class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiHistoryItem()
C#
public dbiHistoryItem()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members
Overload List


%%PageItemTitle%%

dbiHistoryItem Constructor(Int32,enumActionType)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class > dbiHistoryItem Constructor : dbiHistoryItem Constructor(Int32,enumActionType)

nGroup
The group ID of the history item
nAction
The dbiHistoryItem.enumActionType Enumeration member
Initializes a new instance of the dbiHistoryItem class

Syntax

Visual Basic (Usage) Copy Code
Dim nGroup As Integer
Dim nAction As dbiHistoryItem.enumActionType

Dim instance As New dbiHistoryItem(nGroup, nAction)
C#
public dbiHistoryItem(
   int nGroup,
   dbiHistoryItem.enumActionType nAction
)

Parameters

nGroup
The group ID of the history item
nAction
The dbiHistoryItem.enumActionType Enumeration member

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members
Overload List


%%PageItemTitle%% $$Properties$$

dbiHistoryItem Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiHistoryItem Class

"

For a list of all members of this type, see dbiHistoryItem members.

"

Public Properties

 | Name | Description
public Property | ActionType | Determines the type of action that is taking place.
public Property | BarIndex | Gets or sets the index of the Timebar where the action is occuring.
public Property | End | The end date and time of the Timebar before the action has been performed.
public Property | Group | Gets or sets an internal number to identify the sequence where the action takes place.
public Property | Link | Gets the dbiLinkItem which was added to or removed from the schedule.
public Property | ListItem | The original dbiListItem the action was performed on.
public Property | ListItemTo | The dbiListItem a Timebar has been vertically moved to.
public Property | Start | The start date and time of the Timebar before the action has been performed.
public Property | TimeBar | The original dbiTimeBarItem the action was performed on.
public Property | TimeBarTo | The dbiTimeBarItem after it has been moved vertically.
Top

See Also

Reference

dbiHistoryItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ActionType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : ActionType Property

Determines the type of action that is taking place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiHistoryItem.enumActionType

instance.ActionType = value

value = instance.ActionType
C#
public dbiHistoryItem.enumActionType ActionType {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : BarIndex Property

Gets or sets the index of the Timebar where the action is occuring.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : End Property

The end date and time of the Timebar before the action has been performed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As Date

instance.End = value

value = instance.End
C#
public DateTime End {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

Group Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : Group Property

Gets or sets an internal number to identify the sequence where the action takes place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As Integer

instance.Group = value

value = instance.Group
C#
public int Group {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

Link Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : Link Property

Gets the dbiLinkItem which was added to or removed from the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : ListItem Property

The original dbiListItem the action was performed on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

ListItemTo Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : ListItemTo Property

The dbiListItem a Timebar has been vertically moved to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiListItem

instance.ListItemTo = value

value = instance.ListItemTo
C#
public dbiListItem ListItemTo {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : Start Property

The start date and time of the Timebar before the action has been performed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As Date

instance.Start = value

value = instance.Start
C#
public DateTime Start {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

TimeBar Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : TimeBar Property

The original dbiTimeBarItem the action was performed on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiTimeBarItem

instance.TimeBar = value

value = instance.TimeBar
C#
public dbiTimeBarItem TimeBar {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

TimeBarTo Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiHistoryItem Class : TimeBarTo Property

The dbiTimeBarItem after it has been moved vertically.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiTimeBarItem

instance.TimeBarTo = value

value = instance.TimeBarTo
C#
public dbiTimeBarItem TimeBarTo {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

dbiLinkItem Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItem Class

Provides properties for defining a link item.

Object Model

dbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
C#
public class dbiLinkItem : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiLinkItem

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiLinkItem Class Members
See Also Fields Properties Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItem Class

"

The following tables list the members exposed by dbiLinkItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiLinkItem Constructor | Overloaded. Initializes a new instance of the dbiLinkItem class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | StrokeProperty | Identifies the DependencyProperty for the Stroke Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
Top

Public Properties

 | Name | Description
public Property | LinkDirection | Gets or sets how the link will be placed between time bars.
public Property | LinkType | Gets or sets the type of link for the link line.
public Property | Stroke | Gets or sets the brush used to paint the link line.
public Property | Tag | Gets or sets the tag or object for the object.
public Property | TimeBarFrom | Gets or sets the time bar where the link begins.
public Property | TimeBarTo | Gets or sets the time bar where the link ends.
Top

See Also

Reference

dbiLinkItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiLinkItem Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : dbiLinkItem Constructor

Initializes a new instance of the dbiLinkItem class.

Overload List

Overload | Description
dbiLinkItem Constructor() | Initializes a new instance of the dbiLinkItem class.
dbiLinkItem Constructor(dbiTimeBarItem,dbiTimeBarItem) | Initializes a new instance of the dbiLinkItem class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

dbiLinkItem Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class > dbiLinkItem Constructor : dbiLinkItem Constructor()

Initializes a new instance of the dbiLinkItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiLinkItem()
C#
public dbiLinkItem()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members
Overload List


%%PageItemTitle%%

dbiLinkItem Constructor(dbiTimeBarItem,dbiTimeBarItem)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class > dbiLinkItem Constructor : dbiLinkItem Constructor(dbiTimeBarItem,dbiTimeBarItem)

objFrom
The dbiTimeBarItem being linked
objTo
The dbiTimeBarItem being linked to
Initializes a new instance of the dbiLinkItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objFrom As dbiTimeBarItem
Dim objTo As dbiTimeBarItem

Dim instance As New dbiLinkItem(objFrom, objTo)
C#
public dbiLinkItem(
   dbiTimeBarItem objFrom,
   dbiTimeBarItem objTo
)

Parameters

objFrom
The dbiTimeBarItem being linked
objTo
The dbiTimeBarItem being linked to

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members
Overload List


%%PageItemTitle%% $$Properties$$

dbiLinkItem Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItem Class

"

For a list of all members of this type, see dbiLinkItem members.

"

Public Properties

 | Name | Description
public Property | LinkDirection | Gets or sets how the link will be placed between time bars.
public Property | LinkType | Gets or sets the type of link for the link line.
public Property | Stroke | Gets or sets the brush used to paint the link line.
public Property | Tag | Gets or sets the tag or object for the object.
public Property | TimeBarFrom | Gets or sets the time bar where the link begins.
public Property | TimeBarTo | Gets or sets the time bar where the link ends.
Top

See Also

Reference

dbiLinkItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

LinkDirection Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : LinkDirection Property

Gets or sets how the link will be placed between time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As dbiLinkItem.enumLinkDirection

instance.LinkDirection = value

value = instance.LinkDirection
C#
public dbiLinkItem.enumLinkDirection LinkDirection {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

LinkType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : LinkType Property

Gets or sets the type of link for the link line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As dbiLinkItem.enumLinkType

instance.LinkType = value

value = instance.LinkType
C#
public dbiLinkItem.enumLinkType LinkType {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

Stroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : Stroke Property

Gets or sets the brush used to paint the link line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As Brush

instance.Stroke = value

value = instance.Stroke
C#
public Brush Stroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : Tag Property

Gets or sets the tag or object for the object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
public object Tag {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

TimeBarFrom Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : TimeBarFrom Property

Gets or sets the time bar where the link begins.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As dbiTimeBarItem

instance.TimeBarFrom = value

value = instance.TimeBarFrom
C#
public dbiTimeBarItem TimeBarFrom {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

TimeBarTo Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : TimeBarTo Property

Gets or sets the time bar where the link ends.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As dbiTimeBarItem

instance.TimeBarTo = value

value = instance.TimeBarTo
C#
public dbiTimeBarItem TimeBarTo {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%% $$Fields$$

dbiLinkItem Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItem Class

"

For a list of all members of this type, see dbiLinkItem members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | StrokeProperty | Identifies the DependencyProperty for the Stroke Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
Top

See Also

Reference

dbiLinkItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

StrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : StrokeProperty Field

Identifies the DependencyProperty for the Stroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiLinkItem.StrokeProperty
C#
public static readonly DependencyProperty StrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

TagProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : TagProperty Field

Identifies the DependencyProperty for the Tag Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiLinkItem.TagProperty
C#
public static readonly DependencyProperty TagProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

dbiLinkItemCollection Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItemCollection Class

The collection of link items

Object Model

dbiLinkItemCollection ClassdbiLinkItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
C#
[DefaultMemberAttribute("Item")]
public class dbiLinkItemCollection : System.Collections.ObjectModel.ObservableCollection<dbiLinkItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiLinkItemCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiLinkItemCollection Class Members
See Also Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItemCollection Class

"

The following tables list the members exposed by dbiLinkItemCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiLinkItemCollection Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiLinkItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiLinkItemCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : dbiLinkItemCollection Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiLinkItemCollection()
C#
public dbiLinkItemCollection()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%% $$Methods$$

dbiLinkItemCollection Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItemCollection Class

"

For a list of all members of this type, see dbiLinkItemCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiLinkItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Add Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : Add Method

Adds an object to the end of the collection

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(dbiTimeBarItem,dbiTimeBarItem) | Adds an object to the end of the collection. This overload will create a new dbiLinkItem, based on the supplied parameters, and add it to the collection.
Add(dbiLinkItem) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

Add() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection

instance.Add()
C#
public void Add()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members
Overload List


%%PageItemTitle%%

Add(dbiTimeBarItem,dbiTimeBarItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class > Add Method : Add(dbiTimeBarItem,dbiTimeBarItem) Method

TimeBarFrom
The dbiTimeBarItem being linked
TimeBarTo
The dbiTimeBarItem being linked to
Adds an object to the end of the collection. This overload will create a new dbiLinkItem, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim TimeBarFrom As dbiTimeBarItem
Dim TimeBarTo As dbiTimeBarItem

instance.Add(TimeBarFrom, TimeBarTo)
C#
public void Add(
   dbiTimeBarItem TimeBarFrom,
   dbiTimeBarItem TimeBarTo
)

Parameters

TimeBarFrom
The dbiTimeBarItem being linked
TimeBarTo
The dbiTimeBarItem being linked to

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members
Overload List


%%PageItemTitle%%

Add(dbiLinkItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class > Add Method : Add(dbiLinkItem) Method

obj
The dbiLinkItem to add to the end of the collection.
Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim obj As dbiLinkItem

instance.Add(obj)
C#
public new void Add(
   dbiLinkItem obj
)

Parameters

obj
The dbiLinkItem to add to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : IndexOf Method

obj
The dbiLinkItem to find the index value for.
Gets the 0 based index of the first occurence of an object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim obj As dbiLinkItem
Dim value As Integer

value = instance.IndexOf(obj)
C#
public new int IndexOf(
   dbiLinkItem obj
)

Parameters

obj
The dbiLinkItem to find the index value for.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : Insert Method

Inserts an object into the collection

Overload List

Overload | Description
Insert(Int32,dbiTimeBarItem,dbiTimeBarItem) | Inserts an object into the collection. This overload will create a new dbiLinkItem, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,dbiLinkItem) | Inserts an object into the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

Insert(Int32,dbiTimeBarItem,dbiTimeBarItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class > Insert Method : Insert(Int32,dbiTimeBarItem,dbiTimeBarItem) Method

nIndex

The zero-based index to insert the new dbiLinkItem before

TimeBarFrom
The dbiTimeBarItem being linked
TimeBarTo
The dbiTimeBarItem being linked to
Inserts an object into the collection. This overload will create a new dbiLinkItem, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim nIndex As Integer
Dim TimeBarFrom As dbiTimeBarItem
Dim TimeBarTo As dbiTimeBarItem

instance.Insert(nIndex, TimeBarFrom, TimeBarTo)
C#
public void Insert(
   int nIndex,
   dbiTimeBarItem TimeBarFrom,
   dbiTimeBarItem TimeBarTo
)

Parameters

nIndex

The zero-based index to insert the new dbiLinkItem before

TimeBarFrom
The dbiTimeBarItem being linked
TimeBarTo
The dbiTimeBarItem being linked to

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,dbiLinkItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class > Insert Method : Insert(Int32,dbiLinkItem) Method

nIndex

The zero-based index to insert the new dbiLinkItem before

obj
he dbiLinkItem to insert.
Inserts an object into the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim nIndex As Integer
Dim obj As dbiLinkItem

instance.Insert(nIndex, obj)
C#
public new void Insert(
   int nIndex,
   dbiLinkItem obj
)

Parameters

nIndex

The zero-based index to insert the new dbiLinkItem before

obj
he dbiLinkItem to insert.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : Remove Method

obj
The dbiLinkItem to remove from the collection.
Removes the first occurence of a specific object from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim obj As dbiLinkItem

instance.Remove(obj)
C#
public new void Remove(
   dbiLinkItem obj
)

Parameters

obj
The dbiLinkItem to remove from the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : RemoveAt Method

nIndex
The zero-based index value to remove the object at.
Removes the object at the specified index of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim nIndex As Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   int nIndex
)

Parameters

nIndex
The zero-based index value to remove the object at.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%% $$Properties$$

dbiLinkItemCollection Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItemCollection Class

"

For a list of all members of this type, see dbiLinkItemCollection members.

"

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

See Also

Reference

dbiLinkItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Item Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : Item Property

nIndex
The zero-based index of the object in the collection.
Get or set a particular object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim nIndex As Integer
Dim value As dbiLinkItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiLinkItem this[
   int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the object in the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

dbiListCell Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCell Class

Provides the properties for defining Cells in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
C#
public class dbiListCell : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiListCell

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiListCell Class Members
See Also Fields Properties Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCell Class

"

The following tables list the members exposed by dbiListCell.

"

Public Constructors

 | Name | Description
public Constructor | dbiListCell Constructor | Overloaded. Initializes a new instance of the dbiListCell class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | DateTimeProperty | Identifies the DependencyProperty for the DateTime Property
static (Shared in Visual Basic) | DoubleProperty | Identifies the DependencyProperty for the Double Property
static (Shared in Visual Basic) | ForegroundProperty | Identifies the DependencyProperty for the Foreground Property
static (Shared in Visual Basic) | ImageIndexProperty | Identifies the DependencyProperty for the ImageIndex Property
static (Shared in Visual Basic) | ImageOffsetProperty | Identifies the DependencyProperty for the ImageOffset Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TextProperty | Identifies the DependencyProperty for the Text Property
Top

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the list cell.
public Property | DateTime | Gets or sets the DateTime value for the list cell. This property is used for column sorting.
public Property | Double | Gets or sets the double-precision floating-point number for the list cell. This property is used for column sorting.
public Property | Foreground | Gets or sets the brush used to paint the text or foreground of the list cell.
public Property | ImageIndex | Gets or sets the image index for the list cell.
public Property | ImageOffset | Gets or sets the offset used to calculate the placement of an image in a cell.
public Property | Tag | Gets or sets the tag or object for the object.
public Property | Text | Gets or sets the text for the list cell.
Top

See Also

Reference

dbiListCell Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiListCell Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : dbiListCell Constructor

Initializes a new instance of the dbiListCell class.

Overload List

Overload | Description
dbiListCell Constructor() | Initializes a new instance of the dbiListCell class
dbiListCell Constructor(String) | Initializes a new instance of the dbiListCell class setting the Text Property to string parameter.
dbiListCell Constructor(Int32) | Initializes a new instance of the dbiListCell class setting the ImageIndex Property to the int32 parameter.
dbiListCell Constructor(String,DateTime) | Initializes a new instance of the dbiListCell class setting the Text Property to string parameter and the DateTime Property to the datetime parameter.
dbiListCell Constructor(String,Double) | Initializes a new instance of the dbiListCell class setting the Text Property to string parameter and the Double Property to the double parameter.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

dbiListCell Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class > dbiListCell Constructor : dbiListCell Constructor()

Initializes a new instance of the dbiListCell class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiListCell()
C#
public dbiListCell()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members
Overload List


%%PageItemTitle%%

dbiListCell Constructor(String)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class > dbiListCell Constructor : dbiListCell Constructor(String)

strText
Value to use for the Text Property
Initializes a new instance of the dbiListCell class setting the Text Property to string parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As New dbiListCell(strText)
C#
public dbiListCell(
   string strText
)

Parameters

strText
Value to use for the Text Property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members
Overload List


%%PageItemTitle%%

dbiListCell Constructor(Int32)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class > dbiListCell Constructor : dbiListCell Constructor(Int32)

nImage
Value to use for the ImageIndex Property
Initializes a new instance of the dbiListCell class setting the ImageIndex Property to the int32 parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim nImage As Integer

Dim instance As New dbiListCell(nImage)
C#
public dbiListCell(
   int nImage
)

Parameters

nImage
Value to use for the ImageIndex Property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members
Overload List


%%PageItemTitle%%

dbiListCell Constructor(String,DateTime)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class > dbiListCell Constructor : dbiListCell Constructor(String,DateTime)

strText
Value to use for the Text Property
dtDateTime
Value to use for the DateTime Property
Initializes a new instance of the dbiListCell class setting the Text Property to string parameter and the DateTime Property to the datetime parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As String
Dim dtDateTime As Date

Dim instance As New dbiListCell(strText, dtDateTime)
C#
public dbiListCell(
   string strText,
   DateTime dtDateTime
)

Parameters

strText
Value to use for the Text Property
dtDateTime
Value to use for the DateTime Property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members
Overload List


%%PageItemTitle%%

dbiListCell Constructor(String,Double)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class > dbiListCell Constructor : dbiListCell Constructor(String,Double)

strText
Value to use for the Text Property
nNumber
Value to use for the Double Property
Initializes a new instance of the dbiListCell class setting the Text Property to string parameter and the Double Property to the double parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As String
Dim nNumber As Double

Dim instance As New dbiListCell(strText, nNumber)
C#
public dbiListCell(
   string strText,
   double nNumber
)

Parameters

strText
Value to use for the Text Property
nNumber
Value to use for the Double Property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members
Overload List


%%PageItemTitle%% $$Properties$$

dbiListCell Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCell Class

"

For a list of all members of this type, see dbiListCell members.

"

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the list cell.
public Property | DateTime | Gets or sets the DateTime value for the list cell. This property is used for column sorting.
public Property | Double | Gets or sets the double-precision floating-point number for the list cell. This property is used for column sorting.
public Property | Foreground | Gets or sets the brush used to paint the text or foreground of the list cell.
public Property | ImageIndex | Gets or sets the image index for the list cell.
public Property | ImageOffset | Gets or sets the offset used to calculate the placement of an image in a cell.
public Property | Tag | Gets or sets the tag or object for the object.
public Property | Text | Gets or sets the text for the list cell.
Top

See Also

Reference

dbiListCell Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Background Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : Background Property

Gets or sets the brush used to paint the background of the list cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Brush

instance.Background = value

value = instance.Background
C#
public Brush Background {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

DateTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : DateTime Property

Gets or sets the DateTime value for the list cell. This property is used for column sorting.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Date

instance.DateTime = value

value = instance.DateTime
C#
[TypeConverterAttribute("., dbiScheduleWPF, Version=2.5.0.0, Culture=neutral, PublicKeyToken=0e75c9c0bb3bd0d4")]
public DateTime DateTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

Double Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : Double Property

Gets or sets the double-precision floating-point number for the list cell. This property is used for column sorting.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Double

instance.Double = value

value = instance.Double
C#
public double Double {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

Foreground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : Foreground Property

Gets or sets the brush used to paint the text or foreground of the list cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Brush

instance.Foreground = value

value = instance.Foreground
C#
public Brush Foreground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

ImageIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : ImageIndex Property

Gets or sets the image index for the list cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public int ImageIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

ImageOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : ImageOffset Property

Gets or sets the offset used to calculate the placement of an image in a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Point

instance.ImageOffset = value

value = instance.ImageOffset
C#
public Point ImageOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : Tag Property

Gets or sets the tag or object for the object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
public object Tag {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : Text Property

Gets or sets the text for the list cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%% $$Fields$$

dbiListCell Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCell Class

"

For a list of all members of this type, see dbiListCell members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | DateTimeProperty | Identifies the DependencyProperty for the DateTime Property
static (Shared in Visual Basic) | DoubleProperty | Identifies the DependencyProperty for the Double Property
static (Shared in Visual Basic) | ForegroundProperty | Identifies the DependencyProperty for the Foreground Property
static (Shared in Visual Basic) | ImageIndexProperty | Identifies the DependencyProperty for the ImageIndex Property
static (Shared in Visual Basic) | ImageOffsetProperty | Identifies the DependencyProperty for the ImageOffset Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TextProperty | Identifies the DependencyProperty for the Text Property
Top

See Also

Reference

dbiListCell Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : BackgroundProperty Field

Identifies the DependencyProperty for the Background Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListCell.BackgroundProperty
C#
public static readonly DependencyProperty BackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

DateTimeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : DateTimeProperty Field

Identifies the DependencyProperty for the DateTime Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListCell.DateTimeProperty
C#
public static readonly DependencyProperty DateTimeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

DoubleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : DoubleProperty Field

Identifies the DependencyProperty for the Double Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListCell.DoubleProperty
C#
public static readonly DependencyProperty DoubleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

ForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : ForegroundProperty Field

Identifies the DependencyProperty for the Foreground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListCell.ForegroundProperty
C#
public static readonly DependencyProperty ForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

ImageIndexProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : ImageIndexProperty Field

Identifies the DependencyProperty for the ImageIndex Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListCell.ImageIndexProperty
C#
public static readonly DependencyProperty ImageIndexProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

ImageOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : ImageOffsetProperty Field

Identifies the DependencyProperty for the ImageOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListCell.ImageOffsetProperty
C#
public static readonly DependencyProperty ImageOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

TagProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : TagProperty Field

Identifies the DependencyProperty for the Tag Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListCell.TagProperty
C#
public static readonly DependencyProperty TagProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

TextProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : TextProperty Field

Identifies the DependencyProperty for the Text Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListCell.TextProperty
C#
public static readonly DependencyProperty TextProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

dbiListCellCollection Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCellCollection Class

The collection of list cells

Object Model

dbiListCellCollection ClassdbiListCell Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
C#
[DefaultMemberAttribute("Item")]
public class dbiListCellCollection : System.Collections.ObjectModel.ObservableCollection<dbiListCell>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiListCellCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiListCellCollection Class Members
See Also Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCellCollection Class

"

The following tables list the members exposed by dbiListCellCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiListCellCollection Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection.
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiListCellCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiListCellCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : dbiListCellCollection Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiListCellCollection()
C#
public dbiListCellCollection()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%% $$Methods$$

dbiListCellCollection Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCellCollection Class

"

For a list of all members of this type, see dbiListCellCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection.
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiListCellCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Add Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : Add Method

Adds an object to the end of the collection.

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(String) | Adds an object to the end of the collection. This overload will create a new dbiListCell, based on the supplied parameter, and add it to the collection.
Add(Int32) | Adds an object to the end of the collection. This overload will create a new dbiListCell, based on the supplied parameter, and add it to the collection.
Add(String,Double) | Adds an object to the end of the collection. This overload will create a new dbiListCell, based on the supplied parameters, and add it to the collection.
Add(String,DateTime) | Adds an object to the end of the collection. This overload will create a new dbiListCell, based on the supplied parameters, and add it to the collection.
Add(dbiListCell) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

Add() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection

instance.Add()
C#
public void Add()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Add(String) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Add Method : Add(String) Method

strText
The text of the new list cell.
Adds an object to the end of the collection. This overload will create a new dbiListCell, based on the supplied parameter, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim strText As String

instance.Add(strText)
C#
public void Add(
   string strText
)

Parameters

strText
The text of the new list cell.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Add(Int32) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Add Method : Add(Int32) Method

nImage
The image index for the new list cell.
Adds an object to the end of the collection. This overload will create a new dbiListCell, based on the supplied parameter, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim nImage As Integer

instance.Add(nImage)
C#
public void Add(
   int nImage
)

Parameters

nImage
The image index for the new list cell.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Add(String,Double) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Add Method : Add(String,Double) Method

strText
The text for the new list cell.
nNumber
The double for the new list cell.
Adds an object to the end of the collection. This overload will create a new dbiListCell, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim strText As String
Dim nNumber As Double

instance.Add(strText, nNumber)
C#
public void Add(
   string strText,
   double nNumber
)

Parameters

strText
The text for the new list cell.
nNumber
The double for the new list cell.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Add(String,DateTime) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Add Method : Add(String,DateTime) Method

strText
The text for the new list cell
dtDateTime
The datetime for the new list cell.
Adds an object to the end of the collection. This overload will create a new dbiListCell, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim strText As String
Dim dtDateTime As Date

instance.Add(strText, dtDateTime)
C#
public void Add(
   string strText,
   DateTime dtDateTime
)

Parameters

strText
The text for the new list cell
dtDateTime
The datetime for the new list cell.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Add(dbiListCell) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Add Method : Add(dbiListCell) Method

obj
The dbiListCell to add to the end of the collection.
Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim obj As dbiListCell

instance.Add(obj)
C#
public new void Add(
   dbiListCell obj
)

Parameters

obj
The dbiListCell to add to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : IndexOf Method

obj
The dbiListCell to find the index of
Gets the 0 based index of the first occurence of an object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim obj As dbiListCell
Dim value As Integer

value = instance.IndexOf(obj)
C#
public new int IndexOf(
   dbiListCell obj
)

Parameters

obj
The dbiListCell to find the index of

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : Insert Method

Inserts an object into the collection.

Overload List

Overload | Description
Insert(Int32,String) | Inserts an object into the collection. This overload will create a new dbiListCell, based on the supplied parameter, and insert it in to the collection.
Insert(Int32,Int32) | Inserts an object into the collection. This overload will create a new dbiListCell, based on the supplied parameter, and insert it in to the collection.
Insert(Int32,String,Double) | Inserts an object into the collection. This overload will create a new dbiListCell, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,String,DateTime) | Inserts an object into the collection. This overload will create a new dbiListCell, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,dbiListCell) | Inserts an object into the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

Insert(Int32,String) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Insert Method : Insert(Int32,String) Method

nIndex
The zero-based index to insert the new dbiListCell before.
strText
The text of the new list cell.
Inserts an object into the collection. This overload will create a new dbiListCell, based on the supplied parameter, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim nIndex As Integer
Dim strText As String

instance.Insert(nIndex, strText)
C#
public void Insert(
   int nIndex,
   string strText
)

Parameters

nIndex
The zero-based index to insert the new dbiListCell before.
strText
The text of the new list cell.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,Int32) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Insert Method : Insert(Int32,Int32) Method

nIndex
The zero-based index to insert the new dbiListCell before.
nImage
The image index for the new list cell.
Inserts an object into the collection. This overload will create a new dbiListCell, based on the supplied parameter, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim nIndex As Integer
Dim nImage As Integer

instance.Insert(nIndex, nImage)
C#
public void Insert(
   int nIndex,
   int nImage
)

Parameters

nIndex
The zero-based index to insert the new dbiListCell before.
nImage
The image index for the new list cell.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,String,Double) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Insert Method : Insert(Int32,String,Double) Method

nIndex
The zero-based index to insert the new dbiListCell before.
strText
The text of the new list cell.
nNumber
The double for the new list cell.
Inserts an object into the collection. This overload will create a new dbiListCell, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim nIndex As Integer
Dim strText As String
Dim nNumber As Double

instance.Insert(nIndex, strText, nNumber)
C#
public void Insert(
   int nIndex,
   string strText,
   double nNumber
)

Parameters

nIndex
The zero-based index to insert the new dbiListCell before.
strText
The text of the new list cell.
nNumber
The double for the new list cell.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,String,DateTime) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Insert Method : Insert(Int32,String,DateTime) Method

nIndex
The zero-based index to insert the new dbiListCell before.
strText
The text of the new list cell.
dtDateTime
The datetime for the new list cell.
Inserts an object into the collection. This overload will create a new dbiListCell, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim nIndex As Integer
Dim strText As String
Dim dtDateTime As Date

instance.Insert(nIndex, strText, dtDateTime)
C#
public void Insert(
   int nIndex,
   string strText,
   DateTime dtDateTime
)

Parameters

nIndex
The zero-based index to insert the new dbiListCell before.
strText
The text of the new list cell.
dtDateTime
The datetime for the new list cell.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,dbiListCell) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class > Insert Method : Insert(Int32,dbiListCell) Method

nIndex
The zero-based index to insert the new dbiListCell before.
obj
The dbiListCell to add to insert.
Inserts an object into the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim nIndex As Integer
Dim obj As dbiListCell

instance.Insert(nIndex, obj)
C#
public new void Insert(
   int nIndex,
   dbiListCell obj
)

Parameters

nIndex
The zero-based index to insert the new dbiListCell before.
obj
The dbiListCell to add to insert.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : Remove Method

obj
The dbiListCell to remove from the collection.
Removes the first occurence of a specific object from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim obj As dbiListCell

instance.Remove(obj)
C#
public new void Remove(
   dbiListCell obj
)

Parameters

obj
The dbiListCell to remove from the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : RemoveAt Method

nIndex
The zero-based index to remove the object at.
Removes the object at the specified index of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim nIndex As Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   int nIndex
)

Parameters

nIndex
The zero-based index to remove the object at.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%% $$Properties$$

dbiListCellCollection Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCellCollection Class

"

For a list of all members of this type, see dbiListCellCollection members.

"

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

See Also

Reference

dbiListCellCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Item Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : Item Property

nIndex
Get or set a particular object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim nIndex As Integer
Dim value As dbiListCell

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiListCell this[
   int nIndex
]; {get; set;}

Parameters

nIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

dbiListItem Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItem Class

Provides the properties for defining items in the list

Object Model

dbiListItem ClassdbiListCellCollection ClassdbiListCell ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiListItemCollection ClassdbiListItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiListItem ClassdbiTimeBarCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
C#
public class dbiListItem : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiListItem

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiListItem Class Members
See Also Fields Properties Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItem Class

"

The following tables list the members exposed by dbiListItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiListItem Constructor | Overloaded. Initializes a new instance of the dbiListItem class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | CellsProperty | Identifies the DependencyProperty for the Cells Property
static (Shared in Visual Basic) | CustomAreasProperty | Identifies the DependencyProperty for the CustomAreas Property
static (Shared in Visual Basic) | ForegroundProperty | Identifies the DependencyProperty for the Foreground Property
static (Shared in Visual Basic) | HeaderProperty | Identifies the DependencyProperty for the Header Property
static (Shared in Visual Basic) | HorzStrokeProperty | Identifies the DependencyProperty for the HorzStroke Property
static (Shared in Visual Basic) | HorzStrokeThicknessProperty | Identifies the DependencyProperty for the HorzStrokeThickness Property
static (Shared in Visual Basic) | ItemsProperty | Identifies the DependencyProperty for the Items Property
static (Shared in Visual Basic) | MaxTimeBarsProperty | Identifies the DependencyProperty for the MaxTimeBars Property
static (Shared in Visual Basic) | NotesProperty | Identifies the DependencyProperty for the Notes Property
static (Shared in Visual Basic) | ReadOnlyProperty | Identifies the DependencyProperty for the ReadOnly Property
static (Shared in Visual Basic) | ScheduleBackgroundProperty | Identifies the DependencyProperty for the ScheduleBackground Property
static (Shared in Visual Basic) | ScheduleHorzStrokeProperty | Identifies the DependencyProperty for the ScheduleHorzStroke Property
static (Shared in Visual Basic) | ScheduleHorzStrokeThicknessProperty | Identifies the DependencyProperty for the ScheduleHorzStrokeThickness Property
static (Shared in Visual Basic) | SelectedProperty | Identifies the DependencyProperty for the Selected Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TimeBarsProperty | Identifies the DependencyProperty for the TimeBars Property
Top

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the list item.
public Property | Cells | Gets or sets the collection of list cells for the list item.
public Property | Collapsed | Determines if the list item is collapsed.
public Property | CustomAreas | Gets or sets the list of custom areas for the list item.
public Property | Foreground | Gets or sets the brush used to paint the foreground or text of the list item.
public Property | Header | Gets or sets whether a list item acts like a header.
public Property | HorzStroke | Gets or sets the brush used to paint a horizontal line at the bottom of the list item.
public Property | HorzStrokeThickness | Gets or sets the thickness of the brush used to paint a horizontal line at the bottom of the list item.
public Property | IsExpanded | Gets the state of the list item as to whether it is expanded or collapsed.
public Property | Items | Get the collection of child items for this parent item
public Property | MaxTimeBars | Gets or sets the maximum amount of time bars for a list item.
public Property | Notes | Gets or sets a collection of notes for the list item.
public Property | Parent | Gets the parent item of this list item.
public Property | ReadOnly | Gets or sets whether new time bars can be added to the list item with the mouse
public Property | ScheduleBackground | Gets or sets the brush used to paint the background of the schedule area of the list item.
public Property | ScheduleHorzStroke | Gets or sets the brush used to paint a horizontal line at the bottom of the list item in the schedule.
public Property | ScheduleHorzStrokeThickness | Gets or sets the thickness of the brush used to paint a horizontal line at the bottom of the list item in the schedule.
public Property | Selected | Gets or sets whether this list item is in a selected state.
public Property | Tag | Gets or sets the tag or object for the list item.
public Property | TimeBars | Gets or sets a collection of time bars for the list item.
Top

Public Methods

 | Name | Description
public Method | Collapse | Collapse the current item.
public Method | EnsureVisible | Expands all items related to the item
public Method | Expand | Expand the current item.
public Method | ExpandAll | Expands the item, and expands all layers of children beneath it.
public Method | ExpandParents | Make sure all parent items are expanded so that this list item can be made visible.
public Method | Toggle | Collapse or expand the current item.
Top

See Also

Reference

dbiListItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiListItem Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : dbiListItem Constructor

Initializes a new instance of the dbiListItem class.

Overload List

Overload | Description
dbiListItem Constructor() | Initializes a new instance of the dbiListItem class.
dbiListItem Constructor(String) | Initializes a new instance of the dbiListItem class.
dbiListItem Constructor(String,Double) | Initializes a new instance of the dbiListItem class.
dbiListItem Constructor(String,DateTime) | Initializes a new instance of the dbiListItem class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

dbiListItem Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class > dbiListItem Constructor : dbiListItem Constructor()

Initializes a new instance of the dbiListItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiListItem()
C#
public dbiListItem()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members
Overload List


%%PageItemTitle%%

dbiListItem Constructor(String)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class > dbiListItem Constructor : dbiListItem Constructor(String)

strText
The text value to assign to the first cell of the list item.
Initializes a new instance of the dbiListItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As New dbiListItem(strText)
C#
public dbiListItem(
   string strText
)

Parameters

strText
The text value to assign to the first cell of the list item.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members
Overload List


%%PageItemTitle%%

dbiListItem Constructor(String,Double)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class > dbiListItem Constructor : dbiListItem Constructor(String,Double)

strText
The text value to assign to the first cell of the list item.
nNumber
The double value to assign to the first cell in the list item
Initializes a new instance of the dbiListItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As String
Dim nNumber As Double

Dim instance As New dbiListItem(strText, nNumber)
C#
public dbiListItem(
   string strText,
   double nNumber
)

Parameters

strText
The text value to assign to the first cell of the list item.
nNumber
The double value to assign to the first cell in the list item

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members
Overload List


%%PageItemTitle%%

dbiListItem Constructor(String,DateTime)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class > dbiListItem Constructor : dbiListItem Constructor(String,DateTime)

strText
The text value to assign to the first cell of the list item.
dtDateTime
The datetime value to assign to the first cell in the list item
Initializes a new instance of the dbiListItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As String
Dim dtDateTime As Date

Dim instance As New dbiListItem(strText, dtDateTime)
C#
public dbiListItem(
   string strText,
   DateTime dtDateTime
)

Parameters

strText
The text value to assign to the first cell of the list item.
dtDateTime
The datetime value to assign to the first cell in the list item

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members
Overload List


%%PageItemTitle%% $$Methods$$

dbiListItem Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItem Class

"

For a list of all members of this type, see dbiListItem members.

"

Public Methods

 | Name | Description
public Method | Collapse | Collapse the current item.
public Method | EnsureVisible | Expands all items related to the item
public Method | Expand | Expand the current item.
public Method | ExpandAll | Expands the item, and expands all layers of children beneath it.
public Method | ExpandParents | Make sure all parent items are expanded so that this list item can be made visible.
public Method | Toggle | Collapse or expand the current item.
Top

See Also

Reference

dbiListItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Collapse Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Collapse Method

Collapse the current item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem

instance.Collapse()
C#
public void Collapse()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

EnsureVisible Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : EnsureVisible Method

Expands all items related to the item

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem

instance.EnsureVisible()
C#
public void EnsureVisible()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Expand Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Expand Method

Expand the current item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem

instance.Expand()
C#
public void Expand()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ExpandAll Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ExpandAll Method

Expands the item, and expands all layers of children beneath it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem

instance.ExpandAll()
C#
public void ExpandAll()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ExpandParents Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ExpandParents Method

Make sure all parent items are expanded so that this list item can be made visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem

instance.ExpandParents()
C#
public void ExpandParents()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Toggle Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Toggle Method

Collapse or expand the current item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem

instance.Toggle()
C#
public void Toggle()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%% $$Properties$$

dbiListItem Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItem Class

"

For a list of all members of this type, see dbiListItem members.

"

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the list item.
public Property | Cells | Gets or sets the collection of list cells for the list item.
public Property | Collapsed | Determines if the list item is collapsed.
public Property | CustomAreas | Gets or sets the list of custom areas for the list item.
public Property | Foreground | Gets or sets the brush used to paint the foreground or text of the list item.
public Property | Header | Gets or sets whether a list item acts like a header.
public Property | HorzStroke | Gets or sets the brush used to paint a horizontal line at the bottom of the list item.
public Property | HorzStrokeThickness | Gets or sets the thickness of the brush used to paint a horizontal line at the bottom of the list item.
public Property | IsExpanded | Gets the state of the list item as to whether it is expanded or collapsed.
public Property | Items | Get the collection of child items for this parent item
public Property | MaxTimeBars | Gets or sets the maximum amount of time bars for a list item.
public Property | Notes | Gets or sets a collection of notes for the list item.
public Property | Parent | Gets the parent item of this list item.
public Property | ReadOnly | Gets or sets whether new time bars can be added to the list item with the mouse
public Property | ScheduleBackground | Gets or sets the brush used to paint the background of the schedule area of the list item.
public Property | ScheduleHorzStroke | Gets or sets the brush used to paint a horizontal line at the bottom of the list item in the schedule.
public Property | ScheduleHorzStrokeThickness | Gets or sets the thickness of the brush used to paint a horizontal line at the bottom of the list item in the schedule.
public Property | Selected | Gets or sets whether this list item is in a selected state.
public Property | Tag | Gets or sets the tag or object for the list item.
public Property | TimeBars | Gets or sets a collection of time bars for the list item.
Top

See Also

Reference

dbiListItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Background Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Background Property

Gets or sets the brush used to paint the background of the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Brush

instance.Background = value

value = instance.Background
C#
public Brush Background {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Cells Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Cells Property

Gets or sets the collection of list cells for the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As dbiListCellCollection

instance.Cells = value

value = instance.Cells
C#
public dbiListCellCollection Cells {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Collapsed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Collapsed Property

Determines if the list item is collapsed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Boolean

instance.Collapsed = value

value = instance.Collapsed
C#
public bool Collapsed {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

CustomAreas Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : CustomAreas Property

Gets or sets the list of custom areas for the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As dbiCustomAreaCollection

instance.CustomAreas = value

value = instance.CustomAreas
C#
public dbiCustomAreaCollection CustomAreas {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Foreground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Foreground Property

Gets or sets the brush used to paint the foreground or text of the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Brush

instance.Foreground = value

value = instance.Foreground
C#
public Brush Foreground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Header Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Header Property

Gets or sets whether a list item acts like a header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Boolean

instance.Header = value

value = instance.Header
C#
public bool Header {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

HorzStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : HorzStroke Property

Gets or sets the brush used to paint a horizontal line at the bottom of the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Brush

instance.HorzStroke = value

value = instance.HorzStroke
C#
public Brush HorzStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

HorzStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : HorzStrokeThickness Property

Gets or sets the thickness of the brush used to paint a horizontal line at the bottom of the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Double

instance.HorzStrokeThickness = value

value = instance.HorzStrokeThickness
C#
public double HorzStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

IsExpanded Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : IsExpanded Property

Gets the state of the list item as to whether it is expanded or collapsed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Boolean

value = instance.IsExpanded
C#
public bool IsExpanded {get;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Items Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Items Property

Get the collection of child items for this parent item

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As dbiListItemCollection

instance.Items = value

value = instance.Items
C#
public dbiListItemCollection Items {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

MaxTimeBars Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : MaxTimeBars Property

Gets or sets the maximum amount of time bars for a list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Integer

instance.MaxTimeBars = value

value = instance.MaxTimeBars
C#
public int MaxTimeBars {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Notes Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Notes Property

Gets or sets a collection of notes for the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As dbiScheduleNoteCollection

instance.Notes = value

value = instance.Notes
C#
public dbiScheduleNoteCollection Notes {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Parent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Parent Property

Gets the parent item of this list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As dbiListItem

value = instance.Parent
C#
public dbiListItem Parent {get;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ReadOnly Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ReadOnly Property

Gets or sets whether new time bars can be added to the list item with the mouse

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public bool ReadOnly {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ScheduleBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ScheduleBackground Property

Gets or sets the brush used to paint the background of the schedule area of the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Brush

instance.ScheduleBackground = value

value = instance.ScheduleBackground
C#
public Brush ScheduleBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ScheduleHorzStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ScheduleHorzStroke Property

Gets or sets the brush used to paint a horizontal line at the bottom of the list item in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Brush

instance.ScheduleHorzStroke = value

value = instance.ScheduleHorzStroke
C#
public Brush ScheduleHorzStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ScheduleHorzStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ScheduleHorzStrokeThickness Property

Gets or sets the thickness of the brush used to paint a horizontal line at the bottom of the list item in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Double

instance.ScheduleHorzStrokeThickness = value

value = instance.ScheduleHorzStrokeThickness
C#
public double ScheduleHorzStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Selected Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Selected Property

Gets or sets whether this list item is in a selected state.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Boolean

instance.Selected = value

value = instance.Selected
C#
public bool Selected {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Tag Property

Gets or sets the tag or object for the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
public object Tag {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

TimeBars Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : TimeBars Property

Gets or sets a collection of time bars for the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As dbiTimeBarCollection

instance.TimeBars = value

value = instance.TimeBars
C#
public dbiTimeBarCollection TimeBars {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%% $$Fields$$

dbiListItem Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItem Class

"

For a list of all members of this type, see dbiListItem members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | CellsProperty | Identifies the DependencyProperty for the Cells Property
static (Shared in Visual Basic) | CustomAreasProperty | Identifies the DependencyProperty for the CustomAreas Property
static (Shared in Visual Basic) | ForegroundProperty | Identifies the DependencyProperty for the Foreground Property
static (Shared in Visual Basic) | HeaderProperty | Identifies the DependencyProperty for the Header Property
static (Shared in Visual Basic) | HorzStrokeProperty | Identifies the DependencyProperty for the HorzStroke Property
static (Shared in Visual Basic) | HorzStrokeThicknessProperty | Identifies the DependencyProperty for the HorzStrokeThickness Property
static (Shared in Visual Basic) | ItemsProperty | Identifies the DependencyProperty for the Items Property
static (Shared in Visual Basic) | MaxTimeBarsProperty | Identifies the DependencyProperty for the MaxTimeBars Property
static (Shared in Visual Basic) | NotesProperty | Identifies the DependencyProperty for the Notes Property
static (Shared in Visual Basic) | ReadOnlyProperty | Identifies the DependencyProperty for the ReadOnly Property
static (Shared in Visual Basic) | ScheduleBackgroundProperty | Identifies the DependencyProperty for the ScheduleBackground Property
static (Shared in Visual Basic) | ScheduleHorzStrokeProperty | Identifies the DependencyProperty for the ScheduleHorzStroke Property
static (Shared in Visual Basic) | ScheduleHorzStrokeThicknessProperty | Identifies the DependencyProperty for the ScheduleHorzStrokeThickness Property
static (Shared in Visual Basic) | SelectedProperty | Identifies the DependencyProperty for the Selected Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TimeBarsProperty | Identifies the DependencyProperty for the TimeBars Property
Top

See Also

Reference

dbiListItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : BackgroundProperty Field

Identifies the DependencyProperty for the Background Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.BackgroundProperty
C#
public static readonly DependencyProperty BackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

CellsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : CellsProperty Field

Identifies the DependencyProperty for the Cells Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.CellsProperty
C#
public static readonly DependencyProperty CellsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

CustomAreasProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : CustomAreasProperty Field

Identifies the DependencyProperty for the CustomAreas Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.CustomAreasProperty
C#
public static readonly DependencyProperty CustomAreasProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ForegroundProperty Field

Identifies the DependencyProperty for the Foreground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.ForegroundProperty
C#
public static readonly DependencyProperty ForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

HeaderProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : HeaderProperty Field

Identifies the DependencyProperty for the Header Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.HeaderProperty
C#
public static readonly DependencyProperty HeaderProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

HorzStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : HorzStrokeProperty Field

Identifies the DependencyProperty for the HorzStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.HorzStrokeProperty
C#
public static readonly DependencyProperty HorzStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

HorzStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : HorzStrokeThicknessProperty Field

Identifies the DependencyProperty for the HorzStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.HorzStrokeThicknessProperty
C#
public static readonly DependencyProperty HorzStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ItemsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ItemsProperty Field

Identifies the DependencyProperty for the Items Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.ItemsProperty
C#
public static readonly DependencyProperty ItemsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

MaxTimeBarsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : MaxTimeBarsProperty Field

Identifies the DependencyProperty for the MaxTimeBars Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.MaxTimeBarsProperty
C#
public static readonly DependencyProperty MaxTimeBarsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

NotesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : NotesProperty Field

Identifies the DependencyProperty for the Notes Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.NotesProperty
C#
public static readonly DependencyProperty NotesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ReadOnlyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ReadOnlyProperty Field

Identifies the DependencyProperty for the ReadOnly Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.ReadOnlyProperty
C#
public static readonly DependencyProperty ReadOnlyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ScheduleBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ScheduleBackgroundProperty Field

Identifies the DependencyProperty for the ScheduleBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.ScheduleBackgroundProperty
C#
public static readonly DependencyProperty ScheduleBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ScheduleHorzStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ScheduleHorzStrokeProperty Field

Identifies the DependencyProperty for the ScheduleHorzStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.ScheduleHorzStrokeProperty
C#
public static readonly DependencyProperty ScheduleHorzStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ScheduleHorzStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ScheduleHorzStrokeThicknessProperty Field

Identifies the DependencyProperty for the ScheduleHorzStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.ScheduleHorzStrokeThicknessProperty
C#
public static readonly DependencyProperty ScheduleHorzStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

SelectedProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : SelectedProperty Field

Identifies the DependencyProperty for the Selected Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.SelectedProperty
C#
public static readonly DependencyProperty SelectedProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

TagProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : TagProperty Field

Identifies the DependencyProperty for the Tag Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.TagProperty
C#
public static readonly DependencyProperty TagProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

TimeBarsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : TimeBarsProperty Field

Identifies the DependencyProperty for the TimeBars Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiListItem.TimeBarsProperty
C#
public static readonly DependencyProperty TimeBarsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

dbiListItemCollection Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItemCollection Class

The collection of list items

Object Model

dbiListItemCollection ClassdbiListItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
C#
[DefaultMemberAttribute("Item")]
public class dbiListItemCollection : System.Collections.ObjectModel.ObservableCollection<dbiListItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiListItemCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiListItemCollection Class Members
See Also Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItemCollection Class

"

The following tables list the members exposed by dbiListItemCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiListItemCollection Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection.
public Method | ItemCount | Overloaded. Gets a count of all items, and their sub items, in the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
public Method | Sort | sorts the items in the collection
public Method | VisibleItemCount | Gets the number of visible items in the current collection, and all sub items of the items contained in it.
Top

See Also

Reference

dbiListItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiListItemCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : dbiListItemCollection Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiListItemCollection()
C#
public dbiListItemCollection()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%% $$Methods$$

dbiListItemCollection Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItemCollection Class

"

For a list of all members of this type, see dbiListItemCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection.
public Method | ItemCount | Overloaded. Gets a count of all items, and their sub items, in the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
public Method | Sort | sorts the items in the collection
public Method | VisibleItemCount | Gets the number of visible items in the current collection, and all sub items of the items contained in it.
Top

See Also

Reference

dbiListItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Add Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : Add Method

Adds an object to the end of the collection

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(String) | Adds an object to the end of the collection. This overload will create a new dbiListItem, based on the supplied parameter, and add it to the collection.
Add(String,Double) | Adds an object to the end of the collection. This overload will create a new dbiListItem, based on the supplied parameters, and add it to the collection.
Add(String,DateTime) | Adds an object to the end of the collection. This overload will create a new dbiListItem, based on the supplied parameters, and add it to the collection.
Add(dbiListItem) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

Add() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection

instance.Add()
C#
public void Add()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

Add(String) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > Add Method : Add(String) Method

strText
The text value to assign to the first cell of the list item.
Adds an object to the end of the collection. This overload will create a new dbiListItem, based on the supplied parameter, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim strText As String

instance.Add(strText)
C#
public void Add(
   string strText
)

Parameters

strText
The text value to assign to the first cell of the list item.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

Add(String,Double) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > Add Method : Add(String,Double) Method

strText
The text value to assign to the first cell of the list item.
nNumber
The double value to assign to the first cell in the list item
Adds an object to the end of the collection. This overload will create a new dbiListItem, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim strText As String
Dim nNumber As Double

instance.Add(strText, nNumber)
C#
public void Add(
   string strText,
   double nNumber
)

Parameters

strText
The text value to assign to the first cell of the list item.
nNumber
The double value to assign to the first cell in the list item

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

Add(String,DateTime) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > Add Method : Add(String,DateTime) Method

strText
The text value to assign to the first cell of the list item.
dtDateTime
The datetime value to assign to the first cell in the list item
Adds an object to the end of the collection. This overload will create a new dbiListItem, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim strText As String
Dim dtDateTime As Date

instance.Add(strText, dtDateTime)
C#
public void Add(
   string strText,
   DateTime dtDateTime
)

Parameters

strText
The text value to assign to the first cell of the list item.
dtDateTime
The datetime value to assign to the first cell in the list item

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

Add(dbiListItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > Add Method : Add(dbiListItem) Method

obj
The dbiListItem to add to the end of the collection.
Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim obj As dbiListItem

instance.Add(obj)
C#
public new void Add(
   dbiListItem obj
)

Parameters

obj
The dbiListItem to add to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : IndexOf Method

obj
The dbiListItem to find the index value for.
Gets the 0 based index of the first occurence of an object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim obj As dbiListItem
Dim value As Integer

value = instance.IndexOf(obj)
C#
public new int IndexOf(
   dbiListItem obj
)

Parameters

obj
The dbiListItem to find the index value for.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : Insert Method

Inserts an object into the collection.

Overload List

Overload | Description
Insert(Int32,String) | Inserts an object into the collection. This overload will create a new dbiListItem, based on the supplied parameter, and insert it in to the collection.
Insert(Int32,String,Double) | Inserts an object into the collection. This overload will create a new dbiListItem, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,String,DateTime) | Inserts an object into the collection. This overload will create a new dbiListItem, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,dbiListItem) | Inserts an object into the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

Insert(Int32,String) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > Insert Method : Insert(Int32,String) Method

nIndex
The zero-based index to insert the new dbiListItem before.
strText
The text value to assign to the first cell of the list item.
Inserts an object into the collection. This overload will create a new dbiListItem, based on the supplied parameter, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim nIndex As Integer
Dim strText As String

instance.Insert(nIndex, strText)
C#
public void Insert(
   int nIndex,
   string strText
)

Parameters

nIndex
The zero-based index to insert the new dbiListItem before.
strText
The text value to assign to the first cell of the list item.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,String,Double) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > Insert Method : Insert(Int32,String,Double) Method

nIndex
The zero-based index to insert the new dbiListItem before.
strText
The text value to assign to the first cell of the list item.
nNumber
The double value to assign to the first cell in the list item
Inserts an object into the collection. This overload will create a new dbiListItem, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim nIndex As Integer
Dim strText As String
Dim nNumber As Double

instance.Insert(nIndex, strText, nNumber)
C#
public void Insert(
   int nIndex,
   string strText,
   double nNumber
)

Parameters

nIndex
The zero-based index to insert the new dbiListItem before.
strText
The text value to assign to the first cell of the list item.
nNumber
The double value to assign to the first cell in the list item

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,String,DateTime) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > Insert Method : Insert(Int32,String,DateTime) Method

nIndex
The zero-based index to insert the new dbiListItem before.
strText
The text value to assign to the first cell of the list item.
dtDateTime
The datetime value to assign to the first cell in the list item
Inserts an object into the collection. This overload will create a new dbiListItem, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim nIndex As Integer
Dim strText As String
Dim dtDateTime As Date

instance.Insert(nIndex, strText, dtDateTime)
C#
public void Insert(
   int nIndex,
   string strText,
   DateTime dtDateTime
)

Parameters

nIndex
The zero-based index to insert the new dbiListItem before.
strText
The text value to assign to the first cell of the list item.
dtDateTime
The datetime value to assign to the first cell in the list item

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,dbiListItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > Insert Method : Insert(Int32,dbiListItem) Method

nIndex
The zero-based index to insert the new dbiListItem before.
obj
The dbiListItem to insert.
Inserts an object into the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim nIndex As Integer
Dim obj As dbiListItem

instance.Insert(nIndex, obj)
C#
public new void Insert(
   int nIndex,
   dbiListItem obj
)

Parameters

nIndex
The zero-based index to insert the new dbiListItem before.
obj
The dbiListItem to insert.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

ItemCount Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : ItemCount Method

Gets a count of all items, and their sub items, in the collection.

Overload List

Overload | Description
ItemCount() | Gets a count of all items, and their sub items, in the collection.
ItemCount(Boolean) | Gets a count of all items, and their sub items, in the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

ItemCount() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > ItemCount Method : ItemCount() Method

Gets a count of all items, and their sub items, in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim value As Integer

value = instance.ItemCount()
C#
public int ItemCount()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

ItemCount(Boolean) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class > ItemCount Method : ItemCount(Boolean) Method

bIncludeSubItems
Determines if sub-items should be counted as well.
Gets a count of all items, and their sub items, in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim bIncludeSubItems As Boolean
Dim value As Integer

value = instance.ItemCount(bIncludeSubItems)
C#
public int ItemCount(
   bool bIncludeSubItems
)

Parameters

bIncludeSubItems
Determines if sub-items should be counted as well.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : Remove Method

obj
The dbiListItem to remove.
Removes the first occurence of a specific object from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim obj As dbiListItem

instance.Remove(obj)
C#
public new void Remove(
   dbiListItem obj
)

Parameters

obj
The dbiListItem to remove.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : RemoveAt Method

nIndex
The zero-based index to remove the object at.
Removes the object at the specified index of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim nIndex As Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   int nIndex
)

Parameters

nIndex
The zero-based index to remove the object at.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

Sort Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : Sort Method

bAscending
Determines if the sort is in ascending order or not.
nColumn
The zero-based index of the column to sort on
bCheckCase
Determines if character case is to be considered in the sort
objParent
The dbiScheduleWPF control the collection resides in.
sorts the items in the collection

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim bAscending As Boolean
Dim nColumn As Integer
Dim bCheckCase As Boolean
Dim objParent As dbiScheduleWPF

instance.Sort(bAscending, nColumn, bCheckCase, objParent)
C#
public void Sort(
   bool bAscending,
   int nColumn,
   bool bCheckCase,
   dbiScheduleWPF objParent
)

Parameters

bAscending
Determines if the sort is in ascending order or not.
nColumn
The zero-based index of the column to sort on
bCheckCase
Determines if character case is to be considered in the sort
objParent
The dbiScheduleWPF control the collection resides in.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

VisibleItemCount Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : VisibleItemCount Method

Gets the number of visible items in the current collection, and all sub items of the items contained in it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim value As Integer

value = instance.VisibleItemCount()
C#
public int VisibleItemCount()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%% $$Properties$$

dbiListItemCollection Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItemCollection Class

"

For a list of all members of this type, see dbiListItemCollection members.

"

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

See Also

Reference

dbiListItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Item Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : Item Property

nIndex
The zero-based index of the object in the collection.
Get or set a particular object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim nIndex As Integer
Dim value As dbiListItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiListItem this[
   int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the object in the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

dbiScheduleNote Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNote Class

Provides properties for defining a schedule note

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
C#
public class dbiScheduleNote : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiScheduleNote

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiScheduleNote Class Members
See Also Fields Properties Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNote Class

"

The following tables list the members exposed by dbiScheduleNote.

"

Public Constructors

 | Name | Description
public Constructor | dbiScheduleNote Constructor | Overloaded. Initializes a new instance of the dbiScheduleNote class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ImageAlignmentProperty | Identifies the DependencyProperty for the ImageAlignment Property
static (Shared in Visual Basic) | ImageIndexProperty | Identifies the DependencyProperty for the ImageIndex Property
static (Shared in Visual Basic) | ImageOffsetProperty | Identifies the DependencyProperty for the ImageOffset Property
static (Shared in Visual Basic) | LockedProperty | Identifies the DependencyProperty for the Locked Property
static (Shared in Visual Basic) | NoteTimeProperty | Identifies the DependencyProperty for the NoteTime Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TextProperty | Identifies the DependencyProperty for the Text Property
Top

Public Properties

 | Name | Description
public Property | ImageAlignment | Gets or sets the alignment used to calculate the position of a schedule note image.
public Property | ImageIndex | Gets or sets the index from the image list for the schedule note image.
public Property | ImageOffset | Gets or sets the vertical and horizontal offset used to calculate the position of a schedule note image.
public Property | Locked | Determines if the note is locked onto the schedule.
public Property | NoteTime | Gets or sets the DateTime for the note.
public Property | Tag | Gets or sets a tag or object for the object.
public Property | Text | Gets or sets the main text for the note item.
Top

See Also

Reference

dbiScheduleNote Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleNote Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : dbiScheduleNote Constructor

Initializes a new instance of the dbiScheduleNote class.

Overload List

Overload | Description
dbiScheduleNote Constructor() | Initializes a new instance of the dbiScheduleNote class.
dbiScheduleNote Constructor(String,DateTime) | Initializes a new instance of the dbiScheduleNote class.
dbiScheduleNote Constructor(dbiScheduleNote) | Initializes a new instance of the dbiScheduleNote class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

dbiScheduleNote Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class > dbiScheduleNote Constructor : dbiScheduleNote Constructor()

Initializes a new instance of the dbiScheduleNote class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleNote()
C#
public dbiScheduleNote()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

dbiScheduleNote Constructor(String,DateTime)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class > dbiScheduleNote Constructor : dbiScheduleNote Constructor(String,DateTime)

strText
The text value to assign to the new schedule note
dtTime
The datetime value to assign to the new schedule note
Initializes a new instance of the dbiScheduleNote class.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As String
Dim dtTime As Date

Dim instance As New dbiScheduleNote(strText, dtTime)
C#
public dbiScheduleNote(
   string strText,
   DateTime dtTime
)

Parameters

strText
The text value to assign to the new schedule note
dtTime
The datetime value to assign to the new schedule note

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

dbiScheduleNote Constructor(dbiScheduleNote)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class > dbiScheduleNote Constructor : dbiScheduleNote Constructor(dbiScheduleNote)

objNote
The dbiScheduleNote to copy property values from
Initializes a new instance of the dbiScheduleNote class.

Syntax

Visual Basic (Usage) Copy Code
Dim objNote As dbiScheduleNote

Dim instance As New dbiScheduleNote(objNote)
C#
public dbiScheduleNote(
   dbiScheduleNote objNote
)

Parameters

objNote
The dbiScheduleNote to copy property values from

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%% $$Properties$$

dbiScheduleNote Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNote Class

"

For a list of all members of this type, see dbiScheduleNote members.

"

Public Properties

 | Name | Description
public Property | ImageAlignment | Gets or sets the alignment used to calculate the position of a schedule note image.
public Property | ImageIndex | Gets or sets the index from the image list for the schedule note image.
public Property | ImageOffset | Gets or sets the vertical and horizontal offset used to calculate the position of a schedule note image.
public Property | Locked | Determines if the note is locked onto the schedule.
public Property | NoteTime | Gets or sets the DateTime for the note.
public Property | Tag | Gets or sets a tag or object for the object.
public Property | Text | Gets or sets the main text for the note item.
Top

See Also

Reference

dbiScheduleNote Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ImageAlignment Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : ImageAlignment Property

Gets or sets the alignment used to calculate the position of a schedule note image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As enumImageAlignment

instance.ImageAlignment = value

value = instance.ImageAlignment
C#
public enumImageAlignment ImageAlignment {get; set;}

Remarks

This property is used to determine the alignment when the Locked property is True.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ImageIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : ImageIndex Property

Gets or sets the index from the image list for the schedule note image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public virtual int ImageIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ImageOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : ImageOffset Property

Gets or sets the vertical and horizontal offset used to calculate the position of a schedule note image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As Point

instance.ImageOffset = value

value = instance.ImageOffset
C#
public Point ImageOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

Locked Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : Locked Property

Determines if the note is locked onto the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As Boolean

instance.Locked = value

value = instance.Locked
C#
public bool Locked {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

NoteTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : NoteTime Property

Gets or sets the DateTime for the note.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As Date

instance.NoteTime = value

value = instance.NoteTime
C#
[TypeConverterAttribute("., dbiScheduleWPF, Version=2.5.0.0, Culture=neutral, PublicKeyToken=0e75c9c0bb3bd0d4")]
public virtual DateTime NoteTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : Tag Property

Gets or sets a tag or object for the object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
public object Tag {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : Text Property

Gets or sets the main text for the note item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%% $$Fields$$

dbiScheduleNote Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNote Class

"

For a list of all members of this type, see dbiScheduleNote members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ImageAlignmentProperty | Identifies the DependencyProperty for the ImageAlignment Property
static (Shared in Visual Basic) | ImageIndexProperty | Identifies the DependencyProperty for the ImageIndex Property
static (Shared in Visual Basic) | ImageOffsetProperty | Identifies the DependencyProperty for the ImageOffset Property
static (Shared in Visual Basic) | LockedProperty | Identifies the DependencyProperty for the Locked Property
static (Shared in Visual Basic) | NoteTimeProperty | Identifies the DependencyProperty for the NoteTime Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TextProperty | Identifies the DependencyProperty for the Text Property
Top

See Also

Reference

dbiScheduleNote Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ImageAlignmentProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : ImageAlignmentProperty Field

Identifies the DependencyProperty for the ImageAlignment Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleNote.ImageAlignmentProperty
C#
public static readonly DependencyProperty ImageAlignmentProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ImageIndexProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : ImageIndexProperty Field

Identifies the DependencyProperty for the ImageIndex Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleNote.ImageIndexProperty
C#
public static readonly DependencyProperty ImageIndexProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ImageOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : ImageOffsetProperty Field

Identifies the DependencyProperty for the ImageOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleNote.ImageOffsetProperty
C#
public static readonly DependencyProperty ImageOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

LockedProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : LockedProperty Field

Identifies the DependencyProperty for the Locked Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleNote.LockedProperty
C#
public static readonly DependencyProperty LockedProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

NoteTimeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : NoteTimeProperty Field

Identifies the DependencyProperty for the NoteTime Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleNote.NoteTimeProperty
C#
public static readonly DependencyProperty NoteTimeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

TagProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : TagProperty Field

Identifies the DependencyProperty for the Tag Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleNote.TagProperty
C#
public static readonly DependencyProperty TagProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

TextProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : TextProperty Field

Identifies the DependencyProperty for the Text Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleNote.TextProperty
C#
public static readonly DependencyProperty TextProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

dbiScheduleNoteCollection Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNoteCollection Class

The collection of schedule notes

Object Model

dbiScheduleNoteCollection ClassdbiScheduleNote Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
C#
[DefaultMemberAttribute("Item")]
public class dbiScheduleNoteCollection : System.Collections.ObjectModel.ObservableCollection<dbiScheduleNote>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiScheduleNoteCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiScheduleNoteCollection Class Members
See Also Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNoteCollection Class

"

The following tables list the members exposed by dbiScheduleNoteCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiScheduleNoteCollection Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection.
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiScheduleNoteCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleNoteCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : dbiScheduleNoteCollection Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleNoteCollection()
C#
public dbiScheduleNoteCollection()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%% $$Methods$$

dbiScheduleNoteCollection Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNoteCollection Class

"

For a list of all members of this type, see dbiScheduleNoteCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection.
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Overloaded. Inserts an object into the collection
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiScheduleNoteCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Add Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : Add Method

Adds an object to the end of the collection.

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(String,DateTime) | Adds an object to the end of the collection. This overload will create a new dbiScheduleNote, based on the supplied parameters, and add it to the collection.
Add(dbiScheduleNote) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Add() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection

instance.Add()
C#
public void Add()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members
Overload List


%%PageItemTitle%%

Add(String,DateTime) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class > Add Method : Add(String,DateTime) Method

strText
The text value to assign to the new schedule note
dtTime
The datetime value to assign to the new schedule note
Adds an object to the end of the collection. This overload will create a new dbiScheduleNote, based on the supplied parameters, and add it to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim strText As String
Dim dtTime As Date

instance.Add(strText, dtTime)
C#
public void Add(
   string strText,
   DateTime dtTime
)

Parameters

strText
The text value to assign to the new schedule note
dtTime
The datetime value to assign to the new schedule note

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members
Overload List


%%PageItemTitle%%

Add(dbiScheduleNote) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class > Add Method : Add(dbiScheduleNote) Method

obj
The dbiScheduleNote to add to the collection.
Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim obj As dbiScheduleNote

instance.Add(obj)
C#
public new void Add(
   dbiScheduleNote obj
)

Parameters

obj
The dbiScheduleNote to add to the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : IndexOf Method

obj
The dbiScheduleNote to find the index of.
Gets the 0 based index of the first occurence of an object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim obj As dbiScheduleNote
Dim value As Integer

value = instance.IndexOf(obj)
C#
public new int IndexOf(
   dbiScheduleNote obj
)

Parameters

obj
The dbiScheduleNote to find the index of.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : Insert Method

Inserts an object into the collection

Overload List

Overload | Description
Insert(Int32,String,DateTime) | Inserts an object into the collection. This overload will create a new dbiScheduleNote, based on the supplied parameters, and insert it in to the collection.
Insert(Int32,dbiScheduleNote) | Inserts an object into the collection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Insert(Int32,String,DateTime) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class > Insert Method : Insert(Int32,String,DateTime) Method

nIndex
The zero-based index to insert the new dbiScheduleNote before.
strText
The text value to assign to the new schedule note
dtTime
The datetime value to assign to the new schedule note
Inserts an object into the collection. This overload will create a new dbiScheduleNote, based on the supplied parameters, and insert it in to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim nIndex As Integer
Dim strText As String
Dim dtTime As Date

instance.Insert(nIndex, strText, dtTime)
C#
public void Insert(
   int nIndex,
   string strText,
   DateTime dtTime
)

Parameters

nIndex
The zero-based index to insert the new dbiScheduleNote before.
strText
The text value to assign to the new schedule note
dtTime
The datetime value to assign to the new schedule note

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,dbiScheduleNote) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class > Insert Method : Insert(Int32,dbiScheduleNote) Method

nIndex
The zero-based index to insert the new dbiScheduleNote before.
obj
The dbiScheduleNote to insert.
Inserts an object into the collection

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim nIndex As Integer
Dim obj As dbiScheduleNote

instance.Insert(nIndex, obj)
C#
public new void Insert(
   int nIndex,
   dbiScheduleNote obj
)

Parameters

nIndex
The zero-based index to insert the new dbiScheduleNote before.
obj
The dbiScheduleNote to insert.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members
Overload List


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : Remove Method

obj
The dbiScheduleNote to remove.
Removes the first occurence of a specific object from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim obj As dbiScheduleNote

instance.Remove(obj)
C#
public new void Remove(
   dbiScheduleNote obj
)

Parameters

obj
The dbiScheduleNote to remove.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : RemoveAt Method

nIndex
The zero-based index to remove the object at.
Removes the object at the specified index of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim nIndex As Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   int nIndex
)

Parameters

nIndex
The zero-based index to remove the object at.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%% $$Properties$$

dbiScheduleNoteCollection Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNoteCollection Class

"

For a list of all members of this type, see dbiScheduleNoteCollection members.

"

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

See Also

Reference

dbiScheduleNoteCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Item Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : Item Property

nIndex
The zero-based index of the object in the collection.
Get or set a particular object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim nIndex As Integer
Dim value As dbiScheduleNote

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiScheduleNote this[
   int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the object in the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

dbiScheduleObject Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObject Class

Provides properties for defining schedules

Object Model

dbiScheduleObject ClassdbiGuideLine ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
C#
public class dbiScheduleObject : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiScheduleObject

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiScheduleObject Class Members
See Also Fields Properties Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObject Class

"

The following tables list the members exposed by dbiScheduleObject.

"

Public Constructors

 | Name | Description
public Constructor | dbiScheduleObject Constructor | Overloaded. Initializes a new instance of the dbiScheduleObject class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AlternateBrushesProperty | Identifies the DependencyProperty for the AlternateBrushes Property
static (Shared in Visual Basic) | AlternateItemsProperty | Identifies the DependencyProperty for the AlternateItems Property
static (Shared in Visual Basic) | AltEvenBackgroundProperty | Identifies the DependencyProperty for the AltEvenBackground Property
static (Shared in Visual Basic) | AltOddBackgroundProperty | Identifies the DependencyProperty for the AltOddBackground Property
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | DateFormatProperty | Identifies the DependencyProperty for the DateFormat Property
static (Shared in Visual Basic) | DayLengthProperty | Identifies the DependencyProperty for the DayLength Property
static (Shared in Visual Basic) | DisplayDaysProperty | Identifies the DependencyProperty for the DisplayDays Property
static (Shared in Visual Basic) | DisplayTimeBarDatesProperty | Identifies the DependencyProperty for the DisplayTimeBarDates Property
static (Shared in Visual Basic) | DisplayTimeLinesProperty | Identifies the DependencyProperty for the DisplayTimeLines Property
static (Shared in Visual Basic) | EndProperty | Identifies the DependencyProperty for the End Property
static (Shared in Visual Basic) | FirstDayOfWeekProperty | Identifies the DependencyProperty for the FirstDayOfWeek Property
static (Shared in Visual Basic) | GuideLinesProperty | Identifies the DependencyProperty for the GuideLines Property
static (Shared in Visual Basic) | HeaderBackgroundProperty | Identifies the DependencyProperty for the HeaderBackground Property
static (Shared in Visual Basic) | LineMaxSizeProperty | Identifies the DependencyProperty for the LineMaxSize Property
static (Shared in Visual Basic) | LineMinSizeProperty | Identifies the DependencyProperty for the LineMinSize Property
static (Shared in Visual Basic) | MajorTimeLineProperty | Identifies the DependencyProperty for the MajorTimeLine Property
static (Shared in Visual Basic) | MonthFormatProperty | Identifies the DependencyProperty for the MonthFormat Property
static (Shared in Visual Basic) | RulerAlignProperty | Identifies the DependencyProperty for the RulerAlign Property
static (Shared in Visual Basic) | RulerBackgroundProperty | Identifies the DependencyProperty for the RulerBackground Property
static (Shared in Visual Basic) | RulerDivisionsProperty | Identifies the DependencyProperty for the RulerDivisions Property
static (Shared in Visual Basic) | RulerForegroundProperty | Identifies the DependencyProperty for the RulerForeground Property
static (Shared in Visual Basic) | RulerLineStrokeProperty | Identifies the DependencyProperty for the RulerLineStroke Property
static (Shared in Visual Basic) | RulerOffsetProperty | Identifies the DependencyProperty for the RulerOffset Property
static (Shared in Visual Basic) | RulerSplitProperty | Identifies the DependencyProperty for the RulerSplit Property
static (Shared in Visual Basic) | RulerTitleProperty | Identifies the DependencyProperty for the RulerTitle Property
static (Shared in Visual Basic) | StartProperty | Identifies the DependencyProperty for the Start Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TimeFormatProperty | Identifies the DependencyProperty for the TimeFormat Property
static (Shared in Visual Basic) | TimeLineBreakProperty | Identifies the DependencyProperty for the TimeLineBreak Property
static (Shared in Visual Basic) | TimeLineStartProperty | Identifies the DependencyProperty for the TimeLineStart Property
static (Shared in Visual Basic) | TimeLineStrokeProperty | Identifies the DependencyProperty for the TimeLineStroke Property
static (Shared in Visual Basic) | TimeLineStrokeThicknessProperty | Identifies the DependencyProperty for the TimeLineStrokeThickness Property
static (Shared in Visual Basic) | TimeTypeProperty | Identifies the DependencyProperty for the TimeType Property
static (Shared in Visual Basic) | WeekendBackgroundProperty | Identifies the DependencyProperty for the WeekendBackground Property
static (Shared in Visual Basic) | YearFormatProperty | Identifies the DependencyProperty for the YearFormat Property
Top

Public Properties

 | Name | Description
public Property | AlternateBrushes | Gets or sets whether alternating brushes will be used in the schedule lines.
public Property | AlternateItems | Gets or sets the amount of lines to color with the odd or even colors before the other color is used.
public Property | AltEvenBackground | Gets or sets one of the alternating line colors for a schedule line.
public Property | AltOddBackground | Gets or sets one of the alternating line colors for a schedule line.
public Property | Background | Gets or sets the brush used to paint the background of the schedule area
public Property | Breaks | Gets the number of breaks or time segments in the schedule.
public Property | DateFormat | Gets or sets how the date strings will appear in the time rulers.
public Property | DayLength | Gets or sets the amount of characters used when drawing the day names in the ruler.
public Property | DisplayDays | Gets or sets whether day values will be placed in a daily ruler along with the days of the month.
public Property | DisplayTimeBarDates | Gets or sets whether the time bar dates will be displayed in the time bars
public Property | DisplayTimeLines | Gets or sets whether time lines will be drawn in the schedule.
public Property | End | Gets or sets the ending time and date for the schedule.
public Property | FirstDayOfWeek | Gets or sets the first day of a week.
public Property | GuideLine | Gets or sets the temporary guide lines in the control.
public Property | GuideLines | Gets or sets the collection of GuideLines in the schedule
public Property | HeaderBackground | Gets or sets the brush used to paint the background of list items marked as headers in the list.
public Property | HorzScrollValue | Gets or sets the current horizontal scroll value representing the schedule view.
public Property | LineMaxSize | Gets or sets the height of the lines marking major time segments within the ruler.
public Property | LineMinSize | Gets or sets the height of the lines marking minor time segments within the ruler.
public Property | MajorTimeLine | Gets or sets whether a full vertical line will be drawn at major time segments in the ruler.
public Property | MonthFormat | Gets or sets how the dates in a monthly defined ruler will be displayed.
public Property | RulerAlign | Gets or sets the alignment for the text within the ruler.
public Property | RulerBackground | Gets or sets the background brush of the ruler.
public Property | RulerDivisions | Gets or sets the amount of divisions to place between the major time segments.
public Property | RulerForeground | Gets or sets the foreground brush of the ruler.
public Property | RulerLineStroke | Gets or sets the line color of the ruler.
public Property | RulerOffset | Gets or sets the value used to calculate the horizontal and vertical position of the text within the rulers.
public Property | RulerSplit | Gets or sets whether the ruler will be split in half along the vertical axis.
public Property | RulerTitle | Gets or sets the text to be placed at the top half of the time ruler.
public Property | Start | Gets or sets the starting time and date for the schedule.
public Property | Tag | Gets or sets a tag or object for the object.
public Property | TimeFormat | Gets or sets how the time strings will appear in the time rulers.
public Property | TimeLineBreak | Gets or sets the frequency for the time lines along the major time segments.
public Property | TimeLineDashPattern | Gets or sets the dash pattern used to paint the time lines.
public Property | TimeLineStart | Gets or sets the offset used to calculate where the first time line will be drawn.
public Property | TimeLineStroke | Gets or sets the brush used to paint time lines in the schedule.
public Property | TimeLineStrokeThickness | Gets or sets the default stroke thickness for the line used to paint the time lines.
public Property | TimeType | Gets or sets the type of time increment to be used within the ruler.
public Property | WeekendBackground | Gets or sets the brush used to color the weekend days.
public Property | YearFormat | Gets or sets how the dates in a yearly defined ruler will be displayed
Top

See Also

Reference

dbiScheduleObject Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleObject Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : dbiScheduleObject Constructor

Initializes a new instance of the dbiScheduleObject class.

Overload List

Overload | Description
dbiScheduleObject Constructor() | Initializes a new instance of the dbiScheduleObject class.
dbiScheduleObject Constructor(dbiScheduleWPF) | Initializes a new instance of the dbiScheduleObject class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

dbiScheduleObject Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class > dbiScheduleObject Constructor : dbiScheduleObject Constructor()

Initializes a new instance of the dbiScheduleObject class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleObject()
C#
public dbiScheduleObject()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

dbiScheduleObject Constructor(dbiScheduleWPF)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class > dbiScheduleObject Constructor : dbiScheduleObject Constructor(dbiScheduleWPF)

objCtrl
The dbiScheduleWPF control that will contain the new schedule.
Initializes a new instance of the dbiScheduleObject class.

Syntax

Visual Basic (Usage) Copy Code
Dim objCtrl As dbiScheduleWPF

Dim instance As New dbiScheduleObject(objCtrl)
C#
public dbiScheduleObject(
   dbiScheduleWPF objCtrl
)

Parameters

objCtrl
The dbiScheduleWPF control that will contain the new schedule.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%% $$Properties$$

dbiScheduleObject Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObject Class

"

For a list of all members of this type, see dbiScheduleObject members.

"

Public Properties

 | Name | Description
public Property | AlternateBrushes | Gets or sets whether alternating brushes will be used in the schedule lines.
public Property | AlternateItems | Gets or sets the amount of lines to color with the odd or even colors before the other color is used.
public Property | AltEvenBackground | Gets or sets one of the alternating line colors for a schedule line.
public Property | AltOddBackground | Gets or sets one of the alternating line colors for a schedule line.
public Property | Background | Gets or sets the brush used to paint the background of the schedule area
public Property | Breaks | Gets the number of breaks or time segments in the schedule.
public Property | DateFormat | Gets or sets how the date strings will appear in the time rulers.
public Property | DayLength | Gets or sets the amount of characters used when drawing the day names in the ruler.
public Property | DisplayDays | Gets or sets whether day values will be placed in a daily ruler along with the days of the month.
public Property | DisplayTimeBarDates | Gets or sets whether the time bar dates will be displayed in the time bars
public Property | DisplayTimeLines | Gets or sets whether time lines will be drawn in the schedule.
public Property | End | Gets or sets the ending time and date for the schedule.
public Property | FirstDayOfWeek | Gets or sets the first day of a week.
public Property | GuideLine | Gets or sets the temporary guide lines in the control.
public Property | GuideLines | Gets or sets the collection of GuideLines in the schedule
public Property | HeaderBackground | Gets or sets the brush used to paint the background of list items marked as headers in the list.
public Property | HorzScrollValue | Gets or sets the current horizontal scroll value representing the schedule view.
public Property | LineMaxSize | Gets or sets the height of the lines marking major time segments within the ruler.
public Property | LineMinSize | Gets or sets the height of the lines marking minor time segments within the ruler.
public Property | MajorTimeLine | Gets or sets whether a full vertical line will be drawn at major time segments in the ruler.
public Property | MonthFormat | Gets or sets how the dates in a monthly defined ruler will be displayed.
public Property | RulerAlign | Gets or sets the alignment for the text within the ruler.
public Property | RulerBackground | Gets or sets the background brush of the ruler.
public Property | RulerDivisions | Gets or sets the amount of divisions to place between the major time segments.
public Property | RulerForeground | Gets or sets the foreground brush of the ruler.
public Property | RulerLineStroke | Gets or sets the line color of the ruler.
public Property | RulerOffset | Gets or sets the value used to calculate the horizontal and vertical position of the text within the rulers.
public Property | RulerSplit | Gets or sets whether the ruler will be split in half along the vertical axis.
public Property | RulerTitle | Gets or sets the text to be placed at the top half of the time ruler.
public Property | Start | Gets or sets the starting time and date for the schedule.
public Property | Tag | Gets or sets a tag or object for the object.
public Property | TimeFormat | Gets or sets how the time strings will appear in the time rulers.
public Property | TimeLineBreak | Gets or sets the frequency for the time lines along the major time segments.
public Property | TimeLineDashPattern | Gets or sets the dash pattern used to paint the time lines.
public Property | TimeLineStart | Gets or sets the offset used to calculate where the first time line will be drawn.
public Property | TimeLineStroke | Gets or sets the brush used to paint time lines in the schedule.
public Property | TimeLineStrokeThickness | Gets or sets the default stroke thickness for the line used to paint the time lines.
public Property | TimeType | Gets or sets the type of time increment to be used within the ruler.
public Property | WeekendBackground | Gets or sets the brush used to color the weekend days.
public Property | YearFormat | Gets or sets how the dates in a yearly defined ruler will be displayed
Top

See Also

Reference

dbiScheduleObject Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AlternateBrushes Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : AlternateBrushes Property

Gets or sets whether alternating brushes will be used in the schedule lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Boolean

instance.AlternateBrushes = value

value = instance.AlternateBrushes
C#
public virtual bool AlternateBrushes {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AlternateItems Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : AlternateItems Property

Gets or sets the amount of lines to color with the odd or even colors before the other color is used.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

instance.AlternateItems = value

value = instance.AlternateItems
C#
public int AlternateItems {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AltEvenBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : AltEvenBackground Property

Gets or sets one of the alternating line colors for a schedule line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Brush

instance.AltEvenBackground = value

value = instance.AltEvenBackground
C#
public Brush AltEvenBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AltOddBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : AltOddBackground Property

Gets or sets one of the alternating line colors for a schedule line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Brush

instance.AltOddBackground = value

value = instance.AltOddBackground
C#
public Brush AltOddBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Background Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : Background Property

Gets or sets the brush used to paint the background of the schedule area

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Brush

instance.Background = value

value = instance.Background
C#
public Brush Background {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Breaks Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : Breaks Property

Gets the number of breaks or time segments in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

value = instance.Breaks
C#
public int Breaks {get;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DateFormat Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DateFormat Property

Gets or sets how the date strings will appear in the time rulers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As String

instance.DateFormat = value

value = instance.DateFormat
C#
public virtual string DateFormat {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DayLength Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DayLength Property

Gets or sets the amount of characters used when drawing the day names in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

instance.DayLength = value

value = instance.DayLength
C#
public int DayLength {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DisplayDays Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DisplayDays Property

Gets or sets whether day values will be placed in a daily ruler along with the days of the month.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Boolean

instance.DisplayDays = value

value = instance.DisplayDays
C#
public virtual bool DisplayDays {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DisplayTimeBarDates Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DisplayTimeBarDates Property

Gets or sets whether the time bar dates will be displayed in the time bars

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Boolean

instance.DisplayTimeBarDates = value

value = instance.DisplayTimeBarDates
C#
public virtual bool DisplayTimeBarDates {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DisplayTimeLines Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DisplayTimeLines Property

Gets or sets whether time lines will be drawn in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Boolean

instance.DisplayTimeLines = value

value = instance.DisplayTimeLines
C#
public virtual bool DisplayTimeLines {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : End Property

Gets or sets the ending time and date for the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Date

instance.End = value

value = instance.End
C#
[TypeConverterAttribute("., dbiScheduleWPF, Version=2.5.0.0, Culture=neutral, PublicKeyToken=0e75c9c0bb3bd0d4")]
public DateTime End {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

FirstDayOfWeek Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : FirstDayOfWeek Property

Gets or sets the first day of a week.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As enumFirstDayOfWeek

instance.FirstDayOfWeek = value

value = instance.FirstDayOfWeek
C#
public enumFirstDayOfWeek FirstDayOfWeek {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : GuideLine Property

Gets or sets the temporary guide lines in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public dbiGuideLine GuideLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GuideLines Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : GuideLines Property

Gets or sets the collection of GuideLines in the schedule

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiGuideLineCollection

instance.GuideLines = value

value = instance.GuideLines
C#
public dbiGuideLineCollection GuideLines {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

HeaderBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : HeaderBackground Property

Gets or sets the brush used to paint the background of list items marked as headers in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Brush

instance.HeaderBackground = value

value = instance.HeaderBackground
C#
public Brush HeaderBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

HorzScrollValue Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : HorzScrollValue Property

Gets or sets the current horizontal scroll value representing the schedule view.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

instance.HorzScrollValue = value

value = instance.HorzScrollValue
C#
public int HorzScrollValue {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LineMaxSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : LineMaxSize Property

Gets or sets the height of the lines marking major time segments within the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

instance.LineMaxSize = value

value = instance.LineMaxSize
C#
public int LineMaxSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LineMinSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : LineMinSize Property

Gets or sets the height of the lines marking minor time segments within the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

instance.LineMinSize = value

value = instance.LineMinSize
C#
public int LineMinSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MajorTimeLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : MajorTimeLine Property

Gets or sets whether a full vertical line will be drawn at major time segments in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Boolean

instance.MajorTimeLine = value

value = instance.MajorTimeLine
C#
public virtual bool MajorTimeLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MonthFormat Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : MonthFormat Property

Gets or sets how the dates in a monthly defined ruler will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As enumMonthFormat

instance.MonthFormat = value

value = instance.MonthFormat
C#
public enumMonthFormat MonthFormat {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerAlign Property

Gets or sets the alignment for the text within the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As enumRulerAlign

instance.RulerAlign = value

value = instance.RulerAlign
C#
public enumRulerAlign RulerAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerBackground Property

Gets or sets the background brush of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Brush

instance.RulerBackground = value

value = instance.RulerBackground
C#
public Brush RulerBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerDivisions Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerDivisions Property

Gets or sets the amount of divisions to place between the major time segments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

instance.RulerDivisions = value

value = instance.RulerDivisions
C#
public int RulerDivisions {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerForeground Property

Gets or sets the foreground brush of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Brush

instance.RulerForeground = value

value = instance.RulerForeground
C#
public Brush RulerForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerLineStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerLineStroke Property

Gets or sets the line color of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Brush

instance.RulerLineStroke = value

value = instance.RulerLineStroke
C#
public Brush RulerLineStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerOffset Property

Gets or sets the value used to calculate the horizontal and vertical position of the text within the rulers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Point

instance.RulerOffset = value

value = instance.RulerOffset
C#
public Point RulerOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerSplit Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerSplit Property

Gets or sets whether the ruler will be split in half along the vertical axis.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Boolean

instance.RulerSplit = value

value = instance.RulerSplit
C#
public virtual bool RulerSplit {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerTitle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerTitle Property

Gets or sets the text to be placed at the top half of the time ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As String

instance.RulerTitle = value

value = instance.RulerTitle
C#
public virtual string RulerTitle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : Start Property

Gets or sets the starting time and date for the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Date

instance.Start = value

value = instance.Start
C#
[TypeConverterAttribute("., dbiScheduleWPF, Version=2.5.0.0, Culture=neutral, PublicKeyToken=0e75c9c0bb3bd0d4")]
public DateTime Start {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : Tag Property

Gets or sets a tag or object for the object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
public object Tag {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeFormat Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeFormat Property

Gets or sets how the time strings will appear in the time rulers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As String

instance.TimeFormat = value

value = instance.TimeFormat
C#
public virtual string TimeFormat {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineBreak Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeLineBreak Property

Gets or sets the frequency for the time lines along the major time segments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

instance.TimeLineBreak = value

value = instance.TimeLineBreak
C#
public int TimeLineBreak {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineDashPattern Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeLineDashPattern Property

Gets or sets the dash pattern used to paint the time lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As List(Of Double)

instance.TimeLineDashPattern = value

value = instance.TimeLineDashPattern
C#
public List<double> TimeLineDashPattern {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineStart Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeLineStart Property

Gets or sets the offset used to calculate where the first time line will be drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

instance.TimeLineStart = value

value = instance.TimeLineStart
C#
public int TimeLineStart {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeLineStroke Property

Gets or sets the brush used to paint time lines in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Brush

instance.TimeLineStroke = value

value = instance.TimeLineStroke
C#
public Brush TimeLineStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeLineStrokeThickness Property

Gets or sets the default stroke thickness for the line used to paint the time lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Double

instance.TimeLineStrokeThickness = value

value = instance.TimeLineStrokeThickness
C#
public double TimeLineStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeType Property

Gets or sets the type of time increment to be used within the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As enumTimeType

instance.TimeType = value

value = instance.TimeType
C#
public enumTimeType TimeType {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

WeekendBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : WeekendBackground Property

Gets or sets the brush used to color the weekend days.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Brush

instance.WeekendBackground = value

value = instance.WeekendBackground
C#
public Brush WeekendBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

YearFormat Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : YearFormat Property

Gets or sets how the dates in a yearly defined ruler will be displayed

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As enumYearFormat

instance.YearFormat = value

value = instance.YearFormat
C#
public enumYearFormat YearFormat {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%% $$Fields$$

dbiScheduleObject Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObject Class

"

For a list of all members of this type, see dbiScheduleObject members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AlternateBrushesProperty | Identifies the DependencyProperty for the AlternateBrushes Property
static (Shared in Visual Basic) | AlternateItemsProperty | Identifies the DependencyProperty for the AlternateItems Property
static (Shared in Visual Basic) | AltEvenBackgroundProperty | Identifies the DependencyProperty for the AltEvenBackground Property
static (Shared in Visual Basic) | AltOddBackgroundProperty | Identifies the DependencyProperty for the AltOddBackground Property
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | DateFormatProperty | Identifies the DependencyProperty for the DateFormat Property
static (Shared in Visual Basic) | DayLengthProperty | Identifies the DependencyProperty for the DayLength Property
static (Shared in Visual Basic) | DisplayDaysProperty | Identifies the DependencyProperty for the DisplayDays Property
static (Shared in Visual Basic) | DisplayTimeBarDatesProperty | Identifies the DependencyProperty for the DisplayTimeBarDates Property
static (Shared in Visual Basic) | DisplayTimeLinesProperty | Identifies the DependencyProperty for the DisplayTimeLines Property
static (Shared in Visual Basic) | EndProperty | Identifies the DependencyProperty for the End Property
static (Shared in Visual Basic) | FirstDayOfWeekProperty | Identifies the DependencyProperty for the FirstDayOfWeek Property
static (Shared in Visual Basic) | GuideLinesProperty | Identifies the DependencyProperty for the GuideLines Property
static (Shared in Visual Basic) | HeaderBackgroundProperty | Identifies the DependencyProperty for the HeaderBackground Property
static (Shared in Visual Basic) | LineMaxSizeProperty | Identifies the DependencyProperty for the LineMaxSize Property
static (Shared in Visual Basic) | LineMinSizeProperty | Identifies the DependencyProperty for the LineMinSize Property
static (Shared in Visual Basic) | MajorTimeLineProperty | Identifies the DependencyProperty for the MajorTimeLine Property
static (Shared in Visual Basic) | MonthFormatProperty | Identifies the DependencyProperty for the MonthFormat Property
static (Shared in Visual Basic) | RulerAlignProperty | Identifies the DependencyProperty for the RulerAlign Property
static (Shared in Visual Basic) | RulerBackgroundProperty | Identifies the DependencyProperty for the RulerBackground Property
static (Shared in Visual Basic) | RulerDivisionsProperty | Identifies the DependencyProperty for the RulerDivisions Property
static (Shared in Visual Basic) | RulerForegroundProperty | Identifies the DependencyProperty for the RulerForeground Property
static (Shared in Visual Basic) | RulerLineStrokeProperty | Identifies the DependencyProperty for the RulerLineStroke Property
static (Shared in Visual Basic) | RulerOffsetProperty | Identifies the DependencyProperty for the RulerOffset Property
static (Shared in Visual Basic) | RulerSplitProperty | Identifies the DependencyProperty for the RulerSplit Property
static (Shared in Visual Basic) | RulerTitleProperty | Identifies the DependencyProperty for the RulerTitle Property
static (Shared in Visual Basic) | StartProperty | Identifies the DependencyProperty for the Start Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TimeFormatProperty | Identifies the DependencyProperty for the TimeFormat Property
static (Shared in Visual Basic) | TimeLineBreakProperty | Identifies the DependencyProperty for the TimeLineBreak Property
static (Shared in Visual Basic) | TimeLineStartProperty | Identifies the DependencyProperty for the TimeLineStart Property
static (Shared in Visual Basic) | TimeLineStrokeProperty | Identifies the DependencyProperty for the TimeLineStroke Property
static (Shared in Visual Basic) | TimeLineStrokeThicknessProperty | Identifies the DependencyProperty for the TimeLineStrokeThickness Property
static (Shared in Visual Basic) | TimeTypeProperty | Identifies the DependencyProperty for the TimeType Property
static (Shared in Visual Basic) | WeekendBackgroundProperty | Identifies the DependencyProperty for the WeekendBackground Property
static (Shared in Visual Basic) | YearFormatProperty | Identifies the DependencyProperty for the YearFormat Property
Top

See Also

Reference

dbiScheduleObject Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AlternateBrushesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : AlternateBrushesProperty Field

Identifies the DependencyProperty for the AlternateBrushes Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.AlternateBrushesProperty
C#
public static readonly DependencyProperty AlternateBrushesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AlternateItemsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : AlternateItemsProperty Field

Identifies the DependencyProperty for the AlternateItems Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.AlternateItemsProperty
C#
public static readonly DependencyProperty AlternateItemsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AltEvenBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : AltEvenBackgroundProperty Field

Identifies the DependencyProperty for the AltEvenBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.AltEvenBackgroundProperty
C#
public static readonly DependencyProperty AltEvenBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AltOddBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : AltOddBackgroundProperty Field

Identifies the DependencyProperty for the AltOddBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.AltOddBackgroundProperty
C#
public static readonly DependencyProperty AltOddBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

BackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : BackgroundProperty Field

Identifies the DependencyProperty for the Background Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.BackgroundProperty
C#
public static readonly DependencyProperty BackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DateFormatProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DateFormatProperty Field

Identifies the DependencyProperty for the DateFormat Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.DateFormatProperty
C#
public static readonly DependencyProperty DateFormatProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DayLengthProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DayLengthProperty Field

Identifies the DependencyProperty for the DayLength Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.DayLengthProperty
C#
public static readonly DependencyProperty DayLengthProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DisplayDaysProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DisplayDaysProperty Field

Identifies the DependencyProperty for the DisplayDays Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.DisplayDaysProperty
C#
public static readonly DependencyProperty DisplayDaysProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DisplayTimeBarDatesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DisplayTimeBarDatesProperty Field

Identifies the DependencyProperty for the DisplayTimeBarDates Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.DisplayTimeBarDatesProperty
C#
public static readonly DependencyProperty DisplayTimeBarDatesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DisplayTimeLinesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DisplayTimeLinesProperty Field

Identifies the DependencyProperty for the DisplayTimeLines Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.DisplayTimeLinesProperty
C#
public static readonly DependencyProperty DisplayTimeLinesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

EndProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : EndProperty Field

Identifies the DependencyProperty for the End Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.EndProperty
C#
public static readonly DependencyProperty EndProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

FirstDayOfWeekProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : FirstDayOfWeekProperty Field

Identifies the DependencyProperty for the FirstDayOfWeek Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.FirstDayOfWeekProperty
C#
public static readonly DependencyProperty FirstDayOfWeekProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GuideLinesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : GuideLinesProperty Field

Identifies the DependencyProperty for the GuideLines Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.GuideLinesProperty
C#
public static readonly DependencyProperty GuideLinesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

HeaderBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : HeaderBackgroundProperty Field

Identifies the DependencyProperty for the HeaderBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.HeaderBackgroundProperty
C#
public static readonly DependencyProperty HeaderBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LineMaxSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : LineMaxSizeProperty Field

Identifies the DependencyProperty for the LineMaxSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.LineMaxSizeProperty
C#
public static readonly DependencyProperty LineMaxSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LineMinSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : LineMinSizeProperty Field

Identifies the DependencyProperty for the LineMinSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.LineMinSizeProperty
C#
public static readonly DependencyProperty LineMinSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MajorTimeLineProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : MajorTimeLineProperty Field

Identifies the DependencyProperty for the MajorTimeLine Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.MajorTimeLineProperty
C#
public static readonly DependencyProperty MajorTimeLineProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MonthFormatProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : MonthFormatProperty Field

Identifies the DependencyProperty for the MonthFormat Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.MonthFormatProperty
C#
public static readonly DependencyProperty MonthFormatProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerAlignProperty Field

Identifies the DependencyProperty for the RulerAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.RulerAlignProperty
C#
public static readonly DependencyProperty RulerAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerBackgroundProperty Field

Identifies the DependencyProperty for the RulerBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.RulerBackgroundProperty
C#
public static readonly DependencyProperty RulerBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerDivisionsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerDivisionsProperty Field

Identifies the DependencyProperty for the RulerDivisions Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.RulerDivisionsProperty
C#
public static readonly DependencyProperty RulerDivisionsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerForegroundProperty Field

Identifies the DependencyProperty for the RulerForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.RulerForegroundProperty
C#
public static readonly DependencyProperty RulerForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerLineStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerLineStrokeProperty Field

Identifies the DependencyProperty for the RulerLineStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.RulerLineStrokeProperty
C#
public static readonly DependencyProperty RulerLineStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerOffsetProperty Field

Identifies the DependencyProperty for the RulerOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.RulerOffsetProperty
C#
public static readonly DependencyProperty RulerOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerSplitProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerSplitProperty Field

Identifies the DependencyProperty for the RulerSplit Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.RulerSplitProperty
C#
public static readonly DependencyProperty RulerSplitProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerTitleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : RulerTitleProperty Field

Identifies the DependencyProperty for the RulerTitle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.RulerTitleProperty
C#
public static readonly DependencyProperty RulerTitleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

StartProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : StartProperty Field

Identifies the DependencyProperty for the Start Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.StartProperty
C#
public static readonly DependencyProperty StartProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TagProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TagProperty Field

Identifies the DependencyProperty for the Tag Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.TagProperty
C#
public static readonly DependencyProperty TagProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeFormatProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeFormatProperty Field

Identifies the DependencyProperty for the TimeFormat Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.TimeFormatProperty
C#
public static readonly DependencyProperty TimeFormatProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineBreakProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeLineBreakProperty Field

Identifies the DependencyProperty for the TimeLineBreak Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.TimeLineBreakProperty
C#
public static readonly DependencyProperty TimeLineBreakProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineStartProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeLineStartProperty Field

Identifies the DependencyProperty for the TimeLineStart Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.TimeLineStartProperty
C#
public static readonly DependencyProperty TimeLineStartProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeLineStrokeProperty Field

Identifies the DependencyProperty for the TimeLineStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.TimeLineStrokeProperty
C#
public static readonly DependencyProperty TimeLineStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeLineStrokeThicknessProperty Field

Identifies the DependencyProperty for the TimeLineStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.TimeLineStrokeThicknessProperty
C#
public static readonly DependencyProperty TimeLineStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeTypeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : TimeTypeProperty Field

Identifies the DependencyProperty for the TimeType Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.TimeTypeProperty
C#
public static readonly DependencyProperty TimeTypeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

WeekendBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : WeekendBackgroundProperty Field

Identifies the DependencyProperty for the WeekendBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.WeekendBackgroundProperty
C#
public static readonly DependencyProperty WeekendBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

YearFormatProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : YearFormatProperty Field

Identifies the DependencyProperty for the YearFormat Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleObject.YearFormatProperty
C#
public static readonly DependencyProperty YearFormatProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

dbiScheduleObjectCollection Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObjectCollection Class

The collection of schedule objects

Object Model

dbiScheduleObjectCollection ClassdbiScheduleObject Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
C#
[DefaultMemberAttribute("Item")]
public class dbiScheduleObjectCollection : System.Collections.ObjectModel.ObservableCollection<dbiScheduleObject>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiScheduleObjectCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiScheduleObjectCollection Class Members
See Also Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObjectCollection Class

"

The following tables list the members exposed by dbiScheduleObjectCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiScheduleObjectCollection Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Inserts an object into the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiScheduleObjectCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleObjectCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : dbiScheduleObjectCollection Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleObjectCollection()
C#
public dbiScheduleObjectCollection()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%% $$Methods$$

dbiScheduleObjectCollection Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObjectCollection Class

"

For a list of all members of this type, see dbiScheduleObjectCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of the collection
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Inserts an object into the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiScheduleObjectCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Add Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : Add Method

Adds an object to the end of the collection

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(dbiScheduleObject) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

Add() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection

instance.Add()
C#
public void Add()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members
Overload List


%%PageItemTitle%%

Add(dbiScheduleObject) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class > Add Method : Add(dbiScheduleObject) Method

obj
The dbiScheduleObject to add to the collection.
Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim obj As dbiScheduleObject

instance.Add(obj)
C#
public new void Add(
   dbiScheduleObject obj
)

Parameters

obj
The dbiScheduleObject to add to the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : IndexOf Method

obj
The dbiScheduleObject to find the index of.
Gets the 0 based index of the first occurence of an object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim obj As dbiScheduleObject
Dim value As Integer

value = instance.IndexOf(obj)
C#
public new int IndexOf(
   dbiScheduleObject obj
)

Parameters

obj
The dbiScheduleObject to find the index of.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : Insert Method

nIndex
The zero-based index to insert the new dbiScheduleObject before.
obj
The dbiScheduleObject to be inserted
Inserts an object into the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim nIndex As Integer
Dim obj As dbiScheduleObject

instance.Insert(nIndex, obj)
C#
public new void Insert(
   int nIndex,
   dbiScheduleObject obj
)

Parameters

nIndex
The zero-based index to insert the new dbiScheduleObject before.
obj
The dbiScheduleObject to be inserted

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : Remove Method

obj
The dbiScheduleObject to remove
Removes the first occurence of a specific object from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim obj As dbiScheduleObject

instance.Remove(obj)
C#
public new void Remove(
   dbiScheduleObject obj
)

Parameters

obj
The dbiScheduleObject to remove

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : RemoveAt Method

nIndex
The zero-based index to remove the object at.
Removes the object at the specified index of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim nIndex As Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   int nIndex
)

Parameters

nIndex
The zero-based index to remove the object at.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%% $$Properties$$

dbiScheduleObjectCollection Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObjectCollection Class

"

For a list of all members of this type, see dbiScheduleObjectCollection members.

"

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

See Also

Reference

dbiScheduleObjectCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Item Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : Item Property

nIndex
The zero-based index of the object in the collection.
Get or set a particular object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim nIndex As Integer
Dim value As dbiScheduleObject

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiScheduleObject this[
   int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the object in the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

dbiScheduleWPF Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF Class

Provides properties/methods/events for a multi-resource schedule

Object Model

dbiScheduleWPF ClassdbiColumnItemCollection ClassdbiColumnItem ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiListItemCollection ClassdbiListItem ClassdbiLinkItemCollection ClassdbiLinkItem ClassdbiScheduleObjectCollection ClassdbiScheduleObject Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
C#
[LicenseProviderAttribute(Dbi.dbiLicenseProvider)]
public class dbiScheduleWPF : System.Windows.Controls.UserControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.UserControl
Dbi.WpfControl.dbiSchedule.dbiScheduleWPF

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiScheduleWPF Class Members
See Also Fields Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF Class

"

The following tables list the members exposed by dbiScheduleWPF.

"

Public Constructors

 | Name | Description
public Constructor | dbiScheduleWPF Constructor | Initializes a new instance of the dbiScheduleWPF class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ActiveScheduleProperty | Identifies the DependencyProperty for the ActiveSchedule Property
static (Shared in Visual Basic) | AllowHorzMovesProperty | Identifies the DependencyProperty for the AllowHorzMoves Property
static (Shared in Visual Basic) | AllowNewBarsProperty | Identifies the DependencyProperty for the AllowNewBars Property
static (Shared in Visual Basic) | AllowResizeBarsProperty | Identifies the DependencyProperty for the AllowResizeBars Property
static (Shared in Visual Basic) | AllowVertMovesProperty | Identifies the DependencyProperty for the AllowVertMoves Property
static (Shared in Visual Basic) | AltListBrushesProperty | Identifies the DependencyProperty for the AltListBrushes Property
static (Shared in Visual Basic) | AltListEvenBackgroundProperty | Identifies the DependencyProperty for the AltListEvenBackground Property
static (Shared in Visual Basic) | AltListItemsProperty | Identifies the DependencyProperty for the AltListItems Property
static (Shared in Visual Basic) | AltListOddBackgroundProperty | Identifies the DependencyProperty for the AltListOddBackground Property
static (Shared in Visual Basic) | AutoDuplicateProperty | Identifies the DependencyProperty for the AutoDuplicate Property
static (Shared in Visual Basic) | BarSelectBackgroundProperty | Identifies the DependencyProperty for the BarSelectBackground Property
static (Shared in Visual Basic) | BarSelectForegroundProperty | Identifies the DependencyProperty for the BarSelectForeground Property
static (Shared in Visual Basic) | BarSelectStrokeProperty | Identifies the DependencyProperty for the BarSelectStroke Property
static (Shared in Visual Basic) | BarSelectStrokeThicknessProperty | Identifies the DependencyProperty for the BarSelectStrokeThickness Property
static (Shared in Visual Basic) | BorderBrushProperty | Identifies the DependencyProperty for the BorderBrush Property
static (Shared in Visual Basic) | ColumnsProperty | Identifies the DependencyProperty for the Columns Property
static (Shared in Visual Basic) | CornerBackgroundProperty | Identifies the DependencyProperty for the CornerBackground Property
static (Shared in Visual Basic) | CurrentTimeColorToProperty | Identifies the DependencyProperty for the CurrentTimeColorTo Property
static (Shared in Visual Basic) | CurrentTimeLineProperty | Identifies the DependencyProperty for the CurrentTimeLine Property
static (Shared in Visual Basic) | CurrentTimeOffsetProperty | Identifies the DependencyProperty for the CurrentTimeOffset Property
static (Shared in Visual Basic) | CurrentTimeStrokeProperty | Identifies the DependencyProperty for the CurrentTimeStroke Property
static (Shared in Visual Basic) | CurrentTimeStrokeThicknessProperty | Identifies the DependencyProperty for the CurrentTimeStrokeThickness Property
static (Shared in Visual Basic) | CustomAreaBackgroundProperty | Identifies the DependencyProperty for the CustomAreaBackground Property
static (Shared in Visual Basic) | CustomAreasProperty | Identifies the DependencyProperty for the CustomAreas Property
static (Shared in Visual Basic) | DayMonthOffsetProperty | Identifies the DependencyProperty for the DayMonthOffset Property
static (Shared in Visual Basic) | DayNamesProperty | Identifies the DependencyProperty for the DayNames Property
static (Shared in Visual Basic) | DisplayGuideLinesProperty | Identifies the DependencyProperty for the DisplayGuideLines Property
static (Shared in Visual Basic) | DisplayListGuideProperty | Identifies the DependencyProperty for the DisplayListGuide Property
static (Shared in Visual Basic) | DivisionDistanceProperty | Identifies the DependencyProperty for the DivisionDistance Property
static (Shared in Visual Basic) | EditModeProperty | Identifies the DependencyProperty for the EditMode Property
static (Shared in Visual Basic) | FillListProperty | Identifies the DependencyProperty for the FillList Property
static (Shared in Visual Basic) | GridFrequencyProperty | Identifies the DependencyProperty for the GridFrequency Property
static (Shared in Visual Basic) | GuideImagePositionProperty | Identifies the DependencyProperty for the GuideImagePosition Property
static (Shared in Visual Basic) | GuideLineDashPatternProperty | Identifies the DependencyProperty for the GuideLineDashPattern Property
static (Shared in Visual Basic) | GuideLineDistanceProperty | Identifies the DependencyProperty for the GuideLineDistance Property
static (Shared in Visual Basic) | GuideLinePositionProperty | Identifies the DependencyProperty for the GuideLinePosition Property
static (Shared in Visual Basic) | GuideLineStrokeProperty | Identifies the DependencyProperty for the GuideLineStroke Property
static (Shared in Visual Basic) | GuideLineStrokeThicknessProperty | Identifies the DependencyProperty for the GuideLineStrokeThickness Property
static (Shared in Visual Basic) | GuideSelectStrokeProperty | Identifies the DependencyProperty for the GuideSelectStroke Property
static (Shared in Visual Basic) | HandleListRightClickProperty | Identifies the DependencyProperty for the HandleListRightClick Property
static (Shared in Visual Basic) | HandleMapAreaRightClickProperty | Identifies the DependencyProperty for the HandleMapAreaRightClick Property
static (Shared in Visual Basic) | HandleScheduleRightClickProperty | Identifies the DependencyProperty for the HandleScheduleRightClick Property
static (Shared in Visual Basic) | HeaderAlignProperty | Identifies the DependencyProperty for the HeaderAlign Property
static (Shared in Visual Basic) | HeaderBackgroundProperty | Identifies the DependencyProperty for the HeaderBackground Property
static (Shared in Visual Basic) | HeaderFontFamilyProperty | Identifies the DependencyProperty for the HeaderFontFamily Property
static (Shared in Visual Basic) | HeaderFontSizeProperty | Identifies the DependencyProperty for the HeaderFontSize Property
static (Shared in Visual Basic) | HeaderFontStyleProperty | Identifies the DependencyProperty for the HeaderFontStyle Property
static (Shared in Visual Basic) | HeaderFontWeightProperty | Identifies the DependencyProperty for the HeaderFontWeight Property
static (Shared in Visual Basic) | HeaderForegroundProperty | Identifies the DependencyProperty for the HeaderForeground Property
static (Shared in Visual Basic) | HeaderHeightProperty | Identifies the DependencyProperty for the HeaderHeight Property
static (Shared in Visual Basic) | HeaderVisibleProperty | Identifies the DependencyProperty for the HeaderVisible Property
static (Shared in Visual Basic) | HistorySizeProperty | Identifies the DependencyProperty for the HistorySize Property
static (Shared in Visual Basic) | ImagesProperty | Identifies the DependencyProperty for the Images Property
static (Shared in Visual Basic) | ItemHeaderBackgroundProperty | Identifies the DependencyProperty for the ItemHeaderBackground Property
static (Shared in Visual Basic) | ItemHeaderForegroundProperty | Identifies the DependencyProperty for the ItemHeaderForeground Property
static (Shared in Visual Basic) | ItemHeightOffsetProperty | Identifies the DependencyProperty for the ItemHeightOffset Property
static (Shared in Visual Basic) | ItemsProperty | Identifies the DependencyProperty for the Items Property
static (Shared in Visual Basic) | LineArrowAfterProperty | Identifies the DependencyProperty for the LineArrowAfter Property
static (Shared in Visual Basic) | LineArrowBackgroundProperty | Identifies the DependencyProperty for the LineArrowBackground Property
static (Shared in Visual Basic) | LineArrowBeforeProperty | Identifies the DependencyProperty for the LineArrowBefore Property
static (Shared in Visual Basic) | LineArrowPositionProperty | Identifies the DependencyProperty for the LineArrowPosition Property
static (Shared in Visual Basic) | LineArrowTypeProperty | Identifies the DependencyProperty for the LineArrowType Property
static (Shared in Visual Basic) | LinkLineStrokeProperty | Identifies the DependencyProperty for the LinkLineStroke Property
static (Shared in Visual Basic) | LinksProperty | Identifies the DependencyProperty for the Links Property
static (Shared in Visual Basic) | ListBackgroundProperty | Identifies the DependencyProperty for the ListBackground Property
static (Shared in Visual Basic) | ListFontFamilyProperty | Identifies the DependencyProperty for the ListFontFamily Property
static (Shared in Visual Basic) | ListFontSizeProperty | Identifies the DependencyProperty for the ListFontSize Property
static (Shared in Visual Basic) | ListFontStyleProperty | Identifies the DependencyProperty for the ListFontStyle Property
static (Shared in Visual Basic) | ListFontWeightProperty | Identifies the DependencyProperty for the ListFontWeight Property
static (Shared in Visual Basic) | ListForegroundProperty | Identifies the DependencyProperty for the ListForeground Property
static (Shared in Visual Basic) | ListGuideBackgroundProperty | Identifies the DependencyProperty for the ListGuideBackground Property
static (Shared in Visual Basic) | ListGuideDistanceProperty | Identifies the DependencyProperty for the ListGuideDistance Property
static (Shared in Visual Basic) | ListGuideFadeDurationProperty | Identifies the DependencyProperty for the ListGuideFadeDuration Property
static (Shared in Visual Basic) | ListGuideForegroundProperty | Identifies the DependencyProperty for the ListGuideForeground Property
static (Shared in Visual Basic) | ListGuideWidthProperty | Identifies the DependencyProperty for the ListGuideWidth Property
static (Shared in Visual Basic) | ListHorzStrokeProperty | Identifies the DependencyProperty for the ListHorzStroke Property
static (Shared in Visual Basic) | ListHorzStrokeThicknessProperty | Identifies the DependencyProperty for the ListHorzStrokeThickness Property
static (Shared in Visual Basic) | ListImageAlignProperty | Identifies the DependencyProperty for the ListImageAlign Property
static (Shared in Visual Basic) | ListTextAlignProperty | Identifies the DependencyProperty for the ListTextAlign Property
static (Shared in Visual Basic) | ListTitleProperty | Identifies the DependencyProperty for the ListTitle Property
static (Shared in Visual Basic) | ListTypeProperty | Identifies the DependencyProperty for the ListType Property
static (Shared in Visual Basic) | ListVertStrokeProperty | Identifies the DependencyProperty for the ListVertStroke Property
static (Shared in Visual Basic) | ListVertStrokeThicknessProperty | Identifies the DependencyProperty for the ListVertStrokeThickness Property
static (Shared in Visual Basic) | MapAreaProperty | Identifies the DependencyProperty for the MapArea Property
static (Shared in Visual Basic) | MapBackgroundProperty | Identifies the DependencyProperty for the MapBackground Property
static (Shared in Visual Basic) | MapHeightProperty | Identifies the DependencyProperty for the MapHeight Property
static (Shared in Visual Basic) | MapLineProperty | Identifies the DependencyProperty for the MapLine Property
static (Shared in Visual Basic) | MapLineThicknessProperty | Identifies the DependencyProperty for the MapLineThickness Property
static (Shared in Visual Basic) | MapStrokeProperty | Identifies the DependencyProperty for the MapStroke Property
static (Shared in Visual Basic) | MapStrokeThicknessProperty | Identifies the DependencyProperty for the MapStrokeThickness Property
static (Shared in Visual Basic) | MinBarTimeProperty | Identifies the DependencyProperty for the MinBarTime Property
static (Shared in Visual Basic) | MonthNamesProperty | Identifies the DependencyProperty for the MonthNames Property
static (Shared in Visual Basic) | NotesDistanceProperty | Identifies the DependencyProperty for the NotesDistance Property
static (Shared in Visual Basic) | NotesPositionProperty | Identifies the DependencyProperty for the NotesPosition Property
static (Shared in Visual Basic) | OverlapSpanProperty | Identifies the DependencyProperty for the OverlapSpan Property
static (Shared in Visual Basic) | OverlapStrokeProperty | Identifies the DependencyProperty for the OverlapStroke Property
static (Shared in Visual Basic) | OverlapStrokeThicknessProperty | Identifies the DependencyProperty for the OverlapStrokeThickness Property
static (Shared in Visual Basic) | PercentBackgroundProperty | Identifies the DependencyProperty for the PercentBackground Property
static (Shared in Visual Basic) | PrintFontFamilyProperty | Identifies the DependencyProperty for the PrintFontFamily Property
static (Shared in Visual Basic) | PrintFontSizeProperty | Identifies the DependencyProperty for the PrintFontSize Property
static (Shared in Visual Basic) | PrintFontStyleProperty | Identifies the DependencyProperty for the PrintFontStyle Property
static (Shared in Visual Basic) | PrintFontWeightProperty | Identifies the DependencyProperty for the PrintFontWeight Property
static (Shared in Visual Basic) | PrintFooterAlignProperty | Identifies the DependencyProperty for the PrintFooterAlign Property
static (Shared in Visual Basic) | PrintFooterMarginProperty | Identifies the DependencyProperty for the PrintFooterMargin Property
static (Shared in Visual Basic) | PrintListAlwaysProperty | Identifies the DependencyProperty for the PrintListAlways Property
static (Shared in Visual Basic) | PrintListWidthProperty | Identifies the DependencyProperty for the PrintListWidth Property
static (Shared in Visual Basic) | PrintMarginProperty | Identifies the DependencyProperty for the PrintMargin Property
static (Shared in Visual Basic) | PrintPageTextProperty | Identifies the DependencyProperty for the PrintPageText Property
static (Shared in Visual Basic) | PrintSubTitleMarginProperty | Identifies the DependencyProperty for the PrintSubTitleMargin Property
static (Shared in Visual Basic) | PrintSubTitleProperty | Identifies the DependencyProperty for the PrintSubTitle Property
static (Shared in Visual Basic) | PrintTimeDistanceProperty | Identifies the DependencyProperty for the PrintTimeDistance Property
static (Shared in Visual Basic) | PrintTitleAlignProperty | Identifies the DependencyProperty for the PrintTitleAlign Property
static (Shared in Visual Basic) | PrintTitleFontFamilyProperty | Identifies the DependencyProperty for the PrintTitleFontFamily Property
static (Shared in Visual Basic) | PrintTitleFontSizeProperty | Identifies the DependencyProperty for the PrintTitleFontSize Property
static (Shared in Visual Basic) | PrintTitleFontStyleProperty | Identifies the DependencyProperty for the PrintTitleFontStyle Property
static (Shared in Visual Basic) | PrintTitleFontWeightProperty | Identifies the DependencyProperty for the PrintTitleFontWeight Property
static (Shared in Visual Basic) | PrintTitleMarginProperty | Identifies the DependencyProperty for the PrintTitleMargin Property
static (Shared in Visual Basic) | PrintTitleProperty | Identifies the DependencyProperty for the PrintTitle Property
static (Shared in Visual Basic) | RulerBackgroundProperty | Identifies the DependencyProperty for the RulerBackground Property
static (Shared in Visual Basic) | RulerFontFamilyProperty | Identifies the DependencyProperty for the RulerFontFamily Property
static (Shared in Visual Basic) | RulerFontSizeProperty | Identifies the DependencyProperty for the RulerFontSize Property
static (Shared in Visual Basic) | RulerFontStyleProperty | Identifies the DependencyProperty for the RulerFontStyle Property
static (Shared in Visual Basic) | RulerFontWeightProperty | Identifies the DependencyProperty for the RulerFontWeight Property
static (Shared in Visual Basic) | RulerForegroundProperty | Identifies the DependencyProperty for the RulerForeground Property
static (Shared in Visual Basic) | RulerLineStrokeProperty | Identifies the DependencyProperty for the RulerLineStroke Property
static (Shared in Visual Basic) | RulerSelectBackgroundProperty | Identifies the DependencyProperty for the RulerSelectBackground Property
static (Shared in Visual Basic) | RulerSelectOffsetProperty | Identifies the DependencyProperty for the RulerSelectOffset Property
static (Shared in Visual Basic) | ScheduleBackgroundProperty | Identifies the DependencyProperty for the ScheduleBackground Property
static (Shared in Visual Basic) | ScheduleHeaderBackgroundProperty | Identifies the DependencyProperty for the ScheduleHeaderBackground Property
static (Shared in Visual Basic) | ScheduleHeaderPositionProperty | Identifies the DependencyProperty for the ScheduleHeaderPosition Property
static (Shared in Visual Basic) | ScheduleHorzStrokeProperty | Identifies the DependencyProperty for the ScheduleHorzStroke Property
static (Shared in Visual Basic) | ScheduleHorzStrokeThicknessProperty | Identifies the DependencyProperty for the ScheduleHorzStrokeThickness Property
static (Shared in Visual Basic) | SchedulesProperty | Identifies the DependencyProperty for the Schedules Property
static (Shared in Visual Basic) | SelectedBackgroundProperty | Identifies the DependencyProperty for the SelectedBackground Property
static (Shared in Visual Basic) | SelectedForegroundProperty | Identifies the DependencyProperty for the SelectedForeground Property
static (Shared in Visual Basic) | SelectedRadiusProperty | Identifies the DependencyProperty for the SelectedRadius Property
static (Shared in Visual Basic) | SelectedStrokeProperty | Identifies the DependencyProperty for the SelectedStroke Property
static (Shared in Visual Basic) | SelectedStrokeThicknessProperty | Identifies the DependencyProperty for the SelectedStrokeThickness Property
static (Shared in Visual Basic) | SelectModeDashPatternProperty | Identifies the DependencyProperty for the SelectModeDashPattern Property
static (Shared in Visual Basic) | SelectModeStrokeProperty | Identifies the DependencyProperty for the SelectModeStroke Property
static (Shared in Visual Basic) | SelectModeStrokeThicknessProperty | Identifies the DependencyProperty for the SelectModeStrokeThickness Property
static (Shared in Visual Basic) | SnapToDivisionsProperty | Identifies the DependencyProperty for the SnapToDivisions Property
static (Shared in Visual Basic) | SnapToGridProperty | Identifies the DependencyProperty for the SnapToGrid Property
static (Shared in Visual Basic) | SnapToGuideProperty | Identifies the DependencyProperty for the SnapToGuide Property
static (Shared in Visual Basic) | SortArrowAscendProperty | Identifies the DependencyProperty for the SortArrowAscend Property
static (Shared in Visual Basic) | SortArrowBackgroundProperty | Identifies the DependencyProperty for the SortArrowBackground Property
static (Shared in Visual Basic) | SortArrowDescendProperty | Identifies the DependencyProperty for the SortArrowDescend Property
static (Shared in Visual Basic) | SortArrowHorzAlignProperty | Identifies the DependencyProperty for the SortArrowHorzAlign Property
static (Shared in Visual Basic) | SortArrowOffsetProperty | Identifies the DependencyProperty for the SortArrowOffset Property
static (Shared in Visual Basic) | SortArrowSizeProperty | Identifies the DependencyProperty for the SortArrowSize Property
static (Shared in Visual Basic) | SortArrowVertAlignProperty | Identifies the DependencyProperty for the SortArrowVertAlign Property
static (Shared in Visual Basic) | SortOnCaseProperty | Identifies the DependencyProperty for the SortOnCase Property
static (Shared in Visual Basic) | SplitterBarBackgroundProperty | Identifies the DependencyProperty for the SplitterBarBackground Property
static (Shared in Visual Basic) | TextIntoViewProperty | Identifies the DependencyProperty for the TextIntoView Property
static (Shared in Visual Basic) | TimeBarBackgroundProperty | Identifies the DependencyProperty for the TimeBarBackground Property
static (Shared in Visual Basic) | TimeBarExtensionProperty | Identifies the DependencyProperty for the TimeBarExtension Property
static (Shared in Visual Basic) | TimeBarFontFamilyProperty | Identifies the DependencyProperty for the TimeBarFontFamily Property
static (Shared in Visual Basic) | TimeBarFontSizeProperty | Identifies the DependencyProperty for the TimeBarFontSize Property
static (Shared in Visual Basic) | TimeBarFontStyleProperty | Identifies the DependencyProperty for the TimeBarFontStyle Property
static (Shared in Visual Basic) | TimeBarFontWeightProperty | Identifies the DependencyProperty for the TimeBarFontWeight Property
static (Shared in Visual Basic) | TimeBarForegroundProperty | Identifies the DependencyProperty for the TimeBarForeground Property
static (Shared in Visual Basic) | TimeBarMarginProperty | Identifies the DependencyProperty for the TimeBarMargin Property
static (Shared in Visual Basic) | TimeBarMinWidthProperty | Identifies the DependencyProperty for the TimeBarMinWidth Property
static (Shared in Visual Basic) | TimeBarRadiusProperty | Identifies the DependencyProperty for the TimeBarRadius Property
static (Shared in Visual Basic) | TimeBarShadowColorProperty | Identifies the DependencyProperty for the TimeBarShadowColor Property
static (Shared in Visual Basic) | TimeBarShadowOpacityProperty | Identifies the DependencyProperty for the TimeBarShadowOpacity Property
static (Shared in Visual Basic) | TimeBarShadowsProperty | Identifies the DependencyProperty for the TimeBarShadows Property
static (Shared in Visual Basic) | TimeBarStrokeProperty | Identifies the DependencyProperty for the TimeBarStroke Property
static (Shared in Visual Basic) | TimeBarStrokeThicknessProperty | Identifies the DependencyProperty for the TimeBarStrokeThickness Property
static (Shared in Visual Basic) | TimeBarTextWrapProperty | Identifies the DependencyProperty for the TimeBarTextWrap Property
static (Shared in Visual Basic) | TimeDistanceProperty | Identifies the DependencyProperty for the TimeDistance Property
static (Shared in Visual Basic) | TipsBackgroundProperty | Identifies the DependencyProperty for the TipsBackground Property
static (Shared in Visual Basic) | TipsFontFamilyProperty | Identifies the DependencyProperty for the TipsFontFamily Property
static (Shared in Visual Basic) | TipsFontSizeProperty | Identifies the DependencyProperty for the TipsFontSize Property
static (Shared in Visual Basic) | TipsFontStyleProperty | Identifies the DependencyProperty for the TipsFontStyle Property
static (Shared in Visual Basic) | TipsFontWeightProperty | Identifies the DependencyProperty for the TipsFontWeight Property
static (Shared in Visual Basic) | TipsForegroundProperty | Identifies the DependencyProperty for the TipsForeground Property
static (Shared in Visual Basic) | TipsOnChangeBarProperty | Identifies the DependencyProperty for the TipsOnChangeBar Property
static (Shared in Visual Basic) | TipsOnCreateBarProperty | Identifies the DependencyProperty for the TipsOnCreateBar Property
static (Shared in Visual Basic) | TipsOnGuideLinesProperty | Identifies the DependencyProperty for the TipsOnGuideLines Property
static (Shared in Visual Basic) | TipsOnNotesProperty | Identifies the DependencyProperty for the TipsOnNotes Property
static (Shared in Visual Basic) | TipsOnOverBarProperty | Identifies the DependencyProperty for the TipsOnOverBar Property
static (Shared in Visual Basic) | TipsShadowColorProperty | Identifies the DependencyProperty for the TipsShadowColor Property
static (Shared in Visual Basic) | TipsShadowOpacityProperty | Identifies the DependencyProperty for the TipsShadowOpacity Property
static (Shared in Visual Basic) | TipsShadowsProperty | Identifies the DependencyProperty for the TipsShadows Property
static (Shared in Visual Basic) | TipsStrokeProperty | Identifies the DependencyProperty for the TipsStroke Property
static (Shared in Visual Basic) | TipsStrokeThicknessProperty | Identifies the DependencyProperty for the TipsStrokeThickness Property
static (Shared in Visual Basic) | ToolbarBackgroundProperty | Identifies the DependencyProperty for the ToolbarBackground Property
static (Shared in Visual Basic) | ToolbarOnRightClickProperty | Identifies the DependencyProperty for the ToolbarOnRightClick Property
static (Shared in Visual Basic) | ToolbarShadowColorProperty | Identifies the DependencyProperty for the ToolbarShadowColor Property
static (Shared in Visual Basic) | ToolbarShadowOpacityProperty | Identifies the DependencyProperty for the ToolbarShadowOpacity Property
static (Shared in Visual Basic) | ToolbarShadowProperty | Identifies the DependencyProperty for the ToolbarShadow Property
static (Shared in Visual Basic) | TreeCloseProperty | Identifies the DependencyProperty for the TreeClose Property
static (Shared in Visual Basic) | TreeLevelIndentProperty | Identifies the DependencyProperty for the TreeLevelIndent Property
static (Shared in Visual Basic) | TreeOpenProperty | Identifies the DependencyProperty for the TreeOpen Property
static (Shared in Visual Basic) | WeekendBackgroundProperty | Identifies the DependencyProperty for the WeekendBackground Property
static (Shared in Visual Basic) | WeekendDaysProperty | Identifies the DependencyProperty for the WeekendDays Property
Top

Public Properties

 | Name | Description
public Property | ActiveSchedule | Gets or sets the active or visible schedule in the control.
public Property | AllowHorzMoves | Gets or sets whether whether time bars can be moved horizontally with the mouse.
public Property | AllowNewBars | Gets or sets whether time bars can be added with the mouse.
public Property | AllowResizeBars | Gets or sets whether time bars can be resized with the mouse.
public Property | AllowVertMoves | Gets or sets whether whether time bars can be moved vertically with the mouse.
public Property | AltListBrushes | Gets or sets whether the background of list items will be painted with alternating brushes.
public Property | AltListEvenBackground | Gets or sets the brush used to paint the background of a list item when painting alternate list item backgrounds.
public Property | AltListItems | Gets or sets the amount of lines to paint the list item backgrounds with one brush before the other brush is used.
public Property | AltListOddBackground | Gets or sets the brush used to paint the background of a list item when painting alternate list item backgrounds.
public Property | AutoDuplicate | Gets or sets whether a duplicate time bar will be created when the "Shift" key is pressed, and a time bar is clicked and dragged.
public Property | BarSelectBackground | Gets or sets the brush used to paint the selected time bars.
public Property | BarSelectForeground | Gets or sets the brush used to paint the text in selected time bars.
public Property | BarSelectStroke | Gets or sets the brush used to paint the border of selected time bars.
public Property | BarSelectStrokeThickness | Gets or sets default stroke thickness for the line used to paint the border of a selected time bar.
public Property | BorderBrush | Gets or sets the Brush used to paint the main borders in the control
public Property | Columns | Gets or sets the list of columns in the list side of the control.
public Property | ControlStyle | Sets a series of properties so that the control represents a certain style or theme.
public Property | CornerBackground | Gets or sets the brush used to paint the bottom right corner of the control when it becomes visible.
public Property | CurrentTimeColorTo | Gets or sets the secondary color of the current time line.
public Property | CurrentTimeLine | Gets or sets whether the current time line will be displayed in the schedule.
public Property | CurrentTimeOffset | Gets or sets the time span used to offset the current time and date.
public Property | CurrentTimeStroke | Gets or sets the brush used to paint the current time line.
public Property | CurrentTimeStrokeThickness | Gets or sets default stroke thickness for the line used to paint the current time line.
public Property | CustomAreaBackground | Gets or sets the default brush used to paint the CustomAreas in the schedule.
public Property | CustomAreas | Gets or sets the list of custom areas for the schedule.
public Property | DayMonthOffset | Gets or sets the offset used to calculate the starting day of the week in a monthly ruler.
public Property | DayNames | Gets or sets the names of the day of the week.
public Property | DisplayGuideLines | Gets or sets whether guide lines will be painted in the schedules.
public Property | DisplayListGuide | Gets or sets whether a list guide can appear in the schedule.
public Property | DivisionDistance | Gets or sets how close the edge of a time bar must be to a major time division point before the time bar is snapped to that point (in pixels).
public Property | EditMode | Gets or sets the edit mode for the schedule.
public Property | FillList | Gets or sets whether the last list column fills the list area.
public Property | GridFrequency | Gets or sets the distance where the bar can be moved or sized to.
public Property | GuideImagePosition | Gets or sets whether guid line images will appear in the front or behind of the ruler text.
public Property | GuideLineDashPattern | Gets or sets the dash pattern used to paint the guide lines.
public Property | GuideLineDistance | Gets or sets how close the edge of a time bar must be to a guide line before the time bar is snapped to the guide line location (in pixels).
public Property | GuideLinePosition | Gets or sets whether guide lines will be in the front or back of the time bars.
public Property | GuideLineStroke | Gets or sets the default brush used to paint the guide lines.
public Property | GuideLineStrokeThickness | Gets or sets default stroke thickness for the line used to paint the guide lines.
public Property | GuideSelectStroke | Gets or sets the brush used to paint the currently selected guide line.
public Property | HandleListRightClick | Gets or sets whether the control will handle the right click event if the right click occurs in the list.
public Property | HandleMapAreaRightClick | Gets or sets whether the control will handle the right click event if the right click occurs in the map area.
public Property | HandleScheduleRightClick | Gets or sets whether the control will handle the right click event if the right click occurs in the schedule.
public Property | HeaderAlign | Gets or sets the default alignment for the text in the column headers in the list.
public Property | HeaderBackground | Gets or sets the brush used to paint the background of the column headers in the list.
public Property | HeaderFontFamily | Gets or sets the font family used to paint the text in a column header.
public Property | HeaderFontSize | Gets or sets the font size used to paint the text in a column header.
public Property | HeaderFontStyle | Gets or sets the font style used to paint the text in a column header.
public Property | HeaderFontWeight | Gets or sets the font weight used to paint the text in a column header.
public Property | HeaderForeground | Gets or sets the brush used to paint the text of the column header.
public Property | HeaderHeight | Gets or sets the height of the header in the list.
public Property | HeaderVisible | Gets or sets whether the column headers in the list will be visible
public Property | HistorySize | Gets or sets the maximum size of the history file.
public Property | Images | Gets or sets the list containing the various images for the control.
public Property | ItemHeaderBackground | Gets or sets the brush used to paint the background of list items marked as headers in the list.
public Property | ItemHeaderForeground | Gets or sets the brush used to paint the foreground of list items marked as headers in the list.
public Property | ItemHeightOffset | Gets or Sets the offset used to calculate the height of items in the list.
public Property | Items | Gets or sets the collection of list items in the control.
public Property | LineArrowAfter | Gets or sets the image used for the image after arrow marker.
public Property | LineArrowBackground | Gets or sets the default brush used to paint the solid line arrows.
public Property | LineArrowBefore | Gets or sets the image used for the image before arrow marker.
public Property | LineArrowPosition | Gets or sets where the line arrows will be drawn in the schedules.
public Property | LineArrowType | Gets or sets the type of line arrows that will be drawn in the schedules.
public Property | LinkLineStroke | Gets or sets the default brush used to paint the link lines.
public Property | Links | Gets or sets the the links used to connect different time bars
public Property | ListBackground | Gets or sets the brush used to paint the background of the list.
public Property | ListFontFamily | Gets or sets the font family used to paint the text in a list.
public Property | ListFontSize | Gets or sets the font size used to paint the text in a list.
public Property | ListFontStyle | Gets or sets the font style used to paint the text in a list.
public Property | ListFontWeight | Gets or sets the font weight used to paint the text in a list.
public Property | ListForeground | Gets or sets the brush used to paint the text of the list.
public Property | ListGuideBackground | Gets or sets the default brush used to paint the background of the list guide.
public Property | ListGuideDistance | Gets or sets the minimum distance that the mouse has to be from the splitter bar before the list guide appears.
public Property | ListGuideFadeDuration | Gets or sets the time in milliseconds on how fast to allow the list guide to fade into appearance.
public Property | ListGuideForeground | Gets or sets the default brush used to paint the text or foreground of the list guide.
public Property | ListGuideWidth | Gets or sets the width of the list guide.
public Property | ListHorzStroke | Gets or sets the brush used to paint the horizontal lines in the list area.
public Property | ListHorzStrokeThickness | Gets or sets default stroke thickness used to paint the horizontal lines in the list area.
public Property | ListImageAlign | Gets or sets the default horizontal alignment of the images in the list.
public Property | ListItemHeight | Gets the height of the list items in the control.
public Property | ListScrollValue | Gets or sets the value of the lists horizontal scroll bar.
public Property | ListTextAlign | Gets or sets the default horizontal alignment of the text in the list.
public Property | ListTitle | Gets or sets the text to be displayed at the top of the list. This text will only be painted if no columns have been defined.
public Property | ListType | Gets or sets whether the list side of the control will act as a tree view or list view control.
public Property | ListVertStroke | Gets or sets the brush used to paint the vertical lines in the list area.
public Property | ListVertStrokeThickness | Gets or sets default stroke thickness used to paint the vertical lines in the list area.
public Property | ListWidth | Gets or sets the width of the list area of the control.
public Property | MapArea | Gets or sets whether the map area of the control will be visible.
public Property | MapBackground | Gets or sets the brush used to paint the background of the map area.
public Property | MapHeight | Gets or sets the height of the map area.
public Property | MapLine | Gets or sets the brush used to paint the current view border of the map area.
public Property | MapLineThickness | Gets or sets default stroke thickness used to paint the border of the current view of the map area.
public Property | MapStroke | Gets or sets the brush used to paint the border of the map area.
public Property | MapStrokeThickness | Gets or sets default stroke thickness used to paint the border of the map area.
public Property | MinBarTime | Gets or sets the minimum time span of a time bar.
public Property | MonthNames | Gets or sets the names of the month of the year.
public Property | NotesDistance | Gets or sets the distance between notes when locked.
public Property | NotesPosition | Gets or sets where the schedule notes will be drawn in the schedules.
public Property | OverlapSpan | Gets or sets the additional time span used to determine if a time bar overlaps another time bar.
public Property | OverlapStroke | Gets or sets the default brush used to paint the overlap lines for the time bars.
public Property | OverlapStrokeThickness | Gets or sets default stroke thickness used to paint the overlap lines for the time bars.
public Property | PercentBackground | Gets or sets the brush used to paint the backround of a percent bar within a time bar.
public Property | PrintFontFamily | Gets or sets the font family used to paint the sub-title and footer text in a printed report.
public Property | PrintFontSize | Gets or sets the font size used to paint the sub-title and footer text in a printed report.
public Property | PrintFontStyle | Gets or sets the font style used to paint the sub-title and footer text in a printed report.
public Property | PrintFontWeight | Gets or sets the font weight used to paint the sub-title and footer text in a printed report.
public Property | PrintFooterAlign | Gets or sets the horizontal alignment of the footer text in a printed report.
public Property | PrintFooterMargin | Gets or sets the margin space used to place around the footer in a printed report.
public Property | PrintListAlways | Gets or sets whether the list will be printed on every page of a printed report.
public Property | PrintListWidth | Gets or sets the width of the list in a printed report.
public Property | PrintMargin | Gets or sets the margin space used to determine the area on a page that cannot be printed to.
public Property | PrintPageText | Gets or sets the text describing the page number in the footer.
public Property | PrintSubTitle | Gets or sets the sub-title for the printed report.
public Property | PrintSubTitleMargin | Gets or sets the margin space used to place around the sub-titles in a printed report.
public Property | PrintTimeDistance | Gets or sets the distance between the major time units in a printed report.
public Property | PrintTitle | Gets or sets the title for the printed report.
public Property | PrintTitleAlign | Gets or sets the alignment for the print title.
public Property | PrintTitleFontFamily | Gets or sets the font family used to paint the title in a printed report.
public Property | PrintTitleFontSize | Gets or sets the font size used to paint the title in a printed report.
public Property | PrintTitleFontStyle | Gets or sets the font style used to paint the title in a printed report.
public Property | PrintTitleFontWeight | Gets or sets the font weight used to paint the title in a printed report.
public Property | PrintTitleMargin | Gets or sets the margin space used to place around the titles in a printed report.
public Property | RedoHistory | Gets the redo history file for the time bars.
public Property | RulerBackground | Gets or sets the brush used to paint the background of the ruler area.
public Property | RulerFontFamily | Gets or sets the font family used to paint the text in a list.
public Property | RulerFontSize | Gets or sets the font size used to paint the text in a list.
public Property | RulerFontStyle | Gets or sets the font style used to paint the text in a list.
public Property | RulerFontWeight | Gets or sets the font weight used to paint the text in a list.
public Property | RulerForeground | Gets or sets the brush used to paint the foreground of the ruler area.
public Property | RulerLineStroke | Gets or sets the brush used to paint lines in the ruler.
public Property | RulerSelectBackground | Gets or sets the brush used to paint the selected time bars span in the ruler.
public Property | RulerSelectOffset | Gets or sets the offset value used to calculate the vertical height and position of the selected area in the rulers.
public Property | SchedScrollValue | Gets or sets the value of the schedules horizontal scroll bar.
public Property | ScheduleAreaWidth | Gets or sets the width of the schedule area of the control.
public Property | ScheduleBackground | Gets or sets the brush used to paint the background of the schedule area.
public Property | ScheduleHeaderBackground | Gets or sets the brush used to paint the background of schedule items marked as headers in the list.
public Property | ScheduleHeaderPosition | Gets or sets whether schedule header line items will be in the front or back of the custom areas and time lines.
public Property | ScheduleHorzStroke | Gets or sets the brush used to paint the horizontal lines in the schedule area.
public Property | ScheduleHorzStrokeThickness | Gets or sets default stroke thickness for the line used to paint the horizontal lines in the schedule area.
public Property | Schedules | Gets or sets the list of schedules within the control.
public Property | SelectedBackground | Gets or sets the brush used to paint the background of selected list items in the list.
public Property | SelectedForeground | Gets or sets the brush used to paint the text of selected list items in the list.
public Property | SelectedRadius | Gets or sets the x-radius of the ellipse that is used to round the corner of a selected list item.
public Property | SelectedStroke | Gets or sets the default brush used to paint the border of a selected list item.
public Property | SelectedStrokeThickness | Gets or sets default stroke thickness for the line used to paint the border of a selected list item.
public Property | SelectModeDashPattern | Gets or sets the dash pattern used to paint the selected mode lines.
public Property | SelectModeStroke | Gets or sets the default brush used to paint the selected mode lines.
public Property | SelectModeStrokeThickness | Gets or sets default stroke thickness for the line used to paint the selected modelines.
public Property | SnapToDivisions | Gets or sets how a time bar will align itself to the major ruler division points when being created, moved, or sized with the mouse.
public Property | SnapToGrid | Gets or sets whether a time bar will use the GridFrequency value to align itself to the control when being created, moved or sized with the mouse.
public Property | SnapToGuide | Gets or sets whether a time bar will align itself to the guide line when being created, moved or sized with the mouse.
public Property | SortArrowAscend | Gets or sets the image used for the ascending sort arrow.
public Property | SortArrowBackground | Gets or sets the brush used to paint the sort arrows in the column headers in the list.
public Property | SortArrowDescend | Gets or sets the image used for the descending sort arrow.
public Property | SortArrowHorzAlign | Gets or sets the value used horizontally align the sort arrows in the list.
public Property | SortArrowOffset | Gets or sets the value used to calculate the horizontal and vertical position of the sort arrows in the list.
public Property | SortArrowSize | Gets or sets the size of length of the sort arrows in the list.
public Property | SortArrowVertAlign | Gets or sets the value used vertically align the sort arrows in the list.
public Property | SortOnCase | Gets or sets whether a sort routine will test for upper or lower case text when performing the sort.
public Property | SplitterBarBackground | Gets or sets the brush used to paint the splitter bar.
public Property | SplitterBarWidth | Gets or sets the width of the splitter bar area of the control.
public Property | TextIntoView | Gets or sets whether the text in a time bar will always be placed in the visible part of the time bar.
public Property | TimeBarBackground | Gets or sets the default brush used to paint the time bars in the schedule.
public Property | TimeBarExtension | Gets or sets the extension size on each side of a time bar used to resize a time bar with the mouse.
public Property | TimeBarFontFamily | Gets or sets the font family used to paint the text in a time bar.
public Property | TimeBarFontSize | Gets or sets the font size used to paint the text in a time bar.
public Property | TimeBarFontStyle | Gets or sets the font style used to paint the text in a time bar.
public Property | TimeBarFontWeight | Gets or sets the font weight used to paint the text in a time bar.
public Property | TimeBarForeground | Gets or sets the default brush used to paint the text of the time bars in the schedule.
public Property | TimeBarMargin | Gets or sets the margin size on each side of a time bar used to resize a time bar with the mouse.
public Property | TimeBarMinWidth | Gets or sets the minimim width for a time bar.
public Property | TimeBarRadius | Gets or sets the radius of the ellipse that is used to round the corner of a time bar.
public Property | TimeBarShadowColor | Gets or sets the color of a time bar shadow effect
public Property | TimeBarShadowOpacity | Gets or sets the opacity of a time bar shadow effect.
public Property | TimeBarShadows | Gets or sets whether a shadow effect will be placed around a time bar.
public Property | TimeBarStroke | Gets or sets the default brush used to paint the time bar borders in the schedule.
public Property | TimeBarStrokeThickness | Gets or sets default stroke thickness for the line used to paint the border of a time bar.
public Property | TimeBarTextWrap | Gets or sets whether the text in a time bar can be displayed on multiple lines.
public Property | TimeDistance | Gets or sets the distance between the major time units.
public Property | TipsBackground | Gets or sets the brush used to paint the backround of a tool tip.
public Property | TipsFontFamily | Gets or sets the font family used to paint the text in the tool tips.
public Property | TipsFontSize | Gets or sets the font size used to paint the text in the tool tips.
public Property | TipsFontStyle | Gets or sets the font style used to paint the text in the tool tips.
public Property | TipsFontWeight | Gets or sets the font weight used to paint the text in the tool tips.
public Property | TipsForeground | Gets or sets the brush used to paint the text of a tool tip.
public Property | TipsOnChangeBar | Gets or sets whether tool tips will appear when a time bar is being moved or sized.
public Property | TipsOnCreateBar | Gets or sets whether tool tips will appear when a time bar is being created.
public Property | TipsOnGuideLines | Gets or sets whether tool tips will appear when the mouse is dragging a guide line.
public Property | TipsOnNotes | Gets or sets whether tool tips will appear when the mouse hovers over a note.
public Property | TipsOnOverBar | Gets or sets whether tool tips will appear when the mouse hovers over a time bar.
public Property | TipsShadowColor | Gets or sets the color of a tool tip shadow effect.
public Property | TipsShadowOpacity | Gets or sets the opacity of a tool tip shadow effect.
public Property | TipsShadows | Gets or sets whether a shadow effect will be placed around a tool tip.
public Property | TipsStroke | Gets or sets the brush used to paint the border of a tool tip.
public Property | TipsStrokeThickness | Gets or sets the border thickness of a tool tip.
public Property | ToolbarBackground | Gets or sets the brush used to paint the backround of the tool bar.
public Property | ToolbarOnRightClick | Gets or sets whether a tool bar for the edit modes will appear when the schedule is right clicked on.
public Property | ToolbarShadow | Gets or sets whether a shadow effect will be placed around a tool bar.
public Property | ToolbarShadowColor | Gets or sets the color of a tool bar shadow effect.
public Property | ToolbarShadowOpacity | Gets or sets the opacity of a tool bar shadow effect.
public Property | TreeClose | Gets or sets the image used in the list to represent items that own other child items they are not being shown.
public Property | TreeLevelIndent | Gets or sets on offset used to calculate the distance to indent each level of a tree.
public Property | TreeOpen | Gets or sets the image used in the list to represent items that own other child items they are being shown.
public Property | UndoHistory | Gets the undo history file for the time bars.
public Property | VertScrollValue | Gets or sets the value of the vertical scroll bar.
public Property | WeekendBackground | Gets or sets the brush used to paint the days marked as weekends.
public Property | WeekendDays | Gets or sets the list that represents the days representing the weekend.
Top

Public Methods

 | Name | Description
public Method | BarToBack | Move the time bar behind all other time bars in the schedule area.
public Method | BarToFront | Move the time bar in front of all other time bars in the schedule area.
public Method | CustomBrush | Creates a custom gradient based on two colors and a pattern.
public Method | DateTimeAt | Overloaded. Gets the DateTime value that exists at a given point. Coordinates provided here are based on the schedule area and not the control itself.
public Method | EnsureListItemVisible | Ensures that the list item is visible and moved to the current viewing area.
public Method | InDeadZone | Overloaded. Determines if there is a conflict with a deadzone
public Method | IndexesFromTimeBar | Gets the index value of the time bar and its parent item.
public Method | IndexFromListItem | Gets the current line item index value of a dbiListItem object.
public Method | IndexOfListItem | Gets the absolute line item index value of a dbiListItem object.
public Method | InitializeComponent | InitializeComponent
public Method | Invalidate | Invalidates the control to cause it to redraw itself.
public Method | ListItemAt | Get the list item object that exists at a given point.
public Method | ListItemParent | Gets the parent item of a time bar.
public Method | NotesAt | Get a list of ScheduleNotes that exists at a given point.
public Method | Print | Print the contents of the active schedule.
public Method | Redo | Perform an redo operation.
public Method | RulerHeight | Gets the height of the ruler in the schedule area.
public Method | ScheduleAreaAt | Gets the part of the schedule that exists at a given point.
public Method | ScrollToDateTime | Moves the position of the horizontal scroll bar in the schedule so that a given DateTime value is visible.
public Method | SelectedTimeBars | Gets a collection of time bars that are currently selected in the control.
public Method | SortList | Sorts the items within the list.
public Method | TimeBarParent | Gets the parent list item of a time bar.
public Method | TimeBarsAfterSchedule | Overloaded. Gets a collection of time bars that exist after the visble area of a schedule.
public Method | TimeBarsAt | Overloaded. Gets a collection of time bars that exists at a given point
public Method | TimeBarsBeforeSchedule | Overloaded. Gets a collection of time bars that exist before the visble area of a schedule.
public Method | Undo | Perform an undo operation.
Top

Public Events

 | Name | Description
public Event | AfterGuideLineInserted | Event fired after a new GuideLine is inserted with the mouse.
public Event | AfterGuideLineMoved | Event fired after a GuideLine is moved with the mouse.
public Event | AfterGuideLineRemoved | Event fired after a GuideLine is removed with the mouse.
public Event | AfterPrint | Event fired after the print operation has completed.
public Event | AfterTimeBarInserted | Occurs after a Timebar is inserted.
public Event | AfterTimeBarLinked | Occurs after 2 Timebars have been linked together.
public Event | AfterTimeBarMoved | Occurs after a Timebar has been moved.
public Event | AfterTimeBarRemoved | Occurs after a Timebar is removed.
public Event | AfterTimeBarSized | Occurs after a Timebar has been sized.
public Event | AfterTimeBarSplit | Occurs after a time bar has been split.
public Event | AfterTimeBarUnlinked | Occurs after the link between two Timebars has been removed.
public Event | BeforeGuideLineInsert | Event fired before a new GuideLine is inserted with the mouse.
public Event | BeforeGuideLineMove | Event fired before a GuideLine is moved with the mouse.
public Event | BeforeGuideLineRemove | Event fired before a GuideLine is removed with the mouse.
public Event | BeforePrint | Event fired before the print operation has started.
public Event | BeforeTimeBarInsert | Occurs before a Timebar is inserted.
public Event | BeforeTimeBarLink | Occurs before 2 times bars are linked together.
public Event | BeforeTimeBarMove | Occurs before a Timebar is moved.
public Event | BeforeTimeBarRemove | Occurs before a Timebar is removed.
public Event | BeforeTimeBarSelect | Occurs before a Timebar is selected.
public Event | BeforeTimeBarSize | Occurs before a Timebar is sized.
public Event | BeforeTimeBarSplit | Occurs before a time bar is split.
public Event | BeforeTimeBarUnlink | Occurs before the link between two Timebars has been removed.
public Event | BeforeToolTips | Occurs before a tool tip is displayed.
public Event | ColumnHeaderClick | Event fired when the header of a column is clicked.
public Event | ControlError | Occurs when an error takes place in the control.
public Event | DeadZoneDrop | Event fired when a time bar is moved onto a dead zone area with the mouse.
public Event | EditModeChanged | Event fired when the EditMode is changed on the control.
public Event | FirstDraw | Occurs after the control has been drawn for the first time.
public Event | GuideLineClick | Event fired when a GuideLine is clicked.
public Event | GuideLineMove | Event fired when a GuideLine is moved.
public Event | HistoryChange | Occurs when an item in the RedoHistory or UndoHistory collections change.
public Event | ItemMouseOver | Occurs when the mouse moves over a new object ni the schedule area
public Event | LineArrowClick | Event fired when a line arrow is clicked.
public Event | LineArrowMouseOver | Event fired when the mouse moves over a line arrow.
public Event | ListItemClick | Occurs when a list item is clicked.
public Event | NoteClick | Event fired when a schedule note is clicked.
public Event | PrintProgress | Occurs just before each page, of the printed report, is printed.
public Event | RedoAction | Occurs after a redo action has taken place.
public Event | ScheduleClick | Occurs when the schedule area is clicked by the mouse.
public Event | ScheduleMouseMove | Occurs when the mouse moves over the schedule area.
public Event | TimeBarClick | Occurs when a Timebar is clicked on.
public Event | TimeBarSizing | Occurs as the size of the Timebar is being changed by the mouse.
public Event | UndoAction | Occurs after an undo action has taken place.
public Event | UserDrawnBarAfter | This event fires after the timebar image has been created. This allows the developer to work with the graphics of an already drawn timebar.
public Event | UserDrawnBarBefore | Event fired at the point a time bar is drawn to provide custom painting of the time bar area. NOTE: Any time bar can be “User Drawn” and an item can contain any combination of user drawn and control drawn time bars.
public Event | UserDrawnLineAfter | Event fired after all objects have been rendered inside the item. Allowing for custom appearance in front of all other objects.
public Event | UserDrawnLineBefore | Event fired before the list item is rendered, allowing for custom appearance and background.
public Event | ValuePoint | Occurs before each time value is drawn in the ruler.
Top

See Also

Reference

dbiScheduleWPF Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : dbiScheduleWPF Constructor

Initializes a new instance of the dbiScheduleWPF class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF()
C#
public dbiScheduleWPF()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%% $$Methods$$

dbiScheduleWPF Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF Class

"

For a list of all members of this type, see dbiScheduleWPF members.

"

Public Methods

 | Name | Description
public Method | BarToBack | Move the time bar behind all other time bars in the schedule area.
public Method | BarToFront | Move the time bar in front of all other time bars in the schedule area.
public Method | CustomBrush | Creates a custom gradient based on two colors and a pattern.
public Method | DateTimeAt | Overloaded. Gets the DateTime value that exists at a given point. Coordinates provided here are based on the schedule area and not the control itself.
public Method | EnsureListItemVisible | Ensures that the list item is visible and moved to the current viewing area.
public Method | InDeadZone | Overloaded. Determines if there is a conflict with a deadzone
public Method | IndexesFromTimeBar | Gets the index value of the time bar and its parent item.
public Method | IndexFromListItem | Gets the current line item index value of a dbiListItem object.
public Method | IndexOfListItem | Gets the absolute line item index value of a dbiListItem object.
public Method | InitializeComponent | InitializeComponent
public Method | Invalidate | Invalidates the control to cause it to redraw itself.
public Method | ListItemAt | Get the list item object that exists at a given point.
public Method | ListItemParent | Gets the parent item of a time bar.
public Method | NotesAt | Get a list of ScheduleNotes that exists at a given point.
public Method | Print | Print the contents of the active schedule.
public Method | Redo | Perform an redo operation.
public Method | RulerHeight | Gets the height of the ruler in the schedule area.
public Method | ScheduleAreaAt | Gets the part of the schedule that exists at a given point.
public Method | ScrollToDateTime | Moves the position of the horizontal scroll bar in the schedule so that a given DateTime value is visible.
public Method | SelectedTimeBars | Gets a collection of time bars that are currently selected in the control.
public Method | SortList | Sorts the items within the list.
public Method | TimeBarParent | Gets the parent list item of a time bar.
public Method | TimeBarsAfterSchedule | Overloaded. Gets a collection of time bars that exist after the visble area of a schedule.
public Method | TimeBarsAt | Overloaded. Gets a collection of time bars that exists at a given point
public Method | TimeBarsBeforeSchedule | Overloaded. Gets a collection of time bars that exist before the visble area of a schedule.
public Method | Undo | Perform an undo operation.
Top

See Also

Reference

dbiScheduleWPF Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BarToBack Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarToBack Method

objTimeBar
The dbiTimeBar to shift behind all other time bars.
Move the time bar behind all other time bars in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objTimeBar As dbiTimeBarItem
Dim value As Boolean

value = instance.BarToBack(objTimeBar)
C#
public bool BarToBack(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimeBar to shift behind all other time bars.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BarToFront Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarToFront Method

objTimeBar
The dbiTimeBar to shift in front all other time bars.
Move the time bar in front of all other time bars in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objTimeBar As dbiTimeBarItem
Dim value As Boolean

value = instance.BarToFront(objTimeBar)
C#
public bool BarToFront(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimeBar to shift in front all other time bars.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CustomBrush Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CustomBrush Method

clrFrom
The primary color for the custom brush
clrTo
The secondary color for the custom brush
enumBrush
The fill effect to create for the brush.
Creates a custom gradient based on two colors and a pattern.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim clrFrom As Color
Dim clrTo As Color
Dim enumBrush As enumBrushType
Dim value As LinearGradientBrush

value = instance.CustomBrush(clrFrom, clrTo, enumBrush)
C#
public LinearGradientBrush CustomBrush(
   Color clrFrom,
   Color clrTo,
   enumBrushType enumBrush
)

Parameters

clrFrom
The primary color for the custom brush
clrTo
The secondary color for the custom brush
enumBrush
The fill effect to create for the brush.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DateTimeAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DateTimeAt Method

Gets the DateTime value that exists at a given point. Coordinates provided here are based on the schedule area and not the control itself.

Overload List

Overload | Description
DateTimeAt(Int32) | Gets the DateTime value that exists at a given point. Coordinates provided here are based on the schedule area and not the control itself.
DateTimeAt(Point) | Gets the DateTime value that exists at a given point. Coordinates provided here are based on the schedule area and not the control itself.
DateTimeAt(Point,dbiScheduleObject) | Gets the DateTime value that exists at a given point. Coordinates provided here are based on the schedule area and not the control itself.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DateTimeAt(Int32) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > DateTimeAt Method : DateTimeAt(Int32) Method

nxPoint
The x-coordinate to retrieve the datetime value of.
Gets the DateTime value that exists at a given point. Coordinates provided here are based on the schedule area and not the control itself.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim nxPoint As Integer
Dim value As Date

value = instance.DateTimeAt(nxPoint)
C#
public DateTime DateTimeAt(
   int nxPoint
)

Parameters

nxPoint
The x-coordinate to retrieve the datetime value of.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

DateTimeAt(Point) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > DateTimeAt Method : DateTimeAt(Point) Method

ptMouse
The coordinates to retrieve the datetime value of.
Gets the DateTime value that exists at a given point. Coordinates provided here are based on the schedule area and not the control itself.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ptMouse As Point
Dim value As Date

value = instance.DateTimeAt(ptMouse)
C#
public DateTime DateTimeAt(
   Point ptMouse
)

Parameters

ptMouse
The coordinates to retrieve the datetime value of.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

DateTimeAt(Point,dbiScheduleObject) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > DateTimeAt Method : DateTimeAt(Point,dbiScheduleObject) Method

ptMouse
The coordinates to retrieve the datetime value of.
objSchedule
The dbiScheduleObject the coordinates are relative to.
Gets the DateTime value that exists at a given point. Coordinates provided here are based on the schedule area and not the control itself.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ptMouse As Point
Dim objSchedule As dbiScheduleObject
Dim value As Date

value = instance.DateTimeAt(ptMouse, objSchedule)
C#
public DateTime DateTimeAt(
   Point ptMouse,
   dbiScheduleObject objSchedule
)

Parameters

ptMouse
The coordinates to retrieve the datetime value of.
objSchedule
The dbiScheduleObject the coordinates are relative to.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

EnsureListItemVisible Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : EnsureListItemVisible Method

objItem
The dbiListItem to ensure visible.
Ensures that the list item is visible and moved to the current viewing area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objItem As dbiListItem
Dim value As Boolean

value = instance.EnsureListItemVisible(objItem)
C#
public bool EnsureListItemVisible(
   dbiListItem objItem
)

Parameters

objItem
The dbiListItem to ensure visible.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InDeadZone Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InDeadZone Method

Determines if there is a conflict with a deadzone

Overload List

Overload | Description
InDeadZone(dbiTimeBarItem,dbiListItem) | Determine if a time bar is inside a dead zone.
InDeadZone(DateTime,DateTime,dbiListItem,Boolean) | Determine if a given time period is inside a dead zone.
InDeadZone(DateTime,DateTime,dbiTimeBarItem,dbiListItem,Boolean) | Determine if a given time period is inside a dead zone.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InDeadZone(dbiTimeBarItem,dbiListItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > InDeadZone Method : InDeadZone(dbiTimeBarItem,dbiListItem) Method

objTimeBar
The time bar to test.
objItem
The dbiListItem to test the customarea collection of.
Determine if a time bar is inside a dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objTimeBar As dbiTimeBarItem
Dim objItem As dbiListItem
Dim value As Boolean

value = instance.InDeadZone(objTimeBar, objItem)
C#
public bool InDeadZone(
   dbiTimeBarItem objTimeBar,
   dbiListItem objItem
)

Parameters

objTimeBar
The time bar to test.
objItem
The dbiListItem to test the customarea collection of.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

InDeadZone(DateTime,DateTime,dbiListItem,Boolean) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > InDeadZone Method : InDeadZone(DateTime,DateTime,dbiListItem,Boolean) Method

dtBarStart
The starting datetime value
dtBarEnd
The ending datetime value
objItem
The dbiListItem to test the customarea collection of.
bGuideLine
Determines if the test is for a guideline.
Determine if a given time period is inside a dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dtBarStart As Date
Dim dtBarEnd As Date
Dim objItem As dbiListItem
Dim bGuideLine As Boolean
Dim value As Boolean

value = instance.InDeadZone(dtBarStart, dtBarEnd, objItem, bGuideLine)
C#
public bool InDeadZone(
   DateTime dtBarStart,
   DateTime dtBarEnd,
   dbiListItem objItem,
   bool bGuideLine
)

Parameters

dtBarStart
The starting datetime value
dtBarEnd
The ending datetime value
objItem
The dbiListItem to test the customarea collection of.
bGuideLine
Determines if the test is for a guideline.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

InDeadZone(DateTime,DateTime,dbiTimeBarItem,dbiListItem,Boolean) Method
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > InDeadZone Method : InDeadZone(DateTime,DateTime,dbiTimeBarItem,dbiListItem,Boolean) Method

dtBarStart
The starting datetime value
dtBarEnd
The ending datetime value
objTimeBar
The time bar to test.
objItem
The dbiListItem to test the customarea collection of.
bGuideLine
Determines if the test is for a guideline.
Determine if a given time period is inside a dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dtBarStart As Date
Dim dtBarEnd As Date
Dim objTimeBar As dbiTimeBarItem
Dim objItem As dbiListItem
Dim bGuideLine As Boolean
Dim value As Boolean

value = instance.InDeadZone(dtBarStart, dtBarEnd, objTimeBar, objItem, bGuideLine)
C#
public bool InDeadZone(
   DateTime dtBarStart,
   DateTime dtBarEnd,
   dbiTimeBarItem objTimeBar,
   dbiListItem objItem,
   bool bGuideLine
)

Parameters

dtBarStart
The starting datetime value
dtBarEnd
The ending datetime value
objTimeBar
The time bar to test.
objItem
The dbiListItem to test the customarea collection of.
bGuideLine
Determines if the test is for a guideline.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

IndexesFromTimeBar Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IndexesFromTimeBar Method

objTimeBar
The time bar to retrieve the indexes for.
Gets the index value of the time bar and its parent item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objTimeBar As dbiTimeBarItem
Dim value As Point

value = instance.IndexesFromTimeBar(objTimeBar)
C#
public Point IndexesFromTimeBar(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The time bar to retrieve the indexes for.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IndexFromListItem Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IndexFromListItem Method

itemFrom
The dbiListItem to retrieve the index value for.
Gets the current line item index value of a dbiListItem object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim itemFrom As dbiListItem
Dim value As Integer

value = instance.IndexFromListItem(itemFrom)
C#
public int IndexFromListItem(
   dbiListItem itemFrom
)

Parameters

itemFrom
The dbiListItem to retrieve the index value for.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IndexOfListItem Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IndexOfListItem Method

objFindItem
The dbiListItem to retrieve the index value for.
Gets the absolute line item index value of a dbiListItem object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objFindItem As dbiListItem
Dim value As Integer

value = instance.IndexOfListItem(objFindItem)
C#
public int IndexOfListItem(
   dbiListItem objFindItem
)

Parameters

objFindItem
The dbiListItem to retrieve the index value for.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InitializeComponent Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InitializeComponent Method

InitializeComponent

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.InitializeComponent()
C#
[DebuggerNonUserCodeAttribute()]
[GeneratedCodeAttribute(Tool="PresentationBuildTasks", Version="4.0.0.0")]
public void InitializeComponent()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Invalidate() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Invalidate() Method

Invalidates the control to cause it to redraw itself.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListItemAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListItemAt Method

ptPoint
The coordinates to check for a dbiListItem.
Get the list item object that exists at a given point.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ptPoint As Point
Dim value As dbiListItem

value = instance.ListItemAt(ptPoint)
C#
public dbiListItem ListItemAt(
   Point ptPoint
)

Parameters

ptPoint
The coordinates to check for a dbiListItem.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListItemParent Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListItemParent Method

objTimeBar
The time bar to retrieve the parent item of.
Gets the parent item of a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objTimeBar As dbiTimeBarItem
Dim value As dbiListItem

value = instance.ListItemParent(objTimeBar)
C#
public dbiListItem ListItemParent(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The time bar to retrieve the parent item of.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

NotesAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : NotesAt Method

ptPoint
The coordinates to check for dbiScheduleNotes.
Get a list of ScheduleNotes that exists at a given point.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ptPoint As Point
Dim value As List(Of dbiScheduleNote)

value = instance.NotesAt(ptPoint)
C#
public List<dbiScheduleNote> NotesAt(
   Point ptPoint
)

Parameters

ptPoint
The coordinates to check for dbiScheduleNotes.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Print Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Print Method

Print the contents of the active schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.Print()
C#
public void Print()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Redo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Redo Method

Perform an redo operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.Redo()
C#
public bool Redo()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerHeight Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerHeight Method

Gets the height of the ruler in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

value = instance.RulerHeight()
C#
public int RulerHeight()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleAreaAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleAreaAt Method

ptPoint
The coordinates to determine the relative area of the control.
Gets the part of the schedule that exists at a given point.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ptPoint As Point
Dim value As enumScheduleArea

value = instance.ScheduleAreaAt(ptPoint)
C#
public enumScheduleArea ScheduleAreaAt(
   Point ptPoint
)

Parameters

ptPoint
The coordinates to determine the relative area of the control.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScrollToDateTime Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScrollToDateTime Method

dtValue
The datetime value to scroll the view to.
nOffset
The amount of time segments to use as a buffer from the left side of the schedule when displaying the requested DayeTime value. By default, the requested DateTime value will be displayed as the first time segment in the control. We can move this to the left or right by entering a value to this parameter other than 0.
Moves the position of the horizontal scroll bar in the schedule so that a given DateTime value is visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dtValue As Date
Dim nOffset As Short
Dim value As Boolean

value = instance.ScrollToDateTime(dtValue, nOffset)
C#
public bool ScrollToDateTime(
   DateTime dtValue,
   short nOffset
)

Parameters

dtValue
The datetime value to scroll the view to.
nOffset
The amount of time segments to use as a buffer from the left side of the schedule when displaying the requested DayeTime value. By default, the requested DateTime value will be displayed as the first time segment in the control. We can move this to the left or right by entering a value to this parameter other than 0.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedTimeBars Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedTimeBars Method

Gets a collection of time bars that are currently selected in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As dbiTimeBarCollection

value = instance.SelectedTimeBars()
C#
public dbiTimeBarCollection SelectedTimeBars()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortList(Int32,enumSortDirection) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortList(Int32,enumSortDirection) Method

nColumn
The index value of the column to sort on.
enumSort
The direction of the sort.
Sorts the items within the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim nColumn As Integer
Dim enumSort As enumSortDirection
Dim value As Boolean

value = instance.SortList(nColumn, enumSort)
C#
public bool SortList(
   int nColumn,
   enumSortDirection enumSort
)

Parameters

nColumn
The index value of the column to sort on.
enumSort
The direction of the sort.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarParent Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarParent Method

objTimeBar
The time bar to retrieve the parent item of.
Gets the parent list item of a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objTimeBar As dbiTimeBarItem
Dim value As dbiListItem

value = instance.TimeBarParent(objTimeBar)
C#
public dbiListItem TimeBarParent(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The time bar to retrieve the parent item of.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarsAfterSchedule Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarsAfterSchedule Method

Gets a collection of time bars that exist after the visble area of a schedule.

Overload List

Overload | Description
TimeBarsAfterSchedule(dbiListItem) | Gets a collection of time bars that exist after the visble area of a schedule.
TimeBarsAfterSchedule(dbiScheduleObject,dbiListItem) | Gets a collection of time bars that exist after the visble area of a schedule.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarsAfterSchedule(dbiListItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > TimeBarsAfterSchedule Method : TimeBarsAfterSchedule(dbiListItem) Method

objItem
The dbiListItem to check for time bars on.
Gets a collection of time bars that exist after the visble area of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objItem As dbiListItem
Dim value As List(Of dbiTimeBarItem)

value = instance.TimeBarsAfterSchedule(objItem)
C#
public List<dbiTimeBarItem> TimeBarsAfterSchedule(
   dbiListItem objItem
)

Parameters

objItem
The dbiListItem to check for time bars on.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

TimeBarsAfterSchedule(dbiScheduleObject,dbiListItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > TimeBarsAfterSchedule Method : TimeBarsAfterSchedule(dbiScheduleObject,dbiListItem) Method

objSched
The dbiScheduleObject to test.
objItem
The dbiListItem to check for time bars on.
Gets a collection of time bars that exist after the visble area of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objSched As dbiScheduleObject
Dim objItem As dbiListItem
Dim value As List(Of dbiTimeBarItem)

value = instance.TimeBarsAfterSchedule(objSched, objItem)
C#
public List<dbiTimeBarItem> TimeBarsAfterSchedule(
   dbiScheduleObject objSched,
   dbiListItem objItem
)

Parameters

objSched
The dbiScheduleObject to test.
objItem
The dbiListItem to check for time bars on.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

TimeBarsAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarsAt Method

Gets a collection of time bars that exists at a given point

Overload List

Overload | Description
TimeBarsAt(Point) | Get a list of time bars that exists at a given point.
TimeBarsAt(Point,Boolean) | Gets a list of time bars that exists at a given point

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarsAt(Point) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > TimeBarsAt Method : TimeBarsAt(Point) Method

ptPoint
The coordinates to check for time bars.
Get a list of time bars that exists at a given point.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ptPoint As Point
Dim value As List(Of dbiTimeBarItem)

value = instance.TimeBarsAt(ptPoint)
C#
public List<dbiTimeBarItem> TimeBarsAt(
   Point ptPoint
)

Parameters

ptPoint
The coordinates to check for time bars.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

TimeBarsAt(Point,Boolean) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > TimeBarsAt Method : TimeBarsAt(Point,Boolean) Method

ptPoint
The coordinates to check for time bars.
bAbsolute
Determines if the mouse point provided is for the schedule area only, and not the entire control.
Gets a list of time bars that exists at a given point

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ptPoint As Point
Dim bAbsolute As Boolean
Dim value As List(Of dbiTimeBarItem)

value = instance.TimeBarsAt(ptPoint, bAbsolute)
C#
public List<dbiTimeBarItem> TimeBarsAt(
   Point ptPoint,
   bool bAbsolute
)

Parameters

ptPoint
The coordinates to check for time bars.
bAbsolute
Determines if the mouse point provided is for the schedule area only, and not the entire control.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

TimeBarsBeforeSchedule Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarsBeforeSchedule Method

Gets a collection of time bars that exist before the visble area of a schedule.

Overload List

Overload | Description
TimeBarsBeforeSchedule(dbiListItem) | Gets a collection of time bars that exist before the visble area of a schedule.
TimeBarsBeforeSchedule(dbiScheduleObject,dbiListItem) | Gets a collection of time bars that exist before the visble area of a schedule.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarsBeforeSchedule(dbiListItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > TimeBarsBeforeSchedule Method : TimeBarsBeforeSchedule(dbiListItem) Method

objItem
The dbiListItem to check for time bars on.
Gets a collection of time bars that exist before the visble area of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objItem As dbiListItem
Dim value As List(Of dbiTimeBarItem)

value = instance.TimeBarsBeforeSchedule(objItem)
C#
public List<dbiTimeBarItem> TimeBarsBeforeSchedule(
   dbiListItem objItem
)

Parameters

objItem
The dbiListItem to check for time bars on.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

TimeBarsBeforeSchedule(dbiScheduleObject,dbiListItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > TimeBarsBeforeSchedule Method : TimeBarsBeforeSchedule(dbiScheduleObject,dbiListItem) Method

objSched
The dbiScheduleObject to test.
objItem
The dbiListItem to check for time bars on.
Gets a collection of time bars that exist before the visble area of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim objSched As dbiScheduleObject
Dim objItem As dbiListItem
Dim value As List(Of dbiTimeBarItem)

value = instance.TimeBarsBeforeSchedule(objSched, objItem)
C#
public List<dbiTimeBarItem> TimeBarsBeforeSchedule(
   dbiScheduleObject objSched,
   dbiListItem objItem
)

Parameters

objSched
The dbiScheduleObject to test.
objItem
The dbiListItem to check for time bars on.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

Undo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Undo Method

Perform an undo operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.Undo()
C#
public bool Undo()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%% $$Properties$$

dbiScheduleWPF Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF Class

"

For a list of all members of this type, see dbiScheduleWPF members.

"

Public Properties

 | Name | Description
public Property | ActiveSchedule | Gets or sets the active or visible schedule in the control.
public Property | AllowHorzMoves | Gets or sets whether whether time bars can be moved horizontally with the mouse.
public Property | AllowNewBars | Gets or sets whether time bars can be added with the mouse.
public Property | AllowResizeBars | Gets or sets whether time bars can be resized with the mouse.
public Property | AllowVertMoves | Gets or sets whether whether time bars can be moved vertically with the mouse.
public Property | AltListBrushes | Gets or sets whether the background of list items will be painted with alternating brushes.
public Property | AltListEvenBackground | Gets or sets the brush used to paint the background of a list item when painting alternate list item backgrounds.
public Property | AltListItems | Gets or sets the amount of lines to paint the list item backgrounds with one brush before the other brush is used.
public Property | AltListOddBackground | Gets or sets the brush used to paint the background of a list item when painting alternate list item backgrounds.
public Property | AutoDuplicate | Gets or sets whether a duplicate time bar will be created when the "Shift" key is pressed, and a time bar is clicked and dragged.
public Property | BarSelectBackground | Gets or sets the brush used to paint the selected time bars.
public Property | BarSelectForeground | Gets or sets the brush used to paint the text in selected time bars.
public Property | BarSelectStroke | Gets or sets the brush used to paint the border of selected time bars.
public Property | BarSelectStrokeThickness | Gets or sets default stroke thickness for the line used to paint the border of a selected time bar.
public Property | BorderBrush | Gets or sets the Brush used to paint the main borders in the control
public Property | Columns | Gets or sets the list of columns in the list side of the control.
public Property | ControlStyle | Sets a series of properties so that the control represents a certain style or theme.
public Property | CornerBackground | Gets or sets the brush used to paint the bottom right corner of the control when it becomes visible.
public Property | CurrentTimeColorTo | Gets or sets the secondary color of the current time line.
public Property | CurrentTimeLine | Gets or sets whether the current time line will be displayed in the schedule.
public Property | CurrentTimeOffset | Gets or sets the time span used to offset the current time and date.
public Property | CurrentTimeStroke | Gets or sets the brush used to paint the current time line.
public Property | CurrentTimeStrokeThickness | Gets or sets default stroke thickness for the line used to paint the current time line.
public Property | CustomAreaBackground | Gets or sets the default brush used to paint the CustomAreas in the schedule.
public Property | CustomAreas | Gets or sets the list of custom areas for the schedule.
public Property | DayMonthOffset | Gets or sets the offset used to calculate the starting day of the week in a monthly ruler.
public Property | DayNames | Gets or sets the names of the day of the week.
public Property | DisplayGuideLines | Gets or sets whether guide lines will be painted in the schedules.
public Property | DisplayListGuide | Gets or sets whether a list guide can appear in the schedule.
public Property | DivisionDistance | Gets or sets how close the edge of a time bar must be to a major time division point before the time bar is snapped to that point (in pixels).
public Property | EditMode | Gets or sets the edit mode for the schedule.
public Property | FillList | Gets or sets whether the last list column fills the list area.
public Property | GridFrequency | Gets or sets the distance where the bar can be moved or sized to.
public Property | GuideImagePosition | Gets or sets whether guid line images will appear in the front or behind of the ruler text.
public Property | GuideLineDashPattern | Gets or sets the dash pattern used to paint the guide lines.
public Property | GuideLineDistance | Gets or sets how close the edge of a time bar must be to a guide line before the time bar is snapped to the guide line location (in pixels).
public Property | GuideLinePosition | Gets or sets whether guide lines will be in the front or back of the time bars.
public Property | GuideLineStroke | Gets or sets the default brush used to paint the guide lines.
public Property | GuideLineStrokeThickness | Gets or sets default stroke thickness for the line used to paint the guide lines.
public Property | GuideSelectStroke | Gets or sets the brush used to paint the currently selected guide line.
public Property | HandleListRightClick | Gets or sets whether the control will handle the right click event if the right click occurs in the list.
public Property | HandleMapAreaRightClick | Gets or sets whether the control will handle the right click event if the right click occurs in the map area.
public Property | HandleScheduleRightClick | Gets or sets whether the control will handle the right click event if the right click occurs in the schedule.
public Property | HeaderAlign | Gets or sets the default alignment for the text in the column headers in the list.
public Property | HeaderBackground | Gets or sets the brush used to paint the background of the column headers in the list.
public Property | HeaderFontFamily | Gets or sets the font family used to paint the text in a column header.
public Property | HeaderFontSize | Gets or sets the font size used to paint the text in a column header.
public Property | HeaderFontStyle | Gets or sets the font style used to paint the text in a column header.
public Property | HeaderFontWeight | Gets or sets the font weight used to paint the text in a column header.
public Property | HeaderForeground | Gets or sets the brush used to paint the text of the column header.
public Property | HeaderHeight | Gets or sets the height of the header in the list.
public Property | HeaderVisible | Gets or sets whether the column headers in the list will be visible
public Property | HistorySize | Gets or sets the maximum size of the history file.
public Property | Images | Gets or sets the list containing the various images for the control.
public Property | ItemHeaderBackground | Gets or sets the brush used to paint the background of list items marked as headers in the list.
public Property | ItemHeaderForeground | Gets or sets the brush used to paint the foreground of list items marked as headers in the list.
public Property | ItemHeightOffset | Gets or Sets the offset used to calculate the height of items in the list.
public Property | Items | Gets or sets the collection of list items in the control.
public Property | LineArrowAfter | Gets or sets the image used for the image after arrow marker.
public Property | LineArrowBackground | Gets or sets the default brush used to paint the solid line arrows.
public Property | LineArrowBefore | Gets or sets the image used for the image before arrow marker.
public Property | LineArrowPosition | Gets or sets where the line arrows will be drawn in the schedules.
public Property | LineArrowType | Gets or sets the type of line arrows that will be drawn in the schedules.
public Property | LinkLineStroke | Gets or sets the default brush used to paint the link lines.
public Property | Links | Gets or sets the the links used to connect different time bars
public Property | ListBackground | Gets or sets the brush used to paint the background of the list.
public Property | ListFontFamily | Gets or sets the font family used to paint the text in a list.
public Property | ListFontSize | Gets or sets the font size used to paint the text in a list.
public Property | ListFontStyle | Gets or sets the font style used to paint the text in a list.
public Property | ListFontWeight | Gets or sets the font weight used to paint the text in a list.
public Property | ListForeground | Gets or sets the brush used to paint the text of the list.
public Property | ListGuideBackground | Gets or sets the default brush used to paint the background of the list guide.
public Property | ListGuideDistance | Gets or sets the minimum distance that the mouse has to be from the splitter bar before the list guide appears.
public Property | ListGuideFadeDuration | Gets or sets the time in milliseconds on how fast to allow the list guide to fade into appearance.
public Property | ListGuideForeground | Gets or sets the default brush used to paint the text or foreground of the list guide.
public Property | ListGuideWidth | Gets or sets the width of the list guide.
public Property | ListHorzStroke | Gets or sets the brush used to paint the horizontal lines in the list area.
public Property | ListHorzStrokeThickness | Gets or sets default stroke thickness used to paint the horizontal lines in the list area.
public Property | ListImageAlign | Gets or sets the default horizontal alignment of the images in the list.
public Property | ListItemHeight | Gets the height of the list items in the control.
public Property | ListScrollValue | Gets or sets the value of the lists horizontal scroll bar.
public Property | ListTextAlign | Gets or sets the default horizontal alignment of the text in the list.
public Property | ListTitle | Gets or sets the text to be displayed at the top of the list. This text will only be painted if no columns have been defined.
public Property | ListType | Gets or sets whether the list side of the control will act as a tree view or list view control.
public Property | ListVertStroke | Gets or sets the brush used to paint the vertical lines in the list area.
public Property | ListVertStrokeThickness | Gets or sets default stroke thickness used to paint the vertical lines in the list area.
public Property | ListWidth | Gets or sets the width of the list area of the control.
public Property | MapArea | Gets or sets whether the map area of the control will be visible.
public Property | MapBackground | Gets or sets the brush used to paint the background of the map area.
public Property | MapHeight | Gets or sets the height of the map area.
public Property | MapLine | Gets or sets the brush used to paint the current view border of the map area.
public Property | MapLineThickness | Gets or sets default stroke thickness used to paint the border of the current view of the map area.
public Property | MapStroke | Gets or sets the brush used to paint the border of the map area.
public Property | MapStrokeThickness | Gets or sets default stroke thickness used to paint the border of the map area.
public Property | MinBarTime | Gets or sets the minimum time span of a time bar.
public Property | MonthNames | Gets or sets the names of the month of the year.
public Property | NotesDistance | Gets or sets the distance between notes when locked.
public Property | NotesPosition | Gets or sets where the schedule notes will be drawn in the schedules.
public Property | OverlapSpan | Gets or sets the additional time span used to determine if a time bar overlaps another time bar.
public Property | OverlapStroke | Gets or sets the default brush used to paint the overlap lines for the time bars.
public Property | OverlapStrokeThickness | Gets or sets default stroke thickness used to paint the overlap lines for the time bars.
public Property | PercentBackground | Gets or sets the brush used to paint the backround of a percent bar within a time bar.
public Property | PrintFontFamily | Gets or sets the font family used to paint the sub-title and footer text in a printed report.
public Property | PrintFontSize | Gets or sets the font size used to paint the sub-title and footer text in a printed report.
public Property | PrintFontStyle | Gets or sets the font style used to paint the sub-title and footer text in a printed report.
public Property | PrintFontWeight | Gets or sets the font weight used to paint the sub-title and footer text in a printed report.
public Property | PrintFooterAlign | Gets or sets the horizontal alignment of the footer text in a printed report.
public Property | PrintFooterMargin | Gets or sets the margin space used to place around the footer in a printed report.
public Property | PrintListAlways | Gets or sets whether the list will be printed on every page of a printed report.
public Property | PrintListWidth | Gets or sets the width of the list in a printed report.
public Property | PrintMargin | Gets or sets the margin space used to determine the area on a page that cannot be printed to.
public Property | PrintPageText | Gets or sets the text describing the page number in the footer.
public Property | PrintSubTitle | Gets or sets the sub-title for the printed report.
public Property | PrintSubTitleMargin | Gets or sets the margin space used to place around the sub-titles in a printed report.
public Property | PrintTimeDistance | Gets or sets the distance between the major time units in a printed report.
public Property | PrintTitle | Gets or sets the title for the printed report.
public Property | PrintTitleAlign | Gets or sets the alignment for the print title.
public Property | PrintTitleFontFamily | Gets or sets the font family used to paint the title in a printed report.
public Property | PrintTitleFontSize | Gets or sets the font size used to paint the title in a printed report.
public Property | PrintTitleFontStyle | Gets or sets the font style used to paint the title in a printed report.
public Property | PrintTitleFontWeight | Gets or sets the font weight used to paint the title in a printed report.
public Property | PrintTitleMargin | Gets or sets the margin space used to place around the titles in a printed report.
public Property | RedoHistory | Gets the redo history file for the time bars.
public Property | RulerBackground | Gets or sets the brush used to paint the background of the ruler area.
public Property | RulerFontFamily | Gets or sets the font family used to paint the text in a list.
public Property | RulerFontSize | Gets or sets the font size used to paint the text in a list.
public Property | RulerFontStyle | Gets or sets the font style used to paint the text in a list.
public Property | RulerFontWeight | Gets or sets the font weight used to paint the text in a list.
public Property | RulerForeground | Gets or sets the brush used to paint the foreground of the ruler area.
public Property | RulerLineStroke | Gets or sets the brush used to paint lines in the ruler.
public Property | RulerSelectBackground | Gets or sets the brush used to paint the selected time bars span in the ruler.
public Property | RulerSelectOffset | Gets or sets the offset value used to calculate the vertical height and position of the selected area in the rulers.
public Property | SchedScrollValue | Gets or sets the value of the schedules horizontal scroll bar.
public Property | ScheduleAreaWidth | Gets or sets the width of the schedule area of the control.
public Property | ScheduleBackground | Gets or sets the brush used to paint the background of the schedule area.
public Property | ScheduleHeaderBackground | Gets or sets the brush used to paint the background of schedule items marked as headers in the list.
public Property | ScheduleHeaderPosition | Gets or sets whether schedule header line items will be in the front or back of the custom areas and time lines.
public Property | ScheduleHorzStroke | Gets or sets the brush used to paint the horizontal lines in the schedule area.
public Property | ScheduleHorzStrokeThickness | Gets or sets default stroke thickness for the line used to paint the horizontal lines in the schedule area.
public Property | Schedules | Gets or sets the list of schedules within the control.
public Property | SelectedBackground | Gets or sets the brush used to paint the background of selected list items in the list.
public Property | SelectedForeground | Gets or sets the brush used to paint the text of selected list items in the list.
public Property | SelectedRadius | Gets or sets the x-radius of the ellipse that is used to round the corner of a selected list item.
public Property | SelectedStroke | Gets or sets the default brush used to paint the border of a selected list item.
public Property | SelectedStrokeThickness | Gets or sets default stroke thickness for the line used to paint the border of a selected list item.
public Property | SelectModeDashPattern | Gets or sets the dash pattern used to paint the selected mode lines.
public Property | SelectModeStroke | Gets or sets the default brush used to paint the selected mode lines.
public Property | SelectModeStrokeThickness | Gets or sets default stroke thickness for the line used to paint the selected modelines.
public Property | SnapToDivisions | Gets or sets how a time bar will align itself to the major ruler division points when being created, moved, or sized with the mouse.
public Property | SnapToGrid | Gets or sets whether a time bar will use the GridFrequency value to align itself to the control when being created, moved or sized with the mouse.
public Property | SnapToGuide | Gets or sets whether a time bar will align itself to the guide line when being created, moved or sized with the mouse.
public Property | SortArrowAscend | Gets or sets the image used for the ascending sort arrow.
public Property | SortArrowBackground | Gets or sets the brush used to paint the sort arrows in the column headers in the list.
public Property | SortArrowDescend | Gets or sets the image used for the descending sort arrow.
public Property | SortArrowHorzAlign | Gets or sets the value used horizontally align the sort arrows in the list.
public Property | SortArrowOffset | Gets or sets the value used to calculate the horizontal and vertical position of the sort arrows in the list.
public Property | SortArrowSize | Gets or sets the size of length of the sort arrows in the list.
public Property | SortArrowVertAlign | Gets or sets the value used vertically align the sort arrows in the list.
public Property | SortOnCase | Gets or sets whether a sort routine will test for upper or lower case text when performing the sort.
public Property | SplitterBarBackground | Gets or sets the brush used to paint the splitter bar.
public Property | SplitterBarWidth | Gets or sets the width of the splitter bar area of the control.
public Property | TextIntoView | Gets or sets whether the text in a time bar will always be placed in the visible part of the time bar.
public Property | TimeBarBackground | Gets or sets the default brush used to paint the time bars in the schedule.
public Property | TimeBarExtension | Gets or sets the extension size on each side of a time bar used to resize a time bar with the mouse.
public Property | TimeBarFontFamily | Gets or sets the font family used to paint the text in a time bar.
public Property | TimeBarFontSize | Gets or sets the font size used to paint the text in a time bar.
public Property | TimeBarFontStyle | Gets or sets the font style used to paint the text in a time bar.
public Property | TimeBarFontWeight | Gets or sets the font weight used to paint the text in a time bar.
public Property | TimeBarForeground | Gets or sets the default brush used to paint the text of the time bars in the schedule.
public Property | TimeBarMargin | Gets or sets the margin size on each side of a time bar used to resize a time bar with the mouse.
public Property | TimeBarMinWidth | Gets or sets the minimim width for a time bar.
public Property | TimeBarRadius | Gets or sets the radius of the ellipse that is used to round the corner of a time bar.
public Property | TimeBarShadowColor | Gets or sets the color of a time bar shadow effect
public Property | TimeBarShadowOpacity | Gets or sets the opacity of a time bar shadow effect.
public Property | TimeBarShadows | Gets or sets whether a shadow effect will be placed around a time bar.
public Property | TimeBarStroke | Gets or sets the default brush used to paint the time bar borders in the schedule.
public Property | TimeBarStrokeThickness | Gets or sets default stroke thickness for the line used to paint the border of a time bar.
public Property | TimeBarTextWrap | Gets or sets whether the text in a time bar can be displayed on multiple lines.
public Property | TimeDistance | Gets or sets the distance between the major time units.
public Property | TipsBackground | Gets or sets the brush used to paint the backround of a tool tip.
public Property | TipsFontFamily | Gets or sets the font family used to paint the text in the tool tips.
public Property | TipsFontSize | Gets or sets the font size used to paint the text in the tool tips.
public Property | TipsFontStyle | Gets or sets the font style used to paint the text in the tool tips.
public Property | TipsFontWeight | Gets or sets the font weight used to paint the text in the tool tips.
public Property | TipsForeground | Gets or sets the brush used to paint the text of a tool tip.
public Property | TipsOnChangeBar | Gets or sets whether tool tips will appear when a time bar is being moved or sized.
public Property | TipsOnCreateBar | Gets or sets whether tool tips will appear when a time bar is being created.
public Property | TipsOnGuideLines | Gets or sets whether tool tips will appear when the mouse is dragging a guide line.
public Property | TipsOnNotes | Gets or sets whether tool tips will appear when the mouse hovers over a note.
public Property | TipsOnOverBar | Gets or sets whether tool tips will appear when the mouse hovers over a time bar.
public Property | TipsShadowColor | Gets or sets the color of a tool tip shadow effect.
public Property | TipsShadowOpacity | Gets or sets the opacity of a tool tip shadow effect.
public Property | TipsShadows | Gets or sets whether a shadow effect will be placed around a tool tip.
public Property | TipsStroke | Gets or sets the brush used to paint the border of a tool tip.
public Property | TipsStrokeThickness | Gets or sets the border thickness of a tool tip.
public Property | ToolbarBackground | Gets or sets the brush used to paint the backround of the tool bar.
public Property | ToolbarOnRightClick | Gets or sets whether a tool bar for the edit modes will appear when the schedule is right clicked on.
public Property | ToolbarShadow | Gets or sets whether a shadow effect will be placed around a tool bar.
public Property | ToolbarShadowColor | Gets or sets the color of a tool bar shadow effect.
public Property | ToolbarShadowOpacity | Gets or sets the opacity of a tool bar shadow effect.
public Property | TreeClose | Gets or sets the image used in the list to represent items that own other child items they are not being shown.
public Property | TreeLevelIndent | Gets or sets on offset used to calculate the distance to indent each level of a tree.
public Property | TreeOpen | Gets or sets the image used in the list to represent items that own other child items they are being shown.
public Property | UndoHistory | Gets the undo history file for the time bars.
public Property | VertScrollValue | Gets or sets the value of the vertical scroll bar.
public Property | WeekendBackground | Gets or sets the brush used to paint the days marked as weekends.
public Property | WeekendDays | Gets or sets the list that represents the days representing the weekend.
Top

See Also

Reference

dbiScheduleWPF Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ActiveSchedule Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ActiveSchedule Property

Gets or sets the active or visible schedule in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.ActiveSchedule = value

value = instance.ActiveSchedule
C#
public int ActiveSchedule {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AllowHorzMoves Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AllowHorzMoves Property

Gets or sets whether whether time bars can be moved horizontally with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.AllowHorzMoves = value

value = instance.AllowHorzMoves
C#
public bool AllowHorzMoves {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AllowNewBars Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AllowNewBars Property

Gets or sets whether time bars can be added with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.AllowNewBars = value

value = instance.AllowNewBars
C#
public bool AllowNewBars {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AllowResizeBars Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AllowResizeBars Property

Gets or sets whether time bars can be resized with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.AllowResizeBars = value

value = instance.AllowResizeBars
C#
public bool AllowResizeBars {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AllowVertMoves Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AllowVertMoves Property

Gets or sets whether whether time bars can be moved vertically with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.AllowVertMoves = value

value = instance.AllowVertMoves
C#
public bool AllowVertMoves {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AltListBrushes Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AltListBrushes Property

Gets or sets whether the background of list items will be painted with alternating brushes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.AltListBrushes = value

value = instance.AltListBrushes
C#
public bool AltListBrushes {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AltListEvenBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AltListEvenBackground Property

Gets or sets the brush used to paint the background of a list item when painting alternate list item backgrounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.AltListEvenBackground = value

value = instance.AltListEvenBackground
C#
public Brush AltListEvenBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AltListItems Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AltListItems Property

Gets or sets the amount of lines to paint the list item backgrounds with one brush before the other brush is used.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.AltListItems = value

value = instance.AltListItems
C#
public int AltListItems {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AltListOddBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AltListOddBackground Property

Gets or sets the brush used to paint the background of a list item when painting alternate list item backgrounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.AltListOddBackground = value

value = instance.AltListOddBackground
C#
public Brush AltListOddBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AutoDuplicate Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AutoDuplicate Property

Gets or sets whether a duplicate time bar will be created when the "Shift" key is pressed, and a time bar is clicked and dragged.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.AutoDuplicate = value

value = instance.AutoDuplicate
C#
public bool AutoDuplicate {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BarSelectBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarSelectBackground Property

Gets or sets the brush used to paint the selected time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.BarSelectBackground = value

value = instance.BarSelectBackground
C#
public Brush BarSelectBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BarSelectForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarSelectForeground Property

Gets or sets the brush used to paint the text in selected time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.BarSelectForeground = value

value = instance.BarSelectForeground
C#
public Brush BarSelectForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BarSelectStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarSelectStroke Property

Gets or sets the brush used to paint the border of selected time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.BarSelectStroke = value

value = instance.BarSelectStroke
C#
public Brush BarSelectStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BarSelectStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarSelectStrokeThickness Property

Gets or sets default stroke thickness for the line used to paint the border of a selected time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.BarSelectStrokeThickness = value

value = instance.BarSelectStrokeThickness
C#
public double BarSelectStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BorderBrush Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BorderBrush Property

Gets or sets the Brush used to paint the main borders in the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.BorderBrush = value

value = instance.BorderBrush
C#
public new Brush BorderBrush {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Columns Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Columns Property

Gets or sets the list of columns in the list side of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As dbiColumnItemCollection

instance.Columns = value

value = instance.Columns
C#
public dbiColumnItemCollection Columns {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ControlStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ControlStyle Property

Sets a series of properties so that the control represents a certain style or theme.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.ControlStyle = value
C#
public enumControlStyle ControlStyle {set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CornerBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CornerBackground Property

Gets or sets the brush used to paint the bottom right corner of the control when it becomes visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.CornerBackground = value

value = instance.CornerBackground
C#
public Brush CornerBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeColorTo Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeColorTo Property

Gets or sets the secondary color of the current time line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As SolidColorBrush

instance.CurrentTimeColorTo = value

value = instance.CurrentTimeColorTo
C#
public SolidColorBrush CurrentTimeColorTo {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeLine Property

Gets or sets whether the current time line will be displayed in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.CurrentTimeLine = value

value = instance.CurrentTimeLine
C#
public bool CurrentTimeLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeOffset Property

Gets or sets the time span used to offset the current time and date.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As TimeSpan

instance.CurrentTimeOffset = value

value = instance.CurrentTimeOffset
C#
public TimeSpan CurrentTimeOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeStroke Property

Gets or sets the brush used to paint the current time line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.CurrentTimeStroke = value

value = instance.CurrentTimeStroke
C#
public Brush CurrentTimeStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeStrokeThickness Property

Gets or sets default stroke thickness for the line used to paint the current time line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.CurrentTimeStrokeThickness = value

value = instance.CurrentTimeStrokeThickness
C#
public double CurrentTimeStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CustomAreaBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CustomAreaBackground Property

Gets or sets the default brush used to paint the CustomAreas in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.CustomAreaBackground = value

value = instance.CustomAreaBackground
C#
public Brush CustomAreaBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CustomAreas Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CustomAreas Property

Gets or sets the list of custom areas for the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As dbiCustomAreaCollection

instance.CustomAreas = value

value = instance.CustomAreas
C#
public dbiCustomAreaCollection CustomAreas {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DayMonthOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DayMonthOffset Property

Gets or sets the offset used to calculate the starting day of the week in a monthly ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.DayMonthOffset = value

value = instance.DayMonthOffset
C#
public int DayMonthOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DayNames Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DayNames Property

Gets or sets the names of the day of the week.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value() As String

instance.DayNames = value

value = instance.DayNames
C#
public string[] DayNames {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DisplayGuideLines Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DisplayGuideLines Property

Gets or sets whether guide lines will be painted in the schedules.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.DisplayGuideLines = value

value = instance.DisplayGuideLines
C#
public bool DisplayGuideLines {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DisplayListGuide Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DisplayListGuide Property

Gets or sets whether a list guide can appear in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.DisplayListGuide = value

value = instance.DisplayListGuide
C#
public bool DisplayListGuide {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DivisionDistance Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DivisionDistance Property

Gets or sets how close the edge of a time bar must be to a major time division point before the time bar is snapped to that point (in pixels).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.DivisionDistance = value

value = instance.DivisionDistance
C#
public int DivisionDistance {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

EditMode Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : EditMode Property

Gets or sets the edit mode for the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As enumEditMode

instance.EditMode = value

value = instance.EditMode
C#
public enumEditMode EditMode {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FillList Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FillList Property

Gets or sets whether the last list column fills the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.FillList = value

value = instance.FillList
C#
public bool FillList {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GridFrequency Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GridFrequency Property

Gets or sets the distance where the bar can be moved or sized to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.GridFrequency = value

value = instance.GridFrequency
C#
public int GridFrequency {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideImagePosition Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideImagePosition Property

Gets or sets whether guid line images will appear in the front or behind of the ruler text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As enumGuideImagePosition

instance.GuideImagePosition = value

value = instance.GuideImagePosition
C#
public enumGuideImagePosition GuideImagePosition {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineDashPattern Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineDashPattern Property

Gets or sets the dash pattern used to paint the guide lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As List(Of Double)

instance.GuideLineDashPattern = value

value = instance.GuideLineDashPattern
C#
public List<double> GuideLineDashPattern {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineDistance Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineDistance Property

Gets or sets how close the edge of a time bar must be to a guide line before the time bar is snapped to the guide line location (in pixels).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.GuideLineDistance = value

value = instance.GuideLineDistance
C#
public int GuideLineDistance {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLinePosition Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLinePosition Property

Gets or sets whether guide lines will be in the front or back of the time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As enumGuideLinePosition

instance.GuideLinePosition = value

value = instance.GuideLinePosition
C#
public enumGuideLinePosition GuideLinePosition {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineStroke Property

Gets or sets the default brush used to paint the guide lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.GuideLineStroke = value

value = instance.GuideLineStroke
C#
public Brush GuideLineStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineStrokeThickness Property

Gets or sets default stroke thickness for the line used to paint the guide lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.GuideLineStrokeThickness = value

value = instance.GuideLineStrokeThickness
C#
public double GuideLineStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideSelectStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideSelectStroke Property

Gets or sets the brush used to paint the currently selected guide line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.GuideSelectStroke = value

value = instance.GuideSelectStroke
C#
public Brush GuideSelectStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HandleListRightClick Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HandleListRightClick Property

Gets or sets whether the control will handle the right click event if the right click occurs in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.HandleListRightClick = value

value = instance.HandleListRightClick
C#
public bool HandleListRightClick {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HandleMapAreaRightClick Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HandleMapAreaRightClick Property

Gets or sets whether the control will handle the right click event if the right click occurs in the map area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.HandleMapAreaRightClick = value

value = instance.HandleMapAreaRightClick
C#
public bool HandleMapAreaRightClick {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HandleScheduleRightClick Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HandleScheduleRightClick Property

Gets or sets whether the control will handle the right click event if the right click occurs in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.HandleScheduleRightClick = value

value = instance.HandleScheduleRightClick
C#
public bool HandleScheduleRightClick {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderAlign Property

Gets or sets the default alignment for the text in the column headers in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As TextAlignment

instance.HeaderAlign = value

value = instance.HeaderAlign
C#
public TextAlignment HeaderAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderBackground Property

Gets or sets the brush used to paint the background of the column headers in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.HeaderBackground = value

value = instance.HeaderBackground
C#
public Brush HeaderBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderFontFamily Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderFontFamily Property

Gets or sets the font family used to paint the text in a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontFamily

instance.HeaderFontFamily = value

value = instance.HeaderFontFamily
C#
public FontFamily HeaderFontFamily {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderFontSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderFontSize Property

Gets or sets the font size used to paint the text in a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.HeaderFontSize = value

value = instance.HeaderFontSize
C#
public double HeaderFontSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderFontStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderFontStyle Property

Gets or sets the font style used to paint the text in a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontStyle

instance.HeaderFontStyle = value

value = instance.HeaderFontStyle
C#
public FontStyle HeaderFontStyle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderFontWeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderFontWeight Property

Gets or sets the font weight used to paint the text in a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontWeight

instance.HeaderFontWeight = value

value = instance.HeaderFontWeight
C#
public FontWeight HeaderFontWeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderForeground Property

Gets or sets the brush used to paint the text of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.HeaderForeground = value

value = instance.HeaderForeground
C#
public Brush HeaderForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderHeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderHeight Property

Gets or sets the height of the header in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
public int HeaderHeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderVisible Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderVisible Property

Gets or sets whether the column headers in the list will be visible

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.HeaderVisible = value

value = instance.HeaderVisible
C#
public bool HeaderVisible {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HistorySize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HistorySize Property

Gets or sets the maximum size of the history file.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.HistorySize = value

value = instance.HistorySize
C#
public int HistorySize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Images Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Images Property

Gets or sets the list containing the various images for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As List(Of ImageSource)

instance.Images = value

value = instance.Images
C#
public List<ImageSource> Images {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ItemHeaderBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ItemHeaderBackground Property

Gets or sets the brush used to paint the background of list items marked as headers in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ItemHeaderBackground = value

value = instance.ItemHeaderBackground
C#
public Brush ItemHeaderBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ItemHeaderForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ItemHeaderForeground Property

Gets or sets the brush used to paint the foreground of list items marked as headers in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ItemHeaderForeground = value

value = instance.ItemHeaderForeground
C#
public Brush ItemHeaderForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ItemHeightOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ItemHeightOffset Property

Gets or Sets the offset used to calculate the height of items in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.ItemHeightOffset = value

value = instance.ItemHeightOffset
C#
public int ItemHeightOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Items Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Items Property

Gets or sets the collection of list items in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As dbiListItemCollection

instance.Items = value

value = instance.Items
C#
public dbiListItemCollection Items {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowAfter Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowAfter Property

Gets or sets the image used for the image after arrow marker.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As ImageSource

instance.LineArrowAfter = value

value = instance.LineArrowAfter
C#
public ImageSource LineArrowAfter {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowBackground Property

Gets or sets the default brush used to paint the solid line arrows.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.LineArrowBackground = value

value = instance.LineArrowBackground
C#
public Brush LineArrowBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowBefore Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowBefore Property

Gets or sets the image used for the image before arrow marker.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As ImageSource

instance.LineArrowBefore = value

value = instance.LineArrowBefore
C#
public ImageSource LineArrowBefore {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowPosition Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowPosition Property

Gets or sets where the line arrows will be drawn in the schedules.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As enumLineArrowPosition

instance.LineArrowPosition = value

value = instance.LineArrowPosition
C#
public enumLineArrowPosition LineArrowPosition {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowType Property

Gets or sets the type of line arrows that will be drawn in the schedules.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As enumLineArrowType

instance.LineArrowType = value

value = instance.LineArrowType
C#
public enumLineArrowType LineArrowType {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LinkLineStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LinkLineStroke Property

Gets or sets the default brush used to paint the link lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.LinkLineStroke = value

value = instance.LinkLineStroke
C#
public Brush LinkLineStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Links Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Links Property

Gets or sets the the links used to connect different time bars

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As dbiLinkItemCollection

instance.Links = value

value = instance.Links
C#
public dbiLinkItemCollection Links {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListBackground Property

Gets or sets the brush used to paint the background of the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ListBackground = value

value = instance.ListBackground
C#
public Brush ListBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListFontFamily Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListFontFamily Property

Gets or sets the font family used to paint the text in a list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontFamily

instance.ListFontFamily = value

value = instance.ListFontFamily
C#
public FontFamily ListFontFamily {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListFontSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListFontSize Property

Gets or sets the font size used to paint the text in a list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.ListFontSize = value

value = instance.ListFontSize
C#
public double ListFontSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListFontStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListFontStyle Property

Gets or sets the font style used to paint the text in a list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontStyle

instance.ListFontStyle = value

value = instance.ListFontStyle
C#
public FontStyle ListFontStyle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListFontWeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListFontWeight Property

Gets or sets the font weight used to paint the text in a list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontWeight

instance.ListFontWeight = value

value = instance.ListFontWeight
C#
public FontWeight ListFontWeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListForeground Property

Gets or sets the brush used to paint the text of the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ListForeground = value

value = instance.ListForeground
C#
public Brush ListForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideBackground Property

Gets or sets the default brush used to paint the background of the list guide.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ListGuideBackground = value

value = instance.ListGuideBackground
C#
public Brush ListGuideBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideDistance Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideDistance Property

Gets or sets the minimum distance that the mouse has to be from the splitter bar before the list guide appears.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.ListGuideDistance = value

value = instance.ListGuideDistance
C#
public int ListGuideDistance {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideFadeDuration Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideFadeDuration Property

Gets or sets the time in milliseconds on how fast to allow the list guide to fade into appearance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.ListGuideFadeDuration = value

value = instance.ListGuideFadeDuration
C#
public int ListGuideFadeDuration {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideForeground Property

Gets or sets the default brush used to paint the text or foreground of the list guide.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ListGuideForeground = value

value = instance.ListGuideForeground
C#
public Brush ListGuideForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideWidth Property

Gets or sets the width of the list guide.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.ListGuideWidth = value

value = instance.ListGuideWidth
C#
public int ListGuideWidth {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListHorzStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListHorzStroke Property

Gets or sets the brush used to paint the horizontal lines in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ListHorzStroke = value

value = instance.ListHorzStroke
C#
public Brush ListHorzStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListHorzStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListHorzStrokeThickness Property

Gets or sets default stroke thickness used to paint the horizontal lines in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.ListHorzStrokeThickness = value

value = instance.ListHorzStrokeThickness
C#
public double ListHorzStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListImageAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListImageAlign Property

Gets or sets the default horizontal alignment of the images in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As TextAlignment

instance.ListImageAlign = value

value = instance.ListImageAlign
C#
public TextAlignment ListImageAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListItemHeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListItemHeight Property

Gets the height of the list items in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

value = instance.ListItemHeight
C#
public int ListItemHeight {get;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListScrollValue Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListScrollValue Property

Gets or sets the value of the lists horizontal scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.ListScrollValue = value

value = instance.ListScrollValue
C#
public double ListScrollValue {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListTextAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListTextAlign Property

Gets or sets the default horizontal alignment of the text in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As TextAlignment

instance.ListTextAlign = value

value = instance.ListTextAlign
C#
public TextAlignment ListTextAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListTitle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListTitle Property

Gets or sets the text to be displayed at the top of the list. This text will only be painted if no columns have been defined.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As String

instance.ListTitle = value

value = instance.ListTitle
C#
public string ListTitle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListType Property

Gets or sets whether the list side of the control will act as a tree view or list view control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As enumListType

instance.ListType = value

value = instance.ListType
C#
public enumListType ListType {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListVertStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListVertStroke Property

Gets or sets the brush used to paint the vertical lines in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ListVertStroke = value

value = instance.ListVertStroke
C#
public Brush ListVertStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListVertStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListVertStrokeThickness Property

Gets or sets default stroke thickness used to paint the vertical lines in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.ListVertStrokeThickness = value

value = instance.ListVertStrokeThickness
C#
public double ListVertStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListWidth Property

Gets or sets the width of the list area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.ListWidth = value

value = instance.ListWidth
C#
public double ListWidth {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapArea Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapArea Property

Gets or sets whether the map area of the control will be visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.MapArea = value

value = instance.MapArea
C#
public bool MapArea {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapBackground Property

Gets or sets the brush used to paint the background of the map area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.MapBackground = value

value = instance.MapBackground
C#
public Brush MapBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapHeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapHeight Property

Gets or sets the height of the map area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.MapHeight = value

value = instance.MapHeight
C#
public int MapHeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapLine Property

Gets or sets the brush used to paint the current view border of the map area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.MapLine = value

value = instance.MapLine
C#
public Brush MapLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapLineThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapLineThickness Property

Gets or sets default stroke thickness used to paint the border of the current view of the map area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.MapLineThickness = value

value = instance.MapLineThickness
C#
public double MapLineThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapStroke Property

Gets or sets the brush used to paint the border of the map area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.MapStroke = value

value = instance.MapStroke
C#
public Brush MapStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapStrokeThickness Property

Gets or sets default stroke thickness used to paint the border of the map area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.MapStrokeThickness = value

value = instance.MapStrokeThickness
C#
public double MapStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MinBarTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MinBarTime Property

Gets or sets the minimum time span of a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As TimeSpan

instance.MinBarTime = value

value = instance.MinBarTime
C#
public TimeSpan MinBarTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MonthNames Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MonthNames Property

Gets or sets the names of the month of the year.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value() As String

instance.MonthNames = value

value = instance.MonthNames
C#
public string[] MonthNames {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

NotesDistance Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : NotesDistance Property

Gets or sets the distance between notes when locked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.NotesDistance = value

value = instance.NotesDistance
C#
public int NotesDistance {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

NotesPosition Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : NotesPosition Property

Gets or sets where the schedule notes will be drawn in the schedules.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As enumNotesPosition

instance.NotesPosition = value

value = instance.NotesPosition
C#
public enumNotesPosition NotesPosition {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

OverlapSpan Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : OverlapSpan Property

Gets or sets the additional time span used to determine if a time bar overlaps another time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As TimeSpan

instance.OverlapSpan = value

value = instance.OverlapSpan
C#
public TimeSpan OverlapSpan {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

OverlapStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : OverlapStroke Property

Gets or sets the default brush used to paint the overlap lines for the time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.OverlapStroke = value

value = instance.OverlapStroke
C#
public Brush OverlapStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

OverlapStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : OverlapStrokeThickness Property

Gets or sets default stroke thickness used to paint the overlap lines for the time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.OverlapStrokeThickness = value

value = instance.OverlapStrokeThickness
C#
public double OverlapStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PercentBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PercentBackground Property

Gets or sets the brush used to paint the backround of a percent bar within a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.PercentBackground = value

value = instance.PercentBackground
C#
public Brush PercentBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFontFamily Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFontFamily Property

Gets or sets the font family used to paint the sub-title and footer text in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontFamily

instance.PrintFontFamily = value

value = instance.PrintFontFamily
C#
public FontFamily PrintFontFamily {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFontSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFontSize Property

Gets or sets the font size used to paint the sub-title and footer text in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.PrintFontSize = value

value = instance.PrintFontSize
C#
public double PrintFontSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFontStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFontStyle Property

Gets or sets the font style used to paint the sub-title and footer text in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontStyle

instance.PrintFontStyle = value

value = instance.PrintFontStyle
C#
public FontStyle PrintFontStyle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFontWeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFontWeight Property

Gets or sets the font weight used to paint the sub-title and footer text in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontWeight

instance.PrintFontWeight = value

value = instance.PrintFontWeight
C#
public FontWeight PrintFontWeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFooterAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFooterAlign Property

Gets or sets the horizontal alignment of the footer text in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As TextAlignment

instance.PrintFooterAlign = value

value = instance.PrintFooterAlign
C#
public TextAlignment PrintFooterAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFooterMargin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFooterMargin Property

Gets or sets the margin space used to place around the footer in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Thickness

instance.PrintFooterMargin = value

value = instance.PrintFooterMargin
C#
public Thickness PrintFooterMargin {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintListAlways Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintListAlways Property

Gets or sets whether the list will be printed on every page of a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.PrintListAlways = value

value = instance.PrintListAlways
C#
public bool PrintListAlways {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintListWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintListWidth Property

Gets or sets the width of the list in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.PrintListWidth = value

value = instance.PrintListWidth
C#
public int PrintListWidth {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintMargin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintMargin Property

Gets or sets the margin space used to determine the area on a page that cannot be printed to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Thickness

instance.PrintMargin = value

value = instance.PrintMargin
C#
public Thickness PrintMargin {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintPageText Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintPageText Property

Gets or sets the text describing the page number in the footer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As String

instance.PrintPageText = value

value = instance.PrintPageText
C#
public string PrintPageText {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintSubTitle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintSubTitle Property

Gets or sets the sub-title for the printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As String

instance.PrintSubTitle = value

value = instance.PrintSubTitle
C#
public string PrintSubTitle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintSubTitleMargin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintSubTitleMargin Property

Gets or sets the margin space used to place around the sub-titles in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Thickness

instance.PrintSubTitleMargin = value

value = instance.PrintSubTitleMargin
C#
public Thickness PrintSubTitleMargin {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTimeDistance Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTimeDistance Property

Gets or sets the distance between the major time units in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.PrintTimeDistance = value

value = instance.PrintTimeDistance
C#
public int PrintTimeDistance {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitle Property

Gets or sets the title for the printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As String

instance.PrintTitle = value

value = instance.PrintTitle
C#
public string PrintTitle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleAlign Property

Gets or sets the alignment for the print title.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As TextAlignment

instance.PrintTitleAlign = value

value = instance.PrintTitleAlign
C#
public TextAlignment PrintTitleAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleFontFamily Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleFontFamily Property

Gets or sets the font family used to paint the title in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontFamily

instance.PrintTitleFontFamily = value

value = instance.PrintTitleFontFamily
C#
public FontFamily PrintTitleFontFamily {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleFontSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleFontSize Property

Gets or sets the font size used to paint the title in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.PrintTitleFontSize = value

value = instance.PrintTitleFontSize
C#
public double PrintTitleFontSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleFontStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleFontStyle Property

Gets or sets the font style used to paint the title in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontStyle

instance.PrintTitleFontStyle = value

value = instance.PrintTitleFontStyle
C#
public FontStyle PrintTitleFontStyle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleFontWeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleFontWeight Property

Gets or sets the font weight used to paint the title in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontWeight

instance.PrintTitleFontWeight = value

value = instance.PrintTitleFontWeight
C#
public FontWeight PrintTitleFontWeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleMargin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleMargin Property

Gets or sets the margin space used to place around the titles in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Thickness

instance.PrintTitleMargin = value

value = instance.PrintTitleMargin
C#
public Thickness PrintTitleMargin {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RedoHistory Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RedoHistory Property

Gets the redo history file for the time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As List(Of dbiHistoryItem)

value = instance.RedoHistory
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public List<dbiHistoryItem> RedoHistory {get;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerBackground Property

Gets or sets the brush used to paint the background of the ruler area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.RulerBackground = value

value = instance.RulerBackground
C#
public Brush RulerBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerFontFamily Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerFontFamily Property

Gets or sets the font family used to paint the text in a list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontFamily

instance.RulerFontFamily = value

value = instance.RulerFontFamily
C#
public FontFamily RulerFontFamily {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerFontSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerFontSize Property

Gets or sets the font size used to paint the text in a list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.RulerFontSize = value

value = instance.RulerFontSize
C#
public double RulerFontSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerFontStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerFontStyle Property

Gets or sets the font style used to paint the text in a list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontStyle

instance.RulerFontStyle = value

value = instance.RulerFontStyle
C#
public FontStyle RulerFontStyle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerFontWeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerFontWeight Property

Gets or sets the font weight used to paint the text in a list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontWeight

instance.RulerFontWeight = value

value = instance.RulerFontWeight
C#
public FontWeight RulerFontWeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerForeground Property

Gets or sets the brush used to paint the foreground of the ruler area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.RulerForeground = value

value = instance.RulerForeground
C#
public Brush RulerForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerLineStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerLineStroke Property

Gets or sets the brush used to paint lines in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.RulerLineStroke = value

value = instance.RulerLineStroke
C#
public Brush RulerLineStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerSelectBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerSelectBackground Property

Gets or sets the brush used to paint the selected time bars span in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.RulerSelectBackground = value

value = instance.RulerSelectBackground
C#
public Brush RulerSelectBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerSelectOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerSelectOffset Property

Gets or sets the offset value used to calculate the vertical height and position of the selected area in the rulers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.RulerSelectOffset = value

value = instance.RulerSelectOffset
C#
public int RulerSelectOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SchedScrollValue Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SchedScrollValue Property

Gets or sets the value of the schedules horizontal scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.SchedScrollValue = value

value = instance.SchedScrollValue
C#
public double SchedScrollValue {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleAreaWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleAreaWidth Property

Gets or sets the width of the schedule area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.ScheduleAreaWidth = value

value = instance.ScheduleAreaWidth
C#
public double ScheduleAreaWidth {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleBackground Property

Gets or sets the brush used to paint the background of the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ScheduleBackground = value

value = instance.ScheduleBackground
C#
public Brush ScheduleBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleHeaderBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleHeaderBackground Property

Gets or sets the brush used to paint the background of schedule items marked as headers in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ScheduleHeaderBackground = value

value = instance.ScheduleHeaderBackground
C#
public Brush ScheduleHeaderBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleHeaderPosition Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleHeaderPosition Property

Gets or sets whether schedule header line items will be in the front or back of the custom areas and time lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As enumScheduleHeaderPosition

instance.ScheduleHeaderPosition = value

value = instance.ScheduleHeaderPosition
C#
public enumScheduleHeaderPosition ScheduleHeaderPosition {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleHorzStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleHorzStroke Property

Gets or sets the brush used to paint the horizontal lines in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ScheduleHorzStroke = value

value = instance.ScheduleHorzStroke
C#
public Brush ScheduleHorzStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleHorzStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleHorzStrokeThickness Property

Gets or sets default stroke thickness for the line used to paint the horizontal lines in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.ScheduleHorzStrokeThickness = value

value = instance.ScheduleHorzStrokeThickness
C#
public double ScheduleHorzStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Schedules Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Schedules Property

Gets or sets the list of schedules within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As dbiScheduleObjectCollection

instance.Schedules = value

value = instance.Schedules
C#
public dbiScheduleObjectCollection Schedules {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedBackground Property

Gets or sets the brush used to paint the background of selected list items in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.SelectedBackground = value

value = instance.SelectedBackground
C#
public Brush SelectedBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedForeground Property

Gets or sets the brush used to paint the text of selected list items in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.SelectedForeground = value

value = instance.SelectedForeground
C#
public Brush SelectedForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedRadius Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedRadius Property

Gets or sets the x-radius of the ellipse that is used to round the corner of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.SelectedRadius = value

value = instance.SelectedRadius
C#
public int SelectedRadius {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedStroke Property

Gets or sets the default brush used to paint the border of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.SelectedStroke = value

value = instance.SelectedStroke
C#
public Brush SelectedStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedStrokeThickness Property

Gets or sets default stroke thickness for the line used to paint the border of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.SelectedStrokeThickness = value

value = instance.SelectedStrokeThickness
C#
public double SelectedStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectModeDashPattern Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectModeDashPattern Property

Gets or sets the dash pattern used to paint the selected mode lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As List(Of Double)

instance.SelectModeDashPattern = value

value = instance.SelectModeDashPattern
C#
public List<double> SelectModeDashPattern {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectModeStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectModeStroke Property

Gets or sets the default brush used to paint the selected mode lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.SelectModeStroke = value

value = instance.SelectModeStroke
C#
public Brush SelectModeStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectModeStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectModeStrokeThickness Property

Gets or sets default stroke thickness for the line used to paint the selected modelines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.SelectModeStrokeThickness = value

value = instance.SelectModeStrokeThickness
C#
public double SelectModeStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SnapToDivisions Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SnapToDivisions Property

Gets or sets how a time bar will align itself to the major ruler division points when being created, moved, or sized with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As enumSnapToDivisions

instance.SnapToDivisions = value

value = instance.SnapToDivisions
C#
public enumSnapToDivisions SnapToDivisions {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SnapToGrid Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SnapToGrid Property

Gets or sets whether a time bar will use the GridFrequency value to align itself to the control when being created, moved or sized with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.SnapToGrid = value

value = instance.SnapToGrid
C#
public bool SnapToGrid {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SnapToGuide Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SnapToGuide Property

Gets or sets whether a time bar will align itself to the guide line when being created, moved or sized with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.SnapToGuide = value

value = instance.SnapToGuide
C#
public bool SnapToGuide {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowAscend Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowAscend Property

Gets or sets the image used for the ascending sort arrow.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As ImageSource

instance.SortArrowAscend = value

value = instance.SortArrowAscend
C#
public ImageSource SortArrowAscend {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowBackground Property

Gets or sets the brush used to paint the sort arrows in the column headers in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.SortArrowBackground = value

value = instance.SortArrowBackground
C#
public Brush SortArrowBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowDescend Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowDescend Property

Gets or sets the image used for the descending sort arrow.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As ImageSource

instance.SortArrowDescend = value

value = instance.SortArrowDescend
C#
public ImageSource SortArrowDescend {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowHorzAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowHorzAlign Property

Gets or sets the value used horizontally align the sort arrows in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As HorizontalAlignment

instance.SortArrowHorzAlign = value

value = instance.SortArrowHorzAlign
C#
public HorizontalAlignment SortArrowHorzAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowOffset Property

Gets or sets the value used to calculate the horizontal and vertical position of the sort arrows in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Point

instance.SortArrowOffset = value

value = instance.SortArrowOffset
C#
public Point SortArrowOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowSize Property

Gets or sets the size of length of the sort arrows in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.SortArrowSize = value

value = instance.SortArrowSize
C#
public int SortArrowSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowVertAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowVertAlign Property

Gets or sets the value used vertically align the sort arrows in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As VerticalAlignment

instance.SortArrowVertAlign = value

value = instance.SortArrowVertAlign
C#
public VerticalAlignment SortArrowVertAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortOnCase Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortOnCase Property

Gets or sets whether a sort routine will test for upper or lower case text when performing the sort.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.SortOnCase = value

value = instance.SortOnCase
C#
public bool SortOnCase {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SplitterBarBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SplitterBarBackground Property

Gets or sets the brush used to paint the splitter bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.SplitterBarBackground = value

value = instance.SplitterBarBackground
C#
public Brush SplitterBarBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SplitterBarWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SplitterBarWidth Property

Gets or sets the width of the splitter bar area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.SplitterBarWidth = value

value = instance.SplitterBarWidth
C#
public double SplitterBarWidth {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TextIntoView Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TextIntoView Property

Gets or sets whether the text in a time bar will always be placed in the visible part of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.TextIntoView = value

value = instance.TextIntoView
C#
public bool TextIntoView {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarBackground Property

Gets or sets the default brush used to paint the time bars in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.TimeBarBackground = value

value = instance.TimeBarBackground
C#
public Brush TimeBarBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarExtension Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarExtension Property

Gets or sets the extension size on each side of a time bar used to resize a time bar with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.TimeBarExtension = value

value = instance.TimeBarExtension
C#
public int TimeBarExtension {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarFontFamily Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarFontFamily Property

Gets or sets the font family used to paint the text in a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontFamily

instance.TimeBarFontFamily = value

value = instance.TimeBarFontFamily
C#
public FontFamily TimeBarFontFamily {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarFontSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarFontSize Property

Gets or sets the font size used to paint the text in a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.TimeBarFontSize = value

value = instance.TimeBarFontSize
C#
public double TimeBarFontSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarFontStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarFontStyle Property

Gets or sets the font style used to paint the text in a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontStyle

instance.TimeBarFontStyle = value

value = instance.TimeBarFontStyle
C#
public FontStyle TimeBarFontStyle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarFontWeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarFontWeight Property

Gets or sets the font weight used to paint the text in a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontWeight

instance.TimeBarFontWeight = value

value = instance.TimeBarFontWeight
C#
public FontWeight TimeBarFontWeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarForeground Property

Gets or sets the default brush used to paint the text of the time bars in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.TimeBarForeground = value

value = instance.TimeBarForeground
C#
public Brush TimeBarForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarMargin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarMargin Property

Gets or sets the margin size on each side of a time bar used to resize a time bar with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.TimeBarMargin = value

value = instance.TimeBarMargin
C#
public int TimeBarMargin {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarMinWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarMinWidth Property

Gets or sets the minimim width for a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.TimeBarMinWidth = value

value = instance.TimeBarMinWidth
C#
public int TimeBarMinWidth {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarRadius Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarRadius Property

Gets or sets the radius of the ellipse that is used to round the corner of a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.TimeBarRadius = value

value = instance.TimeBarRadius
C#
public int TimeBarRadius {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarShadowColor Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarShadowColor Property

Gets or sets the color of a time bar shadow effect

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As SolidColorBrush

instance.TimeBarShadowColor = value

value = instance.TimeBarShadowColor
C#
public SolidColorBrush TimeBarShadowColor {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarShadowOpacity Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarShadowOpacity Property

Gets or sets the opacity of a time bar shadow effect.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.TimeBarShadowOpacity = value

value = instance.TimeBarShadowOpacity
C#
public double TimeBarShadowOpacity {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarShadows Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarShadows Property

Gets or sets whether a shadow effect will be placed around a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.TimeBarShadows = value

value = instance.TimeBarShadows
C#
public bool TimeBarShadows {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarStroke Property

Gets or sets the default brush used to paint the time bar borders in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.TimeBarStroke = value

value = instance.TimeBarStroke
C#
public Brush TimeBarStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarStrokeThickness Property

Gets or sets default stroke thickness for the line used to paint the border of a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.TimeBarStrokeThickness = value

value = instance.TimeBarStrokeThickness
C#
public double TimeBarStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarTextWrap Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarTextWrap Property

Gets or sets whether the text in a time bar can be displayed on multiple lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.TimeBarTextWrap = value

value = instance.TimeBarTextWrap
C#
public bool TimeBarTextWrap {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeDistance Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeDistance Property

Gets or sets the distance between the major time units.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.TimeDistance = value

value = instance.TimeDistance
C#
public int TimeDistance {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsBackground Property

Gets or sets the brush used to paint the backround of a tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.TipsBackground = value

value = instance.TipsBackground
C#
public Brush TipsBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsFontFamily Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsFontFamily Property

Gets or sets the font family used to paint the text in the tool tips.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontFamily

instance.TipsFontFamily = value

value = instance.TipsFontFamily
C#
public FontFamily TipsFontFamily {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsFontSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsFontSize Property

Gets or sets the font size used to paint the text in the tool tips.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.TipsFontSize = value

value = instance.TipsFontSize
C#
public double TipsFontSize {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsFontStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsFontStyle Property

Gets or sets the font style used to paint the text in the tool tips.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontStyle

instance.TipsFontStyle = value

value = instance.TipsFontStyle
C#
public FontStyle TipsFontStyle {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsFontWeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsFontWeight Property

Gets or sets the font weight used to paint the text in the tool tips.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontWeight

instance.TipsFontWeight = value

value = instance.TipsFontWeight
C#
public FontWeight TipsFontWeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsForeground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsForeground Property

Gets or sets the brush used to paint the text of a tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.TipsForeground = value

value = instance.TipsForeground
C#
public Brush TipsForeground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnChangeBar Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnChangeBar Property

Gets or sets whether tool tips will appear when a time bar is being moved or sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.TipsOnChangeBar = value

value = instance.TipsOnChangeBar
C#
public bool TipsOnChangeBar {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnCreateBar Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnCreateBar Property

Gets or sets whether tool tips will appear when a time bar is being created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.TipsOnCreateBar = value

value = instance.TipsOnCreateBar
C#
public bool TipsOnCreateBar {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnGuideLines Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnGuideLines Property

Gets or sets whether tool tips will appear when the mouse is dragging a guide line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.TipsOnGuideLines = value

value = instance.TipsOnGuideLines
C#
public bool TipsOnGuideLines {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnNotes Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnNotes Property

Gets or sets whether tool tips will appear when the mouse hovers over a note.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.TipsOnNotes = value

value = instance.TipsOnNotes
C#
public bool TipsOnNotes {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnOverBar Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnOverBar Property

Gets or sets whether tool tips will appear when the mouse hovers over a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.TipsOnOverBar = value

value = instance.TipsOnOverBar
C#
public bool TipsOnOverBar {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsShadowColor Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsShadowColor Property

Gets or sets the color of a tool tip shadow effect.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As SolidColorBrush

instance.TipsShadowColor = value

value = instance.TipsShadowColor
C#
public SolidColorBrush TipsShadowColor {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsShadowOpacity Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsShadowOpacity Property

Gets or sets the opacity of a tool tip shadow effect.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.TipsShadowOpacity = value

value = instance.TipsShadowOpacity
C#
public double TipsShadowOpacity {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsShadows Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsShadows Property

Gets or sets whether a shadow effect will be placed around a tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.TipsShadows = value

value = instance.TipsShadows
C#
public bool TipsShadows {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsStroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsStroke Property

Gets or sets the brush used to paint the border of a tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.TipsStroke = value

value = instance.TipsStroke
C#
public Brush TipsStroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsStrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsStrokeThickness Property

Gets or sets the border thickness of a tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.TipsStrokeThickness = value

value = instance.TipsStrokeThickness
C#
public double TipsStrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarBackground Property

Gets or sets the brush used to paint the backround of the tool bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.ToolbarBackground = value

value = instance.ToolbarBackground
C#
public Brush ToolbarBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarOnRightClick Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarOnRightClick Property

Gets or sets whether a tool bar for the edit modes will appear when the schedule is right clicked on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.ToolbarOnRightClick = value

value = instance.ToolbarOnRightClick
C#
public bool ToolbarOnRightClick {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarShadow Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarShadow Property

Gets or sets whether a shadow effect will be placed around a tool bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.ToolbarShadow = value

value = instance.ToolbarShadow
C#
public bool ToolbarShadow {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarShadowColor Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarShadowColor Property

Gets or sets the color of a tool bar shadow effect.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As SolidColorBrush

instance.ToolbarShadowColor = value

value = instance.ToolbarShadowColor
C#
public SolidColorBrush ToolbarShadowColor {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarShadowOpacity Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarShadowOpacity Property

Gets or sets the opacity of a tool bar shadow effect.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.ToolbarShadowOpacity = value

value = instance.ToolbarShadowOpacity
C#
public double ToolbarShadowOpacity {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TreeClose Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TreeClose Property

Gets or sets the image used in the list to represent items that own other child items they are not being shown.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As ImageSource

instance.TreeClose = value

value = instance.TreeClose
C#
public ImageSource TreeClose {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TreeLevelIndent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TreeLevelIndent Property

Gets or sets on offset used to calculate the distance to indent each level of a tree.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.TreeLevelIndent = value

value = instance.TreeLevelIndent
C#
public int TreeLevelIndent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TreeOpen Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TreeOpen Property

Gets or sets the image used in the list to represent items that own other child items they are being shown.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As ImageSource

instance.TreeOpen = value

value = instance.TreeOpen
C#
public ImageSource TreeOpen {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UndoHistory Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UndoHistory Property

Gets the undo history file for the time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As List(Of dbiHistoryItem)

value = instance.UndoHistory
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public List<dbiHistoryItem> UndoHistory {get;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

VertScrollValue Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : VertScrollValue Property

Gets or sets the value of the vertical scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.VertScrollValue = value

value = instance.VertScrollValue
C#
public double VertScrollValue {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

WeekendBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : WeekendBackground Property

Gets or sets the brush used to paint the days marked as weekends.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.WeekendBackground = value

value = instance.WeekendBackground
C#
public Brush WeekendBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

WeekendDays Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : WeekendDays Property

Gets or sets the list that represents the days representing the weekend.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As List(Of DayOfWeek)

instance.WeekendDays = value

value = instance.WeekendDays
C#
public List<DayOfWeek> WeekendDays {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%% $$Fields$$

dbiScheduleWPF Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF Class

"

For a list of all members of this type, see dbiScheduleWPF members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | ActiveScheduleProperty | Identifies the DependencyProperty for the ActiveSchedule Property
static (Shared in Visual Basic) | AllowHorzMovesProperty | Identifies the DependencyProperty for the AllowHorzMoves Property
static (Shared in Visual Basic) | AllowNewBarsProperty | Identifies the DependencyProperty for the AllowNewBars Property
static (Shared in Visual Basic) | AllowResizeBarsProperty | Identifies the DependencyProperty for the AllowResizeBars Property
static (Shared in Visual Basic) | AllowVertMovesProperty | Identifies the DependencyProperty for the AllowVertMoves Property
static (Shared in Visual Basic) | AltListBrushesProperty | Identifies the DependencyProperty for the AltListBrushes Property
static (Shared in Visual Basic) | AltListEvenBackgroundProperty | Identifies the DependencyProperty for the AltListEvenBackground Property
static (Shared in Visual Basic) | AltListItemsProperty | Identifies the DependencyProperty for the AltListItems Property
static (Shared in Visual Basic) | AltListOddBackgroundProperty | Identifies the DependencyProperty for the AltListOddBackground Property
static (Shared in Visual Basic) | AutoDuplicateProperty | Identifies the DependencyProperty for the AutoDuplicate Property
static (Shared in Visual Basic) | BarSelectBackgroundProperty | Identifies the DependencyProperty for the BarSelectBackground Property
static (Shared in Visual Basic) | BarSelectForegroundProperty | Identifies the DependencyProperty for the BarSelectForeground Property
static (Shared in Visual Basic) | BarSelectStrokeProperty | Identifies the DependencyProperty for the BarSelectStroke Property
static (Shared in Visual Basic) | BarSelectStrokeThicknessProperty | Identifies the DependencyProperty for the BarSelectStrokeThickness Property
static (Shared in Visual Basic) | BorderBrushProperty | Identifies the DependencyProperty for the BorderBrush Property
static (Shared in Visual Basic) | ColumnsProperty | Identifies the DependencyProperty for the Columns Property
static (Shared in Visual Basic) | CornerBackgroundProperty | Identifies the DependencyProperty for the CornerBackground Property
static (Shared in Visual Basic) | CurrentTimeColorToProperty | Identifies the DependencyProperty for the CurrentTimeColorTo Property
static (Shared in Visual Basic) | CurrentTimeLineProperty | Identifies the DependencyProperty for the CurrentTimeLine Property
static (Shared in Visual Basic) | CurrentTimeOffsetProperty | Identifies the DependencyProperty for the CurrentTimeOffset Property
static (Shared in Visual Basic) | CurrentTimeStrokeProperty | Identifies the DependencyProperty for the CurrentTimeStroke Property
static (Shared in Visual Basic) | CurrentTimeStrokeThicknessProperty | Identifies the DependencyProperty for the CurrentTimeStrokeThickness Property
static (Shared in Visual Basic) | CustomAreaBackgroundProperty | Identifies the DependencyProperty for the CustomAreaBackground Property
static (Shared in Visual Basic) | CustomAreasProperty | Identifies the DependencyProperty for the CustomAreas Property
static (Shared in Visual Basic) | DayMonthOffsetProperty | Identifies the DependencyProperty for the DayMonthOffset Property
static (Shared in Visual Basic) | DayNamesProperty | Identifies the DependencyProperty for the DayNames Property
static (Shared in Visual Basic) | DisplayGuideLinesProperty | Identifies the DependencyProperty for the DisplayGuideLines Property
static (Shared in Visual Basic) | DisplayListGuideProperty | Identifies the DependencyProperty for the DisplayListGuide Property
static (Shared in Visual Basic) | DivisionDistanceProperty | Identifies the DependencyProperty for the DivisionDistance Property
static (Shared in Visual Basic) | EditModeProperty | Identifies the DependencyProperty for the EditMode Property
static (Shared in Visual Basic) | FillListProperty | Identifies the DependencyProperty for the FillList Property
static (Shared in Visual Basic) | GridFrequencyProperty | Identifies the DependencyProperty for the GridFrequency Property
static (Shared in Visual Basic) | GuideImagePositionProperty | Identifies the DependencyProperty for the GuideImagePosition Property
static (Shared in Visual Basic) | GuideLineDashPatternProperty | Identifies the DependencyProperty for the GuideLineDashPattern Property
static (Shared in Visual Basic) | GuideLineDistanceProperty | Identifies the DependencyProperty for the GuideLineDistance Property
static (Shared in Visual Basic) | GuideLinePositionProperty | Identifies the DependencyProperty for the GuideLinePosition Property
static (Shared in Visual Basic) | GuideLineStrokeProperty | Identifies the DependencyProperty for the GuideLineStroke Property
static (Shared in Visual Basic) | GuideLineStrokeThicknessProperty | Identifies the DependencyProperty for the GuideLineStrokeThickness Property
static (Shared in Visual Basic) | GuideSelectStrokeProperty | Identifies the DependencyProperty for the GuideSelectStroke Property
static (Shared in Visual Basic) | HandleListRightClickProperty | Identifies the DependencyProperty for the HandleListRightClick Property
static (Shared in Visual Basic) | HandleMapAreaRightClickProperty | Identifies the DependencyProperty for the HandleMapAreaRightClick Property
static (Shared in Visual Basic) | HandleScheduleRightClickProperty | Identifies the DependencyProperty for the HandleScheduleRightClick Property
static (Shared in Visual Basic) | HeaderAlignProperty | Identifies the DependencyProperty for the HeaderAlign Property
static (Shared in Visual Basic) | HeaderBackgroundProperty | Identifies the DependencyProperty for the HeaderBackground Property
static (Shared in Visual Basic) | HeaderFontFamilyProperty | Identifies the DependencyProperty for the HeaderFontFamily Property
static (Shared in Visual Basic) | HeaderFontSizeProperty | Identifies the DependencyProperty for the HeaderFontSize Property
static (Shared in Visual Basic) | HeaderFontStyleProperty | Identifies the DependencyProperty for the HeaderFontStyle Property
static (Shared in Visual Basic) | HeaderFontWeightProperty | Identifies the DependencyProperty for the HeaderFontWeight Property
static (Shared in Visual Basic) | HeaderForegroundProperty | Identifies the DependencyProperty for the HeaderForeground Property
static (Shared in Visual Basic) | HeaderHeightProperty | Identifies the DependencyProperty for the HeaderHeight Property
static (Shared in Visual Basic) | HeaderVisibleProperty | Identifies the DependencyProperty for the HeaderVisible Property
static (Shared in Visual Basic) | HistorySizeProperty | Identifies the DependencyProperty for the HistorySize Property
static (Shared in Visual Basic) | ImagesProperty | Identifies the DependencyProperty for the Images Property
static (Shared in Visual Basic) | ItemHeaderBackgroundProperty | Identifies the DependencyProperty for the ItemHeaderBackground Property
static (Shared in Visual Basic) | ItemHeaderForegroundProperty | Identifies the DependencyProperty for the ItemHeaderForeground Property
static (Shared in Visual Basic) | ItemHeightOffsetProperty | Identifies the DependencyProperty for the ItemHeightOffset Property
static (Shared in Visual Basic) | ItemsProperty | Identifies the DependencyProperty for the Items Property
static (Shared in Visual Basic) | LineArrowAfterProperty | Identifies the DependencyProperty for the LineArrowAfter Property
static (Shared in Visual Basic) | LineArrowBackgroundProperty | Identifies the DependencyProperty for the LineArrowBackground Property
static (Shared in Visual Basic) | LineArrowBeforeProperty | Identifies the DependencyProperty for the LineArrowBefore Property
static (Shared in Visual Basic) | LineArrowPositionProperty | Identifies the DependencyProperty for the LineArrowPosition Property
static (Shared in Visual Basic) | LineArrowTypeProperty | Identifies the DependencyProperty for the LineArrowType Property
static (Shared in Visual Basic) | LinkLineStrokeProperty | Identifies the DependencyProperty for the LinkLineStroke Property
static (Shared in Visual Basic) | LinksProperty | Identifies the DependencyProperty for the Links Property
static (Shared in Visual Basic) | ListBackgroundProperty | Identifies the DependencyProperty for the ListBackground Property
static (Shared in Visual Basic) | ListFontFamilyProperty | Identifies the DependencyProperty for the ListFontFamily Property
static (Shared in Visual Basic) | ListFontSizeProperty | Identifies the DependencyProperty for the ListFontSize Property
static (Shared in Visual Basic) | ListFontStyleProperty | Identifies the DependencyProperty for the ListFontStyle Property
static (Shared in Visual Basic) | ListFontWeightProperty | Identifies the DependencyProperty for the ListFontWeight Property
static (Shared in Visual Basic) | ListForegroundProperty | Identifies the DependencyProperty for the ListForeground Property
static (Shared in Visual Basic) | ListGuideBackgroundProperty | Identifies the DependencyProperty for the ListGuideBackground Property
static (Shared in Visual Basic) | ListGuideDistanceProperty | Identifies the DependencyProperty for the ListGuideDistance Property
static (Shared in Visual Basic) | ListGuideFadeDurationProperty | Identifies the DependencyProperty for the ListGuideFadeDuration Property
static (Shared in Visual Basic) | ListGuideForegroundProperty | Identifies the DependencyProperty for the ListGuideForeground Property
static (Shared in Visual Basic) | ListGuideWidthProperty | Identifies the DependencyProperty for the ListGuideWidth Property
static (Shared in Visual Basic) | ListHorzStrokeProperty | Identifies the DependencyProperty for the ListHorzStroke Property
static (Shared in Visual Basic) | ListHorzStrokeThicknessProperty | Identifies the DependencyProperty for the ListHorzStrokeThickness Property
static (Shared in Visual Basic) | ListImageAlignProperty | Identifies the DependencyProperty for the ListImageAlign Property
static (Shared in Visual Basic) | ListTextAlignProperty | Identifies the DependencyProperty for the ListTextAlign Property
static (Shared in Visual Basic) | ListTitleProperty | Identifies the DependencyProperty for the ListTitle Property
static (Shared in Visual Basic) | ListTypeProperty | Identifies the DependencyProperty for the ListType Property
static (Shared in Visual Basic) | ListVertStrokeProperty | Identifies the DependencyProperty for the ListVertStroke Property
static (Shared in Visual Basic) | ListVertStrokeThicknessProperty | Identifies the DependencyProperty for the ListVertStrokeThickness Property
static (Shared in Visual Basic) | MapAreaProperty | Identifies the DependencyProperty for the MapArea Property
static (Shared in Visual Basic) | MapBackgroundProperty | Identifies the DependencyProperty for the MapBackground Property
static (Shared in Visual Basic) | MapHeightProperty | Identifies the DependencyProperty for the MapHeight Property
static (Shared in Visual Basic) | MapLineProperty | Identifies the DependencyProperty for the MapLine Property
static (Shared in Visual Basic) | MapLineThicknessProperty | Identifies the DependencyProperty for the MapLineThickness Property
static (Shared in Visual Basic) | MapStrokeProperty | Identifies the DependencyProperty for the MapStroke Property
static (Shared in Visual Basic) | MapStrokeThicknessProperty | Identifies the DependencyProperty for the MapStrokeThickness Property
static (Shared in Visual Basic) | MinBarTimeProperty | Identifies the DependencyProperty for the MinBarTime Property
static (Shared in Visual Basic) | MonthNamesProperty | Identifies the DependencyProperty for the MonthNames Property
static (Shared in Visual Basic) | NotesDistanceProperty | Identifies the DependencyProperty for the NotesDistance Property
static (Shared in Visual Basic) | NotesPositionProperty | Identifies the DependencyProperty for the NotesPosition Property
static (Shared in Visual Basic) | OverlapSpanProperty | Identifies the DependencyProperty for the OverlapSpan Property
static (Shared in Visual Basic) | OverlapStrokeProperty | Identifies the DependencyProperty for the OverlapStroke Property
static (Shared in Visual Basic) | OverlapStrokeThicknessProperty | Identifies the DependencyProperty for the OverlapStrokeThickness Property
static (Shared in Visual Basic) | PercentBackgroundProperty | Identifies the DependencyProperty for the PercentBackground Property
static (Shared in Visual Basic) | PrintFontFamilyProperty | Identifies the DependencyProperty for the PrintFontFamily Property
static (Shared in Visual Basic) | PrintFontSizeProperty | Identifies the DependencyProperty for the PrintFontSize Property
static (Shared in Visual Basic) | PrintFontStyleProperty | Identifies the DependencyProperty for the PrintFontStyle Property
static (Shared in Visual Basic) | PrintFontWeightProperty | Identifies the DependencyProperty for the PrintFontWeight Property
static (Shared in Visual Basic) | PrintFooterAlignProperty | Identifies the DependencyProperty for the PrintFooterAlign Property
static (Shared in Visual Basic) | PrintFooterMarginProperty | Identifies the DependencyProperty for the PrintFooterMargin Property
static (Shared in Visual Basic) | PrintListAlwaysProperty | Identifies the DependencyProperty for the PrintListAlways Property
static (Shared in Visual Basic) | PrintListWidthProperty | Identifies the DependencyProperty for the PrintListWidth Property
static (Shared in Visual Basic) | PrintMarginProperty | Identifies the DependencyProperty for the PrintMargin Property
static (Shared in Visual Basic) | PrintPageTextProperty | Identifies the DependencyProperty for the PrintPageText Property
static (Shared in Visual Basic) | PrintSubTitleMarginProperty | Identifies the DependencyProperty for the PrintSubTitleMargin Property
static (Shared in Visual Basic) | PrintSubTitleProperty | Identifies the DependencyProperty for the PrintSubTitle Property
static (Shared in Visual Basic) | PrintTimeDistanceProperty | Identifies the DependencyProperty for the PrintTimeDistance Property
static (Shared in Visual Basic) | PrintTitleAlignProperty | Identifies the DependencyProperty for the PrintTitleAlign Property
static (Shared in Visual Basic) | PrintTitleFontFamilyProperty | Identifies the DependencyProperty for the PrintTitleFontFamily Property
static (Shared in Visual Basic) | PrintTitleFontSizeProperty | Identifies the DependencyProperty for the PrintTitleFontSize Property
static (Shared in Visual Basic) | PrintTitleFontStyleProperty | Identifies the DependencyProperty for the PrintTitleFontStyle Property
static (Shared in Visual Basic) | PrintTitleFontWeightProperty | Identifies the DependencyProperty for the PrintTitleFontWeight Property
static (Shared in Visual Basic) | PrintTitleMarginProperty | Identifies the DependencyProperty for the PrintTitleMargin Property
static (Shared in Visual Basic) | PrintTitleProperty | Identifies the DependencyProperty for the PrintTitle Property
static (Shared in Visual Basic) | RulerBackgroundProperty | Identifies the DependencyProperty for the RulerBackground Property
static (Shared in Visual Basic) | RulerFontFamilyProperty | Identifies the DependencyProperty for the RulerFontFamily Property
static (Shared in Visual Basic) | RulerFontSizeProperty | Identifies the DependencyProperty for the RulerFontSize Property
static (Shared in Visual Basic) | RulerFontStyleProperty | Identifies the DependencyProperty for the RulerFontStyle Property
static (Shared in Visual Basic) | RulerFontWeightProperty | Identifies the DependencyProperty for the RulerFontWeight Property
static (Shared in Visual Basic) | RulerForegroundProperty | Identifies the DependencyProperty for the RulerForeground Property
static (Shared in Visual Basic) | RulerLineStrokeProperty | Identifies the DependencyProperty for the RulerLineStroke Property
static (Shared in Visual Basic) | RulerSelectBackgroundProperty | Identifies the DependencyProperty for the RulerSelectBackground Property
static (Shared in Visual Basic) | RulerSelectOffsetProperty | Identifies the DependencyProperty for the RulerSelectOffset Property
static (Shared in Visual Basic) | ScheduleBackgroundProperty | Identifies the DependencyProperty for the ScheduleBackground Property
static (Shared in Visual Basic) | ScheduleHeaderBackgroundProperty | Identifies the DependencyProperty for the ScheduleHeaderBackground Property
static (Shared in Visual Basic) | ScheduleHeaderPositionProperty | Identifies the DependencyProperty for the ScheduleHeaderPosition Property
static (Shared in Visual Basic) | ScheduleHorzStrokeProperty | Identifies the DependencyProperty for the ScheduleHorzStroke Property
static (Shared in Visual Basic) | ScheduleHorzStrokeThicknessProperty | Identifies the DependencyProperty for the ScheduleHorzStrokeThickness Property
static (Shared in Visual Basic) | SchedulesProperty | Identifies the DependencyProperty for the Schedules Property
static (Shared in Visual Basic) | SelectedBackgroundProperty | Identifies the DependencyProperty for the SelectedBackground Property
static (Shared in Visual Basic) | SelectedForegroundProperty | Identifies the DependencyProperty for the SelectedForeground Property
static (Shared in Visual Basic) | SelectedRadiusProperty | Identifies the DependencyProperty for the SelectedRadius Property
static (Shared in Visual Basic) | SelectedStrokeProperty | Identifies the DependencyProperty for the SelectedStroke Property
static (Shared in Visual Basic) | SelectedStrokeThicknessProperty | Identifies the DependencyProperty for the SelectedStrokeThickness Property
static (Shared in Visual Basic) | SelectModeDashPatternProperty | Identifies the DependencyProperty for the SelectModeDashPattern Property
static (Shared in Visual Basic) | SelectModeStrokeProperty | Identifies the DependencyProperty for the SelectModeStroke Property
static (Shared in Visual Basic) | SelectModeStrokeThicknessProperty | Identifies the DependencyProperty for the SelectModeStrokeThickness Property
static (Shared in Visual Basic) | SnapToDivisionsProperty | Identifies the DependencyProperty for the SnapToDivisions Property
static (Shared in Visual Basic) | SnapToGridProperty | Identifies the DependencyProperty for the SnapToGrid Property
static (Shared in Visual Basic) | SnapToGuideProperty | Identifies the DependencyProperty for the SnapToGuide Property
static (Shared in Visual Basic) | SortArrowAscendProperty | Identifies the DependencyProperty for the SortArrowAscend Property
static (Shared in Visual Basic) | SortArrowBackgroundProperty | Identifies the DependencyProperty for the SortArrowBackground Property
static (Shared in Visual Basic) | SortArrowDescendProperty | Identifies the DependencyProperty for the SortArrowDescend Property
static (Shared in Visual Basic) | SortArrowHorzAlignProperty | Identifies the DependencyProperty for the SortArrowHorzAlign Property
static (Shared in Visual Basic) | SortArrowOffsetProperty | Identifies the DependencyProperty for the SortArrowOffset Property
static (Shared in Visual Basic) | SortArrowSizeProperty | Identifies the DependencyProperty for the SortArrowSize Property
static (Shared in Visual Basic) | SortArrowVertAlignProperty | Identifies the DependencyProperty for the SortArrowVertAlign Property
static (Shared in Visual Basic) | SortOnCaseProperty | Identifies the DependencyProperty for the SortOnCase Property
static (Shared in Visual Basic) | SplitterBarBackgroundProperty | Identifies the DependencyProperty for the SplitterBarBackground Property
static (Shared in Visual Basic) | TextIntoViewProperty | Identifies the DependencyProperty for the TextIntoView Property
static (Shared in Visual Basic) | TimeBarBackgroundProperty | Identifies the DependencyProperty for the TimeBarBackground Property
static (Shared in Visual Basic) | TimeBarExtensionProperty | Identifies the DependencyProperty for the TimeBarExtension Property
static (Shared in Visual Basic) | TimeBarFontFamilyProperty | Identifies the DependencyProperty for the TimeBarFontFamily Property
static (Shared in Visual Basic) | TimeBarFontSizeProperty | Identifies the DependencyProperty for the TimeBarFontSize Property
static (Shared in Visual Basic) | TimeBarFontStyleProperty | Identifies the DependencyProperty for the TimeBarFontStyle Property
static (Shared in Visual Basic) | TimeBarFontWeightProperty | Identifies the DependencyProperty for the TimeBarFontWeight Property
static (Shared in Visual Basic) | TimeBarForegroundProperty | Identifies the DependencyProperty for the TimeBarForeground Property
static (Shared in Visual Basic) | TimeBarMarginProperty | Identifies the DependencyProperty for the TimeBarMargin Property
static (Shared in Visual Basic) | TimeBarMinWidthProperty | Identifies the DependencyProperty for the TimeBarMinWidth Property
static (Shared in Visual Basic) | TimeBarRadiusProperty | Identifies the DependencyProperty for the TimeBarRadius Property
static (Shared in Visual Basic) | TimeBarShadowColorProperty | Identifies the DependencyProperty for the TimeBarShadowColor Property
static (Shared in Visual Basic) | TimeBarShadowOpacityProperty | Identifies the DependencyProperty for the TimeBarShadowOpacity Property
static (Shared in Visual Basic) | TimeBarShadowsProperty | Identifies the DependencyProperty for the TimeBarShadows Property
static (Shared in Visual Basic) | TimeBarStrokeProperty | Identifies the DependencyProperty for the TimeBarStroke Property
static (Shared in Visual Basic) | TimeBarStrokeThicknessProperty | Identifies the DependencyProperty for the TimeBarStrokeThickness Property
static (Shared in Visual Basic) | TimeBarTextWrapProperty | Identifies the DependencyProperty for the TimeBarTextWrap Property
static (Shared in Visual Basic) | TimeDistanceProperty | Identifies the DependencyProperty for the TimeDistance Property
static (Shared in Visual Basic) | TipsBackgroundProperty | Identifies the DependencyProperty for the TipsBackground Property
static (Shared in Visual Basic) | TipsFontFamilyProperty | Identifies the DependencyProperty for the TipsFontFamily Property
static (Shared in Visual Basic) | TipsFontSizeProperty | Identifies the DependencyProperty for the TipsFontSize Property
static (Shared in Visual Basic) | TipsFontStyleProperty | Identifies the DependencyProperty for the TipsFontStyle Property
static (Shared in Visual Basic) | TipsFontWeightProperty | Identifies the DependencyProperty for the TipsFontWeight Property
static (Shared in Visual Basic) | TipsForegroundProperty | Identifies the DependencyProperty for the TipsForeground Property
static (Shared in Visual Basic) | TipsOnChangeBarProperty | Identifies the DependencyProperty for the TipsOnChangeBar Property
static (Shared in Visual Basic) | TipsOnCreateBarProperty | Identifies the DependencyProperty for the TipsOnCreateBar Property
static (Shared in Visual Basic) | TipsOnGuideLinesProperty | Identifies the DependencyProperty for the TipsOnGuideLines Property
static (Shared in Visual Basic) | TipsOnNotesProperty | Identifies the DependencyProperty for the TipsOnNotes Property
static (Shared in Visual Basic) | TipsOnOverBarProperty | Identifies the DependencyProperty for the TipsOnOverBar Property
static (Shared in Visual Basic) | TipsShadowColorProperty | Identifies the DependencyProperty for the TipsShadowColor Property
static (Shared in Visual Basic) | TipsShadowOpacityProperty | Identifies the DependencyProperty for the TipsShadowOpacity Property
static (Shared in Visual Basic) | TipsShadowsProperty | Identifies the DependencyProperty for the TipsShadows Property
static (Shared in Visual Basic) | TipsStrokeProperty | Identifies the DependencyProperty for the TipsStroke Property
static (Shared in Visual Basic) | TipsStrokeThicknessProperty | Identifies the DependencyProperty for the TipsStrokeThickness Property
static (Shared in Visual Basic) | ToolbarBackgroundProperty | Identifies the DependencyProperty for the ToolbarBackground Property
static (Shared in Visual Basic) | ToolbarOnRightClickProperty | Identifies the DependencyProperty for the ToolbarOnRightClick Property
static (Shared in Visual Basic) | ToolbarShadowColorProperty | Identifies the DependencyProperty for the ToolbarShadowColor Property
static (Shared in Visual Basic) | ToolbarShadowOpacityProperty | Identifies the DependencyProperty for the ToolbarShadowOpacity Property
static (Shared in Visual Basic) | ToolbarShadowProperty | Identifies the DependencyProperty for the ToolbarShadow Property
static (Shared in Visual Basic) | TreeCloseProperty | Identifies the DependencyProperty for the TreeClose Property
static (Shared in Visual Basic) | TreeLevelIndentProperty | Identifies the DependencyProperty for the TreeLevelIndent Property
static (Shared in Visual Basic) | TreeOpenProperty | Identifies the DependencyProperty for the TreeOpen Property
static (Shared in Visual Basic) | WeekendBackgroundProperty | Identifies the DependencyProperty for the WeekendBackground Property
static (Shared in Visual Basic) | WeekendDaysProperty | Identifies the DependencyProperty for the WeekendDays Property
Top

See Also

Reference

dbiScheduleWPF Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ActiveScheduleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ActiveScheduleProperty Field

Identifies the DependencyProperty for the ActiveSchedule Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ActiveScheduleProperty
C#
public static readonly DependencyProperty ActiveScheduleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AllowHorzMovesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AllowHorzMovesProperty Field

Identifies the DependencyProperty for the AllowHorzMoves Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.AllowHorzMovesProperty
C#
public static readonly DependencyProperty AllowHorzMovesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AllowNewBarsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AllowNewBarsProperty Field

Identifies the DependencyProperty for the AllowNewBars Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.AllowNewBarsProperty
C#
public static readonly DependencyProperty AllowNewBarsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AllowResizeBarsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AllowResizeBarsProperty Field

Identifies the DependencyProperty for the AllowResizeBars Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.AllowResizeBarsProperty
C#
public static readonly DependencyProperty AllowResizeBarsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AllowVertMovesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AllowVertMovesProperty Field

Identifies the DependencyProperty for the AllowVertMoves Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.AllowVertMovesProperty
C#
public static readonly DependencyProperty AllowVertMovesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AltListBrushesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AltListBrushesProperty Field

Identifies the DependencyProperty for the AltListBrushes Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.AltListBrushesProperty
C#
public static readonly DependencyProperty AltListBrushesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AltListEvenBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AltListEvenBackgroundProperty Field

Identifies the DependencyProperty for the AltListEvenBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.AltListEvenBackgroundProperty
C#
public static readonly DependencyProperty AltListEvenBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AltListItemsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AltListItemsProperty Field

Identifies the DependencyProperty for the AltListItems Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.AltListItemsProperty
C#
public static readonly DependencyProperty AltListItemsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AltListOddBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AltListOddBackgroundProperty Field

Identifies the DependencyProperty for the AltListOddBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.AltListOddBackgroundProperty
C#
public static readonly DependencyProperty AltListOddBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AutoDuplicateProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AutoDuplicateProperty Field

Identifies the DependencyProperty for the AutoDuplicate Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.AutoDuplicateProperty
C#
public static readonly DependencyProperty AutoDuplicateProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BarSelectBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarSelectBackgroundProperty Field

Identifies the DependencyProperty for the BarSelectBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.BarSelectBackgroundProperty
C#
public static readonly DependencyProperty BarSelectBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BarSelectForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarSelectForegroundProperty Field

Identifies the DependencyProperty for the BarSelectForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.BarSelectForegroundProperty
C#
public static readonly DependencyProperty BarSelectForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BarSelectStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarSelectStrokeProperty Field

Identifies the DependencyProperty for the BarSelectStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.BarSelectStrokeProperty
C#
public static readonly DependencyProperty BarSelectStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BarSelectStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BarSelectStrokeThicknessProperty Field

Identifies the DependencyProperty for the BarSelectStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.BarSelectStrokeThicknessProperty
C#
public static readonly DependencyProperty BarSelectStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BorderBrushProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BorderBrushProperty Field

Identifies the DependencyProperty for the BorderBrush Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.BorderBrushProperty
C#
public static readonly DependencyProperty BorderBrushProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ColumnsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ColumnsProperty Field

Identifies the DependencyProperty for the Columns Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ColumnsProperty
C#
public static readonly DependencyProperty ColumnsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CornerBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CornerBackgroundProperty Field

Identifies the DependencyProperty for the CornerBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.CornerBackgroundProperty
C#
public static readonly DependencyProperty CornerBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeColorToProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeColorToProperty Field

Identifies the DependencyProperty for the CurrentTimeColorTo Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.CurrentTimeColorToProperty
C#
public static readonly DependencyProperty CurrentTimeColorToProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeLineProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeLineProperty Field

Identifies the DependencyProperty for the CurrentTimeLine Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.CurrentTimeLineProperty
C#
public static readonly DependencyProperty CurrentTimeLineProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeOffsetProperty Field

Identifies the DependencyProperty for the CurrentTimeOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.CurrentTimeOffsetProperty
C#
public static readonly DependencyProperty CurrentTimeOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeStrokeProperty Field

Identifies the DependencyProperty for the CurrentTimeStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.CurrentTimeStrokeProperty
C#
public static readonly DependencyProperty CurrentTimeStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CurrentTimeStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CurrentTimeStrokeThicknessProperty Field

Identifies the DependencyProperty for the CurrentTimeStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.CurrentTimeStrokeThicknessProperty
C#
public static readonly DependencyProperty CurrentTimeStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CustomAreaBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CustomAreaBackgroundProperty Field

Identifies the DependencyProperty for the CustomAreaBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.CustomAreaBackgroundProperty
C#
public static readonly DependencyProperty CustomAreaBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CustomAreasProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CustomAreasProperty Field

Identifies the DependencyProperty for the CustomAreas Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.CustomAreasProperty
C#
public static readonly DependencyProperty CustomAreasProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DayMonthOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DayMonthOffsetProperty Field

Identifies the DependencyProperty for the DayMonthOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.DayMonthOffsetProperty
C#
public static readonly DependencyProperty DayMonthOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DayNamesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DayNamesProperty Field

Identifies the DependencyProperty for the DayNames Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.DayNamesProperty
C#
public static readonly DependencyProperty DayNamesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DisplayGuideLinesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DisplayGuideLinesProperty Field

Identifies the DependencyProperty for the DisplayGuideLines Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.DisplayGuideLinesProperty
C#
public static readonly DependencyProperty DisplayGuideLinesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DisplayListGuideProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DisplayListGuideProperty Field

Identifies the DependencyProperty for the DisplayListGuide Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.DisplayListGuideProperty
C#
public static readonly DependencyProperty DisplayListGuideProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DivisionDistanceProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DivisionDistanceProperty Field

Identifies the DependencyProperty for the DivisionDistance Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.DivisionDistanceProperty
C#
public static readonly DependencyProperty DivisionDistanceProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

EditModeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : EditModeProperty Field

Identifies the DependencyProperty for the EditMode Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.EditModeProperty
C#
public static readonly DependencyProperty EditModeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FillListProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FillListProperty Field

Identifies the DependencyProperty for the FillList Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.FillListProperty
C#
public static readonly DependencyProperty FillListProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GridFrequencyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GridFrequencyProperty Field

Identifies the DependencyProperty for the GridFrequency Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.GridFrequencyProperty
C#
public static readonly DependencyProperty GridFrequencyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideImagePositionProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideImagePositionProperty Field

Identifies the DependencyProperty for the GuideImagePosition Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.GuideImagePositionProperty
C#
public static readonly DependencyProperty GuideImagePositionProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineDashPatternProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineDashPatternProperty Field

Identifies the DependencyProperty for the GuideLineDashPattern Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.GuideLineDashPatternProperty
C#
public static readonly DependencyProperty GuideLineDashPatternProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineDistanceProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineDistanceProperty Field

Identifies the DependencyProperty for the GuideLineDistance Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.GuideLineDistanceProperty
C#
public static readonly DependencyProperty GuideLineDistanceProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLinePositionProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLinePositionProperty Field

Identifies the DependencyProperty for the GuideLinePosition Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.GuideLinePositionProperty
C#
public static readonly DependencyProperty GuideLinePositionProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineStrokeProperty Field

Identifies the DependencyProperty for the GuideLineStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.GuideLineStrokeProperty
C#
public static readonly DependencyProperty GuideLineStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineStrokeThicknessProperty Field

Identifies the DependencyProperty for the GuideLineStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.GuideLineStrokeThicknessProperty
C#
public static readonly DependencyProperty GuideLineStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideSelectStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideSelectStrokeProperty Field

Identifies the DependencyProperty for the GuideSelectStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.GuideSelectStrokeProperty
C#
public static readonly DependencyProperty GuideSelectStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HandleListRightClickProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HandleListRightClickProperty Field

Identifies the DependencyProperty for the HandleListRightClick Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HandleListRightClickProperty
C#
public static readonly DependencyProperty HandleListRightClickProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HandleMapAreaRightClickProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HandleMapAreaRightClickProperty Field

Identifies the DependencyProperty for the HandleMapAreaRightClick Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HandleMapAreaRightClickProperty
C#
public static readonly DependencyProperty HandleMapAreaRightClickProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HandleScheduleRightClickProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HandleScheduleRightClickProperty Field

Identifies the DependencyProperty for the HandleScheduleRightClick Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HandleScheduleRightClickProperty
C#
public static readonly DependencyProperty HandleScheduleRightClickProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderAlignProperty Field

Identifies the DependencyProperty for the HeaderAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HeaderAlignProperty
C#
public static readonly DependencyProperty HeaderAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderBackgroundProperty Field

Identifies the DependencyProperty for the HeaderBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HeaderBackgroundProperty
C#
public static readonly DependencyProperty HeaderBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderFontFamilyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderFontFamilyProperty Field

Identifies the DependencyProperty for the HeaderFontFamily Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HeaderFontFamilyProperty
C#
public static readonly DependencyProperty HeaderFontFamilyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderFontSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderFontSizeProperty Field

Identifies the DependencyProperty for the HeaderFontSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HeaderFontSizeProperty
C#
public static readonly DependencyProperty HeaderFontSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderFontStyleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderFontStyleProperty Field

Identifies the DependencyProperty for the HeaderFontStyle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HeaderFontStyleProperty
C#
public static readonly DependencyProperty HeaderFontStyleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderFontWeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderFontWeightProperty Field

Identifies the DependencyProperty for the HeaderFontWeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HeaderFontWeightProperty
C#
public static readonly DependencyProperty HeaderFontWeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderForegroundProperty Field

Identifies the DependencyProperty for the HeaderForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HeaderForegroundProperty
C#
public static readonly DependencyProperty HeaderForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderHeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderHeightProperty Field

Identifies the DependencyProperty for the HeaderHeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HeaderHeightProperty
C#
public static readonly DependencyProperty HeaderHeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HeaderVisibleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HeaderVisibleProperty Field

Identifies the DependencyProperty for the HeaderVisible Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HeaderVisibleProperty
C#
public static readonly DependencyProperty HeaderVisibleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HistorySizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HistorySizeProperty Field

Identifies the DependencyProperty for the HistorySize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.HistorySizeProperty
C#
public static readonly DependencyProperty HistorySizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ImagesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ImagesProperty Field

Identifies the DependencyProperty for the Images Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ImagesProperty
C#
public static readonly DependencyProperty ImagesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ItemHeaderBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ItemHeaderBackgroundProperty Field

Identifies the DependencyProperty for the ItemHeaderBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ItemHeaderBackgroundProperty
C#
public static readonly DependencyProperty ItemHeaderBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ItemHeaderForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ItemHeaderForegroundProperty Field

Identifies the DependencyProperty for the ItemHeaderForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ItemHeaderForegroundProperty
C#
public static readonly DependencyProperty ItemHeaderForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ItemHeightOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ItemHeightOffsetProperty Field

Identifies the DependencyProperty for the ItemHeightOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ItemHeightOffsetProperty
C#
public static readonly DependencyProperty ItemHeightOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ItemsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ItemsProperty Field

Identifies the DependencyProperty for the Items Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ItemsProperty
C#
public static readonly DependencyProperty ItemsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowAfterProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowAfterProperty Field

Identifies the DependencyProperty for the LineArrowAfter Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.LineArrowAfterProperty
C#
public static readonly DependencyProperty LineArrowAfterProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowBackgroundProperty Field

Identifies the DependencyProperty for the LineArrowBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.LineArrowBackgroundProperty
C#
public static readonly DependencyProperty LineArrowBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowBeforeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowBeforeProperty Field

Identifies the DependencyProperty for the LineArrowBefore Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.LineArrowBeforeProperty
C#
public static readonly DependencyProperty LineArrowBeforeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowPositionProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowPositionProperty Field

Identifies the DependencyProperty for the LineArrowPosition Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.LineArrowPositionProperty
C#
public static readonly DependencyProperty LineArrowPositionProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowTypeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowTypeProperty Field

Identifies the DependencyProperty for the LineArrowType Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.LineArrowTypeProperty
C#
public static readonly DependencyProperty LineArrowTypeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LinkLineStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LinkLineStrokeProperty Field

Identifies the DependencyProperty for the LinkLineStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.LinkLineStrokeProperty
C#
public static readonly DependencyProperty LinkLineStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LinksProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LinksProperty Field

Identifies the DependencyProperty for the Links Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.LinksProperty
C#
public static readonly DependencyProperty LinksProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListBackgroundProperty Field

Identifies the DependencyProperty for the ListBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListBackgroundProperty
C#
public static readonly DependencyProperty ListBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListFontFamilyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListFontFamilyProperty Field

Identifies the DependencyProperty for the ListFontFamily Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListFontFamilyProperty
C#
public static readonly DependencyProperty ListFontFamilyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListFontSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListFontSizeProperty Field

Identifies the DependencyProperty for the ListFontSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListFontSizeProperty
C#
public static readonly DependencyProperty ListFontSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListFontStyleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListFontStyleProperty Field

Identifies the DependencyProperty for the ListFontStyle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListFontStyleProperty
C#
public static readonly DependencyProperty ListFontStyleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListFontWeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListFontWeightProperty Field

Identifies the DependencyProperty for the ListFontWeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListFontWeightProperty
C#
public static readonly DependencyProperty ListFontWeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListForegroundProperty Field

Identifies the DependencyProperty for the ListForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListForegroundProperty
C#
public static readonly DependencyProperty ListForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideBackgroundProperty Field

Identifies the DependencyProperty for the ListGuideBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListGuideBackgroundProperty
C#
public static readonly DependencyProperty ListGuideBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideDistanceProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideDistanceProperty Field

Identifies the DependencyProperty for the ListGuideDistance Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListGuideDistanceProperty
C#
public static readonly DependencyProperty ListGuideDistanceProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideFadeDurationProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideFadeDurationProperty Field

Identifies the DependencyProperty for the ListGuideFadeDuration Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListGuideFadeDurationProperty
C#
public static readonly DependencyProperty ListGuideFadeDurationProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideForegroundProperty Field

Identifies the DependencyProperty for the ListGuideForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListGuideForegroundProperty
C#
public static readonly DependencyProperty ListGuideForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListGuideWidthProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListGuideWidthProperty Field

Identifies the DependencyProperty for the ListGuideWidth Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListGuideWidthProperty
C#
public static readonly DependencyProperty ListGuideWidthProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListHorzStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListHorzStrokeProperty Field

Identifies the DependencyProperty for the ListHorzStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListHorzStrokeProperty
C#
public static readonly DependencyProperty ListHorzStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListHorzStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListHorzStrokeThicknessProperty Field

Identifies the DependencyProperty for the ListHorzStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListHorzStrokeThicknessProperty
C#
public static readonly DependencyProperty ListHorzStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListImageAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListImageAlignProperty Field

Identifies the DependencyProperty for the ListImageAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListImageAlignProperty
C#
public static readonly DependencyProperty ListImageAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListTextAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListTextAlignProperty Field

Identifies the DependencyProperty for the ListTextAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListTextAlignProperty
C#
public static readonly DependencyProperty ListTextAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListTitleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListTitleProperty Field

Identifies the DependencyProperty for the ListTitle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListTitleProperty
C#
public static readonly DependencyProperty ListTitleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListTypeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListTypeProperty Field

Identifies the DependencyProperty for the ListType Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListTypeProperty
C#
public static readonly DependencyProperty ListTypeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListVertStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListVertStrokeProperty Field

Identifies the DependencyProperty for the ListVertStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListVertStrokeProperty
C#
public static readonly DependencyProperty ListVertStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListVertStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListVertStrokeThicknessProperty Field

Identifies the DependencyProperty for the ListVertStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ListVertStrokeThicknessProperty
C#
public static readonly DependencyProperty ListVertStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapAreaProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapAreaProperty Field

Identifies the DependencyProperty for the MapArea Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.MapAreaProperty
C#
public static readonly DependencyProperty MapAreaProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapBackgroundProperty Field

Identifies the DependencyProperty for the MapBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.MapBackgroundProperty
C#
public static readonly DependencyProperty MapBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapHeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapHeightProperty Field

Identifies the DependencyProperty for the MapHeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.MapHeightProperty
C#
public static readonly DependencyProperty MapHeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapLineProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapLineProperty Field

Identifies the DependencyProperty for the MapLine Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.MapLineProperty
C#
public static readonly DependencyProperty MapLineProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapLineThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapLineThicknessProperty Field

Identifies the DependencyProperty for the MapLineThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.MapLineThicknessProperty
C#
public static readonly DependencyProperty MapLineThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapStrokeProperty Field

Identifies the DependencyProperty for the MapStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.MapStrokeProperty
C#
public static readonly DependencyProperty MapStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MapStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MapStrokeThicknessProperty Field

Identifies the DependencyProperty for the MapStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.MapStrokeThicknessProperty
C#
public static readonly DependencyProperty MapStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MinBarTimeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MinBarTimeProperty Field

Identifies the DependencyProperty for the MinBarTime Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.MinBarTimeProperty
C#
public static readonly DependencyProperty MinBarTimeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MonthNamesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MonthNamesProperty Field

Identifies the DependencyProperty for the MonthNames Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.MonthNamesProperty
C#
public static readonly DependencyProperty MonthNamesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

NotesDistanceProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : NotesDistanceProperty Field

Identifies the DependencyProperty for the NotesDistance Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.NotesDistanceProperty
C#
public static readonly DependencyProperty NotesDistanceProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

NotesPositionProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : NotesPositionProperty Field

Identifies the DependencyProperty for the NotesPosition Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.NotesPositionProperty
C#
public static readonly DependencyProperty NotesPositionProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

OverlapSpanProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : OverlapSpanProperty Field

Identifies the DependencyProperty for the OverlapSpan Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.OverlapSpanProperty
C#
public static readonly DependencyProperty OverlapSpanProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

OverlapStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : OverlapStrokeProperty Field

Identifies the DependencyProperty for the OverlapStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.OverlapStrokeProperty
C#
public static readonly DependencyProperty OverlapStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

OverlapStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : OverlapStrokeThicknessProperty Field

Identifies the DependencyProperty for the OverlapStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.OverlapStrokeThicknessProperty
C#
public static readonly DependencyProperty OverlapStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PercentBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PercentBackgroundProperty Field

Identifies the DependencyProperty for the PercentBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PercentBackgroundProperty
C#
public static readonly DependencyProperty PercentBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFontFamilyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFontFamilyProperty Field

Identifies the DependencyProperty for the PrintFontFamily Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintFontFamilyProperty
C#
public static readonly DependencyProperty PrintFontFamilyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFontSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFontSizeProperty Field

Identifies the DependencyProperty for the PrintFontSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintFontSizeProperty
C#
public static readonly DependencyProperty PrintFontSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFontStyleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFontStyleProperty Field

Identifies the DependencyProperty for the PrintFontStyle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintFontStyleProperty
C#
public static readonly DependencyProperty PrintFontStyleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFontWeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFontWeightProperty Field

Identifies the DependencyProperty for the PrintFontWeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintFontWeightProperty
C#
public static readonly DependencyProperty PrintFontWeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFooterAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFooterAlignProperty Field

Identifies the DependencyProperty for the PrintFooterAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintFooterAlignProperty
C#
public static readonly DependencyProperty PrintFooterAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintFooterMarginProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintFooterMarginProperty Field

Identifies the DependencyProperty for the PrintFooterMargin Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintFooterMarginProperty
C#
public static readonly DependencyProperty PrintFooterMarginProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintListAlwaysProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintListAlwaysProperty Field

Identifies the DependencyProperty for the PrintListAlways Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintListAlwaysProperty
C#
public static readonly DependencyProperty PrintListAlwaysProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintListWidthProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintListWidthProperty Field

Identifies the DependencyProperty for the PrintListWidth Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintListWidthProperty
C#
public static readonly DependencyProperty PrintListWidthProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintMarginProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintMarginProperty Field

Identifies the DependencyProperty for the PrintMargin Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintMarginProperty
C#
public static readonly DependencyProperty PrintMarginProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintPageTextProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintPageTextProperty Field

Identifies the DependencyProperty for the PrintPageText Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintPageTextProperty
C#
public static readonly DependencyProperty PrintPageTextProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintSubTitleMarginProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintSubTitleMarginProperty Field

Identifies the DependencyProperty for the PrintSubTitleMargin Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintSubTitleMarginProperty
C#
public static readonly DependencyProperty PrintSubTitleMarginProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintSubTitleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintSubTitleProperty Field

Identifies the DependencyProperty for the PrintSubTitle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintSubTitleProperty
C#
public static readonly DependencyProperty PrintSubTitleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTimeDistanceProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTimeDistanceProperty Field

Identifies the DependencyProperty for the PrintTimeDistance Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintTimeDistanceProperty
C#
public static readonly DependencyProperty PrintTimeDistanceProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleAlignProperty Field

Identifies the DependencyProperty for the PrintTitleAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintTitleAlignProperty
C#
public static readonly DependencyProperty PrintTitleAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleFontFamilyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleFontFamilyProperty Field

Identifies the DependencyProperty for the PrintTitleFontFamily Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintTitleFontFamilyProperty
C#
public static readonly DependencyProperty PrintTitleFontFamilyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleFontSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleFontSizeProperty Field

Identifies the DependencyProperty for the PrintTitleFontSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintTitleFontSizeProperty
C#
public static readonly DependencyProperty PrintTitleFontSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleFontStyleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleFontStyleProperty Field

Identifies the DependencyProperty for the PrintTitleFontStyle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintTitleFontStyleProperty
C#
public static readonly DependencyProperty PrintTitleFontStyleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleFontWeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleFontWeightProperty Field

Identifies the DependencyProperty for the PrintTitleFontWeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintTitleFontWeightProperty
C#
public static readonly DependencyProperty PrintTitleFontWeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleMarginProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleMarginProperty Field

Identifies the DependencyProperty for the PrintTitleMargin Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintTitleMarginProperty
C#
public static readonly DependencyProperty PrintTitleMarginProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintTitleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintTitleProperty Field

Identifies the DependencyProperty for the PrintTitle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.PrintTitleProperty
C#
public static readonly DependencyProperty PrintTitleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerBackgroundProperty Field

Identifies the DependencyProperty for the RulerBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.RulerBackgroundProperty
C#
public static readonly DependencyProperty RulerBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerFontFamilyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerFontFamilyProperty Field

Identifies the DependencyProperty for the RulerFontFamily Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.RulerFontFamilyProperty
C#
public static readonly DependencyProperty RulerFontFamilyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerFontSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerFontSizeProperty Field

Identifies the DependencyProperty for the RulerFontSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.RulerFontSizeProperty
C#
public static readonly DependencyProperty RulerFontSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerFontStyleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerFontStyleProperty Field

Identifies the DependencyProperty for the RulerFontStyle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.RulerFontStyleProperty
C#
public static readonly DependencyProperty RulerFontStyleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerFontWeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerFontWeightProperty Field

Identifies the DependencyProperty for the RulerFontWeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.RulerFontWeightProperty
C#
public static readonly DependencyProperty RulerFontWeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerForegroundProperty Field

Identifies the DependencyProperty for the RulerForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.RulerForegroundProperty
C#
public static readonly DependencyProperty RulerForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerLineStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerLineStrokeProperty Field

Identifies the DependencyProperty for the RulerLineStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.RulerLineStrokeProperty
C#
public static readonly DependencyProperty RulerLineStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerSelectBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerSelectBackgroundProperty Field

Identifies the DependencyProperty for the RulerSelectBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.RulerSelectBackgroundProperty
C#
public static readonly DependencyProperty RulerSelectBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RulerSelectOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RulerSelectOffsetProperty Field

Identifies the DependencyProperty for the RulerSelectOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.RulerSelectOffsetProperty
C#
public static readonly DependencyProperty RulerSelectOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleBackgroundProperty Field

Identifies the DependencyProperty for the ScheduleBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ScheduleBackgroundProperty
C#
public static readonly DependencyProperty ScheduleBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleHeaderBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleHeaderBackgroundProperty Field

Identifies the DependencyProperty for the ScheduleHeaderBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ScheduleHeaderBackgroundProperty
C#
public static readonly DependencyProperty ScheduleHeaderBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleHeaderPositionProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleHeaderPositionProperty Field

Identifies the DependencyProperty for the ScheduleHeaderPosition Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ScheduleHeaderPositionProperty
C#
public static readonly DependencyProperty ScheduleHeaderPositionProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleHorzStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleHorzStrokeProperty Field

Identifies the DependencyProperty for the ScheduleHorzStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ScheduleHorzStrokeProperty
C#
public static readonly DependencyProperty ScheduleHorzStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleHorzStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleHorzStrokeThicknessProperty Field

Identifies the DependencyProperty for the ScheduleHorzStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ScheduleHorzStrokeThicknessProperty
C#
public static readonly DependencyProperty ScheduleHorzStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SchedulesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SchedulesProperty Field

Identifies the DependencyProperty for the Schedules Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SchedulesProperty
C#
public static readonly DependencyProperty SchedulesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedBackgroundProperty Field

Identifies the DependencyProperty for the SelectedBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SelectedBackgroundProperty
C#
public static readonly DependencyProperty SelectedBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedForegroundProperty Field

Identifies the DependencyProperty for the SelectedForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SelectedForegroundProperty
C#
public static readonly DependencyProperty SelectedForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedRadiusProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedRadiusProperty Field

Identifies the DependencyProperty for the SelectedRadius Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SelectedRadiusProperty
C#
public static readonly DependencyProperty SelectedRadiusProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedStrokeProperty Field

Identifies the DependencyProperty for the SelectedStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SelectedStrokeProperty
C#
public static readonly DependencyProperty SelectedStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectedStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectedStrokeThicknessProperty Field

Identifies the DependencyProperty for the SelectedStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SelectedStrokeThicknessProperty
C#
public static readonly DependencyProperty SelectedStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectModeDashPatternProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectModeDashPatternProperty Field

Identifies the DependencyProperty for the SelectModeDashPattern Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SelectModeDashPatternProperty
C#
public static readonly DependencyProperty SelectModeDashPatternProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectModeStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectModeStrokeProperty Field

Identifies the DependencyProperty for the SelectModeStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SelectModeStrokeProperty
C#
public static readonly DependencyProperty SelectModeStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SelectModeStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SelectModeStrokeThicknessProperty Field

Identifies the DependencyProperty for the SelectModeStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SelectModeStrokeThicknessProperty
C#
public static readonly DependencyProperty SelectModeStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SnapToDivisionsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SnapToDivisionsProperty Field

Identifies the DependencyProperty for the SnapToDivisions Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SnapToDivisionsProperty
C#
public static readonly DependencyProperty SnapToDivisionsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SnapToGridProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SnapToGridProperty Field

Identifies the DependencyProperty for the SnapToGrid Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SnapToGridProperty
C#
public static readonly DependencyProperty SnapToGridProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SnapToGuideProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SnapToGuideProperty Field

Identifies the DependencyProperty for the SnapToGuide Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SnapToGuideProperty
C#
public static readonly DependencyProperty SnapToGuideProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowAscendProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowAscendProperty Field

Identifies the DependencyProperty for the SortArrowAscend Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SortArrowAscendProperty
C#
public static readonly DependencyProperty SortArrowAscendProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowBackgroundProperty Field

Identifies the DependencyProperty for the SortArrowBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SortArrowBackgroundProperty
C#
public static readonly DependencyProperty SortArrowBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowDescendProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowDescendProperty Field

Identifies the DependencyProperty for the SortArrowDescend Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SortArrowDescendProperty
C#
public static readonly DependencyProperty SortArrowDescendProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowHorzAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowHorzAlignProperty Field

Identifies the DependencyProperty for the SortArrowHorzAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SortArrowHorzAlignProperty
C#
public static readonly DependencyProperty SortArrowHorzAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowOffsetProperty Field

Identifies the DependencyProperty for the SortArrowOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SortArrowOffsetProperty
C#
public static readonly DependencyProperty SortArrowOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowSizeProperty Field

Identifies the DependencyProperty for the SortArrowSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SortArrowSizeProperty
C#
public static readonly DependencyProperty SortArrowSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortArrowVertAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortArrowVertAlignProperty Field

Identifies the DependencyProperty for the SortArrowVertAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SortArrowVertAlignProperty
C#
public static readonly DependencyProperty SortArrowVertAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortOnCaseProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortOnCaseProperty Field

Identifies the DependencyProperty for the SortOnCase Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SortOnCaseProperty
C#
public static readonly DependencyProperty SortOnCaseProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SplitterBarBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SplitterBarBackgroundProperty Field

Identifies the DependencyProperty for the SplitterBarBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.SplitterBarBackgroundProperty
C#
public static readonly DependencyProperty SplitterBarBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TextIntoViewProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TextIntoViewProperty Field

Identifies the DependencyProperty for the TextIntoView Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TextIntoViewProperty
C#
public static readonly DependencyProperty TextIntoViewProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarBackgroundProperty Field

Identifies the DependencyProperty for the TimeBarBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarBackgroundProperty
C#
public static readonly DependencyProperty TimeBarBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarExtensionProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarExtensionProperty Field

Identifies the DependencyProperty for the TimeBarExtension Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarExtensionProperty
C#
public static readonly DependencyProperty TimeBarExtensionProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarFontFamilyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarFontFamilyProperty Field

Identifies the DependencyProperty for the TimeBarFontFamily Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarFontFamilyProperty
C#
public static readonly DependencyProperty TimeBarFontFamilyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarFontSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarFontSizeProperty Field

Identifies the DependencyProperty for the TimeBarFontSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarFontSizeProperty
C#
public static readonly DependencyProperty TimeBarFontSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarFontStyleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarFontStyleProperty Field

Identifies the DependencyProperty for the TimeBarFontStyle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarFontStyleProperty
C#
public static readonly DependencyProperty TimeBarFontStyleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarFontWeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarFontWeightProperty Field

Identifies the DependencyProperty for the TimeBarFontWeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarFontWeightProperty
C#
public static readonly DependencyProperty TimeBarFontWeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarForegroundProperty Field

Identifies the DependencyProperty for the TimeBarForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarForegroundProperty
C#
public static readonly DependencyProperty TimeBarForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarMarginProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarMarginProperty Field

Identifies the DependencyProperty for the TimeBarMargin Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarMarginProperty
C#
public static readonly DependencyProperty TimeBarMarginProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarMinWidthProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarMinWidthProperty Field

Identifies the DependencyProperty for the TimeBarMinWidth Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarMinWidthProperty
C#
public static readonly DependencyProperty TimeBarMinWidthProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarRadiusProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarRadiusProperty Field

Identifies the DependencyProperty for the TimeBarRadius Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarRadiusProperty
C#
public static readonly DependencyProperty TimeBarRadiusProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarShadowColorProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarShadowColorProperty Field

Identifies the DependencyProperty for the TimeBarShadowColor Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarShadowColorProperty
C#
public static readonly DependencyProperty TimeBarShadowColorProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarShadowOpacityProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarShadowOpacityProperty Field

Identifies the DependencyProperty for the TimeBarShadowOpacity Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarShadowOpacityProperty
C#
public static readonly DependencyProperty TimeBarShadowOpacityProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarShadowsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarShadowsProperty Field

Identifies the DependencyProperty for the TimeBarShadows Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarShadowsProperty
C#
public static readonly DependencyProperty TimeBarShadowsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarStrokeProperty Field

Identifies the DependencyProperty for the TimeBarStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarStrokeProperty
C#
public static readonly DependencyProperty TimeBarStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarStrokeThicknessProperty Field

Identifies the DependencyProperty for the TimeBarStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarStrokeThicknessProperty
C#
public static readonly DependencyProperty TimeBarStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarTextWrapProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarTextWrapProperty Field

Identifies the DependencyProperty for the TimeBarTextWrap Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeBarTextWrapProperty
C#
public static readonly DependencyProperty TimeBarTextWrapProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeDistanceProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeDistanceProperty Field

Identifies the DependencyProperty for the TimeDistance Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TimeDistanceProperty
C#
public static readonly DependencyProperty TimeDistanceProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsBackgroundProperty Field

Identifies the DependencyProperty for the TipsBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsBackgroundProperty
C#
public static readonly DependencyProperty TipsBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsFontFamilyProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsFontFamilyProperty Field

Identifies the DependencyProperty for the TipsFontFamily Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsFontFamilyProperty
C#
public static readonly DependencyProperty TipsFontFamilyProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsFontSizeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsFontSizeProperty Field

Identifies the DependencyProperty for the TipsFontSize Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsFontSizeProperty
C#
public static readonly DependencyProperty TipsFontSizeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsFontStyleProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsFontStyleProperty Field

Identifies the DependencyProperty for the TipsFontStyle Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsFontStyleProperty
C#
public static readonly DependencyProperty TipsFontStyleProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsFontWeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsFontWeightProperty Field

Identifies the DependencyProperty for the TipsFontWeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsFontWeightProperty
C#
public static readonly DependencyProperty TipsFontWeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsForegroundProperty Field

Identifies the DependencyProperty for the TipsForeground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsForegroundProperty
C#
public static readonly DependencyProperty TipsForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnChangeBarProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnChangeBarProperty Field

Identifies the DependencyProperty for the TipsOnChangeBar Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsOnChangeBarProperty
C#
public static readonly DependencyProperty TipsOnChangeBarProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnCreateBarProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnCreateBarProperty Field

Identifies the DependencyProperty for the TipsOnCreateBar Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsOnCreateBarProperty
C#
public static readonly DependencyProperty TipsOnCreateBarProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnGuideLinesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnGuideLinesProperty Field

Identifies the DependencyProperty for the TipsOnGuideLines Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsOnGuideLinesProperty
C#
public static readonly DependencyProperty TipsOnGuideLinesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnNotesProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnNotesProperty Field

Identifies the DependencyProperty for the TipsOnNotes Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsOnNotesProperty
C#
public static readonly DependencyProperty TipsOnNotesProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsOnOverBarProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsOnOverBarProperty Field

Identifies the DependencyProperty for the TipsOnOverBar Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsOnOverBarProperty
C#
public static readonly DependencyProperty TipsOnOverBarProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsShadowColorProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsShadowColorProperty Field

Identifies the DependencyProperty for the TipsShadowColor Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsShadowColorProperty
C#
public static readonly DependencyProperty TipsShadowColorProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsShadowOpacityProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsShadowOpacityProperty Field

Identifies the DependencyProperty for the TipsShadowOpacity Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsShadowOpacityProperty
C#
public static readonly DependencyProperty TipsShadowOpacityProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsShadowsProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsShadowsProperty Field

Identifies the DependencyProperty for the TipsShadows Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsShadowsProperty
C#
public static readonly DependencyProperty TipsShadowsProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsStrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsStrokeProperty Field

Identifies the DependencyProperty for the TipsStroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsStrokeProperty
C#
public static readonly DependencyProperty TipsStrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TipsStrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TipsStrokeThicknessProperty Field

Identifies the DependencyProperty for the TipsStrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TipsStrokeThicknessProperty
C#
public static readonly DependencyProperty TipsStrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarBackgroundProperty Field

Identifies the DependencyProperty for the ToolbarBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ToolbarBackgroundProperty
C#
public static readonly DependencyProperty ToolbarBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarOnRightClickProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarOnRightClickProperty Field

Identifies the DependencyProperty for the ToolbarOnRightClick Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ToolbarOnRightClickProperty
C#
public static readonly DependencyProperty ToolbarOnRightClickProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarShadowColorProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarShadowColorProperty Field

Identifies the DependencyProperty for the ToolbarShadowColor Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ToolbarShadowColorProperty
C#
public static readonly DependencyProperty ToolbarShadowColorProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarShadowOpacityProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarShadowOpacityProperty Field

Identifies the DependencyProperty for the ToolbarShadowOpacity Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ToolbarShadowOpacityProperty
C#
public static readonly DependencyProperty ToolbarShadowOpacityProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolbarShadowProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolbarShadowProperty Field

Identifies the DependencyProperty for the ToolbarShadow Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.ToolbarShadowProperty
C#
public static readonly DependencyProperty ToolbarShadowProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TreeCloseProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TreeCloseProperty Field

Identifies the DependencyProperty for the TreeClose Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TreeCloseProperty
C#
public static readonly DependencyProperty TreeCloseProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TreeLevelIndentProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TreeLevelIndentProperty Field

Identifies the DependencyProperty for the TreeLevelIndent Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TreeLevelIndentProperty
C#
public static readonly DependencyProperty TreeLevelIndentProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TreeOpenProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TreeOpenProperty Field

Identifies the DependencyProperty for the TreeOpen Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.TreeOpenProperty
C#
public static readonly DependencyProperty TreeOpenProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

WeekendBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : WeekendBackgroundProperty Field

Identifies the DependencyProperty for the WeekendBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.WeekendBackgroundProperty
C#
public static readonly DependencyProperty WeekendBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

WeekendDaysProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : WeekendDaysProperty Field

Identifies the DependencyProperty for the WeekendDays Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiScheduleWPF.WeekendDaysProperty
C#
public static readonly DependencyProperty WeekendDaysProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%% $$Events$$

dbiScheduleWPF Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF Class

"

For a list of all members of this type, see dbiScheduleWPF members.

"

Public Events

 | Name | Description
public Event | AfterGuideLineInserted | Event fired after a new GuideLine is inserted with the mouse.
public Event | AfterGuideLineMoved | Event fired after a GuideLine is moved with the mouse.
public Event | AfterGuideLineRemoved | Event fired after a GuideLine is removed with the mouse.
public Event | AfterPrint | Event fired after the print operation has completed.
public Event | AfterTimeBarInserted | Occurs after a Timebar is inserted.
public Event | AfterTimeBarLinked | Occurs after 2 Timebars have been linked together.
public Event | AfterTimeBarMoved | Occurs after a Timebar has been moved.
public Event | AfterTimeBarRemoved | Occurs after a Timebar is removed.
public Event | AfterTimeBarSized | Occurs after a Timebar has been sized.
public Event | AfterTimeBarSplit | Occurs after a time bar has been split.
public Event | AfterTimeBarUnlinked | Occurs after the link between two Timebars has been removed.
public Event | BeforeGuideLineInsert | Event fired before a new GuideLine is inserted with the mouse.
public Event | BeforeGuideLineMove | Event fired before a GuideLine is moved with the mouse.
public Event | BeforeGuideLineRemove | Event fired before a GuideLine is removed with the mouse.
public Event | BeforePrint | Event fired before the print operation has started.
public Event | BeforeTimeBarInsert | Occurs before a Timebar is inserted.
public Event | BeforeTimeBarLink | Occurs before 2 times bars are linked together.
public Event | BeforeTimeBarMove | Occurs before a Timebar is moved.
public Event | BeforeTimeBarRemove | Occurs before a Timebar is removed.
public Event | BeforeTimeBarSelect | Occurs before a Timebar is selected.
public Event | BeforeTimeBarSize | Occurs before a Timebar is sized.
public Event | BeforeTimeBarSplit | Occurs before a time bar is split.
public Event | BeforeTimeBarUnlink | Occurs before the link between two Timebars has been removed.
public Event | BeforeToolTips | Occurs before a tool tip is displayed.
public Event | ColumnHeaderClick | Event fired when the header of a column is clicked.
public Event | ControlError | Occurs when an error takes place in the control.
public Event | DeadZoneDrop | Event fired when a time bar is moved onto a dead zone area with the mouse.
public Event | EditModeChanged | Event fired when the EditMode is changed on the control.
public Event | FirstDraw | Occurs after the control has been drawn for the first time.
public Event | GuideLineClick | Event fired when a GuideLine is clicked.
public Event | GuideLineMove | Event fired when a GuideLine is moved.
public Event | HistoryChange | Occurs when an item in the RedoHistory or UndoHistory collections change.
public Event | ItemMouseOver | Occurs when the mouse moves over a new object ni the schedule area
public Event | LineArrowClick | Event fired when a line arrow is clicked.
public Event | LineArrowMouseOver | Event fired when the mouse moves over a line arrow.
public Event | ListItemClick | Occurs when a list item is clicked.
public Event | NoteClick | Event fired when a schedule note is clicked.
public Event | PrintProgress | Occurs just before each page, of the printed report, is printed.
public Event | RedoAction | Occurs after a redo action has taken place.
public Event | ScheduleClick | Occurs when the schedule area is clicked by the mouse.
public Event | ScheduleMouseMove | Occurs when the mouse moves over the schedule area.
public Event | TimeBarClick | Occurs when a Timebar is clicked on.
public Event | TimeBarSizing | Occurs as the size of the Timebar is being changed by the mouse.
public Event | UndoAction | Occurs after an undo action has taken place.
public Event | UserDrawnBarAfter | This event fires after the timebar image has been created. This allows the developer to work with the graphics of an already drawn timebar.
public Event | UserDrawnBarBefore | Event fired at the point a time bar is drawn to provide custom painting of the time bar area. NOTE: Any time bar can be “User Drawn” and an item can contain any combination of user drawn and control drawn time bars.
public Event | UserDrawnLineAfter | Event fired after all objects have been rendered inside the item. Allowing for custom appearance in front of all other objects.
public Event | UserDrawnLineBefore | Event fired before the list item is rendered, allowing for custom appearance and background.
public Event | ValuePoint | Occurs before each time value is drawn in the ruler.
Top

See Also

Reference

dbiScheduleWPF Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

AfterGuideLineInserted Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterGuideLineInserted Event

Event fired after a new GuideLine is inserted with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterGuideLineInsertedHandler

AddHandler instance.AfterGuideLineInserted, handler
C#
public event dbiScheduleWPF.AfterGuideLineInsertedHandler AfterGuideLineInserted

Event Data

The event handler receives an argument of type AfterGuideLineInsertedEventArgs containing data related to this event. The following AfterGuideLineInsertedEventArgs properties provide information specific to this event.

Property | Description
GuideLine | The dbiGuideLine that was inserted.
LineIndex | The zero-based index of the dbiGuideLine in the dbiGuideLineCollection.
LineTime | The date/time value for the dbiGuideLine

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterGuideLineMoved Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterGuideLineMoved Event

Event fired after a GuideLine is moved with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterGuideLineMovedHandler

AddHandler instance.AfterGuideLineMoved, handler
C#
public event dbiScheduleWPF.AfterGuideLineMovedHandler AfterGuideLineMoved

Event Data

The event handler receives an argument of type AfterGuideLineMovedEventArgs containing data related to this event. The following AfterGuideLineMovedEventArgs properties provide information specific to this event.

Property | Description
GuideLine | The dbiGuideLine that was moved.
LineIndex | The zero-based index of the dbiGuideLine in the dbiGuideLineCollection.
LineTime | The date/time value for the dbiGuideLine.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterGuideLineRemoved Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterGuideLineRemoved Event

Event fired after a GuideLine is removed with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterGuideLineRemovedHandler

AddHandler instance.AfterGuideLineRemoved, handler
C#
public event dbiScheduleWPF.AfterGuideLineRemovedHandler AfterGuideLineRemoved

Event Data

The event handler receives an argument of type AfterGuideLineRemovedEventArgs containing data related to this event. The following AfterGuideLineRemovedEventArgs properties provide information specific to this event.

Property | Description
GuideLine | The dbiGuideLine that was removed.
LineIndex | The zero-based index of the dbiGuideLine in the dbiGuideLineCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterPrint Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterPrint Event

Event fired after the print operation has completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterPrintHandler

AddHandler instance.AfterPrint, handler
C#
public event dbiScheduleWPF.AfterPrintHandler AfterPrint

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterTimeBarInserted Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterTimeBarInserted Event

Occurs after a Timebar is inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterTimeBarInsertedHandler

AddHandler instance.AfterTimeBarInserted, handler
C#
public event dbiScheduleWPF.AfterTimeBarInsertedHandler AfterTimeBarInserted

Event Data

The event handler receives an argument of type AfterTimeBarInsertedEventArgs containing data related to this event. The following AfterTimeBarInsertedEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the inserted Timebar.
ListItem | The dbiListItem containing the TimeBar after it was inserted.
TimeBarItem | The dbiTimeBarItem after it has been inserted.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterTimeBarLinked Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterTimeBarLinked Event

Occurs after 2 Timebars have been linked together.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterTimeBarLinkedHandler

AddHandler instance.AfterTimeBarLinked, handler
C#
public event dbiScheduleWPF.AfterTimeBarLinkedHandler AfterTimeBarLinked

Event Data

The event handler receives an argument of type AfterTimeBarLinkedEventArgs containing data related to this event. The following AfterTimeBarLinkedEventArgs properties provide information specific to this event.

Property | Description
Link | The dbiLinkItem that was created.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterTimeBarMoved Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterTimeBarMoved Event

Occurs after a Timebar has been moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterTimeBarMovedHandler

AddHandler instance.AfterTimeBarMoved, handler
C#
public event dbiScheduleWPF.AfterTimeBarMovedHandler AfterTimeBarMoved

Event Data

The event handler receives an argument of type AfterTimeBarMovedEventArgs containing data related to this event. The following AfterTimeBarMovedEventArgs properties provide information specific to this event.

Property | Description
ListItemFrom | The dbiListItem containing the timebar before it was moved.
ListItemTo | The dbiListItem containing the timebar after it has been moved.
TimeBarItem | The timebar that was moved.
Vertical | Determines if the timebar moved vertically.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterTimeBarRemoved Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterTimeBarRemoved Event

Occurs after a Timebar is removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterTimeBarRemovedHandler

AddHandler instance.AfterTimeBarRemoved, handler
C#
public event dbiScheduleWPF.AfterTimeBarRemovedHandler AfterTimeBarRemoved

Event Data

The event handler receives an argument of type AfterTimeBarRemovedEventArgs containing data related to this event. The following AfterTimeBarRemovedEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar that was removed.
ListItem | The dbiListItem containing the timebar before it was removed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterTimeBarSized Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterTimeBarSized Event

Occurs after a Timebar has been sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterTimeBarSizedHandler

AddHandler instance.AfterTimeBarSized, handler
C#
public event dbiScheduleWPF.AfterTimeBarSizedHandler AfterTimeBarSized

Event Data

The event handler receives an argument of type AfterTimeBarSizedEventArgs containing data related to this event. The following AfterTimeBarSizedEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar that was resized.
ListItem | The dbiListItem that contains the resized timebar.
TimeBarItem | The timebar that was resized.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterTimeBarSplit Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterTimeBarSplit Event

Occurs after a time bar has been split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterTimeBarSplitHandler

AddHandler instance.AfterTimeBarSplit, handler
C#
public event dbiScheduleWPF.AfterTimeBarSplitHandler AfterTimeBarSplit

Event Data

The event handler receives an argument of type AfterTimeBarSplitEventArgs containing data related to this event. The following AfterTimeBarSplitEventArgs properties provide information specific to this event.

Property | Description
ListItem | The dbiListItem that contains the newly split timebars
TimeBarNew | The newly created timebar
TimeBarOld | The original exisiting timebar

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AfterTimeBarUnlinked Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AfterTimeBarUnlinked Event

Occurs after the link between two Timebars has been removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.AfterTimeBarUnlinkedHandler

AddHandler instance.AfterTimeBarUnlinked, handler
C#
public event dbiScheduleWPF.AfterTimeBarUnlinkedHandler AfterTimeBarUnlinked

Event Data

The event handler receives an argument of type AfterTimeBarUnlinkedEventArgs containing data related to this event. The following AfterTimeBarUnlinkedEventArgs properties provide information specific to this event.

Property | Description
Link | The dbiLinkItem that was removed from two timebars.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeGuideLineInsert Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeGuideLineInsert Event

Event fired before a new GuideLine is inserted with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeGuideLineInsertHandler

AddHandler instance.BeforeGuideLineInsert, handler
C#
public event dbiScheduleWPF.BeforeGuideLineInsertHandler BeforeGuideLineInsert

Event Data

The event handler receives an argument of type BeforeGuideLineInsertEventArgs containing data related to this event. The following BeforeGuideLineInsertEventArgs properties provide information specific to this event.

Property | Description
AllowInsert | Determines if the GuideLine can be inserted.
GuideLine | The dbiGuideLine that is being inserted
LineTime | The DateTime value for the new dbiGuideLine.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeGuideLineMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeGuideLineMove Event

Event fired before a GuideLine is moved with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeGuideLineMoveHandler

AddHandler instance.BeforeGuideLineMove, handler
C#
public event dbiScheduleWPF.BeforeGuideLineMoveHandler BeforeGuideLineMove

Event Data

The event handler receives an argument of type BeforeGuideLineMoveEventArgs containing data related to this event. The following BeforeGuideLineMoveEventArgs properties provide information specific to this event.

Property | Description
AllowMove | Determines if the GuideLine can be moved.
GuideLine | The GuideLine that is being moved.
InDeadZone | Indicates if the move puts the GuideLine in conflict with a deadzone.
LineIndex | The zero-based index of the GuideLine being moved.
LineTime | The DateTime value the GuideLine is moving to.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeGuideLineRemove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeGuideLineRemove Event

Event fired before a GuideLine is removed with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeGuideLineRemoveHandler

AddHandler instance.BeforeGuideLineRemove, handler
C#
public event dbiScheduleWPF.BeforeGuideLineRemoveHandler BeforeGuideLineRemove

Event Data

The event handler receives an argument of type BeforeGuideLineRemoveEventArgs containing data related to this event. The following BeforeGuideLineRemoveEventArgs properties provide information specific to this event.

Property | Description
AllowRemoval | Determines if the GuideLine can be removed.
GuideLine | The GuideLine to remove
LineIndex | The zero-based index of the GuideLine to be removed.
LineTime | The original time of the guideline before removal.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforePrint Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforePrint Event

Event fired before the print operation has started.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforePrintHandler

AddHandler instance.BeforePrint, handler
C#
public event dbiScheduleWPF.BeforePrintHandler BeforePrint

Event Data

The event handler receives an argument of type BeforePrintEventArgs containing data related to this event. The following BeforePrintEventArgs properties provide information specific to this event.

Property | Description
Pages | The number of pages that will be printed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeTimeBarInsert Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeTimeBarInsert Event

Occurs before a Timebar is inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeTimeBarInsertHandler

AddHandler instance.BeforeTimeBarInsert, handler
C#
public event dbiScheduleWPF.BeforeTimeBarInsertHandler BeforeTimeBarInsert

Event Data

The event handler receives an argument of type BeforeTimeBarInsertEventArgs containing data related to this event. The following BeforeTimeBarInsertEventArgs properties provide information specific to this event.

Property | Description
AllowInsert | Determines if the timebar can be inserted
ListItem | The dbiListItem the timebar is being inserted to.
TimeBarItem | The timebar being inserted.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeTimeBarLink Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeTimeBarLink Event

Occurs before 2 times bars are linked together.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeTimeBarLinkHandler

AddHandler instance.BeforeTimeBarLink, handler
C#
public event dbiScheduleWPF.BeforeTimeBarLinkHandler BeforeTimeBarLink

Event Data

The event handler receives an argument of type BeforeTimeBarLinkEventArgs containing data related to this event. The following BeforeTimeBarLinkEventArgs properties provide information specific to this event.

Property | Description
AllowLink | Determines if the timebars can be linked
Link | The dbiLinkItem that will link the two timebars.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeTimeBarMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeTimeBarMove Event

Occurs before a Timebar is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeTimeBarMoveHandler

AddHandler instance.BeforeTimeBarMove, handler
C#
public event dbiScheduleWPF.BeforeTimeBarMoveHandler BeforeTimeBarMove

Event Data

The event handler receives an argument of type BeforeTimeBarMoveEventArgs containing data related to this event. The following BeforeTimeBarMoveEventArgs properties provide information specific to this event.

Property | Description
AllowMove | Determines if the timebar can be moved.
End | The new end DateTime for the timebar.
ListItemFrom | The dbiListItem containing the timebar before it is moved.
ListItemTo | The dbiListItem containing the timebar afetr it is moved.
Start | The new start DateTime for the timebar.
TimeBarItem | The dbiTimeBarItem before it is moved.
Vertical | Determines if the timebar is being moved vertically.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeTimeBarRemove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeTimeBarRemove Event

Occurs before a Timebar is removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeTimeBarRemoveHandler

AddHandler instance.BeforeTimeBarRemove, handler
C#
public event dbiScheduleWPF.BeforeTimeBarRemoveHandler BeforeTimeBarRemove

Event Data

The event handler receives an argument of type BeforeTimeBarRemoveEventArgs containing data related to this event. The following BeforeTimeBarRemoveEventArgs properties provide information specific to this event.

Property | Description
AllowRemoval | Determines if the Timebar can be removed.
BarIndex | The zero-based index value of the Timebar to be removed.
ListItem | The dbiListItem containing the timebar to be removed.
TimeBarItem | The timebar to be removed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeTimeBarSelect Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeTimeBarSelect Event

Occurs before a Timebar is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeTimeBarSelectHandler

AddHandler instance.BeforeTimeBarSelect, handler
C#
public event dbiScheduleWPF.BeforeTimeBarSelectHandler BeforeTimeBarSelect

Event Data

The event handler receives an argument of type BeforeTimeBarSelectEventArgs containing data related to this event. The following BeforeTimeBarSelectEventArgs properties provide information specific to this event.

Property | Description
AllowSelect | Determines if the timebar can be selected.
BarIndex | The zero-based index value of the Timebar being selected.
ListItem | The dbiListItem that contains the timebar before it is selected.
TimeBarItem | The timebar before it is selected.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeTimeBarSize Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeTimeBarSize Event

Occurs before a Timebar is sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeTimeBarSizeHandler

AddHandler instance.BeforeTimeBarSize, handler
C#
public event dbiScheduleWPF.BeforeTimeBarSizeHandler BeforeTimeBarSize

Event Data

The event handler receives an argument of type BeforeTimeBarSizeEventArgs containing data related to this event. The following BeforeTimeBarSizeEventArgs properties provide information specific to this event.

Property | Description
AllowSize | Determines if the Timebar can be sized.
BarIndex | The zero-based index value of the Timebar to be sized.
End | The new end DateTime for the Timebar.
ListItem | The dbiListITem containg the timebar being sized.
Start | The new start DateTime for the Timebar.
TimeBarItem | The timebar before it is sized.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeTimeBarSplit Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeTimeBarSplit Event

Occurs before a time bar is split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeTimeBarSplitHandler

AddHandler instance.BeforeTimeBarSplit, handler
C#
public event dbiScheduleWPF.BeforeTimeBarSplitHandler BeforeTimeBarSplit

Event Data

The event handler receives an argument of type BeforeTimeBarSplitEventArgs containing data related to this event. The following BeforeTimeBarSplitEventArgs properties provide information specific to this event.

Property | Description
AllowSplit | Determines if the Timebar can be split.
BarIndex | The zero-based index value of the Timebar to be split.
ListItem | The dbiListItem that contains the timebar that is being split.
SplitAt | The DateTime value where the split will occur.
TimeBarItem | The timebar that will be split.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeTimeBarUnlink Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeTimeBarUnlink Event

Occurs before the link between two Timebars has been removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeTimeBarUnlinkHandler

AddHandler instance.BeforeTimeBarUnlink, handler
C#
public event dbiScheduleWPF.BeforeTimeBarUnlinkHandler BeforeTimeBarUnlink

Event Data

The event handler receives an argument of type BeforeTimeBarUnlinkEventArgs containing data related to this event. The following BeforeTimeBarUnlinkEventArgs properties provide information specific to this event.

Property | Description
AllowUnlink | Determines if the dbiLinkItem can be removed.
Link | The dbiLinkItem to remove.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeforeToolTips Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeforeToolTips Event

Occurs before a tool tip is displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.BeforeToolTipsHandler

AddHandler instance.BeforeToolTips, handler
C#
public event dbiScheduleWPF.BeforeToolTipsHandler BeforeToolTips

Event Data

The event handler receives an argument of type BeforeToolTipsEventArgs containing data related to this event. The following BeforeToolTipsEventArgs properties provide information specific to this event.

Property | Description
Display | Determines if the tool tip will be displayed.
ListItem | The dbiListItem containing the timebar or schedule note displaying the tooltip.
ScheduleNote | The schedule note displaying the tooltip.
ScrollValue | The position of th vertical scrollbar.
Text | The text to display in the tooltip.
TimeBar | The timebar displaying the tooltip.
TipsType | The type of tooltip being displayed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ColumnHeaderClick Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ColumnHeaderClick Event

Event fired when the header of a column is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.ColumnHeaderClickHandler

AddHandler instance.ColumnHeaderClick, handler
C#
public event dbiScheduleWPF.ColumnHeaderClickHandler ColumnHeaderClick

Event Data

The event handler receives an argument of type ColumnHeaderClickEventArgs containing data related to this event. The following ColumnHeaderClickEventArgs properties provide information specific to this event.

Property | Description
Button | The mouse button that clicked the header.
Column | The column item that had its header clicked.
ColumnIndex | The zero-based index value of the column item that had its header clicked.
MouseEvent | The MouseEvent arguments related to the click.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ControlError Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ControlError Event

Occurs when an error takes place in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.ControlErrorHandler

AddHandler instance.ControlError, handler
C#
public event dbiScheduleWPF.ControlErrorHandler ControlError

Event Data

The event handler receives an argument of type ControlErrorEventArgs containing data related to this event. The following ControlErrorEventArgs properties provide information specific to this event.

Property | Description
Error | The ID number of the error which has occurred.
Message | The description of the error which has occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DeadZoneDrop Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DeadZoneDrop Event

Event fired when a time bar is moved onto a dead zone area with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.DeadZoneDropHandler

AddHandler instance.DeadZoneDrop, handler
C#
public event dbiScheduleWPF.DeadZoneDropHandler DeadZoneDrop

Event Data

The event handler receives an argument of type DeadZoneDropEventArgs containing data related to this event. The following DeadZoneDropEventArgs properties provide information specific to this event.

Property | Description
CustomArea | The dbiCustomArea that is designated as a deadzone.
TimeBar | The timebar source of the deadzonedrop.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

EditModeChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : EditModeChanged Event

Event fired when the EditMode is changed on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.EditModeChangedHandler

AddHandler instance.EditModeChanged, handler
C#
public event dbiScheduleWPF.EditModeChangedHandler EditModeChanged

Event Data

The event handler receives an argument of type EditModeChangedEventArgs containing data related to this event. The following EditModeChangedEventArgs properties provide information specific to this event.

Property | Description
EditMode | The new EditMode for the control.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FirstDraw Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FirstDraw Event

Occurs after the control has been drawn for the first time.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.FirstDrawHandler

AddHandler instance.FirstDraw, handler
C#
public event dbiScheduleWPF.FirstDrawHandler FirstDraw

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineClick Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineClick Event

Event fired when a GuideLine is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.GuideLineClickHandler

AddHandler instance.GuideLineClick, handler
C#
public event dbiScheduleWPF.GuideLineClickHandler GuideLineClick

Event Data

The event handler receives an argument of type GuideLineClickEventArgs containing data related to this event. The following GuideLineClickEventArgs properties provide information specific to this event.

Property | Description
Button | The mouse button that was used to click the GuideLine.
GuideLine | The dbiGuideLine that was clicked.
LineIndex | The zero-based index of the GuideLine in the collection.
MouseEvent | The MouseEvent arguments related to the click.
NewGuideLine | Determines if the GuideLine is new
OnImage | Determines if the click was on the image or the line.
X | The X position of the mouse where the click occurred.
Y | The Y position of the mouse where the click occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GuideLineMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GuideLineMove Event

Event fired when a GuideLine is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.GuideLineMoveHandler

AddHandler instance.GuideLineMove, handler
C#
public event dbiScheduleWPF.GuideLineMoveHandler GuideLineMove

Event Data

The event handler receives an argument of type GuideLineMoveEventArgs containing data related to this event. The following GuideLineMoveEventArgs properties provide information specific to this event.

Property | Description
GuideLine | The GuideLine being moved.
LineTime | The current DateTime value of the GuideLine
NewLine | The new DateTime value for the GuideLine.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HistoryChange Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HistoryChange Event

Occurs when an item in the RedoHistory or UndoHistory collections change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.HistoryChangeHandler

AddHandler instance.HistoryChange, handler
C#
public event dbiScheduleWPF.HistoryChangeHandler HistoryChange

Event Data

The event handler receives an argument of type HistoryChangeEventArgs containing data related to this event. The following HistoryChangeEventArgs properties provide information specific to this event.

Property | Description
Redo | Determines if an item in the RedoHistory collection changed.
Undo | Determines if an item in the UndoHistory collection changed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ItemMouseOver Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ItemMouseOver Event

Occurs when the mouse moves over a new object ni the schedule area

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.ItemMouseOverHandler

AddHandler instance.ItemMouseOver, handler
C#
public event dbiScheduleWPF.ItemMouseOverHandler ItemMouseOver

Event Data

The event handler receives an argument of type ItemMouseOverEventArgs containing data related to this event. The following ItemMouseOverEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar the mouse is over.
GuideLineIndex | The zero-based index value of the GuideLine the mouse is over.
GuideLineItem | The GuideLine the mouse is over.
ListItem | The ListItem the mouse is over.
MouseEvent | The MouseEvent arguments related to the movement.
NoteIndex | The zero-based index value of the note the mouse is over.
NoteItem | The ScheduleNote the mouse is over
TimeBarItem | The time bar the mouse is over.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowClick Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowClick Event

Event fired when a line arrow is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.LineArrowClickHandler

AddHandler instance.LineArrowClick, handler
C#
public event dbiScheduleWPF.LineArrowClickHandler LineArrowClick

Event Data

The event handler receives an argument of type LineArrowClickEventArgs containing data related to this event. The following LineArrowClickEventArgs properties provide information specific to this event.

Property | Description
Button | The MouseButton that performed the click.
Direction | The direction of the clicked Line Arrow.
ListItem | The ListItem where the LineArrow exists.
MouseEvent | The MouseEvent arguments related to the click.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LineArrowMouseOver Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LineArrowMouseOver Event

Event fired when the mouse moves over a line arrow.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.LineArrowMouseOverHandler

AddHandler instance.LineArrowMouseOver, handler
C#
public event dbiScheduleWPF.LineArrowMouseOverHandler LineArrowMouseOver

Event Data

The event handler receives an argument of type LineArrowMouseOverEventArgs containing data related to this event. The following LineArrowMouseOverEventArgs properties provide information specific to this event.

Property | Description
Direction | The direction of the Line Arrow the mouse is over.
ListItem | The ListItem where the LineArrow exists.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ListItemClick Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ListItemClick Event

Occurs when a list item is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.ListItemClickHandler

AddHandler instance.ListItemClick, handler
C#
public event dbiScheduleWPF.ListItemClickHandler ListItemClick

Event Data

The event handler receives an argument of type ListItemClickEventArgs containing data related to this event. The following ListItemClickEventArgs properties provide information specific to this event.

Property | Description
Button | Gets the mouse button used to perform the click operation.
Column | Gets the column where the click took place. If no columns are defined, then the property will report a value of -1.
ListItem | Gets the list item object that was clicked on.
MouseEvent | Gets the mouse event arguments for the click event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

NoteClick Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : NoteClick Event

Event fired when a schedule note is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.NoteClickHandler

AddHandler instance.NoteClick, handler
C#
public event dbiScheduleWPF.NoteClickHandler NoteClick

Event Data

The event handler receives an argument of type NoteClickEventArgs containing data related to this event. The following NoteClickEventArgs properties provide information specific to this event.

Property | Description
Button | The MouseButton that performed the click.
ListItem | The ListItem where the clicked note exists.
MouseEvent | The MouseEvent arguments related to the click.
ScheduleNote | The dbiScheduleNote that was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PrintProgress Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PrintProgress Event

Occurs just before each page, of the printed report, is printed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.PrintProgressHandler

AddHandler instance.PrintProgress, handler
C#
public event dbiScheduleWPF.PrintProgressHandler PrintProgress

Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CancelPrint | Determines if the print operation will be cancelled.
Page | The next page to be printed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RedoAction Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RedoAction Event

Occurs after a redo action has taken place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.RedoActionHandler

AddHandler instance.RedoAction, handler
C#
public event dbiScheduleWPF.RedoActionHandler RedoAction

Event Data

The event handler receives an argument of type RedoActionEventArgs containing data related to this event. The following RedoActionEventArgs properties provide information specific to this event.

Property | Description
HistoryItem | Gets the history item for the RedoActionEvent.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleClick Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleClick Event

Occurs when the schedule area is clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.ScheduleClickHandler

AddHandler instance.ScheduleClick, handler
C#
public event dbiScheduleWPF.ScheduleClickHandler ScheduleClick

Event Data

The event handler receives an argument of type ScheduleClickEventArgs containing data related to this event. The following ScheduleClickEventArgs properties provide information specific to this event.

Property | Description
Button | The MouseButton that performed the click.
MouseEvent | The MouseEvent arguments related to the click
Position | The position where the click occured.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ScheduleMouseMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ScheduleMouseMove Event

Occurs when the mouse moves over the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.ScheduleMouseMoveHandler

AddHandler instance.ScheduleMouseMove, handler
C#
public event dbiScheduleWPF.ScheduleMouseMoveHandler ScheduleMouseMove

Event Data

The event handler receives an argument of type ScheduleMouseMoveEventArgs containing data related to this event. The following ScheduleMouseMoveEventArgs properties provide information specific to this event.

Property | Description
MouseEvent | The MouseEvent arguments related to the mouse movement
Position | The current position of the cursor.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarClick Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarClick Event

Occurs when a Timebar is clicked on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.TimeBarClickHandler

AddHandler instance.TimeBarClick, handler
C#
public event dbiScheduleWPF.TimeBarClickHandler TimeBarClick

Event Data

The event handler receives an argument of type TimeBarClickEventArgs containing data related to this event. The following TimeBarClickEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar.
Button | The MouseButton being clicked.
ListItem | The dbiListItem containing the time bar being clicked
MouseEvent | The MouseEvent arguments related to the click
TimeBarItem | The dbiTimeBarItem being clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TimeBarSizing Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TimeBarSizing Event

Occurs as the size of the Timebar is being changed by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.TimeBarSizingHandler

AddHandler instance.TimeBarSizing, handler
C#
public event dbiScheduleWPF.TimeBarSizingHandler TimeBarSizing

Event Data

The event handler receives an argument of type TimeBarSizingEventArgs containing data related to this event. The following TimeBarSizingEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar.
End | The ending date time value of the Timebar.
ListItem | The dbiListItem containing the time bar being sized.
Start | The starting date time value of the Timebar.
TimeBarItem | The dbiTimeBarItem being sized.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UndoAction Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UndoAction Event

Occurs after an undo action has taken place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.UndoActionHandler

AddHandler instance.UndoAction, handler
C#
public event dbiScheduleWPF.UndoActionHandler UndoAction

Event Data

The event handler receives an argument of type UndoActionEventArgs containing data related to this event. The following UndoActionEventArgs properties provide information specific to this event.

Property | Description
HistoryItem | Gets the history item for the UndoActionEvent.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UserDrawnBarAfter Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UserDrawnBarAfter Event

This event fires after the timebar image has been created. This allows the developer to work with the graphics of an already drawn timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.UserDrawnBarAfterHandler

AddHandler instance.UserDrawnBarAfter, handler
C#
public event dbiScheduleWPF.UserDrawnBarAfterHandler UserDrawnBarAfter

Event Data

The event handler receives an argument of type UserDrawnBarAfterEventArgs containing data related to this event. The following UserDrawnBarAfterEventArgs properties provide information specific to this event.

Property | Description
BarRect | Gets the rectangular region in the schedule representing the time bar.
Canvas | Gets the Canvas object the represent the schedule.
LineRect | Gets the rectangular region in the schedule representing the line item hosting the time bar.
ListItem | Gets the dbiListItem object representing the line being drawn.
Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
TimeBarItem | Gets the dbiTimeBarItem object representing the time bar being drawn.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UserDrawnBarBefore Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UserDrawnBarBefore Event

Event fired at the point a time bar is drawn to provide custom painting of the time bar area. NOTE: Any time bar can be “User Drawn” and an item can contain any combination of user drawn and control drawn time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.UserDrawnBarBeforeHandler

AddHandler instance.UserDrawnBarBefore, handler
C#
public event dbiScheduleWPF.UserDrawnBarBeforeHandler UserDrawnBarBefore

Event Data

The event handler receives an argument of type UserDrawnBarBeforeEventArgs containing data related to this event. The following UserDrawnBarBeforeEventArgs properties provide information specific to this event.

Property | Description
BarRect | Gets the rectangular region in the schedule representing the time bar.
Canvas | Gets the Canvas object the represent the schedule.
LineRect | Gets the rectangular region in the schedule representing the line item hosting the time bar.
ListItem | Gets the dbiListItem object hosting the time bar being drawn.
PaintBar | Gets or sets whether the control should paint the time bar.
PaintText | Gets or sets whether the control should paint the text in the time bar.
Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
TimeBarItem | Gets the dbiTimeBarItem object representing the time bar being drawn.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UserDrawnLineAfter Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UserDrawnLineAfter Event

Event fired after all objects have been rendered inside the item. Allowing for custom appearance in front of all other objects.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.UserDrawnLineAfterHandler

AddHandler instance.UserDrawnLineAfter, handler
C#
public event dbiScheduleWPF.UserDrawnLineAfterHandler UserDrawnLineAfter

Event Data

The event handler receives an argument of type UserDrawnLineAfterEventArgs containing data related to this event. The following UserDrawnLineAfterEventArgs properties provide information specific to this event.

Property | Description
Canvas | Gets the Canvas object the represent the schedule.
LineRect | Gets the rectangular region in the schedule representing the line item.
LineStart | Gets the starting DateTime value for the line.
ListItem | Gets the dbiListItem object representing the line being drawn.
Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UserDrawnLineBefore Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UserDrawnLineBefore Event

Event fired before the list item is rendered, allowing for custom appearance and background.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.UserDrawnLineBeforeHandler

AddHandler instance.UserDrawnLineBefore, handler
C#
public event dbiScheduleWPF.UserDrawnLineBeforeHandler UserDrawnLineBefore

Event Data

The event handler receives an argument of type UserDrawnLineBeforeEventArgs containing data related to this event. The following UserDrawnLineBeforeEventArgs properties provide information specific to this event.

Property | Description
Canvas | Gets the Canvas object the represent the schedule.
LineRect | Gets the rectangular region in the schedule representing the line item.
LineStart | Gets the starting DateTime value for the line.
ListItem | Gets the dbiListItem object representing the line being drawn.
PaintLine | Gets or sets whether the control will paint the time bars on the list item.
Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ValuePoint Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ValuePoint Event

Occurs before each time value is drawn in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As dbiScheduleWPF.ValuePointHandler

AddHandler instance.ValuePoint, handler
C#
public event dbiScheduleWPF.ValuePointHandler ValuePoint

Event Data

The event handler receives an argument of type ValuePointEventArgs containing data related to this event. The following ValuePointEventArgs properties provide information specific to this event.

Property | Description
CurrentTime | The DateTime value of the major unit being drawn.
Text | The text to display in the ruler.
Value | The value of the major time unit.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

dbiTimeBarCollection Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarCollection Class

The collection of time bars

Object Model

dbiTimeBarCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
C#
[DefaultMemberAttribute("Item")]
public class dbiTimeBarCollection : System.Collections.ObjectModel.ObservableCollection<dbiTimeBarItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiTimeBarCollection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiTimeBarCollection Class Members
See Also Properties Methods Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarCollection Class

"

The following tables list the members exposed by dbiTimeBarCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiTimeBarCollection Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of a collection.
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Inserts an object into the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiTimeBarCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiTimeBarCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : dbiTimeBarCollection Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiTimeBarCollection()
C#
public dbiTimeBarCollection()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%% $$Methods$$

dbiTimeBarCollection Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarCollection Class

"

For a list of all members of this type, see dbiTimeBarCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an object to the end of a collection.
public Method | Clear | Removes all objects from the collection.
public Method | IndexOf | Gets the 0 based index of the first occurence of an object in the collection.
public Method | Insert | Inserts an object into the collection.
public Method | Remove | Removes the first occurence of a specific object from the collection.
public Method | RemoveAt | Removes the object at the specified index of the collection.
Top

See Also

Reference

dbiTimeBarCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Add Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : Add Method

Adds an object to the end of a collection.

Overload List

Overload | Description
Add() | Adds an object to the end of the collection.
Add(dbiTimeBarItem) | Adds an object to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

Add() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class > Add Method : Add() Method

Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection

instance.Add()
C#
public void Add()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members
Overload List


%%PageItemTitle%%

Add(dbiTimeBarItem) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class > Add Method : Add(dbiTimeBarItem) Method

obj
The dbiTimeBarItem to add to the end of the collection.
Adds an object to the end of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim obj As dbiTimeBarItem

instance.Add(obj)
C#
public new void Add(
   dbiTimeBarItem obj
)

Parameters

obj
The dbiTimeBarItem to add to the end of the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members
Overload List


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : IndexOf Method

obj
The dbiTimeBarItem to find the index of.
Gets the 0 based index of the first occurence of an object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim obj As dbiTimeBarItem
Dim value As Integer

value = instance.IndexOf(obj)
C#
public new int IndexOf(
   dbiTimeBarItem obj
)

Parameters

obj
The dbiTimeBarItem to find the index of.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : Insert Method

nIndex
The zero-based index to insert the new dbiTimeBarItem before.
obj
The dbiTimeBarItem to insert.
Inserts an object into the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim nIndex As Integer
Dim obj As dbiTimeBarItem

instance.Insert(nIndex, obj)
C#
public new void Insert(
   int nIndex,
   dbiTimeBarItem obj
)

Parameters

nIndex
The zero-based index to insert the new dbiTimeBarItem before.
obj
The dbiTimeBarItem to insert.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : Remove Method

obj
The dbiTimeBarItem to remove from the collection.
Removes the first occurence of a specific object from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim obj As dbiTimeBarItem

instance.Remove(obj)
C#
public new void Remove(
   dbiTimeBarItem obj
)

Parameters

obj
The dbiTimeBarItem to remove from the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : RemoveAt Method

nIndex
The zero-based index to remove the object at.
Removes the object at the specified index of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim nIndex As Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   int nIndex
)

Parameters

nIndex
The zero-based index to remove the object at.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%% $$Properties$$

dbiTimeBarCollection Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarCollection Class

"

For a list of all members of this type, see dbiTimeBarCollection members.

"

Public Properties

 | Name | Description
public Property | Item | Get or set a particular object in the collection.
Top

See Also

Reference

dbiTimeBarCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Item Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : Item Property

nIndex
The zero-based index value of the object in the collection.
Get or set a particular object in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim nIndex As Integer
Dim value As dbiTimeBarItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiTimeBarItem this[
   int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index value of the object in the collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

dbiTimeBarItem Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarItem Class

Provides properties for defining a time bar

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
C#
public class dbiTimeBarItem : System.Windows.DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiTimeBarItem

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

dbiTimeBarItem Class Members
See Also Fields Properties Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarItem Class

"

The following tables list the members exposed by dbiTimeBarItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiTimeBarItem Constructor | Overloaded. Initializes a new instance of the dbiTimeBarItem class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | EndImageOffsetProperty | Identifies the DependencyProperty for the EndImageOffset Property
static (Shared in Visual Basic) | EndImageProperty | Identifies the DependencyProperty for the EndImage Property
static (Shared in Visual Basic) | EndProperty | Identifies the DependencyProperty for the End Property
static (Shared in Visual Basic) | ForegroundProperty | Identifies the DependencyProperty for the Foreground Property
static (Shared in Visual Basic) | HeightProperty | Identifies the DependencyProperty for the Height Property
static (Shared in Visual Basic) | ImageAlignProperty | Identifies the DependencyProperty for the ImageAlign Property
static (Shared in Visual Basic) | ImageProperty | Identifies the DependencyProperty for the Image Property
static (Shared in Visual Basic) | LockedProperty | Identifies the DependencyProperty for the Locked Property
static (Shared in Visual Basic) | MileStoneProperty | Identifies the DependencyProperty for the MileStone Property
static (Shared in Visual Basic) | PercentBackgroundProperty | Identifies the DependencyProperty for the PercentBackground Property
static (Shared in Visual Basic) | PercentHeightProperty | Identifies the DependencyProperty for the PercentHeight Property
static (Shared in Visual Basic) | PercentValueProperty | Identifies the DependencyProperty for the PercentValue Property
static (Shared in Visual Basic) | StartImageOffsetProperty | Identifies the DependencyProperty for the StartImageOffset Property
static (Shared in Visual Basic) | StartImageProperty | Identifies the DependencyProperty for the StartImage Property
static (Shared in Visual Basic) | StartProperty | Identifies the DependencyProperty for the Start Property
static (Shared in Visual Basic) | StrokeProperty | Identifies the DependencyProperty for the Stroke Property
static (Shared in Visual Basic) | StrokeThicknessProperty | Identifies the DependencyProperty for the StrokeThickness Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TextAlignProperty | Identifies the DependencyProperty for the TextAlign Property
static (Shared in Visual Basic) | TextProperty | Identifies the DependencyProperty for the Text Property
static (Shared in Visual Basic) | VerticalOffsetProperty | Identifies the DependencyProperty for the VerticalOffset Property
Top

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the time bar.
public Property | End | Gets or sets the ending time of the time bar.
public Property | EndImage | Gets or sets the image index of an image to paint on the time bar.
public Property | EndImageOffset | Gets or sets the offset point used to calcaulate the position of the end image.
public Property | EntryID | Gets or sets the unique entry or identifier key for the time bar.
public Property | Foreground | Gets or sets the brush used to paint the text of the time bar.
public Property | Height | Gets or sets the height of the time bar. If this value is greater than 0, it will override the calculated height of the time bar by the host control.
public Property | Image | Gets or sets the image index of an image to paint inside the time bar.
public Property | ImageAlign | Gets or sets the main image alignment for the time bar.
public Property | IsMoved | Gets or sets whether a time bar has been moved during a vertical drag.
public Property | IsSelected | Gets or sets whether the time bar is currently selected.
public Property | Locked | Gets or sets whether the time bar can be moved by the mouse.
public Property | MaxTime | Gets or sets the maximum length of time of the time bar.
public Property | MileStone | Gets or sets if the timebar will be displayed as a milestone
public Property | MinTime | Gets or sets the minimum length of time of the time bar.
public Property | PercentBackground | Gets or sets the brush used to paint the percent bar background of the time bar.
public Property | PercentHeight | Gets or sets the height of the percent complete bar inside the regular time bar.
public Property | PercentValue | Gets or sets the value of the percent complete bar inside the regular time bar.
public Property | Start | Gets or sets the starting time of the time bar.
public Property | StartImage | Gets or sets the image index of an image to paint on the time bar.
public Property | StartImageOffset | Gets or sets the offset point used to calcaulate the position of the start image.
public Property | Stroke | Gets or sets the brush used to paint the border of the time bar.
public Property | StrokeThickness | Gets or sets the thickness of the border of the time bar.
public Property | Tag | Gets or sets a tag or object for the object.
public Property | Text | Gets or sets the main text for the time bar.
public Property | TextAlign | Gets or sets the main text alignment for the time bar.
public Property | VerticalOffset | Gets or sets a value used to calculate the vertical position of the time bar.
Top

Public Methods

 | Name | Description
public Method | Copy | Copy the contents from one dbiTimeBarItem to this one.
Top

See Also

Reference

dbiTimeBarItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiTimeBarItem Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : dbiTimeBarItem Constructor

Initializes a new instance of the dbiTimeBarItem class.

Overload List

Overload | Description
dbiTimeBarItem Constructor() | Initializes a new instance of the dbiTimeBarItem class.
dbiTimeBarItem Constructor(DateTime,DateTime) | Initializes a new instance of the dbiTimeBarItem class.
dbiTimeBarItem Constructor(DateTime,DateTime,String) | Initializes a new instance of the dbiTimeBarItem class.
dbiTimeBarItem Constructor(DateTime,DateTime,String,String) | Initializes a new instance of the dbiTimeBarItem class.
dbiTimeBarItem Constructor(String) | Constructor accepting a VCalendar string.
dbiTimeBarItem Constructor(dbiTimeBarItem) | Initializes a new instance of the dbiTimeBarItem class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

dbiTimeBarItem Constructor()
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor()

Initializes a new instance of the dbiTimeBarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiTimeBarItem()
C#
public dbiTimeBarItem()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

dbiTimeBarItem Constructor(DateTime,DateTime)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor(DateTime,DateTime)

dtStart
The start DateTime for the new time bar
dtEnd
The end DateTime for the new time bar
Initializes a new instance of the dbiTimeBarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As Date
Dim dtEnd As Date

Dim instance As New dbiTimeBarItem(dtStart, dtEnd)
C#
public dbiTimeBarItem(
   DateTime dtStart,
   DateTime dtEnd
)

Parameters

dtStart
The start DateTime for the new time bar
dtEnd
The end DateTime for the new time bar

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

dbiTimeBarItem Constructor(DateTime,DateTime,String)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor(DateTime,DateTime,String)

dtStart
The start DateTime for the new time bar
dtEnd
The end DateTime for the new time bar
strText
The text to display in the new time bar
Initializes a new instance of the dbiTimeBarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As Date
Dim dtEnd As Date
Dim strText As String

Dim instance As New dbiTimeBarItem(dtStart, dtEnd, strText)
C#
public dbiTimeBarItem(
   DateTime dtStart,
   DateTime dtEnd,
   string strText
)

Parameters

dtStart
The start DateTime for the new time bar
dtEnd
The end DateTime for the new time bar
strText
The text to display in the new time bar

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

dbiTimeBarItem Constructor(DateTime,DateTime,String,String)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor(DateTime,DateTime,String,String)

dtStart
The start DateTime for the new time bar
dtEnd
The end DateTime for the new time bar
strText
the text to display in the new time bar
strEntryID
The text to assign to the EntryID property of the new time bar
Initializes a new instance of the dbiTimeBarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As Date
Dim dtEnd As Date
Dim strText As String
Dim strEntryID As String

Dim instance As New dbiTimeBarItem(dtStart, dtEnd, strText, strEntryID)
C#
public dbiTimeBarItem(
   DateTime dtStart,
   DateTime dtEnd,
   string strText,
   string strEntryID
)

Parameters

dtStart
The start DateTime for the new time bar
dtEnd
The end DateTime for the new time bar
strText
the text to display in the new time bar
strEntryID
The text to assign to the EntryID property of the new time bar

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

dbiTimeBarItem Constructor(String)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor(String)

strVCalendar
the VCalendar formated string to base the new time bar off of
Constructor accepting a VCalendar string.

Syntax

Visual Basic (Usage) Copy Code
Dim strVCalendar As String

Dim instance As New dbiTimeBarItem(strVCalendar)
C#
public dbiTimeBarItem(
   string strVCalendar
)

Parameters

strVCalendar
the VCalendar formated string to base the new time bar off of

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

dbiTimeBarItem Constructor(dbiTimeBarItem)
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor(dbiTimeBarItem)

objTimeBar
The dbiTimeBar to copy property values from.
Initializes a new instance of the dbiTimeBarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objTimeBar As dbiTimeBarItem

Dim instance As New dbiTimeBarItem(objTimeBar)
C#
public dbiTimeBarItem(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimeBar to copy property values from.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%% $$Methods$$

dbiTimeBarItem Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarItem Class

"

For a list of all members of this type, see dbiTimeBarItem members.

"

Public Methods

 | Name | Description
public Method | Copy | Copy the contents from one dbiTimeBarItem to this one.
Top

See Also

Reference

dbiTimeBarItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Copy Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Copy Method

objTimeBar
The dbiTimeBarItem to copy property values from.
Copy the contents from one dbiTimeBarItem to this one.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim objTimeBar As dbiTimeBarItem
Dim value As Boolean

value = instance.Copy(objTimeBar)
C#
public bool Copy(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimeBarItem to copy property values from.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%% $$Properties$$

dbiTimeBarItem Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarItem Class

"

For a list of all members of this type, see dbiTimeBarItem members.

"

Public Properties

 | Name | Description
public Property | Background | Gets or sets the brush used to paint the background of the time bar.
public Property | End | Gets or sets the ending time of the time bar.
public Property | EndImage | Gets or sets the image index of an image to paint on the time bar.
public Property | EndImageOffset | Gets or sets the offset point used to calcaulate the position of the end image.
public Property | EntryID | Gets or sets the unique entry or identifier key for the time bar.
public Property | Foreground | Gets or sets the brush used to paint the text of the time bar.
public Property | Height | Gets or sets the height of the time bar. If this value is greater than 0, it will override the calculated height of the time bar by the host control.
public Property | Image | Gets or sets the image index of an image to paint inside the time bar.
public Property | ImageAlign | Gets or sets the main image alignment for the time bar.
public Property | IsMoved | Gets or sets whether a time bar has been moved during a vertical drag.
public Property | IsSelected | Gets or sets whether the time bar is currently selected.
public Property | Locked | Gets or sets whether the time bar can be moved by the mouse.
public Property | MaxTime | Gets or sets the maximum length of time of the time bar.
public Property | MileStone | Gets or sets if the timebar will be displayed as a milestone
public Property | MinTime | Gets or sets the minimum length of time of the time bar.
public Property | PercentBackground | Gets or sets the brush used to paint the percent bar background of the time bar.
public Property | PercentHeight | Gets or sets the height of the percent complete bar inside the regular time bar.
public Property | PercentValue | Gets or sets the value of the percent complete bar inside the regular time bar.
public Property | Start | Gets or sets the starting time of the time bar.
public Property | StartImage | Gets or sets the image index of an image to paint on the time bar.
public Property | StartImageOffset | Gets or sets the offset point used to calcaulate the position of the start image.
public Property | Stroke | Gets or sets the brush used to paint the border of the time bar.
public Property | StrokeThickness | Gets or sets the thickness of the border of the time bar.
public Property | Tag | Gets or sets a tag or object for the object.
public Property | Text | Gets or sets the main text for the time bar.
public Property | TextAlign | Gets or sets the main text alignment for the time bar.
public Property | VerticalOffset | Gets or sets a value used to calculate the vertical position of the time bar.
Top

See Also

Reference

dbiTimeBarItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Background Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Background Property

Gets or sets the brush used to paint the background of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Brush

instance.Background = value

value = instance.Background
C#
public Brush Background {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : End Property

Gets or sets the ending time of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Date

instance.End = value

value = instance.End
C#
[TypeConverterAttribute("., dbiScheduleWPF, Version=2.5.0.0, Culture=neutral, PublicKeyToken=0e75c9c0bb3bd0d4")]
public DateTime End {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

EndImage Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : EndImage Property

Gets or sets the image index of an image to paint on the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Integer

instance.EndImage = value

value = instance.EndImage
C#
public int EndImage {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

EndImageOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : EndImageOffset Property

Gets or sets the offset point used to calcaulate the position of the end image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Point

instance.EndImageOffset = value

value = instance.EndImageOffset
C#
public Point EndImageOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

EntryID Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : EntryID Property

Gets or sets the unique entry or identifier key for the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As String

instance.EntryID = value

value = instance.EntryID
C#
public string EntryID {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Foreground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Foreground Property

Gets or sets the brush used to paint the text of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Brush

instance.Foreground = value

value = instance.Foreground
C#
public Brush Foreground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Height Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Height Property

Gets or sets the height of the time bar. If this value is greater than 0, it will override the calculated height of the time bar by the host control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Integer

instance.Height = value

value = instance.Height
C#
public int Height {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Image Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Image Property

Gets or sets the image index of an image to paint inside the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Integer

instance.Image = value

value = instance.Image
C#
public int Image {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ImageAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : ImageAlign Property

Gets or sets the main image alignment for the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As enumAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
public enumAlignment ImageAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

IsMoved Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : IsMoved Property

Gets or sets whether a time bar has been moved during a vertical drag.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Boolean

instance.IsMoved = value

value = instance.IsMoved
C#
public bool IsMoved {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

IsSelected Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : IsSelected Property

Gets or sets whether the time bar is currently selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Boolean

instance.IsSelected = value

value = instance.IsSelected
C#
public bool IsSelected {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Locked Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Locked Property

Gets or sets whether the time bar can be moved by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Boolean

instance.Locked = value

value = instance.Locked
C#
public bool Locked {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

MaxTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : MaxTime Property

Gets or sets the maximum length of time of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As TimeSpan

instance.MaxTime = value

value = instance.MaxTime
C#
public TimeSpan MaxTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

MileStone Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : MileStone Property

Gets or sets if the timebar will be displayed as a milestone

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Boolean

instance.MileStone = value

value = instance.MileStone
C#
public bool MileStone {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

MinTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : MinTime Property

Gets or sets the minimum length of time of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As TimeSpan

instance.MinTime = value

value = instance.MinTime
C#
public TimeSpan MinTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentBackground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : PercentBackground Property

Gets or sets the brush used to paint the percent bar background of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Brush

instance.PercentBackground = value

value = instance.PercentBackground
C#
public Brush PercentBackground {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentHeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : PercentHeight Property

Gets or sets the height of the percent complete bar inside the regular time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Integer

instance.PercentHeight = value

value = instance.PercentHeight
C#
public int PercentHeight {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentValue Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : PercentValue Property

Gets or sets the value of the percent complete bar inside the regular time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Integer

instance.PercentValue = value

value = instance.PercentValue
C#
public int PercentValue {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Start Property

Gets or sets the starting time of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Date

instance.Start = value

value = instance.Start
C#
[TypeConverterAttribute("., dbiScheduleWPF, Version=2.5.0.0, Culture=neutral, PublicKeyToken=0e75c9c0bb3bd0d4")]
public DateTime Start {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

StartImage Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : StartImage Property

Gets or sets the image index of an image to paint on the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Integer

instance.StartImage = value

value = instance.StartImage
C#
public int StartImage {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

StartImageOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : StartImageOffset Property

Gets or sets the offset point used to calcaulate the position of the start image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Point

instance.StartImageOffset = value

value = instance.StartImageOffset
C#
public Point StartImageOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Stroke Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Stroke Property

Gets or sets the brush used to paint the border of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Brush

instance.Stroke = value

value = instance.Stroke
C#
public Brush Stroke {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

StrokeThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : StrokeThickness Property

Gets or sets the thickness of the border of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Double

instance.StrokeThickness = value

value = instance.StrokeThickness
C#
public double StrokeThickness {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Tag Property

Gets or sets a tag or object for the object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
public object Tag {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Text Property

Gets or sets the main text for the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

TextAlign Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : TextAlign Property

Gets or sets the main text alignment for the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As enumBarTextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public enumBarTextAlign TextAlign {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

VerticalOffset Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : VerticalOffset Property

Gets or sets a value used to calculate the vertical position of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Integer

instance.VerticalOffset = value

value = instance.VerticalOffset
C#
public int VerticalOffset {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%% $$Fields$$

dbiTimeBarItem Class Fields
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarItem Class

"

For a list of all members of this type, see dbiTimeBarItem members.

"

Public Fields

 | Name | Description
static (Shared in Visual Basic) | BackgroundProperty | Identifies the DependencyProperty for the Background Property
static (Shared in Visual Basic) | EndImageOffsetProperty | Identifies the DependencyProperty for the EndImageOffset Property
static (Shared in Visual Basic) | EndImageProperty | Identifies the DependencyProperty for the EndImage Property
static (Shared in Visual Basic) | EndProperty | Identifies the DependencyProperty for the End Property
static (Shared in Visual Basic) | ForegroundProperty | Identifies the DependencyProperty for the Foreground Property
static (Shared in Visual Basic) | HeightProperty | Identifies the DependencyProperty for the Height Property
static (Shared in Visual Basic) | ImageAlignProperty | Identifies the DependencyProperty for the ImageAlign Property
static (Shared in Visual Basic) | ImageProperty | Identifies the DependencyProperty for the Image Property
static (Shared in Visual Basic) | LockedProperty | Identifies the DependencyProperty for the Locked Property
static (Shared in Visual Basic) | MileStoneProperty | Identifies the DependencyProperty for the MileStone Property
static (Shared in Visual Basic) | PercentBackgroundProperty | Identifies the DependencyProperty for the PercentBackground Property
static (Shared in Visual Basic) | PercentHeightProperty | Identifies the DependencyProperty for the PercentHeight Property
static (Shared in Visual Basic) | PercentValueProperty | Identifies the DependencyProperty for the PercentValue Property
static (Shared in Visual Basic) | StartImageOffsetProperty | Identifies the DependencyProperty for the StartImageOffset Property
static (Shared in Visual Basic) | StartImageProperty | Identifies the DependencyProperty for the StartImage Property
static (Shared in Visual Basic) | StartProperty | Identifies the DependencyProperty for the Start Property
static (Shared in Visual Basic) | StrokeProperty | Identifies the DependencyProperty for the Stroke Property
static (Shared in Visual Basic) | StrokeThicknessProperty | Identifies the DependencyProperty for the StrokeThickness Property
static (Shared in Visual Basic) | TagProperty | Identifies the DependencyProperty for the Tag Property
static (Shared in Visual Basic) | TextAlignProperty | Identifies the DependencyProperty for the TextAlign Property
static (Shared in Visual Basic) | TextProperty | Identifies the DependencyProperty for the Text Property
static (Shared in Visual Basic) | VerticalOffsetProperty | Identifies the DependencyProperty for the VerticalOffset Property
Top

See Also

Reference

dbiTimeBarItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : BackgroundProperty Field

Identifies the DependencyProperty for the Background Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.BackgroundProperty
C#
public static readonly DependencyProperty BackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

EndImageOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : EndImageOffsetProperty Field

Identifies the DependencyProperty for the EndImageOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.EndImageOffsetProperty
C#
public static readonly DependencyProperty EndImageOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

EndImageProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : EndImageProperty Field

Identifies the DependencyProperty for the EndImage Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.EndImageProperty
C#
public static readonly DependencyProperty EndImageProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

EndProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : EndProperty Field

Identifies the DependencyProperty for the End Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.EndProperty
C#
public static readonly DependencyProperty EndProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ForegroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : ForegroundProperty Field

Identifies the DependencyProperty for the Foreground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.ForegroundProperty
C#
public static readonly DependencyProperty ForegroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

HeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : HeightProperty Field

Identifies the DependencyProperty for the Height Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.HeightProperty
C#
public static readonly DependencyProperty HeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ImageAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : ImageAlignProperty Field

Identifies the DependencyProperty for the ImageAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.ImageAlignProperty
C#
public static readonly DependencyProperty ImageAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ImageProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : ImageProperty Field

Identifies the DependencyProperty for the Image Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.ImageProperty
C#
public static readonly DependencyProperty ImageProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

LockedProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : LockedProperty Field

Identifies the DependencyProperty for the Locked Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.LockedProperty
C#
public static readonly DependencyProperty LockedProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

MileStoneProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : MileStoneProperty Field

Identifies the DependencyProperty for the MileStone Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.MileStoneProperty
C#
public static readonly DependencyProperty MileStoneProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentBackgroundProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : PercentBackgroundProperty Field

Identifies the DependencyProperty for the PercentBackground Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.PercentBackgroundProperty
C#
public static readonly DependencyProperty PercentBackgroundProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentHeightProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : PercentHeightProperty Field

Identifies the DependencyProperty for the PercentHeight Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.PercentHeightProperty
C#
public static readonly DependencyProperty PercentHeightProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentValueProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : PercentValueProperty Field

Identifies the DependencyProperty for the PercentValue Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.PercentValueProperty
C#
public static readonly DependencyProperty PercentValueProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

StartImageOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : StartImageOffsetProperty Field

Identifies the DependencyProperty for the StartImageOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.StartImageOffsetProperty
C#
public static readonly DependencyProperty StartImageOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

StartImageProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : StartImageProperty Field

Identifies the DependencyProperty for the StartImage Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.StartImageProperty
C#
public static readonly DependencyProperty StartImageProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

StartProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : StartProperty Field

Identifies the DependencyProperty for the Start Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.StartProperty
C#
public static readonly DependencyProperty StartProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

StrokeProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : StrokeProperty Field

Identifies the DependencyProperty for the Stroke Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.StrokeProperty
C#
public static readonly DependencyProperty StrokeProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

StrokeThicknessProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : StrokeThicknessProperty Field

Identifies the DependencyProperty for the StrokeThickness Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.StrokeThicknessProperty
C#
public static readonly DependencyProperty StrokeThicknessProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

TagProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : TagProperty Field

Identifies the DependencyProperty for the Tag Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.TagProperty
C#
public static readonly DependencyProperty TagProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

TextAlignProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : TextAlignProperty Field

Identifies the DependencyProperty for the TextAlign Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.TextAlignProperty
C#
public static readonly DependencyProperty TextAlignProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

TextProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : TextProperty Field

Identifies the DependencyProperty for the Text Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.TextProperty
C#
public static readonly DependencyProperty TextProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

VerticalOffsetProperty Field
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : VerticalOffsetProperty Field

Identifies the DependencyProperty for the VerticalOffset Property

Syntax

Visual Basic (Usage) Copy Code
Dim value As DependencyProperty

value = dbiTimeBarItem.VerticalOffsetProperty
C#
public static readonly DependencyProperty VerticalOffsetProperty

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

DeadZoneDropEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : DeadZoneDropEventArgs Class

Provides data for the DeadZoneDrop Event

Object Model

DeadZoneDropEventArgs ClassdbiCustomArea ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
C#
public class DeadZoneDropEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.DeadZoneDropEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

DeadZoneDropEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

DeadZoneDropEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : DeadZoneDropEventArgs Class

"

The following tables list the members exposed by DeadZoneDropEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | DeadZoneDropEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | CustomArea | The dbiCustomArea that is designated as a deadzone.
public Property | TimeBar | The timebar source of the deadzonedrop.
Top

See Also

Reference

DeadZoneDropEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

DeadZoneDropEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > DeadZoneDropEventArgs Class : DeadZoneDropEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DeadZoneDropEventArgs()
C#
public DeadZoneDropEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%% $$Properties$$

DeadZoneDropEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : DeadZoneDropEventArgs Class

"

For a list of all members of this type, see DeadZoneDropEventArgs members.

"

Public Properties

 | Name | Description
public Property | CustomArea | The dbiCustomArea that is designated as a deadzone.
public Property | TimeBar | The timebar source of the deadzonedrop.
Top

See Also

Reference

DeadZoneDropEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

CustomArea Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > DeadZoneDropEventArgs Class : CustomArea Property

The dbiCustomArea that is designated as a deadzone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
Dim value As dbiCustomArea

instance.CustomArea = value

value = instance.CustomArea
C#
public dbiCustomArea CustomArea {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%%

TimeBar Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > DeadZoneDropEventArgs Class : TimeBar Property

The timebar source of the deadzonedrop.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
Dim value As dbiTimeBarItem

instance.TimeBar = value

value = instance.TimeBar
C#
public dbiTimeBarItem TimeBar {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%%

EditModeChangedEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : EditModeChangedEventArgs Class

Provides data for the EditModeChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditModeChangedEventArgs
C#
public class EditModeChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.EditModeChangedEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

EditModeChangedEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

EditModeChangedEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : EditModeChangedEventArgs Class

"

The following tables list the members exposed by EditModeChangedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | EditModeChangedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | EditMode | The new EditMode for the control.
Top

See Also

Reference

EditModeChangedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

EditModeChangedEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > EditModeChangedEventArgs Class : EditModeChangedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New EditModeChangedEventArgs()
C#
public EditModeChangedEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

EditModeChangedEventArgs Class
EditModeChangedEventArgs Members


%%PageItemTitle%% $$Properties$$

EditModeChangedEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : EditModeChangedEventArgs Class

"

For a list of all members of this type, see EditModeChangedEventArgs members.

"

Public Properties

 | Name | Description
public Property | EditMode | The new EditMode for the control.
Top

See Also

Reference

EditModeChangedEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

EditMode Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > EditModeChangedEventArgs Class : EditMode Property

The new EditMode for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditModeChangedEventArgs
Dim value As enumEditMode

instance.EditMode = value

value = instance.EditMode
C#
public enumEditMode EditMode {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

EditModeChangedEventArgs Class
EditModeChangedEventArgs Members


%%PageItemTitle%%

FirstDrawEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : FirstDrawEventArgs Class

Provides data for the FirstDraw Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As FirstDrawEventArgs
C#
public class FirstDrawEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.FirstDrawEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

FirstDrawEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

FirstDrawEventArgs Class Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : FirstDrawEventArgs Class

"

The following tables list the members exposed by FirstDrawEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | FirstDrawEventArgs Constructor | Initializes a new instance of the class.
Top

See Also

Reference

FirstDrawEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

FirstDrawEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > FirstDrawEventArgs Class : FirstDrawEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New FirstDrawEventArgs()
C#
public FirstDrawEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

FirstDrawEventArgs Class
FirstDrawEventArgs Members


%%PageItemTitle%%

GuideLineClickEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : GuideLineClickEventArgs Class

Provides data for the GuideLineClick Event

Object Model

GuideLineClickEventArgs ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
C#
public class GuideLineClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.GuideLineClickEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

GuideLineClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : GuideLineClickEventArgs Class

"

The following tables list the members exposed by GuideLineClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | GuideLineClickEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Button | The mouse button that was used to click the GuideLine.
public Property | GuideLine | The dbiGuideLine that was clicked.
public Property | LineIndex | The zero-based index of the GuideLine in the collection.
public Property | MouseEvent | The MouseEvent arguments related to the click.
public Property | NewGuideLine | Determines if the GuideLine is new
public Property | OnImage | Determines if the click was on the image or the line.
public Property | X | The X position of the mouse where the click occurred.
public Property | Y | The Y position of the mouse where the click occurred.
Top

See Also

Reference

GuideLineClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

GuideLineClickEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineClickEventArgs Class : GuideLineClickEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New GuideLineClickEventArgs()
C#
public GuideLineClickEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%% $$Properties$$

GuideLineClickEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : GuideLineClickEventArgs Class

"

For a list of all members of this type, see GuideLineClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The mouse button that was used to click the GuideLine.
public Property | GuideLine | The dbiGuideLine that was clicked.
public Property | LineIndex | The zero-based index of the GuideLine in the collection.
public Property | MouseEvent | The MouseEvent arguments related to the click.
public Property | NewGuideLine | Determines if the GuideLine is new
public Property | OnImage | Determines if the click was on the image or the line.
public Property | X | The X position of the mouse where the click occurred.
public Property | Y | The Y position of the mouse where the click occurred.
Top

See Also

Reference

GuideLineClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Button Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineClickEventArgs Class : Button Property

The mouse button that was used to click the GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As MouseButton

instance.Button = value

value = instance.Button
C#
public MouseButton Button {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineClickEventArgs Class : GuideLine Property

The dbiGuideLine that was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineClickEventArgs Class : LineIndex Property

The zero-based index of the GuideLine in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public int LineIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

MouseEvent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineClickEventArgs Class : MouseEvent Property

The MouseEvent arguments related to the click.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As MouseButtonEventArgs

instance.MouseEvent = value

value = instance.MouseEvent
C#
public MouseButtonEventArgs MouseEvent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

NewGuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineClickEventArgs Class : NewGuideLine Property

Determines if the GuideLine is new

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As Boolean

instance.NewGuideLine = value

value = instance.NewGuideLine
C#
public bool NewGuideLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

OnImage Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineClickEventArgs Class : OnImage Property

Determines if the click was on the image or the line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As Boolean

instance.OnImage = value

value = instance.OnImage
C#
public bool OnImage {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

X Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineClickEventArgs Class : X Property

The X position of the mouse where the click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As Double

instance.X = value

value = instance.X
C#
public double X {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

Y Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineClickEventArgs Class : Y Property

The Y position of the mouse where the click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As Double

instance.Y = value

value = instance.Y
C#
public double Y {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

GuideLineMoveEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : GuideLineMoveEventArgs Class

Provides data for the GuideLineMove Event

Object Model

GuideLineMoveEventArgs ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineMoveEventArgs
C#
public class GuideLineMoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.GuideLineMoveEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineMoveEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

GuideLineMoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : GuideLineMoveEventArgs Class

"

The following tables list the members exposed by GuideLineMoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | GuideLineMoveEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | GuideLine | The GuideLine being moved.
public Property | LineTime | The current DateTime value of the GuideLine
public Property | NewLine | The new DateTime value for the GuideLine.
Top

See Also

Reference

GuideLineMoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

GuideLineMoveEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineMoveEventArgs Class : GuideLineMoveEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New GuideLineMoveEventArgs()
C#
public GuideLineMoveEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineMoveEventArgs Class
GuideLineMoveEventArgs Members


%%PageItemTitle%% $$Properties$$

GuideLineMoveEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : GuideLineMoveEventArgs Class

"

For a list of all members of this type, see GuideLineMoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | GuideLine | The GuideLine being moved.
public Property | LineTime | The current DateTime value of the GuideLine
public Property | NewLine | The new DateTime value for the GuideLine.
Top

See Also

Reference

GuideLineMoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineMoveEventArgs Class : GuideLine Property

The GuideLine being moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineMoveEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineMoveEventArgs Class
GuideLineMoveEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineMoveEventArgs Class : LineTime Property

The current DateTime value of the GuideLine

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineMoveEventArgs
Dim value As Date

instance.LineTime = value

value = instance.LineTime
C#
public DateTime LineTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineMoveEventArgs Class
GuideLineMoveEventArgs Members


%%PageItemTitle%%

NewLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > GuideLineMoveEventArgs Class : NewLine Property

The new DateTime value for the GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineMoveEventArgs
Dim value As Boolean

instance.NewLine = value

value = instance.NewLine
C#
public bool NewLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

GuideLineMoveEventArgs Class
GuideLineMoveEventArgs Members


%%PageItemTitle%%

HistoryChangeEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : HistoryChangeEventArgs Class

Provides data for the HistoryChange Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryChangeEventArgs
C#
public class HistoryChangeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.HistoryChangeEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

HistoryChangeEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

HistoryChangeEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : HistoryChangeEventArgs Class

"

The following tables list the members exposed by HistoryChangeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | HistoryChangeEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Redo | Determines if an item in the RedoHistory collection changed.
public Property | Undo | Determines if an item in the UndoHistory collection changed.
Top

See Also

Reference

HistoryChangeEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

HistoryChangeEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > HistoryChangeEventArgs Class : HistoryChangeEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New HistoryChangeEventArgs()
C#
public HistoryChangeEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

HistoryChangeEventArgs Class
HistoryChangeEventArgs Members


%%PageItemTitle%% $$Properties$$

HistoryChangeEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : HistoryChangeEventArgs Class

"

For a list of all members of this type, see HistoryChangeEventArgs members.

"

Public Properties

 | Name | Description
public Property | Redo | Determines if an item in the RedoHistory collection changed.
public Property | Undo | Determines if an item in the UndoHistory collection changed.
Top

See Also

Reference

HistoryChangeEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Redo Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > HistoryChangeEventArgs Class : Redo Property

Determines if an item in the RedoHistory collection changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryChangeEventArgs
Dim value As Boolean

instance.Redo = value

value = instance.Redo
C#
public bool Redo {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

HistoryChangeEventArgs Class
HistoryChangeEventArgs Members


%%PageItemTitle%%

Undo Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > HistoryChangeEventArgs Class : Undo Property

Determines if an item in the UndoHistory collection changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryChangeEventArgs
Dim value As Boolean

instance.Undo = value

value = instance.Undo
C#
public bool Undo {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

HistoryChangeEventArgs Class
HistoryChangeEventArgs Members


%%PageItemTitle%%

ItemMouseOverEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ItemMouseOverEventArgs Class

Provides data for the ItemMouseOver Event

Object Model

ItemMouseOverEventArgs ClassdbiGuideLine ClassdbiListItem ClassdbiScheduleNote ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
C#
public class ItemMouseOverEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.ItemMouseOverEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

ItemMouseOverEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ItemMouseOverEventArgs Class

"

The following tables list the members exposed by ItemMouseOverEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ItemMouseOverEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar the mouse is over.
public Property | GuideLineIndex | The zero-based index value of the GuideLine the mouse is over.
public Property | GuideLineItem | The GuideLine the mouse is over.
public Property | ListItem | The ListItem the mouse is over.
public Property | MouseEvent | The MouseEvent arguments related to the movement.
public Property | NoteIndex | The zero-based index value of the note the mouse is over.
public Property | NoteItem | The ScheduleNote the mouse is over
public Property | TimeBarItem | The time bar the mouse is over.
Top

See Also

Reference

ItemMouseOverEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ItemMouseOverEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ItemMouseOverEventArgs Class : ItemMouseOverEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ItemMouseOverEventArgs()
C#
public ItemMouseOverEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%% $$Properties$$

ItemMouseOverEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ItemMouseOverEventArgs Class

"

For a list of all members of this type, see ItemMouseOverEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar the mouse is over.
public Property | GuideLineIndex | The zero-based index value of the GuideLine the mouse is over.
public Property | GuideLineItem | The GuideLine the mouse is over.
public Property | ListItem | The ListItem the mouse is over.
public Property | MouseEvent | The MouseEvent arguments related to the movement.
public Property | NoteIndex | The zero-based index value of the note the mouse is over.
public Property | NoteItem | The ScheduleNote the mouse is over
public Property | TimeBarItem | The time bar the mouse is over.
Top

See Also

Reference

ItemMouseOverEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ItemMouseOverEventArgs Class : BarIndex Property

The zero-based index value of the Timebar the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

GuideLineIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ItemMouseOverEventArgs Class : GuideLineIndex Property

The zero-based index value of the GuideLine the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As Integer

instance.GuideLineIndex = value

value = instance.GuideLineIndex
C#
public int GuideLineIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

GuideLineItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ItemMouseOverEventArgs Class : GuideLineItem Property

The GuideLine the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As dbiGuideLine

instance.GuideLineItem = value

value = instance.GuideLineItem
C#
public dbiGuideLine GuideLineItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ItemMouseOverEventArgs Class : ListItem Property

The ListItem the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

MouseEvent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ItemMouseOverEventArgs Class : MouseEvent Property

The MouseEvent arguments related to the movement.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As MouseEventArgs

instance.MouseEvent = value

value = instance.MouseEvent
C#
public MouseEventArgs MouseEvent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

NoteIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ItemMouseOverEventArgs Class : NoteIndex Property

The zero-based index value of the note the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As Integer

instance.NoteIndex = value

value = instance.NoteIndex
C#
public int NoteIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

NoteItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ItemMouseOverEventArgs Class : NoteItem Property

The ScheduleNote the mouse is over

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As dbiScheduleNote

instance.NoteItem = value

value = instance.NoteItem
C#
public dbiScheduleNote NoteItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ItemMouseOverEventArgs Class : TimeBarItem Property

The time bar the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

LineArrowClickEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : LineArrowClickEventArgs Class

Provides data for the LineArrowClick Event

Object Model

LineArrowClickEventArgs ClassdbiListItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
C#
public class LineArrowClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.LineArrowClickEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowClickEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

LineArrowClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : LineArrowClickEventArgs Class

"

The following tables list the members exposed by LineArrowClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | LineArrowClickEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | Direction | The direction of the clicked Line Arrow.
public Property | ListItem | The ListItem where the LineArrow exists.
public Property | MouseEvent | The MouseEvent arguments related to the click.
Top

See Also

Reference

LineArrowClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

LineArrowClickEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > LineArrowClickEventArgs Class : LineArrowClickEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New LineArrowClickEventArgs()
C#
public LineArrowClickEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%% $$Properties$$

LineArrowClickEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : LineArrowClickEventArgs Class

"

For a list of all members of this type, see LineArrowClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | Direction | The direction of the clicked Line Arrow.
public Property | ListItem | The ListItem where the LineArrow exists.
public Property | MouseEvent | The MouseEvent arguments related to the click.
Top

See Also

Reference

LineArrowClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Button Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > LineArrowClickEventArgs Class : Button Property

The MouseButton that performed the click.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
Dim value As MouseButton

instance.Button = value

value = instance.Button
C#
public MouseButton Button {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%%

Direction Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > LineArrowClickEventArgs Class : Direction Property

The direction of the clicked Line Arrow.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
Dim value As enumLineArrowDirection

instance.Direction = value

value = instance.Direction
C#
public enumLineArrowDirection Direction {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > LineArrowClickEventArgs Class : ListItem Property

The ListItem where the LineArrow exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%%

MouseEvent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > LineArrowClickEventArgs Class : MouseEvent Property

The MouseEvent arguments related to the click.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
Dim value As MouseButtonEventArgs

instance.MouseEvent = value

value = instance.MouseEvent
C#
public MouseButtonEventArgs MouseEvent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%%

LineArrowMouseOverEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : LineArrowMouseOverEventArgs Class

Provides data for the LineArrowMouseOver Event

Object Model

LineArrowMouseOverEventArgs ClassdbiListItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowMouseOverEventArgs
C#
public class LineArrowMouseOverEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.LineArrowMouseOverEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowMouseOverEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

LineArrowMouseOverEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : LineArrowMouseOverEventArgs Class

"

The following tables list the members exposed by LineArrowMouseOverEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | LineArrowMouseOverEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Direction | The direction of the Line Arrow the mouse is over.
public Property | ListItem | The ListItem where the LineArrow exists.
Top

See Also

Reference

LineArrowMouseOverEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

LineArrowMouseOverEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > LineArrowMouseOverEventArgs Class : LineArrowMouseOverEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New LineArrowMouseOverEventArgs()
C#
public LineArrowMouseOverEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowMouseOverEventArgs Class
LineArrowMouseOverEventArgs Members


%%PageItemTitle%% $$Properties$$

LineArrowMouseOverEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : LineArrowMouseOverEventArgs Class

"

For a list of all members of this type, see LineArrowMouseOverEventArgs members.

"

Public Properties

 | Name | Description
public Property | Direction | The direction of the Line Arrow the mouse is over.
public Property | ListItem | The ListItem where the LineArrow exists.
Top

See Also

Reference

LineArrowMouseOverEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Direction Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > LineArrowMouseOverEventArgs Class : Direction Property

The direction of the Line Arrow the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowMouseOverEventArgs
Dim value As enumLineArrowDirection

instance.Direction = value

value = instance.Direction
C#
public enumLineArrowDirection Direction {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowMouseOverEventArgs Class
LineArrowMouseOverEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > LineArrowMouseOverEventArgs Class : ListItem Property

The ListItem where the LineArrow exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowMouseOverEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

LineArrowMouseOverEventArgs Class
LineArrowMouseOverEventArgs Members


%%PageItemTitle%%

ListItemClickEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ListItemClickEventArgs Class

Provides data for the ListItemClick Event

Object Model

ListItemClickEventArgs ClassdbiListItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListItemClickEventArgs
C#
public class ListItemClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.ListItemClickEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ListItemClickEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

ListItemClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ListItemClickEventArgs Class

"

The following tables list the members exposed by ListItemClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ListItemClickEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Button | Gets the mouse button used to perform the click operation.
public Property | Column | Gets the column where the click took place. If no columns are defined, then the property will report a value of -1.
public Property | ListItem | Gets the list item object that was clicked on.
public Property | MouseEvent | Gets the mouse event arguments for the click event.
Top

See Also

Reference

ListItemClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ListItemClickEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ListItemClickEventArgs Class : ListItemClickEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ListItemClickEventArgs()
C#
public ListItemClickEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ListItemClickEventArgs Class
ListItemClickEventArgs Members


%%PageItemTitle%% $$Properties$$

ListItemClickEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ListItemClickEventArgs Class

"

For a list of all members of this type, see ListItemClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | Gets the mouse button used to perform the click operation.
public Property | Column | Gets the column where the click took place. If no columns are defined, then the property will report a value of -1.
public Property | ListItem | Gets the list item object that was clicked on.
public Property | MouseEvent | Gets the mouse event arguments for the click event.
Top

See Also

Reference

ListItemClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Button Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ListItemClickEventArgs Class : Button Property

Gets the mouse button used to perform the click operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListItemClickEventArgs
Dim value As MouseButton

instance.Button = value

value = instance.Button
C#
public MouseButton Button {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ListItemClickEventArgs Class
ListItemClickEventArgs Members


%%PageItemTitle%%

Column Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ListItemClickEventArgs Class : Column Property

Gets the column where the click took place. If no columns are defined, then the property will report a value of -1.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListItemClickEventArgs
Dim value As Integer

instance.Column = value

value = instance.Column
C#
public int Column {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ListItemClickEventArgs Class
ListItemClickEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ListItemClickEventArgs Class : ListItem Property

Gets the list item object that was clicked on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListItemClickEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ListItemClickEventArgs Class
ListItemClickEventArgs Members


%%PageItemTitle%%

MouseEvent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ListItemClickEventArgs Class : MouseEvent Property

Gets the mouse event arguments for the click event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListItemClickEventArgs
Dim value As MouseButtonEventArgs

instance.MouseEvent = value

value = instance.MouseEvent
C#
public MouseButtonEventArgs MouseEvent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ListItemClickEventArgs Class
ListItemClickEventArgs Members


%%PageItemTitle%%

NoteClickEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : NoteClickEventArgs Class

Provides data for the NoteClick Event

Object Model

NoteClickEventArgs ClassdbiListItem ClassdbiScheduleNote Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteClickEventArgs
C#
public class NoteClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.NoteClickEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

NoteClickEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

NoteClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : NoteClickEventArgs Class

"

The following tables list the members exposed by NoteClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | NoteClickEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | ListItem | The ListItem where the clicked note exists.
public Property | MouseEvent | The MouseEvent arguments related to the click.
public Property | ScheduleNote | The dbiScheduleNote that was clicked.
Top

See Also

Reference

NoteClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

NoteClickEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > NoteClickEventArgs Class : NoteClickEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New NoteClickEventArgs()
C#
public NoteClickEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

NoteClickEventArgs Class
NoteClickEventArgs Members


%%PageItemTitle%% $$Properties$$

NoteClickEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : NoteClickEventArgs Class

"

For a list of all members of this type, see NoteClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | ListItem | The ListItem where the clicked note exists.
public Property | MouseEvent | The MouseEvent arguments related to the click.
public Property | ScheduleNote | The dbiScheduleNote that was clicked.
Top

See Also

Reference

NoteClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Button Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > NoteClickEventArgs Class : Button Property

The MouseButton that performed the click.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteClickEventArgs
Dim value As MouseButton

instance.Button = value

value = instance.Button
C#
public MouseButton Button {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

NoteClickEventArgs Class
NoteClickEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > NoteClickEventArgs Class : ListItem Property

The ListItem where the clicked note exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteClickEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

NoteClickEventArgs Class
NoteClickEventArgs Members


%%PageItemTitle%%

MouseEvent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > NoteClickEventArgs Class : MouseEvent Property

The MouseEvent arguments related to the click.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteClickEventArgs
Dim value As MouseButtonEventArgs

instance.MouseEvent = value

value = instance.MouseEvent
C#
public MouseButtonEventArgs MouseEvent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

NoteClickEventArgs Class
NoteClickEventArgs Members


%%PageItemTitle%%

ScheduleNote Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > NoteClickEventArgs Class : ScheduleNote Property

The dbiScheduleNote that was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteClickEventArgs
Dim value As dbiScheduleNote

instance.ScheduleNote = value

value = instance.ScheduleNote
C#
public dbiScheduleNote ScheduleNote {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

NoteClickEventArgs Class
NoteClickEventArgs Members


%%PageItemTitle%%

PrintProgressEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : PrintProgressEventArgs Class

Provides data for the PrintProgress Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As PrintProgressEventArgs
C#
public class PrintProgressEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.PrintProgressEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

PrintProgressEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

PrintProgressEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : PrintProgressEventArgs Class

"

The following tables list the members exposed by PrintProgressEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | PrintProgressEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | CancelPrint | Determines if the print operation will be cancelled.
public Property | Page | The next page to be printed.
Top

See Also

Reference

PrintProgressEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

PrintProgressEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > PrintProgressEventArgs Class : PrintProgressEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New PrintProgressEventArgs()
C#
public PrintProgressEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


%%PageItemTitle%% $$Properties$$

PrintProgressEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : PrintProgressEventArgs Class

"

For a list of all members of this type, see PrintProgressEventArgs members.

"

Public Properties

 | Name | Description
public Property | CancelPrint | Determines if the print operation will be cancelled.
public Property | Page | The next page to be printed.
Top

See Also

Reference

PrintProgressEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

CancelPrint Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > PrintProgressEventArgs Class : CancelPrint Property

Determines if the print operation will be cancelled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As PrintProgressEventArgs
Dim value As Boolean

instance.CancelPrint = value

value = instance.CancelPrint
C#
public bool CancelPrint {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


%%PageItemTitle%%

Page Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > PrintProgressEventArgs Class : Page Property

The next page to be printed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As PrintProgressEventArgs
Dim value As Integer

instance.Page = value

value = instance.Page
C#
public int Page {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


%%PageItemTitle%%

RedoActionEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : RedoActionEventArgs Class

Provides data for the RedoAction Event

Object Model

RedoActionEventArgs ClassdbiHistoryItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RedoActionEventArgs
C#
public class RedoActionEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.RedoActionEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

RedoActionEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

RedoActionEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : RedoActionEventArgs Class

"

The following tables list the members exposed by RedoActionEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | RedoActionEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | HistoryItem | Gets the history item for the RedoActionEvent.
Top

See Also

Reference

RedoActionEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

RedoActionEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > RedoActionEventArgs Class : RedoActionEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New RedoActionEventArgs()
C#
public RedoActionEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

RedoActionEventArgs Class
RedoActionEventArgs Members


%%PageItemTitle%% $$Properties$$

RedoActionEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : RedoActionEventArgs Class

"

For a list of all members of this type, see RedoActionEventArgs members.

"

Public Properties

 | Name | Description
public Property | HistoryItem | Gets the history item for the RedoActionEvent.
Top

See Also

Reference

RedoActionEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

HistoryItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > RedoActionEventArgs Class : HistoryItem Property

Gets the history item for the RedoActionEvent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RedoActionEventArgs
Dim value As dbiHistoryItem

instance.HistoryItem = value

value = instance.HistoryItem
C#
public dbiHistoryItem HistoryItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

RedoActionEventArgs Class
RedoActionEventArgs Members


%%PageItemTitle%%

ScheduleClickEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ScheduleClickEventArgs Class

Provides data for the ScheduleClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
C#
public class ScheduleClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.ScheduleClickEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ScheduleClickEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

ScheduleClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ScheduleClickEventArgs Class

"

The following tables list the members exposed by ScheduleClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ScheduleClickEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | MouseEvent | The MouseEvent arguments related to the click
public Property | Position | The position where the click occured.
Top

See Also

Reference

ScheduleClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ScheduleClickEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ScheduleClickEventArgs Class : ScheduleClickEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ScheduleClickEventArgs()
C#
public ScheduleClickEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%% $$Properties$$

ScheduleClickEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ScheduleClickEventArgs Class

"

For a list of all members of this type, see ScheduleClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | MouseEvent | The MouseEvent arguments related to the click
public Property | Position | The position where the click occured.
Top

See Also

Reference

ScheduleClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Button Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ScheduleClickEventArgs Class : Button Property

The MouseButton that performed the click.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As MouseButton

instance.Button = value

value = instance.Button
C#
public MouseButton Button {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

MouseEvent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ScheduleClickEventArgs Class : MouseEvent Property

The MouseEvent arguments related to the click

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As MouseButtonEventArgs

instance.MouseEvent = value

value = instance.MouseEvent
C#
public MouseButtonEventArgs MouseEvent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

Position Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ScheduleClickEventArgs Class : Position Property

The position where the click occured.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As Point

instance.Position = value

value = instance.Position
C#
public Point Position {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

ScheduleMouseMoveEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ScheduleMouseMoveEventArgs Class

Provides data for the ScheduleMouseMove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleMouseMoveEventArgs
C#
public class ScheduleMouseMoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.ScheduleMouseMoveEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ScheduleMouseMoveEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

ScheduleMouseMoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ScheduleMouseMoveEventArgs Class

"

The following tables list the members exposed by ScheduleMouseMoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ScheduleMouseMoveEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | MouseEvent | The MouseEvent arguments related to the mouse movement
public Property | Position | The current position of the cursor.
Top

See Also

Reference

ScheduleMouseMoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ScheduleMouseMoveEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ScheduleMouseMoveEventArgs Class : ScheduleMouseMoveEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ScheduleMouseMoveEventArgs()
C#
public ScheduleMouseMoveEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ScheduleMouseMoveEventArgs Class
ScheduleMouseMoveEventArgs Members


%%PageItemTitle%% $$Properties$$

ScheduleMouseMoveEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ScheduleMouseMoveEventArgs Class

"

For a list of all members of this type, see ScheduleMouseMoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | MouseEvent | The MouseEvent arguments related to the mouse movement
public Property | Position | The current position of the cursor.
Top

See Also

Reference

ScheduleMouseMoveEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

MouseEvent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ScheduleMouseMoveEventArgs Class : MouseEvent Property

The MouseEvent arguments related to the mouse movement

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleMouseMoveEventArgs
Dim value As MouseEventArgs

instance.MouseEvent = value

value = instance.MouseEvent
C#
public MouseEventArgs MouseEvent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ScheduleMouseMoveEventArgs Class
ScheduleMouseMoveEventArgs Members


%%PageItemTitle%%

Position Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ScheduleMouseMoveEventArgs Class : Position Property

The current position of the cursor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleMouseMoveEventArgs
Dim value As Point

instance.Position = value

value = instance.Position
C#
public Point Position {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ScheduleMouseMoveEventArgs Class
ScheduleMouseMoveEventArgs Members


%%PageItemTitle%%

TimeBarClickEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : TimeBarClickEventArgs Class

Provides data for the TimeBarClick Event

Object Model

TimeBarClickEventArgs ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
C#
public class TimeBarClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.TimeBarClickEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarClickEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : TimeBarClickEventArgs Class

"

The following tables list the members exposed by TimeBarClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarClickEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | Button | The MouseButton being clicked.
public Property | ListItem | The dbiListItem containing the time bar being clicked
public Property | MouseEvent | The MouseEvent arguments related to the click
public Property | TimeBarItem | The dbiTimeBarItem being clicked.
Top

See Also

Reference

TimeBarClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

TimeBarClickEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarClickEventArgs Class : TimeBarClickEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New TimeBarClickEventArgs()
C#
public TimeBarClickEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%% $$Properties$$

TimeBarClickEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : TimeBarClickEventArgs Class

"

For a list of all members of this type, see TimeBarClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | Button | The MouseButton being clicked.
public Property | ListItem | The dbiListItem containing the time bar being clicked
public Property | MouseEvent | The MouseEvent arguments related to the click
public Property | TimeBarItem | The dbiTimeBarItem being clicked.
Top

See Also

Reference

TimeBarClickEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarClickEventArgs Class : BarIndex Property

The zero-based index value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

Button Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarClickEventArgs Class : Button Property

The MouseButton being clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As MouseButton

instance.Button = value

value = instance.Button
C#
public MouseButton Button {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarClickEventArgs Class : ListItem Property

The dbiListItem containing the time bar being clicked

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

MouseEvent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarClickEventArgs Class : MouseEvent Property

The MouseEvent arguments related to the click

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As MouseButtonEventArgs

instance.MouseEvent = value

value = instance.MouseEvent
C#
public MouseButtonEventArgs MouseEvent {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarClickEventArgs Class : TimeBarItem Property

The dbiTimeBarItem being clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

TimeBarSizingEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : TimeBarSizingEventArgs Class

Provides data for the TimeBarSizing Event

Object Model

TimeBarSizingEventArgs ClassdbiListItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
C#
public class TimeBarSizingEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.TimeBarSizingEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarSizingEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarSizingEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : TimeBarSizingEventArgs Class

"

The following tables list the members exposed by TimeBarSizingEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarSizingEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | End | The ending date time value of the Timebar.
public Property | ListItem | The dbiListItem containing the time bar being sized.
public Property | Start | The starting date time value of the Timebar.
public Property | TimeBarItem | The dbiTimeBarItem being sized.
Top

See Also

Reference

TimeBarSizingEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

TimeBarSizingEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarSizingEventArgs Class : TimeBarSizingEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New TimeBarSizingEventArgs()
C#
public TimeBarSizingEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%% $$Properties$$

TimeBarSizingEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : TimeBarSizingEventArgs Class

"

For a list of all members of this type, see TimeBarSizingEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | End | The ending date time value of the Timebar.
public Property | ListItem | The dbiListItem containing the time bar being sized.
public Property | Start | The starting date time value of the Timebar.
public Property | TimeBarItem | The dbiTimeBarItem being sized.
Top

See Also

Reference

TimeBarSizingEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarSizingEventArgs Class : BarIndex Property

The zero-based index value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public int BarIndex {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarSizingEventArgs Class : End Property

The ending date time value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As Date

instance.End = value

value = instance.End
C#
public DateTime End {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarSizingEventArgs Class : ListItem Property

The dbiListItem containing the time bar being sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarSizingEventArgs Class : Start Property

The starting date time value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As Date

instance.Start = value

value = instance.Start
C#
public DateTime Start {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > TimeBarSizingEventArgs Class : TimeBarItem Property

The dbiTimeBarItem being sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

UndoActionEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UndoActionEventArgs Class

Provides data for the UndoAction Event

Object Model

UndoActionEventArgs ClassdbiHistoryItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UndoActionEventArgs
C#
public class UndoActionEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.UndoActionEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UndoActionEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

UndoActionEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UndoActionEventArgs Class

"

The following tables list the members exposed by UndoActionEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UndoActionEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | HistoryItem | Gets the history item for the UndoActionEvent.
Top

See Also

Reference

UndoActionEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

UndoActionEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UndoActionEventArgs Class : UndoActionEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UndoActionEventArgs()
C#
public UndoActionEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UndoActionEventArgs Class
UndoActionEventArgs Members


%%PageItemTitle%% $$Properties$$

UndoActionEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UndoActionEventArgs Class

"

For a list of all members of this type, see UndoActionEventArgs members.

"

Public Properties

 | Name | Description
public Property | HistoryItem | Gets the history item for the UndoActionEvent.
Top

See Also

Reference

UndoActionEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

HistoryItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UndoActionEventArgs Class : HistoryItem Property

Gets the history item for the UndoActionEvent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UndoActionEventArgs
Dim value As dbiHistoryItem

instance.HistoryItem = value

value = instance.HistoryItem
C#
public dbiHistoryItem HistoryItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UndoActionEventArgs Class
UndoActionEventArgs Members


%%PageItemTitle%%

UserDrawnBarAfterEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnBarAfterEventArgs Class

Provides data for the UserDrawnBarAfter Event

Object Model

UserDrawnBarAfterEventArgs ClassdbiListItem ClassdbiScheduleObject ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
C#
public class UserDrawnBarAfterEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.UserDrawnBarAfterEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarAfterEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnBarAfterEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnBarAfterEventArgs Class

"

The following tables list the members exposed by UserDrawnBarAfterEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnBarAfterEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarRect | Gets the rectangular region in the schedule representing the time bar.
public Property | Canvas | Gets the Canvas object the represent the schedule.
public Property | LineRect | Gets the rectangular region in the schedule representing the line item hosting the time bar.
public Property | ListItem | Gets the dbiListItem object representing the line being drawn.
public Property | Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
public Property | TimeBarItem | Gets the dbiTimeBarItem object representing the time bar being drawn.
Top

See Also

Reference

UserDrawnBarAfterEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

UserDrawnBarAfterEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarAfterEventArgs Class : UserDrawnBarAfterEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnBarAfterEventArgs()
C#
public UserDrawnBarAfterEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%% $$Properties$$

UserDrawnBarAfterEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnBarAfterEventArgs Class

"

For a list of all members of this type, see UserDrawnBarAfterEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarRect | Gets the rectangular region in the schedule representing the time bar.
public Property | Canvas | Gets the Canvas object the represent the schedule.
public Property | LineRect | Gets the rectangular region in the schedule representing the line item hosting the time bar.
public Property | ListItem | Gets the dbiListItem object representing the line being drawn.
public Property | Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
public Property | TimeBarItem | Gets the dbiTimeBarItem object representing the time bar being drawn.
Top

See Also

Reference

UserDrawnBarAfterEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BarRect Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarAfterEventArgs Class : BarRect Property

Gets the rectangular region in the schedule representing the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As Rect

instance.BarRect = value

value = instance.BarRect
C#
public Rect BarRect {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

Canvas Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarAfterEventArgs Class : Canvas Property

Gets the Canvas object the represent the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As Canvas

instance.Canvas = value

value = instance.Canvas
C#
public Canvas Canvas {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

LineRect Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarAfterEventArgs Class : LineRect Property

Gets the rectangular region in the schedule representing the line item hosting the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As Rect

instance.LineRect = value

value = instance.LineRect
C#
public Rect LineRect {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarAfterEventArgs Class : ListItem Property

Gets the dbiListItem object representing the line being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

Schedule Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarAfterEventArgs Class : Schedule Property

Gets the dbiScheduleObject object representing the schedule being drawn into.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As dbiScheduleObject

instance.Schedule = value

value = instance.Schedule
C#
public dbiScheduleObject Schedule {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarAfterEventArgs Class : TimeBarItem Property

Gets the dbiTimeBarItem object representing the time bar being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

UserDrawnBarBeforeEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnBarBeforeEventArgs Class

Provides data for the UserDrawnBarBefore Event

Object Model

UserDrawnBarBeforeEventArgs ClassdbiListItem ClassdbiScheduleObject ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarBeforeEventArgs
C#
public class UserDrawnBarBeforeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.UserDrawnBarBeforeEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnBarBeforeEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnBarBeforeEventArgs Class

"

The following tables list the members exposed by UserDrawnBarBeforeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnBarBeforeEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarRect | Gets the rectangular region in the schedule representing the time bar.
public Property | Canvas | Gets the Canvas object the represent the schedule.
public Property | LineRect | Gets the rectangular region in the schedule representing the line item hosting the time bar.
public Property | ListItem | Gets the dbiListItem object hosting the time bar being drawn.
public Property | PaintBar | Gets or sets whether the control should paint the time bar.
public Property | PaintText | Gets or sets whether the control should paint the text in the time bar.
public Property | Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
public Property | TimeBarItem | Gets the dbiTimeBarItem object representing the time bar being drawn.
Top

See Also

Reference

UserDrawnBarBeforeEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

UserDrawnBarBeforeEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarBeforeEventArgs Class : UserDrawnBarBeforeEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnBarBeforeEventArgs()
C#
public UserDrawnBarBeforeEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Class
UserDrawnBarBeforeEventArgs Members


%%PageItemTitle%% $$Properties$$

UserDrawnBarBeforeEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnBarBeforeEventArgs Class

"

For a list of all members of this type, see UserDrawnBarBeforeEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarRect | Gets the rectangular region in the schedule representing the time bar.
public Property | Canvas | Gets the Canvas object the represent the schedule.
public Property | LineRect | Gets the rectangular region in the schedule representing the line item hosting the time bar.
public Property | ListItem | Gets the dbiListItem object hosting the time bar being drawn.
public Property | PaintBar | Gets or sets whether the control should paint the time bar.
public Property | PaintText | Gets or sets whether the control should paint the text in the time bar.
public Property | Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
public Property | TimeBarItem | Gets the dbiTimeBarItem object representing the time bar being drawn.
Top

See Also

Reference

UserDrawnBarBeforeEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

BarRect Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarBeforeEventArgs Class : BarRect Property

Gets the rectangular region in the schedule representing the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarBeforeEventArgs
Dim value As Rect

instance.BarRect = value

value = instance.BarRect
C#
public Rect BarRect {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Class
UserDrawnBarBeforeEventArgs Members


%%PageItemTitle%%

Canvas Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarBeforeEventArgs Class : Canvas Property

Gets the Canvas object the represent the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarBeforeEventArgs
Dim value As Canvas

instance.Canvas = value

value = instance.Canvas
C#
public Canvas Canvas {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Class
UserDrawnBarBeforeEventArgs Members


%%PageItemTitle%%

LineRect Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarBeforeEventArgs Class : LineRect Property

Gets the rectangular region in the schedule representing the line item hosting the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarBeforeEventArgs
Dim value As Rect

instance.LineRect = value

value = instance.LineRect
C#
public Rect LineRect {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Class
UserDrawnBarBeforeEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarBeforeEventArgs Class : ListItem Property

Gets the dbiListItem object hosting the time bar being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarBeforeEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Class
UserDrawnBarBeforeEventArgs Members


%%PageItemTitle%%

PaintBar Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarBeforeEventArgs Class : PaintBar Property

Gets or sets whether the control should paint the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarBeforeEventArgs
Dim value As Boolean

instance.PaintBar = value

value = instance.PaintBar
C#
public bool PaintBar {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Class
UserDrawnBarBeforeEventArgs Members


%%PageItemTitle%%

PaintText Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarBeforeEventArgs Class : PaintText Property

Gets or sets whether the control should paint the text in the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarBeforeEventArgs
Dim value As Boolean

instance.PaintText = value

value = instance.PaintText
C#
public bool PaintText {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Class
UserDrawnBarBeforeEventArgs Members


%%PageItemTitle%%

Schedule Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarBeforeEventArgs Class : Schedule Property

Gets the dbiScheduleObject object representing the schedule being drawn into.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarBeforeEventArgs
Dim value As dbiScheduleObject

instance.Schedule = value

value = instance.Schedule
C#
public dbiScheduleObject Schedule {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Class
UserDrawnBarBeforeEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnBarBeforeEventArgs Class : TimeBarItem Property

Gets the dbiTimeBarItem object representing the time bar being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarBeforeEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnBarBeforeEventArgs Class
UserDrawnBarBeforeEventArgs Members


%%PageItemTitle%%

UserDrawnLineAfterEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnLineAfterEventArgs Class

Provides data for the UserDrawnLineAfter Event

Object Model

UserDrawnLineAfterEventArgs ClassdbiListItem ClassdbiScheduleObject Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineAfterEventArgs
C#
public class UserDrawnLineAfterEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.UserDrawnLineAfterEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineAfterEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnLineAfterEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnLineAfterEventArgs Class

"

The following tables list the members exposed by UserDrawnLineAfterEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnLineAfterEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Canvas | Gets the Canvas object the represent the schedule.
public Property | LineRect | Gets the rectangular region in the schedule representing the line item.
public Property | LineStart | Gets the starting DateTime value for the line.
public Property | ListItem | Gets the dbiListItem object representing the line being drawn.
public Property | Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
Top

See Also

Reference

UserDrawnLineAfterEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

UserDrawnLineAfterEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineAfterEventArgs Class : UserDrawnLineAfterEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnLineAfterEventArgs()
C#
public UserDrawnLineAfterEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineAfterEventArgs Class
UserDrawnLineAfterEventArgs Members


%%PageItemTitle%% $$Properties$$

UserDrawnLineAfterEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnLineAfterEventArgs Class

"

For a list of all members of this type, see UserDrawnLineAfterEventArgs members.

"

Public Properties

 | Name | Description
public Property | Canvas | Gets the Canvas object the represent the schedule.
public Property | LineRect | Gets the rectangular region in the schedule representing the line item.
public Property | LineStart | Gets the starting DateTime value for the line.
public Property | ListItem | Gets the dbiListItem object representing the line being drawn.
public Property | Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
Top

See Also

Reference

UserDrawnLineAfterEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Canvas Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineAfterEventArgs Class : Canvas Property

Gets the Canvas object the represent the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineAfterEventArgs
Dim value As Canvas

instance.Canvas = value

value = instance.Canvas
C#
public Canvas Canvas {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineAfterEventArgs Class
UserDrawnLineAfterEventArgs Members


%%PageItemTitle%%

LineRect Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineAfterEventArgs Class : LineRect Property

Gets the rectangular region in the schedule representing the line item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineAfterEventArgs
Dim value As Rect

instance.LineRect = value

value = instance.LineRect
C#
public Rect LineRect {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineAfterEventArgs Class
UserDrawnLineAfterEventArgs Members


%%PageItemTitle%%

LineStart Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineAfterEventArgs Class : LineStart Property

Gets the starting DateTime value for the line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineAfterEventArgs
Dim value As Date

instance.LineStart = value

value = instance.LineStart
C#
public DateTime LineStart {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineAfterEventArgs Class
UserDrawnLineAfterEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineAfterEventArgs Class : ListItem Property

Gets the dbiListItem object representing the line being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineAfterEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineAfterEventArgs Class
UserDrawnLineAfterEventArgs Members


%%PageItemTitle%%

Schedule Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineAfterEventArgs Class : Schedule Property

Gets the dbiScheduleObject object representing the schedule being drawn into.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineAfterEventArgs
Dim value As dbiScheduleObject

instance.Schedule = value

value = instance.Schedule
C#
public dbiScheduleObject Schedule {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineAfterEventArgs Class
UserDrawnLineAfterEventArgs Members


%%PageItemTitle%%

UserDrawnLineBeforeEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnLineBeforeEventArgs Class

Provides data for the UserDrawnLineBefore Event

Object Model

UserDrawnLineBeforeEventArgs ClassdbiListItem ClassdbiScheduleObject Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineBeforeEventArgs
C#
public class UserDrawnLineBeforeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.UserDrawnLineBeforeEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineBeforeEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnLineBeforeEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnLineBeforeEventArgs Class

"

The following tables list the members exposed by UserDrawnLineBeforeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnLineBeforeEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Canvas | Gets the Canvas object the represent the schedule.
public Property | LineRect | Gets the rectangular region in the schedule representing the line item.
public Property | LineStart | Gets the starting DateTime value for the line.
public Property | ListItem | Gets the dbiListItem object representing the line being drawn.
public Property | PaintLine | Gets or sets whether the control will paint the time bars on the list item.
public Property | Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
Top

See Also

Reference

UserDrawnLineBeforeEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

UserDrawnLineBeforeEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineBeforeEventArgs Class : UserDrawnLineBeforeEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnLineBeforeEventArgs()
C#
public UserDrawnLineBeforeEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineBeforeEventArgs Class
UserDrawnLineBeforeEventArgs Members


%%PageItemTitle%% $$Properties$$

UserDrawnLineBeforeEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : UserDrawnLineBeforeEventArgs Class

"

For a list of all members of this type, see UserDrawnLineBeforeEventArgs members.

"

Public Properties

 | Name | Description
public Property | Canvas | Gets the Canvas object the represent the schedule.
public Property | LineRect | Gets the rectangular region in the schedule representing the line item.
public Property | LineStart | Gets the starting DateTime value for the line.
public Property | ListItem | Gets the dbiListItem object representing the line being drawn.
public Property | PaintLine | Gets or sets whether the control will paint the time bars on the list item.
public Property | Schedule | Gets the dbiScheduleObject object representing the schedule being drawn into.
Top

See Also

Reference

UserDrawnLineBeforeEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

Canvas Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineBeforeEventArgs Class : Canvas Property

Gets the Canvas object the represent the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineBeforeEventArgs
Dim value As Canvas

instance.Canvas = value

value = instance.Canvas
C#
public Canvas Canvas {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineBeforeEventArgs Class
UserDrawnLineBeforeEventArgs Members


%%PageItemTitle%%

LineRect Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineBeforeEventArgs Class : LineRect Property

Gets the rectangular region in the schedule representing the line item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineBeforeEventArgs
Dim value As Rect

instance.LineRect = value

value = instance.LineRect
C#
public Rect LineRect {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineBeforeEventArgs Class
UserDrawnLineBeforeEventArgs Members


%%PageItemTitle%%

LineStart Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineBeforeEventArgs Class : LineStart Property

Gets the starting DateTime value for the line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineBeforeEventArgs
Dim value As Date

instance.LineStart = value

value = instance.LineStart
C#
public DateTime LineStart {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineBeforeEventArgs Class
UserDrawnLineBeforeEventArgs Members


%%PageItemTitle%%

ListItem Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineBeforeEventArgs Class : ListItem Property

Gets the dbiListItem object representing the line being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineBeforeEventArgs
Dim value As dbiListItem

instance.ListItem = value

value = instance.ListItem
C#
public dbiListItem ListItem {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineBeforeEventArgs Class
UserDrawnLineBeforeEventArgs Members


%%PageItemTitle%%

PaintLine Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineBeforeEventArgs Class : PaintLine Property

Gets or sets whether the control will paint the time bars on the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineBeforeEventArgs
Dim value As Boolean

instance.PaintLine = value

value = instance.PaintLine
C#
public bool PaintLine {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineBeforeEventArgs Class
UserDrawnLineBeforeEventArgs Members


%%PageItemTitle%%

Schedule Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > UserDrawnLineBeforeEventArgs Class : Schedule Property

Gets the dbiScheduleObject object representing the schedule being drawn into.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineBeforeEventArgs
Dim value As dbiScheduleObject

instance.Schedule = value

value = instance.Schedule
C#
public dbiScheduleObject Schedule {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

UserDrawnLineBeforeEventArgs Class
UserDrawnLineBeforeEventArgs Members


%%PageItemTitle%%

ValuePointEventArgs Class
See Also Members
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ValuePointEventArgs Class

Provides data for the ValuePoint Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
C#
public class ValuePointEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WpfControl.dbiSchedule.ValuePointEventArgs

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ValuePointEventArgs Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Members$$

ValuePointEventArgs Class Members
See Also Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ValuePointEventArgs Class

"

The following tables list the members exposed by ValuePointEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ValuePointEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | CurrentTime | The DateTime value of the major unit being drawn.
public Property | Text | The text to display in the ruler.
public Property | Value | The value of the major time unit.
Top

See Also

Reference

ValuePointEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

ValuePointEventArgs Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ValuePointEventArgs Class : ValuePointEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ValuePointEventArgs()
C#
public ValuePointEventArgs()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%% $$Properties$$

ValuePointEventArgs Class Properties
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : ValuePointEventArgs Class

"

For a list of all members of this type, see ValuePointEventArgs members.

"

Public Properties

 | Name | Description
public Property | CurrentTime | The DateTime value of the major unit being drawn.
public Property | Text | The text to display in the ruler.
public Property | Value | The value of the major time unit.
Top

See Also

Reference

ValuePointEventArgs Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

CurrentTime Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ValuePointEventArgs Class : CurrentTime Property

The DateTime value of the major unit being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As Date

instance.CurrentTime = value

value = instance.CurrentTime
C#
public DateTime CurrentTime {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ValuePointEventArgs Class : Text Property

The text to display in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

Value Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > ValuePointEventArgs Class : Value Property

The value of the major time unit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As Integer

instance.Value = value

value = instance.Value
C#
public int Value {get; set;}

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

dbiColumnItem.enumSortBy Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItem.enumSortBy Enumeration

Specifies the value type to perform a sort on

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem.enumSortBy
C#
public enum dbiColumnItem.enumSortBy : System.Enum

Members

Member | Description
DateTime | Sort will occur on the datetime value
Double | Sort will occur on the double value
None | No sort
Text | Sort will occur on the text value

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.dbiColumnItem.enumSortBy

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiHistoryItem.enumActionType Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiHistoryItem.enumActionType Enumeration

Specifies the type of Undo/Redo action added to the HistoryCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem.enumActionType
C#
public enum dbiHistoryItem.enumActionType : System.Enum

Members

Member | Description
Create | An new Timebar has been created. Undo - The Timebar will be removed. Redo - The Timebar will be re-created
Empty | Undo - No items in the collection. Redo - No items in the collection.
Link | A new link has been created. Undo - The new link will be removed. Redo - the removed link will be re-created.
Move | An existing Timebar has been moved. Undo - The Timebar will be moved back to the last location. Redo - The Timebar will be moved to the newer location.
Remove | An existing Timebar was deleted. Undo - The deleted Timebar will be re-added. Redo - The re-added Timebar will be removed.
Size | An existing Timebar has been sized. Undo - The Timebar will be resized to the last size. Redo - The resized Timebar will be resized to the newer size.
UnLink | An existing link is removed. Undo - The removed link will be re-added. Redo - The re-added link will be removed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.dbiHistoryItem.enumActionType

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiLinkItem.enumLinkDirection Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItem.enumLinkDirection Enumeration

Specifies the direction of a link.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem.enumLinkDirection
C#
public enum dbiLinkItem.enumLinkDirection : System.Enum

Members

Member | Description
EndToEnd | Links from the end of the Timebar from to the end of the Timebar to.
EndToStart | Links from the end of the Timebar from to the start of the Timebar to.
StartToEnd | Links from the start of the Timebar from to the end of the Timebar to.
StartToStart | Links from the start of the Timebar from to the start of the Timebar to.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.dbiLinkItem.enumLinkDirection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiLinkItem.enumLinkType Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItem.enumLinkType Enumeration

Specifies the type of link to display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem.enumLinkType
C#
public enum dbiLinkItem.enumLinkType : System.Enum

Members

Member | Description
Direct | A straight line between 2 Timebars with no arrows.
Reciprocal | A line with a right angle and arrows at the source and destination Timebars.
Standard | A line with a right angle and arrows at the destination Timebar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.dbiLinkItem.enumLinkType

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumAlignment Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumAlignment Enumeration

Specifies the horizontal alignment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumAlignment
C#
public enum enumAlignment : System.Enum

Members

Member | Description
Center | Centered
Default | default alignment
Left | Left justified
Right | Right justified

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumAlignment

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumBarTextAlign Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumBarTextAlign Enumeration

Specifies the position of the primary text of a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumBarTextAlign
C#
public enum enumBarTextAlign : System.Enum

Members

Member | Description
Center | The primary text will appear centered in the Timebar.
Left | The primary text will appear left justified in the Timebar.
LeftOfBar | The primary text will appear to the left of the Timebar.
Right | The primary text will appear right justified in the Timebar.
RightOfBar | The primary text will appear to the right of the Timebar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumBarTextAlign

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumBrushType Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumBrushType Enumeration

Specifies the pre-built Gradient brush style.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumBrushType
C#
public enum enumBrushType : System.Enum

Members

Member | Description
Diagonal | The primary color will appear in the bottom/right corner of the control, and gradually turn into the secondary color in the top/left corner of the object.
Horizontal | The primary color will appear on the left side of the control, and gradually turn into the secondary color on the right of the object.
HorizontalBump | The primary color will appear on the left and right sides of the control, and gradually turn into the secondary color towards the center of the object.
HorizontalEdge | The primary color meets the secondary color at a sharp horizontal point.
ReverseDiagonal | The primary color will appear in the bottom/left corner of the control, and gradually turn into the secondary color in the top/right corner of the control.
Vertical | The primary color will appear on the top of the control, and gradually turn into the secondary color on the bottom of the control.
VerticalBump | The primary color will appear on the top and bottom sides of the control, and gradually turn into the secondary color towards the center of the control.
VerticalEdge | The primary color meets the secondary color at a sharp vertical point.
VerticalEdge2 | A modified version of the VerticalEdge fill type that slightly adjusts the positioning of the colors to better fill larger areas.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumBrushType

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumControlStyle Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumControlStyle Enumeration

Preset styles and property values to assign to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumControlStyle
C#
public enum enumControlStyle : System.Enum

Members

Member | Description
LunaBlue | A Luna Blue inspired style
ZuneBlack | A Zune black inspired style

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumControlStyle

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumEditMode Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumEditMode Enumeration

Specifies the editmode for the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumEditMode
C#
public enum enumEditMode : System.Enum

Members

Member | Description
Edit | Enables the user to create/edit a Timebar.
Erase | Enables the user to remove a Timebar.
GuideLine | Enable the user to add, move and remove GuideLines in the main Schedule Area. Left clicking in the Schedule Area will add a GuideLine, left clicking and dragging a GuideLine will move it. If you wish to remove a GuideLine in this manner, drag the line off the Schedule either to the left of right. While in this mode, the BeforeGuideLineInsert Event, BeforeGuideLineMove Event, BeforeGuideLineRemove Event will fire before the GuideLine is manipulated while the AfterGuideLineInserted Event, AfterGuideLineMoved Event, AfterGuideLineRemoved Event will fire after the GuideLine has been added to the respective dbiScheduleObject.GuideLines collection.
Link | Enables the user to link 2 Timebars together.
Select | Enables the user to select a Timebar.
Split | Enable the user to split one Timebar into two Timebars, one retaining the original properties, while the second Timebar is a newly created Timebar.
Unlink | Enabled the user to unlink 2 Timebars.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumEditMode

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumFirstDayOfWeek Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumFirstDayOfWeek Enumeration

Specifies the first day of the week in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumFirstDayOfWeek
C#
public enum enumFirstDayOfWeek : System.Enum

Members

Member | Description
Friday | Weeks will begin on Friday.
Monday | Weeks will begin on Monday.
Saturday | Weeks will begin on Saturday.
Sunday | Weeks will begin on Sunday.
Thursday | Weeks will begin on Thursday.
Tuesday | Weeks will begin on Tuesday.
Wednesday | Weeks will begin on Tuesday.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumFirstDayOfWeek

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumGuideImagePosition Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumGuideImagePosition Enumeration

Specifies the ZOrder of the Guide Image in relation to the ruler text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumGuideImagePosition
C#
public enum enumGuideImagePosition : System.Enum

Members

Member | Description
Back | Behind ruler text.
Front | In front of ruler text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumGuideImagePosition

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumGuideLinePosition Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumGuideLinePosition Enumeration

Specifies the ZOrder of the GuideLine in relation to the TimeBars in the Schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumGuideLinePosition
C#
public enum enumGuideLinePosition : System.Enum

Members

Member | Description
Back | GuideLine appears behind the TimeBars
Front | GuideLine appears in front of the TimeBars

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumGuideLinePosition

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumImageAlignment Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumImageAlignment Enumeration

Specifies the horizontal alignment for the image

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumImageAlignment
C#
public enum enumImageAlignment : System.Enum

Members

Member | Description
Center | Centered
Left | Left justified
Right | Right justified

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumImageAlignment

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumLineArrowDirection Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumLineArrowDirection Enumeration

Specifies which direction on the schedule, the LineArrow is pointing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumLineArrowDirection
C#
public enum enumLineArrowDirection : System.Enum

Members

Member | Description
After | After the visible area
Before | Before the visible area
Null | Neither direction

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumLineArrowDirection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumLineArrowPosition Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumLineArrowPosition Enumeration

Specifies how the LineArrow is shown inside the Schedule, in relation to the other objects.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumLineArrowPosition
C#
public enum enumLineArrowPosition : System.Enum

Members

Member | Description
Back | LineArrows will appear behind other objects.
Front | LineArrows will appear in front of other objects.
None | No LineArrows will be displayed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumLineArrowPosition

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumLineArrowType Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumLineArrowType Enumeration

Specifices th type of LineArrows to display

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumLineArrowType
C#
public enum enumLineArrowType : System.Enum

Members

Member | Description
Image | LineArrows will display images based on the LineArrowBefore Property and LineArrowAfter Property respectively.
Solid | LineArrows will be drawn as solid arrows, using the LineArrowBackground Property to paint/color it.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumLineArrowType

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumListType Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumListType Enumeration

Determines how the ListItems will be drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumListType
C#
public enum enumListType : System.Enum

Members

Member | Description
ListView | Determines how the ListItems will be drawn.
TreeView | The ListItems will be drawn in a tree format.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumListType

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumMonthFormat Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumMonthFormat Enumeration

Specifies how the monthly ruler is displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumMonthFormat
C#
public enum enumMonthFormat : System.Enum

Members

Member | Description
Dates | The major time segments will display dates.
Weeks | The major time segments will display week numbers.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumMonthFormat

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumNotesPosition Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumNotesPosition Enumeration

Specifies how the ScheduleNotes are shown inside the Schedule, in relation to the other objects.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumNotesPosition
C#
public enum enumNotesPosition : System.Enum

Members

Member | Description
Back | ScheduleNotes are displayed behind other objects.
Front | ScheduleNotes are displayed in front of other objects.
None | No ScheduleNotes are displayed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumNotesPosition

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumRulerAlign Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumRulerAlign Enumeration

Specifies the alignment of the ruler text in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumRulerAlign
C#
public enum enumRulerAlign : System.Enum

Members

Member | Description
Center | Ruler text will be placed between major time divisions.
Left | Ruler text will be placed to the left of major time divisions.
Over | Ruler text will be placed over major time divisions.
Right | Ruler text will be placed to the right of major time divisions.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumRulerAlign

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumScheduleArea Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumScheduleArea Enumeration

Specifies a location inside the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumScheduleArea
C#
public enum enumScheduleArea : System.Enum

Members

Member | Description
Corner | The bottom right corner where the horizontal and vertical scrollbars meet.
List | The List area
ListScrollBar | The horizontal scrollbar for the list area
Map | The map area
None | nowhere in the control
Ruler | The ruler area
Schedule | The schedule area
ScheduleScrollBar | The horizontal scrollbar for the schedule area
Splitter | The splitter bar
VerticalScrollBar | The vertical scrollbar

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumScheduleArea

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumScheduleHeaderPosition Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumScheduleHeaderPosition Enumeration

Specifies the ZOrder of ListItems marked as headers, in the schedule portion of the control, in relation to the customareas and time lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumScheduleHeaderPosition
C#
public enum enumScheduleHeaderPosition : System.Enum

Members

Member | Description
Back | They will be drawn behind the other objects
Front | They will be drawn in front of the other objects

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumScheduleHeaderPosition

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumSnapToDivisions Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumSnapToDivisions Enumeration

Specifies how the mouse will snap to the divisions in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumSnapToDivisions
C#
public enum enumSnapToDivisions : System.Enum

Members

Member | Description
Absolute | Always snap to a division
Nearing | Snap when within DivisionDistance of a division.
None | Do not snap to the divisions.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumSnapToDivisions

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumSortDirection Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumSortDirection Enumeration

Determines the directions of the sort.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumSortDirection
C#
public enum enumSortDirection : System.Enum

Members

Member | Description
Ascending | Ascending order
Descending | Descending order

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumSortDirection

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumTimeType Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumTimeType Enumeration

Specifies the type of unit to display in the rules.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumTimeType
C#
public enum enumTimeType : System.Enum

Members

Member | Description
Days | Sets the ruler to display days of the month.
Hours | Sets the ruler to display hours.
Months | Sets the ruler to primarily group by months and subgroup by MonthFormat Property (weeks or dates).
Weeks | Sets the ruler to display weeks of the month.
Years | Sets the ruler to primarily group by years and subgroup by YearFormat Property (weeks, months or quarters).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumTimeType

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumTipsType Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumTipsType Enumeration

Specifies the type of tool tip to display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumTipsType
C#
public enum enumTipsType : System.Enum

Members

Member | Description
GuideLine | Tool tip is displayed when the mouse moves over a GuideLine
Move | Tool tip is displayed when the Timebar is moving.
Note | Tool tip is displayed when the mouse moves over a ScheduleNote
Over | Tool tip is displayed when the mouse moves over a Timebar.
Scroll | Tool tip is displayed when the thumb of the vertical scroll is in a down state.
Size | Tool tip is displayed when a Timebar is being sized.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumTipsType

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

enumYearFormat Enumeration
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : enumYearFormat Enumeration

Specifies how the yearly ruler is displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumYearFormat
C#
public enum enumYearFormat : System.Enum

Members

Member | Description
Months | The major time segments will display for each month.
Quarters | Each year will be displayed with 4 major time segments.
Weeks | The major time segments will display week numbers.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WpfControl.dbiSchedule.enumYearFormat

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterGuideLineInsertedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterGuideLineInsertedHandler Delegate

sender
e
Represents the method that handles the AfterGuideLineInserted Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterGuideLineInsertedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterGuideLineInsertedHandler(
   object sender,
   AfterGuideLineInsertedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterGuideLineInsertedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterGuideLineMovedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterGuideLineMovedHandler Delegate

sender
e
Represents the method that handles the AfterGuideLineMoved Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterGuideLineMovedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterGuideLineMovedHandler(
   object sender,
   AfterGuideLineMovedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterGuideLineMovedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterGuideLineRemovedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterGuideLineRemovedHandler Delegate

sender
e
Represents the method that handles the AfterGuideLineRemoved Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterGuideLineRemovedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterGuideLineRemovedHandler(
   object sender,
   AfterGuideLineRemovedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterGuideLineRemovedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterPrintHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterPrintHandler Delegate

sender
e
Represents the method that handles the AfterPrint Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterPrintHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterPrintHandler(
   object sender,
   AfterPrintEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterPrintHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterTimeBarInsertedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterTimeBarInsertedHandler Delegate

sender
e
Represents the method that handles the AfterTimeBarInserted Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterTimeBarInsertedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterTimeBarInsertedHandler(
   object sender,
   AfterTimeBarInsertedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterTimeBarInsertedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterTimeBarLinkedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterTimeBarLinkedHandler Delegate

sender
e
Represents the method that handles the AfterTimeBarLinked Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterTimeBarLinkedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterTimeBarLinkedHandler(
   object sender,
   AfterTimeBarLinkedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterTimeBarLinkedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterTimeBarMovedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterTimeBarMovedHandler Delegate

sender
e
Represents the method that handles the AfterTimeBarMoved Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterTimeBarMovedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterTimeBarMovedHandler(
   object sender,
   AfterTimeBarMovedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterTimeBarMovedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterTimeBarRemovedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterTimeBarRemovedHandler Delegate

sender
e
Represents the method that handles the AfterTimeBarRemoved Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterTimeBarRemovedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterTimeBarRemovedHandler(
   object sender,
   AfterTimeBarRemovedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterTimeBarRemovedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterTimeBarSizedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterTimeBarSizedHandler Delegate

sender
e
Represents the method that handles the AfterTimeBarSized Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterTimeBarSizedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterTimeBarSizedHandler(
   object sender,
   AfterTimeBarSizedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterTimeBarSizedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterTimeBarSplitHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterTimeBarSplitHandler Delegate

sender
e
Represents the method that handles the AfterTimeBarSplit Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterTimeBarSplitHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterTimeBarSplitHandler(
   object sender,
   AfterTimeBarSplitEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterTimeBarSplitHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.AfterTimeBarUnlinkedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.AfterTimeBarUnlinkedHandler Delegate

sender
e
Represents the method that handles the AfterTimeBarUnlinked Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.AfterTimeBarUnlinkedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.AfterTimeBarUnlinkedHandler(
   object sender,
   AfterTimeBarUnlinkedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.AfterTimeBarUnlinkedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeGuideLineInsertHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeGuideLineInsertHandler Delegate

sender
e
Represents the method that handles the BeforeGuideLineInsert Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeGuideLineInsertHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeGuideLineInsertHandler(
   object sender,
   BeforeGuideLineInsertEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeGuideLineInsertHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeGuideLineMoveHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeGuideLineMoveHandler Delegate

sender
e
Represents the method that handles the BeforeGuideLineMove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeGuideLineMoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeGuideLineMoveHandler(
   object sender,
   BeforeGuideLineMoveEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeGuideLineMoveHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeGuideLineRemoveHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeGuideLineRemoveHandler Delegate

sender
e
Represents the method that handles the BeforeGuideLineRemove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeGuideLineRemoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeGuideLineRemoveHandler(
   object sender,
   BeforeGuideLineRemoveEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeGuideLineRemoveHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforePrintHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforePrintHandler Delegate

sender
e
Represents the method that handles the BeforePrint Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforePrintHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforePrintHandler(
   object sender,
   BeforePrintEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforePrintHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeTimeBarInsertHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeTimeBarInsertHandler Delegate

sender
e
Represents the method that handles the BeforeTimeBarInsert Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeTimeBarInsertHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeTimeBarInsertHandler(
   object sender,
   BeforeTimeBarInsertEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeTimeBarInsertHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeTimeBarLinkHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeTimeBarLinkHandler Delegate

sender
e
Represents the method that handles the BeforeTimeBarLink Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeTimeBarLinkHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeTimeBarLinkHandler(
   object sender,
   BeforeTimeBarLinkEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeTimeBarLinkHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeTimeBarMoveHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeTimeBarMoveHandler Delegate

sender
e
Represents the method that handles the BeforeTimeBarMove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeTimeBarMoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeTimeBarMoveHandler(
   object sender,
   BeforeTimeBarMoveEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeTimeBarMoveHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeTimeBarRemoveHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeTimeBarRemoveHandler Delegate

sender
e
Represents the method that handles the BeforeTimeBarRemove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeTimeBarRemoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeTimeBarRemoveHandler(
   object sender,
   BeforeTimeBarRemoveEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeTimeBarRemoveHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeTimeBarSelectHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeTimeBarSelectHandler Delegate

sender
e
Represents the method that handles the BeforeTimeBarSelect Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeTimeBarSelectHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeTimeBarSelectHandler(
   object sender,
   BeforeTimeBarSelectEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeTimeBarSelectHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeTimeBarSizeHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeTimeBarSizeHandler Delegate

sender
e
Represents the method that handles the BeforeTimeBarSize Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeTimeBarSizeHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeTimeBarSizeHandler(
   object sender,
   BeforeTimeBarSizeEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeTimeBarSizeHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeTimeBarSplitHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeTimeBarSplitHandler Delegate

sender
e
Represents the method that handles the BeforeTimeBarSplit Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeTimeBarSplitHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeTimeBarSplitHandler(
   object sender,
   BeforeTimeBarSplitEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeTimeBarSplitHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeTimeBarUnlinkHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeTimeBarUnlinkHandler Delegate

sender
e
Represents the method that handles the BeforeTimeBarUnlink Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeTimeBarUnlinkHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeTimeBarUnlinkHandler(
   object sender,
   BeforeTimeBarUnlinkEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeTimeBarUnlinkHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.BeforeToolTipsHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.BeforeToolTipsHandler Delegate

sender
e
Represents the method that handles the BeforeToolTips Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.BeforeToolTipsHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.BeforeToolTipsHandler(
   object sender,
   BeforeToolTipsEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.BeforeToolTipsHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.ColumnHeaderClickHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.ColumnHeaderClickHandler Delegate

sender
e
Represents the method that handles the ColumnHeaderClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.ColumnHeaderClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.ColumnHeaderClickHandler(
   object sender,
   ColumnHeaderClickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.ColumnHeaderClickHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.ControlErrorHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.ControlErrorHandler Delegate

sender
e
Represents the method that handles the ControlError Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.ControlErrorHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.ControlErrorHandler(
   object sender,
   ControlErrorEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.ControlErrorHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.DeadZoneDropHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.DeadZoneDropHandler Delegate

sender
e
Represents the method that handles the DeadZoneDrop Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.DeadZoneDropHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.DeadZoneDropHandler(
   object sender,
   DeadZoneDropEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.DeadZoneDropHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.EditModeChangedHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.EditModeChangedHandler Delegate

sender
e
Represents the method that handles the EditModeChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.EditModeChangedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.EditModeChangedHandler(
   object sender,
   EditModeChangedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.EditModeChangedHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.FirstDrawHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.FirstDrawHandler Delegate

sender
e
Represents the method that handles the FirstDraw Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.FirstDrawHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.FirstDrawHandler(
   object sender,
   FirstDrawEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.FirstDrawHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.GuideLineClickHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.GuideLineClickHandler Delegate

sender
e
Represents the method that handles the GuideLineClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.GuideLineClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.GuideLineClickHandler(
   object sender,
   GuideLineClickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.GuideLineClickHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.GuideLineMoveHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.GuideLineMoveHandler Delegate

sender
e
Represents the method that handles the GuideLineMove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.GuideLineMoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.GuideLineMoveHandler(
   object sender,
   GuideLineMoveEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.GuideLineMoveHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.HistoryChangeHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.HistoryChangeHandler Delegate

sender
e
Represents the method that handles the HistoryChange Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.HistoryChangeHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.HistoryChangeHandler(
   object sender,
   HistoryChangeEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.HistoryChangeHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.ItemMouseOverHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.ItemMouseOverHandler Delegate

sender
e
Represents the method that handles the ItemMouseOver Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.ItemMouseOverHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.ItemMouseOverHandler(
   object sender,
   ItemMouseOverEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.ItemMouseOverHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.LineArrowClickHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.LineArrowClickHandler Delegate

sender
e
Represents the method that handles the LineArrowClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.LineArrowClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.LineArrowClickHandler(
   object sender,
   LineArrowClickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.LineArrowClickHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.LineArrowMouseOverHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.LineArrowMouseOverHandler Delegate

sender
e
Represents the method that handles the LineArrowMouseOver Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.LineArrowMouseOverHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.LineArrowMouseOverHandler(
   object sender,
   LineArrowMouseOverEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.LineArrowMouseOverHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.ListItemClickHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.ListItemClickHandler Delegate

sender
e
Represents the method that handles the ListItemClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.ListItemClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.ListItemClickHandler(
   object sender,
   ListItemClickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.ListItemClickHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.NoteClickHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.NoteClickHandler Delegate

sender
e
Represents the method that handles the NoteClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.NoteClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.NoteClickHandler(
   object sender,
   NoteClickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.NoteClickHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.PrintProgressHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.PrintProgressHandler Delegate

sender
e
Represents the method that handles the PrintProgress Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.PrintProgressHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.PrintProgressHandler(
   object sender,
   PrintProgressEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.PrintProgressHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.RedoActionHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.RedoActionHandler Delegate

sender
e
Represents the method that handles the RedoAction Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.RedoActionHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.RedoActionHandler(
   object sender,
   RedoActionEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.RedoActionHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.ScheduleClickHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.ScheduleClickHandler Delegate

sender
e
Represents the method that handles the ScheduleClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.ScheduleClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.ScheduleClickHandler(
   object sender,
   ScheduleClickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.ScheduleClickHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.ScheduleMouseMoveHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.ScheduleMouseMoveHandler Delegate

sender
e
Represents the method that handles the ScheduleMouseMove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.ScheduleMouseMoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.ScheduleMouseMoveHandler(
   object sender,
   ScheduleMouseMoveEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.ScheduleMouseMoveHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.TimeBarClickHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.TimeBarClickHandler Delegate

sender
e
Represents the method that handles the TimeBarClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.TimeBarClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.TimeBarClickHandler(
   object sender,
   TimeBarClickEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.TimeBarClickHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.TimeBarSizingHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.TimeBarSizingHandler Delegate

sender
e
Represents the method that handles the TimeBarSizing Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.TimeBarSizingHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.TimeBarSizingHandler(
   object sender,
   TimeBarSizingEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.TimeBarSizingHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.UndoActionHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.UndoActionHandler Delegate

sender
e
Represents the method that handles the UndoAction Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.UndoActionHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.UndoActionHandler(
   object sender,
   UndoActionEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.UndoActionHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.UserDrawnBarAfterHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.UserDrawnBarAfterHandler Delegate

sender
e
Represents the method that handles the UserDrawnBarAfter Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.UserDrawnBarAfterHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.UserDrawnBarAfterHandler(
   object sender,
   UserDrawnBarAfterEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.UserDrawnBarAfterHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.UserDrawnBarBeforeHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.UserDrawnBarBeforeHandler Delegate

sender
e
Represents the method that handles the UserDrawnBarBefore Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.UserDrawnBarBeforeHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.UserDrawnBarBeforeHandler(
   object sender,
   UserDrawnBarBeforeEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.UserDrawnBarBeforeHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.UserDrawnLineAfterHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.UserDrawnLineAfterHandler Delegate

sender
e
Represents the method that handles the UserDrawnLineAfter Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.UserDrawnLineAfterHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.UserDrawnLineAfterHandler(
   object sender,
   UserDrawnLineAfterEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.UserDrawnLineAfterHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.UserDrawnLineBeforeHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.UserDrawnLineBeforeHandler Delegate

sender
e
Represents the method that handles the UserDrawnLineBefore Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.UserDrawnLineBeforeHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.UserDrawnLineBeforeHandler(
   object sender,
   UserDrawnLineBeforeEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.UserDrawnLineBeforeHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleWPF.ValuePointHandler Delegate
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleWPF.ValuePointHandler Delegate

sender
e
Represents the method that handles the ValuePoint Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleWPF.ValuePointHandler(AddressOf HandlerMethod)
C#
public delegate void dbiScheduleWPF.ValuePointHandler(
   object sender,
   ValuePointEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF.ValuePointHandler Members
Dbi.WpfControl.dbiSchedule Namespace


%%ItemTitle%%

Setting the List Item's Height
Developing with dbiScheduleWPF > About the List Area > Setting the List Item's Height

Glossary Item Box

The height of the items in the list is determined by the ListFontSize property and the ItemHeightOffset property of the DbiScheduleWPF control. NOTE: The height of an individual dbiListItem cannot be discretely set. All items in the DbiScheduleWPF List are assigned the same height.

Example:

Change the height of the list items by 20 pixels.

[VB.NET]

Me.DbiScheduleWPF1.ItemHeightOffset = 20

[C#]

this.DbiScheduleWPF1.ItemHeightOffset = 20;

[XAML]

<my:DbiScheduleWPF ItemHeightOffset="0">


%%ItemTitle%%

Sorting Schedule Items
Developing with dbiScheduleWPF > About the List Area > Sorting Schedule Items

Glossary Item Box

The SortList method on the control allows the developer to programmatically sort the items in the list.

SortList(int nColumn, enumSortDirection enumSort)

The SortOnCase property can be used to notify the sort routine to include/exclude case sensitivity during a sort.

Sorting Data within the List

The DbiScheduleWPF List has built in support for the user to sort the list items by clicking on a column header. To implement sorting via a header click the developer must describe how the data will be sorted in the dbiColumnItem class and provide the actual value to be used in the sort to a dbiListCell object.

The dbiColumnItem class contains a property called SortBy. It is an enumerated property describing how the data will be sorted. The control supports Text, Doubles, and DateTime sorting (NOTE: Booleans can be described as a Double). If the SortBy property in the dbiColumnItem object has been specified, the developer must also provide the list with the actual value that the sort routine will use. The actual value to be used in the sort is described in the dbiListCell class. NOTE: The default value for the SortBy property is “None”.

If the sort has been set up as a "DateTime" or "Double" type, the sort routine will look at the data in these properties instead of the Text property. The advantage to this method is that the actual text in a cell can be set up anyway the developer may choose, while having the option of explicitly providing the value to be sorted independent of the presentation.

The following example illustrates how to set up a column to display dollar values and have them sort by their respective double values.

[C#]

//Create a column definition and add it to the control

Dbi.WPFControl.dbiSchedule.dbiColumnItem objColumn;

objColumn = new Dbi.WPFControl.dbiSchedule.dbiColumnItem("Price");

objColumn.SortBy = Dbi.WPFControl.dbiSchedule.dbiColumnItem.enumSortBy.Double;

objColumn.TextAlign = Dbi.WPFControl.dbiSchedule.enumAlignment.Right;

objColumn.ListTextAlign = Dbi.WPFControl.dbiSchedule.enumAlignment.Right;

DbiScheduleWPF1.Columns.Add(objColumn);

//Add some items to the list.

DbiScheduleWPF1.Items.Add("$873.99", 873.99);

DbiScheduleWPF1.Items.Add("$19.99", 19.99);

[VB.NET]

'Create a column definition and add it to the control

Dim objColumn As New Dbi.WPFControl.dbiSchedule.dbiColumnItem("Price")

objColumn.SortBy = Dbi.WPFControl.dbiSchedule.dbiColumnItem.enumSortBy.Double

objColumn.TextAlign = Dbi.WPFControl.dbiSchedule.enumAlignment.Right

objColumn.ListTextAlign = Dbi.WPFControl.dbiSchedule.enumAlignment.Right

DbiScheduleWPF1.Columns.Add(objColumn)

'Add some items to the list.

DbiScheduleWPF1.Items.Add("$873.99", 873.99)

DbiScheduleWPF1.Items.Add("$19.99", 19.99)

[XAML]

<my:DbiScheduleWPF.Columns>

     <my:dbiColumnItem Text="Price" SortBy="Double"  TextAlign="Right" ListTextAlign="Right"/>

</my:DbiScheduleWPF.Columns>

<my:DbiScheduleWPF.Items>

    <my:dbiListItem>

         <my:dbiListItem.Cells>

              <my:dbiListCell Text="$873.99" Double="873.99"/>

         </my:dbiListItem.Cells>

    </my:dbiListItem>

    <my:dbiListItem>

         <my:dbiListItem.Cells>

              <my:dbiListCell Text="$19.99" Double="19.99"/>

         </my:dbiListItem.Cells>

    </my:dbiListItem>

</my:DbiScheduleWPF.Items>

The following example illustrates how to set up a column to display Date Time values and have them sort on their date/time value instead of their textual presentation value.

[C#]

//Create a DateTime column definition and add it to the control

Dbi.WPFControl.dbiSchedule.dbiColumnItem objColumn;

objColumn = new Dbi.WPFControl.dbiSchedule.dbiColumnItem("Date");

objColumn.SortBy = Dbi.WPFControl.dbiSchedule.dbiColumnItem.enumSortBy.DateTime;

DbiScheduleWPF1.Columns.Add(objColumn);

//Add some items to the list.

DateTime dtDate = DateTime.Now;

dbiScheduleWPF1.Items.Add("January 5th, 2014", new DateTime(2014, 1, 5));

dbiScheduleWPF1.Items.Add("January 7th, 2014", new DateTime(2014, 1, 7));

[VB.NET]

'Create a column definition and add it to the control

Dim objColumn As New Dbi.WPFControl.dbiSchedule.dbiColumnItem("Date")

objColumn.SortBy = Dbi.WPFControl.dbiSchedule.dbiColumnItem.enumSortBy.DateTime

DbiScheduleWPF1.Columns.Add(objColumn)

'Add some items to the list.

DbiScheduleWPF1.Items.Add("January 5th, 2014", New DateTime(2014, 1, 5))

DbiScheduleWPF1.Items.Add("January 7th, 2014", New DateTime(2014, 1, 7))

[XAML]

<my:DbiScheduleWPF.Columns>

     <my:dbiColumnItem Text="Date" SortBy="DateTime"/>

</my:DbiScheduleWPF.Columns>

<my:DbiScheduleWPF.Items>

    <my:dbiListItem>

         <my:dbiListItem.Cells>

              <my:dbiListCell Text="January 5th, 2014" DateTime="01/05/2014"/>

         </my:dbiListItem.Cells>

    </my:dbiListItem>

    <my:dbiListItem>

         <my:dbiListItem.Cells>

              <my:dbiListCell Text="$19.99" Double="19.99"/>

              <my:dbiListCell Text="January 7th, 2014" DateTime="01/07/2014"/>

         </my:dbiListItem.Cells>

    </my:dbiListItem>

</my:DbiScheduleWPF.Items>


%%ItemTitle%%

Using the Schedule Items List Area
Developing with dbiScheduleWPF > About the List Area > Using the Schedule Items List Area

Glossary Item Box

Defining the Schedule Item Text and Data for Each Column

The DbiScheduleWPF List area is a collection of dbiListItem objects. The presentation of each dbiListItem object is governed by a collection of dbiListCell objects each of which corresponds to the columns that have been defined for the list area. The dbiListCell objects define the presentation of the data in the cell and the value of the data in the cell which is used for sorting.

The number of columns defined in the list area is at a minimum of 1, or a maximum of all defined dbiColumnItem objects assigned to it. The new method on the dbiListItem object is overloaded to allow the developer to create a new item with a default cell object to hold all the relevant data for the first column. To add further columns to the dbiListItem the developer must create and set the values for each subsequent cell object and add it to the dbiListItems collection of cell objects.

[C#]

//Create a new schedule list item.

Dbi.WPFControl.dbiSchedule.dbiListItem objItem;

//NOTE: The new automatically creates the first Cell object for the item.

objItem = new Dbi.WPFControl.dbiSchedule.dbiListItem("Column #1 Text");

//Create a new cell object.

Dbi.WPFControl.dbiSchedule.dbiListCell objCell;

objCell = new Dbi.WPFControl.dbiSchedule.dbiListCell("Column #2 Text");

//Add the new cell object to the list item's collection of cells.

objItem.Cells.Add(objCell);

//Add the item to the Schedule List.

DbiScheduleWPF1.Items.Add(objItem);

[VB.NET]

'NOTE: The new automatically creates the first Cell object for the item.

Dim objItem = New Dbi.WPFControl.dbiSchedule.dbiListItem("Column #1 Text")

'Create a new cell object.

Dim objCell = New Dbi.WPFControl.dbiSchedule.dbiListCell("Column #2 Text")

'Add the new cell object to the list item's collection of cells.

objItem.Cells.Add(objCell)

'Add the item to the Schedule List.

DbiScheduleWPF1.Items.Add(objItem)

[XAML]

<my:dbiListItem>

<my:dbiListItem.Cells>

<my:dbiListCell Text="Column #1 Text" />

<my:dbiListCell Text="Column #2 Text"/>

</my:dbiListItem.Cells>

</my:dbiListItem>

NOTE: The developer also has the option of using the overloaded Cells.Add method which creates the cell in line and adds it to the item’s cell collection.

[C#]

objItem.Cells.Add("Column #2 Text");

[VB.NET]

objItem.Cells.Add("Column #2 Text")

NOTE: If the developer wants a blank column in an item they must create an empty dbiListCell object for the blank column.

Column Header Data versus Column Format Data

The dbiColumn class is used to describe the items that make up the column header, some of the column properties for the list, and to describe how the column data will be sorted. To help determine what property paints what part of the list, all properties specific to the list area are prefixed with "List".

For example to create a list that has one column with white text on a black background in the column header and whose items have blue text on a red background …

[C#]

//Create a new column object.

Dbi.WPFControl.dbiSchedule.dbiColumnItem objColumn;

objColumn = new Dbi.WPFControl.dbiSchedule.dbiColumnItem();

//Set the appearance of a column header.

objColumn.Background = new SolidColorBrush(Colors.Black);

objColumn.Foreground = new SolidColorBrush(Colors.White);

objColumn.Text = "Column 1";

//Set the appearance of the list area below the column header.

objColumn.ListBackground = new SolidColorBrush(Colors.Red);

objColumn.ListForeground = new SolidColorBrush(Colors.Blue);

//Add the column to the Schedule List area.

DbiScheduleWPF1.Columns.Add(objColumn);

[VB.NET]

'Create a new column object.

Dim objColumn = New Dbi.WPFControl.dbiSchedule.dbiColumnItem()

'Set the appearance of a column header.

objColumn.Background = New SolidColorBrush(Colors.Black)

objColumn.Foreground = New SolidColorBrush(Colors.White)

objColumn.Text = "Column 1"

'Set the appearance of the list area below the column header.

objColumn.ListBackground = New SolidColorBrush(Colors.Red)

objColumn.ListForeground = New SolidColorBrush(Colors.Blue)

'Add the column to the Schedule List area.

DbiScheduleWPF1.Columns.Add(objColumn)

[XAML]

<my:DbiScheduleWPF Name="DbiScheduleWPF1" ListBackground="Red" ListForeground="Black">

<my:DbiScheduleWPF.Columns>

              <my:dbiColumnItem Text="Column 1" Background="Black" Foreground="White"/>

</my:DbiScheduleWPF.Columns>

</my:DbiScheduleWPF>

The dbiListCell Class

The dbiListCell class is used to store the text and sorting data for individual columns in the list. It can also be used to change the appearance of a cell itself such as the background and text colors. For example …

[C#]

objCell.Background = new SolidColorBrush(Colors.Green);

[VB.NET]

objCell.Background = New SolidColorBrush(Colors.Green)

[XAML]

<my:dbiListCell Text="Column #2 Text" Background="Green"/>

Adding Images to the Cells

The DbiScheduleWPF control supports images in both the cells in a list item and the cells in the column headers. All images assigned to these cells must first exist in the Images collection property of the control. Images are referenced through their index value in the Images collection on the control. To add images to the images collection in the DbiScheduleWPF control use the following pattern in the XAML …

<my:DbiScheduleWPF.Images>

<BitmapImage UriSource="/AssemblyName;component/Images/Image1.png"/>

<BitmapImage UriSource="/AssemblyName;component/Images/Image2.png"/>

<BitmapImage UriSource="/AssemblyName;component/Images/Image3.png"/>

<BitmapImage UriSource="/AssemblyName;component/Images/Image4.png"/>

</my:DbiScheduleWPF.Images>

Images in Column Headers: Once a column header object has been defined the developer sets the dbiColumnItem.ImageIndex property to the index of the desired image in the Images collection property.

[C#]

dbiColumnItem objColumn = new dbiColumnItem("Notes");

objColumn.ImageIndex = 3;

objColumn.ImageAlign = enumAlignment.Left;

DbiScheduleWPF1.Columns.Add(objColumn);

[VB.NET]

Dim objColumn As New Dbi.WPFControl.dbiSchedule.dbiColumnItem("Notes")

objColumn.ImageIndex = 3

objColumn.ImageAlign = Dbi.WPFControl.dbiSchedule.enumAlignment.Left

DbiScheduleWPF1.Columns.Add(objColumn)

[XAML]

<my:dbiColumnItem Text="Notes" ImageIndex="3" ImageAlign="Left" />

List Items: Any images assigned to a list item must be done so through the dbiListCell class. In the example below an image is added to the second column of the list item.

[C#]

Dbi.WPFControl.dbiSchedule.dbiListCell objCell = new Dbi.WPFControl.dbiSchedule.dbiListCell();

objCell.ImageIndex = 1;

objItem.Cells.Add(objCell);

Alternatively the image can be referenced in the new constructor of the dbiListCell object …

objItem.Cells.Add(new Dbi.WPFControl.dbiSchedule.dbiListCell (1));

[VB.NET]

Dim objCell = New Dbi.WPFControl.dbiSchedule.dbiListCell()

objCell.ImageIndex = 1

objItem.Cells.Add(objCell)

DbiScheduleWPF1.Items.Add(objItem)

Alternatively the image can be referenced in the new constructor of the dbiListCell object …

objItem.Cells.Add(New Dbi.WPFControl.dbiSchedule.dbiListCell(1))

[XAML]

<my:dbiListCell ImageIndex="1"/>

Image Alignment: For images in the list area, the default alignment is set by the controls ListImageAlign property. This can be overridden by the dbiColumnItem ListImageAlign property for the appropriate column. For images in the column headers, the default alignment is centered, but this can be overridden by the dbiColumnItem ImageAlign property for the column.

Coloring the List Area

The AltListEvenBackground and AltListOddBackground properties for alternating line brushes can also be used to set the colors in the list area.


%%ItemTitle%%

Schedules
Developing with dbiScheduleWPF > About the Schedule Area > Schedules

Glossary Item Box

The first step in presenting a schedule in the DbiScheduleWPF control is to create a schedule object and add it to the DbiScheduleWPF control's Schedules collection. NOTE: A schedule must be created and displayed before any time bars can be rendered or created. A schedule is an instance of the dbiScheduleObject class and is stored in the Schedules collection of the DbiScheduleWPF control. The DbiScheduleWPF control is designed to render one schedule object at a time. Other schedule objects can be made active using the ActiveSchedule property on the DbiScheduleWPF control.

A schedule object encapsulates two areas; the top section or ruler that displays the time line for the schedule, and the scheduling area that presents the interactive surface in which time bars, links, and guidelines are created, modified, and deleted.

Defining the Time Period for a Schedule

The dbiScheduleWPF control is capable of scheduling time bars in increments of minutes to months, based on the TimeType property of the dbiScheduleObject. The duration of time presented by a dbiScheduleObject is defined by its Start and End DateTime values. The width of the schedule is determined by the TimeType property and the TimeDistance property relative to the start and end of the schedule.

For example: If a schedule starts on a Monday at 8:00 am and goes until the following Friday at 8:00 pm the start of the dbiScheduleObject would be set to Monday's date at 8:00 am and the end of the schedule would be set to Friday's date at 8:00 pm. If the TimeType of the dbiScheduleObject was set to hours and TimeDistance set to 6, each hour in the day would require 6 pixels. The total width of the Schedule would be 6 * the number of hours between 8:00 am Monday and 8:00 pm Friday. NOTE: The larger the value for the TimeDistance the wider the schedule becomes as a whole.

The Ruler

The ruler defines the time line for the DbiScheduleWPF object. The ruler is displayed in the top right hand area of the control.

By default, the ruler is split horizontally in two. The top half of the ruler displays the date of the time line in the visible area at the bottom of the ruler. NOTE: As the schedule is horizontally scrolled, the date shown in the top of the ruler reflects the day as at the point where the time line touches the splitter bar (the bar that separates the list area from the schedule area). The format of the date displayed in the top half of the ruler is defined by the DateFormat property of the dbiScheduleObject class.

Using the RulerSplit property of the dbiScheduleObject class, the developer can optionally remove the top half of the ruler (RulerSplit = False).

In addition to the split ruler option, the developer may also replace the text in the top half of the ruler with a custom text string using the RulerTitle property of the dbiScheduleObject class.

The time values placed in the bottom half of the ruler are determined by the TimeType property of the dbiScheduleObject class. Valid time types are; Hours, Days, Weeks, Months, or Years. The distance between each major time value is determined by the TimeDistance property of the main control. (See Setting up Different Views for additional details).

Customizing the Time Values

Just before each time value is drawn, the ValuePoint event will be fired. In the ValuePoint event the “e” event arguments passed includes a Text property that can be used by the developer to change the default text for the time segment being drawn. For instance, if the dbiScheduleObject was set up with a TimeType of Years with a Year format of Quarters, the text describing each time segment would simply be a number between 1 and 4.

The developer could then test for this number inside the ValuePoint event and change the text for the ruler from the quarter number to the appropriate season.

For Example:

[VB.NET]

Private Sub DbiScheduleWPF1_ValuePoint(sender As System.Object, e As Dbi.WPFControl.dbiSchedule.ValuePointEventArgs) Handles DbiScheduleWPF1.ValuePoint

If Me.DbiScheduleWPF1.Schedules(0).TimeType = _ Dbi.WPFControl.dbiSchedule.enumTimeType.Years Then

If Me.DbiScheduleWPF1.Schedules(0).YearFormat = _ Dbi.WPFControl.dbiSchedule.enumYearFormat.Quarters Then

Select Case e.Value

Case 1

                        e.Text = "Winter"

                    Case 2

                        e.Text = "Spring"

                    Case 3

                        e.Text = "Summer"

                    Case 4

                        e.Text = "Fall"

End Select

End If

End If

End Sub

[C#]

private void DbiScheduleWPF1_ValuePoint(object sender, Dbi.WPFControl.dbiSchedule.ValuePointEventArgs e)

{

if (this.DbiScheduleWPF1.Schedules[0].TimeType == Dbi.WPFControl.dbiSchedule.enumTimeType.Years)

    {

if (this.DbiScheduleWPF1.Schedules[0].YearFormat == Dbi.WPFControl.dbiSchedule.enumYearFormat.Quarters)

        {

            switch (e.Value)

            {

                case 1:

                    e.Text = "Winter";

                    break;

                case 2:

                    e.Text = "Spring";

                    break;

                case 3:

                    e.Text = "Summer";

                    break;

                case 4:

                    e.Text = "Fall";

                    break;

            }

        }

    }

}


%%ItemTitle%%

Coloring the Background of the Schedule
Developing with dbiScheduleWPF > About the Schedule Area > Coloring the Background of the Schedule

Glossary Item Box

The background of a schedule object is painted using the dbiScheduleObject’s Background property. If that property is null, the background will be painted with the DbiScheduleWPF control’s ScheduleBackground property...

The developer can also use the AltEvenBackground and AltOddBackground properties from the dbiScheduleObject class for alternating line brushes.


%%ItemTitle%%

The List Guide
Developing with dbiScheduleWPF > About the Schedule Area > The List Guide

Glossary Item Box

A list guide is a replicated image of the first column in the list area of the control that is drawn in the schedule area of the control. Its purpose is to assist the user in determining where a time bar is being created or moved when working in the right hand side of the schedule area. The list guide will only appear when a time bar is being created or moved, and will disappear when that action completes.

The list guide can appear any time a time bar is created or moved, or it can be made to only appear if the mouse pointer is a specified distance from the scroll bar (ListGuideDistance property).


%%ItemTitle%%

An Overview of the Time Bar Object
Developing with dbiScheduleWPF > About Time Bars > An Overview of the Time Bar Object

Glossary Item Box

A time bar represents a period of time within a schedule item in the DbiScheduleWPF control. A time bar is represented in the control by the dbiTimeBarItem class. Time bars are stored in the TimeBars collection found in the dbiListItem class.

Text

A time bar has a visible text string which is stored in the TimeBar.Text property of the dbiTimeBarItem class. This text can be aligned within the bar, or it can be aligned outside of the bar to the right or left. The time bar text font can be changed through the control's various "TimeBarFont" prefixed properties, and the text of all time bars in the control can be set to wrap within a bar using the DbiScheduleWPF control's TimeBarTextWrap property.

Bar Images

Images can be assigned to the front and back of a time bar by setting the StartImage and EndImage properties of the dbiTimeBarItem object respectively.

A time bar using the same image for the start and end from the collection of custom icons built into the control

Additional Features

Set the DisplayTimeBarDates property of the dbiScheduleObject class to True to display the starting and ending days of a time bar at its start and end.

A time bar with starting and ending dates present in the bar.

To insure a time bar's text is always visible for time bars not fully visible at the front of the control set the DbiScheduleWPF control's TextIntoView property to True. When a time bar is scrolled or moved to the front of the schedule area, the text will moved to the right of the bar to display as much of the text as possible in the portion of the time bar visible in the control.

Without TextIntoView set to true.

With TextIntoView set to True. As the Scrollbar on the schedule area moves to the right the Text will move inside the time bar when it hits the splitter bar between the schedule object and the list area.


%%ItemTitle%%

Creating Time Bars
Developing with dbiScheduleWPF > About Time Bars > Creating Time Bars

Glossary Item Box

All time bars within the DbiScheduleWPF control are based upon the dbiTimeBarItem class. These time bars are then stored in the TimeBars collection of the appropriate dbiListItem object (the resource being scheduled). Before adding time bars to a schedule the item to which the time bar belongs must first be created. Time bars can be added programmatically through code or interactively with the control (using the mouse - left clicking and dragging horizontally, or via drag and drop.

Example:

Add a time bar to the first item in the list.

[VB.NET]

Dim dtStart = New System.DateTime(2014, 1, 1, 4, 0, 0)

Dim dtEnd = New System.DateTime(2014, 1, 1, 8, 0, 0)

'Create a new time bar

Dim dbiBar = New Dbi.WPFControl.dbiSchedule.dbiTimeBarItem(dtStart, dtEnd, "My Time Bar")

'Add the new time bar to the first item in the list

DbiScheduleWPF1.Items(0).TimeBars.Add(dbiBar)

[C#]

Dbi.WPFControl.dbiSchedule.dbiTimeBarItem dbiBar;

System.DateTime dtStart;

System.DateTime dtEnd;

dtStart = new System.DateTime(2014,01,01,4,0,0);

dtEnd = new System.DateTime(2014, 01, 01, 8, 0, 0);

//Create a new time bar

dbiBar = new Dbi.WPFControl.dbiSchedule.dbiTimeBarItem(dtStart, dtEnd, "My Time Bar");

//Add the new time bar to the first item in the list

DbiScheduleWPF1.Items[0].TimeBars.Add(dbiBar);

Entering an Appointment Interactively

A time bar can be entered directly into a schedule through mouse interaction. To create a time bar by clicking and dragging, the EditMode property of the DbiScheduleWPF control must be set to Edit (cursor is presented as a pencil). Using the mouse, left-click on one of the items in the schedule area and holding the button down drag the mouse horizontally to the left or right to create a new time bar. When the button is released the time bar is created.

Schedule is in edit mode

Left mouse button down

Horizontal Drag

Left mouse up … time bar complete.

For more information on Edit mode please see the section on Schedule Edit Modes .


%%ItemTitle%%

Styling the Time Bar
Developing with dbiScheduleWPF > About Time Bars > Styling the Time Bar

Glossary Item Box

By default, a time bar is 10 pixels less in height than the height of its host list item (5 pixels from the top and 5 from the bottom) and is vertically centered within the host item. However the actual height of a time bar can be set using the “Height” property of the dbiTimeBar class. NOTE: A Height value greater than 0 will cause the time bar to be drawn with this height instead of the calculated height based on the height of the host list item. The time bar's color is determined by the TimeBarBackground property of the main control, and it initially contains no text and no images on either side of the bar.

Time Bar Images

It is also possible to add images to each end of a time bar. To set images on a time bar use the StartImage and EndImage properties of the dbiTimeBar class.

A time bar using the built in diamond image.

Example:

Create a time bar using custom images in the DbiScheduleWPF control's images collection …

[VB.NET]

Dim dbiBar = New Dbi.WPFControl.dbiSchedule.dbiTimeBarItem() 'Create a new time bar

'Set its start image to the first image in the Images collection on the DbiScheduleWPF control

dbiBar.StartImage = 1

'Set the end image to the second image in the Images collection on the DbiScheduleWPF control

dbiBar.EndImage = 2

[C#]

//Create a new time bar

dbiBar = new Dbi.WPFControl.dbiSchedule.dbiTimeBarItem(dtStart,dtEnd);

//Set its start image to the first image in the Images collection on the DbiScheduleWPF control

dbiBar.StartImage = 1;

//Set the end image to the second image in the Images collection on the DbiScheduleWPF control

dbiBar.EndImage = 2;

[XAML]

<my:dbiTimeBarItem StartImage="1" EndImage="2"/>

NOTE: The images used in the above code are referenced through the Images collection of the DbiScheduleWPF control.

The DbiScheduleWPF control contains 15 stock icons. The stock icons can be displayed by assigning the negative numbers 2 to 16 to the StartImage and EndImage properties of the dbiTimeBar class.

Example:

Create a time bar style using stock images stored in the DbiScheduleWPF control

[VB.NET]

Dim dbiBar = New Dbi.WPFControl.dbiSchedule.dbiTimeBarItem() 'Create a new time bar

'Set its start image to the white triangle up stock image in the DbiScheduleWPF control

dbiBar.StartImage = -11

'Set the end image to the white triangle down stock image in the DbiScheduleWPF control

dbiBar.EndImage = -6

[C#]

//Create a new time bar

dbiBar = new Dbi.WPFControl.dbiSchedule.dbiTimeBarItem(dtStart,dtEnd);

//'Set its start image to the white triangle up stock image in the DbiScheduleWPF control

dbiBar.StartImage = -11;

// 'Set the end image to the white triangle down stock image in the DbiScheduleWPF control

dbiBar.EndImage = -6;

[XAML]

<my:dbiTimeBarItem StartImage="-11" EndImage="-6"/>

The first five stock icons are triangles pointing down. The next five are triangles pointing up and the final five stock icons are diamonds. The stock icons come in the following colors ... blue, aqua, red, black, and white. The image below illustrates the different images. NOTE: A negative number is required to use a stock image.

The EndImageOffset and StartImageOffset properties of the dbiTimeBar class are used to help position an image on the start/end of a bar. The developer may be required to experiment with these properties to achieve a particular style.

Colors and Priorities

Any color values defined in a time bar will take priority over any other colors assigned to a time bar. Color values from a time bar will be ignored if the colors are defined as Empty (Null). The same can be said about other properties in the dbiTimeBar class. The order in which the control uses the properties to describe a time bar are as follows:

dbiTimeBarItem -> dbiSchedule

Milestones

A milestone is a special type of bar style. A bar style is defined as a milestone by assigning a True value to the Milestone property of the dbiTimeBar class. Milestones represent a certain place in time, therefore the starting and ending dates and times for a milestone are identical.

NOTE: Time bars marked as milestones cannot be re-sized. They can only be moved.

NOTE: A milestone bar indicates that the bar itself will be very thin (with respect to width). It will be too thin to place text or color into it.

NOTE: By default, milestone bars will have any text assigned to it displayed to the right of the bar.

Additional Properties

Vertical Offset

By default, the DbiScheduleWPF control attempts to place time bars in the vertical center of their host list item. This position can be changed using the VerticalOffset property of the dbiTimeBar class. However, it should be noted to take care when using this property to make sure the time bar remains inside the host list item. If the VerticalOffset value causes the time bar to be drawn outside of the boundaries of the List Item in which it resides there is a chance that it may be painted over by routines painting the other list items.

Rounded Corners

The corners of the time bars can be set using the controls TimeBarRadius property. This single property changes the X and Y setting for all corners of the time bar equally.

Time Bar Shadows

The developer can apply a shadow effect to the time bars using the DbiScheduleWPF control’s TimeBarShadows, TimeBarShadowColor, and TimeBarShadowOpacity properties.


%%ItemTitle%%

Moving Time Bars Vertically and Horizontally
Developing with dbiScheduleWPF > About Time Bars > Moving Time Bars Vertically and Horizontally

Glossary Item Box

The AllowVertMoves property of the DbiScheduleWPF control defaults to true, allowing users to drag time bars between items in the schedule. To disable vertical moving of time bars, set the AllowVertMoves property to false. Similarly, the AllowHorzMoves property of the DbiScheduleWPF control allows the developer to allow/disable the horizontal movement of time bars in the schedule.

NOTE: The DbiScheduleWPF control events BeforeTimeBarMove and AfterTimeBarMoved that fire in response to time bar moves pass in the ScheduleItemFrom schedule item object and ScheduleItemTo schedule item object to assist the developer in assessing the move request. The events also pass in a Vertical parameter that describes if the time bar move is between items.


%%ItemTitle%%

Displaying Time Bar Conflicts
Developing with dbiScheduleWPF > About Time Bars > Displaying Time Bar Conflicts

Glossary Item Box

By default there are no visual cues that two or more time bars overlap in a given area of a schedule item.

Time bars overlapping without any visual cue.

In the case where time bars overlap the developer may want to provide a visual cue to the user by displaying the overlap. The DbiScheduleWPF control supports the display of overlapping time bars through the OverlapSpan , OverlapStroke , and OverlapStrokeThickness properties of the DbiScheduleWPF class. If the OverlapStrokeThickness property is set to a value greater than 0, any time bars from the same list item will have their horizontal lines drawn differently at the location where the overlap occurs.

In the example above, the horizontal lines where the bars overlap become thicker.

The OverlapSpan property of the DbiScheduleWPF control defines the tolerance for when two time bars are considered to be in conflict. By default, the Overlap span property is set to zero, meaning that two time bars must physically be in contact before they are considered to be in conflict. NOTE: When one time bar starts at the same time as another time bar ends they are NOT considered to be in conflict. Setting the OverlapSpan property to a timespan value greater than 0 would cause the previous case to generate a conflict and consequently draw an overlap if the OverlapStrokeThickness value was greater than 0.

Example:

Set the DbiScheduleWPF control to display time bar conflicts when time bars are within 5 minutes of each other.

[VB.NET]

Dim timespanOverlap As New TimeSpan

timespanOverlap = TimeSpan.FromMinutes(5)  'Set the TimeSpanOverlap value to five minutes

Me.DbiScheduleWPF1.OverlapSpan = timespanOverlap 'Set the OverlapSpan to the timespan above

DbiScheduleWPF1.OverlapStrokeThickness = 2  'Set the schedule to display overlapping time bars

 [C#]

System.TimeSpan timespanOverlap;

timespanOverlap = TimeSpan.FromMinutes(5); //Set the TimeSpanOverlap value to five minutes

DbiScheduleWPF1.OverlapSpan = timespanOverlap; //Set the OverlapSpan to the timespan above

DbiScheduleWPF1.OverlapStrokeThickness =2; //Set the schedule to display overlapping time bars

[XAML]
<my:DbiScheduleWPF Name="DbiScheduleWPF1" OverlapStrokeThickness="2" OverlapSpan="00:05">


%%ItemTitle%%

Miscellaneous Features
Developing with dbiScheduleWPF > About Time Bars > Miscellaneous Features

Glossary Item Box

Determining if a Time Bar Drop is Valid

When time bars are created or moved through code (not through user interaction with the control), the concept of "Dead Zones" is not considered by the control, i.e. time bars can be created and moved into Dead Zones through code. The DbiScheduleWPF control's InDeadZone method can be used to assist the developer in determining if a time bar addition or move will interact with a Dead Zone(s) before initiating the action.

Determining THE Schedule Item a Time Bar Belongs To

The ListItemParent method of the DbiScheduleWPF control can be used to determine the schedule item to which a time bar belongs. The method returns the schedule item object of a given time bar. NOTE: If no schedule item is found, the method returns a null value.

Example:

Find the schedule item to which a specified time bar belongs.

[VB.NET]

Dim objItem As Dbi.WPFControl.dbiSchedule.dbiListItem

Dim objBar As Dbi.WPFControl.dbiSchedule.dbiTimeBarItem

objBar = GetTimeBar() 'Some custom sub routine that returns a time bar object

'Pass the time bar object into the ListItemParent method

objItem = DbiScheduleWPF1.ListItemParent(objBar)

If (Not (objItem Is Nothing)) Then

'If the schedule item returned is not null, we found the parent list item for the selected time bar.

End If

[C#]

Dbi.WPFControl.dbiSchedule.dbiListItem objItem;

Dbi.WPFControl.dbiSchedule.dbiTimeBarItem objBar;

objBar = GetTimeBar(); //Some custom sub routine that returns a time bar object

//Pass the time bar object into the ListItemParent method

objItem = DbiScheduleWPF1.ListItemParent(objBar);

if (objItem == null)

{

//If the schedule item returned is not null, we found the parent list item for the selected time bar.

}

Time Bar Order

Time bars are painted based upon their order in the collection. Therefore the first time bar in the collection is painted first; the second is painted second, and so on. To change the order in which time bars are painted, i.e. which time bar is painted on top of another time bar, use the DbiScheduleWPF control's BarToBack and BarToFront methods.

Date Formatting and Internationalization

The date and time formatting in the DbiScheduleWPF control defaults to the regional settings on the computer on which the control is being run. To discretely change a date or time format use the appropriate date or time format property in the control or the control's objects (such as the ScheduleObject's DateFormat and TimeFormat properties). NOTE: These properties accept a string that is based upon the DateTimeFormatInfo class from the .NET Framework Class Library. Please refer the MSDN documentation for a complete reference as to how to create a format string using the DateTimeFormatInfo class


%%ItemTitle%%

Creating a Printed Report
Developing with dbiScheduleWPF > Creating Output > Creating a Printed Report

Glossary Item Box

The DbiScheduleWPF control is capable of producing a printed report using the built-in Print method. The method creates a report containing all of the items (and their time bars) in the control as a whole.

Example: Send the entire contents of the control to a printer selected by the user.

[VB.NET]

'Send the report to the printer
Me.DbiScheduleWPF1.Print()

[C#]

//Send the report to the printer
this.DbiScheduleWPF1.Print();

Prior to sending the output to the Print method the developer can customize the report using the following properties:

Property | Type | Description
PrintFontFamily | FontFamily | Determines the Font Family for the text in the sub-title and footer of the printed report.
PrintFontSize | Double | Determines the size of the font for the text in the sub title and footer of the printed report.
PrintFontStyle | FontStyle | Determines the style of the font (Italic or Normal) for the text in the sub title and footer of the printed report.
PrintFontWeight | FontWeight | Determines the weight of the font for the text in the sub title and footer of the printed report.
PrintFooterAlign | TextAlignment | Determines the alignment of the text in the footer of the printed report.
PrintFooterMargin | Thickness | Determines the margin to place around the text in the footer of the printed report.
PrintListAlways | Boolean | When set to True prints the list area on each horizontal page in the printed report. When set to False, prints the list only on the first horizontal page.
PrintListWidth | Integer | Determines the width of the list area in pixels for a printed report.
PrintPageText | String | Determines text describing the page number in the footer.
PrintSubTitle | String | Determines the sub-title for the printed report.
PrintSubTitleMargin | Thickness | Determines the margin to place around the text in the Subtitle of the printed report.
PrintTimeDistance | Integer | Determines the distance in pixels between the major time segments in a printed report.
PrintTitle | String | Determines the title for the printed report.
PrintTitleAlign | TextAlignment | Determines the alignment for the print title.
PrintTitleFontFamily | FontFamily | Determines the Font Family for the text in the title of the printed report.
PrintTitleFontSize | Double | Determines the Font Size for the text in the title of the printed report.
PrintTitleFontStyle | FontStyle | Determines the style of the font (Italic or Normal) for the text in the title of the printed report.
PrintTitleFontWeight | FontWeight | Determines the weight of the font for the text in the title of the printed report.
PrintTitleMargin | Thickness | Determines the margin to place around the text in the title of the printed report.

The dbiScheduleWPF control provides three events to assist the developer in customizing the print functionality;

BeforePrint – Fires just before the print job begins. The “e” argument passed to the event contains a Pages property that indicates the total number of pages to be printed.

AfterPrint – Fires when the print job is complete.

PrintProgress – Fires once for each page just before the page is to be printed. The “e” argument passes the number of the page to be printed and a CancelPrint property, which if set to true cancels the print job.


%%ItemTitle%%

Databinding
Developing with dbiScheduleWPF > Data Binding > Databinding

Glossary Item Box

INTRODUCTION

The DbiScheduleWPF control provides a presentation and interaction surface through which the scheduling of resources can be created and maintained. The control encapsulates three basic objects: Schedules (time line over which the resources are being managed), Items (the resources being scheduled), and Time Bars (the periods of time for which the resources are being utilized).

A simple example of a scheduling application would be the management of meeting rooms. In this scenario the Schedules would represent the periods of time for which the meeting room schedules would be published, for example the days of the week or weeks of the month. The Items in the Schedule would represent the rooms being scheduled for meetings, and the Scheduled Time (Time Bars) would represent the Meetings being held in the specified meeting room. The database structure to store the data for the application would look something like...

The DbiScheduleWPF control allows the developer to create and maintain a close binding to the database objects represented in its collections. In addition to the traditional database connectivity provided through the WPF framework, a third option for persisting the state of the collections is to use the DbiScheduleWPFDB XML Database assembly that ships with the DbiScheduleWPF control. This assembly provides the developer with the methods necessary to save and load the DbiScheduleWPF control using an XML database stored in a local or network directory connected to the client machine. IMPORTANT NOTE: Using the DbiScheduleWPFDB XML Database assembly requires no coding in the DbiScheduleWPF control’s events to capture and persist changes to the schedule. For more information on using the dbiSCcheduleSLDB assembly please refer to Developing with DbiScheduleWPF – Using the DbiScheduleWPFDB XML Database Assembly.

The DbiScheduleWPF control maintains 2 collections that reflect the data being stored in the database;

1. Schedule Items - describe the resource that is being scheduled. These could be people, rooms, positions/tasks, equipment, in essence any item that requires scheduling for its fulfillment or utilization. NOTE: Whereas the DbiScheduleWPF control maintains a Schedule Items collection, the items themselves are not editable inside the control. Accordingly the developer would not need to update the items based on events in the DbiScheduleWPF control.

2. Time Bars - Discreet periods of time that signify the resource's utilization. Each Schedule Item has its own collection of Time Bars that in essence represent the schedule for that item. Time Bars can be added to an item, have their start and end dates/times changed, have their text changed, be moved between items, and be deleted. Accordingly the DbiScheduleWPF control raises events to allow the developer to persist these changes to the objects in the database they represent.

As you can see from this simple example the Items collection in the control reflects the MeetingRooms table in the database, and the TimeBars collection in the control reflects the Meetings table in the database.

DBISCHEDULEWPF POINTS OF INTEGRATION FOR DATA

There are essentially three points of integration to consider when binding the DbiScheduleWPF control to a database:

1. Loading the control with data from the database.

2. Responding to changes (edits) in the data in the control.

3. Responding to Add, Move, and Delete events to the data in the control.

LOADING THE CONTROL FROM THE DATABASE

To programmatically load data from the database into the control the developer should use the DbiScheduleWPF.FirstDraw event to code the retrieval/setup of the ScheduleObjects, Schedule Items, and TimeBars data from the database.

NOTE: Using the FirstDraw event insures the control is fully formed (colors, fonts, etc. are assigned correctly) before modifying its contents. The FirstDraw event only fires once therefore it provides an ideal event in which to load the control for the first time.

First create an instance of a Schedule object describing the overall start and end date of the timeline to be considered along with any special formatting for the timeline and add the Schedule object to the Schedules collection in the DbiScheduleWPF control, and then activate the schedule object in the control. In our Meeting Rooms scenario, the Schedule object would describe a time line for a day, a week, or a month (start date of first day of month, end date of last day of month). The time line could be set to hourly mode to allow the schedule time to be in hours or sub-increments of hours such as 15 minutes, etc., or the time line can be set to days, weeks, months, or years.

Within the same FirstDraw event the next step is to programmatically add the Schedule Items (dbiListItem objects) to the control's Items collection, and for each Schedule Item its associated time bars (dbiTimeBarItem object) to the dbiListItem's TimeBars collection.

In our Meeting Rooms example this would require reading a Meeting Room from the MeetingRooms table, creating a dbiListItem object with the properties from the MeetingRooms table record and adding that object to the DbiScheduleWPF control's Items collection.

Once the Item (Meeting Room) has been added to the items collection, the TimeBars (Meetings) associated with the Meeting Room are read from the Meetings table and each record related to the selected MeetingRoom record is added to the Item's TimeBars collection.

To persist the relationship between a DbiScheduleWPF object and the database object it represents store the database object in the DbiScheduleWPF object's Tag property. Tags are of type Object and can therefore be used to store any kind of object, including an object from a database maintained in memory. If the data access for the application implements collections of objects used to represent the physical tables in a database, then storing the database object in the object's Tag property can be a very powerful tool for providing fast read/write/delete access to the data being represented by the object.

IMPORTANT NOTE: When an item is added to the items collection in the control (Meeting Room), the developer should persist the relationship to the record that the item represents. This will allow the developer to identify the item's object in the database with which to link new time bar records when adding new time bars to the schedule plan. Similarly, when a new time bar is created the record it represents should be persisted to allow for updates or removal when the time bar is moved or deleted.

When complete, the DbiScheduleWPF control will display a timeline as specified in the ScheduleObject, the Meeting Rooms as items in the list area of the DbiScheduleWPF control, and the Meetings as time bars in the schedule area of the control in their respective meeting room items.

RESPONDING TO TIME BAR CHANGES (EDITS/MOVES) IN THE CONTROL

When a time bar is sized, either made larger or smaller, it represents a change in the period of time the item containing the time bar is committed within the schedule. This change in size needs to be persisted in the database object that the time bar reflects.

When a time bar is moved within an item in the DbiScheduleWPF control (left or right) it represents a change in the schedule commitment for the item to which the time bar is attached. When a time bar is moved between items in the DbiScheduleWPF control it represents a change in the schedule commitment for two items, the item that originally contained the time bar and the item that contains the time bar after the move is finished. A move to a time bar needs to be persisted in the database object that the time bar reflects.

The DbiScheduleWPF control has two events that fire in response to a time bar move ... BeforeTimeBarMove, and AfterTimeBarMoved.

The BeforeTimeBarMove event fires after a time bar move has been initiated but before the move is completed. This event is provided to allow the developer to test to see if the move will be allowed. The primary reason for disallowing a move is that it will cause a conflict with other time bars. There may be other reasons to disallow a move (rights to a specific item or other rule detail). Within the BeforeTimeBarMove event the developer has the option of preventing the move causing the time bar to be returned to its original position.

IMPORTANT NOTE: The BeforeTimeBarMove event arguments include the time bar object being moved. This allows the developer to query the object for its persistence scheme (record id, Database Object, etc.), thereby allowing the event to relate to the database object represented by the time bar being moved.

The AfterTimeBarMoved event is fired after the move has been completed. This event is provided for the developer to store the change in the data back to the database object represented by the time bar being moved.

IMPORTANT NOTE: The AfterTimeBarMoved event arguments include the time bar object being moved. This allows the developer to query the object for its persistence scheme (record id, database object, etc.), thereby allowing the event to relate to the database object represented by the time bar being moved.

RESPONDING TO ADD AND DELETE TIME BAR EVENTS IN THE CONTROL

When a time bar is added to the control, programmatically or through the mouse interface (clicking and dragging) a BeforeTimeBarInsert event and an AfterTimeBarInserted event fires. In the case where the Add event is raised as the result of user interaction (clicking and dragging), the developer can recognize the addition of a time bar in either event and programmatically add a database object to the database collection representing the time bar.

IMPORTANT NOTE: Both events pass the time bar object being created as part of the event arguments. This allows the developer to query the newly added time bar and create a database object in the time bar database collection that reflects the properties of the new time bar.

IMPORTANT NOTE: When a new time bar is added to the schedule and saved in the database, the persistence scheme (record id, database object, etc.) of the newly added database object should be stored in the time bar to identify the source database object for any future changes or deletions of the time bar.

SUMMARY

Databinding the DbiScheduleWPF control requires three distinct points of integration; loading the data from the database, responding to changes (moves/edits) to the time bars in the schedule object, and responding to Adds (new), Moves, and Deletes to the time bars in the schedule plan. Each of the objects in the schedule (items and time bars) has properties that allow the developer to persist the relationship of the object in the database being reflected in the item or time bar. Each event that is fired in the schedule passes the time bar against which the event occurred (move, size, add, remove) to allow the developer to read the necessary property values (start time, end time, etc.) and its persistence scheme (record id, database object, etc.) to the object in the database.

NOTE: The discussion above is based on a simple example (meeting rooms) that does not involve multiple resources against the same time bar (for example equipment such as projectors, people, etc.). These items could be added however as detail to the time bar record in the database and reflected in the schedule as detail to the time bar, either as text, a tip, or a drill down form invoked by a mouse action on the time bar. Also, this example does not take into account the linking of time bars. Links are a separate collection in the control and therefore represent a separate table in the database. In a fashion similar to the time bars, links have their own set of events (BeforeTimeBarLink, AfterTimeBarLinked, BeforeTimeBarUnlinked, AfterTimeBarUnlinked) in which the programmer can code the binding of the objects to the database.


%%ItemTitle%%

Displaying Tool Tips
Developing with dbiScheduleWPF > dbiScheduleWPF Presentation > Displaying Tool Tips

Glossary Item Box

The DbiScheduleWPF control is capable of displaying tool tips in the schedule in response to a variety of different actions. These actions include:

Creating a Time Bar: If the TipsOnCreateBar property of the DbiScheduleWPF control is set to “True” a tool tip will appear under the time bar as it is being created. The information in the tool tip will include the start and end time for the time bar, and the time span (Change) of the time bar.

The tool tip above is displaying the start time, end time, and time span of the tool bar.

Changing a Time Bar: If the TipsOnChangeBar property is set to “True” a tool tip will appear when a time bar is being moved or sized. The information in the tool tip will include the start and end time for the time bar, and the time span (Change) of the time bar.

Moving the Mouse Over a Time Bar: If the TipsOnOverBar property is set to “True” a tool tip will appear when the mouse moves over a time bar. The information in the tool tip will include the start and end time for the time bar.

Moving the Mouse over a Schedule Note: If the TipsOnNotes property is set to “ True” a tool tip will appear when the mouse moves over a note in the schedule. NOTE: By default the information in the schedule note tool tip only includes the current text value of the schedule note.

Moving the Mouse over a Schedule GUIDELINE: If the TipsOnGuideLines property is set to “True” a tool tip will appear when the mouse moves a guide line when the edit mode is set to guidelines. The information in the tooltip will reflect the time at which the guideline sits on the schedule object.

Intercepting the Tool Tip Text

To customize the content of a tool tip the developer can intercept it before it is displayed and either Cancel the appearance of the tool tip altogether, or change the text to be displayed in the tool tip. The DbiScheduleWPF control's BeforeToolTips event fires before any tool tip is shown and is used to modify the content of/cancel the tool tip.

Example:

Modify the tool tip text in the BeforeToolTips event when a tool tip for the Guide Line move is about to be displayed.

NOTE: The e argument passed in the event has a property defining the text to be displayed.

[VB.NET]

Private Sub DbiScheduleWPF1_BeforeToolTips(sender As System.Object, e As Dbi.WPFControl.dbiSchedule.BeforeToolTipsEventArgs) Handles DbiScheduleWPF1.BeforeToolTips

If e.TipsType = Dbi.WPFControl.dbiSchedule.enumTipsType.GuideLine Then

e.Text = "Guideline" & vbCrLf & e.Text

End If

End Sub

[C#]

private void DbiScheduleWPF1_BeforeToolTips(object sender, Dbi.WPFControl.dbiSchedule.BeforeToolTipsEventArgs e)

{

    if (e.TipsType == Dbi.WPFControl.dbiSchedule.enumTipsType.GuideLine)

        e.Text = "GuideLine"+ System.Environment.NewLine + e.Text;

}


%%ItemTitle%%

Map Area
Developing with dbiScheduleWPF > dbiScheduleWPF Presentation > Map Area

Glossary Item Box

The map area displays a compressed version of all items and time bars loaded in the DbiScheduleWPF control in an area across the top of the control.

The image above shows a DbiScheduleWPF control with 10 resources and their related time bars for a schedule spanning 2 days. The map area presents all the days of the schedule in its entirety (all items, for all days in the schedule object) in a compressed image so they can be viewed simultaneously along the top of the control. An orange rectangle appears in the map area that represents the approximate current viewing area in the main schedule. If the user clicks on the map area, the view in the schedule area will change to display the area where the user clicked.

NOTE: If there are many line items, or if the schedule object is extraordinarily large (spans a long period of time relative to the time distance), the compressed image could become blurry. It is important to note the standard schedule area of the control is drawn to display only those items in the visible scrolling area, but the map schedule has to draw everything. Accordingly the performance of the control may begin to degrade if the map area is visible and the schedules are very large.

The appearance of the map area is determined by the MapArea property. Setting the property to true turns the map area on, setting the property to false turns the map area off. The height of the map area in pixels is determined by the MapHeight property.


%%ItemTitle%%

Setting up Different Views
Developing with dbiScheduleWPF > dbiScheduleWPF Presentation > Setting up Different Views

Glossary Item Box

Zooming

By changing the value of the TimeDistance property in the DbiScheduleWPF control, the developer can effectively zoom in and out of the view in the schedule(s) being displayed. This ability to zoom in or out of a schedule provides the developer with the option of presenting micro or macro views of the detail in the schedule. In the case where the items being scheduled require very precise time increments the TimeDistance value can be set to a higher value. NOTE: The higher the TimeDistance value the larger the distance between major time units (a major time unit will be wider). When the distance between major time units is larger, a user is able to position a time bar more precisely with the mouse. In the case where it is desirable to see more of the schedule simultaneously set the TimeDistance property to a smaller value.

General Notes

The TimeDistance property of the DbiScheduleWPF control can be used to set up different views of a schedule. It specifies the distance (in pixels) between the major time units within the Ruler of the DbiScheduleWPF control. If the TimeType property of the dbiScheduleObject class is set to "Hours", the TimeDistance property specifies the distance between the hours of the day. If the TimeType property is set to "Days", the TimeDistance property specifies the distance between the days of the month, and so on.

· The TimeDistance property is the number of pixels between major time units. For maximum efficiency, the TimeDistance property should be set to a value that corresponds in equal increments to the major time unit segments. For example, if the TimeType property of the dbiScheduleObject class is set to "Hours", the TimeDistance property of the DbiScheduleWPF control should be set to a value that corresponds to the sixty minutes in that hour (i.e. 120, 60, 30, 15). If the property is set to a value that is not incrementally equal to the minutes in an hour, for example 37, a time bar could not be moved to exactly half past the hour. If the TimeDistance property was set to a value of 60, then each pixel on the screen would represent one minute.

· The SnapToGrid property allows the developer to coerce a time bar start time to a minimum value within the time line. If the SnapToGrip property is set to a value of True a time bar can only be moved to a position within the major time unit as specified by the GridFrequency setting. For example, if the major time unit is set to Hours, the TimeDistance property is set to 60 (one pixel for each minute) then the user can place a time bar to start on any minute within an hour. To insure that time bars can only start on 15 minutes after the hour, 30 minutes after the hour, 45 minutes after the hour, or on the hour, the GridFrequency would be set to 15 and the SnapToGrid property would be set to true. In this case moving or creating a time bar in the schedule would automatically snap the start time to the nearest 15 minute increment.

· NOTE: The TimeDistance property affects all schedules in the control equally. The control does not support separate TimeDistance values for each schedule object in the DbiScheduleWPF control's Schedules collection.

NOTE: The PrintTimeDistance property is the equivalent of the TimeDistance property when printing the schedule control.


%%ItemTitle%%

Creating Custom Areas
Developing with dbiScheduleWPF > dbiScheduleWPF Presentation > Creating Custom Areas

Glossary Item Box

Custom areas are discrete objects that are used to color the schedule object and/or create "dead zones". Custom areas can be assigned to all items in a schedule or individual items in a schedule.

Using the CustomArea class

Custom areas can be created at design time in XAML or the Custom Areas Collection editor (from the property inspector) or they can be created programmatically through code at runtime.

Example:

Create a custom area for all line items in a schedule.

[VB.NET]

Dim dtStart As System.DateTime

Dim dtEnd As System.DateTime

dtStart = New DateTime(2014, 1, 1, 1, 30, 0)    'Starts at 1:30 AM

dtEnd = New DateTime(2014, 1, 1, 2, 0, 0)       'Ends at 2:00 AM

'Create a new instance of the custom area object,set its start and end date/times,

'and color the schedule red for the designated period of time.

Dim objColor = New Dbi.WPFControl.dbiSchedule.dbiCustomArea(dtStart, dtEnd, New System.Windows.Media.SolidColorBrush(Color.FromArgb(255, 255, 0, 0)))

'Add the custom area to the Schedule's Custom Areas collection

Me.DbiScheduleWPF1.CustomAreas.Add(objColor)

[C#]

System.DateTime dtStart;

System.DateTime dtEnd;

dtStart = new DateTime(2014, 1, 1, 1, 30, 0);   //Starts at 1:30 AM

dtEnd = new DateTime(2014, 1, 1, 2, 0, 0);      //Ends at 2:00 AM

//Create a new instance of the custom area object,set its start and end date/times,

//and color the schedule red for the designated period of time.

Dbi.WPFControl.dbiSchedule.dbiCustomArea objColor;

objColor = new Dbi.WPFControl.dbiSchedule.dbiCustomArea(dtStart, dtEnd, new System.Windows.Media.SolidColorBrush(Color.FromArgb(255, 255, 0, 0)));

//Add the custom area to the Schedule's Custom Areas collection

DbiScheduleWPF1.CustomAreas.Add(objColor);

[XAML]

<my:DbiScheduleWPF.CustomAreas>

<my:dbiCustomArea Start="01/01/14 01:30 am" End="01/01/14 02:00 am" Background="Red"/>

</my:DbiScheduleWPF.CustomAreas>

Custom areas can also be assigned to a single line item. To specify an individual item in the list the custom area must be added to the item's custom areas collection.

Example:

Create the custom area for the third item in the list using the custom area created above.

[VB.NET]

Me.DbiScheduleWPF1.Items(2).CustomAreas.Add(objColor)

[C#]

this.DbiScheduleWPF1.Items[2].CustomAreas.Add(objColor);

[XAML]

<my:dbiListItem.CustomAreas>

<my:dbiCustomArea Start="01/01/14 02:30 am" End="01/01/14 04:00 am"/>

</my:dbiListItem.CustomAreas>

Daily Areas

It is possible to set up a single entry for a custom area that is repeated on all days by setting the Daily property of the dbiCustomArea class to a value of true. NOTE: The time defined for a custom area must be less than 24 hours if it is to be repeated as a "daily" custom area.

Creating Dead Zones

A dead zone is defined as an area where an appointment cannot be created, moved, or sized into. Dead zones only apply to time bars created or changed in the control while in edit mode (i.e. through user interaction). Dead zones have no effect on time bars being added or changed through code. It is the responsibility of the programmer to obey dead zones when programmatically changing time bars. NOTE: The InDeadZone method can be used to determine if an appointment created in code is in conflict with a dead zone.


%%ItemTitle%%

Schedule Edit Modes
Developing with dbiScheduleWPF > Edit Modes > Schedule Edit Modes

Glossary Item Box

Using the mouse, time bars can be selected, created, and moved, sized, erased and linked/unlinked within the schedule. The type of edit action is determined by the EditMode property of the control. The edit modes available are Edit, Erase, Select, Link, Unlink and GuideLine.

Edit

Indicated by the pencil cursor, the edit mode allows the user to create, size and move time bars. To create a new time bar, left click in an item in the schedule and drag the mouse to the left or right. When the mouse button is released, a new time bar is created.

To size a time bar, left click on either end of a time bar and drag horizontally in either direction. Release the mouse button to complete the operation.

NOTE: If a time bar is sized so that its end time is less than or equal to the start time, one of two actions can occur;

1. By default, the time bar will be erased.

2. If the MinTime property from the dbiTimeBarItem class or the MinBarTime property from the control are set to a value greater than 0, the time bar will be set to that minimum time span. If both those properties are greater than 0, the time span for the time bar will be set to the greater value.

There are a variety of restrictions that can be placed into the schedules to prevent a time bar from being created, moved or sized. These include:

· Actions (move, size, create) that would place the time bar in a dead zone (See section on Creating Custom Areas for more details)

· Actions (vertical move or create) that would cause the number of time bars in an item to exceed the maximum number of time bars allowed for that item. NOTE: The limit for the number of time bars allowed on an item is set in the MaxTimeBars property of the dbiListItem object.

· Actions (select, move, create, size, erase, link) to time bars in an item that has been set to a read only state through the ReadOnly property of the dbiListItem class.

· Actions (select, move, create, size, erase, link) to a time bar whose Locked property is set to True. To set a time bar to be locked (read only), use the dbiTimeBarItem class Locked property.

· The modification of actions (such as cancelling) in the BeforeTimeBarInsert, BeforeTimeBarSize or BeforeTimeBarMove events.

· The prevention/allowing of vertical time bar moves using the AllowVertMoves property of the control. Setting the property to true allows time bars to be moved vertically between items, setting the property to false restricts movement of a time bar to horizontal moves only within its host item.

Erase

Indicated by the eraser mouse cursor. This mode allows the user to erase individual time bars by clicking on them.

Select

Indicated by the large "+" mouse cursor, this mode allows the user to click and drag an area in the schedule, creating a loop and selecting all time bars within or touching the edge of the loop. NOTE: The Select mode allows users to select more than one time bar simultaneously. Once selected, the time bars can then all be moved or sized at the same time. The restrictions for moving or sizing time bars in this mode are the same as the Edit mode noted above.

NOTE: Multiple time bars can also be selected discretely by setting the EditMode property to Select and holding down the Ctrl key while left clicking on the desired time bars.

Link

The link mode is indicated in the control by the chain link mouse cursor. This mode allows the user to click on one time bar, drag the link to another time bar and release the mouse to create a link. When complete, a link between the two time bars is created. (See section on Time Bar Linking for more details and restrictions.)

Unlink

The Unlink mode is indicated in the control by the broken chain link mouse cursor. This mode allows the user to click and drag between two linked time bars to break the link. (See section on Time Bar Linking for more details and restrictions.)

SPLIT

The Split mode is indicated in the control by the scissors mouse cursor. This mode allows the user to click in an existing time bar and split the time bar into two sections at the cursor position to create two time bars.


%%ItemTitle%%

Error Messages
Developing with dbiScheduleWPF > Error Messages > Error Messages

Glossary Item Box

There are six trappable errors that may be raised by the control during its operation. NOTE: All error messages are sent directly to the ControlError event and are parameterized as an integer value and text message. These errors include:

1 - Create In Dead Zone: An attempt was made to create a time bar in a dead zone.

2 - Move In Dead Zone: An attempt was made to move a time bar into a dead zone.

3 - Drop In Dead Zone: An attempt was made to drop a time bar into a dead zone.

1000 - Invalid Time Bar: An attempt was made to call a function with an invalid time bar.

1001 - Max Time Bars Exceeded: An attempt was made to create or move a time bar on a line item where the maximum number of time bars has already been placed.

1002 - Invalid Time Bar Move: An attempt was made to move a time bar into an invalid area.


%%ItemTitle%%

Implementing Scroll Bars
Developing with dbiScheduleWPF > Implementing Scroll Bars > Implementing Scroll Bars

Glossary Item Box

Programmatically setting the viewing areas of the DbiScheduleWPF Control

The DbiScheduleWPF control provides the developer with multiple methods to programmatically set the viewing areas of the control. There are three scroll bars that manage the list and schedule regions within the control; the vertical scroll bar, a List horizontal scroll bar, and a Schedule horizontal scroll bar. These scroll bars can be programmatically set using their respective scroll values. The control also includes a ScrollToDateTime method to allow the developer to programmatically navigate to a given date and time within a schedule object.

The control provides three additional properties for tracking and manipulating the scroll bars within the control; ListScrollValue, SchedScrollValue, VertScrollValue . This extended functionality provides the developer with the tools necessary for the programmatic positioning of the schedule control necessary to address issues such as schedule synchronization (multiple instances of the DbiScheduleWPF control), or “Go To’ functionality (Date/Time, List item, etc.) within an application.

To get and set the values of the scroll bars in the control there are three properties:

VertScrollValue The current scroll value of the Vertical Scrollbar

ListScrollValue The current scroll value of the List Scrollbar

SchedScrollValue The current scroll value of the Schedule Scrollbar

Each ScrollValue property represents the value of the associated scroll bar.

ScrollToDateTime

The ScrollToDateTime method of the DbiScheduleWPF control allows the developer to programmatically move to any date/time within the active ScheduleObject. The method requires two parameters:

dtValue (DateTime) - The date/time to locate and make visible in the viewing area of the schedule control.

nOffset (short) - The number of major time units in the ScheduleObject to display the dtValue relative to the left side of the schedule area in the control. Using a nOffset value of 0 displays the dtValue as the first time in the scheduling area of the control. Setting a positive or negative value in the nOffset parameter moves the viewing area left (positive) or right (negative) the specified number of major time units.

Example

Scroll the schedule control horizontally to display a specified date/time.

[VB.NET]

Dim datetime2ScrollTo = New DateTime(2014, 1, 2, 8, 0, 0)

Me.DbiScheduleWPF1.ScrollToDateTime(datetime2ScrollTo, 0)

 [C#]

System.DateTime datetime2ScrollTo;

datetime2ScrollTo = new DateTime(2014, 1, 2, 8, 0, 0);

DbiScheduleWPF1.ScrollToDateTime(datetime2ScrollTo, 0);


%%ItemTitle%%

Time Bar Linking
Developing with dbiScheduleWPF > Time Bar Linking > Time Bar Linking

Glossary Item Box

Time bar links are defined by the dbiLinkItem class. Time bar links can be created in two different ways; programmatically through code, or through user interaction with the control when in the Link edit mode.

Example:

Programmatically create a link between two time bars.

[VB.NET]

'Create a new link item object between the first time bar in the second resource and

'the first time bar in the third resource.

Dim timeBarFrom As Dbi.WPFControl.dbiSchedule.dbiTimeBarItem = Me.DbiScheduleWPF1.Items(1).TimeBars(0)

Dim timeBarTo As Dbi.WPFControl.dbiSchedule.dbiTimeBarItem = Me.DbiScheduleWPF1.Items(2).TimeBars(0)

Dim objLink As New Dbi.WPFControl.dbiSchedule.dbiLinkItem(timeBarFrom, timeBarTo)

'Add the link to the DbiScheduleWPF control's links collection

Me.DbiScheduleWPF1.Links.Add(objLink)

[C#]

//Create a new link item object between the first time bar in the second resource and

//the first time bar in the third resource.

Dbi.WPFControl.dbiSchedule.dbiTimeBarItem timeBarFrom = DbiScheduleWPF1.Items[1].TimeBars[0];

Dbi.WPFControl.dbiSchedule.dbiTimeBarItem timeBarTo = DbiScheduleWPF1.Items[2].TimeBars[0];

Dbi.WPFControl.dbiSchedule.dbiLinkItem objLink;

objLink = new Dbi.WPFControl.dbiSchedule.dbiLinkItem(timeBarFrom, timeBarTo);

//Add the link to the DbiScheduleWPF control's links collection

DbiScheduleWPF1.Links.Add(objLink);

IMPORTANT NOTE: All time bar links are defined with a source (the time bar from which the link originates) and a destination (the time bar on which the link terminates). A time bar that is the source of a link is said to be "linked to" another time bar. A time bar that is the destination of a link is said to be "linked from another time bar".

To allow the user to create links between time bars in the schedule, set the control's EditMode to "Link". The user clicks on a time bar, drags the mouse to another time bar, and releases the mouse. A link is visually displayed between the two time bars. NOTE: The control responds to user input when in link mode by firing a BeforeTimeBarLink event and AfterTimeBarLinked event. These events can be used to validate the input, optionally cancel or allow the link, and to code the necessary data binding logic to persist the link in the database.

IMPORTANT NOTE: A single time bar can be linked to zero, one, or many other time bars; a one-to-many relationship.

Time bar links can be broken using the mouse by setting the EditMode property to "Unlink". Clicking and dragging between the time bars connected by a link causes the link to be removed when the mouse button is released on the second time bar. If two time bars are loop linked (one time bar links to another, and then another link goes back to the first time bar), the primary link will be removed first.

There are three different types of time bar links:

1. Standard Link: A link with square lines and an arrow at the destination time bar.

2. Reciprocal Link: A link with square lines and arrows at the source and destination time bar.

3. Direct Link: A straight line between two time bars with no arrows.

There are four different directions available:

1. Start to End: A link that begins at the start of the source time bar and terminates at the end of the destination time bar.

2. Start to Start: A link that begins at the start of the source time bar and terminates at the start of the destination time bar.

3. End to Start: A link that begins at the end of the source time bar and terminates at the start of the destination time bar.

4. End to End: A link that begins at the end of the source time bar and terminates at the end of the destination time bar.

LINK TYPE LINK DIRECTION | Standard | Reciprocal | Direct
Start to End |  |  |
Start to Start |  |  |
End to Start |  |  |
End to End |  |  |

Link Navigation

The Links collection in the DbiScheduleWPF control manages all the time bars links. NOTE: A time bar does not store any information concerning its links. To determine what time bar links exist and to navigate the links the developer must refer to the Links collection in the DbiScheduleWPF control.

For example, to identify all the time bars linked to a given time bar the following code can be used …

[VB.NET]

Private Function getAllLinkedTimeBars(ByVal timebar2Test As Dbi.WPFControl.dbiSchedule.dbiTimeBarItem) As List(Of Dbi.WPFControl.dbiSchedule.dbiTimeBarItem)

Dim allLinkedTimeBars As New List(Of Dbi.WPFControl.dbiSchedule.dbiTimeBarItem)

'Use LINQ to query the Links collection on the DbiScheduleWPF control for all Time Bars linked from a specified Time Bar.

Dim timeBarLinksFound = From allTimeBarLinks As Dbi.WPFControl.dbiSchedule.dbiLinkItem In Me.DbiScheduleWPF1.Links _

                              Where allTimeBarLinks.TimeBarFrom Is timebar2Test _

                              Select allTimeBarLinks

If timeBarLinksFound.Count > 0 Then

'Links were found going from the timebar2Test

Dim timeBarLink2Process As Dbi.WPFControl.dbiSchedule.dbiLinkItem

For Each timeBarLink2Process In timeBarLinksFound

'Add the TimeBarTo object to the allLinkedTimeBars collection.

allLinkedTimeBars.Add(timeBarLink2Process.TimeBarTo)

Next

End If

Return allLinkedTimeBars

End Function

[C#]

private List<Dbi.WPFControl.dbiSchedule.dbiTimeBarItem> getAllLinkedTimeBars( Dbi.WPFControl.dbiSchedule.dbiTimeBarItem timebar2Test)

{

    List<Dbi.WPFControl.dbiSchedule.dbiTimeBarItem> allLinkedTimeBars;

    allLinkedTimeBars = new List<Dbi.WPFControl.dbiSchedule.dbiTimeBarItem>();

    //Use LINQ to query the Links collection on the DbiScheduleWPF control for all Time Bars linked from a specified Time Bar.

    var timeBarLinksFound = from allTimeBarLinks in DbiScheduleWPF1.Links

                            where allTimeBarLinks.TimeBarFrom == timebar2Test

                            select allTimeBarLinks;

    if (timeBarLinksFound.Count() > 0)

        //Links were found going from the timebar2Test

    {

        foreach (Dbi.WPFControl.dbiSchedule.dbiLinkItem timeBarLink2Process in timeBarLinksFound)

            //Add the TimeBarTo object to the allLinkedTimeBars collection.

            allLinkedTimeBars.Add(timeBarLink2Process.TimeBarTo);

    }

    return allLinkedTimeBars;

}

Using the above routine a developer could use the following code to update all linked time bars based on a move or resize of a given time bar.

IMPORTANT NOTE: The following code is intended for linked time bars in-line from left to right in the schedule. The following code will not work with circular or looped time bar links (a time bar linked from more than one source).

[VB.NET]

Public Sub moveAllLinked(ByVal initialTimeBar As Dbi.WPFControl.dbiSchedule.dbiTimeBarItem, ByVal timespanDelta As TimeSpan)

'Custom Sub routine to move all time bars linked from a given time bar.

'NOTE: The timespanDelta value is calculated as the change in end date/time of the 'source time bar prior to calling the sub routine

Dim timeBars2Process As List(Of Dbi.WPFControl.dbiSchedule.dbiTimeBarItem)

timeBars2Process = getAllLinkedTimeBars(initialTimeBar)

processAllLinked(timeBars2Process, timespanDelta)

Dim nextTimeBar2Test As Dbi.WPFControl.dbiSchedule.dbiTimeBarItem

For Each nextTimeBar2Test In timeBars2Process

'NOTE: This is a recursive process to account for a linked time bar being linked to another time bar(s).

moveAllLinked(nextTimeBar2Test, timespanDelta)

Next

End Sub

Public Sub processAllLinked(ByVal allTimeBars2process As List(Of Dbi.WPFControl.dbiSchedule.dbiTimeBarItem), ByVal timespanDelta As TimeSpan)

Dim timeBar2Process As Dbi.WPFControl.dbiSchedule.dbiTimeBarItem

For Each timeBar2Process In allTimeBars2process

timeBar2Process.Start = timeBar2Process.Start.Add(timespanDelta)

timeBar2Process.End = timeBar2Process.End.Add(timespanDelta)

Next

End Sub

[C#]

private void moveAllLinked(Dbi.WPFControl.dbiSchedule.dbiTimeBarItem initialTimeBar, TimeSpan timespanDelta)

{

    //Custom Sub routine to move all time bars linked from a given time bar.

    //NOTE: The timespanDelta value is calculated as the change in end date/time of the 'source time bar prior to calling the sub routine

    List<Dbi.WPFControl.dbiSchedule.dbiTimeBarItem> timeBars2Process;

    timeBars2Process = getAllLinkedTimeBars(initialTimeBar);

    processAllLinked(timeBars2Process, timespanDelta);

    foreach(Dbi.WPFControl.dbiSchedule.dbiTimeBarItem nextTimeBar2Test in timeBars2Process)

        //NOTE: This is a recursive process to account for a linked time bar being linked to another time bar(s).

        moveAllLinked(nextTimeBar2Test, timespanDelta);

}

private void processAllLinked(List<Dbi.WPFControl.dbiSchedule.dbiTimeBarItem> allTimeBars2process, TimeSpan timespanDelta)

{

    foreach (Dbi.WPFControl.dbiSchedule.dbiTimeBarItem timeBar2Process in allTimeBars2process)

    {

        timeBar2Process.Start = timeBar2Process.Start.Add(timespanDelta);

        timeBar2Process.End = timeBar2Process.End.Add(timespanDelta);

    }

}


%%ItemTitle%%

Undo/Redo Functionality
Developing with dbiScheduleWPF > Undo/Redo > Undo/Redo Functionality

Glossary Item Box

Extending the Undo/Redo Feature

The DbiScheduleWPF control includes built-in Undo/Redo functionality to assist the developer in providing Undo/Redo functionality in their applications. The control contains two collections; UndoHistory and RedoHistory to record user interaction with the objects in the control. The following actions are logged by the history collections:

· Creating a Time Bar

· Moving a Time Bar

· Sizing a Time Bar

· Erasing a Time Bar

· Linking a Time Bar

· Unlinking a Time Bar

The control can record as many actions as the control's HistorySize property (the larger the value the more actions can be recorded).

By default, every time a time bar in the control is created, deleted, moved, sized, split, or linked using the mouse, an entry is created in the controls history collection to record that action. That history collection is then used for the undo/redo feature. However, if the action is executed as the result of code that action is not recorded in the history collection.

The DbiScheduleWPF control provides two methods to implement the Undo/Redo features; DbiScheduleWPF.Undo() and DbiScheduleWPF.Redo().


%%ItemTitle%%

User Drawn Functionality
Developing with dbiScheduleWPF > User Drawn > User Drawn Functionality

Glossary Item Box

User Drawn Functionality

User drawn functionality allows the developer to add, remove, or change items in the schedule area in ways that go beyond the default scope of the control. The user drawn functionality is surfaced in two different ways; User Drawn Lines and User Drawn Time Bars.

User Drawn Lines: This involves drawing all the time bars into the schedule area of a list item. The DbiScheduleWPF control surfaces two events; UserDrawnLineBefore and UserDrawnLineAfter to support this functionality. Each of these events receives an e parameter with the following properties.

Name | Type | Description
Canvas | Canvas | The canvas element that is being painted on.
LineRect | Rect | The rectangular region of the area being painted.
LineStart | DateTime | The starting data and time of the line.
ListItem | dbiListItem | The list item object that is currently being painted.
PaintLine NOTE: UserDrawnLineBefore event only | Boolean | Determines whether the time bars will be drawn by the control. If the developer does not want the control to draw any time bars, set this property to false in the UserDrawnLineBefore event.
Schedule | dbiScheduleObject | The current schedule object being displayed.

Just before any time bars that may exist in a list item are painted, the control will fire the UserDrawnLineBefore event. At this time the developer can prevent the control from painting the time bars, draw their own time bars, or add any other object they may desire. If the developer needs to prevent any time bars from being painted, the e.PaintLine property needs to be set to false in this event.

It should be noted that if the developer adds drawing elements here and allows the time bars to be painted, those new elements will be behind the time bars. Similarly, using the UserDrawnLineAfter event to paint any elements will cause those elements to be drawn on top of the time bars.

Using the UserDrawnLine events will not prevent the control from painting the background of the line, or any other objects such as notes. Use the UserDrawnLine events to paint a new background if so desired.

User Drawn Time Bars: This involves drawing individual time bars. The DbiScheduleWPF control surfaces two events to support this functionality; UserDrawnBarBefore and UserDrawnBarAfter. Each of these events receives an “e” parameter with the following properties…

Name | Type | Description
BarRect | Rect | The rectangular region of the time bar.
Canvas | Canvas | The canvas element that is being painted on.
LineRect | Rect | The rectangular region of the area hosting the time bar.
ListItem | dbiListItem | The list item object that hosts the time bar.
PaintBar NOTE: UserDrawnBarBefore event only. | Boolean | Determines whether the time bar will be drawn by the control. If the developer does not want the control to draw this time bar, set this property to false in the UserDrawnBarBefore event. This only involves the time bar itself, and not any text that may exist in it.
PaintText NOTE: UserDrawnBarBefore event only.. | Boolean | Determines whether the time bar text will be drawn by the control. If the developer does not want the control to draw the text, set this property to false in the UserDrawnBarBefore event. This only involves the time bar text itself, and not the time bar background.
Schedule | dbiScheduleObject | The current schedule object being displayed.
TimeBarItem | dbiTimeBarItem | The object representing the time bar being painted.

Just before a time bar is painted, the UserDrawnBarBefore event is fired. If the developer requires the control to not paint the time bar and/or time bar text, they need to set the e.PaintBar and/or e.PaintText properties to false.

Firing Order for the User Drawn events.

UserDrawnLineBefore

UserDrawnBarBefore

UserDrawnBarAfter

Repeat for each time bar in that line

UserDrawnLineAfter

Repeat for each list item visible in the control.

In the screen shot above, all 4 user drawn events were used to paint additional items into the schedule area of the control. The UserDrawnLineBefore event was used to paint the blue and purple rectangles in the line items marked as headers. The UserDrawnLineAfter event was used to paint the text in each list item describing the amount of time bars in that line item. The UserDrawnBarBefore event was used to replace the first group of child items rectangle shaped time bars with ellipses. And the UserDrawnBarAfter event was used to paint a circle at the top left corner in each time bar in the second group of child items.


%%ItemTitle%%

GuideLines
Developing with dbiScheduleWPF > Working with Guide Lines > GuideLines

Glossary Item Box

Working with Guide Lines

Guide Lines are vertical lines used to represent specific times in a schedule. Guide lines provide the user with discrete “snap-to” functionality making it easier to position time bars.

Guide lines enhance the process of creating and maintaining a schedule. Guide lines are not intended to be included in the static display functionality of the schedule and accordingly they have certain limitations. Guide lines are not rendered in a printed report, and are not part of the Undo/Redo functionality.

Adding Guide Lines to the Schedules

Guide lines are assigned to a specific schedule object. Therefore, if the user wants to display a guide line in multiple schedules for a specific time the guide line must be created for each schedule object in which it is to appear. There are two ways to add a guide line to a schedule …

1.) User Interaction: Set the EditMode property of the control to GuideLine. Click a point on the schedule. In the OnMouseUp event, the new guide line will be created.

2.) Programmatically: Create a dbiGuideLine object through code and assign it to a schedule.

For example…

[VB.NET]

Dim objGuideLine = New Dbi.WPFControl.dbiSchedule.dbiGuideLine

objGuideLine.LineTime = Me.DbiScheduleWPF1.Schedules(0).Start.AddHours(4)

Me.DbiScheduleWPF1.Schedules(0).GuideLines.Add(objGuideLine)

[C#]

Dbi.WPFControl.dbiSchedule.dbiGuideLine objGuideLine;

objGuideLine = new Dbi.WPFControl.dbiSchedule.dbiGuideLine();

objGuideLine.LineTime = DbiScheduleWPF1.Schedules[0].Start.AddHours(4);

DbiScheduleWPF1.Schedules[0].GuideLines.Add(objGuideLine);

[XAML]

<my:dbiScheduleObject.GuideLines>

<my:dbiGuideLine LineTime="01/01/14 04:00 am"/>

</my:dbiScheduleObject.GuideLines>

When a guide line is added with the mouse a BeforeGuideLineInsert and AfterGuideLineInserted event will be fired by the DbiScheduleWPF control. These events can be used to validate the action and optionally prevent the guide line from being inserted, and to set the appearance of the guide line.

Changing the Position of a Guide Line

The position of a guide line in a schedule is based on the DateTime value assigned to the LineTime property of the dbiGuideLine object. Changing the position of a guide line can be achieved in one of three ways ...

1.) User Interaction with the guideline in the schedule: Set the EditMode property of the control to GuideLine, Click and drag an existing guide line horizontally in the schedule. On the OnMouseUp event, the guide line will be set at its new position and time. NOTE: To move the guideline inside the schedule area the EditMode must be set to GuideLine.

2.) User Interaction with the guideline in the ruler: If an image has been assigned to a guide line the image appears in the ruler area. Click and drag the image horizontally in the ruler to change its time. NOTE: The EditMode of the control DOES NOT have to be set to GuideLine.

3.) Programmatically: Change the value of the LineTime property of the dbiGuideLine object through code.

When a guide line is moved with the mouse a BeforeGuideLineMove and AfterGuideLineMoved event will be fired. The “Before” event can be used to validate and optionally prevent the guide line from being moved. NOTE: As a guide line is being moved with the mouse, the GuideLineMove event will be firing.

Removing Guide Lines from the Schedules

Guide lines can be removed from a Schedule Object in one of three ways …

1.) User Interaction with the guideline in the schedule: Set the EditMode property of the control to GuideLine, Click and drag an existing guide line horizontally off of the schedule. On the OnMouseUp event, the guide line will be removed.

2.) User Interaction with the guideline in the ruler: If an image has been assigned to a guide line, click and drag the image horizontally off of the schedule. NOTE: The EditMode of the control DOES NOT have to be set to GuideLine.

3.) Programmatically: Remove the guide line through code.

When a guide line is being removed with the mouse a BeforeGuideLineRemove and AfterGuideLineRemoved event will be fired. The “Before” event can be used to validate the action and optionally prevent the guide line from being removed.

Adding Images to a Guide Line

Each guide line can be assigned an image that is rendered in the ruler section of the control. By default the image will be vertically aligned to the bottom of the ruler and horizontally aligned so that the middle of the image is on top of the guide line. The position can be changed though the image offset properties of the GuideLine object. NOTE: It is possible to display an image for a time line inside the actual schedule instead of the ruler area however this is NOT a recommended practice as the logic for the guide line images assumes they are within the ruler area of the schedule. Unpredictable results may occur by placing them elsewhere. To add an image to a guide line perform the following …

1.) Add an image to applications resources.

2.) Add the image DbiScheduleWPF.Images collection.

3.) Set the ImageIndex property of a dbiGuideLine object to the index value of an image in the Images collection.

Snapping a Time Bar to a Guide Line

To cause time bars to be snapped to a guide line, the SnapToGuide property of the DbiScheduleWPF control must be set to True. As one end of a time bar approaches a guide line the edge of the time bar will become aligned with the guide line. The distance at which the time bar is “snapped” to the guide line is determined in pixels and is defined in the GuideLineDistance property of the DbiScheduleWPF control. The maximum value for the GuideLineDistance property is 10.

When a time bar is “snapped” to a guide line, it is assigned the actual time of that guide line. For example, if a guide line is set to 1:13:15 (1 hour, 13 minutes, 15 seconds), when a time bar is snapped to the guide line, its beginning (or end depending on the proximity of the guide line) will be set to the 1:13:15 setting.

NOTE : Because the Snap to Guide Lines feature is based on pixels, a time bar will only snap to a guide line that is visible within the schedule object. If a guide line is not visible in the schedule object the time bar will not snap to its value.

NOTE : Working with GuideLines and SnapToGrid... please be aware that if you have snap-to-grid enabled with snap-to-guidelines, be sure to synchronize the guidelines to the gridfrequency. If the guidelines fall too close to the gridfrequency but not exactly then there may be issues related to the drawing of the time bars as they attempt to position themselves to accommodate both values.


%%ItemTitle%%

Schedule Notes
Developing with dbiScheduleWPF > Working with Schedule Notes > Schedule Notes

Glossary Item Box

Schedule Item Notes

The DbiScheduleWPF control includes Schedule Notes functionality to allow the developer to embed notes in the schedule object area of the control to assist the user in creating and maintaining efficient and effective schedules.

Schedule Notes are represented with an image. The developer has the option of using the built in default image …

or assigning a custom image …

by setting the guideline’s ImageIndex property to the index value of an image stored in the Images collection on the DbiScheduleWPF control.

Notes can be rendered specific to a date and time or locked to always appear in the active Schedule Object.

When a Note is locked the developer must specify a value for the alignment of the Note within the item. This insures that the Note is always displayed in the area of the Schedule Object being viewed.

NOTE: If the Note object has its Locked property set to false, the Note will only be rendered at the date and time assigned to its NoteTime property.

To automatically render the text of the Note in a tooltip when the user hovers the mouse over a Note, set the DbiScheduleWPF's TipsOnNotes property to true.

For an example of how to programmatically manipulate the Schedule Item Note object, please refer to the Schedule Notes sample application.

IMPORTANT: Notes are not rendered in the Map Area or in the DbiScheduleWPF Print functionality.

Example – Add a note to the second item in the DbiScheduleWPF control and lock its position to the left of the Schedule Object …

[VB.NET]

'Create a new note object.

Dim objScheduleNote = New Dbi.WPFControl.dbiSchedule.dbiScheduleNote()

'Set the Note's properties to have it use the 4th image in the image list

'and have it aligned left in the schedule object.

objScheduleNote.Locked = True

objScheduleNote.Text = "This is the Note"

objScheduleNote.ImageIndex = 3

objScheduleNote.ImageAlignment = Dbi.WPFControl.dbiSchedule.enumImageAlignment.Left

DbiScheduleWPF1.Items(1).Notes.Add(objScheduleNote)

[C#]

//Create a new note object.

Dbi.WPFControl.dbiSchedule.dbiScheduleNote objScheduleNote;

objScheduleNote = new Dbi.WPFControl.dbiSchedule.dbiScheduleNote();

//Set the Note's properties to have it use the 4th image in the image list

//and have it aligned left in the schedule object.

objScheduleNote.Locked = true;

objScheduleNote.Text = "This is the Note";

objScheduleNote.ImageIndex = 3;

objScheduleNote.ImageAlignment = Dbi.WPFControl.dbiSchedule.enumImageAlignment.Left;

DbiScheduleWPF1.Items[1].Notes.Add(objScheduleNote);

[XAML]

<my:dbiListItem.Notes>

<my:dbiScheduleNote ImageIndex="3" ImageAlignment="Left" Text="This is the Note" Locked="True"/>

</my:dbiListItem.Notes>


%%ItemTitle%%

Using the DbiScheduleWPFDB XML Database Assembly
Developing with dbiScheduleWPF > Working with the dbiScheduleWPFDB XML Database Assembly > Using the DbiScheduleWPFDB XML Database Assembly

Glossary Item Box

The DbiScheduleWPFDB assembly is designed to allow the developer to quickly implement an XML database to persist the state of the DbiScheduleWPF collections in to a storage location accessible from the client machine.

The DbiScheduleWPFDB assembly is included in the Solutions Schedule for Silverlight package and requires the developer add it as a reference to the project in order to use it. Once the assembly is referenced the following steps are required for implementation in the application …

1.  Create a variable of type DbiScheduleWPFDB.DbiScheduleWPFDB in the applications class declaration.

[VB.NET]

Private myScheduleSLDB As DbiScheduleWPFDB.DbiScheduleWPFDB

[C#]

private DbiScheduleWPFDB.DbiScheduleWPFDB myScheduleSLDB;

2. Create an instance of the DbiScheduleWPFDB (XML Database Engine) passing in the instance of the DbiScheduleWPF control on the form. This binds the XML Database functionality to the instance of the schedule control. Typically this would be done in the New() event of the main form of the application.

[VB.NET]

myScheduleSLDB = New DbiScheduleWPFDB.DbiScheduleWPFDB(Me.DbiScheduleWPF1)

[C#]

myScheduleSLDB = new DbiScheduleWPFDB.DbiScheduleWPFDB(DbiScheduleWPF1);

3. Implement the Save and Load functionality based on the requirement of the application. This may be through a menu selection, button click, or passively when the application starts up/shuts down.

The DbiScheduleWPFDB class contains two methods to save and load the collections from the DbiScheduleWPF control …

SaveAll2XMLDB (myFileName2Save) – saves the contents of the DbiScheduleWPF control to a file name and directory as selected by the user. By default the file name for the XML data is set to "DbiScheduleWPFDB"

However the developer can override this in the SaveAll2LocalDirectory method by passing a string describing the default name for the file. The method returns a System.Exception if an error is encountered or nothing if it completes successfully.

LoadAllFromXMLDB() – loads the contents of the DbiScheduleWPF control from an XML database stored in a file name and directory as selected by the user. The method returns a System.Exception if an error is encountered or nothing if it completes successfully.

IMPORTANT NOTE: The DbiScheduleWPFDB Save and Load functionality will only persist object tag data that is of type String. Any tag objects that are not of type string will be ignored.


%%ItemTitle%%

Working with DateTime values in XAML
Developing with dbiScheduleWPF > Working with DateTime values in XAML

Glossary Item Box

Normally when dealing with DateTime properties on objects in XAML, the values have to either be handled programmatically or with a converter.

The dbiScheduleWPF control, has a built in converter which is attached to all the DateTime properties on all the objects contained in it. This allows developers to assign values to those properties in XAML directly, if needed.

The one caveat, is that the converter normally applies the format of the DateTime based on the culture of the machine where the application is running. This can be an issue if the developers and client have different settings.

For example: "1/2/2012" can mean either January 2 2012 or February 1 2012. This discrepency may prevent your application from running correctly, and may cause issues with your data.

As such, the built in converter has been hardcoded to us an "en-US" culture to handle all DateTime values, assigned directly to the property.

Example:

<dbiScheduleWPF:dbiScheduleObject Start="1/2/2012 12:00:00 AM" />

This value will always be interpreted by the control as January 2 2012, regardless of the machine where the application is running.

PLESE NOTE: This converter is only used by the properties when passed a string value, such as assigning the value in XAML. If you create your own DateTime variable programmatically and assign it as the value for the DateTime property of the object, the value will be accepted as is (no conversion is required and none will be done).


%%phrase%%

dbiScheduleWPF Assembly

Object Model

dbiScheduleWPF ClassdbiColumnItemCollection ClassdbiColumnItem ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiListItemCollection ClassdbiListItem ClassdbiLinkItemCollection ClassdbiLinkItem ClassdbiScheduleObjectCollection ClassdbiScheduleObject Class
Multi-Resource Scheduling control assembly for WPF

Namespaces

Namespace | Description
Dbi.WpfControl.dbiSchedule | Multi-Resource Scheduling control namespace for WPF


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Introduction


%%PageItemTitle%% $$Methods$$

dbiColumnItem Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItem Class

"

For a list of all members of this type, see dbiColumnItem members.

"

See Also

Reference

dbiColumnItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Events$$

dbiColumnItemCollection Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiColumnItemCollection Class

"

For a list of all members of this type, see dbiColumnItemCollection members.

"

See Also

Reference

dbiColumnItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiColumnItemCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : dbiColumnItemCollection Constructor

Overload List

Overload | Description
dbiColumnItemCollection Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

CollectionChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : CollectionChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim handler As NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
C#
[__DynamicallyInvokableAttribute()]
public event NotifyCollectionChangedEventHandler CollectionChanged

Event Data

The event handler receives an argument of type NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : Contains Method

item
The object to locate in the Collection. The value can be null for reference types.
Determines whether an element is in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim item As dbiColumnItem
Dim value As Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public bool Contains(
   dbiColumnItem item
)

Parameters

item
The object to locate in the Collection. The value can be null for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim array() As dbiColumnItem
Dim index As Integer

instance.CopyTo(array, index)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   dbiColumnItem[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : Count Property

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim value As Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim value As IEnumerator(Of dbiColumnItem)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public IEnumerator<dbiColumnItem> GetEnumerator()

Return Value

An IEnumerator for the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

Move Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItemCollection Class : Move Method

oldIndex
newIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItemCollection
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItemCollection Class
dbiColumnItemCollection Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiColumnItem Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%% $$Methods$$

dbiCustomArea Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomArea Class

"

For a list of all members of this type, see dbiCustomArea members.

"

See Also

Reference

dbiCustomArea Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Events$$

dbiCustomAreaCollection Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiCustomAreaCollection Class

"

For a list of all members of this type, see dbiCustomAreaCollection members.

"

See Also

Reference

dbiCustomAreaCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiCustomAreaCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : dbiCustomAreaCollection Constructor

Overload List

Overload | Description
dbiCustomAreaCollection Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

CollectionChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : CollectionChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim handler As NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
C#
[__DynamicallyInvokableAttribute()]
public event NotifyCollectionChangedEventHandler CollectionChanged

Event Data

The event handler receives an argument of type NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : Contains Method

item
The object to locate in the Collection. The value can be null for reference types.
Determines whether an element is in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim item As dbiCustomArea
Dim value As Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public bool Contains(
   dbiCustomArea item
)

Parameters

item
The object to locate in the Collection. The value can be null for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim array() As dbiCustomArea
Dim index As Integer

instance.CopyTo(array, index)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   dbiCustomArea[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : Count Property

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim value As Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim value As IEnumerator(Of dbiCustomArea)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public IEnumerator<dbiCustomArea> GetEnumerator()

Return Value

An IEnumerator for the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Move Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomAreaCollection Class : Move Method

oldIndex
newIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiCustomArea Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%% $$Methods$$

dbiGuideLine Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLine Class

"

For a list of all members of this type, see dbiGuideLine members.

"

See Also

Reference

dbiGuideLine Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Events$$

dbiGuideLineCollection Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiGuideLineCollection Class

"

For a list of all members of this type, see dbiGuideLineCollection members.

"

See Also

Reference

dbiGuideLineCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiGuideLineCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : dbiGuideLineCollection Constructor

Overload List

Overload | Description
dbiGuideLineCollection Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

CollectionChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : CollectionChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim handler As NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
C#
[__DynamicallyInvokableAttribute()]
public event NotifyCollectionChangedEventHandler CollectionChanged

Event Data

The event handler receives an argument of type NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : Contains Method

item
The object to locate in the Collection. The value can be null for reference types.
Determines whether an element is in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim item As dbiGuideLine
Dim value As Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public bool Contains(
   dbiGuideLine item
)

Parameters

item
The object to locate in the Collection. The value can be null for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim array() As dbiGuideLine
Dim index As Integer

instance.CopyTo(array, index)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   dbiGuideLine[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : Count Property

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim value As Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim value As IEnumerator(Of dbiGuideLine)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public IEnumerator<dbiGuideLine> GetEnumerator()

Return Value

An IEnumerator for the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Move Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLineCollection Class : Move Method

oldIndex
newIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiGuideLine Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%% $$Methods$$

dbiLinkItem Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItem Class

"

For a list of all members of this type, see dbiLinkItem members.

"

See Also

Reference

dbiLinkItem Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Events$$

dbiLinkItemCollection Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiLinkItemCollection Class

"

For a list of all members of this type, see dbiLinkItemCollection members.

"

See Also

Reference

dbiLinkItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiLinkItemCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : dbiLinkItemCollection Constructor

Overload List

Overload | Description
dbiLinkItemCollection Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

CollectionChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : CollectionChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim handler As NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
C#
[__DynamicallyInvokableAttribute()]
public event NotifyCollectionChangedEventHandler CollectionChanged

Event Data

The event handler receives an argument of type NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : Contains Method

item
The object to locate in the Collection. The value can be null for reference types.
Determines whether an element is in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim item As dbiLinkItem
Dim value As Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public bool Contains(
   dbiLinkItem item
)

Parameters

item
The object to locate in the Collection. The value can be null for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim array() As dbiLinkItem
Dim index As Integer

instance.CopyTo(array, index)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   dbiLinkItem[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : Count Property

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim value As Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim value As IEnumerator(Of dbiLinkItem)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public IEnumerator<dbiLinkItem> GetEnumerator()

Return Value

An IEnumerator for the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

Move Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItemCollection Class : Move Method

oldIndex
newIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItemCollection
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItemCollection Class
dbiLinkItemCollection Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members
Overload List


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members
Overload List


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiLinkItem Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%% $$Methods$$

dbiListCell Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCell Class

"

For a list of all members of this type, see dbiListCell members.

"

See Also

Reference

dbiListCell Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Events$$

dbiListCellCollection Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListCellCollection Class

"

For a list of all members of this type, see dbiListCellCollection members.

"

See Also

Reference

dbiListCellCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiListCellCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : dbiListCellCollection Constructor

Overload List

Overload | Description
dbiListCellCollection Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

CollectionChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : CollectionChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim handler As NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
C#
[__DynamicallyInvokableAttribute()]
public event NotifyCollectionChangedEventHandler CollectionChanged

Event Data

The event handler receives an argument of type NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : Contains Method

item
The object to locate in the Collection. The value can be null for reference types.
Determines whether an element is in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim item As dbiListCell
Dim value As Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public bool Contains(
   dbiListCell item
)

Parameters

item
The object to locate in the Collection. The value can be null for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim array() As dbiListCell
Dim index As Integer

instance.CopyTo(array, index)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   dbiListCell[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : Count Property

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim value As Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim value As IEnumerator(Of dbiListCell)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public IEnumerator<dbiListCell> GetEnumerator()

Return Value

An IEnumerator for the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

Move Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCellCollection Class : Move Method

oldIndex
newIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCellCollection
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCellCollection Class
dbiListCellCollection Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members
Overload List


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members
Overload List


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListCell Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListCell

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListCell Class
dbiListCell Members


%%PageItemTitle%% $$Events$$

dbiListItemCollection Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiListItemCollection Class

"

For a list of all members of this type, see dbiListItemCollection members.

"

See Also

Reference

dbiListItemCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiListItemCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : dbiListItemCollection Constructor

Overload List

Overload | Description
dbiListItemCollection Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

CollectionChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : CollectionChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim handler As NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
C#
[__DynamicallyInvokableAttribute()]
public event NotifyCollectionChangedEventHandler CollectionChanged

Event Data

The event handler receives an argument of type NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : Contains Method

item
The object to locate in the Collection. The value can be null for reference types.
Determines whether an element is in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim item As dbiListItem
Dim value As Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public bool Contains(
   dbiListItem item
)

Parameters

item
The object to locate in the Collection. The value can be null for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim array() As dbiListItem
Dim index As Integer

instance.CopyTo(array, index)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   dbiListItem[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : Count Property

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim value As Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim value As IEnumerator(Of dbiListItem)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public IEnumerator<dbiListItem> GetEnumerator()

Return Value

An IEnumerator for the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

Move Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItemCollection Class : Move Method

oldIndex
newIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItemCollection
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItemCollection Class
dbiListItemCollection Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members
Overload List


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members
Overload List


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiListItem Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiListItem

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiListItem Class
dbiListItem Members


%%PageItemTitle%% $$Methods$$

dbiScheduleNote Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNote Class

"

For a list of all members of this type, see dbiScheduleNote members.

"

See Also

Reference

dbiScheduleNote Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Events$$

dbiScheduleNoteCollection Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleNoteCollection Class

"

For a list of all members of this type, see dbiScheduleNoteCollection members.

"

See Also

Reference

dbiScheduleNoteCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleNoteCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : dbiScheduleNoteCollection Constructor

Overload List

Overload | Description
dbiScheduleNoteCollection Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

CollectionChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : CollectionChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim handler As NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
C#
[__DynamicallyInvokableAttribute()]
public event NotifyCollectionChangedEventHandler CollectionChanged

Event Data

The event handler receives an argument of type NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : Contains Method

item
The object to locate in the Collection. The value can be null for reference types.
Determines whether an element is in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim item As dbiScheduleNote
Dim value As Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public bool Contains(
   dbiScheduleNote item
)

Parameters

item
The object to locate in the Collection. The value can be null for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim array() As dbiScheduleNote
Dim index As Integer

instance.CopyTo(array, index)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   dbiScheduleNote[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : Count Property

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim value As Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim value As IEnumerator(Of dbiScheduleNote)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public IEnumerator<dbiScheduleNote> GetEnumerator()

Return Value

An IEnumerator for the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Move Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNoteCollection Class : Move Method

oldIndex
newIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleNote Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%% $$Methods$$

dbiScheduleObject Class Methods
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObject Class

"

For a list of all members of this type, see dbiScheduleObject members.

"

See Also

Reference

dbiScheduleObject Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%% $$Events$$

dbiScheduleObjectCollection Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiScheduleObjectCollection Class

"

For a list of all members of this type, see dbiScheduleObjectCollection members.

"

See Also

Reference

dbiScheduleObjectCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiScheduleObjectCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : dbiScheduleObjectCollection Constructor

Overload List

Overload | Description
dbiScheduleObjectCollection Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

CollectionChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : CollectionChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim handler As NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
C#
[__DynamicallyInvokableAttribute()]
public event NotifyCollectionChangedEventHandler CollectionChanged

Event Data

The event handler receives an argument of type NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : Contains Method

item
The object to locate in the Collection. The value can be null for reference types.
Determines whether an element is in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim item As dbiScheduleObject
Dim value As Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public bool Contains(
   dbiScheduleObject item
)

Parameters

item
The object to locate in the Collection. The value can be null for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim array() As dbiScheduleObject
Dim index As Integer

instance.CopyTo(array, index)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   dbiScheduleObject[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : Count Property

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim value As Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim value As IEnumerator(Of dbiScheduleObject)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public IEnumerator<dbiScheduleObject> GetEnumerator()

Return Value

An IEnumerator for the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

Move Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObjectCollection Class : Move Method

oldIndex
newIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObjectCollection
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObjectCollection Class
dbiScheduleObjectCollection Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleObject Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ActualHeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ActualHeight Property

Gets the rendered height of this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

value = instance.ActualHeight
C#
public double ActualHeight {get;}

Property Value

The element's height, as a value in device-independent units (1/96th inch per unit). The default value is 0 (zero).

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ActualWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ActualWidth Property

Gets the rendered width of this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

value = instance.ActualWidth
C#
public double ActualWidth {get;}

Property Value

The element's width, as a value in device-independent units (1/96th inch per unit). The default value is 0 (zero).

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AddHandler Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AddHandler Method

Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AddHandler(RoutedEvent,Delegate) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > AddHandler Method : AddHandler(RoutedEvent,Delegate) Method

routedEvent
An identifier for the routed event to be handled.
handler
A reference to the handler implementation.
Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim routedEvent As RoutedEvent
Dim handler As Delegate

instance.AddHandler(routedEvent, handler)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler
)

Parameters

routedEvent
An identifier for the routed event to be handled.
handler
A reference to the handler implementation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

AddHandler(RoutedEvent,Delegate,Boolean) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > AddHandler Method : AddHandler(RoutedEvent,Delegate,Boolean) Method

routedEvent
An identifier for the routed event to be handled.
handler
A reference to the handler implementation.
handledEventsToo
true to register the handler such that it is invoked even when the routed event is marked handled in its event data; false to register the handler with the default condition that it will not be invoked if the routed event is already marked handled. The default is false.Do not routinely ask to rehandle a routed event. For more information, see Remarks.
Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim routedEvent As RoutedEvent
Dim handler As Delegate
Dim handledEventsToo As Boolean

instance.AddHandler(routedEvent, handler, handledEventsToo)
C#
public void AddHandler(
   RoutedEvent routedEvent,
   Delegate handler,
   bool handledEventsToo
)

Parameters

routedEvent
An identifier for the routed event to be handled.
handler
A reference to the handler implementation.
handledEventsToo
true to register the handler such that it is invoked even when the routed event is marked handled in its event data; false to register the handler with the default condition that it will not be invoked if the routed event is already marked handled. The default is false.Do not routinely ask to rehandle a routed event. For more information, see Remarks.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

AddToEventRoute Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AddToEventRoute Method

route
The event route that handlers are added to.
e
The event data that is used to add the handlers. This method uses the System.Windows.RoutedEventArgs.RoutedEvent property of the event data to create the handlers.
Adds handlers to the specified System.Windows.EventRoute for the current System.Windows.UIElement event handler collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim route As EventRoute
Dim e As RoutedEventArgs

instance.AddToEventRoute(route, e)
C#
public void AddToEventRoute(
   EventRoute route,
   RoutedEventArgs e
)

Parameters

route
The event route that handlers are added to.
e
The event data that is used to add the handlers. This method uses the System.Windows.RoutedEventArgs.RoutedEvent property of the event data to create the handlers.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AllowDrop Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AllowDrop Property

Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public bool AllowDrop {get; set;}

Property Value

true if this element can be used as the target of a drag-and-drop operation; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ApplyAnimationClock Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ApplyAnimationClock Method

Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ApplyAnimationClock(DependencyProperty,AnimationClock) Method
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > ApplyAnimationClock Method : ApplyAnimationClock(DependencyProperty,AnimationClock) Method

dp
The identifier for the property to animate.
clock
The animation clock that controls and declares the animation.
Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim clock As AnimationClock

instance.ApplyAnimationClock(dp, clock)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void ApplyAnimationClock(
   DependencyProperty dp,
   AnimationClock clock
)

Parameters

dp
The identifier for the property to animate.
clock
The animation clock that controls and declares the animation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) Method
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > ApplyAnimationClock Method : ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) Method

dp
The property to animate.
clock
The animation clock that controls and declares the animation.
handoffBehavior
A value of the enumeration. The default is System.Windows.Media.Animation.HandoffBehavior.SnapshotAndReplace, which will stop any existing animation and replace with the new one.
Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim clock As AnimationClock
Dim handoffBehavior As HandoffBehavior

instance.ApplyAnimationClock(dp, clock, handoffBehavior)
C#
public void ApplyAnimationClock(
   DependencyProperty dp,
   AnimationClock clock,
   HandoffBehavior handoffBehavior
)

Parameters

dp
The property to animate.
clock
The animation clock that controls and declares the animation.
handoffBehavior
A value of the enumeration. The default is System.Windows.Media.Animation.HandoffBehavior.SnapshotAndReplace, which will stop any existing animation and replace with the new one.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

ApplyTemplate Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ApplyTemplate Method

Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.ApplyTemplate()
C#
public bool ApplyTemplate()

Return Value

true if visuals were added to the tree; returns false otherwise.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AreAnyTouchesCaptured Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AreAnyTouchesCaptured Property

Gets a value that indicates whether at least one touch is captured to this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.AreAnyTouchesCaptured
C#
public bool AreAnyTouchesCaptured {get;}

Property Value

true if at least one touch is captured to this element; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AreAnyTouchesCapturedWithin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AreAnyTouchesCapturedWithin Property

Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.AreAnyTouchesCapturedWithin
C#
public bool AreAnyTouchesCapturedWithin {get;}

Property Value

true if at least one touch is captured to this element or any child elements in its visual tree; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AreAnyTouchesDirectlyOver Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AreAnyTouchesDirectlyOver Property

Gets a value that indicates whether at least one touch is pressed over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.AreAnyTouchesDirectlyOver
C#
public bool AreAnyTouchesDirectlyOver {get;}

Property Value

true if at least one touch is pressed over this element; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

AreAnyTouchesOver Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : AreAnyTouchesOver Property

Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.AreAnyTouchesOver
C#
public bool AreAnyTouchesOver {get;}

Property Value

true if at least one touch is pressed over this element or any child elements in its visual tree; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Arrange Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Arrange Method

finalRect
The final size that the parent computes for the child element, provided as a System.Windows.Rect instance.
Positions child elements and determines a size for a System.Windows.UIElement. Parent elements call this method from their System.Windows.UIElement.ArrangeCore(System.Windows.Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim finalRect As Rect

instance.Arrange(finalRect)
C#
public void Arrange(
   Rect finalRect
)

Parameters

finalRect
The final size that the parent computes for the child element, provided as a System.Windows.Rect instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Background Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Background Property

Gets or sets a brush that describes the background of a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.Background = value

value = instance.Background
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Appearance")]
public Brush Background {get; set;}

Property Value

The brush that is used to fill the background of the control. The default is System.Windows.Media.Brushes.Transparent.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeginAnimation Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeginAnimation Method

Starts an animation for a specified animated property on this element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeginAnimation(DependencyProperty,AnimationTimeline) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > BeginAnimation Method : BeginAnimation(DependencyProperty,AnimationTimeline) Method

dp
The property to animate, which is specified as a dependency property identifier.
animation
The timeline of the animation to start.
Starts an animation for a specified animated property on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim animation As AnimationTimeline

instance.BeginAnimation(dp, animation)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void BeginAnimation(
   DependencyProperty dp,
   AnimationTimeline animation
)

Parameters

dp
The property to animate, which is specified as a dependency property identifier.
animation
The timeline of the animation to start.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) Method
See Also
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > BeginAnimation Method : BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) Method

dp
The property to animate, which is specified as the dependency property identifier.
animation
The timeline of the animation to be applied.
handoffBehavior
A value of the enumeration that specifies how the new animation interacts with any current (running) animations that are already affecting the property value.
Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim animation As AnimationTimeline
Dim handoffBehavior As HandoffBehavior

instance.BeginAnimation(dp, animation, handoffBehavior)
C#
public void BeginAnimation(
   DependencyProperty dp,
   AnimationTimeline animation,
   HandoffBehavior handoffBehavior
)

Parameters

dp
The property to animate, which is specified as the dependency property identifier.
animation
The timeline of the animation to be applied.
handoffBehavior
A value of the enumeration that specifies how the new animation interacts with any current (running) animations that are already affecting the property value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

BeginInit Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeginInit Method

Starts the initialization process for this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.BeginInit()
C#
public virtual void BeginInit()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeginStoryboard Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BeginStoryboard Method

Begins the sequence of actions that are contained in the provided storyboard.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BeginStoryboard(Storyboard) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > BeginStoryboard Method : BeginStoryboard(Storyboard) Method

storyboard
The storyboard to begin.
Begins the sequence of actions that are contained in the provided storyboard.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim storyboard As Storyboard

instance.BeginStoryboard(storyboard)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void BeginStoryboard(
   Storyboard storyboard
)

Parameters

storyboard
The storyboard to begin.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

BeginStoryboard(Storyboard,HandoffBehavior) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > BeginStoryboard Method : BeginStoryboard(Storyboard,HandoffBehavior) Method

storyboard
The storyboard to begin.
handoffBehavior
A value of the enumeration that describes behavior to use if a property described in the storyboard is already animated.
Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim storyboard As Storyboard
Dim handoffBehavior As HandoffBehavior

instance.BeginStoryboard(storyboard, handoffBehavior)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void BeginStoryboard(
   Storyboard storyboard,
   HandoffBehavior handoffBehavior
)

Parameters

storyboard
The storyboard to begin.
handoffBehavior
A value of the enumeration that describes behavior to use if a property described in the storyboard is already animated.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

BeginStoryboard(Storyboard,HandoffBehavior,Boolean) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > BeginStoryboard Method : BeginStoryboard(Storyboard,HandoffBehavior,Boolean) Method

storyboard
The storyboard to begin.
handoffBehavior
A value of the enumeration that describes behavior to use if a property described in the storyboard is already animated.
isControllable
Declares whether the animation is controllable (can be paused) after it is started.
Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim storyboard As Storyboard
Dim handoffBehavior As HandoffBehavior
Dim isControllable As Boolean

instance.BeginStoryboard(storyboard, handoffBehavior, isControllable)
C#
public void BeginStoryboard(
   Storyboard storyboard,
   HandoffBehavior handoffBehavior,
   bool isControllable
)

Parameters

storyboard
The storyboard to begin.
handoffBehavior
A value of the enumeration that describes behavior to use if a property described in the storyboard is already animated.
isControllable
Declares whether the animation is controllable (can be paused) after it is started.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

BindingGroup Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BindingGroup Property

Gets or sets the System.Windows.Data.BindingGroup that is used for the element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As BindingGroup

instance.BindingGroup = value

value = instance.BindingGroup
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[LocalizabilityAttribute(Category=LocalizationCategory.Text |
    LocalizationCategory.Ignore |
    LocalizationCategory.NeverLocalize,
   Readability=Readability.Readable,
   Modifiability=Modifiability.Modifiable)]
public BindingGroup BindingGroup {get; set;}

Property Value

The System.Windows.Data.BindingGroup that is used for the element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BorderThickness Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BorderThickness Property

Gets or sets the border thickness of a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Thickness

instance.BorderThickness = value

value = instance.BorderThickness
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Appearance")]
public Thickness BorderThickness {get; set;}

Property Value

A thickness value; the default is a thickness of 0 on all four sides.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BringIntoView Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : BringIntoView Method

Attempts to bring this element into view, within any scrollable regions it is contained within.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

BringIntoView() Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > BringIntoView Method : BringIntoView() Method

Attempts to bring this element into view, within any scrollable regions it is contained within.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.BringIntoView()
C#
public void BringIntoView()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

BringIntoView(Rect) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > BringIntoView Method : BringIntoView(Rect) Method

targetRectangle
Specified size of the element that should also be brought into view.
Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim targetRectangle As Rect

instance.BringIntoView(targetRectangle)
C#
public void BringIntoView(
   Rect targetRectangle
)

Parameters

targetRectangle
Specified size of the element that should also be brought into view.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

CacheMode Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CacheMode Property

Gets or sets a cached representation of the System.Windows.UIElement.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As CacheMode

instance.CacheMode = value

value = instance.CacheMode
C#
public CacheMode CacheMode {get; set;}

Property Value

A System.Windows.Media.CacheMode that holds a cached representation of the System.Windows.UIElement.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CaptureMouse Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CaptureMouse Method

Attempts to force capture of the mouse to this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.CaptureMouse()
C#
public bool CaptureMouse()

Return Value

true if the mouse is successfully captured; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CaptureStylus Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CaptureStylus Method

Attempts to force capture of the stylus to this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.CaptureStylus()
C#
public bool CaptureStylus()

Return Value

true if the stylus was successfully captured; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CaptureTouch Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CaptureTouch Method

touchDevice
The device to capture.
Attempts to force capture of a touch to this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim touchDevice As TouchDevice
Dim value As Boolean

value = instance.CaptureTouch(touchDevice)
C#
public bool CaptureTouch(
   TouchDevice touchDevice
)

Parameters

touchDevice
The device to capture.

Return Value

true if the specified touch is captured to this element; otherwise, false.

Exceptions

Exception | Description
System.ArgumentNullException | touchDevice is null.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

Clip Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Clip Property

Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Geometry

instance.Clip = value

value = instance.Clip
C#
public Geometry Clip {get; set;}

Property Value

The geometry to be used for clipping area sizing. The default is a null System.Windows.Media.Geometry.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ClipToBounds Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ClipToBounds Property

Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.ClipToBounds = value

value = instance.ClipToBounds
C#
public bool ClipToBounds {get; set;}

Property Value

true if the content should be clipped; otherwise, false. The default value is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

CommandBindings Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : CommandBindings Property

Gets a collection of System.Windows.Input.CommandBinding objects associated with this element. A System.Windows.Input.CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As CommandBindingCollection

value = instance.CommandBindings
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public CommandBindingCollection CommandBindings {get;}

Property Value

The collection of all System.Windows.Input.CommandBinding objects.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Content Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Content Property

Gets or sets the content of a System.Windows.Controls.ContentControl.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Object

instance.Content = value

value = instance.Content
C#
[CustomCategoryAttribute("Content")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public object Content {get; set;}

Property Value

An object that contains the control's content. The default value is null.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ContentStringFormat Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ContentStringFormat Property

Gets or sets a composite string that specifies how to format the System.Windows.Controls.ContentControl.Content property if it is displayed as a string.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As String

instance.ContentStringFormat = value

value = instance.ContentStringFormat
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CustomCategoryAttribute("Content")]
public string ContentStringFormat {get; set;}

Property Value

A composite string that specifies how to format the System.Windows.Controls.ContentControl.Content property if it is displayed as a string.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ContentTemplate Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ContentTemplate Property

Gets or sets the data template used to display the content of the System.Windows.Controls.ContentControl.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As DataTemplate

instance.ContentTemplate = value

value = instance.ContentTemplate
C#
[CustomCategoryAttribute("Content")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public DataTemplate ContentTemplate {get; set;}

Property Value

A data template. The default value is null.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ContentTemplateSelector Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ContentTemplateSelector Property

Gets or sets a template selector that enables an application writer to provide custom template-selection logic.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As DataTemplateSelector

instance.ContentTemplateSelector = value

value = instance.ContentTemplateSelector
C#
[CustomCategoryAttribute("Content")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public DataTemplateSelector ContentTemplateSelector {get; set;}

Property Value

A data template selector. The default value is null.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ContextMenu Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ContextMenu Property

Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
public ContextMenu ContextMenu {get; set;}

Property Value

The context menu assigned to this element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ContextMenuClosing Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ContextMenuClosing Event

Occurs just before any context menu on the element is closed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As ContextMenuEventHandler

AddHandler instance.ContextMenuClosing, handler
C#
public event ContextMenuEventHandler ContextMenuClosing

Event Data

The event handler receives an argument of type ContextMenuEventArgs containing data related to this event. The following ContextMenuEventArgs properties provide information specific to this event.

Property | Description
CursorLeft | Gets the horizontal position of the mouse.
CursorTop | Gets the vertical position of the mouse.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ContextMenuOpening Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ContextMenuOpening Event

Occurs when any context menu on the element is opened.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As ContextMenuEventHandler

AddHandler instance.ContextMenuOpening, handler
C#
public event ContextMenuEventHandler ContextMenuOpening

Event Data

The event handler receives an argument of type ContextMenuEventArgs containing data related to this event. The following ContextMenuEventArgs properties provide information specific to this event.

Property | Description
CursorLeft | Gets the horizontal position of the mouse.
CursorTop | Gets the vertical position of the mouse.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Cursor Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Cursor Property

Gets or sets the cursor that displays when the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
C#
public Cursor Cursor {get; set;}

Property Value

The cursor to display. The default value is defined as null per this dependency property. However, the practical default at run time will come from a variety of factors.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DataContext Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DataContext Property

Gets or sets the data context for an element when it participates in data binding.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Object

instance.DataContext = value

value = instance.DataContext
C#
[LocalizabilityAttribute(Category=LocalizationCategory.Text |
    LocalizationCategory.Ignore |
    LocalizationCategory.NeverLocalize,
   Readability=Readability.Readable,
   Modifiability=Modifiability.Modifiable)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public object DataContext {get; set;}

Property Value

The object to use as data context.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DataContextChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DataContextChanged Event

Occurs when the data context for this element changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.DataContextChanged, handler
C#
public event DependencyPropertyChangedEventHandler DataContextChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DesiredSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DesiredSize Property

Gets the size that this element computed during the measure pass of the layout process.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Size

value = instance.DesiredSize
C#
public Size DesiredSize {get;}

Property Value

The computed size, which becomes the desired size for the arrange pass.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DragEnter Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DragEnter Event

Occurs when the input system reports an underlying drag event with this element as the drag target.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DragEventHandler

AddHandler instance.DragEnter, handler
C#
public event DragEventHandler DragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DragLeave Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DragLeave Event

Occurs when the input system reports an underlying drag event with this element as the drag origin.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DragEventHandler

AddHandler instance.DragLeave, handler
C#
public event DragEventHandler DragLeave

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

DragOver Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : DragOver Event

Occurs when the input system reports an underlying drag event with this element as the potential drop target.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DragEventHandler

AddHandler instance.DragOver, handler
C#
public event DragEventHandler DragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Drop Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Drop Event

Occurs when the input system reports an underlying drop event with this element as the drop target.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DragEventHandler

AddHandler instance.Drop, handler
C#
public event DragEventHandler Drop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Effect Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Effect Property

Gets or sets the bitmap effect to apply to the System.Windows.UIElement. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Effect

instance.Effect = value

value = instance.Effect
C#
public Effect Effect {get; set;}

Property Value

An System.Windows.Media.Effects.Effect that represents the bitmap effect.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

EndInit Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : EndInit Method

Indicates that the initialization process for the element is complete.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.EndInit()
C#
public virtual void EndInit()

Exceptions

Exception | Description
System.InvalidOperationException | System.Windows.FrameworkElement.EndInit was called without System.Windows.FrameworkElement.BeginInit having previously been called on the element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FindCommonVisualAncestor Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FindCommonVisualAncestor Method

otherVisual
A visual object of type System.Windows.DependencyObject.
Returns the common ancestor of two visual objects.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim otherVisual As DependencyObject
Dim value As DependencyObject

value = instance.FindCommonVisualAncestor(otherVisual)
C#
public DependencyObject FindCommonVisualAncestor(
   DependencyObject otherVisual
)

Parameters

otherVisual
A visual object of type System.Windows.DependencyObject.

Return Value

The common ancestor of the visual object and otherVisual if one exists; otherwise, null.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FindName Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FindName Method

Finds an element that has the provided identifier name.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FindName(String) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FindName(String) Method

name
The name of the requested element.
Finds an element that has the provided identifier name.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim name As String
Dim value As Object

value = instance.FindName(name)
C#
public object FindName(
   string name
)

Parameters

name
The name of the requested element.

Return Value

The requested element. This can be null if no matching element was found.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FindResource Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FindResource Method

resourceKey
The key identifier for the requested resource.
Searches for a resource with the specified key, and throws an exception if the requested resource is not found.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim resourceKey As Object
Dim value As Object

value = instance.FindResource(resourceKey)
C#
public object FindResource(
   object resourceKey
)

Parameters

resourceKey
The key identifier for the requested resource.

Return Value

The requested resource. If no resource with the provided key was found, an exception is thrown. An System.Windows.DependencyProperty.UnsetValue value might also be returned in the exception case.

Exceptions

Exception | Description
System.Windows.ResourceReferenceKeyNotFoundException | resourceKey was not found and an event handler does not exist for the System.Windows.Threading.Dispatcher.UnhandledException event.-or-resourceKey was not found and the System.Windows.Threading.DispatcherUnhandledExceptionEventArgs.Handled property is false in the System.Windows.Threading.Dispatcher.UnhandledException event.
System.ArgumentNullException | resourceKey is null.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FlowDirection Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FlowDirection Property

Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FlowDirection

instance.FlowDirection = value

value = instance.FlowDirection
C#
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Readable,
   Modifiability=Modifiability.Modifiable)]
public FlowDirection FlowDirection {get; set;}

Property Value

The direction that text and other UI elements flow within their parent element, as a value of the enumeration. The default value is System.Windows.FlowDirection.LeftToRight.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Focus Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Focus Method

Attempts to set focus to this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.Focus()
C#
public bool Focus()

Return Value

true if keyboard focus and logical focus were set to this element; false if only logical focus was set to this element, or if the call to this method did not force the focus to change.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Focusable Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Focusable Property

Gets or sets a value that indicates whether the element can receive focus. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.Focusable = value

value = instance.Focusable
C#
public bool Focusable {get; set;}

Property Value

true if the element is focusable; otherwise false. The default is false, but see Remarks.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FocusableChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FocusableChanged Event

Occurs when the value of the System.Windows.UIElement.Focusable property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.FocusableChanged, handler
C#
public event DependencyPropertyChangedEventHandler FocusableChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FocusVisualStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FocusVisualStyle Property

Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Style

instance.FocusVisualStyle = value

value = instance.FocusVisualStyle
C#
public Style FocusVisualStyle {get; set;}

Property Value

The desired style to apply on focus. The default value as declared in the dependency property is an empty static System.Windows.Style. However, the effective value at run time is often (but not always) a style as supplied by theme support for controls.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FontFamily Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FontFamily Property

Gets or sets the font family of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontFamily

instance.FontFamily = value

value = instance.FontFamily
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[LocalizabilityAttribute(Category=LocalizationCategory.Title |
    LocalizationCategory.Button |
    LocalizationCategory.ComboBox |
    LocalizationCategory.Menu |
    LocalizationCategory.ToolTip |
    LocalizationCategory.TextFlow |
    LocalizationCategory.Font,
   Readability=Readability.Readable,
   Modifiability=Modifiability.Modifiable)]
[CategoryAttribute("Appearance")]
public FontFamily FontFamily {get; set;}

Property Value

A font family. The default is the system dialog font.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FontSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FontSize Property

Gets or sets the font size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.FontSize = value

value = instance.FontSize
C#
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Readable,
   Modifiability=Modifiability.Modifiable)]
[TypeConverterAttribute("System.Windows.FontSizeConverter, PresentationFramework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Appearance")]
public double FontSize {get; set;}

Property Value

The size of the text in the System.Windows.Controls.Control. The default is System.Windows.SystemFonts.MessageFontSize. The font size must be a positive number.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FontStretch Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FontStretch Property

Gets or sets the degree to which a font is condensed or expanded on the screen.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontStretch

instance.FontStretch = value

value = instance.FontStretch
C#
[CategoryAttribute("Appearance")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public FontStretch FontStretch {get; set;}

Property Value

A System.Windows.FontStretch value. The default is System.Windows.FontStretches.Normal.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FontStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FontStyle Property

Gets or sets the font style.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontStyle

instance.FontStyle = value

value = instance.FontStyle
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Appearance")]
public FontStyle FontStyle {get; set;}

Property Value

A System.Windows.FontStyle value. The default is System.Windows.FontStyles.Normal.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

FontWeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : FontWeight Property

Gets or sets the weight or thickness of the specified font.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As FontWeight

instance.FontWeight = value

value = instance.FontWeight
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Appearance")]
public FontWeight FontWeight {get; set;}

Property Value

A System.Windows.FontWeight value. The default is System.Windows.FontWeights.Normal.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ForceCursor Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ForceCursor Property

Gets or sets a value that indicates whether this System.Windows.FrameworkElement should force the user interface (UI) to render the cursor as declared by the System.Windows.FrameworkElement.Cursor property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.ForceCursor = value

value = instance.ForceCursor
C#
public bool ForceCursor {get; set;}

Property Value

true if cursor presentation while over this element is forced to use current System.Windows.FrameworkElement.Cursor settings for the cursor (including on all child elements); otherwise false. The default value is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Foreground Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Foreground Property

Gets or sets a brush that describes the foreground color.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.Foreground = value

value = instance.Foreground
C#
[CategoryAttribute("Appearance")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public Brush Foreground {get; set;}

Property Value

The brush that paints the foreground of the control. The default value is the system dialog font color.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GetAnimationBaseValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GetAnimationBaseValue Method

dp
The dependency property to check.
Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetAnimationBaseValue(dp)
C#
public object GetAnimationBaseValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to check.

Return Value

The property value as if no animations are attached to the specified dependency property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GetBindingExpression Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GetBindingExpression Method

dp
The target System.Windows.DependencyProperty to get the binding from.
Returns the System.Windows.Data.BindingExpression that represents the binding on the specified property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim value As BindingExpression

value = instance.GetBindingExpression(dp)
C#
public BindingExpression GetBindingExpression(
   DependencyProperty dp
)

Parameters

dp
The target System.Windows.DependencyProperty to get the binding from.

Return Value

A System.Windows.Data.BindingExpression if the target property has an active binding; otherwise, returns null.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GiveFeedback Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GiveFeedback Event

Occurs when the input system reports an underlying drag-and-drop event that involves this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
public event GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effects | Gets a value that indicates the effects of drag-and-drop operation.
UseDefaultCursors | Gets or sets a Boolean value indicating whether default cursor feedback behavior should be used for the associated drag-and-drop operation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GotFocus Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GotFocus Event

Occurs when this element gets logical focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As RoutedEventHandler

AddHandler instance.GotFocus, handler
C#
public event RoutedEventHandler GotFocus

Event Data

The event handler receives an argument of type RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance.
Source | Gets or sets a reference to the object that raised the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GotKeyboardFocus Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GotKeyboardFocus Event

Occurs when the keyboard is focused on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As KeyboardFocusChangedEventHandler

AddHandler instance.GotKeyboardFocus, handler
C#
public event KeyboardFocusChangedEventHandler GotKeyboardFocus

Event Data

The event handler receives an argument of type KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GotMouseCapture Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GotMouseCapture Event

Occurs when this element captures the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseEventHandler

AddHandler instance.GotMouseCapture, handler
C#
public event MouseEventHandler GotMouseCapture

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
RightButton | Gets the current state of the right mouse button.
StylusDevice | Gets the stylus device associated with this event.
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GotStylusCapture Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GotStylusCapture Event

Occurs when this element captures the stylus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.GotStylusCapture, handler
C#
public event StylusEventHandler GotStylusCapture

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

GotTouchCapture Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : GotTouchCapture Event

Occurs when a touch is captured to this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.GotTouchCapture, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> GotTouchCapture

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HasAnimatedProperties Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HasAnimatedProperties Property

Gets a value indicating whether this element has any animated properties.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.HasAnimatedProperties
C#
public bool HasAnimatedProperties {get;}

Property Value

true if this element has animations attached to any of its properties; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HasContent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HasContent Property

Gets a value that indicates whether the System.Windows.Controls.ContentControl contains content.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.HasContent
C#
[BrowsableAttribute(false)]
[ReadOnlyAttribute(true)]
public bool HasContent {get;}

Property Value

true if the System.Windows.Controls.ContentControl has content; otherwise false. The default value is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Height Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Height Property

Gets or sets the suggested height of the element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.Height = value

value = instance.Height
C#
[TypeConverterAttribute("System.Windows.LengthConverter, PresentationFramework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Unreadable,
   Modifiability=Modifiability.Modifiable)]
public double Height {get; set;}

Property Value

The height of the element, in device-independent units (1/96th inch per unit). The default value is System.Double.NaN. This value must be equal to or greater than 0.0. See Remarks for upper bound information.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HorizontalAlignment Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HorizontalAlignment Property

Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As HorizontalAlignment

instance.HorizontalAlignment = value

value = instance.HorizontalAlignment
C#
public HorizontalAlignment HorizontalAlignment {get; set;}

Property Value

A horizontal alignment setting, as a value of the enumeration. The default is System.Windows.HorizontalAlignment.Stretch.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

HorizontalContentAlignment Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : HorizontalContentAlignment Property

Gets or sets the horizontal alignment of the control's content.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As HorizontalAlignment

instance.HorizontalContentAlignment = value

value = instance.HorizontalContentAlignment
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Layout")]
public HorizontalAlignment HorizontalContentAlignment {get; set;}

Property Value

One of the System.Windows.HorizontalAlignment values. The default is System.Windows.HorizontalAlignment.Left.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Initialized Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Initialized Event

Occurs when this System.Windows.FrameworkElement is initialized. This event coincides with cases where the value of the System.Windows.FrameworkElement.IsInitialized property changes from false (or undefined) to true.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler

AddHandler instance.Initialized, handler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event EventHandler Initialized

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InputBindings Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InputBindings Property

Gets the collection of input bindings associated with this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As InputBindingCollection

value = instance.InputBindings
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public InputBindingCollection InputBindings {get;}

Property Value

The collection of input bindings.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InputHitTest Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InputHitTest Method

Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InputHitTest(Point) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InputHitTest(Point) Method

point
The offset coordinates within this element.
Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim point As Point
Dim value As IInputElement

value = instance.InputHitTest(point)
C#
public IInputElement InputHitTest(
   Point point
)

Parameters

point
The offset coordinates within this element.

Return Value

The element child that is located at the given position.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InputScope Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InputScope Property

Gets or sets the context for input used by this System.Windows.FrameworkElement.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As InputScope

instance.InputScope = value

value = instance.InputScope
C#
public InputScope InputScope {get; set;}

Property Value

The input scope, which modifies how input from alternative input methods is interpreted. The default value is null (which results in a default handling of commands).

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Invalidate Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Invalidate Method

Invalidates the control to cause it to redraw itself.

Overload List

Overload | Description
Invalidate | Invalidates the control to cause it to redraw itself.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InvalidateArrange Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InvalidateArrange Method

Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by System.Windows.UIElement.UpdateLayout.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.InvalidateArrange()
C#
public void InvalidateArrange()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InvalidateMeasure Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InvalidateMeasure Method

Invalidates the measurement state (layout) for the element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.InvalidateMeasure()
C#
public void InvalidateMeasure()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

InvalidateVisual Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : InvalidateVisual Method

Invalidates the rendering of the element, and forces a complete new layout pass. System.Windows.UIElement.OnRender(System.Windows.Media.DrawingContext) is called after the layout cycle is completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.InvalidateVisual()
C#
public void InvalidateVisual()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsAncestorOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsAncestorOf Method

descendant
A value of type System.Windows.DependencyObject.
Determines whether the visual object is an ancestor of the descendant visual object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim descendant As DependencyObject
Dim value As Boolean

value = instance.IsAncestorOf(descendant)
C#
public bool IsAncestorOf(
   DependencyObject descendant
)

Parameters

descendant
A value of type System.Windows.DependencyObject.

Return Value

true if the visual object is an ancestor of descendant; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsArrangeValid Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsArrangeValid Property

Gets a value indicating whether the computed size and position of child elements in this element's layout are valid.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsArrangeValid
C#
public bool IsArrangeValid {get;}

Property Value

true if the size and position of layout are valid; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsDescendantOf Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsDescendantOf Method

ancestor
A value of type System.Windows.DependencyObject.
Determines whether the visual object is a descendant of the ancestor visual object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ancestor As DependencyObject
Dim value As Boolean

value = instance.IsDescendantOf(ancestor)
C#
public bool IsDescendantOf(
   DependencyObject ancestor
)

Parameters

ancestor
A value of type System.Windows.DependencyObject.

Return Value

true if the visual object is a descendant of ancestor; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsEnabled Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsEnabled Property

Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.IsEnabled = value

value = instance.IsEnabled
C#
public bool IsEnabled {get; set;}

Property Value

true if the element is enabled; otherwise, false. The default value is true.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsEnabledChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsEnabledChanged Event

Occurs when the value of the System.Windows.UIElement.IsEnabled property on this element changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsEnabledChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsEnabledChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsFocused Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsFocused Property

Gets a value that determines whether this element has logical focus. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsFocused
C#
public bool IsFocused {get;}

Property Value

true if this element has logical focus; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsHitTestVisible Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsHitTestVisible Property

Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.IsHitTestVisible = value

value = instance.IsHitTestVisible
C#
public bool IsHitTestVisible {get; set;}

Property Value

true if this element could be returned as a hit test result from at least one point; otherwise, false. The default value is true.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsHitTestVisibleChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsHitTestVisibleChanged Event

Occurs when the value of the System.Windows.UIElement.IsHitTestVisible dependency property changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsHitTestVisibleChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsHitTestVisibleChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsInitialized Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsInitialized Property

Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its System.Windows.FrameworkElement.EndInit method called.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsInitialized
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public bool IsInitialized {get;}

Property Value

true if the element is initialized per the aforementioned XAML processing or method calls; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsInputMethodEnabled Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsInputMethodEnabled Property

Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsInputMethodEnabled
C#
public bool IsInputMethodEnabled {get;}

Property Value

true if an input method is active; otherwise, false. The default value of the underlying attached property is true; however, this will be influenced by the actual state of input methods at runtime.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsKeyboardFocused Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsKeyboardFocused Property

Gets a value indicating whether this element has keyboard focus. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsKeyboardFocused
C#
public bool IsKeyboardFocused {get;}

Property Value

true if this element has keyboard focus; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsKeyboardFocusedChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsKeyboardFocusedChanged Event

Occurs when the value of the System.Windows.UIElement.IsKeyboardFocused property changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsKeyboardFocusedChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsKeyboardFocusedChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsKeyboardFocusWithin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsKeyboardFocusWithin Property

Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsKeyboardFocusWithin
C#
public bool IsKeyboardFocusWithin {get;}

Property Value

true if keyboard focus is on the element or its child elements; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsKeyboardFocusWithinChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsKeyboardFocusWithinChanged Event

Occurs when the value of the System.Windows.UIElement.IsKeyboardFocusWithinChanged property changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsKeyboardFocusWithinChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsKeyboardFocusWithinChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsLoaded Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsLoaded Property

Gets a value that indicates whether this element has been loaded for presentation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsLoaded
C#
public bool IsLoaded {get;}

Property Value

true if the current element is attached to an element tree; false if the element has never been attached to a loaded element tree.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsManipulationEnabled Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsManipulationEnabled Property

Gets or sets a value that indicates whether manipulation events are enabled on this System.Windows.UIElement.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.IsManipulationEnabled = value

value = instance.IsManipulationEnabled
C#
[CustomCategoryAttribute("Touch")]
public bool IsManipulationEnabled {get; set;}

Property Value

true if manipulation events are enabled on this System.Windows.UIElement; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsMeasureValid Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsMeasureValid Property

Gets a value indicating whether the current size returned by layout measure is valid.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsMeasureValid
C#
public bool IsMeasureValid {get;}

Property Value

true if the measure pass of layout returned a valid and current value; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsMouseCaptured Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsMouseCaptured Property

Gets a value indicating whether the mouse is captured to this element. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsMouseCaptured
C#
public bool IsMouseCaptured {get;}

Property Value

true if the element has mouse capture; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsMouseCapturedChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsMouseCapturedChanged Event

Occurs when the value of the System.Windows.UIElement.IsMouseCaptured property changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsMouseCapturedChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsMouseCapturedChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsMouseCaptureWithin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsMouseCaptureWithin Property

Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsMouseCaptureWithin
C#
public bool IsMouseCaptureWithin {get;}

Property Value

true if this element or a contained element has mouse capture; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsMouseCaptureWithinChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsMouseCaptureWithinChanged Event

Occurs when the value of the System.Windows.UIElement.IsMouseCaptureWithinProperty changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsMouseCaptureWithinChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsMouseCaptureWithinChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsMouseDirectlyOver Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsMouseDirectlyOver Property

Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsMouseDirectlyOver
C#
public bool IsMouseDirectlyOver {get;}

Property Value

true if the mouse pointer is over the same element result as a hit test; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsMouseDirectlyOverChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsMouseDirectlyOverChanged Event

Occurs when the value of the System.Windows.UIElement.IsMouseDirectlyOver property changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsMouseDirectlyOverChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsMouseDirectlyOverChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsMouseOver Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsMouseOver Property

Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsMouseOver
C#
public bool IsMouseOver {get;}

Property Value

true if mouse pointer is over the element or its child elements; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsStylusCaptured Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsStylusCaptured Property

Gets a value indicating whether the stylus is captured by this element. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsStylusCaptured
C#
public bool IsStylusCaptured {get;}

Property Value

true if the element has stylus capture; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsStylusCapturedChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsStylusCapturedChanged Event

Occurs when the value of the System.Windows.UIElement.IsStylusCaptured property changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsStylusCapturedChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsStylusCapturedChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsStylusCaptureWithin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsStylusCaptureWithin Property

Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsStylusCaptureWithin
C#
public bool IsStylusCaptureWithin {get;}

Property Value

true if this element or a contained element has stylus capture; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsStylusCaptureWithinChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsStylusCaptureWithinChanged Event

Occurs when the value of the System.Windows.UIElement.IsStylusCaptureWithin property changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsStylusCaptureWithinChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsStylusCaptureWithinChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsStylusDirectlyOver Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsStylusDirectlyOver Property

Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsStylusDirectlyOver
C#
public bool IsStylusDirectlyOver {get;}

Property Value

true if the stylus pointer is over the same element result as a hit test; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsStylusDirectlyOverChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsStylusDirectlyOverChanged Event

Occurs when the value of the System.Windows.UIElement.IsStylusDirectlyOver property changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsStylusDirectlyOverChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsStylusDirectlyOverChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsStylusOver Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsStylusOver Property

Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsStylusOver
C#
public bool IsStylusOver {get;}

Property Value

true if stylus cursor is over the element or its child elements; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsTabStop Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsTabStop Property

Gets or sets a value that indicates whether a control is included in tab navigation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.IsTabStop = value

value = instance.IsTabStop
C#
[CategoryAttribute("Behavior")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public bool IsTabStop {get; set;}

Property Value

true if the control is included in tab navigation; otherwise, false. The default is true.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsVisible Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsVisible Property

Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.IsVisible
C#
public bool IsVisible {get;}

Property Value

true if the element is visible; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

IsVisibleChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : IsVisibleChanged Event

Occurs when the value of the System.Windows.UIElement.IsVisible property changes on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DependencyPropertyChangedEventHandler

AddHandler instance.IsVisibleChanged, handler
C#
public event DependencyPropertyChangedEventHandler IsVisibleChanged

Event Data

The event handler receives an argument of type DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

KeyDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : KeyDown Event

Occurs when a key is pressed while focus is on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As KeyEventHandler

AddHandler instance.KeyDown, handler
C#
public event KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character.
ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME).
InputSource | Gets the input source that provided this input.
IsDown | Gets a value that indicates whether the key referenced by the event is in the down state.
IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key.
IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state.
IsUp | Gets a value that indicates whether the key referenced by the event is in the up state.
Key | Gets the keyboard key associated with the event.
KeyStates | Gets the state of the keyboard key associated with this event.
SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

KeyUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : KeyUp Event

Occurs when a key is released while focus is on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As KeyEventHandler

AddHandler instance.KeyUp, handler
C#
public event KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character.
ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME).
InputSource | Gets the input source that provided this input.
IsDown | Gets a value that indicates whether the key referenced by the event is in the down state.
IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key.
IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state.
IsUp | Gets a value that indicates whether the key referenced by the event is in the up state.
Key | Gets the keyboard key associated with the event.
KeyStates | Gets the state of the keyboard key associated with this event.
SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Language Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Language Property

Gets or sets localization/globalization language information that applies to an element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As XmlLanguage

instance.Language = value

value = instance.Language
C#
public XmlLanguage Language {get; set;}

Property Value

The language information for this element. The default value is an System.Windows.Markup.XmlLanguage with its System.Windows.Markup.XmlLanguage.IetfLanguageTag value set to the string "en-US".

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LayoutTransform Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LayoutTransform Property

Gets or sets a graphics transformation that should apply to this element when layout is performed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Transform

instance.LayoutTransform = value

value = instance.LayoutTransform
C#
public Transform LayoutTransform {get; set;}

Property Value

The transform this element should use. The default is System.Windows.Media.Transform.Identity.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LayoutUpdated Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LayoutUpdated Event

Occurs when the layout of the various visual elements associated with the current System.Windows.Threading.Dispatcher changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler

AddHandler instance.LayoutUpdated, handler
C#
public event EventHandler LayoutUpdated

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Loaded Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Loaded Event

Occurs when the element is laid out, rendered, and ready for interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As RoutedEventHandler

AddHandler instance.Loaded, handler
C#
public event RoutedEventHandler Loaded

Event Data

The event handler receives an argument of type RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance.
Source | Gets or sets a reference to the object that raised the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LostFocus Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LostFocus Event

Occurs when this element loses logical focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As RoutedEventHandler

AddHandler instance.LostFocus, handler
C#
public event RoutedEventHandler LostFocus

Event Data

The event handler receives an argument of type RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance.
Source | Gets or sets a reference to the object that raised the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LostKeyboardFocus Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LostKeyboardFocus Event

Occurs when the keyboard is no longer focused on this element,.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As KeyboardFocusChangedEventHandler

AddHandler instance.LostKeyboardFocus, handler
C#
public event KeyboardFocusChangedEventHandler LostKeyboardFocus

Event Data

The event handler receives an argument of type KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LostMouseCapture Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LostMouseCapture Event

Occurs when this element loses mouse capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseEventHandler

AddHandler instance.LostMouseCapture, handler
C#
public event MouseEventHandler LostMouseCapture

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
RightButton | Gets the current state of the right mouse button.
StylusDevice | Gets the stylus device associated with this event.
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LostStylusCapture Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LostStylusCapture Event

Occurs when this element loses stylus capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.LostStylusCapture, handler
C#
public event StylusEventHandler LostStylusCapture

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

LostTouchCapture Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : LostTouchCapture Event

Occurs when this element loses a touch capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.LostTouchCapture, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> LostTouchCapture

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ManipulationBoundaryFeedback Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ManipulationBoundaryFeedback Event

Occurs when the manipulation encounters a boundary.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of ManipulationBoundaryFeedbackEventArgs)

AddHandler instance.ManipulationBoundaryFeedback, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<ManipulationBoundaryFeedbackEventArgs> ManipulationBoundaryFeedback

Event Data

The event handler receives an argument of type ManipulationBoundaryFeedbackEventArgs containing data related to this event. The following ManipulationBoundaryFeedbackEventArgs properties provide information specific to this event.

Property | Description
BoundaryFeedback | Gets the unused portion of the direct manipulation.
ManipulationContainer | Gets the container that the System.Windows.Input.ManipulationBoundaryFeedbackEventArgs.BoundaryFeedback property is relative to.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ManipulationCompleted Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ManipulationCompleted Event

Occurs when a manipulation and inertia on the System.Windows.UIElement object is complete.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of ManipulationCompletedEventArgs)

AddHandler instance.ManipulationCompleted, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<ManipulationCompletedEventArgs> ManipulationCompleted

Event Data

The event handler receives an argument of type ManipulationCompletedEventArgs containing data related to this event. The following ManipulationCompletedEventArgs properties provide information specific to this event.

Property | Description
FinalVelocities | Gets the velocities that are used for the manipulation.
IsInertial | Gets a value that indicates whether the System.Windows.UIElement.ManipulationCompleted event occurs during inertia.
ManipulationContainer | Gets the container that defines the coordinates for the manipulation.
ManipulationOrigin | Gets the point from which the manipulation originated.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
TotalManipulation | Gets the total transformation that occurs during the current manipulation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ManipulationDelta Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ManipulationDelta Event

Occurs when the input device changes position during a manipulation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of ManipulationDeltaEventArgs)

AddHandler instance.ManipulationDelta, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<ManipulationDeltaEventArgs> ManipulationDelta

Event Data

The event handler receives an argument of type ManipulationDeltaEventArgs containing data related to this event. The following ManipulationDeltaEventArgs properties provide information specific to this event.

Property | Description
CumulativeManipulation | Gets the cumulated changes of the current manipulation.
DeltaManipulation | Gets the most recent changes of the current manipulation.
IsInertial | Gets a value that indicates whether the System.Windows.UIElement.ManipulationDelta event occurs during inertia.
ManipulationContainer | Gets the container that defines the coordinates for the manipulation.
ManipulationOrigin | Gets the point from which the manipulation originated.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
Velocities | Gets the rates of the most recent changes to the manipulation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ManipulationInertiaStarting Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ManipulationInertiaStarting Event

Occurs when the input device loses contact with the System.Windows.UIElement object during a manipulation and inertia begins.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of ManipulationInertiaStartingEventArgs)

AddHandler instance.ManipulationInertiaStarting, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<ManipulationInertiaStartingEventArgs> ManipulationInertiaStarting

Event Data

The event handler receives an argument of type ManipulationInertiaStartingEventArgs containing data related to this event. The following ManipulationInertiaStartingEventArgs properties provide information specific to this event.

Property | Description
ExpansionBehavior | Get or sets the rate of slowdown of expansion inertial movement.
InitialVelocities | Gets the rates of changes to the manipulation that occur before inertia starts.
ManipulationContainer | Gets the container that the System.Windows.Input.ManipulationStartedEventArgs.ManipulationOrigin property is relative to.
ManipulationOrigin | Gets or sets the point from which the manipulation originated.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
RotationBehavior | Gets or sets the rate of slowdown of rotational inertial movement.
TranslationBehavior | Gets and sets the rate of slowdown of linear inertial movement.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ManipulationStarted Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ManipulationStarted Event

Occurs when an input device begins a manipulation on the System.Windows.UIElement object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of ManipulationStartedEventArgs)

AddHandler instance.ManipulationStarted, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<ManipulationStartedEventArgs> ManipulationStarted

Event Data

The event handler receives an argument of type ManipulationStartedEventArgs containing data related to this event. The following ManipulationStartedEventArgs properties provide information specific to this event.

Property | Description
ManipulationContainer | Gets the container that the System.Windows.Input.ManipulationStartedEventArgs.ManipulationOrigin property is relative to.
ManipulationOrigin | Gets the point from which the manipulation originated.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ManipulationStarting Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ManipulationStarting Event

Occurs when the manipulation processor is first created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of ManipulationStartingEventArgs)

AddHandler instance.ManipulationStarting, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<ManipulationStartingEventArgs> ManipulationStarting

Event Data

The event handler receives an argument of type ManipulationStartingEventArgs containing data related to this event. The following ManipulationStartingEventArgs properties provide information specific to this event.

Property | Description
IsSingleTouchEnabled | Gets or sets whether one finger can start a manipulation.
ManipulationContainer | Gets or sets the container that all manipulation events and calculations are relative to.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
Mode | Gets or sets which types of manipulations are possible.
Pivot | Gets or sets an object that describes the pivot for a single-point manipulation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Margin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Margin Property

Gets or sets the outer margin of an element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Thickness

instance.Margin = value

value = instance.Margin
C#
public Thickness Margin {get; set;}

Property Value

Provides margin values for the element. The default value is a System.Windows.Thickness with all properties equal to 0 (zero).

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MaxHeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MaxHeight Property

Gets or sets the maximum height constraint of the element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.MaxHeight = value

value = instance.MaxHeight
C#
[TypeConverterAttribute("System.Windows.LengthConverter, PresentationFramework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Unreadable,
   Modifiability=Modifiability.Modifiable)]
public double MaxHeight {get; set;}

Property Value

The maximum height of the element, in device-independent units (1/96th inch per unit). The default value is System.Double.PositiveInfinity. This value can be any value equal to or greater than 0.0. System.Double.PositiveInfinity is also valid.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MaxWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MaxWidth Property

Gets or sets the maximum width constraint of the element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.MaxWidth = value

value = instance.MaxWidth
C#
[TypeConverterAttribute("System.Windows.LengthConverter, PresentationFramework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Unreadable,
   Modifiability=Modifiability.Modifiable)]
public double MaxWidth {get; set;}

Property Value

The maximum width of the element, in device-independent units (1/96th inch per unit). The default value is System.Double.PositiveInfinity. This value can be any value equal to or greater than 0.0. System.Double.PositiveInfinity is also valid.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Measure Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Measure Method

availableSize
The available space that a parent element can allocate a child element. A child element can request a larger space than what is available; the provided size might be accommodated if scrolling is possible in the content model for the current element.
Updates the System.Windows.UIElement.DesiredSize of a System.Windows.UIElement. Parent elements call this method from their own System.Windows.UIElement.MeasureCore(System.Windows.Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim availableSize As Size

instance.Measure(availableSize)
C#
public void Measure(
   Size availableSize
)

Parameters

availableSize
The available space that a parent element can allocate a child element. A child element can request a larger space than what is available; the provided size might be accommodated if scrolling is possible in the content model for the current element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MinHeight Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MinHeight Property

Gets or sets the minimum height constraint of the element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.MinHeight = value

value = instance.MinHeight
C#
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Unreadable,
   Modifiability=Modifiability.Modifiable)]
[TypeConverterAttribute("System.Windows.LengthConverter, PresentationFramework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public double MinHeight {get; set;}

Property Value

The minimum height of the element, in device-independent units (1/96th inch per unit). The default value is 0.0. This value can be any value equal to or greater than 0.0. However, System.Double.PositiveInfinity is NOT valid, nor is System.Double.NaN.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MinWidth Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MinWidth Property

Gets or sets the minimum width constraint of the element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.MinWidth = value

value = instance.MinWidth
C#
[TypeConverterAttribute("System.Windows.LengthConverter, PresentationFramework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Unreadable,
   Modifiability=Modifiability.Modifiable)]
public double MinWidth {get; set;}

Property Value

The minimum width of the element, in device-independent units (1/96th inch per unit). The default value is 0.0. This value can be any value equal to or greater than 0.0. However, System.Double.PositiveInfinity is not valid, nor is System.Double.NaN.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseDoubleClick Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseDoubleClick Event

Occurs when a mouse button is clicked two or more times.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
public event MouseButtonEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseDown Event

Occurs when any mouse button is pressed while the pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.MouseDown, handler
C#
public event MouseButtonEventHandler MouseDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseEnter Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseEnter Event

Occurs when the mouse pointer enters the bounds of this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseEventHandler

AddHandler instance.MouseEnter, handler
C#
public event MouseEventHandler MouseEnter

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
RightButton | Gets the current state of the right mouse button.
StylusDevice | Gets the stylus device associated with this event.
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseLeave Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseLeave Event

Occurs when the mouse pointer leaves the bounds of this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseEventHandler

AddHandler instance.MouseLeave, handler
C#
public event MouseEventHandler MouseLeave

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
RightButton | Gets the current state of the right mouse button.
StylusDevice | Gets the stylus device associated with this event.
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseLeftButtonDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseLeftButtonDown Event

Occurs when the left mouse button is pressed while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.MouseLeftButtonDown, handler
C#
public event MouseButtonEventHandler MouseLeftButtonDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseLeftButtonUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseLeftButtonUp Event

Occurs when the left mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.MouseLeftButtonUp, handler
C#
public event MouseButtonEventHandler MouseLeftButtonUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseMove Event

Occurs when the mouse pointer moves while over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseEventHandler

AddHandler instance.MouseMove, handler
C#
public event MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
RightButton | Gets the current state of the right mouse button.
StylusDevice | Gets the stylus device associated with this event.
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseRightButtonDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseRightButtonDown Event

Occurs when the right mouse button is pressed while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.MouseRightButtonDown, handler
C#
public event MouseButtonEventHandler MouseRightButtonDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseRightButtonUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseRightButtonUp Event

Occurs when the right mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.MouseRightButtonUp, handler
C#
public event MouseButtonEventHandler MouseRightButtonUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseUp Event

Occurs when any mouse button is released over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.MouseUp, handler
C#
public event MouseButtonEventHandler MouseUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MouseWheel Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MouseWheel Event

Occurs when the user rotates the mouse wheel while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseWheelEventHandler

AddHandler instance.MouseWheel, handler
C#
public event MouseWheelEventHandler MouseWheel

Event Data

The event handler receives an argument of type MouseWheelEventArgs containing data related to this event. The following MouseWheelEventArgs properties provide information specific to this event.

Property | Description
Delta | Gets a value that indicates the amount that the mouse wheel has changed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

MoveFocus Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : MoveFocus Method

request
The direction that focus is to be moved, as a value of the enumeration.
Moves the keyboard focus away from this element and to another element in a provided traversal direction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim request As TraversalRequest
Dim value As Boolean

value = instance.MoveFocus(request)
C#
public bool MoveFocus(
   TraversalRequest request
)

Parameters

request
The direction that focus is to be moved, as a value of the enumeration.

Return Value

Returns true if focus is moved successfully; false if the target element in direction as specified does not exist or could not be keyboard focused.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Name Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Name Property

Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As String

instance.Name = value

value = instance.Name
C#
[DesignerSerializationOptionsAttribute(DesignerSerializationOptions.SerializeAsAttribute)]
[MergablePropertyAttribute(false)]
[LocalizabilityAttribute(Category=LocalizationCategory.Text |
    LocalizationCategory.Ignore |
    LocalizationCategory.NeverLocalize,
   Readability=Readability.Readable,
   Modifiability=Modifiability.Modifiable)]
public string Name {get; set;}

Property Value

The name of the element. The default is an empty string.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

OnApplyTemplate Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : OnApplyTemplate Method

When overridden in a derived class, is invoked whenever application code or internal processes call System.Windows.FrameworkElement.ApplyTemplate.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.OnApplyTemplate()
C#
public virtual void OnApplyTemplate()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Opacity Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Opacity Property

Gets or sets the opacity factor applied to the entire System.Windows.UIElement when it is rendered in the user interface (UI). This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.Opacity = value

value = instance.Opacity
C#
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Unreadable,
   Modifiability=Modifiability.Modifiable)]
public double Opacity {get; set;}

Property Value

The opacity factor. Default opacity is 1.0. Expected values are between 0.0 and 1.0.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

OpacityMask Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : OpacityMask Property

Gets or sets an opacity mask, as a System.Windows.Media.Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Brush

instance.OpacityMask = value

value = instance.OpacityMask
C#
public Brush OpacityMask {get; set;}

Property Value

The brush to use for opacity masking.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

OverridesDefaultStyle Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : OverridesDefaultStyle Property

Gets or sets a value that indicates whether this element incorporates style properties from theme styles.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.OverridesDefaultStyle = value

value = instance.OverridesDefaultStyle
C#
public bool OverridesDefaultStyle {get; set;}

Property Value

true if this element does not use theme style properties; all style-originating properties come from local application styles, and theme style properties do not apply. false if application styles apply first, and then theme styles apply for properties that were not specifically set in application styles. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Padding Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Padding Property

Gets or sets the padding inside a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Thickness

instance.Padding = value

value = instance.Padding
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Layout")]
public Thickness Padding {get; set;}

Property Value

The amount of space between the content of a System.Windows.Controls.Control and its System.Windows.FrameworkElement.Margin or System.Windows.Controls.Border. The default is a thickness of 0 on all four sides.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Parent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Parent Property

Gets the logical parent element of this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As DependencyObject

value = instance.Parent
C#
public DependencyObject Parent {get;}

Property Value

This element's logical parent.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PointFromScreen Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PointFromScreen Method

point
The System.Windows.Point value in screen coordinates.
Converts a System.Windows.Point in screen coordinates into a System.Windows.Point that represents the current coordinate system of the System.Windows.Media.Visual.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim point As Point
Dim value As Point

value = instance.PointFromScreen(point)
C#
public Point PointFromScreen(
   Point point
)

Parameters

point
The System.Windows.Point value in screen coordinates.

Return Value

The converted System.Windows.Point value that represents the current coordinate system of the System.Windows.Media.Visual.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PointToScreen Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PointToScreen Method

point
The System.Windows.Point value that represents the current coordinate system of the System.Windows.Media.Visual.
Converts a System.Windows.Point that represents the current coordinate system of the System.Windows.Media.Visual into a System.Windows.Point in screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim point As Point
Dim value As Point

value = instance.PointToScreen(point)
C#
public Point PointToScreen(
   Point point
)

Parameters

point
The System.Windows.Point value that represents the current coordinate system of the System.Windows.Media.Visual.

Return Value

The converted System.Windows.Point value in screen coordinates.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PredictFocus Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PredictFocus Method

direction
The direction for which a prospective focus change should be determined.
Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim direction As FocusNavigationDirection
Dim value As DependencyObject

value = instance.PredictFocus(direction)
C#
public DependencyObject PredictFocus(
   FocusNavigationDirection direction
)

Parameters

direction
The direction for which a prospective focus change should be determined.

Return Value

The next element that focus would move to if focus were actually traversed. May return null if focus cannot be moved relative to this element for the provided direction.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | Specified one of the following directions in the System.Windows.Input.TraversalRequest: System.Windows.Input.FocusNavigationDirection.Next, System.Windows.Input.FocusNavigationDirection.Previous, System.Windows.Input.FocusNavigationDirection.First, System.Windows.Input.FocusNavigationDirection.Last. These directions are not legal for System.Windows.FrameworkElement.PredictFocus(System.Windows.Input.FocusNavigationDirection) (but they are legal for System.Windows.FrameworkElement.MoveFocus(System.Windows.Input.TraversalRequest)).

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewDragEnter Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewDragEnter Event

Occurs when the input system reports an underlying drag event with this element as the drag target.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DragEventHandler

AddHandler instance.PreviewDragEnter, handler
C#
public event DragEventHandler PreviewDragEnter

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewDragLeave Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewDragLeave Event

Occurs when the input system reports an underlying drag event with this element as the drag origin.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DragEventHandler

AddHandler instance.PreviewDragLeave, handler
C#
public event DragEventHandler PreviewDragLeave

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewDragOver Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewDragOver Event

Occurs when the input system reports an underlying drag event with this element as the potential drop target.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DragEventHandler

AddHandler instance.PreviewDragOver, handler
C#
public event DragEventHandler PreviewDragOver

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewDrop Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewDrop Event

Occurs when the input system reports an underlying drop event with this element as the drop target.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As DragEventHandler

AddHandler instance.PreviewDrop, handler
C#
public event DragEventHandler PreviewDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffects | Gets a member of the System.Windows.DragDropEffects enumeration that specifies which operations are allowed by the originator of the drag event.
Data | Gets a data object that contains the data associated with the corresponding drag event.
Effects | Gets or sets the target drag-and-drop operation.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewGiveFeedback Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewGiveFeedback Event

Occurs when a drag-and-drop operation is started.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As GiveFeedbackEventHandler

AddHandler instance.PreviewGiveFeedback, handler
C#
public event GiveFeedbackEventHandler PreviewGiveFeedback

Event Data

The event handler receives an argument of type GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effects | Gets a value that indicates the effects of drag-and-drop operation.
UseDefaultCursors | Gets or sets a Boolean value indicating whether default cursor feedback behavior should be used for the associated drag-and-drop operation.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewGotKeyboardFocus Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewGotKeyboardFocus Event

Occurs when the keyboard is focused on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As KeyboardFocusChangedEventHandler

AddHandler instance.PreviewGotKeyboardFocus, handler
C#
public event KeyboardFocusChangedEventHandler PreviewGotKeyboardFocus

Event Data

The event handler receives an argument of type KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewKeyDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewKeyDown Event

Occurs when a key is pressed while focus is on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As KeyEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
public event KeyEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character.
ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME).
InputSource | Gets the input source that provided this input.
IsDown | Gets a value that indicates whether the key referenced by the event is in the down state.
IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key.
IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state.
IsUp | Gets a value that indicates whether the key referenced by the event is in the up state.
Key | Gets the keyboard key associated with the event.
KeyStates | Gets the state of the keyboard key associated with this event.
SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewKeyUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewKeyUp Event

Occurs when a key is released while focus is on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As KeyEventHandler

AddHandler instance.PreviewKeyUp, handler
C#
public event KeyEventHandler PreviewKeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
DeadCharProcessedKey | Gets the key that is part of dead key composition to create a single combined character.
ImeProcessedKey | Gets the keyboard key referenced by the event, if the key will be processed by an Input Method Editor (IME).
InputSource | Gets the input source that provided this input.
IsDown | Gets a value that indicates whether the key referenced by the event is in the down state.
IsRepeat | Gets a value that indicates whether the keyboard key referenced by the event is a repeated key.
IsToggled | Gets a value that indicates whether the key referenced by the event is in the toggled state.
IsUp | Gets a value that indicates whether the key referenced by the event is in the up state.
Key | Gets the keyboard key associated with the event.
KeyStates | Gets the state of the keyboard key associated with this event.
SystemKey | Gets the keyboard key referenced by the event, if the key will be processed by the system.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewLostKeyboardFocus Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewLostKeyboardFocus Event

Occurs when the keyboard is no longer focused on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As KeyboardFocusChangedEventHandler

AddHandler instance.PreviewLostKeyboardFocus, handler
C#
public event KeyboardFocusChangedEventHandler PreviewLostKeyboardFocus

Event Data

The event handler receives an argument of type KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewMouseDoubleClick Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewMouseDoubleClick Event

Occurs when a user clicks the mouse button two or more times.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.PreviewMouseDoubleClick, handler
C#
public event MouseButtonEventHandler PreviewMouseDoubleClick

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewMouseDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewMouseDown Event

Occurs when any mouse button is pressed while the pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.PreviewMouseDown, handler
C#
public event MouseButtonEventHandler PreviewMouseDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewMouseLeftButtonDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewMouseLeftButtonDown Event

Occurs when the left mouse button is pressed while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.PreviewMouseLeftButtonDown, handler
C#
public event MouseButtonEventHandler PreviewMouseLeftButtonDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewMouseLeftButtonUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewMouseLeftButtonUp Event

Occurs when the left mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.PreviewMouseLeftButtonUp, handler
C#
public event MouseButtonEventHandler PreviewMouseLeftButtonUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewMouseMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewMouseMove Event

Occurs when the mouse pointer moves while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseEventHandler

AddHandler instance.PreviewMouseMove, handler
C#
public event MouseEventHandler PreviewMouseMove

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
MouseDevice | Gets the mouse device associated with this event.
RightButton | Gets the current state of the right mouse button.
StylusDevice | Gets the stylus device associated with this event.
XButton1 | Gets the current state of the first extended mouse button.
XButton2 | Gets the state of the second extended mouse button.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewMouseRightButtonDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewMouseRightButtonDown Event

Occurs when the right mouse button is pressed while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.PreviewMouseRightButtonDown, handler
C#
public event MouseButtonEventHandler PreviewMouseRightButtonDown

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewMouseRightButtonUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewMouseRightButtonUp Event

Occurs when the right mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.PreviewMouseRightButtonUp, handler
C#
public event MouseButtonEventHandler PreviewMouseRightButtonUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewMouseUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewMouseUp Event

Occurs when any mouse button is released while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseButtonEventHandler

AddHandler instance.PreviewMouseUp, handler
C#
public event MouseButtonEventHandler PreviewMouseUp

Event Data

The event handler receives an argument of type MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
ButtonState | Gets the state of the button associated with the event.
ChangedButton | Gets the button associated with the event.
ClickCount | Gets the number of times the button was clicked.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewMouseWheel Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewMouseWheel Event

Occurs when the user rotates the mouse wheel while the mouse pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As MouseWheelEventHandler

AddHandler instance.PreviewMouseWheel, handler
C#
public event MouseWheelEventHandler PreviewMouseWheel

Event Data

The event handler receives an argument of type MouseWheelEventArgs containing data related to this event. The following MouseWheelEventArgs properties provide information specific to this event.

Property | Description
Delta | Gets a value that indicates the amount that the mouse wheel has changed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewQueryContinueDrag Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewQueryContinueDrag Event

Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As QueryContinueDragEventHandler

AddHandler instance.PreviewQueryContinueDrag, handler
C#
public event QueryContinueDragEventHandler PreviewQueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the current status of the associated drag-and-drop operation.
EscapePressed | Gets a Boolean value indicating whether the ESC key has been pressed.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewStylusButtonDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewStylusButtonDown Event

Occurs when the stylus button is pressed while the pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusButtonEventHandler

AddHandler instance.PreviewStylusButtonDown, handler
C#
public event StylusButtonEventHandler PreviewStylusButtonDown

Event Data

The event handler receives an argument of type StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewStylusButtonUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewStylusButtonUp Event

Occurs when the stylus button is released while the pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusButtonEventHandler

AddHandler instance.PreviewStylusButtonUp, handler
C#
public event StylusButtonEventHandler PreviewStylusButtonUp

Event Data

The event handler receives an argument of type StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewStylusDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewStylusDown Event

Occurs when the stylus touches the digitizer while it is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusDownEventHandler

AddHandler instance.PreviewStylusDown, handler
C#
public event StylusDownEventHandler PreviewStylusDown

Event Data

The event handler receives an argument of type StylusDownEventArgs containing data related to this event. The following StylusDownEventArgs properties provide information specific to this event.

Property | Description
TapCount | Gets the number of times the tablet pen was tapped.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewStylusInAirMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewStylusInAirMove Event

Occurs when the stylus moves over an element without actually touching the digitizer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.PreviewStylusInAirMove, handler
C#
public event StylusEventHandler PreviewStylusInAirMove

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewStylusInRange Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewStylusInRange Event

Occurs when the stylus is close enough to the digitizer to be detected, while over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.PreviewStylusInRange, handler
C#
public event StylusEventHandler PreviewStylusInRange

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewStylusMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewStylusMove Event

Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, System.Windows.UIElement.PreviewStylusInAirMove is raised instead.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.PreviewStylusMove, handler
C#
public event StylusEventHandler PreviewStylusMove

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewStylusOutOfRange Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewStylusOutOfRange Event

Occurs when the stylus is too far from the digitizer to be detected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.PreviewStylusOutOfRange, handler
C#
public event StylusEventHandler PreviewStylusOutOfRange

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewStylusSystemGesture Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewStylusSystemGesture Event

Occurs when a user performs one of several stylus gestures.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusSystemGestureEventHandler

AddHandler instance.PreviewStylusSystemGesture, handler
C#
public event StylusSystemGestureEventHandler PreviewStylusSystemGesture

Event Data

The event handler receives an argument of type StylusSystemGestureEventArgs containing data related to this event. The following StylusSystemGestureEventArgs properties provide information specific to this event.

Property | Description
SystemGesture | Gets the System.Windows.Input.SystemGesture that raises the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewStylusUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewStylusUp Event

Occurs when the user raises the stylus off the digitizer while the stylus is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.PreviewStylusUp, handler
C#
public event StylusEventHandler PreviewStylusUp

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewTextInput Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewTextInput Event

Occurs when this element gets text in a device-independent manner.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As TextCompositionEventHandler

AddHandler instance.PreviewTextInput, handler
C#
public event TextCompositionEventHandler PreviewTextInput

Event Data

The event handler receives an argument of type TextCompositionEventArgs containing data related to this event. The following TextCompositionEventArgs properties provide information specific to this event.

Property | Description
ControlText | Gets control text associated with a System.Windows.Input.TextComposition event.
SystemText | Gets system text associated with a System.Windows.Input.TextComposition event.
Text | Gets input text associated with a System.Windows.Input.TextComposition event.
TextComposition | Gets the System.Windows.Input.TextComposition associated with a System.Windows.Input.TextComposition event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewTouchDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewTouchDown Event

Occurs when a finger touches the screen while the finger is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.PreviewTouchDown, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> PreviewTouchDown

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewTouchMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewTouchMove Event

Occurs when a finger moves on the screen while the finger is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.PreviewTouchMove, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> PreviewTouchMove

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

PreviewTouchUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : PreviewTouchUp Event

Occurs when a finger is raised off of the screen while the finger is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.PreviewTouchUp, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> PreviewTouchUp

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

QueryContinueDrag Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : QueryContinueDrag Event

Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
public event QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the current status of the associated drag-and-drop operation.
EscapePressed | Gets a Boolean value indicating whether the ESC key has been pressed.
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

QueryCursor Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : QueryCursor Event

Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As QueryCursorEventHandler

AddHandler instance.QueryCursor, handler
C#
public event QueryCursorEventHandler QueryCursor

Event Data

The event handler receives an argument of type QueryCursorEventArgs containing data related to this event. The following QueryCursorEventArgs properties provide information specific to this event.

Property | Description
Cursor | Gets or sets the cursor associated with this event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RaiseEvent Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RaiseEvent Method

Raises a specific routed event. The System.Windows.RoutedEvent to be raised is identified within the System.Windows.RoutedEventArgs instance that is provided (as the System.Windows.RoutedEventArgs.RoutedEvent property of that event data).

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RaiseEvent(RoutedEventArgs) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RaiseEvent(RoutedEventArgs) Method

e
A System.Windows.RoutedEventArgs that contains the event data and also identifies the event to raise.
Raises a specific routed event. The System.Windows.RoutedEvent to be raised is identified within the System.Windows.RoutedEventArgs instance that is provided (as the System.Windows.RoutedEventArgs.RoutedEvent property of that event data).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim e As RoutedEventArgs

instance.RaiseEvent(e)
C#
public void RaiseEvent(
   RoutedEventArgs e
)

Parameters

e
A System.Windows.RoutedEventArgs that contains the event data and also identifies the event to raise.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RegisterName Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RegisterName Method

name
Name to use for the specified name-object mapping.
scopedElement
Object for the mapping.
Provides an accessor that simplifies access to the System.Windows.NameScope registration method.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim name As String
Dim scopedElement As Object

instance.RegisterName(name, scopedElement)
C#
public void RegisterName(
   string name,
   object scopedElement
)

Parameters

name
Name to use for the specified name-object mapping.
scopedElement
Object for the mapping.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ReleaseAllTouchCaptures Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ReleaseAllTouchCaptures Method

Releases all captured touch devices from this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.ReleaseAllTouchCaptures()
C#
public void ReleaseAllTouchCaptures()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ReleaseMouseCapture Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ReleaseMouseCapture Method

Releases the mouse capture, if this element held the capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.ReleaseMouseCapture()
C#
public void ReleaseMouseCapture()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ReleaseStylusCapture Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ReleaseStylusCapture Method

Releases the stylus device capture, if this element held the capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.ReleaseStylusCapture()
C#
public void ReleaseStylusCapture()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ReleaseTouchCapture Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ReleaseTouchCapture Method

touchDevice
The device to release.
Attempts to release the specified touch device from this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim touchDevice As TouchDevice
Dim value As Boolean

value = instance.ReleaseTouchCapture(touchDevice)
C#
public bool ReleaseTouchCapture(
   TouchDevice touchDevice
)

Parameters

touchDevice
The device to release.

Return Value

true if the touch device is released; otherwise, false.

Exceptions

Exception | Description
System.ArgumentNullException | touchDevice is null.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RemoveHandler Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RemoveHandler Method

routedEvent
handler

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim routedEvent As RoutedEvent
Dim handler As Delegate

instance.RemoveHandler(routedEvent, handler)
C#
public void RemoveHandler(
   RoutedEvent routedEvent,
   Delegate handler
)

Parameters

routedEvent
handler

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RenderSize Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RenderSize Property

Gets (or sets, but see Remarks) the final render size of this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Size

instance.RenderSize = value

value = instance.RenderSize
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Size RenderSize {get; set;}

Property Value

The rendered size for this element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RenderTransform Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RenderTransform Property

Gets or sets transform information that affects the rendering position of this element. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Transform

instance.RenderTransform = value

value = instance.RenderTransform
C#
public Transform RenderTransform {get; set;}

Property Value

Describes the specifics of the desired render transform. The default is System.Windows.Media.Transform.Identity.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RenderTransformOrigin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RenderTransformOrigin Property

Gets or sets the center point of any possible render transform declared by System.Windows.UIElement.RenderTransform, relative to the bounds of the element. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Point

instance.RenderTransformOrigin = value

value = instance.RenderTransformOrigin
C#
public Point RenderTransformOrigin {get; set;}

Property Value

The value that declares the render transform. The default value is a System.Windows.Point with coordinates (0,0).

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

RequestBringIntoView Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : RequestBringIntoView Event

Occurs when System.Windows.FrameworkElement.BringIntoView(System.Windows.Rect) is called on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As RequestBringIntoViewEventHandler

AddHandler instance.RequestBringIntoView, handler
C#
public event RequestBringIntoViewEventHandler RequestBringIntoView

Event Data

The event handler receives an argument of type RequestBringIntoViewEventArgs containing data related to this event. The following RequestBringIntoViewEventArgs properties provide information specific to this event.

Property | Description
TargetObject | Gets the object that should be made visible in response to the event.
TargetRect | Gets the rectangular region in the object's coordinate space which should be made visible.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Resources Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Resources Property

Gets or sets the locally-defined resource dictionary.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As ResourceDictionary

instance.Resources = value

value = instance.Resources
C#
[AmbientAttribute()]
public ResourceDictionary Resources {get; set;}

Property Value

The current locally-defined dictionary of resources, where each resource can be accessed by key.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SetBinding Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SetBinding Method

Attaches a binding to this element, based on the provided binding object.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SetBinding(DependencyProperty,BindingBase) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > SetBinding Method : SetBinding(DependencyProperty,BindingBase) Method

dp
Identifies the property where the binding should be established.
binding
Represents the specifics of the data binding.
Attaches a binding to this element, based on the provided binding object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim binding As BindingBase
Dim value As BindingExpressionBase

value = instance.SetBinding(dp, binding)
C#
public BindingExpressionBase SetBinding(
   DependencyProperty dp,
   BindingBase binding
)

Parameters

dp
Identifies the property where the binding should be established.
binding
Represents the specifics of the data binding.

Return Value

Records the conditions of the binding. This return value can be useful for error checking.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

SetBinding(DependencyProperty,String) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > SetBinding Method : SetBinding(DependencyProperty,String) Method

dp
Identifies the destination property where the binding should be established.
path
The source property name or the path to the property used for the binding.
Attaches a binding to this element, based on the provided source property name as a path qualification to the data source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim path As String
Dim value As BindingExpression

value = instance.SetBinding(dp, path)
C#
public BindingExpression SetBinding(
   DependencyProperty dp,
   string path
)

Parameters

dp
Identifies the destination property where the binding should be established.
path
The source property name or the path to the property used for the binding.

Return Value

Records the conditions of the binding. This return value can be useful for error checking.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SetResourceReference Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SetResourceReference Method

dp
The property to which the resource is bound.
name
The name of the resource.
Searches for a resource with the specified name and sets up a resource reference to it for the specified property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim name As Object

instance.SetResourceReference(dp, name)
C#
public void SetResourceReference(
   DependencyProperty dp,
   object name
)

Parameters

dp
The property to which the resource is bound.
name
The name of the resource.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

ShouldSerializeCommandBindings Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ShouldSerializeCommandBindings Method

Returns whether serialization processes should serialize the contents of the System.Windows.UIElement.CommandBindings property on instances of this class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.ShouldSerializeCommandBindings()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool ShouldSerializeCommandBindings()

Return Value

true if the System.Windows.UIElement.CommandBindings property value should be serialized; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ShouldSerializeContent Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ShouldSerializeContent Method

Indicates whether the System.Windows.Controls.ContentControl.Content property should be persisted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.ShouldSerializeContent()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public virtual bool ShouldSerializeContent()

Return Value

true if the System.Windows.Controls.ContentControl.Content property should be persisted; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ShouldSerializeInputBindings Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ShouldSerializeInputBindings Method

Returns whether serialization processes should serialize the contents of the System.Windows.UIElement.InputBindings property on instances of this class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.ShouldSerializeInputBindings()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool ShouldSerializeInputBindings()

Return Value

true if the System.Windows.UIElement.InputBindings property value should be serialized; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ShouldSerializeResources Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ShouldSerializeResources Method

Returns whether serialization processes should serialize the contents of the System.Windows.FrameworkElement.Resources property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.ShouldSerializeResources()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool ShouldSerializeResources()

Return Value

true if the System.Windows.FrameworkElement.Resources property value should be serialized; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ShouldSerializeStyle Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ShouldSerializeStyle Method

Returns whether serialization processes should serialize the contents of the System.Windows.FrameworkElement.Style property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.ShouldSerializeStyle()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool ShouldSerializeStyle()

Return Value

true if the System.Windows.FrameworkElement.Style property value should be serialized; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ShouldSerializeTriggers Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ShouldSerializeTriggers Method

Returns whether serialization processes should serialize the contents of the System.Windows.FrameworkElement.Triggers property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

value = instance.ShouldSerializeTriggers()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool ShouldSerializeTriggers()

Return Value

true if the System.Windows.FrameworkElement.Triggers property value should be serialized; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SizeChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SizeChanged Event

Occurs when either the System.Windows.FrameworkElement.ActualHeight or the System.Windows.FrameworkElement.ActualWidth properties change value on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As SizeChangedEventHandler

AddHandler instance.SizeChanged, handler
C#
public event SizeChangedEventHandler SizeChanged

Event Data

The event handler receives an argument of type SizeChangedEventArgs containing data related to this event. The following SizeChangedEventArgs properties provide information specific to this event.

Property | Description
HeightChanged | Gets a value that indicates whether the System.Windows.FrameworkElement.Height component of the size changed.
NewSize | Gets the new System.Windows.Size of the object.
PreviousSize | Gets the previous System.Windows.Size of the object.
WidthChanged | Gets a value that indicates whether the System.Windows.FrameworkElement.Width component of the size changed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SnapsToDevicePixels Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SnapsToDevicePixels Property

Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.SnapsToDevicePixels = value

value = instance.SnapsToDevicePixels
C#
public bool SnapsToDevicePixels {get; set;}

Property Value

true if the element should render in accordance to device pixels; otherwise, false. The default as declared on System.Windows.UIElement is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SortList Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SortList Method

Sorts the items within the list.

Overload List

Overload | Description
SortList | Sorts the items within the list.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

SourceUpdated Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : SourceUpdated Event

Occurs when the source value changes for any existing property binding on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of DataTransferEventArgs)

AddHandler instance.SourceUpdated, handler
C#
public event EventHandler<DataTransferEventArgs> SourceUpdated

Event Data

The event handler receives an argument of type DataTransferEventArgs containing data related to this event. The following DataTransferEventArgs properties provide information specific to this event.

Property | Description
Property | Gets the specific binding target property that is involved in the data transfer event.
TargetObject | Gets the binding target object of the binding that raised the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Style Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Style Property

Gets or sets the style used by this element when it is rendered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Style

instance.Style = value

value = instance.Style
C#
public Style Style {get; set;}

Property Value

The applied, nondefault style for the element, if present. Otherwise, null. The default for a default-constructed System.Windows.FrameworkElement is null.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusButtonDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusButtonDown Event

Occurs when the stylus button is pressed while the pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusButtonEventHandler

AddHandler instance.StylusButtonDown, handler
C#
public event StylusButtonEventHandler StylusButtonDown

Event Data

The event handler receives an argument of type StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusButtonUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusButtonUp Event

Occurs when the stylus button is released while the pointer is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusButtonEventHandler

AddHandler instance.StylusButtonUp, handler
C#
public event StylusButtonEventHandler StylusButtonUp

Event Data

The event handler receives an argument of type StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusDown Event

Occurs when the stylus touches the digitizer while the stylus is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusDownEventHandler

AddHandler instance.StylusDown, handler
C#
public event StylusDownEventHandler StylusDown

Event Data

The event handler receives an argument of type StylusDownEventArgs containing data related to this event. The following StylusDownEventArgs properties provide information specific to this event.

Property | Description
TapCount | Gets the number of times the tablet pen was tapped.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusEnter Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusEnter Event

Occurs when the stylus enters the bounds of this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.StylusEnter, handler
C#
public event StylusEventHandler StylusEnter

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusInAirMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusInAirMove Event

Occurs when the stylus moves over an element without actually touching the digitizer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.StylusInAirMove, handler
C#
public event StylusEventHandler StylusInAirMove

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusInRange Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusInRange Event

Occurs when the stylus is close enough to the digitizer to be detected, while over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.StylusInRange, handler
C#
public event StylusEventHandler StylusInRange

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusLeave Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusLeave Event

Occurs when the stylus leaves the bounds of the element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.StylusLeave, handler
C#
public event StylusEventHandler StylusLeave

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusMove Event

Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, System.Windows.UIElement.StylusInAirMove is raised instead.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.StylusMove, handler
C#
public event StylusEventHandler StylusMove

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusOutOfRange Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusOutOfRange Event

Occurs when the stylus is too far from the digitizer to be detected, while over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.StylusOutOfRange, handler
C#
public event StylusEventHandler StylusOutOfRange

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusSystemGesture Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusSystemGesture Event

Occurs when a user performs one of several stylus gestures.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusSystemGestureEventHandler

AddHandler instance.StylusSystemGesture, handler
C#
public event StylusSystemGestureEventHandler StylusSystemGesture

Event Data

The event handler receives an argument of type StylusSystemGestureEventArgs containing data related to this event. The following StylusSystemGestureEventArgs properties provide information specific to this event.

Property | Description
SystemGesture | Gets the System.Windows.Input.SystemGesture that raises the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

StylusUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : StylusUp Event

Occurs when the user raises the stylus off the digitizer while it is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As StylusEventHandler

AddHandler instance.StylusUp, handler
C#
public event StylusEventHandler StylusUp

Event Data

The event handler receives an argument of type StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TabIndex Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TabIndex Property

Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Integer

instance.TabIndex = value

value = instance.TabIndex
C#
[CategoryAttribute("Behavior")]
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public int TabIndex {get; set;}

Property Value

A value that determines the order of logical navigation for a device. The default value is System.Int32.MaxValue.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Tag Property

Gets or sets an arbitrary object value that can be used to store custom information about this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[LocalizabilityAttribute(Category=LocalizationCategory.Text |
    LocalizationCategory.Ignore |
    LocalizationCategory.NeverLocalize,
   Readability=Readability.Readable,
   Modifiability=Modifiability.Modifiable)]
public object Tag {get; set;}

Property Value

The intended value. This property has no default value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TargetUpdated Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TargetUpdated Event

Occurs when the target value changes for any property binding on this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of DataTransferEventArgs)

AddHandler instance.TargetUpdated, handler
C#
public event EventHandler<DataTransferEventArgs> TargetUpdated

Event Data

The event handler receives an argument of type DataTransferEventArgs containing data related to this event. The following DataTransferEventArgs properties provide information specific to this event.

Property | Description
Property | Gets the specific binding target property that is involved in the data transfer event.
TargetObject | Gets the binding target object of the binding that raised the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Template Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Template Property

Gets or sets a control template.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As ControlTemplate

instance.Template = value

value = instance.Template
C#
public ControlTemplate Template {get; set;}

Property Value

The template that defines the appearance of the System.Windows.Controls.Control.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TemplatedParent Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TemplatedParent Property

Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As DependencyObject

value = instance.TemplatedParent
C#
public DependencyObject TemplatedParent {get;}

Property Value

The element whose System.Windows.FrameworkTemplate System.Windows.FrameworkTemplate.VisualTree caused this element to be created. This value is frequently null; see Remarks.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TextInput Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TextInput Event

Occurs when this element gets text in a device-independent manner.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As TextCompositionEventHandler

AddHandler instance.TextInput, handler
C#
public event TextCompositionEventHandler TextInput

Event Data

The event handler receives an argument of type TextCompositionEventArgs containing data related to this event. The following TextCompositionEventArgs properties provide information specific to this event.

Property | Description
ControlText | Gets control text associated with a System.Windows.Input.TextComposition event.
SystemText | Gets system text associated with a System.Windows.Input.TextComposition event.
Text | Gets input text associated with a System.Windows.Input.TextComposition event.
TextComposition | Gets the System.Windows.Input.TextComposition associated with a System.Windows.Input.TextComposition event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolTip Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolTip Property

Gets or sets the tool-tip object that is displayed for this element in the user interface (UI).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Object

instance.ToolTip = value

value = instance.ToolTip
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[LocalizabilityAttribute(Category=LocalizationCategory.Title |
    LocalizationCategory.Menu |
    LocalizationCategory.ToolTip,
   Readability=Readability.Readable,
   Modifiability=Modifiability.Modifiable)]
[CategoryAttribute("Appearance")]
public object ToolTip {get; set;}

Property Value

The tooltip object. See Remarks below for details on why this parameter is not strongly typed.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolTipClosing Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolTipClosing Event

Occurs just before any tooltip on the element is closed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As ToolTipEventHandler

AddHandler instance.ToolTipClosing, handler
C#
public event ToolTipEventHandler ToolTipClosing

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToolTipOpening Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToolTipOpening Event

Occurs when any tooltip on the element is opened.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As ToolTipEventHandler

AddHandler instance.ToolTipOpening, handler
C#
public event ToolTipEventHandler ToolTipOpening

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

ToString Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : ToString Method

Returns the string representation of a System.Windows.Controls.Control object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As String

value = instance.ToString()
C#
public virtual string ToString()

Return Value

A string that represents the control.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TouchDown Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TouchDown Event

Occurs when a finger touches the screen while the finger is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.TouchDown, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> TouchDown

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TouchEnter Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TouchEnter Event

Occurs when a touch moves from outside to inside the bounds of this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.TouchEnter, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> TouchEnter

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TouchesCaptured Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TouchesCaptured Property

Gets all touch devices that are captured to this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As IEnumerable(Of TouchDevice)

value = instance.TouchesCaptured
C#
public IEnumerable<TouchDevice> TouchesCaptured {get;}

Property Value

An enumeration of System.Windows.Input.TouchDevice objects that are captured to this element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TouchesCapturedWithin Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TouchesCapturedWithin Property

Gets all touch devices that are captured to this element or any child elements in its visual tree.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As IEnumerable(Of TouchDevice)

value = instance.TouchesCapturedWithin
C#
public IEnumerable<TouchDevice> TouchesCapturedWithin {get;}

Property Value

An enumeration of System.Windows.Input.TouchDevice objects that are captured to this element or any child elements in its visual tree.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TouchesDirectlyOver Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TouchesDirectlyOver Property

Gets all touch devices that are over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As IEnumerable(Of TouchDevice)

value = instance.TouchesDirectlyOver
C#
public IEnumerable<TouchDevice> TouchesDirectlyOver {get;}

Property Value

An enumeration of System.Windows.Input.TouchDevice objects that are over this element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TouchesOver Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TouchesOver Property

Gets all touch devices that are over this element or any child elements in its visual tree.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As IEnumerable(Of TouchDevice)

value = instance.TouchesOver
C#
public IEnumerable<TouchDevice> TouchesOver {get;}

Property Value

An enumeration of System.Windows.Input.TouchDevice objects that are over this element or any child elements in its visual tree.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TouchLeave Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TouchLeave Event

Occurs when a touch moves from inside to outside the bounds of this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.TouchLeave, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> TouchLeave

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TouchMove Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TouchMove Event

Occurs when a finger moves on the screen while the finger is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.TouchMove, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> TouchMove

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TouchUp Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TouchUp Event

Occurs when a finger is raised off of the screen while the finger is over this element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As EventHandler(Of TouchEventArgs)

AddHandler instance.TouchUp, handler
C#
[CustomCategoryAttribute("Touch")]
public event EventHandler<TouchEventArgs> TouchUp

Event Data

The event handler receives an argument of type TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
TouchDevice | Gets the touch that generated the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TransformToAncestor Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TransformToAncestor Method

Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Visual ancestor of the visual object.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TransformToAncestor(Visual3D) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > TransformToAncestor Method : TransformToAncestor(Visual3D) Method

ancestor
The System.Windows.Media.Media3D.Visual3D to which the coordinates are transformed.
Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Media3D.Visual3D ancestor of the visual object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ancestor As Visual3D
Dim value As GeneralTransform2DTo3D

value = instance.TransformToAncestor(ancestor)
C#
public GeneralTransform2DTo3D TransformToAncestor(
   Visual3D ancestor
)

Parameters

ancestor
The System.Windows.Media.Media3D.Visual3D to which the coordinates are transformed.

Return Value

A System.Windows.Media.Media3D.GeneralTransform2DTo3D.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

TransformToAncestor(Visual) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class > TransformToAncestor Method : TransformToAncestor(Visual) Method

ancestor
The System.Windows.Media.Visual to which the coordinates are transformed.
Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified System.Windows.Media.Visual ancestor of the visual object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim ancestor As Visual
Dim value As GeneralTransform

value = instance.TransformToAncestor(ancestor)
C#
public GeneralTransform TransformToAncestor(
   Visual ancestor
)

Parameters

ancestor
The System.Windows.Media.Visual to which the coordinates are transformed.

Return Value

A value of type System.Windows.Media.GeneralTransform.

Exceptions

Exception | Description
System.ArgumentNullException | ancestor is null.
System.ArgumentException | ancestor is not an ancestor of the visual.
System.InvalidOperationException | The visual objects are not related.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members
Overload List


%%PageItemTitle%%

TransformToDescendant Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TransformToDescendant Method

descendant
The System.Windows.Media.Visual to which the coordinates are transformed.
Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified visual object descendant.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim descendant As Visual
Dim value As GeneralTransform

value = instance.TransformToDescendant(descendant)
C#
public GeneralTransform TransformToDescendant(
   Visual descendant
)

Parameters

descendant
The System.Windows.Media.Visual to which the coordinates are transformed.

Return Value

A value of type System.Windows.Media.GeneralTransform.

Exceptions

Exception | Description
System.ArgumentNullException | descendant is null.
System.ArgumentException | The visual is not an ancestor of the descendant visual.
System.InvalidOperationException | The visual objects are not related.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TransformToVisual Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TransformToVisual Method

visual
The System.Windows.Media.Visual to which the coordinates are transformed.
Returns a transform that can be used to transform coordinates from the System.Windows.Media.Visual to the specified visual object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim visual As Visual
Dim value As GeneralTransform

value = instance.TransformToVisual(visual)
C#
public GeneralTransform TransformToVisual(
   Visual visual
)

Parameters

visual
The System.Windows.Media.Visual to which the coordinates are transformed.

Return Value

A value of type System.Windows.Media.GeneralTransform.

Exceptions

Exception | Description
System.ArgumentNullException | visual is null.
System.InvalidOperationException | The visual objects are not related.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TranslatePoint Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TranslatePoint Method

point
The point value, as relative to this element.
relativeTo
The element to translate the given point into.
Translates a point relative to this element to coordinates that are relative to the specified element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim point As Point
Dim relativeTo As UIElement
Dim value As Point

value = instance.TranslatePoint(point, relativeTo)
C#
public Point TranslatePoint(
   Point point,
   UIElement relativeTo
)

Parameters

point
The point value, as relative to this element.
relativeTo
The element to translate the given point into.

Return Value

A point value, now relative to the target element rather than this source element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Triggers Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Triggers Property

Gets the collection of triggers established directly on this element, or in child elements.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As TriggerCollection

value = instance.Triggers
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public TriggerCollection Triggers {get;}

Property Value

A strongly typed collection of System.Windows.Trigger objects.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

TryFindResource Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : TryFindResource Method

resourceKey
The key identifier of the resource to be found.
Searches for a resource with the specified key, and returns that resource if found.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim resourceKey As Object
Dim value As Object

value = instance.TryFindResource(resourceKey)
C#
public object TryFindResource(
   object resourceKey
)

Parameters

resourceKey
The key identifier of the resource to be found.

Return Value

The found resource, or null if no resource with the provided key is found.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Uid Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Uid Property

Gets or sets the unique identifier (for localization) for this element. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As String

instance.Uid = value

value = instance.Uid
C#
public string Uid {get; set;}

Property Value

A string that is the unique identifier for this element.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Unloaded Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Unloaded Event

Occurs when the element is removed from within an element tree of loaded elements.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim handler As RoutedEventHandler

AddHandler instance.Unloaded, handler
C#
public event RoutedEventHandler Unloaded

Event Data

The event handler receives an argument of type RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible System.Windows.RoutedEventArgs.Source adjustment by a parent class.
RoutedEvent | Gets or sets the System.Windows.RoutedEventArgs.RoutedEvent associated with this System.Windows.RoutedEventArgs instance.
Source | Gets or sets a reference to the object that raised the event.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UnregisterName Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UnregisterName Method

name
Name of the name-object pair to remove from the current scope.
Simplifies access to the System.Windows.NameScope de-registration method.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim name As String

instance.UnregisterName(name)
C#
public void UnregisterName(
   string name
)

Parameters

name
Name of the name-object pair to remove from the current scope.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UpdateDefaultStyle Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UpdateDefaultStyle Method

Reapplies the default style to the current System.Windows.FrameworkElement.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.UpdateDefaultStyle()
C#
public void UpdateDefaultStyle()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UpdateLayout Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UpdateLayout Method

Ensures that all visual child elements of this element are properly updated for layout.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.UpdateLayout()
C#
public void UpdateLayout()

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

UseLayoutRounding Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : UseLayoutRounding Property

Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Boolean

instance.UseLayoutRounding = value

value = instance.UseLayoutRounding
C#
public bool UseLayoutRounding {get; set;}

Property Value

true if layout rounding is applied; otherwise, false. The default is false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

VerticalAlignment Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : VerticalAlignment Property

Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As VerticalAlignment

instance.VerticalAlignment = value

value = instance.VerticalAlignment
C#
public VerticalAlignment VerticalAlignment {get; set;}

Property Value

A vertical alignment setting. The default is System.Windows.VerticalAlignment.Stretch.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

VerticalContentAlignment Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : VerticalContentAlignment Property

Gets or sets the vertical alignment of the control's content.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As VerticalAlignment

instance.VerticalContentAlignment = value

value = instance.VerticalContentAlignment
C#
[BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[CategoryAttribute("Layout")]
public VerticalAlignment VerticalContentAlignment {get; set;}

Property Value

One of the System.Windows.VerticalAlignment values. The default is System.Windows.VerticalAlignment.Top.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Visibility Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Visibility Property

Gets or sets the user interface (UI) visibility of this element. This is a dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Visibility

instance.Visibility = value

value = instance.Visibility
C#
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Unreadable,
   Modifiability=Modifiability.Modifiable)]
public Visibility Visibility {get; set;}

Property Value

A value of the enumeration. The default value is System.Windows.Visibility.Visible.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%%

Width Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiScheduleWPF Class : Width Property

Gets or sets the width of the element.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleWPF
Dim value As Double

instance.Width = value

value = instance.Width
C#
[LocalizabilityAttribute(Category=LocalizationCategory.None,
   Readability=Readability.Unreadable,
   Modifiability=Modifiability.Modifiable)]
[TypeConverterAttribute("System.Windows.LengthConverter, PresentationFramework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35")]
public double Width {get; set;}

Property Value

The width of the element, in device-independent units (1/96th inch per unit). The default value is System.Double.NaN. This value must be equal to or greater than 0.0. See Remarks for upper bound information.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiScheduleWPF Class
dbiScheduleWPF Members


%%PageItemTitle%% $$Events$$

dbiTimeBarCollection Class Events
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace : dbiTimeBarCollection Class

"

For a list of all members of this type, see dbiTimeBarCollection members.

"

See Also

Reference

dbiTimeBarCollection Class
Dbi.WpfControl.dbiSchedule Namespace


%%PageItemTitle%%

dbiTimeBarCollection Constructor
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : dbiTimeBarCollection Constructor

Overload List

Overload | Description
dbiTimeBarCollection Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

CollectionChanged Event
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : CollectionChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim handler As NotifyCollectionChangedEventHandler

AddHandler instance.CollectionChanged, handler
C#
[__DynamicallyInvokableAttribute()]
public event NotifyCollectionChangedEventHandler CollectionChanged

Event Data

The event handler receives an argument of type NotifyCollectionChangedEventArgs containing data related to this event. The following NotifyCollectionChangedEventArgs properties provide information specific to this event.

Property | Description
Action |
NewItems |
NewStartingIndex |
OldItems |
OldStartingIndex |

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : Contains Method

item
The object to locate in the Collection. The value can be null for reference types.
Determines whether an element is in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim item As dbiTimeBarItem
Dim value As Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public bool Contains(
   dbiTimeBarItem item
)

Parameters

item
The object to locate in the Collection. The value can be null for reference types.

Return Value

true if item is found in the Collection; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : CopyTo Method

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim array() As dbiTimeBarItem
Dim index As Integer

instance.CopyTo(array, index)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   dbiTimeBarItem[] array,
   int index
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from Collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
System.ArgumentNullException | array is null.
System.ArgumentOutOfRangeException | index is less than zero.
System.ArgumentException | The number of elements in the source Collection is greater than the available space from index to the end of the destination array.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : Count Property

Gets the number of elements actually contained in the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim value As Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public int Count {get;}

Property Value

The number of elements actually contained in the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the Collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim value As IEnumerator(Of dbiTimeBarItem)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public IEnumerator<dbiTimeBarItem> GetEnumerator()

Return Value

An IEnumerator for the Collection.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

Move Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarCollection Class : Move Method

oldIndex
newIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarCollection
Dim oldIndex As Integer
Dim newIndex As Integer

instance.Move(oldIndex, newIndex)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void Move(
   int oldIndex,
   int newIndex
)

Parameters

oldIndex
newIndex

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarCollection Class
dbiTimeBarCollection Members


%%PageItemTitle%%

CheckAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : CheckAccess Method

Determines whether the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Boolean

value = instance.CheckAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool CheckAccess()

Return Value

true if the calling thread has access to this object; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ClearValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : ClearValue Method

Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ClearValue(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > ClearValue Method : ClearValue(DependencyProperty) Method

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.
Clears the local value of a property. The property to be cleared is specified by a System.Windows.DependencyProperty identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim dp As DependencyProperty

instance.ClearValue(dp)
C#
public void ClearValue(
   DependencyProperty dp
)

Parameters

dp
The dependency property to be cleared, identified by a System.Windows.DependencyProperty object reference.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

ClearValue(DependencyPropertyKey) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method

key
The key for the dependency property to be cleared.
Clears the local value of a read-only property. The property to be cleared is specified by a System.Windows.DependencyPropertyKey.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim key As DependencyPropertyKey

instance.ClearValue(key)
C#
public void ClearValue(
   DependencyPropertyKey key
)

Parameters

key
The key for the dependency property to be cleared.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to call System.Windows.DependencyObject.ClearValue(System.Windows.DependencyProperty) on a sealed System.Windows.DependencyObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

CoerceValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : CoerceValue Method

dp
The identifier for the dependency property to coerce.
Coerces the value of the specified dependency property. This is accomplished by invoking any System.Windows.CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim dp As DependencyProperty

instance.CoerceValue(dp)
C#
public void CoerceValue(
   DependencyProperty dp
)

Parameters

dp
The identifier for the dependency property to coerce.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value were invalid or do not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

DependencyObjectType Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : DependencyObjectType Property

Gets the System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As DependencyObjectType

value = instance.DependencyObjectType
C#
public DependencyObjectType DependencyObjectType {get;}

Property Value

A System.Windows.DependencyObjectType that wraps the CLR type of this instance.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Dispatcher Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Dispatcher Property

Gets the System.Windows.Threading.Dispatcher this System.Windows.Threading.DispatcherObject is associated with.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Dispatcher

value = instance.Dispatcher
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Dispatcher Dispatcher {get;}

Property Value

The dispatcher.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Equals Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : Equals Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public bool Equals(
   object obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

GetHashCode Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : GetHashCode Method

Gets a hash code for this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Integer

value = instance.GetHashCode()
C#
public int GetHashCode()

Return Value

A signed 32-bit integer hash code.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

GetLocalValueEnumerator Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : GetLocalValueEnumerator Method

Creates a specialized enumerator for determining which dependency properties have locally set values on this System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As LocalValueEnumerator

value = instance.GetLocalValueEnumerator()
C#
public LocalValueEnumerator GetLocalValueEnumerator()

Return Value

A specialized local value enumerator.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

GetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : GetValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the current effective value of a dependency property on this instance of a System.Windows.DependencyObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim dp As DependencyProperty
Dim value As Object

value = instance.GetValue(dp)
C#
public object GetValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the current effective value.

Exceptions

Exception | Description
System.InvalidOperationException | The specified dp or its value was invalid, or the specified dp does not exist.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

InvalidateProperty Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : InvalidateProperty Method

Re-evaluates the effective value for the specified dependency property

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

InvalidateProperty(DependencyProperty) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : InvalidateProperty(DependencyProperty) Method

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.
Re-evaluates the effective value for the specified dependency property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim dp As DependencyProperty

instance.InvalidateProperty(dp)
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void InvalidateProperty(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to invalidate.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

IsSealed Property
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : IsSealed Property

Gets a value that indicates whether this instance is currently sealed (read-only).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As Boolean

value = instance.IsSealed
C#
public bool IsSealed {get;}

Property Value

true if this instance is sealed; otherwise, false.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ReadLocalValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : ReadLocalValue Method

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.
Returns the local value of a dependency property, if it exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim dp As DependencyProperty
Dim value As Object

value = instance.ReadLocalValue(dp)
C#
public object ReadLocalValue(
   DependencyProperty dp
)

Parameters

dp
The System.Windows.DependencyProperty identifier of the property to retrieve the value for.

Return Value

Returns the local value, or returns the sentinel value System.Windows.DependencyProperty.UnsetValue if no local value is set.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

SetCurrentValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : SetCurrentValue Method

Sets the value of a dependency property without changing its value source.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

SetCurrentValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : SetCurrentValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the value of a dependency property without changing its value source.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim dp As DependencyProperty
Dim value As Object

instance.SetCurrentValue(dp, value)
C#
public void SetCurrentValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

SetValue Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : SetValue Method

Sets the local value of a dependency property, specified by its dependency property identifier.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

SetValue(DependencyProperty,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > SetValue Method : SetValue(DependencyProperty,Object) Method

dp
The identifier of the dependency property to set.
value
The new local value.
Sets the local value of a dependency property, specified by its dependency property identifier.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim dp As DependencyProperty
Dim value As Object

instance.SetValue(dp, value)
C#
public void SetValue(
   DependencyProperty dp,
   object value
)

Parameters

dp
The identifier of the dependency property to set.
value
The new local value.

Exceptions

Exception | Description
System.InvalidOperationException | Attempted to modify a read-only dependency property, or a property on a sealed System.Windows.DependencyObject.
System.ArgumentException | value was not the correct type as registered for the dp property.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

SetValue(DependencyPropertyKey,Object) Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.
Sets the local value of a read-only dependency property, specified by the System.Windows.DependencyPropertyKey identifier of the dependency property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim key As DependencyPropertyKey
Dim value As Object

instance.SetValue(key, value)
C#
public void SetValue(
   DependencyPropertyKey key,
   object value
)

Parameters

key
The System.Windows.DependencyPropertyKey identifier of the property to set.
value
The new local value.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

VerifyAccess Method
[image]
dbiScheduleWPF Assembly > Dbi.WpfControl.dbiSchedule Namespace > dbiTimeBarItem Class : VerifyAccess Method

Enforces that the calling thread has access to this System.Windows.Threading.DispatcherObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem

instance.VerifyAccess()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void VerifyAccess()

Exceptions

Exception | Description
System.InvalidOperationException | the calling thread does not have access to this System.Windows.Threading.DispatcherObject.

Requirements

Target Platforms: Windows XP SP2,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Dbi.WpfControl.dbiSchedule Namespace Inheritance Hierarchy
dbiScheduleWPF Assembly : Dbi.WpfControl.dbiSchedule Namespace

Inheritance Hierarchy

System.Object
Dbi.WpfControl.dbiSchedule.dbiHistoryItem
System.Collections.ObjectModel.Collection<T>
System.Collections.ObjectModel.ObservableCollection<T>
Dbi.WpfControl.dbiSchedule.dbiColumnItemCollection
Dbi.WpfControl.dbiSchedule.dbiCustomAreaCollection
Dbi.WpfControl.dbiSchedule.dbiGuideLineCollection
Dbi.WpfControl.dbiSchedule.dbiLinkItemCollection
Dbi.WpfControl.dbiSchedule.dbiListCellCollection
Dbi.WpfControl.dbiSchedule.dbiListItemCollection
Dbi.WpfControl.dbiSchedule.dbiScheduleNoteCollection
Dbi.WpfControl.dbiSchedule.dbiScheduleObjectCollection
Dbi.WpfControl.dbiSchedule.dbiTimeBarCollection
System.EventArgs
Dbi.WpfControl.dbiSchedule.AfterGuideLineInsertedEventArgs
Dbi.WpfControl.dbiSchedule.AfterGuideLineMovedEventArgs
Dbi.WpfControl.dbiSchedule.AfterGuideLineRemovedEventArgs
Dbi.WpfControl.dbiSchedule.AfterPrintEventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarInsertedEventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarLinkedEventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarMovedEventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarRemovedEventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarSizedEventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarSplitEventArgs
Dbi.WpfControl.dbiSchedule.AfterTimeBarUnlinkedEventArgs
Dbi.WpfControl.dbiSchedule.BeforeGuideLineInsertEventArgs
Dbi.WpfControl.dbiSchedule.BeforeGuideLineMoveEventArgs
Dbi.WpfControl.dbiSchedule.BeforeGuideLineRemoveEventArgs
Dbi.WpfControl.dbiSchedule.BeforePrintEventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarInsertEventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarLinkEventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarMoveEventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarRemoveEventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarSelectEventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarSizeEventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarSplitEventArgs
Dbi.WpfControl.dbiSchedule.BeforeTimeBarUnlinkEventArgs
Dbi.WpfControl.dbiSchedule.BeforeToolTipsEventArgs
Dbi.WpfControl.dbiSchedule.ColumnHeaderClickEventArgs
Dbi.WpfControl.dbiSchedule.ControlErrorEventArgs
Dbi.WpfControl.dbiSchedule.DeadZoneDropEventArgs
Dbi.WpfControl.dbiSchedule.EditModeChangedEventArgs
Dbi.WpfControl.dbiSchedule.FirstDrawEventArgs
Dbi.WpfControl.dbiSchedule.GuideLineClickEventArgs
Dbi.WpfControl.dbiSchedule.GuideLineMoveEventArgs
Dbi.WpfControl.dbiSchedule.HistoryChangeEventArgs
Dbi.WpfControl.dbiSchedule.ItemMouseOverEventArgs
Dbi.WpfControl.dbiSchedule.LineArrowClickEventArgs
Dbi.WpfControl.dbiSchedule.LineArrowMouseOverEventArgs
Dbi.WpfControl.dbiSchedule.ListItemClickEventArgs
Dbi.WpfControl.dbiSchedule.NoteClickEventArgs
Dbi.WpfControl.dbiSchedule.PrintProgressEventArgs
Dbi.WpfControl.dbiSchedule.RedoActionEventArgs
Dbi.WpfControl.dbiSchedule.ScheduleClickEventArgs
Dbi.WpfControl.dbiSchedule.ScheduleMouseMoveEventArgs
Dbi.WpfControl.dbiSchedule.TimeBarClickEventArgs
Dbi.WpfControl.dbiSchedule.TimeBarSizingEventArgs
Dbi.WpfControl.dbiSchedule.UndoActionEventArgs
Dbi.WpfControl.dbiSchedule.UserDrawnBarAfterEventArgs
Dbi.WpfControl.dbiSchedule.UserDrawnBarBeforeEventArgs
Dbi.WpfControl.dbiSchedule.UserDrawnLineAfterEventArgs
Dbi.WpfControl.dbiSchedule.UserDrawnLineBeforeEventArgs
Dbi.WpfControl.dbiSchedule.ValuePointEventArgs
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
Dbi.WpfControl.dbiSchedule.dbiColumnItem
Dbi.WpfControl.dbiSchedule.dbiCustomArea
Dbi.WpfControl.dbiSchedule.dbiGuideLine
Dbi.WpfControl.dbiSchedule.dbiLinkItem
Dbi.WpfControl.dbiSchedule.dbiListCell
Dbi.WpfControl.dbiSchedule.dbiListItem
Dbi.WpfControl.dbiSchedule.dbiScheduleNote
Dbi.WpfControl.dbiSchedule.dbiScheduleObject
Dbi.WpfControl.dbiSchedule.dbiTimeBarItem
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.UserControl
Dbi.WpfControl.dbiSchedule.dbiScheduleWPF

See Also

Reference

dbiScheduleWPF Assembly


%%Phrase%%

Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z